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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty 
statements accompanying such products and services. Nothing herein should be construed 
as constituting an additional warranty. HP shall not be liable for technical or editorial errors 
or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or 
copying. Consistent with FAR 12.211 and 12.212, Commercial Computer Software, 
Computer Software Documentation, and Technical Data for Commercial Items are licensed 
to the U.S. Government under vendor's standard commercial license.

Third-Party Web Sites

HP provides links to external third-party Web sites to help you find supplemental 
information.  Site content and availability may change without notice.  HP makes no 
representations or warranties whatsoever as to site content or availability.

Copyright Notices

©  1993 - 2007 Mercury Interactive Corporation, All rights reserved

Trademark Notices

Adobe® is a trademark of Adobe Systems Incorporated.

JavaTM is a US trademark of Sun Microsystems, Inc.

Microsoft® and Windows® are U.S registered trademarks of Microsoft Corporation.
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Documentation Updates

This manual’s title page contains the following identifying information:

• Software version number, which indicates the software version

• Document release date, which changes each time the document is updated

• Software release date, which indicates the release date of this version of the software

To check for recent updates, or to verify that you are using the most recent edition of a 
document, go to:

http://ovweb.external.hp.com/lpe/doc_serv/ 
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Support

Mercury Product Support

You can obtain support information for products formerly produced by Mercury as follows:

• If you work with an HP Software Services Integrator (SVI) partner (www.hp.com/
managementsoftware/svi_partner_list), contact your SVI agent.

• If you have an active HP Software support contract, visit the HP Software Support Web 
site and use the Self-Solve Knowledge Search to find answers to technical questions.

• For the latest information about support processes and tools available for products 
formerly produced by Mercury, we encourage you to visit the Mercury Customer Support 
Web site at: http://support.mercury.com.

• If you have additional questions, contact your HP Sales Representative.

HP Software Support

You can visit the HP Software Support Web site at:

www.hp.com/managementsoftware/services 

HP Software online support provides an efficient way to access interactive technical support 
tools. As a valued support customer, you can benefit by using the support site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. 
Many also require a support contract. To find more information about access levels, go to: 
www.hp.com/managementsoftware/access_level 

To register for an HP Passport ID, go to: 
www.managementsoftware.hp.com/passport-registration.html
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Welcome to This Guide

Welcome to HP Quality Center, a Web-based test management tool. 
Quality Center helps you organize and manage all phases of the application 
testing process, including specifying testing requirements, planning tests, 
executing tests, and tracking defects.

How This Guide is Organized

The Quality Center User’s Guide describes how to use Quality Center to 
manage the application testing process for your application. 

It contains the following parts:

 Part I Quality Center Basics

Provides an overview of the Quality Center features and methodology.

 Part II Release Management

Describes how to define releases and cycles for managing the development 
and testing process.

 Part III Requirements Specification

Describes how to define testing requirements by building a requirements 
tree.

 Part IV Test Planning

Describes how to plan the testing process, from building a test plan tree to 
creating tests.
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Welcome
 Part V Test Execution

Describes how to create test sets, execute manual and automated tests, and 
review test results.

 Part VI Defect Tracking

Describes how to report application defects to a Quality Center project and 
keep track of the repair process until the defects are resolved.

 Part VII Quality Center Analysis

Describes how you can monitor the testing and defect tracking process by 
creating reports, Excel reports, graphs, and project documentation. 

 Part VIII Appendixes

Describes how to work with the VAPI-XP testing tool, and provides a list of 
Quality Center keyboard shortcuts.

Documentation Library

The Documentation Library is an online help system that describes how to 
use Quality Center. You can access the Documentation Library in the 
following ways:

➤ Click Documentation Library in the Quality Center Help menu to open 
the Documentation Library home page. The home page provides quick 
links to the main help topics.

➤ Click Help on this page in the Quality Center Help menu to open the 
Documentation Library to the topic that describes the current page.
16



Welcome
Documentation Library Guides

The Documentation Library consists of the following guides and references, 
available online, in PDF format, or both. PDFs can be read and printed using 
Adobe Reader, which can be downloaded from the Adobe Web site 
(http://www.adobe.com).

Getting Started explains how to use the Documentation Library and how it 
is organized. (Available online.)

What’s New? describes the newest features in the latest versions of 
Quality Center. (Available online and in PDF format.)

You can also access What’s New? from the Quality Center Help menu. In 
addition, you can choose Help > Product Feature Movies to view short 
movies that demonstrate the main product features. 

Readme provides last-minute news and information about Quality Center. 

Quality Center Guides:

HP Quality Center User’s Guide explains how to use Quality Center to 
organize and execute all phases of the testing process. It describes how to 
define requirements, plan tests, run tests, and track defects. (Available 
online and in PDF format.)

HP Quality Center Administrator’s Guide explains how to create and 
maintain projects using Site Administration, and how to customize projects 
using Project Customization. (Available online and in PDF format.)

HP Quality Center Tutorial is a self-paced guide teaching you how to use 
Quality Center to manage the software testing process. (Available in PDF 
format.)

HP Quality Center Installation Guide explains how to install Quality Center 
on a server machine in a cluster environment or as a stand-alone 
application. (Available in PDF format.)

Business Process Testing Guides:

HP Business Process Testing User’s Guide explains how to use Business 
Process Testing to create business process tests. (Available online and in PDF 
format.)
17
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Welcome
HP Business Process Testing Tutorial provides a self-paced guide that teaches 
you the basics of Business Process Testing in the Quality Center application. 
(Available in PDF format.)

API References:

HP Quality Center Database Reference provides a complete online reference 
for the project database tables and fields. (Available online.)

HP Quality Center Open Test Architecture API Reference provides a 
complete online reference for the Quality Center COM-based API. You can 
use the Quality Center open test architecture to integrate your own 
configuration management, defect tracking, and home-grown testing tools 
with a Quality Center project. (Available online.)

HP Quality Center Site Administration API Reference provides a complete 
online reference for the Site Administration COM-based API. You can use 
the Site Administration API to enable your application to organize, manage, 
and maintain Quality Center users, projects, domains, connections, and site 
configuration parameters. (Available online.)

HP Quality Center Custom Test Type Guide provides a complete online 
guide for creating your own testing tool and integrating it into the Quality 
Center environment. (Available online.)

Additional Online Resources

The following additional online resources are available from the 
Quality Center Help menu:

Knowledge Base uses your default Web browser to open the Mercury 
Customer Support Web Site directly to the Knowledge Base landing page.

Customer Support Web Site uses your default Web browser to open the 
Mercury Customer Support Web site. This site enables you to browse the 
Mercury Support Knowledge Base and add your own articles. You can also 
post to and search user discussion forums, submit support requests, 
download patches and updated documentation, and more. The URL for this 
Web site is http://support.mercury.com. 
18
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HP Software Web site uses your default Web browser to access the HP 
Software Web site. This site provides you with the most up-to-date 
information on HP Software products. This includes new software releases, 
seminars and trade shows, customer support, and more. The URL for this 
Web site is http://www.hp.com/managementsoftware. 

Add-ins Page opens the HP Quality Center Add-ins Page, which offers 
integrations with HP testing tools, as well as third-party, synchronization, 
and version control tools. For more information, refer to the 
HP Quality Center Installation Guide.
19
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Typographical Conventions 

This guide uses the following typographical conventions:

UI Elements and 
Function Names

This style indicates the names of interface elements on 
which you perform actions, file names or paths, and 
other items that require emphasis. For example, “Click 
the Save button.” It also indicates method or function 
names. For example, "The wait_window statement has 
the following parameters:"

Arguments This style indicates method, property, or function 
arguments and book titles. For example, “Refer to the 
HP User’s Guide.”

<Replace Value> Angle brackets enclose a part of a file path or URL 
address that should be replaced with an actual value. 
For example, <MyProduct installation folder>\bin.

Example This style is used for examples and text that is to be 
typed literally. For example, “Type Hello in the edit 
box.”

CTRL+C This style indicates keyboard keys. For example, “Press 
ENTER.”

[ ] Square brackets enclose optional arguments.

{ } Curly brackets indicate that one of the enclosed values 
must be assigned to the current argument. 

... In a line of syntax, an ellipsis indicates that more items 
of the same format may be included. In a 
programming example, an ellipsis is used to indicate 
lines of a program that were intentionally omitted.

| A vertical bar indicates that one of the options 
separated by the bar should be selected.
20
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1
Introduction

Welcome to HP Quality Center, the HP Web-based test management tool. 
You access Quality Center over the Internet or a corporate intranet, via a 
Web browser.

Application testing is a complex process involving the development and 
execution of thousands of tests. Often, tests are required for multiple 
hardware platforms, multiple configurations (computers, operating systems, 
and browsers) and multiple application versions. Managing all aspects of the 
testing process can be time-consuming and difficult.

Quality Center simplifies and organizes test management by giving you 
systematic control over the testing process. It helps you create a framework 
and foundation for your testing workflow.

Quality Center helps you maintain a project database of tests that cover all 
aspects of your application’s functionality. Every test in your project is 
designed to fulfill a specified requirement of your application. To meet the 
various goals of a project, you organize the tests in your project into unique 
groups. Quality Center provides an intuitive and efficient method for 
scheduling and executing test sets, collecting test results, and analyzing the 
data.

Quality Center also features a sophisticated system for tracking application 
defects, enabling you to monitor defects closely from initial detection until 
resolution. By linking Quality Center to your e-mail system, defect tracking 
information can be shared by all application development, quality 
assurance, customer support, and information systems personnel.
23



Chapter 1 • Introduction
Quality Center offers integration with HP testing tools (WinRunner, 
QuickTest Professional, LoadRunner, and Visual API-XP) as well as third-
party and custom testing tools, and requirement and configuration 
management tools. Quality Center communicates seamlessly with the 
testing tool of your choice, providing you with a complete solution to fully 
automated application testing.

Quality Center guides you through the releases specification, requirements 
specification, test planning, test execution, and defect tracking phases of the 
testing process. By integrating all the tasks involved in application testing, it 
helps ensure that your customers receive the highest quality applications.
24



Chapter 1 • Introduction
The Test Management Process

Test management with Quality Center involves five phases: 

Specify Releases. Develop a release-cycle management plan.

Specify Requirements. Analyze your application and determine your 
requirements.

Plan Tests. Create a test plan, based on your requirements.

Execute Tests. Create test sets and perform test runs.

Track Defects. Report defects detected in your application and track how 
repairs are progressing.

Throughout each phase, you can analyze data by generating detailed reports 
and graphs.

Specify
Requirements

Plan
Tests

Execute
Tests

Track
Defects

Specify
Releases
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Chapter 1 • Introduction
Specifying Releases 

Develop a release-cycle management plan. 

Define Releases and Cycles. Build a releases tree to define your releases and 
cycles and the project timeline. A release represents a group of changes in 
one or more applications that will be available for distribution at the same 
time. A cycle represents a development and QA cycle based on the project 
timeline.

Assign Requirements. Define requirements in the Requirements module and 
assign them to releases and cycles in the releases tree. 

Assign and Run Test Sets. Create test set folders in the Test Lab module and 
assign to cycles in the releases tree. A test set is a group of tests in a 
Quality Center project designed to achieve specific test goals. After assigning 
test set folders to a cycle, run the test sets under these test set folders. 

Define Releases and 
Cycles

Assign
Requirements

Assign and Run 
Test Sets

Assign Defects

Analyze
Releases and Cycles
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Chapter 1 • Introduction
Assign Defects. Submit new defects detected in your application to a 
Quality Center project. Assign defects to the relevant releases and cycles in 
the releases tree.

Analyze Releases and Cycles. Generate reports and graphs to assist in 
analyzing the progress of the release. Review your releases tree to ensure that 
it meets your release goals.

Specifying Requirements 

Analyze your application and determine your requirements. 

Define Testing Scope. Examine application documentation in order to 
determine your testing scope—test goals, objectives, and strategies.

Define
Testing Scope

Create
Requirements

Detail
Requirements

Assign to Releases

Analyze
Requirements
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Chapter 1 • Introduction
Create Requirements. Build a requirements tree to define your overall 
requirements.

Detail Requirements. For each requirement topic in the requirements tree, 
create a list of detailed requirements. Describe each requirement, assign it a 
priority level, and add attachments if necessary.

Assign to Releases. Assign each requirement to releases and cycles in the 
releases tree in the Releases module. The releases tree shows your product 
releases within a hierarchical tree structure. 

Analyze Requirements. Generate reports and graphs to assist in analyzing 
your requirements. Review your requirements to ensure they meet your 
testing scope.
28



Chapter 1 • Introduction
Planning Tests 

Create a test plan, based on your requirements. 

Define Testing Strategy. Examine your application, system environment, 
and testing resources in order to determine your testing goals.

Define Test Subjects. Divide your application into functions to be tested. 
Build a test plan tree to hierarchically divide your application into testing 
units, or subjects.

Define Tests. Determine the types of tests you need for each subject. Add a 
basic definition of each test to the test plan tree.

Create Requirements Coverage. Link each test with one or more 
requirements.

Define
Testing Strategy

Define
Test Subjects

Design
Tests

Create Requirements 
Coverage

Design
Test Steps

Automate
Tests

Analyze
Test Plan
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Chapter 1 • Introduction
Design Test Steps. Develop manual tests by adding steps to the tests in your 
test plan tree. Test steps describe the test operations and the expected 
outcome of each test. Decide which tests to automate.

Automate Tests. For tests that you decide to automate, create test scripts 
with HP testing tools, or custom or third-party testing tools.

Analyze Test Plan. Generate reports and graphs to assist in analyzing test 
planning data. Review your tests to determine their suitability to your 
testing goals.

Running Tests 

Create test sets and perform test runs. 

Create Test Sets. Define groups of tests to meet the various testing goals in 
your project. These might include, for example, testing a new application 
version or a specific function in an application. Determine which tests to 
include in each test set. Assign test set folders to cycles defined in the 
releases tree in the Releases module. 

Define Testing 
Scope

Create
Requirements

Create
Requirements

Detail 
Requirements

Detail 
Requirements

Analyze 
Requirements

Analyze 
Requirements

Create
Test Sets

Schedule
Runs

Run Tests
Manually

Analyze Test Results

Run Tests
Automatically
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Schedule Runs. Schedule test execution and assign tasks to application 
testers. 

Run Tests. Execute the tests in your test set automatically or manually.

Analyze Test Results. View the results of your test runs in order to determine 
whether a defect has been detected in your application. Generate reports 
and graphs to help analyze these results.

Tracking Defects 

Submit defects detected in your application and track how repairs are 
progressing. 

Add Defects. Report new defects detected in your application. Quality 
assurance testers, developers, project managers, and end users can add 
defects during any phase in the testing process.

Review New Defects. Review new defects and determine which ones should 
be fixed.

Add
Defects

Review
New Defects

Repair
Open Defects

Test
New Build

Analyze
Defect Data
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Repair Open Defects. Correct the defects that you decided to fix.

Test New Build. Test a new build of your application. Continue this process 
until defects are repaired.

Analyze Defect Data. Generate reports and graphs to assist in analyzing the 
progress of defect repairs, and to help determine when to release the 
application.

Working with Project Databases 

When you create a Quality Center project, you need to store and manage 
the data generated and collected by Quality Center. Each project is 
supported by a database that stores project information.

Quality Center projects are repositories that contain releases, cycles, 
requirements, tests, test sets, test runs, defects, project documentation, and 
customization information. A Quality Center user needs constant access to 
this data in order to be able to work on an application testing project. 

For more information on supported database servers, refer to the 
HP Quality Center Installation Guide.

For more information on creating and managing Quality Center projects, 
refer to the HP Quality Center Administrator’s Guide.

User Privileges 

Quality Center enables you to manage user access to a project. By creating a 
list of authorized users and assigning each user a password and user group, 
you control the kinds of additions and modifications each user makes to the 
project. The user group determines the privileges that the user has within a 
project. Quality Center includes a privileges and permissions mechanism 
that enables you to create rules for specific fields in a project.

For detailed information on the user groups available in Quality Center, and 
on assigning passwords and privileges, refer to the HP Quality Center 
Administrator’s Guide.
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Importing from Microsoft Word and Microsoft Excel

You can import data from Word or Excel to a Quality Center project.

Importing from Word

You can import requirement or test plan data from a Word document to a 
Quality Center project. To import from Word, you must install the Microsoft 
Word Add-in and the HP Quality Center Connectivity Add-in on your client 
machine. To install an add-in, choose Help > Add-ins Page to open the 
HP Quality Center Add-ins page, and click the appropriate add-in link.

For more information, refer to the HP Quality Center Microsoft Word Add-in 
Guide available on the Microsoft Word Add-in page.

Importing from Excel

You can import requirement, test plan, or defect data from an Excel 
worksheet to a Quality Center project. To import from Excel, you must 
install the Microsoft Excel Add-in and the HP Quality Center Connectivity 
Add-in on your client machine. To install an add-in, choose Help > Add-ins 
Page to open the HP Quality Center Add-ins page, and click the appropriate 
add-in link.

For more information, refer to the HP Quality Center Microsoft Excel Add-in 
Guide available on the Microsoft Excel Add-in page.
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2
Getting Started

This chapter explains how to start Quality Center and introduces the 
Quality Center window.

Starting Quality Center

You launch Quality Center on your machine from your Web browser.

To start Quality Center:

 1 Open your Web browser and type your Quality Center URL
http://<Quality Center server name>[<:port number>]/qcbin. Contact your 
system administrator if you do not have the correct path.

This chapter describes: On page:

Starting Quality Center 35

The Quality Center Window 40

Quality Center Common Toolbar 42

Changing User Properties and Password 44

Clearing History 45

Viewing Administrator Messages 47
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The HP Quality Center Options window opens.

 2 Click the Quality Center link.

The first time you run Quality Center, files are downloaded to your 
machine, and if it is not already installed, the Microsoft .NET Framework 2.0 
Setup program runs. Subsequently, Quality Center carries out a version 
check. If there is a newer version on the server, updated files are downloaded 
to your machine. For more information on the downloaded files, refer to the 
HP Quality Center Installation Guide. 
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Note: 

➤ To download files to your machine, you must log in with administrator 
privileges. This applies if you are running Quality Center for the first 
time, upgrading to a newer version, or applying a service pack.

➤ If file downloads are prohibited through your browser, you can install 
these files from the HP Quality Center Client Side Setup Add-in on the 
HP Quality Center Add-in page. For more information on installing add-
ins, refer to the HP Quality Center Installation Guide. 

➤ Quality Center prompts you to install Microsoft .NET Framework 2.0 if it 
is not already installed on your machine. To perform the installation, 
follow the instructions in the Software Update Installation Wizard (if 
Windows Installer 3.1 is not installed) and the Microsoft .NET 
Framework 2.0 Setup.
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After the Quality Center version has been checked and files have been 
updated if necessary, the HP Quality Center Login window opens.

 3 In the Login Name box, type your user name. 

 4 In the Password box, type the password assigned to you by your site 
administrator.

To change your assigned password, see “Changing User Properties and 
Password” on page 44.

 5 Select the Automatically log in to my last domain and project on this 
machine check box if you want Quality Center to automatically log in to the 
last project in which you were working.
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 6 Click the Authenticate button. Quality Center verifies your user name and 
password and determines which domains and projects you can access. If you 
specified automatic login, Quality Center opens.

If authentication fails, check that your user name and password are correct 
and try again.

 7 In the Domain list, select a domain. By default, the last domain in which 
you were working is displayed.

 8 In the Project list, select a project. By default, the last project in which you 
were working is displayed.

If the demonstration project was installed on the Quality Center server, you 
can select the QualityCenter_Demo project (make sure that you select 
DEFAULT in the Domain list). The project helps introduce you to 
Quality Center and includes sample requirements, tests, test sets, test runs, 
and defects. For more information, refer to the HP Quality Center Tutorial.

 9 Click the Login button. Quality Center opens and displays the module 
(Releases, Requirements, Test Plan, Test Lab, or Defects) in which you last 
worked during your previous session.

The first time you run Quality Center, the Welcome page opens. From the 
Welcome page, you can directly access this User’s Guide and other 
Quality Center documentation. If you do not want to display the Welcome 
page each time you log in to Quality Center, select Don’t show this again. 
To open the Welcome page at any time, choose Help > Welcome Page.

 10 To exit and return to the HP Quality Center Login window, click the Logout 
button located on the upper-right side of the window. 

Alternatively, choose Tools > Change Project to log in to a different project.
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The Quality Center Window

When you connect to a project, the Quality Center main window opens and 
displays the module in which you were last working. On the upper-right 
side of the window, the domain, project, and your user name are displayed. 

The Quality Center window contains the following key elements:

➤ Quality Center sidebar. Provides access to the Quality Center modules. For 
more information, see “Quality Center Modules” on page 41.

➤ Quality Center common toolbar. Provides navigation buttons, access to 
common tools, documentation and additional resources. This toolbar is 
located on the upper-right part of the window. For more information, see 
“Quality Center Common Toolbar” on page 42.

➤ Module menu bar. Displays the names of menus from which you select 
commands in the current Quality Center module.

➤ Module toolbar. Contains buttons for frequently-used commands in the 
current Quality Center module.

Common toolbar

Module menu bar
Module toolbar

Quality Center
sidebar
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Quality Center Modules
Quality Center has the following modules, which are accessible from the 
sidebar:

➤ Releases. Enables you to define releases and cycles for managing the testing 
process.

➤ Requirements. Enables you to specify testing requirements. This includes 
defining what you are testing, defining requirement topics and items, 
linking requirements with tests and defects, and analyzing the 
requirements.

➤ Test Plan. Enables you to develop a test plan based on your testing 
requirements. This includes dividing your plan into categories, developing 
tests, automating tests where beneficial, linking tests with requirements and 
defects, and analyzing the plan.

➤ Test Lab. Enables you to run tests on your application and analyze the 
results.

➤ Defects. Enables you to add defects, determine repair priorities, repair open 
defects, and analyze the data.

Depending on your Quality Center license, you may also have access to the 
Business Components module. This module enables subject matter experts 
to drive the quality optimization process using Business Process Testing, the 
HP test automation solution. For more information, refer to the HP Business 
Process Testing User’s Guide.

To customize the module names, refer to the HP Quality Center Installation 
Guide.

Tip: You can navigate between the modules using shortcut keys. Use 
CTRL+SHIFT+1 to access the Requirements module, CTRL+SHIFT+2 to access 
the Test Plan module, etc. Additionally, you can perform many other 
Quality Center operations using shortcut keys. For a list of shortcut keys, see 
Appendix B, “Quality Center Keyboard Shortcuts.”
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Quality Center Common Toolbar

The Quality Center common toolbar, located on the upper-right side of the 
Quality Center window, is accessible from all modules and contains the 
following buttons:

Navigation Buttons

Back. Navigates back to your previous location in Quality Center.

Forward. Navigates forward to your next location in Quality Center.

Tools Button

Change Project. Enables you to log out of your current project and select 
one of the five most recently opened projects on that machine (if 
appropriate), or select a different project from the Login window.

Customize. Opens the Project Customization window, enabling you to 
customize your project. For more information, refer to the HP Quality Center 
Administrator’s Guide.

New Defect. Opens the New Defect dialog box, enabling you to add a new 
defect. For more information, see Chapter 31, “Adding and Tracking 
Defects.”

Spelling and Grammar: 

➤ Check Spelling. Checks the spelling for the selected word or text box. If 
there are no errors, a confirmation message opens. If errors are found, the 
Spelling dialog box opens and displays the word together with 
replacement suggestions.

➤ Spelling Options. Opens the Spelling Options dialog box, enabling you 
to configure the way Quality Center checks spelling. 

➤ Thesaurus. Opens the Thesaurus dialog box and displays a synonym, 
antonym, or related word for the selected word. You can replace the 
selected word or look up new words.

Clear History. Opens the Clear History dialog box, enabling you to delete 
history data from your project. This is only available for users with project 
administrator permissions. For more information, see “Clearing History” on 
page 45.
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Document Generator. Opens the Document Generator. For more 
information, see Chapter 36, “Generating Project Documents.”

Excel Report Generator. Opens the Excel Report Generator. For more 
information, see Chapter 37, “Generating Excel Reports.”

Dashboard. Opens HP Quality Center Dashboard, the HP platform that 
enables IT teams to track application readiness in real-time and manage 
project risk. For more information, refer to the HP Quality Center Dashboard 
documentation set.

To customize the Tools menu, refer to the HP Quality Center Installation 
Guide.

Help Button

The Help button enables you to open the Quality Center Documentation 
Library and other additional online resources. It also enables you to display 
version information for each Quality Center client component. For more 
information, see “Documentation Library” on page 16 and “Additional 
Online Resources” on page 18.

To customize the Help menu, refer to the HP Quality Center Installation 
Guide.

Logout Button

The Logout button logs you out of your current project to the 
HP Quality Center Login window.
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Changing User Properties and Password

You can change your user properties, including full name, e-mail address, 
phone number, and description. E-mail information is important because it 
enables you to receive defects, requirements, tests and test set notifications 
directly to your mailbox. You can also change your password for accessing 
Quality Center projects.

The site administrator can change and override a user’s properties or 
password. For more information, refer to the HP Quality Center 
Administrator’s Guide.

To change user properties and password:

 1 On the upper-right side of the window, click the Tools button and choose 
Customize. The Project Customization window opens. 

 2 Click the User Properties link. The User Properties window opens.
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 3 Edit the following user properties: Full Name, E-mail, Phone Number, 
Description.

 4 Click Save to save your changes.

 5 Click the Change Password button. The Change Password dialog box opens.

 6 In the Old Password box, type your old password.

 7 In the New Password box, type the new password.

 8 In the Retype New Password box, retype the new password.

 9 Click OK to save your changes. The Change Password dialog box closes.

 10 On the upper-right side of the window, click the Return button to exit the 
Project Customization window and return to your project.

Clearing History 

When you customize your project, you can instruct Quality Center to 
preserve a log of values for the system and user fields in your Requirement, 
Test, Test Set, Test Instance, and Defect entities. The history data that is 
generated is displayed in the History tabs of the Requirements, Test Plan, 
Test Lab, and Defects modules. For more information on enabling history 
for a field, refer to the HP Quality Center Administrator’s Guide.

When the history data is no longer needed, you can choose to delete this 
data from your Quality Center project. For example, if you have successfully 
run the test sets you created, you may want to clear the test history from 
your project.
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You can choose to clear all history data, or you can select a specific entity or 
field whose history you want to clear. In addition, you can choose to delete 
history data up to and including a specific date. Quality Center clears the 
data displayed in the History tab of the corresponding modules.

Note: You must have project administrator permissions to clear history. 

To clear history:

 1 On the upper-right side of the window, click the Tools button and choose 
Clear History. The Clear History dialog box opens.

 2 In the Entity box, select the entity whose history you want to delete. To 
delete history data from all entities, select All.

 3 In the Field box, select the field whose history you want to delete. To delete 
history data from all fields, select All.

 4 In the Until Date box, select a date. All data up to and including the selected 
date is deleted.

 5 Click OK.
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Viewing Administrator Messages

The site administrator can send messages to users connected to 
Quality Center projects informing them about important maintenance or 
other issues. For example, the site administrator may send a message 
warning that a project you are connected to will be disconnected, or that a 
Quality Center server will be restarted.

For more information on sending messages from Site Administration, refer 
to the HP Quality Center Administrator’s Guide.

To view administrator messages:

 1 When the site administrator sends you a message, a pop-up window 
automatically opens on your machine displaying the message text.

 2 If there is more than one message, use the Previous Message and Next 
Message buttons to view other messages.

 3 To close the message box, click the Close button.
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Working with Quality Center Data

You can view and modify the data in your project using Quality Center grids 
and trees. 

This chapter describes: On page:
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About Working with Quality Center Data

Quality Center organizes and displays data in grids or trees:

Note that as Quality Center grids and trees vary in the type of content they 
display, the activities described in this chapter do not always apply to all 
grids and trees.

Tree/Grid Description

Releases Tree Available in the Releases module. Displays the releases and 
cycles for a Quality Center project. For more information, see 
Chapter 9, “Developing the Releases Tree”.

Requirements 
Tree/Grid

Available in the Requirements module. Displays the testing 
requirements for a Quality Center project. For more 
information, see Chapter 12, “Developing the Requirements 
Tree”.

Test Plan Tree Available in the Test Plan module. Displays the tests in a 
Quality Center project, grouped by subjects. For more 
information, see Chapter 17, “Developing the Test Plan Tree”.

Test Grid Available in the Test Plan module. Displays all the tests in a 
Quality Center project. For more information, see 
Chapter 16, “The Test Plan Module at a Glance”.

Design Steps 
Grid

Available in the Test Plan module. Displays the steps of a test. 
For more information, see Chapter 19, “Building Tests”.

Test Sets 
Tree/Grid

Available in the Test Lab module. Displays the test sets—a 
group of tests that you run in order to achieve a specific 
testing goal—in a Quality Center project. For more 
information, see Chapter 24, “Creating Test Sets”.

Execution Grid Available in the Test Lab module. Displays all the tests in a 
test set. For more information, see Chapter 23, “The Test Lab 
Module at a Glance”.

Defects Grid Available in the Defects module. Displays the defects in a 
Quality Center project. For more information, see 
Chapter 31, “Adding and Tracking Defects”.
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Tip: You can save your tree and grid settings, such as sorting and filters, as a 
favorite view. For more information, see Chapter 6, “Working with Favorite 
Views”.

Arranging Columns 

You can customize data by specifying the order in which columns appear, 
and by changing column size. Quality Center displays your customized 
column settings the next time you open the project.

Tip: You can also rearrange columns by dragging the column headers.

Setting Column Order

You determine which columns are displayed in Quality Center and the order 
in which they appear using the Select Columns dialog box. For example, 
you can set Subject as the first column in the Test Grid.
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To determine column appearance and order:

 1 Click the Select Columns button. The Select Columns dialog box opens.

Available Columns lists columns that are not currently displayed. 
Visible Columns lists columns that are currently displayed.

Note: If you are opening the Select Columns dialog box from the 
Requirements module, this dialog box also displays the Requirement Type 
box and the Hide Risk-Based Quality Management Columns check box.

 2 If you are working in the Requirements module, select a requirement type 
from the Requirement Type list. The columns available for the requirement 
type are displayed.

 3 If you are working in the Requirements module, you can select the Hide 
Risk-Based Quality Management Columns check box to hide the 
requirement fields related to risk-based quality management from the 
Available Columns list. Clear the check box to make the fields visible.
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 4 Select column names and click the arrow buttons (> and <) to move them 
between Available Columns and Visible Columns. Click the double arrow 
buttons (>> and <<) to move all the columns from one list to the other. Note 
that you can also drag the column names between lists or double-click a 
column name to move a column between lists.

Note: Columns displayed with the  icon cannot be removed from the 
Visible Columns list.

 5 In Visible Columns, set the order in which columns appear by using the Up 
and Down arrows. You can also drag the column names up or down.

 6 To set non-scrolling columns, specify the number of non-scrolling columns 
you want to set in Fixed Columns. Starting from the leftmost column, the 
number of columns you specify will be set as non-scrolling. Non-scrolling 
columns remain stationary when you scroll horizontally. These columns are 
shaded.

 7 Click OK to close the dialog box and apply the new column order.

Resizing Columns

You can resize columns using the mouse. Click on the right edge of a 
column heading and drag to adjust the width. Note that you can only resize 
columns that are not fixed (non-scrolling).
53



Chapter 3 • Working with Quality Center Data
Selecting Users

When you select a column in a Quality Center grid or tree with a user name 
value, Quality Center displays a users list with the name and full name of 
each user. You can sort the users list, search for users, group users by user 
groups, and select users from the list or from a group tree. 

To select users:

 1 Select a user field and click the drop-down arrow. The Users List dialog box 
opens.

To sort the Users List in ascending or descending order by user name or full 
name, click the Name or Full Name column heading. Click the column 
heading again to reverse the sort order. 

 2 To search users, you can:

➤ Search incrementally by typing the first character in the user name. You 
can type additional characters to narrow down the search. 
Quality Center begins searching as soon as you type the first character of 
the search string, and highlights the record with the first occurrence of 
all the characters in the search string.

➤ Search users by user name or full name. Type the name of a user (or part 
of the name) in the Find box. Click the Find button. Quality Center 
highlights the record with the first occurrence of the search string.
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 3 To display users by user group, select View by Group. The users are grouped 
by user group.

To expand a branch in the tree, click the Expand  sign to the left of the 
user group name. To collapse a branch in the tree, click the Collapse  sign 
to the left of the user group name.

 4 Select a user and click OK. The Users List dialog box closes and the user 
value is displayed in the data field.

Filtering Records 

You can filter Quality Center data to display only those records that meet 
the criteria that you define. You can assign a single item (such as “Failed”) or 
a logical expression (such as “Passed Or Failed”) to a filter. Only records 
meeting all the criteria of the filter appear in the grid or tree. 

In addition, you can define multiple filters. For example, you can define the 
Status filter as “Failed” and the Tester filter as “David Or Mark”. Only failed 
test runs performed by David or Mark are displayed.

Tip: You can save filter and sort information as a favorite view and then load 
it as needed. To save as a favorite view, choose Favorites > Add to Favorites. 
For more information, see Chapter 6, “Working with Favorite Views”.
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To define a filter:

 1 Click the appropriate Set Filter/Sort button. The Filter dialog box opens and 
displays the Filter Condition tab.

Note: If you are opening the Filter dialog box from the Requirements 
module, this dialog box also displays the Requirement Type box and the 
Hide Risk-Based Quality Management Columns check box.

 2 To define a filter by a requirement type, in the Requirement Type box, click 
the browse button. The Select Filter Condition dialog box opens. Select a 
requirement type. Click OK to close the Select Filter Condition dialog box. 
The Filter Condition tab displays the relevant field names.
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 3 If you are working in the Requirements module, you can select the Hide 
Risk-Based Quality Management Columns check box to hide the 
requirement fields related to risk-based quality management. Only fields for 
which no filter condition is set are hidden. Clear the check box to make the 
fields visible.

 4 To go to a field in the Filter Condition tab, click a box in the Field Name 
column and type the first character of the field name. Quality Center 
highlights the first occurrence.

 5 To set a filter condition for a field, click the corresponding Filter Condition 
box. Click the browse button. The Select Filter Condition dialog box opens.
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Notes: 

➤ If you select a field with a user name value, the Select Filter Condition 
dialog box displays a user list that enables you to sort users, search for 
users, group users by user groups, and select users from the list or from a 
group tree. For more information, see “Selecting Users” on page 54.

➤ In the Requirements module, if you select the Req Parent field, the Select 
Filter Condition dialog box displays the requirements tree, sorted by 
requirement name. If you select a requirement from the requirements 
tree, its full path is displayed in the Condition box. Only requirements 
which are descendents of this requirement are displayed when you apply 
the filter.

 6 Define the filter condition. If applicable, select items from the list. You can 
add operators to create a logical expression. 
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Note: The following should be considered when defining a filter condition:

➤ Some items that appear in hierarchical lists contain sublists. These items 
are preceded by a folder icon. To choose an item from a sublist, double-
click the folder and click the item.

➤ When defining a condition for a user, you can specify the current user 
(select [CurrentUser]), or an entire user group (for example, [Developer]).

➤ If you type an item with more than one word, it must be enclosed in 
quotes. For example, to search for the test Login Boundary, in the 
Condition box, type the following: "login boundary"

➤ If you only want to type part of the item, use an asterisk (*). For example, 
to search for all tests with the word Login, in the Condition box, type the 
following: *login*. To search for all tests that begin with the words Insert 
New in the Condition box, type the following: "insert new*"

➤ To specify an empty field, type the following: ""

➤ To specify a non-empty field, type the following: not ""

 7 Click OK to close the Select Filter Condition dialog box.

 8 To add cross filters, click the Show Advanced Filter arrow. For more 
information, see “Advanced/Cross Filtering Records” on page 61.

 9 To copy the settings, click the Copy Filter Settings button. For more 
information, see “Copying Settings” on page 70.

 10 To clear the settings, click the Clear Filter button.

 11 Click OK to close the Filter dialog box.
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Any filters are applied and the filter description is displayed. For a grid, 
Quality Center also displays the condition in the grid filter box, which 
appears under each column name. 

Tip: For a grid, you can also define a filter by using the grid filter box. To 
display grid filter boxes, choose View > Grid Filters. If the filter box is empty, 
no filter is currently applied to the column. Type directly into the box, or 
click the box to display the Browse button, which opens the Select Filter 
Condition dialog box. 

Note: If you are filtering in the requirements tree, parents of filter entities 
that do not correspond to the filter are displayed with the  icon.

Common toolbar

Grid filter box for 
column Designer
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Advanced/Cross Filtering Records 

When defining a filter, you can also include a cross filter. This is an advanced 
second filter on an associated item such as requirements, tests, test sets, or 
defects. For example, in the test plan tree, you can define the cross filter for 
associated test sets as “Open”. This ensures that only tests that belong to an 
open test set are displayed. Alternatively, you can define the associated test 
set filter to find tests that are not in any test set.

The following table summarizes the cross filters available in each 
Quality Center module:

Module Cross Filter

Requirements ➤ Tests. Filters the requirements by covered tests.

➤ Defects. Filters the requirements by defects that have been 
directly or indirectly-linked to the requirements.

➤ Requirements: Trace from. Filters the requirements by 
traced from requirements.

➤ Requirements: Trace to. Filters the requirements by traced 
to requirements.

➤ Show requirements with alerts. Filters the requirements by 
alerts that have been triggered.

Test Plan ➤ Requirements. Filters the tests by covered requirements.

➤ Test Sets. Filters the tests by test sets that contain the tests.

➤ Defects. Filters the tests by defects that have been directly or 
indirectly-linked to the tests.

➤ Show tests with alerts. Filters the tests by alerts that have 
been triggered.

Test Lab - Test 
Sets list

➤ Tests. Filters the test sets by contained tests.

➤ Defects. Filters the test sets by defects that have been 
directly or indirectly-linked to the tests.
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To define a cross filter:

 1 Click the appropriate Set Filter/Sort button. The Filter dialog box opens and 
displays the Filter tab. 

For more information on defining a filter, see “Filtering Records” on 
page 55.

Test Lab - 
Execution Grid

➤ Requirements. Filters the test instances by tests that cover 
selected requirements.

➤ Defects. Filters the tests by defects that have been directly or 
indirectly-linked to the tests.

➤ Show test instances with alerts. Filters the test instances by 
alerts that have been triggered.

Defects ➤ Requirements. Filters the defects by linked requirements.

➤ Test Sets. Filters the defects by linked test sets.

➤ Tests. Filters the defects by linked tests.

➤ Show defects with alerts. Filters the defects by alerts that 
have been triggered.

Module Cross Filter
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 2 Click the Show Advanced Filter arrow to display the cross filter options.
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 3 Under Cross filter by, select a filter check box. For example, select “Test 
Sets”. The Cross Filter dialog box opens.

In the Test Plan module, the following options are available:

➤ Filter tests not in any test set. Filters tests that are not part of any test set. 
For example, this can help you identify tests that have not been run. This 
option is only available in the Cross Filter: Test Sets dialog box. 

➤ Filter tests with no requirement coverage. Filters tests that do not cover 
any requirements. For example, this can help you identify redundant 
tests or tests with missing requirement coverage links. This option is only 
available in the Cross Filter: Requirements dialog box.

 4 Define the cross filter, using the same rules you would to define a filter. For 
more information, see “Filtering Records” on page 55.

 5 To copy the settings, click the Copy Filter Settings button. For more 
information, see “Copying Settings” on page 70.

 6 To clear the settings, click the Clear Filter button.
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 7 Click OK to save your changes and close the Cross Filter dialog box. In the 
Filter dialog box, under Cross filter by, the cross filters you defined are 
displayed.

 8 Click OK to save your changes and close the Filter dialog box.

Sorting Records 

By default, records appear in Quality Center according to the order in which 
they were added. When you set sorting priorities, records are displayed 
according to the ASCII sort order. The ASCII sort order considers records 
beginning with a space or character before considering those beginning 
with numbers. It then considers uppercase letters and, finally, lowercase 
letters.

For example, if the Designer column in the Test Grid is assigned the highest 
sort priority, records are sorted in the ASCII sort order according to the 
names appearing in the Designer column. If Test Name is assigned the next 
highest priority, test records assigned the same name in the Designer 
column are then sorted in the ASCII sort order according to their test name.

Note: You can save filter and sort information as a favorite view and then 
load it as needed. To save as a favorite view, choose Favorites > Add to 
Favorites. For more information, see Chapter 6, “Working with Favorite 
Views”.

To sort records:

 1 Click the appropriate Set Filter/Sort button. The Filter dialog box opens.

Note: If you are opening the Filter dialog box from the Requirements 
module, this dialog box also displays the Requirement Type box and the 
Hide Risk-Based Quality Management Columns check box.
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 2 Click the View Order tab.

Available Fields contains the names of all the fields you can display. 
Sorted Fields contains the names of the fields currently assigned a sorting 
priority.

 3 If you are working in the Requirements module, select a requirement type 
from the Requirement Type list. The View Order tab displays the relevant 
field names.

 4 If you are working in the Requirements module, you can select the Hide 
Risk-Based Quality Management Columns check box to hide the 
requirement fields related to risk-based quality management from the 
Available Fields list. Clear the check box to make the fields visible.

 5 Select field names and click the arrow buttons (> and <) to move a name 
between Available Fields and Sorted Fields. Click the double arrow buttons 
(>> and <<) to move all the names from one list to the other. You can also 
drag the field names between lists or double-click a column name to move a 
column between lists.
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 6 In Sorted Fields, select a field and use the Sort Ascending and Sort 
Descending buttons to sort the field in an ascending or descending order.

 7 In Sorted Fields, select a field and use the Move Field Up and Move Field 
Down buttons to set the sort priority. You can also drag the field names up 
or down.

 8 To copy the settings, click the Copy Filter Settings button. For more 
information, see “Copying Settings” on page 70.

 9 To clear the settings, click the Clear Filter button.

 10 Click OK to apply the sort order.
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Grouping Grid Records

When working with Quality Center grids, you can separate data into groups 
according to specified criteria. You can determine the information by which 
Quality Center groups records, and set the hierarchical order in which they 
are displayed (up to three levels). This enables you to navigate more easily 
through large sets of data.

For example, if you select the Assigned To column in the Defects Grid as the 
highest group by priority, records are grouped according to the names 
appearing in the Assigned To column. If you select Status and Severity as 
the next highest priorities respectively, test defects assigned the same name 
in the Assigned To column are next grouped according to their status, and 
then their severity.

Notes:

➤ You cannot select a group header and perform Quality Center actions on 
an entire group. To perform actions on multiple records, use Ctrl or Shift 
to select records.

➤ If you group records by a field containing multiple values, the 
information in each value is grouped as its entire value. This value is the 
category for grouping. For example, a value with English and French will 
be grouped once as English;French, and not as part of separate English 
and French categories. For more information on allowing multiple 
values, refer to the HP Quality Center Administrator’s Guide.

➤ The group by list displays only system and user-defined fields associated 
with a User List or Lookup List type field. For more information on field 
types, refer to the HP Quality Center Administrator’s Guide.
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To group grid records:

 1 Click the appropriate Set Filter/Sort button. The Filter dialog box opens.

Note: If you are opening the Filter dialog box from the Requirements 
module, this dialog box also displays the Requirement Type box and the 
Hide Risk-Based Quality Management Columns check box.

 2 Click the Group tab.

 3 If you are working in the Requirements module, select a requirement type 
from the Requirement Type list. The Group tab displays the relevant field 
names.

 4 If you are working in the Requirements module, you can select the Hide 
Risk-Based Quality Management Columns check box to hide the 
requirement fields related to risk-based quality management. Clear the 
check box to make the fields visible.
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 5 Click the Group items by arrow. Choose the field by which you want to 
group records.

 6 To group records by additional fields, click the Then by arrow and choose 
the field by which you want to group records. If you group records by more 
than one field, select fields in the hierarchical order that you want them to 
be displayed. Note that you cannot select a field that has already been 
selected.

 7 To remove a group level, change the level to (none). If you change a parent 
group level to (none), its child group levels automatically change to (none).

 8 To copy the settings, click the Copy Filter Settings button. For more 
information, see “Copying Settings” on page 70.

 9 To clear the settings, click the Clear Filter button.

 10 Click OK to close the Filter dialog box.

The grid records are grouped by the group by settings.

Copying Settings

You can copy and paste the filter, sort, and group by settings to and from the 
Clipboard. You can copy the settings and paste them to another project. You 
can also share the settings with another user by pasting them to an e-mail or 
a text file. 

To copy settings:

 1 Click the appropriate Set Filter/Sort button. The Filter dialog box opens.

 2 Click the Copy Filter Settings button. The settings are copied to the 
Clipboard.
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 3 To paste to another project, log in to the project to which you want to paste 
the settings, display the appropriate module, and open the Filter dialog box. 
Click the Paste Filter Settings button. Click OK.

To paste to an e-mail or a text file, click the paste button. 

Refreshing and Clearing Settings 

You can refresh and clear the filter, sort, and group by settings applied to 
Quality Center data.

➤ To refresh the data in a grid or tree, click the Refresh All button. 

➤ To clear all the filters and sorting priorities in a grid or tree, click the Set 
Filter/Sort arrow and choose Clear Filter/Sort.

Searching Records

You can use text search to search for records in predefined fields of the 
Requirements, Test Plan, and Defects modules. The searchable text fields are 
predefined by the project administrator in Project Customization. For more 
information on defining searchable fields, refer to the HP Quality Center 
Administrator’s Guide.

When you enter a keyword, Quality Center searches the predefined fields for 
the keyword or variations of the keyword. For example, if you type log, the 
search will find fields containing log, logs, logging, and logged. The search 
will not find login or logical because these are not variations of the word. For 
more information on search details, see “Search Considerations” on page 72.

If you have defined filter conditions for a module, you can restrict the 
search to the filtered records, or you can search all records in the module 
(this saves you having to clear the current filter and redefine it again). If you 
have a folder selected in the module, the search is still performed on all the 
records in the module, subject to the filtering option that you selected. 
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Quality Center displays the search results in a list, sorted in order of 
relevance. You can view search results, and display record details. You can 
customize the data by determining which columns are displayed and the 
order in which they appear. 

Note: Text search is only available if it has been enabled for the project. 
Contact your Quality Center site administrator if the search option is 
unavailable.

Search Considerations
When you use text search, you should consider the following:

➤ The search ignores the following: articles (a, an, the); coordinate 
conjunctions (and, but, for, nor, or); boolean operators (and, or, not, if, 
or, then).

➤ If you type more than one search word, the results will include all records 
that contain at least one of the search words.

➤ The letter case does not affect the results.

➤ The search ranks the results and displays them in order of relevance.

To search records:

 1 Click the Text Search button or choose Edit > Text Search. The text search 
pane opens in the lower part of the window. 

 2 In the Search for box, type the words you want to find. In the Test Plan 
module, specify whether you want to search Tests or Design Steps.
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 3 To search all records in the module, clear the Restrict to current filter check 
box. 

 4 Click Search. Quality Center performs the text search on the predefined 
fields and displays the search results in order of relevance. For more 
information on search details, see “Search Considerations” on page 72.

 5 To change the column appearance and order, click the Select Columns 
button. The Select Columns dialog box opens. For more information, see 
“Arranging Columns” on page 51.

 6 To view the list of predefined search fields set in Project Customization, click 
the Searchable Fields Information button. The list of predefined search fields 
is displayed. Click OK to close the searchable fields list.

 7 To display record details, select a record and click the record ID or Name 
link. Alternatively, select the record and click the Go to Entity button.

Note: In Quality Center tree views, the record details only display if the 
record matches the current filter. To display details for records that do not 
match this filter, change or clear the filter.

Exporting Data to a File 

You can export the data in a grid as a text file, Microsoft Excel worksheet, 
Microsoft Word document, or HTML document.

To export data to a file:

 1 You can export all grid data or selected records:

➤ To export all grid data, right-click the grid and choose Export > All. The 
Export All Grid Data dialog box opens.

➤ To export selected records in the grid, select the records using the Ctrl or 
Shift key. Right-click the grid and choose Export > Selected. The Export 
Selected Grid Data dialog box opens.

 2 In the Save in box, choose a location for the file.
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 3 In the File name box, type a name for the file.

 4 In the Save as type box, select a file type. 

 5 Click Save.
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Alerting on Changes

You can instruct Quality Center to create alerts automatically and send 
e-mail to notify those responsible when changes occur in your project that 
may impact the testing process. You can also add your own follow up alerts.

About Alerting Changes

You can keep track of changes to your requirements, tests, and defects as you 
perform project testing. There are two alerting functions available in 
Quality Center:

➤ Automatic notification alerts. Your Quality Center project administrator can 
activate alert rules. The rules are based on associations you make in 
Quality Center between requirements, tests, and defects. When an entity in 
your project changes, Quality Center alerts  any associated entities that 
may be impacted by the change. The alerts can be seen by all users. 
Quality Center also notifies the person responsible for the entity at the time 
of the change of any associated entities that may be impacted by the 
change. For more information, see “Understanding Alerts” on page 76 and 
“Viewing Alerts” on page 80.

This chapter describes: On page:
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Clearing Alerts 81
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➤ Follow up alerts. You can add a follow up flag  to a specific requirement, 
test, test instance, or defect to remind yourself to follow up on an issue. 
When the follow up date arrives, Quality Center sends you e-mail. For more 
information, see “Flagging for Follow Up” on page 82.

Understanding Alerts

When a requirement, test, or defect changes, Quality Center alerts the 
associated entities and can notify those responsible for any associated 
entities. The alert rules in Quality Center are based on the following 
associations you can create:

➤ You can associate a test in the test plan tree with a requirement. This is 
accomplished by creating requirements coverage in the Test Plan module, 
or by creating tests coverage in the Requirements module. For more 
information, see Chapter 18, “Linking Tests to Requirements.”

➤ You can associate a test instance with a defect. This is performed by creating 
Linked Defects in the Test Plan module, or by adding a defect during a 
manual test run. For more information, see Chapter 32, “Linking Defects.”

➤ You can create traceability links between requirements in the Requirements 
module. For more information, see Chapter 13, “Tracing Requirements.”

After you establish associations in your project, you can track changes using 
these associations. When an entity in your project changes, Quality Center 
alerts any associated entities that may be impacted by the change. The alerts 
can be seen by all users. Quality Center also notifies the person responsible 
for the entity at the time of the change of any associated entities that may 
be impacted by the change.
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Your Quality Center project administrator can activate four alert rules:

For more information on activating alert rules in Project Customization, 
refer to the HP Quality Center Administrator’s Guide.

Alert Example
Suppose you are using the QualityCenter_Demo project based on the 
Mercury Tours application. In Project Customization, your project 
administrator activates the first rule: When a requirement is modified, alert the 
associated tests. The project administrator also specifies that notifications be 
sent by e-mail.

Rule Description Entities Flagged User Notified by E-mail

1 When a requirement is 
modified, alert the 
associated tests.

Note: A change to the 
requirement can be any 
modification, excluding 
changes to the Direct 
Cover Status field and 
the risk-based quality 
management fields.

Tests covering the 
requirement

Test designer. 

2 When a defect status 
changes to “Fixed”, 
alert the associated test 
instances.

Test instances 
associated with the 
defect

Responsible tester for 
the test instance.

3 When a test run 
successfully (status 
changes to “Passed”), 
alert the linked defects.

Defects linked to 
the test run

User assigned the 
defect.

4 When a requirement is 
modified or deleted, 
alert traced to 
requirements and child 
requirements.

The requirement’s 
child requirements 
and traced to 
requirements 

Author of the 
requirement.
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In the Requirements module, your QA manager defines the requirement 
Page Download Time (under Application Performance). 

In the Test Plan module, the QA manager then defines a new test 
Connect_Site_Stress for this requirement (under Mercury Tours Site > 
Welcome Page). In the Details tab, the project administrator assigns the new 
test to designer Cecil.
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In the Req Coverage tab, the QA Manager links the Connect_Site_Stress test 
to the Page Download Time requirement. 

A QA tester, Mike, reviews the requirement Page Download Time and 
decides that 10 seconds to download the page is too long. He changes the 
requirement description to 7 seconds. As a result, Cecil now needs to adjust 
his test Connect_Site_Stress so that it meets the changed requirements.

With the rule activated, Mike’s change to the requirement causes 
Quality Center to flag the associated test. This alert can be seen by Cecil, the 
designer responsible for the test, and all other project users. 
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When clicking the Alerts flag, the Alerts dialog box opens and displays the 
details of the change. For more information, see “Viewing Alerts” on 
page 80. 

In addition, Cecil (being the test’s designer) receives an automatic 
Quality Center notification e-mail message that describes the change Mike 
made to the Page Download Time requirement and recommends that Cecil 
check the associated test, Connect_Site_Stress. Cecil clicks a link to open 
Quality Center and display the specified requirement or test.

Viewing Alerts

You can view a list of alerts for a selected entity. The entity can be one of the 
following:

➤ a requirement in a Requirements module view

➤ a test in the test plan tree or Test Grid

➤ a test instance in the Execution Grid

➤ a defect in the Defects Grid or Defect Details dialog box

Note: You can also view a list of all alerts for a selected module by selecting 
the Show <entity> with alerts option in the Filter dialog box. For more 
information, see “Advanced/Cross Filtering Records” on page 61.

For more information on how Quality Center creates alerts, see 
“Understanding Alerts” on page 76.

To view alerts:

 1 Select an entity with an alert as follows:

➤ In the main module, click the Alerts flag  in the Alerts column of the 
tree or grid. If this column is not visible, choose View > Indicator 
Columns. Alternatively, choose Edit > Alerts.

➤ In the Defect Details dialog boxes , click the Alerts button.
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A red flag indicates that the alert is new. A gray flag indicates that the alert 
has already been read.

The Alerts dialog box opens.

Quality Center displays the selected entity and lists the alerts. You can click 
a link in the dialog box to highlight the item in Quality Center.

 2 You can click the Delete Alert button to delete a specific alert, or click Clear 
All to delete all alerts for the entity. Click Yes to confirm. Note that you can 
only clear alerts that are assigned to you, or that are not assigned to any 
user. The user to which an alert is assigned is the user that is sent e-mail 
notification when the alert is triggered. For a list of alerts, and the users that 
are sent e-mail notification, see “Understanding Alerts” on page 76.

 3 Close the Alerts dialog box.

Clearing Alerts

You can clear an individual alert or all alerts for a selected entity from the 
Alerts dialog box. For more information on the Alerts dialog box, see 
“Viewing Alerts” on page 80.

In addition, you can clear all the alerts associated with all the entities in a 
Quality Center module. If you choose this option, only alerts associated 
with entities that match the current filter are cleared. In addition, you can 
only clear alerts that are assigned to you, or that are not assigned to any 
user. The user to which an alert is assigned is the user that is sent e-mail 
notification when the alert is triggered. This user is listed in the Alerts dialog 
box for the alert. For a list of alerts, and the users that are sent e-mail 
notification, see “Understanding Alerts” on page 76.
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To clear all the alerts for a module:

 1 If you are working in the Requirement, Test Plan, or Defects module, choose 
Edit > Clear Alerts. If you are working in the Test Lab module, choose Tests > 
Clear Alerts.

 2 Click Yes to confirm. The alerts are cleared.

Flagging for Follow Up

Quality Center enables you to add your own alerts, in addition to automatic 
traceability notifications. You can use follow up flags to remind yourself to 
follow up on something. For example, you can set a follow up flag on a 
defect to remind yourself to check the status in a week. 

You can set follow up flags for:

➤ a requirement in a Requirements module view

➤ a test in the test plan tree or Test Grid

➤ a test instance in the Execution Grid

➤ a defect in the Defects Grid or Defect Details dialog box

When you add a flag, Quality Center adds a gray flag icon  to the record. 
You can open the follow up alert at any time to view the details. When the 
follow up date arrives, Quality Center sends you e-mail and changes the flag 
icon to red.

Quality Center also displays an information bar for a follow up alert. This 
appears in the right pane of the test plan tree for a test follow up, in the Test 
Instance Properties dialog box for a test instance follow up, and in the 
Defect Details dialog box for a defect follow up.

Note: A follow up flag is specific to your user login name. Anyone else 
viewing the record does not see your follow up alert.

You can create new follow up alerts, or view and modify existing alerts.
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Creating Follow Up Alerts
You can create a follow up alert for a requirement, test, test instance, or 
defect. 

To create a follow up alert:

 1 Select the record you want to flag for follow up. Click the Flag for Follow Up 
button, or right-click the record and choose Flag for Follow Up. The Flag For 
Follow Up dialog box opens. 

 2 In Follow up by, select the date you want Quality Center to send the follow 
up e-mail.

 3 In Description, type the reminder you want to display.

 4 Click OK. Quality Center saves the follow up alert and adds the flag icon  
to the record.

Modifying Follow Up Flags
You can open a follow up alert you created for a record. You can view and 
modify the details, or delete the follow up. 
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To modify a follow up alert:

 1 Click the flag icon  in the Follow Up Flag column for the flagged record in 
the tree or grid. If this column is not visible, choose View > Indicator 
Columns. The Flag For Follow Up dialog box opens. 

 2 To modify the alert, change the Follow up by date or Description. Click OK 
to close the dialog box.

 3 To remove the follow up flag, click the Clear Flag button. Click Yes to 
confirm and close the dialog box.
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Adding Attachments

You can add an attachment to a Quality Center record.

This chapter describes: On page:
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About Adding Attachments

Throughout the testing process, you can add attachments to help illustrate 
your work. You can attach a file, URL, snapshot of your application, items 
from the Clipboard, or system information. When you add an attachment 
to a record, Quality Center adds the  icon to the record. 

You manage attachments using the Attachments dialog box. 

You can also manage attachments from the Attachments tab, the Test 
Instance Properties dialog box, the New Defect or Defect Details dialog box, 
and the Requirement Details dialog box.
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Attaching a File 

You can attach a file to a Quality Center record.

To attach a file:

 1 In the Attachments dialog box, click the File button. The Open dialog box 
opens.

 2 Choose a file name and click Open. Alternatively, double-click a file name.

The file name appears in the Attachments list, together with the size and 
date modified. An icon for the application associated with the file appears 
next to the file name.

 3 In the Description box, add any comments related to the attached file.

Attaching a URL 

You can attach a Uniform Resource Locator (URL) to a Quality Center 
record. This can be any valid URL scheme such as HTTP, FTP, Gopher, News, 
Mailto, and File.

To attach a URL:

 1 In the Attachments dialog box, click the URL button. The Attach Uniform 
Resource Locator (URL) dialog box opens.

 2 In the URL box, type a valid URL and click OK.

The URL appears in the Attachments list. An icon for your default Web 
browser appears next to the URL.

 3 In the Description box, add any comments related to the attached URL.
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Attaching a Snapshot 

You can attach images of your application to a Quality Center record.

To attach a snapshot:

 1 In the Attachments dialog box, click the Snapshot button. The Snapshot 
dialog box opens.

 2 Drag the camera icon onto an object that you want to capture. The captured 
image is displayed in the Snapshot dialog box.

 3 You can change the magnification level of the captured image. 

➤ Click Zoom Out or Zoom In to reach the desired magnification level. 

➤ Click Normal to return to the standard level.

 4 Click Attach. 

Quality Center assigns the image a unique file name with a .jpg extension. 
The file name appears in the Attachments list, with an image icon next to it. 
The size of the file and the date on which it was modified are also displayed.

 5 In the Description box, add any comments related to the attached snapshot.
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Attaching System Information

You can attach information about your machine to a Quality Center record.

To attach system information:

 1 In the Attachments dialog box, click the System Info button. The System 
Information dialog box opens.

 2 To attach information from a single tab, click a tab and click the Current 
Topic button. 
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 3 To attach information from all tabs, click All Topics.

The information is assigned a unique file name with a .tsi extension. The file 
name appears in the Attachments list, with an icon next to it. The size of the 
file and the date on which it was modified are also displayed.

 4 In the Description box, add any comments related to the attached text file.

Attaching Items from the Clipboard 

You can attach text and images that you copied to the Clipboard to a 
Quality Center record.

To attach an item from the Clipboard:

 1 Copy a text string or an image to the Clipboard.

 2 In the Attachments dialog box, click the Clipboard button.

A text string is assigned a unique file name with a .txt extension. An image 
is assigned a unique file name with a .jpg extension. The attached file 
appears in the Attachments list, with an icon next to it. The size of the file 
and the date on which it was modified are also displayed.

Managing Attachments

You can view, modify, save, and delete an attachment in the Attachments 
dialog box or tab.

Viewing Attachments
You can view an attachment in the Attachments list.

To view an attachment:

 1 In the Attachments list, select an attachment. The corresponding 
description is displayed underneath in the Description box.

 2 Double-click the attachment, or click the Download and Open button. The 
attachment opens in the application associated with it. For example, a URL 
opens in your default Web browser.
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Modifying Attachments
You can modify an attachment in the Attachments list. When you open an 
attachment in the associated application, Quality Center downloads the 
attachment to a local directory on your client machine. After making 
changes, you must save the attachment twice. First, you save it locally in the 
application in which you opened it. Then, in Quality Center, you click the 
Upload Selected button to save the local copy of the attachment to your 
Quality Center project.

To modify an attachment:

 1 Double-click an attachment in the Attachments list. A local copy of the 
attachment opens in the application associated with it. 

 2 Modify the attachment.

 3 Save the attachment in the application. This saves the local copy of your 
attachment.

 4 Close the attachment.

 5 In Quality Center, click the Upload Selected button in the Attachments 
dialog box. This saves the local copy to the Quality Center project.

Saving Attachments
You can save an attachment to the local directory of your client machine.

To save an attachment:

 1 In the Attachments list, select an attachment and click the Save As button. 
The Save Attachment dialog box opens.

 2 In the Save in box, choose a location for the file.

 3 In the File name box, type a name for the file.

 4 Click Save. The attachment is downloaded and saved to a local directory on 
your client machine.
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Deleting Attachments
You can delete an attachment from the Attachments list.

To delete an attachment:

 1 In the Attachments list, select the attachment to delete. To select more than 
one attachment, use the CTRL key.

 2 Click the Delete Selected button and click Yes to confirm.
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Working with Favorite Views

A favorite view is a view of a Quality Center window with the settings you 
apply to it. You can save your favorite views and reload them in the future.

About Working with Favorite Views

You determine the way a Quality Center window looks by selecting certain 
settings for it. For example, these settings may include applying a filter to 
grid columns, sorting fields in a report, or setting the appearance of a graph. 
You can save a favorite view for future use and then load it as necessary.

You save favorite views in either a public folder or a private folder. Views in a 
public folder are accessible to all users. Views in a private folder are 
accessible only to the user who created them. 

Some favorite view commands are accessible only to certain user groups. For 
more information on user group privileges, refer to the HP Quality Center 
Administrator’s Guide.

This chapter describes: On page:
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Note: Working with favorite views is different from the description in this 
chapter for the Test Lab module, Quality Center reports and graphs, and 
Document Generator. 

➤ In the Test Lab module, choose Tests > Favorites to display the favorite 
view commands. Choose View to load an existing view, Add to add a new 
view, and Organize to organize your views. 

➤ In Quality Center reports and graphs, click the Add to Favorites button 
to add a new view and the Edit Favorites button to organize your views.

➤ In the Document Generator, click the Add to Favorites button to add a 
new view and the Favorites button to organize your views.

Adding Favorite Views 

You can add a view to your private folder or to the public folder.

To add a favorite view:

 1 Choose Favorites > Add to Favorites. The Add Favorite dialog box opens.
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 2 In the Name box, type a name for the view.

 3 In Location: 

➤ Select Private to add the view to your private folder. Favorite views in this 
folder can only be accessed by you. 

➤ Select Public to add the view to the common folder. Favorite views in this 
folder can be accessed by all users of the project.

The favorite views that already exist in the folder you selected are displayed 
under Existing Favorites.

 4 Click OK. The new view is added to your private folder or to the public 
folder.

Loading Favorite Views

You can load an existing favorite view in a Quality Center window.

To load a favorite view:

➤ To load a recently used favorite view, open the Favorites menu and choose a 
view.

Note: By default, Quality Center displays the four most recently used views 
on the Favorites menu. You can define the number of views displayed on 
the menu by setting the FAVORITES_DEPTH parameter in the 
Site Configuration tab in Site Administration. For more information, refer to 
the HP Quality Center Administrator’s Guide.

➤ To load a favorite view, choose Favorites > Private or Favorites > Public and 
choose a view.

Alternatively, on the module toolbar, select a view from the Favorite bar. By 
default, the Favorite bar is not displayed. To display it, choose View > 
Favorite Bar. The Favorite bar is available from Quality Center grid views 
only.
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Updating Views

You can update the settings of an existing view.

To update a view:

 1 Load a favorite view from the Favorites menu. For more information, see 
“Loading Favorite Views” on page 95.

 2 Make changes to the view.

 3 Choose Favorites > Add to Favorites. The Add Favorite dialog box opens.

 4 Under Existing Favorites, select the view name and click OK.

 5 Click Yes to overwrite the previous settings.

Organizing Favorite Views

You can organize the list of favorite views in the private and public folders 
by changing the properties of a view and by deleting views.

To organize favorite views:

 1 Choose Favorites > Organize Favorites. The Organize Favorites dialog box 
opens.
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 2 To change properties, select a view from the list and click Properties. The 
Properties dialog box opens.

 3 In the Name box, type a new name for the view. 

 4 Under Location:

➤ Select Private to add the view name to your private folder. It can only be 
accessed by you.

➤ Select Public to add the view name to a common folder. It can be 
accessed by all users.

 5 Click OK to save the properties. Click Yes to confirm.

 6 To delete a favorite view, select it from the list and click Delete. Click OK to 
confirm.

 7 Click Close to close the Organize Favorites dialog box.
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7
The Release Management Workflow

You begin the application testing process by defining a releases tree in the 
Releases module. 

This chapter describes how you use Quality Center to manage the release life 
cycle. The release management workflow consists of the following stages.

Define Releases and 
Cycles

Assign
Requirements

Assign and Run 
Test Sets

Assign Defects

Analyze
Releases and Cycles
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Before you begin using Quality Center, make sure you have a project in 
which to place your data. For information on creating projects, refer to the 
HP Quality Center Administrator’s Guide.

Defining Releases and Cycles

The foundation of the Releases module is the releases tree. This tree enables 
the modeling of upcoming releases within a hierarchical tree structure. 

A project manager starts by defining a release folder along with its releases. A 
release represents a group of changes in one or more applications that will 
be available for distribution at the same time. After defining the release, a 
QA manager defines cycles. A cycle is a set of development and quality 
assurance efforts performed to achieve a common goal based on the release 
timeline.

For example, suppose you are defining upcoming releases for the sample 
Mercury Tours application. The Mercury Tours Application folder contains 
Release 10.5. This release includes four cycles. You might define the releases 
and cycles in the releases tree as follows:

For more information on defining releases, see Chapter 9, “Creating a 
Releases Tree.”
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Assigning Requirements

After defining the releases tree, the QA manager defines and reviews the 
requirements in the Requirements module and assigns them to releases and 
cycles. Requirements describe in detail what needs to be tested in your 
application. 

For example, in the requirements tree, under the Mercury Tours Application 
folder, you might assign Booking System and Application Security to the 
Cycle 1 - New Features cycle in the Release 10.5 release.

Requirements are used as a basis for the test plan in the Test Plan module. 
The tests you create during the test plan phase should cover these 
requirements. 

For more information on requirements, see Chapter 12, “Developing the 
Requirements Tree.”

For more information on test plan, see Chapter 17, “Developing the Test 
Plan Tree.” For more information on coverage, see Chapter 18, “Linking 
Tests to Requirements.”
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Assigning and Running Test Sets

After the QA manager assigns requirements, the QA team leader assigns each 
test set folder in the Test Lab module to a cycle. A test set is a group of test 
instances in a Quality Center project designed to achieve specific test goals.

For example in the test set tree, you might define the following test set 
folders for Release 10.5.

Each test set folder is assigned to a cycle. For example, the Cycle 1 test set 
folder is assigned to the Cycle 1 - New Features cycle. 

After the QA team leader assigns test set folders to a cycle, the QA engineer 
runs the test sets under these test set folders. 

For more information on test sets, see Chapter 24, “Creating Test Sets.” For 
more information on running tests, see Chapter 26, “Running Tests 
Manually” and Chapter 27, “Running Tests Automatically.”
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Assigning Defects

If an application flaw is detected while running a test set, the QA engineer 
can submit a defect. Quality Center automatically creates a link between the 
test run, associated release and cycle, and the new defect. 

Suppose a defect is detected while running a test instance from a test set in 
the Cycle 1 test set folder. When the defect is initially submitted to the 
project, the Detected in Release field is assigned to the Release 10.5 release, 
and the Detected in Cycle field is assigned to the Cycle 1 - New Features 
cycle. 

While reviewing and deciding which new defects need to be fixed, the QA 
manager assigns them to the appropriate release and cycle. 

Continuing with this example, suppose this defect is planned to be fixed in 
the next cycle. The Target Release field would be assigned to Release 10.5, 
and the Target Cycle field would be assigned to Cycle 2 - New Features + 
Regression. 

A defect can be submitted to a Quality Center project from any module at 
any stage of the testing process.

For more information on submitting defects, see Chapter 31, “Adding and 
Tracking Defects.”

Analyzing Releases and Cycles

Following test runs, the QA manager reviews the test progress to determine 
how well it meets the release goals. The QA manager can also determine 
how many defects were resolved, and how many still remain open. The 
results can be analyzed at a release or at a cycle level. 

The QA manager can track the progress of the testing process in real time by 
analyzing the releases tree and ensuring that it matches the release goals. For 
more information on analyzing results at a release or at a cycle level, see 
Chapter 9, “Creating a Releases Tree.”
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8
The Releases Module at a Glance

This chapter introduces the key elements in the Releases module.

This chapter describes: On page:

The Releases Module 108

The Releases Menu Bar 109

The Releases Toolbar 109

The Release and Cycle Fields 110
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The Releases Module

You define releases and cycles in Quality Center using the Releases module, 
which is opened by clicking the Releases button on the sidebar.

The Releases module contains the following key elements:

➤ Releases menu bar. Displays drop-down menus of Releases module 
commands. 

➤ Releases toolbar. Contains buttons of Releases module commands. 

➤ Details tab. Describes the release folder, release, or cycle currently selected in 
the releases tree. It also indicates range of release and cycle dates. The 
Statistics pane displays the requirements and test set folders associated with 
the release or cycle.

➤ Attachments tab. Lists attachments that provide additional information on 
the currently selected release folder, release, or cycle. For more information, 
see Chapter 5, “Adding Attachments”.
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➤ Progress tab. Shows a high-level overview of the progress of your release or 
cycle. For more information, see “Viewing Coverage Progress of Releases and 
Cycles” on page 121.

➤ Quality tab. Shows the number of defects opened over the course of your 
release or cycle. It also shows the number of outstanding defects. For more 
information, see “Viewing Defects of Releases and Cycles” on page 125.

The Releases Menu Bar 

The Releases menu bar contains the following menus.

➤ The Releases menu contains commands that enable you to add release 
folders, releases, and cycles. 

➤ The Edit menu contains commands that enable you to cut, paste, delete, 
and rename release folders, releases, and cycles. It also contains a command 
to create a duplicate of a cycle.

➤ The View menu contains commands that enable you to expand and collapse 
the releases tree. It also contains a command to refresh the releases tree.

The Releases Toolbar 

The Releases toolbar contains the following buttons.

New Release Folder. Adds a new release folder to the releases tree. 

New Release. Adds a new release to the releases tree. 

New Cycle. Adds a new cycle to the releases tree.

Cut. Cuts a release folder or a release from the releases tree to move it to a 
different location in the tree.

Paste. Pastes a cut release folder or a release to the specified location in the 
tree.

Duplicate Cycle. Creates a duplicate of a cycle within the same release.
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Delete. Deletes the selected item. Deleting a release folder also deletes its 
releases and cycles. Deleting a release also deletes its cycles.

Refresh All. Refreshes the releases tree and tabs so that it displays the most 
up-to-date data.

The Release and Cycle Fields 

The Details tab of the Releases module displays the following fields:

Notes: 

➤ The dates for the cycles must be contained within the dates for the 
releases.

➤ You can add user-defined fields and change the label of any of the fields 
in the Releases module. For more information, refer to the 
HP Quality Center Administrator’s Guide.

Field Description

Name The release folder, release, or cycle name.

Start Date The date on which the release or cycle starts. Click the down 
arrow to display a calendar and select a start date.

End Date The date on which the release or cycle ends. Click the down 
arrow to display a calendar and select an end date.

Statistics Statistics on the requirements and test set folders assigned to 
your releases and cycles.

Description The release folder, release, or cycle description.
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9 
Developing the Releases Tree

The issuing of application releases is often challenging. It requires aligning 
your business priorities and quality expectations with your project 
requirements, tests, and defects. Most applications require testing on 
multiple hardware platforms, multiple configurations (computers, operating 
systems, and browsers), and multiple application versions. Managing all 
aspects of an application release can be time-consuming and difficult. In the 
Releases module, you can organize and track your upcoming releases by 
defining a releases tree.

This chapter describes: On page:

About Developing the Releases Tree 112

Creating a Releases Tree 117

Adding Releases to Release Folders 117

Adding Cycles to Releases 118

Viewing Assigned Requirements and Test Set Folders 119

Viewing Coverage Progress of Releases and Cycles 121

Viewing Defects of Releases and Cycles 125

Modifying the Releases Tree 127
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About Developing the Releases Tree 

In the Releases module, you can organize and track your upcoming releases 
by defining a hierarchical releases tree containing releases and cycles. A 
release represents a group of changes in one or more applications that will be 
available for distribution at the same time. Each release can contain a 
number of cycles. A cycle represents a development and QA cycle based on 
the project timeline. Both releases and cycles have defined start and end 
dates.

After defining the releases tree, you define requirements in the 
Requirements module and assign them to releases and cycles (see 
Chapter 12, “Developing the Requirements Tree”). Requirements describe in 
detail what needs to be tested in your application.

To cover your requirements (making sure that all of the features developed 
in a particular cycle are fully tested), you create tests in the Test Plan module 
(see Chapter 17, “Developing the Test Plan Tree” and Chapter 18, “Linking 
Tests to Requirements”). 

Then in the Test Lab module, you create a test set folder to store your test 
sets. Next, you assign the test set folder to a cycle. You then add test sets to 
your test set folder. Finally, you complete the test coverage planning by 
adding tests to each test set (see Chapter 24, “Creating Test Sets”).

You then run your test sets (see Chapter 26, “Running Tests Manually,” and 
Chapter 27, “Running Tests Automatically”). If application flaws are 
detected , you can submit defects, which you assign to a particular release 
and cycle in the releases tree (see Chapter 31, “Adding and Tracking 
Defects”). This enables all relevant developers and testers to determine what 
needs to be fixed and the target date for each fix. 

After running the specified test sets, you can review the release progress in 
the Releases module to determine how well it meets your release goals. You 
can also determine how many defects were detected and how many defects 
are outstanding. You can analyze results at the level of a release or a cycle.
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Release Management Example

Suppose you are developing a flight reservation application. In four months, 
you plan on releasing version 10.5. Your release includes four cycles. The 
first cycle is for testing new features. The second cycle is for regression 
testing. The third cycle is for sanity testing. The fourth cycle verifies the full 
functionality of the application. Your releases tree may be defined as 
follows:

In the Requirements module, you would decide which requirements need to 
be covered in each cycle and assign them to the relevant cycles accordingly. 
In the Test Plan module, you would then create tests and associate them 
with the assigned requirements to create coverage. 

In the Test Lab module, you would create test set folders and assign them to 
specific cycles. For this example, you might define the Cycle 1, Cycle 2, 
Cycle 3, and Cycle 4 test set subfolders:

Note that after assigning a test set folder to a cycle, the test set folder icon 
 is replaced by the assigned test set folder icon .
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For each assigned test set folder, you would then create test sets and add 
tests to them, for example:

After running the test sets from the assigned test set folders, you can review 
the progress in the Progress tab to determine how well it meets your release 
goals. This provides you with a high-level overview of the progress of your 
release. The following shows the progress in the Release 10.5 example.
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The top pane shows the total and remaining days in the release, total test 
instances for the release, actual and remaining test instances to run, and 
more. 

The bottom pane displays the Coverage Progress graph. The curves 
displayed in this graph are accumulative, that is, each curve is calculated by 
accumulating of all the release information from the beginning of the 
release. 

The Assigned requirements curve indicates the distribution of the assigned 
requirements within the release's cycles. In this example, the curve indicates 
a 100% value in the Cycle 4 - Full cycle. 

The Planned coverage curve below the Assigned requirements curve 
indicates the percentage of requirements that are covered throughout the 
release. In this example only 60% of the requirements are covered in the 
Cycle 4 - Full cycle.

The Executed coverage curve below the Planned coverage curve indicates 
the percentage of tests that were run as the release progressed. In this 
example, the curve indicates that at Cycle 4 - Full only 40% of the assigned 
tests were run.

The Passed Coverage curve is below the Executed coverage curve. It 
indicates the test runs in which the most recent status is passed. In this 
example, the curve indicates a 20% value in the Cycle 4 - Full cycle.
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For each cycle, you can view the number of defects submitted and their 
severity in the Quality tab. Suppose that while running the Cycle 1 test set 
under the Release 10.5 test set folder, four application flaws are detected. In 
the Releases tree, you would select Cycle 1 - New Features cycle and click 
the Quality tab to view the number of defects opened over the course of the 
cycle. The defects are categorized by severity level, ranging from 1-Low to 
5-Urgent.

In the Defect Opening Rate graph, you can see that out of the four defects 
detected while testing the first cycle, two defects are assigned a severity 
value of 3-High, one defect is assigned 5-Urgent, and one defect is assigned 
2-Medium.

In the Outstanding Defects graph, you can see that two out of the four 
defects are still outstanding. One defect is assigned 2-Medium the other 
defect is assigned 3-High.
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Creating a Releases Tree

You define a hierarchical framework for your releases by creating a releases 
tree. For each release folder in the tree, you define releases and add cycles to 
them. You start a releases tree by adding a folder under the Releases root 
folder.

To create a releases tree:

 1 In the releases tree, select the Releases folder.

 2 Click the New Release Folder button or choose Releases > New Release 
Folder. The New Release Folder dialog box opens.

 3 Type the Release Folder Name and click OK. The new folder is added under 
Releases in the releases tree.

 4 In the Details tab, type a description for the release folder.

 5 Click the Attachments tab to add an attachment to the folder if necessary. 
An attachment can be a file, URL, snapshot of your application, an item 
from the Clipboard, or system information. For more information, see 
Chapter 5, “Adding Attachments.”

 6 To create additional folders, select a folder and repeat steps 2 to 5.

Adding Releases to Release Folders

After creating the releases tree, you add releases to your release folders. For 
each defined release, you add cycles.

To add a release to a release folder:

 1 Select a release folder in the releases tree.

 2 Click the New Release button or choose Releases > New Release. The New 
Release dialog box opens. 

 3 Type the Release Name and click OK. The new release appears under the 
selected release folder.
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 4 Enter the following release details in the Details tab:

 5 Click the Attachments tab to add an attachment to the release if necessary. 
An attachment can be a file, URL, snapshot of your application, an item 
from the Clipboard, or system information. For more information, see 
Chapter 5, “Adding Attachments.”

 6 To create additional releases, select a release folder and repeat steps 2 to 5.

Adding Cycles to Releases

After adding releases to your release folders, you add cycles to each release.

To add a cycle to a release:

 1 Select a release in the releases tree.

 2 Click the New Cycle button or choose Releases > New Cycle. The New Cycle 
dialog box opens. 

 3 Type the Cycle Name and click OK. The new cycle appears under the 
selected release.

Field Description

Start Date The date on which the release starts. Click the down arrow to 
display a calendar and select a start date.

End Date The date on which the release ends. Click the down arrow to 
display a calendar and select an end date.

Description Type a description of the release.
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 4 Enter the following cycle details in the Details tab:

Note that the dates for the cycles must be contained within the dates of the 
releases.

 5 Click the Attachments tab to add an attachment to the cycle if necessary. An 
attachment can be a file, URL, snapshot of your application, an item from 
the Clipboard, or system information. For more information, see Chapter 5, 
“Adding Attachments.”

 6 To create additional cycles, select a release and repeat steps 2 to 5.

Viewing Assigned Requirements and Test Set Folders

You can view statistics on the requirements and test set folders assigned to 
your releases and cycles.

To view assigned requirements for a release or a cycle:

 1 In the releases tree, select a release or a cycle.

Field Description

Start Date The date on which the cycle starts. Click the down arrow to 
display a calendar and select a start date.

End Date The date on which the cycle ends. Click the down arrow to 
display a calendar and select an end date.

Description Type a description of the cycle.
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 2 Click the Details tab. The details for the release or cycle are displayed.

 3 If you select a release, under the Statistics area, you can view the following 
statistics:

Option Description

Requirements assigned to 
release

Displays the number of requirements associated 
with the selected release. To view the requirements 
assigned to the release in the Requirements 
module, click the link displaying the number of 
requirements. Alternatively, in the releases tree, 
right-click the release and choose Show 
Requirements.
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If you select a cycle, under the Statistics area, you can view the following 
statistics:

Viewing Coverage Progress of Releases and Cycles

The Progress tab displays statistics and graphs to provide visual indications 
of the current progress of your release or cycle. This tab shows information 
such as elapsed and remaining days, completed and remaining test 
instances to run, and actual and required execution rate. 

To view coverage progress of a release or a cycle:

 1 Select a release or a cycle in the releases tree.

Option Description

Requirements assigned to 
cycle

Displays the number of requirements associated 
with the selected cycle. To view the requirements 
assigned to the cycle in the Requirements module, 
click the link displaying the number of 
requirements. Alternatively, in the releases tree, 
right-click the cycle and choose Show 
Requirements.

Test set folders assigned to 
cycle

Displays the number of test set folders associated 
with the selected cycle.To view the test set folders 
assigned to the cycle in the Test Lab module, click 
the link displaying the number of test set folders. 
Alternatively, in the releases tree, right-click the 
cycle and choose Show Test Set Folders.
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 2 Click the Progress tab.

For each release, you can view the following information in the top pane of 
the Progress tab:

Option Description

Total days in release The total number of days in a selected release (end 
date - start date). 

Remaining days in 
release

The total number of days remaining in a selected 
release.

Total test instances for 
release

The total number of test instances included in the test 
set folders assigned to a selected release.

Remaining test 
instances to run

The total number of test instances included in the 
assigned test set folders of a selected release that have 
not yet run.

Required execution rate 
(test instances/day)

The average number of test instance runs required per 
day for the remaining days in a selected release.

Actual execution rate 
(test instances/day)

The average number of test instance runs per day in 
the selected release up to the current date.
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For each cycle, you can view the following information in the top pane of 
the Progress tab:

Days (progress bar) The percentage of days elapsed in a selected release.

Test Instance Runs 
(progress bar)

The percentage of test instance runs completed in a 
selected release.

Option Description

Total days in cycle The total number of days in a selected cycle (end date - 
start date). 

Remaining days in cycle The total number of days remaining in a selected 
cycle.

Total test instances for 
cycle

The total number of test instances included in the test 
set folders assigned to a selected cycle.

Remaining test 
instances to run

The total number of test instances included in the 
assigned test set folders of a selected cycle that have 
not yet run.

Required execution rate 
(test instances/day)

The average number of test instance runs required per 
day for the remaining days in a selected cycle.

Actual execution rate 
(test instances/day)

The average number of test instance runs per day in 
the selected cycle up to the current date.

Days (progress bar) The percentage of days elapsed in a selected cycle.

Test Instance Runs 
(progress bar)

The percentage of test instance runs completed in a 
selected cycle.

Option Description
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 3 To customize the Coverage Progress graph for a selected release, select or 
clear the check boxes for the following options:

 4 To customize the Coverage Progress graph for a selected cycle, select or clear 
the check boxes for the following options:

 5 To refresh the data in the Progress tab, click the Refresh All button. 

Option Description

Assigned 
requirements

The accumulated percentage of requirements assigned to all 
cycles within a release. 

Planned 
coverage

The accumulated percentage of tests planned for all cycles 
within a release. 

Executed 
coverage

The accumulated percentage of tests that ran in all cycles 
within a release. 

Passed coverage The accumulated percentage of tests that ran successfully in 
all cycles within a release. 

Option Description

Planned coverage The percentage of tests planned to be run each day 
within a cycle.

Executed coverage The percentage of tests that ran each day within a 
cycle.

Passed coverage The percentage of tests that ran successfully each day 
within a cycle.
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Viewing Defects of Releases and Cycles

The Quality tab helps you draw conclusions quickly and see the number of 
defects submitted over the course of a release or cycle. The defects are 
categorized by severity in terms of how they impact system operation. The 
severity level ranges from Low-1 to Urgent-5. You can view the graphs at 
any stage of the testing process to check the progress of your release.

For each release, you can view the following graphs in the Quality tab:

Graph Description

Defect Opening 
Rate

Displays the number of defects opened over the course of a 
release. The graph displays defects whose Detected in Release 
value matches the selected release. The defects are grouped 
according to their level of Severity. The x-axis displays the 
number of defects according to their severity on the last day 
of each cycle. 

Outstanding 
Defects

Displays the number of outstanding defects for the selected 
release. The graph displays defects whose Target Release 
value matches the selected release or is empty. The defects are 
grouped according to their level of Severity. The x-axis 
displays the outstanding defects according to their severity 
on the last day of each cycle. By default, New, Open, and 
Reopened defects are considered outstanding. 
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For each cycle, you can view the following graphs in the Quality tab:

To view the defects for a release or a cycle:

 1 Select a release or a cycle in the releases tree.

 2 Click the Quality tab.

The tab displays the Defect Opening Rate and Outstanding Defects graphs 
for the selected release or cycle.

Graph Description

Defect Opening 
Rate

Displays the number of defects opened over the course of a 
cycle. The graph displays defects whose Detected in Cycle 
value matches the selected cycle. The defects are grouped 
according to their level of Severity. The x-axis displays the 
number of existing defects for each date.

Outstanding 
Defects

Displays the number of outstanding defects for a cycle. The 
graph displays defects whose Detected in Cycle value matches 
the selected cycle. The defects are grouped according to their 
level of Severity. The x-axis displays the number of existing 
defects that are outstanding on each date. By default, New, 
Open, and Reopened defects are considered outstanding.
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 3 In the Defect Opening Rate graph, you can select or clear the check boxes of 
the defect severity levels displayed in this graph.

 4 In the Outstanding Defects graph, you can:

➤ Select or clear the check boxes of the defect severity levels displayed in 
this graph.

➤ Determine which defects are displayed in the graph by filtering them by 
their status. Click Configure Outstanding Defects. In the Configure 
Outstanding Defects dialog box, select a defect status and click the arrow 
buttons (> and <) to move it between Available Defect Status and Visible 
Defect Status. To move all of the types from one list to the other, click 
the double arrow buttons (>> and <<). Click OK. 

 5 To refresh the data in the Quality tab, click the Refresh All button. 

Modifying the Releases Tree

This section on modifying the releases tree includes the following topics:

➤ Renaming Release Folders, Releases, and Cycles

➤ Moving Release Folders and Releases

➤ Duplicating Cycles

➤ Deleting Release Folders, Releases, and Cycles

Renaming Release Folders, Releases, and Cycles
You can rename a release folder, release, or cycle.

To rename a release folder, release, or cycle:

 1 Select an item from the releases tree.

 2 Choose Edit > Rename.

 3 Edit the item name and press ENTER. 
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Moving Release Folders and Releases
You can move a release folder or a release to a different location in the 
releases tree. Moving a release folder also moves its releases and cycles. 
Moving a release also moves its cycles. The Releases root folder cannot be 
moved. 

Tip: You can also move a release folder or a release to a new location in the 
releases tree by dragging it.

To move a release folder or a release:

 1 Select a release folder or a release from the releases tree. To move more than 
one item, press the CTRL key and select the items you want to move.

 2 Click the Cut button. Alternatively, choose Edit > Cut.

 3 Select a folder in the releases tree.

 4 Click the Paste button. Alternatively, choose Edit > Paste.

Duplicating Cycles
You can create a duplicate of a cycle within the same release. 

To duplicate a cycle:

 1 Select a cycle from the releases tree. 

To duplicate more than one cycle, press the CTRL key and select the cycles 
you want to duplicate. You can select only multiple cycles that belong to the 
same release.

 2 Click the Duplicate Cycle button. Alternatively, choose Edit > Duplicate 
Cycle. A duplicate copy is added to the release.
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Deleting Release Folders, Releases, and Cycles
You can delete a release folder, release, or cycle. When you delete a folder, 
the releases and cycles under the folder are also deleted. When you delete a 
release, the cycles under it are also deleted.

Note: Deleting a release folder, release, or cycle, also unassigns the 
associated requirements, test set folders, and defects.

To delete a release folder, release, or cycle:

 1 Select an item from the releases tree. To delete more than one item, press the 
Ctrl key and select the items you want to delete.

 2 Click the Delete button. Alternatively, choose Edit > Delete. A confirmation 
message displays.

 3 Click Yes to confirm. The items are deleted.
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10
The Requirements Specification 
Workflow

After you define a releases tree in the Releases module, you continue the 
application testing process by specifying requirements. Requirements 
describe in detail what needs to be tested in your application, and provide 
the test team with the foundation on which the entire testing process is 
based. After specifying requirements, you assign them to the releases and 
cycles defined in the Releases module. 
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This chapter describes how you use the Requirements module to specify 
requirements. The requirements specification workflow consists of the 
following: 

Define
Testing Scope

Create
Requirements

Detail
Requirements

Assign to Releases

Analyze
Requirements
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Defining the Testing Scope

The test team begins the testing process by gathering all available 
documentation on the application under test, such as marketing and 
business requirements documents, system requirements specifications, and 
design documents. 

Use these documents to obtain a thorough understanding of the application 
under test and determine your testing scope—test goals, objectives, and 
strategies.

Ask the following questions when determining your testing scope:

➤ What is the main purpose and direction of the application?

➤ What are the major features of the application?

➤ What is the relative importance of each element in the application 
functionality?

➤ What are the critical or high-risk functions of the application?

➤ What are your testing priorities? 

➤ Do your customers/end-users agree with your testing priorities?

➤ What are your overall quality goals?

You can use risk-based testing to help you decide how to allocate the testing 
resources you have available. For more information, see Chapter 14, 
“Calculating Requirement Risks.”
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Creating the Requirements Outline

Quality Assurance managers use the testing scope to determine the overall 
requirements for the application under test. They define requirement topics 
and assign them to the QA testers in the test team. Each QA tester uses 
Quality Center to record the requirement topics for which they are 
responsible.

Requirement topics are recorded in the Requirements module by creating a 
requirements tree. The requirements tree is a graphical representation of your 
requirements specification, displaying the hierarchical relationship between 
different requirements.

For example, consider a flight reservation application that lets you manage 
flight scheduling, passenger bookings, and ticket sales. The QA manager 
may define your major requirements as: Online Travel Booking Services, 
Online Travel Information Source, Profile Management, Reservation 
Management, Booking System, Application Security, Application Usability, 
Application Client System, and Application Performance. For the complete 
example, refer to the QualityCenter_Demo project.

For more information, see Chapter 12, “Developing the Requirements Tree.”
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Defining Requirements

For each requirement topic, a QA tester creates a list of detailed 
requirements in the requirements tree. For example, the requirement topic 
Profile Management may be broken down into the following requirements: 

Each requirement in the tree is described in detail and can include any 
relevant attachments. The QA tester assigns the requirement a priority level 
which is taken into consideration when the test team creates the test plan. 

After defining your requirements, you can add traceability between the 
requirements. When analyzing the impact of a change proposed in a specific 
requirement, traceability shows the other requirements that the change 
might affect. For more information, see Chapter 13, “Tracing 
Requirements.”
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Assigning Requirements to Releases

QA managers assign the requirements to releases and cycles in the releases 
tree in the Releases module. The releases tree specifies past, current, and 
upcoming product releases within a hierarchical tree structure. A release 
represents a group of changes in one or more applications that will be 
available for distribution at the same time. A cycle is a set of development 
and quality assurance efforts performed to achieve a common goal based on 
the release timeline. For more information on assigning requirements, see 
“Assigning Requirements to Releases or Cycles” on page 164.

The assigned requirements are then used as a basis for the test plan in the 
Test Plan module. The tests you create during the test plan phase are then 
linked to these requirements to create coverage. For more information on 
requirements and tests coverage, see Chapter 18, “Linking Tests to 
Requirements.” 

Analyzing your Requirements Specification

QA managers review the requirements, ensuring that they meet the testing 
scope defined earlier. They change a requirement from a Not Reviewed 
status to a Reviewed status once it is approved. 

To help review the requirements, you can generate reports and graphs. For 
more information, see Chapter 33, “Generating Reports,” and Chapter 34, 
“Generating Graphs.”
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11
The Requirements Module at a Glance

This chapter introduces the key elements in the Requirements module.

The Requirements Module

You specify requirements in Quality Center using the Requirements module, 
which is opened by clicking the Requirements button on the sidebar. You 
can display requirements in the following views: Requirements Tree, 
Requirement Details, Requirements Grid, or Coverage Analysis.

Note: You can also import requirements to your Quality Center project from 
Microsoft Word, Excel, or other third-party requirement management tools. 
To import requirements, you must first install the appropriate 
HP Quality Center add-in. For more information, refer to the 
HP Quality Center Installation Guide. 

This chapter describes: On page:

The Requirements Module 139

The Requirements Menu Bar 151

The Requirements Toolbar 152

The Requirement Fields 153
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Requirements Tree
The Requirements Tree view enables you to display requirements in a tree. 

The Requirements Tree view contains the following key elements:

➤ Requirements menu bar. Displays drop-down menus of Requirements 
module commands. For more information, see “The Requirements Menu 
Bar” on page 151.

➤ Requirements toolbar. Contains buttons for commands commonly used 
when creating and modifying requirements. For more information, see “The 
Requirements Toolbar” on page 152.
140



Chapter 11 • The Requirements Module at a Glance
➤ Indicator columns. Indicates that the specified requirement has 
attachments, linked defects, alerts, and follow up flags. Choose View > 
Indicator Columns to display these columns.

➤ Requirements tree. Displays requirements in a tree.

➤ Information Panel. Displays the following tabs: Description, Comments, 
Attachments, History, and Rich Text. Choose View > Information Panel or 
click the Show arrow  to display these tabs.
 

Column Description

Attachments Click the  icon to view attachments for the 
requirement. For more information, see Chapter 5, 
“Adding Attachments.”

Linked Defects Click the  icon to view linked defects for the 
requirement. For more information, see Chapter 32, 
“Linking Defects.”

Alerts Click the  icon to view alerts for the requirement. 
For more information, see “Viewing Alerts” on 
page 80.

Follow Up Flags Click the  icon to view follow up alerts for the 
requirement. For more information, see “Flagging 
for Follow Up” on page 82.

Tab Description

Description Displays a description of the currently selected 
requirement. 

Comments Displays comments about the currently selected 
requirement. 

Attachments Lists attachments that provide additional 
information about the currently selected 
requirement. For more information, see Chapter 5, 
“Adding Attachments”.
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Tip: To find a specific requirement by ReqID in the Requirements Tree view, 
choose Requirements > Go to Requirement, and enter the requirement ID. 
To display the requirement ID, select the ReqID column using the Select 
Columns dialog box. You can only go to requirements that are in the 
current filter.

History Displays a list of changes made to the currently 
selected requirement. For more information, see 
“Viewing Requirement History” on page 175.

Rich Text Enables you to add, view, and edit Microsoft Word 
rich text directly from Quality Center. For more 
information, see “Adding Rich Text to 
Requirements” on page 165.

Tab Description
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Requirement Details
The Requirement Details view enables you to display for requirements the 
tests with which they are associated, requirements with which they are 
traced, and defects with which they are linked. It also enables you to 
calculate and analyze requirement risks.

The Requirement Details view contains the following key elements:

➤ Requirements menu bar. Displays drop-down menus of Requirements 
module commands. For more information, see “The Requirements Menu 
Bar” on page 151.

➤ Requirements toolbar. Contains buttons for commands commonly used 
when creating and modifying requirements. For more information, see “The 
Requirements Toolbar” on page 152.
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➤ Indicator columns. Indicates that the specified requirement has 
attachments, linked defects, alerts, and follow up flags. Choose View > 
Indicator Columns to display these columns.
 

➤ Requirements tree. Displays requirements in a tree.

➤ Details tab. Displays details about the currently selected requirement. It also 
includes the following tabs:

For more information on the fields displayed in the Details tab, see “The 
Requirement Fields” on page 153.

Column Description

Attachments Click the  icon to view attachments for the 
requirement. For more information, see Chapter 5, 
“Adding Attachments.”

Linked Defects Click the  icon to view linked defects for the 
requirement. For more information, see Chapter 32, 
“Linking Defects.”

Alerts Click the  icon to view alerts for the requirement. 
For more information, see “Viewing Alerts” on 
page 80.

Follow Up Flags Click the  icon to view follow up alerts for the 
requirement. For more information, see “Flagging 
for Follow Up” on page 82.

Tab Description

Description Displays a description of the currently selected 
requirement. 

Comments Displays comments about the currently selected 
requirement. 

Rich Text Enables you to add, view, and edit Microsoft Word 
rich text directly from Quality Center. For more 
information, see “Adding Rich Text to 
Requirements” on page 165.
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➤ Requirements Traceability tab. Lists the requirements linked to the currently 
selected requirement. For more information, see Chapter 13, “Tracing 
Requirements.”

➤ Test Coverage tab. Lists the tests associated with the currently selected 
requirement. For more information, see Chapter 18, “Linking Tests to 
Requirements”.

➤ Linked Defects tab. Lists the defects linked to the currently selected 
requirement. For more information, see Chapter 32, “Linking Defects.”

➤ Risk tab. Calculates and analyzes requirement risks. For more information, 
see Chapter 14, “Calculating Requirement Risks.”

➤ Attachments tab. Lists the attachments that provide additional information 
about the currently selected requirement. For more information, see 
Chapter 5, “Adding Attachments”.

Tip: To find a specific requirement by ReqID in the Requirement Details 
view, choose Requirements > Go to Requirement, and enter the requirement 
ID. To display the requirement ID, select the ReqID column using the Select 
Columns dialog box. You can only go to requirements that are in the 
current filter.
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Requirements Grid
The Requirements Grid view enables you to display requirements in a flat 
non-hierarchical view. Each line in the grid displays a separate requirement. 

The Requirements Grid view contains the following key elements:

➤ Requirements menu bar. Displays drop-down menus of Requirements 
module commands. For more information, see “The Requirements Menu 
Bar” on page 151.

➤ Requirements toolbar. Contains buttons for commands commonly used 
when creating and modifying requirements. For more information, see “The 
Requirements Toolbar” on page 152.
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➤ Indicator columns. Indicates that the specified requirement has 
attachments, linked defects, alerts, and follow up flags. Choose View > 
Indicator Columns to display these columns.

➤ Information Panel. Displays the following tabs: Description, Comments, 
Attachments, History, and Rich Text. Choose View > Information Panel or 
click the Show arrow  to display these tabs.
 

Column Description

Attachments Click the  icon to view attachments for the 
requirement. For more information, see Chapter 5, 
“Adding Attachments.”

Linked Defects Click the  icon to view linked defects for the 
requirement. For more information, see Chapter 32, 
“Linking Defects.”

Alerts Click the  icon to view alerts for the requirement. 
For more information, see “Viewing Alerts” on 
page 80.

Follow Up Flags Click the  icon to view follow up alerts for the 
requirement. For more information, see “Flagging 
for Follow Up” on page 82.

Tab Description

Description Displays a description for the currently selected 
requirement. 

Comments Displays comments about the currently selected 
requirement. 

Attachments Lists attachments that provide additional 
information about the currently selected 
requirement. For more information, see Chapter 5, 
“Adding Attachments”.
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Tip: To find a specific requirement by ReqID in the Requirements Grid view, 
choose Requirements > Go to Requirement, and enter the requirement ID. 
To display the requirement ID, select the ReqID column using the Select 
Columns dialog box.

Coverage Analysis
The Coverage Analysis view enables you to analyze the breakdown of child 
requirements according to test coverage status. 

History Displays a list of changes made to the currently 
selected requirement. For more information, see 
“Viewing Requirement History” on page 175.

Rich Text Enables you to add, view, and edit Microsoft Word 
rich text directly from Quality Center. For more 
information, see “Adding Rich Text to 
Requirements” on page 165.

Tab Description
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The Coverage Analysis view contains the following key elements:

➤ Requirements menu bar. Displays drop-down menus of Requirements 
module commands. For more information, see “The Requirements Menu 
Bar” on page 151.

➤ Requirements toolbar. Contains buttons for commands commonly used 
when creating and modifying requirements. For more information, see “The 
Requirements Toolbar” on page 152.

➤ Indicator columns. Indicates that the specified requirement has 
attachments, linked defects, alerts, and follow up flags. Choose View > 
Indicator Columns to display these columns.

➤ Requirements tree. Displays requirements in a tree.

Column Description

Attachments Click the  icon to view attachments for the 
requirement. For more information, see Chapter 5, 
“Adding Attachments.”

Linked Defects Click the  icon to view linked defects for the 
requirement. For more information, see Chapter 32, 
“Linking Defects.”

Alerts Click the  icon to view alerts for the requirement. 
For more information, see “Viewing Alerts” on 
page 80.

Follow Up Flags Click the  icon to view follow up alerts for the 
requirement. For more information, see “Flagging 
for Follow Up” on page 82.
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➤ Information Panel. Displays the following tabs: Description, Comments, 
Attachments, History, and Rich Text. Choose View > Information Panel or 
click the Show arrow  to display these tabs.
 

Tip: To find a specific requirement by ReqID in the Requirement Details 
view, choose Requirements > Go to Requirement, and enter the requirement 
ID. To display the requirement ID, select the ReqID column using the Select 
Columns dialog box. You can only go to requirements that are in the 
current filter.

Tab Description

Description Displays a description for the currently selected 
requirement. 

Comments Displays comments about the currently selected 
requirement. 

Attachments Lists attachments that provide additional 
information about the currently selected 
requirement. For more information, see Chapter 5, 
“Adding Attachments”.

History Displays a list of changes made to the currently 
selected requirement. For more information, see 
“Viewing Requirement History” on page 175.

Rich Text Enables you to add, view, and edit Microsoft Word 
rich text directly from Quality Center. For more 
information, see “Adding Rich Text to 
Requirements” on page 165.
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The Requirements Menu Bar 

The Requirements menu bar has the following menus. The menus and 
commands available in the menu bar may change depending on the 
requirements view.

➤ The Requirements menu contains commands that enable you to add and 
locate requirements in the tree, generate a test from a requirement, display 
requirement details, and mail a requirement.

➤ The Edit menu contains commands that enable you to cut, copy, paste, 
rename, or delete a requirement, or to find, replace, or search requirements. 
You can also view and clear alerts for requirements and flag requirements for 
follow-ups. For more information on alerts and follow-ups, see Chapter 4, 
“Alerting on Changes.”

➤ The View menu contains commands that enable you to set the display of 
the requirements tree or grid, filter and sort the requirements, set the 
displayed columns, and select a requirement view.

➤ The Favorites menu contains commands that enable you to add, organize, 
and load favorite views. For more information, see “Working with Favorite 
Views” on page 93.

➤ The Analysis menu contains commands that enable you to generate 
requirements reports and graphs. For more information on requirements 
reports, see Chapter 33, “Generating Reports.” For more information on 
requirements graphs, see Chapter 34, “Generating Graphs.”

Tip: You can access the Requirements menu bar from the Requirements 
module by pressing the shortcut key F9. Additionally, you can perform 
many other Quality Center operations using shortcut keys. For a list of 
shortcut keys, see Appendix B, “Quality Center Keyboard Shortcuts.”
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The Requirements Toolbar 

The Requirements toolbar has the following buttons. The buttons available 
in the toolbar may change depending on the requirements view.

New Folder. Adds a new folder to the requirements tree. 

New Requirement. Adds a new requirement to the requirements tree. 

Delete. Deletes the selected requirement. Deleting a requirement also 
deletes its child requirements, tests coverage, defects linkage, and 
attachments.

Refresh All. Refreshes the requirements tree or grid so that it displays the 
most up-to-date requirements.

Set Filter/Sort. Includes the following options:

➤ Set Filter/Sort. Opens the Filter dialog box, enabling you to filter and sort 
the requirements in the requirements tree or grid. 

➤ Clear Filter/Sort. Clears any filters or sorting that you have applied to the 
requirements tree or grid.

Select Columns. Opens the Select Columns dialog box, enabling you to 
determine which fields to display in the requirements tree or grid and their 
order. For more information, see “Arranging Columns” on page 51.

Requirement Details. Opens the Requirement Details dialog box, enabling 
you to display the details of the selected requirement. For more information, 
see “Updating Requirements” on page 167.

Attachments. Opens the Requirement Details dialog box in the Attachments 
view, enabling you to add an attachment to the selected requirement. For 
more information, see Chapter 5, “Adding Attachments.”

Go To Requirement in Requirements Tree. Goes to the Requirements Tree 
view and highlights the selected requirement.

Zoom In. Changes the level of detail in the requirements tree. For more 
information, see “Zooming the Tree” on page 173.
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Send by E-mail. Opens the Send E-mail dialog box, enabling you to send 
requirement e-mail to recipients selected from a list or to the author of the 
requirement. For more information, see “Mailing Requirements” on 
page 176.

Text Search. Opens the text search pane in the lower part of the window, 
enabling you to enter keywords and search predefined fields. For more 
information, see “Searching Records” on page 71.

Favorite. Click the Favorite arrow to display a list of favorite views. Favorite 
views enable you to reload a Quality Center window with the settings you 
apply to it. (Available only in the Requirements Grid view. To display the 
Favorite bar, choose View > Favorite Bar.) For more information on favorite 
views, see Chapter 6, “Working with Favorite Views.”

The Requirement Fields 

The Requirement module displays the following fields:

Field Description

Author The user name of the person who created the requirement. By 
default, this is the login user name. 

Comments Displays comments about the requirement.

Creation Date The date on which the requirement was created. By default, 
the creation date is set to the current database server date. 
Click the down arrow to display a calendar and select a 
different creation date.

Creation Time The time at which the requirement was created. By default, the 
creation time is set to the current database server time.

Description A description of the requirement.
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Direct Cover 
Status

The current status of the requirement. By default, the status is 
Not Covered.

A requirement status can be one of the following:

➤ Not Covered. The requirement has not been linked to a test.

➤ Failed. One or more tests covered by the requirement have 
an execution status of “Failed”.

➤ Not Completed. One or more tests covered by the 
requirement have an execution status of “Not Completed”.

➤ Passed. All the tests covered by the requirement have an 
execution status of “Passed”. 

➤ No Run. All the tests covered by the requirement have an 
execution status of “No Run”.

➤ N/A. The current status of the requirement is not applicable.

➤ -----. The requirement does not have a direct cover status as 
it belongs to a requirement type that does not support 
coverage.

You can click a status to open the Tests Coverage dialog box for 
the selected requirement. Available only in the Requirements 
Tree and Coverage Analysis. For more information on 
coverage, see Chapter 18, “Linking Tests to Requirements.”

Modified Indicates the date the requirement was last changed.

Name The requirement name.

Old Type 
(obsolete)

(formerly Type)

The type of requirement (obsolete). In previous versions of 
Quality Center, the type could be any value configured in the 
project, with typical values Change, Functional, Guideline, 
Quality, Standard, and System.

Note that this field can only be in use for requirements of 
undefined type.

Priority The priority of the requirement, ranging from low priority 
(level 1) to urgent priority (level 5).

Product The component of the application on which the requirement 
is based.

Field Description
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RBQM Business 
Impact

The calculated Business Criticality for the requirement. 
Possible values are A (Critical), B (Important), and C (Nice to 
have). This field is only in use for assessment requirements.

RBQM Custom 
Business Impact

The user-defined custom Business Criticality for the 
requirement. Possible values are A (Critical), B (Important), and 
C (Nice to have). This field is only in use for assessment 
requirements.

RBQM Custom 
Failure 
Probability

The user-defined custom Failure Probability for the 
requirement. Possible values are 1 (High), 2 (Medium), and 
3 (Low). This field is only in use for assessment requirements.

RBQM Custom 
Testing Hours

The user-defined effort required to test the requirement., 
measured in units defined in Project Customization. This field 
is only in use for assessment requirements.

RBQM Custom 
Testing Level

The user defined level at which to test the requirement. 
Possible values are 1-Full, 2-Partial, 3-Sanity, and 4-None. This 
field is only in use for assessment requirements.

RBQM Date of 
Last Analysis

The date a risk-based testing analysis was last performed on the 
requirement. This field is only in use for analysis requirements.

RBQM Effective 
Business Impact

The effective Business Criticality for the requirement. Possible 
values are A (Critical), B (Important), and C (Nice to have). This 
field is only in use for assessment requirements.

RBQM Effective 
Failure 
Probability

The effective Failure Probability for the requirement. Possible 
values are 1 (High), 2 (Medium), and 3 (Low). This field is only 
in use for assessment requirements.

RBQM 
Estimated RnD 
Effort

The user-defined estimate of the effort required to develop the 
requirement. This field is only in use for assessment 
requirements.

RBQM Exclude 
from Analysis

Indicates whether to exclude the requirement from risk 
analysis. A requirement may be excluded from risk analysis if it 
belongs to a type for which risk assessments are not available, 
or if you specifically exclude it from analysis.

RBQM Failure 
Probability

The calculated Failure Probability for the requirement. Possible 
values are 1 (High), 2 (Medium), and 3 (Low). This field is only 
in use for assessment requirements.

Field Description
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RBQM Testing 
Hours

The calculated effort required to test the requirement, 
measured in units defined in Project Customization. This field 
is only in use for assessment requirements.

RBQM Testing 
Level

The calculated level at which to test the requirement. Possible 
values are 1-Full, 2-Partial, 3-Sanity, and 4-None. This field is 
only in use for assessment requirements.

RBQM Use 
Custom 
Business Impact

Indicates whether to use the user-defined Business Criticality, 
instead of the Business Criticality calculated by Quality Center. 
This field is only in use for assessment requirements.

RBQM Use 
Custom Failure 
Probability

Indicates whether to use the user-defined Failure Probability, 
instead of the Failure Probability calculated by Quality Center. 
This field is only in use for assessment requirements.

RBQM Use 
Custom Results

Indicates whether to use the user-defined testing effort and 
testing level, instead of the values calculated by 
Quality Center. This field is only in use for assessment 
requirements.

Req ID A unique alphanumeric ID for the requirement that is assigned 
automatically. Note that the Req ID cannot be modified.

Req Parent The name of the parent requirement.

Field Description
156



Chapter 11 • The Requirements Module at a Glance
Reviewed Indicates whether the requirement has been reviewed and 
approved by the person responsible.

Requirement 
Type

Indicates the type of requirement. Default values are: 

➤  Business. A business process requirement. By default, 
you cannot add coverage to this requirement.

➤  Folder. A folder for organizing requirements. By default, 
you cannot add coverage to this requirement.

➤  Functional. A system behavioral requirement.

➤  Group. A collection of related requirements.

➤  Testing. A system performance requirement.

➤  Undefined. An undefined requirement.

You can customize the default types and create your own 
requirement types. For more information on customizing 
requirement types, refer to the HP Quality Center Administrator’s 
Guide.

Target Cycle Indicates the cycle in which the requirement was assigned. 
Click the down arrow to select a different cycle.

Target Release Indicates the release in which the requirement was assigned. 
Click the down arrow to select a different release.

Field Description
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Notes: 

➤ You can add user-defined fields and change the label of any of the fields 
in the Requirements module. You can also customize project lists. For 
more information, refer to the HP Quality Center Administrator’s Guide.

➤ You can use the Script Editor to restrict and dynamically change the 
fields and values in the Requirements module. For more information, 
refer to the HP Quality Center Administrator’s Guide.

➤ When you select a requirement column with a user name value 
(including user-defined fields), Quality Center displays a list with the 
name and full name of each user. You can search for users, sort users, 
group users by user group, and select users from the users list or a group 
tree. For more information, see “Selecting Users” on page 54.
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Developing the Requirements Tree

The requirements tree organizes and displays your requirements 
hierarchically.

This chapter describes: On page:

About Developing the Requirements Tree 160

Creating a Requirements Tree 161

Assigning Requirements to Releases or Cycles 164

Adding Rich Text to Requirements 165

Updating Requirements 167

Finding Requirements 169

Replacing Field Values 171

Viewing the Requirements Tree 173

Viewing Requirement History 175

Mailing Requirements 176

Modifying Requirements 179

Creating Tests from Requirements 182
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About Developing the Requirements Tree 

The process of specifying testing requirements can be tedious and 
time-consuming. In many cases, the test team records requirements in a 
word-processed document or in a spreadsheet. This requirements document 
is complicated to maintain, difficult to organize and sort, and cannot be 
associated with tests and defects you create based on the requirements, or 
with other requirements.

The Requirements module enables you to define and manage your 
requirements. The test team records requirements in Quality Center by 
creating a requirements tree. This is a graphical representation of your 
requirements specification, displaying your requirements hierarchically. 

After defining your requirements, you can establish traceability between two 
or more requirements. Requirements traceability defines a relationship 
between the requirements. When analyzing the impact of a change 
proposed in a specific requirement, the traceability links indicate the other 
requirements that the change might affect. When a requirement changes, 
Quality Center alerts the directly influenced traced requirements. For more 
information on establishing traceability between requirements, see 
Chapter 13, “Tracing Requirements.”

During the requirements specification phase, you assign your requirements 
to a release or a cycle in the releases tree. Requirements can be assigned to 
one or more releases or cycles. For more information, see “Assigning 
Requirements to Releases or Cycles” on page 164.

After you have created tests, you associate assigned requirements with tests 
and defects. In this way, you can keep track of your testing needs at all stages 
of the testing process. If a requirement changes, you can immediately 
identify which tests and defects are affected, and who is responsible. For 
more information on associating requirements with tests, see Chapter 18, 
“Linking Tests to Requirements.” For more information on associating 
requirements with defects, see Chapter 32, “Linking Defects.”
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Note: This chapter assumes you are using the Requirements module’s 
Requirements Tree to create a requirements tree. For information on the 
Requirements Grid view, see “Requirements Grid” on page 146. For 
information on the Requirement Details view and Coverage Analysis view, 
see Chapter 18, “Linking Tests to Requirements.”

Creating a Requirements Tree

You start a requirements tree by adding requirements to the Requirements 
root folder. You can organize your requirement topics into folders. The root 
folder cannot be renamed or deleted.

Note: In addition to creating requirements directly in Quality Center, you 
can also import requirement data from Microsoft Word or Microsoft Excel to 
your Quality Center project. To import from Word, you must install the 
Microsoft Word Add-in and the HP Quality Center Connectivity Add-in. To 
import from Excel, you must install the Microsoft Excel Add-in and the 
HP Quality Center Connectivity Add-in. You can install the add-ins from the 
HP Quality Center Add-ins page. For more information, refer to the 
HP Quality Center Installation Guide.

To create a requirements tree:

 1 In the Requirements module, choose View > Requirements Tree to display 
the Requirements Tree view.

 2 To add a requirement at the main level, select the Requirements root folder. 
To create a child requirement, select a requirement.

 3 To add a folder, click the New Folder button or choose Requirements > New 
Folder. In the Create New Requirement Folder dialog box, type the Folder 
Name and click OK. Note that a folder name cannot include the following 
characters: \ ^ *
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 4 To add a requirement, click the New Requirement button. Alternatively, 
choose Requirements > New Requirement. The Create New Requirement 
dialog box opens.

 5 In the Requirement Type list, select a requirement type. For more 
information on requirement types, see “The Requirement Fields” on 
page 153.

 6 In the Requirement Name box, type a name for the new requirement. A 
requirement name cannot include the following characters: \ ^ *

 7 Click OK. The New Requirement dialog box opens.
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 8 Add details for the requirement. Note that a required field is displayed in 
red. For more information on the available fields in the Requirements 
module, see “The Requirement Fields” on page 153.

 9 To clear the data in the New Requirement dialog box, click the Clear button.

 10 You can add an attachment to your requirement:

➤ Click the Attach File button to attach a text file.

➤ Click the Attach URL button to attach a URL.

➤ Click the Attach Snapshot button to capture and attach an image.

➤ Click the Attach Sysinfo button to attach information about your 
machine.

➤ Click the Attach Clipboard button to attach text or an image from the 
Clipboard.

For more information about adding attachments, see Chapter 5, “Adding 
Attachments.”

 11 You can check the spelling in the New Requirement dialog box:

➤ Click the Check Spelling button to check the spelling for the selected 
word or text box. 

➤ Click the Spelling Options button to open the Spelling Options dialog 
box, enabling you to configure the way Quality Center checks spelling. 

➤ Click the Thesaurus button to open the Thesaurus dialog box and display 
a synonym, antonym, or related word for the selected word. 

 12 Click Submit to add the new requirement to the tree. 

 13 Click Close to close the New Requirement dialog box.

 14 To add test coverage for the requirement, choose View > Requirement 
Details. You can also choose View > Coverage Analysis to display the 
breakdown of child requirements according to test coverage status. For more 
information, see Chapter 18, “Linking Tests to Requirements.”

 15 To add requirement traceability links for the requirement, choose View > 
Requirement Details and click the Requirements Traceability tab. For more 
information, see Chapter 13, “Tracing Requirements.”
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 16 To add defect links for the requirement, choose View > Requirement Details 
and click the Linked Defects tab. For more information, see Chapter 32, 
“Linking Defects.”

Assigning Requirements to Releases or Cycles

After you have defined your requirements in the requirements tree, you 
assign the requirements to a release or a cycle in the Releases module. You 
can assign requirements to one or more releases or cycles in the releases tree. 
For more information, see Chapter 9, “Developing the Releases Tree.”

During the test planning stage, you associate the tests in the Test Plan 
module to your assigned requirements to create coverage. By defining 
coverage, you can keep track of the relationship between the tests in your 
test plan and your requirements. For more information on coverage, see 
Chapter 18, “Linking Tests to Requirements.”

During the test running stage, you add the tests that cover the assigned 
requirements to test sets in the Test Lab module, and then you assign the 
test set folders to cycles. For more information, see “Assigning Test Set 
Folders to Cycles” on page 327.

To assign a requirement to a release or a cycle:

 1 In the requirements tree, select the requirement that you want to assign to a 
release or a cycle. To select more than one requirement, use the Ctrl key.

 2 To assign to a release, choose Requirements > Assign To Release. 
Alternatively, right-click and choose Assign To Release. The Assign To 
Release dialog box opens. Expand the tree and select a release. Click OK to 
close the dialog box.

To assign to a cycle, choose Requirements > Assign To Cycle. Alternatively, 
right-click and choose Assign To Cycle. The Assign To Cycle dialog box 
opens. Expand the tree and select a cycle. Click OK to close the dialog box.

 3 If the selected requirement contains child requirements, a confirmation box 
opens. Click Yes to assign the requirement and its child requirements. Click 
No to assign the requirement without its child requirements.
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Adding Rich Text to Requirements

You can add, view, and edit Microsoft Word rich text from within 
Quality Center, without the need to edit the text in Word. Changes you 
make to the rich text for a requirement are saved automatically when you 
move to a different requirement or a different module.

Notes: 

➤ To verify supported versions of Microsoft Word, refer to the 
HP Quality Center Installation Guide.

➤ Microsoft Word must be closed when adding or editing rich text.

To add rich text to a requirement:

 1 In the requirements tree, select a requirement and click the Details tab.

 2 In the Details tab, click the Rich Text tab. A Microsoft Word editor is 
displayed.
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 3 Edit the rich text as you would in Word. For more information on using 
Word to edit rich text, refer to the Microsoft Word documentation.

 4 To edit rich text in a separate window, click the Maximize Content button.

 5 To replace the existing rich text with content from a saved Word file, in the 
Rich Text tab, choose File > Import.

 6 To replace the existing rich text with a blank page, in the Rich Text tab, 
choose File > New.

 7 To save the rich text as a Word document, choose File > Save.
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Updating Requirements

You can update your requirements directly in the requirements tree or grid, 
or in the Requirement Details dialog box. Using the Requirement Details 
dialog box, you can update the details, attachments, tests coverage, 
requirement traceability links, risk-based quality management settings, and 
defect links for any requirement. You can also view a list of changes made to 
any requirement.

To update a requirement:

 1 Double-click the requirement you want to update. Alternatively, select the 
requirement and click the Requirement Details button. The Requirement 
Details dialog box opens.
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 2 You can click the First button to display the first requirement in the tree or 
grid, or the Previous button to display the preceding requirement.

 3 You can click the Next button to display the next requirement in the tree or 
grid, or the Last button to display the final requirement in the tree or grid.

 4 Click the Send by E-mail button to send an e-mail with the requirement 
details. For more information on mailing requirements, see “Mailing 
Requirements” on page 176.

 5 In the Details view, you can add or modify information for the selected 
requirement. For more information on available fields in the Details view, 
see “The Requirement Fields” on page 153.

 6 Click Requirements Traceability on the sidebar to add requirement 
traceability links for the requirement. For more information on traceability, 
see Chapter 13, “Tracing Requirements.”

 7 Click Test Coverage on the sidebar to add test coverage for the requirement. 
For more information on test coverage, see Chapter 18, “Linking Tests to 
Requirements.”

 8 Click Linked Defects on the sidebar to add defect links for the requirement. 
A clickable icon  is placed next to the requirement in the Requirements 
Grid. For more information on linked defects, see “Linking Defects” on 
page 435.

 9 Click Risk on the sidebar to use risk-based quality management to help you 
determine a strategy for testing the requirement. For more information on 
risk-based testing, see Chapter 14, “Calculating Requirement Risks.”

 10 Click Attachments on the sidebar to add an attachment to the requirement. 
An attachment can be a file, URL, snapshot of your application, system 
information, or an item from the Clipboard. A clickable attachment icon  
is placed next to the requirement in the Requirements Grid. For more 
information on attachments, see Chapter 5, “Adding Attachments.”

 11 Click History on the sidebar to view the history of changes made to the 
requirement. For more information, see “Viewing Requirement History” on 
page 175.

 12 Click OK to save your changes and close the Requirement Details dialog box.
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Finding Requirements

You can search for a particular requirement in the requirements tree or in 
the requirements grid using the Find command.

Tip: If Text Search is available, it is recommended that you use it to search 
for requirements. Text search provides a more powerful search by enabling 
you to search for keywords and variations of keywords. For information on 
using the text search, see “Searching Records” on page 71.

Finding Requirements in the Requirements Tree
You can search for a requirement in the requirements tree. If you have 
applied filters to the tree, the search is restricted to the requirements 
currently displayed.

To find a requirement in the requirements tree:

 1 Choose Edit > Find. The Find Requirement dialog box opens.

 2 In the Find in Field box, select the criterion to search for. 

 3 In the Value to Find box, type or select the value of the field you chose. The 
search is not case sensitive.

 4 Click Find. The Requirements module attempts to locate the requirement 
with the specified value. If the search is successful, the Search Results dialog 
box opens and displays a list of possible matches. Select a result from the list 
and click the Go To button to highlight the requirement in the 
requirements tree. If the search is unsuccessful, an information box opens.
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Finding Requirements in the Requirements Grid
You can search for requirements in the requirements grid, based on the 
value of a particular field. If you have applied filters to the grid, the search is 
restricted to the requirements currently displayed.

To find a requirement in the requirements grid:

 1 Choose Edit > Find. The Find dialog box opens.

 2 In the Find in Field box, select a field in the grid.

 3 In the Value to Find box, type or select the value of the field, for which you 
want to search.

 4 Select Exact Match if you want to find requirements with field values that 
exactly match the Value to Find string.

 5 Select Case Sensitive if you want the search to distinguish between 
uppercase and lowercase characters.

 6 Select Use Wildcards if you want to use asterisk (*) characters in your search 
string in order to type only part of the item.

 7 Click Find Next. If the search is successful, the matching requirement is 
chosen in the grid. If the search is unsuccessful, an information box opens.

 8 Click Find Next again to find the next requirement that matches the criteria.
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Replacing Field Values

You can replace field values in the requirements tree or in the requirements 
grid using the Replace command.

Replace Field Values in the Requirements Tree
You can replace field values for a selected requirement and all of its child 
requirements, or for all requirements in the requirements tree.

To replace a field value in the requirements tree:

 1 To replace a field value for the selected requirement and of its child 
requirements, select a requirement in the tree and choose Edit > Replace > 
Replace Selected. 

To replace all values, choose Edit > Replace > Replace All. 

The Replace dialog box opens.

 2 In the Find in Field box, select the field in which you want to replace values.

 3 In the Value to Find box, type or select the value for which you want to 
search. 

 4 In the Replace with box, type or select a replacement value.

 5 To distinguish between uppercase and lowercase characters, select the Case 
Sensitive check box.

 6 To search for an exact value, select the Exact Match check box. 
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 7 To receive a prompt before each value is replaced, select the Prompt on 
replace check box. 

 8 Click Replace. If you selected Prompt on replace in step 7, the Confirm 
dialog box opens.

➤ Select Yes to replace the current occurrence of the value.

➤ Select Replace All to replace the value, either in the selected requirement 
and its child requirements, or in all the requirements, according to your 
selection in step 1.

 9 An Information dialog box opens, showing the number of values that were 
replaced, and the number of instances where the values were not replaced. 
Click OK.

Replace Field Values in the Requirements Grid
You can replace field values in the requirements grid using the Replace 
command.

To replace a field value in the requirements grid:

 1 Choose Edit > Replace. The Find/Replace dialog box opens.

 2 In the Find in Field box, select the column in which you want to search for a 
specific value. 

 3 In the Value to Find box, type or select the value to find. 

 4 In the Replace with box, type or select a replacement field value.
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 5 To distinguish between uppercase and lowercase characters, select the Case 
Sensitive check box.

 6 To search for an exact value, select the Exact Match check box.

 7 To start the search from the top of the grid, select the From Beginning check 
box.

 8 To use asterisk (*) characters in your search string in order to type only part 
of the item, select the Use Wildcard check box.

 9 To replace the found item and find the next occurrence, click Replace.

 10 To replace all occurrences of the value in the grid, click Replace All.

Viewing the Requirements Tree

You can change the way the Requirements module displays the 
requirements tree. This includes zooming in and out of the tree, refreshing 
the tree, filtering the tree, and expanding and collapsing the branches of the 
tree.

Zooming the Tree
You can zoom in and zoom out of the requirement topics in the 
requirements tree. This enables you to change the level of detail that the 
tree displays.

To zoom in:

 1 Select a requirement topic in the requirements tree.

 2 Click the Zoom In button on the toolbar. Alternatively, right-click the 
requirement and choose Zoom In.

The requirements tree only displays the selected requirement topic and 
includes a heading with the hierarchical path of the requirement topic.

To zoom out:

To reverse a zoom in action, you can either zoom out one level or zoom out 
to the highest hierarchical level.
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➤ Click the Zoom In arrow and choose Zoom Out One Level to undo the 
previous zoom in command.

➤ Click the Zoom In arrow and choose Zoom Out To Root to zoom out to the 
highest hierarchical level and display the entire requirements tree. 

Refreshing the Tree
You can refresh the data in the tree so that it displays the most up-to-date 
requirements. To refresh the tree, click the Refresh All button.

Filtering Requirement
You can filter and sort requirements in the Requirement module. Click the 
Set Filter/Sort arrow and choose from the following options:

➤ Set Filter/Sort. Opens the Filter dialog box, enabling you to filter and sort 
the requirements in the Requirement module. 

➤ Clear Filter/Sort. Clears any filters or sorting that you have applied to the 
requirements tree or grid.

For more information, see Chapter 3, “Working with Quality Center Data.”

Expanding and Collapsing the Tree
You can expand and collapse the branches in the requirements tree. This 
enables you to change the level of detail that the tree displays.

To expand and collapse the tree:

➤ To expand a branch in the tree, click the Expand  sign to the left of the 
branch name. To expand all the levels in a branch, right-click the branch 
name and choose Expand All. 

➤ To collapse a branch in the tree, click the Collapse  sign to the left of the 
branch name. To collapse all the levels in a branch, right-click the branch 
name and choose Collapse.
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Viewing Requirement History 

You can view a list of changes made to any requirement in the requirements 
tree.

To view the history of changes to a requirement:

 1 In the requirements tree, select a requirement and choose View > 
Information Panel. 

 2 Click the History tab. The history of changes made to the requirement is 
displayed in a grid.

For each change to the requirement, the grid displays the date and time of 
the change and the name of the user who made the change. 

 3 Expand a change to view a list of fields modified during the change. For 
each field, the grid displays the old value and the new value. To expand all 
changes, click the Expand All button.

 4 You can specify which changes are displayed in the grid. In the Field list, 
select a field name to view only changes made to that field. Select <All> to 
view changes made to all fields.

For information on preserving the history of changes made to a field, refer 
to the HP Quality Center Administrator’s Guide.
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Mailing Requirements 

You can send e-mail about a requirement to other users in your 
Quality Center project. This enables you to routinely inform development 
and quality assurance personnel about the status of your requirements. A 
link is included in the e-mail message that enables the recipient to go 
directly to the requirement.

Note: By default, Quality Center sends e-mail in HTML format. To send 
e-mail as plain text instead, edit the MAIL_FORMAT parameter in the 
Site Configuration tab in Site Administration. For more information, refer to 
the HP Quality Center Administrator’s Guide.
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To mail a requirement: 

 1 Select one or more requirements and click the Send by E-mail button. The 
Send E-mail dialog box opens.

Tip: You can automatically send the e-mail to a specific user type. This can 
be any requirement column with a user name value, including user-defined 
fields. Click the Send by E-mail arrow and choose an option. For example, 
choose Send by E-mail to Author to send the e-mail to the user who wrote 
the requirement.
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 2 Type a valid e-mail address or user name. Alternatively, click the To button 
or CC button to select users. The Select Recipients dialog box opens. 

You can sort the users list, search for users, group users by user groups, and 
select users from the list or from a group tree. For more information, see 
“Selecting Users” on page 54.

Select the users or user groups to which you want to send the e-mail, and 
click OK. 

 3 In the Subject box, type a subject for the e-mail.

 4 Choose whether you want to include the Attachments, History, Tests 
Coverage and/or Traced Requirements of the requirement. If you include 
the requirement’s Attachments, any rich text for the requirement is 
included as a separate attachment.

 5 In the Additional comments box, add any comments you may have.
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 6 To check the spelling in the dialog box:

➤ Click the Check Spelling button to check the spelling for the selected 
word or text box. If there are no errors, a confirmation message opens. If 
errors are found, the Spelling dialog box opens and displays the word 
together with replacement suggestions.

➤ Click the Spelling Options button to open the Spelling Options dialog 
box, enabling you to configure the way spelling is checked. 

➤ Click the Thesaurus button to open the Thesaurus dialog box and display 
a synonym, antonym, or related word for the selected word. You can 
replace the selected word or look up new words.

 7 Click Custom to customize the e-mail. In the Select Fields dialog box, you 
can specify fields to include in the e-mail. 

 8 Click Send to send the e-mail.

Modifying Requirements

This section on modifying requirements includes the following topics:

➤ Renaming Requirements

➤ Copying Requirements

➤ Copying URLs of Requirements

➤ Moving Requirements

➤ Deleting Requirements

Renaming Requirements
You can rename a requirement in the Requirements module. A name cannot 
include the following characters: \ ^ *

Note: You cannot rename the root folder.
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To rename a requirement:

➤ To rename a requirement in the tree, select a requirement and choose Edit > 
Rename. Alternatively, right-click the requirement and choose Rename. Edit 
the requirement name and press ENTER.

➤ To rename a requirement in the grid, click the requirement’s name and type 
a new name.

Copying Requirements
You can copy a requirement within the same project or between projects. 
When you copy a requirement topic, any children of the requirement topic 
are also copied.

Note: 

➤ Test coverage, defect linkage, and risk-based quality management data for 
the requirement are not copied.

➤ To copy a requirement with traceability, you must also copy its associated 
traced requirements.

➤ The root folder cannot be copied within the same project.

To copy a requirement:

 1 Select a requirement from the requirements tree or grid. To copy more than 
one requirement, press the Ctrl key and select the requirements you want to 
copy.

 2 Choose Edit > Copy. Alternatively, right-click and choose Copy. 

 3 If you are copying a requirement from the grid to the requirements tree, 
choose View > Requirements Tree. The Requirements Tree view is displayed.

 4 Select a requirement in the requirements tree.

 5 Choose Edit > Paste. Alternatively, right-click and choose Paste.

Note that if you paste a requirement that has the same name as an existing 
requirement, the suffix _Copy is added automatically to the end of the 
requirement’s name. 
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Copying URLs of Requirements
You can copy a requirement and paste its URL as a link. The requirement 
itself is not copied. Instead, you can paste the address into another location, 
such as an e-mail or a document. Clicking the link opens Quality Center 
and takes you to the requirement. 

To copy a URL of a requirement:

 1 Select a requirement from the requirements tree or grid. 

 2 Choose Edit > Copy URL. Alternatively, right-click and choose Copy URL.

 3 Paste the URL.

Moving Requirements
You can move a requirement to a different location in the requirements tree. 
Moving a requirement topic also moves its child requirements, tests 
coverage, requirement traceability links, and defects linkage. The root folder 
cannot be moved.

Tip: You can also move a requirement to a new location in the requirements 
tree by dragging it.

To move a requirement:

 1 Select a requirement from the requirements tree. To move more than one 
requirement, press the Ctrl key and select the requirements you want to 
move.

 2 Choose Edit > Cut or right-click the requirements and choose Cut.

 3 Select a requirement in the requirements tree.

 4 Choose Edit > Paste. Alternatively, right-click and choose Paste. 
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Deleting Requirements
You can delete a requirement from the Requirements module. Deleting a 
requirement also deletes its child requirements, tests coverage, requirement 
traceability links, and defects linkage. Note that you cannot delete the root 
folder.

To delete a requirement:

 1 Select a requirement. To delete more than one requirement, press the Ctrl 
key and select the requirements you want to delete.

 2 Click the Delete button or right-click and choose Delete.

 3 Click Yes to confirm.

Creating Tests from Requirements 

After you have created the requirements tree, you use the requirements as a 
basis for defining the tests in your test plan tree and running tests in a test 
set. Note that you must have the necessary permissions in order to create 
tests.

There are two methods you can use to create tests from requirements:

➤ Convert Requirements to Tests. Convert requirements to tests in a specified 
subject in the test plan tree. You can convert selected requirements or all 
requirements in the requirements tree. This method, using the Convert to 
Tests wizard, assists you when designing your test plan tree. See “Converting 
Requirements to Tests” on page 183.

➤ Generate a Test from Requirements. Convert requirements to a test in a 
specified subject in the test plan tree and a specified test set in the Test Lab 
module. This method, using the Generate Test dialog box, enables you to 
quickly run a test when analyzing your requirements. See “Generating a Test 
from Requirements” on page 187.
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Converting Requirements to Tests
Use the Convert to Tests wizard to convert requirements to tests in a 
specified subject in the test plan tree. Coverage is automatically created 
between the requirements and their corresponding tests.

To convert requirements to tests:

 1 To convert a specific requirement, select the requirement in the 
requirements tree. To convert all requirements, select the root requirement 
folder in the requirements tree.

 2 Choose Requirements > Convert to Tests.

The Step 1 dialog box opens.
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 3 Choose an automatic conversion method:

➤ Select Convert lowest child requirements to design steps to convert all 
lowest level child requirements to design steps, the next level up to tests, 
and all levels above to subjects.

➤ Select Convert lowest child requirements to tests to convert all lowest 
level child requirements to tests and all levels above to subjects.

➤ Select Convert all requirements to subjects to convert all selected 
requirements to subjects.

 4 Click Next to begin converting the requirements. To cancel the conversion 
process and return to the Step 1 dialog box, click the Stop button in the 
progress bar. When the conversion process is complete, the results are 
displayed in the Step 2 dialog box.

Note: If you are converting a single requirement, the wizard skips this dialog 
box.
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 5 To view the wizard legend, click the Legend link.

 6 For each converted item, you can do the following:

➤ Select the item and click the Convert to Subject button or right-click the 
item and choose Subject, to change the item to a subject in the test plan 
tree. Children can then be either subjects or tests. Note that subject 
names must be unique.

➤ Select the item and click the Convert to Test button or right-click the 
item and choose Test, to change the item to a test in the test plan tree. 
Children are then converted to steps. Note that test names must be 
unique.

➤ Select the item and click the Convert to Step button or right-click the 
item and choose Step, to change the item to a step in the test plan tree. 
Children are then converted to step descriptions.

➤ Select the item and click the Convert to Description button or right-click 
the item and choose Description, to change the item to a step description 
in the test plan tree. Children are then converted to indented description 
text.

➤ Select the item and click the Exclude from Conversion button or 
right-click the item and choose Exclude to exclude the item from the test 
plan tree.

 7 Clear the Auto Complete Children check box if you do not want the wizard 
to assist you when you make changes. If this option is selected and you 
change the level of a parent, for example, from a subject to a test, the wizard 
changes the level of all the children, for example, from tests to test steps.
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 8 Click Next. The Step 3 dialog box opens.

 9 Under Destination Subject Path, click the Select Subject button to select a 
subject from your test plan tree in the Select Destination Subject dialog box. 
Alternatively, type a new subject name. By default, the subject folder and 
tests are placed in the Subject folder of the Test Plan module. 

 10 Click Finish. 

 11 To stop the conversion process and return to the Step 3 dialog box, click the 
Stop button in the progress bar. 

Note: If you stop the conversion process, any requirements already 
converted are not deleted from the test plan tree. You must delete them 
manually.

 12 Click Close to close the Convert to Tests wizard or view the error messages 
that have been generated.
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Generating a Test from Requirements
Use the Generate Test dialog box to convert requirements to a test in a 
specified subject in the test plan tree and a specified test set in the Test Lab 
module. Coverage is automatically created between the requirements and 
their corresponding tests. Note that by default you cannot generate a test for 
the following requirement types, which do not enable coverage: Business, 
Folder, and Group.

To generate a test from requirements:

 1 Select a requirement and choose Requirements > Generate Test. 
Alternatively, right-click a requirement in the requirements tree and choose 
Generate Test. The Generate Test dialog box opens.

 2 In the Subject box, select a subject from your test plan tree or type a new 
subject name. By default, the test is placed in the Temporary Tests folder in 
the Test Plan module.

 3 In the Test Name box, type a name for the new test. By default, the new test 
is assigned the same name as the requirement.

 4 If you do not want to create design steps, clear the Create Design Steps 
check box. If this option is selected, a step is added to the test for each child 
requirement.

 5 Select Add Test to Test Set to add the test to a test set in the Test Lab 
module. In the Test Set list, select a test set or type a new test set name.

 6 Click OK.
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13 
Tracing Requirements

Requirements traceability defines a relationship between requirements. As 
requirements or their linked requirements change, you can trace and 
monitor the impact of these changes. 

About Tracing Requirements

Requirements traceability defines a relationship between two or more 
requirements. When analyzing the impact of a change proposed in a specific 
requirement, the traceability links indicate the other requirements that the 
change might affect.

After defining your requirements in the requirements tree (see Chapter 12, 
“Developing the Requirements Tree”), you can establish traceability 
between the requirements. Using the Requirements Traceability tab in the 
Requirement Details view, you can add traceability links to and from a 
selected requirement. Trace from links indicate requirements that affect a 
selected requirement. Trace to links indicate requirements that are affected 
by a selected requirement.

This chapter describes: On page:

About Tracing Requirements 189

Defining Traceability Relationships 192

Viewing Traceability Relationships 194

Viewing Traceability Impact 196

Removing Traceability Relationship Links 198
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When a requirement changes, Quality Center alerts the affected 
requirements. The alerts can be seen by all users. Quality Center also sends 
e-mail notifications to the authors of the affected requirements. For more 
information on alerts, see Chapter 4, “Alerting on Changes.”

Requirements Traceability Example
To implement this relationship between the requirements, suppose 
Requirement_1B and Requirement_2B affect Requirement_1A. You select 
Requirement_1A in the requirements tree. In the Relationships tab, you add 
Requirement_1B and Requirement_2B to the Trace From grid. 
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If you select Requirement_1B in the requirements tree, the Trace To grid 
indicates that Requirement_1B is traced to Requirement_1A. If you select 
Requirement_2B in the requirements tree, the Trace To grid indicates that 
Requirement_2B is traced to Requirement_1A.  

When a requirement changes, Quality Center flags the traced to 
requirements and sends e-mail to notify the authors to evaluate the impact 
on their requirements. For example, if you change Requirement_1B or 
Requirement_2B, Quality Center alerts Requirement_1A and alerts its author. 
Note that alerts are visible to all users.
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Defining Traceability Relationships

You can define traceability relationships between requirements in the 
Relationships tab. This tab contains the Trace From and Trace To grids. The 
Trace From grid displays requirements that affect a selected requirement. 
The Trace To grid displays the requirements that are affected by the selected 
requirement.

You define a relationship by selecting a requirement from the requirements 
tree or by typing a requirement ID. 

To define a relationship using the requirements tree:

 1 In the Requirement Details view, select a requirement from the 
requirements tree and click the Requirements Traceability tab. By default, 
the Relationships tab is displayed.

 2 Click the Show/Hide arrow to display the Trace From or Trace To grid. 

 3 In the Relationships tab, click the Add Requirement Traceability button to 
open the requirements tree in the right pane.

 4 To search for a specific requirement in the tree, type the name (or part of the 
name) of the requirement in the Find box and click the Find button. If the 
search is successful, the requirement is highlighted in the tree.
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 5 To filter or sort requirements in the tree, click the Set Filter/Sort button. For 
more information on filtering and sorting records, see Chapter 3, “Working 
with Quality Center Data”. 

 6 To refresh the tree, click the Refresh All button. 

 7 Select a requirement to add to the grid:

➤ Click the Add to Traceability arrow and choose Add to Traceability (Trace 
To) to add the requirement to the Trace To grid.

➤ Click the Add to Traceability arrow and choose Add to Traceability (Trace 
From) to add the requirement to the Trace From grid.

The requirement is added to the grid.

Tip: You can also add a requirement traceability link by dragging a 
requirement from the requirements tree to the appropriate grid.

 8 Click the Close button to hide the requirements tree in the right pane.

To define a relationship by typing a requirement ID:

 1 In the Requirement Details view, select a requirement from the 
requirements tree and click the Requirements Traceability tab. By default, 
the Relationships tab is displayed.

 2 Click the Show/Hide arrow to display the Trace From or Trace To grid. 

 3 Click the Add Requirement Traceability button and choose one of the 
following options:

➤ By ID (Trace From). Add a traceability link to the Trace From grid by 
typing a requirement ID.

➤ By ID (Trace To). Add a traceability link to the Trace To grid by typing a 
requirement ID.

The Trace Existing Requirement dialog box opens.

 4 Type the requirement ID for the requirement you want to add and click 
Trace. The requirement is added to the specified grid.
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Viewing Traceability Relationships

You can display traceability relationships that exist between requirements in 
the Relationships tab. This tab contains the Trace From and Trace To grids. 
The Trace From grid displays requirements that affect a selected 
requirement. The Trace To grid displays the requirements that are affected 
by the selected requirement. 

In addition to the columns described in “The Requirement Fields” on 
page 153, the Relationships tab can also display the following columns:

Column Description

Created By The user name of the person who created the requirement 
link. By default, this is the login user name. 

Creation Date The date on which the requirement link was created. By 
default, the creation date is set to the current database 
server date.

Modified The date and time on which the requirement link was 
modified. By default, the date and time are set to the 
current database server date and time.
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To view traceability relationships:

 1 In the Requirement Details view, select a requirement from the 
requirements tree and click the Requirements Traceability tab. By default, 
the Relationships tab is displayed.

 2 To refresh the grids, click the Refresh All button. 

 3 To set column appearance and order, click the Select Columns arrow and 
choose Select Column (Trace From) or Select Column (Trace To). The Select 
Columns dialog box opens. For more information, see “Arranging 
Columns” on page 51.

 4 To display a traced requirement in the requirements tree, select a 
requirement and click the Go To Requirement button.

 5 To view details of a traced requirement, select a traced requirement and click 
the Requirement Details button. The Requirement Details dialog box opens. 
For more information, see “Updating Requirements” on page 167.

Requirement Trace 
ID

A unique alphanumeric ID for the requirement link that is 
assigned automatically.

Trace Comment Displays comments about the requirement link.

Column Description
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Viewing Traceability Impact

After establishing traceability relationships, you can analyze the impact of 
requirement changes by reviewing the relationships. The Impact Analysis 
tab helps you understand the many associations and dependencies that 
exist between the requirements by displaying them in a hierarchical tree 
structure. Unlike the Relationships tab, the Impact Analysis tab shows the 
affected requirements along with their parent and child requirements. 

The Trace From tree displays requirements that affect a selected 
requirement. For example, the following Trace From tree indicates that 
Req_A is traced from Requirement_1B. Requirements is the parent 
requirement of Req_A. Req_B is the parent requirement of Requirement_1B. 
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The Trace To tree displays requirements that are affected by a selected 
requirement. For example, the following Trace To tree indicates that 
Requirement_1B is traced to Req_A. Requirement_1A through 
Requirement_4A are child requirements of Req_A, which are affected by 
Req_A. 

The Impact Analysis tab contains the following icons:

Icon Description

A child requirement affected by a change to a selected requirement.

A parent requirement that affects a selected requirement.

A traced-to requirement.

A traced-from requirement.

A recursive relationship between the requirements.
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To view traceability impact:

 1 In the Requirement Details view, select a requirement from the 
requirements tree and click the Requirements Traceability tab. By default, 
the Relationships tab is displayed.

 2 Click the Impact Analysis tab.

 3 To refresh the tree, click the Refresh All button. 

 4 To display a traced requirement in the requirements tree, select a 
requirement and click the Go To Requirement button.

 5 To view details of a traced requirement, select a traced requirement and click 
the Requirement Details button. The Requirement Details dialog box opens. 
For more information, see “Updating Requirements” on page 167.

Removing Traceability Relationship Links

You can remove a traceability relationship link from the Relationships tab.

To remove a traceability relationship link:

 1 In the Requirement Details view, select a requirement from the 
requirements tree and click the Requirements Traceability tab. By default, 
the Relationships tab is displayed.

 2 Click the Show/Hide arrow to display the Trace From or Trace To grid. 

 3 In the appropriate grid, select a traceability relationship link. To select more 
than one link, press the Ctrl key and select the links you want to remove.

 4 Click the Remove from Traceability button, or right-click and choose 
Remove from Traceability.

 5 Click Yes to confirm.
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14 
Calculating Requirement Risks

You can use risk-based quality management to help you decide on a testing 
strategy for your requirements.

This chapter describes: On page:

About Calculating Requirement Risks 200

Understanding The Risk-Based Quality Management Process 201

Determining the Risk Category 203

Defining the Testing Policy Settings 205

Finalizing the Testing Policy 207

Analyzing the Testing Strategy 211

Risk-Based Quality Management Example 215
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About Calculating Requirement Risks

When planning how to test your requirements, you generally do not have 
unlimited resources available, and are not able to fully test every 
requirement. You must make compromises and only partially test 
requirements that have low criticality to the business, or those that have 
only a minor risk associated with their implementation. The risk-based 
quality management feature enables you to calculate at which level to test 
each requirement, based on the nature of the requirement and the resources 
you have available. You can then plan your testing process based on these 
recommendations.

Each requirement type can be enabled for risk-based quality management. 
Each requirement type with risk-based quality management enabled 
supports either risk analysis or risk assessment:

➤ An analysis requirement is a requirement belonging to a type that represents 
higher levels in the requirements tree hierarchy, such as the Folder type. You 
perform risk analysis on an analysis requirement based on the assessment 
requirements under it in the requirements tree.

➤ An assessment requirement is a requirement belonging to a type that 
represents requirements that are children of analysis requirements and at a 
lower level in the requirements tree hierarchy. Assessment requirements 
under a particular analysis requirement form the basis for risk analysis on 
that analysis requirement.

You work with risk-based quality management in the Requirement Details 
view of the Requirements module. You can also work with risk-based quality 
management in the Risk view of the Requirement Details dialog box.

You can customize default settings for risk-based quality management. For 
more information on customizing default risk-based quality management 
settings, see the HP Quality Center Administrator’s Guide.
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Understanding The Risk-Based Quality Management 
Process

Performing a risk-based quality management analysis for an analysis 
requirement involves the following steps: 

Determining Risk Categories

For each assessment requirement under the analysis requirement, you 
determine the Risk Category. The Risk Category is composed of two factors: 
Business Criticality and Failure Probability. Business Criticality measures 
how crucial a requirement is for the business. Failure Probability indicates 
how likely a test based on the requirement is to fail, based on the 
complexity of the requirement’s implementation. Quality Center can 
calculate a value for each of these factors based on the values you assign to 
each of a series of criteria related to these factors. You can also assign a value 
for each factor directly. For more information, see “Determining the Risk 
Category” on page 203.

Define Testing 
Scope

Create
Requirements

Create
Requirements

Detail 
Requirements

Detail 
Requirements

Analyze 
Requirements

Analyze 
Requirements

Determine
Risk Categories

Define Testing Policy
Settings

Finalize
Testing Policy

Analyze
Testing Strategy
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Defining Testing Policy Settings

After you determine the Risk Category of the assessment requirements 
under an analysis requirement, you define the initial settings for testing the 
analysis requirement and the assessment requirements under it. These 
settings include how much time to assign to a requirement of a specific 
Failure Probability were you to test it fully and how long it would take you 
to perform partial or basic testing on a requirement. You also decide which 
level of testing you want to perform on requirements for each Risk Category. 
For more information, see “Defining the Testing Policy Settings” on 
page 205.

Finalizing the Testing Policy

After you determine the testing policy settings, Quality Center calculates the 
total estimated testing time for the analysis requirement and the assessment 
requirements under it. You decide how many resources you have to assign to 
test these requirements, and can then make adjustments to the testing 
policy to ensure that you have enough time to perform all the testing, and 
that no resources are wasted. For more information, see “Finalizing the 
Testing Policy” on page 207.

Analyzing the Testing Strategy

After you finalize how many resources to allocate to each requirement, you 
can view a report to display and analyze the conclusions you reached. For 
more information, see “Analyzing the Testing Strategy” on page 211.

For an example of using risk-based quality management to help you decide 
on a testing strategy for a requirement, see “Risk-Based Quality Management 
Example” on page 215.
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Determining the Risk Category

You can assign or calculate the Risk Category of an assessment requirement. 
The Risk Category is composed of its Business Criticality and Failure 
Probability. Quality Center then uses this category to calculate how many 
resources to assign to each requirement.

➤ The Business Criticality of a requirement is a measure of how important the 
requirement is to your business. It does not measure how complex the 
requirement is to implement. It has three possible values: A - Critical, 
B - Important, and C - Nice to Have. For example, a requirement affecting a 
minor feature that is likely to be used rarely might be assigned a Nice to Have 
Business Criticality, whereas a requirement that is essential to your 
application’s functionality would probably be assigned a Critical Business 
Criticality.

➤ The Failure Probability of a requirement is a measure of how likely a test on 
the requirement is to fail, based on the technical complexity of the 
requirement’s implementation, without consideration of the requirement’s 
impact on the business. It has three possible values: 1 - High, 2 - Medium, 
and 3 - Low. For example, a requirement whose implementation involves 
making significant changes across most areas of your application probably 
has a high complexity and would be assigned a High Failure Probability. In 
contrast, a requirement that involves changing an icon in your application 
would probably not have many associated risks, and so is likely to be 
assigned a Low Failure Probability.

You determine the Business Criticality and Failure Probability of a 
requirement by assigning them values directly or by assigning values to a set 
of criteria. If you do not determine both these factors for a requirement, 
Quality Center does not include the requirement in the risk analysis.

You can customize these criteria, their possible values, and how these values 
determine the Business Criticality and Failure Probability. For more 
information, see the HP Quality Center Administrator’s Guide.
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To determine the Risk Category for a requirement:

 1 In the Requirement Details view of the Requirements module, select an 
assessment requirement and click the Risk tab. In the Risk tab, click the 
Business Criticality tab. The Business Criticality tab displays a list of criteria 
used to determine Business Criticality.

 2 Assign a value to each criterion. To assign a value to a criterion, in the 
Criterion column, click a criterion name and select a value from the Value 
column. You can view a description of a criterion in the Description of 
Criterion box.

After you have assigned a value to each criterion, the Calculated Business 
Criticality is updated to according to the values you assigned to the criteria.
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 3 To ignore the Business Criticality value calculated on the basis of the values 
for the criteria, and use instead a custom value when performing risk 
analysis, select Override calculated value. In the Custom Business Criticality 
box, select the Business Criticality value which you want to use when 
performing risk analysis.

 4 Click the Failure Probability tab and repeat steps 2 to 3 above to determine 
the Failure Probability value for the requirement.

 5 To ignore an assessment requirement when performing risk analysis, select 
the Exclude from Analysis check box located at the top of the Risk tab.

 6 In the Estimated development time box, you can type the estimated time 
needed to develop the requirement. Quality Center can then calculate the 
total estimated development time for an analysis requirement and its 
children as the sum of the estimated development times of the children. 
Assigning the estimated development effort is optional, and does not affect 
the risk analysis.

Defining the Testing Policy Settings

After you have defined the Risk Category for each requirement, you 
determine how much time each requirement needs to be tested. The time 
needed to test a requirement depends on the Failure Probability of the 
requirement. A requirement with a high Failure Probability generally 
requires more testing time as it is more likely that the requirement’s 
implementation contains defects. For each Failure Probability, you define 
the Testing Time needed to test fully a requirement with that Failure 
Probability. The Testing Time is measured by a label that you define in 
Project Customization. You can measure the Testing Time in hours, days, 
weeks, or months.

Quality Center defines four Testing Levels: Full, Partial, Basic, and None. For 
partial and basic testing, you define how much Testing Time is required for a 
requirement as a percentage of full testing. For example, if 20 hours are 
required to perform full testing on a requirement and partial testing is 
defined as 75% of full testing, Quality Center calculates that 15 hours are 
required to perform partial testing on the requirement. A requirement 
whose Testing Level is set to None is not tested at all, and the Testing Effort 
is therefore zero.
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After you define the Testing Time required for each Testing Level and Failure 
Probability, you can estimate at what Testing Level to test requirements. For 
each Risk Category, you assign a Testing Level. This determines at what level 
to test requirements of that Risk Category.

You can customize the testing policy used by default. For more information, 
see the HP Quality Center Administrator’s Guide.

To define the testing policy settings for a requirement:

 1 In the Requirement Details view of the Requirements module, select an 
analysis requirement and click the Risk tab. Click the Show button to 
display the Change Analysis Constants section.

 2 Under Testing Time (full) per failure probability, for each Failure Probability 
value, type the estimated Testing Time required to fully test a requirement 
with the Failure Probability value.

 3 Under Testing level, in the Partial and Basic boxes, type the default Testing 
Time required for partial testing and basic testing of a requirement. You 
express this as a percentage of the effort required for full testing.

 4 In the Testing Policy grid, you can define the level to test a requirement of 
each Risk Category.

To define these levels, click the arrow next to the cell in the grid 
corresponding to a particular Risk Category value. Select a Testing Level 
from the available Testing Levels. The available Testing Levels are Full, 
Partial, Basic, and None. Next to each Testing Level, you can see the 
estimated time needed to test a requirement at that level, based on the 
Testing Efforts and Testing Levels you defined.
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 5 To display the default constants used, as set in Project Customization, click 
the Show Defaults button. The Risk-Based Quality Management Constants 
Defaults dialog box opens.

In the Risk-Based Quality Management Constants Defaults dialog box, you 
can click the Restore Defaults button to assign these default values to the 
constants used for the current requirement.

Click Close to close the Risk-Based Quality Management Constants Defaults 
dialog box.

Finalizing the Testing Policy

Based on the testing policy you defined, Quality Center can calculate the 
total estimated testing time for the analysis requirement and the assessment 
requirements under it. You estimate how much time you have available to 
test these requirements and make adjustments to the testing policy to make 
sure that the testing time required does not exceed the testing resources 
available.

For example, suppose you have 100 hours available to test a requirement. 
Quality Center estimates that you need 120 hours to test the requirement 
using the current Testing Levels. You decide to lower the Testing Level for 
requirements with Nice to Have Business Criticality and Medium Failure 
Probability from Partial to Basic. After you adjust the Testing Level and 
recalculate the testing time, Quality Center estimates that you need only 98 
hours to perform the testing, which is within the time you have available. 
You can therefore now plan testing your requirement based on 
Quality Center’s recommendations.

To finalize the testing policy:

 1 Make sure that you have determined the Risk Category of all assessment 
requirements that are located under the analysis requirement for which you 
want to finalize the testing policy, and that you want to include in the risk 
analysis. For more information on determining the Risk Category, see 
“Determining the Risk Category” on page 203.

 2 You can filter the requirements tree to include only the assessment 
requirements you want to include in the risk analysis. For more information 
on filtering, see “Filtering Records” on page 55.
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 3 If you do not want to use the default Testing Effort and Testing Level values, 
make sure that you have defined custom values. For more information, see 
“Defining the Testing Policy Settings” on page 205.

 4 In the Requirement Details view of the Requirements module, select an 
analysis requirement and click the Risk tab.

 5 In the Total allocated testing time box, type the time available to test the 
analysis requirement and the assessment requirements under it.
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 6 Click the Perform Risk Analysis button. Quality Center calculates the Testing 
Level and Testing Time for each assessment requirement under the analysis 
requirement that matches the current filter. This calculation is based on the 
assessment requirements’ Risk Category, and the Testing Level and Testing 
Time values you defined for the analysis requirement. The results of this 
calculation are displayed in the following ways:

➤ Total required testing time. Displays the total calculated time required to 
test all the assessment requirements under the analysis requirement 
matching the current filter and included in the risk analysis.

➤ Total required development time. Displays the total time required to 
develop all the assessment requirements under the analysis requirement, 
based on the required development time you optionally estimated for 
each assessment requirement.

➤ No. of Requirements per Risk Category graph. Displays the number of 
child requirements of the analysis requirement of each Risk Category.

➤ Total Testing Time per Risk Category graph. Displays the total calculated 
testing time required to test all the requirements of each Risk Category.

 7 To display which requirements are included in each risk category, and which 
were not included in the analysis, click a segment in the Requirements per 
Risk graph, or the missing assessment or excluded links. The Drill Down 
Results dialog box opens and displays a grid with a list of requirements in 
the category. You can determine the order and appearance of the columns 
and view details for an individual requirement. You can also export the 
contents of the grid as a text file, Microsoft Excel spreadsheet, Microsoft 
Word document, or HTML document. For more information, see “Exporting 
Data to a File” on page 73.

Tip: The missing assessment link displays the requirements for which you 
did not determine a Risk Category or exclude explicitly from the analysis. It 
is recommended that you check these requirements to make sure that there 
are no requirements that should be assigned a Risk Category. If you really do 
not want to include a requirement in the analysis, it is recommended that 
you exclude it from the analysis explicitly.
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 8 Compare the total calculated testing time with the resources you have 
available. If the resources you have available are not sufficient to test the 
requirement according to the current settings, it is recommended that you 
reduce the Testing Level for a Risk Category, or reduce the Testing Time 
assigned to each Testing Level, and perform the calculation again. For more 
information on changing the Testing Levels and Testing Times, see 
“Defining the Testing Policy Settings” on page 205.

 9 When you are satisfied with the testing policy, click the Save and Apply to 
Children button to apply it to all assessment requirements under the 
analysis requirement that match the current filter.

 10 You can now analyze how the testing policy you decided upon for the 
analysis requirement affects the assessment requirements under it, and 
produce a report detailing your testing strategy. For more information, see 
“Analyzing the Testing Strategy” on page 211.
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Analyzing the Testing Strategy

After you have finalized your testing policy for an analysis requirement, you 
can analyze the testing strategy for the analysis requirement and for the 
assessment requirements under it. Note that the analysis results are only 
valid for the requirements at the time the analysis was last performed. If you 
subsequently modify the Risk Categories of the requirements, or the testing 
policy, you should re-perform the analysis.

Analyzing the Testing Strategy for Analysis Requirements
After you have finalized your testing policy for an analysis requirement, you 
can generate a report detailing your testing strategy.

To analyze the testing strategy for an analysis requirement:

 1 In the Requirement Details view of the Requirements module, select an 
analysis requirement and click the Risk tab.

 2 Click the Generate Report button. The Generate Report dialog box opens.

 3 In the Default Location box, type the location and name of the Word file to 
which you want the data to be exported. You can click the browse button to 
select a location from the Save As dialog box.

 4 To add the report as an attachment to the analysis requirement, in addition 
to saving the report in the location you specified, select Add report as 
attachment.

 5 To include a list of the requirements included in the risk analysis, select 
Include list of requirements in the report.
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 6 Click Generate. A report is generated and saved in the location you 
specified.

The report may contain the following headings, depending on the options 
you selected in the Generate Report dialog box:

Heading Description

Date last saved The date on which the risk analysis was last 
performed.

Filter The filter used to determine which requirements 
were included in the risk analysis.

Processed The number of requirements included in the risk 
analysis. Also provides a breakdown of which 
requirements had assessment, which were missing 
assessment, and which were excluded from 
assessment.
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Analyzing the Testing Strategy for Assessment 
Requirements
After you have finalized your testing policy for an analysis requirement, you 
can analyze its effect on the assessment requirements under the analysis 
requirement.

Total required testing time The total time required to test the requirements 
included in the risk analysis, according to the 
testing policy you determined.

Total allocated testing 
time

The total time allocated to test the requirements 
included in the risk analysis.

Total required 
development time

The total time required to develop the features 
defined by the requirements.

No. of Requirements per 
Risk Category

A graph displaying a breakdown of the number of 
requirements by their Risk Category.

Total Testing Time per Risk 
Category

A graph displaying the total time needed to test all 
the requirements of each Risk Category.

Implemented testing 
policy

The time necessary to test requirements belonging 
to each Risk Category, according to the testing 
policy used in the risk analysis.

Analyzed requirements A list of the requirements included in the risk 
analysis which had assessments, together which 
their Risk Category, Testing Level, and Testing Time.

Requirements with 
missing assessments

A list of the requirements included in the risk 
analysis which did not have assessments.

Excluded requirements A list of the requirements excluded from the risk 
analysis. These may be requirements explicitly 
excluded from the analysis, or requirements 
belonging to a type that does not support risk-based 
quality management.

Heading Description
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To analyze the testing strategy for an assessment requirement:

 1 In the Requirement Details view of the Requirements module, select an 
assessment requirement and click the Risk tab. Click the Analysis Results tab.

The Analysis Results tab displays the conclusions of the last analysis you 
performed on an analysis requirement that is a parent of the assessment 
requirement:

➤ Based on analysis requirement. Displays the analysis requirement on 
which the last analysis that included the current requirement was 
performed. You can click the analysis requirement’s name to go to the 
analysis requirement in the requirements tree.

➤ Last analysis on date. The date on which the last analysis that included 
the current requirement was performed

➤ Overall Risk Assessment. Displays the Business Criticality and Failure 
Probability for the requirement.

➤ Calculated Testing Level. The level at which to test the requirement, as 
calculated in the last analysis that included the current requirement.

➤ Calculated Testing Time. The time allocated to test the requirement, as 
calculated in the last analysis that included the current requirement.
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 2 To override the calculated values in the next calculation, and instead use 
custom values, select the Use these for the next calculation check box. In 
the Testing Level box, select the Testing Level to use for the next calculation. 
In the Testing Time box, type the Testing Effort to use for the next 
calculation. When you next perform an analysis that includes the current 
requirement, these values will be used instead of the calculated values.

Note: You cannot override the calculated values if you have not determined 
the Risk Category for the requirement. For more information on 
determining the Risk Category for a requirement, see “Determining the Risk 
Category” on page 203.

Risk-Based Quality Management Example

Suppose you are using a project based on an application for reserving flights 
and vacations. You want to plan the testing of the analysis requirement 
Online Travel Information Source, located under Mercury Tours Application.
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You begin by assigning values to the Business Criticality criteria for the child 
assessment requirement Itineraries Information. As information on travel 
itineraries is for display purposes and does not involve calculation or 
validation, you assign the value Display to the criterion Type of Process. As 
incorrect information on travel itineraries could result in legal action, you 
assign the value Legal to the criterion Impact of failure. You also assign the 
value Very often to the criterion Frequency of use, and the value Many/High 
to the criterion Number/Significance of affected users. Quality Center now 
calculates the Business Criticality of the requirement as A.

Similarly, you determine the Failure Probability by assigning values to its 
criteria. Quality Center calculates the Failure Probability as 2, to give an 
overall Risk Category A2. You then proceed to determine the Risk Category 
for each of the assessment requirements Maps, Travel Guides, and Tips & 
FAQ.
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You are now ready to perform a risk analysis on the requirement Online 
Travel Information Source. You decide to use Quality Center’s default testing 
policy and perform a risk analysis based on this policy. Quality Center 
calculates that you need 63 hours to test the requirement. However, you 
only have 50 hours available, which is 79% of the required resources, so 
need to modify the testing policy.

You change the Testing Level for requirements with Risk Category A2 from 
Full to Partial. Quality Center re-calculates the time needed to test the 
requirement as 58 hours, which is still greater than the time available. You 
therefore modify the definition of partial testing by defining it as 55% of full 
testing instead of 67%. The time needed to test the requirement is now 
estimated at 52 hours, which is the amount of time you have available, so 
you decide to accept this modified testing policy.
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You now have sufficient resources to test the requirement, so you create a 
risk analysis report to summarize the testing strategy recommended by 
Quality Center, and give it to the testing team for them to use as a basis for 
their test plan.
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15
The Test Plan Workflow

Developing a clear and concise test plan is an essential requirement for 
successful application testing. A good test plan enables you to assess the 
quality of your application at any point in the testing process.

This chapter describes how you develop a test plan using the Test Plan 
module. Developing a test plan consists of the following: 

Define
Testing Strategy

Define
Test Subjects

Design
Tests

Create Requirements 
Coverage

Design
Test Steps

Automate
Tests

Analyze
Test Plan
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Defining Testing Strategy

Outline a strategy for achieving your testing requirements, as defined in the 
Requirements module. Ask yourself two basic questions: 

How should you test your application?

➤ Which testing techniques will you use (stress tests, security tests, 
performance and load tests, etc.)? 

➤ How will you handle defects (severity classification, authorization to open 
and close defects, etc.)?

What resources do you require?

➤ What resources do you require in order to test (personnel, hardware, etc.)?

➤ When will the various tasks be completed?

For example, consider a flight reservation application that lets you manage 
flight scheduling, passenger bookings, and ticket sales. Testing will require 
designing both manual and automated tests. You could assign testing 
personnel with programming experience the task of designing automated 
tests, while non-programmers could design manual tests.

Defining Test Subjects

Consider the hierarchical relationship of the functions in your application. 
Divide the functions into subjects and build a test plan tree representing 
your application’s functionality. 

The test plan tree is a graphical representation of your test plan. It is a 
hierarchical list of tests organized according to topic, which describes the set 
of tests you will implement in order to meet your quality requirements. For 
example, the flight reservation application could require that you include 
Flight Finder, Book Flight, Flight Confirmation, and Flight Cost as test 
subjects.

For a complete description and illustration of how to create a test plan tree, 
see Chapter 17, “Developing the Test Plan Tree”.
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Designing Tests

Plan tests for each subject in your test plan tree. Decide which types of tests 
to create for each subject, such as sanity level tests or regression tests. (For an 
explanation of these test types, see Chapter 24, “Creating Test Sets”.) Then 
create the tests and assign them to a branch of the test plan tree. For 
example, in the flight reservation application, you could include the 
following tests under the subject Flight Finder: Airline Preference, Departing 
and Arriving Locations, Departing Date, Find Flight, Flight Time Preference, 
and Number of Passengers.

You can link a test to specific defects. This is useful, for example, when a 
new test is created specifically for a known defect. By creating a link, you 
can determine if the test should be run based on the status of the defect. 

For information on planning tests, see Chapter 17, “Developing the Test 
Plan Tree”.

Creating Requirements Coverage

Link each test in the test plan tree with a requirement or requirements in 
the requirements tree. By defining requirements coverage for a test, you can 
keep track of the relationship between the tests in your test plan and your 
original testing requirements. For example, in the flight reservation 
application, the tests in the subject Registration cover the requirement topic 
Customer Personal Information.

For information on requirements coverage, see Chapter 18, “Linking Tests to 
Requirements”.
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Designing Test Steps

Design the tests in your test plan tree. Create test steps describing the 
operations to perform and the expected results. After you define the test 
steps, decide whether to perform the test manually or to automate it.

For manual tests you define steps, execute them on your application, and 
record the results of each one. Use manual tests in cases where the test 
requires a response by the tester. Manual tests include usability tests, one-
time tests, tests that need to be run immediately, tests requiring knowledge 
of the application, and tests without predictable results. 

For example, in the flight reservation application, tests that check if a dialog 
box is user-friendly require user response. Therefore, you should make these 
tests manual.

For information on designing test steps, see Chapter 19, “Building Tests.”

Automating Tests

Automating a test allows unattended execution of the test at high speed. It 
also makes the test reusable and repeatable. For example, you automate 
functional, benchmark, unit, stress and load tests, as well as tests requiring 
detailed information about applications. 

After designing test steps, you can decide which tests to automate. Factors 
influencing test automation include frequency of execution, volume of data 
input, length of execution time, and complexity. 

For automated tests, you can first design test steps and automate them by 
generating a test script. The test script can be for WinRunner, QuickTest 
Professional, LoadRunner, or Visual API-XP.

For example, in the flight reservation application, you can automate a test 
that checks whether the login mechanism works. After adding test steps, 
you create a test script. Then, using QuickTest Professional, you complete 
the automated test script.

For more information on creating automated tests, see Chapter 20, 
“Creating Automated Tests.”
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You can also create automated system tests that provide system information 
for a machine, capture a desktop image, or restart a machine. For more 
information, see Chapter 21, “Working with System Tests”.

Analyzing Your Test Plan

Review your test plan to determine how well it meets the goals that you 
defined at the beginning of the testing process. Then, analyze your test plan 
by generating reports and graphs. For more information, see Part VII, 
“Quality Center Analysis.”

For example, you can create a report that displays design step data for each 
test in a test plan tree. You can then use this report to help you determine 
your test design priorities.

In order to best ensure the success of the testing process, it is recommended 
that you analyze your test plan throughout the testing process. Review the 
plan, and determine whether or not it matches your testing goals. Make 
adjustments to your test plan accordingly.
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16
The Test Plan Module at a Glance

This chapter introduces the key elements in the Test Plan module.

This chapter describes: On page:

The Test Plan Tree 228

The Test Plan Menu Bar 230

The Test Plan Toolbar 231

The Test Grid 232
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The Test Plan Tree

You design tests in Quality Center in the Test Plan module, which you open 
by clicking the Test Plan button on the sidebar. To view the test plan tree, 
choose View > Test Plan Tree. 

The test plan tree contains the following key elements:

➤ Test Plan menu bar. Displays drop-down menus of Test Plan module 
commands. For more information, see “The Test Plan Menu Bar” on 
page 230.

➤ Test Plan toolbar. Contains buttons of commands commonly used when 
creating and modifying the test plan tree. For more information, see “The 
Test Plan Toolbar” on page 231.

➤ Test Plan Tree. A graphical representation of your test plan. For more 
information, see Chapter 17, “Developing the Test Plan Tree.”

➤ Details tab. A description of the subject folder or test currently selected on 
the test plan tree. For more information, see Chapter 17, “Developing the 
Test Plan Tree.”
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➤ Design Steps tab. A list of test steps explaining how to execute the test 
currently selected on the test plan tree. The tab includes an icon  if the 
selected test has design steps. For more information, see Chapter 19, 
“Building Tests.”

➤ Test Script tab. The test script for the test currently selected on the test plan 
tree. The tab includes an icon  if the selected test has a test script. For 
more information, see Chapter 20, “Creating Automated Tests.” For more 
information on using the Test Script tab in Business Process Testing, refer to 
the HP Business Process Testing User’s Guide.

➤ Attachments tab. A list of attachments that provide additional information 
for the test currently selected on the test plan tree. The tab includes an 
icon  if the selected test has any attachments. For more information, see 
Chapter 5, “Adding Attachments.”

➤ Req Coverage tab. A list of the requirements that are met by the test 
currently selected on the test plan tree. The tab includes an icon  if the 
selected test has requirements coverage. For more information, see 
Chapter 18, “Linking Tests to Requirements.”

➤ Linked Defects tab. A list of the defects that are linked to the test currently 
selected on the test plan tree. For more information, see Chapter 32, 
“Linking Defects.”

➤ Live Analysis tab. A graphical representation of test data related to the 
selected subject folder in the test plan tree. For more information, see 
Chapter 35, “Generating Live Analysis Graphs.”

Tips: 

➤ Right-click a test in the test plan tree and choose Go to Test in Test Set. 
The Select Test Set dialog box opens. Select the test set containing the 
current test and the test instance that you want to run, and click OK. The 
Test Lab module opens with the selected test highlighted.

➤ To find a specific test by Test ID in the test plan tree, choose Tests > 
Go to Test, and enter the test ID. To display the test ID, select the Test ID 
column using the Select Columns dialog box. You can only go to tests 
that are in the current filter.
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The Test Plan Menu Bar 

The Test Plan menu bar has the following menus:

➤ The Tests menu contains commands that enable you to manage the folders 
and tests in the tree, go to tests in test sets, and to mail tests. For more 
information, see Chapter 17, “Developing the Test Plan Tree.” 

➤ The Edit menu contains commands that enable you to cut, copy, paste, 
rename, delete, find, replace, or search tests. You can also view and clear 
alerts for tests and flag tests for follow-ups. For more information on alerts 
and follow-ups, see Chapter 4, “Alerting on Changes.”

➤ The View menu contains commands that enable you to set the display of 
tests in the test plan tree or grid, filter and sort the tests, and set the 
displayed columns.

➤ The Favorites menu contains commands that enable you to add and 
organize favorite views. Available only in Test Grid. For more information 
on favorite views, see Chapter 6, “Working with Favorite Views.”

➤ The Analysis menu contains commands that enable you to generate 
planning reports and graphs. For more information on planning reports, see 
Chapter 33, “Generating Reports.” For more information on planning 
graphs, see Chapter 34, “Generating Graphs,” and Chapter 35, “Generating 
Live Analysis Graphs.”

Tip: You can access the Test Plan menu bar from the Test Plan module by 
pressing the shortcut key F9. Additionally, you can perform many other 
Quality Center operations using shortcut keys. For a list of shortcut keys, see 
Appendix B, “Quality Center Keyboard Shortcuts.”
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The Test Plan Toolbar 

The Test Plan toolbar has the following buttons:

New Folder. Adds a new subject folder to the test plan tree. For more 
information, see “Creating a Test Plan Tree” on page 239.

New Test. Adds a new test to the test plan tree. For more information, see 
“Adding Tests to a Test Plan Tree” on page 240.

Delete. Deletes the selected folder or test from the tree. For more 
information, see “Deleting a Folder or Test” on page 258.

Refresh All. Refreshes the test plan tree so that it displays the most up-to-
date tests.

Set Filter/Sort. Includes the following options:

➤ Set Filter/Sort. Opens the Filter dialog box, enabling you to filter and sort 
the tests in the test plan tree. 

➤ Clear Filter/Sort. Clears any filters or sorting that you have applied to the 
test plan tree.

For more information on filtering and sorting tests, see Chapter 3, “Working 
with Quality Center Data.”

Sort Folders. Opens the Sort Folders in Test Plan Tree dialog box, enabling 
you to custom sort the folders in the test plan tree. By default, folders are 
sorted by name. For more information, see “Sorting a Test Plan Tree” on 
page 256.

Flag for Follow Up. Opens the Flag For Follow Up dialog box, enabling you 
to add or modify a follow up flag for a test. For more information, see 
“Flagging for Follow Up” on page 82.
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Send by E-mail. Opens the Send E-mail dialog box, enabling you to send e-
mail containing the selected tests to recipients selected from a list, or to any 
other e-mail addresses. For more information, see “Mailing Tests” on 
page 248.

Text Search. Opens the text search pane in the lower part of the window, 
enabling you to enter keywords and search predefined fields. For more 
information, see “Searching Records” on page 71.

The Test Grid 

The Test Grid displays all the tests in a Quality Center project. Each row 
displays a separate test record. Each column represents a separate data item.

To view the Test Grid, choose View > Test Grid. 
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You can view and modify test information in the Test Grid. For example, 
you can copy several automated tests and paste them in another project, or 
you can delete several tests at once. In addition, you can save the grid 
information in several formats, including a text file, Word document, HTML 
document, XML document, and Excel spreadsheet.

The Test Grid contains the following key elements:

➤ Test Grid toolbar. Contains buttons of commands commonly used when 
creating and modifying the Test Grid. For more information, see “The Test 
Grid Toolbar” on page 234.

➤ Indicator columns. Indicates that the specified test has attachments, linked 
defects, alerts, and follow up flags. Choose View > Indicator Columns to 
display these columns.

➤ Grid filter. Displays the filter that is currently applied to a column. For more 
information, see “Filtering Records” on page 55.

➤ Description tab. Displays a description of the selected test in the Test Grid.

➤ Attachments tab. Displays the attachments for the selected test. For more 
information, see Chapter 5, “Adding Attachments.”

Column Description

Attachments Click the  icon to view attachments for the test. 
For more information, see Chapter 5, “Adding 
Attachments.”

Linked Entities Click the  icon to view linked entities for the test. 
For more information, see Chapter 32, “Linking 
Defects.”

Alerts Click the  icon to view alerts for the test. For more 
information, see “Viewing Alerts” on page 80.

Follow Up Flags Click the  icon to view follow up alerts for the 
test. For more information, see “Flagging for Follow 
Up” on page 82.
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➤ History tab. Displays the changes made to a test. For each change, the grid 
displays the date and time of the change and the name of the user who 
made the change. You can expand a change to view a list of fields modified 
during the change. For each field, the grid displays the old value and the 
new value.

Tip: To find a specific test by Test ID in the Test Grid, choose Test > 
Go to Test, and enter the test ID. To display the test ID, select the Test ID 
column using the Select Columns dialog box.

The Test Grid Toolbar
The Test Grid toolbar has the following buttons:

Delete Selected Tests. Deletes the selected tests from the Test Grid.

Refresh All. Refreshes the Test Grid so that it displays the most up-to-date 
tests. 

Set Filter/Sort. Includes the following options:

➤ Set Filter/Sort. Opens the Filter dialog box, enabling you to filter, sort, 
and group the tests in the Test Grid.

➤ Clear Filter/Sort. Clears any filters, sorting, or grouping that you have 
applied to the Test Grid.

For more information on filtering and sorting tests, see Chapter 3, “Working 
with Quality Center Data.”

Select Columns. Opens the Select Columns dialog box, enabling you to 
determine which columns to display in the grid and their order. For more 
information, see “Arranging Columns” on page 51.

Go to Test in Test Plan Tree. Closes the Test Grid and displays the selected 
test in the test plan tree.

Attachments. Opens the Attachments dialog box, enabling you to add an 
attachment to the selected test. For more information, see Chapter 5, 
“Adding Attachments.”
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Flag for Follow Up. Opens the Flag For Follow Up dialog box, enabling you 
to add or modify a follow up flag for a test. For more information, see 
“Flagging for Follow Up” on page 82.

Send by E-mail. Opens the Send E-mail dialog box, enabling you to send 
e-mail containing the selected test to recipients selected from a list, or to any 
other e-mail addresses. For more information, see “Mailing Tests” on 
page 248.

Text Search. Opens the text search pane in the lower part of the window, 
enabling you to enter keywords and search predefined fields. For more 
information, see “Searching Records” on page 71.

Test Grid Columns
The Test Grid displays the following test planning data columns:

Column Description

Comments Displays comments about the test.

Creation Date The date on which the test was created. By default, the 
creation date is set to the current server date. Click the 
down arrow to display a calendar and select a different 
creation date.

Description Describes the test.

Designer The user name of the person who designed the test.

Estimated DevTime The time estimated to design and develop the test.

Execution Status The execution status of the last run of an instance of 
the test. Execution status can be one of the following: 
Failed, N/A, No Run, Not Completed, Passed.

Modified The date and time of the last change to the test.

Path The test’s path on the server side (relative to the test 
repository).

Status The planning status of the test. The default status is 
Design.
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Notes: 

➤ You can add user-defined fields and change the label of any of the fields 
in the Test Grid. You can also customize project lists. For more 
information, refer to the HP Quality Center Administrator’s Guide.

➤ You can use the Script Editor to restrict and dynamically change the 
fields and values in the Test Grid. For more information, refer to the 
HP Quality Center Administrator’s Guide.

➤ When you select a Test Grid column with a user name value, 
Quality Center displays a list with the name and full name of each user. 
You can search for users, sort users, group users by user group, and select 
users from the users list or a group tree. For more information, see 
“Selecting Users” on page 54.

Subject The subject folder in the test plan tree in which the 
test resides.

Template Indicates whether the manual test or QuickTest 
Professional test is a test template. The value in this 
column is Y if the test is a test template; N or empty 
otherwise. For more information on manual template 
tests, see “Marking a Manual Test as a Template Test” 
on page 280. For more information on QuickTest 
Professional template tests, see “Adding Tests to a Test 
Plan Tree” on page 240.

Test ID A unique numeric ID for the test, assigned 
automatically by Quality Center. The Test ID is read-
only. 

Test Name The name of the test.

Type The type of test. For example, manual or WinRunner.

Column Description
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Developing the Test Plan Tree

The test plan tree organizes and displays your tests hierarchically, according 
to test subjects.

This chapter describes: On page:

About the Test Plan Tree 238

Creating a Test Plan Tree 239

Adding Tests to a Test Plan Tree 240

Viewing the Test Plan Tree 245

Viewing Instances of Tests 247

Mailing Tests 248

Finding Tests in the Tree or Test Grid 250

Replacing Field Values in the Test Grid 253

Copying Tests and Subject Folders 254

Copying URLs of Tests 255

Sorting a Test Plan Tree 256

Modifying a Test Plan Tree 257
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About the Test Plan Tree

The typical application is too large to test as a whole. The Test Plan module 
enables you to divide your application according to functionality. You 
divide your application into units, or subjects, by creating a test plan tree. 
This is a graphical representation of your test plan, displaying your tests 
according to the hierarchical relationship of their functions. 

After you define subjects in the tree, you decide which tests to create for 
each subject and add them to the tree. At this stage, you define basic 
information about the test, such as its name, status, and the designer. You 
can also attach a file, URL, application snapshot or system information to 
illustrate a test. Afterwards, you define the test steps. Test steps contain 
detailed instructions on how to execute a test and evaluate the results.

During the testing process, you may need to modify your test plan. You can 
update the test plan tree at any time.

There are a number of methods for organizing your test plan by subject. For 
example, you could define subjects according to:

➤ application functionality—such as editing, file operations, and reporting

➤ type of testing—such as functional, user interface, performance, and load

Suppose you are testing a flight reservation application that lets you manage 
flight scheduling, passenger bookings, and ticket sales. (For the complete 
example, refer to the QualityCenter_Demo project.) You might define the 
following subjects for the test plan tree:
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Notice how, for example, the Itinerary subject contains additional subject 
folders. These folders further categorize the tests in the test plan tree by 
creating additional levels of subjects.

After you build the basic structure of your plan, you create tests and assign 
them to each subject. For example, in the test plan tree shown above, you 
might assign tests to the Reservation Details subject folder as follows:

Note: Developing and editing a test plan tree requires appropriate user 
permissions. For more information, refer to the HP Quality Center 
Administrator’s Guide.

Creating a Test Plan Tree

You define a hierarchical framework for your test plan by creating a test plan 
tree that may contain folders and subfolders. 

Note: In addition to creating a test plan tree directly in Quality Center, you 
can also import test plan data from Microsoft Word or Microsoft Excel to 
your Quality Center project. To import from Word, you must install the 
Microsoft Word Add-in and the HP Quality Center Connectivity Add-in. To 
import from Excel, you must install the Microsoft Excel Add-in and the 
HP Quality Center Connectivity Add-in. You can install the add-ins from the 
HP Quality Center Add-ins page. For more information, refer to the 
HP Quality Center Installation Guide.
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To create a test plan tree:

 1 In the test plan tree, select a subject folder and click the New Folder button, 
or choose Tests > New Folder. The New Folder dialog box opens.

 2 In the Folder Name box, type a name for the subject and click OK. Note that 
a folder name cannot include the following characters: \ ^ *

The new subject folder appears under Subject in the test plan tree.

 3 In the Description tab, type a description of the subject. 

 4 Click the Attachments tab to add an attachment to the new folder if 
necessary. An attachment can be a file, URL, snapshot of your application, 
an item from the Clipboard, or system information. For more information, 
see Chapter 5, “Adding Attachments.”

 5 To create additional subjects at the main level, repeat steps 1 to 4.

 6 To create a subfolder, select a subject folder and repeat steps 1 to 4. 

Adding Tests to a Test Plan Tree 

Once you have created a test plan tree containing the main test subjects, 
you are ready to create tests. Each test should have a distinct objective, such 
as verifying a specific function or system requirement. The tests you define 
should be based on the goals you set at the beginning of the testing process.

For example, in the flight reservation application, you could define a test 
called Password Verification that checks that only users that provide the 
correct password can sign on. You could place this test under the subject 
Sign-On/Sign-Off.
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Tip: You can automatically create tests based directly on your requirements 
in the Requirements module. For more information, see “Creating Tests 
from Requirements” on page 182.

To add new tests:

 1 Choose a subject folder in the test plan tree.

 2 Click the New Test button, or choose Tests > New Test. The Create New Test 
dialog box opens.

Note: If you have installed the QuickTest Professional Add-in on your 
machine, the Create New Test dialog box includes the Template box.

 3 Select a test type from the Test Type list. You can select the following test 
types:

Test Type Description

MANUAL A Quality Center manual test.

WR-AUTOMATED A test that is executed by WinRunner, HP’s functional 
testing tool for Microsoft Windows applications.

LR-SCENARIO A scenario that is executed by LoadRunner, HP’s load 
testing tool.
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Note: After test creation, you can change the test type from the Test Grid. 
You may be able to select from the Test Grid additional test types to those 
listed above, including the WR-BATCH test type for a WinRunner batch test.

 4 In the Test Name box, type a name for the test. A test name cannot include 
the following characters: \ / : " ? < > | * % ' 

QUICKTEST_TEST A test that is executed by QuickTest Professional, HP’s 
functional enterprise testing tool. 

This test type is only available if you have installed the 
appropriate add-in from the HP Quality Center Add-ins 
page. For more information on installing add-ins, refer to 
the HP Quality Center Installation Guide.

VAPI-XP-TEST A test that is created using Visual API-XP, the 
Quality Center open test architecture API testing tool. For 
more information, see Appendix A, “Working with 
VAPI-XP.”

SYSTEM-TEST A test that instructs Quality Center to provide system 
information, capture a desktop image, or restart a 
machine. For more information, see Chapter 21, 
“Working with System Tests.”

BUSINESS-PROCESS A business process test. For more information, refer to the 
HP Business Process Testing User’s Guide.

Test Type Description
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 5 If you selected QUICKTEST_TEST from the Test Type list, the Template box is 
available. You create your new test based on another QuickTest test, defined 
as a template test. The template test is copied to your new test, without the 
test results. 

Note: To set the QuickTest add-ins that Quality Center associates with a new 
QuickTest test, choose a template test that lists the appropriate add-ins. 
Alternatively, use the default template test provided on your Quality Center 
client. This test loads the Web and ActiveX add-ins by default. For more 
information, refer to the QuickTest documentation and the relevant 
QuickTest add-in documentation.

To select a template test, click the browse button. The Select Tests dialog box 
opens. By default, only QuickTest template tests are displayed. 

Select the template test and click the Add Test button. The Select Tests 
dialog box closes and the template test is displayed in the Template box.

Note: To set a QuickTest Professional test as a template test, right-click the 
test in the test plan tree, and choose Template Test.

 6 Click OK to close the Create New Test dialog box.

If required test fields were defined in the Project Customization window, the 
Required Test Fields dialog box opens. Select values for the required fields, 
and click OK.

The new test appears in the test plan tree under the subject folder you 
selected. In the Details tab, the name is added to the Test Name box.
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 7 Enter the following test details in the Details tab:

Note: You can change the label of any of the test detail fields. You can also 
add user-defined fields to the test details. For more information, refer to the 
HP Quality Center Administrator’s Guide.

 8 In the Details tab, click the Description tab and type a description for the 
test.

 9 In the Details tab, click the Comments tab to add a comment to the test. In 
the Comments tab, click the Add Comment button. A new section is added 
to the Comments tab, displaying your user name and the database’s current 
date.

 10 Click the Attachments tab to add an attachment to the new test if necessary. 
An attachment can be a file, URL, snapshot of your application, an item 
from the Clipboard, or system information. For more information, see 
Chapter 5, “Adding Attachments.”

 11 Click the Req Coverage tab to define requirements coverage. For more 
information, see Chapter 18, “Linking Tests to Requirements.”

 12 Click the Linked Defects tab to link defects to the test. For more 
information, see Chapter 32, “Linking Defects.”

 13 Click the Design Steps tab to define steps for the test. For more information, 
see Chapter 19, “Building Tests.”

Option Description

Designer The person who designed the test. By default, the name of the 
user who is currently logged in to Quality Center is displayed. 
Click the down arrow to select a different user name.

Creation Date The date on which the test was created. By default, the creation 
date is set to the current database server date. Click the down 
arrow to display a calendar and select a different creation date.

Status The current status of the test. The default status is Design. Click 
the down arrow to select a different status from the list.
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Viewing the Test Plan Tree

Use the test plan tree to review the overall structure of your test plan and to 
view the tests assigned to each subject.

A test plan tree can include the following test icons:

Manual test

Manual test that includes test steps

Manual Template test

Manual Template test that includes test steps

WinRunner test

WinRunner batch test

For more information on creating and working with WinRunner batch 
tests, refer to the WinRunner User’s Guide.

LoadRunner scenario

QuickTest Professional test

QuickTest Professional Template test

QuickTest Professional test that includes test steps
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Note: A question mark icon in the test plan tree indicates that the QuickTest 
Professional add-in is not installed on your machine. For more information 
on installing add-ins, refer to the HP Quality Center Installation Guide.

To view tests in the test plan tree:

By default, the test plan tree displays only the highest level subjects in the 
subject hierarchy.

➤ To expand a branch in the tree, click the Expand  sign to the left of the 
branch name. To expand all the branches in the tree, right-click the Subject 
folder and choose Expand All. 

➤ To collapse a branch in the tree, click the Collapse  sign to the left of the 
branch name. To collapse all the branches in the tree, right-click the Subject 
folder and choose Collapse.

➤ To view tests associated with a particular subject, double-click a subject 
folder . 

➤ To refresh all tests in the test plan tree, click the Refresh All button.

➤ Click the Set Filter/Sort button to filter and sort the tests in the test plan 
tree. For more information, see Chapter 3, “Working with Quality Center 
Data.” Any currently applied filters or sorting orders are displayed under the 
test plan tree toolbar.

➤ To view all the tests in a Quality Center project at once, choose View > Test 
Grid. 

QuickTest Professional Template test that includes test steps

Visual API-XP test 

System test

Vuser Script test
246



Chapter 17 • Developing the Test Plan Tree
Viewing Instances of Tests

You can view instances of tests you create in the Test Plan module in test sets 
in the Test Lab module. You can view which test sets contain an instance of 
a test, and go to such a test instance in the Test Lab module.

To view an instance of a test:

 1 In the test plan tree, select a test and choose Tests > Go to Test in Test Set. 
Alternatively, right-click a test and choose Go to Test in Test Set. If there is 
only one instance of the selected test, the Test Lab module opens with the 
instance highlighted. If there is more than one instance, the Select Test Set 
dialog box opens.

 2 In the Test Set box, select the test set containing the test instance you want 
to go to, from the list of all test instances containing the test.

 3 In the Test Instance box, select the instance of the test from the test 
instances in the selected test set.

 4 Click OK. The Test Lab module opens with the selected test instance 
highlighted.
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Mailing Tests 

You can send e-mail about a test to other users in your project. This enables 
you to routinely inform development and quality assurance personnel 
about the status of your tests. A Go To Test link is included in the e-mail, 
enabling the recipient to go directly to the test.

Note: By default, Quality Center sends e-mail in HTML format. To send 
e-mail as plain text instead, edit the MAIL_FORMAT parameter in the 
Site Configuration tab in Site Administration. For more information, refer to 
the HP Quality Center Administrator’s Guide.

To mail a test: 

 1 Select one or more tests in the test plan tree or in the Test Grid, and click the 
Send by E-mail button. The Send E-mail dialog box opens.
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Tip: You can automatically send the e-mail to a specific user type. This can 
be any test column with a user name value, including user-defined fields. 
Click the Send by E-mail arrow and choose an option. For example, choose 
Send Mail to Designer to send the e-mail to the user who designed the test.

 2 Type a valid e-mail address or user name. Alternatively, click the To button 
or CC button to select users. The Select Recipients dialog box opens. 

You can sort the users list, search for users, group users by user groups, and 
select users from the list or from a group tree. For more information, see 
“Selecting Users” on page 54. 

Select the users or user groups to whom you want to send the e-mail, and 
click OK. 
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 3 In the Subject box, type a subject for the e-mail. By default, if you select 
only one test, the domain, project, test ID, and name of the test are 
displayed in the Subject box.

 4 If you select more than one test, the tests are listed in the Item box. You can 
clear any tests you do not want to include in the e-mail.

 5 Choose whether you want to include the Attachments, History, and/or 
Design Steps of the test.

 6 In the Additional comments box, add any comments you may have.

 7 To check the spelling in the dialog box:

➤ Click the Check Spelling button to check the spelling for the selected 
word or text box. If there are no errors, a confirmation message opens. If 
errors are found, the Spelling dialog box opens and displays the word 
together with replacement suggestions.

➤ Click the Spelling Options button to open the Spelling Options dialog 
box, enabling you to configure the way spelling is checked. 

➤ Click the Thesaurus button to open the Thesaurus dialog box and display 
a synonym, antonym, or related word for the selected word. You can 
replace the selected word or look up new words.

 8 Click Custom to customize the e-mail. In the Select Fields dialog box, you 
can specify fields to include in the e-mail.

 9 Click Send to send the e-mail.

Finding Tests in the Tree or Test Grid

You can search for a particular test in the test plan tree or in the Test Grid 
using the Find command.

Tip: If Text Search is available, you can use it to search for tests in the test 
plan tree or Test Grid. Text search provides a more powerful search by 
allowing you to search for keywords and variations of keywords. For 
information on using the text search, see “Searching Records” on page 71.
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Finding Tests in the Test Plan Tree
You can search for a folder or test in the test plan tree. If you have applied 
filters to the test plan tree, the search is restricted to the tests currently 
displayed.

To find a folder or test in the test plan tree:

 1 Select a subject folder in the test plan tree, and choose Edit > Find.

The Find Folder/Test dialog box opens and displays the folder name in the 
Find in box. If you are searching the entire tree, the folder name is Subject.

 2 In the Value To Find box, type the name (or part of the name) of the folder 
or test. Note that the search is not case sensitive.

 3 Check Include Tests to search for both folders and tests.

 4 Click Find.

The Test Plan module attempts to locate the folder or test. If the search is 
successful, the Search Results dialog box opens and displays a list of possible 
matches. Select a result from the list and click the Go To button to highlight 
the folder or test in the test plan tree. 

If the search is unsuccessful, an information box opens.
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Finding Tests in the Test Grid
You can search for tests in the Test Grid, based on the value of a particular 
field. If you have applied filters to the Test Grid, the search is restricted to 
the tests currently displayed.

To find tests in the Test Grid:

 1 Choose View > Test Grid.

 2 Choose Edit > Find. The Find dialog box opens.

 3 In the Find in Field box, select a field in the grid.

 4 In the Value to Find box, type or select the value of the field, for which you 
want to search.

 5 Select Exact Match if you want to find tests with field values that exactly 
match the Value to Find string.

 6 Select Case Sensitive if you want the search to distinguish between 
uppercase and lowercase characters.

 7 Select Use Wildcards if you want to use asterisk (*) characters in your search 
string in order to type only part of the item.

 8 Click Find Next. If the search is successful, the matching test is chosen in the 
grid. If the search is unsuccessful, an information box opens.

 9 Click Find Next again to find the next test that matches the criteria.
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Replacing Field Values in the Test Grid

You can replace field values in the Test Grid using the Replace command.

To replace a field value in the Test Grid:

 1 Choose Edit > Replace. The Find/Replace dialog box opens.

 2 In the Find in Field box, select the column in which you want to search for a 
specific value. 

 3 In the Value to Find box, type or select the value to find. 

 4 In the Replace with box, type or select a replacement field value.

 5 To distinguish between uppercase and lowercase characters, select the Case 
Sensitive check box.

 6 To search for an exact value, select the Exact Match check box.

 7 To start the search from the top of the grid, select the From Beginning check 
box.

 8 To use asterisk (*) characters in your search string in order to type only part 
of the item, select the Use Wildcard check box.

 9 To replace the found item and find the next occurrence, click Replace.

 10 To replace all occurrences of the value in the grid, click Replace All.
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Copying Tests and Subject Folders

You can copy tests and subject folders within the same project or between 
projects.

Copying Tests or Subject Folders within the Same Project
You can copy tests and subject folders within the same project. 

To copy a test or a subject folder within the same project:

 1 Select the test or the subject folder that you want to copy in the test plan 
tree. To copy more than one test or subject folder, use the Ctrl key.

 2 Choose Edit > Copy. Alternatively, right-click and choose Copy.

 3 Select the folder to which you want to copy the tests or subject folders.

 4 Choose Edit > Paste. Alternatively, right-click and choose Paste.

Copying Tests or Subject Folders between Projects
You can copy tests and subject folders from one project to another. If the 
tests or subject folders contain calls to other tests, you can instruct 
Quality Center to copy them using one of the following methods:

➤ Copy tests or subject folders and link them to existing tests in the target 
project. If a called test does not exist in the target project, Quality Center 
copies and pastes it into the target project.

➤ Copy tests or subject folders along with the called tests into the target 
project. 

➤ Copy tests or subject folders without copying called tests into the target 
project.

To copy a test or a subject folder between projects:

 1 Select the test or the subject folder that you want to copy in the test plan 
tree. To copy more than one test or subject folder, use the Ctrl key.

 2 Choose Edit > Copy. Alternatively, right-click and choose Copy.

 3 Open another instance of Quality Center and log in to the project to which 
you want to paste the tests.
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 4 Select the folder to which you want to copy the tests or subject folders.

 5 Choose Edit > Paste. Alternatively, right-click and choose Paste. The Paste 
Tests/Subject Folders to Target Project dialog box opens. 

 6 Select one of the following options:

➤ Copy tests/subject folders and link to existing called tests. 
Quality Center copies the tests or subject folders and pastes them into 
the target project. The copied tests or subject folders are linked to 
existing tests with the same name. If a called test does not exist in the 
target project, Quality Center copies and pastes it into the target project.

➤ Copy tests/subject folders and called tests. Quality Center copies the 
tests or subject folders along with the called tests, and pastes them into 
the target project. If a called test name already exists in the target project, 
the copied called test is renamed to resolve the duplicate test name.

➤ Copy tests/subject folders without copying called tests. Quality Center 
copies the tests or subject folders without copying the called tests, and 
pastes them into the target projects. The copied tests or subject folders 
are not linked to any called tests.

Click OK. 

Copying URLs of Tests

You can copy a test and paste its URL as a link. The test itself is not copied. 
Instead, you can paste the address into another location, such as an e-mail 
or a document. Clicking on the link opens up Quality Center and takes you 
to the test. 

To copy a URL of a test:

 1 Select a test from the test plan tree or grid. 

 2 Choose Edit > Copy URL. Alternatively, right-click and choose Copy URL.

 3 Paste the URL.
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Sorting a Test Plan Tree 

By default, subjects are displayed in a test plan tree in alphabetical order. 
You can sort the folders in the test plan tree and create a custom sort 
according to your needs.

Note: You must have project administrator permissions to create a custom 
sort. For more information on assigning user group permissions, refer to the 
HP Quality Center Administrator’s Guide.

To sort a test plan tree:

 1 Click the Sort Folders button on the toolbar. The Sort Folders in Test Plan 
Tree dialog box opens.

By default, Folder Name is selected.
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 2 To create a custom sort, select Custom Sort.

 3 Click a subject folder on the left side of the dialog box. The subfolders 
appear on the right side.

 4 Choose a subfolder on the right side of the dialog box and click the Up or 
Down arrow buttons to set the sorting priority for your test plan tree. You 
can also drag the subfolder up or down.

 5 Click Close to apply the sort order to your test plan tree.

Modifying a Test Plan Tree

You can rename or delete subject folders and tests in the test plan tree.

Renaming a Folder or Test
You can rename a folder or a test.

To rename a folder or test:

 1 Select an item from the test plan tree.

 2 Click the item. Alternatively, right-click the item and choose Rename.

 3 Edit the item name and press Enter or click another location.
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Deleting a Folder or Test
You can delete a folder or test from the test plan tree. When you delete a 
folder, you can choose to delete the folder only, or the folder, its subfolders, 
and tests. If you choose to delete the folder only, all of the tests are moved to 
the Unattached folder in the test plan tree. If you choose to delete a folder 
and tests, all subfolders and tests under the selected folder are deleted 
permanently. If you delete a test, the test and test script are deleted 
permanently.

To delete a folder:

 1 Select a folder from the test plan tree. To delete more than one folder, press 
the Ctrl key and select the folders you want to delete.

 2 Click the Delete button, or choose Edit > Delete. Alternatively, 
right-click the folder and choose Delete. The Confirm Delete Folder dialog 
box opens.

 3 Select Delete folders only or Delete folders and tests.

 4 Click Yes.

To delete a test:

 1 Select a test from the test plan tree. To delete more than one test, press the 
Ctrl key and select the tests you want to delete.

 2 Click the Delete button, or choose Edit > Delete. Alternatively, 
right-click the test and choose Delete.

 3 Click Yes to confirm.
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Linking Tests to Requirements

It is essential that the tests in your test plan meet your original 
requirements. To keep track of the relationship between your requirements 
and tests, you add links between them.

About Linking Tests to Requirements 

You begin by defining your requirements in the requirements tree and then 
assigning them to a release or a cycle in the releases tree (see Chapter 12, 
“Developing the Requirements Tree”). In the planning stage, you build a test 
plan tree based on these assigned requirements (see Chapter 17, 
“Developing the Test Plan Tree”). To keep track of the relationship between 
your assigned requirements and tests, you add links between them.

In the Test Plan module, you create requirements coverage by selecting 
requirements to link to a test. Alternatively, in the Requirements module, 
you create test coverage by selecting tests to link to a requirement. A test can 
cover more than one requirement, and a requirement can be covered by 
more than one test.

This chapter describes: On page:

About Linking Tests to Requirements 259

Linking Requirements to a Test 262

Linking Tests to a Requirement 266

Analyzing Coverage 270
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Note: You can also create coverage between test instances and requirements. 
You can enable this feature using the ALLOW_REQ_COVERAGE_BY_
TEST_INSTANCE parameter in Site Administration. For more information on 
this parameter, see the HP Quality Center Administrator’s Guide.

You can link requirements and tests to defects. This can help you ensure 
compliance with your testing needs throughout the testing process (see 
Chapter 32, “Linking Defects”). If a requirement changes, you can 
immediately identify which tests and defects are affected, and who is 
responsible.

Requirements Coverage Example
Suppose you are using the QualityCenter_Demo project based on the 
Mercury Tours application. Click the Test Plan button on the sidebar. In the 
test plan tree, under Profiling, expand the Registration folder and select the 
Phone (Contact Information) test. 
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The Phone (Contact Information) test verifies the customer phone number 
in the Registration page. If you click the Req Coverage tab, you can see that 
this test covers the following requirement topics: Customer Personal 
Information, and Correct Error Messages.

Test Coverage Example
Continuing with the requirements coverage example, you can also view 
coverage in the QualityCenter_Demo project from the other direction. Click 
the Requirements button on the sidebar. In the requirements tree, under 
Requirements, expand the requirement topics Mercury Tours Application, 
Profile Management, and Registration, and then select the requirement 
Customer Personal Information. 

The Customer Personal Information requirement ensures that the flight 
reservation system includes personal information about the customer. In the 
Test Coverage tab, you can see that this requirement is covered by the 
following tests: Email (Contact Information), First & Last Name (Contact 
Information), Mailing Information, Phone (Contact Information), and 
Registration.
261



Chapter 18 • Linking Tests to Requirements
Linking Requirements to a Test 

During test planning, when you select a test in the test plan tree, the test’s 
requirements coverage is displayed in the Req Coverage tab. 

The coverage grid lists the requirements that are covered by the selected test. 
You can view, add, and remove requirements from the coverage grid. 

The columns in the Req Coverage tab display data for the covered test 
requirements. In addition to the columns described in “The Requirement 
Fields” on page 153, the coverage grid can also display the following 
columns:

Column Description

Coverage Type The type of coverage. The value in this column can be 
“Test” or “Test Instance”.

Entity Name The entity name.

Entity Status The current execution status of the entity.
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Viewing the Requirements Coverage Grid
You can set column appearance and order in the coverage grid. You can view 
requirements in the coverage grid with their full path. In addition, you can 
instruct Quality Center to go to a requirement in the requirements tree.

To view the Requirements Coverage Grid:

 1 In the test plan tree, select a test.

 2 Click the Req Coverage tab.

 3 To refresh the coverage grid so that it displays the most up-to-date 
requirements, click the Refresh All button.

 4 To set column appearance and order in the coverage grid, click the Select 
Columns button. For more information, see “Arranging Columns” on 
page 51.

 5 To display the location of the requirements in the requirements tree, right-
click the coverage grid and choose Show Full Path.

 6 To go to a requirement in the requirements tree, click the requirement in the 
coverage grid. Alternatively, right-click the requirement and choose Go To 
Requirement in Requirements Tree.
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Adding Requirements Coverage
To add requirements coverage to a test, you select one or more requirements 
from the requirements tree. Note that by default you cannot add coverage 
for the following requirement types: Business, Folder, and Group.

Note: Requirements coverage is created automatically when you convert a 
requirement to a test. Therefore, even if you have not yet added 
requirements coverage, it may already exist. For more information, see 
“Creating Tests from Requirements” on page 182.

To add requirements coverage:

 1 In the test plan tree, select a test.

 2 Click the Req Coverage tab.

 3 Click the Select Req button to display the requirements tree in the right 
pane. 

 4 To search for a specific requirement in the tree, type the name (or part of the 
name) of the requirement in the Find box and click the Find button. If the 
search is successful, the requirement is highlighted in the tree.
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 5 To filter and sort requirements in the tree, click the Set Filter/Sort button. 
For more information, see Chapter 3, “Working with Quality Center Data”.

 6 To refresh the requirements tree or coverage grid, click the appropriate 
Refresh All button. 

 7 Select a requirement or requirement topic to add to the coverage: 

➤ Click the Add to Coverage (Without Children) button to add the 
requirement without the requirement’s child requirements. Alternatively, 
double-click the requirement.

➤ Click the Add to Coverage arrow and choose Add to Coverage (Include 
Children) to add the requirement, including its child requirements. Only 
child requirements that match the current filter and that belong to a type 
that supports test coverage are added to the coverage.

The requirement is added to the coverage grid.

Tip: You can also define requirements coverage by dragging a requirement in 
the requirements tree to the coverage grid. The requirement is added to the 
coverage grid without its child requirements.

 8 Click the Close button to hide the requirements tree.

Removing Requirements Coverage
You can remove requirements from a test’s requirements coverage.

To remove requirements coverage from a test:

 1 In the test plan tree, select a test.

 2 Click the Req Coverage tab.

 3 Select a requirement from the coverage grid to delete.

 4 Click the Remove Selected button, and click Yes to confirm.
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Linking Tests to a Requirement 

You can link tests to requirements using the Requirements module.

When you select a requirement in the requirements tree, the requirement’s 
test coverage is displayed in the Test Coverage tab. The coverage grid lists 
the tests that cover the selected requirement. You can view, add, and remove 
tests from the coverage grid. 

The columns in the Test Coverage grid display data for the tests that cover 
the requirement. In addition to the columns described in “Test Grid 
Columns” on page 235, the coverage grid can also display the following 
columns:

Column Description

Coverage Type The type of coverage. The value in this column can be 
“Test” or “Test Instance”.

Entity Name The entity name.

Entity Status The current execution status of the entity.
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Viewing the Test Coverage Grid
You can filter the coverage grid, and show or hide full coverage. You can also 
instruct Quality Center to go to a test in the test plan tree.

To view the Test Coverage Grid:

 1 In the Requirement Details view, select a requirement.

 2 Click the Test Coverage tab.

 3 To filter the coverage grid by status type, select a status from the Status Filter 
list. For example, you can select to view only tests that have passed. Select 
All to clear the filter.

 4 To refresh the data in the coverage grid, click the Refresh All button.

 5 To filter, sort, or group records in the coverage grid, click the Set Filter/Sort 
button. To clear any filters, sorting, or group by settings, click the Set 
Filter/Sort arrow and choose Clear Filter/Sort.

 6 To set column appearance and order in the grid, click the Select Columns 
button. For more information on the Select Columns dialog box, see 
“Arranging Columns” on page 51.

 7 To show the test coverage of all the children of the requirement, check the 
Full Coverage check box. By default, full coverage is not displayed.

 8 To go to the test in the test plan tree, click the test in the coverage grid. 
Alternatively, right-click the test in the coverage grid and choose Go to Test 
in Test Plan Tree.

 9 To go to the test in the Test Lab module, right-click the test in the coverage 
grid and choose Go to Test in Test Set.

 10 On the lower-right side of the window, click Show to display the Coverage 
Chart. This pie chart graphically displays the run status of the tests in the 
coverage grid.
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Adding Test Coverage
To add test coverage to a requirement, you select tests from the test plan 
tree. Note that by default you cannot add coverage for the following 
requirement types: Business, Folder, and Group.

Note: Test coverage is created automatically when you generate a test from a 
requirement. Therefore, even if you have not yet added test coverage, it may 
already exist. For more information, see “Creating Tests from Requirements” 
on page 182.

To add test coverage to a requirement:

 1 In the requirements tree, select a requirement. The Test Coverage tab 
displays the coverage grid for the selected requirement.

 2 In the Test Coverage tab, click the Select Tests button to display the test 
plan tree in the right pane.
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 3 To search for a specific test in the tree, type the name (or part of the name) 
of the test in the Find box and click the Find button. If the search is 
successful, the test is highlighted in the tree.

 4 To filter or sort tests in the tree, click the Set Filter/Sort button. For more 
information on filtering and sorting records, see Chapter 3, “Working with 
Quality Center Data”. 

 5 To refresh the tree, click the Refresh All button. 

 6 To add a test to the requirement's test coverage, in the Test Plan Tree tab, 
select a test or a test folder and click the Add To Coverage button. The test is 
added to the coverage grid. If you select a folder, only tests that match your 
current filter are added to the test coverage.

Tip: You can also define test coverage by dragging a test or a test folder from 
the Test Plan Tree tab to the coverage grid.

 7 Click the Close button to hide the test plan tree in the right pane.

Removing Test Coverage
You can remove tests from a requirement’s test coverage.

To remove test coverage from a requirement:

 1 In the requirements tree, select a requirement. The Test Coverage tab 
displays the coverage grid for the selected requirement.

 2 Select a test from the coverage grid to delete.

 3 Click the Remove From Coverage button and click Yes to confirm.
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Analyzing Coverage

In the Requirements module, you can use the Coverage Analysis view to 
examine the status of your requirements. This enables you to understand 
the breakdown of child requirements according to test coverage. You can set 
the coverage analysis by cycle, enabling you to view in the analysis only the 
coverage of runs that are assigned to specific cycles.

For example, in the QualityCenter_Demo project, select the requirement 
Application Client System, located under the requirement Mercury Tours 
Application. This requirement has twelve children, including itself. In the 
Coverage Analysis, you can see that two of the children have a status of 
Failed (one or more of the tests covered by the requirement failed). When 
you analyze this, you can see that three (27%) of the tests associated with 
this requirement failed.

Note: By default, coverage is available only for the following requirement 
types: Functional, Testing, and Undefined.

To analyze coverage:

 1 Choose View > Coverage Analysis. 
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The Coverage Analysis displays the following columns:

 2 To include in the analysis only tests that have runs that are assigned to 
specific cycles, in the Coverage calculation by cycle box, click the browse 
button. The releases tree opens. Expand the tree and select the cycles for 
which you want to analyze coverage. Click OK to close the releases tree.

 3 Click the Coverage Analysis column for the requirement you want to 
analyze. Alternatively, right-click the requirement, and choose Coverage 
Analysis. The Coverage Analysis dialog box opens.

Column Description

Name The requirements tree, listing requirements grouped 
hierarchically.

Direct Cover Status The current status of the requirement, determined 
according to the status of the tests associated with the 
requirement. For example, if the direct cover status is 
“Not Completed”, then one or more tests covered by the 
requirement have not been completed. For a complete 
definition, see “Direct Cover Status” on page 154. 

Coverage Analysis This column graphically displays the direct cover status of 
the requirement and its children. Requirements which do 
not match the current filter, or requirements with direct 
cover status “N/A” are not counted in the analysis.

If you set the coverage by cycle, Quality Center does not 
use the Direct Cover Status field in its calculations. 
Instead, it uses calculated direct cover status values based 
on the tests that have instances belonging to test set 
folders that are assigned to cycles included in the filter. In 
this case, requirements that do not have test coverage for 
any of the cycles in the filter are not counted in the 
analysis.

In the above example, the Coverage Analysis for the first 
requirement Mercury Tours Application shows that it has 
three lowest level child requirements that have Failed and 
ten lowest level child requirements that are Not Covered.
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For example, click the Coverage Analysis column for the requirement 
Application Client System. The graph shows that this requirement has two 
requirements that have Failed and ten child requirements that are Not 
Covered.

 4 Click a section in the graph to display a list of child requirements with the 
selected status. In this example, click the Failed area of the graph to show 
the requirements with a status of Failed. The names of the two requirements 
with Failed status are displayed.

You can select a requirement and click Go To to highlight the requirement 
in the requirements tree.
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 5 Click the Show Tests Coverage link to extend the Coverage Analysis dialog 
box and display the Tests Coverage Chart.

This pie chart graphically displays the full test coverage for the requirement, 
grouped according to test status. In this example, the Application Client 
System requirement and its child requirements are associated with three 
Failed tests, three No Run tests, and five Passed tests. Note that if a parent 
requirement has several children all of which cover the same test, that test is 
included only once in the parent requirement’s Tests Coverage Chart.
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 6 Click a section in the chart to view the list of tests with the selected status 
that cover the requirement and its children. The Tests Coverage dialog box 
opens with the Status Filter set to the status of the area you selected in the 
chart.

Note that if a parent requirement has several children all of which cover the 
same test, that test is included once for each child requirement in the parent 
requirement’s Tests Coverage Chart.

You can change the Status Filter or modify test coverage for the 
requirement. For more information, see “Linking Tests to a Requirement” on 
page 266.

 7 To display the Tests Coverage Chart, click the Show button.

 8 Click Close to close the Test Coverage dialog box.

 9 Click Close to close the Coverage Analysis dialog box.

 10 To save the Coverage Analysis view to a Word document, choose 
Requirements > Export > Word Document. A Word document is created, 
displaying a bar graph for each parent requirement in the requirements tree.
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Building Tests

After you create a test plan tree, you are ready to develop the tests by 
defining design steps.

About Building Tests

You build tests in the Test Plan module by defining design steps: detailed, 
step-by-step instructions on how to execute a test. A step includes the 
actions to perform on your application, the input to enter, and the expected 
output. A step can also include parameters. You define steps for a test after 
you add the test to the test plan tree and define basic test information.

You can create design steps for both manual and automated tests. For a 
manual test, you complete test planning and design once you finish 
creating the steps. Using your plan, you can begin execution immediately. 
Automated tests require that you create automated test scripts using HP 
testing tools, or custom or third-party testing tools. 

This chapter describes: On page:

About Building Tests 275

Defining Design Steps 277

Calling a Manual Test with Parameters 279

Managing Design Steps 284
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If you decide to automate a test, a test script is created based on the design 
steps you defined. After evaluating your test design, you decide whether to 
automate a test. For further information, see Chapter 20, “Creating 
Automated Tests.”

You design steps for a test using the Design Steps tab in the test plan tree.
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Defining Design Steps 

You add design steps to a test using the Design Step Editor.

To define a design step:

 1 Select a test in the test plan tree and click the Design Steps tab. 

 2 Click the New Step button or right-click in the Design Steps tab and choose 
New Step. The Design Step Editor opens and displays a default step name in 
the Step Name box. 

The default step name is the sequential number of the design step (Step 1 if 
you are adding steps to a test for the first time). You can change the name by 
typing a different name in the box.

 3 Type a Description and Expected Result for the design step.

 4 To insert a parameter, click the Insert Parameter button. For more 
information on parameters, see “Calling a Manual Test with Parameters” on 
page 279.

 5 To manually save the current step, click the Save Steps button.
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 6 To add additional steps, click the New Step button. The next sequential 
number appears in the Step Name box.

 7 Click OK to close the Design Step Editor and add the steps.

The design steps appear in the Design Steps tab. In the test plan tree, a 
footprint  appears next to the test icon, indicating that steps were 
defined for the test.

 8 You can associate an attachment with a design step. An attachment can be a 
file, URL, snapshot, an item from the Clipboard, or system information. To 
add an attachment to a design step, select a step and click the Attachments 
button. For more information, see Chapter 5, “Adding Attachments.”

Notes: 

➤ You can copy steps from an existing test. For more information, see 
“Managing Design Steps” on page 284.

➤ If you add an attachment to a design step, a copy of the attachment is 
made every time the test is run. For more information on running tests, 
see “Running a Test Manually” on page 364.
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Calling a Manual Test with Parameters 

In a design step, you can include a call to a manual test. When you run the 
calling test, its design steps include the steps from the called test. This is 
useful if you have common steps that you often want to perform as parts of 
other tests. 

To increase the flexibility and power of a test, you can add parameters to the 
called test and to the tests that call it. A parameter is a variable that can be 
assigned a value from outside the test in which it is defined. You can change 
the value of a parameter according to the test that is calling it, or for 
different instances of a test in a test set. 

For example, you can create a template test Login_Template that logs in a 
user when you start your application. You need to call this test at the 
beginning of each test. In some cases, you will want to log in as a regular 
user while in others, you will need to log in as the project administrator. You 
can therefore create two parameters, <<<user name>>> and 
<<<password>>>, and change the values according to the type of test that is 
calling Login_Template. If the most common login is a regular user, you can 
set the default values for the parameters to a regular user name and 
password.

This section includes the following parts:

➤ Marking a Manual Test as a Template Test

➤ Adding a Parameter

➤ Viewing a Parameter Value

➤ Calling a Test with Parameters
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Marking a Manual Test as a Template Test
You can mark a manual test in the test plan tree as a template test. A template 
test is called by other tests and generally includes parameters. 

Note: You do not need to set a test as a template test to be able to call it or to 
add parameters. Marking a test as a template test is used for filtering 
purposes only.

To mark a manual test as a template test:

Right-click a manual test in the test plan tree, and choose Mark as Template 
Test. The manual test icon changes from gray to white to indicate that it is 
now a template test.

Adding a Parameter
You can add a parameter to the description or expected results of a manual 
design step.

To add a parameter:

 1 In the Design Steps tab, place the cursor in the Description box or Expected 
Results box of the step to which you want to add the parameter.

 2 Click the Insert Parameter button. The Parameter Properties dialog box 
opens.

 3 Type a Parameter Name and click OK. A parameter name may not include 
the following characters: ~ ? ’ < >

The new parameter is added to the step using the syntax <<<parameter 
name>>>. 
280



Chapter 19 • Building Tests
Note: If you apply formatting to a parameter name in a design step, you 
must apply the same formatting to the entire parameter name, including 
the <<< and >>> characters. For example, if you want to italicize the 
parameter <<<password>>>, you must italicize the entire string 
<<<password>>> and not just the word password.

Viewing a Parameter Value
You can view the parameter values of a manual test. 

To view a parameter value:

 1 Select a manual test in the test plan tree and click the Design Steps tab. 

 2 Click the Test Parameters button. The Current Test Parameters dialog box 
opens and displays the parameters contained in the test. 

 3 Click Close.
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Calling a Test with Parameters 
When you add a call to a manual test containing a parameter, you can 
assign a value to the parameter. 

To call a test with parameters:

 1 In the Design Steps tab, select the step after which you want to include a call 
to another test and click the Call to Test button. The Select a Test dialog box 
opens.

 2 By default, only template tests are displayed. If you want to choose a test 
that is not a template test, clear Show only Template Tests.

 3 To filter and sort the tests in the Select a Test dialog box, click the Set 
Filter/Sort button. The Filter dialog box opens. For more information on 
filtering and sorting, see Chapter 3, “Working with Quality Center Data.”

 4 To search for a specific test, type the name (or part of the name) of the test 
in the Find box and click the Find button. If the search is successful, the test 
is highlighted in the tree.

 5 To refresh all tests in the tree, click the Refresh All button. 

 6 Select the manual test with parameters that you want to call. 
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 7 Click OK. The Parameters of Test dialog box opens and displays the 
parameters of the test you are calling. 

 8 In the Value column, type or change the value for each parameter. Note that 
a parameter value may not include the following characters: ~ ? ’ < >

 9 Click OK. The call is inserted as a link in your design steps, and the values 
assigned to the parameters in the called test are displayed.

Note: If you do not assign values to parameters when creating a test call, you 
are prompted to do so when you call this test from another test, when you 
add your test to a test set, or when you run your test. 

 10 To edit the values you assigned to the parameters in the called test, right-
click the test call and choose Called Test Parameters. In the Called Test 
Parameters dialog box, type the new values you want to assign to the 
parameters, and click OK.
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Managing Design Steps

This section on managing design steps includes the following topics:

➤ Editing Design Steps

➤ Reordering Design Steps

➤ Renumbering Design Steps

➤ Resizing Design Steps

➤ Arranging Design Step Columns

➤ Deleting Design Steps

➤ Copying Design Steps within the Same Project

➤ Copying Design Steps between Projects

➤ Finding and Replacing Step Text

Editing Design Steps
You can edit existing design steps or add new ones.

To modify design steps:

 1 Choose a test in the test plan tree and click the Design Steps tab.
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 2 Double-click a step, or select a step and click the Edit Step button. The 
Design Step Editor opens. 

You can proceed through the steps in a test using the browse buttons:

➤ Click the First Step button to display the first step in the test, or the 
Previous Step button to display the preceding step.

➤ Click the Next Step button to display the subsequent step in the test, or 
the Last Step button to display the final step in the test.

Tip: You can navigate between steps in the Design Step Editor using shortcut 
keys. Use ALT+HOME to access the first step, ALT+LEFT to access the previous 
step, ALT+RIGHT to access the next step, and ALT+END to access the last step.

 3 Edit step descriptions and expected results by typing in the Description and 
Expected Result areas.

 4 Click the New Step button to add a step after the currently selected step.

 5 Click OK to close the Design Step Editor and save your changes.
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Reordering Design Steps
You can change the order of the steps in a test.

To reorder design steps:

 1 Choose a test in the test plan tree and click the Design Steps tab.

 2 Position the mouse pointer on the gray sidebar to the left of the step you 
want to move. The mouse pointer changes to .

 3 Click and drag the step to the desired position.

Renumbering Design Steps
You can renumber your steps after you add, delete, or reorder steps in a test. 

To renumber design steps:

 1 Choose a test in the test plan tree and click the Design Steps tab.

 2 Click the Renumber Steps button.

Resizing Design Steps
You can adjust the row size of the steps in a test. This enables you to view all 
the text in the Description or Expected Result columns if the text is long. 

To resize design steps:

 1 Choose a test in the test plan tree and click the Design Steps tab.

 2 Position the mouse pointer in the gray sidebar on the lower edge of the step 
you want to resize. The mouse pointer changes to .

 3 Click and drag the step to adjust the row size.

 4 Click the Adjust Rows Height button.
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Arranging Design Step Columns
You can determine which columns appear and the order in which they 
appear in the Design Steps tab.

To arrange columns:

 1 Choose a test in the test plan tree and click the Design Steps tab.

 2 Click the Select Columns button. The Select Columns dialog box opens. For 
more information, see “Arranging Columns” on page 51.

Deleting Design Steps
You can remove steps from a test.

To delete a design step:

 1 Choose a test in the test plan tree and click the Design Steps tab.

 2 Choose the step that you want to delete. To delete more than one step, 
position the mouse pointer on the gray sidebar to the left of the step that 
you want to delete. The mouse pointer changes to . Click to select the 
step. Then use the CTRL or SHIFT key to select additional steps.

 3 Click the Delete Selected button. Alternatively, right-click and choose 
Delete Selected.

 4 Click Yes to confirm.

Copying Design Steps within the Same Project
You can copy design steps from another test in the same project. 

To copy design steps from another test in a different project, see “Copying 
Design Steps between Projects” on page 288. 

To copy a design step within the same project:

 1 Select the test in the test plan tree from which you want to copy steps and 
click the Design Steps tab.

 2 Select the step that you want to copy. To copy more than one step, position 
the mouse pointer on the gray sidebar to the left of the step that you want 
to copy. The mouse pointer changes to . Click to select the step. Then use 
the CTRL or SHIFT key to select additional steps.
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 3 Click the Copy Steps button, or right-click and choose Copy.

 4 Select the test to which you want to copy the steps, and click the Design 
Steps tab.

 5 Click the Paste Steps button or right-click and choose Paste.

Copying Design Steps between Projects
You can copy design steps in a test from one project to another. If the design 
steps contain calls to other tests, you can instruct Quality Center to copy 
them using one of the following methods:

➤ Copy design steps and link them to existing tests in the target project. If a 
called test does not exist in the target project, Quality Center copies and 
pastes it into the target project.

➤ Copy design steps and called tests into the target project.

➤ Copy design steps without copying called tests into the target project.

To copy a design step between projects:

 1 Select the test in the test plan tree from which you want to copy steps and 
click the Design Steps tab.

 2 Select the step that you want to copy. To copy more than one step, position 
the mouse pointer on the gray sidebar to the left of the step that you want 
to copy. The mouse pointer changes to . Click to select the step. Then use 
the CTRL or SHIFT key to select additional steps.

 3 Click the Copy Steps button, or right-click and choose Copy.

 4 Open another instance of Quality Center and log in to the project to which 
you want to paste the steps.

 5 Select the test to which you want to copy the steps, and click the Design 
Steps tab.

 6 Click the Paste Steps button or right-click and choose Paste. The Paste 
Design Steps to Target Project dialog box opens. 
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 7 Select one of the following options:

➤ Copy design steps and link to existing called tests. Quality Center copies 
the design steps and pastes them into the target project. The copied 
design steps are linked to existing tests with the same name. If a called 
test does not exist in the target project, Quality Center copies and pastes 
it into the target project.

➤ Copy design steps and called tests. Quality Center copies the design 
steps and called tests and pastes them into the target project. If a called 
test name already exists in the target project, the copied called test is 
renamed to resolve the duplicate test name.

➤ Copy design steps without copying called tests. Quality Center copies 
the design steps without copying the called tests, and pastes them into 
the target projects. The copied design steps are not linked to any called 
tests.

Click OK. 

Finding and Replacing Step Text
You can search for specific text in the design steps in the Design Steps tab. 
For a single step, you can also find and replace specific text in the Design 
Steps Editor.

To find text in the Design Steps tab:

 1 Choose a test in the test plan tree and click the Design Steps tab.

 2 Click the Find Text button. The Find dialog box opens.

 3 In the Find in Field box, select the criterion to search for.
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 4 In the Value to Find box, select the value of the field you chose.

 5 To distinguish between uppercase and lowercase characters, select the Case 
Sensitive check box.

 6 To search for an exact value, select the Exact Match check box.

 7 To use asterisk (*) characters in your search string to type only part of the 
item, select the Use Wildcard check box.

 8 Click Find Next. If the search is successful, the step is highlighted. If the 
search is unsuccessful, an information box opens.

 9 Click Close to close the dialog box.

To find and replace text in the Design Steps Editor:

 1 Choose a test in the test plan tree and click the Design Steps tab.

 2 Click the New Step button to add a new step, or click the Edit Step button 
to modify an existing step. The Design Step Editor opens.

 3 Click the Find/Replace Text button. The Replace dialog box opens.

 4 In the Find what box, type the text for which you want to search.

 5 To replace the specified text, type the text you want to use as replacement 
text in the Replace with box.

 6 To search for whole words, select the Match whole word only box.

 7 To search for an exact value, select the Match case check box.

 8 Click Find Next. If the search is unsuccessful, an information box opens.

 9 Click Replace to replace the first occurrence of the text, or Replace All to 
replace all occurrences of the text.
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Creating Automated Tests

After you have designed test steps, you can use them as a framework for 
creating an automated test script.

About Creating Automated Tests 

Test planning involves deciding which tests to automate. If you choose to 
automate a test, you can generate a test script and run the test using 
WinRunner, QuickTest Professional, LoadRunner, or Visual API-XP.

Consider the following issues when deciding whether to automate a test.

Frequency of Execution

Tests that will run with each new version of your application are good 
candidates for automation. These include sanity tests that check basic 
functionality across an entire application. Each time there is a new version 
of the application, you run these tests to check the stability of the new 
version, before proceeding to more in-depth testing.

Tests that use multiple data values for the same operation (data-driven tests) 
are also good candidates for automation. Running the same test manually—
each time with a different set of input data—can be tedious and ineffective. 
By creating an automated data-driven test, you can run a single test with 
multiple sets of data.

This chapter describes: On page:

About Creating Automated Tests 291

Generating Automated Test Scripts 293
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Stress/Load Testing

It is also recommended that you automate tests that are run many times 
(stress tests) and tests that check a multi-user client/server system (load 
tests). For example, suppose a test must be repeated a thousand times. 
Running the test manually would be extremely impractical. In this case, you 
could use QuickTest Professional to create a test that runs a thousand 
iterations.

When Not To Automate Tests

Generally, the more user involvement a test requires, the less appropriate it 
is to automate. The following describes test cases that should not be 
automated:

➤ Usability tests—tests providing usage models that check how easy the 
application is to use.

➤ Tests that you only have to run once.

➤ Tests that you need to run immediately.

➤ Tests based on user intuition and knowledge of the application.

➤ Tests with no predictable results.
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Generating Automated Test Scripts

After you have created steps for a manual test, you can generate a test script 
skeleton in which you can write scripts to run the test as an automated test.

Any text that appeared in the steps of the manual test is listed as comments 
in the generated test script. If the manual test has parameters, they are also 
listed as comment text.

To generate an automated test script:

 1 In the test plan tree, choose the manual test that you want to automate.

 2 Click the Design Steps tab and click the Generate Script button. 

 3 Choose an automated test type to convert to:

Note: The QUICKTEST_TEST test type is only available if you have installed 
the appropriate add-in from the HP Quality Center Add-ins page. For more 
information on installing add-ins, refer to the HP Quality Center Installation 
Guide.

Test 
Icon

Test Type Description

WR-AUTOMATED A test that is executed by WinRunner, the HP 
functional testing tool for Microsoft Windows 
applications.

VAPI-XP-TEST A test that is created by Visual API-XP, the 
Quality Center open test architecture API testing 
tool. For more information on VAPI-XP tests, see 
Appendix A, “Working with VAPI-XP.”

LR-SCENARIO A scenario that is executed by LoadRunner, the HP 
load testing tool.

QUICKTEST_TEST A test that is executed by QuickTest Professional, 
the HP functional enterprise testing tool.
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The Test Plan module uses the steps of the selected test to create an 
automated test script. In the test plan tree, note that the manual test icon  
next to the test you just automated is now replaced with the automated test 
icon.

 4 Click the Test Script tab to view the test script. 

 5 If the test is a WinRunner test, you can attach a different test script to the 
test by clicking the Copy From button. The Select Test dialog box opens, 
enabling you to select a WinRunner test from the file system. 

 6 For WinRunner, LoadRunner, and QuickTest Professional tests, to display 
your test script in the testing tool for which it is created, click the Launch 
button. You can now modify your test as necessary.
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Working with System Tests

Using system tests, you can instruct Quality Center to provide system 
information for a machine, capture a desktop image, or restart a machine.

About Working with System Tests

You can run a system test to retrieve a machine’s system information, view a 
captured desktop image of a test run on a machine, or restart a machine. For 
example, you can run a system cleanup test that will restart the machine on 
which an automated test failed. You can also create a system test to retrieve 
information about a machine’s resource usage before or after a test run.

This chapter describes: On page:

About Working with System Tests 295

Adding System Tests to a Test Plan Tree 296

Defining a System Test 298

Running a System Test 299

Viewing System Test Results 300
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You create a system test by adding a system test to the test plan tree, 
defining the test, and adding the test to a test set.

Note: To run a system test, you must install the System Test Remote Agent 
Add-in and the HP Quality Center Connectivity Add-in on the machine 
where the test is to be run. For more information on HP Quality Center 
add-ins, refer to the HP Quality Center Installation Guide.

When running a system test, the following steps are created:

➤ SysInfo. Collection of system information

➤ Snapshot. Capture of desktop image

➤ Reboot Start and Reboot Finish. Machine restart

You can view details for each of these steps after your system test has 
finished running. You can also view the system information that has been 
retrieved—such as CPU, memory, and processes running on the machine—
and an image of the machine executing the system test.

Adding System Tests to a Test Plan Tree

You begin creating a system test by adding it to your test plan tree.

To add a system test to a test plan tree:

 1 Choose a subject folder in the test plan tree.

 2 Click the New Test button, or choose Tests > New Test. The Create New Test 
dialog box opens.
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 3 In the Test Type box, select SYSTEM-TEST. 

Note: If you have installed the QuickTest Professional Add-in on your 
machine, the Create New Test dialog box includes the Template box.

 4 In the Test Name box, type a name for the test.

 5 Click OK.

Note: If required test fields were defined in Project Customization, the 
Required Test Fields dialog box opens. Select values for the required fields 
and click OK.

The new system test with a system test icon  appears in the test plan tree 
under the subject folder you selected. 

 6 You can add details and attachments to the test, and define requirements 
coverage. For more information, see Chapter 17, “Developing the Test Plan 
Tree.”
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Defining a System Test

Once you have added your system test to the test plan tree, you can define a 
test script for the test. 

To define a system test:

 1 Select the system test you created from the test plan tree, and click the Test 
Script tab.

 2 Select Collect system information to collect information such as CPU, 
memory, and processes running on the machine when the system test is 
run. 

 3 Select Capture desktop image to add an attachment displaying a snapshot 
of the machine’s desktop, when the system test is run. 
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 4 Select Restart the computer to instruct Quality Center to restart the 
machine when the system test is run. 

Notes: 

➤ To use the Restart the computer option, you must enable auto login on 
your machine. Choose Start > Programs > HP Quality Center SystemTest 
Agent > SystemTest Agent (configuration). The Auto Restart Settings 
dialog box opens. By default, User Name and Domain are read-only. Type 
your password and click OK. 

➤ To select a different user name, reopen the Auto Restart Settings dialog 
box. User Name and Domain are no longer read-only. Modify the values 
and click OK.

 5 Click the Save button to save your system test settings.

After you define your system test in the Test Plan module, you can choose to 
add the test to a test set in the Test Lab module. For information on creating 
test sets, see Chapter 24, “Creating Test Sets”.

Running a System Test

Once you have defined your system test and added it to a test set in the Test 
Lab module, you can run it. System tests can be run on your own machine, 
or on multiple remote host machines connected to your network. 

For more information on running tests, see Chapter 27, “Running Tests 
Automatically”.
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Viewing System Test Results

You can view the results of your system test in the Test Lab module.

To view system test results:

 1 In the Execution Grid, double-click your system test, or select the test and 
click the Test Instance Properties button. In the Execution Flow tab, right-
click the system test and choose Test Instance Properties. 

The Test Instance Properties dialog box opens and displays the All Runs 
view.

You can view the status, execution date, and execution time for the 
following steps that are created during a system test run: 

➤ SysInfo. Details for collection of system information

➤ Snapshot. Details for capture of desktop image

➤ Reboot Start and Reboot Finish. Details for machine restart
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 2 Click the Collected System Info link to view the collected system 
information, for example, CPU, memory, and processes running on the 
machine.

 3 Click the Captured Desktop Image link to view the desktop image of the 
machine executing the system test.
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22
The Test Lab Workflow

As your application changes, you run the manual and automated tests in 
your project in order to locate defects and assess quality.

This chapter describes how you run tests using the Quality Center Test Lab 
module. Executing tests consists of the following: 

Define Testing 
Scope

Create
Requirements

Create
Requirements

Detail 
Requirements

Detail 
Requirements

Analyze 
Requirements

Analyze 
Requirements

Create
Test Sets

Schedule
Runs

Run Tests
Manually

Analyze Test Results

Run Tests
Automatically
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Creating Test Sets

Start by creating test sets and choosing which tests to include in each set. A 
test set is a group of tests in a Quality Center project designed to achieve 
specific testing goals. In the sample Mercury Tours application, for example, 
you could create a set of sanity tests that checks the basic functionality of 
the application. You could include tests that check the login mechanism, 
and tests that check the flight booking mechanism.

After you have created test sets, you assign test set folders to cycles defined 
in the releases tree in the Releases module. A cycle represents a development 
and QA cycle based on the project timeline.

For more information, see Chapter 24, “Creating Test Sets”.

Scheduling Test Runs

Quality Center enables you to control the execution of tests in a test set. You 
can set conditions, and schedule the date and time for executing your tests. 
You can also set the sequence in which to execute the tests. For example, 
you can determine that you want to run test2 only after test1 has finished, 
and run test3 only if test1 passed. 

For more information, see Chapter 25, “Scheduling Test Runs.”

Running Tests Manually

Once you have defined test sets, you can begin executing the tests. When 
you run a test manually, you execute the test steps that you defined during 
test planning. You pass or fail each step, depending on whether the 
application’s actual results match the expected output. 

For example, suppose you are testing the process of booking a flight in the 
sample Mercury Tours application. You open the application, create a new 
order, and book a flight, following the instructions detailed by the test steps.

For more information, see Chapter 26, “Running Tests Manually.”
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Running Tests Automatically

Once you have defined test sets, you can begin executing the tests. You can 
select all the tests in a test set, or specific tests. Your selection can include 
both automated and manual tests. 

When you run an automated test, the selected testing tool opens 
automatically, runs the test, and exports the test results to Quality Center. 
When you run a manual test, e-mail is sent to a designated tester, requesting 
that they run the manual test.

For more information, see Chapter 27, “Running Tests Automatically.”

You can also run an automated system test to provide system information, 
capture a desktop image, or restart a machine. For more information on 
running system tests, see Chapter 21, “Working with System Tests.”

Analyzing Test Results

Following a test run, you analyze test results. Your goal is to identify failed 
steps and to determine whether a defect has been detected in your 
application, or if the expected results of your test need to be updated. If a 
defect has been detected, you can create a new defect and link it to the test 
run, or link an already-existing defect with the test run. For more 
information, see Chapter 32, “Linking Defects.”

You can validate test results regularly by viewing run data and by generating 
reports and graphs. For more information, see Chapter 33, “Generating 
Reports,” Chapter 34, “Generating Graphs,” and Chapter 35, “Generating 
Live Analysis Graphs.”

For more information on understanding the data that appears in 
Quality Center following a test run, see Chapter 28, “Viewing Test Results.”
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The Test Lab Module at a Glance

This chapter introduces the key elements in the Test Lab module.

This chapter describes: On page:

The Test Lab Module 310

The Test Lab Menu Bar 311

The Test Lab Toolbars 312

The Execution Grid 314

The Execution Flow 320
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The Test Lab Module 

You create test sets and perform test runs in the Test Lab module of 
Quality Center, which you open by clicking the Test Lab button on the 
sidebar. 

The Test Lab module contains the following key elements:

➤ Test Lab menu bar. Displays drop-down menus of Test Lab module 
commands. For more information, see “The Test Lab Menu Bar” on 
page 311.

➤ Test Set toolbar. Contains buttons of commands commonly used when 
creating and modifying test sets in the test sets tree. For more information, 
see “Test Set Toolbar” on page 313.

➤ Test Set pane. Displays your test sets hierarchically in a test sets tree. By 
default, the tests are grouped in folders. You can also view your test sets as a 
list, by choosing View > Test Sets Grid. For more information on creating a 
test sets tree, see “Creating a Test Sets Tree” on page 326.

➤ Execution Grid tab. Displays test data in a grid. For more information, see 
“The Execution Grid” on page 314.
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➤ Execution Flow tab. Displays test data in a diagram. For more information, 
see “The Execution Flow” on page 320.

➤ Test Set Properties tab. Displays the current test set details, attachments, 
e-mail notification rules, and on failure instructions. For more information, 
see Chapter 24, “Creating Test Sets.”

➤ Linked Defects tab. Displays a list of entities linked to the current test set. 
For more information, see Chapter 32, “Linking Defects.”

➤ Select Tests pane. Displays tests in the right pane to enable you to add tests 
to a test set. To open this pane, click the Select Tests button. The Select Tests 
pane contains two tabs. The Test Plan Tree tab displays the test plan tree. 
The Requirements Tree tab displays tests according to associated 
requirements.

➤ Live Analysis tab. A graphical representation of test data related to the 
selected test set folder in the test set tree. For more information, see 
Chapter 35, “Generating Live Analysis Graphs.”

Tip: Right-click a test in the Execution Grid or Execution Flow, and choose 
Go to Test in Test Plan Tree to open the Test Plan module and highlight the 
selected test in the test plan tree.

The Test Lab Menu Bar

The Test Lab menu bar has the following menus:

➤ The Test Sets menu contains commands that enable you to create, manage, 
and run your test sets. You can purge runs, view test set properties, add hosts 
and set host groups, and export the contents of the Execution Grid to a file. 
For more information, see Chapter 24, “Creating Test Sets”. 

➤ The Edit menu contains commands that enable you to cut, copy, paste, 
rename, or delete a test set, or to find a folder or test set. In the Execution 
Flow tab, it enables you to find the test in the flow.

➤ The View menu contains commands that enable you to filter and sort test 
sets, and set the display in the Test Sets Tree and the Test Sets Grid.
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➤ The Tests menu is available only in the Execution Grid and Execution Flow. 
It contains commands that enable you to run tests, run tests manually, 
continue test runs, remove tests from test sets, set the display in the 
Execution Grid, view test instance properties, reorder tests, find tests, select 
tests, and view last run result. For more information, see Chapter 24, 
“Creating Test Sets”. You can also add, view , and organize favorites. For 
more information, see Chapter 6, “Working with Favorite Views.” In 
additional, you can view and add alerts for tests and flag tests for follow-ups. 
For more information, see Chapter 4, “Alerting on Changes”.

➤ The Analysis menu contains commands that enable you to generate 
execution reports and graphs. For more information on execution reports, 
see Chapter 33, “Generating Reports.” For more information on execution 
graphs, see Chapter 34, “Generating Graphs,” and Chapter 35, “Generating 
Live Analysis Graphs.”

Tip: You can access the Test Lab menu bar from the Test Lab module by 
pressing the shortcut key F9. Additionally, you can perform many other 
Quality Center operations using shortcut keys. For a list of shortcut keys, see 
Appendix B, “Quality Center Keyboard Shortcuts.”

The Test Lab Toolbars

The Test Lab module includes the following toolbars: Test Set and Select 
Tests. 

In addition, you can use the toolbars in the Execution Grid tab and 
Execution Flow tab. For more information, see “The Execution Grid 
Toolbar” on page 316, and the “The Execution Flow Toolbar” on page 321.
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Test Set Toolbar
The Test Set toolbar has the following buttons:

New Folder. Opens the New Folder dialog box, enabling you to create a new 
test set folder. The folder is added to the test sets tree in the left pane. For 
more information, see “Creating a Test Sets Tree” on page 326.

New Test Set. Opens the New Test Set dialog box, enabling you to create a 
new test set in an existing folder. For more information, see “Adding Test 
Sets” on page 328.

Delete. Deletes folders and test sets from the test sets tree. Deletes test sets 
from the test sets grid. For more information, see “Deleting a Test Set” on 
page 346.

Assign To Cycle. Enables you to assign a test set folder to a cycle. For more 
information, see “Assigning Test Set Folders to Cycles” on page 327.

Refresh All. Refreshes the test sets tree or test sets grid so that it displays the 
most up-to-date test sets.

Set Filter/Sort. Includes the following options:

➤ Set Filter/Sort. Opens the Filter dialog box, enabling you to filter and sort 
test sets. 

➤ Clear Filter/Sort. Clears any filters or sorts that you have applied.

For more information, see “Filtering Records” on page 55.

Select Tests Toolbar
To display the test plan tree in the right pane, click the Select Tests button. 
The Test Plan Tree tab is displayed. If you click the Requirements Tree tab, 
the tests are displayed according to associated requirements.

The Select Tests toolbar has the following buttons:

Add Tests to Test Set. Adds tests to a test set. 

Refresh All. Refreshes the tree.
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Set Filter/Sort. Includes the following options:

➤ Set Filter/Sort. Opens the Filter dialog box, enabling you to filter and sort 
tests. 

➤ Clear Filter/Sort. Clears any filters or sorting that you have applied.

Find. Searches for a specific test in the tree. If the search is successful, the test 
is highlighted in the tree.

The Execution Grid 

In the Execution Grid, your test data is organized and displayed in a grid. 
Each line in the grid displays a separate test record.  
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The Execution Grid tab contains the following key elements:

➤ Execution Grid toolbar. Contains buttons of commands commonly used 
when executing and viewing tests. See “The Execution Grid Toolbar” on 
page 316.

➤ Indicator columns. Indicates that the specified test instance has 
attachments, linked defects, alerts, and follow up flags. Choose Tests > 
Indicator Columns to display these columns.

➤ Grid filter. Displays the filter that is currently applied to a column. To 
display grid filters, choose Tests > Grid Filters.

➤ Last Run Result pane. Displays the results of the last test run. To display the 
last run result pane, choose Tests > Last Run Result or click the Show arrow.

➤ Favorite views. Enables you to view, add, and organize views in the Favorites 
list. Choose Tests > Favorites to access the favorite views commands. For 
more information on favorite views, see Chapter 6, “Working with Favorite 
Views.”

Column Description

Attachments Click the  icon to view attachments for the test 
instance. For more information, see Chapter 5, 
“Adding Attachments.”

Linked Entities Click the  icon to view linked entities for the test 
instance. For more information, see Chapter 32, 
“Linking Defects.”

Alerts Click the  icon to view alerts for the test instance. 
For more information, see “Viewing Alerts” on 
page 80.

Follow Up Flags Click the  icon to view follow up alerts for the test 
instance. For more information, see “Flagging for 
Follow Up” on page 82.
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The Execution Grid Toolbar
The Execution Grid toolbar has the following buttons:

Select Tests. Displays the test plan tree in the right pane. You use the test 
plan tree to select tests to add to a test set. You can also click the 
Requirements Tree tab to view tests according to associated requirements. 
For more information, see “Adding Tests to a Test Set” on page 330.

Run. If you select a manual test, opens the Manual Runner dialog box to run 
the test. If you select an automated test, opens the Automatic Runner dialog 
box to run the test. It also includes the following options:

➤ Run Manually. Runs an automated test manually.

➤ Continue Manual Run. Resumes a manual test run.

For more information on running a test manually, see Chapter 26, 
“Running Tests Manually”. For more information on running a test 
automatically, see Chapter 27, “Running Tests Automatically”.

Run Test Set. Opens the Automatic Runner dialog box to run the test set. 
Test sets can include both manual and automated tests. For more 
information, see “Running a Test Automatically” on page 374.

Remove Tests from Test Set. Removes the selected tests from the test set. For 
more information, see “Removing a Test from a Test Set” on page 342.

Refresh All. Refreshes the Execution Grid so that it displays the most 
up-to-date tests based on the filters you have selected.

Set Filter/Sort. Opens the Filter dialog box, enabling you to filter and sort 
the tests in the Execution Grid. Includes the following options:

➤ Set Filter/Sort. Opens the Filter dialog box, enabling you to filter and sort 
tests. 

➤ Clear Filter/Sort. Clears any filters or sorting that you have applied in the 
Execution Grid.

For more information, see “Filtering Records” on page 55.

Select Columns. Opens the Select Columns dialog box, enabling you to 
determine which columns to display in the Execution Grid and their order. 
For more information, see “Arranging Columns” on page 51.
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Test Instance Properties. Opens the Test Instance Properties dialog box to 
display the properties of the selected test instance. For more information, 
see “Viewing Test Results” on page 385.

Attachments. Opens the Test Instance Properties dialog box, enabling you to 
add an attachment to a test run instance. For more information, see 
Chapter 5, “Adding Attachments.”

Flag for Follow Up. Opens the Flag For Follow Up dialog box, enabling you 
to add or modify a follow up flag for a test instance. For more information, 
see “Flagging for Follow Up” on page 82.

Execution Grid Columns
The Execution Grid displays the following columns, grouped into test 
planning data (Plan) and test run data:

Column Description

Exec Date The date on which the test was last executed.

Modified The date and time of the last change to the test in the 
Execution Grid.

Plan: Comments Displays comments about the test.

Plan: Creation Date The date on which the test was created. By default, the 
creation date is set to the current database server date. 

Plan: Description Describes the test.

Plan: Designer The user name of the person who designed the test.

Plan: Estimated 
DevTime

The time estimated to design and develop the test.

Plan: Execution Status The execution status of the last run of an instance of the 
test. Execution status can be one of the following: 
Failed, N/A, No Run, Not Completed, Passed.

Plan: Modified The date and time of the last change to the test in the 
Test Plan module.

Plan: Path The test’s file system path on the server side (relative to 
the test repository).
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Plan: Status The planning status of the test. The default status is 
Design.

Plan: Subject The subject folder in the test plan tree in which the test 
resides.

Plan: Template Indicates whether the test is a test template. The value 
in this column can be “Y” or “N”.

Plan: Test Name The name of the test.

Plan: Type The type of test. For example, manual or WinRunner.

Planned Exec Date The date on which it was planned to execute the test.

Planned Exec Time The time at which it was planned to execute the test.

Planned Host Name The name or IP address of the machine to run the test.

Responsible Tester The user name of the person responsible for running 
the test.

Status The status of the last test run. Execution status can be 
one of the following: Failed, N/A, No Run, Not 
Completed, Passed.

Target Cycle Indicates the cycle in which the test was assigned. Click 
the down arrow to select a different cycle.

Test Version The version number of the test.

Tester The user name of the person who last executed the test.

Time The time at which the test was last executed.

Column Description
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Notes: 

➤ You can add user-defined fields and change the label of any of the fields 
in the Execution Grid. You can also customize project lists. For more 
information, refer to the HP Quality Center Administrator’s Guide.

➤ You can use the Script Editor to restrict and dynamically change the 
fields and values in the Execution Grid. For more information, refer to 
the HP Quality Center Administrator’s Guide.

➤ When you select an Execution Grid column with a user name value, 
Quality Center displays a list with the name and full name of each user. 
You can search for users, sort users, group users by user group, and select 
users from the users list or a group tree. For more information, see 
“Selecting Users” on page 54.
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The Execution Flow 

In the Execution Flow, your test data is organized and displayed in a 
diagram. You use the Execution Flow to control the way your tests are 
executed. You can specify when and under what conditions you want a test 
to be executed. 

For more information on the Execution Flow tab, see Chapter 25, 
“Scheduling Test Runs.” 

The Execution Flow tab contains the following key elements:

➤ Execution Flow toolbar. Contains buttons of commands commonly used 
when scheduling test executions. See “The Execution Flow Toolbar” on 
page 321.

➤ Execution Flow diagram. Displays tests with conditions in a diagram. For 
more information, see Chapter 25, “Scheduling Test Runs.”
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The Execution Flow Toolbar
The Execution Flow toolbar has the following buttons:

Select Tests. Displays the test plan tree in the right pane. You use the test 
plan tree to select tests to add to a test set. You can also click the 
Requirements Tree tab to view tests according to associated requirements. 
For more information, see “Adding Tests to a Test Set” on page 330.

Run. If you select a manual test, opens the Manual Runner dialog box to run 
the test. If you select an automated test, opens the Automatic Runner dialog 
box to run the test. It also includes the following options:

➤ Run Manually. Runs an automated test manually.

➤ Continue Manual Run. Resumes a manual test run.

For more information on running test manually, see Chapter 26, “Running 
Tests Manually”. For more information on running test automatically, see 
Chapter 27, “Running Tests Automatically.”

Run Test Set. Opens the Automatic Runner dialog box to run the test set. 
Test sets can include both manual and automated tests. For more 
information, see “Running a Test Automatically” on page 374.

Find Test In Flow. Opens the Find Test dialog box, enabling you to find a test 
in the Execution Flow. For more information, see “Finding Tests” on 
page 361.

Remove Tests from Test Set. Removes the selected tests from the test set.

Refresh Flow. Refreshes the Execution Flow diagram so that it displays the 
most up-to-date tests.

Arrange Layout. Rearranges the tests in a hierarchical layout, enabling you 
to view dependencies between different tests.

Zoom In. Increases the magnification level so that you can view a section of 
the Execution Flow more closely.

Zoom Out. Decreases the magnification level so that you can view more of 
the Execution Flow.
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Fit Picture In Window. Redisplays the diagram to fit the window. Click the 
Fit Picture In Window arrow to select a magnification option. For more 
information, see “Viewing the Execution Flow Diagram” on page 361.

Add Time Dependency to Flow. Adds a time dependency icon to the 
diagram. To create a time dependency for a test, link the arrow from the 
icon to a test in the Execution Flow. The default time dependency is the 
Quality Center server’s current date and time. For more information, see 
“Scheduling a Test Run” on page 354.
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Creating Test Sets

You can organize test execution by creating test sets. A test set contains a 
subset of the tests in your project. The test sets tree organizes and displays 
your test sets hierarchically.

This chapter describes: On page:

About Creating Test Sets 324

Creating a Test Sets Tree 326

Assigning Test Set Folders to Cycles 327

Adding Test Sets 328

Adding Tests to a Test Set 330

Setting the Test Set Notifications 332

Setting the Test Set On Failure Rules 334

Managing Test Sets 338
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About Creating Test Sets

After you design tests in the Test Plan module, you create a test sets tree. A 
test sets tree enables you to organize your testing process by grouping test 
sets in folders and organizing them in different hierarchical levels in the Test 
Lab module. A test set is a group of tests in a Quality Center project designed 
to achieve specific test goals. Test sets can include both manual and 
automated tests. After you create a test sets tree, you assign test set folders to 
cycles defined in the releases tree in the Releases module.

To decide which test sets to create, think about the testing goals you defined 
at the beginning of the testing process. Consider issues such as the current 
state of the application and the addition or modification of new features.

Following are examples of general categories of test sets you can create:

Test Set Description

Sanity Checks the entire application at a basic level—focusing on 
breadth, rather than depth—to verify that the application is 
functional and stable. This set includes fundamental tests 
that contain positive checks, validating that the application 
is functioning properly. For example, in the Mercury Tours 
application, you could test whether the application opens, 
and enables you to log in.

Regression Tests the system in a more in-depth manner than a sanity set. 
This set can include both positive and negative checks. 
Negative tests attempt to fail an application to demonstrate 
that the application is not functioning properly.

Advanced Tests both breadth and depth. This set covers the entire 
application, and also tests the application’s advanced 
options. You can run this set when there is ample time for 
testing.

Function Tests a subsystem of an application. This could be a single 
feature or a group of features. For example, in the Mercury 
Tours application, a function set could test all activities 
related to booking a flight.
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Suppose you want to test new features added to Release 10.5 of the Mercury 
Tours application. Release 10.5 consists of four cycles, and you want to test 
the new features for the release in Cycle 1, Cycle 2, and Cycle 4. Because the 
tests you need to run to test the new features are the same for each of these 
cycles, you want to use the same test set as a basis for testing new features in 
each of the cycles.

In the test sets tree, you can create the folder Release 10.5 for the release. 
Under this folder, you create the folder Cycle 1 for the first cycle of the 
release. In the Cycle 1 folder, you create a test set New Features containing 
the tests necessary to test new features for the release. After you create this 
test sets and add its tests, you can copy and paste the Cycle 1 folder and use 
it as a basis for the other cycles that test new features.

Note that by default, the uppermost level in a test sets tree is the Root folder. 
You cannot delete the Root folder or add test sets directly to it. Under the 
Root folder, the Unattached folder contains all test sets no longer associated 
with a folder. You cannot add a test set to the Unattached folder. When you 
delete a folder, you can instruct the Test Lab module to move the folder's 
test sets to the Unattached folder or to permanently delete the test sets. 
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Creating a Test Sets Tree

You define a hierarchical framework for your test sets by creating a test sets 
tree. The test sets tree can contain folders at the main level and subfolders 
below the main folders. For each folder in the test sets tree, you define a test 
set and add test instances to it. You start a test sets tree by adding a folder to 
the Root folder.

After you have created a test sets tree, you assign test set folders to cycles 
defined in the releases tree in the Releases module. For more information, 
“Assigning Test Set Folders to Cycles” on page 327.

To create a test sets tree:

 1 Choose View > Test Sets Tree to display the test sets tree view in the Test Set 
pane.

 2 In the test sets tree, select the Root folder.

 3 Click the New Folder button or choose Test Sets > New Folder. The New 
Folder dialog box opens.

 4 Type the Folder Name and click OK. Note that a folder name cannot include 
the following characters: \ ^ * 

The new folder appears under Root in the test sets tree.

 5 In the Details tab, complete the test set folder details by assigning the test 
set folder to a cycle. For more information, see “Assigning Test Set Folders to 
Cycles” on page 327.

 6 In the Description tab, type a description of the test set folder. 

 7 Click the Attachments tab to add an attachment to the new test set folder if 
necessary. An attachment can be a file, URL, snapshot of your application, 
an item from the Clipboard, or system information. For more information, 
see Chapter 5, “Adding Attachments.”
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 8 To create additional folders, select a folder and repeat steps 3 and 7. 

Assigning Test Set Folders to Cycles

After you have created a test sets tree, you assign test set folders to cycles 
defined in the releases tree in the Releases module. For more information, 
see Chapter 9, “Developing the Releases Tree.”

To assign a test set folder to a cycle:

 1 In the test sets tree, select the test set folder that you want to assign to a 
cycle. 

 2 Click the Assign To Cycle button or choose Test Sets > Assign To Cycle. 
Alternatively, in the Details tab, click the browse button next to the 
Assigned to cycle box. The Assign To Cycle dialog box opens. 

 3 Expand the tree and select a cycle. 

 4 Click OK to close the Assign To Cycle dialog box. In the test set tree, the test 
set folder icon  is replaced by the assigned test set folder icon . 

The Details tab displays the following test set folder details:

You can click the Show button to view the following details:
 

Field Description

Assigned to cycle Indicates the cycle to which the selected test set 
folder is assigned.

Cycle start date The date on which the cycle starts. 

Cycle end date The date on which the cycle ends. 

Remaining days in cycle The total number of days remaining in the cycle.

Total test instances The total number of test instances in the selected 
test set folder.

Remaining test instances 
to run

The total number of test instances in the selected 
test set folder that have not yet run.
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 5 To clear an assigned test set folder, select it, click the Assign To Cycle arrow, 
and choose Clear Assigned Cycle. Alternatively, select an assigned test set 
folder and choose Test Sets > Clear Assigned Cycle. 

Adding Test Sets

You can add a test set to a folder in your test sets tree, or to the test sets grid.

To add a test set:

 1 You can add a test set to the test sets tree or test sets grid:

➤ Display the test sets tree by choosing View > Test Sets Tree. In the test 
sets tree, choose a folder and click the New Test Set button or choose Test 
Sets > New Test Set.

➤ Display the test sets grid by choosing View > Test Sets Grid. Click the 
New Test Set button  or choose Test Sets > New Test Set.

The New Test Set dialog box opens.

If you opened the dialog box from the test sets tree, the Test Set Folder box 
displays the preselected folder name.

 2 If you opened the New Test Set dialog box from the test sets grid, click the 
browse button in the Test Set Folder box, and choose a folder.
328



Chapter 24 • Creating Test Sets
 3 In the Test Set Name box, type a name for the test set. Note that a test set 
name cannot include the following characters: \ ^ , " *

 4 In the Description box, type a description of the test set.

 5 Click OK. The test set name is added to the test sets tree. 

 6 Click the Test Set Properties tab and select the Details link. Alternatively, 
choose Test Sets > Test Set Properties > Test Set Details.

 7 In Close Date, select the planned closing date for the test set.

 8 In Open Date, select a date from the calendar. By default, the date is set to 
the current database server date.

 9 In ITG Request Id, add the IT Governance request ID. Note that this is 
relevant only when integrating with an IT Governance tool.

 10 In Status, set the status of the test set to Open or Closed.

 11 Click the Attachments link to add an attachment to the test set. An 
attachment can be a file, URL, snapshot of your application, an item from 
the Clipboard, or system information. For more information on 
attachments, see Chapter 5, “Adding Attachments.”
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 12 Click the Notifications link to instruct Quality Center to send e-mail to 
specified users if certain events occur. For more information, see “Setting the 
Test Set Notifications” on page 332.

 13 Click the On Failure link to set rules for the automated tests in the test set in 
the event of a test failure. For more information, see “Setting the Test Set On 
Failure Rules” on page 334.

Adding Tests to a Test Set 

After you have defined a test set, you can add manual and automated tests 
from the test plan tree, or tests covering requirements from the 
requirements tree, to the test set. You can also include instances of the same 
test in different test sets or add more than one instance to the same test set.

To add tests from the test plan tree to a test set:

 1 Select a test set from the test sets tree or test sets grid.

 2 In the Execution Grid tab or Execution Flow tab, click the Select Tests 
button. By default, the right pane displays the test plan tree in the Test Plan 
Tree tab. 

 3 Select a test or folder and click the Add Tests to Test Set button. 

Tip: You can also add tests by double-clicking or dragging a folder or test in 
the test plan tree to the Execution Grid or Execution Flow.

 4 If you are adding a folder, a message box opens. Click Yes to confirm.

Note: Only tests that match the current filter in the Test Plan Tree tab are 
added.
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 5 If any of the tests you are adding are already in the test set, the Create Test 
Instance dialog box opens. It displays the tests that already exist in the test 
set and how many instances there are. Select the tests you still want to add 
to the test set and click Create.

 6 If the test you are adding has unassigned parameters, the Parameters dialog 
box opens, enabling you to assign values to the parameters. For more 
information on parameters, see “Calling a Manual Test with Parameters” on 
page 279.

 7 Click the Close button to close the right pane.

To add tests covering requirements from the requirements tree to a test set:

 1 Select a test set from the test sets tree or test sets grid.

 2 In the Execution Grid tab or Execution Flow tab, click the Select Tests 
button. 

 3 In the right pane, click the Requirements Tree tab, the tests are displayed 
according to associated requirements. 

 4 To add a test, select the test and click the Add Tests Covering Requirement 
button.

Tip: You can also add tests by double-clicking or dragging a test or 
requirement in the Requirements Tree tab to the Execution Grid or 
Execution Flow.
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 5 To add all tests that cover a selected requirement, select the requirement and 
click the Add Tests Covering Requirement button.

To add all tests that cover a selected requirement and its children, select the 
requirement. Click the Add Tests Covering Requirement arrow and choose 
Add Tests Covering Requirement and Children.

A message box opens. Click Yes to confirm.

Note: Only tests that match the current filter in the Requirements Tree tab 
are added.

 6 If any of the tests you are adding are already in the test set, the Create Test 
Instance dialog box opens. It displays the tests that already exist in the test 
set and how many instances there are. Select the tests you still want to add 
to the test set and click Create.

 7 If the test you are adding has unassigned parameters, the Parameters dialog 
box opens, enabling you to assign values to the parameters. For more 
information on parameters, see “Calling a Manual Test with Parameters” on 
page 279.

 8 Click the Close button to close the right pane. 

Setting the Test Set Notifications 

You can instruct Quality Center to send e-mail to a specified user if any of 
the following events occur for a test set:

➤ Any test in the test set fails.

➤ A test in the test set fails due to reasons other than the test logic itself. 
Environmental failure could include, for example, function calls not 
returning, access violations, version incompatibility between application 
components, a missing DLL, inadequate permissions, and many other 
reasons.

➤ All tests in the test set that were run have finished running. Note that this 
does not include tests that were not run.
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To set the test set notifications:

 1 Select a test set from the test sets tree or the test sets grid.

 2 Click the Test Set Properties tab and select the Notifications link. 
Alternatively, choose Test Sets > Test Set Properties > Notifications.

 3 Select one or more events for the test set.

 4 To specify who should receive the e-mail, type a valid e-mail address.

Alternatively, click the To button. The Select Recipients dialog box opens. 
Select individual users or an entire user group. Click OK. To send an e-mail 
to a user, the user must have a valid e-mail address set up in their user 
properties. For more information on defining user properties, refer to the 
HP Quality Center Administrator’s Guide.

 5 In the Message box, type a message for the e-mail.
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Setting the Test Set On Failure Rules 

You can set on failure rules for a test set which instruct Quality Center in the 
event that an automated test in the test set fails. This includes instructions 
on how many times the test should be rerun, and the clean up test that 
should be run before the test is rerun. For any automated test in the test set, 
you can change the default on failure rules. 

To set the test set on failure rules:

 1 Select a test set from the test sets tree or test sets grid.

 2 Click the Test Set Properties tab and select the On Failure link. Alternatively, 
choose Test Sets > Test Set Properties > On Failure.

 3 To set the test set on failure rule, select the first check box and specify the 
number of times an automated test should be rerun. 

 4 To include a cleanup test, select the second check box and click the browse 
button to select the cleanup test from the test plan tree in the Select 
Cleanup Test dialog box.

 5 You can change the default failure rules for a specific test in the test set. For 
more information, see “Changing the Default Failure Rules for Specific 
Tests” on page 335.
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 6 On the final failure of any test in the test set, you can instruct 
Quality Center to:

➤ Do nothing.

➤ Stop the test set.

➤ Run the test set again a specified number of times.

Changing the Default Failure Rules for Specific Tests
You can change the default failure rules for specific tests in a test set. These 
rules instruct Quality Center in the event that the test fails. This includes 
the number of times the test should be rerun and the clean up test that 
should be run before the test is rerun.

Note: You can also use the Run Events view in the Test Instance Properties 
dialog box to set the on failure rules for a test in a test set. For more 
information, see “Viewing Test Run Events” on page 396.

To change the default failure rules for specific tests:

 1 Set the default failure rules. For more information, see “Setting the Test Set 
On Failure Rules” on page 334.
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 2 To change the default failure rules for specific tests, click the Settings per 
test button. The On Test Failure dialog box opens.

 3 You can use the following options to specify the number of times an 
automated test should be rerun:

➤ To specify for a selected test, double-click the corresponding cell in the 
Number of Reruns column. The Number of Reruns dialog box opens. 
Specify the number of reruns and click Apply. 

➤ To specify for selected tests, select the tests or click the Select All button. 
Press Ctrl and double-click any cell in the Number of Reruns column. 
Alternatively, click the Change Selected Tests arrow and choose Change 
Number of Reruns. The Number of Reruns dialog box opens. Note that 
the Apply to all selected tests option is selected. Specify the number of 
reruns and click Apply.
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 4 You can use the following options to specify a cleanup test:

➤ To specify for a selected test, double-click the corresponding cell in the 
Cleanup Test column. The Select Cleanup Test dialog box opens. Select a 
clean up test from the test plan tree and click Apply.

➤ To specify one cleanup test for the selected tests, select the tests or click 
the Select All button. Press Ctrl and double-click any cell in the Cleanup 
Test column. Alternatively, click the Change Selected Tests arrow and 
choose Change Cleanup Test. The Select Cleanup Test dialog box opens. 
Note that the Apply to all selected tests option is selected. Select a clean 
up test from the test plan tree and click Apply.

 5 To reset the default failure rules, select a test and click the Set to Default 
button. Click Yes to confirm.

 6 To clear the settings for a test, select a test and click Clear. Click Yes to 
confirm.

 7 To copy the settings from one test to another, select a test to copy and click 
the Copy Test Settings button.

Select a test to paste and click the Paste Test Settings button.

 8 Click OK to save your changes and close the On Test Failure dialog box. 
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Managing Test Sets 

This section on managing test sets includes the following topics:

➤ Finding a Test Set in the Tree

➤ Finding a Test in the Execution Grid

➤ Replace Field Values in the Execution Grid

➤ Removing a Test from a Test Set

➤ Copying a Test Set or a Test Set Folder within the Same Project

➤ Copying a Test Set or a Test Set Folder between Projects

➤ Copying a URL of a Test Set

➤ Renaming a Test Set

➤ Deleting a Test Set Folder

➤ Deleting a Test Set

➤ Resetting a Test Set

➤ Purging a Test Run from a Test Set

Finding a Test Set in the Tree
You can search for a folder or test set in the test sets tree. If you have applied 
filters to the test sets tree, the Test Lab module restricts the search to the test 
sets currently displayed.
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To find a folder or test set:

 1 Select a folder in the test sets tree.

 2 Choose Edit > Find Folder/Test Set. The Find Folder/Test Set dialog box 
opens and displays the folder name in the Find in box. If you are searching 
the entire tree, the folder name is Root.

 3 In the Value To Find box, type the name (or part of the name) of the folder 
or test set. Note that the search is not case sensitive.

 4 Check Include Test Sets to include test sets in the search.

 5 Click Find.

The Test Lab module attempts to locate the folder or test set. If the search is 
successful, the Search Results dialog box opens and displays a list of possible 
matches. Select a result from the list and click the Go To button to highlight 
the folder or test set in the test sets tree. 

If the search is unsuccessful, an information box opens.
339



Chapter 24 • Creating Test Sets
Finding a Test in the Execution Grid
You can search for tests in the Execution Grid, based on the value of a 
particular field. If you have applied filters to the grid, the search is restricted 
to the tests currently displayed.

To find a test in the Execution Grid:

 1 Choose Tests > Find. The Find dialog box opens.

 2 In the Find in Field box, select a field in the grid.

 3 In the Value to Find box, type or select the value of the field, for which you 
want to search.

 4 Select Exact Match if you want to find tests with field values that exactly 
match the Value to Find string.

 5 Select Case Sensitive if you want the search to distinguish between 
uppercase and lowercase characters.

 6 Select Use Wildcard if you want to use asterisk (*) characters in your search 
string in order to type only part of the item.

 7 Click Find Next. If the search is successful, the matching test is chosen in the 
grid. If the search is unsuccessful, an information box opens.

 8 Click Find Next again to find the next test that matches the criteria.
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Replace Field Values in the Execution Grid
You can replace field values in the Execution Grid using the Replace 
command.

To replace a field value in the requirements grid:

 1 Choose Tests > Replace. The Find/Replace dialog box opens.

 2 In the Find in Field box, select the column in which you want to search for a 
specific value. 

 3 In the Value to Find box, type or select the value to find. 

 4 In the Replace with box, type or select a replacement field value.

 5 To distinguish between uppercase and lowercase characters, select the Case 
Sensitive check box.

 6 To search for an exact value, select the Exact Match check box.

 7 To start the search from the top of the grid, select the From Beginning check 
box.

 8 To use asterisk (*) characters in your search string in order to type only part 
of the item, select the Use Wildcard check box.

 9 To replace the found item and find the next occurrence, click Replace.

 10 To replace all occurrences of the value in the grid, click Replace All.
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Removing a Test from a Test Set
You can remove tests from a test set.

To remove a test from a test set:

 1 Select a test set from the test sets tree or the test sets grid. The tests are 
displayed in the Execution Grid or Execution Flow.

 2 Select the test that you want to remove. To remove more than one test from 
the Execution Grid or Execution Flow, press the Ctrl key and select the tests 
you want to remove.

 3 Click the Remove Tests from Test Set button.

 4 Click Yes to confirm. 

Copying a Test Set or a Test Set Folder within the Same 
Project
You can copy a test set or a test set folder within the same project. Note that 
test run information is not copied. 

To copy a test set or a test set folder within the same project:

 1 Select a test set or a test set folder from the test sets tree. To copy more than 
one test set or folder, use the Ctrl key.

 2 Choose Edit > Copy. Alternatively, right-click and choose Copy.

 3 Select the folder to which you want to copy the test set or subject folder.

 4 Choose Edit > Paste. Alternatively, right-click and choose Paste.

Copying a Test Set or a Test Set Folder between Projects
You can copy test sets and test set folders from one project to another. If the 
test sets or test set folders contain calls to other tests, you can instruct 
Quality Center to copy them using one of the following methods:

➤ Copy test sets or test set folders and link them to existing tests in the target 
project. If a called test does not exist in the target project, Quality Center 
copies and pastes it into the target project.

➤ Copy test sets or test set folders along with the called tests into the target 
project.
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➤ Copy test sets or test set folders without copying called tests into the target 
project.

Note that test run information is not copied.

To copy a test set or a test set folder between projects:

 1 Select the test set or the test set folder that you want to copy in the test sets 
tree. To copy more than one test set or folder, use the Ctrl key.

 2 Choose Edit > Copy. Alternatively, right-click and choose Copy.

 3 Open another instance of Quality Center and log in to the project to which 
you want to paste the tests.

 4 Select the folder to which you want to copy the test sets or test set folders.

 5 Choose Edit > Paste. Alternatively, right-click and choose Paste. The Paste 
Test Sets/Test Set Folders to Target Project dialog box opens. 

 6 Select one of the following options:

➤ Copy test sets/test set folders and link to existing called tests. 
Quality Center copies the test sets or test set folders and pastes them into 
the target project. The copied test sets/test set folders are linked to 
existing tests with the same name. If a called test does not exist in the 
target project, Quality Center copies and pastes it into the target project.

➤ Copy test sets/test set folders and called tests. Quality Center copies the 
test sets or test set folders along with called tests, and pastes them into 
the target project. If a called test name already exists in the target project, 
the copied called test is renamed to resolve the duplicate test name.

➤ Copy test sets/test set folders and called tests. Quality Center copies the 
test sets or test set folders without copying the called tests, and pastes 
them into the target projects. The copied test sets or test set folders are 
not linked to any called tests.

Click OK. 
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Copying a URL of a Test Set
You can copy a test set and paste its URL as a link. The test set itself is not 
copied. Instead, you can paste the address into another location, such as an 
e-mail or a document. Clicking on the link opens up Quality Center and 
takes you to the test set. 

To copy a URL of a test set:

 1 Select a test set from the test sets tree or grid. 

 2 Choose Edit > Copy URL. Alternatively, right-click and choose Copy URL.

 3 Paste the URL.

Renaming a Test Set
You can rename a test set or test set folder. Note that you cannot rename the 
default test set.

To rename a test set:

 1 Select a test set or test set folder from the test sets tree or the test sets grid.

 2 Right-click the test set or test set folder and choose Rename.

 3 Edit the test set name and press Enter. 
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Deleting a Test Set Folder
You can delete a folder and move all of its test sets to the Unattached folder, 
or you can permanently delete a folder with all its test sets.

To delete a test set folder:

 1 Select a folder from the test sets tree. To delete more than one folder, press 
the Ctrl key and select the folders you want to delete.

 2 Click the Delete button, or choose Edit > Delete. The Confirm Delete Folder 
dialog box opens.

 3 To delete, you can:

➤ Select Delete folders only to delete the folder and move all test sets to the 
the Unattached folder. The Unattached folder contains all test sets that 
are no longer associated with a folder.

➤ Select Delete folders and test sets to permanently delete the folder and 
all its test sets.

 4 Click Yes to confirm.
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Deleting a Test Set
You can delete a test set from a project. Note that you cannot delete the 
default test set.

To delete a test set:

 1 Select a test set from the test sets tree or the test sets grid. To delete more 
than one test set, press the Ctrl key and select the test sets you want to 
delete.

 2 Click the Delete button, or choose Edit > Delete.

 3 Click Yes to confirm. 

Resetting a Test Set
Resetting a test set changes the status of all the tests in the test set to No 
Run. When resetting a test set, you can also decide if you want to delete the 
test run results. 

To reset the current test set:

 1 Select a test set from the test sets tree or the test sets grid.

 2 Choose Test Sets > Reset Test Set. The Confirm Reset Test Set dialog box 
opens.

 3 To instruct the Test Lab module not to delete the test run results for the test 
set, clear the Delete all the test run results in test set check box.

 4 Click Yes to confirm.
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Purging a Test Run from a Test Set 
You can use the Purge Runs wizard to delete old test run results in your 
project.

To purge a test run from a test set:

 1 Choose Test Sets > Purge Runs. The Select Test Sets to Purge dialog box 
opens, enabling you to select test sets to purge.

Using the arrows, move the appropriate test set names from the Available 
Test Sets box to the Selected Test Sets box. 

Tip: You can also drag the test sets between lists.
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 2 Click Next. The Choose Type of Purge dialog box opens, enabling you to 
select the purge type and define the purge conditions.

By default, the Purge Runs wizard deletes all the runs in the selected test 
sets. To instruct the wizard to only delete run steps but keep the overall run 
details, in the Delete box select Run Steps Only.

➤ If you are deleting Runs:

Under From runs older than, select a period of time before which you 
want to delete test run results.

In Keep last, select the number of test run results to keep for each test.

➤ If you are deleting Run Steps Only:

Under From runs older than, select a period of time before which you 
want to delete run steps.
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 3 Click Next. The Confirm Purge Request dialog box opens, summarizing the 
deletions you chose to make.

 4 Click Purge to confirm.
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25
Scheduling Test Runs

The Test Lab module enables you to control the execution of the tests in a 
test set.

About Scheduling Test Runs 

In the Execution Flow, you can specify a date and time, and set conditions 
for executing a test. A condition is based on the results of another specified 
test in the Execution Flow. By setting conditions, you can instruct the Test 
Lab module to postpone execution of the current test until the other 
specified test has either finished running or passed. You can also set the 
sequence in which to execute the tests. 

For example, in the Mercury Tours test set, you can determine that test2 will 
run only if test1 passed, and test3 will run only if test2 passed. 

This chapter describes: On page:

About Scheduling Test Runs 351

Scheduling a Test Run 354

Modifying a Test Run Schedule 357

Arranging Tests Sequentially 360

Finding Tests 361

Viewing the Execution Flow Diagram 361
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Unlike the Execution Grid, which displays the tests with only test run 
information, the Execution Flow displays the tests with conditions in a 
diagram.

In the Execution Flow, a test set is represented by the Test Set  icon. Each 
test in the diagram is represented by a test icon. 

A dashed line  arrow indicates that the test is to be executed after 
the previous test, with no conditions. 

A solid line  arrow indicates a condition and can be blue or 
green. If the solid line is blue, it indicates that the test is to be executed only 
if the previous test has status Finished. If the solid line is green, it indicates 
that the test is to be executed only if the previous test has status Passed.
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When a test is time-dependent, a Time Dependency  icon is added to the 
diagram. 
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Scheduling a Test Run 

The Execution Flow tab enables you to watch the execution process as it 
happens and to control the way your tests are executed. You can specify 
under what conditions you want a test to be executed (execution conditions) 
and when (time dependency).

Note: After you schedule your tests, you must run them. For more 
information, see “Running Tests Manually” on page 363 and “Running Tests 
Automatically” on page 373.

To schedule a test run:

 1 In the Execution Flow tab, double-click a test. Alternatively, right-click a test 
and choose Test Run Schedule. The Run Schedule dialog box opens and 
displays the Execution Conditions tab.
354



Chapter 25 • Scheduling Test Runs
 2 To add a condition, click New. The New Execution Condition dialog box 
opens.

 3 In the Test box, select the test on which you want the current test to be 
dependent.

➤ Select Finished (default) to instruct the Test Lab module to execute the 
current test only after the specified test has finished executing.

➤ Select Passed to instruct the Test Lab module to execute the current test 
only if the specified test has finished executing and has passed.

 4 In the Comments box, add any relevant information regarding the 
condition.

 5 Click OK. The condition is added to the list.

Tip: You can also add a condition directly in the Execution Flow. Click a test 
icon (not the test name) and drag the arrow to another test. By default, the 
condition is set to Finished. To change the condition, double-click the 
condition arrow and select Passed. 
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 6 Click the Time Dependency tab to specify when you want the test to be 
executed.

 7 Select Run At Specified Time, and select a Date and/or Time.

Tip: You can schedule the test run date and time by clicking the Add Time 
Dependency To Flow  button, and linking it to a test. Double-click the 
icon to set the time in the Time Dependency dialog box.

 8 Click OK to close the Run Schedule dialog box. In the Execution Flow, the 
diagram displays the tests and the conditions. 
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Modifying a Test Run Schedule

You can modify and delete conditions and time dependency information for 
a test run schedule.

This section includes:

➤ Editing Execution Conditions

➤ Deleting Execution Conditions

➤ Editing Time Dependency

➤ Deleting Time Dependency

➤ Deleting All Conditions and Dependencies

Editing Execution Conditions
You can edit conditions connected to a test run.

To edit an execution condition:

 1 In the Execution Flow, double-click a condition arrow. Alternatively, right-
click a condition arrow and choose Execution Condition. The Execution 
Condition dialog box opens.

 2 Modify any relevant information regarding the condition and click OK.
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Deleting Execution Conditions
You can delete a single condition or all conditions connected to a test. 

To delete an execution condition for a test:

 1 In the Execution Flow, right-click a condition arrow and choose Remove 
Execution Condition.

 2 Click Yes to confirm. The condition arrow is removed.

To delete all execution conditions for a test:

 1 In the Execution Flow, right-click a test and choose Remove Test’s Execution 
Conditions.

 2 Click Yes to confirm. All connecting arrows are removed.

Editing Time Dependency
You can modify the date and time of a scheduled test run.

To edit time dependency:

 1 In the Execution Flow, double-click the Time Dependency  icon 
connected to a test. The Time Dependency dialog box opens. 

 2 Modify the date and/or time, and click OK.
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Deleting Time Dependency
You can delete a specified time dependency.

To delete time dependency:

 1 In the Execution Flow, right-click a Time Dependency  icon connected to 
a test and choose Remove Time Dependency. 

 2 Click Yes to confirm. The Time Dependency icon is removed from the 
Execution Flow.

Deleting All Conditions and Dependencies
You can delete all execution conditions and time dependencies in a test set.

To delete all execution conditions for a test set:

 1 Right-click in the Execution Flow and choose Remove All Execution 
Conditions.

 2 If your test set includes both execution conditions and time dependencies, 
the Remove All Execution Conditions dialog box opens.

Choose one of the following options:

➤ Run conditions and time dependencies. Removes the execution 
conditions and time dependencies from your test set.

➤ Run conditions only. Removes the execution conditions from your test 
set.

➤ Time dependencies only. Removes the time dependencies from your test 
set.

Click OK. The execution conditions and/or time dependencies are removed.
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 3 If your test set contains only execution conditions or only time 
dependencies, a confirm dialog box opens. Click Yes to confirm. The 
execution conditions or time dependencies are removed.

Arranging Tests Sequentially 

In the Execution Flow, you can change the execution order of the tests 
displayed in the diagram.

To rearrange tests sequentially:

 1 in the Execution Flow, press the CTRL key and select two or more tests.

 2 Right-click a test and choose Order Tests. The Order Tests dialog box opens. 

 3 Select a test from the list and click the up or down arrow to change the 
position of the test in the sequence.

 4 Click OK. 
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Finding Tests 

You can search for a test in the Execution Flow.

To find a test:

 1 Click the Find Test In Flow button on the toolbar, or choose Edit > Find Test 
in Flow. The Find Test dialog box opens.

 2 In the Value to Find box, type the name (or part of the name) of the test. 
The search is not case sensitive.

 3 Click Find. The Test Lab module attempts to locate the test.

 4 If the search is successful, the Search Results dialog box opens and displays a 
list of possible matches. Select a result from the list, and click the Go To 
button to highlight the test in the Execution Flow. 

Click the Keep on Top button to display the Find Results dialog box on top 
of all open windows. 

To display a selected window on top of the Find Results dialog box, click the 
Not on Top button.

 5 If the search is unsuccessful, an information box opens. 

Viewing the Execution Flow Diagram

You can change the way the Execution Flow is displayed. This includes 
zooming in and out of the diagram, rearranging the tests in a hierarchical 
layout, refreshing the diagram, and displaying full test names in the 
diagram. You can also copy the diagram to the Clipboard.
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Layout

Click the Arrange Layout button to rearrange the tests in a hierarchical 
layout. This enables you to view dependencies between different tests.

Zoom In

Click the Zoom In button to increase the magnification level of the diagram 
to make it appear larger.

Zoom Out

Click the Zoom Out button to reduce the magnification level of the diagram 
to make it appear smaller.

Fit Picture In Window

Click the Fit Picture in Window button to redisplay the diagram to fit in the 
window. You can also click the down arrow to select a magnification option:

➤ Select a specific magnification level, such as 25%, 50%, 150% or 200%.

➤ Select Normal to display the diagram at 100% magnification.

➤ Select Fit In Window to display the entire diagram in the window.

➤ Select Custom Zoom to specify a zoom level. In the Custom Zoom dialog 
box, type a zoom level and click Zoom.

Refresh Flow

Click the Refresh Flow button to refresh the Execution Flow diagram so that 
it displays the most up-to-date tests.

Show Full Test Names

Choose Tests > Flow > Show Full Test Names to display full test names in the 
Execution Flow diagram. By default, long names are truncated.

Copy to Clipboard

Choose Tests > Flow > Copy to Clipboard to copy the Execution Flow 
diagram to the Clipboard as a bitmap.
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Running Tests Manually

When you run tests manually, you follow the test steps and perform 
operations on the application under test. You pass or fail each step, 
depending on whether the actual application results match the expected 
output. You can run both manual and automated tests manually.

About Running Tests Manually

You run tests manually by following the test steps you defined during test 
planning: 

 1 Perform operations on the application under test. Follow the instructions 
detailed in the test step descriptions.

 2 Compare the actual results with the expected results. When performing the 
steps, decide whether the application responds according to the expected 
results.

 3 Assign a pass or fail status to each step, depending on whether or not the 
expected results match the actual results. 

This chapter describes: On page:

About Running Tests Manually 363

Running a Test Manually 364

Editing the Test Steps 370
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 4 If a step fails, explain how the application actually responded. A test fails if 
one or more steps fail.

You can execute tests more than once in the same set. Each execution is 
considered a new test run. 

After test execution is complete, you can view a summary of test results in 
the Test Lab module. The updated status for each test run appears in the 
Execution Grid. Results for each test step appear in the Last Run Result pane. 
You can view more detailed results in the Test Instance Properties dialog 
box. For more information on viewing test results, see Chapter 28, “Viewing 
Test Results.”

Running a Test Manually 

When you run a test manually, you follow the test steps and perform 
operations on the application under test. You compare the expected results 
with the actual outcome and record the results. You can execute a test as 
many times as you want. Test results are stored separately for each run. You 
can run both manual and automated tests manually.

Note that while executing a test manually you can modify the test steps. You 
can choose to save the modifications in the original test in the Test Plan 
module and the test instance in the Test Lab module. Alternatively, you can 
save them for the current test run only. For more information, see “Editing 
the Test Steps” on page 370.

You can also resume a manual test run that was paused during execution. 
For more information, see “Resuming a Manual Test Run” on page 371.

Note: If you are running a business process test, refer to the HP Business 
Process Testing User’s Guide.
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To run a test manually:

 1 In the Execution Grid tab or Execution Flow tab, select the tests you want to 
run manually. 

➤ To run a single manual test, select the test and click the Run button.

➤ To run two or more manual tests, select the tests and click the Run 
button. The Manual Test Run dialog box opens.

By default, the Manual Runner (Run according to the order in the 
Execution Grid) option is selected. This option runs the tests according to 
the order displayed in the Execution Grid.

To run manual tests automatically, select Automatic Runner (Run 
according to the order in the Execution Flow). This option runs the tests 
according to the order displayed in the Execution Flow. For more 
information on running tests automatically, see “Running a Test 
Automatically” on page 374.

If you do not want the Manual Test Run dialog box to be displayed the 
next time you run manual tests, select Don’t show this again. To enable, 
choose Tests > Enable Manual Test Run Confirmation. 

Click OK. 

➤ To run automated tests manually, select the tests, click the Run arrow, 
and choose Run Manually. 
365



Chapter 26 • Running Tests Manually
The Manual Runner dialog box opens.

 2 Under Run Details, you can edit the following run information:

➤ Run Name. The name of the test run.

➤ Tester. The user name of the person who executed the test.

 3 Click the Operating System Info link to display operating system 
information. The Operating System Information dialog box opens.
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You can edit the following operating system information:

➤ Operating System. The operating system on the machine where you 
perform your test steps. By default, the operating system on your 
Quality Center client machine is displayed.

➤ OS Service Pack. The operating system service pack.

➤ OS Build Number. The operating system build number.

 4 Under Test Details, you can view details of the test. Click More to open the 
Test Properties dialog box and display test details and attachments. For more 
information on test properties, see Chapter 17, “Developing the Test Plan 
Tree.”

 5 To add attachments to the test run, click the Attach to Run button. An 
attachment can be a file, URL, snapshot of your application, an item from 
the Clipboard, or system information. For more information on 
attachments, see Chapter 5, “Adding Attachments.”

 6 To add a defect to the test run, click the New Defect button. The New Defect 
dialog box opens. Quality Center automatically creates a link between the 
test run and the new defect. For more information, see Chapter 31, “Adding 
and Tracking Defects”, and Chapter 32, “Linking Defects”.

 7 To end the run at this point, you can click the End Run button. 
Quality Center saves the test run. To cancel the run completely, click the 
Cancel Run button and click No to confirm.

 8 Click the Begin Run button to start the test run. 

If the test you are running has unassigned parameters, the Parameter Values 
for Run dialog box opens, enabling you to assign values. For more 
information on parameters, see “Calling a Manual Test with Parameters” on 
page 279.
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The Manual Runner: Step Details dialog box opens.

Note: You cannot assign multiple values to a parameter during a test run.

In Filter by, you can filter the steps in the test according to the Status 
column.

Tip: You can conveniently read each test step and record the results using 
the compact view display of this dialog box. To open this display, click the 
Compact View button. To return to the steps grid, click the Back to Steps 
Grid button.

 9 If there are no test steps, or if you want to make changes to the steps, you 
can edit the test steps before you begin executing them. For more 
information, see “Editing the Test Steps” on page 370.
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 10 To view the values of the test parameters, click the Show Parameters button. 
The Parameter Values for Run dialog box opens. For more information on 
parameters, see “Calling a Manual Test with Parameters” on page 279.

 11 Open the application being tested and execute the first step of the test.

➤ Click Pass Selected if the actual result is the same as the expected result. 
A green check is added to the step and the step status changes to Passed. 
(To pass all the test steps at once, click the Pass Selected arrow and 
choose Pass All.)

➤ If the actual result is different from the expected result, type the actual 
result in the Actual box and click the Fail Selected button. A red X is 
added to the step and the step status changes to Failed. (To fail all the test 
steps at once, click the Fail Selected arrow and choose Fail All.)

 12 Click Attachments to add attachments to the test step. To add attachments 
to the entire test run, click the Attachments arrow and choose Attach to 
Run. For more information on attachments, see Chapter 5, “Adding 
Attachments.”

 13 Click New Defect if you detect an application flaw while running the test. 
The New Defect dialog box opens, enabling you to add the defect. 
Quality Center automatically creates a link between the test run and the 
new defect. For more information, see “Adding New Defects” on page 419 
and “Linking Defects” on page 435.

 14 Click the Keep on Top button to display the Manual Runner: Step Details 
dialog box on top of all open windows. To display selected windows on top 
of the Manual Runner: Step Details dialog box, click the Not on Top button.

 15 Perform the remaining steps.

 16 Click the End Run button when you complete the test run, or to pause 
execution of the test run. To resume a manual test run that was paused 
during execution, see “Resuming a Manual Test Run” on page 371.
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Editing the Test Steps 

While executing a test in the Manual Runner: Step Details dialog box, you 
can add, delete, or modify test steps. After you finish executing the test, you 
can save your design steps with the changes you make. 

To edit a test step:

 1 Open the Manual Runner: Step Details dialog box. For more information, 
see “Running a Test Manually” on page 364.

 2 Click the Add Step button to add a step. A new step with a default step 
name is added. You can enter details about the new step in the Description 
box.

 3 Click the Delete Selected button to delete a selected step or steps, and click 
Yes to confirm.

 4 Click the End Run button to close the dialog box. A message box opens. 

 5 Click Yes to save your changes and update your test in the Test Plan and Test 
Lab modules. Click No to save your changes in the current test run only.

Note that the Test Lab module enables you to update changes made to called 
tests in the current test run only. The called tests are not affected. For more 
information on called tests, see “Calling a Manual Test with Parameters” on 
page 279.
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Resuming a Manual Test Run 

If a manual test run was paused during execution, you can continue the run 
at a later stage. 

Note: The Continue Manual Run command continues the last run of the 
selected test. If you want to resume running a previous run, click the Test 
Instance Properties button, select All Runs on the sidebar and choose the 
test run you want to resume. Click the Continue button.

To resume a manual test run:

 1 In the Execution Grid tab or Execution Flow tab, select the test you want to 
resume running.

 2 Choose Tests > Continue Manual Run. Alternatively, click the Run arrow and 
choose Continue Manual Run. The Manual Runner dialog box opens for the 
selected test.

 3 Continue running the test. 
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Running Tests Automatically 

You can run tests automatically, directly from Quality Center. You can 
choose to run tests on your machine or on remote hosts. 

About Running Tests Automatically

You can run tests automatically on your machine or on remote hosts. A host 
is any machine connected to your network on which a testing tool has 
already been installed.

You can select the tests you want to run from the Execution Grid tab or 
Execution Flow tab. Note that you can choose to run all of the tests in a test 
set, or specific tests, and that you can include both automated and manual 
tests. The selected tests are displayed in the Automatic Runner dialog box. 

When you run an automated test, Quality Center opens the selected testing 
tool automatically, runs the test on your local machine or on remote hosts, 
and exports the results to Quality Center. 

This chapter describes: On page:
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When you run a manual test from the Automatic Runner dialog box, 
Quality Center notifies a designated tester by e-mail to run the test on a 
specified host.

You can also run an automated system test to provide system information, 
capture a desktop image, or restart a machine. For more information on 
system tests, see Chapter 21, “Working with System Tests.”

Running a Test Automatically

When you run an automated test, Quality Center opens the selected testing 
tool automatically, runs the test, and exports the test results to 
Quality Center. When you run a manual test, e-mail is sent to a designated 
tester, requesting that they run the manual test.

You can run an entire test set or specific tests including both automated and 
manual tests. Your selected tests are displayed in the Automatic Runner 
dialog box.

The following should be considered when running tests automatically:

➤ Before running a test on a remote host, you must first set up hosts in the 
Host Manager dialog box. For more information, see “Setting Up Hosts 
for Remote Test Execution” on page 379.

➤ To run the same test concurrently on multiple remote hosts, add multiple 
instances of the test to your test set. For more information, see “Adding 
Tests to a Test Set” on page 330.

➤ To run several test sets concurrently on multiple remote hosts, open a 
new Automatic Runner dialog box instance for each test set. 

➤ To enable Quality Center to run QuickTest Professional or WinRunner 
tests on a remote host, open the relevant application on the remote host 
and select the required option. For more information, refer to the 
QuickTest Professional User’s Guide or the WinRunner User’s Guide.

➤ If you run a WinRunner test in batch mode, each test that is called from 
the batch test is considered a separate test, and not part of the batch test 
itself. Any test called from the batch test that is not already included in 
the test set is added to the test set at the end of the test run.
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QuickTest Professional users should consider the following:

➤ Before running a QuickTest test, Quality Center loads the QuickTest 
add-ins that are associated with the selected test. You must ensure that 
you run the test on a machine on which the required QuickTest add-ins 
are installed. For more information on working with add-ins and 
associated add-in lists in QuickTest, refer to the QuickTest Professional 
documentation and the relevant QuickTest add-in documentation.

➤ When you run QuickTest Professional tests from the Test Lab module, 
they are automatically run in Fast mode. They cannot be run in Normal 
mode.

To run tests automatically:

 1 Select a test set from the test sets tree or the test sets grid.

 2 You can set conditions and schedule the date and time for executing your 
tests. You can also set the order in which you want your tests to be executed. 
For more information, see Chapter 25, “Scheduling Test Runs.”

 3 You can run all the tests in a test set or select specific tests:

➤ To run a test set, in the Execution Grid tab or Execution Flow tab, click 
the Run Test Set button. Alternatively, choose Test Sets > Run Test Set.

➤ To run selected tests, in the Execution Grid tab or Execution Flow tab, 
select one or more tests and click the Run button. Alternatively, choose 
Tests > Run.
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The Automatic Runner dialog box opens and displays the tests.

 4 You can run your tests locally or remotely:

➤ To execute the tests locally, select the Run All Tests Locally check box.

➤ To execute the tests remotely, clear the Run All Tests Locally check box. 
For each test, you must select a host machine. Click the Run on Host grid 
box, and click the browse button. The Select Host dialog box opens. 
Under <Any Host>, you can select a host to run the test.

Alternatively, you can select a host group. Note that if you select a host 
group, Quality Center runs the test on the first available host in the 
group, not on every host in the group.

 5 To instruct Quality Center to create an execution log file during the test run, 
select the Enable Log check box. For more information, see “Viewing the 
Execution Log” on page 378.
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 6 Click Run to run the selected tests. Click Run All to run all the tests in the 
Automatic Runner dialog box. 

For an automated test, Quality Center opens the selected testing tool 
automatically and runs the test. Test execution commences only when the 
selected host becomes available to run tests.

For a manual test, Quality Center notifies a designated tester by e-mail to 
run the test. This notification can be sent only if you have designated a 
tester for the test with a valid e-mail address. To designate a tester, locate the 
test in the Execution Grid tab, place the mouse pointer in the Responsible 
Tester column, and click the arrow button. Select a name from the list.

The test execution progress is displayed in the Status column.

 7 If you need to terminate test execution before it has been completed, click 
Stop.

 8 If you selected Enable Log before you started the test run (see Step 5), you 
can view the Execution Log by choosing Run > View Execution Log. For 
more information, see “Viewing the Execution Log” on page 378.

 9 Choose Run > Exit to close the Automatic Runner dialog box.

 10 After the test run is complete, you can view a summary of test results in 
Quality Center. The updated status for each test run appears in the 
Execution Grid tab. Results for each test step appear in the Last Run Result 
pane. You can view more detailed results in the Test Instance Properties 
dialog box. For more information on test results, see Chapter 28, “Viewing 
Test Results.”
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Viewing the Execution Log 

The Execution Log contains details about the executed tests, such as the 
project name, user name, and test set name. For each test, the log includes 
the date and time of the run, the host, and a description of the run.

Note: You can only view the Execution Log if you selected Enable Log in the 
Automatic Runner dialog box before you executed the test. For more 
information, see Step 5 on page 376.

To view the Execution Log:

 1 After the test run is complete, choose Run > View Execution Log in the 
Automatic Runner dialog box. The Execution Log dialog box opens.
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 2 To filter the execution log:

➤ In the Test list box, select a test and click the Refresh button. 

➤ In the Host list box, select a host and click the Refresh button. 

 3 Choose Log > Open to display another execution log file.

 4 Choose Log > Delete to delete the execution log. Click Yes to confirm.

 5 Choose Log > Exit to close the Execution Log.

Setting Up Hosts for Remote Test Execution 

You can run tests on any host connected to your network. Using the Host 
Manager dialog box, you can create a list of available hosts for test 
execution. You can also organize hosts into groups to be used for a specific 
project.

Note: If you specify a host group for remote test execution, Quality Center 
runs the test on the first available host, not every host in the host group.
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To set up hosts for remote test execution:

 1 Choose Test Sets > Host Manager. The Host Manager dialog box opens.

If no hosts are displayed in the Available Hosts list, click the Get Hosts on 
the Network button. Quality Center scans the Network Neighborhood 
directory and inserts each host found into the Available Hosts list.

To synchronize the hosts in the Available Hosts list with the hosts in the 
Network Neighborhood directory, click the Get Hosts on the Network arrow 
and choose Synchronize Hosts in the Project with Hosts on Net. 
Quality Center adds hosts found in the Network Neighborhood directory 
and deletes hosts that were not found in the Network Neighborhood 
directory.

 2 To add a host to the Available Hosts list, click the New Host button. The 
New Host dialog box opens. In the Host Name box, type the name of the 
host machine. In the Description box, type a description of the host. Click 
OK. 
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 3 To delete a host from the Available Hosts list, select the host and click the 
Delete Host button. Click Yes to confirm.

 4 To create a host group, click the New Host Group button. The New Host 
Group dialog box opens. In the Group Name box, type a name for the host 
group. In the Description box, type a description of the host group. Click 
OK.

 5 To add a host to a host group, select a group from the Host Group list. Select 
a host from the Available Hosts list, and click the Add Host To Host Group 
button. Alternatively, double-click a group.

 6 To remove a host from a host group, select a group from the Host Group list. 
Select a host from the Hosts in Group list. Click the Remove Host From Host 
Group button.

 7 To delete a host group, select the group from the Host Group list. Click the 
Delete Host Group button. Click Yes to confirm.

 8 Click Close to close the Host Manager dialog box.

Ordering Tests in the Execution Grid 

You can change the order of the tests in the Execution Grid. Quality Center 
runs the tests according to the specified order, grouped by host type. For 
example, if you have your tests ordered as test1, test2, and test3, 
Quality Center runs test1 and test3 first if they are set to run on the same 
host, followed by test2 on a different host.

Note: When determining the order for running tests, Quality Center first 
checks the Execution Flow. The order you define in the Execution Grid is 
only used if there are no conditions set in the Execution Flow. For more 
information on scheduling tests in the Execution Flow, see Chapter 25, 
“Scheduling Test Runs.”
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To order tests in the Execution Grid:

 1 Choose Tests > Order Tests. The Order Tests dialog box opens. 

 2 Select a test from the list, and click the up or down arrow to change the 
position of the test in the sequence. 

Tip: You can also drag the tests up or down.

 3 Click OK.
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Finding and Replacing Values in the Execution Grid 

You can search and replace field values in the Execution Grid.

To find a value:

 1 Choose Tests > Find. The Find dialog box opens.

 2 In the Find in Field box, select the column in which you want to search for a 
specific value.

 3 In the Value to Find box, type or select the value to find.

 4 You can select Exact Match to search for an exact value.

 5 You can select Case Sensitive to distinguish between uppercase and 
lowercase characters.

 6 You can select Use Wildcard to use asterisk (*) characters in your search 
string in order to type only part of the item.

 7 Click Find Next. Quality Center attempts to locate any tests with the 
specified value. If the search is successful, the test is highlighted in the 
Execution Grid. If the search is unsuccessful, an information box opens.
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To replace a value:

 1 Choose Tests > Replace. The Find/Replace dialog box opens.

 2 In the Find in Field box, select the column in which you want to search for a 
specific value.

 3 In the Value to Find box, type or select the value to find.

 4 In the Replace with box, type or select a replacement field value.

 5 You can select Case Sensitive to distinguish between uppercase and 
lowercase characters.

 6 You can select Exact Match to search for an exact value.

 7 You can select From Beginning to start the search from the top of the 
Execution Grid.

 8 You can select Use Wildcard to use asterisk (*) characters in your search 
string in order to type only part of the item.

 9 To replace:

➤ Click Replace to replace the found item and find the next occurrence.

➤ Click Replace All to replace all occurrences in the Execution Grid. 
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Viewing Test Results

After running test instances, you analyze the test results to determine which 
test instances failed, and which steps caused the failure.

This chapter describes: On page:

About Viewing Test Results 386

Viewing Test Results 386

Viewing Details of a Test Run 389

Comparing Results of All Runs 391

Viewing Configuration of a Test Run 393

Viewing Linked Defects 398

Viewing Test Run History 399
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About Viewing Test Results

After running test instances, you can view the results in Quality Center. Test 
results consist of the overall pass/fail status of a test instance and the 
pass/fail status of each step in a test instance. These results help you 
determine whether a defect was detected in your application. In some cases, 
you may decide that a step failed because the expected results are no longer 
valid and need to be updated. 

Following the execution of manual and automated tests, you can view 
results and general test information in the Execution Grid. Use the Test 
Instance Properties dialog box to view test run details, compare the results of 
the most recent test run with previous runs, manage attachments, view test 
run configuration information, view linked defects, and view a history of 
test run changes.

Note: For information on viewing system test results, see Chapter 21, 
“Working with System Tests.”

In addition, you can analyze the progress of a test set by periodically 
generating execution reports and graphs. For further information, see 
Chapter 33, “Generating Reports,” Chapter 34, “Generating Graphs,” and 
Chapter 35, “Generating Live Analysis Graphs.”

Viewing Test Results

You can view the test results from the Test Instance Properties dialog box.

To view the test results:

 1 In the Execution Grid, double-click a test, or select a test instance and click 
the Test Instance Properties button. 

In the Execution Flow, right-click a test instance and choose Test Instance 
Properties. 
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The Test Instance Properties dialog box opens and displays the test name 
and test type. By default, the All Runs view is displayed.

 2 Click a view on the sidebar. The Test Instance Properties dialog box contains 
the following views:

View Description

Details Displays run details of a test instance. For more 
information, see “Viewing Details of a Test Run” on 
page 389.

All Runs Display the results of all test runs. For more information, 
see “Comparing Results of All Runs” on page 391.
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 3 You can click the First Test button to display the first test instance, or the 
Previous Test button to display the preceding test instance in the current 
Execution Grid.

 4 You can click the Next Test button to display the next test instance, or the 
Last Test button to display the final test instance in the current Execution 
Grid.

 5 You can click the Flag for Follow Up button to add or modify a follow up 
flag for the test instance. For more information, see Chapter 4, “Alerting on 
Changes.”

 6 If the test instance has an alert, you can click the Alerts button to open the 
Alerts dialog box. For more information, see “Viewing Alerts” on page 80.

Attachments Displays any attachments to a test instance. Also includes 
any attachments that were added to the test during test 
planning. For more information, see Chapter 5, “Adding 
Attachments.”

Configuration Displays run configuration information for a test instance. 
For more information, see “Viewing Configuration of a 
Test Run” on page 393. 

Linked Defects Displays linked defects and requirements coverage for a 
test instance. For more information, see “Viewing Linked 
Defects” on page 398.

Note: If coverage between test instances and requirements 
is enabled with the ALLOW_REQ_COVERAGE_
BY_TEST_INSTANCE parameter, the Linkage and Coverage 
view is available instead of the Linked Defects view. The 
Linkage and Coverage view displays linked defects and 
requirements coverage for a test instance. For more 
information on this parameter, see the HP Quality Center 
Administrator’s Guide. For more information on 
requirements coverage, see “Linking Requirements to a 
Test” on page 262.

History Displays the history of changes to the test instance. For 
more information, see “Viewing Test Run History” on 
page 399.

View Description
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Viewing Details of a Test Run 

You can view run details of a test instance in the Details view. 

To view details of a test run:

 1 Open the Test Instance Properties dialog box. For more information, see 
“Viewing Test Results” on page 386.

 2 In the Test Instance Properties dialog box, click Details on the sidebar. 
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 3 In the Details view, you can verify the following test information:

If you edit the test information, the changes you make are reflected in the 
Execution Grid.

Note: You can change the label of any of the fields in the Details tab. You 
can also add user-defined fields to the Details view. For more information, 
refer to the HP Quality Center Administrator’s Guide.

Option Description

Description The description of the test.

Exec Date The date on which the test was last executed.

Planned Exec Time The time at which the test was planned to be executed.

Responsible Tester The user name of the user who last executed the test.

Planned Exec Date The date on which the test was planned to be executed.

Planned Host Name The name or IP address of the machine on which the test 
was planned to run.

Status The current status of the test. A test status can be one of 
the following:

Failed. The test run failed.

N/A. The current status of the test is not applicable.

No Run. The test has not been run.

Not Completed. The test run was not completed. 

Passed. The test run was successful.

Tester The user name of the user that is actually executing the 
test.

Time The time at which the test was last executed.
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Comparing Results of All Runs 

Quality Center enables you to compare the results of a test run with the 
results of previous runs. Using the All Runs view, you can view run details 
and step results for all the runs of a selected test instance.

To view results of all runs for a test:

 1 Open the Test Instance Properties dialog box. For more information, see 
“Viewing Test Results” on page 386.

 2 In the Test Instance Properties dialog box, click All Runs on the sidebar. 

 3 To view run records with a certain status, choose a status from the View 
Runs list.
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 4 To filter, sort, or group the run records, click the Set Filter/Sort button. For 
more information on filtering, sorting, and grouping records, see Chapter 3, 
“Working with Quality Center Data.” If you set a filter, the description is 
displayed above the grid.

 5 To clear any filters or sorting that you have applied to the run records, click 
the Set Filter/Sort arrow and choose Clear Filter/Sort.

 6 To refresh the grid so that it displays the most up-to-date runs based on the 
filters you have selected, click the Refresh button.

 7 To set column appearance and order in the grid, click the Select Columns 
button. For more information on the Select Columns dialog box, see 
“Arranging Columns” on page 51.

 8 To remove a run from the grid, select a run and click Delete Selected. Click 
Yes to confirm.

 9 To view the test steps of a run, select a run and click Show Run Steps. The 
Run Steps dialog box opens and displays the step’s description, expected 
results, and actual results. For more information on test steps, see 
Chapter 19, “Building Tests.”

 10 To add an attachment to a test run, select a run and click the Attachments 
button. The Attachments dialog box opens. For more information on 
attachments, see Chapter 5, “Adding Attachments.”

 11 To add defect links to a run, select a run and click Linked Defects. The 
Linked Defects dialog box opens. For more information on linked defects, 
see Chapter 32, “Linking Defects.”

 12 To continue running a previous run, select a run and click Continue.

 13 For automated test instances, you can click one of the following buttons or 
links:

Button/Link Test Type Description

LR-SCENARIO Opens and displays the results in 
LoadRunner Analysis.

QUICKTEST_TEST Opens and displays the report in 
QuickTest Professional.
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Note: The QUICKTEST_TEST test type is only available if you have installed 
the appropriate add-in from the HP Quality Center Add-ins page. For more 
information on installing add-ins, refer to the HP Quality Center Installation 
Guide.

Viewing Configuration of a Test Run

You can view or set the parameter values for a manual test instance or an 
automated test instance in the Configuration view. You can also view and 
edit the On Failure rules for an automated test instance. 

This section includes:

➤ Setting Manual Test Parameters

➤ Setting Automated Test Parameters

➤ Viewing Test Run Events

Collected System 
Info

Captured 
Desktop Image

SYSTEM-TEST The Collected System Info link opens 
the System Information dialog box.

The Captured Desktop Image link 
opens the captured image. 

For more information on viewing 
system tests, see “Viewing System Test 
Results” on page 300.

WR-AUTOMATED 
or WR-BATCH

Opens and displays the report in 
WinRunner.

Button/Link Test Type Description
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Setting Manual Test Parameters
You can view the manual test parameters that you defined in the Design 
Steps tab of the Test Plan module. You can also set values for these 
parameters before a test run. For information on adding manual test 
parameters, see “Calling a Manual Test with Parameters” on page 279.

To view and set manual test parameter values:

 1 Open the Test Instance Properties dialog box. For more information, see 
“Viewing Test Results” on page 386.

 2 In the Test Instance Properties dialog box, click Configuration on the 
sidebar. The Manual tab is displayed. 

 3 In the Value column, you can view and set the value of each parameter. If 
you change a parameter value, the change is implemented in the next test 
run. 
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Setting Automated Test Parameters
You can set parameter values and other configuration options for an 
automated test instance from the Configuration view. For more information 
on working with parameters and other run options in automated tests, refer 
to the user guide for your automated test, QuickTest Professional User’s Guide 
or WinRunner User’s Guide.

To set automated test parameters and other configuration options:

 1 Open the Test Instance Properties dialog box. For more information, see 
“Viewing Test Results” on page 386.

 2 In the Test Instance Properties dialog box, click Configuration on the sidebar 
and click the Automated tab. 
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 3 In the Parameter Value column, you can view and edit the value of each 
parameter. Note that if you change a parameter value, the change is 
implemented in the next test run. 

Note: When defining the WinRunnerCommandLine parameter, you must 
specify the path within quotes. For example:

-ini “C:\program files\wrun.ini”

 4 You may be able to set additional configuration options, depending on the 
type of automated test you are running. For more information, refer to the 
user guide for your automated test.

Viewing Test Run Events
You can view and edit the On Failure rules for an automated test instance 
using the Run Events view. These rules instruct Quality Center in the event 
that the test instance fails. This includes the number of times the test 
instance should be rerun and the clean up test that should be run before the 
test instance is rerun. 

Note: If you change the failure rules in the Run Events view, your changes 
are implemented in the next test run.

You can also set On Failure rules for a test by choosing Test Set > Test Set 
Properties > On Failure and clicking the Settings per Test button. For more 
information, see “Setting the Test Set On Failure Rules” on page 334.
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To view test run events:

 1 Open the Test Instance Properties dialog box. For more information, see 
“Viewing Test Results” on page 386.

 2 In the Test Instance Properties dialog box, click Configuration on the 
sidebar, and click the Run Events tab. 

 3 To set the test On Failure rule, select the first check box and specify the 
number of times the test instance should be rerun. 

 4 To include a clean up test, select the Run clean up test check box and click 
the browse button. In the Select Clean Up Test dialog box, select the test 
from the test plan tree and click the Add Test icon.
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Viewing Linked Defects

You can view and manage defect links made to other Quality Center 
entities.

To view linked defects:

 1 Open the Test Instance Properties dialog box. For more information, see 
“Viewing Test Results” on page 386.

 2 In the Test Instance Properties dialog box, click Linked Defects on the 
sidebar.

Note: If coverage between test instances and requirements is enabled with 
the ALLOW_REQ_COVERAGE_BY_TEST_INSTANCE parameter, click Linkage 
and Coverage on the sidebar. For more information on this parameter, see 
the HP Quality Center Administrator’s Guide.
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 3 In the Linked Defects tab, you can view, add, and remove defect links. For 
more information, see Chapter 32, “Linking Defects.”

Viewing Test Run History

You can view a list of changes made to the test instance in the History view.

To view the history of changes to a test run:

 1 Open the Test Instance Properties dialog box. For more information, see 
“Viewing Test Results” on page 386.

 2 In the Test Instance Properties dialog box, click History on the sidebar. 

For each change to the test instance, the grid displays the date and time of 
the change and the name of the user who made the change.
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 3 Expand a change to view a list of fields modified during the change. For 
each field, the grid displays the old value and the new value. To expand all 
changes, click the Expand All button.

 4 You can specify which changes are displayed in the grid. In the Field list, 
select a field name to view only changes made to that field. Select <All> to 
view changes made to all fields.

For information on preserving the history of changes made to a field, refer 
to the HP Quality Center Administrator’s Guide.
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The Defect Tracking Workflow

Locating and repairing application defects efficiently is essential to the 
development process. Defects can be detected and added to your 
Quality Center project by users during all stages of the testing process. Using 
the Quality Center Defects module, you can report design flaws in your 
application, and track data derived from defect records.

This chapter describes how you track defects. The defects tracking workflow 
consists of the following: 

Define Testing 
Scope

Create
Requirements

Create
Requirements

Detail 
Requirements

Detail 
Requirements

Analyze 
Requirements

Analyze 
Requirements

Add
Defects

Review
New Defects

Repair
Open Defects

Test
New Build

Analyze
Defect Data
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Adding Defects

When you discover a defect in your application, you submit a defect to the 
Quality Center project. The project stores defect information that can be 
accessed by authorized users, such as members of the development, quality 
assurance, and support teams. You can associate this new defect with the 
cycle and release in which it was detected.

Suppose you are testing the Mercury Tours application. You just ran the 
Cycle 1 test set under the Release 10.5 test set folder and one of the test runs 
revealed a defect when entering expiration dates for credit card numbers. 
When the defect is initially submitted to the project, the Detected in 
Release field is assigned to the Release 10.5 release, and the Detected in 
Cycle field is assigned to the Cycle 1 - New Features cycle. For more 
information on releases and cycles, see Chapter 7, “The Release 
Management Workflow.”

You can link this new defect with the test you ran, for future reference. You 
can also link defects to other Quality Center entities, such as requirements, 
tests and other defects. For more information, see Chapter 32, “Linking 
Defects.”

You can also view, update, and analyze defects in the project. For more 
information, see Chapter 31, “Adding and Tracking Defects”.

Reviewing New Defects

Review all new defects in the project and decide which ones to fix. This task 
is usually performed by the project manager. Change the status of a new 
defect to Open, and assign it to a member of the development team. 

In the Target Release field, assign the open defect to the release that is 
targeted to be fixed. In the Target Cycle field, assign the defect to the cycle 
that is targeted to be closed. For example, suppose the defect detected when 
entering expiration dates for credit card numbers is planned to be fixed in 
the next cycle. Assign the Target Release field to Release 10.5, and the 
Target Cycle field to Cycle 2 - New Features + Regression. 
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While reviewing new defects, if duplicate defects appear in the project, 
change their status to either Closed or Rejected, or delete them from the 
project.

Repairing Open Defects

Fix the Open defects. This involves identifying the cause of the defects, and 
modifying and rebuilding the application. These tasks are performed by 
application developers. When a defect is repaired, assign it the status Fixed. 
For example, suppose the defect detected when entering expiration dates for 
credit card numbers was repaired in a new application build. You would 
update the defect status from Open to Fixed.

Testing a New Application Build

Run tests on the new build of the application. If a defect does not recur, 
assign it the status Closed. If a defect is detected again, assign it the status 
Reopen, and return to the previous stage (see “Repairing Open Defects” on 
page 405). This task is usually performed by the quality assurance manager 
or project manager. For information on running tests, see Chapter 26, 
“Running Tests Manually” and Chapter 27, “Running Tests Automatically.”

Analyzing Defect Data

View data from defect reports to see how many defects were resolved, and 
how many still remain open. As you work, you can save settings that are 
helpful in the defect-tracking process, and reload them as needed. For more 
information, see Chapter 6, “Working with Favorite Views.”

Reports and graphs enable you to analyze the progress of defect repairs, and 
view how long defects have been residing in a project. This helps you 
determine when the application can be released. For more information, see 
Chapter 33, “Generating Reports” or Chapter 34, “Generating Graphs.”
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The Defects Module at a Glance

This chapter introduces the key elements in the Defects module.

This chapter describes: On page:

The Defects Module 408

The Defects Menu Bar 411

The Defects Toolbar 412

The Defects Grid 414
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The Defects Module 

You track defects in the Quality Center Defects module, which you open by 
clicking the Defects button on the sidebar. 

The Defects module contains the following key elements:

➤ Defects menu bar. Displays drop-down menus of Defects module 
commands. For more information, see “The Defects Menu Bar” on page 411.

➤ Defects toolbar. Contains buttons for commands commonly used when 
adding, managing, and tracking defects. For more information, see “The 
Defects Toolbar” on page 412.
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➤ Indicator Columns. Indicates that the specified defect has attachments, 
linked entities, alerts, and follow up flags. Choose View > Indicator Columns 
to display these columns.

➤ Grid filter. Displays the filter that is currently applied to a column.

➤ Defects Grid. Displays defect data in a grid. For more information, see “The 
Defects Grid” on page 414.

Column Description

Attachments Click the  icon to view attachments for the defect. 
For more information, see Chapter 5, “Adding 
Attachments.”

Linked Entities Click the  icon to view linked entities for the 
defect. For more information, see Chapter 32, 
“Linking Defects.”

Alerts Click the  icon to view alerts for the defect. For 
more information, see “Viewing Alerts” on page 80.

Follow Up Flags Click the  icon to view follow up alerts for the 
defect. For more information, see “Flagging for 
Follow Up” on page 82.
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➤ Information Panel. Displays the following tabs: Description, Attachments, 
and History. Choose View > Information Panel > Show or click the Show 
arrow  to display these tabs.
 

Tip: To find a specific defect by Defect ID in the Defects Grid, choose Defects 
> Go To Defect. 

Tab Description

Description Displays the description for the currently selected 
defect. You can also display the following options:

➤ Summary. Choose View > Information Panel > 
Summary to display a defect’s summary. 

➤ Comments. Choose View > Information Panel > 
Comments to view and add comments for a 
defect.

For more information, see “Updating Defects” on 
page 425.

Attachments Displays the attachments for the selected defect. For 
more information, see Chapter 5, “Adding 
Attachments.”

History Displays a defect’s history. For more information, 
see “Viewing Defect History” on page 429.
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The Defects Menu Bar 

The Defects menu bar has the following menus:

➤ The Defects menu contains commands that enable you to add, go to, mail, 
print, and export defects, as well as view defect details.

➤ The Edit menu contains commands that enable you to copy, paste, or delete 
defects, find and replace field values, search defects, go to a specific defect in 
the grid, and find similar defects or text. You can also view and clear alerts 
for defects and flag defects for follow-ups. For more information on alerts 
and follow-ups, see Chapter 4, “Alerting on Changes.”

➤ The View menu contains commands that enable you to set the display in 
the Defects Grid. 

➤ The Favorites menu contains commands that enable you to view a selected 
item in the Favorites list, add a Defects Grid view to your Favorites list, and 
organize the Favorites list. For more information on favorite views, see 
Chapter 6, “Working with Favorite Views.”

➤ The Analysis menu contains commands that enable you to generate defect 
reports and graphs. For more information on defect reports, see Chapter 33, 
“Generating Reports.” For more information on defect graphs, see 
Chapter 34, “Generating Graphs.”

Tip: You can access the Defects menu bar from the Defects module by 
pressing the shortcut key F9. Additionally, you can perform many other 
Quality Center operations using shortcut keys. For a list of shortcut keys, see 
Appendix B, “Quality Center Keyboard Shortcuts.”
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The Defects Toolbar 

The Defects toolbar has the following buttons:

New Defect. Opens the New Defect dialog box, enabling you to add a new 
defect to the Defects Grid. For more information, see “Adding New Defects” 
on page 419.

Delete. Deletes the selected defects from the Defects Grid. For more 
information, see “Deleting Defects” on page 434.

Refresh All. Refreshes the Defects Grid so that it displays the most up-to-date 
defects based on the filters you have selected. 

Set Filter/Sort. Includes the following options:

➤ Set Filter/Sort. Opens the Filter dialog box, enabling you to filter, sort, 
and group the defects in the Defects Grid.

➤ Clear Filter/Sort. Clears any filters, sorting, or grouping that you have 
applied to the Defects Grid. 

For more information on filtering and sorting defects, see Chapter 3, 
“Working with Quality Center Data.”

Select Columns. Opens the Select Columns dialog box, enabling you to 
define which columns appear in the Defects Grid, and the order in which 
they appear. For more information, see “Arranging Columns” on page 51.

Defect Details. Opens the Defect Details dialog box to display the details of 
the selected defect. For more information, see “Updating Defects” on 
page 425.

Attachments. Opens the Defect Details dialog box, enabling you to add an 
attachment to a defect. For more information, see Chapter 5, “Adding 
Attachments.”

Flag for Follow Up. Opens the Flag For Follow Up dialog box, enabling you 
to add or modify a follow up flag for a defect. For more information, see 
“Flagging for Follow Up” on page 82.
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Send by E-mail. Opens the Send E-mail dialog box, enabling you to send 
defect e-mail to recipients selected from a list, or to any other e-mail address. 
For more information, see “Mailing Defects” on page 430.

Find Similar Defects. Includes the following options:

➤ Find Similar Defects. Conducts a search for similar defects and, if any are 
found, displays them in the Similar Defects dialog box. 

➤ Find Similar Text. Opens the Find Similar Text dialog box, enabling you 
to search for similar defects by specifying a text string and, if any are 
found, displays them in the Similar Defects dialog box.

For more information on finding similar defects, see “Matching Defects” on 
page 421.

Text Search. Opens the text search pane in the lower part of the window, 
enabling you to enter keywords and search predefined fields. For more 
information, see “Searching Records” on page 71.

Favorite. Click the Favorite arrow to display a list of favorite views. Favorite 
views enable you to reload a Quality Center window with the settings you 
apply to it. If you do not see the Favorite bar, choose View > Favorite Bar to 
display it. For more information on favorite views, see Chapter 6, “Working 
with Favorite Views.”
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The Defects Grid

Quality Center organizes and displays defect data in a grid. Each line in the 
Defects Grid displays a separate defect record. The Defects Grid can display 
the following columns:

Column Description

Actual Fix Time Indicates the actual number of days needed to fix the 
defect. If this field is left blank, Quality Center 
automatically calculates the Actual Fix Time as Closing 
Date - Detected on Date.

Assigned To The user name of the person who is assigned to fix the 
defect. Click the down arrow to display a list displaying 
the name and full name of each user. 

Closed in Version Indicates the application version in which the defect was 
closed. Click the down arrow to display a list of versions.

Closing Date Indicates the date on which the defect was closed. Click 
the down arrow to display a calendar and select a closing 
date.

Comments Displays comments about the defect.

Defect ID A unique numeric ID for the defect, assigned 
automatically by Quality Center. The Defect ID is read-
only.

Description Describes the defect in detail.

Detected By The user name of the person who found the defect. By 
default, Quality Center inserts the login user name into 
this field.

Detected in Cycle Indicates the cycle in which the defect was detected. Click 
the down arrow to select a different cycle. 

Note that when assigning a defect to a cycle in the 
Detected in Cycle field, Quality Center automatically 
assigns its release to the Detected in Release field.

Detected in Release Indicates the release in which the defect was detected. 
Click the down arrow to select a different release.
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Detected in Version Indicates the application version in which the defect was 
detected. Click the down arrow to display a list of 
versions.

Detected on Date The date on which the defect was detected. By default, the 
current database server date is displayed. Click the down 
arrow to select a different detection date.

Estimated Fix Time Indicates the estimated number of days required for fixing 
the defect.

Modified Indicates the date and time when this defect was last 
changed.

Planned Closing 
Version

Indicates in which version the defect is planned to be 
fixed. Click the down arrow to display a list of versions.

Priority The priority of the defect, ranging from low priority 
(level 1) to urgent priority (level 5).

Project The name of the project where the defect occurs. Click the 
down arrow to display a list of projects.

Reproducible Indicates whether the defect can be recreated under the 
same conditions by which it was detected. Click the down 
arrows to choose Y or N.

Severity The severity of the defect, ranging from low (level 1) to 
urgent (level 5).

Status The current status of the defect. By default, the status is 
New. Defect status can be one of the following: Closed, 
Fixed, New, Open, Rejected, Reopen. 

Subject Indicates the subject folder. Click the down arrow to 
display a list of subjects.

Summary A brief summary of the defect.

Column Description
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Notes: 

➤ You can add user-defined fields and change the label of any of the fields 
in the Defects Grid. You can also customize project lists. For more 
information, refer to the HP Quality Center Administrator’s Guide.

➤ You can use the Script Editor to restrict and dynamically change the 
fields and values in the Defects Grid. For more information, refer to the 
HP Quality Center Administrator’s Guide.

➤ When you select a defects column with a user name value, 
Quality Center displays a list with the name and full name of each user. 
You can search for users, sort users, group users by user group, and select 
users from the users list or a group tree. For more information, see 
“Selecting Users” on page 54.

Target Cycle Indicates in which cycle the defect is targeted to be fixed. 
Click the down arrow to select a different cycle.

Note that when assigning a defect to a cycle in the Target 
Cycle field, Quality Center automatically assigns its 
release to the Target Release field.

Target Release Indicates in which release the defect is targeted to be 
closed. Click the down arrow to select a different release.

Column Description
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Adding and Tracking Defects

You use the Defects module to add application defects directly to a 
Quality Center project. You can then track defects until the application 
developers and application testers determine that they are resolved.

This chapter describes: On page:

About Adding and Tracking Defects 418

Adding New Defects 419

Matching Defects 421

Updating Defects 425

Finding and Replacing Values 427

Viewing Defect History 429

Mailing Defects 430

Copying Defects 433

Copying URLs of Defects 433

Printing Defects 434

Deleting Defects 434
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About Adding and Tracking Defects

Defect records inform members of the application development and quality 
assurance teams of new defects discovered by other members. By sharing 
defect information, both the application development and defect repair 
processes are faster, more efficient, and more comprehensive. As you 
monitor the progress of defect repair, you update the information in your 
Quality Center project.

Suppose you detect a defect in the Mercury Tours application. When you 
initially report the defect in Quality Center, by default it is assigned the 
status New. A quality assurance manager or project manager reviews the 
defect, determines a repair priority, changes its status to Open, and assigns it 
to a member of the development team. A developer repairs the defect and 
assigns it the status Fixed. You retest the application, making sure that the 
defect does not recur. The quality assurance manager or project manager 
determines that the defect is actually repaired and assigns it the status 
Closed.

Notes: 

➤ You can link defects to other Quality Center entities, such as 
requirements, tests and other defects. For more information, see 
Chapter 32, “Linking Defects.”

➤ You can use the Workflow Script Editor to restrict and dynamically 
change the fields and values in the Defects module. You can also 
customize the fields for a specific user group. For more information, refer 
to the HP Quality Center Administrator’s Guide.
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Adding New Defects 

You can add a new defect to a Quality Center project from any module at 
any stage of the testing process.

Note: In addition to adding defects directly in Quality Center, you can also 
import defect data from Microsoft Excel to your Quality Center project. To 
import from Excel, you must install the Microsoft Excel Add-in and the 
HP Quality Center Connectivity Add-in. You can install these add-ins from 
the HP Quality Center Add-ins page. For more information, refer to the 
HP Quality Center Installation Guide.

To add a new defect:

 1 To add a new defect from any module, click the Tools button on the 
upper-right corner of the Quality Center window. Choose New Defect. 

To add a new defect from the Defects module, click the New Defect button. 
The New Defect dialog box opens.
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 2 Enter the relevant defect details. Note that a required field is displayed in red 
and that Quality Center fills in some fields by default. For more information 
on available fields in the New Defect dialog box, see Chapter 30, “The 
Defects Module at a Glance.”

 3 To clear the data in the New Defect dialog box, click the Clear button.

 4 You can add an attachment to your defect:

➤ Click the Attach File button to attach a file.

➤ Click the Attach URL button to attach a URL.

➤ Click the Attach Snapshot button to capture and attach an image.

➤ Click the Attach SysInfo button to attach information about your 
machine.

➤ Click the Attach Clipboard Content button to attach an item from the 
Clipboard.

For more information about adding attachments, see Chapter 5, “Adding 
Attachments.”

 5 To eliminate duplicate or similar defects, you can:

➤ Click the Find Similar Defects button to conduct a search for similar 
defects based on keywords from the Summary and Description fields.

➤ Click the Find Similar Defects arrow and choose Find Similar Text to 
search for similar defects by specifying a text string.

For more information, see “Matching Defects” on page 421.

 6 You can check the spelling in the dialog box:

➤ Click the Check Spelling button to check the spelling for the selected 
word or text box. If there are no errors, a confirmation message opens. If 
errors are found, the Spelling dialog box opens and displays the word 
which is misspelled together with replacement suggestions.

➤ Click the Spelling Options button to open the Spelling Options dialog 
box, enabling you to configure the way Quality Center checks spelling. 

➤ Click the Thesaurus button to open the Thesaurus dialog box and display 
a synonym, antonym, or related word for the selected word. You can 
replace the selected word or look up new words.
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 7 Click the Submit button to add the defect to the project. Quality Center 
assigns a Defect ID to the new defect.

 8 Click Close.

Matching Defects 

Matching defects enables you to eliminate duplicate or similar defects in 
your project. Each time you add a new defect, Quality Center stores lists of 
keywords from the Summary and Description fields. When you search for 
similar defects, keywords in these fields are matched against other defects.

Note that keywords are more than two characters, and letter case does not 
affect your results. The following are ignored: articles (a, an, the); coordinate 
conjunctions (and, but, for, nor, or); boolean operators (and, or, not, if, then); 
and wildcards (?, *, [ ]). 

There are two methods you can use to conduct a search for similar defects:

➤ Find Similar Defects. Compares a selected defect with all other existing 
defects in your project. You can conduct a search for similar defects in the 
Defects Grid, or before submitting a new defect in the New Defect dialog 
box. See “Finding Similar Defects” on page 422.

➤ Find Similar Text. Compares a specific text string against all other existing 
defects in your project. You can conduct a search for similar defects in the 
Defects Grid, or before submitting a new defect in the New Defect dialog 
box. You can limit your results by specifying a percentage of detected 
similarity. See “Finding Similar Text” on page 423.

Tip: If Text Search is available, it is recommended that you use it to search 
for similar defects. Text search provides a more powerful search by allowing 
you to search for keywords and variations of keywords. For information on 
using the text search, see “Searching Records” on page 71.
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Finding Similar Defects
You can match defects by comparing a selected defect with all other existing 
defects in your project. When similar defects are found, they are displayed 
according to the percentage of detected similarity. 

To find similar defects:

 1 In the Defects Grid, select a defect and click the Find Similar Defects button. 
Alternatively, in the New Defect dialog box, before you submit a defect, click 
the Find Similar Defects button.

Results are displayed in the Similar Defects dialog box, ordered by 
percentage of detected similarity, as listed in the Similar column. If no 
similar defects are found, a message is displayed.
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 2 To see more details for a defect in the Similar Defects dialog box, 
double-click the defect.

 3 Click Close to close the Similar Defects dialog box.

Finding Similar Text
You can match defects by comparing a specific text string with all other 
existing defects in your project. You can limit the results of defects found to 
those that meet a specific similarity percentage. For example, suppose that 
you are searching for defects with the word Help. If you limit your results to 
25 percent, the search returns the following results:

If you limit your results to 100 percent, the search returns the following 
results:

To find similar text:

 1 In the Defects Grid, click the Find Similar Defects arrow and choose Find 
Similar Text. Alternatively, in the New Defect dialog box, before you submit 
a defect, click the Find Similar Defects arrow and choose Find Similar Text.

The Find Similar Text dialog box opens. 
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 2 To limit the results of defects found to those with a minimum similarity, 
type a percentage in the Percent of Similarity box. By default, Quality Center 
returns defects with a similarity of at least 25 percent.

 3 In the Text to Find box, type the text string. 

 4 Click OK. Results are displayed in the Similar Defects dialog box, ordered by 
percentage of detected similarity, as listed in the Similar column. If no 
similar defects are found, a message is displayed.

 5 To see more details for a defect in the Similar Defects dialog box, 
double-click the defect.

 6 Click Close to close the Similar Defects dialog box.
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Updating Defects

Tracking the repair of defects in a project requires that you periodically 
update defects. You can do so directly in the Defects Grid, or in the Defect 
Details dialog box.

To update defects:

 1 In the Defects Grid, double-click the defect you want to update. 
Alternatively, select the defect and click the Defect Details button. The 
Defect Details dialog box opens. 

 2 You can click the First button to display the first defect in the grid, or the 
Previous button to display the preceding defect.

 3 You can click the Next button to display the next defect in the grid, or the 
Last button to display the final defect in the grid.
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 4 To display a specific defect in the Defect Details dialog box, click the Go To 
Defect button. The Go To Defect dialog box opens. Type a Defect ID and 
click OK.

 5 You can click the Flag for Follow Up button to add or modify a follow up 
flag for the defect. For more information, see Chapter 4, “Alerting on 
Changes.”

 6 If the defect has an alert, you can click the Alerts button to open the Alerts 
dialog box. For more information, see “Viewing Alerts” on page 80.

 7 Click the Send by E-mail button to send e-mail with the defect details. For 
more information on mailing defects, see “Mailing Defects” on page 430.

 8 Click the Create Report For This Defect button to generate a defect report 
for the defect. For more information on defect reports, see Chapter 33, 
“Generating Reports.”

 9 If the defect is linked to a test run, you can click the Execution Report link at 
the bottom of the Defect Details dialog box to generate an execution report. 
The execution report displays detailed information about the linked test 
run. For more information on execution reports, see Chapter 33, 
“Generating Reports.”

 10 In the Details view, you can add or modify information for the selected 
defect. For more information on available fields in the Details view, see 
Chapter 30, “The Defects Module at a Glance.”

To add a new comment, click the Add Comment button. A new section is 
added to the Comments box, displaying your user name and the database’s 
current date.

 11 Click Attachments on the sidebar to add an attachment to the defect. 
An attachment can be a file, URL, snapshot of your application, system 
information, or an item from the Clipboard. A clickable attachment icon  
is placed next to the defect in the Defects Grid. For more information on 
attachments, see Chapter 5, “Adding Attachments.”
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 12 Click Linked Entities on the sidebar. The following tabs are available:

➤ Defects. Enables you to view and add links to existing defects. For 
example, you can link a defect to a duplicate defect.

➤ Others. Enables you to view and remove links from other entities. You 
cannot add new links.

For more information on linked defects, see Chapter 32, “Linking Defects.”

 13 Click History on the sidebar to view the history of changes made to the 
defect. For more information, see “Viewing Defect History” on page 429.

 14 Click OK to save your changes and return to the Defects Grid.

Finding and Replacing Values 

You can search and replace field values in the Defects Grid using the 
Find/Replace command.

Tip: If text search is available, you can use it to search for defects in the 
Defects Grid. Text search provides a more powerful search by allowing you 
to search for keywords and variations of keywords. For information on using 
the text search, see “Searching Records” on page 71.

To find a value:

 1 In the Defects Grid, choose Edit > Find. The Find dialog box opens.
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 2 In the Find in Field box, select the column in which you want to search for a 
specific value.

 3 In the Value to Find box, type or select the value to find. 

 4 To search for an exact value, select the Exact Match check box.

 5 To distinguish between uppercase and lowercase characters, select the Case 
Sensitive check box.

 6 To use asterisk (*) characters in your search string in order to type only part 
of the item, select the Use Wildcard check box.

 7 Click Find Next. Quality Center attempts to locate any defects with the 
specified value. If the search is successful, the defect is highlighted in the 
Defects Grid. If the search is unsuccessful, an information box opens.

To replace a value:

 1 In the Defects Grid, choose Edit > Replace. The Find/Replace dialog box 
opens.

 2 In the Find in Field box, select the column in which you want to search for a 
specific value. 

 3 In the Value to Find box, type or select the value to find. 

 4 In the Replace with box, type or select a replacement field value.

 5 To distinguish between uppercase and lowercase characters, select the Case 
Sensitive check box.

 6 To search for an exact value, select the Exact Match check box.
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 7 To start the search from the top of the Defects Grid, select the From 
Beginning check box.

 8 To use asterisk (*) characters in your search string in order to type only part 
of the item, select the Use Wildcard check box.

 9 To replace the found item and find the next occurrence, click Replace.

 10 To replace all occurrences of the value in the Defects Grid, click Replace All.

Viewing Defect History

You can view a list of changes made to a defect. Note that you can only see 
changes for selected fields predefined by the project administrator in Project 
Customization. For more information on enabling the history option for a 
field, refer to the HP Quality Center Administrator’s Guide.

To view the history of changes to a defect:

 1 To display the history in the Defects Grid, select a defect and choose 
View > Information Panel > Show. Click the History tab. 

Alternatively, in the Defects Grid, double-click a defect to open the Defect 
Details dialog box and click History on the sidebar.

The history of changes made to the defect is displayed in a grid.

For each change to the defect, the grid displays the date and time of the 
change and the name of the user who made the change.
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 2 Expand a change to view a list of fields modified during the change. For 
each field, the grid displays the old value and the new value. To expand all 
changes, click the Expand All button.

 3 You can specify which changes are displayed in the grid. In the Field list, 
select a field name to view only changes made to that field. Select <All> to 
view changes made to all fields.

Mailing Defects 

You can send e-mail about a defect to another user. This enables you to 
inform development and quality assurance personnel about defect repair 
activity. Quality Center includes a Go To Defect link in the e-mail, which 
enables the recipient to go directly to the defect.

Note: By default, Quality Center sends e-mail in HTML format. To send 
e-mail as plain text instead, edit the MAIL_FORMAT parameter in the 
Site Configuration tab in Site Administration. For more information, refer to 
the HP Quality Center Administrator’s Guide.
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To mail a defect: 

 1 In the Defects Grid, select one or more defects and click the Send by E-mail 
button. The Send E-mail dialog box opens.

Tip: You can automatically send the e-mail to a specific user type. This can 
be any defect column with a user name value, including user-defined fields. 
Click the Send by E-mail arrow and choose an option. For example, choose 
Send Mail to Detected By to send the e-mail to the user who detected the 
defect.
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 2 Type a valid e-mail address or user name. Alternatively, click the To button 
or CC button to select users. The Select Recipients dialog box opens. 

You can sort the users list, search for users, group users by user groups, and 
select users from the list or from a group tree. For more information, see 
“Selecting Users” on page 54.

Select the users or user groups to which you want to send the e-mail, and 
click OK. 

 3 In the Subject box, type a subject for the e-mail. By default, if you select 
only one defect, the domain, project, defect ID, and summary of the defect 
are displayed in the Subject box.

 4 In the Items box, you can clear any items you do not want to include in the 
e-mail.

 5 Select whether you want to include the Attachments and/or History of the 
defect.

 6 In the Additional comments box, add any comments you have.
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 7 You can check the spelling in the dialog box:

➤ Click the Check Spelling button to check the spelling for the selected 
word or text box. If there are no errors, a confirmation message opens. If 
errors are found, the Spelling dialog box opens and displays the word 
that is misspelled together with replacement suggestions.

➤ Click the Spelling Options button to open the Spelling Options dialog 
box, enabling you to configure the way Quality Center checks spelling. 

➤ Click the Thesaurus button to open the Thesaurus dialog box and display 
a synonym, antonym, or related word for the selected word. You can 
replace the selected word or look up new words.

 8 Click Custom to customize the e-mail. In the Select Fields dialog box, you 
can specify fields to include in the e-mail.

 9 Click Send to send the e-mail.

Copying Defects

You can copy a defect to any Quality Center project.

To copy a defect:

 1 In the Defects Grid, select the defect you want to copy. To copy more than 
one defect, press the CTRL key and select the defects you want to copy.

 2 Choose Edit > Copy. Alternatively, right-click and choose Copy.

 3 In the project to which you want to copy the defects, in the Defects Grid, 
choose Edit > Paste. Alternatively, right-click and choose Paste.

Copying URLs of Defects

You can copy a defect and paste its URL as a link. The defect itself is not 
copied. Instead, you can paste the address into another location, such as an 
e-mail or a document. Clicking on the link opens up Quality Center and 
takes you to the defect. 
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To copy a URL of a defect:

 1 From the Defects Grid, select a defect. 

 2 Choose Edit > Copy URL. Alternatively, right-click and choose Copy URL.

 3 Paste the URL.

Printing Defects

You can print all defects or selected defects in the Defects Grid.

To print defects:

 1 You can print all defects or selected defects:

➤ To print all defects, choose Defects > Print > All.

➤ To print selected defects, select the defects using the CTRL or SHIFT keys 
and choose Defects > Print > Selected. 

The Print Preview dialog box opens. 

 2 Use the buttons on the toolbar to adjust and set up the page before printing.

 3 Click the Print button or choose File > Print.

Deleting Defects

You can delete old or duplicate defects from a project. When you delete a 
defect, Quality Center does not reuse the Defect ID.

To delete a defect:

 1 In the Defects Grid, select a defect to delete.

 2 Click the Delete button or choose Edit > Delete. Alternatively, right-click the 
defect and choose Delete.

 3 Click Yes to confirm.
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Linking Defects

You can link defects to any other entity in Quality Center. 

About Linking Defects

You can link a defect to the following entities: requirements, tests, test sets, 
test instances, runs, run steps, and other defects. Defect linkage is useful, for 
example, when a new test is created specifically for a defect. By creating this 
linkage, you can determine if the test should be run based on the status of 
the defect.

A defect can be linked directly or indirectly to an entity. When you add a 
defect link to an entity, Quality Center adds a direct link to this entity and 
indirect links to other related entities. In addition, during a manual test run, 
if you add a defect, Quality Center automatically creates a linkage between 
the test run and the new defect.

This chapter describes: On page:

About Linking Defects 435

Viewing Defect Links 438

Adding Defect Links 439

Removing Defect Links 440
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The following diagram illustrates the flow of indirect linkage:

For example, when you link a defect to a run step, Quality Center adds an 
indirect link to its run, test instance, test set, and test. If the same test is 
covered by a requirement, an indirect link is also added to the requirement. 
Note that the indirect linkage is a one-directional flow. For example, if you 
link a defect to a run it is not indirectly linked to its run steps.

Using the Linked Defects dialog box or tab, you can view and manage defect 
links.
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The Linked Defects grid contains the following columns:

For more information on the defect fields, see “The Defects Grid” on 
page 414.

Column Description

Created By The user name of the person who created the link.

Creation Date The date on which the link was created.

Defect ID A unique numeric ID for the defect, assigned 
automatically by Quality Center. The Defect ID is read-
only.

Link Comment Enables you to add comments about the link.

Link ID A unique numeric ID for the link, assigned 
automatically by Quality Center. The Link ID is read-
only.

Link Type A value of the Link Type customized list. For more 
information on lists, refer to the HP Quality Center 
Administrator’s Guide.

Linked By Status The current status of the linked entity.

Linked Entity ID A unique numeric ID for the linked entity, assigned 
automatically by Quality Center. The Linked Entity ID 
is read-only.

Linked Entity Name The linked entity name. For example, the requirement 
name.

Link Entity Type The linked entity type (for example: step, test, test set).
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Viewing Defect Links

You can filter links, set column appearance and order in the grid, and refresh 
the grid. In addition, you can view details of a defect and instruct 
Quality Center to go to a module and highlight a linked entity.

➤ To refresh the grid, click the Refresh All button. 

➤ To filter and sort the defect links, click the Set Filter/Sort button. For more 
information on filtering and sorting, see “Filtering Records” on page 55. If 
you set a filter, the description of the filter is displayed above the grid.

➤ To set column appearance and order in the grid, click the Select Columns 
button. For more information, see “Arranging Columns” on page 51.

➤ To view details of a defect, select a defect link and click the Defect Details 
button. The Defect Details dialog box opens. For more information, see 
“Updating Defects” on page 425.

➤ To open the Defects module and highlight the linked defect, select a defect 
link. Click the Go To arrow and choose Go To Defect. 

Alternatively, click the Defect ID link to open the Defects module and 
highlight the linked defect.

➤ To open the relevant module and highlight the linked entity, select a defect 
link. Click the Go To arrow and choose Go To ‘Linked By’ Entity.

Alternatively, click the Linked Entity Name link to open the relevant module 
and highlight the linked entity.

➤ To display direct links, select Direct Links from the Type of Link list. To 
display direct and indirect links, select All Links. Not available in the Defects 
module.

➤ To display defect links added to parent requirements, select Current Req 
Links from the Show Links For list. To display defect links added to parent 
and children requirements, select Including Child’s Links. Available only in 
the Requirements module.
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Adding Defect Links

You can add a defect link by submitting a new defect or by selecting an 
existing defect. When you link an entity to a defect, Quality Center adds the 

 icon to the entity and to the linked defect. 

Adding Links by Submitting New Defects
You can add a defect link by submitting a new defect.

To add a link by submitting a new defect:

 1 In the Linked Defects tab or dialog box, click the Add and Link Defect 
button, or right-click the grid and choose Add and Link Defect. The New 
Defect dialog box opens.

 2 Enter the relevant defect details. For more information on adding defects, 
see “Adding New Defects” on page 419. 

 3 Click the Submit button in the New Defect dialog box. The defect is added 
to the project and the defect link is displayed in the Linked Defects grid.

Adding Links by Selecting Existing Defects
You can add a defect link by selecting an existing defect.

To add a link by selecting an existing defect:

 1 In the Linked Defects tab or dialog box, click the Link Existing Defect arrow, 
or right-click the grid and choose Link Existing Defect. 

 2 Choose By ID or Select:

➤ To add a link by typing a defect ID, choose By ID. In the Link Existing 
Defect dialog box, type the defect ID and click Link. The defect link is 
displayed in the grid.

➤ To add a link by a selecting a defect, choose Select. In the Defects to Link 
dialog box, select the defect. To select more than one defect, press the 
CTRL key and select the defects you want to link. Click Link. The defect 
links are displayed in the grid.
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Removing Defect Links

You can remove defect links from the Linked Defects grid.

Note: You can only remove direct links. Indirect links are removed 
automatically when the direct links are removed.

To remove a defect link:

 1 In the Linked Defects tab or dialog box, select a link in the grid. To select 
more than one defect, press the Ctrl key and select the defects you want to 
remove.

 2 Click the Remove Link button, or right-click and choose Remove Link.

 3 Click Yes to confirm.
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Generating Reports 

Quality Center reports can be generated from each Quality Center module.

About Generating Reports

Quality Center reports help you assess the progress of defining requirements 
and tests coverage, the test plan, test runs, and defect tracking. You use 
reports to assist in determining testing priorities and defect repair schedules, 
and in setting application release dates. You can generate reports at any time 
during the testing process.

Reports can be generated from the Requirements, Test Plan, Test Lab, and 
Defects modules. You can display reports using their default settings, or you 
can customize them. When customizing a report, you can apply filters and 
sort conditions, and determine the layout of the fields in the report. You can 
further customize the report by adding sub-reports. For more information 
on customizing reports, “Customizing Reports” on page 450.

This chapter describes: On page:

About Generating Reports 443

Available Reports and Sub-Reports 444

Creating Reports 448

Customizing Reports 450
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You can save the settings of your reports as favorite views and reload them 
as needed. You can also save your reports as text files or HTML documents. 
In addition, you can export report data to Microsoft Excel.

Note: You can export grid data as a text file, Microsoft Excel spreadsheet, 
Microsoft Word document, or HTML document. You export data from the 
Requirements Grid, Test Grid, Execution Grid, or Defects Grid. For more 
information, see “Exporting Data to a File” on page 73.

Available Reports and Sub-Reports

You can generate reports from the Requirements module, Test Plan module, 
Test Lab module, and Defects module. For each report you can add sub-
reports.

Available Reports
You can generate reports from the Requirements module, Test Plan module, 
Test Lab module, and Defects module.

Requirements Module Reports

The following reports are available in the Requirements module:

Report Description

Standard Requirements Lists the requirements that appear in the requirements 
tree. 

Tabular Displays the requirements that appear in the 
requirements tree in a grid format. 

Requirements with 
Coverage Tests

Lists the requirements that appear in the requirements 
tree with their tests coverage information. 
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Test Plan Module Reports

The following reports are available in the Test Plan module:

Test Lab Module Reports

The following reports are available in the Test Lab module:

Requirements with 
Coverage Tests and 
Steps

Lists the requirements that appear in the requirements 
tree with their tests coverage information. It also 
displays the test steps for each tests coverage. 

Requirements with 
Linked Defects

Lists the requirements that appear in the requirements 
tree with their linked defects. 

Requirements with 
Traceability

Lists the requirements that appear in the requirements 
tree with their associated traced to and traced from 
requirements. 

Report Description

Standard Test Planning Lists the tests in the test plan tree.

Subject Tree Lists the tests in the test plan tree by subject.

Tests with Design Steps Lists the tests that appear in the test plan tree, 
including their design steps.

Tests with Covered 
Requirements

Lists the tests that appear in the test plan tree with 
their requirements coverage information. 

Tests with Linked 
Defects

Lists the tests that appear in the test plan tree with 
their linked defects.

Report Description

Current Test Set Lists the tests that appear in the current test set.

Cross Test Set Lists the test sets that appear in the Test Sets list, 
without listing their tests.

Test Set Hierarchy with 
Tests

Lists the test sets hierarchically, as well as the status of 
each of the test sets. 

Report Description
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Defects Module Reports

The following reports are available in the Defects module:

Cross Test Set with 
Tests

Lists the test sets that appear in the Test Sets list, 
including their tests.

Current Test Set with 
Failed Test Runs

Lists tests from the current test set, with “Failed” test 
run status.

Cross Test Set with 
Failed Test Runs

Lists tests from all test sets, with “failed” test run 
status.

Execution Notification Lists the tests that are displayed in the current test set 
with the results of their last test run.

Report Description

Standard Defects Lists the defects that appear in the project. 

Tabular Defects Displays the defects that appear in the project in a grid 
format.

Defects with Linked 
Tests and Runs

Lists the defects with their linked tests and test run 
results.

Fixed or Rejected 
Defects

Lists defects with “fixed” or “rejected” status.

Fixed or Rejected 
Defects Detected by 
Current User

Lists defects with “fixed” or “rejected” status that were 
detected by the current user.

Opened Defects 
Assigned to Current 
User

List defects with “open” status that are assigned to the 
current user.

Report Description
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Available Sub-Reports
Each report can contain sub-reports. In addition, sub-reports themselves 
might contain other sub-reports. The sub-reports available depend on the 
type of the parent report.

The following sub-reports may be available:

Report Description

Contained Tests Lists the tests in a test set.

Coverage Requirements Lists information for requirements that cover a test.

Design Steps Lists the design steps for a test.

Linked Defects Lists the defects that are linked to a record.

Linked Entities List all entities that are linked to a defect.

Parent Test Lists the parent test of a test.

Related Defects Lists related defects for each subject in a test plan tree.

Related Requirements Lists the requirements that are linked to a defect.

Requirements Coverage Lists the tests that cover a requirement.

Run Steps Lists the run steps for a test run.

Runs Lists all runs of a test.

Source Execution Test Lists the executed tests that are linked to a defect.

Source Run Lists the test runs that are linked to a defect.

Source Test Lists the tests that are linked to a defect.

Trace To Lists the requirements traced to a requirement.

Trace From Lists the requirements traced from a requirement.
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Creating Reports 

You can create a report from the Requirements, Test Plan, Test Lab, and 
Defects modules. Depending on the current module, you have different 
report options. You can use the default report or customize it to meet your 
needs.

To create a report:

 1 Select the Quality Center module from which you want to create a report.

 2 Choose Analysis > Reports, and select the type of report you want to create. 
For more information on report types, see “Available Reports” on page 444.

Tip: You can create a quick report for specific records. For more information, 
see “Creating Quick Reports” on page 449.

The report opens with default data displayed. 
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 3 You can click the First Page button to display the first page of the report, or 
the Previous Page button to display the preceding page.

 4 You can click the Next Page button to display the subsequent page of the 
report, or the Last Page button to display the final page.

 5 To customize your report, click the Configure Report and Sub-Reports 
button. For more information, see “Customizing Reports” on page 450.

 6 To regenerate the report so that it displays the most up-to-date data, click 
the Generate Report button.

 7 To print your report, click the Print arrow and choose Current Page or 
All Pages. The Print dialog box opens. Change the printer settings if 
necessary. Click Print.

 8 To save your report, click the Save arrow and choose Current Page or All 
Pages. The Save Web Page dialog box opens. Change the file name if 
necessary. To save the report in its original format, select Web Page, 
complete in the Save as type list. To save it as a text file, select Text File and 
click Save.

 9 To export the report data to Microsoft Excel, right-click the report and 
choose Export to Microsoft Excel. Excel must be installed on your machine 
to export report data to Excel.

 10 To save the settings of your report as a favorite view, click the Add to 
Favorites button. For more information, see Chapter 6, “Working with 
Favorite Views.”

 11 Click Close to close the report and return to the current Quality Center 
module.

Creating Quick Reports
You can create a quick report for specific records. In addition, in the 
Requirements module you can create a quick report for a requirement and 
its children.

Note: You cannot view a quick report for multiple nodes in the test plan 
tree.
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To create a quick report:

 1 Select the requirements, tests, or defects for which you want to create a 
report. To create a report for more than one record, press the Ctrl key and 
select the records for which you want to create a report.

 2 Create the report using one of the following options:

➤ To create a report for the selected records, choose Analysis > 
Report Selected. Alternatively, right-click the records and choose Report 
Selected. The report opens with data for the selected records displayed.

➤ In the Requirements module, to create a quick report for a requirement 
and its children, choose Analysis > Report Selected with Children. 
Alternatively, right-click the requirement and choose Report Selected 
with Children. The report opens with data for the selected requirement 
and its children.

Customizing Reports

You can determine the appearance and contents of your Quality Center 
reports.

To customize a report:

 1 Select the Quality Center module from which you want to generate a report.

 2 Choose Analysis > Reports and select the report you want to customize. For 
more information on report types, see “Available Reports” on page 444. The 
report opens with default data displayed.
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 3 Click the Configure Report and Sub-Reports button to customize your 
report. The Report Configuration page opens with the default options 
displayed.

 4 In the Reports list, select a main report or a sub-report. The Report 
Configuration pane displays the available options.

 5 Under Page, you can set the number of items per display page (available for 
the main report):

➤ To limit the number of items per page, select Limit items per page to and 
specify the number of items per page.

➤ To display all items in one page, select All items in one page.

 6 Under Template, you can use the Quality Center default report template or 
your own template. (This option is available for the main report only.)
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 7 Under Filter, you can define or clear filters and sorting priorities:

➤ Click the Set Filter/Sort button to filter and sort your data according to 
criteria you choose.

➤ Click the Clear Filter/Sort button to clear all the filters and sorting 
priorities.

For more information, see Chapter 3, “Working with Quality Center Data.”

 8 Under Fields, you can set the fields you want to appear in the report and 
their order.

➤ Select All Fields (auto-layout) to display all fields in the report.

➤ Select Custom Fields (layout), and click the Select Fields button to choose 
the fields and set their order. For more information, see “Arranging 
Columns” on page 51.

 9 You can also select the following options. Note that not all options are 
available in all modules.

Option Description

Grid View Displays the report as a grid.

Attachments Displays a list of associated attachments.

History Displays a list of all the changes made to a 
requirement, test, or defect.

Keep Parent-Child Order Displays the requirement topic with the child 
requirement below it. Selecting this option disables 
your defined filters and sorting priorities. 

Show Paragraph Number Displays the assigned hierarchical numbers to each 
requirement in the tree. Note that the numbers are 
not related to the unique Req ID assigned to each 
requirement. 

Rich Text Includes rich text for the requirements in the report.

Show Full Coverage Displays the tests coverage for each requirement in 
the tree. 
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 10 To add a sub-report, click the Add Sub-Report button. In the Type list, select 
a sub-report type and click OK. The sub-report is added to the Reports list. 
For more information on available sub-report types, see “Available Sub-
Reports” on page 447.

 11 To delete a sub-report, select the sub-report and click the Delete Sub-Report 
button.

 12 Click the Apply button to generate a new report.

Show Steps only for 
"Failed" Runs 

Displays test steps only for failed test runs. 

Show Test Set Name Displays the test set name in the test run 
information.

Option Description
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34 
Generating Graphs

You can generate graphs that let you view images describing the 
information in a Quality Center project.

About Generating Graphs

Quality Center graphs help you draw conclusions quickly and see the 
relationships between different types of data in a project. You can create 
graphs at any stage of the testing process to check the progress of test 
requirements, test planning, test execution, and defect tracking for your 
application. After you generate a graph, you can customize graph properties 
to display information according to your specifications. 

This chapter describes: On page:

About Generating Graphs 455

Quality Center Graph Types 456

Creating Graphs 474

Customizing the Graph Content 478

Customizing the Graph Settings 484

Customizing the Graph Description 488
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Quality Center Graph Types

Quality Center enables you to generate graphs from the Requirements 
module, Test Plan module, Test Lab module, and Defects module.

Requirements Module Graphs
You can generate the following graphs from the Requirements module:

Graph Description

Requirements - 
Summary Graph

Shows how many requirements are currently in a 
Quality Center project. For more information, see 
“Requirements - Summary Graph” on page 459.

Requirements - 
Progress Graph

Shows how many requirements accumulated in a 
Quality Center project at specific points during a period of 
time. For more information, see “Requirements - Progress 
Graph” on page 460.

Requirements - 
Coverage Graph

Shows how many requirements are currently in a 
Quality Center project, according to their test coverage 
status. For more information, see “Requirements - 
Coverage Graph” on page 461.

Requirements - 
Trend Graph

Shows the history of changes to specific requirement 
fields in a Quality Center project, for each time interval 
displayed. For more information, see “Requirements - 
Trend Graph” on page 462.
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Test Plan Module Graphs
You can generate the following graphs from the Test Plan module:

Test Lab Module Graphs
You can generate the following graphs from the Test Lab module:

Graph Description

Test Planning - 
Summary Graph

Shows how many tests are currently in a Quality Center 
project. For more information, see “Test Planning - 
Summary Graph” on page 463.

Test Planning - 
Progress Graph

Shows how many tests accumulated in a Quality Center 
project at specific points during a period of time. For more 
information, see “Test Planning - Progress Graph” on 
page 464.

Test Planning - 
Trend Graph

Shows the history of changes to specific Test Plan fields in 
a Quality Center project, for each time interval displayed. 
For more information, see “Test Planning - Trend Graph” 
on page 465.

Graph Description

Test Execution - 
Summary Graph 
(Current Test Set)

Shows how many tests in a Quality Center project belong 
to the current test set. For more information, see “Test 
Execution - Summary Graph (Current Test Set)” on 
page 466.

Test Execution - 
Progress Graph 
(Current Test Set) 

Shows how many tests accumulated in the current test set 
at specific points during a period of time. For more 
information, see “Test Execution - Progress Graph 
(Current Test Set)” on page 467.

Test Execution - 
Summary Graph 
(Cross Test Set)

Shows how many tests in a Quality Center project belong 
to all the test sets. For more information, see “Test 
Execution - Summary Graph (Cross Test Set)” on 
page 468.

Test Execution - 
Progress Graph 
(Cross Test Set)

Shows how many tests accumulated in all the test sets at 
specific points during a period of time. For more 
information, see “Test Execution - Progress Graph (Cross 
Test Set)” on page 469.
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Defects Module Graphs
You can generate the following graphs from the Defects module:

Graph Description

Defects - Summary 
Graph

Shows a summary of the number of defects in a 
Quality Center project, or the estimated/actual amount of 
time taken to fix these defects. For more information, see 
“Defects - Summary Graph” on page 470.

Defects - Progress 
Graph

Shows the accumulation of defects in a Quality Center 
project, or the estimated/actual amount of time taken to 
fix these defects, at specific points during a period of time. 
For more information, see “Defects - Progress Graph” on 
page 471.

Defects - Age Graph Shows the lifetime of defects in a Quality Center project. 
For more information, see “Defects - Age Graph” on 
page 472.

Defects - Trend 
Graph

Shows the history of changes to specific defect fields in a 
Quality Center project, for each time interval displayed. 
For more information, see “Defects - Trend Graph” on 
page 473.
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Requirements - Summary Graph 
The Requirements - Summary Graph shows how many requirements are 
currently in a Quality Center project. The number of requirements is 
displayed according to the criteria that you specify. You can specify the type 
of data displayed along the x-axis, and the requirement information by 
which Quality Center groups the data. 

For example, choose Author from the X-Axis list to display the number of 
requirements that exist in your project, according to author. Select Priority 
from the Grouped By list to group requirements in the graph columns 
according to their level of priority. You can select the Show ‘Not Covered’ 
parents check box to include parent requirements with a ‘Not Covered’ 
status in the graph. Click the Refresh button to refresh the graph display.

For more information on customizing the Requirements - Summary Graph, 
see “Customizing Summary Graphs” on page 479. 

By default, the graph appears as a bar chart. To view the graph as a pie chart, 
click the Pie Chart tab.
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Requirements - Progress Graph 

The Requirements - Progress Graph shows how many requirements 
accumulated in a Quality Center project at specific points during a period of 
time. The number of requirements is displayed according to the criteria that 
you specify. You can specify the time interval displayed along the x-axis, and 
the requirement information by which Quality Center groups the data. You 
can also specify whether you want to view the number of requirements or 
the change in the number of requirements. 

For example, choose Direct Cover Status from the Group By list to group the 
displayed requirements according to their test coverage status. Under 
Period, select Last 5 weeks to display this interval along the x-axis. (Note 
that the graph displays data measured on the last day of each week.) Under 
Display Options, select Regular to view the number of requirements, as 
opposed to the change in the number of requirements. Click the Refresh 
button to refresh the graph display.

For more information on customizing the Requirements - Progress Graph, 
see “Customizing Progress Graphs” on page 480. 

The graph can be viewed as a line chart only.
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Requirements - Coverage Graph 

The Requirements - Coverage Graph shows how many requirements are 
currently in a Quality Center project, according to their test coverage status.

You can specify the requirement information by which Quality Center 
groups the data. For example, select Priority from the Grouped By list to 
group requirements in the graph’s columns according to their level of 
priority. Select the Show ‘Not Covered’ parents check box to include parent 
requirements with a ‘Not Covered’ status in the graph. Click the Refresh 
button to refresh the graph display.

Note: The Requirements - Coverage Graph is a specific type of summary 
graph. If you select a different requirement field from the X-Axis list, a 
regular Requirements - Summary Graph is displayed.

For more information on customizing the Requirements - Coverage Graph, 
see “Customizing Summary Graphs” on page 479. 

By default, the graph appears as a bar chart. To view the graph as a pie chart, 
click the Pie Chart tab.
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Requirements - Trend Graph 

The Requirements - Trend Graph shows the history of changes to specific 
requirement fields in a Quality Center project, for each time interval 
displayed. You specify the field for which you want to view the number of 
changes, and the time period for which you want to view data. 

For example, choose Direct Cover Status from the Count Changes in Field 
list to display the number of changes made to the “Direct Cover Status” 
requirement field. Under Period, select Last 5 weeks to display this time 
period along the x-axis. (Note that the graph displays a sum of the data 
measured for each week.) Click the Refresh button to refresh the graph 
display.

For more information on customizing the Requirements - Trend Graph, see 
“Customizing Trend Graphs” on page 483. 

Note that each status change is only recorded once for the purpose of this 
graph. For example, if a field was changed from “Not Completed” to 
“Passed” to “Not Completed”, the “Not Completed” status change will only 
be recorded once in this graph.

The Requirements - Trend Graph can be viewed as a bar chart only.
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Test Planning - Summary Graph 

The Test Planning - Summary Graph shows how many tests are currently in 
a Quality Center project. The number of tests is displayed according to the 
criteria that you specify. You can specify the type of data displayed along the 
x-axis, and the test plan information by which Quality Center groups the 
data. 

For example, choose Designer from the X-Axis list to display the number of 
tests that exist in your project, according to designer. Select Priority from the 
Grouped By list to group tests in the graph’s columns according to their 
level of priority. Click the Refresh button to refresh the graph display.

For more information on customizing the Test Planning - Summary Graph, 
see “Customizing Summary Graphs” on page 479. 

By default, the graph appears as a bar chart. To view the graph as a pie chart, 
click the Pie Chart tab.
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Test Planning - Progress Graph
The Test Planning - Progress Graph shows how many tests accumulated in a 
Quality Center project at specific points during a period of time. The 
number of tests is displayed according to the criteria that you specify. You 
can specify the time interval displayed along the x-axis and the test plan 
information by which Quality Center groups the data. You can also specify 
whether you want to view the number of tests or the change in the number 
of tests. 

For example, choose Status from the Group by list to group the displayed 
tests according to their level of priority. Under Period, select All days and 
Show daily info to display each day along the x-axis. Under Display Options, 
select Regular to view the number of tests, as opposed to the change in the 
number of tests. Click the Refresh button to refresh the graph display.

For more information on customizing the Test Planning - Progress Graph, 
see “Customizing Progress Graphs” on page 480. 

The graph can be viewed as a line chart only.
464



Chapter 34 • Generating Graphs
Test Planning - Trend Graph
The Test Planning - Trend Graph shows the history of changes to specific 
Test Plan fields in a Quality Center project, for each time interval displayed. 
You specify the field for which you want to view the number of changes, 
and the time period for which you want to view data. 

For example, choose Status from the Count changes in field list to display 
the number of changes made to the Test Plan “Status” field. Under Period, 
select Last 5 weeks to display this time period along the x-axis. (Note that 
the graph displays a sum of the data measured for each week.) Click the 
Refresh button to refresh the graph display.

For more information on customizing the Test Planning - Trend Graph, see 
“Customizing Trend Graphs” on page 483. 

Note that each status change is only recorded once for the purpose of this 
graph. For example, if a field was changed from “Ready” to “Repair” to 
“Ready”, the “Ready” status change will only be recorded once in this graph.

The Test Planning - Trend Graph can be viewed as a bar chart only.
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Test Execution - Summary Graph (Current Test Set)
The Test Execution - Summary Graph (Current Test Set) shows how many 
tests in a Quality Center project belong to the current test set. The number 
of tests is displayed according to the criteria that you specify. You can 
specify the type of data displayed along the x-axis, and the test plan and test 
in test set information by which Quality Center groups the data. 

For example, choose Status from the X-Axis list to display the number of 
tests that exist in your project, according to test status. Select Plan: Priority 
from the Grouped By list to group tests in the graph’s columns according to 
their level of priority. Click the Refresh button to refresh the graph display.

For more information on customizing the Test Execution - Summary Graph 
(Current Test Set), see “Customizing Summary Graphs” on page 479.

By default, the graph appears as a bar chart. To view the graph as a pie chart, 
click the Pie Chart tab.
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Test Execution - Progress Graph (Current Test Set)
The Test Execution - Progress Graph (Current Test Set) shows how many 
tests accumulated in the current test set at specific points during a period of 
time. The number of tests is displayed according to the criteria that you 
specify. You can specify the time interval displayed along the x-axis, and the 
test plan and test in test set information by which Quality Center groups the 
data. You can also specify whether you want to view the number of tests or 
the change in the number of tests. 

For example, choose Status from the Group by list to group the displayed 
tests according to their status. Under Period, select Last 5 weeks to display 
this interval along the x-axis. (Note that the graph displays data measured 
on the last day of each week.) Under Display Options, select Regular to view 
the number of tests, as opposed to the change in the number of tests. Click 
the Refresh button to refresh the graph display.

For more information on customizing the Test Execution - Progress Graph 
(Current Test Set), see “Customizing Progress Graphs” on page 480. 

The graph can be viewed as a line chart only.
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Test Execution - Summary Graph (Cross Test Set)
The Test Execution - Summary Graph (Cross Test Set) shows how many tests 
in a Quality Center project belong to all the test sets. The number of tests is 
displayed according to the criteria that you specify. You can specify the type 
of data displayed along the x-axis, and the test plan and test in test set 
information by which Quality Center groups the data. 

For example, choose Plan:Designer from the X-Axis list to display the 
number of tests that exist in your project, according to the test plan 
designer. Select Status from the Grouped by list to group tests in the graph’s 
columns according to their status. Click the Refresh button to refresh the 
graph display.

For more information on customizing the Test Execution - Summary Graph 
(Cross Test Set), see “Customizing Summary Graphs” on page 479.

By default, the graph appears as a bar chart. To view the graph as a pie chart, 
click the Pie Chart tab.
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Test Execution - Progress Graph (Cross Test Set)
The Test Execution - Progress Graph (Cross Test Set) shows how many tests 
accumulated in all the test sets at specific points during a period of time. 
The number of tests is displayed according to the criteria that you specify. 
You can specify the time interval displayed along the x-axis, and the test 
plan and test in test set information by which Quality Center groups the 
data. You can also specify whether you want to view the number of tests or 
the change in the number of tests. 

For example, choose Status from the Group By list to group the displayed 
tests according to their status. Under Period, select Last 5 weeks and Show 
daily info to display daily data for this time interval along the x-axis. Under 
Display Options, select Regular to view the number of tests, as opposed to 
the change in the number of tests. Click the Refresh button to refresh the 
graph display.

For more information on customizing the Test Execution - Progress Graph 
(Cross Test Set), see “Customizing Progress Graphs” on page 480. 

The graph can be viewed as a line chart only.
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Defects - Summary Graph
The Defects - Summary Graph shows a summary of the number of defects in 
a Quality Center project, or the estimated/actual amount of time taken to 
fix these defects. The information is displayed according to the criteria that 
you specify. You can specify the type of data displayed along the x-axis, the 
type of data displayed along the y-axis, and the defect information by which 
Quality Center groups the data. 

For example, choose Assigned To from the X-Axis list to display the number 
of defects that exist in your project, according to the people to whom they 
are assigned. Select Status from the Grouped By list to group defects in the 
graph’s columns according to their status. Under Data Type, select Count to 
display the number of defects along the y-axis. Click the Refresh button to 
refresh the graph display.

For more information on customizing the Defects - Summary Graph, see 
“Customizing Summary Graphs” on page 479. 

By default, the graph appears as a bar chart. To view the graph as a pie chart, 
click the Pie Chart tab.
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Defects - Progress Graph
The Defects - Progress Graph shows the accumulation of defects in a 
Quality Center project, or the estimated/actual amount of time taken to fix 
these defects, at specific points during a period of time. The information is 
displayed according to the criteria that you specify. You can specify the time 
interval displayed along the x-axis, the defect information by which 
Quality Center groups the data, and the data displayed along the y-axis. You 
can also specify whether you want to view the number of defects or the 
change in the number of defects. 

For example, choose Status from the Group by list to group the displayed 
defects according to their status. Under Data Type, select Count to view the 
number of defects along the y-axis, as opposed to the estimated/actual 
amount of time taken to fix the defects. Under Period, select Last 5 weeks to 
display this interval along the x-axis. (Note that the graph displays data 
measured on the last day of each week.) Under Display Options, select 
Regular to view the number of defects, as opposed to the change in the 
number of defects. Click the Refresh button to refresh the graph display.

For more information on customizing the Defects - Progress Graph, see 
“Customizing Progress Graphs” on page 480. 

The graph can be viewed as a line chart only.
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Defects - Age Graph
The Defects - Age Graph shows the lifetime of defects in a Quality Center 
project. The lifetime of a defect begins when it is reported, and ends when it 
is closed. The information in this graph is displayed according to the criteria 
that you specify. You can specify the defect information by which 
Quality Center groups the data, and the data displayed along the y-axis. You 
can also specify the time interval that you want to use to divide the data, if 
you want to view graph content in two data columns. 

For example, choose Status from the Group by list to group the displayed 
defects according to their status. Under Data Type, select Count to view the 
number of defects along the y-axis, as opposed to the estimated/actual 
amount of time taken to fix the defects. Under Age Grouping, select No 
Grouping to display all of the available age groupings. Click the Refresh 
button to refresh the graph display.

For more information on customizing the Defects - Age Graph, see 
“Customizing Defect Age Graphs” on page 482. 

Note that the age of a “Closed” defect is the difference between the date on 
which it was reported and the date on which it was closed. After a defect is 
closed, its age is fixed.

The Defects - Age Graph can be viewed as a bar chart only.
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Defects - Trend Graph
The Defects - Trend Graph shows the history of changes to specific defect 
fields in a Quality Center project, for each time interval displayed. You 
specify the field for which you want to view the number of changes, and the 
time period for which you want to view data. 

For example, choose Priority from the Count Changes in Field list to display 
the number of changes made to the “Priority” defect field. Under Period, 
select Last 5 weeks to display this time period along the x-axis. (Note that 
the graph displays a sum of the data measured for each week.) Click the 
Refresh button to refresh the graph display.

For more information on customizing the Defects - Trend Graph, see 
“Customizing Trend Graphs” on page 483. 

Note that each priority change is only recorded once for the purpose of this 
graph. For example, if a field was changed from “Urgent” to “Very High” to 
“Urgent”, the “Urgent” priority change will only be recorded once in this 
graph.

The Defects - Trend Graph can be viewed as a bar chart only.
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Creating Graphs

You can generate a graph from any Quality Center module. Depending on 
the current Quality Center module, you have different graph options. For 
example, in the Defects module, you can generate a graph that displays the 
number of defects assigned to each member of a quality assurance team. 

To create a graph:

 1 Select the Quality Center module from which you want to generate a graph.

 2 Choose Analysis > Graphs, and select a graph type. For more information on 
graph types, see “Quality Center Graph Types” on page 456.

Tip: You can also use the Graph Wizard to guide you through the graph 
creation process. For more information on using the Graph Wizard, see 
“Creating Graphs Using the Graph Wizard” on page 476.

The graph opens with default data and appearance settings. 
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A graph contains the following components:

➤ Display tabs. Displays the graph as a bar chart, pie chart, line chart, or 
data grid. You can also display information about the graph.

➤ Favorite graphs area. Enables you to save and load favorite customized 
graphs.

➤ Graph toolbar. Contains the commands you use to display, print, 
magnify, and customize graphs.

➤ Customizing graph properties area. Enables you to specify the 
information that appears in a graph.

 3 Select an available graph display tab:

➤ Bar Chart. Displays the graph as a bar graph. 

➤ Pie Chart. Displays the graph as a pie graph. 

➤ Line Chart. Displays the graph as a line graph. 

➤ Data Grid. Displays the graph as a grid.

 4 Customize the graph content. For more information, see “Customizing the 
Graph Content” on page 478.

 5 To further analyze your data, click a segment in the graph. The Drill Down 
Results dialog box opens and displays a grid with more details. You can 
determine the column appearance and order. You can also save the contents 
of a grid as a text file, Microsoft Excel spreadsheet, Microsoft Word 
document, or HTML document. For more information, see Chapter 3, 
“Working with Quality Center Data.” 

 6 You can use the graph toolbar to customize graph settings and appearance, 
as well as to print the graph and copy it to the clipboard. For more 
information, see “Customizing the Graph Settings” on page 484.

 7 You can click the Save Graph Data button to save the contents of a graph as 
a text file, Microsoft Excel spreadsheet, or HTML document.
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 8 You can click the Add to Favorites button to add a graph view to your 
Favorites list. For more information, see Chapter 6, “Working with Favorite 
Views.” 

If you save your graph as a favorite, you can change the predefined graph 
description. For more information, see “Customizing the Graph 
Description” on page 488.

 9 Click Close to close the graph and return to the current Quality Center 
module.

Creating Graphs Using the Graph Wizard
You can create a graph using the Graph Wizard. The Graph Wizard takes you 
through the steps involved in creating a graph and defining its settings.

To create a graph using the Graph Wizard:

 1 Select the Quality Center module from which you want to generate the 
graph.

 2 Choose Analysis > Graphs > Graph Wizard. The Graph Wizard dialog box for 
the current module opens.
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 3 Under Graph type, select the type of graph that you want to display. For 
more information on graph types, see “Quality Center Graph Types” on 
page 456. Click Next.

 4 This step applies if you are working in the Test Lab module. Under Select a 
test set option, specify which test sets to include in the graph. The following 
options are available: 

➤ Show current test set. Includes data from the currently selected test set 
only. This is selected by default.

➤ Show all test sets. Includes data from all test sets.

Click Next.

 5 Under Select a filter option, specify which filter to use to define the records 
included in the graph:

➤ Use current filter. Uses the filter defined in the current view. This is 
selected by default.

➤ Do not use a filter. Includes all records in the current module in the 
graph.

➤ Define a new filter. Enables you to define a new filter. Click the Filter 
button to open the Filter dialog box, and define the filter.

For more information on filtering Quality Center data, see “Filtering 
Records” on page 55.

Click Next. 

 6 In the Group By box, select the field by which you want data to be grouped 
in the graph. For a progress graph, you can only select a field for which 
history has been enabled. For more information on enabling history for a 
field, refer to the HP Quality Center Administrator’s Guide. 

If you are working in the Requirements module, and you select Direct Cover 
Status in this step, you will later need to specify whether to include parent 
requirements with a “Not Covered” status.

Click Next if applicable.

 7 This step applies if you are creating a summary graph. In the X-Axis box, 
select the field that you want to use for the X-axis. Click Next if applicable.
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 8 This step applies if you are working in the Requirements module, and you 
have selected Direct Cover Status in the Group By box. Under Select a 
coverage option, select which requirements to include in the graph:

➤ Do not show ‘Not Covered’ parents. Does not include parent 
requirements with a ‘Not Covered’ status. 

➤ Show ‘Not Covered’ parents. Includes all requirements. 

For more information on coverage, see Chapter 18, “Linking Tests to 
Requirements.”

 9 Click Finish. The graph opens with the settings you defined in the Graph 
Wizard.

Customizing the Graph Content

You can specify what information appears in a graph. This includes 
customizing a summary graph, progress graph, age graph, and trend graph.

Note: If you group data by a field containing multiple values, the 
information in each value is grouped as its entire value. This value is the 
category for grouping. For example, a value with English and French will be 
grouped once as English;French, and not as part of separate English and 
French categories. For more information on allowing multiple values, refer 
to the HP Quality Center Administrator’s Guide.
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Customizing Summary Graphs 
You can specify the information that appears in a summary type graph.

To customize a summary graph: 

 1 Choose a field from the X-Axis list to determine the information displayed 
along the x-axis of the graph.

 2 Choose a field from the Grouped By list to determine the information by 
which Quality Center groups data in the graph.

Note that you can group the data by string or list fields only.

 3 In the Requirements module, if you chose to group by the Direct Cover 
Status field, you can select the Show ‘Not Covered’ parents check box to 
include parent requirements with a Not Covered status in the graph.
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 4 Under Data Type, you set the y-axis of the graph:

➤ Select Count to display the total number of items (for example, a count 
of open defects). 

➤ Select Sum of and choose Estimated Fix Time to display the estimated 
time required for fixing the defects, or Actual Fix Time to display the 
actual time spent on fixing the defects. (Available only in the Defects 
module.)

 5 Click the Filter button to open the Filter dialog box and filter the graph 
content. For more information, see “Filtering Records” on page 55.

 6 Click the Refresh button to apply your changes. The new graph is displayed.

Customizing Progress Graphs
You can specify the information that appears in a progress type graph.
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To customize a progress graph: 

 1 Choose a field from the Group by list to specify the information by which 
Quality Center groups data in the graph. You can select only a field for 
which the History option has been enabled in Project Customization.

 2 Under Data Type, set the y-axis of the graph:

➤ Select Count to display the total number of items (for example, a count 
of open defects). 

➤ Select Sum of and choose Estimated Fix Time to display the estimated 
time required for fixing the defects, or Actual Fix Time to display the 
actual time spent on fixing the defects. (This is available only in the 
Defects module.)

 3 Under Period, select the period of time you want the graph to show.

 4 Under Display Options:

➤ Select Regular to view the number of requirements, tests, or defects over 
the period of time you selected. 

➤ Select Changes over Time to view the change in the number of 
requirements, tests, or defects over the period of time you selected. Note 
that each record begins at 0.

 5 Click Filter to open the Filter dialog box and filter the graph content. For 
more information, see “Filtering Records” on page 55.

 6 Click the Refresh button to apply your changes. The new graph is displayed.
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Customizing Defect Age Graphs
You can specify the information that appears in an age type graph. The age 
type graph is only available in the Defects module.

To customize an age graph: 

 1 Choose a field from the Group By list to determine the information by 
which Quality Center groups data in the graph.

 2 Under Data Type, set the y-axis of the graph:

➤ Select Count to display the total number of items (for example, a count 
of open defects). 

➤ Select Sum of and choose Estimated Fix Time to display the estimated 
time required for fixing the defects, or Actual Fix Time to display the 
actual time spent on fixing the defects. 

 3 You can view the graph content in two data columns. All data older than a 
certain time interval (for example, older than six months) appears in one 
column, and all data more recent than that time interval (for example, less 
than six months old) appears in the other column. 
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To view graph content in two data columns, under Age Grouping, select the 
time interval.

 4 Click the Filter button to open the Filter dialog box and filter the graph 
content. For more information, see “Filtering Records” on page 55.

 5 Click the Refresh button to apply your changes. The new graph is displayed.

Customizing Trend Graphs
You can specify the information that appears in a trend type graph.

To customize a trend graph:

 1 Choose a field from the Count changes in field list to determine the 
information for which Quality Center shows changes in the graph. You can 
select one field or all fields. 

 2 Under Period, select the time period you want the graph to show.

 3 Click Filter to open the Filter dialog box and filter the graph content. For 
more information, see “Filtering Records” on page 55.

 4 Click the Refresh button to apply your changes. The new graph is displayed.
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Customizing the Graph Settings 

You can determine how information appears in the graph using the graph 
toolbar. The toolbar includes the following buttons. Some buttons may not 
be available for all graph types.

Show Total Values. Toggles between displaying and hiding a total value in 
the graph. This option is only available for progress type graphs.

Scroll to the Left. Scrolls the graph to the left. (This button is enabled when 
the Zoom In and Zoom Out buttons are in use.)

Scroll to the Right. Scrolls the graph to the right. (This button is enabled 
when the Zoom In and Zoom Out buttons are in use.)

Show All. Returns the graph to its normal size. (This button is enabled when 
the Zoom In and Zoom Out buttons are in use.)

Zoom In. Increases the magnification of the graph.

Zoom Out. Decreases the magnification of the graph.

Set Graph Appearance. Changes the appearance of the graph, enabling you 
to customize the graph title, graph color, and graph display. For more 
information, see “Setting the Graph Appearance” on page 485.

Copy Graph to Clipboard. Includes the following options:

➤ Copy Graph (Color). Copies the graph in color to the Clipboard.

➤ Copy Graph (Monochrome). Copies the graph in monochrome to the 
Clipboard.

➤ Copy Full Screen Graph (Color). Copies the graph in color to the 
Clipboard, enlarged to fit full screen.

➤ Copy Full Screen Graph (Monochrome). Copies the graph in 
monochrome to the Clipboard, enlarged to fit full screen.
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Print Graph. Includes the following options:

➤ Print Graph (Color). Prints the graph in color.

➤ Print Graph (Monochrome). Prints the graph in monochrome.

➤ Print Graph and Details (Color). Prints the graph and its description in 
color.

➤ Print Graph and Details (Monochrome). Prints the graph and its 
description in monochrome.

Edit Categories. Enables you to combine X-Axis and Group By field values 
into categories. For more information, see “Editing Graph Categories” on 
page 486.

Setting the Graph Appearance
After you have created your graph, you can change its titles and appearance. 
For a bar chart, you can specify the display parameters for the bars. For a line 
chart, you can specify the display parameters for the lines.

To set the graph appearance:

 1 Click the Set Graph Appearance button located in the graph toolbar. The 
Graph Appearance dialog box opens.
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 2 Click the Titles tab to change the titles of the graph, the Y-axis, or the X-axis. 
You can click the Font button to change a title’s font or color. You can click 
the Reset Titles button to reset the original titles. Note that for a pie chart, 
you can only change the title of the graph.

 3 Click the Appearance tab to change the colors of the various components in 
your graph, to modify the orientation of the labels at the base of the graph 
(for a bar chart and a line chart only), or to display the graph with a 3-D 
effect.

 4 For a bar chart, click the Bar Parameters tab to specify whether you want the 
values for each bar to be displayed. You can also fix the bar width. If you 
specify that the values of each bar are to be displayed, you can change the 
data that is displayed for each bar, or its position relative to the bar. 

For a line chart, click the Line Parameters tab to specify whether you want 
the line frame to be displayed and which format you want to use for the 
date on the X-axis.

Editing Graph Categories
You can combine values for the X-Axis and Grouped By fields into 
categories. This enables you to group together data for different field values 
and display the combined data as one category. For example, suppose the 
Priority field has five values: Low, Medium, High, Very High, and Urgent. You 
might combine the values Medium and High into a category Important, and 
the values Very High and Urgent into a category Critical. The graph would 
then display data divided into three categories: Low, Important, and Critical.

To edit categories for a graph:

 1 Click the Edit Categories button located in the graph toolbar and select one 
of the following options:

➤ Edit X-Axis Categories. Enables you to combine X-Axis field values into 
categories for graph display. This option is only available for summary 
graphs and Requirements Coverage graphs.

➤ Edit Group By Categories. Enables you to combine Group By field values 
into categories for graph display. 
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The Edit X-Axis Categories or Edit Group By Categories dialog box opens.

 2 In the Name column, type a name for a category.

 3 Click the Expression column and click the browse button. The New 
Category dialog box opens.
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 4 To select which field values to include in the category, select field values and 
click the arrow buttons (> and <) to move them between Available groups 
and Groups in new category. Click the double arrow buttons (>> and <<) to 
move all the field values from one list to the other. You can also drag field 
values between lists. 

Note: You cannot include a field value in more than one category.

Click OK to close the New Category dialog box.

 5 To add a new category, click the New button and repeat steps 2 to 4.

 6 To delete a category, select the category and click the Delete button.

 7 To delete all categories, click the Clear All button. Click Yes to confirm.

 8 Click OK to close the Edit X-Axis Categories or Edit Group By Categories 
dialog box.

 9 To reset the X-Axis or Grouped By categories to their default settings, click 
the Edit Categories button located in the graph toolbar and select one of the 
following options:

➤ Reset X-Axis Categories. Restore the X-Axis categories. This option is only 
available for summary graphs and Requirements Coverage graphs.

➤ Reset Group By Categories. Restore the Group By categories.

Click Yes to confirm. The X-Axis or Grouped By categories are reset.

Customizing the Graph Description

If you save your graph as a favorite, you can change the predefined graph 
description. You can also add any text you like to the description.

To customize the graph description:

 1 Click the Description tab to display the Graph Description pane. 

 2 In the Graph Description pane, edit the graph description.
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35 
Generating Live Analysis Graphs

Live Analysis graphs enable you to create and display a dynamic graphical 
representation of data related to test plans and test sets. You use Live 
Analysis graphs to view data that relates to a test subject folder or test set 
folder. Each time that you click on a test subject folder or test set folder, the 
graphs change to reflect the data related to your selection.

This chapter describes: On page:

About Generating Live Analysis Graphs 490

Creating Live Analysis Graphs 490

Deleting Live Analysis Graphs 498

Setting the Graph Appearance 499
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About Generating Live Analysis Graphs

You create Live Analysis graphs to provide a dynamic quick visual overview 
of all the tests in a folder, or test sets in a test set folder. After you have 
created a graph, you can access it by choosing the Live Analysis tab when 
you are in the tree view of the Test Plan or Test Lab modules.

When you update a record in the folder, the data change is reflected in the 
graph, without the need for the graph to be manually regenerated.

Live Analysis graphs differ from the graphs described in Chapter 34, 
“Generating Graphs”, in that you do not have to recreate a graph to view 
data that has changed. In addition, the layout and settings of the graph are 
preserved when you select another folder in the same module. This enables 
you to view the same graphical analysis of different folders without the need 
to recreate the graphs.

Creating Live Analysis Graphs

You can create Live Analysis graphs for test subject folders and test set 
folders. For more information on creating Live Analysis graphs for test 
subject folders, see “Creating Test Subject Folder Graphs” on page 491. For 
more information on creating Live Analysis graphs for test set folders, see 
“Creating Test Set Folder Graphs” on page 494.

Note: The Live Analysis graphs that you create are unique for your user 
login. Each project user can create Live Analysis graphs which will be visible 
only to that user but will not be visible to other users.
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Creating Test Subject Folder Graphs
In the Live Analysis tab, you can create Live Analysis graphs for tests in your 
test subject folders. After you define the data that you want to display, the 
graphs are automatically updated each time the data changes in one or more 
of the tests in the test subject folder for which you created the graph.

Note: Live Analysis graphs only represent tests which are located directly 
below the selected test subject folder. They do not include tests located at a 
lower hierarchical level in child folders of the selected test subject folder.

To create a test subject folder graph:

 1 Click the Test Plan button on the sidebar to display the Test Plan module.

 2 Choose View > Test Plan Tree. The test plan tree view is displayed.

 3 In the test plan tree, select a test subject folder.

 4 Click the Live Analysis tab.
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The Live Analysis tab is divided into two panes, each of which can display a 
graph. 

 5 If you already have two graphs displayed and you want to create a new 
graph, delete one of the existing graphs. For more information, see 
“Deleting Live Analysis Graphs” on page 498.

 6 Click the Add Graph link in the pane in which you want to display the 
graph. Alternatively, choose Analysis > Live Analysis > Add Graph. The 
Graph Wizard: Test Plan Module dialog box opens.

 7 Under Graph type, select the type of graph that you want to display. You 
can generate the following graphs from the Test Plan module:

Graph Description

Summary Graph Shows how many tests are currently in the selected test 
subject folder.

Progress Graph Shows how many tests accumulated in the selected test 
subject folder, at specific points during a period of time.

Trend Graph Shows the history of changes to specific Test Plan fields in 
the selected test subject folder, for each time interval 
displayed. 
492



Chapter 35 • Generating Live Analysis Graphs
Click Next.

 8 In the Group By box, select the field by which you want the tests to be 
grouped in the graph. For a progress graph, you can only select a field for 
which history has been enabled. For more information on enabling history 
for a field, refer to the HP Quality Center Administrator’s Guide

 9 If you chose to create a summary graph, click Next. In the X-Axis box, select 
the field that you want to use for the X-axis. 

 10 Click Finish. The Live Analysis graph is displayed in the pane that you 
selected.

The graph properties that you specified are displayed at the top of the graph. 
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Note: The data displayed in the graph reflects the filters that you have set 
for the test plan tree. For more information on filtering, see “Filtering 
Records” on page 55.

 11 Click the Full Screen View button to maximize the graph. To return to the 
normal view, click the Close button.

 12 To further analyze your data, click a segment in the graph. The Drill Down 
Results dialog box opens and displays a grid with more details. You can 
determine the column appearance and order. You can also export the 
contents of a grid as a text file, Microsoft Excel spreadsheet, Microsoft Word 
document, or HTML document. For more information, see “Exporting Data 
to a File” on page 73. 

 13 To change the color of a bar in a bar graph or a line in a line graph, right-
click the bar or line, or click the corresponding entry in the graph legend. In 
the Color dialog box that opens, select the new color from one of the color 
palettes.

 14 Click the Set Graph Appearance button to customize the graph title, graph 
color, and graph display. For more graph appearance options, see “Setting 
the Graph Appearance” on page 499.

Creating Test Set Folder Graphs
In the Live Analysis tab, you can create Live Analysis graphs for the test sets 
in your test set folders. After you define the data that you want to display, 
the graphs are automatically updated each time the data changes in one or 
more test sets in the folder for which you created the graph. 

Note: Live Analysis graphs only represent test sets which are located directly 
below the selected test set folder. They do not include test sets located at a 
lower hierarchical level in child folders of the selected test set folder.
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To create a test set folder graph:

 1 Click the Test Lab button on the sidebar to display the Test Lab module.

 2 Choose View > Test Sets Tree. The Test Sets Tree view is displayed.

 3 In the test sets tree, select a test set folder.

 4 Click the Live Analysis tab. 

The Live Analysis tab is divided into two panes, each of which can display a 
graph. 

 5 If you already have two graphs displayed and you want to create a new 
graph, delete one of the existing graphs. For more information, see 
“Deleting Live Analysis Graphs” on page 498.
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 6 Click the Add Graph link in the pane in which you want to display the 
graph. Alternatively, choose Analysis > Live Analysis > Add Graph. The 
Graph Wizard: Test Lab Module dialog box opens.

 7 Under Graph type, select the type of graph that you want to display. You 
can generate the following graphs from the Test Lab module:

Click Next.

Graph Description

Summary Graph Shows how many tests belong to the test sets in the 
selected folder. 

Progress Graph Shows how many tests accumulated in the test sets in the 
selected folders, at specific points during a period of time.
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 8 In the Group By box, select the field by which you want the tests to be 
grouped in the graph. For a progress graph, you can only select a field for 
which history has been enabled. For more information on enabling history 
for a field, refer to the HP Quality Center Administrator’s Guide.

 9 If you chose to create a summary graph, click Next. In the X-Axis box, select 
the field that you want to use for the X-axis.

 10 Click Finish. The Live Analysis graph is displayed in the pane that you 
selected.

The graph properties that you specified are displayed at the top of the graph. 
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Note: The data displayed in the graph reflects the filters that you have set 
for the test sets tree. For more information on filtering, see “Filtering 
Records” on page 55.

 11 Click the Full Screen View button to maximize the graph. To return to the 
normal view, click the Close button.

 12 To further analyze your data, click a segment in the graph. The Drill Down 
Results dialog box opens and displays a grid with more details. You can 
determine the column appearance and order. You can also export the 
contents of a grid as a text file, Microsoft Excel spreadsheet, Microsoft Word 
document, or HTML document. For more information, see “Exporting Data 
to a File” on page 73.

 13 To change the color of a bar in a bar graph or a line in a line graph, right-
click the bar or line, or click the corresponding entry in the graph legend. In 
the Color dialog box that opens, select the new color from one of the color 
palettes.

 14 Click the Set Graph Appearance button to customize the graph title, graph 
color, and graph display. For more graph appearance options, see “Setting 
the Graph Appearance” on page 499.

Deleting Live Analysis Graphs

You can delete a Live Analysis graph. If you have two Live Analysis graphs 
displayed for a folder and you want to create a new graph, you must first 
delete one of the existing graphs.

To delete a Live Analysis graph:

 1 Click the Remove Graph button located at the top of the graph you want to 
delete. Alternatively, choose Analysis > Live Analysis > Remove Graph.

 2 Click Yes to confirm. The graph is deleted from the selected pane and the 
Add Graph link is displayed.
498



Chapter 35 • Generating Live Analysis Graphs
Setting the Graph Appearance

After you have created your graph, you can change its titles and appearance. 
For a bar chart, you can specify the display parameters for the bars. For a line 
chart, you can specify the display parameters for the lines.

To set the graph appearance:

 1 Click the Set Graph Appearance button located at the top of the graph. 
Alternatively, choose Analysis > Live Analysis > Set Graph Appearance. The 
Graph Appearance dialog box opens and displays the General tab.

The General tab displays read-only information about the graph.

 2 Click the Titles tab to change the titles of the graph, the Y-axis, or the X-axis. 
You can click the Font button to change a title’s font, size, formatting, or 
color. You can click the Reset Titles button to reset the original titles.

 3 Click the Appearance tab to change the colors of the various components in 
your graph, to modify the orientation of the labels at the base of the graph, 
or to display the graph with a 3-D effect.
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 4 For a bar chart, click the Bar Parameters tab to specify whether you want the 
values for each bar to be displayed. You can also fix the bar width. If you 
specify that the values of each bar are to be displayed, you can change the 
data that is displayed for each bar, or its position relative to the bar. 

For a line chart, click the Line Parameters tab to specify whether you want 
the line frame to be displayed and which format you want to use for the 
date on the X-axis.
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36
Generating Project Documents

The Quality Center Document Generator enables you to create a Microsoft 
Word document containing a project’s requirements, planning, test list, test 
set folders, and defect tracking data.

Notes: 

➤ The Document Generator can only be run if Microsoft Word has been 
enabled to run macros. If you receive a security message while using the 
Document Generator, you must set the security level of Microsoft Word 
to medium or low. To do this, choose Tools > Macro > Security from the 
Word menu bar. On the Security Level tab, select the desired level of 
protection (Medium or Low), and click OK.

➤ To verify supported versions of Microsoft Word, refer to the 
HP Quality Center Installation Guide.

This chapter describes: On page:

About Using the Document Generator 502

Launching the Document Generator 504

Setting Formatting Instructions 505

Specifying Project Data 511

Generating a Project Document 535
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About Using the Document Generator

The Document Generator enables you to create a hard copy of the data 
contained in a Quality Center project. You create the document by 
performing the following tasks:

 1 Set document format.

 2 Specify document content.

 3 Generate and edit the document.

First, you set formatting instructions in order to determine how your project 
document will look. For example, you can print a company logo on each 
page of the document, create a table of contents and an index, and place test 
scripts and file attachments in the text of your document.

Next, you specify the project data that will be presented in your document. 
You can select information from the Quality Center modules. For example, 
from the Test Plan module, you can choose which folders and tests to 
include from the test plan tree, sort this data alphabetically or in a custom 
sort order, and display the data as lists or tables. 

After you have set the formatting instructions and specified the document’s 
content, you can save the document settings as a favorite view for future use 
and generate the document. After document generation is complete, you 
can view and edit the document in Microsoft Word. The information for 
each module that you select is printed in a separate chapter of the project 
document. 
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Below is a sample page from a Microsoft Word project document generated 
by the Document Generator. 
503



Chapter 36 • Generating Project Documents
Launching the Document Generator

To start the Document Generator, click the Tools button on the upper-right 
of the Quality Center window. Choose Document Generator. The 
Document Generator opens. 
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Setting Formatting Instructions 

Before you can generate a document, you set formatting instructions that 
control how the document will look and what is included in the cover page.

To set formatting instructions:

 1 Open the Document Generator. By default, the Document link is selected in 
the Document Generator tree and the Document Settings tab is displayed.

 2 Type a Title for the document, Author details, and a Description of the 
document.
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 3 Click the Options tab. 

 4 Under Include with Document, you can select the following options to 
include in the project document:

Option Description

First page The cover page of the project document. This displays the 
title of the document, the date the document was created, 
and the name of the document’s author. You specify this 
information in the Document Settings tab.

Table of contents A list of all sections in the project document.

Index An alphabetical list of all the information in the project 
document. The index appears at the end of the document.
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 5 Under Attachment Placement Options, choose where attachments will 
appear in the document: 

 6 Under Attachment Embedding Options, choose whether the project 
document contains the data from attachments as a linked icon or as 
embedded text:

 7 Under Test Script Options, choose where test scripts will appear in the 
document:

 8 Under Graph Options, choose where graphs will appear in the document:

 9 Select Do not generate a paragraph if there is no corresponding project 
information if you do not want to include empty data fields in the project 
document.

Option Description

In text Displays attachments in the main text of the document.

In appendix Places attachments in a separate appendix.

Option Description

As icons Places a link to the attachment in the document as an 
icon.

As expanded text Adds the attachment to the document as expanded text.

Option Description

In text Displays test scripts in the main text of the document.

In appendix Places test scripts in a separate appendix.

Option Description

In text Displays graphs in the main text of the document.

In appendix Places graphs in a separate appendix.
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 10 To set the image that is placed at the top of each page of the project 
document, click the Logo tab.

You can define a logo for the project document, and save the image so that 
it is available for other users in the current project. If you do not select an 
image, the Document Generator uses the HP logo in the project document.

 11 Click the Load from File button. The Open dialog box opens. 

 12 Locate the image and click Open. The image is displayed in the Logo tab. To 
unload the image, click Unload.

 13 To save the displayed image in the current project, click the Save button. To 
delete the image, click the Remove Saved button. 

 14 To load a saved image that was cleared (using the Unload button), click the 
Load from Saved button.
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 15 To set paper properties, click the Customization tab and click the Page Setup 
button.
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The Page Setup dialog box opens.

 16 Set the measurement units, margins, orientation, and paper size to be used 
for project documents. Click OK to return to the Customization tab.
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Specifying Project Data 

Select a check box in the Document Generator tree to specify project data to 
include in your project document.

Check Box Description

Document Use the Document Settings, Options, Logo, and 
Customization tabs to set formatting instructions. For 
more information, see “Setting Formatting Instructions” 
on page 505. Note that this option is always selected.

Requirements Specify which requirements, traced requirements, tests 
coverage, and linked defects to include from the 
Requirements module. For more information, see 
“Specifying Requirements Module Data” on page 512.

Business 
Components

If you use HP Business Process Testing, refer to the HP 
Business Process Testing User’s Guide.

Test Plan Expand to specify which test subject folders and which 
tests to include from the Test Plan module. For more 
information, see “Specifying Test Plan Module Data from 
the Test Plan Tree View” on page 516 and “Specifying Test 
Plan Module Data from the Test Grid View” on page 520.

Select Subject Tree to specify which test subject folders to 
include from the Test Plan module.

Select Subject Tests to specify which tests to include from 
the selected folders.

Select Test List to specify which tests to include from the 
Test Grid.
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Specifying Requirements Module Data
You use the Requirements page to specify the requirement information from 
the Requirements module that should appear in the Requirements section of 
the project document.

Note: Microsoft Word is limited to nine header levels in the table of 
contents. If the requirements tree has more than nine hierarchical levels, 
these levels will not appear in the table of contents of the generated project 
document.

Test Lab Specify which test set folders to include from the Test Lab 
module. Expand to select which test sets, tests and test 
runs to include. For more information, see “Specifying 
Test Lab Module Data” on page 524.

Select Test Sets to specify which test sets to include.

Select Tests to specify which tests to include from the 
selected test sets.

Select Runs to specify which test runs to include from the 
selected tests in a test set.

Defects Specify which defects to include from the Defects module. 
For more information, see “Specifying Defects Module 
Data” on page 533.

Check Box Description
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To specify Requirements module data:

 1 Select the Requirements check box in the Document Generator tree and 
click the Requirements link. The Requirements page is displayed.

 2 Under Requirements, select one of the following options:

Option Description

All Includes all the requirements from the requirements tree.

By status Includes only requirements with the selected status.

Selected Includes only selected requirements. Click the Filter & 
Sort button to specify the criteria for selecting 
requirements. For more information on using the Filter 
dialog box, see Chapter 3, “Working with Quality Center 
Data.”
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 3 Under Requirements Layout, select one of the following options:

 4 If you selected Full page as the Requirements Layout, you can set the 
following options:

Option Description

Full page Displays a list of the selected requirements. Click the 
Customize button to choose the information to appear in 
the document.

Tabular Displays the requirements as a table. Click the Customize 
button to open the Tabular Layout dialog box to 
customize the table. Use the Tabular Layout dialog box to 
choose the columns that will appear in the table, and set 
the column order, width, and captions.

Coverage Analysis Displays a graphical breakdown of the direct cover status 
for each requirement. Click the Customize button to open 
the Coverage Analysis dialog box to choose whether to 
display the analysis in color or black and white, the 
number of hierarchal levels to display, and whether to 
display a legend.

Option Description

Page break after 
each requirement

Inserts page breaks in the project document after each 
requirement.

Rich content Includes Microsoft Word content for each requirement.

Trace From Includes traced from requirements in the document. Click 
the Customize button to open the Tabular Layout dialog 
box to customize the traceability table. Use the Tabular 
Layout dialog box to choose the columns that will appear 
in the table, and set the column order, width, and 
captions.
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 5 To include graphs in the project document, select Graphs and select graphs 
from the graph list located at the bottom of the page. Only graphs that you 
saved as favorites are included in the list. For more information on favorite 
views, see Chapter 6, “Working with Favorite Views.”

Trace To Includes traced to requirements in the document. Click 
the Customize button to open the Tabular Layout dialog 
box to customize the traceability table. Use the Tabular 
Layout dialog box to choose the columns that will appear 
in the table, and set the column order, width, and 
captions.

Coverage Includes test coverage for the requirements in the 
document. Click the Customize button to open the 
Tabular Layout dialog box to customize the coverage 
table. Use the Tabular Layout dialog box to choose the 
columns that will appear in the table, and set the column 
order, width, and captions.

Attachments Includes requirement attachments in the document. 
Requirement attachments are files that have been 
associated with the requirement, such as text files, images, 
or URLs.

Linked defects Includes linked defects in the document. Click the 
Customize button to open the Tabular Layout dialog box 
to customize the linked defects table. Use the Tabular 
Layout dialog box to choose the defect columns that will 
appear in the table, and to set the column order, width 
and captions. You can also specify whether to display only 
defects that have been directly linked to requirements or 
to include indirectly-linked defects as well.

Option Description
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Specifying Test Plan Module Data from the Test Plan Tree 
View
You use the Subject Tree and Subject Tests pages to specify the information 
from the test plan tree view of the Test Plan module that should appear in 
the project document.

Note: Microsoft Word is limited to nine header levels in the table of 
contents. If the test plan tree has more than nine hierarchical levels, these 
levels will not appear in the table of contents of the generated project 
document.

To specify Test Plan module data from the test plan tree view:

 1 Expand the Test Plan node in the Document Generator tree. Select the 
Subject Tree check box and click the Subject Tree link. The Subject Tree 
page is displayed.
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 2 Under Tree Sort, determine the order of the test plan tree information in the 
document:

 3 Under Folders, specify which test plan tree folders you want to include in 
the document:

 4 To include folder attachments in the document, select Attachments. Folder 
attachments are files that have been associated with the folder, such as text 
files, images, or URLs.

 5 To insert page breaks in the project document after each test subject folder, 
select Page break after each folder.

Option Description

Alphabetical The contents of the folders will be organized according to 
the alphabetical order of the folders in the test plan tree. 
For example, suppose the test plan tree contains two 
folders, Automated Tests and Manual Tests. The tests in 
the Automated Tests folder will be printed before the tests 
in the Manual Tests folder.

Custom The contents of the folders will be organized according to 
the custom sort order you set for displaying test plan tree 
folders. By default, subject folders in the test plan tree 
appear in alphabetical order (by name). For example, 
suppose the test plan tree contains two folders, 
Automated Tests and Manual Tests. You can create a sort 
order that prints the tests in the Manual Tests folder 
before the tests in the Automated Tests folder. For more 
information about creating a custom sort order for the test 
plan tree, see Chapter 17, “Developing the Test Plan Tree.”

Option Description

All Includes all the folders in the test plan tree.

Selected Includes only the folders you choose from the test plan 
tree. You select the folders from the test plan tree 
displayed on the right side of the Subject Tree page.
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 6 To include graphs in the document, select Graphs and select graphs from 
the list. Only graphs you saved as favorites are included in the list. For more 
information on favorite views, see Chapter 6, “Working with Favorite 
Views.”

 7 To include test data in the project document, expand the Subject Tree node 
in the Document Generator tree. Select the Subject Tests check box and 
click the Subject Tests link. The Subject Tests page is displayed.
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 8 Under Tests, specify which tests you want to include in the document:

 9 To include design steps from the test, select Design steps.

Under Layout, specify how design steps will be organized:

Under Properties, specify what to include from the design steps:

 10 To include test scripts in the document, select Test scripts.

Option Description

All tests Includes all the tests from the selected test plan tree 
folders.

Selected Includes only selected tests. Click the Filter & Sort button 
to specify the criteria for selecting tests. For more 
information on using the Filter dialog box, see Chapter 3, 
“Working with Quality Center Data.”

Option Description

Full page Displays a list of all the design steps in a test. Click the 
Customize button to choose the information to appear in 
the document.

Tabular Displays all the design steps in a test as a table. Click the 
Customize button to open the Tabular Layout dialog box 
to customize the table. Use the Tabular Layout dialog box 
to choose the columns that will appear in the table, and 
set the column order, width, and captions.

Option Description

Recursive Includes called tests from the design steps.

Attachments Includes all design step attachments.
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 11 If you use Business Process Testing, you can include the layout of the 
components included in the tests. Select Components detailed layout and 
choose what to include in the detailed layout:

➤ To include component steps, select Component steps. Click the 
Customize button to open the Tabular Layout dialog box to customize 
the component steps table. Use the Tabular Layout dialog box to choose 
the defect columns that will appear in the table, and to set the column 
order, width and captions. 

➤ To include the iteration list, select Iterations list.

 12 To include test attachments in the document, select Attachments.

 13 To display a list of all the changes made to the tests, and which user made 
each change, select History.

 14 To insert page breaks in the project document after each test, select Page 
break after each test.

 15 To include a table of linked defects, select Linked defects. Click the 
Customize button to open the Tabular Layout dialog box to customize the 
linked defects table. Use the Tabular Layout dialog box to choose the defect 
columns that will appear in the table, and to set the column order, width 
and captions. You can also specify whether to display only defects that have 
been directly linked to tests or to include indirectly-linked defects as well.

Specifying Test Plan Module Data from the Test Grid View
You use the Test List page to specify the tests from the Test Grid that should 
appear in the project document. For more information about the Test Grid, 
see Chapter 3, “Working with Quality Center Data.”
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To specify Test Plan module data from the Test Grid view:

 1 Expand the Test Plan node in the Document Generator tree. Select the Test 
List check box and click the Test List link. The Test List page is displayed.

 2 Under Tests, specify which tests you want to include in the document:

Option Description

All tests Includes all the tests from the Test Grid.

Selected Includes only selected tests. Click the Filter & Sort button 
to specify the criteria for selecting tests. For more 
information on using the Filter dialog box, see Chapter 3, 
“Working with Quality Center Data.”
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 3 Under Test Layout, specify how the tests will be organized:

 4 To insert page breaks in the project document after each test, select Page 
break after each test.

 5 If you selected Full page as the Test Layout, you can select Design steps to 
include design steps from the test.

Under Layout, specify how design steps will be organized:

Under Properties, specify what to include from the design steps:

Option Description

Full page Displays a list of all the tests in the project. Click the 
Customize button to choose the information to appear in 
the document.

Tabular Displays all the tests as a table. Click the Customize 
button to open the Tabular Layout dialog box to 
customize the table. Use the Tabular Layout dialog box to 
choose the columns that will appear in the table, and set 
the column order, width, and captions.

Option Description

Full page Displays a list of all the design steps in a test. Click the 
Customize button to choose the information to appear in 
the document.

Tabular Displays all the design steps in a test as a table. Click the 
Customize button to open the Tabular Layout dialog box 
to customize the table. Use the Tabular Layout dialog box 
to choose the columns that will appear in the table, and 
set the column order, width, and captions.

Option Description

Recursive Includes called tests from the design steps.

Attachments Includes all design step attachments.
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 6 If you selected Full page as the Test Layout, you can also set the following 
options:

 7 To include graphs in the document, select Graphs and select graphs from 
the graph list located at the bottom of the page. Only graphs you saved as 
favorites are included in the list. For more information on favorite views, see 
Chapter 6, “Working with Favorite Views.”

Option Description

Test scripts Includes test scripts in the document.

Components 
detailed layout

If you use HP Business Process Testing, you can include 
the detailed layout of the components included in the 
tests. Choose what to include in the detailed layout:

Component steps: Includes component steps. Click the 
Customize button to open the Tabular Layout dialog box 
to customize the component steps table. Use the Tabular 
Layout dialog box to choose the defect columns that will 
appear in the table, and to set the column order, width 
and captions. 

Iterations list: Includes the iteration list.

Attachments Includes test run attachments in the document.

Linked defects Includes a table of linked defects. Click the Customize 
button to open the Tabular Layout dialog box to 
customize the linked defects table. Use the Tabular Layout 
dialog box to choose the defect columns that will appear 
in the table, and to set the column order, width and 
captions. You can also specify whether to display only 
defects that have been directly linked to tests or to include 
indirectly-linked defects as well.

History Displays a list of all the changes made to the tests, and 
who made them.
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Specifying Test Lab Module Data
You use the Test Lab, Test Sets, Tests, and Runs pages to specify the 
information from the Test Lab module that should appear in the project 
document.

Note: Microsoft Word is limited to nine header levels in the table of 
contents. If the test sets tree has more than nine hierarchical levels, these 
levels will not appear in the table of contents of the generated project 
document.

To specify Test Lab module data:

 1 Select the Test Lab check box in the Document Generator tree and click the 
Test Lab link. The Test Lab page opens.
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 2 Under Folders, specify which test lab folders you want to include in the 
document:

 3 To include test set attachments, select Attachments.

 4 To insert page breaks in the project document after each test sets folder, 
select Page break after each test sets folder.

 5 To include graphs in the document, select Graphs and select graphs from 
the graph list located at the bottom of the page. Only graphs you saved as 
favorites are included in the list. For more information on favorite views, see 
Chapter 6, “Working with Favorite Views.”

Option Description

All Includes all the folders in the test sets tree.

Selected Includes only the folders you choose from the test sets 
tree. You select the folders from the test sets tree displayed 
under Folders.
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 6 Expand the Test Lab node in the Document Generator tree.

To include test set data in the project document, select the Test Sets check 
box and click the Test Sets link in the Document Generator tree. The Test 
Sets page is displayed.

 7 Under Available Test Sets, specify which test sets you want to include in the 
document:

Option Description

All Includes all the test sets in the selected test set folder.

Selected Includes only selected test sets. Click the Filter & Sort 
button to specify the criteria for selecting the test sets. For 
more information on using the Filter dialog box, see 
Chapter 3, “Working with Quality Center Data.”
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 8 To include linked defects, select Linked defects. Click the Customize button 
to customize the linked defects. Use the Tabular Layout dialog box to choose 
the defect columns that will appear in the table, and to set the column 
order, width and captions. You can also specify whether to display only 
defects that have been directly linked to test sets or to include indirectly-
linked defects as well.

 9 To insert page breaks in the project document after each test set, select Page 
break after each test set.

 10 To include graphs in the document, select Graphs, and select graphs from 
the list. Only graphs you saved as favorites are included in the list. For more 
information on favorite views, see Chapter 6, “Working with Favorite 
Views.”

 11 Expand Tests Sets in the Document Generator tree.

To include test data in the project document, select the Tests check box and 
click the Tests link. The Test Page is displayed.
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 12 Under Tests, specify which tests you want to include in the document:

 13 Under Test Layout, specify how the tests will be organized:

Option Description

All tests Includes all the tests in the selected test set.

Selected Includes only selected tests. Click the Filter & Sort button 
to specify the criteria for selecting tests. For more 
information on using the Filter dialog box, see Chapter 3, 
“Working with Quality Center Data.”

Option Description

Full page Displays test information as a list. Click the Customize 
button to choose the information to appear in the 
document.

Tabular Displays test information as a table. Click the Customize 
button to open the Tabular Layout dialog box to 
customize the table. Use the Tabular Layout dialog box to 
choose the columns that will appear in the table, and set 
the column order, width, and captions.

Note: If you select Tabular, you cannot include test runs 
in the document.
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 14 If you selected Full page as the Test Layout, you can also set the following 
options:

Option Description

Test scripts Includes test scripts in the document.

Components 
detailed layout

If you use HP Business Process Testing, you can include 
the detailed layout of the components included in the 
tests. Choose what to include in the detailed layout:

Component steps: Includes component steps. Click the 
Customize button to open the Tabular Layout dialog box 
to customize the component steps table. Use the Tabular 
Layout dialog box to choose the defect columns that will 
appear in the table, and to set the column order, width 
and captions.

Iterations list: Includes the iteration list.

Attachments Includes test run attachments in the document.

Linked defects Includes linked defects as a table. Click the Customize 
button to customize the linked defects table. Use the 
Tabular Layout dialog box to choose the defect columns 
that will appear in the table, and to set the column order, 
width and captions. You can also specify whether to 
display only defects that have been directly linked to tests 
or to include indirectly-linked defects as well.

History Displays a list of all the changes made to the tests, and 
who made them.

Page break after 
each test

Inserts page breaks in the project document after each 
test.
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 15 To include test run data in the project document, expand Tests in the 
Document Generator tree. Select the Runs check box and click the Runs link. 
The Runs page is displayed. 

 16 Under Runs, choose one of the following options:

Option Description

Last run Includes only the last run of the test.

All runs Includes all runs of the test. 

Selected Includes only selected runs in the document. Click the 
Filter & Sort button to specify the criteria for selecting 
tests. For more information on using the Filter dialog box, 
see Chapter 3, “Working with Quality Center Data.”
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 17 Under Run Layout, choose one of the following options:

 18 If you selected Full page as the Run Layout, you can select Run steps to 
include a list of run steps in the document.

If you are including run steps in the document, choose one of the following 
options under Layout:

You can also select Defects to include a table of defects linked with run 
steps. Click the Customize button to open the Tabular Layout dialog box to 
customize the linked defects table. Use the Tabular Layout dialog box to 
choose the defect columns that will appear in the table, and to set the 
column order, width and captions. You can also specify whether to display 
only defects that have been directly linked to run steps or to include 
indirectly-linked defects as well.

If you are including run steps in the document, you can select Attachments 
to include run steps attachments in the document.

Option Description

Full page Displays a list of all the test runs. Click the Customize 
button to choose the information to appear in the 
document.

Tabular Displays all the test runs as a table. Click the Customize 
button to open the Tabular Layout dialog box to 
customize the table. Use the Tabular Layout dialog box to 
choose the columns that will appear in the table, and set 
the column order, width, and captions.

Option Description

Full page Displays a list of all the steps in a run. Click the Customize 
button to choose the information to appear in the 
document.

Tabular Displays all the steps in a run as a table. Click the 
Customize button to open the Tabular Layout dialog box 
to customize the table. Use the Tabular Layout dialog box 
to choose the columns that will appear in the table, and 
set the column order, width, and captions.
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 19 If you selected Full page as the Run Layout, you can set the following 
options:

Option Description

Linked defects Includes a table of defects linked with test runs. Click the 
Customize button to open the Tabular Layout dialog box 
to customize the linked defects table. Use the Tabular 
Layout dialog box to choose the defect columns that will 
appear in the table, and to set the column order, width 
and captions. You can also specify whether to display only 
defects that have been directly linked to test runs or to 
include indirectly-linked defects as well.

Attachments Includes test run attachments in the document.
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Specifying Defects Module Data
You use the Defects page to specify the defect information from the Defects 
module that should appear in the Track Defects section of the project 
document.

To specify Defects module data:

 1 To include defect data in the project document, select the Defects check box 
and click the Defects link in the Document Generator tree. The Defects page 
is displayed.
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 2 Under Defects, choose one of the following options:

 3 Under Defects Layout, choose one of the following options:

 4 If you selected the Full page as the Defects Layout, you can also set the 
following options:

Option Description

All defects Includes all the defects from the Defects Grid.

Selected Includes only selected defects. Click the Filter and Sort 
button to specify the criteria for selecting defects. For 
more information on using the Filter dialog box, see 
Chapter 3, “Working with Quality Center Data.”

Option Description

Full page Displays all the selected defects as a list. Click the 
Customize button to choose the information to appear in 
the document.

Tabular Displays all the selected defects as a table. Click the 
Customize button to open the Tabular Layout dialog box 
to customize the table. Use the Tabular Layout dialog box 
to choose the columns that will appear in the table, set 
the column order, width, and captions.

Option Description

Attachments Includes defect attachments in the document.

Linked defects Includes linked defects as a table. Click the Customize 
button to open the Tabular Layout dialog box to 
customize the linked defects table. Use the Tabular Layout 
dialog box to choose the defect columns that will appear 
in the table, and to set the column order, width and 
captions. You can also specify whether only direct links 
will be displayed.
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 5 To include graphs in the document, select Graphs and select graphs from 
the list. Only graphs you saved as favorites are included in the list. For more 
information on favorite views, see Chapter 6, “Working with Favorite 
Views.”

Generating a Project Document

After you set formatting instructions and specify project data, you can 
generate the project document. You save the document as a Microsoft Word 
file.

Tip: You can generate a preview project document that enables you to 
quickly see how the document will look, without all the detail included. To 
generate a preview project document, click the Preview button. 
Quality Center opens Microsoft Word and displays the preview project 
document.

To generate a document:

 1 If there are open project document files from previous runs of the 
Document Generator, close the files.

 2 Click the Full Document button. The Save As dialog box opens.

Linked entities Includes linked entities as a table. Click the Customize 
button to open the Tabular Layout dialog box to 
customize the linked entities table. Use the Tabular Layout 
dialog box to choose the defect columns that will appear 
in the table, and to set the column order, width and 
captions. You can also change the captions and the width 
of the table columns.

History Displays a list of all the changes made to the defects.

Page break after 
each defect

Inserts page breaks in the project document after each 
defect.

Option Description
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 3 In the Save As box, set the location for the document in your network file 
system.

 4 In the File name box, assign the document a name.

 5 Click the Save button. 

Quality Center begins generating the document and a dialog box displays 
document creation progress. To cancel document generation, click the Stop 
button.

When the process is complete, Microsoft Word opens and displays the 
document.

If the generated document contains links to attachments, a folder is created 
in the same location as the document, and the attachment files are copied 
to this folder. The name of the attachment folder is the name of the 
document with the suffix “_Attachments”. If you send the document to 
someone, you can send the attachment folder along with it so that the 
recipient can access the attachments by using the links.
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Generating Excel Reports

You can generate Excel reports that enable you to export Quality Center 
data to Microsoft Excel and analyze the data from within Excel.

Note: To verify supported versions of Microsoft Excel, refer to the 
HP Quality Center Installation Guide.

This chapter describes: On page:

About Generating Excel Reports 538

Launching The Excel Report Generator 539

Creating Excel Reports 540

Adding Parameters 548

Generating Reports 551

Managing Excel Reports 552
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About Generating Excel Reports

You can export Quality Center data to Microsoft Excel. This enables you to 
use Excel to analyze your data and present it in graphical form. A report 
consists of a set of data defined by SQL queries on the project database. You 
can also run a Visual Basic script on the extracted data to process and 
analyze the data. 

For example, you could create a pivot table to summarize Defects module 
data, such as to display in tabular format the number of defects assigned to 
different users with different statuses.

You can also create a report with parameters. This enables you to create a 
more flexible report that you only need to create once but can be used in a 
number of different contexts. 

After you have created a report, you can delete it, rename it, duplicate it, or 
export its definition to an XML file. You can also import a report definition 
that has previously been exported to an XML file.
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Launching The Excel Report Generator

You create, generate, and manage reports in the Excel Report Generator. To 
open the Excel Report Generator, click the Tools button on the upper-right 
of the Quality Center window, and select Excel Report Generator.

Note: Most of the Excel Reports functionality is unavailable if you do not 
belong to a user group that has the necessary permissions. For more 
information on user groups and permissions, see the HP Quality Center 
Administrator’s Guide.
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The Excel Report Generator consists of the following key elements:

➤ Excel Reports toolbar. Contains buttons for commands commonly used 
when creating and modifying Excel reports.

➤ Excel Reports tree. Located in the left pane, displaying available reports for 
the project.

➤ General tab. Contains basic data about a report.

➤ Query tab. Enables you to define and test SQL queries that extract data from 
the Quality Center project database to Excel.

➤ Post-processing tab. Enables you to define a Visual Basic script to run in 
Excel after report data has been exported.

➤ Generation Settings tab. Enables you to define settings for generating a 
report.

Creating Excel Reports

To create an Excel report, you follow the following steps:

➤ You first add the report to the Excel Reports tree. For more information, see 
“Adding Reports” on page 541.

➤ You then define which data to include in the report by defining an SQL 
query to extract the data from the project database. For more information, 
see “Creating SQL Queries” on page 543.

➤ You can also optionally include a Visual Basic script to process the data in 
Excel after it has been exported from Quality Center. For more information, 
see “Creating a Post-processing Script” on page 546.

After you have defined these settings, you can generate the report. For more 
information on generating reports, see “Generating Reports” on page 551.
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Adding Reports
You begin report creation by adding a report to the Excel Reports tree.

To add a report:

 1 Click the Tools button on the upper-right of the Quality Center window, 
and select Excel Report Generator. The Excel Report Generator opens.

 2 In the Excel Reports tree, select the folder in which you want to create the 
report:

➤ Public. Reports in this folder are available to all users of the project.

➤ Private. Reports in this folder are available only to the user who created 
them.

Click the Add Excel Report button. The New Excel Report dialog box opens.

 3 In the Excel Report Name box, type a name for your report and click OK. 
Note that a report name cannot include the following characters: / \ ? * = < 
> | : . " ' %

The report is added to the Excel Reports tree.
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 4 Click the General tab. The General tab displays general settings for the 
report.

 5 In the Designer box, select the name of the report designer. By default, your 
user name is displayed.

 6 In the Status box, select the status of your report. 

The report status informs other users whether the report is ready to 
generated. The following options are available for the report status:

➤ Ready. Indicates that the report is ready to be generated. 

➤ Not Ready. Indicates that the report is not ready to be generated. If a user 
tries to generate a report with this status, a warning message displays.

 7 In the Description box, type a description for your report. You can change 
how the description is formatted using the options in the formatting 
toolbar. If this toolbar is not available, right-click the Description box and 
select Toolbar Visible.

 8 You can now define SQL queries to extract data from your Quality Center 
project. For more information, see “Creating SQL Queries” on page 543.
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Creating SQL Queries
After you have added a report to the Excel Reports tree, you must define 
which project data you want to include in the report. You define this data by 
creating SQL queries to extract the data.

Important: It is recommended that you run only queries that extract data 
from the project database. You should not run queries that alter the project 
database by adding, modifying, or deleting database records.

By default, to ensure that your queries are valid and do not alter the project 
database, Quality Center checks the following:

➤ that the query starts with the command SELECT.

➤ that the query contains only one SQL statement.

➤ that the query does not contain any of the following commands (except 
in comments): INSERT, DELETE, UPDATE, DROP, CREATE, COMMIT, 
ROLLBACK, ALTER, EXEC, EXECUTE, MERGE, GRANT, REVOKE, SET, INTO, 
or TRUNCATE.

You can customize whether this verification is performed, and how it is 
performed, using the SQL_QUERY_VALIDATION_ENABLED and 
SQL_QUERY_VALIDATION_BLACK_LIST parameters in Site Administration. 
For more information, see the HP Quality Center Administrator’s Guide.
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To create an SQL query:

 1 In the Excel Reports tree, select a report. Click the Query tab. 

The Query tab consists of the following panes and tabs:

➤ SQL pane. Contains the SQL statements for the queries in the report.

➤ Query Parameters tab. Contains a list of parameters for the query.

➤ Query Results tab. Contains the results of tests of the query.

➤ Entities pane. Contains a list of Quality Center database fields and 
entities that you can add to the query. You can view fields and entities by 
their name, their database column name, or by both. To change the view, 
click the Entities View button and select a view.

 2 In the SQL pane, type an SQL statement to define the data set you want to 
use for your report.

SQL pane

Entities pane
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Notes: 

➤ You must write the SQL statement using the version of SQL used by the 
project database. To view the database type used for your project 
database, click the Database Type button.

➤ The @ and \ characters have a special meaning and are not read literally 
when running SQL statements on the project database. If you want these 
characters to be read literally, you should replace @ by \@ and \ by \\. 
For example, if you want the statement 
SELECT * FROM BUG WHERE BUG.BG_SUMMARY = ‘@parameter@’ 
to be run literally on the Quality Center database, type 
SELECT * FROM BUG WHERE BUG.BG_SUMMARY = ‘\@parameter\@’.

 3 You can add a project entity to your SQL statement. The following options 
are available:

➤ To add a project entity without a column alias, double-click an entity in 
the Entities pane, or select an entity and click the Add Entity to Query 
button. 

➤ To add a project entity with the column alias defined by the entity title, 
select the entity you want to add. Click the Add Entity to Query arrow 
and choose Add Entity to Query with Entity Title as Alias.

The entity is added to your SQL statement at the current cursor location.

 4 You can add a parameter to your SQL statement. For more information, see 
“Adding Parameters” on page 548.

 5 You can test the query and view the results of the test in the Query Results 
tab. You can choose to view all the results of the query or only the first ten 
records:

➤ Click Run Query to view all the results of the query in the Query Results 
tab. If your query contains parameters, you are asked to type a value for 
each parameter, or confirm the default value.

➤ Click Test Query to display only the first ten records from the results of 
the query. If your query contains parameters, Quality Center uses the 
default values for the parameters.
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 6 You can search for text in your query. To search for text, type the string you 
want to search for in the Find box and click the Find button.

 7 To add a new query, click the Add Query button. The query is added as a 
new tab to the SQL pane with the default name Sheet<number>. The results 
from each query will be displayed in a separate Excel worksheet.

 8 You can rename a query. To rename a query, select the query and click the 
Rename button. In the Rename Sheet Name dialog box, type the new name 
and click OK. The Excel worksheet containing the data extracted by the 
query will have the same name as the query.

 9 To delete a query, select the query and click the Delete button. Alternatively, 
right-click the query and choose Delete. Click Yes to confirm.

Creating a Post-processing Script
You can create a Visual Basic script to run after the data is exported to Excel. 
You use this script to manipulate the data in Excel. For example, you could 
present requirements data in Excel as a pivot table, you could perform 
calculations on defects data to calculate the average time an open defect 
takes to be fixed, or you could create a graph based on exported data.

To create a post-processing script:

 1 In the Excel Reports tree, select a report. Click the Post-processing tab.
546



Chapter 37 • Generating Excel Reports
 2 In the script editor box, type the Visual Basic script you want to run after the 
data defined in your query is imported to Excel. You should base this script 
on the template script already displayed in the Script Editor box. For further 
guidelines for creating a post-processing script, see “Guidelines for Creating 
a Post-Processing Script” on page 547.

 3 To run the post-processing script after the data is exported to Excel, select 
Run post-processing. If you do not select this check box, the script is not 
run when you generate the report.

 4 You can search for text in your post-processing script. To search for text, 
type the string you want to search for in the Find box and click the Find 
button.

Guidelines for Creating a Post-Processing Script

When writing the post-processing script, consider the following guidelines:

➤ Before you run a post-processing script, you must configure your Microsoft 
Excel security settings so that Excel can run the script. In Excel, choose Tools 
> Macro > Security. The Security dialog box opens. In the Security Level tab, 
select Low. In the Trusted Publishers tab, select Trust access to Visual Basic 
Project.

➤ Your post-processing script must contain a Sub procedure named 
QC_PostProcessing. This procedure serves as the entry point to your script. 
This procedure cannot return a value and cannot take any arguments.

➤ Before you can work with the report data in Excel, you must first define the 
range containing the report data. You define this range in two steps: 

➤ You first define the worksheet containing the report data by creating a 
worksheet object containing the data. For example, if the worksheet is 
named Sheet1, you can use the statement Set MainWorksheet = 
ActiveWorkbook.Worksheets(“Sheet1”).

➤ After you define the worksheet containing the report data, you define the 
range containing the data by creating a range object containing the data. 
For example, you if defined the worksheet object with name 
MainWorksheet, you can use the statement Set DataRange = 
MainWorksheet.UsedRange. 

After you define this range, you can manipulate the data contained in it 
using Visual Basic code.
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➤ New Quality Center projects contain several default reports. You can use the 
scripts in these reports as a basis for developing your own scripts.

Adding Parameters

You can include parameters in the SQL query for a report. For each 
parameter, you can assign a default value. When you generate the report, 
you are prompted to enter the value of the parameter, or confirm the default 
value. Alternatively, you can choose to always use the default value, without 
the need to be prompted by Quality Center each time you generate the 
report.

For example, suppose you want to create a report that displays a graph of 
the number of requirements added to your project over a period of time. 
You might want to run the report several times, each time for a different 
period of time. You can avoid the need to create multiple reports by creating 
a single report with parameters for the start date and end date of the period. 
Each time you generate the report, you are prompted to enter the start and 
end dates for the period.

You first add parameters for each report to the Parameters list. You can add 
global parameters that are accessible to all queries in a report, or you can 
add parameters that can only be used in particular queries. After you have 
added parameters to the Parameters list, you can add parameters from the 
Parameters list to the queries in the report.

Adding Parameters to the Parameters List
Before you can add a parameter to a query, you must add it to the 
Parameters list.

To add a parameter to the Parameters list:

 1 In the Excel Reports tree, select a report. Click the Query tab.
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 2 In the Query Parameters tab, click the New Parameter button. The New 
Parameter dialog box opens.

 3 In the Parameter Name box, type a name for the parameter.

 4 In the Default Value box, type a default value for the parameter. If you 
choose not to prompt for the parameter’s value when generating the report, 
this value is used. It is also displayed as the default you if choose to prompt 
for the parameter’s value.

 5 In the Description box, type a description for the parameter.

 6 Select the Hide On Run check box if you do not want Quality Center to 
prompt for the parameter’s value when you generate the report.

 7 Select the Global Parameter check box to make the parameter available in 
all queries in your report. If you do not select this check box, the parameter 
is only available in the current query.

 8 Click OK. The parameter is added to the Parameters list.

 9 To delete a parameter from the Parameters list, select the parameter and 
click Delete. Click Yes to confirm.
549



Chapter 37 • Generating Excel Reports
Note: If you delete a parameter that is in use in a report query, queries 
containing the parameter will not be valid. If you try to delete such a 
parameter from the Parameters list, a warning message displays.

 10 To edit a parameter in the Parameters list, select the parameter and click Edit 
Parameter. In the Edit Parameter dialog box, edit the parameter settings and 
click OK.

Adding a Parameter to an SQL Query
After you have added a parameter to the Parameters list, you can add it to 
your SQL query.

To add a parameter to an SQL query:

 1 In the Excel Reports tree, select a report. Click the Query tab.

 2 In the SQL pane, located in the upper left of the Query tab, place the cursor 
in the location where you want to add the parameter.

 3 In the Query Parameters tab, select a parameter from the Parameters list, and 
click the Add Parameter to Query button. The parameter is added to the 
query.

Note: For a parameter representing a text value, you must manually add 
single quotes (') around the parameter in the SQL pane. For example, if the 
SQL pane contains the phrase WHERE BUG.BG_DETECTED_BY = 
@name@, you must replace the text @name@ with '@name@'.
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Generating Reports

After you have created your report, you can generate the report to extract 
the data you specified in the SQL queries from the project database and 
export it to Excel.

To generate a report:

 1 In the Excel Reports tree, select a report. Click the Generation Settings tab.

 2 If you want Quality Center to open the report in Excel after it is generated, 
select the Open Report check box.

 3 In the Save report as target file box, type the location and name of the 
Excel file to which you want the data to be exported. You can click the 
browse button to select a location from the Save Report dialog box.

 4 Click the Generate Excel Report button to generate the report.

➤ If the status of the report is Not Ready, you are informed of this and 
asked if you want to generate the report anyway. Click Yes to generate 
the report.

➤ If the report query contains parameters, the Report Parameters dialog box 
opens. Type the parameter values in the Value column and click OK.

The report is saved in the location you defined. If you chose to open the 
report after it is generated, Excel opens and displays the report. If you did 
not choose to open the report after it is generated, a confirmation message 
displays.
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Managing Excel Reports

After you have created an Excel report, you can delete, rename, or duplicate 
it. You can also export and import a report definition.

Deleting Excel Reports
You can delete an Excel report.

To delete an Excel report:

 1 In the Excel Reports tree, select a report and click the Delete button. 
Alternatively, right-click the report and choose Delete.

 2 Click Yes to confirm.

Renaming Excel Reports
You can rename an Excel report.

To rename an Excel report:

 1 In the Excel Reports tree, select a report and click the report name.

 2 Type the new name for the report and press ENTER.

Duplicating Excel Reports
You can duplicate an Excel report. This enables you to base a new Excel 
report on an existing report by duplicating the existing report and making 
the necessary modifications to the resulting copy.

To duplicate an Excel report

 1 In the Excel Reports tree, select a report.

 2 Click the Duplicate Excel Report button. Alternatively, right-click the report 
and choose Duplicate Excel Report. A copy of the report is created in the 
same location in the Excel Reports tree.
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Exporting Excel Report Definitions
You can export the definition for an Excel report to an XML file. This 
enables you to transfer configuration settings for an Excel report between 
Quality Center projects, or to archive a definition for an Excel report for 
future use.

To export an Excel report definition:

 1 In the Excel Reports tree, select a report and click the Export Excel Report 
Definition button. Alternatively, right-click the report and choose Export 
Excel Report Definition. The Export Excel Report Definition dialog box 
opens.

 2 In the Save in box, choose a location for the XML file.

 3 In the File name box, type a name for the XML file. 

 4 Click Save.

Importing Excel Report Definitions
You can import an Excel report definition that has previously been saved as 
an XML file.

To import an Excel report definition:

 1 In the Excel Reports tree, select the folder to which you want the report to 
be imported and click the Import Excel Report Definition button. 
Alternatively, right-click the location to which you want the report to be 
imported and choose Import Excel Report Definition. The Import Excel 
Report Definition dialog box opens.

 2 In the File name box, select the report definition XML file.

 3 Click Open. The report definition is added to the Excel Reports tree in the 
location you specified.
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A
Working with VAPI-XP 

The VAPI-XP open test architecture API testing tool enables you to create 
new testing scripts, or edit existing scripts, and integrate them into your 
testing process. 

This chapter describes: On page:

About Working with VAPI-XP 558

Creating VAPI-XP Test Scripts 558

Editing VAPI-XP Test Scripts 568

Using the VAPI-XP API 573

Running VAPI-XP Tests in Debug Mode 578

Running VAPI-XP Tests in Test Mode 579

Debugging VAPI-XP Test Scripts 581
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About Working with VAPI-XP

The VAPI-XP testing tool enables you to create new testing scripts using 
Microsoft VBScript, Microsoft JavaScript (JScript version), PerlScript, and 
PythonScript, and integrate these scripts into your testing process. Using 
VAPI-XP test scripts, you can test COM/DCOM servers, SOAP-based Web 
services, Java APIs (such as Java classes and EJBs), and console applications. 
You can also use VAPI-XP to create a LoadRunner virtual user.

In addition, VAPI-XP is fully integrated with Quality Center, enabling you to 
design your VAPI-XP test script to call any Quality Center test or test set, and 
execute it as part of your own script. This allows you to build a more 
advanced test set execution flow, in which you can filter tests in a test set 
during execution, based on the status or type of each test.

VAPI-XP is also fully integrated with the Quality Center Open Test 
Architecture API. All open test architecture API classes and methods can be 
referenced from the VAPI-XP user interface so that you can easily include 
them in your test script. 

Creating VAPI-XP Test Scripts

You create a VAPI-XP test script from the test plan tree in the Test Plan 
module.

Note: You can also convert a manual test to a VAPI-XP test. In the Design 
Steps tab, click the Generate Script button and select VAPI-XP-TEST. 
Quality Center creates a VAPI-XP test script that includes code for the steps 
that you defined. It also includes code for called tests that were part of the 
original manual test. For more information on manual tests, see Chapter 19, 
“Building Tests.”
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To create a VAPI-XP test script:

 1 Choose a subject folder in the test plan tree.

 2 Click the New Test button or choose Tests > New Test. The Create New Test 
dialog box opens.

 3 In the Test Type box, select VAPI-XP-TEST.

 4 In the Test Name box, type a name for the test. Note that a test name 
cannot include the following characters: \ / : " ? < > | * % ‘

Click OK.

Note: If required test fields were defined in the Project Customization 
window, the Required Test Fields dialog box opens. Select values for the 
required fields, and click OK.
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The HP VAPI-XP Wizard opens.

 5 In the Script Language box, select a script language. 

Note: To create a VAPI-XP test script using ActiveState’s ActivePython or 
ActivePerl scripts, you must install the script language on your machine. 
From the Help menu in the Test Script tab, select ActivePython Home Page 
or ActivePerl Home Page, and follow the appropriate installation 
instructions.

Microsoft’s VBScript and JScript are usually installed with Internet Explorer. 
If they are not installed on your machine, select VBScript Home Page or 
JScript Home Page from the Help menu in the Test Script tab, and follow the 
appropriate installation instructions.

 6 In the Script Name box, type a name for the VAPI-XP test script.
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 7 If you selected VBScript or JavaScript as your test scripting language, you can 
select Create HP LoadRunner Vuser to create a LoadRunner virtual user 
script that can be run in the LoadRunner Controller. 

Note: To run this virtual user in the Controller, you must install the latest 
version of the HP Quality Center Connectivity Add-in on your LoadRunner 
client machine. This add-in is available from the HP Quality Center Add-ins 
page. For more information, refer to the HP Quality Center Installation Guide.

 8 Click Next to continue creating the test script using the HP VAPI-XP Wizard. 
The following dialog box opens.

Note: In each dialog box, you can click Finish to close the Wizard and 
continue creating the test script in the Test Script tab.
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 9 Select the type of test you want to create.

 10 Click Next to continue creating the test script using the HP VAPI-XP Wizard. 

➤ If you selected COM/DCOM Server Test, choose the Program IDs of the 
COM/DCOM objects in your machine’s registry that you want to test, 
and click the + button. Each selected COM/DCOM object and its 
description is displayed in the box below.
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➤ If you selected Java Class Test, type the full name of the Java class that 
you want to test in the Java Class Name box, and click the + button. The 
Java class name you typed appears in the text box below.

Note: You can only use a Java class that has a public constructor that does 
not take arguments.
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Under Java Virtual Machine, select Other JVM if you do not want to use 
the default Microsoft Java virtual machine, and specify the following: 

➤ JVM Runtime. The Java virtual machine runtime executable file 
(usually java.exe).

➤ Java Compiler. The executable file that recompiles the bytecode at the 
execution platform (usually javac.exe).

➤ Classpath. A list of additional (non-standard) Java libraries, separated 
by semi-colons (;), required to run the specified Java application. Note 
that if you do not specify the Java classpath, Quality Center uses the 
environment variable CLASSPATH.

➤ JVM Parameters. The parameters for the Java virtual machine run-time 
executable file.

If the Microsoft Java virtual machine (required to support the debugging 
of your test script) is not installed on your machine, run the 
msjavx86.exe file located in the Redist directory on your 
HP Quality Center DVD.

To use other Java virtual machines, install the Bean Scripting Framework 
(BSF) Java package on the client machine. Unzip the bsf-bin-22.zip file 
located in the Redist directory on your HP Quality Center DVD. In the 
unzipped file, locate the path of the bsf.jar file and add it to the 
CLASSPATH field. Ensure that the CLASSPATH environment variable 
contains a dot (.) to specify the current directory.

When working with other Java virtual machines, add the location of the 
BSF DLLs to the system path, as follows: In the Control Panel, choose 
System > System Properties, and then click the Advanced tab. Click the 
Environment Variables button, and in the System Variables area, edit the 
Path parameter by adding the path of the following DLLs: msvcp60.dll, 
bsfactivescriptengine.dll, and bsfactivescriptengine_g.dll. Click OK.
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➤ If you selected Web Service (SOAP) Test, choose the SOAP client library 
from the SOAP Client Library list, and type or select the URL you want to 
test in the Web Service Definition box. Click the + button. The URL you 
typed appears in the text box below.

Note: Two SOAP client libraries are supported: Microsoft SOAP SDK and 
PocketSOAP. Note that even if you choose to work with PocketSOAP, you 
must install Microsoft SOAP SDK to parse Web services. If Microsoft SOAP 
SDK is not already installed on your machine, run the SoapToolkit30.exe file 
located in the Redist directory on your HP Quality Center DVD.
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➤ If you selected Console Application Test, type the name of the 
application file you want to test in the Application Executable File box, 
and its parameters in the Command Line Parameters box. 

Clear the Use VAPI-XP Output instead of Standard Output box if you do 
not want to replace the standard output with the VAPI-XP output 
window.

In the Application Timeout box, type the time, in milliseconds, for 
Quality Center to wait for the application to finish running. Note that if 
the timeout is set to -1, Quality Center waits an infinite amount of time 
for the application to finish running.

Click the + button. The data you entered appears in the text box below.
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 11 Click Next to continue creating the test script using the HP VAPI-XP Wizard. 
The following dialog box opens.

 12 In the Service list, select the functions you want to add to your test script. 
Double-click each function, or drag and drop it, to add it to your script code. 
The function is added to the box below the Service list.

 13 If required, enter additional parameters or add extra code to the script in the 
lower pane.

 14 Click Finish. The new test appears in the test plan tree under the subject 
folder you selected.

Note: You can choose to add details and attachments to the VAPI-XP test 
you created, or define requirements coverage. For information, see 
Chapter 17, “Developing the Test Plan Tree.” 
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Editing VAPI-XP Test Scripts

After you have created a VAPI-XP test script using the HP VAPI-XP Wizard, 
you can edit it in the Test Script tab.

Tip: You can display the Test Script tab in a separate window by selecting 
View > Window Screen, or clicking the Window Screen button.

To edit a VAPI-XP test script:

 1 In the test plan tree, select a VAPI-XP test, and click the Test Script tab. The 
test script is displayed.

Note: To view or edit the properties of the test script you created, choose 
Test > Properties.
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 2 To view a list of object definitions, methods, and properties that you can 
add to your script, select one of the following options:

➤ Test > References > COM Library References. Opens the References dialog 
box in which you can choose the COM object definitions, methods, and 
properties you want to view.

➤ Test > References > SOAP Web Service References. Opens the Add Web 
Service Reference dialog box in which you can enter the Web service 
object definition or method you want to view. 

➤ Test > References > Java Class References. Opens the Add Java Class 
Reference dialog box in which you can enter the Java class object 
definition or method you want to view.

 3 Select View > Browsers, or click the Show/Hide Browsers button. The 
following tabs are displayed.

➤ Library tab. Displays a list of VAPI-XP (SRunner), Quality Center 
(TDAPIOLELib), and COM/DCOM object definitions, methods, and 
properties that you can add to your script. For an explanation of VAPI-XP 
object definitions, methods, and properties, see “Using the VAPI-XP API” 
on page 573. For an explanation of Quality Center object definitions, 
methods, and properties, refer to the HP Quality Center Open Test 
Architecture API Reference.

➤ Soap tab. Displays a list of Web service object definitions and methods 
that you can add to your script. 

➤ Java tab. Displays a list of Java class object definitions and methods that 
you can add to your script. 
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➤ Function tab. Displays a list of functions contained in your script.

➤ Object tab. Displays a list of objects with defined names that you can add 
to your script.

Note: For a description of each object definition, method, or property, select 
View > Output, and click the Help tab.

 4 To add an object definition, method, or property to the current function in 
your script, place the cursor in the appropriate place in your code, and 
double-click the object definition, method, or property in the Library, Soap, 
or Java tabs. 
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 5 To add an object with a defined name, select the object definition, method, 
or property in the Library, Soap, or Java tabs, and choose Test > Add Object. 
In the Add Object dialog box, type the name you want to assign to the 
object and click OK. The object is added to the Object tab.

To add the object to your script, double-click the object, or right-click it and 
select Insert into Script.

 6 To check the syntax of your code, choose Test > Check Syntax, or click the 
Syntax Check button. Select View > Output to view the verification results in 
the Output tab.
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Additional Editing Functions
You can also perform the following editing functions in the Test Script tab:

➤ To undo a previous action, click the Undo button. To restore an action that 
was undone, click the Redo button.

➤ To remove a section of code from one part of your script, and place it in 
another part of the script, select the section and click the Cut and Paste 
buttons. 

➤ To copy a section of code from one part of your script, and place it in 
another part of the script, select the section and click the Copy and Paste 
buttons. 

➤ To delete a section of code, select it and click the Delete button.

➤ To locate specific text within your script, click the Find in Script button. In 
the Find Text dialog box, type the text for which you want to search. Select 
the options, direction, scope, and origin for your search, and click OK. 

To find another occurrence of the text within the script, choose 
Search > Find Next.

➤ To locate specific text within your script and replace it with different text, 
click the Replace button. In the Find Text dialog box, type the text you want 
to search for in the Text to find box. Type the text with which you want to 
replace this text in the Replace with box. Select the options, direction, 
scope, and origin for your search, and click OK. To replace all instances of 
the text in the script, click the Replace All button.

➤ To locate a specific line number within your script, choose Search > Go to 
Line Number. In the Go to Line Number dialog box, type the line number 
you want to find, and click OK.

➤ To change the editor options, such as the margins, fonts, and screen/text 
colors, click the Editor button. Set the properties you want in the Editor, 
Display, and Colors tabs, and click OK.

After you have finished editing your script, click the Save button to save the 
changes you made. 
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Using the VAPI-XP API 

The VAPI-XP tool contains a built-in library of VAPI-XP object definitions 
that you can reference as you are creating your test script.

Using the TDHelper Object
The TDHelper object supplies the following functions that you can use to 
perform Quality Center-related tasks.

RunTestSet

Executes the selected test set and returns the accumulated test set execution 
status.

RunTestSet([Name = "default"], [Filter = ""], [Locally = FALSE], [Host = ""], 
[HostGroup = ""])

Name. Test set name. Optional. Default = "default"

Filter. Test filter. Defines tests to run. If empty, instructs Quality Center to 
run all the tests in a specified test set. Optional. Default = ""

Locally. If set to TRUE, instructs Quality Center to run test set locally. 
Optional. Default = FALSE

Host. Host on which test set will be run. Optional. Default = ""

HostGroup. Host group in which test set will be run. Optional. Default = ""

RunTest

Executes the selected test and returns the test execution status. 

RunTest(Name, Instance, TestSet, [Locally = FALSE], [Host = ""], [HostGroup = ""])

Name. Test name.

Instance. Test instance.

TestSet. Test set name.

Locally. If set to TRUE, instructs Quality Center to run test set locally. 
Optional. Default = FALSE
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Host. Host on which test set will be run. Optional. Default = ""

HostGroup. Host group in which test set will be run. Optional. Default = ""

AddDefect

Adds a new defect to the current test, if the test is being run in debug mode. 
If the test is being run in test mode, a new defect is added to the current run 
of the test instance in the current test set. Returns a created defect object.

AddDefect([Fields], [StepKey])

Fields. Two-dimensional array—the first dimension is for the field name, 
and the second for the field value. Optional.

StepKey. Step ID for step related to new defect. Optional.

AddDefectUI

Adds a new defect to the current test (in debug mode) or the current run (in 
test mode), using the Quality Center New Defect dialog box.

AddDefectUI([StepKey])

StepKey. Step ID for step related to new defect. Optional.

AddStepToRun

Adds a new step to the current run. Returns a created step object.

AddStepToRun(Name, [Desc], [Expected], [Actual], [Status])

Name. Step name.

Desc. Step description. Optional.

Expected. Expected step result. Optional.

Actual. Actual step result. Optional.

Status. Step status. Optional.
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DownLoadAttachment

Downloads the attachment associated with a test object. Returns the local 
path to which the download was performed.

DownLoadAttachment(Name, item)

Name. The attachment name.

item. Reference to the object with the attachment.

UpLoadAttachment

Uploads an attachment and associates it with a test object.

UpLoadAttachment(path, item)

path. The local path (fully specified file name) of the item to upload.

item. Reference to the object to which to associate the attachment.

Using the TDInput Object
The TDInput object supplies the following function that you can use to 
obtain an input value from an end user.

GetInput

Displays the Input dialog box, enabling you to obtain an input value from 
an end user.

GetInput([Caption],[Name])

Caption. Dialog box caption. Optional.

Name. Name of the input value. Optional.
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Using the TDOutput Object
The TDOutput object supplies the following functions that you can use to 
control the VAPI-XP Output tab.

Clear Method

Clears the Output tab.

Clear

Print Method

Prints the text message to a new line in the Output tab.

Print(Msg)

HookDebug Property

Sets or removes the hook for the OutputDebugString tab API function.

HookDebug

Text Property

Gets or sets the Output tab text.

String Text
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Using the XTools Object
The XTools object supplies the following functions that you can use to 
perform general tasks.

run

Runs command line with passed attributes.

run(Command, [Args = ""], [Timeout = -1], [UseOutput = TRUE])

Command. Application executable file.

Args. Application arguments. Optional. Default = ""

Timeout. Timeout in milliseconds. If this is -1, Quality Center waits an 
infinite amount of time for the application to finish running.

UseOutput. If TRUE, Quality Center replaces the standard output with the 
VAPI-XP output window.

WrapArray

Creates an array of variants from an array of objects. For example, if a called 
object returns as a method result an array of strings, none of the supported 
script engines is able to read the array. Calling the WrapArray function and 
passing the returned array as a function parameter creates an array of 
variants that can be understood by the scripting engine.

WrapArray (array)

array. Array to wrap. 

Sleep

Suspends script execution for a specified amount of time.

Sleep(interval)

interval. Time (in milliseconds) for script execution suspension
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Running VAPI-XP Tests in Debug Mode

Once you have created and edited your VAPI-XP test script, you can run it in 
debug mode or test mode. Running a VAPI-XP test in debug mode enables 
you to execute the test without including it in a test set and without 
creating test run data in the Quality Center project. It is generally 
recommended that you use the debug mode while you are developing your 
test, and the test mode once you have completed creating your test.

To run a VAPI-XP test in debug mode:

 1 In the Test Plan module, select a VAPI-XP test from the test plan tree, and 
click the Test Script tab.

 2 Select Test > Execute (Debug Mode), or click the Execute Script button. 
Quality Center begins executing the test script you selected.

 3 Select View > Output to view the output generated by the test script.

➤ To clear the Output tab, click the Clear Output button.

➤ To copy the output text to the clipboard, select it and click the Copy 
Selected Text to Clipboard button.

➤ To view the test script output in a Web browser, click the Open Output 
Text in Web Browser button.

➤ To print the test script output, click the Print Output button.

 4 To stop executing the VAPI-XP test before it finishes running, select Test > 
Stop, or click the Stop button.
578



Appendix A • Working with VAPI-XP
Running VAPI-XP Tests in Test Mode

You can run your VAPI-XP test in test mode once you have added the test to 
a test set in the Test Lab module. For information on adding tests to test sets, 
see Chapter 24, “Creating Test Sets.”

Note that when you run a VAPI-XP test in test mode, test run data is created 
in the Quality Center project.

You can run your VAPI-XP test in test mode from either the Test Plan or Test 
Lab module.

Note: To run VAPI-XP tests remotely, you must install the HP Quality Center 
Client Side Setup Add-in and the HP Quality Center Connectivity Add-in on 
the host machine on which the tests are executed. For more information on 
HP Quality Center add-ins, refer to the HP Quality Center Installation Guide.

To run a VAPI-XP test in test mode from the Test Plan module:

 1 Select a VAPI-XP test from the test plan tree, and click the Test Script tab.

 2 Select Test > Execute (Test Mode). The Select Test Set dialog box opens.

 3 In the Test Set box, select the test set containing the current VAPI-XP test. 

 4 In the Instance box, select the test instance that you want to run. 

 5 In the Run Name box, type the name you want to assign to the test run. 

 6 Click OK. Quality Center begins executing the test you selected.
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 7 To view the output generated by the test script, select View > Output. For an 
explanation of the Output tab, see “Running VAPI-XP Tests in Debug Mode” 
on page 578.

 8 To stop executing the VAPI-XP test before it finishes running, select 
Test > Stop, or click the Stop button.

To run a VAPI-XP test in test mode from the Test Lab module:

 1 From the Test Sets list, select the test set containing the VAPI-XP test you 
want to run.

 2 In the Execution Grid, select the test you want to run, and click the Run 
button. The Automatic Runner dialog box opens, displaying the selected 
test.

 3 In the Run on Host column, select a host machine on which to run the 
VAPI-XP test, or choose Run All Tests Locally to run the test on your local 
machine.
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 4 Click the Run button. The VAPI-XP Test Script window opens as 
Quality Center begins executing the selected VAPI-XP test. When 
Quality Center finishes executing the test, the Automatic Runner dialog box 
displays the status of the test run.

Debugging VAPI-XP Test Scripts

If your test run was not successfully completed, you can use VAPI-XP’s 
Integrated Debugger to assist you in debugging your VAPI-XP test script. 

Note: You cannot use the Integrated Debugger to debug PerlScript or 
PythonScript test scripts.

To debug a VAPI-XP test script:

 1 In the Test Script tab of the Test Plan module, select Debug > Integrated 
Debugger. Additional buttons controlling the debugging process are 
displayed on the toolbar.

 2 To set a breakpoint in a script, select the line in the script where you want to 
set the breakpoint, and choose Debug > Toggle Breakpoint or click the 
Toggle Breakpoint button. Alternatively, click the gray margin next to the 
line in the script. The line you selected is highlighted in red.
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 3 Click the Execute Script button. Quality Center begins executing the script, 
stopping at the defined breakpoint. The Output tab displays the following 
message. 

 4 To instruct Quality Center to enter the script after the breakpoint, choose 
Debug > Step Into or click the Step Into button. The line in the script that 
follows the breakpoint is highlighted in blue.

 5 To instruct Quality Center to step over a line in the script, click the Step 
Over button or choose Debug > Step Over.
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 6 To instruct Quality Center to execute the script, choose Debug > Step Out or 
click the Step Out button. The output is displayed in the Output tab.

 7 To view or edit the value of each variable in the script, choose 
Debug > Variables or click the Show Variables button. The Variables dialog 
box opens, displaying the variables available in the current script. Select a 
variable to view its properties.

To change a variable’s value, type the new value you want to assign to it in 
the Value box and click Update. Click OK to save your changes and close the 
Variables dialog box.

 8 To view information about a specific variable while debugging, choose 
Debug > Watch or click the Show Watch Window button to display the 
Watch tab. 
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To add a variable to the Watch tab, click +, enter a variable name in the 
Prompt box, and click OK. The variable and its values are displayed in the 
Watch tab.

 9 To instruct Quality Center to resume executing the script, choose 
Debug > Resume Execution or click the Resume Execution button.

 10 Choose Debug > Stop Debugging, or click the Stop Debugging button to 
stop the Integrated Debugger from debugging your script. 
584



B
Quality Center Keyboard Shortcuts

You can navigate Quality Center, and perform many Quality Center 
commands by using shortcut keys.

Switching Between Quality Center Modules

You can switch between the Quality Center modules using 
CTRL+SHIFT+<number> shortcut keys. The number represents the sequential 
order in which the module is displayed in the module sidebar. For example, 
if Requirements is the first module, press CTRL+SHIFT+1. If Business 
Components is the second module, press CTRL+SHIFT+2.

This chapter describes: On page:

Switching Between Quality Center Modules 585

General Keyboard Shortcuts 586

Attachments Shortcuts 588

Send E-mail Dialog Box Shortcuts 588

Releases Module Shortcuts 589

Requirements Module Shortcuts 589

Business Components Module Shortcuts 590

Test Plan Module Shortcuts 591

Test Lab Module Shortcuts 592

Defects Module Shortcuts 593
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General Keyboard Shortcuts

You can navigate Quality Center, and perform common commands by 
pressing the following shortcut keys:

Shortcut Key Function

DOWN ARROW or UP 
ARROW

Selects the previous and next item respectively.

LEFT ARROW or RIGHT 
ARROW

In the tree folders, collapses or expands the folders 
respectively.

In the grid view, selects the previous and next grid 
column respectively.

TAB Selects the next data box in a tab or dialog box.

SHIFT+TAB Selects the previous data box in a tab or dialog box.

CTRL+SHIFT+ 
<sequence number>

Switches between the sidebar views in the Requirement 
Details, Defect Details, and Test Instance Properties 
dialog boxes

CTRL+TAB Moves forward through the tabs.

CTRL+SHIFT+TAB Moves backward through the tabs.

F9 or ALT Focuses on the module menu options. Press LEFT ARROW, 
RIGHT ARROW, DOWN ARROW or UP ARROW to navigate 
the menus.

ALT+DOWN Opens the drop-down lists for list boxes. Press DOWN 
ARROW or UP ARROW to select a list value.

LEFT ARROW Expands a folder that contains sub-folders in the tree 
view (if it is collapsed).

RIGHT ARROW Collapses a folder that contains sub-folders in the tree 
view (if it is expanded).

ALT+G Goes to the selected entity.

ALT+HOME/END Displays the first or last entity respectively in the 
Requirement Details, Defect Details, or Test Instance 
Properties dialog box. 
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ALT+LEFT/RIGHT 
ARROW

Displays the previous or next entity respectively in the 
Requirement Details, Defect Details, or Test Instance 
Properties dialog box. 

F5 Refreshes all data in the selected tree, grid, or folder.

CTRL+F Opens a Find dialog box that helps you search for 
specified text. 

CTRL+C Copies the selected item and puts it on the Clipboard.

CTRL+V Pastes the contents of the Clipboard to the selected 
location.

CTRL+X Cuts the selected item and puts it on the Clipboard.

CTRL+Z Undoes the last action.

CTRL+A Selects all items.

DELETE Deletes the selection.

F1 Displays help for the selected dialog box.

F2 Renames an entity.

F7 Spell checks the selected word or text box.

SHIFT+F7, 
SHIFT+CTRL+F7

Opens the Thesaurus dialog box and displays a 
synonym, antonym, or related word for the selected 
word.

CTRL+ALT+T OR 
CTRL+T

Creates a tab (for memo fields)

Shortcut Key Function
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Attachments Shortcuts

You can perform the following commands in the Attachments tab/dialog 
box by pressing the corresponding shortcut keys:

Send E-mail Dialog Box Shortcuts

You can perform the following commands in the Send E-mail dialog box by 
pressing the corresponding shortcut keys:

Shortcut Key Function

CTRL+F Attaches a file

CTRL+W Attaches a URL

CTRL+P Attaches a snapshot

CTRL+I Attaches system information

CTRL+B Attaches Clipboard content

SPACE Opens an attachment

CTRL+U Uploads an attachment

CTRL+S Saves an attachment

CTRL+DELETE Deletes an attachment

Shortcut Key Function

ALT+C OR ALT+T Opens the Select Recipients dialog box

ALT+S Sends the e-mail

CTRL+ALT+O Opens the Spelling Options dialog box
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Releases Module Shortcuts

You can perform the following commands in the Releases module by 
pressing the corresponding shortcut keys:

Requirements Module Shortcuts

You can perform the following commands in the Requirements module by 
pressing the corresponding shortcut keys:

Shortcut Key Function

CTRL+N Creates a new release folder

CTRL+R Creates a new release

CTRL+Y Creates a new cycle

CTRL+D Creates a copy of a cycle

CTRL+DELETE Deletes a release, release folder, or cycle

Shortcut Key Function

CTRL+ALT+N Creates a new folder

ALT+N Creates a new requirement

CTRL+I Zooms in 

CTRL+O Zooms out one level

CTRL+A Adds test to coverage

CTRL+M Sends requirement by e-mail (from Requirement Details 
dialog box)
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Business Components Module Shortcuts

You can perform the following commands in the Business Components 
module by pressing the corresponding shortcut keys:

Shortcut Key Function

CTRL+N Creates a new component

CTRL+ALT+N Creates a new components folder

F8 Validates the selected component

ALT+S Takes a snapshot of an image (from Snapshot tab)

ALT+L Loads an image from a file (from Snapshot tab)

ALT+N Creates a new input parameter (from Parameters tab)

ALT+D Deletes an input parameter (from Parameters tab)

ALT+W Creates a new output parameter (from Parameters tab)

ALT+L Deletes an output parameter (from Parameters tab)

ALT+N Creates a new step (from Design Steps tab)

ALT+E Edits a step (from Design Steps tab)

CTRL+P Selects a parameter (from Design Steps tab)

CTRL+R Creates a parameter (from Design Steps tab)

CTRL+K Completes the parameter name, based on the first 
character or characters of the parameter name that you 
have entered (from Design Steps tab)

CTRL+S Saves a step (from Design Steps tab)

ALT+M Adds comments (from Details tab)
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Test Plan Module Shortcuts

You can perform the following commands in the Test Plan module by 
pressing the corresponding shortcut keys:

Shortcut Key Function

ALT+N Creates a new step (from Design Steps tab)

CTRL+P Inserts a parameter (from Design Steps tab)

SHIFT+ALT+A Adds attachments (from Design Steps tab)

CTRL+L Adds a call to manual test (from Design Steps tab)

ALT+S Selects a requirement (from Design Steps tab)

CTRL+S Saves a step (from Design Steps tab)

ALT+S Adds requirement to coverage (from Req Coverage 
tab)

ALT+R Removes a requirement from coverage (from Req 
Coverage tab)
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Test Lab Module Shortcuts

You can perform the following commands in the Test Lab module by 
pressing the corresponding shortcut keys:

You can perform the following commands in the Manual Runner dialog box 
by pressing the corresponding shortcut keys:

Shortcut Key Function

ALT+N Creates a new test set

CTRL+A Adds test to test set

CTRL+DELETE Removes test from test set

CTRL+F9 Runs test

CTRL+ALT+F9 Runs test manually

CTRL+SHIFT+F9 Continues manual run

ALT+F9 Runs test set

Shortcut Key Function

CTRL+Q Ends the run

CTRL+R Begins the run

CTRL+K Cancels the run

CTRL+U Adds attachments to the test run

CTRL+B Adds a new defect

CTRL+S Adds attachments to the test step

CTRL+P Passes the selected test run steps

CTRL+F Fails the selected test run steps

CTRL+A Passes all the test run steps

CTRL+G Fails all the test run steps

CTRL+UP ARROW/
CTRL+DOWN ARROW

Selects the previous or next test step
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Defects Module Shortcuts

You can perform the following commands in the Defects module by 
pressing the corresponding shortcut keys:

Shortcut Key Function

ALT+N Adds a new defect

CTRL+DELETE Deletes the selected defect

CTRL+ALT+G Finds similar defects

CTRL+ALT+F Finds similar text

CTRL+L Finds the next instance of the specified text

CTRL+M Sends defect by e-mail (from Defect Details tab)

CTRL+N Clears all fields in the New Defect dialog box
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A

Actual execution rate, Progress tab 122, 123
Actual Fix Time, Defects Grid 414
Add and Link Defect button 439
Add command, Favorites 94
Add Comment button 426
Add Entity to Query arrow 545
Add Entity to Query button 545
Add Excel Report button 541
Add Favorite dialog box 94, 96
Add Graph link 492
Add Host to Host Group button 381
Add Object command 571
Add Object dialog box 571
Add Parameter to Query button 550
Add Query button 546
Add report as attachment check box 211
Add Requirement Traceability button 192, 

193
Add Step button, manual test run 370
Add Sub-Report button 453
Add Tests to Test Set button 330, 331
Add Time Dependency To Flow button, 

Execution Flow 356
Add to Coverage button

Req Coverage tab 265
Test Coverage tab 269

Add to Favorites button, reports 449
Add to Favorites command 94, 96
Add to Traceability button, Requirements 

Traceability tab 193
AddDefect VAPI-XP function 574
AddDefectUI VAPI-XP function 574
Add-ins Page command 19
AddStepToRun VAPI-XP function 574
Adjust Rows Height button 286
Adobe Reader 17

advanced filters 61–65
advanced test set 324
Age Grouping, age graph 483
alerts 75
Alerts button 80, 426
Alerts dialog box 81
Alerts flag 80
All Runs view, Test Instance Properties dialog 

box 391
Analysis Results tab 214
analyzing projects

Document Generator 501–536
graphs 455–488
Live Analysis graphs 489
reports 443–453

Arrange Layout button, Execution Flow 362
ASCII sort order 65
Assign To Cycle dialog box 164, 327
Assign To Release dialog box 164
Assigned requirements, Progress tab 124
Assigned To, Defects Grid 414
attachments 85–92

attaching a file 87
attaching a snapshot 88
attaching a URL 87
attaching items from the Clipboard 

90
attaching system information 89
deleting 92
modifying 91
saving 91
viewing 90

Attachments dialog box 86
Attachments tab, Defect Details dialog box 

426
Attachments tab, Defects Grid 410
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Attachments view, Requirement Details 
dialog box 168

Authenticate button 39
Author, Requirements module 153
Auto Complete Children check box 185
Automated tab, Test Instance Properties 

dialog box 395
automated tests

generating test script 293
running 373–384
running manually 363–371
when not to automate 292
when to automate 291

Automatic Runner dialog box 376
Available Columns list 52
Available Fields list 66

B

Back button 42
Back to Steps Grid button, manual test run 

368
Bar Chart tab, graphs 475
Begin Run button, manual test run 367
Browsers command 569
Business Components module 41
Business Criticality 203
Business Criticality tab 204
Business Process Testing 41
Business Process, test type definition 242
By ID (Trace From) command 193
By ID (Trace To) command 193

C

Call to Test button 282
camera icon 88
Cancel Run button, manual test run 367
categories, editing 486
Change Password dialog box 45
Change Project command 42
changes over time, progress graph 481
Check Spelling button

New Defect 163, 420
Send Mail 179, 250, 433

Check Spelling command 42
Check Syntax command 571
Choose Type of Purge dialog box 348
Clear All button 81
Clear button, New Defect dialog box 420
Clear button, New Requirement dialog box 

163
Clear Filter button 71
Clear Filter/Sort button 71, 392, 452
Clear Filter/Sort, Test Coverage tab 267
Clear Method, VAPI-XP 576
Clear Output button 578
Clear Test Sets Filter/Sort command 71
Clear Tests Filter/Sort command 71
clearing history 45
Clipboard button 90
Closed in Version, Defects Grid 414
Closing Date, Defects Grid 414
Collapse command

requirements tree 174
test plan tree 246

columns
resizing 53
setting column order 51

Comments
Requirements module 153
Test Grid 235

Comments pane, Defects Grid 410, 414, 426
Comments tab, test plan tree 244
Compact View button, manual test run 368
comparing defects 421
condition, setting for a test run 354
Configuration view, Test Instance Properties 

dialog box 393
Configure Reports and Sub-Reports button 

449
Confirm Purge Request dialog box 349
Confirm Reset Test Set dialog box 346
Continue button, All Runs view 391
Continue Manual Run command 371
Convert all requirements to subjects 184
Convert lowest child requirements

to design steps 184
to tests 184

Convert to Tests command 183
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Copy button
requirements tree 180
VAPI-XP 572

Copy Filter Settings button 70
Copy From button 294
Copy Graph To Clipboard button, Graph 

toolbar 484
Copy Selected Text to Clipboard button 578
Copy Steps button, Design Steps tab 288
Copy Test Settings button 337
Copy to Clipboard command, Execution 

Flow 362
Copy URL command 181, 255, 344, 433
copying

defects 433
design steps, between projects 288
design steps, within the same project 

287
requirements 180
subject folders, between projects 254
subject folders, within the same 

project 254
test set folders, between projects 342
test set folders, within the same 

project 342
test sets, between projects 342
test sets, within the same project 342
tests, between projects 254
tests, within the same project 254
URL of a defect 433
URL of a requirement 181
URL of a test 255
URL of a test set 344

Count changes in field list 483
coverage

analyzing 270–274
requirements 262–265
test instances 266–274
tests 266–274

Coverage Analysis 270–274
Coverage Analysis button 271
Coverage Analysis dialog box 270–274, 514
Coverage Analysis view 148
Coverage calculation by cycle box 271
Coverage Chart 267

coverage grid
Req Coverage tab 262
Test Coverage tab 266

Coverage Type
Req Coverage tab 262
Test Coverage tab 266

Create New Requirement dialog box 162
Create New Requirement Folder dialog box 

161
Create New Test dialog box 241
Create Report For This Defect button 426
Create Test Instance dialog box 331, 332
Created By, Linked Defects Grid 437
Created By, Traceability Grid view 194
Creation Date

Test Grid 235
test plan tree 244

Creation Date, Linked Defects Grid 437
Creation Date, Requirements module 153
Creation Date, Traceability Grid view 194
Creation Time, Requirements module 153
Cross filter by section 64
Cross Filter dialog box 64
cross filters 61–65

filtering tests not in any test set 64
filtering tests with no requirement 

coverage 64
Current Test Parameters dialog box 281
Custom button 179, 250, 433
Custom Sort option, test plan tree 256
Custom Zoom dialog box 362
Customer Support Web Site command 18
Customization tab, Document Generator 

509
Customize command 42, 44
customizing graph settings 484
Cut button, Releases module 128
cycles. See releases tree

D

Dashboard command 43
Data Grid tab, graphs 475
Data Type, graphs 480, 481, 482
databases supported by Quality Center 32
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date, specifying for a test run 354
Days progress bar, Progress tab 123
Debug Mode, VAPI-XP tests 578
Defect Details dialog box 425
Defect ID

Defects Grid 414
Linked Defects Grid 437

defect links
adding 439
direct 435
indirect 435
overview 435
removing 440
viewing 438

Defect Opening Rate graph, Quality tab 125, 
126

Defects button 408
Defects button, All Runs view 391
Defects check box, Document Generator 533
Defects Grid

adding defects 419
column definitions 414
copying 433
copying URL 433
deleting defects 434
finding and replacing 427
mailing defects 430
matching defects 421
matching text 421
printing defects 434
updating defects 425
viewing defect history 429

Defects link, Document Generator 533
Defects menu, Defects module 411
Defects module

at a glance 407–416
column definitions 414
Defects Grid 417–434
generating project documents 

533–535
graphs 458
main window 408
menu bar 411
overview 418

reports 443–453
toolbar 412
workflow 403–405

Delete Alert button 81
Delete button

All Runs view 391
folders in Test Lab module 345
Releases module 129
test plan tree 258
test sets in Test Lab module 346
VAPI-XP 572

Delete command
Defects Grid 434
requirements tree 182

Delete Host button 381
Delete Host Group button 381
Delete Selected button

attachments 92
Design Steps tab 287
manual test run 370

Delete Selected Tests button, Test Grid 234
Delete Sub-Report button 453
demonstration project 39
Description

Defects Grid 414
Releases module 110
releases tree 118, 119
Requirements module 153
Test Grid 235

Description command 185
Description of Criterion box 204
Description tab

Defects Grid 410
graphs 488
Requirements module 141, 144, 147, 

150
test plan tree 244

Description, details of test run 390
Design Step Editor 275–290
design steps 275–290

adding 277
arranging columns 287
copying between projects 288
copying within the same project 287
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definition 275
deleting 287
finding and replacing 289
modifying 284
renumbering 286
reordering 286
resizing 286

Design Steps tab, Test Plan module 229, 276
Designer

Test Grid 235
test plan tree 244

Details link 329
Details tab

Defect Details dialog box 426
Releases module 118, 119
Requirements module 144
Test Plan module 228, 244

Details view
Requirement Details dialog box 168
Test Instance Properties dialog box 

389
Detected By, Defects Grid 414
Detected in Cycle, Defects module 414
Detected in Release, Defects module 414
Detected in Version, Defects Grid 415
Detected on Date, Defects Grid 415
Direct Cover Status, Requirements module 

154
Display Options, progress graph 481
Document Generator 501–536

Document Generator tree 511
formatting project documents 

505–510
generating and viewing project 

documents 535
launching 504
overview 502
project data 511
specifying Defects module data 

533–535
specifying Requirements module data 

512–515
specifying Test Grid data 520–523

specifying Test Lab module data 
524–532

specifying Test Plan module data 
516–520

Document Settings tab, Document 
Generator 505

Documentation Library 16
documentation updates 19
Domain list, Login window 39
DownLoadAttachment VAPI-XP function 

575
Drill Down Results dialog box 475, 494, 498
Duplicate Cycle button 128
Duplicate Excel Report button 552

E

Edit Categories button, Graph toolbar 486, 
488

Edit menu
Test Lab module 311
Test Plan module 230

Edit Parameter button 550
Edit Step button 285
Editor button 572
Enable Log check box, Automatic Runner 

dialog box 376, 378
Enable Manual Test Run Confirmation 

command 365
End Date

Releases module 110
releases tree 118, 119

End Run button, manual test run 367, 369, 
370

Entities pane 544
Entities View button 544
Entity Name

Req Coverage tab 262
Test Coverage tab 266

Entity Status
Req Coverage tab 262
Test Coverage tab 266

Estimated development time box 205
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Estimated DevTime, Test Grid 235
Estimated Fix Time, Defects Grid 415
Excel

exporting grid data from Quality 
Center 73

exporting report data from Quality 
Center 449

importing to Quality Center 33
Excel Report Generator 539
Excel reports 537

adding 541
creating 540
creating queries 543
deleting 552
duplicating 552
exporting definitions 553
generating 551
importing definitions 553
renaming 552

Excel Reports toolbar 540
Excel Reports tree 540
Excel security settings 547
Exclude command 185
Exclude from Analysis check box 205
excluded link 209
Exec Date

details of test run 390
Execution Grid 317

Execute (Debug Mode) command 578
Execute (Test Mode) command 579
Execute Script button 578, 582
Executed coverage, Progress tab 124
executing test sets 373–384
executing tests

automatically 373–384
manually 363–371

Execution Condition dialog box 357
Execution Conditions tab, Run Schedule of 

Test dialog box 354
execution conditions, setting 354
Execution Flow 351–362

adding a condition 355
adding time dependency 354
adding time dependency to flow 356
arranging tests sequentially 360
at a glance 320

changing the magnification level 362
deleting all conditions and 

dependencies. 359
deleting conditions 358
deleting time dependency 359
editing conditions 357
editing execution conditions 357
editing time dependency 358
finding a test 361
overview 351
running tests automatically 373–384
running tests manually 363–371
showing full test names 362
test sets 323–349
toolbar 321
viewing test results 385–400
viewing tests in hierarchical layout 

362
viewing the Execution Log 378
zooming in 362
zooming out 362

Execution Flow tab 311
Execution Grid

at a glance 314
column definitions 317
finding and replacing 383
ordering tests 381
replacing field values 341
running tests automatically 373–384
running tests manually 363–371
test sets 323–349
toolbar 316
viewing test results 385–400
viewing the Execution Log 378

Execution Grid tab 310
Execution Log 378
Execution Report link, Defect Details dialog 

box 426
Execution Status, Test Grid 235
exiting Quality Center 39, 43
Expand All command, requirements tree 174
Expand command, test plan tree 246
Export All Grid Data dialog box 73
Export command 73
Export Excel Report Definition button 553
Export Selected Grid Data dialog box 73
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Export to Microsoft Excel command 449
Export Word Document command 274
exporting grid data 73

F

Fail All command 369
Fail Selected button, manual test run 369
Failed requirement status 154
Failure Probability 203
Failure Probability tab 205
Favorite Bar command 95
favorite views 93–97

adding 94
changing properties 96
definition 93
deleting 96
loading 95
private folder 93
public folder 93
recently used 95
updating 96

Favorites command 94
fields

resizing 53
setting field order 51

File button 87
filter box in a grid 60
Filter button, graphs 480, 481, 483
Filter Condition box 57
Filter dialog box

Filter tab 56
Group tab 69
View Order tab 66
with advanced filters 63

Filter/Sort command 56, 65, 71
filters

advanced/cross 61–65
clearing 71
copying 70
drop-down user list 54
filtering tests not in any test set 64
filtering tests with no requirement 

coverage 64
grouping users 54
refreshing 71

searching users 54
setting 55–60
viewing user groups 54

Find button
Req Coverage tab 264
Requirements Traceability tab 192
Test Coverage tab 269

Find command
Defects Grid 427
Execution Grid 383
requirements grid 170
requirements tree 169
Test Grid 252

Find dialog box 170, 252, 427
Defects Grid 427
Design Steps tab 289
Execution Grid 383

Find Folder/Test dialog box 251
Find Folder/Test Set command 338
Find in Script button 572
Find Next command

Defects Grid 427
requirements grid 170
Test Grid 252
VAPI-XP 572

Find Requirement dialog box 169
Find Similar Defects button 422, 423
Find Similar Text dialog box 423
Find Test dialog box, Execution Flow 361
Find Test In Flow button 361
Find Text button 289
Find/Replace dialog box 172, 253, 341

Defects Grid 172, 253, 341, 428
Execution Grid 384

Find/Replace Text button 290
Fit Picture In Window button, Execution 

Flow 362
Fixed Columns, Select Columns dialog box 

53
Flag for Follow Up button 83, 84, 426
Flag for Follow Up dialog box 83, 84
flags for follow up

creating 83
modifying and deleting 83
overview 82
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follow up flags
creating 83
modifying and deleting 83
overview 82

Forward button 42
Full Coverage check box, Test Coverage tab 

267
Full Document button 535
Full Screen View button 494
function test set 324

G

General tab 540
Generate Excel Report button 551
Generate Report button 211, 449
Generate Script button 293
Generate Test dialog box 187
generating automated test scripts 293
Generation Settings tab 540
Get Hosts on the Network button 380
Get Net button 380
GetInput VAPI-XP function 575
Getting Started 17
Global Parameter check box 549
Go To Defect button 426
Go to Defect command 410
Go to Entity button 73
Go to Line Number command, VAPI-XP 572
Go to Requirement command

Coverage Analysis view 150
Requirement Details view 145
Requirements Grid view 148
Requirements Tree view 142

Go To Requirement in Requirements Tree 
command 263

Go to Test command
Test Grid 234
test plan tree 229

Go to Test in Test Plan Tree button, Test Grid 
234

Go to Test in Test Plan Tree command 267
Test Lab module 311

Go to Test in Test Set command 267
Test Plan module 229

Graph Appearance dialog box 484, 485
Live Analysis graphs 499

graph settings, customizing 484
Graph Wizard 476
graphs 455–488

Bar Chart tab 475
creating 474
customizing appearance 485
customizing appearance for Live 

Analysis 499
customizing content 478
customizing description 488
customizing settings 484
Data Grid tab 475
Defects - Age Graph 472
Defects - Progress Graph 471
Defects - Summary Graph 470
Defects - Trend Graph 473
editing categories 486
Line Chart tab 475
Live Analysis graphs 489
Live Analysis, test set folder 494
Live Analysis, test subject folder 491
Pie Chart tab 475
Requirements - Coverage Graph 461
Requirements - Progress Graph 460
Requirements - Summary Graph 459
Requirements - Trend Graph 462
Test Execution - Progress Graph (Cross 

Test Set) 469
Test Execution - Progress Graph 

(Current Test Set) 467
Test Execution - Summary Graph 

(Cross Test Set) 468
Test Execution - Summary Graph 

(Current Test Set) 466
Test Planning - Progress Graph 464
Test Planning - Summary Graph 463
Test Planning - Trend Graph 465
toolbar 484
types 456

grid filter box 60
Grid Filters command 60
group criteria

copying 70
setting 68
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Group tab, Filter dialog box 69
Grouped By list 479, 481, 482
grouping grid records 68

H

Help button 43
Help on this page command 16
Hide On Run check box 549
Hide Risk-Based Quality Management 

Columns check box 56, 65, 69
history

clearing 45
History tab

Defect Details dialog box 427
Defects Grid 410, 429
requirements tree 175
Test Grid 234

History view
Test Instance Properties dialog box 

399
History view, Requirement Details dialog box 

168
HookDebug Property, VAPI-XP 576
Host Manager 379
hosts 379

adding host group 381
adding to host group 381
definition 373
deleting host 381
deleting host group 381
removing from host group 381

HP Software Web site command 19
HTML Document, exporting grid data 74

I

images, attaching 88
Impact Analysis tab, Requirements 

Traceability 196
Import Excel Report Definition button 553
importing to Quality Center

from Excel 33
from Word 33

Include list of requirements in the report 
check box 211

Indicator Columns command
Defects module 409
Execution Grid 233, 315
Requirements Grid 144, 147, 149
Test Grid 141

Information Panel command
Coverage Analysis view 150
Defects Grid 410, 429
Requirements Grid 147
Requirements Tree view 141

Insert Parameter button 280
Integrated Debugger, VAPI-XP 581
ITG Request Id

Test Set Properties tab 329

K

keyboard shortcuts 585
Knowledge Base command 18

L

Last Run Results pane, Execution Grid 314
Launch button 294
Line Chart tab, graphs 475
Link Comment, Linked Defects Grid 437
Link Entity Type, Linked Defects Grid 437
Link Existing Defect button 439
Link ID, Linked Defects Grid 437
Link Type, Linked Defects Grid 437
Linkage and Coverage view, Test Instance 

Properties dialog box 398
Linked By Status, Linked Defects Grid 437
Linked Defects dialog box 436

for a test run 392
Linked Defects tab 311, 436

Test Instance Properties dialog box 
398

Test Plan module 229
Linked Defects view, Requirement Details 

dialog box 168
Linked Entities tab

Defect Details dialog box 427
Linked Entity ID, Linked Defects Grid 437
Linked Entity Name, Linked Defects Grid 

437
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linking defects
adding links 439
directly 435
indirectly 435
overview 435
removing links 440
viewing links 438

Live Analysis graphs
creating in test set folder 494
creating in test subject folder 491
customizing appearance 499
deleting 498

Live Analysis tab 491, 495
Load from File button, Document Generator 

508
Load from Saved button, Document 

Generator 508
load testing 222
LoadRunner Scenario, test type definition 

241
Login button 39
Logo tab, Document Generator 508
Logout button 39, 43

M

Mail Requirement button 177
Manual Runner - Step Details dialog box 368
Manual Runner dialog box 366
Manual tab, Test Instance Properties dialog 

box 394
manual tests

converting to VAPI-XP 558
running 363–371

Manual, test type definition 241
Mark as Template Test command 280
matching defects 421
Maximize Content button 166
Mercury Dashboard 43
Mercury Quality Center Login window 38
Mercury Quality Center Options window 36
Microsoft Excel

export report data from Quality 
Center 449

exporting grid data from Quality 
Center 73

importing to Quality Center 33
Microsoft Word

exporting grid data from Quality 
Center 73

generating project documents 535
importing to Quality Center 33

Microsoft Word content 165
missing assessment link 209
Modified

Defects Grid 415
Execution Grid 317
Requirements module 154
Test Grid 235
Traceability Grid view 194

Move Field Down button, Filter dialog box 
67

Move Field Up button, Filter dialog box 67

N

Name
Releases module 110
Requirements module 154

New Cycle button 118
New Cycle dialog box 118
New Defect button, manual test run 369
New Defect command 42
New Execution Condition dialog box 355
New Folder button 161, 326
New Folder dialog box 240, 326
New Host button 380
New Host dialog box 380
New Host Group button 381
New Host Group dialog box 381
New Parameter button 549
New Release button 117
New Release dialog box 117
New Release Folder button 117
New Release Folder dialog box 117
New Requirement button 162
New Requirement dialog box 162
New Step button 277
New Test button 241
New Test Set button 328
New Test Set dialog box 328
No Run requirement status 154
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No. of Requirements per Risk Category graph 
209

Normal magnification level 362
Not Completed requirement status 154
Not Covered requirement status 154
Notifications link 333

O

Old Type (obsolete), Requirements module 
154

On Failure link 334
On Test Failure dialog box 336
Open (Download and Open) button, 

attachments 90
Open Output Text in Web Browser button 

578
Open Report check box 551
Options tab, Document Generator 506
Order Tests command 360
Order Tests dialog box

Execution Flow 360
Execution Grid 381

ordering tests
in the Execution Flow 360
in the Execution Grid 381

Organize command, Favorites (Test Lab 
module) 94

Organize Favorites command 96
Organize Favorites dialog box 96
Output command 571
Output tab 571
Outstanding Defects graph, Quality tab 125, 

126
Override calculated value check box 205

P

Page Setup button, Document Generator 509
Page Setup dialog box, Document Generator 

510
Parameter Properties dialog box 280
parameters

adding to Excel report queries 548
adding to tests 280
calling tests 282

overview 279
viewing values 281

parameters list 548
Parameters of Test dialog box 283
Pass All command 369
Pass Selected button, manual test run 369
Passed coverage, Progress tab 124
Passed requirement status 154
password, changing 44
Paste button, VAPI-XP 572
Paste command, releases tree 128
Paste command, requirements tree 180, 181
Paste Design Steps to Target Project dialog 

box 288
Paste Filter Settings button 71
Paste Steps button, Design Steps tab 288
Paste Test Sets/Test Set Folders to Target 

Project dialog box 343
Paste Test Settings button 337
Paste Tests/Subject Folders to Target Project 

dialog box 255
pasting release folders, releases, and cycles 

128
pasting requirements 180, 181
Path

Execution Grid 317
Test Grid 235

Percent of Similarity box 424
Perform Risk Analysis button 209
performance testing 222
Period

progress graph 481
trend graph 483

Pie Chart tab, graphs 475
Plan, Execution Grid

Comments 317
Creation Date 317
Description 317
Designer 317
Estimated DevTime 317
Execution Status 317
Modified 317
Path 317
Status 318
Subject 318
Template 318
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Test Name 318
Type 318

Planned Closing Version, Defects Grid 415
Planned coverage, Progress tab 124
Planned Exec Date

details of test run 390
Execution Grid 318

Planned Exec Time
details of test run 390
Execution Grid 318

Planned Host Name
details of test run 390
Execution Grid 318

post-processing script
creating 546
guidelines 547

Post-processing tab 540
Preview button, Document Generator 535
Print command, in Defects Grid 434
Print Graph button, Graph toolbar 485
Print Method, VAPI-XP 576
Print Output button 578
Priority

Defects Grid 415
Requirements module 154

private folder, in favorites 95, 97
privileges 32
Product, Requirements module 154
Progress tab, Releases module 121
project databases 32
Project list, Login window 39
Project, Defects Grid 415
Properties dialog box 97
properties, changing 44
public folder, in favorites 95, 97
Purge Runs command 347

Q

Quality Center
changing projects 42
exiting 39, 43
keyboard shortcuts 585
Login window 38
main window 40
Options window 36

overview 23
Quality Center URL 35
starting 35

Quality Center reports 443–453
customizing 450
Defects module reports 446
generating 448
overview 443
Requirements module reports 444
Test Lab module reports 445
Test Plan module reports 445

Quality tab, Releases module 125
QualityCenter_Demo project 39
Query Parameters tab 544
Query Results tab 544
Query tab 540
QuickTest Professional, test type definition 

242

R

Readme 17
Refresh All button

Req Coverage tab 265
Requirements module 174
Select a Test dialog box 282
Test Coverage tab 193
test plan tree 246

Refresh All button, Releases module 124, 127
Refresh All command

Req Coverage tab 265
Refresh button

graphs 480, 481, 483
Test Coverage tab 269

Refresh Filter/Sort button 71
Refresh Test Sets Filter/Sort command 71
Refresh Tests Filter/Sort command 71
regression test set 324
Relationships tab, Requirements Traceability 

194
Releases button 108
Releases module

adding cycles 118
adding releases 117
assigning requirements 164
assigning test set folders to cycles 327
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at a glance 107
field definitions 110
menu bar 109
modifying the tree 127
pasting folders, releases, and cycles 

128
Progress tab 121
Quality tab 125
releases tree 111
statistics 119
toolbar 109
viewing assigned requirements 119
viewing assigned test set folders 119
viewing coverage progress 121
viewing defects 125
workflow 101

releases tree 111
adding cycles 118
adding releases 117
deleting folders, releases, and cycles 

129
duplicating cycles 128
modifying 127
moving folders and releases 128
overview 112
renaming folders, releases, and cycles 

127
root folder 117
statistics 119
viewing assigned requirements 119
viewing assigned test set folders 119
viewing coverage progress 121
viewing defects 125

Remaining days in cycle, Progress tab 123
Remaining days in release, Progress tab 122
Remaining test instances to run, Progress tab 

122, 123
remote execution 373–384
remote hosts, setting up 379
Remove All Execution Conditions command 

359
Remove All Execution Conditions dialog box 

359
Remove Execution Condition command 358

Remove From Coverage button, Test 
Coverage tab 269

Remove from Traceability button 198
Remove Graph button 498
Remove Host From Host Group button 381
Remove Link button 440
Remove Saved button, Document Generator 

508
Remove Selected button, Req Coverage tab 

265
Remove Test’s Execution Conditions 

command 358
Remove Tests from Test Set button 342
Remove Time Dependency command 359
Rename command

requirements tree 179
test set 344

Rename command, Releases module 127
renaming a folder or test in the test plan tree 

257
renaming a requirement 179
Renumber Steps button 286
renumbering design steps 286
reordering design steps 286
Replace All button, VAPI-XP 572
Replace button, VAPI-XP 572
Replace command

Defects Grid 172, 253, 341, 428
Execution Grid 341, 384
requirements tree 171

Replace dialog box 171, 290
requirements tree 171

Report Selected command 450
Report Selected with Children command 450
reporting defects

adding defects 419
at a glance 407–416
Defects Grid 414
deleting defects 434
finding and replacing 427
mailing defects 430
matching defects 421
matching text 421
updating defects 425
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viewing defect history 429
workflow 403–405

reports 443–453
customizing 450
Defects module reports 446
Excel reports 537
generating 448
generating project documents 

501–536
overview 443
Requirements module reports 444
Test Lab module reports 445
Test Plan module reports 445

Reproducible, Defects Grid 415
Req ID, Requirements module 156
Req Parent, Requirements module 156
Reqs Coverage tab, Test Plan module 229
Required execution rate, Progress tab 122, 

123
Requirement Details button 167
Requirement Details dialog box 167
Requirement Details view 143
Requirement Trace ID, Traceability Grid view 

195
Requirement Type, Requirements module 

157
requirements

adding traceability 192
finding 169
finding in grid 170
finding in tree 169
removing traceability 198
replacing field values in grid 172
replacing field values in tree 171
trace from links 189
trace to links 189
viewing traceability 194, 196

Requirements button 139
Requirements check box, Document 

Generator 513
requirements coverage 262–265

adding requirements 264
analyzing 270–274
example 260
overview 259

removing requirements 265
viewing 263

requirements grid
copying URL 181
field definitions 153
finding requirements 170

Requirements Grid view 146
Requirements link, Document Generator 

513
Requirements module

assigning requirements to releases or 
cycles 164

at a glance 139–158
coverage 266–274
Coverage Analysis 270–274
Coverage Analysis view 148
creating requirements 161
field definitions 153
generating project documents 

512–515
graphs 456
mailing a requirement 176
menu bar 151
pasting requirements 180, 181
reports 443–453
Requirement Details view 143
Requirements Grid view 146
requirements tree 159–187
Requirements Tree view 140
toolbar 152
workflow 133–138

requirements traceability 189
adding 192
removing 198
trace from links 189
trace to links 189
viewing 194, 196

Requirements Traceability view, 
Requirement Details dialog box 168

requirements tree 159–187
assigning requirements to releases or 

cycles 164
copying a requirement 180
copying URL 181
creating 161
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creating tests from 182–187
definition 136
deleting a requirement 182
expanding and collapsing 174
field definitions 153
filtering 174
finding requirements 169
mailing a requirement 176
moving a requirement 181
overview 160
refreshing 174
renaming a requirement 179
replacing field values 171, 172
showing in Test Plan module 264
tests coverage 266–274
viewing requirement history 175
zooming out 173

Requirements Tree view 140
Reset Test Set command 346
Reset Titles button 486, 499
resizing grid columns 53
Responsible Tester

details of test run 390
Execution Grid 318

Restrict to current filter check box 73
results for test run 385–400
Resume Execution button, VAPI-XP 584
Reviewed, Requirements module 157
rich text 165
Rich Text tab, Requirements module 165
Risk Category, determining 203
Risk tab, Requirement Details view 204, 206, 

208, 211
Risk view, Requirement Details dialog box 

168
risk-based quality management 199

defining settings 205
determining Risk Category 203
example 215
finalizing testing policy 207
restoring default constants 207

risk-based quality management report 211
Run All Tests Locally check box 376
Run button

Execution Flow tab 365, 375
Execution Grid tab 365, 375

run conditions, setting 354
Run Events view, Test Instance Properties 

dialog box 396
Run Manually button

Execution Flow tab 365
Execution Grid tab 365

Run on Host, Automatic Runner dialog box 
376

Run post-processing check box 547
Run Query button 545
Run Schedule of Test dialog box

Execution Conditions tab 354
Time Dependency tab 356

Run Steps dialog box 392
Run Test Set button

Execution Flow tab 375
Execution Grid tab 375

run VAPI-XP function 577
running test sets 373–384
running tests

automatically 373–384
manually 363–371

Runs check box, Document Generator 530
Runs link, Document Generator 530
RunTest VAPI-XP function 573
RunTestSet VAPI-XP function 573

S

sanity test set 324
Save and Apply to Children button 210
Save button, Document Generator 508
Save Steps button 277
scheduling test execution 351–362
scope 135
script, generating 293
Scroll To The Left button, Graph toolbar 484
Scroll To The Right button, Graph toolbar 

484
Search Results dialog box

Execution Flow 361
requirements tree 169
test plan tree 251
test sets tree 339

search text 71
Searchable Fields Information button 73
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security settings, Excel 547
security testing 222
Select a Test dialog box 282
Select Cleanup Test dialog box 334, 397
Select Columns button, Design Steps tab 287
Select Columns command, Design Steps tab 

287
Select Columns dialog box 52
Select Destination Subject dialog box 186
Select Fields button, reports 452
Select Fields dialog box 179, 250, 433
Select Filter Condition dialog box 57
Select Host dialog box 376
Select Recipients dialog box 178, 249, 432
Select Req button 264
Select Test Set dialog box 579
Select Test Sets to Purge dialog box 347
Select Tests button, Test Coverage tab 268
Select Tests button, test plan tree 330, 331
Send by E-mail button

defects 431
tests 248

Send E-mail dialog box
defects 430
requirements 176
tests 248

Set Filter/Sort button 56, 65, 392, 452
Requirements module 174

Set Filter/Sort, Requirements Traceability tab 
193

Set Filter/Sort, Test Coverage tab 267, 269
Set Graph Appearance button 484, 485, 494, 

498, 499
Set Test Sets Filter/Sort command 56, 65
Set Tests Filter/Sort command 56, 65
Set to Default button 337
Settings per test button 336
Severity, Defects Grid 415
shortcuts 585
Show Advanced Filter arrow 63
Show All button, Graph toolbar 484
Show Full Path command 263
Show Full Test Names command 362
Show Full Test Names command, Execution 

Flow 362

Show Last Run Results command 314
Show only Template Test checkbox 282
Show Parameters button 369
Show Requirements command 120, 121
Show Run Steps button, All Runs view 391
Show Test Set Folders command 121
Show Total Values button, Graph toolbar 

484
Show Variables button 583
Show/Hide Browsers button 569
Similar Defects dialog box 422
Site Administrator, viewing messages from 

47
Sleep VAPI-XP function 577
Snapshot button, Attachments dialog box 88
Snapshot dialog box, Attachments dialog 

box 88
snapshot, attaching 88
Sort Ascending button, Filter dialog box 67
sort criteria

clearing 71
copying 70
refreshing 71
setting 65–67

Sort Descending button, Filter dialog box 67
Sort Folders button 256
Sort Folders in Test Plan Tree dialog box 256
Sorted Fields list 66
specifying requirements 133–138
Spelling and Grammar command

Check Spelling 42
Spelling Options 42
Thesaurus 42

Spelling Options button
New Defect 163, 420
Send Mail 179, 250, 433

Spelling Options command 42
SQL pane 544
SQL queries, creating 543
Start Date

Releases module 110
releases tree 118, 119

starting Quality Center 35
Statistics, Releases module 110
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Status
Defects Grid 415
details of test run 390
Execution Grid 318
Test Grid 235
test plan tree 244

Status Filter list, Test Coverage tab 267
Step command 185
Step Into button 582
Step Out button 583
Step Over button 582
Steps, test 275–290
Stop button

Automatic Runner dialog box 377
Document Generator 536
VAPI-XP 578

Stop Debugging button 584
stress testing 222
Subject

Defects Grid 415
Test Grid 236

Subject command 185
subject folders

adding to test plan tree 239
copying between projects 254
copying within the same project 254
definition 238
deleting 258
finding in test plan tree 251
renaming 257
sorting in test plan tree 256

Subject Tests check box, Document 
Generator 518

Subject Tests link, Document Generator 518
Subject Tree check box, Document 

Generator 516
Subject Tree link, Document Generator 516
Summary pane, Defects Grid 410
Summary, Defects Grid 415
support online 18
Syntax Check button 571
System Info button 89
System Information dialog box 89
System Test, test type definition 242
System tests 295–301

T

Target Cycle
Defects module 416
Execution Grid 318
Requirements module 157

Target Release
Defects module 416
Requirements module 157

TDHelper Object, VAPI-XP 573
TDInput Object, VAPI-XP 575
TDOutput Object, VAPI-XP 576
Template Test command 243
Template, Test Grid 236
Test command 185
test coverage

removing test instances from 269
removing tests from 269
viewing 267

Test Coverage view, Requirement Details 
dialog box 168

test execution
automatically 373–384
manually 363–371
test sets 373–384

Test Grid 232–236
column definitions 235
copying URL 255
deleting tests 234
finding a test 252
generating project documents 

520–523
mailing a test 248
main window 232
replacing field values 253
toolbar 234

Test ID, Test Grid 236
Test Instance Properties dialog box 385–400

All Runs view 391
Automated tab 395
Configuration view 393
Details view 389
History view 399
Linkage and Coverage view 398
Linked Defects tab 398
Manual tab 394
Run Events view 396
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Test Instance Runs progress bar, Progress tab 
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test instances, linking to a requirement 
266–274

Test Lab button 310
Test Lab check box, Document Generator 

524
Test Lab link, Document Generator 524
Test Lab module

assigning test set folders to cycles 327
at a glance 309–322
Execution Flow tab 311
Execution Grid tab 310
generating project documents 

524–532
graphs 457
Linked Defects tab 311
Live Analysis graphs 494
main window 310
menu bar 311
reports 443–453
running tests automatically 373–384
running tests manually 363–371
Select Tests toolbar 313
Test Set Properties tab 311
Test Set toolbar 313
test sets 323–349
viewing test results 385–400
workflow 305–307

Test List check box, Document Generator 
521

Test List link, Document Generator 521
test management process 25

planning tests 29
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specifying requirements 27
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Test Parameters button 281
Test Plan button 228
Test Plan module

at a glance 227–236
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design steps 275–290
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Live Analysis graphs 491
main window 228
menu bar 230
reports 443–453
requirements coverage 262–265
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toolbar 231
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Test Script tab 229, 294
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On Failure 334

test sets 323–349
adding 328
adding tests to 330
assigning folders to cycles 327
copying between projects 342
copying within the same project 342
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test sets grid, copying URL 344
Test Sets link, Document Generator 526
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copying URL 344
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test steps, editing during test run 370
Test Type list, Test Plan module 241
Test Version, Execution Grid 318
TestDirector, see Quality Center
Tester

details of test run 390
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Testing Policy grid 206
testing requirements, specifying 133–138
testing scope 135
Testing Time 205
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finding in Test Grid 252
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262–265
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running locally 376
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analyzing 270–274
example 261
overview 259
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Tests Filter/Sort button 56, 65
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Tests menu
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Text Property, VAPI-XP 576
text search 71
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New Defect 163, 420
Send Mail 179, 250, 433
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Time
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Time Dependency icon 358
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dialog box 356
Time, details of test run 390
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Execution Flow 321
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graphs 484
Releases module 109
Requirements module 152
Select Tests 313
Test Grid 234
Test Plan module 231
Test Set 313

Tools button 42
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Document Generator command 504
New Defect command 42

Total allocated testing time box 208
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Total days in release, Progress tab 122
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122
Total Testing Time per Risk Category graph 

209
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Traceability Grid view 194
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adding 192
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viewing 194, 196

tracking defects
adding defects 419
at a glance 407–416

Defects Grid 414
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matching defects 421
matching text 421
updating defects 425
viewing defect history 429
workflow 403–405

Type, Test Grid 236
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U

Unattached folder, test plan tree 258
Unload button, Document Generator 508
updates, documentation 19
Upload Selected button, attachments 91
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URL button 87
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URL, copy 181, 255, 344, 433
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215
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user privileges 32
User Properties link 44
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users
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searching 54
selecting 54
sorting 54

V

VAPI-XP API 573–577
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creating 558, 558–567
debugging 581, 581–584
editing 568, 568–572
running in debug mode 578
running in test mode 579
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Variables command 583
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Test Lab module 311
Test Plan module 230

View Order tab, Filter dialog box 66
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Visual Basic script

creating 546
guidelines 547

W

Web page, attaching 87
Welcome page 39
Welcome Page command 39
What’s New command 17
Window Screen button 568
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241
WinRunner batch test 245, 374
WinRunner parameters 395
Word

exporting coverage analysis to 274
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Center 73
generating project documents 535
importing to Quality Center 33

Word Document, Export command 274
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X

X-Axis list 479
XML document, exporting grid data 74
XTools Object, VAPI-XP 577

Z

Zoom In button
Execution Flow 362
Graph toolbar 484

Zoom Out button
Execution Flow 362

Graph toolbar 484
Zoom Out One Level button 173
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