HP SiteScope Release Notes

for the Windows, Solaris, and Linux operating systems

Software version: 10.12

Publication date: May 2010

This document is an overview of the changes made to HP SiteScope. It contains important information that is not included in books or Help. You can find information about the following in this document:

Documentation Updates

Changes and Enhancements

Bug Fixes

Notes and Limitations

System Requirements

Support Matrices

HP Software Support

Legal Notices

Note: For release notes from earlier versions of HP SiteScope, see the root directory on the product installation media.

Documentation Updates

The first page of this release notes document contains the following identifying information:

  • Version number, which indicates the software version.
  • Publish date, which changes each time the document is updated.

To check for recent updates or to verify that you are using the most recent edition, visit this URL: HP Software Product Manuals

To retrieve a document, select the:

1. Product name.
2. Version list.
3. Operating System.
4. Preferred Language.
5. Document title.
6. Click Open or Download.

You must have Adobe Reader installed to view files in PDF format (*.pdf). To download Adobe Reader, go to the Adobe web site.

Changes and Enhancements

SSH Stabilization

  • This service pack targets SSH connection and performance issues that were identified in previous SiteScope versions. It includes various improvements for remote server monitoring using SSH.

Auto Template Deployment

  • Added support for connect to server and user login in the auto template deployment XML file. The user name and password can be encrypted with the external encryption tool that is used for encrypting variables.

BAC Integration

  • To avoid DNS server request bursts on SiteScope restart, added a setting to delay successive host resolution calls for remotes and monitors. By default, there is a one second (1000 millisecond) delay between resolving calls. To change the setting, enter a different value in the Delay between host resolution requests (milliseconds) box in Preferences > Infrastructure Settings > General Settings. In addition, SiteScope does not store host resolution results in the host cache if an IP address is returned instead of the fully qualified DNS name (this is an indication of a DNS configuration problem). A warning is written to the log and SiteScope tries to resolve the host on the next attempt. This enables SiteScope to get the correct results after the DNS configuration is fixed without restarting SiteScope.

User Preferences

  • Added support for specifying multiple LDAP service providers when logging in to SiteScope using LDAP authentication. Previously, the IP address of the available server had to be specified, which meant that only one server could be searched. To use, enter the domain name of each LDAP service provider separated by a semi-colon (";") in the LDAP service provider field in User Management Preferences. SiteScope reads the list of LDAP service providers and searches for the available provider from the list.

Bug Fixes

Description
CR ID
Area

Fixed issue of the Subject field of Email alerts not supporting non-English characters by selecting International version in Preferences > General Preferences.

24689

Alerts

Fixed issue of DNS server request bursts on SiteScope restart. For details, see "BAC Integration" in Changes and Enhancements.

36072 / 41459

Business Availability Center Integration

When creating an EMS monitor, make sure that the appropriate topology script is selected for the field mapping:

  • For Events field mapping, use Hosts, Host - Software elements, or Custom script
  • For Measurements field mapping, use Custom script (Note: If you want to send the regular SiteScope topology, do not choose any script)
  • For Tickets field mapping, use Tickets or Custom script

43522

Integration Monitors

Fixed issue of EMS monitors with customized field mapping/topology settings having empty field mapping/topology settings after disabling and then enabling the monitor.

39012

Integration Monitors

Fixed issue of Log File monitor returning "can't read file" instead of 0 matches when no content matches were found.

37804

Monitors

Fixed issue of incorrect counters being displayed when a Microsoft Windows Resources monitor is copied to a template.

43224

Monitors

Fixed issue of auto template deployment XML not working in secure API mode (the _accessControlled property was set to false in the master.config file).

40964

Templates

Fixed issue of the WebLogic 9.x-10.x Application Server Solution Template having the incorrect field name (WEBLOGIC9_URL instead of WEBLOGIC_URL) in the Deployment Values dialog box.

42118

Templates

Added the Additional Classpath field to the WebLogic 9.x-10.x Application Server solution template to enable monitoring of a WebLogic Application Server 10.3. Enter the wlfullclient.jar in the Additional Classpath field in the JMX Monitor Settings.

42117

Templates

Escalation Fixes

Description
SR/E-Sar Number
CR ID
Area

Fixed issue of an error being generated if a Script Alert's argument, or a counter used as a Script Alert's argument, contained one of the following illegal characters: `;&|<>

234748

39400

Alerts

Fixed issue of being unable to use a variable in the Server field of a script alert.

232544

35882

Alerts

Fixed issue of triggered alerts getting stuck due to no timeout for alert threads to be killed. This resulted in associated alerts of the same instance also getting stuck and in monitor runs being skipped.

4601829281

38018

Alerts

Fixed issue of alerts list not being sorted correctly (alphabetically).

4608320520

38268

Alerts

Fixed issue of the <diagnosticTest> property in alert templates not being populated when used with a Log File monitor configured with Server-side processing. Note that this fix involved making changes to files in the <SiteScope installation>\templates.os directory. If you modified these files, these changes will affect you and you should consider making similar modifications to the new files.

233914

37795

Alerts

Fixed issue of email alert templates not displaying the event occurrence time under <diagnosticText> in the alert email.

4610417327

40751

Alert Templates

Fixed issues in SiteScope API of being unable to deploy templates more than once into the same folder when there is no root group folder, and of incorrect parameters being sent when updating parameters via the template.

  • Added support to the DeployTemplate method that enables monitors to be added directly under the template (the _allowTemplateMonitorDirectlyUnderTemplate property is set to True in the master.config file).
  • Added a new UpdateViaTemplate method. Note: This method supports a template with only one monitor directly under the template (where there is no root group folder).

4000968845

40722

API

Fixed issue of being unable to connect to the BAC Gateway Server due to a high number of CLOSE_WAIT connections.

4603495254

39914

Business Availability Center Integration

Fixed issue of SiteScope modifying CIs already reported to BAC by the discovery probe on restart (anti-aging, resynchronization).

4608451445

41862

Business Availability Center Integration

Fixed Monitor History issue of time values being sorted as strings instead of as timestamps.

4604054650

35158

Dashboard

Fixed issue of user permissions not being saved using the Dashboard toolbar when Dashboard view is set to Icon View and Page Options > Save Layout to user Preferences is selected.

4606822425

36364

Dashboard

Fixed performance issues in the SiteScope user interface when multiple users are logged in while viewing Dashboard in Show All Descendant Monitors.

4607337141

37476

Dashboard

Fixed issue of columns disappearing in the SiteScope Dashboard Current Status view after switching to Monitor History view and then back to Current Status view.

4605504449

35748

Dashboard

Fixed issue of the Monitor History view being unavailable for users that did not have SiteScope root group permissions, even if a user had View monitor history permissions.

4158993156

35782

Dashboard

Fixed issue of SiteScope not saving changes to HP BAC Integration Settings when using Global Search and Replace.

4609691845

38250

Global Search and Replace

Fixed issue of the Technology Log File monitor incorrectly displaying regular expression error messages when loading an Event script and clicking the Test Script button.

4608278248

37808

Integration Monitors

Fixed issue of Japanese characters being incorrectly displayed in URL Tool results (added support for UTF-8 character encoding).

4609836894

39943

I18N

Fixed issue of CPU monitor reporting an incorrect value when monitoring on a Red Hat Linux remote server.

4606750242

37189

Monitors

Fixed issue of the JMX monitor being unable to monitor JBoss and Tomcat.

4610565534

39390

Monitors

Fixed issue of the Log file monitor failing to match content for UTF-16LE encoded files.

4607561375

38194

Monitors

Fixed following issues with MAPI monitor:

  • Fixed issue of MAPI monitor with different domain accounts for sender and receiver throwing "Failed to initialize MAPI. Error: -2147467259" when running on Microsoft Windows 2003.
  • Fixed issue in MAPI monitor of being unable to use an account (other than the mailbox account), for logging in to the SiteScope server.

Note: The logon type depends on the environment being used.

While most environments work without adding a key, you might need to add the _dwLogonType and _dwLogonProvider property to the master.config file and configure the parameters. The available ranges are 2-5 and 7-9 for _dwLogonType and 0-3 for _dwLogonProvider.

For more information on these keys, see the following articles:

  • http://msdn.microsoft.com/en-us/library/aa378184%28VS.85%29.aspx
  • http://msdn.microsoft.com/en-us/library/ms692492.aspx

4607184372

230919

38574

39312

Monitors

Fixed issue of not being able to use the Microsoft Exchange 2007 monitor on 64-bit version of Windows 2003, Windows 2008, or Windows XP (since a 32-bit application cannot access the system32 folder on a computer that is running a 64-bit version of Windows), by performing the following:

  • Apply the Microsoft hotfix available from http://support.microsoft.com/?scid=kb;en-us;942589.
  • In Preferences > Infrastructure Preferences > General Settings, enter the PowerShell execute command in the PowerShell execute command field. For example: C:\Windows\Sysnative\WindowsPowerShell\v1.0\powershell.exe

Note: Symlink Sysnative is not available by default on Windows 2003 or Windows XP.

230858

39128

Monitors

Fixed issue of Microsoft Windows Event Log monitor not working with DEBUG mode enabled in the log file.

4608123607

36604

Monitors

Fixed issue when collecting Microsoft Windows Performance Counter metrics from a server using a non-English locale, of metrics being retrieved with a comma (",") in the value instead of a period ("."). For example, 6.789 was retrieved as 6,789. When metric are forwarded to BAC with a comma, BAC rounds the integers (therefore, the value 6,789 was displayed in BAC as 6 instead of 6.789).

4612533618

42594

Monitors

Fixed issue of Microsoft Windows Resources monitor losing disk counter information for the mounted points.

4609834681

39101

Monitors

Fixed issue with the Microsoft Windows Resources monitors of counter values that are available when running the monitor using the Microsoft Windows PDH Library collection method, are not available when using the Direct registry queries method.

4604512677

39305

Monitors

Fixed issue of being unable to create a Network Bandwidth monitor when working with Cisco 650x series switches.

4608827922

39949

Monitors

Fixed issue in Ping monitor of Host name to resolve field not supporting remote servers with an underscore ("_") in the name.

4610404973

38620

Monitors

Fixed issue in Script monitor of being unable to run a .vbs script from a command line via SiteScope without defining the path to the script interpreter in the master.config file.

3605406435

38668

Monitors

Fixed issue of not being able to read all counters for an SNMP by MIB monitor after compiling the MIB file by enabling a sequence of requests for SNMP and setting the maximum number of counters supported by the SNMP by MIB monitor.

  • To enable use of sequence of SNMP requests, select Use sequence of requests for SNMP by MIB in Preferences > Infrastructure Preferences > Monitor Settings.
  • Enter the maximum number of counters supported by the SNMP by MIB monitor in the Maximum number of counters for SNMP by MIB monitor box.

4601331852

33324

Monitors

Fixed issue of URL monitors producing an error when retrieving a page containing links to images with file names that include more than one period (".") in the extension. For example: myFile.cont.jpg

233658

36972

Monitors

Fixed issue with the URL Content monitor status calculation when a regular expression is defined in the Match content for error field.

4600703250

36161

Monitors

Fixed issue of the VMware Performance monitor being unable to receive the counter list if virtual machine names contain multi-byte characters (Japanese or Chinese).

4608989928

37806

Monitors

Fixed issue of content match not working correctly with the Web Service monitor. To enable Web Service monitors defined prior to an upgrade to match the correct value, select the Web Service Monitor use common content match option in Preferences > Infrastructure Preferences > Monitor Settings. This means that Web Service monitors behave in the same way as other monitors where content matching is used. Clear the setting to revert to the old content match behavior.

232116

35716

Monitors

Fixed issue when creating a monitor of not being able to use a regular expression containing more than 4 pairs of grouping parenthesis /(.)(.)(.)(.)(.)/ in the content match.

4609108166

37801

Monitors

Fixed issue of the monitoring interval for monitors changing to the Error frequency value when a Warning (instead of an Error) condition is detected.

4604770970

35766

Monitors

Fixed issue when using Monitor Deployment Wizard of not being able to deploy Siebel Solution Template monitors without remote server verification.

4609182256

39665

Monitor Deployment Wizard

Fixed issue of being unable to create a Management report due to a unique ID exception.

4607420102

37296

Reports

Fixed issue of Linux SSH-based monitors intermittently timing out.

3604355501

37474

SSH

Fixed issue of SiteScope Failover server taking over as the primary SiteScope and throwing an exception to the log file.

4605550755

37544

SiteScope Failover

Fixed issue when filtering objects in the SiteScope tree and then disabling some of the filtered objects using Manage Monitors and Groups, that all objects in the tree were disabled.

4608818921

38087

SiteScope Filter

Fixed issue in Health of SiteScope Server monitor of the Properties tab not displaying when DEBUG is enabled in the log4j.properties file.

4608338470

36729

SiteScope Health

Fixed issue of Health of SiteScope Server monitor not returning values properly when SiteScope is installed on Red Hat Linux.

4606767689

36460

SiteScope Health

Fixed issue of being unable to deploy an SNMP monitor from a template that had a remote defined within it (the SNMP monitor was prefixed with \\).

4610544917

39930

Template

Fixed issue of the XML Validator tool throwing exceptions on any XML file, instead of the file related to the auto template deployment.

4612659055

42751

Auto Template Deployment

Fixed issue in Mail Round Trip Tool when performing a Send only test, that the receiving server details are mandatory when IMAP4 is set.

4610983867

39838

Tools

Fixed issue of being unable to specify more than one LDAP service provider when logging in to SiteScope using LDAP authentication by adding support for a multiple providers list. For details, see "User Preferences" in Changes and Enhancements.

4603948909

42951

User Preferences

Notes and Limitations

Description

CR ID or SR/E-Sar Number

Area

To improve performance, SiteScope uses a topology cache when sending topology data to Business Availability Center's CMDB. If SiteScope attempts to send an existing CI to the CMDB, the CI may not be sent, or created in the CMDB, for up to a week because of the way the topology cache works.
This could happen in the following circumstances:

  • Cut and paste a monitor from one group into a new group. The original group is left empty. Cut and paste the monitor from the new group back into the original group.  
  • In HP BAC Integration Settings, disable data and topology reporting for a monitor and then enable again.
  • A CI that has been manually deleted from the CMDB is not created again until the cache is cleaned out. (EMS flow - Deleting EMS monitors from the CMDB)
Workaround:  If you cannot wait approximately one week to see the CIs, you can manually synchronize the data as follows:  In Preferences > Integration Preferences, edit the relevant integration and in the BAC Preferences Available Operations area, click Re-synchronize.
 

BAC Integration

Deploying SiteScope templates while registering a SiteScope to Business Availability Center may cause a loss of topology data reported to Business Availability Center. It is recommended to avoid making configuration changes while performing Business Availability Center registration.

 

BAC Integration

When working in System Availability Management Administration, the Link Monitor to CI function within SiteScope monitor configuration may not work properly if popups are blocked by the Business Availability Center server. Workaround: Create the link in Business Availability Center using the HP Universal CMDB application (Admin > Universal CMDB > IT Universe Manager).

 

BAC Integration

If SiteScope restarts for any reason while SiteScope establishes a Business Availability Center integration, some topology data that SiteScope forwards to Business Availability Center may be lost. Workaround: If not all topology data was forwarded to Business Availability Center, manually synchronize the data as follows:  In Preferences > Integration Preferences, edit the relevant integration and in the BAC Preferences Available Operations area, click Re-synchronize.

 

BAC Integration

When working under high load conditions, you should suspend all monitors before connecting to HP Business Availability Center for the first time.

 

Capacity Limitations

When SiteScope is integrated with HP Business Availability Center, performing various very high load operations might cause problems in SiteScope. Use the following guidelines:

  • Do not run the Publish Template Changes Wizard for over 3,000 monitors at once.
  • Do not run the Monitor Deployment Wizard to create over 3,000 monitors at once.
  • Do not copy/paste over 3,000 monitors in a single action.
  • Do not perform a Global Search and Replace to modify Business Availability Center integration properties for over 2,500 monitors at one time.

30633

Capacity Limitations

If SiteScope is installed on Microsoft Windows Server 2008, the time zone offset should be defined manually in Preferences > Infrastructure Preferences > General Settings > Time Zone offset, in hours, from Greenwich Mean Time (GMT). For example, if the time zone is GMT +2, type "-2" as the time zone offset. If the time zone is GMT -5, type "5" as the time zone offset. For GMT, type "-999" or "0".

4605889641 (SR)

Configuration

SiteScope group MG files will be deprecated in SiteScope 11.00. Although MG files are still supported in SiteScope 10.12, the Enable configuration files option is no longer selected by default when SiteScope is installed. When upgrading from an earlier version of SiteScope that has this option selected, the MG configuration files are supported.

 

Configuration

When creating a Diagnostics Integration in Integration Preferences, if you select the option Include additional data, all other Diagnostics and Generic Data integrations are affected and will report additional data in the data SiteScope forwards to these applications.  It is recommended to select this option only if you require this additional data for all your Diagnostics and Generic Data integrations.  For details on the option, refer to the "New/Edit Diagnostics Integration Dialog Box" in the "Integration Preferences User Interface" section in Using SiteScope help.

 

Diagnostics Integration

The Dashboard column layout in the Monitor History view cannot be saved during user sessions.

20806

Dashboard

The Review Summary page displays the real host name of the monitored server instead of the name by which the remote machine should be known in SiteScope. This means that you cannot differentiate between multiple remote servers created for the same host machine (for example, where one remote server uses the WMI connection method and another uses NetBios).

 

Global Search and Replace

When performing a global search and replace operation in a load environment of over 1,000 monitors, you may encounter an out of memory error in the Java applet on the client machine performing the global search and replace.
Workaround: Increase the heap size of the Java applet on the client machine. Click Start > Control Panel > Java > Java tab. View the Java Applet Runtime Settings and enter the following in the Java Runtime Parameters field: -Xmx128m (default is 64m).

27880

Global Search and Replace

When using Global Search and Replace, the Server property is available only when monitors from the following group are selected: CPU monitor, Disk Space monitor, Memory monitor, Microsoft Windows Performance Counter monitor, Web Server monitor, or Service monitor. For other monitors, the Server property can only be changed by selecting that specific monitor subtype in the Select Subtype page. For example, if a CPU monitor is selected with a Web Server monitor, the Server property is available. If a monitor not from this group is also selected, the Server property is not available.

36248 / 4605639358

Global Search and Replace

When using the SNMP Browser Tool or the XSL Transformation Tool, the results may not be readable in languages other than English. Workaround: Click the Save To File button, save the results to an external file, and open the file with an external editor.

32444

I18N

For the SiteScope user interface to start, Java Runtime Environment (JRE) must be installed on the SiteScope client machine. If you are using JRE 5, you might get Java script validation errors when opening dialog boxes in SiteScope. Using Firefox 3.0 with JRE 5u14, 5u15, or 5u16 causes the applet to freeze any operation until the browser is closed. Workaround: Configure you browser to use JRE 6u10 or later.

20599, 22818, 24623

Installation and Upgrade

The SiteScope user interface does not start and the following error message is displayed: "Several Java Virtual machines running in the same process caused an error". This is a known Java defect (http://bugs.sun.com/view_bug.do?bug_id=6516270) that might occur when using Internet Explorer 7. Workaround: Either: (1). Use a browser other than Internet Explorer 7. (2). Upgrade to Java 6 update 10 or later. (3). In the Add or Remove Programs dialog box (Start > Control Panel > Add or Remove Programs), remove all Java/Java Runtime Environment installations except for the latest version.

 

Installation and Upgrade

The SiteScope user interface does not start and an error message is displayed while starting the SiteScope applet (for example: "The Java Runtime Environment cannot be loaded"). Workaround: Perform the steps below. After each step, try to reopen SiteScope. If SiteScope fails again, proceed to the next step. (1). Close all the browser's windows. (2). End all remaining browser processes (if any remained) using Windows Task Manager. (3). Clean the local Java applet cache. Select Start > Control Panel > Java, and in the General tab, click Delete Files and then click OK. (4). Clean the local Java applet cache by deleting the content of the following folder: C:\Documents and Settings\<user_name>\Application Data\Sun\Java\Deployment\cache.

 

Installation and Upgrade

SiteScope does not start after upgrading a configuration that contains a DHCP monitor if the Java DHCP library has not been installed on the server where SiteScope is running. Workaround: (1). Download the jDHCP library (either in .zip or in .tar.gz format) from http://www.dhcp.org/javadhcp/. (2). Extract the file named JDHCP.jar and copy it to the <SiteScope root directory>\WEB-INF\lib directory. (3). Restart the SiteScope service.

32628

Installation and Upgrade

After upgrading from SiteScope 7.5 to 9.0 and then to 10.1x, if 7.5.x contained an administrator user and a regular user and the username and password for the administrator was blank, some or all of the monitors and alerts may not be displayed in the user interface after the upgrade. Workaround: After upgrading to SiteScope 9.0, enter the username and password for the administrator user in Preferences > Users Preferences in the user interface.

32727

Installation and Upgrade

The SiteScope menu bar opens but the applet fails to start, and you see a blank screen or an "x" image. Click Start > Control Panel > Java, and in the Java Control Panel, click the Advanced tab. Expand the Default Java for browsers folder (or <APPLET> tag support if you are using Java 5), and make sure that Microsoft Internet Explorer and Mozilla family are selected. Click Apply and then click OK.

 

Installation and Upgrade

If you type the incorrect license number when installing SiteScope, perform the following:

  1. Open the master.config file located in the <SiteScope root>\groups directory, and delete the _license= key value.
  2. Use the PersistencyViewer.bat tool located in <SiteScope root >\SiteScope\bin to search for the following SiteScope objects and delete their _license key value:
    • Filter: com.mercury.sitescope.platform.configmanager.preferences

      Object id: GeneralDefaultPreferences_
    • Filter: com.mercury.sitescope.platform.configmanager.MasterConfig

      Object id: _masterConfig
 

Installation and Upgrade

The ability to report topology data to HP Business Availability Center was enhanced with several complex topologies (such as WebSphere, WebLogic, and so forth). SiteScope must collect the properties for these topologies on the first start after an upgrade. This may take some time because it means connecting to the monitored servers and getting the additional data. A problem may arise during this first restart if this takes longer than 15 minutes because SiteScope automatically restarts if there are no monitors running within 15 minutes. Workaround: After an upgrade, use the following batch file to start SiteScope for the first time: <SiteScope root directory>/bin/go.bat. Once SiteScope is started, for any monitors that are monitoring environments that are not running, select Disable reporting to BAC under the BAC Logging Options. This saves wasted time waiting for the monitored servers to reply.

 

Installation and Upgrade

An Internet Explorer exception error message is thrown inside SiteScope pages, indicating Operation aborted. Workaround: Remove or disable the Skype add-ons on your system. For further details, see http://support.microsoft.com/default.aspx/kb/927917.

 

Installation and Upgrade

If templates and solution templates are missing from the Templates context after installing SiteScope, copy all the templates from the <SiteScope root>\export directory to the <SiteScope root directory>\persistency\import directory (you might need to create this folder if it does not exist).

 

Installation and Upgrade

When logging to SiteScope using LDAP authentication, unable to generate a Management Report due to authentication issues. Workaround: Define the user password in SiteScope to be the same as the one used in LDAP.

31883

LDAP Authentication

Monitor Thresholds. If you clear or add a counter (from the counters tree in the Monitor Settings panel) that has corresponding thresholds defined in the Threshold Settings panel, the counter might be replaced in the Threshold Settings with the next selected counter in the counter tree, replaced by the default counter, or removed from the Threshold Settings panel. This limitation applies to all browsable monitor counter types in template mode only, and to the Microsoft Windows Resources, Apache, and Health monitors in normal and template mode.

 

Monitors

Monitor Tree. If there is a large space between group containers in the SiteScope monitor tree, refresh your browser.

 

Monitors

Composite monitor. The copy to template action is not supported for the Composite monitor (if you click Copy to Template, the server names of the group of monitors that are being monitored by the Composite monitor are copied to the template with the $$SERVER_LIST$$ variable instead of the names of the actual servers).

27803

Monitors

Disk Space monitor. The Disk Space monitor displays slightly different results depending on the protocol that is used (NetBIOS, WMI or non-perfex based SSH).

28593

Monitors

File monitor. If Telnet is used as the connection method for UNIX remote servers running on an HP-UX or Linux operating system, and either (1) the LANG environment variable is unset, or (2) "set -u" is in effect and the LANG or LC_ALL environment variables are unset, the File monitor will not work regardless of the file it is monitoring. Workaround: Permanently set the LANG and LC_ALL environment variables to the default shell for the SiteScope user.

23798

Monitors

Microsoft Windows Event Log monitor. The Microsoft Window Event Log monitor is only able to retrieve partial data when monitoring the event log on a Windows Server 2008 because it cannot read the message DLL file.

30719

Monitors

Microsoft Windows Event Log monitor. The Microsoft Windows Event Log monitor is unable to monitor "Critical" event types on Windows 2008 servers. This is because the event type is not supported in the Event Type list. This limitation is relevant for SiteScopes installed on Windows Server 2008 only.

32441

Monitors

Microsoft Windows Media Server monitor. The Microsoft Windows Media Server monitor is unable get counters from the remote server when monitoring on Windows Server 2008 (64bit).

34286

Monitors

Ping monitor. When SiteScope is installed on Solaris, the Ping monitor might take longer than expected to run, and exceed the timeout for displaying the monitor status in the popup window (the default timeout is 5 seconds). Workaround: In the Ping Monitor Settings panel, increase the value in the Timeout (milliseconds) field.

26236

Monitors

Script monitor. When defining a Script monitor to monitor a Linux remote server using the Telnet connection and the script is defined as USE COMMAND, the match expression may not work properly. This could be caused by a limitation in the number of characters that can be used to run the USE COMMAND. By default, the terminal command line has a length limitation on the size of the command per line.

30899

Monitors

SNMP monitor. When the SNMP monitor is integrated to report data to HP Diagnostics, the measurement label is sent as a name instead of the real measurement name. Workaround: Use the SNMP by MIB monitor instead.

 

Monitors

Technology Integration monitor.

  • When creating a Technology Integration monitor for integrating measurements into HP Business Availability Center (by selecting Measurements as the Sample type in the Field Mapping area of the monitor properties), SiteScope reports only system topology data for the monitor to HP Business Availability Center. This is the standard host topology SiteScope reports to HP Business Availability Center. This cannot be changed by adding a script in the Topology Settings area. If you add a topology script, the script will fail.
  • When creating a Technology Log File Integration monitor, it is recommended to perform the Test Script (during monitor configuration, in the Topology Settings area, select a topology script in the Script field and click Test Script) of the topology script using a short log file. If a long log file is used for testing the topology script, it may take several minutes.

25754

Monitors

After changing the user name or password of a credential profile, any open connections that are using this credential remain open and are not reconnected. Workaround: Restart SiteScope.

30651

Preferences

The current SiteScope Failover solution will be replaced in SiteScope 11.00 with a new SiteScope Failover solution. The new solution will not be backwards compatible with older versions of SiteScope Failover, and all SiteScopes monitored by the new solution will need to be upgraded to SiteScope 11.00.

 

SiteScope Failover

If you experience monitor skips when using the SSH retries mechanism on a UNIX remote server, check the monitor run frequency and the _numberOfRepeatExecForSSHConnection and _UNIXSSHTimeoutSeconds property values in the master.config file to make sure they are not the cause of the skips (for example, if monitor frequency equals the SSH timeout). Note that time is used from _UNIXSSHTimeoutSeconds for every unsuccessful retry. Therefore, if the number of retries is set too high (so that it is longer than the monitor run frequency), this can increase the number of monitor skips and cause SiteScope to restart.

 

SSH

F-Secure is no longer officially supported when monitoring remote servers using SSH.

 

SSH

The Plink SSH connection method is no longer supported when working with remote servers. You should switch to the Internal Java Libraries connection method instead.

36368, 36370

Remote Servers/SSH

Due to a bug in Sun Java, SiteScope installed on Solaris 10 is unable to connect to a remote UNIX server via SSH using Internal Java Libraries. Workaround: In the file <SiteScope root directory>\bin\start-monitor, add the following to the argument list of the JRE (just before the -Dflipper.param.file argument):
-Djava.nio.channels.spi.SelectorProvider=sun.nio.ch.PollSelectorProvider

 

Remote Servers

If a Monitor Summary report is created using an Internet Explorer browser, and Export to file and Comma-delimited (csv) are selected in the Export Settings, an authentication popup window is displayed after clicking Generate Report. Workaround: In the authentication window, click Cancel and the file opens in Microsoft Excel.

30696

Reports

Copying and pasting from SiteScope 10.1x to earlier versions of SiteScope is not supported.

30669

System Availability Management Administration

When copying monitors, groups, or other entities between multiple SiteScope instances, tag assignments are lost even if the tags that were assigned to the copied entities on the source SiteScope are present on the target SiteScope.

32039

System Availability Management Administration

When copying and pasting a SiteScope monitor into a group, the monitor data can take up to an hour before it is displayed in Dashboard in HP Business Availability Center.

32040

System Availability Management Administration

When copying and pasting a monitor that includes a script alert from one SiteScope into another, the remote server of the script alert may not correctly copy into the target SiteScope. Workaround: If you are copying script alerts from one SiteScope to another, ensure that the remote server accessed by the script alert exists in the target SiteScope before copying.

 

System Availability Management Administration

The Technology Log File Integration monitor cannot be copied from one SiteScope to another. Workaround: Create an identical monitor on the target SiteScope (copy all monitor values to it from the original monitor). To copy a sub-tree containing Technology Integration monitors:
1). Copy the sub-tree to a temporary location in the same SiteScope.
2). Delete the Technology Integration monitors.
3). Copy the new sub-tree from the temporary location to the other SiteScope.
4). Delete the temporary location.
5). Create the Technology Integration monitors in the other SiteScope

30759

System Availability Management Administration

If a template contains an invalid dependency (the template contains a dependency that existed once but no longer exists in the imported template), no dependency is shown in the template deployment. When running the Publish Template Changes wizard, the Depends on property is displayed as a difference in the Content Changes page even though there is no dependency displayed in the template. Workaround: Add a new dependency in the template, remove it, and then click Save. This removes the non-existent dependency.

32397

Templates

If the Method or Operating system values in a template remote server contain an incorrect value or are not entered using the same case that is displayed in the drop-down list when configuring a remote server, verification does not work properly, and the first value in the drop-down list is inserted instead. Workaround: Enter the value exactly as it is displayed in the drop-down list on the Remote Servers page.

 

Templates

When using the Event Log Tool, if DNS is selected in the Log name box and the target server does not have a DNS server on it, the Application log content is displayed in the Results panel.

32543

Tools

When using the Database Connection Tool to apply properties to the Database Query monitor or Technology Database Integration monitor, the credential data is lost if a credential profile is selected instead of entering the credentials manually.

32050

Tools

  • The following monitors are end of life and will not work even if configured in previous versions:

Monitor

Recommended Alternative Monitor

Asset monitor
N/A
Astra Load Test
Web Script
Active Directory Performance
N/A
Avalon Event
Technology Integration monitors
BMC Patrol Event
Technology Integration monitors
BMC Patrol Metrics
Technology Integration monitors
CA Unicenter Event
Technology Integration monitors
Compaq Insight Manager Event
Technology Integration monitors
Concord Metrics
Technology Integration monitors
DB2
DB2 8.x
Dynamo
N/A
HP Systems Insight Manager Event
Technology Integration monitors
IPlanet Application Server
SunONE
IPlanet Server
SunONE
IPlanet Web Server
SunONE
Mercury Application Mapping
HP Discovery and Dependency Mapping application
NetCool Event
Technology Integration monitors
NetIQ Metrics
Technology Integration monitors
Network
Network Bandwidth
Quick Test Pro
Web Script
Remedy Ticketing
Technology Integration monitors
RTSP
Real Media Player
SAP
SAP Performance
SAP Portal
SAP CCMS (new)
SilverStream Server
N/A
Tivoli DM Metrics
Technology Integration monitors
Tivoli TEC Event
Technology Integration monitors
WebLogic 5.x Application Server
N/A
WhatsUp Event
Technology Integration monitors

System Requirements

Below are the minimum server and client system requirements and recommendations for running SiteScope, based on the various supported operating systems.

Installation Prerequisites

SiteScope 10.12 must be installed on top of SiteScope 10.1x.

Server System Requirements for Windows

Computer/Processor
800 MHZ or higher
Operating System
Microsoft Windows 2000 Server/Advanced Server SP4
Microsoft Windows 2003 Standard/Enterprise SP1, SP2
Microsoft Windows Server 2003 Enterprise R2 SP1, SP2
Microsoft Windows Server 2008 Standard Enterprise SP2
Memory
1 GB minimum (2 GB+ recommended)
Free Hard Disk Space
2 GB or more (10 GB+ recommended)
Web Browser
Microsoft Internet Explorer 6.0 (SP1 or later) and 7.0
Firefox 2.0, 3.0
Java Plug-in (to view applets)
Recommended: 6u11 and later

Server System Requirements for Solaris

Computer/Processor
Sun 400 MHz UltraSparc II Processor or higher
Operating System
Sun Solaris 9 or 10 (with latest recommended patch cluster)
Memory
1 GB minimum (2 GB+ recommended)
Free Hard Disk Space
2 GB or more (10 GB+ recommended)
Web Browser
Firefox 2.0, 3.0
Java Plug-in (to view applets)
Recommended: 6u11 and later

Server System Requirements for Red Hat Linux

Computer/Processor
800 MHZ or higher
Operating System
RedHat ES/AS Linux 3 or 4, 4.3, 5.2
Memory
1 GB minimum (2 GB+ recommended)
Free Hard Disk Space
2 GB or more (10 GB+ recommended)
Web Browser
Firefox 2.0, 3.0
Java Plug-in (to view applets)
Recommended: 6u11 and later

Note: SiteScope can be installed as a 32-Bit application over 64-Bit environments for the supported operating systems listed above.

Server System Requirements for VMware

The following VMware environments are supported in SiteScope according to the configurations tested below:

Supported and Tested Environments
VMware ESX 3.0
VMware VirtualCenter 3.0
Supported Environments Only
VMware VirtualCenter 2.x
VMware ESX 3.x
VMware ESX 2.5 via VirtualCenter 2.x
VMware ESX 3.x via VirtualCenter 3.x
VMware vCenter Server 4.0VMware ESXi 4.0
VMware ESX 4.0
VMware Configuration Tested
2 VMware Virtual Machines (VM) on one physical server.
Each VM with 2 CPUs at 2Ghz, 2 GB memory, and 10 GB disk space.
No other VMs resident on this physical server.
VMTools installed.
SiteScope Configuration Tested
1 SiteScope on each VM (No other application resident on the VMs).
Each VM with the same version of SiteScope.
6500 total monitors with no more than 650 monitor runs per minute on each VM.

Use these minimum system requirements when installing SiteScope on VMware environments:

Computer/Processor
4 Intel Xeon physical processors, 2 GHz each
Operating System
Microsoft Windows 2003 Standard/Enterprise SP1
Memory
4 GB
Free Hard Disk Space
20 GB (Hard Disk speed: 7200 rpm)
Network Card
1 physical gigabit Network Interface Card
Java Plug-in (to view applets)
Recommended: 6u11 and later
Other Software
VMTools must be installed

Note: Monitor capacity and velocity can be significantly impacted by numerous factors including, but not limited to the following: SiteScope server hardware, operating system, patches, third-party software, network configuration and architecture, location of the SiteScope server in relation to the servers being monitored, monitor types and distribution by type, monitor frequency, monitor execution time, Business Availability Center integration, and Database Logging. The published maximums should not be assumed to be possible in every environment.

Certified Configuration

The following configuration has been certified in a high load environment for an installation of SiteScope that was integrated with HP Business Availability Center. This configuration replaces the recommended configuration that appears in the SiteScope Deployment Guide.

Operating System
Microsoft Windows Server 2003, Enterprise Edition
Version: 5.2.3790 Service Pack 2 Build 3790
System Type
x86-based PC
CPU

4 Intel Xeon 5160 physical processors, 3 GHz each

Total Physical Memory
16 GB
Java Heap Memory
1024 MB
Total Number of Monitors
16000
Total Number of Remote Servers
1250
Monitor Runs per Minute
2000

HP SiteScope Support Matrices

HP Business Availability Center Integration Support Matrix

HP SiteScope Version
HP Business Availability Center Version
8.0x
8.00
7.5x
SiteScope 10.12
Certified
Certified
Certified

Note: SiteScope 10.12 integration with HP Business Availability Center 7.0x has been verified, however it is not officially supported.

HP Software Support

This web site provides contact information and details about the products, services, and support that HP Software offers. For more information, visit the HP Support web site at: HP Software Support Online.

HP Software support provides customer self-solve capabilities. It provides a fast and efficient way to access interactive technical support tools needed to manage your business. As a valued support customer, you can benefit by being able to:

  • Search for knowledge documents of interest
  • Submit and track progress on support cases
  • Submit enhancement requests online
  • Download software patches
  • Manage a support contract
  • Look up HP support contacts
  • Review information about available services
  • Enter discussions with other software customers
  • Research and register for software training

To access the Self-solve knowledge base, visit the Self-solve knowledge search home page.

Note: Most of the support areas require that you register as an HP Passport user and sign in. Many also require an active support contract. To find more information about support access levels, go to: Access levels.

To register for an HP Passport ID, go to: HP Passport Registration.

Legal Notices

© Copyright 2010 Hewlett-Packard Development Company, L.P.

Confidential computer software. Valid license from HP required for possession, use or copying. Consistent with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard commercial license.

The only warranties for HP products and services are set forth in the express warranty statements accompanying such products and services. Nothing herein should be construed as constituting an additional warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

For information about third-party license agreements, see the Third_Party_Agreements directory on the product installation media.

Trademark Notices

Adobe® and Acrobat® are trademarks of Adobe Systems Incorporated.

Intel®, Pentium®, and Intel® Xeon® are trademarks of Intel Corporation in the U.S. and other countries.

JavaTM is a US trademark of Sun Microsystems, Inc.

Microsoft®, Windows®, Windows NT®, and Windows® XP are U.S registered trademarks of Microsoft Corporation.

Oracle is a registered trademark of Oracle Corporation and/or its affiliates.

UNIX® is a registered trademark of The Open Group.

Acknowledgements

This product includes software developed by the Apache Software Foundation (www.apache.org/).

This product includes Java Runtime Environment, including JSSE, JIMI, and JDNI from Sun Microsystems.

This product includes packages from i-net software GmbH (http://www.inetsoftware.de/ products/jdbc-driver).

This product includes the Java Generic Library package from ObjectSpace.

This product includes the Java PerlTools package from ORO.

This product includes MindTerm secure shell Java client from AppGate Network Security.

This product includes the Berkley DB from SleepyCat Software (http://www.oracle.com/database/berkeley-db/index.html).

This product includes the Java MD5 library from Santeri.

This product includes the Java SNMP package from Netaphor Software.

This product includes the SNMP Utilities from AdventNet, Inc (http://www.adventnet.com/ products/snmputilities/index.html).

This product includes the PuTTY NT SSH client (SiteScope for Windows Only) from Simon Tatham.

This product includes the ANTLR from Terrence Parr (http://www.antlr.org/license.html).

This product includes Concurrent utilities for Java from Doug Lea (http://gee.cs.oswego.edu/dl).

This product includes SEDA from Matt Welsh (and The Regents of the University of California) (http://www.eecs.harvard.edu/~mdw/proj/seda/#copyright).

This product includes JEP from Singular Systems (http://www.singularsys.com/order/ license.html).

This product includes Java XML Parser from Datachannel.

If you have any comments or suggestions regarding this document, please send them by e-mail to SW-Doc@hp.com.



© Copyright 2010 Hewlett-Packard Development Company, L.P.