HP Service Virtualization
Software Version: 3.62
Document Release Date: December 2014
Software Release Date: December 2014
Note: To verify that you are using the most recent version of this document, or check for recent updates of any other HP Service Virtualization documentation, visit the HP Software Product Manuals site (requires an HP Passport).
This file provides the following information about HP Service Virtualization 3.62:
This section provides an overview of the features that were introduced or enhanced in HP Service Virtualization. For additional details, see the HP Service Virtualization User Guide.
Protocol Enhancements
Simulation Enhancements
Batch simulation performance enhancements. Improved stability of scheduled batch response simulation with minor UI enhancements, enabling you to:
Service Virtualization Statistics Improvements
SVN Integration Improvements
Other Improvements
Message logging:
Disabled message logging. Message logs store raw message data. To further protect your data, message logging is now automatically disabled if data masking is configured for the service.
Step-by-step installation instructions for Service Virtualization can be found in the HP Service Virtualization Installation Guide. The Installation Guide is available in PDF format in the root folder of the Service Virtualization installation package.
You can also open the Installation Guide from the Windows Start menu after installation.
This section includes:
Minimum hardware configuration
Recommended hardware configuration
For a complete list of all supported operating systems, database servers, browsers, and development environments, see the Service Virtualization support matrix on the HP Software Support site at: http://h20230.www2.hp.com/sc/support_matrices.jsp.
Minimum hardware configuration
The HP Service Virtualization Server 3.62 and HP Service Virtualization Designer 3.62 can run on any hardware configuration that is using a supported operating system and has at least 1GB of physical memory installed and available for each product.
With the minimal hardware configuration, you can perform all functional testing scenarios and some basic performance testing scenarios, provided that they do not create too much load on virtualized services.
Recommended hardware configuration
Virtualization hardware sizing is complicated and may include many factors. For detailed sizing recommendations, contact HP Customer Support. For contact information, see HP Support.
The following hardware configurations provide a good performance balance for normal usage scenarios, where each product is installed on a separate machine.
| HP Service Virtualization Designer |
|
| HP Service Virtualization Server (32-bit edition) |
|
| HP Service Virtualization Server (64-bit edition) |
|
| Database server |
|
The following issues were fixed since the last released version:
Observation: Charts in the exported excel file are displayed incorrectly when the default template for exporting service statistics is modified in MS Excel 2010 or 2013.
Observation: Export of statistics using new templates for statistics export created in MS Excel 2013 or 2010 fails.
Observation: When a virtual service is used for 24 hours (messages are sent for the whole day), statistics data for the service uses approximately 4MB each day.
Observation: Real service is receiving requests even if virtual service is simulating.
Workaround: Stop real service before starting simulation.
Observation: Putting a service into Simulation mode generates an error, written to the server log: TIBCO.EMS.ADMIN.AdminSecurityException: Properties of dynamic destinations are not mutable.
Workaround: Create a destination in EMS for BusinessWorks(BW) service before such service is deployed to a BW Runtime Agent to avoid the creation of dynamic destinations.
Observation: Putting service into Simulation mode generates an error, written to the server log: TIBCO.EMS.ADMIN.AdminSecurityException: Not allowed to change permissions of specified principal.
Workaround: Reconfigure the service to avoid using an admin EMS account.
Observation: Messages with huge attachments may cause the data model editor to freeze.
Workaround: No known workaround.
Observation: Microsoft Access Database Engine 2010, necessary for data driving functionality, cannot be installed on the same computer as MS Office 64-bit.
Workaround: Install MS Office 32-bit.
Observation: When there is any condition other than Ignore on the activity response in a rule with an enabled execution of this activity, the rule will never match.
Workaround: Set an Ignore condition on the topmost element in the activity’s response. Create an additional rule that will contain the original conditions from the activity’s response along with all actions that should be executed when these conditions match.
Observation: If JMS virtual service is configured and the WSDL of WebLogic JMS service is imported in Designer’s virtual service wizard, then WebLogic JMS URL is not parsed correctly and therefore the real destination name (real service endpoint) in the virtual service wizard is not pre-filled automatically.
Workaround: Manually fill in the real destination name in the virtual service wizard. Note that WebLogic uses specific JMS URI format, e.g.: jms://myHost:7001/transports/JMSTransport?URI=JMSTransportQueue (see http://download.oracle.com/docs/cd/E12839_01/web.1111/e13735/jmstransport.htm).
Observation: Client gets errors from server, which resets existing connections.
Workaround: Use Windows Server 2008.
Observation: When working in a project containing a virtual service running on WebSphere MQ that was migrated from HP Service Virtualization 2.00, if you learn additional requests into the service, simulation fails with the following error: “Error while sending message to jms:queue:xxx: Exception has been thrown by the target of an invocation”. The log contains the exception “System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> IBM.WMQ.MQException: MQRC_MD_ERROR”. No message is received by the client.
Workaround: In the Service Description Editor, edit response metadata and disable all learned WebSphere MQ properties.
Observation: User cannot connect to a secured standalone Service Virtualization Server with a user name or password containing non-English characters.
Workaround: Use unsecured standalone server.
Cannot virtualize service with Basic authentication and credentials containing non-English characters on HTTP(s) Gateway agent.
Observation: Virtualization of the service secured with HTTP Basic authentication fails on the HTTP(s) Gateway agent if client credentials contain non-English characters.
Workaround: Use the HTTP(s) Proxy agent to virtualize the service.
Connection to real service fails when using mutual HTTPS.
Observation: Client application does not send the client certificate to establish mutual HTTPS connection.
Solution: Make sure that the Trusted Root Certificate Authorities list on the machine where Service Virtualization is installed does not contain too many installed authorities (50-100). Clean unused or unnecessary authorities to keep the list small. Mutual HTTPS requires the list of trusted authorities to be sent to the client in packet of limited size. The client uses the list to select the correct client certificate. If there are too many authorities, the sent list will be truncated, and your required authority may be in the truncated part.
Observation: Import of COBOL message messages for all COBOL related protocols has the following limitations:
1. File content is previewed with invalid characters.
2. Default encoding/character set is used for processed content. The default value is IBM037 (IBM COM EUROPE EBCDIC).
Workaround:
1. No current workaround.
2. Modify the Designer/Server application configuration file (named HP.SV.StandaloneServer.exe.config or VirtualServiceDesigner.exe.config) and add/update the following lines, replacing the value with the desired encoding:
<configuration>
<appSettingsOverride>
…
<add key="ImsMessageProcessor.DefaultCodePage" value="IBM037" />
<add key="CobolMessageProcessor.DefaultCodePage" value="IBM037" />
…
</appSettingsOverride>
</configuration>
Observation: Error message similar to "Bad Request - Invalid Hostname - HTTP Error 400. The request hostname is invalid" appears in browser when trying to connect to a service using an IPv4 address (something like 16.55.195.180).
Workaround: Either use the service’s host name instead of IPv4 or set the proxy server to HTTP proxy agent’s IPv4 address instead of the host name.
Observation: New virtual service wizard by default sets the first available agent for the given virtual service type, and the Test Endpoint on the Service Properties page of the wizard uses this agent.
Workaround: Continue to the last page of the wizard (Virtualization Summary), and use the Change link in the Virtual Service section to select a custom agent. Run Test Endpoint again. If a project is also created along with a virtual service, choose a project server before changing the agent, by using the Change link in the Project section of the Virtualization Summary page.
Observation: During simulation of a Websphere JMS service, the client does not receive any response, and Service Virtualization generates an error such as: The value for 'JMS_IBM_Character_Set':'sim_default_JMS_IBM_Character_Set' is not valid.
Workaround: Open the data model editor for the relevant data model and expand the Default Rule. Either fill in the proper value for the JMS_IBM_Character_Set column in the response, or set as Not Present. Repeat for all necessary operations.
Observation: MQ Client receives a timeout or a long delayed response, and/or Service Virtualization generates an error such as “Unable to get destination 'hp.sv.dynamic.response.queue.1': MQ reason code is 2085, MQ error is MQRC_UNKNOWN_OBJECT_NAME. ---> IBM.WMQ.MQException: MQRC_UNKNOWN_OBJECT_NAME”. This may happen because the MQ Server and the Service Virtualization Server have different time and performance models and therefore records a long response time.
Workaround: All peers should have the proper time synchronization set. To fix a recorded time difference, either edit the performance model and update the response time value, or use the None performance model for simulation.
Observation: Simulation COBOL over MQ service can fail in some cases. This can be caused by an added default value of MQIIH header from the Default rule.
Workaround: Edit the data model of the service. In the Default rule, set the MQIIH header to the value Not Present.
Observation: When a service with a single data model containing multiple data driven rules, or a service with multiple data models with a data driven rule is switched to simulation mode, a DataDriving timeout can occur and data from MS Excel file are not refreshed.
Workaround: Turn off data synchronization of some data driven rule and manually refresh external data when needed.
Observation: Manual modification of a complex XML schema type in a service description is not supported when the complex type is either created by type derivation (restriction or extension), or is a base type in a complex type derivation.
Workaround: Create a new service using a modified service description.
Observation: In the ALM Resources module, uploading files to a Service Virtualization resource corrupts the Service Virtualization project/service.
Workaround: Do not upload files to a Service Virtualization resource using the ALM client.
Observation: WSDLs with more than 100 operations with large schemas (more than 200 leaves) are not supported.
Workaround: Split WSDL.
Observation: Simulation of a migrated REST service may reply with default responses instead of recorded data in case the UriPath parameter contains “./” values. Simulation of any HTTP based projects (SOAP, XML, Binary) using HTTP Gateway agents with enabled UriPath metadata in the data model may reply with default responses instead of recorded data.
Workaround:
a. Record the messages again.
b. Set ignore function on UriPath metadata (for non-REST projects).
Observation: Service Virtualization Designer randomly crashed during start or immediately after start, and the log contains an error message with fatal severity.
Workaround: Start Designer again.
Observation: IMS Connect protocol error messages are not supported.
Workaround: Not available.
Observation: Occurs when the service description is being learned and the type of the learned values is unknown (defaults to string values which cannot be translated to numeric values).
Workaround: In the Data Model Editor, edit values within the default rule so that they can be converted to a numeric value.
Observation: When a username or password contains non-ascii (national) characters, the user can log in to SVM (Service Virtualization Management) but credentials are not recognized by the Service Virtualization Server.
Workaround: Use a user account with credentials containing only ascii characters.
Observation: Learning empty arrays, when the array element has not been learned before, does not work properly. Simulation of such a service call is broken -- returns null instead of [].
Workaround: Learn/import a non-empty array element first. After that, the empty array’s type does not need to be deduced and the service call is learned correctly.
Observation: When enabling a disabled request metadata, the new column has the Is condition instead of the Ignore condition.
Workaround: Manually change the function on the metadata column to Ignore.
Observation: User has full permission (r,w,d,m) on a service but cannot see the service endpoint properly.
Workaround: Add the Read permission on the specific agent for the user.
Observation: Downloading a project archive from ALM in IE 8 opens a new window and no dialog box for saving the file is opened. Downloading a project archive from ALM in IE 9 opens a new tab and no prompt for saving the file is shown.
Workaround:
IE 8: Apply the procedure from http://support.microsoft.com/kb/323308 and then restart the computer.
IE 9: Switch to the previous tab where file save prompt is displayed.
Observation: User tries to connect to ALM. The error message “Failed to initialize JVM: JNI_ENOMEM (-4)” is displayed, indicating that JVM is unable to reserve the requested amount of memory.
Workaround 1: Open the “virtualservicedesigner.exe.config” file located in the “Designer\bin” folder. In appSettings section, find the key called "SV.JavaVm.PrealocatedMemorySize" and set the desired amount of memory. The recommended value is 256, as follows: “<add key="SV.JavaVm.PrealocatedMemorySize" value="256" />”. Restart the Designer and retry the connection to ALM.
Workaround 2: Open the “jvm-context” file located in the “Designer\bin\config” folder. Decrease the value of the first parameter in JavaOptions section. The initial and recommended value is “-Xmx128M” (128MB), so try to set it to “-Xmx64M”. Restart the Designer and retry the connection to ALM.
Note: You can combine both settings. In this case it is recommended that the “SV.JavaVM.PrealocatedMemorySize” value is set to double of the “–Xm” value.
Observation: Under a high load >10 parallel clients running against a virtual service with a scripted rule, the application may crash with the 80000003 Exception Code, mostly on a 32-bit system.
Workaround: Set maximum engine buffer size to less than 11 in the “scripted-rule-context.xml” file, located in the “Designer\bin\Config” or “Server\bin\Config”.
References are inlined in RPC/Enc communication.
Observation: When sending referenced elements in SOAP RPC/Encoded communication, referenced elements are inlined.
Workaround: None.
Observation: When multiple services are selected, the menu items Export Statistics or Export List are disabled.
Workaround: Make sure you selected services from the same server. Filter out servers that you don’t need.
Observation: When performing a hot swap to a new Performance Model that has batch simulation configured, the batch simulation does not work.
Workaround: Restart simulation to use the newly selected Performance Model.
Observation: After browsing and editing data in Data Model editor, the Designer application crashes.
Solution: Make sure you have latest version of Microsoft .NET Framework installed.
Observation: The .msi installer may fail with the error message "Error 997. Overlapped I/O operation is in progress" when it is run from the command line with logging enabled and when requiring a flush of the log file after each line using the /l*vx! install.log option.
Workaround: Remove the exclamation mark from msiexec logging parameter (! - Flush each line to the log).
For example:
Correct: msiexec /i HPServiceVirtualizationServer-x86.msi /l*vx install.log
Incorrect: msiexec /i HPServiceVirtualizationServer-x86.msi /l*vx! install.log
Observation: This issue occurs when upgrading from 3.61 to 3.62 using the .msp installation file. During installation, after selecting the "Backup" option and clicking next, the Server is automatically stopped, but backup fails with an error that the Server is running. The backup process waits only a short time for the Server to stop before it continues, causing the backup to fail. The next attempt to run backup is successful.
Workaround: Run Backup again, or stop the Server manually in the Windows services management console before running Backup.
Observation: C# rules do not display a result in simulation preview unless the virtual service is in Simulation mode.
Workaround: Switch the virtual service to Simulation mode.
Visit the HP Software Support Online web site at: http://www.hp.com/go/hpsoftwaresupport
This web site provides contact information and details about the products, services, and support that HP Software offers.
HP Software online support provides customer self-solve capabilities. It provides a fast and efficient way to access interactive technical support tools needed to manage your business. As a valued support customer, you can benefit by using the support web site to:
Most of the support areas require that you register as an HP Passport user and sign in. Many also require a support contract. To register for an HP Passport ID, go to:
http://h20229.www2.hp.com/passport-registration.html
To find more information about access levels, go to:
http://h20230.www2.hp.com/new_access_levels.jsp
HP Software Solutions Now accesses the HPSW Solution and Integration Portal Web site. This site enables you to explore HP Product Solutions to meet your business needs, includes a full list of Integrations between HP Products, as well as a listing of ITIL Processes. The URL for this Web site is http://h20230.www2.hp.com/sc/solutions/index.jsp
The only warranties for HP products and services are set forth in the express warranty statements accompanying such products and services. Nothing herein should be construed as constituting an additional warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.
The information contained herein is subject to change without notice.
Confidential computer software. Valid license from HP required for possession, use or copying. Consistent with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard commercial license.
© Copyright 2011 - 2014 Hewlett-Packard Development Company, L.P.
Adobe® is a trademark of Adobe Systems Incorporated.
Microsoft® and Windows® are U.S. registered trademarks of Microsoft Corporation.
UNIX® is a registered trademark of The Open Group.
Send documentation feedback to HP