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Documentation Updates

This guide’s title page contains the following identifying information:

• Software Version Number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

• Software Release Date, which indicates the release date of this version of the software.

To check for recent updates, or to verify that you are using the most recent edition of a document, visit 
the HP software product manuals web site at:

http://ovweb.external.hp.com/lpe/doc_serv/

You will also receive updated or new editions if you subscribe to the appropriate product support 
service. Contact your HP sales representative for details.
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Support

You can visit the HP software support web site at:

http://support.openview.hp.com/support.jsp 

HP Software online support provides an efficient way to access interactive technical support tools. As a 
valued support customer, you can benefit by using the support web site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require 
a support contract.

To find more information about access levels and HP Passport, visit the support web site at:

http://support.openview.hp.com/new_access_levels.jsp
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1 HP Storage Essentials
This chapter addresses the following topics:

• Overview

• Key Features and Benefits of HP Storage Essentials
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Overview

HP Storage Essentials (HP SE) is a family of open standards-built Storage Area Network 
(SAN) management and Storage Resource Management (SRM) solutions. It enables you 
to visualize, monitor, report on, provision, and manage your heterogeneous storage 
environment with unprecedented simplicity and speed. The HP suite delivers integrated 
heterogeneous functionality for network (DAS, SAN, NAS) management, storage 
resource management, provisioning, backup reporting, and application infrastructure 
monitoring. It integrates with HP Systems Insight Manager (HP SIM) to provide advanced 
server and storage management capabilities. The HP SIM suite includes HP Storage 
Essentials Enterprise Edition, and features a base management console and an expanding 
portfolio of value added plug-ins. The architecture and interfaces are based on industry 
standards, allowing for quick deployment and investment protection. HP SE is accessed 
through HP SIM menu items that are labeled HP Storage Essentials. It runs on a central 
server as the HP Storage Essentials central management application (AppStorManager 
service). It relies on CIM Extensions, which act as agents to provide information about 
hosts and applications. A CIM Extension is an agent program that gathers information 
about a host and its applications, and forwards this information to the HP Storage 
Essentials central management application.
10 Chapter 1



 Key Features and Benefits of HP Storage Essentials

HP Storage Essentials offers the following features and benefits:

• End-to-end visibility of business applications

Provides an interface to monitor business applications, including their associated 
infrastructure and interdependencies.

• Web-based global management console

Manages heterogeneous storage environments through a web-based user interface.

• Reporting

Offers flexible, in-depth report generation in both predefined and user-defined 
formats. It can also export data to other management applications.

• Standards-based architecture

Protects user flexibility and investments with a standards-based interface for 
managing heterogeneous storage environments.

• Storage server, network, and subsystem provisioning

Reduces manual processes and risk of downtime caused by free-space outages with 
multi-level storage provisioning.

• Integrated asset management and carriageable

Centralizes all aspects of storage inventory for maximum asset utilization. Improves 
accountability and budgeting with cost accounting-based carriageable on user-defined 
utilization characteristics.

• Integrated storage management

Lowers cost of acquiring and managing a heterogeneous storage environment by 
using multiple disparate point solutions.

• Visualization

Discovers automatically and maps the storage network (DAS, SAN, NAS) and 
backup topology by pictorially displaying the objects, path, and zones between the 
application and the LUN on which the corresponding data resides.
HP Storage Essentials 11



• Zoning and provisioning

Enables end-to-end zoning and provisioning tasks at the host, switch, and disk 
subsystem layers. Provides a common interface for a multi-vendor storage 
environment.

• Utilization management

Monitors availability and utilization at hosts, switches, and arrays. Provides graphical 
trending and forecasting. Soft Quota management enables proactive monitoring of 
consumption levels, and file system management provides file-level scanning, 
analysis, reporting, and policy-based management capabilities.

• Performance management

Monitors performance from application objects down to storage subsystems. 
Monitors applications, hosts, HBAs, switches, and disk subsystems. Enables quick 
detection of bottlenecks that cause performance problems.

• Chargeback

Supports customizable chargeback values, depreciation formulae, asset-based and 
storage-based chargeback models, and business unit groupings. Reports enable 
administrators to associate costs with the quality and quantity of storage used by 
different business units.

• NAS management

Analyzes the impact of configuration changes and file sharing activities.

• Backup management

Offers a single view of backup activities. Identifies unprotected applications, servers, 
and files. Enables root cause analysis of backup failure. Increases utilization of 
backup resources.

• Standards-based architecture

Designs solution on the Storage Management Initiative Specification (SMI-S), the 
storage industry standard for heterogeneous storage network management based on 
the Common Information Model (CIM) and Web-Based Enterprise Management 
(WBEM). Enables support for multi-vendor storage infrastructures and ensures that 
investments are protected.
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• Customizable reports

Generates an extensive set of out-of-the-box reports that satisfy requirements related 
to capacity management and planning, performance management, asset management, 
and chargeback. Reports can be customized and scheduled for automatic email 
distribution. Supports a wide variety of reporting formats, including HTML, XML, 
Microsoft Excel, and PDF.

For more information on features of HP Storage Essentials and other HP management 
products, see the following HP web sites at:

http://www.managementsoftware.hp.com/

http://www.hp.com/go/storageessentials
HP Storage Essentials 13
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2 HP Operations Smart Plug-in for HP 
Storage Essentials
This chapter addresses the following topics:

• Overview

• Features and Functionality
 15



Overview

HP Operations Smart Plug-in for HP Storage Essentials (HP SE SPI) integrates HP 
Storage Essentials (HP SE) with HP Operations Manager for Windows (HPOM). The 
HPOM management scope for HP SE SPI includes systems managed by HP Storage 
Essentials installed in an environment comprising an HPOM and one or more HPOM 
managed nodes. The HP SE SPI is used to monitor the HP Storage Essentials services. 
The HP SE SPI along with the HP Operations Manager Integration for HP Systems Insight 
Manager (HP SIM Integration) integrates HP Storage Essentials with HP Operations 
Manager by forwarding storage events through HP SIM Integration. The HP SIM 
Integration, together with the HP SE SPI, allows the storage network to be monitored and 
managed from the HPOM management server console. The HP SE SPI enables the HPOM 
administrators to troubleshoot problems in the storage network before they become 
serious enough to affect tools, and ultimately the end-users. Storage events are stored in 
the HP database. The HPOM intelligent agents are configured on the HP SIM CMS, the 
HP Storage Essentials CMS and managed servers which are managed nodes in the HPOM 
management domain.
16 Chapter 2



Features and Functionality

The HP Storage Essentials SPI offers the following features and functionality:

• Service discovery

Discovers the HP Storage Essentials CMS (SE CMS) and HP SE managed hosts CIM 
Extension services.

• Service and process monitoring

Monitors the availability of HP SE CMS and Storage Essentials CIM Extension. As a 
result, any service alerts can then be communicated to the HPOM Service map and 
the HPOM active message browser. This enables administrators to perform root-cause 
analysis of the inherent HP Storage Essentials services.

• Policy groups

Contains policies for monitoring the HP SE CMS process (AppStorManager) and the 
HP SE CIM Extension process.

• Tools groups

Contains tools to start, stop, and view the status of the HP SE CMS process 
(AppStorManager) and the HP SE CIM Extension process.

• Self-Healing Services (SHS)

Integrates with HPOM Self-Healing Services to provide improved troubleshooting, 
streamlined problem analysis, and incident reporting, by collecting data and system 
information relevant to the fault. SHS gathers troubleshooting data and saves it in a 
compressed file. For more information, see the Self-Healing Services web site at:

http://managementsoftware.hp.com/service/selfheal
HP Operations Smart Plug-in for HP Storage Essentials 17
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3 Installing HP Storage Essentials SPI
This chapter addresses the following topics:

• Prerequisites

• Installing HP Storage Essentials SPI

• Upgrading the HP Storage Essentials SPI

• Verifying Installation

• Installed File Locations
 19



Prerequisites

This section discusses the prerequisites for installing HP SE SPI. To avoid problems 
during the installation of the HP SE SPI software, it is mandatory that you read this 
section, and other documents recommended in this section before you start the installation 
process.

Hardware Requirements

You must read this section and any other documents recommended in this section before 
installing HP SE SPI. For a detailed list of hardware requirements, see the following 
documents: 

• For the HPOM 8.00 management server, see the HP Operations Manager for 
Windows Installation Guide.

• For the HPOM 8.00 HTTPS managed nodes, see the HP Openview Operations 
HTTPS Agent Concepts and Configuration Guide.

• For HPOM 8.00 DCE managed nodes, see the HP Openview Operations OVO DCE 
Agent Concepts and Configuration Guide.
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Table 1 lists the disk space requirements for each operating system.

Table 1 Disk Space Requirements

System Operating System Installation
Runtime 
Files Total

HPOM 
management 
server

Windows 2000 (supported 
only on OVOW 7.50)
Windows 2003 (32-bit)

4 MB 1 MB 5 MB

HPOM 
managed node

HP-UX 11.00 (supported only 
on OVOW 7.50)
HP-UX 11.11
HP-UX 11.23 IA
HP-UX 11.23 PA
HP-UX 11.31 PA
HP-UX 11.31 IA

1 MB 1 MB 2 MB

Solaris 8, 9,10

RedHat Linux Advanced 
Server 3.0 (32–bit),
RedHat Linux Advanced 
Server 4.0 (32-bit and 64-bit),
SuSE Linux Enterprise Server 
8 (32-bit),
SuSE Linux Enterprise Server 
9 (32-bit and 64-bit)

AIX 5.1, 5.2, and 5.3

Tru64 5.1B

Microsoft Windows 2000, 
Microsoft Windows 2003 
(32-bit)

1 MB 1 MB 2 MB

No additional memory (RAM) is required either on the HPOM or on the managed nodes 
for HP SE SPI.
Installing HP Storage Essentials SPI 21



Software Requirements

This section lists the software requirements for installing HP SE SPI.

Prerequisites

Following are the software requirements for installing the HP SE SPI:

• OVO for Windows 7.50 or HPOM for Windows 8.00 updated with the latest server 
and agent patches

• HP Systems Insight Manager 5.0 with SP5 or 5.1 with SP1

• HP Storage Essentials 5.1.0 or 5.1.1 (Linux)

• HP SIM Integration, Version 1.30

• HP Operations DCE Agent A.07.29, A.07.32

• HP Operations HTTPS Agent 08.50.011

• HP Operations Smart Plug-In Self-Healing Integration Component, Version 2.30

• Install OVOW_00244 patch for running the HP Storage Essentials SPI 1.30 on HP 
OVOW 7.50 

Table 2 lists HPOM versions supported by HP SE SPI.

For more information on installing HP SIM Integration, see HP Operations 
Integration for HP Systems Insight Manager Administrator’s Reference for 
HP Operations Manager for Windows.

Table 2 HPOM Management Server Versions

HPOM management 
server Operating System HPOM Agent Types

OVOW 7.50 Microsoft Windows 2000 DCE

Microsoft Windows 2003 
(32-bit)

HPOM 8.00 Microsoft Windows 2003 
(32-bit)

HTTPS
DCE
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Table 3 lists HP Systems Insight Manager CMS versions supported by HP SE SPI. 

Table 4 lists HP Storage Essentials CMS versions supported by HP SE SPI.

Table 5 lists CIM Extension and HPOM agents supported by HP SE SPI.

Table 3  HP Systems Insight Manager CMS Versions

HP Systems Insight Manager CMS Operating System

HP SIM 5.1 with SP1
HP SIM 5.0 with SP5

• Windows 2000 (supported only on 
OVOW 7.50)

• Windows 2003 (32-bit)

• RedHat Linux AS 4 (32-bit)

• SuSE Linux ES 9 (32-bit)

Table 4  HP Storage Essentials CMS Versions

HP Storage Essentials Operating System

HP SE 5.0
HP SE 5.0.1
HP SE 5.1.0

Windows 2000 (supported only on OVOW 
7.50)
Windows 2003

HP SE 5.1.1 RHEL 4.0 (32-bit) 
SLES 9 (32-bit)
Installing HP Storage Essentials SPI 23



Table 5 CIM Extension and HPOM Agent Versions

Agent Operating System

CIM Extension
HPOM Agent

Windows 2000 (supported only on OVOW 
7.50)
Windows 2003 (32-bit)
HP-UX 11.00 (supported only on OVOW 
7.50)
HP-UX 11.11
HP-UX 11.23 PA
HP-UX 11.23 IA
HP-UX 11.31 PA
HP-UX 11.31 IA
Solaris 8
Solaris 9
Solaris 10
RedHat Linux EL 3.0 (32-bit)
RedHat Linux EL 4.0 (32-bit)
RedHat Linux EL 4.0 (64-bit)
SuSE Linux ES 9 (32-bit)
SuSE Linux ES 9 (64-bit)
AIX 5L 5.1
AIX 5L 5.2
AIX 5L 5.3
Tru64 5.1 B
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Installing HP Storage Essentials SPI

You can install HP SE SPI from the HP Operations Smart Plug-ins DVD. The Installer 
executable verifies whether HPOM is installed. It also installs the package, and loads the 
selected packages to the HPOM management server.

To install the HP SE software bundle on HPOM, complete the following steps:

1 Ensure that the HPOM system where you want to install the HP SE SPI meets 
installation prerequisites. 

For more information, see Prerequisites on page 20.

2 Log in to HPOM as an administrator.

3 Insert the HP Operations Smart Plug-ins DVD. The installation wizard displays, as 
shown in Figure 1.
Installing HP Storage Essentials SPI 25



Figure 1 SPI Installation window
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4 Select SPI for HP Storage Essentials in the Product Selection window, and click Next.

5 Follow the on-screen instructions to complete the installation process. 

The wizard displays the status of the installation.

6 Click Finish to exit from the installation wizard.

For more information on installing HP Operations New and Upgraded Smart 
Plug-ins, see the HP Operations Smart Plug-ins DVD, Installation and Upgrade 
Guide.

Selecting SPI for HP Storage Essentials in the Product Selection window also 
installs HP SIM Integration.
Installing HP Storage Essentials SPI 27



Upgrading the HP Storage Essentials SPI

To upgrade to the latest version of  HP Storage Essentials SPI, complete the following 
steps:

1 Ensure you have read the hardware and software requirements in Prerequisites 
section.

2 If you want to preserve any policy customization that you have made in the previous 
version, you must take a backup to save the complete and current HP Storage 
Essentials SPI policies.

3 Stop HP Storage Essentials SPI Event Listener using the Stop Event Listener tool. 

4 Remove node from the node group using the De-assign node from node group tool. 

5 Install the HP Storage Essentials SPI from the DVD by following the steps mentioned 
in the Installing HP Storage Essentials SPI section. 

6 Ensure that Auto-deployment registry variable Disable is set to False. 

7 Assign node to node group that you have de-assigned using Assign node to node group. 
Re-deploy the instrumentations and policies manually if they are not deployed 
automatically. 

8 Run Get HP SIM Credentials tool and Start Event Listener tool. 
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Verifying Installation

To verify whether the installation of the HP SE SPI is completed successfully on HPOM, 
open the HPOM console and check whether the elements listed in Table 6 are present.

If the elements listed in Table 6 are not present in the HPOM console, you must uninstall 
and reinstall the HP SE SPI to resolve this issue.

Table 6 HPOM elements

HPOM Console Element

Node Groups HP SE CMS-Win
HP SE CMS-Unix
HP SE CIM Extn-Win
HP SE CIM Extn-Unix

Tool Groups HP Storage Essentials 

— AppStorManager-Win

— AppStorManager-Unix

— CIM Extension-Win

— CIM Extension-Unix

— HPSESPI Utils

Policy Groups HP Storage Essentials

— AppStorManager-Win

— AppStorManager-Unix

— CIM Extension-Win

— CIM Extension-Unix

— Service Discovery

User Roles HP Storage Essentials SPI Admin

For information on uninstalling HP SE SPI, see Uninstalling HP Storage Essentials SPI 
on page 67.
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For information on reinstalling HP SE SPI, see Installing HP Storage Essentials SPI on 
page 25.
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Installed File Locations

The installation process copies the necessary files on the HPOM.

Table 7 lists the files and directories that are created during the installation process of HP 
SE SPI on HPOM.

Table 8 lists the directories that are used on deployment of the policies to the HPOM 
managed node(s).

Table 7 Locations on the HPOM

File Type Location

Binaries and Scripts <OvInstallDir>install\HPSESPI
<OvOWShareInstallDir>SPI-Share\HPSESPI

Instrumentation <OvInstallDir>Data\shared\Instrumentation\Supported 
Operating Systems\HP Storage Essentials

Documentation <OvInstallDir>install\HPSESPI\doc

MofFiles <OvInstallDir>install\HPSESPI\NLS\1033\MofFiles

Table 8 File Locations for the HPOM Managed Node

Operating System Location

HP-UX, Solaris, Linux, Tru64  /var/opt/OV/bin/instrumentation

Microsoft Windows <OvAgentDir>\bin\instrumentation

AIX /var/lpp/OV/OpC/instrumentation

The HP SE SPI instrumentation scripts are copied into these paths when the HP Storage 
Essentials instrumentation is deployed to the managed nodes.
Installing HP Storage Essentials SPI 31
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4 Configuring the HP Storage Essentials 
SPI
This chapter addresses the following topics:

• Starting HP Storage Essentials SPI Configuration

• Installing HPOM Agent on Nodes

• Assigning Nodes to the HP Storage Essentials Node Group

• Obtaining HP Storage Essentials Credentials

• Deploying Instrumentation to CIM Extension Nodes

• Configuring the OVO Agent for a Non-root User
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Starting HP Storage Essentials SPI Configuration

Configuring the Storage Essentials SPI involves the following tasks:

• Installing HPOM Agent on Nodes

• Assigning Nodes to the HP Storage Essentials Node Group

• Obtaining HP Storage Essentials Credentials

• Deploying Instrumentation to CIM Extension Nodes
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Installing HPOM Agent on Nodes

The first step in configuring the HP SE SPI is installing the HPOM agent on all the nodes 
where HP SE SPI and/or IM Agents are installed. Before starting the HPOM agent 
installation, ensure that the system on which you want to install the HPOM agent meets 
the installation requirements mentioned in the Prerequisites on page 20. You can install 
the HPOM agent on a managed node by various methods. For more information on the 
various installation methods, see the HP Operations Manager for Windows Installation 
Guide and also the documents listed in Prerequisites on page 20.
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Assigning Nodes to the HP Storage Essentials Node 
Group

Assigning nodes to the node group involves:

• Assigning AppStorManager Node to the Node Group

• Assigning the CIM Extension Node to the Node Group

Assigning AppStorManager Node to the Node Group

This tool assigns the node to the chosen HP SE CMS node group and deploys the HP 
Storage Essentials policy groups AppStorManager-Win or AppStorManager-Unix 
(depending on your node’s operating system), and Service Discovery policies. The service 
discovery policy deployment causes the HP Storage Essentials discovery process to run. If 
an HP Storage Essentials service is not discovered, the corresponding monitor policy is 
disabled.

To assign the nodes, on which the Storage Essentials AppStorManager service is running, 
to the node group, complete the following steps:

1 Log in to the HPOM management server, and start the HPOM Console.

2 Select Tools→HP Storage Essentials→AppStorManager-Win or AppStorManager-Unix 
(depending on your node’s operating system), and right-click Assign AppStorManager 
node to node group.

3 Select All Tasks→Launch Tool. The Edit Parameters window displays, as shown in 
Figure 2.
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Figure 2 Edit Parameters–Assign AppStorManager node to node group

4 From the Select the nodes/services to replace $OPC window pane, select the node on 
which the Storage Essentials AppStorManager service is running.

5 Click Launch…. The Tool Status window displays, as shown in Figure 3.
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Figure 3 Tool Status–Assign AppStorManager node to node group

This assigns the node, on which the Storage Essentials AppStorManager process is 
running, to the HP SE CMS-Win or HP SE CMS-Unix node group.

Assigning the HP SE CMS node to the node group also invokes auto-deployment of HP 
SE SPI Service Discovery and AppStorManager Service Monitoring policies to the node. 
The HP Storage Essentials instrumentation gets auto-deployed along with the Service 
Discovery policy to the node.

When the new nodes in the HP SE CMS-Win or HP SE CMS-Unix node group are added, 
the Service Discovery policy is deployed to each new node.

The automatic policy deployment requires that the HPOM agent be present on the 
managed nodes. If the HPOM agent is not present on the Windows nodes, the 
management server deploys the agent automatically. For UNIX nodes, the agent must be 
installed manually. You can install the HPOM agent by various methods. For more 
information, see Installing HPOM Agent on Nodes on page 35.
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Assigning the CIM Extension Node to the Node Group

To assign the node, on which the Storage Essentials CIM Extension process is running, to 
the node group, complete the following steps:

1 Log in to the HPOM management server, and start the HPOM Console.

2 Select Tools→HP Storage Essentials→CIM Extension-Unix or CIM Extension-Win 
(depending on your node’s operating system), and right-click Assign CIM Extension 
node to node group.

3 Select All Tasks→Launch Tool. The Edit Parameters window displays, as shown in 
Figure 4.
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Figure 4 Edit Parameters–Assign CIM Extension node to node group

4 From the Select the nodes/services to replace $OPC pane, select the node on which the 
Storage Essentials CIM Extension process is running.

5 Click Launch…. The Tool Status window displays, as shown in Figure 5.
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Figure 5 Tool Status–Assign CIM Extension node to node group

This assigns the node, on which the Storage Essentials CIM Extension process is running, 
to the HP SE CIM Extn-Win or HP SE CIM Extn-Unix node group.

Assigning HP SE CIM Extension node to the node group also invokes auto-deployment of 
Storage Essentials CIM Extension Service Monitoring policy to the node.

When the new nodes are added in the HP SE CIM Extn-Win or HP SE CIM Extn-Unix 
node group, the Service Discovery policy is deployed to each new node.
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Obtaining HP Storage Essentials Credentials

To start the functionality provided with the HP SE SPI, you must first enter the HP SIM 
credentials for each HP SE CMS.

To obtain HP SE SPI credentials, complete the following steps:

1 Log in to the HPOM management server, and start the HPOM Console.

2 Select Tools→HP Storage Essentials→HPSESPI Utils, and right-click Get HP SIM 
Credentials.

Enter the same credential that is used to log in to HP Systems Insight Manager. The HP 
SIM credentials used must have the role Domain_Admin in Storage Essentials CMS for 
the HP SE SPI to function correctly. HP SIM credentials are stored in an encrypted format 
on the HPOM managed nodes.
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3 Select All Tasks→Launch Tool. The Edit Parameters window displays, as shown in 
Figure 6.

Figure 6 Edit Parameters–Get HP SIM Credentials

4 From the Select the nodes/services to replace $OPC parameters with: pane, select the 
node on which HP SIM CMS is running.

5 Click Launch.... The following message displays if the selected node is HP SE CMS 
on Windows:

Enter the HP Systems Insight Manager DOMAIN\username:

The following message displays if the selected node is HP SE CMS on UNIX:
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Enter the HP Systems Insight Manager username:

6 At the prompt, enter the HP Systems Insight Manager user name for HP SE CMS on 
this node, and press Enter.

The following message displays at the prompt:

Enter the HP Systems Insight Manager password:

7 Enter the corresponding HP Systems Insight Manager password, and press Enter.

8 Re-enter the password to confirm.

After you enter the password, the following message displays:

Done creating hpsecms.conf file.

Press any key to continue . . .

The tool attempts to verify the user name and password. On success, you are 
prompted to press Enter to exit.

If the credentials entered are not authenticated by HP SE, the following message is 
displayed:

Failed to validate the HP SE CMS credentials. Possible causes 
could be:

1. HP SE CMS is not installed

2. HP SE CMS service is not running

3. HP SE CMS credentials incorrect

Press any key to continue . . .

9 Press Enter. The command prompt window closes.

The credentials are used for Storage Essentials service discovery.

After successful execution, the hpsecms.conf file is created on the HP SE CMS node.

Service Discovery does not function correctly if the user name and password are 
incorrect. If you do not know the user name and password, contact your system 
administrator.
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Deploying Instrumentation to CIM Extension Nodes

After you have successfully assigned the node, on which the Storage Essentials CIM 
Extension service is running, to the HP SE CIM Extn-Win or HP SE CIM Extn-Unix node 
group, HP SE SPI Instrumentation must be deployed to the node.

To deploy instrumentation on the Windows node on which the Storage Essentials CIM 
Extension service is running, complete the following steps:

1 Right-click the HP SE CIMExtn-Win node folder in the nodes tree. 

• Select All Tasks→Deploy instrumentation. The Deploy Instrumentation window 
displays, as shown in Figure 7.

Figure 7 Deploy Instrumentation

To deploy the instrumentation to the multiple nodes, ensure that CIM Extension nodes are 
added to the node group and select the appropriate node group in the nodes tree.
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2 Select HP Storage Essentials.

3 Click OK.
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Configuring the OVO Agent for a Non-root User

To configure non-root agents for HP SE SPI, complete the following steps:

1 Log in to the managed node as a root user, and open a terminal window.

2 Open the following instrumentation directory for HTTPS node:

cd /var/opt/OV/bin/instrumentation

3 Enter the following command at the command prompt:

./HPSESPI_perl HPSESPI_root.pl.

This command generates the HPSESPI.su file.

The following message displays on successful execution of the command:

The script has completed successfully.

Providing Access to Storage Essentials SPI Applications

To provide access to the HP SE SPI applications, complete the following steps:

1 Log in to the managed node as a root user, and open a terminal window.

2 Open the following file:

/etc/HPSESPI.su

3 Edit the file by uncommenting lines or by adding the following:

root:$CIMExtnPath/APPQcime/tools/start

root:$CIMExtnPath/APPQcime/tools/stop

root:$CIMExtnPath/APPQcime/tools/status

root:/etc/init.d/appstormanager start

For information on configuring the OVO agent to run as a non-root user, see the HP 
Operations HTTPS Agent Concepts and Configuration Guide.

HP SE SPI does not support non-root OVO agent on AIX and Tru64 CIM Extension 
nodes.
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root:/etc/init.d/appstormanager stop

On HP-UX and Linux, the $CIMExtnPath is /opt

On Solaris, enter the following command to get the value for $CIMExtnPath:

/usr/bin/pkginfo -r APPQcime
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5 Using HP Storage Essentials SPI
This chapter addresses the following topics:

• Using HP Storage Essentials SPI Node Group

• Using HP Storage Essentials SPI Tools

• Using HP Storage Essentials SPI messages

• Using HP Storage Essentials SPI Service Map
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Using HP Storage Essentials SPI Node Group

Installing HP SE SPI creates the following node groups:

• HP SE CMS-Win

• HP SE CMS-Unix

• HP SE CIM Extn-Win

• HP SE CIM Extn-Unix

Figure 8 shows the HP SE SPI node groups.

Figure 8 HP SE SPI nodes group

For more information on adding nodes to the node groups, see Assigning Nodes to the HP 
Storage Essentials Node Group on page 36.
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Table 9 lists the association between the nodes folder and the relevant tools folders.

Table 9 Association of Nodes Folder with Tools Folder

Nodes Folder Tools Folder

HP SE CMS-Win AppStorManager-Win

HP SE CMS-Unix AppStorManager-Unix

HP SE CIM Extn-Win CIM Extension-Win

HP SE CIM Extn-Unix CIM Extension-Unix
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Using HP Storage Essentials SPI Tools

The HP SE SPI adds the top-level tools group in the HPOM Application bank window. 
The following tools are available in the HP Storage Essentials tools group:

• AppStorManager-Unix

• AppStorManager-Win

• CIM Extension-Unix

• CIM Extension-Win

• HPSESPI Utils

Figure 9 shows the HP SE SPI tools group.

Figure 9 HP SE SPI Tools
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The HP SE SPI tool folders contain a number of tools that enable the HPOM administrator 
to manage HP Storage Essentials. These tools are grouped under the HP Storage 
Essentials folder.

The AppStorManager-Unix or AppStorManager-Win (depending on your node’s operating 
system) tools group contains tools that can be executed on HP SE CMS nodes (UNIX or 
Windows).
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Using the AppStorManager Tools Group

The AppStorManager-Unix or AppStorManager-Win (depending on your node’s operating 
system) tools group includes tools for HP Storage Essentials AppStorManager that are 
executed on HP SE CMS server nodes.

The AppStorManager tools group includes tools that monitor the HP Storage Essentials 
AppStorManager process on selected Unix or Windows nodes.

Table 10 lists the tools in the AppStorManager tools group.

Table 10 AppStorManager Tools Group

Tools Group Tool Name Description

AppStorManager-
Unix

AppStorManager-Unix 
Start

Starts the HP Storage Essentials 
AppStorManager service on the 
selected Unix nodes.

AppStorManager-Unix 
Status

Status of HP Storage Essentials 
AppStorManager service on selected 
Unix nodes.

AppStorManager-Unix 
Stop

Stops HP Storage Essentials 
AppStorManager service on selected 
Unix nodes.

Assign AppStorManager 
Unix node to node group

Assigns Storage Essentials 
AppStorManager Unix node to HP SE 
CMS-Unix node group.

De-assign 
AppStorManager Unix 
node from node group

De-assigns Storage Essentials 
AppStorManager Unix node from HP 
SE CMS-Unix node group.
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Using CIM Extension Tools Group

The CIM Extension-Unix or CIM Extension-Win (depending on your node’s operating 
system) tools group includes tools for HP Storage Essentials CIM Extension that are 
executed on the HP SE CIM Extension nodes (UNIX or Windows). The CIM Extension 
tools group includes the tools that monitor HP Storage Essentials CIM Extension services 
on the selected UNIX or Windows nodes.

AppStorManager-
Win

AppStorManager-Win 
Start

Starts HP Storage Essentials 
AppStorManager service on selected 
Windows nodes.

AppStorManager-Win 
Status

Status of HP Storage Essentials 
AppStorManager service on selected 
Windows nodes.

AppStorManager-Win 
Stop

Stops HP Storage Essentials 
AppStorManager service on selected 
Windows nodes.

Assign AppStorManager 
Windows node to node 
group

Assigns Storage Essentials 
AppStorManager Windows node to 
HP SE CMS-Win node group.

De-assign 
AppStorManager 
Windows node from node 
group

De-assigns Storage Essentials 
AppStorManager Windows node 
from HP SE CMS-Win node group.

Table 10 AppStorManager Tools Group

Tools Group Tool Name Description
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Table 11 lists the tools in the CIM Extension tools group.

Table 11 Tools in the CIM Extension Tools Group

Tools Group Tool Name Description

CIM 
Extension-Unix

CIM Extension-Unix Start Starts HP Storage Essentials CIM 
Extension on selected Unix nodes

CIM Extension-Unix 
Status

Status of the HP Storage Essentials 
CIM Extension on selected Unix 
nodes.

CIM Extension-Unix Stop Stops HP Storage Essentials CIM 
Extension on selected Unix nodes.

Assign CIM Extension 
Unix node to node group

Assigns Storage Essentials CIM 
Extension Unix node to HP SE CIM 
Extn-Unix node group.

De-assign CIM Extension 
Unix node from node 
group

De-assigns Storage Essentials CIM 
Extension Unix node from HP SE 
CIM Extn-Unix node group.

CIM Extension-Win CIM Extension-Win Start Starts the HP Storage Essentials CIM 
Extension on selected Windows 
nodes.

CIM Extension-Win 
Status

Gets the status of HP Storage 
Essentials CIM Extension on 
selected Windows nodes.

CIM Extension-Win Stop Stops the HP Storage Essentials CIM 
Extension on selected Windows 
nodes

Assign CIM Extension 
Windows node to node 
group

Assigns Storage Essentials CIM 
Extension Windows node to HP SE 
CIM Extn-Win node group.

De-assign CIM Extension 
Windows node from node 
group

De-assigns Storage Essentials CIM 
Extension Windows node from HP 
SE CIM Extn-Win node group.
56 Chapter 5



Using HPSESPI Utils Tools Group

The HPSESPI Utils tools group includes tools for performing administrative tasks for HP 
SE SPI. Table 12 lists the tools in the HPSESPI Utils tools group.

Table 12 HPSESPI Utils Tools Group

Tools Group Tools Name Description

HPSESPI Utils Clean HPSESPI - Unix Deletes HP SE SPI files on selected 
Unix managed nodes.
This tool also disables the HP SE SPI 
policies on the DCE managed nodes 
and deletes HTTPS managed nodes.
When agent is running as a non-root 
user, the file /etc/HPSESPI.su will 
not be removed.

Clean HPSESPI - Win Deletes HP SE SPI files on selected 
Windows managed nodes.
This tool also disables the HP SE SPI 
policies on the DCE managed nodes 
and deletes HTTPS managed nodes.
After the successful execution of the 
tool, only HPSESPI_perl.cmd file 
remains on the managed node.

Get HP SIM Credentials Obtains login credentials for Storage 
Essentials for use by HP SE SPI.

Self-Healing Info Runs the HP SE SPI Data collector 
on managed nodes.

Service Discovery - Unix Performs HP Storage Essentials 
Service Discovery on the Unix 
managed nodes.

Service Discovery - Win Performs HP Storage Essentials 
Service Discovery on the Windows 
managed nodes.
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Tracing Off - Unix Sets the HP SE SPI tracing to OFF 
state on Unix managed nodes.

Tracing Off - Win Sets the HP SE SPI tracing to OFF 
state on Windows managed nodes.

Tracing On - Unix Sets the HPSESPI tracing to ON 
state on the Unix managed nodes.

Tracing On - Win Sets the HPSESPI tracing to ON 
state on the Windows managed 
nodes.

Version Verify Verifies the version of HPSESPI 
files.

Table 12 HPSESPI Utils Tools Group

Tools Group Tools Name Description
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Using HP Storage Essentials SPI messages

Events generated by HP SE SPI are grouped under the HP SE SPI’s 
HPSESPI-Storage_Essentials message group. The messages generated by the HP SE SPI 
policies appear in the message browser window and contain information that is vital for 
understanding the problems being reported.

Figure 10 shows the message browser window with a selection of messages generated by 
HP SE SPI.

Figure 10 HPOM message browser showing messages for the HP SE CMS node

The message headline describes the scope of the problem. In the HP SE SPI context, this 
information can be categorized into the following:

• Node - Name of the Storage Essentials management server or CIM Extension.

• Application - Category of the message is Storage Essentials.

• Text - A single line description of the event.

• Object - Source of the event is AppStorManager or CIM Extension.

In Figure 10, there are messages for other SPIs in addition to the messages for HP SE SPI.
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• Group - HPSESPI-Storage_Essentials
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Using HP Storage Essentials SPI Service Map

The HP SE SPI provides the administrator with the additional perspective of service 
views. It discovers the services automatically and uses the discovered data to generate 
service maps that can be viewed by the administrator from the HPOM console.

The HP Storage Essentials managed hosts are discovered by querying the Storage 
Essentials CMS for its managed hosts. Hence, some of the nodes represented in this tree 
may not be HPOM managed nodes; status is shown only for CIM Extension nodes that 
have an HPOM Agent installed and the HP SE SPI configured.

You can decide whether these nodes must be configured as HPOM managed nodes or not. 
You can also decide whether the HP SE SPI policies must be installed or not. If the nodes 
in this tree are HPOM managed nodes with the SE SPI policies deployed, the service view 
node status changes based on the status of the CIM Extension on the node, is displayed, as 
shown in Figure 11.
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Figure 11 HP SE SPI service map showing HP SE AppStorManager process status

Table 13 describes the service status implications of the service map in Figure 11.

Figure 12 shows a Storage Essentials service map where the CIM Extension service on the 
node revati.india.hp.com is not running.

Table 13 HP SE SPI service map showing HP SE AppStorManager process status

Item Description

1 Storage Essentials CMS node

2 Nodes with CIM Extensions installed or 
running
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Figure 12 HP Storage Essentials service map showing HP SE AppStorManager 
process status

The service discovered by the HP SE SPI enables root-cause analysis of problems in 
crucial elements on the CIM Extension node in a HP Storage Essentials network managed 
storage network.

By default, status propagation rules for the objects in the HP Storage Essentials service 
trees are defined such that if the HP SE CIM Extension service objects is critical, item 
marked as 2 as shown in Figure 11, the higher service objects status are decreased by two 
levels to minor. If the HP SE AppStorManager service objects is critical, item marked as 1 
as shown in Figure 11, the higher service objects status are decreased by a level to major. 
The parent service does not change the status of a child object and by default, calculation 
rules for the HP Storage Essentials service trees are set to Most Critical. Hence, if a parent 
service has more than one child service, the parent service assumes the status equal to the 
highest severity of its child services.
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Viewing Services

The service views are created after Storage Essentials CMS is added to the HP SE 
CMS-Win or HP SE CMS-Unix node group and service discovery is invoked. For 
information on adding Storage Essentials CMS is added to the HP SE CMS-Win or HP SE 
CMS-Unix node group, see Assigning Nodes to the HP Storage Essentials Node Group on 
page 36.

Running the appropriate Service Discovery tool on the SE CMS node generates services 
in the HP Storage Essentials service map. Ensure that you perform the steps described in 
Obtaining HP Storage Essentials Credentials on page 42 before performing the steps for 
viewing the discovered HP Storage Essentials service.

To view the discovered HP Storage Essentials service, complete the following steps:

1 Log in to the HPOM management server, and start the HPOM console.

2 Select Services→System Infrastructure on the left pane of the HPOM console. The 
HP Storage Essentials service map displays in the right pane, as shown in Figure 12.

By default, the HP SE SPI service discovery policy is configured to run service discovery 
everyday at 2:00 am. You can change the service discovery period by modifying the 
Service discovery policy. The changed discovery period comes into effect only after the 
policies are re-deployed on the HP SE CMS node.
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Using HP Storage Essentials SPI User Roles

The installation of the HP SE SPI adds a new user role, HP Storage Essentials SPI Admin 
to HPOM is displayed as shown in Figure 13.

Figure 13 User Roles

The HPOM administrator uses user roles to simplify the process of assigning 
responsibilities to HPOM users. The users associated with the role HP SE SPI Admin can 
access all the HP SE SPI tools, policies, and HPSESPI-Storage_Essentials message groups 
assigned to them, and can manage and control the HP SE CMS and HP SE CIM Extension 
nodes.

The HP SE SPI Admin user role assigns the following authorizations:

• Access all messages with message group attribute HPSESPI-Storage_Essentials from 
HP SE CMS or HP SE CIM Extension node.

• Execute any tool in the HP Storage Essentials Tools groups.
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• Update HPOM service map, displaying the HP Storage Essentials services 
successfully discovered.
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6  Uninstalling HP Storage Essentials SPI
This chapter addresses the following topics:

• Deleting HP Storage Essentials SPI Instrumentation from Nodes

• Removing Nodes from the Node Group

• Uninstalling HP Storage Essentials SPI from HPOM

• Uninstalling HP Storage Essentials SPI Components from HPOM
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 Deleting HP Storage Essentials SPI Instrumentation from 
Nodes

To remove HP SE SPI instrumentation from the managed nodes, complete the following 
steps:

1 Open the HPSESPI Utils tools group in the HP SE SPI tools group.

2 Run the Clean HPSESPI - Win tool on the selected Windows managed nodes.

3 Run the Clean HPSESPI - Unix tool on the selected Unix managed nodes.
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Removing Nodes from the Node Group

Removing a node from the node group involves the following:

• Removing the AppStorManager Node from the Node Group

• Removing the CIM Extension Windows Node from the Node Group

Removing the AppStorManager Node from the Node Group

To remove the node, on which the Storage Essentials AppStorManager service is running 
from the HP SE CMS-Win or HP SE CMS-Unix node group, complete the following steps:

1 Log in to the HPOM management server, and start the HPOM Console.

2 Select Tools→HP Storage Essentials→AppStorManager-Win, and right-click 
De-assign AppStorManager node from node group.

3 Select All Tasks→Launch Tool. The Edit Parameters window displays, as shown in 
Figure 14.
Uninstalling HP Storage Essentials SPI 69



Figure 14 Edit Parameters–De-assign AppStorManager node from node group

4 Select the node in the HP SE CMS-Win node group in the Select the nodes/services to 
replace $OPC window pane.

5 Click Launch…. The Tool Status window displays, as shown in Figure 15.
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Figure 15 Tool Status

You have now successfully removed the Windows node, on which the Storage 
Essentials AppStorManager service is running, from the SE AppStorMgr-Win node 
group.

Repeat above steps to remove nodes from the AppStorMgr-Unix Node groups, using 
Tools→HP Storage Essentials→AppStorManager-Unix→De-assign AppStorManager 
Unix node from the node group.

Removing the CIM Extension Windows Node from the Node Group

To remove the node, on which the Storage Essentials CIM Extension service is running, 
from the HP SE CIM Extn-Win or HP SE CIM Extn-Unix node group, complete the 
following steps:

1 Select Tools→HP Storage Essentials→CIM Extension-Win, and right-click De-assign 
CIM Extension Windows node from node group.

2 Select All Tasks→Launch Tool. The Edit Parameters window displays, as shown in 
Figure 16.
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Figure 16 Edit Parameters–De-assign CIM Extension Windows node from node 
group

3 Select the node in the HP SE CIM Extn-Win node group in the Select the nodes/services 
to replace $OPC window pane.

4 Click Launch…. The Tool Status window displays, as shown in Figure 17.
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Figure 17 Tool Status

You have now successfully removed the Windows node, on which the Storage 
Essentials CIM Extension service is running, from the HP SE CIM Extn-Win or HP SE 
CIM Extn-Unix node group.

Repeat above steps to remove nodes from the SE CIM Extension-Unix node groups, 
using the Tools→HP Storage Essentials→CIM Extension-Unix→De-assign CIM 
Extension-Unix node from node group.
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Uninstalling HP Storage Essentials SPI from HPOM

To uninstall the HP SE SPI components from HPOM, complete the following steps:

1 Insert the HP Operations Smart Plug-ins DVD, Installation and Upgrade Guide.

2 Select Remove products to proceed to the product selection dialog box.

3 In the Product Selection Uninstall window, select SPI for HP Storage Essentials and 
click Next as shown in Figure 18.

Ensure that HPOM managed nodes are not present under HP SE SPI node groups. They 
must be moved out of their respective groups before uninstalling HP SE SPI. For 
information on removing the HPOM managed nodes, see Removing Nodes from the 
Node Group on page 69.
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Figure 18 SPI Uninstallation window
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4 Select Remove.

5 Click Finish to complete the uninstallation procedure and exit the wizard.

This removes all the configuration files and executables of HP SE SPI from the 
HPOM server. The HP SE SPI node groups, policies, and tools are also removed from 
the HPOM.

For more information on uninstalling HP Operations New and Upgraded Smart 
Plug-ins, see the HP Operations Smart Plug-ins DVD, Installation and Upgrade 
Guide.

Selecting HP SIM Integration in the Product Selection Uninstall window also uninstalls 
HP SE SPI.
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Uninstalling HP Storage Essentials SPI Components from 
HPOM

Most of the components of the HP SE SPI in HPOM are automatically removed during the 
uninstallation of the product. However, HP SE SPI Admin user role must be removed 
manually.

Removing HP Storage Essentials SPI User Roles

To remove the HP SE SPI user roles, complete the following steps:

1 Select Actions→Configure→User Roles. You can also click User Roles Configuration 
Editor located on the menu bar of the main HPOM. The User Roles window displays, 
as shown in Figure 19.

Figure 19 User Roles

2 Select HP Storage Essentials SPI Admin, and click Delete. 
You have now successfully removed the HP SE SPI user roles.
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7 Troubleshooting HP Storage Essentials 
SPI
This chapter discusses the following topics:

• Before you start

• Troubleshooting
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Before you start

Before investigating the problem, you must perform the following basic checks to ensure 
that the HP SE SPI environment is installed and configured correctly:

• Ensure that the HP SE SPI is installed properly. For more information on installing 
HP SE SPI, see Installing HP Storage Essentials SPI on page 25.

• Ensure that the HP SE SPI is configured properly. For more information on 
configuring HP SE SPI, see Configuring the HP Storage Essentials SPI on page 33.

The above steps ensure that you have installed and configured HP SE SPI in the 
recommended manner, and that the messages seen in the HPOM message browser 
are:

• Intercepted by the HP SE SPI policies.

• Appearing in the HPOM message browser in the form you expect.

If the preliminary check does not resolve the problem, go through the list of common 
problems and their solutions described in the following section.
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Troubleshooting

Following are the issues in the HP SE SPI:

• Service monitoring events not arriving on the HPOM Message Browser console

• HP SE services not visible in the HPOM console

• Auto-deployment of policies failing on HPOM 8.00

• Auto-deployment of policies failing on OVOW 7.50

• SHS related tools fail on non-root HTTPS node says cannot open SPI_SE.xml

Service monitoring events not arriving on the HPOM Message 
Browser console

Table 14 provides troubleshooting information for service monitoring events that do not 
arrive in the HPOM message browser.

Table 14 Service monitoring events not arriving on the HPOM message browser 
console

Symptom Solution

No Storage Essentials service 
monitoring events arrive in 
HPOM message browser

• Ensure that the connection between HPOM and 
the Storage Essentials CMS and the CIM 
Extension nodes is up and running.

• Verify whether the HPOM agent is correctly 
installed and configured on the management 
server, and the HPOM agent processes (especially 
the control agent) are running.

• Ensure that Storage Essentials CMS and CIM 
Extension nodes are added to the appropriate node 
groups. For more information, see Assigning 
Nodes to the HP Storage Essentials Node Group 
on page 36.
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HP SE services not visible in the HPOM console

Table 15 provides troubleshooting information for HP Storage Essentials services that are 
not visible in the HPOM console.
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Table 15 HP Storage Essentials services not visible in the HPOM console

Symptom Solution

HP Storage Essentials 
services are not visible in 
the HPOM console

• Ensure that the connection between the HPOM and the 
Storage Essentials CMS nodes is up and running.

• Verify whether the HPOM agent is correctly installed 
and configured on the management server, and the 
HPOM agent processes (especially the control agent) 
are running.

• If the HP SE CMS credentials are invalid, there is a 
possibility of having error messages in the service 
discovery log at <OvAgentDir>\log\javaagent.log on 
the HP SE CMS node indication authentication 
failures.

• Ensure that the correct HP SIM Credentials are entered 
before adding the node to the SE AppStorMgr-Win node 
group, and also ensure that the nodes are added using 
the Tools→HP Storage 
Essentials→AppStoManager-Win→Assign 
AppStorManager node to node group tool. This ensures 
that the proper credentials are copied to the Storage 
Essentials CMS node along with other instrumentation.

If there are multiple Storage Essentials CMS nodes 
with different credentials, the Get SIM CMS Credentials 
tool must be launched for one node at a time and that 
node must be added to the SE AppStorMgr-Win node 
group before entering the credentials for the next node.

• Ensure that the Service Discovery policies present in 
Policy Management→Policy Groups→HP Storage 
Essentials→Service Discovery are deployed on the HP 
SE CMS nodes. To check whether the policies are 
correctly deployed, right-click the node, select 
View→Policy Inventory, and ensure that the Service 
Discovery policies are present. You can also check the 
service discovery log at 
<OvAgentDir>\log\javaagent.log on the HP SE CMS 
node for error messages.
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Auto-deployment of policies failing on HPOM 8.00

Symptom: auto-deployment of policies failing on HPOM 8.00

Action: OVO Console→Operations Manager→Nodes→Server Configuration 
Utility→Name Space→Policy Management and Deployment→Disable autodeployment 
for all nodes and services

Check that the above parameter value is set to False.

Auto-deployment of policies failing on OVOW 7.50

Symptom: auto-deployment of policies failing on HPOM 7.50

Action: Verify whether the registry key 
SOFTWARE\Hewlett-Packard\OVEnterprise\Management 
Server\AutoDeployment\Disable is set to value 0.

SHS related tools fail on non-root HTTPS node says cannot open 
SPI_SE.xml

The tools Version Verify and Self-Healing Info fails on agent running as non-root user.

Symptom: When the OM Agent is migrated from root user to non-root user, the Version 
Verify and Self-Healing Info fails with the following error.

Cannot open collector output file /tmp/SPI_SE/SPI_SE.xml for writing.

Action: If the OM Agent is migrated from root user to non-root user, delete or rename the 
HP Storage Essentials SPI files/directories from /tmp on the node which were created by 
root user.
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A HP Storage Essentials SPI Policy Groups
The high-level HP SESPI policy groups are available in HP Storage Essentials SPI Policy 
Groups, as shown in Figure 20.
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Using HP Storage Essentials SPI Policy Groups

Policies provided with the HP SE SPI are grouped under the HP Storage Essentials policy 
group is displayed as shown in Figure 20.

Figure 20 HP Storage Essentials Policy Group

Messages generated by the HP SE SPI policies are assigned HPOM severity level as 
defined in the policy groups. By default, all messages generated by the HP SE SPI policy 
belong to HPSESPI-Storage_Essentials message group.

Policies in the AppStorManager and CIM Extension policy groups for the indicated 
operating systems monitor the status of the AppStorManager service running on the HP 
Storage Essentials CMS node and the Storage Essentials CIM Extension service running 
on the HP Storage Essentials managed nodes. These policies generate messages to 
indicate any status change in the monitored services.
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Policies in the Service Discovery policy group discover the Storage Essentials services 
when deployed on the HP SE CMS nodes.

Table 16 describes the policies in the HP SE SPI policy group.

Table 16 HP SE SPI Policy

Policy Group Policy Name Description Policy Type

AppStorManager-U
nix

HPSESPI-AppStor
Manager-Unix

Monitors HP Storage 
Essentials 
AppStorManager service 
on Unix

Measurement 
Threshold

AppStorManager-
Win

HPSESPI-AppStor
Manager-Win

Monitors HP Storage 
Essentials 
AppStorManager service 
on Windows

Measurement 
Threshold

CIM 
Extension-Unix

HPSESPI-CIM 
Extension-Unix

Monitors HP Storage 
Essentials CIM 
Extension on Unix

Measurement 
Threshold

CIM 
Extension-Win

HPSESPI-CIM 
Extension-Win

Monitors HP Storage 
Essentials CIM 
Extension on Windows

Measurement 
Threshold

Service Discovery HPSESPI-Storage_
Essentials_Services

Discovers services of the 
hosts managed by the 
Storage Essentials 
AppStorManager

Service 
Auto-discovery

CIM extension can be either an extension to the Windows WMI service or a separate 
executable called AppStorWin32Agent service. The HPSESPI-CIM_Extension-Win 
monitor policy monitors only the AppStorWin32Agent service, and 
HPSESPI-CIM_Extension-Win is disabled if this service is not present or only the 
extension to the WMI service is present on a Windows managed node.
HP Storage Essentials SPI Policy Groups 89



90 Appendix A


	Installation and Reference Guide
	Contents
	1 HP Storage Essentials
	Overview
	Key Features and Benefits of HP Storage Essentials

	2 HP Operations Smart Plug-in for HP Storage Essentials
	Overview
	Features and Functionality

	3 Installing HP Storage Essentials SPI
	Prerequisites
	Hardware Requirements
	Software Requirements

	Installing HP Storage Essentials SPI
	Upgrading the HP Storage Essentials SPI
	Verifying Installation
	Installed File Locations


	4 Configuring the HP Storage Essentials SPI
	Starting HP Storage Essentials SPI Configuration
	Installing HPOM Agent on Nodes
	Assigning Nodes to the HP Storage Essentials Node Group
	Assigning AppStorManager Node to the Node Group
	Assigning the CIM Extension Node to the Node Group

	Obtaining HP Storage Essentials Credentials
	Deploying Instrumentation to CIM Extension Nodes
	Configuring the OVO Agent for a Non-root User
	Providing Access to Storage Essentials SPI Applications


	5 Using HP Storage Essentials SPI
	Using HP Storage Essentials SPI Node Group
	Using HP Storage Essentials SPI Tools
	Using the AppStorManager Tools Group
	Using CIM Extension Tools Group
	Using HPSESPI Utils Tools Group

	Using HP Storage Essentials SPI messages
	Using HP Storage Essentials SPI Service Map
	Using HP Storage Essentials SPI User Roles

	6 Uninstalling HP Storage Essentials SPI
	Deleting HP Storage Essentials SPI Instrumentation from Nodes
	Removing Nodes from the Node Group
	Removing the AppStorManager Node from the Node Group
	Removing the CIM Extension Windows Node from the Node Group

	Uninstalling HP Storage Essentials SPI from HPOM
	Uninstalling HP Storage Essentials SPI Components from HPOM

	7 Troubleshooting HP Storage Essentials SPI
	Before you start
	Troubleshooting
	Service monitoring events not arriving on the HPOM Message Browser console
	HP SE services not visible in the HPOM console
	Auto-deployment of policies failing on HPOM 8.00
	Auto-deployment of policies failing on OVOW 7.50
	SHS related tools fail on non-root HTTPS node says cannot open SPI_SE.xml

	A HP Storage Essentials SPI Policy Groups
	Using HP Storage Essentials SPI Policy Groups



