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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty statements 
accompanying such products and services. Nothing herein should be construed as constituting an additional 
warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. Consistent 
with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and 
Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard 
commercial license.

Copyright Notices

© Copyright 2008–2009 Hewlett-Packard Development Company, L.P.

Trademark Notices

Linux is a U.S. registered trademark of Linus Torvalds.

Microsoft® and Windows® are U.S. registered trademarks of Microsoft Corporation.

RedHat Linux is trademark of Red Hat, Inc.

UNIX® is a registered trademark of The Open Group.
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Documentation Updates

The title page of this document contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

• Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using the most recent edition of a document, go to:

http://h20230.www2.hp.com/selfsolve/manuals 

This site requires that you register for an HP Passport and sign in. To register for an HP Passport ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

Or click the New users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product support service. 
Contact your HP sales representative for details.
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Support

Visit the HP Software Support Online web site at:

www.hp.com/go/hpsoftwaresupport 

This web site provides contact information and details about the products, services, and support that HP 
Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and efficient way to 
access interactive technical support tools needed to manage your business. As a valued support customer, you 
can benefit by using the support web site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a 
support contract. To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp  
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1 Introducing the Smart Plug-in for Microsoft 
Enterprise Servers
Smart Plug-in (SPI) is add-in software for HP Operations Manager (HPOM). It functions as a 
modular component of HPOM and further improves its monitoring capabilities in managing 
your IT resources. SPIs help you to simplify the tasks of your environment by: 

• Monitoring availability and health

• Detecting performance lapse

• Detecting, preventing, and solving problems

• Documenting problem solutions

• Generating reports

About the Smart Plug-in for Microsoft Enterprise Servers

The Smart Plug-in for Microsoft Enterprise Servers (Microsoft Enterprise Servers SPI) helps 
you to manage the Microsoft Enterprise Servers in your environment. The Microsoft 
Enterprise Servers SPI keeps you informed about the conditions related to the following 
Microsoft Enterprise Servers:

• BizTalk Server 2006 and R2

• Internet Security and Acceleration Server 2006 

• Microsoft Office SharePoint Server 2007

• Microsoft Office Communications Server 2007 and R2

Microsoft Office Communications Server 2007 Deployment Configurations

The Microsoft Office Communications Server 2007 supports the following deployment 
configurations:

• Microsoft Office Communications Server Standard Edition

• Microsoft Office Communications Server Enterprise Edition Consolidated Configuration

• Microsoft Office Communications Server Enterprise Edition Expanded Configuration

The Microsoft Office Communications Server does not support the following deployment 
configurations:

• Microsoft Office Communications Server 2007 configured with load balancing

• Microsoft Office Communications Server 2007 installed on clustered environment
9



Components of Microsoft Enterprise Server SPI

The components of Microsoft Enterprise Server SPI are policies, tools, reports, and graphs.

Policies

Policies are pre-defined thresholds to keep a constant vigilance over the Microsoft Enterprise 
Server environment and improve monitoring schedules in the form of service map alerts and 
messages. Service map alerts are shown in service map while messages are available in 
message browser. The severity level of each message, whether it is a minor, major, or critical 
is shown by a color-code. The messages indicate the problem and help you to take preventive 
action. For more information on policies see Using Policies and Tools. 

Tools

Tools are the utilities to gather more Microsoft Enterprise Server related information. Self 
Healing tools are used for troubleshooting any of the Microsoft Enterprise Servers SPI. The 
MSES_BTS_DB_Configuration tool is used to configure the BizTalk Server of the Microsoft 
Enterprise Servers SPI. For more information see Using Policies and Tools. 

Reports 

Reports are the pictorial representation of various metrics of Microsoft Enterprise Servers. 
Data collected by policies are used to generate reports. For more information on reports see 
Integrating Microsoft Enterprise Servers SPI with HP Reporting and Graphing. 

Graphs 

Graphs represent various metrics of the Microsoft Enterprise Servers. Graphs contain the 
data that are collected by policies. For more information on graphs, see Integrating Microsoft 
Enterprise Servers SPI with HP Reporting and Graphing.

Reports and graphs generated with the help of HP Reporter and HP Performance Manager 
provide you an overview to determine corrective actions to be taken in the long term.

See HP Operations Smart Plug-in for Microsoft Enterprise Servers SPI Online Help or HP 
Operations Smart Plug-in for Microsoft Enterprise Servers SPI Online Help PDF for a detailed 
description of policies, tools, reports, and graphs of the Microsoft Enterprise Servers SPI.

Functions of Microsoft Enterprise Server SPI

The Microsoft Enterprise Server SPI monitors the following Microsoft Enterprise Servers:

• BizTalk Server 2006 

• Internet Security and Acceleration Server 2006 

• Microsoft Office SharePoint Server 2007

• Microsoft Office Communications Server 2007
10 Chapter 1



Monitoring the Availability, Performance, and Event Log

The SPI monitors the Microsoft Enterprise Servers in your environment and maintains the 
thresholds set up by the policies. The Microsoft Enterprise Servers SPI ensure complete 
availability of the services, monitors Windows performance counters, by notifying if the 
thresholds have exceeded and Windows Event Logs. 

Displaying Information

The Microsoft Enterprise Servers SPI displays information in the following ways.

Service Map

Service map shows the newly added and discovered Microsoft Enterprise Servers displayed in 
both the console services tree (left) and the service map (right). Within the service map pane, 
the hierarchy expands to show the specific services present on each Microsoft Enterprise 
Server. 
Introducing the Smart Plug-in for Microsoft Enterprise Servers 11



Figure 1 Service Map)
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Message Browser

The Microsoft Enterprise Servers SPI monitors events and services on the managed nodes 
and generates messages, which are displayed on the message browser of HPOM console. The 
message browser displays messages identified with the problem severity level.

Instruction Text

Error messages generated by the policies of the Microsoft Office Communications Server 2007 
SPI of the Microsoft Enterprise Server SPI contain instruction text which mentions probable 
cause and preventive action to resolve problems. 

Reports and Graphs

Reports and graphs present the information that helps you see trends to manage the 
Microsoft Enterprise Servers in your environment by implementing efficient load balancing, 
capacity planning, and policy scheduling and threshold adjustments.

MSES_BTS_DB_Configuration Tool

The MSES_BTS_DB_Configuration tool is used to configure the Microsoft Enterprise BizTalk 
Server SPI. For more details on MSES_BTS_DB_Configuration too, see Additional 
Configuration Procedure for Microsoft Enterprise Servers SPI for BizTalk Server 2006 on 
page 37.

Generating Reports Using HP Reporter

You can generate reports to analyze the past or present Microsoft Enterprise Servers 
conditions. These web-based reports are automatically generated at periodical intervals. For 
more information on HP Reporter see Integrating Microsoft Enterprise Servers SPI with HP 
Reporting and Graphing.

Graphing Data with HP Performance Manager

After you manually generate the graphs, you can view the data in a more specified and 
granular manner. You can access graphs in the HP Performance Manager (HP PM) console. 
You can integrate the Microsoft Enterprise Servers SPI with HP Performance Manager to 
generate and view graphs.For more information on HP Performance Manager see Integrating 
Microsoft Enterprise Servers SPI with HP Reporting and Graphing. 
Introducing the Smart Plug-in for Microsoft Enterprise Servers 13



Customizing Policies

You can customize the monitoring schedule or measurement threshold policies for any 
Microsoft Enterprise Servers SPI policy. Some of the modifications that can be performed are:

• Script-parameters

• Rules

• Options

Use Software Upgrade Tool Kit 2.0 to retain the customization of the policies. See HP 
Operations Smart Plug-in Upgrade Toolkit Windows User Guide for more details.
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2 Installing and Upgrading Microsoft Enterprise 
Server SPI
Perform the tasks mentioned in the following sections to install and upgrade the Microsoft 
Enterprise Servers SPI. 

The following flowchart shows an overview of installing and configuring the Microsoft 
Enterprise Servers SPI. See Table 1 for references of the legends.

Figure 2 An Overview of Installation and Configuration Steps
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Table 1 References of Legends of Flowchart

The following flowchart shows an overview of upgrading the Microsoft Enterprise Servers 
SPI. See Table 2 for references of the legends.

Legend References

A Prerequisites of Installing Microsoft 
Enterprise Server SPI on page 19

B Installing Microsoft Enterprise Server SPI on 
page 20

C Verifying Installation/Upgrade of Microsoft 
Enterprise Servers SPI on page 25

D Change Unmanaged Nodes to Managed 
Nodes on page 29

E Deploy Instrumentation Categories on 
Managed Nodes on page 30

F Edit Discovery Policy on page 40

G Deploy Discovery Policy on Managed Nodes 
on page 41

H View Service Map on page 43

I Create Data Sources on page 31

J Customize Policies on page 33

K Deploy Manual-Deploy Policy Groups on 
page 34
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Figure 3 An Overview of Upgrade Steps

Table 2 References of Legends of Flowchart

Legend References

A Prepare to install the later version of the 
Microsoft Enterprise Servers SPI on page 23

B Install the later version of the Microsoft 
Enterprise Servers SPI on page 23

C Customize the policies of Microsoft 
Enterprise Servers SPI, if required. on 
page 23

D Deploy updated instrumentation. on page 23

E Verifying Installation/Upgrade of Microsoft 
Enterprise Servers SPI on page 25
Installing and Upgrading Microsoft Enterprise Server SPI 17



Installation Packages

The Microsoft Enterprise Server SPI installation packages include the SPI, graphing, 
reporting, and the console package.

SPI Package

The SPI package is the .msi package, which contains all the functionality of the SPI. It must 
be installed on a HPOM server. You can find the Microsoft Enterprise servers SPI in the 
following location

<SPI DVD>\SPIs\MSESSPI\MSESSPI.msi

Graphing Package

The Graphing package contains the graphs provided by the SPI. Graphs are drawn from 
metrics that are collected in the datasources created by the SPI. You can find the Microsoft 
Enterprise Servers SPI graphing package in the following location:

<SPI DVD>\SPIs\MSESSPI OVPM ConfigurationPackage\HPOvSpiMsesGc.msi

Reporting Package

The Reporter package contains the reports provided by the SPI. The Reporter gathers the 
data from the nodes managed by the SPI, stores the data in its local database, and creates 
.html reports based on the default SPI report policies. You can find the Microsoft Enterprise 
Servers SPI in the following location:

<SPI DVD>\SPIs\MSES Reporter Package\MSESSPI-Reporter.msi

Installation Environments

HPOM for Windows provide the scalable feature of monitoring enterprise application servers. 
SPIs are part of this scalable architecture, allowing for monitoring specific application 
servers. You can select SPIs from the DVD to install on servers managed by HPOM.

Standard Installation of SPI Components on an HPOM 8.10 Server

An HPOM for Windows 8.10 server does not have the OVPMLite and ReporterLite installed 
by default. Only the full versions of these products are available for install. As a result, 
through the HP Operations Smart Plug-Ins DVD you can select to install only the SPI 
packages and not the reporter and the graphing packages. However, if the full version of 
Reporter or Performance Manager is installed on the same machine, then the corresponding 
packages can be installed or removed on the HPOM 8.10 server.
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Standard Installation on Remote Consoles

All the Remote Console packages on the SPI DVD are installed at once on to remote consoles. 
No option is provided to select a particular remote console package.

Standalone HP Reporter or HP Performance Manager

For such a system only the corresponding package of any SPI is enabled and available for 
selection from the HP Operations Smart Plug-Ins DVD. For example, if a system has only HP 
Reporter installed then you can install the reporter package of any SPI on it. The same 
applies to the graphing package on the HP PM.

Prerequisites of Installing Microsoft Enterprise Server SPI

Fulfill the hardware and software requirements before installing the SPI. Also, ensure that 
you install the HPOM server before installing the Microsoft Enterprise Server SPI. It is not 
necessary to stop HPOM sessions before beginning the installation of the Microsoft Enterprise 
Server SPI.

Hardware Requirements

See the HP Operations Manager for Windows Installation Guide for information on hardware 
requirements.

Software Requirements

Ensure that the following software requirements are fulfilled:

On the management server:

• HP Operations Manager for Windows: 8.10

• HP Reporter: 3.80

• HP Performance Manager: 8.20 (if you want to generate graphs)

• HP Operations SPI Data Collector (DSI2DDF): 2.40

• HP SPI Self-Healing Services. (SPI-SHS-OVO, automatically installed while installing 
the SPI using SPIDVD): 3.00

On the managed node:

• HP Operations Agent (version 8.53 or 8.60 (HTTPS) and 7.35 (DCE)) installed and 
configured

• HP Performance Agent: 5.00 (required if you want to use HP Performance Agent for data 
logging)
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Installing Microsoft Enterprise Server SPI

You can install the Microsoft Enterprise Server SPI on a management server.

Installing Microsoft Enterprise Server SPI on a Management Server

The HP Operations Smart Plug-ins DVD contains the Microsoft Enterprise Server SPI.

1 Insert the HP Operations Smart Plug-ins  DVD into the DVD-ROM drive of the 
management server. The installation wizard opens.

2 Click Next. The Smart Plug-in Release Notes and Other Documentation screen appears.
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3 Click Next. The Product Selection screen appears.

4 Select Microsoft Enterprise Servers check box, and click Next. The Enable/Disable 
AutoDeployment screen appears. 

5 Select the Enable button to deploy the Auto-Deploy policies, and click Next. The License 
Agreement screen appears.

6 Accept the terms by selecting the option I accept the terms in the license agreement, and click 
Next. The Ready to Install the Program screen appears.
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7 Click Install. The installation begins. The wizard installs the core SPIs, all necessary 
packages, and the Microsoft Enterprise Servers SPI. 

8 Click Finish after the installation is complete.

Installing Microsoft Enterprise Servers SPI on a Remote Console

Install only the Microsoft Enterprise Servers SPI console packages on the HPOM remote 
consoles.

Installing Microsoft Enterprise Servers SPI in an HPOM Cluster Environment

Before installing the Microsoft Enterprise Servers SPI in a cluster environment, make sure 
that HPOM for Windows 8.10 is installed on each system of the cluster.

Task 1: At the first cluster-aware management server, select and install Smart Plug-ins.

Complete the steps described in Installing Microsoft Enterprise Server SPI before proceeding 
to the next management server.

Task 2: At the next cluster-aware management server, install pre-selected Smart Plug-ins.

Repeat the steps described in Installing Microsoft Enterprise Server SPI on a Management 
Server on each management server in the cluster and continue to every management server 
(as was defined in the HP Operations Manager cluster installation) until you have finished.

Upgrading Microsoft Enterprise Servers SPI

You can upgrade the Microsoft Enterprise Servers SPI on a management server or on a 
remote console.

Use the common installer to detect if any previous version of Microsoft Enterprise Servers SPI 
is already installed. If the previous version is found, then perform the followings tasks for 
upgrade. The common installer also consolidates all SPIs for installation purposes.

The HPOM console does not function properly until you install the Microsoft Enterprise 
Servers SPI on all nodes in the HPOM cluster.

Before beginning, be sure that sufficient disk space is available on each management server 
for the Microsoft Enterprise Servers SPI. Cancelling the installation process before 
completion could result in partial installations and require manual removal of the partially 
installed components.

The 

The HPOM console will not function properly until installations are completed on all the 
nodes in the cluster.
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Upgrading Microsoft Enterprise Servers SPI on a Remote Console

If you are using HPOM on a remote console, follow the Smart Plug-ins upgrade procedure for 
console-only systems:

1 At the console-only system, insert the HP Operations Smart Plug-ins DVD.

2 Follow the instruction screens until a dialog appears saying that a remote console 
installation has been found.

3 Click Next.

The upgrade of all previously installed packages now occurs.

Upgrading Microsoft Enterprise Servers SPI on a Standalone Management 
Server

Perform the following tasks to upgrade the Microsoft Enterprise Servers SPI on a 
management server:

Task 1: Prepare to install the later version of the Microsoft Enterprise Servers SPI

Rename the Microsoft Enterprise Servers SPI policy group. 

1 At the console, select Operations Manager.

2 Double-click Policy management, and Policy groups.

3 Select the SPI for Microsoft Enterprise Servers group and right-click it to rename it (for 
example, SPI for Microsoft EnterpriseServers_OLD).

Task 2: Install the later version of the Microsoft Enterprise Servers SPI

1 Insert the HP Operations Smart Plug-ins DVD and follow the instructions as they appear 
on the screen. See Installing Microsoft Enterprise Server SPI on a Management Server.

2 Select Microsoft Enterprise Servers to install. 

Task 3: Customize the policies of Microsoft Enterprise Servers SPI, if required.

Use Software Upgrade Tool Kit 2.0 to retain the customization of the previous versions of the 
Microsoft Enterprise Servers SPI policies. See HP Operations Smart Plug-in Upgrade Toolkit 
Windows User Guide for more details.

Task 4: Deploy updated instrumentation.

To enable the functioning of the new or updated policies, you must deploy the updated 
Microsoft Enterprise Servers SPI instrumentation. You can deploy instrumentation either on 
a group of nodes (if defined), or on individual nodes.

1 At the HPOM console, open Operations Manager → Nodes.

2 Right-click any node running the Microsoft Enterprise Server.
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3 Select All Tasks → Deploy instrumentation.

4 From the Instrumentation Files area, select SPI Data Collector, SHS Data Collector, 
BizTalk_Server. ISA_Server, MOSS_2k7, and OCS, (depending on your server environment 
setup), and click OK.

5 Repeat steps 1 through 4 as necessary for the remaining nodes which are running 
Microsoft Enterprise Servers. 

Upgrading Microsoft Enterprise Servers SPI in an HPOM Cluster Environment

Before upgrading the Microsoft Enterprise Servers SPI in a cluster environment, make sure 
that HPOM for Windows 8.10 is installed on each system of the cluster.

Task 1: At the first cluster-aware management server, select and install Smart Plug-ins.

Complete the steps described in Upgrading Microsoft Enterprise Servers SPI on a Standalone 
Management Server before proceeding to the next management server.

Task 2: At the next cluster-aware management server, install pre-selected Smart Plug-ins.

Repeat the steps described in Upgrading Microsoft Enterprise Servers SPI on a Standalone 
Management Server on each management server in the cluster and continue to every 
management server (as was defined in the HP Operations Manager cluster installation) until 
you have finished

The HPOM console does not function properly until you upgrade the Microsoft Enterprise 
Servers SPI on all nodes in the HPOM cluster.

Before beginning, be sure that sufficient disk space is available on each management server 
for the Microsoft Enterprise Servers SPI. Cancelling the installation process before 
completion could result in partial installations and require manual removal of the partially 
installed components.

The 

The HPOM console does not function properly until installations are completed on all the 
nodes in the cluster.
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Verifying Installation/Upgrade of Microsoft Enterprise Servers 
SPI

To verify the Microsoft Enterprise Servers SPI has been installed/upgraded properly check 
any one of the following:

• To verify the installation of the Microsoft Enterprise Servers SPI, check if the 
%ovinstalldir%\install\MSESSPI directory is created.

• Check the SPI under policy group. Expand Policy Group under Policy Management. The SPI 
for Microsoft Enterprise Servers in the list verifies the installation/upgrade. You can further 
expand SPI for Microsoft Enterprise Servers and check for Biztalk Server 2006 under BizTalk 
Server, Internet Security and Acceleration Server 2006 under Internet Security and Acceleration 
Server, Microsoft_Office_Communications_Server_2007 under 
Microsoft_Office_Communications_Server, and Microsoft Office SharePoint Server 2007 under 
SharePoint Portal Server depending on your environment setup.

• Verify that the policies have 8.00 version. 
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3 Configuring the Microsoft Enterprise Servers 
SPI
The SPI monitors the Microsoft Enterprise Servers by discovering the existing servers 
(BizTalk, Internet Security and Acceleration, SharePoint Portal, and Microsoft Office 
Communications Server) in your environment and maintaining the thresholds set up by the 
policies. The Microsoft Enterprise Servers SPI expands that discovery and adds multiple 
hierachical levels of details to each server.

The service map identifies the Microsoft Enterprise Servers. You can drill down each 
component of each existing server and find the root cause.

To find the origin of the problem, right-click the service in the service map where the alert 
occurs (indicated by the red color), and select Root Cause. 
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Basic Configuration Procedure

Perform the following tasks for all the Microsoft Enterprise Servers SPI in your environment.

Deploy the discovery policies to discover (detect) the existing services and components of the 
Microsoft Enterprise Servers environment in the managed nodes. Deploying these policies 
launches an automated process that adds the discovered services to the HPOM service tree 
and service map. 
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Change Unmanaged Nodes to Managed Nodes

To change unmanaged node to a managed node, add the nodes to the HPOM console’s nodes 
folder. 

1 In the console, right-click Nodes, and select Configure → Nodes.

2 In the Configure Managed Nodes box, add the unmanaged nodes to the Nodes using any of 
the following methods:
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— In the left pane double-click each node you want to add.

— Drag and drop nodes from left to right. 

— In the left pane, right-click each node, and then select Manage. 

3 (As needed) If a system running the HP Operations agent software is not available in the 
discovered nodes folder in the left pane, in the details pane right-click Nodes, select New 
Node, and then type the system name and other relevant information, and then click OK.

Deploy Instrumentation Categories on Managed Nodes

Deploy the instrumentation categories to the Microsoft Enterprise Servers SPI on the 
managed nodes. To deploy the instrumentation, perform the following steps:

1 In the console tree of HPOM, right-click a node and select All Tasks. Select Deploy 
instrumentation.... The Deploy Instrumentation box opens.

2 Select the mandatory instrumentation categories, SPI Data Collector and SHS Data Collector 
categories. 
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3 Select BizTalk_Server, ISA_Server, MOSS_2k7, and OCS, (depending on your server 
environment setup), and click OK. 

4 Perform steps (a) and (b) for all the Microsoft Enterprise Servers SPI managed nodes.

Create Data Sources

The Microsoft Enterprise Servers SPI collects metric data on the managed nodes, and logs the 
data to a data store on the managed nodes. By default, the SPI stores the data in the 
embedded performance component, also known as CODA of the HP Operations agent.

Deploy the Create Data Sources policy for each Microsoft Enterprise Servers SPI to create the 
required data sources in the data store. 

To deploy the create data sources policy:

1 In the console tree, expand Policy management → Policy groups → SPI for Microsoft 
Enterprise Servers → en → Microsoft_Office_Communications_Server  → 
Microsoft_Office_Communications_Server_2007  → Configuration.

Before creating data sources, discover the services of the Microsoft Enterprise Servers SPI. 
For this, complete the steps in Discovery Configuration Scenarios.

The Create Data Sources policy for BizTalk Server 2006 
(MSES_Biztalk_Create_Coda_DataSources) and Microsoft Office SharePoint Server 2007 
(MSES_MOSS-2k7_CreateCodaDataSources) is an auto-deploy policy and hence is deployed 
automatically while installing the Microsoft Enterprise Servers SPI.

For the Microsoft Office Communications Server 2007, you must deploy the 
OCS_CreateDataSources policy to create data sources manually whereas for Internet 
Security and Acceleration Server 2006 there is no specific policy to create data sources. Data 
source is automatically created after you manual deploy the policies. 
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2 Right-click Configuration, and select All Tasks → Deploy on..... A windows lists all the 
managed nodes.
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3 Select one or more managed nodes on which you want to deploy the 
OCS_CreateDataSources policy, and then click OK. The policy is deployed on the selected 
managed nodes.

Customize Policies

You can customize the policies, if required. For this,:

1 Right-click the policy and select All Tasks, and then Edit.... 

2 Click the Thresholds level (or Rules) or Options tab or both custimize.

3 Click Save and Close. 

If you 

If you choose to customize one or more policies after deploying them, ensure to redeploy the 
policies after customizing them. 
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Deploy Manual-Deploy Policy Groups

Deploy the manually deploy policy group for the <Microsoft Enterprise Server>:

1 In the console tree, expand Policy management → Policy groups → SPI for Microsoft 
Enterprise Servers → en → <Microsoft Enterprise Server> → <Policy Group>. For example, 
Internet Security and Acceleration Server 2007 → Availability Monitoring (example).  

2 Right-click the <Policy Group>. Select All Tasks → Deploy on.... Deploy policies on... Window 
appears listing all the managed nodes.

The BizTalk Server 2006 and Microsoft Office SharePoint Server 2007 have auto-deploy 
policy groups. These policies are automatically deployed on the managed nodes on the 
respective server.

F

For the BizTalk SPI policies, MSES_BizTalk_MessageBox_DatabaseSize and 
MSES_BizTalk_DTA_DatabaseSize, deployed only on the Microsoft BizTalk database nodes.
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3 Select one or more managed nodes on which you want the <Policy Group> to be deployed, 
and then click OK. The <Policy Group> is deployed on the selected nodes.

4 Perform steps 1 through 3 for all the remaining policy groups.

Assign only those policy groups on the managed nodes which host the roles that the policy 
group is related to. For example if the managed node hosts the AccessEdge Enterprise Server, 
deploy only the AccessEdge Server policy group, and so on.
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See the following table to deploy the specific policy group for the specific Microsoft Enterprise 
Server role. 

Table 3 Server and Policy Group

Deploy the following policy groups for all the managed nodes of Microsoft Office 
Communications Server 2007 irrespective of the specific server role:

• Discovery

Policy Management → Policy groups  → SPI for Microsoft Enterprise Servers → en → 
Microsoft_Office_Communications_Server → Microsoft_Office_Communications_Server_2007 
→ Discovery

• Configuration

Policy Management → Policy groups  → SPI for Microsoft Enterprise Servers → en → 
Microsoft_Office_Communications_Server → Microsoft_Office_Communications_Server_2007 
→ Configuration

• Others

Policy Management → Policy groups  → SPI for Microsoft Enterprise Servers → en → 
Microsoft_Office_Communications_Server → Microsoft_Office_Communications_Server_2007 
→ Others

Server Policy Group

BizTalk Server Policy Management → Policy groups  → SPI for 
Microsoft Enterprise Servers → en → BizTalk 
Server → Biztalk Server 2006

Internet Security and 
Acceleration Server

Policy Management → Policy groups  → SPI for 
Microsoft Enterprise Servers → en → Internet 
Security and Acceleration Server → Internet 
Security and Acceleration Server 2006

Microsoft SharePoint 
Portal Server

Policy Management → Policy groups  → SPI for 
Microsoft Enterprise Servers → en → SharePoint 
Portal Server → Microsoft Office SharePoint 
Server 2007

Microsoft Office 
Communications Server

Policy Management → Policy groups  → SPI for 
Microsoft Enterprise Servers → en → 
Microsoft_Office_Communications_Server → 
Microsoft_Office_Communications_Server_2007
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Data Logging Scenarios

If you use Performance Agent as the datastore, data source creation and data logging happens 
in Performance Agent, by default. There is no configuration required.

To create data sources and to log data into CODA, while Performance Agent is installed, 
perform the following:

1 Create a folder dsi2ddf in the path %OvAgentDir%\Conf, if it does not exist.

2 Create an empty file nocoda.opt.

3 Enter the names of the other data sources except OCS, ISASERVER2006, MOSS_2007, 
and  MSES_BIZTALKSERVER_INTERVAL which are to be created and for which the 
data logging has to happen in Performance Agent into the file nocoda.opt.

The data sources OCS,ISASERVER2006, MOSS_2007, 
MSES_BIZTALKSERVER_INTERVAL are created and data logging happens in CODA.

For more details on the data store (CODA) metrics and policy logging details, see Microsoft 
Enterprise Servers SPI Online Help.

Additional Configuration Procedure for Microsoft Enterprise 
Servers SPI for BizTalk Server 2006

Use the MSES_BTS_DB_Configuration tool to configure the Microsoft Enterprise Servers SPI 
for BizTalk Server 2006.

Using MSES_BTS_DB_Configuration Tool

The BizTalk Server 2006 stores data in SQL server instead of the WMI CIMV2 database. The 
the Microsoft Enterprise Servers SPI must connect to the BizTalk Server’s SQL database to 
collect the related data it needs.

Before running Discovery, the HPOM administrator must configure the SQL database for all 
nodes with BizTalk Server installed. Windows integrated security (SSPI mode) does not work 
if the SQL authentication mode is set for SQL server. If SQL authentication is "users /", the 
HPOM console needs to know the SQL user name and password. To connect to SQL server 
even when it is in SQL authentication mode, the HPOM administrator can use the 
MSES_BTS_DB_Configuration tool to store the corresponding SQL server name, and the SQL 
user name and password. If this configuration is not done for BizTalk Server 2006 nodes, the 
default SQL user name and password's value is considered.

The data store metrics is applicable only to the Microsoft Office Communications Server 
2007.
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Launching the MSES_BTS_DB_Configuration Tool

To launch the MSES_BTS_DB_Configuration tool:

1 In the HPOM console, expand Tools → SPI for Microsoft Enterprise Servers → BizTalk Server.

2 Right-click the MSES_BTS_ DB_Configuration tool. Select All Tasks, and then Launch Tool.... 
The Edit Parameters window appears.
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3 Select one or more nodes where you want to configure BizTalk Server 2006 by launching 
the tool, and then click Launch.... A Configure Database window appears for each selected 
node.

4 The Machine Name field is read only. Type the Server Name (for BizTalk Database), SQL 
User Name and SQL password and confirm the password.

5 Save the configuration.
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Discovery Configuration Scenarios

Before deploying the discovery policy group, edit the discovery policy for the following 
Microsoft Enterprise Servers:

• BizTalk Server 2006

• Microsoft Office SharePoint Server 2007

• Microsoft Office Communications Server 2007

Edit Discovery Policy

The BizTalk_Discovery policy discovers the systems infrastructure of the BizTalk Server 2006 
while the Microsoft Office SharePoint Server 2007 Discovery and OCS_Discovery discovers 
the application services of the Microsoft Office SharePoint Server 2007 and the Microsoft 
Office Communications Server 2007.

The following privileges are required:

• The BizTalk_Discovery policy requires BizTalk administrator and local administrator 
privileges and privileges to access all the BizTalk databases.

• The Microsoft Office SharePoint Server 2007 Discovery policy requires SharePoint 
administrator and local administrator privileges and privileges to access the SharePoint 
databases.

• If the agent on the node is not running under the default Local System account, the 
OCS_Discovery policy should run as a user who is member of the 
RTCUniversalGuestAccessGroup group, if the node is a member of the OCS pool. For 
Edge Servers, provide the privileges of a Local Administrator.

To edit the Discovery policy:

1 In the console tree, expand Policy management → Policy groups → SPI for Microsoft 
Enterprise Servers → en → Microsoft_Office_Communications_Server  → 
Microsoft_Office_Communications_Server_2007 → Discovery.

2 Select the OCS_Discovery policy (on the right pane) and double-click to open the editor. 
The OCS_Discovery window appears with the Discover tab opened by default.

3 Type the user credentials and the password in the User Editable Parameters box. The 
username format for:

a DCE agent is domain\user

b HTTPS gent is domain\\user
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4 Click Save and Close.

Perform the same steps for the BizTalk_Discovery policy and Microsoft Office SharePoint 
Server 2007 Discovery policy. 

Deploy Discovery Policy on Managed Nodes

Deploy the Discovery policy group for each Microsoft Enterprise Servers SPI on the managed 
nodes. For this:

1 In the console tree, expand Policy management → Policy groups → SPI for Microsoft 
Enterprise Servers → en → <Microsoft Enterprise Server> → Discovery. 

2 Right-click Discovery of the respective Server, and select All Tasks →Deploy on....
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3 In the Deploy policies on... box, select one or more Microsoft Enterprise Servers nodes, and 
click OK. The Discovery policy of the <Microsoft Enterprise Server> is deployed on the 
selected nodes.

4 To view the deployment, under the Policy Management, right-click Deployment jobs, select 
New Window from Here. From the menu, select Window →Tile Horizontally. 

In the tiled window, you can see the executed processes of the <Microsoft Enterprise 
Server> services discovered and the service map updated. 

Starting at the Services → Systems Infrastructure (for BizTalk Server 2006) and Application 
Services (for Microsoft Office SharePoint Server 2007) of the console tree (in the left pane), 
you can navigate downward to each component, under which you can see a Services folder.

Failed Binary on the Managed Node

In some cases the Agent fails to update the discovered services to the HPOM management 
server. The possible cause and suggested action is as follows:
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• Possible cause: The output of the Microsoft Enterprise Servers SPI discovery policy is not 
a properly formatted xml file. 

• Suggested action: Run the Microsoft Enterprise Servers SPI discovery binary on the 
managed node. To do this:

a Login to the managed node as an administrator.

b From the command prompt, open the instrumentation directory.

c Run the ovadsdisc.exe > out.xml command.

d Check the out.xml is in the required xml format by opening it in the web browser.

View Service Map

After the discovery has occurred, you can see the discovered services graphically represented 
under the <Microsoft Enterprise Server> in the HPOM service map.

1 In the console details pane, select Services → Applications / Systems Infrastructure. 

2 Select the <Microsoft Enterprise Server>. 
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3 Expand the respective component (servers or roles) in the left pane to make it visible in 
the service map in the right pane. 
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4 Using Policies and Tools
Policies and tools monitor the Microsoft Enterprise Servers environment.

Customizing Policies

Policies run according to rules and schedule specifications. Measurement threshold policies 
contain the rules for interpreting Microsoft Enterprise Servers states or conditions.

You can customize specific policies to suit your requirements of the Microsoft Enterprise 
Servers environment.

Customizing Auto-Deploy (Default) Policies

The BizTalk Server 2006 and Microsoft Office SharePoint Server 2007 have auto-deploy 
policy groups. The polices are automatically deployed on the managed nodes on the respective 
server.

To customize the auto-deploy policy:

1 Expand Policy management → Policy groups → SPI for Microsoft Enterprise Servers → en → 
<Microsoft Enterprise Server> → Auto-Deploy. 

2 Double-click Auto-Deploy. All the auto-Deploy policies of the <Microsoft Enterprise 
Server> are listed.

3 Right-click the policy and click All Tasks, and then Edit.... A window appears to enable you 
to customize the policy.

4 Click Task or Schedule or both tabs to customize the policy.

Customizing Monitoring Schedule or Measurement Threshold Policies

You can customize the monitoring schedule or measurement threshold policies for any 
Microsoft Enterprise Servers SPI policy. After you update the policy for the nodes to which 
you want the latest change applied, right-click the Policy group, and select All Tasks → Update 
to latest, and then re-deploy one or more policies to one or more nodes. by following these step:

1 Expand the Agent policies grouped by type, and select Scheduled Task.

2 Right-click the specific <Microsoft Enterprise Servers SPI >policy, and select All Tasks → 
Edit... in the details pane of the console. Alternatively, you can also double-click the 
specific Microsoft Enterprise Servers SPI policy. 

3 Click the Task or Schedule or both tabs to modify the scheduled task policy.
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Creating Custom Data Collection Groups

You can create custom data collections to change the monitoring intervals or thresholds. To 
create a separate group of policies, copy the desired policies into a folder with the new group 
name. After pasting the policies into the new group, you can then modify them and change the 
version numbers. The user-created versions make it possible to deploy specifically tailored 
policies to node groups to meet their monitoring needs. Using this method makes it possible to 
bring nodes and policies together in groups that are easily recognizable.

Using Tools

The Microsoft Enterprise Servers tools are used to configure the Microsoft Enterprise Server 
(BizTalk Server 2006) and for troubleshooting (Self Healing Info).

Launching the Microsoft Enterprise Servers SPI Tools

To launch the Microsoft Enterprise Servers SPI tool:

1 Expand Tools → SPI for Microsoft Enterprise Server.

2 Right-click the tool, and select All Tasks and then click Launch Tool.... All the nodes are 
listed.

3 Select one or more nodes where the tool is to be launched and then click Launch....

For more detailed description on each policy and tool, see the Microsoft Enterprise Servers SPI 
Online Help.
48 Chapter 4



5 Integrating Microsoft Enterprise Servers SPI 
with HP Reporting and Graphing
Reports and graphs provide you with a complete view of the performance of the components of

the Microsoft Enterprise Servers.

Using Reports and Graphs

Reports and graphs cover updates on the availability or the activity or both in Microsoft 
Enterprise Servers for each server running the services.

These web-based reports are automatically generated every night and provide you with a 
routine means of checking the Microsoft Enterprise Server availability on the nodes.

Integrating Microsoft Enterprise Servers SPI with HP Reporter

You must install MSESSPI Reporter package on HP Reporter Server to use the Microsoft 
Enterprise Servers SPI reports. For this, run the Setup.exe. This setup installs the 
Microsoft Enterprise Servers SPI Report Package within the Reporter server. After you 
complete the installation, configure the Reporter to generate reports. 

Installing Report Package

To install the Microsoft Enterprise Servers SPI Report Package on a stand-alone Reporter 
server:

1 Insert the HP Operations Smart Plug-ins DVD.

2 Double-click the file Setup.exe. Follow the instructions as they appear for the 
installation on Management Server for Windows. Select Reports for Microsoft Enterprise 
Servers SPI. Continue the next steps till a dialog box opens indicating the completion of 
the installation. 

3 Select Finish to complete the installation.

If the Microsoft Enterprise Servers SPI is not installed in the Operations Manager Window 
server, you must install it on this server to enable the HP Reporter function in one or more 
managed nodes.
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Configuring Report Package

To configure the Microsoft Enterprise Servers SPI Report Package:

1 Open the Reporter main window and check the status pane to note the changes to the 
Reporter configuration, which include uploading the Microsoft Enterprise Servers SPI 
reports.

The Microsoft Enterprise Servers SPI Reports are automatically assigned to the ALL 
group in the Reporter main window. (See Generating Reports for HPOM Report list.) 

2 Add group and single system reports by assigning reports as desired. 

Reports are available for viewing the following day.

Instructions are available in the HP Reporter Help for assigning Microsoft Enterprise 
Servers SPI reports to the targeted nodes. To access Help, select Reports or Discovered 
Systems in the left panel of the HP Reporter main window and right-click it. Select Report 
Help or Discovered Systems Help from the sub-menu that appears. See the topic “To assign 
a report definition to a Discovered Systems Group.” Reporter also includes two online 
documents: the Concepts Guide and the Installation/Special Configurations Guide for 
further information.

Identify the Microsoft Enterprise Servers SPI reports of group and single 
systems by their full name; for example, abc.xyz.com is acceptable while 
abc is not.
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Generating Reports

After you install the Microsoft Enterprise Servers SPI, the HPOM generates reports using the 
SPI-collected data for Microsoft Enterprise Servers. HPOM runs the reports regularly on a 
nightly schedule. You can see the updated reports every day because the HPOM, by default, 
re-generates reports every night with the day’s data.

Generate the reports using HTML format. The report data of Microsoft Enterprise Servers 
SPI is collected based on metrics used for each report. The HP Reporter identifies the data 
through metric variables. This data is stored in the MS SQL Reporter database. 

You can access the reports of SPI for Microsoft Enterprise Servers from the Reports area of the 
HPOM console. You can find complete description of all the reports in Microsoft Enterprise 
Servers SPI Online Help or Microsoft Enterprise Servers SPI Online Help PDF. 

If you want to customize your reports you must install HP Reporter. The documentation on 
HP Reporter on modifying the reports is available in Concepts Guide, Installation Guide and 
Special Configuration Guide, Online Help, and Release Notes.

If the report contains a huge amount of data, there is a possibility that the browser might 
crash when the reports are viewed in HTML format.In such situations, view the reports in 
pdf format.
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Reports Fail with Oracle Database

Some of the reports fail due to invalid Reporter ODBC driver. 

• Possible cause: The versions of Oracle client to access Oracle database do not match.

• Suggested action: Use Oracle client 9.2.0 to access Oracle 9.2.0 database and 10gR2 client 
to access 10gR2 database

Integrating Microsoft Enterprise Servers SPI with HP Performance 
Manager

The Microsoft Enterprise Servers SPI comes with a set of preconfigured graph templates. 
Ensure that these graph templates are installed on an HP Performance Manager system, and 
that the data store (CODA) runs on the managed node.

To integrate the Microsoft Enterprise Servers SPI with HP Performance Manager, follow 
these steps:

1 Install and configure the Microsoft Enterprise Servers SPI.

2 Install the graph package.

On a Windows system that has HP Performance Manager, follow these steps:

a Insert the Smart Plug-ins DVD-ROM (that contains the reporting packages) into the 
DVD-ROM drive, and in Windows Explorer, double-click:

 <DVD-Drive>\SPIs\MSES SPI OVPM Configuration Package\

HPOvSpiMsesGc.msi.

b Follow the instructions as they appear. Select graphs for Microsoft Enterprise Servers 
SPI. 

For information see the HP Performance Manager documentation. 

If you are using HP Performance Agent for viewing the graphs, the Microsoft Enterprise 
Servers SPI shows incorrect data.
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6 Removing Microsoft Enterprise Servers SPI
You can remove the Microsoft Enterprise Servers SPI by the following ways:

• Using the DVD

• Using the Windows Control Panel - Add/Remove Programs

To remove the Microsoft Enterprise Servers SPI, remove all policies and policy groups from 
the managed nodes, and then from the management server. 

Using DVD

You must remove the SPI components manually before removing the SPI from the 
management server using a DVD.

Removing Microsoft Enterprise Servers SPI Components

The Microsoft Enterprise Servers SPI components include policies, reporting package, and 
graphing package.

Task 1: Remove the Microsoft Enterprise Servers SPI policies from all managed nodes

1 At the console expand the folder Policy Management.

2 Right-click SPI for Microsoft Enterprise Servers, and select All tasks →Uninstall from....

3 In the Uninstall on... window, select each check box next to one or more nodes from which 
you want to remove the policies. 

4 Click OK. 

Task 2: Remove Microsoft Enterprise Servers SPI policy group from the management server

1 At the console expand Policy groups.

2 Right-click SPI for Microsoft Enterprise Servers, and select Delete.

Task 3: Remove Microsoft Enterprise Servers SPI programs from the HPOM management server

1 Insert the HP Operations Smart Plug-ins DVD.

2 Follow the instructions as they appear on the screen and start the uninstall procedure by 
selecting the Remove products.

3 In the Product Selection Uninstall window, select Microsoft Enterprise Servers (SPI), and click 
Next.

To verify policies have been removed, at the HPOM console expand the Nodes, right-click a 
node, and then select View → Policy Inventory.
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4 In the next window select Remove.

5 Click Finish to complete.

Task 4: Remove the Microsoft Enterprise Servers SPI Policies from the Management Server

1 Expand the Agent Policies grouped by type.

2 From each policy type, delete all the versions of the policies of the Microsoft Enterprise 
Servers SPI.

Using the Windows Control Panel

Remove the SPI components before removing the Microsoft Enterprise Servers SPI from the 
management server. To remove the SPI components manually, perform the tasks in 
Removing Microsoft Enterprise Servers SPI Components.

Removing Microsoft Enterprise Servers SPI from Management Server

To remove the SPI from the management server, perform the following steps:

1 From the Start menu, select Settings → Control Panel and open Add/Remove Programs.

2 Select HP Operations Smart Plug-ins, and then click Change.

3 Click Next on the Welcome screen.

4 Select Remove Programs, and select HP Operations Smart Plug-ins.

5 Select MSESSPI.

6 Complete the instructions until a message appears which shows that Microsoft Enterprise 
Servers SPI is removed.

Removing Reporting Package

You can remove the reporting package. To remove the reporting package:

1 From the Start menu, select Settings → Control Panel and open Add/Remove Programs.

2 Select the reporting package, and then click Change.

3 Complete the instructions until a message appears which shows that HP Reporter has 
been removed.

Each window updates you with the status of removing the Microsoft Enterprise Servers SPI.

When you use the Windows Control Panel to remove any SPI, you have two options: (1) to 
remove selected SPIs or (2) to remove HPOM for Windows. If you want to remove both HPOM 
and the SPIs, you must first remove all Smart Plug-ins from managed nodes then from the 
management server. You can then remove SPI from HPOM.
54 Chapter 6



Removing Graphing Package

To remove the graphing package:

1 From the Start menu, select Settings → Control Panel and open Add/Remove Programs.

2 Select the graphing package, and then click Change.

3 Complete the instructions until a message appears which shows that HP Performance 
Manager has been removed.

Removing Reporting and Graphing Package using .msi File

You can also remove the reporting and graphing package by using .msi file.

Removing Reporting Package using .msi file

To remove the reporting package using .msi file, perform the following steps:

1 Browse to:

<SPI DVD>\SPIs\MSES Reporter Package\MSESSPI-Reporter.msi

2 Right-click MSESSPI-Reporter.msi, and then click Uninstall.

3 Confirm the removal of the reporting package by clicking Yes.

Removing Graphing Package using .msi File

To remove the graphing package using the .msi file, perform the following steps:

1 Browse to:

<SPI DVD>\SPIs\MSESSPI OVPM ConfigurationPackage\HPOvSpiMsesGc.msi

2 Right-click HPOvSpiMsesGc.msi, and then click Uninstall. 

3 Confirm the removal of the graphing package by clicking Yes.

Removing Graphing Package

To remove the graphing package:

1 From the Start menu, select Settings → Control Panel and open Add/Remove Programs.

2 Select the graphing package, and then click Change.

3 Complete the instructions until a message appears which shows that HP Performance 
Manager has been removed.
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