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Welcome to This Guide
Welcome to HP SOA Systinet Workbench, a tool for use with SOA Systinet. Taxonomy Editor enables you
to create, modify, and delete taxonomies and download them from or upload them to any number of SOA
Systinet servers.
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Document Conventions

The typographic conventions used in this document are:

Script name or other executable command plus mandatory arguments.run.bat make

A command-line option.[--help]

A choice of arguments.either | or

A command-line argument that should be replaced with an actual value.replace_value

A choice between two command-line arguments where one or the other is
mandatory.

{arg1 | arg2}

Operating system commands and other user input that you can type on the
command line and press Enter to invoke. Items in italics should be replaced
by actual values.

rmdir /S /Q System32

Filenames, directory names, paths and package names.C:\System.ini

Program source code.a.append(b);

An inline Java or C++ class name.server.Version

An inline Java method name.getVersion()

A combination of keystrokes.Shift-N

A label, word or phrase in a GUI window, often clickable.Service View

A button in a GUI window.OK

Menu choice.New->Service
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Documentation Updates

This manual's title page contains the following identifying information:

• Software version number

• Document release date, which changes each time the document is updated

• Software release date, which indicates the release date of this version of the software

To check for recent updates, or to verify that you are using the most recent edition of a document, go to:

http://ovweb.external.hp.com/lpe/doc_serv/
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Support

Mercury Product Support

You can obtain support information for products formerly produced by Mercury as follows:

• If you work with an HP Software Services Integrator (SVI) partner (http://h20230.www2.hp.-
com/svi_partner_list.jsp), contact your SVI agent.

• If you have an active HP Software support contract, visit the HP Software Support Web site and use
the Self-Solve Knowledge Search to find answers to technical questions.

• For the latest information about support processes and tools available for products formerly produced
by Mercury, we encourage you to visit the Mercury Customer Support Web site at: http://hp.-
com/go/hpsoftwaresupport.

• For the latest information about support processes and tools available for products formerly produced
by Systinet, we encourage you to visit the Systinet Online Support Web site at: http://www.systinet.-
com/support/index.

• If you have additional questions, contact your HP Sales Representative.

HP Software Support

You can visit the HP Software Support Web site at:

http://www.hp.com/go/hpsoftwaresupport

HP Software online support provides an efficient way to access interactive technical support tools. As a
valued support customer, you can benefit by using the support site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts
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• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a
support contract. To find more information about access levels, go to: http://h20230.www2.hp.com/new_ac-
cess_levels.jsp

To register for an HP Passport ID, go to: http://h20229.www2.hp.com/passport-registration.html
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1 Getting Started

This chapter shows you how to start using HP SOA Systinet Taxonomy Editor. It contains the following
sections:

Introduction to the User Interface on page 11

Creating a Taxonomy Project on page 13

Use Cases on page 14

Introduction to the User Interface

The user interface is split into four panes with a toolbar across the top, as shown in Figure 1. The upper left
pane is the Project Explorer and the upper right pane is the editor for items selected from the Project
Explorer. Below the editor, there is a Validation Results tab for every taxonomy validation run. The lower
left pane is the Server Explorer, listing all servers associated with the project.
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Figure 1.  Taxonomy Editor UI

Project Explorer displays a hierarchy containing, from highest level to lowest:

• Taxonomies

• Categories and sub-categories

Taxonomy status is indicated by the appearance of a ">" or "?" character to the left of a taxonomy name as
shown in Figure 2. Please see Table 1 on page 41 for more details.
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Figure 2. Taxonomy Status

Clicking an item in the Project Explorer opens a detail tab in the editor.

Most Taxonomy Editor functions can be used with keyboard shortcuts instead of the GUI. A list
is given in Appendix A, Keyboard Shortcuts.

Creating a Taxonomy Project

To work with taxonomies, you need a Taxonomy Project. You can create any number of Taxonomy Projects
to help organize your work. To create a Taxonomy Project:

1 Open the New Taxonomy Project wizard in one of these ways:

• In the Workbench Welcome page, click the Create Taxonomy Project link.

•
Click the New  icon. The New: Select a Wizard window opens. Select HP SOA Systinet-
>Taxonomy Project.

• Alternatively, from the File menu, select File+New-> Taxonomy Project.

• Alternatively, press Alt-Shift-N and then press R. The New Project: Select a Wizard window
opens. Select HP SOA Systinet->Taxonomy Project.

2 Type in a name and location for the project. The default location is the workspace you chose when
you launched Taxonomy Editor

3 Click Next. If no server is defined, the New Server window opens and you go to Step 5. Otherwise
the Choose Server window opens.
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4 Select whether to add a new server to the project or use a server you have already defined. This step
does not appear if there are no defined servers. If you select an existing server, click Next and go to
Step 6.

5 Type in the name and URL of a SOA Systinet server. Taxonomies are downloaded from and published
to this server. You can include additional servers later (see Adding a SOA Systinet Server on page
25). Enter the username and password you use for this server. You can save the password and validate
your connection to the server.

6 Select taxonomies to download from the server. You can filter them by text. Additional taxonomies
can be downloaded later.

Use Cases

Use of HP SOA Systinet Workbench typically involves the following tasks:
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SectionsTask

Adding a SOA Systinet Server on page 25Defining one or more SOA Systinet Servers.

Updating Taxonomies From the Server on page 27Updating local copies of taxonomies stored on SOA
Systinet servers.

• Creating and Deleting Taxonomies on page 23

• Modifying Taxonomies on page 31

Making local modifications

Publishing Changes on page 40Attempting to publish changes

Resolving Conflicts and Validation Issues on page
45

Fixing problems such as conflicts
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2 Searching for Taxonomies

This chapter describes the various search facilities provided by Taxonomy Editor. It includes the following
sections:

• Quick Find Taxonomy on page 17. A simple and fast tool for finding taxonomies in a project.

• Advanced Searching on page 19. A sophisticated tool for finding taxonomies that match various para-
meters.

Quick Find Taxonomy

Using the Quick Find feature is the simplest way to find a taxonomy that you need.

To quickly find a taxonomy in a project:

1 On the main menu bar, click Search, and then select Quick Jump. Alternatively, press Ctrl-J. The
Find Taxonomy wizard opens.
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2 In the input field of the dialog, type the search string.

3 Clicking the  icon opens a menu with the following options:

Show in the tree without opening detail

This option shows the taxonomy (after it is located and chosen) in the tree but does not open
its details page in the editor pane.

Case sensitive

This option enables you to perform a case sensitive or insensitive search.

4 In the On project field, select which project to search for the taxonomy.

5 You should now have a list of located taxonomies in the Matching taxonomies field. Select the tax-
onomy you want to open (left click) and click Open taxonomy.
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The taxonomy should now be selected in Project Explorer. If you did not select the Show in the tree
without opening detail view option, the taxonomy is also open in the main view.

Advanced Searching

When a more elaborate search tool than the Quick Find is needed, use the Taxonomy Editor Advanced
Search. It supports:

• Searching for a specific type.

• Searching according to a specific value of a property

• Searching different text strings: full text, regular expression or whole word

To perform an advanced search for taxonomies:

1 Open the Search Dialog. On the main menu bar, click Search then select Search or press Ctrl-H.

2 Select the Taxonomy Search tab.
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3 In Containing text, type the expression for which you wish to do the text search.

4 In Search only in, choose properties of taxonomy or category to search.

5 In Search controls, select options that you want:

Case sensitive

Enables you to perform a case sensitive or insensitive search.

Whole words only

Lets you perform a whole word or partial match search.

Regular expression

Set this option to perform a regular expression or text search. Text search is default.

6 In Scope, select option that you want:
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Workspace

Searches the Eclipse workspace.

Selected resources

Searches in all entities which are selected in the Project Explorer.

Working set

A working set is a customized selection of resources from the Project Explorer. When you
select this option, click Choose to open a wizard where you can select from existing working
sets or create a new working set. Working sets are persistent–you can create a working set
and select it again in future searches.

7 After you complete all search conditions, click Search. The results appear in the Search view.
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3 Manipulating Taxonomies

This chapter describes how to work with taxonomies, as detailed in the following sections:

• Creating a New Taxonomy on page 23

• Downloading, Updating and Importing Taxonomies on page 25

• Modifying Taxonomies on page 31

• Publishing Changes on page 40

Creating and Deleting Taxonomies

Instead of downloading taxonomies you can create them from scratch. This section also describes how to
delete a taxonomy.

Creating a New Taxonomy

To create a new taxonomy:

1 Do one of the following:

• Right-click the project in Project Explorer where you want to create the new taxonomy. The
context menu opens. Click New->Taxonomy.

• Click File->New->Taxonomy in the menu bar.

• Press Ctrl-N to open a menu of wizards. Select HP SOA Systinet->Taxonomy.

2 Type the taxonomy properties as follows:
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Taxonomy name

Your choice of name for the taxonomy. The content of the name element in the taxonomy's
XML representation.

Taxonomy ID

A unique identifier for the taxonomy. The value of tModelKey attribute in the taxonomy's XML
representation.

Filename

The name of the file in which the taxonomy is stored in the local file and, after publishing,
on the remote server.

Source folder

The project folder that will contain the taxonomy.

3 Click Finish.

The taxonomy should now be visible in Project Explorer. Its NEW status is indicated by the appearance
of its icon. See Figure 2. The character '>' appears before the server and taxonomy labels to indicate that
there are unpublished changes.

It is not possible to create a new taxonomy with the same filename as a taxonomy imported from
the server. However, a conflict can still arise if the taxonomy exists on the server and has not been
imported.

You can also create a new taxonomy by importing a taxonomy from a file.

Deleting a Taxonomy

To delete a local taxonomy, right-click the taxonomy in Project Explorer and select Delete.

To restore a deleted taxonomy, open the project's context menu and click Restore from Local History.
This opens the Eclipse local history wizard. Select the version you want to restore. Alternatively, you can
download the taxonomy from the server, if a version has been published.
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To delete a taxonomy from the server, right-click the taxonomy in Project Explorer and select HP SOA
Systinet->Delete Taxonomy. You will be asked to confirm that you want to delete the taxonomy from the
server and given the option of deleting the local copy as well.

Copy and Paste

Taxonomies can be copied and pasted using:

1 Cut or Copy in the context menu for a taxonomy or selected taxonomies.

2 Paste in the context menu of the target server.

A pasted taxonomy has the status:

• NEW if a taxonomy of that name had not previously existed in that location.

• MODIFIED if pasting overwrote an existing taxonomy.

You will be prompted for confirmation to overwrite any existing taxonomies.

Downloading, Updating and Importing Taxonomies

Taxonomies may be created, downloaded from a SOA Systinet server or imported from a file. Once all
taxonomies have been downloaded, they can be updated individually or exported.

First we describe how to configure a SOA Systinet server so that taxonomies may be downloaded from it.
Then we describe the import actions.

Adding a SOA Systinet Server

You added a server to your project when you created the project (see Creating a Taxonomy Project on page
13). You can add additional servers through a similar procedure.

To add a SOA Systinet server:

1 Right-click a server in the Server Explorer. Its context menu opens.

2 Select New Platform Server. The New Server  wizard opens.
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3 The server properties are as follows:

Name

Your choice of name for this SOA Systinet server.

URL

The prefix of URLs by which this server is accessed, including its application context.

Username and Password

Optional. Login credentials can be entered here or when connecting to the server later.

Save password

If this option is checked, you can enter a username and a password and these credentials will
be encrypted and stored persistently.
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Validate connection

Validates your server credentials when you finish the wizard.

4 Click Finish.

The new server is shown in the Server Explorer.

Downloading Taxonomies from a Server

To download taxonomies from a server:

1 Do one of the following:

• In the Project Explorer, right-click the taxonomy project to which you want to download taxonom-
ies. The project's context menu opens. Select HP SOA Systinet->Download taxonomy.

• In the Server Explorer, right-click the server from which you want to download taxonomies. The
server's context menu opens. Select Download taxonomy.

The Download Taxonomies wizard opens, displaying a list of taxonomies on the server. (If you opened
the wizard from the project, you see the taxonomies on the server associated with that project.)

2 Select the taxonomies you want to download and click Next.

3 Select the location to which you want to download the taxonomies and click Finish.

Taxonomy Editor displays progress while taxonomies are being downloaded from the server. When the
download is complete the taxonomies are visible in Project Explorer as shown in Figure 1. Expand a tax-
onomy's node to view its categories.

Updating Taxonomies From the Server

You can update a local copy of a taxonomy that is also on the server. Right-click the taxonomy to open its
context menu and select HP SOA Systinet->Update taxonomy

Updating a taxonomy overwrites any local changes you made to it. Taxonomy Editor asks you to confirm
that you want to update a taxonomy if updating it would overwrite local changes. Copy your local taxonomy
to a new taxonomy with a different name before updating it if you do not want to lose local changes.
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If there is a conflict between your local version of a taxonomy and the version on a server, updating the
taxonomy can resolve this conflict. See Resolving Conflicts and Validation Issues on page 45.

Importing and Exporting Taxonomy Files

Importing Taxonomies from Files

You can import taxonomies into your Eclipse project from elsewhere in your file system.

To import a taxonomy from your filesystem:

1 Right-click a taxonomy project. Its context menu opens.

2 Select Import->Taxonomy. The Import Taxonomy wizard opens.

3 Browse for the folder holding the taxonomy you want to import. When you select the folder, all XML
files in that folder are displayed.

Chapter 328



4 Select the XML files you want to import as taxonomies.

5 Browse for the project folder into which you want to import the taxonomies.

6 Click Finish.

When importing a taxonomy from a file whose filename already exists in the local folder, Taxonomy
Editor will ask if you want to overwrite the taxonomy. If you press Yes or Yes To All, the current
taxonomy will be updated by attributes and categories from the XML file and its status will be
changed to MODIFIED.

Taxonomy Editor displays a progress indicator while taxonomies are being imported from the file system.
When the import is complete, the taxonomies are visible under the server in Project Explorer as shown in
Figure 1. Under each imported taxonomy you can view its categories.

Now you can publish these imported taxonomies to a SOA Systinet repository.

Exporting Taxonomies to Files

You can export a taxonomy to an XML file in the filesystem, a JAR archive, a deployable archive (EAR
or JAR) or other file types supported by Eclipse. This is the standard Eclipse export function.

To export a taxonomy:

1 Right-click the taxonomy you want to export. Its context menu opens.

2 Select Export. The export wizard opens.
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3 Select the type of file you want to export the taxonomy to. Click Next.

4 A specific wizard opens depending on the type of file you are exporting to. Browse for the destination
and fill in any other information, such as the EAR application. Select whether or not to overwrite ex-
isting files. Click Finish when done.

Taxonomy Editor displays a progress indicator while taxonomies are being exported to the file storage. You
can stop this process anytime by clicking the cancel button.
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Modifying Taxonomies

A taxonomy can be modified by:

• Editing and saving its properties.

• Changing its categories in the Categories tab.

Editing Taxonomy Properties

To edit a taxonomy's properties:

1 Double-click the taxonomy in Project Explorer.

2 Edit properties on sub-tabs of the taxonomy.

3 Save your edits.

The changed status of the taxonomy is then visible in Project Explorer. See Figure 2.

It is not possible to publish changes until they are saved.

The following subsections describe the sub-tabs of a taxonomy tab.

To switch between different sub-tabs of a taxonomy tab by keyboard only, make sure one of the
sub-tabs is focused and press Ctrl-PgDown or Ctrl-PgUp.

Overview Tab

This tab is divided into two collapsible sections. The first is titled General. You can view and edit the fol-
lowing properties in this section:

Name

Your choice of name for the taxonomy. The content of the name element in the taxonomy's XML
representation.
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Taxonomy ID

A unique identifier for the taxonomy which must start with uddi:. The value of tModelKey attribute
in the taxonomy's XML representation.

Description

An optional description.

The second section is titled Origin. It shows:

Resource URL

A REST interface URL where this taxonomy can be viewed on the server once published. Double-
click this URL to visit it in your web browser.

Categories

This tab enables you to change the category structure and category properties of a taxonomy.

The actions in this tab can be performed through keyboard shortcuts, which you may find more
convenient to use.
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Figure 3. Categories Tab

Adding a New Category

To add a new category to a taxonomy:

1 Open the taxonomy to which you want to add the category or sub-category.

2 Change to the Categories tab.

3 Do one of the following:

• Click the Add Next button to add a new category at the same level as the selected category, beneath
it in the list.

• Click the Add Child button to add a new sub-category into the selected category.

• Press INSERT to add a category in the same way as clicking the Add Next button.
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When you add a new category while no category is selected, it will add the category to the
first position of the taxonomy.

4 The New Category wizard now appears. The category properties are:

Name

Your choice of name for the category. This represents the value of the keyName attribute in the
taxonomy's XML representation.

Value

Unique identifier for the category. This represents the value of the keyValue attribute in the
taxonomy's XML representation.

Disabled

If you select this checkbox, the category can be used in an artifact.

5 Click Finish.

The new category should then be visible in Category Structure.

Removing a Category

To remove a category, right-click the category in Category Structure and select Delete.

The deleted category is no longer visible in Category Structure.

Copying, Cutting and Pasting Categories

To cut, copy or paste categories:

1 Select categories in Category Structure that you want to cut or copy. Then right-click and choose
Copy or Cut in the context menu.

2 Then right-click a category and choose Paste or Paste as Sibling in the context menu. Paste adds the
copied categories as sub-categories of the right-clicked category. Paste as Sibling adds the copied
categories at the same level as the right-clicked category, just beneath it.
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Moving Categories

This function moves a category up, down, left or right.

1 Select categories in Category Structure which you want to move.

2 To move categories up or down: Click Up or Down.

To move categories left or right: Click Unindent or Indent.

To move multiple categories at the same time, you must choose categories that are consecutive.

Advanced Properties Tab

This tab enables you to set properties used with UDDI. It is divided into the following sections:

• Compatibility

• Categorization

• Validation

• Reference to

• Value type

Compatibility

Compatibility indicates that this taxonomy can be used only within the UDDI structures of your choice.
Select one or more of the main UDDI structure types (businessEntity, businessService, bindingTemplate
and tModel) in the section labeled Compatibility. All structure types are chosen by default.

Categorization

Categorization refers to the taxonomy type. Select from the following types:
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categorization

(Default) Categorizations can be used in all four main UDDI structures. They are used to tag them
with additional information, such as identity, location, and what the taxonomy describes.

categorizationGroup

New in UDDI version 3, a categorizationGroup groups several categorizations into one logical cat-
egory. For example, a categorizationGroup could be a geographical location comprised of two cat-
egorizations: longitude and latitude. The categorizationGroup option is disabled if the taxonomy
has any categories.

Identifiers

Used in businessEntities and tModels, Identifiers reference published information.

Relationships

Used only in Publisher Assertions, Relationships define the relation between two businessEntities.

Validation

Validation sets whether the values in keyedReferences within the taxonomy will be checked or not. The
validation service may check the expected syntax of values, such as the format of a credit card or ISBN
number. Taxonomies like the ISO 3166 Geographic taxonomy, which permits only existing countries,
checks the existence of the value against a list. A validation service may even permit or deny values depending
on the context in which they are used.

Validation can be against Taxonomy Editor's internal validation service or against an external service. If
you select an external validation service, type in the endpoint URL. You can also select to leave
keyedReferences unvalidated.

Reference

You can add a reference to a key type.

Value Type

Select a Value type for keyValues. You can select from three existing comparators in the system compar-
ator drop-down field or add the endpoint of a custom comparator. The existing comparators are:

systinet-com.comparator.string

keyValues are treated as string values. If keyValues type is unknown then keyValues are treated
as strings. The maximum length is 255 characters.
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systinet-com.comparator.numeric

keyValues are treated as decimal numbers. The value can have a maximum of 19 digits before the
decimal point and a maximum of 6 digits after the decimal point.

systinet-com.comparator.date

keyValues are treated as dates.

Source

This tab enables you to view and directly edit the XML representation of the taxonomy.

Comparing Taxonomies

Taxonomy Editor lets you compare two taxonomies, a local taxonomy against its version on a server, or a
taxonomy against its local history.

To compare two taxonomies:

1 Select the two taxonomies.

2 Right-click. A context menu opens.

3 Select Compare with->Each Other from the context menu.

4 Taxonomy Editor now displays the Comparison view (Figure 4)

To compare a local taxonomy against the version on a server:

1 Right-click a taxonomy in Project Explorer. Its context menu opens.

2 Select HP SOA Systinet->Compare with the latest on server. If the local version and the latest
version on the server are identical, you get a message telling you so. If there are any differences, the
Comparison view opens (Figure 4).

To compare a taxonomy against its local history:

1 Right-click a taxonomy in Project Explorer. Its context menu opens.

2 Select Compare With->Local History. If there is a local history, the Comparison view opens (Fig-
ure 4).
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Figure 4. Comparison View

The Comparison view lists the differences between 2 taxonomies in categories and properties. Click a listed
difference and the details appear in the Taxonomy Compare Results section. Figure 4 displays the differ-
ences in the values for Architect between the two taxonomies. Every difference is prefixed by an icon as
follows:

• : The categories exist in the first taxonomy but not in the second one. Either remove the categories
from the first taxonomy or copy them to the second one. To remove the categories, right-click them and
select Remove... from the context menu. To copy the categories, right-click them and select Copy...
from the context menu.

• : The properties in the two taxonomies or categories are different. You must copy one entity, over-
writing the other. Right-click the entity to copy and select Copy....

• : The categories exist in the second taxonomy but not in the first one. Either remove the categories
from the second taxonomy or copy them to the first one. To remove the categories, right-click them and
select Remove... from the context menu. To copy the categories, right-click them and select Copy...
from the context menu.
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Refreshing Taxonomies to Reflect External Changes

If you have changed a taxonomy outside of Taxonomy Editor and want the Editor to reflect these changes,
refresh the taxonomy. Follow these steps:

1 In the Project Explorer, select an entity or entities corresponding to the taxonomies you wish to refresh.
You may:

• Refresh all taxonomies in a project by selecting that project.

• Refresh individual taxonomies by selecting one or more. (They do not have to be in the same pro-
ject.) In Figure 5 two taxonomies have been chosen.

2 Right-click to open the context menu.

3 Click Refresh, shown in Figure 5.
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Figure 5. Refreshing Taxonomies

Publishing Changes

Publishing is the process of storing changes on a SOA Systinet server including additions, deletions and
modifications. You can publish taxonomies by selecting HP SOA Systinet->Publish Taxonomy from the
context menu of a taxonomy or the selected taxonomies in Project Explorer.

If a publication attempt is not completely successful, this is reported to the user. For a new or modified
taxonomy, success or failure is indicated by its status. Figure 2 shows how to recognize the status of a tax-
onomy and Table 1 on page 41 explains how to interpret it.
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Table 1. Taxonomy Status After Publication

Implication after publicationDescriptionStatus

Publication was successful, including
any modifications.

Local and server versions are
identical.

UP-TO-DATE

Publication was unsuccessful and the
status is unchanged. Either:

This local taxonomy has not been
published to the server.

NEW ?

Taxonomy has been published, but
changes have been made locally since
the last time it was updated.

MODIFIED > • There was an exceptional error
such as a network error.

• Publication was prevented by the
impact the change would have on
server data integrity.

Changes to these taxonomies cannot
be published.

These taxonomies are generated
automatically upon starting SOA
Systinet Platform and are not meant
to be changed by the user.

SYSTEM 

It may not be possible to publish a taxonomy for two reasons:

• A conflicting change on the server

• The validation results that the change would have on server data integrity

In either case additional information is provided in the Validation Results.

Validation Results are divided into 2 parts:

• Local Problems: All problems in the local repository

• Remote Problems: All problems which could occur if the taxonomy were published.
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Figure 6.  Validation Results

You cannot publish a System taxonomy to a remote repository.

Example: Creating and Publishing a Department Taxonomy

In this example, you create and deploy a new taxonomy containing the identities of departments in your
organization.

To follow this example requires the following prerequisites:

• Define your SOA Systinet server, as described in Adding a SOA Systinet Server on page 25.

• Update the local taxonomies, as described in Updating Taxonomies From the Server on page 27.

To create a department taxonomy:

1 Follow the Creating a New Taxonomy on page 23 procedure. Input Departments for the Taxonomy
Name, and then click Finish.
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2 In the Project Explorer, double-click Departments to open the editor and switch to the Categories
tab.

3 Add categories as described in Adding a New Category on page 33. Use the following inputs for the
Name:

• HR

• IT

• Payroll

• Finance

• Sales

• Development

• QA

4 Press Ctrl-S to save your taxonomy.

5 In the Project Explorer, right-click Departments and select Publish.

After publication, the new department taxonomy artifact is visible in the SOA Systinet UI.

• In the Tools tab Catalog Browser, expand Categories and click Taxonomies to view the taxonomies
in the repository.
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4 Resolving Conflicts and Validation Is-
sues

Editing taxonomies can result in two types of issues:

• Local data inconsistency or validity issues taxonomy ID and category value duplication, taxonomy ID
in wrong format, etc).

• A conflict with the server, due to either the version on the server having been altered or changes to the
local taxonomy that would impact server data integrity.

These issues and their resolution are described in the following sections:

• Local Validity on page 45

• Conflict With Server on page 46

Local Validity

By default, the validities of local taxonomies are constantly checked while you work on them. Invalid tax-
onomies are marked in the Project Explorer and their errors are listed in the Problems view. Figure 7
shows the errors for two taxonomies with the same ID.

Figure 7. Invalid Local Taxonomies

To disable validation, unselect Project->Build automatically in the main menu bar.
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Conflict With Server

A local taxonomy and the version on a server can come into conflict either when the version on the server
is changed or when changes to the local version affect artifacts on the server. To show all artifacts categorized
by a taxonomy, run HP SOA Systinet->Show Artifacts Using Taxonomy in the taxonomy's context menu.
This action shows all artifacts that could be affected if the selected taxonomy is changed.

Conflicts between a local taxonomy and a version on the server are revealed when you try to publish the
taxonomy (see Publishing Changes on page 40). In case of conflicts, you receive an error message that the
taxonomy could not be published. You can also check for conflicts without trying to publish, by opening
the taxonomy's context menu and selecting HP SOA Systinet->Validate Data Consistency. The server
must be running for you to check for conflicts.

By default, the Validation Results view shows all points of conflict (see Figure 8). To disable this display,
unselect Validate before publishing taxonomies in Preferences. Conflicts are still detected even with
validation disabled.

Figure 8. Validation Results

Table 2 on page 47 lists possible reasons why a publication attempt is not completely successful and explains
what you can do. The solution is often to update taxonomies, replacing local content with the server content
as described in Updating Taxonomies From the Server on page 27. You may want to make a second copy
of the local taxonomy before updating it. Otherwise you lose all changes you made.

One way to view conflicting changes on a server is to add the same server under a different name.
You can then use HP SOA Systinet Workbench's copy and paste features.
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Table 2. Issues and Resolution

SeverityTypeResolutionIndicationsCase

ErrorConflictTo replace the local tax-
onomy with the server

Your local taxonomy is
CONFLICTING. The
local version cannot be

A taxonomy was changed
on the remote server
while you were modifying
your local version.

version, use the taxonomy
context action HP SOA
Systinet->Update Tax-

published and its modific-
ations are kept.

onomy. You may first
want to copy your local
version to a temporary
location.

ErrorConflictTo replace the local tax-
onomy with the remote

Taxonomy is CONFLICT-
ING. The local version
cannot be published.

A taxonomy was pub-
lished that has the same
filename as a new tax-
onomy you are trying to

server version, use the
taxonomy context action
HP SOA Systinet->Up-

Changes to the local tax-
onomy and server remain
in Project Explorer.

publish to the remote
server. date Taxonomy. You

may first want to copy
your local version to a
temporary location.

ErrorValidation
Results

Change the ID of the new
taxonomy.

The local taxonomy can-
not be published. Changes
to the local taxonomy and

The ID of a taxonomy you
have created is the same
as the ID of an existing
taxonomy on the remote
server

server remain in Project
Explorer. The Validation
Results include a node
giving the taxonomy ID.

ErrorValidation
Results

To restore the original
taxonomy, use the tax-
onomy context action HP

The local taxonomy can-
not be published and re-
mains MODIFIED. The
Validation Results list

You have changed the ID
of a taxonomy used by ar-
tifacts.

SOA Systinet->Update
Taxonomy.artifacts that use the tax-

onomy.
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SeverityTypeResolutionIndicationsCase

ErrorValidation
Results

To restore the original
taxonomy, use the tax-
onomy context action HP
SOA Systinet->Update
Taxonomy.

The local taxonomy can-
not be published and re-
mains MODIFIED. Valid-
ation Results lists arti-
facts that use the category.

A category that you modi-
fied is used by other arti-
facts.

ErrorLocal incon-
sistency

Change taxonomy ID to
another value so that there
aren't 2 taxonomies whose
IDs are the same.

An error message for this
taxonomy is shown.

A new taxonomy's ID is
the same as another local
taxonomy's.

WarningLocal incon-
sistency

Change taxonomy ID to
valid format.

A warning message for
this taxonomy is shown.

Taxonomy ID format is
invalid.

ErrorLocal incon-
sistency

Change a category value
so that there aren't 2 cat-
egories whose value are
the same in one tax-
onomy.

An error message for this
taxonomy is shown.

Category value is duplic-
ated by another category
in the same taxonomy.

ErrorLocal incon-
sistency

Change filename so that
it doesn't contain invalid
character.

An error message for this
taxonomy is shown.

Taxonomy filename con-
tains invalid character for
rest url.

Replacing taxonomies with server content is described in Downloading, Updating and Importing Taxonomies
on page 25

To produce conflicts experimentally you can define two Taxonomy Projects for the same SOA
Systinet server. Modify a taxonomy in one project, save it and publish it to the server. Then
modify it in a different way in the second project. You will get a conflict if you try to publish it.
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5 Customization

This chapter describes settings you can customize in Workbench for Taxonomy Editor. All customization
starts at the Preferences dialog box, shown in Figure 9.

Figure 9. Preferences Dialog Box

To open the Preferences dialog for Taxonomy Editor:
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1 In the menu bar, select Window->Preferences. the Preferences dialog opens, with a tree menu in
the left pane.

2 In the tree menu, go to HP SOA Systinet->Taxonomy Editor.

Customizable settings are described in the following sections:

• Taxonomy Namespace Setting on page 50

• Data Consistency Setting on page 50

Taxonomy Namespace Setting

Your choice of namespace (5.0 or 5.5) that will be used when creating a new taxonomy (Please see Creating
a New Taxonomy on page 23). By default, the namespace 5.5 is selected since this is the newest taxonomy
format used in HP SOA Systinet Registry 5.5, 6.0 and 6.5. However, version 5.5 taxonomies cannot be used
in HP SOA Systinet Registry 5.0. When creating taxonomies that you want to export to HP SOA Systinet
Registry 5.0, please change this setting accordingly. This will affect newly created taxonomies only.

Data Consistency Setting

Validate before publishing taxonomies can be selected or deselected, depending on whether or not you
wish to validate your changes before publishing them to the server. (See Resolving Conflicts and Validation
Issues on page 45.)
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Appendix A. Keyboard Shortcuts
ContextActionShortcut

GlobalAdd SOA Systinet ServerCtrl-Alt-S

GlobalNew taxonomyCtrl-N

 

Categories tabAdd next categoryAlt-A, Insert

Categories tabAdd child categoryAlt-C

Categories tabMove category upAlt-U, Ctrl-ArrowUp

Categories tabMove category downAlt-D, Ctrl-ArrowDown

Categories tabMove category left (unindent)Alt-E, Ctrl-ArrowLeft

Categories tabMove category right (indent)Alt-I, Ctrl-ArrowRight

Categories tabNavigate to category name fieldF2

Categories tabForget changes in current text field and nav-
igate to Category Structure

Esc

Taxonomies editorSwitch to next editor tabCtrl-PageDn

Taxonomies editorSwitch to previous editor tabCtrl-PageUp

 

GlobalActivate editorF12

GlobalClose current editorCtrl-W, Ctrl-F4

GlobalClose all editorsCtrl-Shift-W, Ctrl-Shift-F4

GlobalGo to next editorCtrl-F6

GlobalGo to previous editorCtrl-Shift-F6

GlobalSwitch to editorCtrl-Shift-E

 

GlobalQuick find taxonomyCtrl-J

GlobalSearch taxonomy or categoryCtrl-H
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ContextActionShortcut

 

GlobalShow editing resource in taxonomy explorerAlt-Shift-W

GlobalRefresh itemsF5

 

GlobalSave changes for active editorCtrl-S

GlobalSave changes for all editorsCtrl-Shift-S

 

GlobalCopyCtrl-C, Ctrl-Insert

GlobalCutCtrl-X, Shift-Delete

GlobalDeleteDelete

GlobalPasteCtrl-V, Shift-Insert

 

GlobalShow key assistCtrl-Shift-L
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Glossary
artifact A resource represented by a repository document. Artifacts may be

categorized using taxonomies. This may be achieved by defining artifact
property types in terms of taxonomies.

category A division or classification in a taxonomy.

client An application (or computer system) that enables use of server(s).
See also server.

conflict A simultaneous change to the same data that cannot be resolved. For
example, automatic import or update of data from a SOA Systinet
server may result in conflicts.

context action An action performed using an item on a context menu.
See also context menu.

context menu A menu that pops-up when you right-click an item or selected items to
perform actions possible on them.

credentials Username and password for logging into a system such as a SOA Sys-
tinet server.

data integrity The conformance of data to a format or structure and sometimes also
the accuracy of the data. In particular, data items may refer to each
other by means of identifiers or keys (such as taxonomy IDs or category
names) and a referenced data item must then exist. Also, the meaning
of data may assume constraints such as a fixed set of categories in a
taxonomy. Such assumptions may be informal or hidden, so breaking
the constraints may result in inaccurate data, regardless of its conform-
ance to a particular format.

download Retrieve copies of data from a SOA Systinet server, including initial
copies or updates. Conflicts may prevent updates being applied if
changes have also been made to local copies of data.
See also import, update, Taxonomy XML file, conflict.
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folder A container for documents or files, such as a file system directory or
an Eclipse folder. An Eclipse folder is a file system directory.

IDE Integrated Development Environment

validation The effect of change on data integrity in a SOA Systinet repository.

import Retrieve copies of data from a file. If a local copy with the same name
already exists, you will be asked if you want to overwrite it.
See also download, Taxonomy XML file.

JAR File A file compressed using the Java Archive (JAR) file format.

perspective An Eclipse perspective. This is a view that presents certain features to
the user.

project An Eclipse project containing a hierarchy of folders. Organization by
projects and folders is reflected on your file system where taxonomies
are stored as XML files. Taxonomy explorer displays SOA Systinet
servers in a single hierarchy, so for most users a single project is suffi-
cient for the folders of each SOA Systinet server. Projects are mainly
of interest to users familiar with the Eclipse IDE.

property An attribute or characteristic of an object, entity or artifact etc. that is
represented by a value.

publish Save changes made to copies of data to a repository in which it is stored.

registry A type of repository in which taxonomies may be stored. A registry is
a central listing of the available services and resources in SOA.
See also repository.

repository A repository is used to store resources such as SOA artifacts, including
taxonomies. Taxonomies may be also serve to define the repository
data structure.
See also server.

REST REpresentational State Transfer is an architectural module used to im-
plement networked IT systems. The modeling of communication
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between components is similar to that used by HTTP. The main distin-
guishing features of this model relate to resources.

restore Restore a deleted taxonomy using a copy on hard disk. Taxonomies
can only be restored if they were previously published to a server or
downloaded from the server. Once a deletion has been published to the
server, the deleted taxonomy can no longer be restored.

RCP A Rich Client Platform such as provided by Eclipse. RCPs are used to
produce rich client applications with all the benefits of re-use.
See also rich client.

rich client A client application that enables use of server(s) and the functionality
they provide and provides additional features through client-side pro-
cessing.
See also client.

server A computer that provides a service, such as access to a repository
through a particular port. To access the service requires knowledge of
the computer name (its hostname), the port number and the protocol
used for communication.
See also repository, client.

Service Oriented Architecture Service Oriented Architecture is a simple software design approach in
which all functions are modeled as services and are built to be consumed
over a network using standards-based interoperability and policies.

SOA See Service Oriented Architecture.

SOA Systinet server A server running SOA Systinet. SOA Systinet servers have taxonomies
stored in a repository.
See also server, SOA Systinet.

system taxonomy These taxonomies are generated automatically upon starting the SOA
Systinet platform and are not meant to be changed by the user.
See also SOA Systinet server, taxonomy.

SOA Systinet HP's latest suite of products for SOA Governance and Lifecycle Man-
agement. It consists of a platform and a number of applications. The
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platform provides repository storage and a data model in which tax-
onomies play an important part.

taxonomy A taxonomy defines a set of values that can be used for the classification
of artifacts.

Taxonomy XML file An XML file holding the taxonomy entity from a registry. The root
element of this file is <taxonomy>.
See also import.

tModel A structure that takes the form of keyed metadata (data about data). In
a general sense, the purpose of a tModel within the UDDI specification
is to provide a reference system based on abstraction. Among the roles
that a tModel plays in UDDI is the ability to provide and to describe
compliance with a specification or concept to a taxonomy, for example.

UDDI See Universal Description, Discovery and Integration.

UDDI Registry A UDDI Registry is an implementation of the UDDI specification that
allows web service vendors to register information about the web ser-
vices they offer so that others can find them.
See also registry.

Universal Description, Discov-
ery and Integration

UDDI is a specification for distributed Web-based information registries
of Web services.

URI Uniform Resource Identifier – the generic term for all types of names
and addresses that refer to objects on the World Wide Web. A URL is
one kind of URI.

URL Uniform Resource Locator – the global address of documents and other
resources on the World Wide Web. The first part of the address indicates
what protocol to use and the second part specifies the IP address or the
domain name where the resource is located.
See also URI.

update Updating local copies of data on a SOA Systinet server with respect to
any changes made in the repository. Also obtaining local copies where
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there are none, but the term download more accurately describes both
these cases.
See also download.
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