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Welcome to HP SOA Systinet Workbench
HP SOA Systinet Workbench is a suite of editor tools enabling you to customize your deployment of SOA
Systinet.

Workbench consists of the following editor tools distributed as a single Eclipse development platform:

• HP SOA Systinet Customization Editor enables you to customize the underlying SDM model and the
appearance of these artifacts within SOA Systinet.

• HP SOA Systinet Taxonomy Editor enables you to customize the taxonomies which categorize the arti-
facts in SOA Systinet.

• HP SOA Systinet Assertion Editor enables you to customize the conditions applied by your business
policies within SOA Systinet.

• HP SOA Systinet Report Editor enables you to customize and create report definitions for use with SOA
Systinet.

The first time you start Workbench the welcome screen is displayed:
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Figure 1. Workbench Welcome Screen

Select one of the options to open one of the editor tools, start a new editing project, or view the document-
ation set.

You can return to the welcome screen from any of the editor tools by selecting Help->Welcome from the
menu options.

Welcome to the Report Editor Guide

The Reporting Service provides a solution for report delivery and enables the simple creation and deployment
of new reports. HP SOA Systinet Workbench includes a Report Editor for your use in customizing reports.
The relationship between Reporting and Report Editor is shown in Figure 2.

HP SOA Systinet Report Editor is an implementation of BIRT (Built-In Reporting Tool), an open
source Eclipse-based reporting system. Included in the Help menu is the BIRT documentation.
The BIRT Report Developer Guide describes the general use of BIRT to create reports. The Report
Editor Guide adds to this by explaining how to use this functionality in conjunction with Systinet
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Figure 2. SOA Systinet Reporting Framework

This guide contains the following chapters:

• Getting Started on page 13 introduces the concepts and the user interface used in HP SOA Systinet
Report Editor.

• Using the Report Editor on page 27 describes how to use HP SOA Systinet Report Editor to create and
modify report definitions for use with SOA Systinet..

• Deploying Reports to SOA Systinet on page 47 describes how to deploy your report definitions to SOA
Systinet.

Document Conventions

The typographic conventions used in this document are:

Script name or other executable command plus mandatory arguments.run.bat make
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A command-line option.[--help]

A choice of arguments.either | or

A command-line argument that should be replaced with an actual value.replace_value

A choice between two command-line arguments where one or the other is
mandatory.

{arg1 | arg2}

Operating system commands and other user input that you can type on the
command line and press Enter to invoke. Items in italics should be replaced
by actual values.

rmdir /S /Q System32

Filenames, directory names, paths and package names.C:\System.ini

Program source code.a.append(b);

An inline Java or C++ class name.server.Version

An inline Java method name.getVersion()

A combination of keystrokes.Shift-N

A label, word or phrase in a GUI window, often clickable.Service View

A button in a GUI window.OK

Menu choice.New->Service
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Documentation Updates

This manual's title page contains the following identifying information:

• Software version number

• Document release date, which changes each time the document is updated

• Software release date, which indicates the release date of this version of the software

To check for recent updates, or to verify that you are using the most recent edition of a document, go to:

http://ovweb.external.hp.com/lpe/doc_serv/
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Support

Mercury Product Support

You can obtain support information for products formerly produced by Mercury as follows:

• If you work with an HP Software Services Integrator (SVI) partner (http://h20230.www2.hp.-
com/svi_partner_list.jsp), contact your SVI agent.

• If you have an active HP Software support contract, visit the HP Software Support Web site and use
the Self-Solve Knowledge Search to find answers to technical questions.

• For the latest information about support processes and tools available for products formerly produced
by Mercury, we encourage you to visit the Mercury Customer Support Web site at: http://hp.-
com/go/hpsoftwaresupport.

• For the latest information about support processes and tools available for products formerly produced
by Systinet, we encourage you to visit the Systinet Online Support Web site at: http://www.systinet.-
com/support/index.

• If you have additional questions, contact your HP Sales Representative.

HP Software Support

You can visit the HP Software Support Web site at:

http://www.hp.com/go/hpsoftwaresupport

HP Software online support provides an efficient way to access interactive technical support tools. As a
valued support customer, you can benefit by using the support site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts
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• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a
support contract. To find more information about access levels, go to: http://h20230.www2.hp.com/new_ac-
cess_levels.jsp

To register for an HP Passport ID, go to: http://h20229.www2.hp.com/passport-registration.html
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1 Getting Started

SOA Systinet is distributed with a set of predefined reports and various ways to access them.

HP SOA Systinet Report Editor provides a mechanism to customize both these existing reports, but also
enables you to create new report definitions from scratch or by using templates imported from the SOA
Systinet reporting server.

The Report Editor is used to create and modify report definitions for SOA Systinet.

This chapter introduces Report Editor in the following sections:

• Configuring the Report Editor on page 13 describes how to setup the Report Editor..

• Introduction to the User Interface on page 16 explains the main features of the Report Editor user inter-
face.

• Report Editor Menu Options on page 21 describes the Report Editor options in the Eclipse drop-down
menus.

• Searching the Extension on page 22 explains how to use the search function to find elements in the ex-
tensions.

Configuring the Report Editor

You must make a number of configuration changes to effectively access the resources available in SOA
Systinet:

• Increase the memory allocated to the editor, as described in Increasing the Memory Allocation to the
Report Editor on page 14.

• Create a reporting project, as described in Creating a Reporting Project on page 14.
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• Add the SOA Systinet report library to the editor, as described in Importing SOA Systinet Report
Definitions on page 16.

Increasing the Memory Allocation to the Report Editor

The Report Editor is memory intensive. If you experience performance issues, HP Systinet recommends
increasing the memory allocation.

To increase the memory allocation to the report editor:

1 Open REPEDIT_HOME/start.ini for editing.

2 Set these new values:

• -Xms128m

• -Xmx1024m

3 Save your changes.

4 Restart the editor.

Creating a Reporting Project

The Report Editor organizes your work into project folders in your workspace.

To create a reporting project:

1 Open the New Report Project in one of these ways:

• In the Workbench Welcome page, select Create Report Project.

• Select File > New > Report Project from the menu.

• Alternatively, press Alt-Shift-N and then press R. Expand HP SOA Systinet, select Report Project,
and then click Next.

The New HP SOA Systinet Reporting Project Wizard appears.
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2 Input a name for your project and, if required, change the workspace location, and then click Next.

3 Do one of the following:

• If a reporting server is already setup then, select a server from the list, and then click Finish, or
select Create a new server, and then click Next.

• If a reporting server is not setup, or you selected Create a new server, add a reporting server with
the following parameters

DefinitionParameter

The name of the server to display in the report editorName

The location of the reporting serverURL

Credentials for access to the reporting serverUsername and
Password

Select to preserve the input credentialsSave credentials

Select to validate the server connection

The reporting server must be running to validate.

Validate login at
finish

4 Do one of the following:

• To create a generalized reporting project, click Finish and continue to Importing SOA Systinet
Report Definitions on page 16.

• To create a project associated with a specific report category, click Next and continue this procedure.

5 Select a report category for your reporting project, and then click Next.

6 Select report definitions from the selected category to download to the Report Editor, and then click
Finish.
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Importing SOA Systinet Report Definitions

The SOA Systinet report library contains all the report definitions for SOA Systinet. To modify existing
reports you must import their definitions from the reporting server. To associate new report definitions with
SOA Systinet you must import at least one report to obtain the SOA Systinet report library file.

To import SOA Systinet report definitions:

1 Ensure that the referenced reporting server is running.

2 In the Project Explorer right-click the project and select HP SOA Systinet->Download Report.

3 Select the report category, and then click Next.

4 Select the report definitions you require, and then click Finish.

Introduction to the User Interface

The default Report perspective is split into a number of panes with menu options across the top. On the
left and at the bottom are a number of views enabling you to navigate different aspects of your report project
and the particular report you are working with. The main section contains the details of the report definition
you are working with. Multiple editors can be open in this main section and the functionality of this view
is fully described in the BIRT Report Developer documentation available in the Help menu.
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Figure 3. Report Editor UI

The main navigation views are described in the following sections:

• Project Explorer on page 18

• Data Explorer on page 19

• Server Explorer on page 20
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Project Explorer

The Project Explorer contains a view of the projects in your workspace and the report definitions they
contain. This view is the interaction point with SOA Systinet.

Figure 4. Project Explorer View

Each project contains a set of report definitions and the SOA Systinet library.

Each report definition contains the following sections:

• General – double-click to open a properties editor view enabling you to change the name and description
and to categorize the report definition.

• Report Design – double-click to open a layout editor view enabling you to change the appearance and
content of the report definition.
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The Project Explorer contains additional context menu options enabling you to interact with a running
SOA Systinet Reporting Server. Right-click the project name or a particular report definition, and select
HP SOA Systinet to view the following options:

Table 1. Project Context Menu Options

FunctionOption

Import report definitions from SOA Systinet as described in Importing SOA
Systinet Report Definitions on page 16

Download Report

Create a reporting extension for SOA Systinet containing all the reports in your
project, as described in Deploying a Set of Reports to SOA Systinet on page
47

Build Extension

Table 2. Report Definition Context Menu Options

FunctionOption

Export the report definition to the default reporting server, as described in De-
ploying a Report to SOA Systinet on page 47

Publish Report

Remove the report definition from the default reporting server with an option
to delete it from the report project as well.

Delete Report

Export the report definition to a specified reporting server, as described in De-
ploying a Report to SOA Systinet on page 47

Publish to Other Server

Create a reporting extension for SOA Systinet containing the report, as described
in Deploying a Set of Reports to SOA Systinet on page 47.

Build Extension

Data Explorer

The Data Explorer displays the sources and sets of data used by the particular report you are working with.
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Figure 5. Data Explorer View

Server Explorer

The Server Explorer is a displays the SOA Systinet servers that the Workbench is connected to. The
functionality is shared by all the Workbench editors.
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Figure 6. Server Explorer View

Right-click a server in the Server Explorer to open a context menu with the following options:

Table 3. Server Explorer Context Menu Options

FunctionOption

Add a server for downloading reports (for Report Editor)New Reporting Server

Add a server for downloading assertions and taxonomies (for Assertion Editor,
Taxonomy Editor and Customization Editor)

New Platform Server

Delete server from Server ExplorerRemove Server

Download reports (for Report Editor, reporting server only)Download Report

Download taxonomy (for Taxonomy Editor and Customization Editor, platform
server only)

Download Taxonomy

Download assertions (for Assertion Editor, platform server only)Download Assertion

View and edit server name, URL, username and passwordProperties

Report Editor Menu Options

Rewrite for RE
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The menus in Customization Editor are the normal Eclipse menus with the addition of specific functionality
for the Customization Editor.

The extra menu options in the Customization Editor include:

• TODO

Searching the Extension

Rewrite if function exists in RE

The Customization Editor contains a customized search function that enables you to find entities in the ex-
tension project.

To search your extension project:

1 In the Search menu select Search to open the Search dialog:

2 Complete the SDM search dialog containing parameters:
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DefinitionParameter

The parameter to search the extension forContaining text

Check the box to make the search case sensitiveCase sensitive

Allows more sophisticated search parameters. For example, to find
everything with more than one word. This is an advanced topic beyond the
scope of this guide.

Regular expression

Select the SDM entities to searchSearch For

Select the entity attributes to searchSearch In

Select the extension to searchScope

3 Click Search to execute the search and view the results in the Search view.

Report Editor Use Cases

Each use case describes the high level steps required to implement them. The examples provided at the end
of sections in Creating a Report Definition on page 28 can be used as a reference.

The main use cases are as follows:

• Creating a Report Definition for the SOA Systinet Reporting Tool on page 23 describes how to create
a new report for use with the reporting tool in SOA Systinet.

• Creating a Report for the SOA Systinet Dashboard on page 25 describes how to create a new dashboard
report using an existing template.

• Modifying an Existing Policy Report as a New SOA Systinet View on page 26 describes how to modify
an existing policy manager report and make it available as an alternative view in SOA Systinet.

Creating a Report Definition for the SOA Systinet Reporting Tool

TODO

To enable SOA Systinet to execute the new report, it must be associated with a reporting tool in SOA Sys-
tinet
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1 Follow the procedure described in the Creating a Reporting Tool section of the HP SOA Systinet User
Guide.

2 Input the following parameters in the Publish Reporting Tool page:

DefinitionParameter

Failure Impact ToolName

Overview of the Failure Impact Status of Business ServicesDescription

Select Failure Impact from the drop-down listReport Definition

After creating the reporting tool, execute in the following way:

To execute the failure impact report:

1 In the Tools tab, Report Launcher, click Generate under the Failure Impact heading to immediately
execute the report.

2 Click Failure Impact Tool to view the html version of the report or one of the other format links to
view the report in that format.
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You can also create a scheduled task to use the new reporting tool as described in the Creating a Task section
of the HP SOA Systinet User Guide.

To access the last execution of the report:

• In the Tools tab, Report Launcher, click Failure Impact Tool.

Creating a Report for the SOA Systinet Dashboard

TODO
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Modifying an Existing Policy Report as a New SOA Systinet View

TODO
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2 Using the Report Editor

TODO - rewrite

HP SOA Systinet Workbench includes a Report Editor for SOA Systinet. The report editor is a HP Systinet
implementation of BIRT (Business Intelligence and Reporting Tools), an open source Eclipse-based reporting
system. The implementation includes plug-ins to integrate BIRT with the SOA Systinet reporting service.

The Report Editor includes a guide to using the product. Access this guide from the Help menu after installing
Workbench.

Important: The Report Editor requires JDK 1.5.0 or later and the JAVA_HOME environment
variable must include the path to this version of the JDK.

If you are running Report Editor on Red Hat Linux, install Mozilla GTK 2 and set the MOZ-
ILLA_FIVE_HOME environment variable to point to your Mozilla installation. Otherwise you cannot
run BIRT reports. For example, set export MOZILLA_FIVE_HOME=/opt/mozilla

This chapter includes the following sections::

• Create the report, as described in Creating a Report Definition on page 28.

• Add a data source to the report, as described in Adding a Data Source to the Report on page 28

• Create a dataset, as described in Creating a Data Set on page 29.

• Bind the data to the report, as described in Binding the Data to the Report on page 42.

• Categorize the report to associate it with a particular function in SOA Systinet, as described in Categor-
izing Reports on page 43.
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Creating a Report Definition

The first step in defining a report to create the report definition.

To create a report definition:

1 Select File->New->Report from the menu.

2 Input a name and description for the report, and then click Next.

3 Select the project folder, and then click Finish to create the report definition.

4 In the Library Explorer right-click s2_default.rptlibrary and select Use Library to associate the
report with the library. This step sets default values in the report definition enabling the reporting
server to use it.

5 Press Ctrl+S to save the report definition.

Example 1: Creating a Failure Impact Report Definition

To create the failure impact report definition:

• Follow the procedure described in Creating a Report Definition on page 28 with the following inputs:

DefinitionParameter

Failure ImpactName

Summary of Business Service Failure Impact StatusDescription

Adding a Data Source to the Report

Your report must access the database.

To add a data source to a report:

1 Open the report definition view.
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2 In the Library Explorer expand s2_library.rptlibrary->Data Source.

3 Drag and drop the default database from the Library Explorer to Data Explorer->Data Sources.

4 In the Data Explorer, right-click database to edit the database connection parameters.

5 Click Manage Drivers to open the Manage JDBC Drivers dialog

6 Click Add to browse your filesystem for a driver.

Tip: HP Systinet recommend using the same JDBC driver used during SOA Systinet install-
ation.

7 Select the driver, and then click Open to add it to the list of drivers in the Manage JDBC Drivers
dialog.

8 Select the driver from the list, and then click Ok to return to the Edit Data Source dialog.

9 Input the following parameters:

DefinitionParameter

Select the driver class from the drop-down listDriver Class

Input the location of the database as a JDBC connection stringDatabase URL

Input a user name and password to access the databaseUser Name and
Password

The JNDI name of the data sourceJNDI URL

10 Click Ok.

11 Press Ctrl+S to save your changes.

Creating a Data Set

Each report is associated with a query that returns a data set.
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To create a data set:

1 Open the report definition view.

2 In the Data Explorer, right-click Data Sets and select New Data Set to open the New Data Set dialog.

3 Input the following parameters:

DefinitionParameter

Input a name for the data setData Set Name

Select the data source from the drop-down listData Source

Choose one of the options from the drop-down list:

• SQL Select Query

• SQL Stored Procedure Query

Data Set Type

4 Click Next to open the Query dialog:
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5 Use Schema, Filter, and Type, and then click Apply Filter to focus on the data you require in
Available Items.

Tip: By default, the editor limits the amount of data collected to 20 schemas and 100 tables.

To change the data collection settings:

1 Select Windows->Preferences from the drop-down menu.

2 Expand Report Design->Data Set Editor, and then select JDBC Data Set.
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3 Change the number of schemas and tables as required, and then click Ok.

6 Use Available Items to find the items you require. Drag and drop items from Available Items to the
query editor and construct your query.

Tip: For portability to different SOA Systinet installations using different schemas, remove
the schema name from the variables in your query.

7 Click Finish to add the data set to the report definition.

8 Press Ctrl+S to save your changes.
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Example 2: Creating a Failure Impact Data Set

After configuring the data source, create the data set.

To create the failure impact data set:

1 Follow the procedure described in Creating a Data Set on page 29 with the following inputs:

2 In the New Data Set dialog, input the following parameters:

DefinitionParameter

Failure ImpactData Set Name

databaseData Source

SQL Select QueryData Set Type

3 Use the filter to only display the schema that contains the data that you want to use.

Tip: All standard tables in SOA Systinet begin with RYGA.

4 Use Available Items to explore the data and identify the tables and columns you need for your query.
For this report all the information required is in table RYGA_BSNSERVICE.
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5 Construct your query by typing in the query input area and dragging and dropping items from Available
Items. For this report the query is:

select RYGA_BSNSERVICE.CRITICALITY_NAME as "Failure Impact Status",
            count(RYGA_BSNSERVICE.CRITICALITY_NAME) as "No of Services"
 from RYGA_BSNSERVICE
 group by RYGA_BSNSERVICE.CRITICALITY_NAME
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6 Click Finish to complete your query and view the Output Columns for the data set.

7 Click Preview Results to view the actual data in your database.

8 Click OK and press Ctrl+S to save the data set as part of the report.

Designing a Report

The BIRT Report Developer Guide contains all the information required in order to design the layout and
content of your reports. Select Help->Help Contents to view the guides included with HP SOA Systinet
Workbench.
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Example 3: Designing the Layout of the Failure impact Report

This report is a simple listing of the number of services at each failure impact status with a chart displaying
the data graphically.

To create the failure impact report layout:

1 In the failure_impact.rptdesign view, right-click and select Insert->Label.

2 Type the report heading, Business Service Failure Impact Status.

3 Use the Property Editor view to change the format of the heading.

4 In a blank area of the failure_impact.rptdesign view, right-click and select Insert->Table.

5 Input the table parameters and select the data set. In this case, 2 columns and the Failure Impact data
set.
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6 Select the left-column header row, right-click and select Insert->Text. Input a column header, Failure
Impact Status and click OK. Repeat for the right-column header, No of Services:

7 In the Data Explorer, expand Data Sets->Failure Impact.

8 Drag Failure Impact Status from the Data Explorer to the left-detail cell. Repeat for No of Services
and the right detail cell:

37Using the Report Editor



9 In a blank area of the failure_impact.rptdesign view, right-click and select Insert->Chart to open
the New Chart dialog:
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10 This report requires a pie chart, select Pie Chart, and then click Next:

11 Under Select Data Set, select Use Data Set and Failure Impact from the drop-down list.

12 Drag Failure Impact Status from Data Preview to the Category Definition input.
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13 Drag No of Services from Data Preview to the Slice Size Definition input:

14 Click Next to format the chart appearance.

15 Select Chart Area, amend Chart Title to Business Service Failure Impact Status, and then click Finish
to add the chart to the report definition.
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16 Drag the chart area outline to the size you require, and then press Ctrl+S to save the report definition:
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17 Select the Preview tab to view the report with data from your data source:

Binding the Data to the Report

The data in the data set is available to be added to your report definition.

To bind your data to a report:

1 Open the report definition view.

2 Construct your report layout as described in the BIRT documentation available in the Help menu.

3 Drag and drop items in the Data Explorer data set to the report definition view.
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4 Press Ctrl+S to save your changes.

Categorizing Reports

The Report Editor enables you to categorize reports. Each category corresponds to a particular page or
function in SOA Systinet.

To categorize a report:

1 In the Project Explorer, expand the report you want to categorize and double-click General to open
a view of the report definition containing categorization:

2 The Categories section displays the current categories that apply to your report.

Click Add to open the Add Category dialog:
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3 Select one of the following categories:

• Platform – Dashboard Report. A dashboard report is designed to fit inside a portlet on the
dashboard. Dashboard reports can be utilized in SOA Systinet with the procedure described in the
Adding a Content Report section of the HP SOA Systinet User Guide.

• Platform – Tools Report. A tools report is intended for use with a reporting tool as described in
Creating a Report Definition for the SOA Systinet Reporting Tool on page 23.

• Policy Manager – Artifact Compliance Report. Reports with the artifact compliance report cat-
egory are available in the View menu of compliance report pages as described in the Document
Reports section of the HP SOA Systinet User Guide.

• Policy Manager – Artifact Summary Report. Reports with the artifact summary report category
are available in the View menu of compliance report pages as described in the Document Summary
Reports section of the HP SOA Systinet User Guide.
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• Policy Manager – Business Policy Compliance. Reports with the business policy summary cat-
egory are available in the View menu of compliance report pages as described in the Business
Policy Summary Reports section of the HP SOA Systinet User Guide.

• Policy Manager – Business Policy Summary. Reports with the business policy summary category
are available in the View menu of compliance report pages as described in the Business Policy
Reports section of the HP SOA Systinet User Guide.

• Policy Manager – Detail Report. Reports with the detail report category are available in the View
menu of compliance report pages as described in the Document Reports section of the HP SOA
Systinet User Guide.

• Policy Manager – Homepage Report. Selecting homepage report enables you to select the report
as an area of interest to view on the main Policies tab in SOA Systinet. See the Areas of Interest
section of the HP SOA Systinet User Guide.

Example 4: Categorizing the Failure Impact Report

The failure impact report report must be categorized for use with an SOA Systinet Reporting Tool.

Follow the procedure described in Categorizing Reports on page 43, and select category Platform - Tools
Report.
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3 Deploying Reports to SOA Systinet

When your report is ready, you must deploy it to the reporting server.

The HP SOA Systinet plug-ins offer two methods:

• Deploy a report directly to the reporting server, as described in Deploying a Report to SOA Systinet on
page 47.

• Deploy a set of reports as an extension to the reporting server, as described in Deploying a Set of Reports
to SOA Systinet on page 47.

Deploying a Report to SOA Systinet

The SOA Systinet plug-ins provide extra functionality in the Report Editor enabling you to deploy your
report directly to the reporting server.

To deploy a report to SOA Systinet:

1 Open the report definition view.

2 In the Navigator right-click the report design you want to deploy, and then select HP SOA Systinet-
>Publish Report.

Deploying a Set of Reports to SOA Systinet

You can also deploy a set of reports as an extension.

Creating a Reporting Extension:

1 In the Navigator, right-click the project containing the set of reports you want to deploy and select
HP SOA Systinet>Build Extension... to start the Build Extension Wizard.

2 Input the following parameters:
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DefinitionOption

The name of the reporting extensionName

A description for the reporting extensionDescription

The location of the reporting extensions folderFolder

The filename of the reporting extensionFilename

3 Click Finish to create the extension.

The extension must be deployed to the SOA Systinet reporting server using one of the following methods:

• Use the importexport command, as described in the Reporting Import/Export Tool section of the HP
SOA Systinet Administration Guide.

• Deploy the extension to the reporting server using the setup tool, as described in the Applying Extensions
section of the HP SOA Systinet Administration Guide.
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