HP SiteScope Release Notes

for the Windows, Solaris, and Linux operating systems

Software version: 10.11

Publication date: December 2009

This document is an overview of the changes made to HP SiteScope. It contains important information that is not included in books or Help. You can find information about the following in this document:

Changes and Enhancements

Documentation Updates

Bug Fixes

Notes and Limitations

System Requirements

Support Matrices

HP Software Support

Legal Notices

Note: For release notes from earlier versions of HP SiteScope, see the root directory on the product installation media.

Changes and Enhancements

New Supported Environments

  • SiteScope supports installing and monitoring remote servers running on Microsoft Windows Server 2008 (64 and 32 bit) environments.

    Note: When monitoring on Microsoft Windows Server 2008 remote servers with User Account Control (UAC) enabled, the UAC remote restrictions must be disabled as follows:
  • 1. Open the registry editor as follows: click Start, click Run, type regedit, and press Enter.

    2. Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

    3. If the LocalAccountTokenFilterPolicy registry entry does not exist, on the Edit menu, select New > DWORD Value. Type LocalAccountTokenFilterPolicy, and then press Enter.

    4. Right-click LocalAccountTokenFilterPolicy, and then click Modify.

    5. In the Value data box, type 1, and click OK.

    6. Exit the Registry Editor.

New SiteScope Monitoring Capabilities

  • WMI monitoring is supported (but not certified) in SiteScope on Microsoft Windows Vista and Microsoft Windows 7. Note that when using the Windows Resources monitor, some counters might be displayed as "n/a".
  • SiteScope supports monitoring on VMware vCenter Server 4.0, VMware ESXi 4.0, and VMware ESX 4.0 environments.

Windows SSH Monitoring from SiteScopes Running on UNIX

  • SiteScopes installed on UNIX servers now include extended support for monitoring Microsoft Windows remote servers. The Windows remote server being monitored must be configured for SSH.
    • The following monitors running on UNIX SiteScopes are now supported to monitor non-perfex based Windows SSH: Citrix, ColdFusion, Microsoft ASP Server, Microsoft IIS Server, Microsoft SQL Server, Microsoft Windows Media Server, Microsoft Windows Resources, and Real Media Server. (CPU, Disk Space, and Memory monitors were previously supported.)
    • The following monitors running on UNIX SiteScopes are supported to monitor Windows SSH: Microsoft Windows Event Log and Microsoft Windows Services State.

      Note: Microsoft Windows Dial-up and Microsoft Exchange monitors are not supported on Windows SSH.
    • The Allow Unix to NT setting was removed from Preferences > Infrastructure Preferences > General Settings.

WebLogic Application Server 10.3 Support

  • JMX monitor supports monitoring WebLogic Application Server 10.3. To enable monitoring, enter weblogic.jar or wlfullclient.jar (recommended) in the JMX Monitor Settings Additional Classpath field. Multiple libraries can be entered separated by a semicolon. You can specify the timeout (this is not an ORB timeout) for JMX task execution (mbeans retrieval and conversion into xml) by modifying the _overallJMXCountersRetrievalTimeout property that was added to the master.config file. The default value is 15 minutes.

VuGen 9.51 Support

  • Web Script monitor supports scripts created in HP Virtual User Generator version 9.51 and earlier.

SAP CCMS Enhancements

  • In SAP CCMS monitor, added the ability to filter "SAP CCMS monitor sets" by regular expression, and to monitor other types of counters aside from SAP performance counter.
    • CCMS monitor set match. Enter a regular expression to match the "SAP CCMS monitor sets" you want to view (top level nodes of the CCMS tree). Only counters of matched "tree sets" are requested from SAP and displayed in the counter tree. To change the match, you must reload the counters. If the field is empty, all monitor sets are shown.
    • Monitor all counter types. Select to enable the monitor to collect all other types of counters in addition to collecting SAP performance counters. Note: If this option is selected, it is recommended to use "CCMS monitor set match" to prevent performance capacity problems.

Business Process Monitor Support

  • Installation of SiteScope and Business Process Monitor 8.03 is supported on a single server. To install both on the same machine:
  • 1. Install Business Process Monitor 8.03.

    2. Stop the Business Process Monitor service (it can be found at Start > Programs > HP > BPM > Stop BPM service).

    3. Rename the vpd.properties file in the Windows directory (it is highly recommended to rename it to vpd.properties.BPM). Note: If you later install a Business Process Monitor patch, make sure that you use the correct file by renaming vpd.properties.BPM back to vpd.properties (this also applies if you are uninstalling Business Process Monitor).

    4. Install SiteScope 10.11.

    5. Stop the SiteScope service from the Services control panel (Administrative Tools > Services). The default service name is SiteScope.

    6. In the <SiteScope root directory>\Tomcat\conf\server.xml file, change the default port values for the following connector ports to some other unique values:

    - Server port='8005'
    - Connector port='8080' (Web Server connector)
    - Connector port='8009'
    - Connector port='8082'

    7. Start the Business Process Monitor service and the SiteScope service.

Alert Template Enhancements

  • Added the following properties to SiteScope alert templates:
    • <errorCounterOnly> and <warningCounterOnly>. These properties return only the counter name of counters in error or warning status, whereas the existing <errorOnly> and <warningOnly> properties return the counter name and counter value of counters in error or warning status. To use these properties (both the new and existing ones), add to the master.config file the following property and value: _errorOnly=true.
    • <allThresholds>. This property returns all the thresholds in the monitor, whereas the existing <_classifier> property returns the first threshold only in the email alert.

Virtualization Enhancements

  • SiteScope uses perfmon to connect to the operating system of the VMware virtual machine and query it for CPU usage of the virtual host. When used over a period of time to monitor CPU on VMware, perfmon provided inaccurate performance analysis. VMware resolved this issue by integrating virtual machine performance counters such as CPU and memory into perfmon for Microsoft Windows guest operating systems when VMware Tools is installed. Use the Microsoft Windows Resources monitor to monitor the new counters groups to get accurate CPU utilization and memory data.
    • For vSphere 4.0, install VMware Tools that is packaged with vSphere 4.0. When running the Windows perfmon utility, use the new counter groups (VM Processor and VM Memory) to view real CPU utilization.
    • For VMs running on ESX/ESXi v3.5, contact VMware for a standalone version of this perfmon integration tool.

Documentation Updates

The following information supplements the current SiteScope documentation and should be used along with the SiteScope Help when reading about the specific areas listed.

  • The Microsoft Windows Exchange 2007 monitor includes the Exchange Server Administrators role.
    • Setup Requirements: For each comdlet, the account you use must be delegated as follows (according to Microsoft Exchange Server 2007, Permission Considerations section http://technet.microsoft.com/en-us/library/aa996881.aspx):

Test-MAPIConnectivity

To run the Test-MapiConnectivity cmdlet, the account you use must be delegated the Exchange Server Administrators role and local Administrators group for the target server.

To run the Test-MapiConnectivity cmdlet on a computer that has the Mailbox server role installed, you must log on by using a domain account that has the permissions assigned to the Exchange Server Administrators group. The account must also be a member of the local Administrators group on that computer.

Test-ExchangeSearch

To run the Test-ExchangeSearch cmdlet, the account you use must be delegated the following:

    • Exchange Recipient Administrator role
    • Exchange Server Administrators role and local Administrators group for the target server

Test-MailFlow

To run the Test-Mailflow cmdlet, the account you use must be delegated the Exchange Server Administrators role and local Administrators group for the server where the cmdlet is run.

Test-OWAConnectivity

To run the Test-OwaConnectivity cmdlet to test Outlook Web Access connectivity for all Exchange 2007 virtual directories on a Client Access server, the account you use must be delegated the Exchange Server Administrators role and membership in the local Administrators group for the target server.

Test-WebServicesConnectivity

To run the Test-WebServicesConnectivity cmdlet, the account you use must be delegated the Exchange Administrator role and local Administrators group for the target server.

    • Prepare the System for Using the Microsoft Exchange 2007 Monitor section:
      • New definition: "Exchange Server Administrators. An account that has administrative privileges on the Exchange server."
      • New definition for the SiteScope User: "This is the account that is used to run the SiteScope service. This account must also be a Local Administrator and delegated the Exchange Server Administrators role (see definition above)."
      • New Step 3: "Verify that the SiteScope user logon is a member of Administrators group or a domain administrator account and delegated the Exchange Server Administrators role."
  • Backing up a SiteScope installation includes performing a manual backup, with a new section on recovering the configuration data if SiteScope is down and cannot be restarted.
    • To back up the SiteScope installation:
      1. Stop SiteScope. Although it is not mandatory to stop SiteScope, it is recommended to do so before making a back up.

      2. Make a backup of your current SiteScope installation directory either by:
      • Using the Configuration Tool to export your configuration into a zip file. For details, refer to "Running the Configuration Tool" in the SiteScope Deployment Guide.
      • Copying the following folders and files from the SiteScope installation directory to your backup destination:

Directory
Description

\cache

Contains data samples that were not reported to HP Business Availability Center if HP Business Availability Center was down.

\conf\ems

Contains key configuration and control files used with Integration monitor types. This is only applicable if you use SiteScope as an agent reporting to another HP Business Availability Center application.

\conf\integration

Contains topology files used for integrations with HP Business Availability Center.

\discovery\scripts\custom

Contains custom discovery scripts.

\groups

Contains monitor, alert, report, and other critical configuration data needed for SiteScope operation.

\htdocs

Contains scheduled reports and user-customized style sheets for the SiteScope interface. Backup this directory and copy it to the SiteScope directory (within the same SiteScope versions) to avoid damaging the report pages and to see old reports. This folder cannot be backed up when the configuration is imported into a newer SiteScope version.

\logs

Contains a number of logs including date-coded logs of monitoring data. Selectively back up the most recent monitoring data log files along with the other log types in this directory. You may also want to back up the error.log, RunMonitor.log, access.log, alert.log, and monitorCount.log logs for historical continuity.

\persistency

This is the main persistency directory of the product. All the defined monitors, groups, alerts, templates, and many other SiteScope entities are found in this directory.

\scripts

Contains scripts used by Script monitors.

\scripts.remote

Contains command scripts used by Script monitors to trigger other scripts on remote servers.

\templates.*

Includes data and templates used to customize monitor function, alert content, and other features. The group of subdirectories all begin with the name templates.

Example: templates.mail, templates.os, templates.webscripts

\WEB-INF\lib\peregrine.jar

A file that might have been regenerated when configuring the HP Service Manager integration.

    • To recover the SiteScope installation:
      1. Perform a new installation of SiteScope. For details, refer to "Performing a Full Installation" in the SiteScope Deployment Guide.

      2. After installing SiteScope:
      • If you used the Configuration Tool to make a backup, use the Configuration Tool to import the previously created zip file. For details, refer to "Importing User Data" in the SiteScope Deployment Guide.
      • If you manually created a back up, delete all the folders and files listed above from the new installation directory, and then copy the backed up folders and files to the new installation directory.
  • In the documentation, the limitation that WMI is supported only for machines with an English locale is incorrect and should be ignored.

Bug Fixes

Description
CR ID
Area

Fixed issue of Cross-Performance Reports not showing integration monitor data after performing a hard synchronization.

33485, 33487

Business Availability Center Integration

Fixed issue of not being able to add several certificates with duplicate Alias name to Certificate Management, without having to modify the duplicate Alias names.

33310

Certificate Management

Fixed a memory leak that caused periodic SiteScope failure, by replacing the MindTerm SSH client version.

33923

Configuration

Fixed issue of the domain account being locked several hours after starting SiteScope.

35676

Configuration

Fixed issue of being unable to cut/paste a group if a monitor within the group contains an associated alert.

36063

General

Fixed issue of reports containing errors not being colored red in the Management Report Index page.

33844

Management Reports

Fixed issue of the "Please wait" message in the Manage Groups and Monitors dialog box being displayed in the background when the delete operation is taking a long time.

32671

Monitors

Fixed issue of being unable to run a monitor after deleting the monitor on which it depends.

36030

Monitors

Fixed issue of the Database Counter monitor losing its dependencies on other monitors when deployed through a template.

35322

Monitors

Fixed issue on the SiteScope machine of CPU constantly being at 100% when using a large number of Log File monitors (~1500) that have a high regular expression match count.

35465

Monitors

Fixed issue of EMS synthetic Technology Integration monitors not being sent to HP Business Availability Center during a hard synchronization.

33499

Monitors

Fixed issue in SAP CCMS monitor of timeout error when monitoring a server with a large number of instances. For details, see Changes and Enhancements.

33480

Monitors

Fixed issue of the Server-Centric Reports not displaying data when created in the UNIX Resources monitor.

32767

Monitors

Fixed issue of the VMware Performance monitor failing to load counters when the resource pool name contains special characters.

34739

Monitors

Fixed issue of the Web Service monitor not getting the correct Method names and their arguments.

36090

Monitors

Fixed issue in Log Preferences of the Daily logs to keep value being limited to a maximum of 3 years (1095 days) in the user interface.

33871

Preferences

Fixed issue of the Web Service tool not showing details of the request response.

32863

SiteScope Tools

Fixed issue when deploying monitors from solution templates of the server list not opening when the $$SERVER_LIST$$ variable is used in a server string.

35724

Templates

Added a message about when the upgrade process started and ended to the <SiteScope root directory>\logs\error.log file.

32774

Upgrade

Fixed issue of upgrade failure when trying to upgrade a registered SiteScope while HP Business Availability Center is down.

32773

Upgrade

Fixed issue of many error messages resulting from network errors/exceptions being displayed when the SiteScope client and server are separated by an unstable network, such as VPN over WAN. In some cases, this resulted in the browser being refreshed and the applet being reloaded.

35893

Usability

Escalation Fixes

Description
SR/E-Sar Number
CR ID
Area

Fixed issue of group alerts that target a specific monitor being corrupted when the target monitor is moved.

4603957422

34771

Alerts

Fixed issue of Email alerts not reporting thresholds on error for Microsoft Windows Resources and UNIX Resources monitors.

4604515424

34746

Alerts

Fixed issue of round trip time not being correctly reported to Business Availability Center when SiteScope is reporting from a non-English locale.

4602586280

34140

Business Availability Center Integration

Fixed issue after a SiteScope restart of BAC Integration Settings disappearing and the topology flow stopping.

4603321316

35423

Business Availability Center Integration

Fixed issue of CIs for EMS Technology Integration monitors disappearing from CMDB when aging is enabled by:

    • Resending EMS topology during a hard synchronization of SiteScope.
    • Enabling topology resending as part of an anti-aging process. This process is enabled by adding the property _reportEmsCIsAsPartOfAntiAging=true to the master.config file.

4604735124

35426

Business Availability Center Integration

Fixed NullPointerException issue in event pushing process when adding alert events to monitor history.

3605761611

33084

Configuration

Fixed issue of SiteScope Start/Restart and the daily status report emails containing the incorrect URL (port 8888 instead of 8080).

4602839520

34718

Configuration

Fixed issue of logging monitor statuses not working when database logging was configured to use Microsoft Access.

2607251867

32968

General

Fixed issue of Monitor History being deleted after every SiteScope restart.

2607583831

33081

General

Fixed issue of the monitor filter not working with the standard regular expression format (it worked with POSIX regular expressions only).

4601557301

33500

General

Fixed issue of Microsoft Windows Resources monitor displaying the incorrect number of instances if one of the instances has Japanese characters in its name while monitoring a Japanese machine from a Japanese machine using perfex based SSH.

2603343305

33001

I18N

Fixed issue of the Publish Template Changes Summary Report browser window containing incorrect characters in the title on a non-English environment.

4600598828

35602

I18N

Fixed issue of characters in reports not being displayed when SiteScope is viewed on a non-English environment.

4603442038

34647

I18N

Fixed issue of SiteScope counters not being displayed in LoadRunner when SiteScope is run under an account with a non-English locale.

1604769542

32970

LoadRunner Integration

Fixed issue of the way the Active Directory Replication monitor authenticates to the root Active Directory server.

3603871699

32964

Monitors

Fixed issue in the BroadVision Application Server monitor of "server and port fields cannot be left blank" error displayed when creating the monitor, even though these fields were filled out.

4602471651

34529

Monitors

Fixed issue of CPU monitor displaying "no data" error on the first run after the disable period ends.

229721

32713

Monitors

Fixed issue of the DB2 8.x and 9.x monitor being unable to retrieve counters if the counters from the DB2 server contain invalid XML characters.

4603731651

34769

Monitors

Fixed issue when deploying a template of a Disk Space monitor on a UNIX machine, that the incorrect file system is displayed in the monitor's properties.

4601719285

35385

Monitors

Fixed issue of the File monitor being unable to retrieve the file age after the monitor has been in use for a long time.

4603468924

34244

Monitors

Fixed issue of "out of memory" error when retrieving large configurations using the JMX monitor.

4602875913

35449

Monitors

Fixed issue in JMX monitor of child nodes missing from the counters tree where the node contained both attributes and child nodes.

2603910668

33073

Monitors

Added support to the JMX monitor for monitoring WebLogic Application Server 10.3. For details, see Changes and Enhancements.

1603209411

30660

Monitors

Fixed issue of Log File monitor with run alerts "For each log entry match" selected, not being able to send alerts when Server-side processing mode is selected.

4600612709

33222

Monitors

Fixed issue in Log File monitor of the Multi-line match setting having a limited buffer size. The _logFileMonitorMultiLineBufferedLines property was added to the master.config file, enabling you to configure the buffer size. The default value is 100.

4600612709

33220

Monitors

Fixed issue of reports displaying the incorrect uptime and error summary table for the Log File monitor.

3606279135

32979

Monitors

Fixed timeout issues in the Log File monitor.

4602737223

34577

Monitors

Fixed issue in the Microsoft Windows Event Log monitor of alerts not being sent for event log entries with ID=0.

231269

34484

Monitors

Fixed issue in the Microsoft Windows Event log monitor of File Replication Service not being displayed in the Log name list after updating from SiteScope 7.X.

4605280212

35011

Monitors

Fixed issue of the Microsoft Windows Performance Counter monitor displaying values as infinity instead of the actual value.

4605115816

35243

Monitors

Fixed issue in Microsoft Windows Performance Counter monitor of Quick or Management reports displaying "n/a" values for some measurements even if those values were available in the Dashboard.

231425

34548

Monitors

Fixed issue of Microsoft Windows Services State monitor not displaying all running services in the Dashboard tooltip and in the Monitor History view.

4601393920

33813

Monitors

Fixed issue of Java heap space error when opening a large counter tree in Oracle10g Application Server monitor or VMware Performance monitor.

4600712899

34021

Monitors

Fixed issue of SNMP Trap monitor instances disappearing from persistency and from the MG files after running the DataUploadUtil.bat file from <SiteScope root directory>\tools\TopazIntegration.

4602586280

34136

Monitors

Fixed issue with SNMP Trap monitor in For each SNMP trap matched mode of alerts being triggered when any content is matched.

2606984526

32966

Monitors

Fixed issue in the UNIX Resources monitor of the ppgout and ppscans counters not being displayed when monitoring a Solaris remote server.

230716

34060

Monitors

Fixed issue in the UNIX Resources monitor of the wrong CPU counter being used to monitor processes on a HP-UX remote machine.

3606227885

32810

Monitors

Fixed issue in a URL monitor of the incorrect error message being displayed when the HTTPS certificate is not imported when monitoring a HTTPS site.

4605110865

34964

Monitors

Fixed issue of the URL monitor reporting that the content matched correctly while also reporting that the monitor timed out.

229274, 3605754773

32259, 33127

Monitors

Fixed issue when adding request headers in URL specific monitors of the host header value being ignored by Sitescope. To enable all request header types in URL monitors to be allowed, open Preferences > Infrastructure Preferences > Monitor Settings and select Allow all request headers in URL specific monitors. When selected, the following request header types are allowed: Custom-Content, Custom-Header, Content-Type, Host, User-Agent, Set-Cookie, Method, Protocol, Action, and sslgetOptions. When the setting is cleared, custom headers only are allowed.

1605044179

33125

Monitors

Fixed issue in the URL Sequence monitor of the Tools option not being available in the Dashboard toolbar and shortcut menu.

4601894445

33562, 33562

Monitors

Fixed issue of the WebSphere Application Server monitor returning "Cannot connect to server" status when a counter is unavailable, inaccessible, or if there is a problem retrieving counter information from the WebSphere application. The monitor now returns the status "n/a" for counters for which it cannot retrieve data only, and appends the reason why the counter failed to the counter summary.

4601826396

34623

Monitors

Fixed issue of the WebSphere MQ Status monitor causing performance problems in the WebSphere MQ administrative console when the monitor is running.

3605053574

34013

Monitors

Fixed issue of periodic loss of SiteScope system preferences by suspending the ability to update from the master.config file when removing groups of preferences. Also added the Associated Monitors column to the Remote Servers table. This enables sorting the table by the number of monitors used by each remote server, and removal of unused remote servers (those with 0 associated monitors).

4603533636

35071

Preferences

Fixed issue when monitoring remote servers using SSH connections of monitors timing out and returning no data. Also fixed issue of SSH version 2 based monitors timing out intermittently.

3605899445, 4605839665

33145, 36115

Remote Servers

Fixed issue when creating a report with a bar graph, that the bars displayed the incorrect values (they were always on 0).

230671

33832

Reports

Fixed issue of the Management Report not being available in an Internet Explorer browser if the SiteScope server was using port 80 instead of 8080.

4603321116

34570

Reports

Fixed issue of the _noScientificNotation=#.## setting in the master.config file not being applied to values in the Management Report Index Page.

4601420625

35081

Reports

Fixed issue of the password used to connect to the remote host being sent to log messages during perfex command execution.

3605893304

33103

Security

Fixed issue of the login password being sent to the access.log file as part of the URL during an unsuccessful login.

4603060123

34496

Security

Fixed issue of duplicate Topaz ID occurring in SiteScope Failover after mirroring a primary SiteScope server.

4601102950

33507

SiteScope Failover

Fixed issue of being unable to synchronize the mail subject in the Sync SiteScopes Wizard. The template.mail.subjects file is now included in the Configuration Tool when exporting SiteScope settings.

229831

32953, 32955

System Availability Management Administration

Fixed issue that credential preferences were not always imported when copying monitors from one SiteScope to another.

3605692604

32946

System Availability Management Administration

Fixed issue of being unable to copy monitors between different SiteScopes using Business Availability Center when those monitors had alerts with email actions having "Other" recipients.

3606352059

33100

System Availability Management Administration

Fixed issue of not being able to change the Enable/Disable Monitor settings using the Global Search and Replace feature.

4604379874

35104

System Availability Management Administration

Fixed issue of disabled monitors becoming enabled after publishing template change to a set of servers.

231942

35069

Templates

Fixed issue of Publish Template Changes wizard not accepting changes to alert action variables.

4601954947

33777

Templates

Fixed issue of not being able to specify usage of an external JVM when deploying the WebSphere Application Server monitor using the WebSphere 5.x or 6.x Application Server Solution Template.

4607398595

36366

Templates

Notes and Limitations

Description

CR ID or SR/E-Sar Number

Area

Non-English characters might not be displayed correctly in the subject field in Email alerts.

24689

Alerts

To improve performance, SiteScope uses a topology cache when sending topology data to Business Availability Center's CMDB. If SiteScope attempts to send an existing CI to the CMDB, the CI may not be sent, or created in the CMDB, for up to a week because of the way the topology cache works.
This could happen in the following circumstances:

  • Cut and paste a monitor from one group into a new group. The original group is left empty. Cut and paste the monitor from the new group back into the original group.  
  • In HP BAC Integration Settings, disable data and topology reporting for a monitor and then enable again.
  • A CI that has been manually deleted from the CMDB is not created again until the cache is cleaned out. (EMS flow - Deleting EMS monitors from the CMDB)
Workaround:  If you cannot wait approximately one week to see the CIs, you can manually synchronize the data as follows:  In Preferences > Integration Preferences, edit the relevant integration and in the BAC Preferences Available Operations area, click Re-synchronize.
 

BAC Integration

Deploying SiteScope templates while registering a SiteScope to Business Availability Center may cause a loss of topology data reported to Business Availability Center. It is recommended to avoid making configuration changes while performing Business Availability Center registration.

 

BAC Integration

When working in System Availability Management Administration, the Link Monitor to CI function within SiteScope monitor configuration may not work properly if popups are blocked by the Business Availability Center server. Workaround: Create the link in Business Availability Center using the HP Universal CMDB application (Admin > Universal CMDB > IT Universe Manager).

 

BAC Integration

If SiteScope restarts for any reason while SiteScope establishes a Business Availability Center integration, some topology data that SiteScope forwards to Business Availability Center may be lost. Workaround: If not all topology data was forwarded to Business Availability Center, manually synchronize the data as follows:  In Preferences > Integration Preferences, edit the relevant integration and in the BAC Preferences Available Operations area, click Re-synchronize.

 

BAC Integration

When working under high load conditions, you should suspend all monitors before connecting to HP Business Availability Center for the first time.

 

Capacity Limitations

When SiteScope is integrated with HP Business Availability Center, performing various very high load operations might cause problems in SiteScope. Use the following guidelines:

  • Do not run the Publish Template Changes Wizard for over 3,000 monitors at once.
  • Do not run the Monitor Deployment Wizard to create over 3,000 monitors at once.
  • Do not copy/paste over 3,000 monitors in a single action.
  • Do not perform a Global Search and Replace to modify Business Availability Center integration properties for over 2,500 monitors at one time.

30633

Capacity Limitations

If SiteScope is installed on Microsoft Windows Server 2008, the time zone offset should be defined manually in Preferences > Infrastructure Preferences > General Settings > Time Zone offset, in hours, from Greenwich Mean Time (GMT). For example, if the time zone is GMT +2, type "-2" as the time zone offset. If the time zone is GMT -5, type "5" as the time zone offset. For GMT, type "-999" or "0".

4605889641 (SR)

Configuration

SiteScope group MG files will be deprecated in SiteScope 11.00. Although MG files are still supported in SiteScope 10.11, the Enable configuration files option is no longer selected by default when SiteScope is installed. When upgrading from an earlier version of SiteScope that has this option selected, the MG configuration files are supported.

 

Configuration

When creating a Diagnostics Integration in Integration Preferences, if you select the option Include additional data, all other Diagnostics and Generic Data integrations are affected and will report additional data in the data SiteScope forwards to these applications.  It is recommended to select this option only if you require this additional data for all your Diagnostics and Generic Data integrations.  For details on the option, refer to the "New/Edit Diagnostics Integration Dialog Box" in the "Integration Preferences User Interface" section in Using SiteScope help.

 

Diagnostics Integration

The Dashboard column layout in the Monitor History view cannot be saved during user sessions.

20806

Dashboard

The Review Summary page displays the real host name of the monitored server instead of the name by which the remote machine should be known in SiteScope. This means that you cannot differentiate between multiple remote servers created for the same host machine (for example, where one remote server uses the WMI connection method and another uses NetBios).

 

Global Search and Replace

When performing a global search and replace operation in a load environment of over 1,000 monitors, you may encounter an out of memory error in the Java applet on the client machine performing the global search and replace.
Workaround: Increase the heap size of the Java applet on the client machine. Click Start > Control Panel > Java > Java tab. View the Java Applet Runtime Settings and enter the following in the Java Runtime Parameters field: -Xmx128m (default is 64m).

27880

Global Search and Replace

When using the SNMP Browser Tool or the XSL Transformation Tool, the results may not be readable in languages other than English. Workaround: Click the Save To File button, save the results to an external file, and open the file with an external editor.

32444

I18N

For the SiteScope user interface to start, Java Runtime Environment (JRE) must be installed on the SiteScope client machine. If you are using JRE 5, you might get Java script validation errors when opening dialog boxes in SiteScope. Using Firefox 3.0 with JRE 5u14, 5u15, or 5u16 causes the applet to freeze any operation until the browser is closed. Workaround: Configure you browser to use JRE 6u10 or later.

20599, 22818, 24623

Installation and Upgrade

The SiteScope user interface does not start and the following error message is displayed: "Several Java Virtual machines running in the same process caused an error". This is a known Java defect (http://bugs.sun.com/view_bug.do?bug_id=6516270) that might occur when using Internet Explorer 7. Workaround: Either: (1). Use a browser other than Internet Explorer 7. (2). Upgrade to Java 6 update 10 or later. (3). In the Add or Remove Programs dialog box (Start > Control Panel > Add or Remove Programs), remove all Java/Java Runtime Environment installations except for the latest version.

 

Installation and Upgrade

The SiteScope user interface does not start and an error message is displayed while starting the SiteScope applet (for example: "The Java Runtime Environment cannot be loaded"). Workaround: Perform the steps below. After each step, try to reopen SiteScope. If SiteScope fails again, proceed to the next step. (1). Close all the browser's windows. (2). End all remaining browser processes (if any remained) using Windows Task Manager. (3). Clean the local Java applet cache. Select Start > Control Panel > Java, and in the General tab, click Delete Files and then click OK. (4). Clean the local Java applet cache by deleting the content of the following folder: C:\Documents and Settings\<user_name>\Application Data\Sun\Java\Deployment\cache.

 

Installation and Upgrade

SiteScope does not start after upgrading a configuration that contains a DHCP monitor if the Java DHCP library has not been installed on the server where SiteScope is running. Workaround: (1). Download the jDHCP library (either in .zip or in .tar.gz format) from http://www.dhcp.org/javadhcp/. (2). Extract the file named JDHCP.jar and copy it to the <SiteScope root directory>\WEB-INF\lib directory. (3). Restart the SiteScope service.

32628

Installation and Upgrade

After upgrading from SiteScope 7.5 to 9.0 and then to 10.1x, if 7.5.x contained an administrator user and a regular user and the username and password for the administrator was blank, some or all of the monitors and alerts may not be displayed in the user interface after the upgrade. Workaround: After upgrading to SiteScope 9.0, enter the username and password for the administrator user in Preferences > Users Preferences in the user interface.

32727

Installation and Upgrade

The SiteScope menu bar opens but the applet fails to start, and you see a blank screen or an "x" image. Click Start > Control Panel > Java, and in the Java Control Panel, click the Advanced tab. Expand the Default Java for browsers folder (or <APPLET> tag support if you are using Java 5), and make sure that Microsoft Internet Explorer and Mozilla family are selected. Click Apply and then click OK.

 

Installation and Upgrade

If you type the incorrect license number when installing SiteScope, perform the following:

  1. Open the master.config file located in the <SiteScope root>\groups directory, and delete the _license= key value.
  2. Use the PersistencyViewer.bat tool located in <SiteScope root >\SiteScope\bin to search for the following SiteScope objects and delete their _license key value:
    • Filter: com.mercury.sitescope.platform.configmanager.preferences

      Object id: GeneralDefaultPreferences_
    • Filter: com.mercury.sitescope.platform.configmanager.MasterConfig

      Object id: _masterConfig
 

Installation and Upgrade

The ability to report topology data to HP Business Availability Center was enhanced with several complex topologies (such as WebSphere, WebLogic, and so forth). SiteScope must collect the properties for these topologies on the first start after an upgrade. This may take some time because it means connecting to the monitored servers and getting the additional data. A problem may arise during this first restart if this takes longer than 15 minutes because SiteScope automatically restarts if there are no monitors running within 15 minutes. Workaround: After an upgrade, use the following batch file to start SiteScope for the first time: <SiteScope root directory>/bin/go.bat. Once SiteScope is started, for any monitors that are monitoring environments that are not running, select Disable reporting to BAC under the BAC Logging Options. This saves wasted time waiting for the monitored servers to reply.

 

Installation and Upgrade

An Internet Explorer exception error message is thrown inside SiteScope pages, indicating Operation aborted. Workaround: Remove or disable the Skype add-ons on your system. For further details, see http://support.microsoft.com/default.aspx/kb/927917.

 

Installation and Upgrade

If templates and solution templates are missing from the Templates context after installing SiteScope, copy all the templates from the <SiteScope root>\export directory to the <SiteScope root directory>\persistency\import directory (you might need to create this folder if it does not exist).

 

Installation and Upgrade

When logging to SiteScope using LDAP authentication, unable to generate a Management Report due to authentication issues. Workaround: Define the user password in SiteScope to be the same as the one used in LDAP.

31883

LDAP Authentication

Monitor Thresholds. If you clear or add a counter (from the counters tree in the Monitor Settings panel) that has corresponding thresholds defined in the Threshold Settings panel, the counter might be replaced in the Threshold Settings with the next selected counter in the counter tree, replaced by the default counter, or removed from the Threshold Settings panel. This limitation applies to all browsable monitor counter types in template mode only, and to the Microsoft Windows Resources, Apache, and Health monitors in normal and template mode.

 

Monitors

Monitor Tree. If there is a large space between group containers in the SiteScope monitor tree, refresh your browser.

 

Monitors

Composite monitor. The copy to template action is not supported for the Composite monitor (if you click Copy to Template, the server names of the group of monitors that are being monitored by the Composite monitor are copied to the template with the $$SERVER_LIST$$ variable instead of the names of the actual servers).

27803

Monitors

Disk Space monitor. The Disk Space monitor displays slightly different results depending on the protocol that is used (NetBIOS, WMI or non-perfex based SSH).

28593

Monitors

File monitor. If Telnet is used as the connection method for UNIX remote servers running on an HP-UX or Linux operating system, and either (1) the LANG environment variable is unset, or (2) "set -u" is in effect and the LANG or LC_ALL environment variables are unset, the File monitor will not work regardless of the file it is monitoring. Workaround: Permanently set the LANG and LC_ALL environment variables to the default shell for the SiteScope user.

23798

Monitors

Microsoft Windows Event Log monitor. The Microsoft Window Event Log monitor is only able to retrieve partial data when monitoring the event log on a Windows Server 2008 because it cannot read the message DLL file.

30719

Monitors

Microsoft Windows Event Log monitor. The Microsoft Windows Event Log monitor is unable to monitor "Critical" event types on Windows 2008 servers. This is because the event type is not supported in the Event Type list. This limitation is relevant for SiteScopes installed on Windows Server 2008 only.

32441

Monitors

Microsoft Windows Media Server monitor. The Microsoft Windows Media Server monitor is unable get counters from the remote server when monitoring on Windows Server 2008 (64bit).

34286

Monitors

Microsoft Windows Resources monitor. If you encounter problems with performance counters not being available when using the Microsoft Windows Resources monitor, make sure that the Microsoft Visual C++ 2005 SP1 Redistributable Package (x86) is installed correctly, and reinstall it if the problem persists.

 

Monitors

Ping monitor. When SiteScope is installed on Solaris, the Ping monitor might take longer than expected to run, and exceed the timeout for displaying the monitor status in the popup window (the default timeout is 5 seconds). Workaround: In the Ping Monitor Settings panel, increase the value in the Timeout (milliseconds) field.

26236

Monitors

Script monitor. When defining a Script monitor to monitor a Linux remote server using the Telnet connection and the script is defined as USE COMMAND, the match expression may not work properly. This could be caused by a limitation in the number of characters that can be used to run the USE COMMAND. By default, the terminal command line has a length limitation on the size of the command per line.

30899

Monitors

SNMP monitor. When the SNMP monitor is integrated to report data to HP Diagnostics, the measurement label is sent as a name instead of the real measurement name. Workaround: Use the SNMP by MIB monitor instead.

 

Monitors

Technology Integration monitor.

  • When creating a Technology Integration monitor for integrating measurements into HP Business Availability Center (by selecting Measurements as the Sample type in the Field Mapping area of the monitor properties), SiteScope reports only system topology data for the monitor to HP Business Availability Center. This is the standard host topology SiteScope reports to HP Business Availability Center. This cannot be changed by adding a script in the Topology Settings area. If you add a topology script, the script will fail.
  • When creating a Technology Log File Integration monitor, it is recommended to perform the Test Script (during monitor configuration, in the Topology Settings area, select a topology script in the Script field and click Test Script) of the topology script using a short log file. If a long log file is used for testing the topology script, it may take several minutes.

25754

Monitors

After changing the user name or password of a credential profile, any open connections that are using this credential remain open and are not reconnected. Workaround: Restart SiteScope.

30651

Preferences

The "Plink" SSH connection method is no longer supported when working with remote servers.

36368, 36370

Remote Servers/SSH

Due to a bug in Sun Java, SiteScope installed on Solaris 10 is unable to connect to a remote UNIX server via SSH using Internal Java Libraries. Workaround: In the file <SiteScope root directory>\bin\start-monitor, add the following to the argument list of the JRE (just before the -Dflipper.param.file argument):
-Djava.nio.channels.spi.SelectorProvider=sun.nio.ch.PollSelectorProvider

 

Remote Servers

If a Monitor Summary report is created using an Internet Explorer browser, and Export to file and Comma-delimited (csv) are selected in the Export Settings, an authentication popup window is displayed after clicking Generate Report. Workaround: In the authentication window, click Cancel and the file opens in Microsoft Excel.

30696

Reports

Copying and pasting from SiteScope 10.10 to earlier versions of SiteScope is not supported.

30669

System Availability Management Administration

When copying monitors, groups, or other entities between multiple SiteScope instances, tag assignments are lost even if the tags that were assigned to the copied entities on the source SiteScope are present on the target SiteScope.

32039

System Availability Management Administration

When copying and pasting a SiteScope monitor into a group, the monitor data can take up to an hour before it is displayed in Dashboard in HP Business Availability Center.

32040

System Availability Management Administration

When copying and pasting a monitor that includes a script alert from one SiteScope into another, the remote server of the script alert may not correctly copy into the target SiteScope. Workaround: If you are copying script alerts from one SiteScope to another, ensure that the remote server accessed by the script alert exists in the target SiteScope before copying.

 

System Availability Management Administration

The Technology Log File Integration monitor cannot be copied from one SiteScope to another. Workaround: Create an identical monitor on the target SiteScope (copy all monitor values to it from the original monitor). To copy a sub-tree containing Technology Integration monitors:
1). Copy the sub-tree to a temporary location in the same SiteScope.
2). Delete the Technology Integration monitors.
3). Copy the new sub-tree from the temporary location to the other SiteScope.
4). Delete the temporary location.
5). Create the Technology Integration monitors in the other SiteScope

30759

System Availability Management Administration

If a template contains an invalid dependency (the template contains a dependency that existed once but no longer exists in the imported template), no dependency is shown in the template deployment. When running the Publish Template Changes wizard, the Depends on property is displayed as a difference in the Content Changes page even though there is no dependency displayed in the template. Workaround: Add a new dependency in the template, remove it, and then click Save. This removes the non-existent dependency.

32397

Templates

If the Method or Operating system values in a template remote server contain an incorrect value or are not entered using the same case that is displayed in the drop-down list when configuring a remote server, verification does not work properly, and the first value in the drop-down list is inserted instead. Workaround: Enter the value exactly as it is displayed in the drop-down list on the Remote Servers page.

 

Templates

When using the Event Log Tool, if DNS is selected in the Log name box and the target server does not have a DNS server on it, the Application log content is displayed in the Results panel.

32543

Tools

When using the Database Connection Tool to apply properties to the Database Query monitor or Technology Database Integration monitor, the credential data is lost if a credential profile is selected instead of entering the credentials manually.

32050

Tools

  • The following monitors are end of life and will not work even if configured in previous versions:

Monitor

Recommended Alternative Monitor

Asset monitor
N/A
Astra Load Test
Web Script
Active Directory Performance
N/A
Avalon Event
Technology Integration monitors
BMC Patrol Event
Technology Integration monitors
BMC Patrol Metrics
Technology Integration monitors
CA Unicenter Event
Technology Integration monitors
Compaq Insight Manager Event
Technology Integration monitors
Concord Metrics
Technology Integration monitors
DB2
DB2 8.x
Dynamo
N/A
HP Systems Insight Manager Event
Technology Integration monitors
IPlanet Application Server
SunONE
IPlanet Server
SunONE
IPlanet Web Server
SunONE
Mercury Application Mapping
HP Discovery and Dependency Mapping application
NetCool Event
Technology Integration monitors
NetIQ Metrics
Technology Integration monitors
Network
Network Bandwidth
Quick Test Pro
Web Script
Remedy Ticketing
Technology Integration monitors
RTSP
Real Media Player
SAP
SAP Performance
SAP Portal
SAP CCMS (new)
SilverStream Server
N/A
Tivoli DM Metrics
Technology Integration monitors
Tivoli TEC Event
Technology Integration monitors
WebLogic 5.x Application Server
N/A
WhatsUp Event
Technology Integration monitors

System Requirements

Below are the minimum server and client system requirements and recommendations for running SiteScope, based on the various supported operating systems.

Installation Prerequisites

SiteScope 10.11 must be installed on top of SiteScope 10.10.

Server System Requirements for Windows

Computer/Processor
800 MHZ or higher
Operating System
Microsoft Windows 2000 Server/Advanced Server SP4
Microsoft Windows 2003 Standard/Enterprise SP1, SP2
Microsoft Windows Server 2003 Enterprise R2 SP1, SP2
Microsoft Windows Server 2008 Standard Enterprise SP2
Memory
1 GB minimum (2 GB+ recommended)
Free Hard Disk Space
2 GB or more (10 GB+ recommended)
Web Browser
Microsoft Internet Explorer 6.0 (SP1 or later) and 7.0
Firefox 2.0, 3.0
Java Plug-in (to view applets)
Recommended: 6u11 and later

Server System Requirements for Solaris

Computer/Processor
Sun 400 MHz UltraSparc II Processor or higher
Operating System
Sun Solaris 9 or 10 (with latest recommended patch cluster)
Memory
1 GB minimum (2 GB+ recommended)
Free Hard Disk Space
2 GB or more (10 GB+ recommended)
Web Browser
Firefox 2.0, 3.0
Java Plug-in (to view applets)
Recommended: 6u11 and later

Server System Requirements for Red Hat Linux

Computer/Processor
800 MHZ or higher
Operating System
RedHat ES/AS Linux 3 or 4, 4.3, 5.2
Memory
1 GB minimum (2 GB+ recommended)
Free Hard Disk Space
2 GB or more (10 GB+ recommended)
Web Browser
Firefox 2.0, 3.0
Java Plug-in (to view applets)
Recommended: 6u11 and later

Note: SiteScope can be installed as a 32-Bit application over 64-Bit environments for the supported operating systems listed above.

Server System Requirements for VMware

The following VMware environments are supported in SiteScope according to the configurations tested below:

Supported and Tested Environments
VMware ESX 3.0
VMware VirtualCenter 3.0
Supported Environments Only
VMware VirtualCenter 2.x
VMware ESX 3.x
VMware ESX 2.5 via VirtualCenter 2.x
VMware ESX 3.x via VirtualCenter 3.x
VMware vCenter Server 4.0VMware ESXi 4.0
VMware ESX 4.0
VMware Configuration Tested
2 VMware Virtual Machines (VM) on one physical server.
Each VM with 2 CPUs at 2Ghz, 2 GB memory, and 10 GB disk space.
No other VMs resident on this physical server.
VMTools installed.
SiteScope Configuration Tested
1 SiteScope on each VM (No other application resident on the VMs).
Each VM with the same version of SiteScope.
6500 total monitors with no more than 650 monitor runs per minute on each VM.

Use these minimum system requirements when installing SiteScope on VMware environments:

Computer/Processor
4 Intel Xeon physical processors, 2 GHz each
Operating System
Microsoft Windows 2003 Standard/Enterprise SP1
Memory
4 GB
Free Hard Disk Space
20 GB (Hard Disk speed: 7200 rpm)
Network Card
1 physical gigabit Network Interface Card
Java Plug-in (to view applets)
Recommended: 6u11 and later
Other Software
VMTools must be installed

Note: Monitor capacity and velocity can be significantly impacted by numerous factors including, but not limited to the following: SiteScope server hardware, operating system, patches, third-party software, network configuration and architecture, location of the SiteScope server in relation to the servers being monitored, monitor types and distribution by type, monitor frequency, monitor execution time, Business Availability Center integration, and Database Logging. The published maximums should not be assumed to be possible in every environment.

Certified Configuration

The following configuration has been certified in a high load environment for an installation of SiteScope that was integrated with HP Business Availability Center. This configuration replaces the recommended configuration that appears in the SiteScope Deployment Guide.

Operating System
Microsoft Windows Server 2003, Enterprise Edition
Version: 5.2.3790 Service Pack 2 Build 3790
System Type
x86-based PC
CPU

4 Intel Xeon 5160 physical processors, 3 GHz each

Total Physical Memory
16 GB
Java Heap Memory
1024 MB
Total Number of Monitors
16000
Total Number of Remote Servers
1250
Monitor Runs per Minute
2000

Client System Requirements

SiteScope client is supported by all Microsoft Windows operating systems (including Microsoft Windows 7) using Microsoft Internet Explorer 6.x-8.0 or Firefox 2.0-3.0x.

HP SiteScope Support Matrices

HP Business Availability Center Integration Support Matrix

HP SiteScope Version
HP Business Availability Center Version
8.0x
8.00
7.5x
SiteScope 10.11
Certified
Certified
Certified

Note: SiteScope 10.11 integration with HP Business Availability Center 7.0x has been verified, however it is not officially supported.

HP Software Support

This web site provides contact information and details about the products, services, and support that HP Software offers. For more information, visit the HP Support web site at: HP Software Support Online.

HP Software support provides customer self-solve capabilities. It provides a fast and efficient way to access interactive technical support tools needed to manage your business. As a valued support customer, you can benefit by being able to:

  • Search for knowledge documents of interest
  • Submit and track progress on support cases
  • Submit enhancement requests online
  • Download software patches
  • Manage a support contract
  • Look up HP support contacts
  • Review information about available services
  • Enter discussions with other software customers
  • Research and register for software training

To access the Self-solve knowledge base, visit the Self-solve knowledge search home page.

Note: Most of the support areas require that you register as an HP Passport user and sign in. Many also require an active support contract. To find more information about support access levels, go to: Access levels.

To register for an HP Passport ID, go to: HP Passport Registration.

Legal Notices

© Copyright 2009 Hewlett-Packard Development Company, L.P.

Confidential computer software. Valid license from HP required for possession, use or copying. Consistent with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard commercial license.

The only warranties for HP products and services are set forth in the express warranty statements accompanying such products and services. Nothing herein should be construed as constituting an additional warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

For information about third-party license agreements, see the Third_Party_Agreements directory on the product installation media.

Trademark Notices

Adobe® and Acrobat® are trademarks of Adobe Systems Incorporated.

Intel®, Pentium®, and Intel® Xeon™ are trademarks of Intel Corporation in the U.S. and other countries.

Java™ is a US trademark of Sun Microsystems, Inc.

Microsoft®, Windows®, Windows NT®, and Windows® XP are U.S registered trademarks of Microsoft Corporation.

Oracle® is a registered US trademark of Oracle Corporation, Redwood City, California.

Unix® is a registered trademark of The Open Group.

Acknowledgements

This product includes software developed by the Apache Software Foundation (www.apache.org/).

This product includes Java Runtime Environment, including JSSE, JIMI, and JDNI from Sun Microsystems.

This product includes packages from i-net software GmbH (http://www.inetsoftware.de/ products/jdbc-driver).

This product includes the Java Generic Library package from ObjectSpace.

This product includes the Java PerlTools package from ORO.

This product includes MindTerm secure shell Java client from AppGate Network Security.

This product includes the Berkley DB from SleepyCat Software (http://www.oracle.com/database/berkeley-db/index.html).

This product includes the Java MD5 library from Santeri.

This product includes the Java SNMP package from Netaphor Software.

This product includes the SNMP Utilities from AdventNet, Inc (http://www.adventnet.com/ products/snmputilities/index.html).

This product includes the PuTTY NT SSH client (SiteScope for Windows Only) from Simon Tatham.

This product includes the ANTLR from Terrence Parr (http://www.antlr.org/license.html).

This product includes Concurrent utilities for Java from Doug Lea (http://gee.cs.oswego.edu/dl).

This product includes SEDA from Matt Welsh (and The Regents of the University of California) (http://www.eecs.harvard.edu/~mdw/proj/seda/#copyright).

This product includes JEP from Singular Systems (http://www.singularsys.com/order/ license.html).

This product includes Java XML Parser from Datachannel.

If you have any comments or suggestions regarding this document, please send them by e-mail to SW-Doc@hp.com.



© Copyright 2009 Hewlett-Packard Development Company, L.P.