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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty 
statements accompanying such products and services. Nothing herein should be construed as 
constituting an additional warranty. HP shall not be liable for technical or editorial errors or 
omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. 
Consistent with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software 
Documentation, and Technical Data for Commercial Items are licensed to the U.S. 
Government under vendor's standard commercial license.

Copyright Notices

© Copyright 2010-2011 Hewlett-Packard Development Company, L.P.

This product includes software developed by the Apache Software Foundation (http://
www.apache.org/).

This product includes software developed by Andy Clark.

This product includes asm software which is Copyright (c) 2000-2005 INRIA, France Telecom 
All rights reserved.

This product includes jquery.sparkline.js software which is Copyright (c) 2007-2009, Adolfo 
Marinucci All rights reserved.

Trademark Notices

Adobe® is a trademark of Adobe Systems Incorporated.

Microsoft® and Windows® are U.S. registered trademarks of Microsoft Corporation.

UNIX® is a registered trademark of The Open Group.

Java is a registered trademark of Oracle and/or its affiliates.
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Documentation Updates

The title page of this document contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

• Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using the most recent edition of a 
document, go to:

http://h20230.www2.hp.com/selfsolve/manuals 

This site requires that you register for an HP Passport and sign in. To register for an HP 
Passport ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

Or click the New users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product 
support service. Contact your HP sales representative for details.
3



Support

Visit the HP Software Support web site at:

www.hp.com/go/hpsoftwaresupport 

This web site provides contact information and details about the products, services, and 
support that HP Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and 
efficient way to access interactive technical support tools needed to manage your business. As 
a valued support customer, you can benefit by using the support web site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many 
also require a support contract. To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html 

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp
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1 Introduction
HP Service Health Reporter (HP SH Reporter) is a cross-domain historical 
infrastructure performance reporting solution. It displays both top-down 
reports from Business Service Management (BSM) Business Service and 
Business Application or HP Operations Manager (HPOM) Node Group 
perspective to the underlying infrastructure and bottoms-up reports from the 
infrastructure to the impacted Business Services and Business Applications 
or Node Groups. It leverages the topology information to show how the 
underlying infrastructure health, performance and availability are affecting 
your Business Services and Business Applications or Node Groups in the long 
term.

Using the reports created by HP SH Reporter, you can compare and analyze 
the usage and performance data of the different IT elements and achieve the 
following goals:

• Analyze the load and efficiency of your IT infrastructure.

• Forecast the performance and plan your capacity and usage.

• Identify the patterns of problems affecting your business and IT 
environment.
 11



HP SH Reporter Components
.

HP provides product support only for the versions of Sybase IQ and SAP 
BusinessObjects that are shipped with HP SH Reporter. HP does not provide 
any support for pre-existing licenses of these products in your system.

For additional information about HP SH Reporter, its architecture, and 
functionality, see the HP Service Health Reporter Concepts Guide.

HP SH Reporter Deployment Scenarios

You can deploy HP SH Reporter in the following environments:

• With BSM Service and Operations Bridge (SaOB)

• With Application Performance Management (APM)

• With HPOM
12 Chapter 1



BSM Service and Operations Bridge

In the deployment scenario, Run-time Service Model (RTSM) is the source of 
the topology information for HP SH Reporter and must be installed in this 
deployment environment. RTSM is also referred to as Operational Database 
(ODB).

HP products supported in this deployment scenario include:

• BSM platform with one or more of its applications such as HP SiteScope, 
Real User Monitor (RUM), and Business Process Monitor (BPM) as the 
data acquisition products

• HPOM with the following Smart Plug-ins:

— Oracle database Smart Plug-in

— Microsoft SQL Server database Smart Plug-in

— IBM WebSphere Application Server Smart Plug-in

— Oracle WebLogic Application Server Smart Plug-in

— Microsoft Active Directory Smart Plug-in

— Microsoft Exchange Smart Plug-in

— Systems Infrastructure Smart Plug-in

— Virtualization Infrastructure Smart Plug-in

• HP Performance Agent and HP Operations agent

• BSM Operations Management (OMi) as the operations bridge in the BSM 
solution

For more information about the BSM Service and Operations Bridge 
deployment scenario, see the HP SH Reporter Concepts Guide.

Application Performance Management

In this deployment scenario, RTSM is the source of topology information and 
must be installed in this deployment environment.

HP products supported in this deployment scenario include BSM platform 
with one or more of its applications such as HP SiteScope, RUM, or BPM as 
the data acquisition products.
Introduction 13



For more information about the Application Performance Management 
deployment scenario, see the HP SH Reporter Concepts Guide.

HPOM

In the HPOM deployment scenario, the HPOM database server is the source 
of the topology information for HP SH Reporter. HPOM must be installed in 
this deployment environment. HPOM database server can include:

• HPOM for Windows

• HPOM for Unix

• HPOM for Linux

• HPOM for Solaris

HP products supported in this deployment scenario include:

• HPOM with its following Smart Plug-ins:

— Oracle database Smart Plug-in

— Microsoft SQL Server database Smart Plug-in

— IBM WebSphere Application Server Smart Plug-in

— Oracle WebLogic Application Server Smart Plug-in

— Microsoft Active Directory Smart Plug-in

— Microsoft Exchange Smart Plug-in

— Systems Infrastructure Smart Plug-in

— Virtualization Infrastructure Smart Plug-in

• HP Performance Agent and HP Operations agent

For more information about the HPOM deployment scenario, see the HP SH 
Reporter Concepts Guide.
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Installation Flowchart

Click the links provided in the flowchart to see the relevant sections.

Complete the prerequisite tasks before 
installing HP SH Reporter. See 
Preinstallation Checklist on page 27.

Install HP SH Reporter by following 
the installation steps. See Installation 
Steps on page 28.

Perform the post-install tasks to 
configure HP SH Reporter. See 
Configuring HP SH Reporter on page 43.

Select and install the Content Packs. See 
Selecting and Installing the Content 
Packs on page 69.

Set up data collection. See Setting Up HP 
SH Reporter for Data Collection on 
page 77.

Validate the installation. See Validating 
Your Installation on page 123.

Start

Stop
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Installation Media

The installation media for HP SH Reporter includes the HP Service Health 
Reporter 9.10 Windows Installation files, Sybase IQ 15.2 ESD 2, SAP 
BusinessObjects XI 3.1 Service Pack 3 (SP3), MySQL 5.1, and the Content 
Packs. The installation media also includes the Xcelsius installation files.

HP SH Reporter Documentation Set

The following is a list of manuals in the HP SH Reporter document set:

• Concepts Guide (in PDF format)

• Installation and Configuration Guide (in PDF format)

• Online Help for Administrators (in HTML format)

• Online Help for Users (in HTML format)

• Handbook of Reports (in PDF format)

• Release Notes (in HTML format)

• Troubleshooting Guide (in PDF and HTML format)

The PDF manuals, including the Release Notes, are located in the 
Documentation directory on your installation media. After installation, the 
manuals will be available in the  
<Installation_Directory>\PMDB\Documentation folder. 

In this instance, <Installation_Directory> is the location where you install HP 
SH Reporter.

You can also open these documents by clicking Start → Programs → HP Software 
→ SH Reporter → Documentation.

To check for recent updates or to verify that you are using the most recent 
edition, visit this URL: http://h20230.www2.hp.com/selfsolve/manuals.
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2 Installation Prerequisites
Hardware Requirements

Component Minimum Required

Processor type 2.00 GHz or higher (x64-bit) Intel Xeon 
or equivalent

Number of CPUs 4

Physical memory 8 GB of RAM

Swap space System managed size

Temporary disk space 100 MB

Free disk space on the drive 
where HP SH Reporter is being 
installed:
• For installing HP SH 

Reporter
• For installing SAP 

BusinessObjects
• For installing Sybase IQ data 

files

15 GB

10 GB

16 GB

Free disk space on C drive (if HP 
SH Reporter is installed on a 
drive other than the C drive)

5 GB
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Software Requirements
 

If you are installing Sybase IQ on a separate drive, it will require 16 GB of 
free space. The other minimum hardware requirements, such as CPU and 
memory, for the Sybase IQ system is the same as that for the machine on 
which you are installing HP SH Reporter, which is given in the Hardware 
Requirements table.

The hardware requirements are the minimum required to install HP SH 
Reporter in your environment. For information about the hardware 
requirements for running HP SH Reporter in specific deployment scenarios, 
see the HP Service Health Reporter Performance and Configuration Guide.

Component Version

Supported operating systems • Microsoft Windows Server 2008 x64 
Enterprise Edition with Service Pack 
2

• Microsoft Windows Server 2003 x64 
Enterprise Edition with Service Pack 
2

• Microsoft Windows Server 2008 R2 
x64 Enterprise Edition with Service 
Pack 1

Web browser • Internet Explorer 7.0
• Internet Explorer 8.0
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Hardware and Software Requirement for Installing 
Xcelsius 2008

Operating System Requirements

Before you can install HP SH Reporter, you must update your operating 
system software, establish network connectivity, and disable anti-virus 
software.

Task 1: Update the Operating System Software

Install all the required Windows operating system patches. Contact your HP 
sales representative for the most recent list of patches.

Component Version

Processor type 1.0 GHz processor

Physical memory 1 GB of RAM

Disk space 350 MB

Operating system The following operating systems are 
supported:
• Microsoft Windows XP
• Microsoft Windows Server 2003
• Microsoft Windows Vista

Software The following versions of Microsoft Office 
are supported:
• Microsoft Office 2003
• Microsoft Office XP
• Microsoft Office 2007
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If you are installing HP SH Reporter on the Windows Server 2003 x64 SP2 
operating system, you must:

• Install Microsoft .NET Framework 2.0 for x64-bit.

• Install the Window Server 2003 x64 update (KB925336).

Installing Microsoft .NET Framework 2.0

Perform the following steps:

1 Log on to the host system as administrator.

2 Click Start → Programs → Internet Explorer. Internet Explorer opens.

3 Type the following URL in the Address bar to open the Microsoft 
Download Center web site:

http://www.microsoft.com/downloads/
details.aspx?FamilyID=B44A0000-ACF8-4FA1-AFFB-40E78D788B0
0&displaylang=en

4 Click Download to download the .NET Framework version 2.0 (x64) 
redistributable package.

5 After the download completes, browse to the location where the file was 
downloaded, and then double-click the NetFx64.exe setup file. The 
Microsoft .NET Framework 2.0 (x64) Setup wizard opens.

6 On the Welcome to Microsoft .NET Framework 2.0 (x64) Setup page, click 
Next to continue. The End-User License Agreement page opens.

7 After reviewing the license agreement, select the I accept the terms of the 
License Agreement check box and click Install. The Installing components 
page opens.

If you are installing HP SH Reporter on the French version of the Windows 
Server 2003 x64 SP2 operating system, in addition to the patches, you must 
install the WindowsServer2003.WindowsXP-KB971812-x64-FRA.exe 
patch file as well.

If you are installing on a Windows Server 2008 system, you do not need to 
install these patches because they are bundled with the operating system.

The URL must be typed out as a single line without any spaces.
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8 After the installation completes, the Setup Complete page opens. Click 
Finish to complete the installation.

Installing the Windows Server 2003 x64 update

Perform the following steps:

1 Log on to the host system as administrator.

2 Click Start → Programs → Internet Explorer. Internet Explorer opens.

3 Type the following URL in the Address bar to open the Microsoft 
Download Center web site:

http://www.microsoft.com/downloads/
details.aspx?FamilyId=4BBC5917-C1AC-402C-86D9-0A8E3B9921F
F&displaylang=en

4 Click Download to download the update.

5 After the download completes, browse to the location where the file was 
downloaded, and then double-click the 
WindowsServer2003.WindowsXP-KB925336-x64-ENU.exe setup file 
to install an operating system update. The Hotfix for Windows x64 
(KB925336) wizard opens.

6 Click Next to continue. The License Agreement page opens.

7 Review the license agreement, select I Agree, and then click Next to 
continue. The Updating Your System page opens.

8 Click Finish to complete the installation.

9 Restart your system.

The URL must be typed out as a single line without any spaces.
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Task 2: Identify Ports for Network Connectivity

The HP SH Reporter database, which is used to store all the 
performance-related data of the IT elements in your environment, uses a 
number of default ports for its different services.

Task 3: Disable Anti-Virus

Anti-virus applications can hinder the installation of HP SH Reporter. During 
the installation process, the anti-virus software might detect the Visual Basic 
scripts running as a part of the installation as viruses and halt the 
installation process.

Therefore, temporarily disable any antivirus software that might be running.

Service Default Port Number

HP SH Reporter Message Broker 21401

HP SH Reporter DB Logger Service 21408

HP SH Reporter Collection Service 21409

HP SH Reporter IM Service 21410

HP SH Reporter Timer No port

HP SH Reporter 21411

HP SH Reporter Sybase Service 21424

Sybase IQ Agent 15.2 21423

MySQL 3306

Apache Tomcat 5.5.20 (SAP BOBJ 
Application Service)

8080

Server Intelligence Agent 
(HOML01GEATON)

6400

If you are using a firewall software, you must open the HP SH Reporter ports 
in the firewall. For instructions, see your firewall documentation.
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To temporarily disable the anti-virus application:

1 On the system tray, right-click the icon for the respective anti-virus 
installed on your system.

2 From the pop-up menu, either select the option to disable the anti-virus, if 
available, or select Properties. The Properties window opens.

3 Click the option to disable the anti-virus.

After you finish installing HP SH Reporter, re-enable the anti-virus software.

Task 4: Verify the Fully Qualified Domain Name (FQDN) of the 
system

Before performing the HP SH Reporter installation, you must verify that DNS 
lookup returns the accurate FQDN of the host system. If the entry for the 
DNS lookup is different from the host name of the system, this can result in 
login failure on the Administration Console. This can occur because during the 
SAP BOBJ installation, the host name of the system is used for creating the 
servers/services and registering them.

To verify the FQDN of the host system, follow these steps:

1 Click Start → Run. The Run dialog box opens.

2 Type cmd in the Open field, and then press ENTER. The Command Prompt 
window opens.

3 Type the following command to check the host name of the system:

hostname

Note the host name of the system.

4 Type the following command to view the IP address of the system:

ipconfig

5 Type the following command to verify the FQDN for the displayed IP 
address:

nslookup <IP address>

where <IP address> is the IP address of the host system.
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Ensure that the name displayed after running the DNS Lookup command 
matches the name displayed after running the HOSTNAME command. If the 
names do not match, you must change the host name of the system.

Web Browser Requirements

To view the HP SH Reporter Administration Console in Internet Explorer 7.x 
and 8.x, you must enable the ActiveX and the JavaScript controls.

Task 1: Enable ActiveX Controls

Perform the following steps to enable ActiveX controls in Internet Explorer 
7.x/8.x:

1 Open Internet Explorer.

2 Click Tools → Internet Options. The Internet Options dialog box opens.

3 On the Security tab, click the Custom level button.

4 Scroll down to the ActiveX controls and plug-ins section.

5 Select the Enable option for all the available options under ActiveX 
controls and plug-ins.

6 Click OK.

7 Click Yes in the Warning message box.

8 Click Apply and then click OK.

Task 2: Enable JavaScript Controls

Perform the following steps to enable JavaScript controls in Internet Explorer 
7.x/8.x:

1 Open Internet Explorer.

2 Click Tools → Internet Options. The Internet Options dialog box opens.

3 On the Security tab, click the Custom level button.

4 Scroll down to the Scripting section.
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5 Select the Enable option for all the available options under Scripting.

6 Click OK.

7 Click Yes in the Warning message box.

8 Click Apply and then click OK.
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3 Installing HP SH Reporter
Preinstallation Checklist

Before you proceed with the installation of HP SH Reporter, make sure that 
the following tasks were completed.

You have the required 
installation media.

See Installation Media on page 16.

Your hardware meets the 
requirements for HP SH 
Reporter.

See Hardware Requirements on 
page 17.

You are using the operating 
system and web browser that 
supports HP SH Reporter.

See Software Requirements on 
page 18.

You installed the required 
patches for your operating 
system.

See Task 1: Update the Operating 
System Software on page 19.

You identified port numbers for 
network and client connectivity.

See Task 2: Identify Ports for 
Network Connectivity on page 22.

You disabled all anti-virus 
applications that might hinder 
the installation of HP SH 
Reporter.

See Task 3: Disable Anti-Virus on 
page 22.

You verified the FQDN of the 
host system where you want to 
install HP SH Reporter.

See Task 4: Verify the Fully Qualified 
Domain Name (FQDN) of the system 
on page 23.

You enabled the necessary 
controls for your web browser.

See Web Browser Requirements on 
page 24.
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Installation Steps

To install HP SH Reporter:

1 Log on to the host system. You must have Administrator privileges.

2 Perform any of following steps to start the installation process:

— To install HP SH Reporter by using the installation media, insert the 
HP SH Reporter DVD. The Autorun feature automatically starts the 
HP Software Installer. 

— To install HP SH Reporter by using the installation files downloaded 
from the HP web site, double-click the HP-SHR_9.10_setup.exe file.

You made sure that the system 
date is the current date.

If you change the system date after 
installing HP SH Reporter, make 
sure that you restart all the HP SH 
Reporter services.

You made sure that HP SH 
Reporter is not already installed 
in the system.

If HP SH Reporter exists on the 
system, uninstall it first before 
proceeding with the installation. For 
the uninstallation steps, see 
Uninstalling HP SH Reporter on 
page 139.

If you planned for a remote 
Sybase IQ installation, you made 
sure that Sybase IQ is not 
already installed on the remote 
system.

If Sybase IQ exists on the remote 
system, uninstall it first before 
proceeding with the installation. For 
the uninstallation steps, see 
Uninstalling Remote Sybase IQ on 
page 141.

Installation of HP SH Reporter over the network is not supported. 
This is because of the large size of the installation files, which 
would require a very high network bandwidth to perform the 
installation.
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HP Software Installer checks the system for any applications or services 
that might hinder the installation of HP SH Reporter. If HP Software 
Installer detects a hindrance, the Application requirements check 
warnings window opens.

3 View the details and resolve or ignore the error or warning:

a Click the specific warning or error to view the details.

b Resolve or ignore the error or warning as described in the details:

– Click Quit to quit the installation and resolve the error.

– Click Continue to ignore the warning and continue the installation

The Introduction (Install) page opens. 

The Introduction (Install) page displays the media location—the location 
of the installation files—and the location of the installation log file.

4 Review the introduction and click Next to continue. The License 
Agreement page opens.

Installation of HP SH Reporter during the changing of the system 
time to Daylight Saving Time (DST) settings is not supported. You 
can install the product either before or after you make the 
necessary DST setting changes.

If this is not your first installation of HP SH Reporter, HP 
Software Installer will prompt you to use the installation 
configuration file, which was created during the initial 
installation. Click Yes in the Installer Configuration message 
box if you want to use the values from the file. Click No to 
continue without using the installation configuration file.
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5 Review the terms, select I accept the terms of the License Agreement, and 
then click Next to continue. The Select Group page opens.

6 Select one of the following options based on your requirements:

— Select the Install HP SH Reporter with Sybase IQ database option if you 
want to install Sybase IQ on the same system as HP SH Reporter.

— Select the Install HP SH Reporter without Sybase IQ database option if you 
want to install Sybase IQ on the remote system. For the steps to 
perform remote Sybase IQ installation, see Remote Installation of 
Sybase IQ on page 36.

HP SH Reporter and remote Sybase IQ cannot be installed on the 
same system.
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Click Next. The Choose the application and data folders page opens.

HP Software Installer checks the system for other installed HP products:

• If other HP products are not installed, the application files for the 
shared HP content are installed in the default folder, 
%OvInstallDir%.

• The common HP software data files are installed in the default folder, 
%OvDataDir%.

• The default install location for HP SH Reporter is C:\HP-SHR\.

7 Accept the default location, or specify a location to install HP SH 
Reporter:

• Click Next to accept the default location and continue the installation.

If any of the HP Software products are installed in the system, HP 
SH Reporter will not ask for install directory for shared 
components.

If HP Business Service Management is installed in the system, HP 
SH Reporter will not ask for the product-specific install directory.
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• Click Browse to select or specify a location, and click Next to continue 
the installation. Make sure that the path does not contain spaces or 
special characters.

• Click Reset to reset the specified locations to the default states.

The Install Checks page opens. HP Software Installer checks the system 
for available disk space and if Sybase IQ, SAP BusinessObjects 
Enterprise, the operating system patch, and .NET Framework 2.0 are 
installed in the system. HP Software Installer validates the product 
install path and also checks for port availability.

8 Review the install check details:

• If the install check fails, click Cancel to stop the installation. See 
Hardware Requirements on page 17 to ensure that the necessary disk 
space is available before proceeding with the installation of HP SH 
Reporter. See Task 3: Disable Anti-Virus on page 22 to resolve 
port-related issues.

• If the install check is successful, click Next to continue.
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HP Software Installer summarizes the HP SH Reporter components, 
application, and data folder location information. The Pre-Install 
Summary page opens.

9 Review the preinstall summary and click Install to continue. The Installing 
page and the SAP BOBJ Install drive dialog box opens.

Once you click the Install button, there is no way to cancel the 
installation. You will have to wait for the installation to complete 
and then uninstall HP SH Reporter, if required. The Rollback 
option is not supported in HP SH Reporter.
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10 Specify the drive where you want to install SAP BusinessObjects in the 
SAP BOBJ Install drive dialog box, and then click OK.
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After the installation completes, HP Software Installer summarizes the 
HP SH Reporter installation details. The Installation Complete page 
opens.

11 Review the post-install details on the Summary and Details tabs. 

12 Click View log file to view the installation log file.

You can use the log file to review the entire installation process and 
troubleshoot any specific issue.

13 Click Done to complete the HP SH Reporter installation.
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If you have not installed Sybase IQ with HP SH Reporter, proceed to the 
remote installation of Sybase IQ.

Remote Installation of Sybase IQ

A typical installation of HP SH Reporter installs the Sybase IQ server and 
client on the same host system along with the HP SH Reporter application. 
However, HP SH Reporter also provides you with an option to remotely install 
the Sybase IQ server on a separate server. In this type of installation, only the 
Sybase IQ client is installed with HP SH Reporter on the host system.

To remotely install Sybase IQ:

1 Log on to the remote system. You must have Administrator privileges.

2 Open the HP Service Health Reporter installation media and browse to 
the location of the Sybase IQ installation files.

3 Double-click the HP-SHR-SybaseIQ_9.10_setup.exe file. The HP 
Software Install Launcher runs and the HP Software Installer window 
opens.

After completing the installation, you may notice that the following HP SH 
Reporter services appear disabled:

• HP SH Reporter Collection Service

• HP SH Reporter DB Logger Service

• HP SH Reporter IM Service

• HP SH Reporter Timer

By default, these services are disabled by the HP Software Installer and will 
automatically be enabled after you perform the post-install configuration 
tasks. The disabled services does not indicate any error in the installation 
process.

The remote Sybase IQ server must be installed before performing the 
post-install configuration tasks on the HP SH Reporter machine.
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HP Software Installer checks the system for any applications or services 
that might hinder the installation of HP SH Reporter. If HP Software 
Installer detects a hindrance, the Application requirements check 
warnings window opens.

4 View the details and resolve or ignore the error or warning:

a Click the specific warning or error to view the details.

b Resolve or ignore the error or warning as described in the details:

– Click Quit to quit the installation and resolve the error.

– Click Continue to ignore the warning and continue the installation

The Introduction (Install) page opens. 

The Introduction (Install) page displays the media location—the location 
of the Sybase IQ installation files—and the location of the installation log 
file.

5 Review the introduction and click Next to continue. The License 
Agreement page opens.
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6 Review the terms, select I accept the terms of the License Agreement, and 
then click Next to continue. The Choose the application and data folders 
page opens.

7 Accept the default location, or specify a location to install Sybase IQ:

• Click Next to accept the default location and continue the installation.

• Click Browse to select or specify a location, and click Next to continue 
the installation.

• Click Reset to reset the specified locations to the default states.
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The Install Checks page opens. HP Software Installer checks the system 
for available disk space and if HP SH Reporter is installed on the system, 
It also validates the install path and check for port availability.

8 Review the install check details:

• If the install check fails, click Cancel to stop the installation. See 
Hardware Requirements on page 17 to ensure that the necessary disk 
space is available before proceeding with the installation of Sybase IQ. 
If the install check is successful, click Next to continue.
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HP Software Installer summarizes the Sybase IQ components, 
application, and data folder location information. The Pre-Install 
Summary page opens.

9 Review the preinstall summary and click Install to continue. The Installing 
page opens.

After the installation completes, HP Software Installer summarizes the 
Sybase IQ installation details. The Installation Complete page opens.

10 Review the post-install details on the Summary and Details tabs. 

11 Click View log file to view the installation log file.

You can use the log file to review the entire installation process and 
troubleshoot any specific issue.

12 Click Done to complete the Sybase IQ installation.
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Installing Xcelsius (Optional)

An Xcelsius report is an interactive Flash-based report created by using the 
SAP BusinessObjects Xcelsius Enterprise tool. The Xcelsius reports available 
in HP SH Reporter are mostly short-term reports with interactivity. These 
reports typically display data from different domains at one place for a quick 
view.

For more information about Xcelsius reports, see the HP Service Health 
Reporter Concepts Guide Chapter 4, Types of Reports.

If you want to customize the Xcelsius Flash-based reports in HP SH Reporter, 
you must install the Xcelsius 2008 application, which is included in the HP 
SH Reporter installation media. Xcelsius 2008 is not required for viewing the 
reports. Therefore, this installation is optional.

Perform the following steps:

1 Copy the Excelsius_2.00.166_DVD-2.zip file from the installation 
media packages folder to a location of your choice.

2 Extract the file.

3 Click Start → Run. The Run dialog box opens.

4 Type cmd and press ENTER to open the Command Prompt window.

5 At the command prompt, type the following command to open the 
directory that contains the Xcelsius command:

cd <extracted file 
path>\IT_Analytics_2.00\DVD-2\IT_Analytics_2.00\Setup\BO 
Installers\xcelsius

In this instance, <extracted file path> is the location where you extracted 
the Xcelsius setup files.

6 At the command prompt, type the following command to install Xcelsius:

install-xcelsius.bat -installdir “<installation directory>”

Xcelsius requires Microsoft Excel as a base for it to work.

This command must be typed as a single line. 
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In this instance, <installation directory> is the location where you want 
to install the Xcelsius files.

7 Close the Command Prompt window.

Proceed to the post-install configuration tasks.
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4 Configuring HP SH Reporter
You must perform all the configuration tasks described in this chapter 
immediately after installing HP SH Reporter, but before you install the 
Content Packs.

The post-install configurations tasks are organized into the following two 
categories:

• If you installed HP SH Reporter with Sybase IQ, proceed to Post-install 
Configuration Tasks in HP SH Reporter with Sybase IQ on page 43.

• If you installed HP SH Reporter with remote Sybase IQ, proceed to 
Post-install Configuration Tasks in HP SH Reporter with Remote Sybase 
IQ on page 54.

After performing the post-install configuration tasks, proceed to Configuring 
the Desktop Heap Memory on page 68.

Post-install Configuration Tasks in HP SH Reporter with 
Sybase IQ

The following flowchart gives you an overview of the post-install tasks for HP 
SH Reporter.
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Click the links provided in the flowchart to see the relevant sections 
mentioned.

Start

Stop

HPOM

   

Is the
installation for

Operations Bridge/APM
or HPOM deployment

scenario?

SaOB

APM

Task 1: Configure HP SH 
Reporter for Multiple Profile 
Database Support on page 45

Task 2: Start the Administration 
Console on page 46.

Task 3: Configure the Database 
Connection on page 47

Task 4: Create the Database 
Schema on page 49

Task 5: Create the Management 
Database User Account on page 51

Task 6: Verify the Sybase IQ 
License Type on page 52
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Task 1: Configure HP SH Reporter for Multiple Profile Database 
Support

You need to perform this task if HP SH Reporter is installed in the 
deployment scenario where RTSM is the topology source.

HP SH Reporter supports the configuration of and data collection from 
multiple Profile databases that are deployed in your HP Business Service 
Management environment. 

However, to ensure that HP SH Reporter identifies and displays all the 
existing Profile databases in the Administration Console, perform the 
following steps:

1 Log on to the HP Business Service Management host system through 
remote access.

2 Browse to the %topaz_home%\Conf folder.

3 Copy the following files from the %topaz_home%\Conf folder to the 
%PMDB_HOME%\config folder on the HP SH Reporter system:

— encryption.properties

— seed.properties

After copying the files, you need to start the HP SH Reporter Service. Perform 
the following steps:

1 On the HP SH Reporter system, click Start → Run. The Run dialog box 
opens.

2 In the Open field, type services.msc. The Services window opens.

3 On the right pane, right-click HP SH Reporter Service, and then click Start.

4 Close the Services window.

If 

 If HP SH Reporter is installed in an HPOM deployment scenario, proceed 
directly to the next task.

If your HP Business Service Management setup is distributed 
where the gateway and data processing servers are separate 
entities, you need to access the data processing server.
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Task 2: Start the Administration Console

Perform the following steps:

1 Click Start → Programs → HP Software → SH Reporter → Administration. The 
HP SH Reporter Administration Console opens.

2 Type administrator in the Login Name field and click Log In to 
continue. The HP Service Health Reporter Configuration Wizard opens.

You can also access the Administration Console directly by typing 
the HP SH Reporter address in a web browser. The default address 
is http://<server name>.<domain name>:21411/BSMRApp/ 
where <server name> is the name of the host system on which you 
have installed HP SH Reporter and <domain name> is the name of 
your domain according to your network configuration.

The post-install HP Service Health Reporter Configuration Wizard 
appears only if you did not complete the post-install configuration 
tasks. The Wizard supports session state persistence, which 
enables you to resume and continue a previously-interrupted 
configuration session.
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Task 3: Configure the Database Connection

On the Configure Database Connection page, provide the details of the 
database server where you want to create a database for HP SH Reporter.
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To configure a database connection:

1 Under Enter Database Connection Parameter, type the following 
values:

2 Under Enter Database User (DBA Privilege) and Password, type the 
following values:

3 Under Choose Password For PMDB Database User 
(PMDB_ADMIN), type the following values:

Host name - Name or IP address of the host where the Sybase IQ 
database server is running.

Port - Port number to query the database server. The 
default port is 21424.

Server name - Name of the Sybase IQ server. Ensure that the 
Sybase IQ server name is unique across the subnet.

The server name displayed in this field is only for 
informational purposes. You must not change the 
server name at any time.

User name - Name of the Sybase IQ database user. The user 
must have DBA privileges. The default user name is 
dba.

Password - Password of the database user. The default 
password is sql.

It is recommended that you change the default 
password before proceeding with the post-install 
configuration tasks. To change the password, see the 
Sybase IQ documentation.

Admin Password - Password of the database administrator.

Confirm Admin 
Password

- Retype the same password to confirm it.
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4 Click Next. The Create Database Schema page opens.

Task 4: Create the Database Schema

On the Create Database Schema page, specify the database deployment size, 
that is, the number of nodes from which HP SH Reporter will collect data. 
Based on your selection, HP SH Reporter calculates and displays the 
recommended database size.

To create the database schema:

1 Under Select Deployment Size, select one of the following data volumes 
based on your requirements.

Low Volume - This option enables HP SH Reporter to support data 
collection from less than 500 nodes.

Medium Volume - This option enables HP SH Reporter to support data 
collection from 500 to 5000 nodes.
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2 Under Recommended IQ Configuration, type the following values:

3 In the Database File Location field, type the location where the 
database files will be stored; for example, C:\HP-SHR\Sybase\db.

4 Click Next. A confirmation dialog box opens.

5 Click Yes. If the database connection and schema creation is successful, a 
confirmation page opens with the schema creation status. If the database 
connection and schema creation fails, click the Previous button to check 
the values provided.

IQ Main 
Cache(MB)

- The recommended size of the main buffer cache for 
the Sybase IQ main store. This value is set by 
default.

IQ Temporary 
Cache(MB)

- The recommended size of the temporary buffer size 
for the Sybase IQ temporary store. This value is set 
by default.

IQ DBSpace Size 
(MB)

- The recommended size for the IQ_System_Main 
dbspace, which stores the main database files. This 
size can be modified.

IQ Temporary 
DBSpace 
Size(MB)

- The recommended size for the IQ_System_Temp 
dbspace, which stores the temporary database files. 
This size can be modified.

Ensure that you have sufficient system resources to support the HP 
SH Reporter data collection volume that you select. For information 
about the resource requirements for the selected volume, see the 
HP Service Health Reporter Support Matrix at http://
support.openview.hp.com/sc/support_matrices.jsp.
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6 Review the database connection and schema creation details and click 
Next. The Create Management Database page opens.

Task 5: Create the Management Database User Account

The management database refers to the online transaction processing (OLTP) 
store used by HP SH Reporter to store its run-time data such as data process 
job stream status, changed tables status, and node information.

On the Create Management Database page, provide the user details for the 
management database.
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To create the management database user account:

1 Under HP SH Reporter Management Database User Information, 
type the following values:

2 Click Next. The Summary page opens.

3 Review the database connection and management database details and 
then click Finish to complete the post-install configuration tasks.

4 Reboot your system to ensure that the dependency between HP SH 
Reporter Collection Service and HP SH Reporter Message Broker Service 
takes effect.

Task 6: Verify the Sybase IQ License Type

If Sybase IQ is installed on a system that uses the Intel EM64T processor, you 
must verify the Sybase IQ license type in the pmdb.lmp file. If the license type 
is not the OEM CPU License, it causes the Sybase IQ license to expire after 
one month and the database stops working.

Follow these steps:

1 Browse to the location where the database files are stored. This is location 
you specified in step 3 on page 50.

2 Open the pmdb.lmp file in an Text Editor.

3 Verify the license type, LT=AC. If the value of LT is not AC, change it to AC.

4 Save the changes and close the file.

After you change the license type in the pmdb.lmp file, you must restart the 
database. Follow these steps:

1 Click Start → Run. The Run dialog box opens.

2 Type services.msc in the Open field, and then press ENTER. The 
Services window opens.

3 On the right pane, right-click the HP SH Reporter Sybase IQ service, and 
then click Restart.

New Password - Password of the management database user.

Confirm New 
Password

- Retype the same password to confirm it.
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Proceed to installing the Content Packs.
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Post-install Configuration Tasks in HP SH Reporter with 
Remote Sybase IQ

The following flowchart gives you an overview of the post-install tasks for HP 
SH Reporter. Click the links provided in the flowchart to see the relevant 
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sections mentioned.

Start

Stop
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installation for
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or HPOM deployment

scenario?

SaOB

APM

Task 3: Start the Administration 
Console on page 58

Task 4: Configure the Database 
Connection on page 59

Task 5: Create the Database 
Schema on page 61

Task 6: Restart the Sybase IQ 
Database on page 63

Task 7: Create the Management 
Database User Account on page 66

Task 1: Start the Sybase IQ 
Database on page 56

Task 2: Configure HP SH 
Reporter for Multiple Profile 
Database Support on page 56

Task 8: Verify the Sybase IQ 
License Type on page 67
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Task 1: Start the Sybase IQ Database

Perform the following steps:

1 Log on to the remote system. You must have Administrator privileges.

2 Click Start → Run. The Run dialog box opens.

3 Type cmd and press ENTER to open the Command Prompt window.

4 At the command prompt, type the following command to start the Sybase 
IQ database:

start_iq @<SHR_home>\Sybase\IQ-15_2\scripts\pmdbConfig.cfg

In this instance, <SHR_home> refers to the install directory of HP SH 
Reporter.

5 Press ENTER. The Starting IQ window opens.

6 Close the command prompt window.

Task 2: Configure HP SH Reporter for Multiple Profile Database 
Support

You need to perform this task if HP SH Reporter is installed in the 
deployment scenario where RTSM is the topology source.

You can stop Sybase IQ from running by right-clicking the Sybase IQ server 
icon in the notification bar and selecting the option from the pop-up menu.

If the Sybase IQ server icon does not appear in the notification bar of your HP 
SH Reporter system, use the following command to stop Sybase IQ:

dbstop -y -c uid=dba;pwd=sql;eng=<server engine 
name>;dbn=utility_db;links=tcpip{host=<host name>.<domain 
name>;port=21424}

In this instance, <server engine name> refer to the name of the Sybase server 
engine, <host name> refers to the name of the system hosting the HP SH 
Reporter database and <domain name> is the name of your domain according 
to your network configuration.

This command must be typed as a single line.
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HP SH Reporter supports the configuration of and data collection from 
multiple Profile databases that are deployed in your HP Business Service 
Management environment. 

However, to ensure that HP SH Reporter identifies and displays all the 
existing Profile databases in the Administration Console, perform the 
following steps:

1 Log on to the HP Business Service Management host system through 
remote access.

2 Browse to the %topaz_home%\Conf folder.

3 Copy the following files from the %topaz_home%\Conf folder to the  
%PMDB_HOME%\config folder on the HP SH Reporter system:

— encryption.properties

— seed.properties

After copying the files, you need to start the HP SH Reporter Service. Perform 
the following steps:

1 On the HP SH Reporter system, click Start → Run. The Run dialog box 
opens.

2 In the Open field, type services.msc. The Services window opens.

3 On the right pane, right-click HP SH Reporter Service, and then click Start.

4 Close the Services window.

If 

 If HP SH Reporter is installed in an HPOM deployment scenario, proceed 
directly to the next task.

If your HP Business Service Management setup is distributed 
where the gateway and data processing servers are separate 
entities, you need to access the data processing server.
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Task 3: Start the Administration Console

Perform the following steps:

1 Click Start → Programs → HP Software → SH Reporter → Administration. The 
HP SH Reporter Administration Console opens.

2 Type administrator in the Login Name field and click Log In to 
continue. The HP Service Health Reporter Configuration Wizard opens.

You can also access the Administration Console directly by typing 
the HP SH Reporter address in a web browser. The default address 
is http://<server name>.<domain name>:21411/BSMRApp/ 
where <server name> is the name of the host system on which you 
have installed HP SH Reporter and <domain name> is the name of 
your domain according to your network configuration.

The post-install HP Service Health Reporter Configuration Wizard 
appears only if you did not complete the post-install configuration 
tasks. The Wizard supports session state persistence, which 
enables you to resume and continue a previously-interrupted 
configuration session.
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Task 4: Configure the Database Connection

On the Configure Database Connection page, provide the details of the 
database server where you want to create a database for HP SH Reporter.

To configure a database connection:

1 On the Configure Database Connection page, select Remote Database.
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2 Under Enter Database Connection Parameter, type the following 
values:

3 Under Enter Database User (DBA Privilege) and Password, type the 
following values:

4 Under Choose Password For PMDB Database User 
(PMDB_ADMIN), type the following values:

Host name - Name or IP address of the host where the Sybase IQ 
database server is running.

Port - Port number to query the database server. The 
default port is 21424.

Server name - Name of the Sybase IQ server. Ensure that the 
Sybase IQ server name is unique across the subnet.

The server name displayed in this field is only for 
informational purposes. You must not change the 
server name at any time.

User name - Name of the Sybase IQ database user. The user 
must have DBA privileges. The default user name is 
dba.

Password - Password of the database user. The default 
password is sql.

It is recommended that you change the default 
password before proceeding with the post-install 
configuration tasks. To change the password, see the 
Sybase IQ documentation.

Admin Password - Password of the database administrator.

Confirm Admin 
Password

- Retype the same password to confirm it.
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5 Click Next. The Create Database Schema page opens.

Task 5: Create the Database Schema

On the Create Database Schema page, specify the database deployment size, 
that is, the number of nodes from which HP SH Reporter will collect data. 
Based on your selection, HP SH Reporter calculates and displays the 
recommended database size.

To create the database schema:

1 Under Select Deployment Size, select one of the following data volumes 
based on your requirements.

Low Volume - This option enables HP SH Reporter to support data 
collection from less than 500 nodes.

Medium Volume - This option enables HP SH Reporter to support data 
collection from 500 to 5000 nodes.
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2 Under Recommended IQ Configuration, type the following values:

3 In the Database File Location field, type the location where the 
database files will be stored; for example, C:\HP-SHR\Sybase\db. Create 
the database folder before typing the path in the Database File Location 
field.

4 Click Next. A confirmation dialog box opens.

You are prompted to validate the existence of the database folder on the 
remote database host machine.

IQ Main 
Cache(MB)

- The recommended size of the main buffer cache for 
the Sybase IQ main store. This value is set by 
default.

IQ Temporary 
Cache(MB)

- The recommended size of the temporary buffer size 
for the Sybase IQ temporary store. This value is set 
by default.

IQ DBSpace Size 
(MB)

- The recommended size for the IQ_System_Main 
dbspace, which stores the main database files. This 
size can be modified.

IQ Temporary 
DBSpace 
Size(MB)

- The recommended size for the IQ_System_Temp 
dbspace, which stores the temporary database files. 
This size can be modified.

Ensure that you have sufficient system resources to support the HP 
SH Reporter data collection volume that you select. For information 
about the resource requirements for the selected volume, see the 
HP Service Health Reporter Support Matrix at http://
support.openview.hp.com/sc/support_matrices.jsp.
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5 Click Yes. If the database connection and schema creation is successful, a 
confirmation page opens with the schema creation status.

You are prompted to copy the newly created pmdbConfig.cfg file to the 
remote system and then restart the database.

If the database connection and schema creation fails, click the Previous 
button to check the values provided.

Task 6: Restart the Sybase IQ Database

For this task, you must first stop the Sybase IQ database from running. Then, 
using the Sybase IQ Service Manager, you must create a Sybase IQ service. 
Using this service, you can then restart the Sybase IQ database.

Perform the following steps:

1 Browse to the newly created database folder and copy the 
pmdbConfig.cfg file to the remote system.

2 Click Start → Run. The Run dialog box opens.
Configuring HP SH Reporter 63



3 Type cmd and press ENTER to open the Command Prompt window.

4 At the command prompt, type the following command to stop the Sybase 
IQ database and then press ENTER:

dbstop -y -c uid=dba;pwd=sql;eng=<server engine 
name>;dbn=utility_db;links=tcpip{host=<host name>.<domain 
name>;port=21424}

In this instance, <server engine name> refers to the name of the Sybase 
server engine, <host name> refers to the name of the system hosting the 
HP SH Reporter database and <domain name> is the name of your 
domain according to your network configuration.

You can also right-click the Sybase IQ server icon in the notification bar 
and stop the database from the menu.

Create a Sybase IQ Service

Running Sybase IQ as a Windows service lets you start a server automatically 
whenever the machine is booted and run in the background as long as 
Windows is running.

To create the Sybase IQ service:

1 Click Start → Programs → Sybase → Sybase 15.2 → Sybase IQ Service 
Manager. The Configure IQ as an NT Service window opens.

2 Click Create a New Service.

This command must be typed as a single line.
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3 In the Service Name field, type the name of the remote Sybase IQ server.

4 In the Startup Parameters field, type all the parameters that are listed 
in the pmdbConfig.cfg file.

5 Browse to %IQDIR15%\scripts and open the pmdbConfig.cfg file. 
Copy all the listed parameters in the file to the Startup Parameters 
field:

-n <server name> <parameters> <database file path>

In this instance, <server name> is the name of the remote Sybase IQ 
server, <parameters> are all the parameters that are present in the 
pmdbConfig.cfg file, and <database file path> is the location of the 
database files on the remote server.

For example, the startup parameters might look like this:

-n testserver1 -x tcpip{port=21424} -c 48m -gc 20 -gd all 
-gl all -gm 100 -gp 4096 -iqmsgsz 100 -iqmsgnum 4 -iqmc 
1845 -iqtc 1430 -iqmt 3500 -ti 4400 -gn 25 
C:\sybaseIQ\db\pmdb.db

Include the full path to the database file. The server cannot start without 
a valid database path name.

6 Click Apply and then click OK.

Start the Sybase IQ Service

1 Click Start → Run. The Run dialog box opens.

2 Type services.msc in the Open field, and then press ENTER. The 
Services window opens.

3 On the right pane, right-click the newly created Sybase IQ service, and 
then click Start.
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4 On the HP SH Reporter host system, in the Administration Console, 
review the database connection and schema creation details and click 
Next. The Create Management Database page opens.

Task 7: Create the Management Database User Account

The management database refers to the online transaction processing (OLTP) 
store used by HP SH Reporter to store its run-time data such as data process 
job stream status, changed tables status, and node information.

On the Create Management Database page, provide the user details for the 
management database.
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To create the management database user account:

1 Under HP SH Reporter Management Database User Information, 
type the following values:

2 Click Next. The Summary page opens.

3 Review the database connection and management database details and 
then click Finish to complete the post-install configuration tasks.

4 Reboot your system to ensure that the dependency between HP SH 
Reporter Collection Service and HP SH Reporter Message Broker Service 
takes effect.

Task 8: Verify the Sybase IQ License Type

If Sybase IQ is installed on a system that uses the Intel EM64T processor, you 
must verify the Sybase IQ license type in the pmdb.lmp file. If the license type 
is not the OEM CPU License, it causes the Sybase IQ license to expire after 
one month and the database stops working.

Follow these steps:

1 Browse to the location where the database files are stored. This is location 
you specified in step 3 on page 62.

2 Open the pmdb.lmp file in an Text Editor.

3 Verify the license type, LT=AC. If the value of LT is not AC, change it to AC.

4 Save the changes and close the file.

After you change the license type in the pmdb.lmp file, you must restart the 
database. Follow these steps:

1 Click Start → Run. The Run dialog box opens.

2 Type services.msc in the Open field, and then press ENTER. The 
Services window opens.

3 On the right pane, right-click the newly created Sybase IQ service, and 
then click Restart.

New Password - Password of the management database user.

Confirm New 
Password

- Retype the same password to confirm it.
Configuring HP SH Reporter 67



Configuring the Desktop Heap Memory

Within a single user’s session, every desktop object has a desktop heap 
memory associated with it. The desktop heap stores certain user interface 
objects such as windows, menus, and hooks. Failures related to desktop heap 
can occur for the following reasons:

• If the session view space for a given session is fully utilized, a new desktop 
heap cannot be created.

• If an existing desktop heap allocation is fully utilized, it is impossible for 
threads that use that desktop to use more desktop heap.

Desktop heal exhaustion can prevent certain processes from starting or cause 
processes to fail. To avoid desktop heap usage issues, you must change the 
default value of the heap memory in the Registry Editor:

1 Click Start → Run. The Run dialog box opens.

2 Type regedit in the Open field, and then press ENTER. The Registry 
Editor window opens.

3 On the left pane, expand HKEY_LOCAL_MACHINE, expand SYSTEM, expand 
CurrentControlSet, expand Control, expand Session Manager, and then click 
SubSystems.

4 On the right pane, right-click Windows, and then click Modify. The Edit 
String dialog box opens.

5 In the Value data box, change the value ObjectDirectory=\Windows 
SharedSection=1024,20480,768 to ObjectDirectory=\Windows 
SharedSection=1024,20480,1536. 

6 Restart your system after making the changes in the Registry Editor.

Performing the above steps helps you avoid certain data processing stream 
failures (with Error Status Codes 128 or 832) in HP SH Reporter, which 
prevents the movement of data the stages of the collection framework—
aggregation, transformation, and staging.

Proceed to installing the Content Packs.
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5 Selecting and Installing the Content 
Packs
The Content Pack installation process involves installing the Content Packs 
common or core files and the domain-specific Content Packs. 

The core Content Packs provide a set of common features such as common 
schema, which can be reused or referred by other Content Packs. 

The Content Packs common files include:

• Core—This Content Pack provides the Core schema required by other 
Content Packs.

• CMDBCore—This Content Pack provides a common logical model used 
by other Content Packs.

• Core_BSM—This Content Pack provides core features required by other 
Business Service Management Application Content Packs.

To decide which Content Pack to install, you have to take into account your 
deployment scenario. The following table lists the various Content Packs and 
their supported deployment scenarios.

Content Pack HPOM

BSM Service 
and Operations 
Bridge

Application 
Performance 
Management

Active_Directory

Appserver_Weblogic

Appserver_WebSphere

BPM

Core_BSM

Database_MSSQL
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Database_Oracle

Exchange_Server

OM

OMi

Real_User_Monitor

System_Management_PA

System_Management_SiS

System_Management_SiS_Cod
a

Virtual_Environment_Manage
ment_PA

Virtual_Environment_Manage
ment_ESX_PA

Virtual_Environment_Manage
ment_ESX_SiS_Coda

Content Pack HPOM

BSM Service 
and Operations 
Bridge

Application 
Performance 
Management

The BPM and Real_User_Monitor Content Packs have dependencies on each 
other. Therefore, make sure that both are installed in your system even if only 
one of them is required.

The OM Content Pack is supported in the Application Performance 
Management deployment scenario only if HPOM coexists with the BSM 
platform. In this case, HP SH Reporter only collects Event data from HPOM.

The Application Performance Management deployment scenario does not 
support application-specific Content Packs such as Active_Directory, 
Appserver_Weblogic, Appserver_WebSphere, Database_MSSQL, 
Database_Oracle, Exchange_Server, and OMi. Similarly, the HPOM 
deployment scenario does not support APM-specific Content Packs such as 
Real_User_Monitor, BPM, and Core_BSM.
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For more information about the Content Pack dependencies and the supported 
products, see Appendix A.

For more information about each Content Pack and the reports provided by 
them, see the HP Service Health Reporter Online Help for Users.

Stopping the HP SH Reporter Data Processes

If you are installing the Content Packs as part of the initial installation of HP 
SH Reporter, proceed directly to the Content Pack installation tasks. 

However, if you are installing the Content Packs while HP SH Reporter is 
operational, make sure that the HP SH Reporter data processes are not 
running at the time of the Content Pack installation. This is because it 
becomes very difficult to ensure the desired state for required resources with 
data processes running. In addition, these data processes might cause the 
Content Pack installation to fail.

To ensure that data processes are not running:

1 Click Start → Run. The Run dialog box opens.

2 Type services.msc in the Open field, and then press ENTER. The 
Services window opens.

3 On the right pane, right-click HP SH Reporter Timer, and then click Stop.

4 Close the Services window.

5 Wait for all data processes that are currently running to complete. You can 
use the following command to monitor the progress of the processes:

abcMonitor -stream ID=ALL -step ID=ALL,state=RUNNING

When the abcMonitor command does not return any records, you are ready 
to proceed with the installation of the Content Packs.

Installing the Content Packs

Use the Package Manager utility to install the Content Packs. 
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To install the Content Packs:

1 Stop the HP SH Reporter Windows services:

a Click Start → Run. The Run dialog box opens.

b Type services.msc in the Open field, and then press ENTER. The 
Services window opens.

c On the right pane, right-click the following services, and then click 
Stop:

– HP SH Reporter Timer

– HP SH Reporter Collection Service

d Close the Services window.

2 Install the Content Packs:

a Click Start → Programs → HP Software → SH Reporter → Package 
Manager. The Content Pack Install Wizard window opens.

b Click Next on the Welcome to the Installation or Uninstallation of 
Content Packs page to continue. The Installation or Uninstallation of 
Content Packs page opens.

Make sure that you open a single instance of the Package Manager.
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c Select Install and click Next to continue. The Business Object 
Configuration page opens..
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d Type in the user credentials to access the SAP BusinessObjects 
Central Management Server and then click Next. The Content Pack 
Selection page opens.

e Select the Content Packs that you want to install and click Next to 
continue. The Selection Summary page opens.

f Review the summary of the Content Pack selections you made.

– Click Back if you want to modify any of the selections.

– Click Install to continue with the installation process.

The Installation Progress page opens.

After the installation completes, Install Wizard summarizes the 
Content Pack installation details. The Installation Complete window 
opens.

g Review the installation details and click Done to complete the Content 
Pack installation.

3 Restart the HP SH Reporter Windows services:

a Click Start → Run. The Run dialog box opens.
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b Type services.msc in the Open field, and then press ENTER. The 
Services window opens.

c On the right pane, right-click the following services, and then click 
Start:

– HP SH Reporter Timer

– HP SH Reporter Collection Service

d Close the Services window.
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6 Setting Up HP SH Reporter for Data 
Collection
HP SH Reporter can start collecting data once the Content Packs are 
installed. Configuring HP SH Reporter for data collection depends on the type 
of topology source you selected for installing HP SH Reporter.

The data collection configuration tasks are organized into the following 
categories:

• If you installed HP SH Reporter in the HPOM deployment scenario, see 
Configuring HP SH Reporter for the HPOM Deployment Scenario on 
page 78.

• If you installed HP SH Reporter in the BSM Service and Operations 
Bridge deployment scenario, see Configuring HP SH Reporter for the BSM 
Service and Operations Bridge Deployment Scenario on page 96.

• If you installed HP SH Reporter in the Application Performance 
Management deployment scenario, see Configuring HP SH Reporter for 
the Application Performance Management Deployment Scenario on 
page 116.
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Configuring HP SH Reporter for the HPOM Deployment 
Scenario

In the HPOM deployment scenario, the HPOM database is the source of the 
topology information of the managed nodes. HP SH Reporter supports data 
collection from both HPOM for Windows and HPOM for Unix, HPOM for 
Linux, and HPOM for Solaris databases.

The topology relationship is limited to node groups, nodes, and node resource. 
The group information is obtained from the HPOM node groups. Node 
resource information is discovered by HP SH Reporter based on the rules 
defined by Content Packs.

You must configure the following data collectors in HP SH Reporter:

• HPOM data collector to retrieve topology information.

• HPOM database collector to retrieve events and messages from the 
HPOM database and collect data from the various nodes.

• HP Performance Agent collector to collect data of enterprise applications, 
database, and system resources from the various managed nodes.

Prerequisite Tasks

Before configuring the HPOM topology source connection, you need to perform 
certain prerequisite tasks depending on how HPOM in installed in your 
environment—whether within a domain or as a standalone system.

Configuring the HP SH Reporter Services for Domain Users

If HP SH Reporter is installed on a system with a domain administrator 
account instead of a local account, the HP SH Reporter Service and HP SH 
Reporter Collection Service will not start for the HPOM deployment scenario. 
Therefore, you must configure the services for the domain user before 
configuring the HPOM service definition source connection.

Configure the HP SH Reporter Service for the Domain Account

Perform the following steps:

1 Click Start → Run. The Run dialog box opens.
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2 Type services.msc in the Open field, and then press ENTER. The 
Services window opens.

3 On the right pane, right-click HP SH Reporter, and then click Stop.

4 Right-click HP SH Reporter and then click Properties. The HP SH Reporter 
Service Properties dialog box opens.

5 On the Log on tab, select This account.

6 Next, type the domain user name in the blank field. For example, if the 
user is of the domain DOMAIN and with the user name Administrator, 
then type DOMAIN\Administrator in the field.

7 Type the user password in the Password field.

8 Retype the password in the Confirm password field.

9 Click Apply and then click OK.

10 On the right pane, right-click HP SH Reporter, and then click Start.

Configure the HP SH Reporter Collection Service for the Domain Account

Perform the following steps:

1 Click Start → Run. The Run dialog box opens.

2 Type services.msc in the Open field, and then press ENTER. The 
Services window opens.

3 On the right pane, right-click HP SH Reporter Collection Service, and then 
click Stop.

4 Right-click HP SH Reporter Collection Service and then click Properties. The 
HP SH Reporter Collection Service Properties dialog box opens.

5 On the Log on tab, select This account.

6 Next, type the domain user name in the blank field.

7 Type the user password in the Password field.

8 Retype the password in the Confirm password field.

9 Click Apply and then click OK.

10 On the right pane, right-click HP SH Reporter Collection Service, and then 
click Start.

These steps are mandatory only if the product is being installed for a domain 
user. These steps are not required if the product is installed for a local user. 
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After performing the configuration steps, proceed with the HPOM service 
definition connection configuration.

Creating Database User Account on an HPOM Database Server

Performing this task depends on how Microsoft SQL Server is set up in the 
HPOM environment and how you can configure HP SH Reporter to 
communicate with the HPOM database server. There are two possible 
scenarios:

• Scenario 1: HPOM for Windows 8.x/9.x is installed on one system with 
Microsoft SQL Server 2005 or Microsoft SQL Server 2008 installed on the 
same system or a remote system. HP SH Reporter, which is installed on 
another system, can be configured to connect to SQL Server either 
through Windows authentication or SQL Server authentication 
(mixed-mode authentication). The authentication method defined in SQL 
Server can be used in HP SH Reporter to configure the HPOM database 
connection.

• Scenario 2: HPOM for Windows 8.x uses Microsoft SQL Server 2005 
Express Edition that is embedded with it by default. Similarly, HPOM for 
Windows 9.x uses the embedded Microsoft SQL Server 2008 Express 
Edition by default. The authentication mode in this scenario is Windows 
NT authentication. However, in this case, a remote connection between 
SQL Server and HP SH Reporter is not possible. Therefore, you must 
create a user account for HP SH Reporter so that mixed-mode 
authentication is possible in this scenario.

Before creating the user account, you must first enable mixed-mode 
authentication. For the steps, see the Enable Mixed Mode authentication after 
installation section in the Microsoft Support KB article at the following URL:

http://support.microsoft.com/kb/319930

To create a user name and password for authentication purposes, perform the 
following steps. If you are using Microsoft SQL Server 2008, the steps are 
similar to the following steps performed in SQL Server 2005:

1 Create a user name and password:

a Log on to the HPOM system with embedded Microsoft SQL Server 
2005.
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b Click Start → Programs → Microsoft SQL Server 2005 → SQL Server 
Management Studio. The Microsoft SQL Server Management Studio 
window opens.

c In the Connect to Server dialog box, select NT Authentication in the 
Authentication list, and then click Connect.

d In the Object Explorer pane, expand Security.

If SQL Server Management Studio is not installed on your system, 
you can download it from the Microsoft web site using the following 
URL: http://www.microsoft.com/downloads/en/
details.aspx?FamilyID=c243a5ae-4bd1-4e3d-94b8-5a0f62bf77
96.
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e Right-click Logins and click New Login. The Login - New dialog box 
opens.

f In the Login name field, type a user name. Specify the other 
necessary details.

g Select the SQL Server authentication radio button.

h In the Password field, type the password.

i In the Confirm password field, retype the password. You might 
want to disable the password enforcement rules to create a simple 
password.

j Click User Mapping.
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k Under Users mapped to this login, select the check box next 
openview.

l Click OK to create the user name and password.

2 The database user must have at least the Connect and Select 
permissions. To enable Connect and Select permissions for the newly 
created user account, follow these steps:

a In the Object Explorer pane, expand Databases.
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b Right-click openview and then click Properties. The Database 
Properties - openview dialog box opens.

c Under the Select a page pane, click Permissions.

d Under Users or roles, click the newly created user account.
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e Under Explicit permissions for test, scroll down to the Connect 
permission, and then select the Grant check box for this permission.
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f Scroll down to the Select permission and select the Grant check box 
for this permission.

g Click OK.

3 Check for the HPOM server port number:

a Click Start → Programs → Microsoft SQL Server 2005 → Configuration 
Tools → SQL Server Configuration Manager. The SQL Server 
Configuration Manager window opens.
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b Expand SQL Server Network Configuration and select Protocols for 
OVOPS. If the instance name has been changed, select the appropriate 
instance name.

c On the right pane, right-click TCP/IP, and then click Enable.

d Right-click TCP/IP again, and click Properties. The TCP/IP Properties 
dialog box opens.
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e On the IP Addresses tab, under the IPAll, note down the port number.

4 Restart the HPOM database server:

a In the SQL Server Configuration Manager window, click SQL Server 
Services.

b On the right pane, right-click SQL Server (OVOPS), and then click 
Restart.

You can use the newly created user name, password, and the observed 
instance name and port number when configuring the HPOM data source 
connection in the Administration Console.

Proceed to configuring the HPOM topology source and the HPOM data source 
connections in HP SH Reporter for data collection. Perform the following 
tasks:

You can perform these steps by using the command prompt utility, osql. For 
more information, see the Microsoft Support KB article at the following URL:

http://support.microsoft.com/kb/325003
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Task 1: Configure the HPOM Service Definition Source

Use the HP SH Reporter Administration Console to configure the HPOM 
service definition source connections to provide the topology information.

Configure the HPOM Data Source Connections

Perform the following steps:

1 Click Start → Programs → HP Software → SH Reporter → Administration. The 
Administration Console opens.

2 On the Login screen, in the Login Name field, type Administrator, and 
then click Log in.

For the steps to create a password for this user name, see Creating a 
Password for the HP SH Reporter Administrator Account on page 119.

3 In the Administration Console, click Topology Source → Service Definition. 
The Service Definition page opens.

4 Under Service Definition Source, select HP OM to create an HPOM 
data source connection.

5 Click Create New. The Connection Parameters dialog box opens.

The default SQL Server Express that gets installed with HPOM for Windows 
does not accept remote connections.

You cannot change the topology source after it has been configured 
on the Service Definition page.
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6 Specify or type the following values in the Connection Parameters 
dialog box:

If you are using the database method of authentication to connect 
to the HPOM database server, you must provide the user details 
that have the select and connect permissions for the “openview” 
database here.

Datasource Type - Select the type of HPOM that is configured in your 
environment. The options include:

• HPOM for Windows
• HPOM for Unix
• HPOM for Linux
• HPOM for Solaris

Database Type - Depending on the data source type that you select, 
the database type is automatically selected for you. 
For the HPOM for Windows data source type, the 
database type is MSSQL. For the HPOM for Unix, 
HPOM for Linux, or HPOM for Solaris, the database 
type is Oracle.

Host name - IP address or fully-qualified domain name (FQDN) 
of the HPOM database server.

Database 
instance

- System identifier (SID) of the database instance in 
the data source. The default database instance is 
OVOPS.

Database name - Name of the HPOM database. This field only 
appears if HPOM for Windows is selected as the 
data source type. The name of the database is 
openview. 

Port - Port number to query the HPOM database server.

To check the port number for the database instance, 
such as OVOPS, see Checking for the HPOM Server 
Port Number on page 92.
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7 Click OK.

8 Click Test Connection to test the connection.

9 Click Save to save the changes.

10 In the message box, click Yes. A Saved Successfully message appears in 
the Information message panel.

You can configure additional HPOM data sources by performing steps 3-6.

11 To change the HPOM data collection schedule for one or more hosts, under 
Schedule HP OM Synchronization, specify a synchronization time 
between 1 and 24 hours in the Hrs box.

12 Click Apply.

13 Click Save to save the changes. A Saved Successfully message appears 
in the Information message panel.

For more information about configuring HPOM service definition sources, see 
the HP Service Health Reporter Online Help for Administrators topic, 
Managing the enterprise topology.

Windows 
Authentication

- Option to enable Windows Authentication for 
accessing the HPOM database. The user can use the 
same credentials to access HPOM as that of the 
Windows system hosting the database. This option 
only appears if HPOM for Windows is selected as the 
data source type.

User name - Name of the HPOM database user. For the HPOM 
for Windows data source type, if the Windows 
Authentication option is selected, this field is 
disabled and appears empty. 

Password - Password of the HPOM database user. For the 
HPOM for Windows data source type, if the 
Windows Authentication option is selected, this field 
is disabled and appears empty.

To collect data from non-domain hosts, appropriate DNS resolutions must be 
made by the HPOM administrator for these hosts so that they are reachable 
by HP SH Reporter, which is installed in the domain.
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Checking for the HPOM Server Port Number

If SQL Server is the database type used in HPOM, see step 3 in Creating 
Database User Account on an HPOM Database Server on page 80 to check for 
the HPOM server port number.

If Oracle is the database type in HPOM, perform the following steps to check 
for the port number:

1 Log on the Oracle server.

2 Browse to the $ORACLE_HOME/network/admin or 
%ORACLE_HOME%\NET80\Admin folder.

3 Open the listener.ora file. The port number for the HPOM server is 
listed in the file.

Task 2: Configure Enterprise Application Data Sources

After you configure the HPOM service definition sources, you must configure 
the data sources to provide data for the various Content Packs that you have 
installed.

Configure the HPOM Database Connection

If you have installed the HPOM Content Pack and created the topology source 
connection for HPOM on the Service Definition page, the same data source 
connection appears on the Operations Manager page. You not do need to 
create a new data source connection. You can test the existing connection and 
save it.

However, updating the data source connection on the Service Definition page 
does not update the connection details on the Operations Manager page.
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Perform the following steps:

1 In the Administration Console, click Collection Configuration → Operations 
Manager. The Operations Manager page opens.

2 Select the check box next to the host name and then click Test Connection 
to test the connection.

3 Click Save to save the changes. A Saved Successfully message appears 
in the Information message panel.

You can configure additional HPOM data sources by clicking the Create 
New button. You can modify a specific data source connection by clicking 
Configure.

4 To change the HPOM data collection schedule for one or more hosts, in the 
Schedule Frequency column, specify a collection time between 1 and 24 
hours in the Hrs box.

5 Click Save to save the changes. A Saved Successfully message appears 
in the Information message panel.

For more information about configuring HPOM data source connections, see 
the HP Service Health Reporter Online Help for Administrators topic, 
Managing HPOM data collection.

Configure the HP Performance Agent Data Sources

In the HPOM deployment scenario, you do not need to create new HP 
Performance Agent data source connections because, by default, all the nodes 
on which HP Performance Agents are installed are automatically discovered 
when the topology information is collected. These HP Performance Agent data 
sources or nodes are listed in the PA Data Source page of the Administration 
Console.
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To view the list of HP Performance Agent data sources:

1 In the Administration Console, click Collection Configuration → PA Data 
Source. The PA Data Source page opens.

2 To view detailed information about the HP Performance Agent data 
sources, click the view name or the number in the PA Data Source 
Summary table. The PA Data Source Details table appears.

3 To change the data collection schedule for one or more hosts, specify a 
polling time between 1 and 24 hours in the Hrs box in the Schedule 
Polling Frequency column.

4 Click Save to save the changes. A Saved Successfully message appears 
in the Information message panel.

5 Close the HP SH Reporter Administration Console.
94 Chapter 6



For more information about configuring HP Performance Agent data source 
connections, see the HP Service Health Reporter Online Help for 
Administrators topic, Managing PA Data Source data collection.

HP SH Reporter starts to collect the historical data from the various 
configured data sources in the HPOM managed environment and generates 
the required reports. For more information about how to view the reports, see 
the HP Service Health Reporter Online Help for Users.

After installing the Content Packs and configuring HP SH Reporter to collect 
data, you must wait for at least three hours before you can view the data in 
the data store tables.
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Configuring HP SH Reporter for the BSM Service and 
Operations Bridge Deployment Scenario

In the BSM Service and Operations Bridge environment, RTSM is the source 
of the topology information for HP SH Reporter. The topology information 
includes all CI as modeled and discovered in RTSM. Group information is 
obtained from the RTSM views. Node resource information is obtained 
directly from RTSM. Collection of the information is through the web service 
interface exposed by RTSM.

Based on the installed Content Packs, you must configure the following data 
collectors in HP SH Reporter: 

• The RTSM collector to collect topology information  and data about the 
various CI types in your environment from the RTSM database. The data 
to be collected is defined by the RTSM view provided with each Content 
Pack.

• The database collector to collect historical synthetic transaction 
monitoring and real user monitoring data from the Profile database and 
the Management database. It also collects events, messages, availability, 
and performance Key Performance Indicators (KPIs) from the databases 
of the data source such as Profile database, Management database, 
HPOM, and HP OMi databases.

• The HP Performance Agent collector to collect system performance 
metrics and data related to applications, databases, and system resources. 
The data is collected by the HP Performance Agents that are installed on 
the managed nodes. 

Task 1: Deploy the Topology Views

In the HP Business Service Management environment, RTSM is used to 
discover the CIs and generate the topology views. To configure HP SH 
Reporter to collect domain-specific data, you first need to deploy those 
topology views for each Content Pack.

These topology views contain the specific CI attributes that Contents Packs 
use to collect the relevant data. However, these topology views can vary from 
one Content Pack to another.
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For example, the Exchange Server Content Pack might require a topology 
view that lists Exchange servers, mailbox servers, mailbox and public folder 
stores, and so on. A System Management Content Pack, however, might 
require a different topology view that lists all the business applications, 
business services, and system resource, such as CPU, memory, disk, within the 
infrastructure. Based on these views, the CI attributes for each Content Pack 
may vary.

To deploy the topology model views for the Content Packs in the HP Business 
Service Management server:

1 Log on to the HP Business Service Management host system as 
administrator.

2 Log on to the host system that has HP SH Reporter installed on it as 
administrator through remote access.

3 Browse to %PMDB_Home%\packages and copy the following topology 
views.

For example, to copy the System Management zip files, browse to 
%pmdb_home%\packages\System_Management\System_Management.
ap\CMDB_View\SM_BSM9_Views.zip and copy the 
SM_BSM9_Views.zip file to the HP Business Service Management host 
system.

4 On the HP Business Service Management host system, click Start → 
Programs → Internet Explorer. The web browser opens.

5 In the web browser, type the following URL:

http://<server_name>.<domain_name>/HPBSM

Content Pack View Name Location

BPM EUM_BSMR.zip %PMDB_Home%\packages\BPM\
BPM.ap\CMDB_View

Real_User_Monitor EUM_BSMR.zip %PMDB_Home%\packages\RUM\
RUM.ap\CMDB_View

System_Management SM_BSM9_Views
.zip

%PMDB_Home%\packages\Syst
em_Management\System_Mana
gement.ap\CMDB_View
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In this instance, <server_name> is the name of the HP Business Service 
Management server, and <domain_name> is the name of the user's 
domain according to the user’s network configuration.

The Business Service Management Login page opens.

6 Type the login name and password and click Log In. The Business Service 
Management - Site Map opens.

7 Click Administration → RTSM Administration. The RTSM Administration 
page opens.

8 Click Administration → Package Manager. The Package Manager page opens.
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9 Click the Deploy Packages to Server (from local disk) icon. The Deploy 
Package to Server dialog box opens.

10 Click the Add icon.

The Deploy Package to Server (from local disk) dialog box opens.

11 Browse to the location of the Content Pack zip files, select the required 
files, and then click Open.
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You can view and select the TQL and ODB views that you want to deploy 
under Select the resources you want to deploy in the Deploy 
Package to Server (from local disk) dialog box. Ensure that all the 
files are selected.

12 Click Deploy to deploy the Content Pack views.

Enabling CI Attributes for a Content Pack

Each Content Pack view includes a list of CI attributes that are specific to that 
Content Pack. The CI attributes that are required for data collection are 
automatically enabled in each of the Content Pack views after you deploy 
them.

To enable additional CI attributes to collect additional information relevant to 
your business needs:

1 Click Start → Programs → Internet Explorer. The web browser opens.

2 In the web browser, type the following URL:

http://<server_name>.<domain_name>/HPBSM

In this instance, <server_name> is the name of the HP Business Service 
Management server, and <domain_name> is the name of the user's 
domain according to user’s network configuration.

The Business Service Management Login page opens.

3 Type the login name and password and click Log In. The Business Service 
Management Site Map opens.

4 Click Administration → RTSM Administration. The RTSM Administration 
page opens.
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5 Click Modeling → Modeling Studio. The Modeling Studio page opens.

6 In the Resources pane, expand HP-SHR, expand a Content Pack folder and 
double-click a topology view to open it.
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7 In the Topology pane, right-click any node in the topology diagram, and 
then click Query Node Properties to view the list of CI attributes for the 
selected node.

The Query Node Properties dialog box opens.
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8 Click Advanced layout settings. The Layout Settings dialog box opens. 
Select the attributes that you want to enable and then click OK.

You have successfully deployed the Content Packs views based on the type of 
deployment scenario selected for HP SH Reporter.

Task 2: Configure SiteScope to integrate with HP SH Reporter

HP SiteScope is an agentless monitoring solution designed to ensure the 
availability and performance of distributed IT infrastructures—for example, 
servers, operating systems, network devices, network services, applications, 
and application components.

For HP SH Reporter to collect VMware virtualization data from SiteScope, 
you must configure SiteScope to integrate with HP SH Reporter. For this, 
ensure that SiteScope 11.11 with the HP Operations agent patch 10.51.285 is 
installed in your environment. In addition, you must import and deploy a 
user-defined template in SiteScope. These templates standardize the 
monitoring of the different IT elements in your enterprise by rapidly 
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deploying sets of monitors that collect data about the IT elements. You must 
also enable SiteScope integration with HP Operations agent for data logging 
so that HP SH Reporter can collect the required data from the agent.

As a prerequisite, integration between SiteScope and BSM has to be enabled 
so that the topology data collected by the SiteScope monitors can be passed to 
BSM. For more information about SiteScope integration with BSM, see 
Chapter 8, Working with Business Service Management (BSM) of the Using 
SiteScope guide.

To integrate SiteScope with HP SH Reporter, follow these steps:

1 Log on to the host system that has HP SH Reporter installed on it as 
administrator.

2 Access SiteScope by typing the SiteScope address in a Web browser. The 
default address is: http://<SiteScope host name>:<port number>/
SiteScope.

3 Import the SiteScope_Template file located in the 
%PMDB_HOME%\packages\System_Management\System_Management.
ap folder to SiteScope. For the steps to import a template in SiteScope, see 
Chapter 39, Import or Export Templates of the Using SiteScope guide. 
This guide is available at the following URL:

http://h20230.www2.hp.com/selfsolve/manuals

4 Deploy the monitors imported by the SiteScope_Template file. For the 
steps, see Chapter 40, Deploy Templates of the Using SiteScope guide.

5 Enable SiteScope to integrate with HP Operations agent for data logging. 
For the steps, see Chapter 9, Working with Operations Manager and BSM 
Using the HP Operations Agent of the Using SiteScope guide.

6 Set the number of monitors and the frequency at which data is fed into the 
HP Operations agent integration. While the default SiteScope 
configuration enables running thousands of monitors, sizing is important 
for planning the maximum number of monitors, metrics, and monitors 
types that can be stored within the SiteScope-HPOM metrics integration.   
For more information, see the Sizing Recommendations for 
SiteScope-Operations Manager Metrics Integration section in Chapter 9 of 
the Using SiteScope guide.
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Task 3: Configure the RTSM Service Definition Source

You can use the HP SH Reporter Administration Console to configure the 
RTSM service definition source to provide the topology information of the 
managed environment.

To configure the RTSM topology data source connections:

1 Click Start → Programs → HP Software → SH Reporter → Administration.

2 On the Login screen, in the Login Name field, type Administrator, and 
then click Log in.  The Administration Console opens.

For the steps to create a password for this user name, see Creating a 
Password for the HP SH Reporter Administrator Account on page 119.

3 In the Administration Console, click Topology Source → Service Definition. 
The Service Definition page opens.

4 Under Service Definition Source, select RTSM to create a RTSM data 
source connection.

5 Click Create New. The Connection Parameters dialog box opens.

You cannot change the topology source after it has been configured 
on the Service Definition page.
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6 Type the following values in the Connection Parameters dialog box:

7 Click OK.

8 Click Test Connection to test the connection.

9 Click Save to save the changes made on this page. 

10 In the message box, click Yes. A Saved Successfully message appears in 
the Information message panel.

11 To change the RTSM data collection schedule, in the Schedule 
Frequency column, specify a collection time between 1 and 24 hours in 
the Hrs box. The default synchronization time is 24 hours.

12 Click Save to save the changes. A Saved Successfully message appears 
in the Information message panel.

For more information about configuring the RTSM service definition source, 
see the HP Service Health Reporter Online Help for Administrators topic, 
Managing the enterprise topology.

Host name - IP address or FQDN of the Business Service 
Management server. If your HP Business Service 
Management installation is distributed, type the  
name of the data processing server (DPS) in the 
Host name field.

Port - Port number to query the RTSM web service. The 
default port number is 21212.

If the port number has been changed, contact your 
database administrator for more information.

User name - Name of the RTSM web service user. The default 
user name is admin.

Password - Password of the RTSM web service user. The default 
password is admin.

You can create only one RTSM data source connection. After the 
connection is created, the Create New button is disabled by default. 
Since this configuration is a one-time setup, make sure that you 
type in the correct values.
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Task 4: Configure Enterprise Application Data Sources

After you configure the RTSM topology source to provide HP SH Reporter 
with the topology information, you can proceed with the configuration of the 
data sources to provide data for the various Content Packs you installed.

Configure the Profile Database Data Source Connections

In your HP Business Service Management deployment, you might have set up 
multiple Profile databases for scaling purposes—one database might not be 
enough to store all the data—or for data separating—all critical data in one 
Profile database and all non-critical data in another. The information about 
the various Profile databases deployed in your environment is stored in the 
Management database. 

To configure the multiple Profile database connections, you only need to 
configure the Management database on the ManagementDB / ProfileDB page. 
After the Management database data source connection is configured, HP SH 
Reporter discovers all the deployed Profile databases and lists them on the 
ManagementDB / ProfileDB page. 

Perform the following steps:

1 In the Administration Console, click Collection Configuration → 
ManagementDB / ProfileDB. The ManagementDB / ProfileDB page opens.
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2 Under Management Database, click Create New. The Connection 
Parameters dialog box opens.

3 Type the following values in the Connection Parameters dialog box:

Host name - Name of the Management database server.

Port - Port number to query the Management database 
server.

Database 
instance

- System Identifier (SID) of the Management 
database instance. 

For information about the database host name, port 
number, and SID, contact your database 
administrator.

Database type - The type of database engine that is used to create 
the Management database. It can either be Oracle or 
MSSQL.
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4 Click OK.

5 Click Test Connection to test the connection.

6 Click Save to save the changes made on this page. A Saved Successfully 
message appears in the Information message pane.

After you save the newly created Management database connection, HP SH 
Reporter retrieves the Profile database information from the Management 
database data source and lists all the existing Profile database data sources 
under the Profile Database section of the page.

Data collection for the Profile database data source is enabled by default. In 
addition, the collection frequency is scheduled for every one hour.

For more information about configuring Profile database data source 
connections, see the HP Service Health Reporter Online Help for 
Administrators topic, Managing ManagementDB / ProfileDB data collection.

Windows 
Authentication

- If you selected MSSQL as the database type, you 
have the option to enable Windows Authentication 
for MSSQL; that is, the user can use the same 
credentials to access SQL Server as that of the 
Windows system hosting the database.

Database name - Name of the database. This field appears only if 
MSSQL is selected as the database type.

User name - Name of the Management database user. If the 
Windows Authentication option is selected, this field 
is disabled and appears empty.

Password - Password of the Management database user. If the 
Windows Authentication option is selected, this field 
is disabled and appears empty.

You can only create a single Management database data source 
connection. After the connection is created, the Create New button 
is disabled by default. Since this configuration is a one-time setup, 
make sure that you type in the correct values.
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Configure the HP Performance Agent Data Source Connections

In the RTSM deployment scenario, you do not need to create new HP 
Performance Agent data source connections because, by default, all the nodes 
on which HP Performance Agent is installed are automatically discovered 
when the topology information is collected. These HP Performance Agent data 
sources or nodes are listed in the PA Data Source page of the Administration 
Console.

To view the list of HP Performance Agent data sources:

1 In the Administration Console, click Collection Configuration → PA Data 
Source. The PA Data Source page opens.

2 To view detailed information about the HP Performance Agent data 
sources, click the view name or the number in the PA Data Source 
Summary table. The PA Data Source Details table appears.

3 To change the data collection schedule for one or more hosts, specify a 
polling time between 1 and 24 hours in the Hrs box in the Schedule 
Polling Frequency column.

4 Click Save to save the changes. A Saved Successfully message appears 
in the Information message panel.
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For more information about configuring HP Performance Agent data source 
connections, see the HP Service Health Reporter Online Help for 
Administrators topic, Managing PA Data Source data collection.

Configure the HPOM Database Connection

If you have installed the HPOM Content Pack, perform the following steps:

1 In the Administration Console, click Collection Configuration → Operations 
Manager. The Operations Manager page opens.

2 Click Create New to create a new data source connection. The Connection 
Parameters dialog box opens.

3 In the Connection Parameters dialog box, type the following values:

If you are using the database method of authentication to connect 
to the HPOM database server, you must provide the user details 
that have the select and connect permissions for the “openview” 
database here.

Host name - IP address or FQDN of the HPOM database server.

Port - Port number to query the HPOM database server.

The default port is 1433 if SQL Server is the 
database type and 1521 if Oracle is the database 
type.

To check for the port number, see Checking for the 
HPOM Server Port Number on page 92.

Database 
Instance

- System identifier (SID) of the HPOM database 
instance. The default database instance is OVOPS.
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4 Click OK.

5 Click Test Connection to test the connection.

6 Click Save to save the changes. A Saved Successfully message appears 
in the Information message panel.

You can configure additional HPOM data sources by performing steps 3-6. 
You can modify a specific data source connection by clicking Configure.

7 To change the HPOM data collection schedule for one or more hosts, in the 
Schedule Frequency column, specify a collection time between 1 and 24 
hours in the Hrs box.

8 Click Save to save the changes. A Saved Successfully message appears 
in the Information message panel.

For more information about configuring HPOM data source connections, see 
the HP Service Health Reporter Online Help for Administrators topic, 
Managing HPOM data collection.

Configure the HP OMi Database Connection

If you install the HP OMi Content Pack, you must configure the HP OMi 
database connection for data collection.

Database type - The type of database engine that is used to create 
the HPOM database. It can either be Oracle or 
MSSQL. The name is openview.

Windows 
Authentication

- If you selected MSSQL as the database type, you 
have the option to enable Windows Authentication 
for MSSQL; that is, the user can use the same 
credentials to access SQL Server as that of the 
Windows system hosting the database.

Database name - Name of the database. This field appears only if 
MSSQL is selected as the database type.

User name - Name of the HPOM database user. If the Windows 
Authentication option is selected, this field is 
disabled and appears empty.

Password - Password of the HPOM database user. If the 
Windows Authentication option is selected, this field 
is disabled and appears empty.
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Before you create a new HP OMi data source connection, make sure that a 
data source connection for the Management database exists on the 
Management DB / Profile DB page. This data connection is required to 
retrieve KPI metadata for HP OMi, which is stored in the Management 
database.

If  you have one or more OMi setups in your environment, you must configure 
the OMi data source that belongs to the HP Business Service Management 
RTSM that was configured as the topology source.

To configure the HP OMi data source connections:

1 In the Administration Console, click Collection Configuration → OMI. The 
OMI page opens.

2 Click Create New to create a new HP OMi data source connection. The 
Connection Parameters dialog box opens.

3 Specify or type the following values in the Connection Parameters 
dialog box:

Host name - Address (IP or FQDN) of the HP OMi database 
server.

Port - Port number to query the HP OMi database server.

Database 
instance

- System Identifier (SID) of the HP OMi database 
instance.

For information about the database hostname, port 
number and SID, contact your HP OMi database 
administrator.

Database type - The type of database engine that is used to create 
the HP OMi database. It can either be Oracle or 
MSSQL.
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4 Click OK.

5 Click Test Connection to test the connection.

6 Click Save to save the changes. A Saved Successfully message appears 
in the Information message panel.

7 To change the HP OMi data collection schedule for one or more hosts, in 
the Schedule Frequency column, specify a collection time between 1 
and 24 hours in the Hrs box.

8 Click Save to save the changes. A Saved Successfully message appears 
in the Information message panel.

Data collection for all the newly created data source connections is enabled by 
default. For more information about configuring HP OMi data source 
connections, see the HP Service Health Reporter Online Help for 
Administrators topic, Managing HP OMi data collection.

Windows 
Authentication

- If you selected MSSQL as the database type, you 
have the option to enable Windows Authentication 
for MSSQL; that is, the user can use the same 
credentials to access SQL Server as that of the 
Windows system hosting the database.

Database name - Name of the database. This field appears only if 
MSSQL is selected as the database type.

User name - Name of the HP OMi database user. If the Windows 
Authentication option is selected, this field is 
disabled and appears empty.

Password - Password of the HP OMi database user. If the 
Windows Authentication option is selected, this field 
is disabled and appears empty.

You can create only one HP OMi data source connection. After the 
connection is created, the Create New button is disabled by 
default. Make sure that you type in the correct values.

After installing the Content Packs and configuring HP SH Reporter to collect 
data in the RTSM deployment scenario, you must wait for at least three hours 
before you can view the data in the data store tables.
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HP SH Reporter starts to collect the historical data from the various 
configured data sources and generates the necessary reports. For more 
information about how to view the reports, see the HP Service Health Reporter 
Online Help for Users.

Enable KPI Data Collection for Service Health CIs

KPIs are high-level indicators of a CI’s performance and availability. The KPI 
data pertaining to certain logical Service Health CIs, such as Business 
Service, Business Application, Business Process, and Host, are logged by 
default in the Profile database. HP SH Reporter collects this data from the 
database for reporting.

However, the KPI data for other CI types are not automatically logged in the 
Profile database. To enable the logging of the KPI data for these CI types, you 
must configure the CIs in the HP Business Service Management. For more 
information, see the Persistent Data and Historical Data section on page 363 
of the HP Business Service Management - Using Service Health guide. This 
guide are available at the following URL for the product, Application 
Performance Management (BAC):

http://h20230.www2.hp.com/selfsolve/manuals
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Configuring HP SH Reporter for the Application 
Performance Management Deployment Scenario

In the Application Performance Management environment, RTSM is the 
source of the topology information for HP SH Reporter. Depending on the 
installed Content Packs, you need to configure the following data collectors in 
HP SH Reporter:

• The RTSM collector to collect topology information  and data about the 
various CI types in your environment from the RTSM database. The data 
to be collected is defined by the RTSM view provided with each Content 
Pack.

• The database collector to collect historical synthetic transaction 
monitoring and real user monitoring data from the Profile database and 
the Management database. System-related data is collected from the  
CODA agent running on the SiteScope server.

The tasks for configuring HP SH Reporter in this deployment scenario is 
similar to that of the BSM Service and Operations Bridge deployment 
scenario, with a few changes. You do not need to configure the HP 
Performance Agent, HPOM, and HP OMi data source connections in the 
Administration Console.

Perform the following tasks:

1 Deploy the topology views. For the steps to perform this task, see Task 1: 
Deploy the Topology Views on page 96.

2 Configure SiteScope to integrate with HP SH Reporter. For the steps to 
perform this task, see Task 2: Configure SiteScope to integrate with HP 
SH Reporter on page 103.

3 Configure the RTSM service definition sources to provide the topology 
information of the managed environment. For the steps to perform this 
task, see Task 3: Configure the RTSM Service Definition Source on 
page 105.
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4 Configure the multiple Profile database connections to provide RUM and 
BPM data. For the steps to perform this task, see Configure the Profile 
Database Data Source Connections on page 107.

HP SH Reporter starts to collect the historical data from the various 
configured data sources and generates the necessary reports. For more 
information about how to view the reports, see the HP Service Health Reporter 
Online Help for Users.

Configuring HP Performance Agent Data Collection in a 
Firewall Environment or via a Proxy

If a network firewall exists, you must configure HP Performance Agents to 
communicate with HP SH Reporter through the firewall. You can also 
configure HP Performance Agent data collection through a proxy server.

For steps to configure communication between HP SH Reporter and the HP 
Performance Agent managed nodes in a firewall environment or through a 
proxy server, see the Operations Manager Firewall Concepts and 
Configuration Guide. This guide is available at the following URL:

http://h20230.www2.hp.com/selfsolve/manuals

Configuring HP Performance Agent for Data Collection 
in Secure Mode

HP Performance Agent supports HTTP 1.1-based communications interface 
for data access between client and server applications. However, you can also 
configure data collection from HP Performance Agent managed nodes via the 
secure (HTTPS) mode.

After installing the Content Packs and configuring HP SH Reporter to collect 
data in the RTSM deployment scenario, you must wait for at least three hours 
before you can view the data in the data store tables.
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For HTTPS communication, the agents must support CODA 8.xx; otherwise, 
HTTP or DCE method will be used. Because HTTPS communication is 
certificate-based, certificates must be installed on the HP SH Reporter system 
and on the managed nodes. The HP SH Reporter system acts as a certificate 
client and the certificate server (certificate authority) is provided by the HP 
management server. The client certificates must be exchanged to establish 
HTTPS communication.

For the steps to install the certificate, see the HP Operations Manager for 
Windows Certificate Management in Environments with Multiple HP Software 
Products white paper. For additional information, see the HP Operations 
Manager for Unix HTTPS Agent Concepts and Configuration Guide. These 
documents are available at the following URL:

http://h20230.www2.hp.com/selfsolve/manuals

Start the HP OpenView Ctrl Service and the HP SH Reporter Collection Service

After configuring the HTTPS communication, perform the following steps:

1 On the HP SH Reporter system, click Start → Run. The Run dialog box 
opens.

2 Type services.msc in the Open field, and then press ENTER. The 
Services window opens.

3 On the right pane, right-click HP OpenView Ctrl Service, and then click 
Start.

4 Right-click HP SH Reporter Collection Service, and then click Restart.

5 Close the Services window.

Configuring the Report Drill Feature Settings

HP SH Reporter includes the SAP BusinessObjects InfoView portal that 
enables you to view the generated reports. SAP BusinessObjects InfoView 
provides a Drill feature that you can use to view information at a daily, 
monthly, and yearly level. However, when drilling up or down within a report, 

If SSL_SECURITY option is set to ALL or REMOTE in the [coda] namespace 
on the HP Performance Agent systems, HTTP communication fails. Only 
HTTPS is supported.
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sections of the report might not display the relevant data for the specified 
level. This is because the report blocks lose the synchronization between the 
Drill options in the report. To ensure that the reports display the correct data, 
you need to re-establish the synchronization by configuring the SAP 
BusinessObjects InfoView Preference settings.

To configure the Drill feature settings:

1 Click Start → Programs → HP Software → SH Reporter → Administration. The 
HP SH Reporter Administration Console opens.

2 In the Administration Console, click Administration → SAP BOBJ. The SAP 
BOBJ page opens.

3 Click Launch InfoView to open SAP BusinessObjects InfoView. The 
BusinessObjects InfoView Login page opens.

4 Type the SAP BusinessObject InfoView user name and password in the 
User Name and Password field, respectively.

5 Click Log On. The SAP BusinessObjects InfoView portal opens.

6 Under Personalize, click Preferences. The Preferences page opens.

7 Click Web Intelligence.

8 Under Drill options, select the Synchronize drill on report blocks option.

9 Click OK.

10 Close the web browser.

Creating a Password for the HP SH Reporter 
Administrator Account

If you want to create a password for the default Administrator user name, 
perform the following steps:

1 Click Start → Programs → HP Software → SH Reporter → Administration. The 
HP SH Reporter Administration Console opens.

2 Log in to the Administrator Console.

3 In the Administrator Console, click Administration → SAP BOBJ. The SAP 
BOBJ page opens.
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4 Access the SAP BOBJ Central Management Console from the SAP BOBJ 
page.

5 On the Central Management Console login screen, in the User Name 
field, type Administrator.

6 Click Log On. The CMC Home screen opens.

7 Click Users and Groups. The Users and Groups screen opens.

8 On the right pane, double-click Administrators.

9 Right-click Administrator and then click Properties. The 
Properties:Administrator dialog box opens.

10 Under Enterprise Password Settings, in the Password field, type a 
new password.

11 In the Confirm field, retype the password to confirm it. You can change 
the Administrator user name, if required, and specify other necessary 
details on this screen.

12 Click Save & Close to accept the changes.

13 Click Log Out to exit the Central Management Console.

Displaying Privacy Information on the Login Screen of 
the Web Service

If you want to display privacy policy information for the system that you are 
using to access the Administration Console web service, you can manually 
customize the Login screen by editing the Privacy.html file. To customize 
the Login screen, follow these steps:

1 On the HP SH Reporter system, browse to 
%PMDB_HOME%\adminServer\webapps\BSMRApp.

2 Open the Privacy.html file in any Text Editor.

3 Follow the instructions provided in the file to edit the content. In this file, 
you can:

• Provide a header message for the Login screen.
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• Provide an image of the company logo to be displayed on the Login 
screen. The logo image must be placed in the 
%PMDB_HOME%\adminServer\images folder.

• Provide the privacy message.

4 Save the file. The Login screen displays the company-specific privacy 
information.
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7 Validating Your Installation
After you installed the HP SH Reporter software and the Content Packs and 
configured HP SH Reporter to collect data from the various data sources, you 
might want to verify if the product is working properly.

This chapter covers certain validation tasks that you can perform to verify the 
success of the installation. After installing and configuring HP SH Reporter, 
wait for at least three hours before performing the following validation tasks.

Check the HP SH Reporter Services

You must check whether the HP SH Reporter services are running, including 
the SAP BOBJ and Sybase IQ services.

To check for the services in the Administration Console, perform the following 
steps:

1 Click Start → Programs → HP Software → SH Reporter → Administration. The 
HP SH Reporter Administration Console opens.

2 Type the user credentials in the Login screen and click Log In. The HP SH 
Reporter Home page opens.

3 On the Home page, observe the status of the HP SH Reporter and SAP 
BOBJ services in the Services Status section.
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The  icon indicates that the services are up and running.

4 Click the HP SH Reporter Status hyperlink to view the list of individual 
services and their status. The Services page opens.

5 In the Service list, select SAP BOBJ Enterprise Status to view the list of 
SAP BOBJ services.

Alternatively, you can also check the services in the Services window by 
performing the following steps:

1 Click Start → Run. The Run dialog box opens.
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2 Type services.msc in the Open field, and then press ENTER. The 
Services window opens.

3 On the right pane, view the status of the HP SH Reporter services.

To check the status of the SAP BOBJ services, you can use the SAP BOBJ 
Central Configuration Manager. Perform the following steps:

1 Click Start → Programs → BusinessObjects XI 3.1 → BusinessObjects 
Enterprise → Central Configuration Manager. The Central Configuration 
Manager window opens.
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2 Click the  button. The Log On dialog box opens.

3 Click Connect. The Manage Servers window opens.

4 Note the status of the listed SAP BOBJ services. All services must be 
enabled and running.

Check for the HP SH Reporter Database

After checking the HP SH Reporter services, you can check if the Performance 
Management database (PMDB) created during the post-install configuration 
phase exists. You can perform this task in the following four ways:

Check the Log File

You can make sure that the database was created without any errors by 
checking the postinstallconfig.log file that is located in the 
%PMDB_HOME%\log folder.

Check the Administration Console
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You can check the status of the database in the Administration Console. 
Perform the following steps:

1 Click Start → Programs → HP Software → SH Reporter → Administration. The 
HP SH Reporter Administration Console opens.

2 Type the user credentials in the Login screen and click Log In. The HP SH 
Reporter Home page opens.

3 On the Home page, observe the status of the PMDB database in the 
Database Status section.

4 On the left pane, click Internal Monitoring → Database Monitoring to view 
more information about the database. The Database Monitoring page 
opens.
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On this page, you can view the detailed database information, connection 
status, availability, and space usage of the database.

Check for the Database Using Sybase Central

You can also use Sybase Central to check for the PMDB database. Perform the 
following steps:

1 Click Start → Programs → Sybase → Sybase IQ 15.2 → Sybase Central Java 
Edition. The Sybase Central window opens.
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2 On the main toolbar, click the  button. The Connect dialog box opens.

3 On the Identification tab, select Supply user ID and password, and then in 
the User ID and Password boxes, type the PMDB database credentials.

4 On the Database tab, in the Server name list, select the database 
server.

5 Click Tools, and in the pop-up menu, click Test Connection to check the 
connection to the database server.

6 In the Test Connection message box, click OK.

7 Click OK to close the Connect dialog box.

8 Note that Sybase Central displays the PMDB database if it exists.
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Check for the Database Using MySQL

You can run a command in MySQL to list all the databases that exist. Using 
the method, you can check for the dwabc database, which stores all the data 
processing-related information.

Perform the following steps:

1 Click Start → Programs → MySQL → MySQL Server 5.1 → MySQL Command 
Line Client. The MySQL Command Line Client window opens.

2 At the prompt, type the password of the PMDB database and then press 
ENTER.

3 At the prompt, type the following command to display all the databases 
and press ENTER:

show databases;

All existing databases related to the HP SH Reporter product are listed. 
Make sure that the dwabc database is displayed.

Check the Topology Collection Status

After you have verified that the HP SH Reporter installation was successful, 
you must verify whether HP SH Reporter has been properly configured to 
collect topology data. By default, topology data collection is scheduled to run 
once a day. You can check if topology collection has occurred by using the 
Administration Console.
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To check the status of the topology collection, perform the following steps:

1 Click Start → Programs → HP Software → SH Reporter → Administration. The 
HP SH Reporter Administration Console opens.

2 Type the user credentials in the Login screen and click Log In. The HP SH 
Reporter Home page opens.

3 On the left pane, click Topology Source → Service Definition. The Service 
Definition page opens.

4 In the Collection columns of the table, make sure that  icon is 
displayed. This icon indicates that the topology data collection was 
successful.

Check for the View CSV Files

After topology collection takes place, HP SH Reporter creates certain View 
files for the topology data. These CSV files are stored in the 
%PMDB_HOME%\reconcil_registry\cmdbRegistry folder. To verify that 
topology collection took place, check the folder for the CSV files. The 
reconcil_registry folder contains the following folders:

• cachedRegistry

• cmdbRegistry

• registryDump

Check for the Installed Content Packs

You can verify if the all the required Content Packs are installed by using the 
Administration Console. To view the list of Content Packs, perform the 
following steps:

1 Click Start → Programs → HP Software → SH Reporter → Administration. The 
HP SH Reporter Administration Console opens.

2 Type the user credentials in the Login screen and click Log In. The HP SH 
Reporter Home page opens.
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3 On the left pane, click Internal Monitoring → SH Reporter Content. The SH 
Reporter Content page opens.

On this page, all the installed Content Packs are displayed with the date of 
installation.

Check the Stream Status for the Content Packs

You might want to verify if the data processing tasks performed by HP SH 
Reporter are running properly without any errors. You can verify if data 
aggregation is taking place on the collected data and data is getting loaded 
into the database for reporting by checking the workflow stream status in the 
Administration Console. For the installed Content Packs, all workflow 
streams must either be running or completed successfully, but not in the 
waiting state. To view the stream details, perform the following steps:

1 Click Start → Programs → HP Software → SH Reporter → Administration. The 
HP SH Reporter Administration Console opens.

2 Type the user credentials in the Login screen and click Log In. The HP SH 
Reporter Home page opens.
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3 On the left pane, click Internal Monitoring → Data Processing. The Data 
Processing page opens.

On this page, you can check the number of workflow streams that are running 
for each Content Pack and the status of those streams.

Check the Stage Folder for CSV Files

Additionally, you can verify that data is getting loaded into the PMDB 
database by checking the %PMDB_HOME%\stage\failed_to_load folder. If 
data has been successfully loaded to the stage tables, there should not be any 
CSV files in the failed_to_load folder.

After data is loaded into the stage tables, it is moved into the database. To 
verify this, check the %PMDB_HOME%\stage\collection\failed_to_load 
folder. If data has been successfully stored in the database, there should not 
any CSV files in the failed_to_stage and failed_to_load folders.

The CSV files for the workflow streams that completed successfully are moved 
into the archive folder.

For the stream aggregation information, you can also check the trend.log 
file located in the %PMDB_HOME%\log folder. For data loading information, you 
can check the loader.log file.
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Check the SAP BusinessObjects Universe

The SAP BusinessObjects universes are files that contain objects and classes 
that map the source data structure in the database to the business terms used 
by the business users. These universes are used by SAP BusinessObjects 
Enterprise in generating the Web Intelligence reports. You can verify if the 
SAP BusinessObjects universe exists for each Content Pack. 

To check for the universes, perform the following steps:

1 Click Start → Programs → BusinessObjects XI 3.1 → BusinessObjects 
Enterprise → Designer.

2 In the User Identification dialog box, click OK. The Universe Designer 
opens.

3 On the File menu, click Import to import a Content Pack universe into the 
Universe Designer. The Import Universe dialog box opens.

4 In the Folder list, select the Content Pack folder. The available universes 
for that Content Pack is listed in the Available Universes section.

5 Select a universe that you want to view and click OK.

6 In the Import Universe message box, click OK. 
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The selected universe is displayed in the Designer.

Check for the Report Folders in SAP BusinessObjects 
InfoView

Perform the following steps:

1 Click Start → Programs → HP Software → SH Reporter → Administration. The 
HP SH Reporter Administration Console opens.

2 Type the user credentials in the Login screen and click Log In. The HP SH 
Reporter Home page opens.

3 On the left pane, click Administration → SAP BOBJ. The SAP BOBJ page 
opens.

4 On the right pane, click Launch InfoView. The SAP BOBJ InfoView login 
screen opens.

5 Type the user credentials and click Log On. The SAP BOBJ InfoView 
opens.
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6 Click Document List. The Document List page opens.

7 Expand the report folders on the left pane and check if the reports are 
displayed on the right pane.

If you can view the relevant information on the Administration Console and in 
the reports in SAP BOBJ InfoView after performing these tasks,, then HP SH 
Reporter has been installed and configured properly in your environment.
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8 Uninstalling HP SH Reporter
In HP SH Reporter, you can remove individual Content Packs without 
removing the entire application. You can also remove the HP SH Reporter 
application by using the HP Software Installer. This process removes all 
installed components including the Content Packs.

Uninstalling the Content Packs

Uninstalling a Content Pack consists of stopping the HP SH Reporter 
Windows services, uninstalling the Content Pack, and then restarting the HP 
SH Reporter Windows services.

If you are uninstalling a Content Pack while HP SH Reporter is operational, 
make sure that the HP SH Reporter data processes are not running or wait for 
all active data processes to complete before uninstalling the Content Pack. 
This is because these active data processes might cause the Content Pack 
uninstallation to fail. For the steps to monitor the data processes, see Stopping 
the HP SH Reporter Data Processes on page 71.

To remove the Content Packs:

1 Stop HP SH Reporter Windows services:

a Log on to the host system as administrator.

b Click Start → Programs → Administrative Tools → Services. The Services 
window appears.

c On the right pane, right-click the following services and select Stop to 
stop the service:

– HP SH Reporter Timer

– HP SH Reporter Collection Service

d Close the Services window.
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2 Remove the Content Packs by using the Package Manager:

a Click Start → Programs → HP Software → SH Reporter → Package 
Manager. The Content Pack Install Wizard window opens.

b Click Next on the Welcome to the Installation or Uninstallation of 
Content Packs page to continue. The Installation or Uninstallation of 
Content Packs page opens.

c Select Uninstall and click Next to continue. The Content Pack Selection 
page opens.

d Select the Content Packs that you want to remove and click Next to 
continue. The Selection Summary page opens.

e Review the summary of the Content Pack selections that you have 
made.

– Click Back to modify any of the selections.

– Click Install to continue with the installation process.

The Uninstallation Progress page opens.

After the uninstallation completes, the Install Wizard summarizes the 
Content Pack installation details. The Uninstallation Complete 
window opens.

f Review the details and click Done to complete the Content Pack 
uninstallation.

3 Restart the HP SH Reporter Windows services:

a Click Start → Run. The Run dialog box opens.

b Type services.msc in the Open field, and then press ENTER. The 
Services window opens.

c On the right pane, right-click the following services, and then click 
Start:

– HP SH Reporter Timer

– HP SH Reporter Collection Service

d Close the Services window.

You successfully uninstalled the Content Packs.
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Uninstalling HP SH Reporter

To remove the entire HP SH Reporter application along with all the Content 
Packs, you can directly uninstall the application.

Perform the following steps:

1 Stop HP SH Reporter Windows services:

a Log on to the host system as administrator.

b Click Start → Run. The Run dialog box opens.

c Type services.msc in the Open field, and then press ENTER. The 
Services window opens.

d Right-click the following services and select Stop to stop the service:

– HP SH Reporter Message Broker

– HP SH Reporter

– HP SH Reporter IM Service

– HP SH Reporter DB Logger Service

– HP SH Reporter Collection Service

– HP SH Reporter Timer

– HP SH Reporter Sybase Service

– Sybase IQ Agent 15.2

e Close the Services window.

2 Remove HP SH Reporter:

a Click Start → Programs → HP Software → SH Reporter → Uninstall. The 
HP Software Installer opens.

HP Software Installer checks the system for any applications or 
services that might hinder the uninstallation process such as 
anti-virus software. If HP Software Installer detects a hindrance, a 
warning or error is generated, and an Application requirements check 
warnings window opens.

If you have Sybase IQ installed on a remote system, you must stop 
the Sybase IQ Agent 15.2 service on the remote system.
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b Click Continue. The Application Maintenance page opens.

c Under Maintenance Selection, make sure that Uninstall is selected 
and then click Next. The Pre-Uninstall Summary page opens.

d Click Uninstall. The Uninstalling page opens.

e After the uninstallation is completed, the Delete dialog box appears. 

f Click Yes to delete the HP SH Reporter directory. The Uninstall 
Complete page opens.

g Click Done to complete the uninstallation.

h Click Yes in the System Restart message box to restart your system.

i Browse to HP SH Reporter directory and check if the HP-SHR and 
Program File (x86)\Business Objects folders have been 
deleted. If the folders exist, manually delete them.

You successfully uninstalled HP SH Reporter from your system.

HP SH Reporter does not support the Modify or Repair options 
displayed in the HP Software Installer. These options are disabled 
by default.
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Uninstalling Remote Sybase IQ

Perform the following steps if you have installed the Sybase IQ server on a 
remote system:

1 Log on to the remote Sybase IQ machine.

2 Click Start → Programs → Administrative Tools → Services. The Services 
window opens.

3 Right-click Sybase IQ Agent 15.2 and then click Stop.

4 Right-click the Sybase IQ service that you created and then click Stop.

5 Click Start → Programs → Sybase → Sybase 15.2 → Sybase IQ Service 
Manager. The Configure IQ as an NT Service window opens.

6 On the right pane, select the service that you want to delete.

7 Click Delete an Existing Service.

8 Click OK.

9 Click Start → Settings → Control Panel.

10 Click Add or Remove Programs in the Control Panel window.

Before performing the remote Sybase IQ uninstallation steps, you must first 
remove HP SH Reporter from the host machine. This ensures that the 
remotes database schema is removed after the Sybase IQ uninstallation.
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11 In the Add or Remove Programs dialog box, click HP Service Health 
Reporter SybaseIQ, and then click Change/Remove. The HP Software 
Installer opens.

HP Software Installer checks the system for any applications or services 
that might hinder the uninstallation process such as anti-virus software. 
If HP Software Installer detects a hindrance, a warning or error is 
generated, and an Application requirements check warnings window 
opens.

12 Click Continue. The Application Maintenance page opens.

13  Under Maintenance Selection, make sure that Uninstall is selected and 
then click Next. The Pre-Uninstall Summary page opens.

14 Click Uninstall. The Uninstalling page opens.

After the uninstallation is completed, the Delete dialog box appears. 

15 Click Yes to delete the HP SH Reporter directory. The Uninstall Complete 
page opens.

16 Click Done to complete the uninstallation.
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17 Browse to Sybase IQ directory and check if the HP-SHR folder has been 
deleted. If the folder exists, manually delete it.

18 Click Yes in the System Restart message box to restart your system.

You successfully uninstalled the Sybase IQ server from your remote system.

Uninstalling HP SH Reporter Manually

If your HP SH Reporter installation fails because of unexpected circumstances 
such as power outage or hardware failure, you can perform the following steps 
to manually clean up the existing HP SH Reporter installation before 
proceeding with a new installation:

Task 1: Stop all HP SH Reporter services

1 Log on to the host system as administrator.

2 Click Start → Run. The Run dialog box opens.

3 Type services.msc in the Open field, and then press ENTER. The 
Services window opens.

4 Right-click the following services and select Stop to stop the service:

• HP SH Reporter Message Broker

• HP SH Reporter

• HP SH Reporter IM Service

• HP SH Reporter DB Logger Service

• HP SH Reporter Collection Service

• HP SH Reporter Timer

• HP SH Reporter Sybase Service

• Sybase IQ Agent 15.2

5 Close the Services window.

If you have Sybase IQ installed on a remote system, you must stop 
the Sybase IQ Agent 15.2 service on the remote system.
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Task 2: Remove SAP BOBJ and MySQL

1 On the Windows desktop, click Start → Settings → Control Panel.

2 Click Add or Remove Programs in the Control Panel window.

3 In the Add or Remove Programs dialog box, click SAP BusinessObjects 
Enterprise XI 3.1 SP3, and then click Change/Remove to uninstall SAP BOBJ 
Enterprise.

4 Follow the instructions in the uninstallation wizard to complete the 
uninstallation.

5 In the Add or Remove Programs dialog box, click SAP BusinessObjects 
Enterprise XI 3.1 FP 3.5, and then click Change/Remove to uninstall SAP 
BOBJ Enterprise.

6 Follow the instructions in the uninstallation wizard to complete the 
uninstallation.

7 After SAP BOBJ Enterprise is successfully uninstalled, in the Add or 
Remove Programs dialog box, click MySQL Server 5.1, and then click 
Change/Remove.

8 Follow the instructions in the uninstallation wizard to complete the 
uninstallation.

Task 3: Remove Sybase IQ

1 On the Windows desktop, click Start → Settings → Control Panel.

2 Click Add or Remove Programs in the Control Panel window.

3 Click Sybase IQ 15.2 (64-bit) in the Add or Remove Programs window and 
then click Change/Remove to remove the Sybase IQ application.

4 Click OK in the InstallShield Wizard message box.

5 Click OK in the next InstallShield Wizard message box that appears.

6 In the Open dialog box, browse to 
%PMDB_HOME%\..\Sybase\_jvmIQ\bin folder, select java.exe, and 
then click Open.

7 In the Sybase IQ uninstallation wizard, click Next on the Welcome page.

8 Ensure that the features that you want to remove are selected and then 
click Next.

9 Click Next and then click Uninstall.
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10 In the Remove Existing File message box, click Yes to All.

11 In the Restore Environment Variable message box, click Yes to All.

12 Click Finish to complete the uninstallation process.

13 Select the Yes, restart my computer option and then click Finish to restart 
your system.

Task 4: Remove Windows Registry entries

Perform this task only if no other HP products are installed on your system.

1 On the Windows desktop, click Start → Run.

2 In the Run dialog box, type regedit and press ENTER. The Registry Editor 
window opens.

3 Expand HKEY_LOCAL_MACHINE, expand Software, and then expand 
Hewlett-Packard.

4 Expand BSM and HP OpenView. You need to manually remove each of the 
components that are listed under these folders.

5 Click a folder and note the package name and the product code.

Task 5: Remove the HP SH Reporter components

1 To uninstall the components, on the Windows desktop, click Start → Run.

2 In the Run dialog box, type cmd and press ENTER. The Command Prompt 
window opens.

3 At the command prompt, type the following command to uninstall a 
component:

msiexec \x <product code value>

In this instance, <product code value> is the value that is listed in the 
right pane of the Registry Editor window for a particular components. For 
example, to uninstall the HPPmdbMsgBus component, type:

msiexec \x {F44672D8-C8A9-45F6-A215-C9CF138E6ED1}

Perform this step for all the components listed under BSM and HP 
OpenView.
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Task 6: Remove specific environment variables

1 In the Control Panel window, double-click System. The System Properties 
dialog box opens.

2 Click the Advanced tab, and then click the Environment Variables button. 
The Environment Variables dialog box opens.

3 Delete the following variables:

• IQDIR15

• IQLOGDIR15

• IQPORT

• OvInstallDir

• PMDB_HOME

• SYBASE

• SYBASE_JRE6_64

• SYBROOT

4 Edit the PATH environment variable by removing everything that relates 
to HP SH Reporter.

Task 7: Remove the HP SH Reporter Folders

1 Browse to the HP SH Reporter install directory.

2 Delete all the folders.

Task 8: Restart your system
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9 Database Backup and Recovery
HP SH Reporter enables you to back up and recover the database to prevent 
data loss in the event of a database failure. It is recommended that you take 
regular backup of the database before you begin using HP SH Reporter in 
production.

HP SH Reporter provides the following backup options:   

• Full Backup: A full backup enables you to take a complete backup of a 
database including the database files and transaction logs. It is 
recommended to take a full backup every week.

• Incremental Backup: An incremental backup enables you to take a 
backup of the transaction logs. It takes a backup of the files that have 
been modified or added since the last full backup. It is recommended to 
take an incremental backup daily.

You must schedule the full backup and the incremental backup tasks to run at 
regular intervals.

In the event of a database failure, HP SH Reporter enables you to recover the 
database from the backup location.

Taking a Backup of the Database

Task 1: Edit the Backup Scripts

HP SH Reporter provides two backup scripts, one each for full backup and 
incremental backup respectively, that you must edit to fit your requirements 
before you begin the backup process. These scripts are available in the 
%PMDB_HOME%\scripts\Sybase folder. The scripts are:

• For Full Backup: IQ_backup_full.sql
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• For Incremental Backup: IQ_backup_incr_since_full.sql (for 
incremental backup)

To edit the scripts follow these steps:

1 Browse to %PMDB_HOME%\scripts\Sybase folder.

2 Open IQ_backup_full.sql with the Notepad application.

In the last parameter within the .sql script, enter the location where you 
want to save the backup files. For example, for the following .sql script, 
you can enter E:\HP-SHR\Backup as the location for backup.

dsi_pmdb_backup 
'FULL',NULL,'READWRITE_FILES_ONLY',NULL,NULL,NULL,NULL,NU
LL,'D','location_for_backup'

Similarly, for the incremental backup, enter the location for backup as 
follows: 

dsi_pmdb_backup 
'INCREMENTAL_SINCE_FULL',NULL,'READWRITE_FILES_ONLY',NULL
,NULL,NULL,NULL,NULL,'D','location_for_backup'

The scripts are run through two batch files 
Execute_FullBackup_Script.bat and 
Execute_IncrSncFullBackup_Script.bat for full backup and 
incremental backup respectively. These batch files are available in 
%PMDB_HOME%\scripts\.

After the scripts are run, a database backup is created with file name suffixed 
with day of the week at the specified location.

Task 2: Edit the Copy Backup Script

HP SH Reporter provides a Copy Backup script that takes a backup of the 
previous full backup file in the specified location.

To edit the copy backup script, enter the location of the existing full backup 
file and the location where you want to save the copied files before starting the 
full backup procedure.

For an HP SH Reporter  installation with a remote database, the 
location_for_backup denotes a valid path on the SybaseIQ database server.
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COPY "location of existing full backup file" "copy to 
location"> %PMDB_HOME%\tmp\Copy_Backup.txt 2>&1 /Y /V

An example of the script is as follows:

COPY "E:\HP-SHR\Backup\Full*" "E:\HP-SHR\Backup\Old\" > 
%PMDB_HOME%\tmp\Copy_Backup.txt 2>&1 /Y /V

Task 3: Schedule the Backup

To take regular backup of the database, you must schedule to run the backup 
scripts by using the Windows Task Scheduler. It is recommended to run a full 
backup once a week and an incremental backup once a day.

Schedule to run the Copy Backup script

The Copy Backup script creates a copy of the full backup database files in the 
specified location to avoid overwriting an existing full backup. You must 
schedule to run the Copy Backup script every time before you run the full 
backup script.

1 Go to Start-> Control Panel -> Scheduled Tasks.

2 Double-click Add Scheduled Task. The Scheduled Task wizard opens.

3 Click Next.

4 Browse to %PMDB_HOME%\scripts and then select CopyBackup.bat. 
Click Next.

5 Type a name for the task and click Weekly under Perform this task. This 
defines the frequency at which the task will be performed. Click Next.

6 Select the time and day you want the task to begin:

a Set the start time.

b Do not change the default value of 1 for the frequency of weeks.

c Select the day of the week. It is recommended to schedule this task on 
a day when the workload is less. You can select multiple days if you 
want to take a full backup more than once a week.

7 Click Next.

8 Enter the user name and password to set the account information.
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9 Click Finish.

Schedule to run the Full Backup Script

You must schedule to run the Full Backup script after the Copy Backup 
script.   

1 Go to Start-> Control Panel -> Scheduled Tasks.

2 Double-click Add Scheduled Task. The Scheduled Task wizard opens.

3 Click Next.

4 Browse to %PMDB_HOME%\scripts and then select 
Execute_FullBackup_Script.bat. Click Next.

5 Type a name for the task and click Weekly under Perform this task. This 
defines the frequency at which the task will be performed. Click Next.

6 Select the time and day you want the task to begin:

a Set the start time.

b Do not change the default value of 1 for the frequency of weeks.

c Select the day of the week. It is recommended to schedule this task on 
a day when the workload is less. You can select multiple days if you 
want to take a Full Backup more than once a week.

7 Click Next.

8 Enter the user name and password to set the account information.

9 Click Finish.

Schedule to run the Incremental Backup Script

You must schedule to run the Incremental Backup script once a day.   

1 Go to Start-> Control Panel -> Scheduled Tasks.

2 Double-click Add Scheduled Task. The Scheduled Task wizard opens.

3 Click Next.

4 Browse to %PMDB_HOME%\scripts and then select 
Execute_FullBackup_Script.bat. Click Next.

5 Type a name for the task and click Daily under Perform this task. This 
defines the frequency at which the task will be performed. Click Next.
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6 Select the time and day you want the task to begin:

a Set the start time.

b Do not change the default value of Daily under Perform this task.

c Set the start date.

7 Click Next.

8 Enter the user name and password to set the account information.

9 Click Finish.

Restoring the Database

In the event of a database failure HP SH Reporter enables you to restore the 
database from an existing database backup. Follow these steps:

1 Stop HP_PMDB_Platform_Sybase service by following these steps:

a Click Start → Run. The Run dialog box opens.

b Type services.msc in the Open field, and then press ENTER. The 
Services window opens.

c On the right pane, right-click the HP_PMDB_Platform_Sybase service, 
and then click Stop.

2 Search for all files with extensions .db, .log, and .iq from the database 
file location and move these files to any other location on the system. 
These files are recreated by the restore process.

3 Start SybaseIQ server. At the command prompt run the following 
command:

start_iq 
@<installation_directory>\Sybase\IQ-15_2\scripts\pmdbConf
ig.cfg

Type the command in a single line.

4 Connect to SybaseIQ server by following these steps:

a On the HP SH Reporter system, click Start-> Run. The Run dialog box 
opens.
Database Backup and Recovery 151



b Type dbisql in the Open field and press ENTER. The Connect dialog 
box on Interactive SQL program opens.

c On the Identification tab, type the following:

– In the User ID field type dba

– In the Password field type sql

– In the Server Name field type the name of the server where the 
HP SH Reporter SybaseIQ database is installed

– In the Database name field type utility_db

d Click Connect. The Interactive SQL window opens.

5 Restore the Full Backup. 

On the SQL Statements box type the following sql statement:

RESTORE DATABASE <path of the database> FROM <location where the 
backup file is saved>

For example: RESTORE DATABASE E:\SybaseDB\pmdb.db FROM 
E:\HP-SHR\backup\Full.Sunday

Although the backup process might create multiple files you are not 
required to restore from the multiple backup files. 

For example, if the backup creates the following three files:

— Full.Sunday.1

— Full.Sunday.2

— Full.Sunday.3

The sql statement that you run is:

RESTORE DATABASE E:\SybaseDB\pmdb.db FROM 
E:\HP-SHR\backup\Full.Sunday

6 Restore the Incremental Backup, if any, after restoring a Full Backup.

If several incremental backup files are available, select and restore the 
latest incremental backup. For example, if the database fails on a 
Thursday and a Full Backup had been taken on the previous Sunday, you 
must restore the Full Backup files of Sunday followed by the Incremental 
Backup taken on the previous Wednesday. 

To restore the Incremental Backup on the SQL Statements box type the 
following sql statement:
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RESTORE DATABASE <path of the database> FROM <location where the 
incremental backup file is saved>

For example: RESTORE DATABASE E:\SybaseDB\pmdb.db FROM 
E:\HP-SHR\backup\Incr_sncfull.Wednesday

7 After restoring the database, you must start the database to access it.

To start an embedded Sybase IQ database follow these steps:

a Click Start → Run. The Run dialog box opens.

b Type services.msc in the Open field, and then press ENTER. The 
Services window opens.

c On the right pane, right-click the HP_PMDB_Platform_Sybase service, 
and then click Start.

To start a remote Sybase IQ database follow these steps:

a Log on to the remote system. You must have Administrator privileges.

b Click Start → Run. The Run dialog box opens.

c Type cmd and press ENTER to open the Command Prompt window.

d At the command prompt, type the following command to start the 
Sybase IQ database:

start_iq 
@<Installation_Directory>\Sybase\IQ-15_4\scripts\pmdbConfig
.cfg <Sybase datafiles location>\pmdb.db

In this instance, <Installation_Directory> is the location where you install 
HP SH Reporter  and <Sybase datafiles location> is the location where 
Sybase IQ database files are stored.
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10 Troubleshooting HP SH Reporter 
Installation
Installation Log Files

When you encounter issues during the installation of HP SH Reporter or the 
Content Packs, the HP Software Installer generates error messages that 
notify you about the installation failure. However, the error messages might 
not provide all the information required to help you resolve the issues. 
Alternatively, you can use the installation log files as one of your 
troubleshooting tools.

HP SH Reporter Log Files

The installation log files for HP SH Reporter are available at the following 
location:

%temp%\..\HPOvInstaller\HP-SHR_9.10\

The log file will have a time stamp attached to it.

For example:

• HP-SHR_9.10_2010.02.12_17_26_HPOvInstallerLog.html

• HP-SHR_9.10_2010.02.12_17_26_HPOvInstallerLog.txt

To view the log file that is specific to the Content Packs, browse to the 
%PMDB_HOME%\log\ folder and open the packagemanager.log file.

SAP BusinessObjects Enterprise Log Files

The installation log file for SAP BusinessObjects can be accessed from the 
following locations:

• <SAP BOBJ Install Directory>\BusinessObjects Enterprise 
12.0\Logging\BOEInstall_0.log
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• <SAP BOBJ Install Directory>\BusinessObjects Enterprise 
12.0\Logging\BOE_FP_3_5_Install_0.log

Sybase IQ Log Files

View the error log file in the Sybase IQ installation directory to find out the 
cause of an installation failure. Sybase IQ writes messages to this file each 
time the system is booted and each time a Sybase error occurs. The error log 
file is available in the following location:

%USERPROFILE%\IQ15Console.log

If you have installed Sybase IQ remotely, the log file is available in the 
following location:

%temp%\..\HPOvInstaller\HP-SHR-SybaseIQ_9.10\

The log file will have a time stamp attached to it.

For example:

• HP-SHR-SybaseIQ_9.10_2010.09.16_08_45_HPOvInstallerLog.html

• HP-SHR-SybaseIQ_9.10_2010.09.16_08_45_HPOvInstallerLog.txt

After identifying the cause of the problem, see the Sybase IQ documentation 
to rectify it. For the latest help documents, see www.sap.com.

MySQL Log File

The installation log file for MySQL can be accessed from:

%temp%\Mysql-install.log

Post-install Configuration Log Files

The following log files provide details on operations performed during the 
post-install configuration phase.

Post-install Log File

%PMDB_HOME%\log\postinstallconfig.log
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This log file contains:

• Details on database schema creation on Sybase IQ.

• Details on HP SH Reporter Management database schema creation on 
MySQL.

HP SH Reporter Services Log Files

These are the console logs for the HP SH Reporter services.

• BSMRCollectionService.log—Log file for the HP SH Reporter 
Collection Service.

• BSMRDBLoggerService.log—Log file for the HP SH Reporter DB 
Logger Service.

• BSMRIMService.log—Log file for the HP SH Reporter IM Service.

• Trend.log—Log file for the HP SH Reporter Timer Service.

HP SH Reporter Log File

%PMDB_HOME%\log\BSMRApp.log

This is a consolidated log file that contains all the error and fatal messages 
generated by the HP SH Reporter components.

Troubleshooting Installation Issues

Problem: Sybase IQ database crash issue

Sybase IQ, shipped with HP SH Reporter, occasionally crashes during the 
product run time. You can identify this crash on the Home page of the 

Administration Console, indicated by the  icon for the database status. In 
addition, after the crash, the HP SH Reporter Sybase Service will be running 
in the Services window, but the Sybase IQ process (iqsrv15.exe) will not be 
displayed in the list of processes in the Windows Task Manager.
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Solution: There is no known solution for this crash scenario. However, HP SH 
Reporter includes a Sybase IQ restart script file, SHRIQFix.bat, that checks 
whether Sybase IQ is down and automatically restarts the database whenever 
it crashes. You must manually schedule this file to run by using the Scheduled 
Tasks Wizard. This script file is located in the %PMDB_HOME%\bin folder.

The script file does not work for Sybase IQ installed on a remote system. In 
this case, you must verify whether Sybase IQ has crashed and then manually 
restart the database from the Services window.

To schedule the restart script file in a system with HP SH Reporter and 
Sybase IQ installed, follow these steps:

1 Click Start → Programs → Accessories → System Tools → Scheduled Tasks. 
The Scheduled Tasks windows opens.

2 Double-click Add Scheduled Task. The Scheduled Task Wizard opens.

3 Click the Next button to proceed.

4 On the next page, click Browse. The Select Program to Schedule window 
opens.

5 Browse to the %PMDB_HOME%\bin folder, select SHRIQFix.bat, and then 
click Open.

6 Click the Next button to proceed.

7 On the next page, type a name for the task in the text box, and then, 
under Perform this task, select Daily. Click Next to proceed.

8 On the next page, specify the start time, the start date, and the frequency 
of the task to be run. Click Next to proceed.

9 On the next page, type your Window’s user credentials and then click Next.

10 On the next page, select the Open advanced properties for this task when I 
click Finish check box, and then click Finish. The Advanced Properties 
dialog box opens.

11 Click the Schedule tab and then click Advanced. The Advanced Schedule 
Options dialog box opens.

12 Select Repeat task and then in the Every field, specify the time at which 
the task should be run.

13 Click OK to close the Advanced Schedule Options dialog box.

14 Click OK to close the Advanced Properties dialog box.
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Problem: Environment variables not set in a virtual machine

If HP SH Reporter is installed on a virtual machine that is not restarted after 
the installation, the environment variables set by the installer will not be 
available to the user.

Solution: After installing HP SH Reporter, restart the virtual machine.

Problem: Environment variables set in one session is not visible in another 
session

The environment variables set during the installation are not visible during 
the post-install session. This can cause the post-installation configuration and 
content pack installation to fail.

Solution: This problem occurs only when HP SH Reporter is installed during 
one Terminal Service Client session and the post-installation configuration 
tasks are attempted in another Terminal Service Client session.

To resolve this, follow these steps:

1 In the current session, on the desktop, right-click My Computer, and then 
click Properties. The System Properties dialog box opens.

2 Click the Advanced tab.

3 Click Environment Variables. The Environment Variables dialog box opens.

4 Click OK.

5 Click OK in the System Properties dialog box.

Problem: Database schema creation takes a long time

During the post-install configuration stage, on the Create Database Schema 
page of the Administration Console, clicking the Next button after typing the 
required values produces no activity and the users have to wait for a long time 
for the process to complete.

Solution: Clear the web browser cache, reload the page, and perform the 
steps again.
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Problem: Content Pack installation fails

When a content pack installation fails, the Administration Console displays 
the installation failure. However, the data processing streams for that failed 
Content Pack are not updated in the Administration Console.

Solution: To resolve this problem, you must uninstall the failed Content 
Pack. For the steps, see Uninstalling the Content Packs on page 137.

Problem: Content Pack uninstallation fails

When removing the Content Packs, the uninstallation process fails and the 
following error message is displayed:

SQL Anywhere Error -210: User 'pmdb_admin' has the row in 
'<table_name>' locked

This failure occurs when one or more database connections have a shared lock 
on a database stage table.

Solution: Perform the following steps:

1 Log on to the host system as administrator.

2 Click Start → Programs → Administrative Tools → Services. The Services 
window appears.

3 On the right pane, right-click the following services and click Stop to stop 
the service:

• HP SH Reporter Collection Service

• HP SH Reporter Timer

4 On the desktop, in the notification bar, right-click the Sybase IQ server 
icon, and then click Shut down <host name>.

If the Sybase IQ server icon does not appear in the notification bar, type 
the following command in the Command Prompt window to shut down 
Sybase IQ:

dbstop -y -c uid=dba;pwd=sql;eng=<server engine 
name>;dbn=utility_db;links=tcpip{host=<host name>.<domain 
name>;port=21424}
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In this instance, <server engine name> refers to the name of the Sybase 
server engine, <host name> refers to the name of the system hosting the 
HP SH Reporter database and <domain name> is the name of your 
domain according to your network configuration.

5 To restart the Sybase IQ service, in the Services window, right-click the HP 
SH Reporter Sybase Service, and then click Start.

Wait for all active streams to complete running:

1 Click Start → Run. The Run dialog box opens.

2 Type cmd in the Open field, and then press ENTER. The Command Prompt 
window opens.

3 Type the following command to pause the loading of the job stream:

abcAdminUtil -pause -type loadBatch

4 Wait for all the loaded job streams to complete running.

5 Check the status by typing the following command:

abcMonitor -stream ID=ALL, state=active

To verify if the tables are locked, perform the following steps:

1 Click Start → Programs → Sybase → Sybase IQ 15.2 → Interactive SQL Java. 
The Interactive SQL Java console opens.

2 In the Connect dialog box, on the Identification tab, select Supply user 
ID and password.

3 Type the user name and password and then press OK.

4 Under SQL Statements, type sp_iqlocks, and then click the Execute all 
SQL statement(s) button to run the command.

If there are locked tables, wait for a few minutes for all workflow streams to 
complete and then run the command again. If there are no locked tables, you 
can proceed with the removal of the Content Packs.

Problem: Sybase IQ uninstallation fails

Uninstalling HP SH Reporter does not remove Sybase IQ 15.2 (64-bit) ESD 2.

If you installed Sybase IQ remotely, then you must start the Sybase 
service that you created on the remote system.
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Solution: Perform the following steps:

1 On the Windows desktop, click Start → Settings → Control Panel.

2 Click Add or Remove Programs in the Control Panel window.

3 Click Sybase IQ 15.2 (64-bit) in the Add or Remove Programs window and 
then click Change/Remove to remove the Sybase IQ application.

4 Click OK in the InstallShield Wizard message box.

5 Click OK in the next InstallShield Wizard message box that appears.

6 In the Open dialog box, browse to 
%PMDB_HOME%\..\Sybase\_jvmIQ\bin folder, select java.exe, and 
then click Open.

7 In the Sybase IQ uninstallation wizard, click Next on the Welcome page.

8 Ensure that the features that you want to remove are selected and then 
click Next.

9 Click Next and then click Uninstall.

10 In the Remove Existing File message box, click Yes to All.

11 In the Restore Environment Variable message box, click Yes to All.

12 Click Finish to complete the uninstallation process.

13 Select the Yes, restart my computer option and then click Finish to restart 
your system.

Problem: Installation failure caused by native Windows Installer error

During the installation of HP SH Reporter, the installation process halts and 
the following error message is displayed:

Unable to proceed with installation since the required native 
installer check failed.

Solution: This problem occurs when the native Windows Installer files are 
damaged or missing, or if the Windows Installer service is unregistered or 
damaged. To resolve this problem, you must reregister the Windows Installer. 
Unregistering and reregistering Windows Installer corrects many Windows  
installation issues. Follow these steps:

1 Click Start → Run. The Run dialog box opens.
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2 In the Open field, type cmd, and press ENTER. The Command Prompt 
window opens.

3 At the command prompt, type the following command to unregister the 
Windows Installer:

msiexec /unregister

4 Type the following command to reregister the Windows Installer:

msiexec /regserver

Problem: Installation failure caused by SAP BOBJ error

While running the HP Software Installer, the installation fails and the 
following error message is displayed:

SAP BusinessObjects is installed on the system. Please Uninstall 
it before installing HP SH Reporter.

Solution: If you have any component that is used by HP SH Reporter, such as 
SAP BOBJ or Sybase IQ, already installed on your system, the HP SH 
Reporter installation will fail as the Installer tries to install the components 
that are bundled with the product.

To resolve this problem, you must remove the existing components from the 
system and run the Installer again.

Problem: Remote Sybase IQ database creation fails

In the HP Service Health Reporter Configuration Wizard, while trying to 
create the Sybase database file on a remote system, the post-install fails and 
the following error message is displayed:

<time stamp>,690  INFO, 
com.hp.bto.bsmr.dao.helper.CreateSybaseIQDatabase.logDBLoginInfo 
, Database Info 
[username->dba;serverName-><server_name>_remote;Dbhostname-><hos
t_name>;port->21421]

<time stamp>,018 ERROR, 
com.hp.bto.bsmr.dao.helper.CreateSybaseIQDatabase.executeSQL, 
Could not connect to the database.
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<time stamp>,049 ERROR, 
com.hp.bto.bsmr.dao.helper.CreateSybaseIQDatabase.executeSQL , 
Specified database not found 

<time stamp>,081 ERROR, 
com.hp.bto.bsmr.dao.helper.CreateSybaseIQDatabase.executeSQL , 
SQLCODE=-83, ODBC 3 State="08001"

Solution: This error occurs if the database file location specified in the HP 
Service Health Reporter Configuration Wizard includes space in the file path. 
To resolve this problem, on the remote system, make sure that the specified 
database file location exists on the remote system. In addition, make sure that 
the path provided in the Post-Install wizard does not contain any spaces.

Problem: Unable to log on to the Administration Console

After  typing in the user credentials in the Administration Console Login 
screen and clicking the Log in button,  the following error message is 
displayed:

Solution: To resolve this problem, perform the following steps:

1 Click OK in the message box.

2 Clear the web browser cache:

a In Internet Explorer, on the menu bar, click Tools, and then click 
Internet Options. The Internet Options dialog box opens.

b Make sure that the General tab is displayed.

c Under Browsing history, click Delete. The Delete Browsing History 
dialog box opens.

d Click Delete files in the Temporary Internet Files section.

e Click Close and then click OK. Your cache should now be clear.
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3 Retype the user credentials in the Login Name and Password fields.

4 Click Log in. The  Administration Console opens.

Problem: Antivirus software causes MySQL error

The presence of certain antivirus software generates a MySQL error with the 
following message logged in the %OvInstallDir%\MySQL\<host 
name>.err file:

InnoDB: Operating system error number 8 in a file operation.

Solution: An operating system error number 8 indicates that there is not 
enough storage to process the command. For more information about the error, 
see http://dev.mysql.com/doc/refman/5.1/en/
operating-system-error-codes.html.

To resolve this problem, you must modify the registry entry for 
IRPStackSize. For information about the cause and the steps to resolve the 
problem, see the Microsoft KB article at http://support.microsoft.com/kb/
177078.

Problem: Intermittent behavior of the Administration Console

At times, the Administration Console does not work properly. After opening 
the Console, the following Windows error message appears:

Solution: To resolve this problem, you must clear the web browser cache.
Troubleshooting HP SH Reporter Installation 165

http://dev.mysql.com/doc/refman/5.1/en/operating-system-error-codes.html
http://dev.mysql.com/doc/refman/5.1/en/operating-system-error-codes.html


166 Chapter 10



A Appendix
This appendix provides you with additional information relevant to HP SH 
Reporter.

Content Pack Dependencies

The following table lists the Content Packs and their respective dependencies; 
that is, the core files that must be installed along with the selected Content 
Packs.

Content Pack Dependency

Active_Directory CMDBCore, System_Management

Application_Server Core, Virtual_Env_Management_PA

Appserver_Weblogic Core, System_Management, OM, 
Application_Server

Appserver_WebSphere Core, System_Management, OM, 
Application_Server

BPM CMDBCore, System_Management, 
Real_User_Monitor

CMDBCore Core

Core No dependencies

Database_MSSQL CMDBCore, 
Virtual_Env_Management_PA

Database_Oracle CMDBCore, 
Virtual_Env_Management_PA
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Supported HP Products

This section provides a list of the supported HP products from where HP SH 
Reporter can collect the data for each Content Pack in the following 
deployment scenarios:

Exchange_Server CMDBCore, System_Management

OM CMDBCore

OMi CMDBCore, Core_BSM

Core_BSM Core, CMDBCore

Real_User_Monitor CMDBCore, 
Virtual_Env_Management_ESX_SiS
_Coda, 
Virtual_Env_Management_ESX_PA, 
BPM

System_Management CMDBCore

System_Management_PA CMDBCore, System_Management

System_Management_SiS CMDBCore, System_Management

System_Management_SiS_Coda CMDBCore, 
System_Management_SiS

Virtual_Env_Management_PA System_Management_PA

Virtual_Env_Management_ESX_PA Virtual_Env_Management_PA

Virtual_Env_Management_ESX_SiS
_Coda

Virtual_Env_Management_ESX_PA, 
System_Management_SiS_Coda

Content Pack Dependency
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BSM Service and Operations Bridge

In this deployment scenario, RTSM is the source of the topology information 
for HP SH Reporter. The following table lists the supported Content Pack 
integrations.

Content Pack Integrated Products Description

System_Management_PA
System_Management_SiS_C
oda
Virtual_Env_Management_E
SX_SiS_Coda
Virtual_Env_Management_E
SX_PA
Virtual_Env_Management_P
A

HP Performance Agent
SiteScope
HP Operations Agent
Systems Infrastructure Smart 
Plug-in (SPI)
Virtualization Infrastructure 
SPI

Data source for system 
management and 
virtualization data. Systems 
Infrastructure SPI and 
Virtualization 
Infrastructure SPI are 
required for the discovery of 
the CIs.

BPM Business Process Monitor Data source for applications 
monitored by Business 
Process Monitor.

Real_User_Monitor Real User Monitor Data source for applications 
monitored by Real User 
Monitor.

OM HPOM for Unix
HPOM for Linux
HPOM for Solaris
HPOM for Windows

Data sources for events from 
HPOM.

OMi BSM Operations Management 
(OMi)

Data source for events from 
OMi.

Core_BSM BSM Service Health Data source for Key 
Performance Indicators 
(KPIs) and Health 
Indicators (HIs) from BSM 
Service Health.
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Exchange_Server Microsoft Exchange Server 
SPI

Data source for the 
application data from 
Microsoft Exchange Server.

Database_Oracle Database Oracle SPI Data source for the 
application data from the 
Oracle database.

Database_MSSQL Database Microsoft SQL 
Server SPI

Data source for the 
application data from 
Microsoft SQL Server.

Appserver_WebSphere WebSphere SPI Data source for the 
application data from 
WebSphere Application 
Server.

Appserver_Weblogic WebLogic SPI Data source for the 
application data from 
WebLogic Application 
Server.

Active Directory Microsoft Active Directory 
SPI

Data source for the 
application data from 
Microsoft Active Directory.

Content Pack Integrated Products Description
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Application Performance Management

In this deployment scenario, RTSM is the source of the topology information 
for HP SH Reporter. The following table lists the supported Content Pack 
integrations.

Content Pack Integrated Products Description

System_Management_SiS_C
oda
Virtual_Env_Management_E
SX_SiS_Coda

SiteScope Data source for system 
management and 
virtualization data.

OM HPOM for Unix
HPOM for Linux
HPOM for Solaris
HPOM for Windows

Data sources for Events 
from HPOM.

BPM Business Process Monitor Data source for applications 
monitored by Business 
Process Monitor.

Real_User_Monitor Real User Monitor Data source for applications 
monitored by Real User 
Monitor.

Core_BSM BSM Service Health Data source for Key 
Performance Indicators 
(KPIs) and Health 
Indicators (HIs) from BSM 
Service Health.
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HPOM

In the HPOM deployment scenario, the HPOM database server is the source 
of the topology information for HP SH Reporter. Following are the supported 
Content Pack integrations.

Content Pack Integrated Products Description

System_Management_PA
Virtual_Env_Management_E
SX_PA

HP Performance Agent
HP Operations Agent
Systems Infrastructure Smart 
Plug-in (SPI)
Virtualization Infrastructure 
SPI

Data source for system 
management and 
virtualization data. Systems 
Infrastructure SPI and 
Virtualization 
Infrastructure SPI are 
required for the discovery of 
the CIs.

OM HPOM for Unix
HPOM for Linux
HPOM for Solaris
HPOM for Windows

Data sources for events from 
HPOM.

Exchange_Server Microsoft Exchange Server 
SPI

Data source for the 
application data from 
Microsoft Exchange Server.

Database_Oracle Database Oracle SPI Data source for the 
application data from the 
Oracle database.

Database_MSSQL Database Microsoft SQL 
Server SPI

Data source for the 
application data from 
Microsoft SQL Server.
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For information about the supported versions of the listed products, see the 
HP Service Health Reporter Software Support Matrix document.

Appserver_WebSphere WebSphere SPI Data source for the 
application data from 
WebSphere Application 
Server.

Appserver_Weblogic WebLogic SPI Data source for the 
application data from 
WebLogic Application 
Server.

Active Directory Microsoft Active Directory 
SPI

Data source for the 
application data from 
Microsoft Active Directory.

Content Pack Integrated Products Description
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We appreciate your feedback!
If an email client is configured on this system, click    

If no email client is available, copy the following information to a new message 
in a web mail client and send the message to docfeedback@hp.com.

Product name and version: HP Service Health Reporter 9.10

Document title: Installation and Configuration Guide

Feedback:   

               

mailto:docfeedback@hp.com ?
Subject=Feedback on HP Service Health Reporter 9.10 Installation and Configuration Guide
&body=Please enter your comments here:
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