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1
About Web Intelligence

How Web Intelligence performs business intelligence over the web
Web Intelligence provides business users an easy to use interactive and flexible user 
interface for building and analyzing reports on corporate data over the web, on secured 
intranets and extranets. The Web Intelligence software is installed by your administrator on 
a web server on your corporate network.

To use Web Intelligence from you local computer, you log into the business intelligence 
portal InfoView via your Internet browser. Then, depending on your security profile, you 
can interact with the reports in corporate documents or edit or build your own documents 
using a Web Intelligence report panel or query panel.

Interacting with Web Intelligence reports
Depending on your security profile and on how Web Intelligence is deployed across your 
organization, you can view, analyze, or enhance and modify the data displayed in 
reports.

Viewing and printing reports
Once logged into the business intelligence portal InfoView, you can access Web 
Intelligence documents and view reports. Onscreen navigation is made easy with 
page-to-page navigation buttons and a document map that allows you to jump from 
section to section or report to report.

The same document can provide the information adapted to each user due to prompts that 
request each user, who opens the document, to specify the data they want to return to the 
reports.

When you print reports, Web Intelligence automatically generates a copy of reports in 
Portable Document Format (PDF) format for optimum print quality.

Drilling results
Drilling on Web Intelligence reports in HTML or in Interactive format enables you to 
analyze the detailed data behind the displayed results. You can turn the report you are 



About Web Intelligence12

viewing into a drillable report or drill on a duplicate of the original report to retain a 
version of the results before your drill analysis.

Once you have found the information you need, you can save a snapshot of the drilled 
report to share the results of your analysis with other Web Intelligence users, or save the 
document in Excel or Portable Document (PDF) format to print or email to other business 
contacts.

Performing on-report analysis
Viewing Web Intelligence reports in Interactive view format enables you to enhance 
reports and fine-tune the data reports contain, to highlight the information that most 
interests you on demand.

On-Report Analysis is designed for:

• users who need to build queries and then want to build reports
• report consumers who need to manipulate the reports created by others 

With On-Report Analysis you can:

• view document metadata to understand the data behind reports and see how reports 
are structured and filtered 

• filter and sort results
• add new tables and charts
• add formulas and create variables
• format and change the layout of charts and tables
• slice and dice results by adding other data to charts and tables

Full information on how to use On-Report Analysis can be found in this guide.
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Note:  On-report analysis of Web Intelligence reports in Interactive view format is only 
available, if your administrator has deployed Web Intelligence in JSP mode.

Creating and editing Web Intelligence documents
You can create or edit Web Intelligence documents using one of several tools:

• Query – HTML
• Java Report Panel
• HTML Report Panel

This section explains the differences between each tool.

Web Intelligence Query – HTML
Designed for users requiring a pure HTML environment to build queries, Web Intelligence 
Query – HTML offers the ability to define the data content of documents on multiple data 
sources. You can use Query – HTML to create new documents from scratch or edit the 
queries in documents created using any of the other Web Intelligence tools.

Used together with On-Report Analysis, Query – HTML provides a complete solution for 
building queries and designing powerful reports in a pure HTML environment. Once you 
have run the queries to generate a standard report, you can leverage Web Intelligence 
On-Report Analysis features to format multiple reports, add formulas, and create variables.
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Note:  Web Intelligence Query – HTML and On-Report Analysis in Interactive view format 
are only available, if your administrator has deployed Web Intelligence in JSP mode.

Web Intelligence Java Report Panel
The Java Report Panel is designed for users who need more flexibility with designing 
report layout and defining formulas and variables. A graphical Formula Editor enables 
you to build formulas rapidly using drag-and-drop.
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Note:  The Web Intelligence Java Report Panel is available if your administrator has 
deployed Web Intelligence in ASP mode and if your administrator has deployed Web 
Intelligence in JSP mode.

Web Intelligence HTML Report Panel
Designed for users who need to build basic reports, the HTML Report Panel provides query 
and report features in a simple wizard-like interface. Each document is based on a single 
data source and can contain multiple reports, displaying different subsets of information.

In addition, the HTML Report Panel is 508 compliant and can be customized for 
specialized deployments.

Note:  The Web Intelligence HTML Report Panel is only available, if your administrator has 
deployed Web Intelligence in JSP mode.

This guide tells you how to build and format Web Intelligence reports using On-Report 
Analysis. For information on building queries using Web Intelligence Query – HTML, see 
Building Queries Using Web Intelligence Query – HTML. For information on using the 
Web Intelligence Java Report Panel, see Building Reports Using the Web Intelligence 
Java Report Panel. For information on using the Web Intelligence HTML Report Panel, 
see Building Reports Using the Web Intelligence HTML Report Panel.
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2
Accessing Web Intelligence via InfoView

Overview
You access Web Intelligence reports via InfoView, the corporate business intelligence 
portal. 

This chapter tells you how to:

• log into InfoView
• log out of InfoView

Logging into InfoView
You access Web Intelligence by using your web browser to log into InfoView, the 
corporate business intelligence portal. Once you are in InfoView, you can analyze and 
enhance Web Intelligence reports.

Before you can use InfoView and Web Intelligence you need the following information:

• a URL to the InfoView server
• the InfoView server name and port number
• your login and password
• your authentication, which controls the InfoView resources available to you

Note:  Contact your administrator for this information, if necessary.

To log into InfoView

1. Launch your web browser.
2. Point your browser to the InfoView bookmark or URL.

The InfoView login page appears.
3. If the System box is blank, type the name of the InfoView server followed by a colon 

(:), and then type the port number.
For example, if the name of the InfoView server is corpbusintell and the port number is 
4200, then type: corpbusintell:4200

Your administrator can provide you with this system information.
4. In the Username box, type your user name.
5. In the Password box, type your password.
6. In the Authentication box, select the authentication provided to you by your 

administrator.
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7. Click Log On.
The InfoView home page appears.

Logging out of InfoView
When you finish using InfoView or Web Intelligence you need to log out, instead of simply 
closing your web browser.

Logging out of InfoView:

• ensures that any preferences you modified during your InfoView session are saved
• lets your administrator track how many users are logged into the system at any given 

time and thus optimize InfoView and Web Intelligence performance

Note:  Before logging out of InfoView, save any documents you have open. For 
information on saving documents, see ”Saving Web Intelligence documents to InfoView” 
on page 248.

To log out of InfoView

1. Click the Logout button.
The login page appears. You are logged out of InfoView.
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3
Setting your Web Intelligence options

Overview
Before you start to use Web Intelligence, you need to set your Web Intelligence Document 
Preferences appropriately to suit your query and reporting needs. This chapter explains:

• how to set your view format options to enable on-report formatting, calculations, filters, 
and analysis on the fly

• how drill options to perform slice-and-dice analysis on results
• how to set your workspace preferences and reporting rules

Selecting Web Intelligence view formats
You can select different view formats for Web Intelligence documents depending on how 
you want to interact with the information displayed on the reports. You select your Web 
Intelligence view options in InfoView. When you modify your view options, the new 
settings are implemented the next time you open a Web Intelligence document.

To select a format to view documents

1. Click the Preferences button on the InfoView toolbar.
2. Click the Web Intelligence Document Preferences tab.

The Web Intelligence Document Preferences page appears.
3. In the Select a view format section, select the view format you want.

Use the following table to help you select the appropriate format:

If you want to... then select...

Open reports, answer prompts, 
navigate reports, and/or 
perform drill analysis,

HTML
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NOTE: Interactive view format is only available if your administrator has 
deployed Web Intelligence in JSP mode.

NOTE: To open files in Portable Document Format (PDF), you need Adobe Acrobat 
Reader installed on your computer. You can download Acrobat Reader free from 
the Adobe web site (visit www.adobe.com). 

1. Click OK.
Any documents you already have open are not affected by the new settings. The new 
settings are activated the next time you open a Web Intelligence document.

Selecting your Drill options
Drilling on reports lets you look deeper into data to discover the details behind a good or 
bad summary result displayed on a table, chart, or section. Before you begin a drill 
session, you can set your drill options in InfoView to specify how reports will change each 
time you drill. This section tells you:

• what drill options are available to you

Modify formatting and data 
displayed on tables and charts, 
define filters, sorts, formulas, 
and and variables, and/or 
perform drill analysis,

If you also want to modify the 
data definition of a document 
by editing the queries, it is 
recommended you select Query 
– HTML as your report panel. 
Using Query – HTML and 
Interactive view format provides 
you with a complete solution for 
building queries and designing 
reports in a pure HTML 
environment. For more 
information, see Building 
Queries Using Web Intelligence 
Query – HTML.

Interactive

View static reports, Portable Document Format

If you want to... then select...

http://www.adobe.com
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• how to select the drill options appropriate for your analysis

Available drill options
This section describes the various options available to you when you perform drill analysis 
on Web Intelligence reports.

Start drill on the existing report or on a duplicate report
When you drill on a report, you can:

• Start drill on the existing report – the current report becomes drillable and when you 
end drill mode, the report displays the drilled values.
Or

• Start drill on a duplicate report – InfoView creates a duplicate of the current report 
and you drill on the duplicate. This means you can compare the results of the original 
report with the results you discover during your drill analysis.

Being prompted if a drill action requires additional data
When you drill the results displayed on a Web Intelligence report, you may want to drill to 
higher- or lower-level information that isn’t included in the scope of analysis for the 
document. When this is the case, Web Intelligence needs to run a new query to retrieve 
the additional data from the data source.

Since queries on large selections of data may take a long time to be completed, you can 
choose to be prompted with a message every time a new query is necessary. The prompt 
message asks you whether you want to run the additional query or not. In addition, the 
prompt lets you apply filters to the extra dimensions you include in the new query. This 
means you can restrict the size of the query to only the data necessary for your analysis.

Note:  You need permission from your administrator to drill out of the scope of analysis 
during a drill session.

Synchronizing drill on all tables and charts in the report
Each table, chart, or free standing cell in a report represents a specific block of data. 
There are two ways to drill on a report that contains multiple blocks:

• synchronize drill on all report blocks
• drill on only the selected block
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The following example shows how each option affects a report as you drill down on the 
Bahamas Beach resort in a table to analyze detailed results per service line.

Showing or hiding the Drill toolbar
When you drill on a value displayed on a report, the drill toolbar appears and displays 
the value on which you drilled. The value displayed on the toolbar filters the results 
displayed on the drilled report.

For example, if you drill on year 2001, the results displayed on the drilled table are Q1, 
Q2, Q3, and Q4 for year 2001. This means that the quarterly values you drilled to are 
filtered by 2001.

In this example, Synchronize drill on report blocks is selected in 
your view options, so both the table and the chart display the drilled 

In this example, Synchronize drill on report blocks is 

The drill toolbar displays 
the value that filters the 
drilled results



Performing On-Report Analysis with Web Intelligence 27

Note:  If the drilled report includes dimensions from multiple queries, a ToolTip appears 
when you rest your cursor on the value displayed on the filter. The ToolTip displays the 
name of the query and the dimension for the value.

The Drill toolbar allows you to select alternative values on the same level, in order to filter 
the results differently. For example, if you use the Drill toolbar illustrated above to select 
“2002,” the results displayed on the drilled table would be Q1, Q2, Q3, and Q4 for year 
2002.

You can opt to hide the Drill toolbar when you start drill mode. The Drill toolbar is only 
useful if you want to select filters during your drill session.

Setting your drill options
You set your drill options in InfoView. When you change your drill options, the changes 
are implemented the next time you start Drill mode.

To set your drill options

1. On the InfoView toolbar, click Preferences.
2. Click the Web Intelligence Document Preferences tab.

The Web Intelligence Document Preferences page appears.
3. In the Select a view format section, select HTML or Interactive.

For information about the difference between these View formats, see ”To select a 
format to view documents” on page 23.

4. In the For each new drill session section, choose whether to drill on the existing 
report or on a duplicate report:

If you want Web Intelligence to... then select...
retain a copy of the original 
report, so that you can compare 
the drilled results to the results on 
the original report,

Start drill on a duplicate report

drill on the existing report, so that 
the original report becomes 
modified by your drill actions,

Start drill on the existing 
report
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1. In the General drill options section, select the options to apply during your drill 
sessions:

1. To apply the new drill settings, click OK.
The modifications are implemented the next time you open a Web Intelligence 
document and start Drill mode.

Note:  There is an additional drill option, Use query drill, that you set at the document level 
rather than in InfoView. Query drill is a special drill mode designed for drilling on 
aggregates in databases like Oracle 9i OLAP. For more information, see ”Using query 
drill” on page 55.

Setting your personal preferences
You can choose personal preferences for how you want Web Intelligence to appear on 
your desktop and how you want some of the reporting options to be applied every time 
you use them.

• My Workspace preferences – define how the Web Intelligence, toolbars, and menus 
appear on your desktop

• Reporting Rules – define how Web Intelligence applies reporting options (such as 
breaks, sorts, and drill), when you use them on reports

If you want Web Intelligence to... then select...
prompt you whenever a drill action 
requires a new query, so that Web 
Intelligence can extend the scope of 
analysis and add more data to 
reports,

Prompt if drill requires 
additional data

For more information, see 
”Being prompted if a drill 
action requires additional data” 
on page 25.

synchronize drilling on all report 
blocks,

Synchronize drill on report 
blocks

For more information, see 
”Synchronizing drill on all 
tables and charts in the report” 
on page 25.

hide the drill toolbar when you 
switch to drill mode,

Hide drill toolbar

For more information see 
”Showing or hiding the Drill 
toolbar” on page 26.
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Note:  If your security profile enables you to define the data included documents, by 
building queries, the ability to define your query rules is also available. For information 
about defining your query rules, see Building Queries Using Web Intelligence Query- 
HTML.

Note:  To set these preferences you need to have a Web Intelligence document open.

To set the display properties of your Web Intelligence workspace

1. With a Web Intelligence document open, click the arrow next to View on the main 
toolbar above the selected report.
For step-by-step information on how to open Web Intelligence documents, see ”To 
open a document and view results in reports” on page 33.

2. Click Preferences.
The Preferences dialog box appears.

3. Make sure the My Workspace tab is selected.
4. Use the following table to help you select the appropriate options:

1. Click OK.

If you want to... then...

Adjust the measurement unit 
used to position the different 
elements on reports,

• Select the arrow next to 
Measurement unit

• Select Inches or 
Centimeters

When you use the contextual 
menu, display the name of the 
part of the report you have 
selected at the top of the menu,

• Select Display the name of 
the selected report element 
on contextual menus

Make the contextual menu 
available, when you place your 
pointer on areas of reports,

• Select Activate contextual 
menus using mouseover

Make the contextual menu 
available, when you right-click 
areas of reports,

• Select Activate contextual 
menus using right-click

Deactivate the contextual menu, 
and only use the toolbar buttons 
and menus to interact with 
reports,

• Select Do not activate 
contextual menus
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Web Intelligence applies the preferences you selected the next time you open a Web 
Intelligence document.

To define your reporting rules

1. Click the arrow next to View on the main toolbar above the selected report.
2. Click Preferences.

The Preferences dialog box appears.
3. Make sure the Reporting Rules tab is selected.
4. Select the appropriate options.

The following table provides information on the options:

If you want to... then...

apply the formatting options you 
select for reports automatically, 
as soon as you select each 
option,

• Check Apply format 
modifications automatically 

display column and row headers 
on tables without breaks,

NOTE: For more 
information, see 
”Inserting, removing, and 
prioritizing breaks” on 
page 172.

• Check Add table header 
when the last break is 
removed from a table

to apply the last sort you add on 
a table first,

• Select The last sort added 
always takes precedence

to apply the last sort you add on 
a table last,

• Select The last sort added is 
applied after any other 
sorts

during a drill session, highlight 
cells you drill with the format 
specified by default

• Select Apply the default 
format settings to drillable 
cells when selected
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1. Click OK.
Web Intelligence applies the preferences you selected the next time you open a Web 
Intelligence document.

Setting the format locale
The format locale determines the language-specific appearance and behavior of Web 
Intelligence documents. The format locale affects, for example, date formats, number formats 
and the order of sorts. 

By default, the document locale is the same as the user interface locale. For example, if the 
user interface is in English, the document formatting follows English rules.

You can save a document with a format locale that is different from the user interface 
locale. To do so, select a locale from the Select a format locale list. If, on next opening 
the document, you choose to maintain the format locale (see ”Choosing the format locale 
on opening a document” on page 32), the document behaves according to the format 
locale you specified. For example, if you specified French (France) as the format locale 
and you open the document through an English user interface, the document is formatted 
and behaves according to French formatting rules. You enter decimal numbers according 
to the English format (3.51) but they appear in the document in the French format (3,51).

Viewing the format locale
You view the document format locale either through the document properties or the 
GetContentLocale() function. For information on how to view the document propeties, see 
”Viewing document properties” on page 79. For information on the GetContentLocale() 
function, see the online help.

during a drill session, highlight 
cells you select for drill with the 
color and font format you 
specify,

• Select Apply custom 
highlighting to drillable 
cells when selected, as 
defined here:
• To format selected cells 

with underlined text, click 
Underlined

• To format selected cell 
backgrounds with a color, 
click the arrow next to 
Background color, then 
select a color

• To format selected cell 
contents with a color, click 
the arrow next to Text 
color, then select a color

If you want to... then...
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Choosing the format locale on opening a document
You can choose whether a document should use the format locale with which it was saved 
or your current format locale. You do so by setting the When viewing a document 
option. If you choose Use the document locale to format the data, Web Intelligence 
uses the formatting locale with which the document was last saved, and saves the 
document with this format locale the next time you save it. If you choose Use my 
formatting locale to format the data, Web Intelligence uses your current formatting 
locale, and saves the document with this locale the next time you save it.

Permanently associating a locale with a document
You can permanently associate a formatting locale with a document by selecting the 
Permanent Regional Formatting option when saving the document. (See ”Saving Web 
Intelligence documents to InfoView” on page 248.) In this case the When viewing a 
document setting has no effect - the document always behaves according to the format 
locale with which it was saved.

Summary of locale settings
The following table summarizes format locale settings:

Setting Description

Select a format locale The document format 
locale (by default the 
same as the user 
interface locale).

When viewing a 
document...

Note:  This setting is 
ignored if the document 
was saved with the 
Permanet Regional 
Formatting option 
checked

Use the document 
locale to format 
the data

Use the format locale 
with which the 
document was last 
saved to format the 
data.

Use my 
formatting locale 
to format the data

Use the current format 
locale to format the 
data.
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4
Navigating reports

Overview
• This chapter tells you how to access and navigate Web Intelligence reports. It includes 

information on:
• accessing Web Intelligence documents, from among documents in InfoView
• refreshing results in reports, by retrieving the latest data from the database
• answering prompts, by specifying the values you want to analyze before generating the 

reports
• navigating reports, using the quickest path to the information that interests you
• searching for text in reports, to find specific data
• viewing the document overview, to understand the data the reports contain and how the 

document is designed

Accessing documents to view reports
You access documents and reports via InfoView.

Note:  Before opening a document, set your Web Intelligence document preferences to the 
view format and drill options that best suit your reporting needs. See ”To select a format to 
view documents” on page 23 and ”To set your drill options” on page 27.

To open a document and view results in reports

1. Make sure you are logged into InfoView.
For full information, see ”To log into InfoView” on page 17.

2. On the InfoView home page, navigate to the document you want to open.
You do this by clicking the folders in My Folders or Public Folders, or by entering a 
keyword or the title of the document in the Search box on the InfoView home page.
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The list of documents appears.

3. Click the document title.
4. If the document contains any prompts that need to be refreshed, you need to select or 

type the value(s) you want returned to the document, and then click Run Query.
For more information, see ”Refreshing results to view the latest results” on page 34.
The results appear on the reports.

Refreshing results to view the latest results
You refresh a document to update the results displayed in its reports with the latest data 
available on the database. When you refresh a document, Web Intelligence retrieves 
the data from the database and returns the up-to-date results to the reports.

Web Intelligence documents can be set to refresh:

• manually – once you have opened a document you can refresh the data yourself to see 
the latest results

• on open – Web Intelligence refreshes the data automatically each time you open the 
document

Note:  You may need to answer prompts, before Web Intelligence can refresh results. For 
information on answering prompts, see ”Answering prompts” on page 35.

To refresh reports manually to see the latest results

• With a report in a Web Intelligence document open, click Refresh Data on the right of 
the main toolbar above the report.
Web Intelligence starts to retrieve the latest data from the database. A message 
appears to tell you how long the data retrieval will take, based on the time it took Web 
Intelligence to retrieve the results the previous time the document was refreshed.
The updated results appear in the reports.

To set a document to refresh automatically when it is opened

1. With a report in a Web Intelligence document open, click the arrow next to Document 
on the main toolbar.

2. Select Properties.
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The Document Properties dialog box appears.
3. Select Refresh on open.
4. Click OK.

Once you have saved the document, Web Intelligence refreshes the results in reports 
automatically each time you re-open it.

Answering prompts
Prompts are dynamic filters that display a question or a list of values each time you refresh 
the data in a Web Intelligence document. You answer the prompt by typing or selecting 
specific values. Web Intelligence retrieves the data that corresponds to those values and 
returns the filtered data to the document. Using prompts lets you limit the document data to 
the specific information that interests you.

For example, you can specify different time periods, product lines, geographies, or 
customer accounts each time you refresh the document and only display the values for the 
information you requested. A single document can contain one or multiple prompts.

To enter value(s) for prompts to view specific data in reports

1. With a report in a Web Intelligence document open, click Refresh Data on the right of 
the main toolbar above the report.
The Prompts dialog box appears.

2. Select a prompt question.
If the prompts are organized hierarchically in a tree, you need to select the prompt at 
the lowest level of the hierarchy first. This type of prompt is referred to as a cascading 
prompt. For more information, see ”Cascading prompts” on page 37.
The values you can choose are listed in the pane on the lower left.

If the prompt has been answered previously, the values selected the last time appear in 
the prompt answer pane on the right. You can either leave those values selected or use 
the << button to remove them.
The options you see when you answer prompts depend on (1) whether this is the first 
time the results have been refreshed or not and (2) the properties set for the prompts 
when they were created.
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3. Select the values from the list of choices in the pane on the left, for which you want to 
view results, or type the values into the text box, and click the >> button to add them to 
the prompt answer box on the right.

NOTE: If you type multiple values, you need to separate each value with a 
semi-colon (;). For example: Florida;Texas

4. Click Run Query.
Web Intelligence retrieves the data for the values you specified, and returns the results 
to the reports.

Viewing and answering prompts in the Left Panel

1. Make sure that the Left Panel is displayed by selecting View > Left panel on the Main 
toolbar.

2. Select User Prompt Input from the list at the top of the Left Panel.
The list of prompts and their values appears in the Left Panel.

3. Type the new prompt value in the box beneath the prompt name , then click Run, or
4. Click Advanced to display the Prompts dialog box and answer the prompt there as 

described in ”To enter value(s) for prompts to view specific data in reports” on 
page 35.
Web Intelligence refreshes the report with the new prompt value(s).

To enter dates to answer a prompt

1. With a report in a Web Intelligence document open, click Refresh Data on the right of 
the main toolbar above the report.
The Prompts dialog box appears.

2. To select a date, click the arrow to the right of the text box, select a date from the 
popup calendar, and then click the >> button to add the date you selected to the list on 
the right.
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If the prompt has been answered previously, the values selected the last time appear in 
the prompt answer pane on the right. You can either leave those values selected or use 
the << button to remove them.

3. If the prompt allows you to select multiple dates, and you want to view results for more 
than one date, repeat step 2.

4. Click Run Query.
Web Intelligence retrieves data for the values you specified, and returns the results to 
the reports.

Cascading prompts
Some prompts are cascading prompts. Cascading prompts allow you to focus on the data 
that interests you without the need to search large amounts of data that does not. For 
example, if you want to include a particular store in a prompt, you can restrict the number 
of stores that you need to search by first selected the store city. When you do so, you see 
only those stores in the city.

When you refresh a document containing cascading prompts, Web Intelligence displays a 
hierarchy of prompts that you answer to arrive at the value that you want to include in your 
report.

Note:  The lists of values of objects that trigger cascading prompts are specially defined in 
the universe to display hierarchically. When a prompt includes such an object, Web 
Intelligence automatically displays the prompt as a cascading prompt.

Example:  Choosing a store

In this example you have a prompt Store Name Equal To <value>. The Store Name object is 
designed in the universe with a hierarchical list of values. When you refresh the document, 
Web Intelligence displays a hierarchy of prompts in the Prompts dialog box to help you 
isolate the store you are looking for. 
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In order to select the store, you must first select the state in which the store city is found, 
then the city in which the store is found, then the store itself. When you select the state, 
Web Intelligence restricts the cities in the list of values of the “Which city is the store in?” 
prompt to the cities in the state; when you select the city, Web Intelligence restricts the 
stores list of values to the stores in the city.

By answering each prompt in turn you arrive at the store name(s) you are looking for.

Finding your way around reports
There are several ways to navigate reports to focus on the information that most interests 
you. This section tells you how to:

• optimize how reports display for onscreen viewing
• view reports in page mode or draft mode
• zoom in or out of reports
• navigate directly to specific reports, sections, and pages

Using Enhanced viewing mode for onscreen viewing
Your administrator can define minimum page margins, headers and footers that are 
applied only when you view reports onscreen. This means that the maximum amount of 
information on report pages is visible when you view reports via your computer screen. To 
apply the page definition set up by your administrator you need to select Enhanced 
viewing mode.
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Note:  The page margins, headers and footers implemented by Enhanced viewing mode 
do not impact the page definition you can apply to reports.

To select Enhanced viewing mode

1. With a report in a Web Intelligence document open, click the arrow next to Document 
on the main toolbar above the report.

2. Click Properties.
The Document Properties dialog box appears.

3. Select Enhanced viewing mode.
4. Click OK.

Web Intelligence applies the page definition optimized for onscreen viewing defined 
by your administrator.

Viewing reports in page mode and draft mode
You can view reports in two viewing modes:

• Page mode – displays the page layout of reports, including page margins, headers, 
and footers

• Draft mode – displays just the tables, reports, and free standing cells in reports

Use Page mode when you want to fine-tune the formatting of tables and charts and the 
layout of report pages. Use Draft mode when you want to focus on analyzing results, add 
calculations or formulas, or add breaks or sorts to tables to organize results.

To switch between viewing modes

1. With a report in a Web Intelligence document open, select the report tab of the report 
you want to view.

2. Click the arrow next to the View button on the main toolbar above the report.
3. Select Page mode or Draft mode.

Web Intelligence displays the selected report in the selected view mode.

Zooming in on results
You can zoom in or out to enlarge or reduce the size at which reports display.

To use zoom

1. With a report in a Web Intelligence document open, verify that the report tab of the 
report you want to view is selected.

2. Click the arrow next to the Zoom drop-down list box on the main toolbar above the 
report.

3. Select the display scale percentage at which you want the report to display.
Web Intelligence applies the zoom you specified to the report.
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Navigating to results in reports
To find the results you are looking for quickly in documents, you can navigate directly to:

• reports
• sections
• pages

To navigate report-to-report

1. Click the report tab of a report.
Web Intelligence displays the report for the selected tab.

To navigate to a section

1. With a report in a Web Intelligence document open, make sure that the Document 
Properties pane is displayed to the left of the selected report.
To display the Document Properties pane, click the Show left pane arrow at the top left 
of the report.

2. Click the arrow to the right of the drop-down list box, then select Navigation Map.
The structure of the document appears with bookmarks to the reports and sections.

3. Click the section you want to view.
The section you selected appears at the top of the report viewing area.

To navigate page-to-page

1. With a report in a Web Intelligence document open, verify you are viewing the 
document in page mode.
If you need to change from Draft mode to Page mode, click the arrow next to View 
on the main toolbar, and then select Page mode.
The page forward and page back arrows appear on the main toolbar.

2. Use the arrows or type a page number into the text box.
Web Intelligence displays the page you specified.

Searching for text in reports
You can use the Search feature to find specific character or numeric strings on report 
pages quickly. This is useful if you are viewing long reports and want to know the results 
for a specific item, such as a specific customer or invoice number.

To search for a text string on a report page

1. Make sure that the Document Properties pane is displayed to the left of the selected 
report.
To display the Document Properties pane, click the Show left pane arrow at the top left 
of the report.

2. Click the arrow to the right of the drop-down list box, then select Find.
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The search options appear.

3. In the text box below Find:, type the string of characters and/or numbers you want to 
find.

4. If you only want to find exact matches to the string you typed, check Match whole 
word.

5. If you want the search to be case sensitive, check Match case.
By default, Web Intelligence searches the report page downwards.
Web Intelligence highlights the first occurrence of the string you specified.

6. To search for more occurrences of the same string, click Find Next.
7. If you want Web Intelligence to search the report page upwards, click Up, then click 

Find Next.

Viewing the document overview
The Document Properties pane provides you with information on the queries and data 
behind the reports. It also shows you how the document is structured into reports and 
sections, and lists the filters and prompts that fine-tune the results. Lastly, it lists the objects 
you can add to reports to include more data, and the table and chart types you can use to 
format the data into meaningful results. 

The following table provides information on the different overviews available in the 
Document Properties pane:

This overview... provides you with...

Document Summary

NOTE: You can print out the 
Document Summary, see ”To 
print out the Document 
Summary” on page 43

information on:

• the document author, 
creation date and the date, 
when the results were last 
refreshed with data from 
the database

• each data source or query 
in the document

• each object in each query
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To view an overview

1. Make sure the Document Properties pane is displayed to the left of the selected 
report.
To display the Document Properties pane, click the Show left pane arrow at the top 
left of the report.

2. Click the arrow to the right of the drop-down list box.

Chart and Table Types predefined formats for charts, 
tables, forms, and cells you 
can add to reports

Available Objects the list of objects that you can 
add to reports (each object 
represents a set of data on the 
database)

Document Structure and Filters an outline of how the 
document is structured and 
displays information on any 
filters that are used to filter the 
results

Navigation Map hyperlinked bookmarks to the 
reports and sections in the 
document

User Prompt Input information on any prompts 
that filter the results (you can 
input different values for the 
prompts and so retrieve 
different results to reports)

Find search options to find a 
specific character or numeric 
string on the selected report 
page

This overview... provides you with...
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3. Select the overview you want to view.

The list you selected appears.

To print out the Document Summary

1. Make sure the Document Properties pane is displayed, to the left of the open report, 
and that Document Summary is selected.

2. Click Printer Friendly.
The Printer Friendly Options dialog box appears.
You can print all or part of the Document Summary information.

3. Select General, Queries, Objects, and Prompts as appropriate.
4. Click OK.

Web Intelligence connects to your default printer and displays the corresponding print 
options.

5. Follow your usual printing procedure.

In this example, the 
Navigation Map is selected
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5
Analyzing results

Overview
Drill analysis allows you to look deeper into the reasons behind results displayed in 
reports. This chapter includes information on:

• how drill analysis works
• starting to drill
• drilling on tables
• drilling on section cells
• drilling on charts
• changing how drilled results are filtered
• drilling beyond report results
• saving drilled results and ending Drill mode
• using query drill

How drill analysis works
Drilling on reports lets you look deeper into data to discover the details behind a good or 
bad summary result displayed on a table, chart, or section. For example if a table includes 
sales results per quarter and you want to analyze the results for each month in Q4, you 
can drill down on “Q4.” The drilled report displays the results for each month in Q4.

If you then want to analyze why a monthly result is significantly low or high in Q4, you 
can drill across to other business indicators included in the scope of the document, such as 
region or service. For example, if you drill by “Region,” the drilled report displays results 
for the drilled month in Q4 broken out by region. You could then identify which region 
was responsible for the low or high results in that specific month. Drilling thus enables you 
to explore the reasons behind results displayed on reports by analyzing different slices of 
data.

Starting to drill
To start analyzing reports using Drill, you need to switch to Drill mode.

Before your switch to drill mode, you need to verify that your drill options are set 
appropriately. To find out how to modify your drill options, see ”Selecting your Drill 
options” on page 24.
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Note:  You can only drill on reports, if you security profile allows you.

To switch to drill mode

1. Verify that the report you want to analyze is selected.
2. Click the Start Drill Mode button on the main toolbar.

A hyperlink appears on each drillable result.

• ”Drilling on tables” on page 46
• ”Drilling on sections” on page 48
• ”Drilling on charts” on page 50

Drilling on tables
You can drill on:

• dimensions - typically retrieve character-type data.

For example: customer names, line names, or dates

• measures – the result of calculations on data in the database
For example: [Revenue] is the calculation of the number of items sold multiplied by item 
price
When you drill on dimensions, the measures in the drilled table are calculated 
according to the dimensions to which you have drilled. For example, if you drill down 
Year to Quarter, the measures in the drilled table are calculated for quarter instead of 
year:

Table before drill

Table after drill
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When you drill on measures, you drill one dimension down each dimension in the 
table. For example, if you drill on Sales revenue for Year and State, the drill table 
shows sales revenue results for Quarter and City:

To drill down on a dimension value on a table

1. Verify you are working in Drill mode.
The Start Drill Mode button is pressed in when you are in Drill mode.

2. Click the value you want to analyze.
For example, click the name of a customer or product, or click a date.
Drillable values are indicated by hyperlinks.
The drilled results appear on the table.
A filter drop-down box appears at the top of the report. This indicates that the value 
you drilled is filtering the results displayed on the drilled table.

For example, if you drill on [Texas], then the filter displays “Texas” to indicate that the 
results displayed on the drilled table are only for Texas.

To drill up on a dimension value on a table

1. Verify you are working in Drill mode.
The Start Drill Mode button is pressed in when you are in Drill mode.

2. Right-click the drillable dimension, then click Drill Up on the Drill menu.
Dimensions where you can drill up display the drill up arrow. 
Or
Click the Drill Up icon in the column header of the dimension value you want to 
analyze.
The drilled report now displays data one dimension level up.
If a filter has been created in the Drill toolbar due to a drill down action, the filter is 
removed when you drill up.

To drill across dimensions using Drill by

1. Verify you are working in Drill mode.

Table before drill

Table after drill
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The Start Drill Mode button is pressed in when you are in Drill mode.
2. Right-click the drillable dimension, then click Drill By... on the Drill menu.

A series of sub menus list the dimensions to which you can drill.
3. Select the dimension you want to analyze.

The drilled results appear on the table.

To drill on a measure value on a table

1. Verify you are working in Drill mode.
The Start Drill Mode button is pressed in when you are in Drill mode.

2. Right click or rest your pointer on the measure value on which you want to drill.
A contextual menu or ToolTip indicates the next dimension(s) in each related drill path.

3. Click the hyperlinked measure or click the option in the Drill menu.
The report now displays data one dimension level down.

A filter for each related dimension value appears as a list box in the Drill toolbar. These 
filters represent the dimension values that you replaced by your drill action. In the 
example above, filters for Year, Lines, and State appear in the Drill toolbar.

NOTE: If the drilled report includes dimensions from multiple queries, a ToolTip 
appears when you rest your cursor on the value displayed on the filter. The ToolTip 
displays the name of the query and the dimension for the value.

Drilling on sections
To perform drill analysis on results in sections of reports, you drill on the value displayed in 
the section cell. When you drill on section cell, the results on all of the tables or charts in 
the drilled section are modified by your drill action. For example, if you drill on a section 
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cell that displays a value for State, such as “California,” the tables or charts in the drilled 
section display results for City:

To drill on a section cell

1. Verify you are working in Drill mode.
The Start Drill Mode button is pressed in when you are in Drill mode.
Drillable values are indicated by hyperlinks.

2. Right click or rest your pointer on the measure value on which you want to drill.
A contextual menu or ToolTip indicates the next dimension(s) in each related drill path.

3. Click the option in the Drill menu or click the hyperlinked value.
The drilled results appear in the section. A filter for each related dimension value 
appears as a list box in the Drill toolbar. These filters represent the dimension values 
that you replaced by your drill action. 

Section before drill

Section after drill

Section cell
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Drilling on charts
You can drill on:

• chart body – drills to the next dimension up or down and displays the values for the 
drilled dimension on the X-axis. The measures displayed on the chart body are 
re-calculated according to the drilled dimension.

• pie chart legends – this is useful, if you are working with a pie chart, because the axis 
labels, which display the names of the dimensions represented by each pie segment, 
are not often displayed. Also, when a result is low, the segment of the pie can be too 
small to drill.

To drill down on a chart

1. Verify you are working in Drill mode.
The Start Drill Mode button is pressed in when you are in Drill mode.

2. Right click or rest your pointer on the chart bar or marker on which you want to drill 
down.
A contextual menu or ToolTip indicates the next dimension(s) in each related drill path.

3. Click the option in the Drill menu or click the chart bar, line, or marker directly.
The drilled results appear in the chart.

A filter for each related dimension value appears as a list box in the Drill toolbar. These 
filters represent the dimension values that you replaced by your drill action.

To drill up on a chart
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1. Verify you are working in Drill mode.
The Start Drill Mode button is pressed in when you are in Drill mode.

2. Right click or rest your pointer on the chart bar or marker on which you want to drill up.
3. Click the Drill Up arrow on the chart axis or click the chart bar, line, or marker directly.

The drilled results appear in the chart.

To drill on pie chart legend

1. Verify you are working in Drill mode.
The Start Drill Mode button is pressed in when you are in Drill mode.

2. Right click or rest your pointer on the legend value on which you want to drill down.

The drilled results appear in the pie chart.

Changing how drilled results are filtered
When you drill on a dimension or measure value in a table or chart, Web Intelligence 
filters the drilled results by the dimension or measure you drilled on. The filter is applied to 
all of the results displayed on the drilled report.

For example, if you drill down on a table cell displaying “California,” to view results for 
cities in California, Web Intelligence filters the values in the entire report for California and 
only displays results for California in the report. If you want to see results for cities in a 
different US state, such as Florida, on the drilled report you can simply change the filter 
value by selecting “Florida” from the drill filter list box.

Drill up arrow

Legend values
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Note:  You can set your Web Intelligence Document Preferences so that the Drill filters 
are either shown or hidden during your drill sessions. For information on how to do this, 
see ”To set your drill options” on page 27.

To change the values that filter drilled results

1. Verify you are working in Drill mode.
The Start Drill Mode button is pressed in when you are in Drill mode.

2. In the Drill toolbar, click the drop-down arrow in the appropriate list box.

Each dimension value associated with that filter appears. 
3. Click the value you want.

Or
If you want to remove the filter, scroll to the top of the list, and then select ( ) 
<ObjectName>
For example, to remove the filters on the [Lines] dimension, select:
( ) Lines
The report displays results based on the new dimension value.

Drilling beyond report results
When you are drilling a Web Intelligence report, you may want to drill up or down to a 
dimension that lies outside the scope of analysis defined for the document. To return the 
additional data, Web Intelligence must run a new query that includes the additional 
dimension(s) you specify. This is called extending the scope of analysis.

When you extend the scope of analysis, you can select filters to limit the data Web 
Intelligence retrieves when running the new query. This saves time, if you are working with 
a large document. If you have several reports in one document, and you select filters when 
you extend the scope of analysis, those filters affect all the reports in the document.
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Note:  You can only extend the scope of analysis during your drill sessions, if your security 
profile allows you. Your security profile is controlled by your administrator.

If your Drill options are not set to display the Extend the Scope of Analysis prompt message 
during drill, you will not be given the option to select filters if you drill beyond the data 
already available in the document. In this case, Web Intelligence immediately runs a new 
query and returns data for all the values on the dimensions you are drilling. To find out 
how to modify your drill options see, ”To set your drill options” on page 27.

To extend the scope of analysis

1. While in drill mode, drill on a cell value for which no further details are included in the 
data definition behind the reports.
A ToolTip informs you that a new query is necessary to return the 
additional data to the document.

If your Drill options are set for Web Intelligence to prompt you when 
a drill action requires a new query, the Extend the Scope of Analysis 
dialog box appears.

The dialog box lists the dimensions in the hierarchy above and below the drilled value. A 
check box appears next to each dimensions below the current dimension you are drilling, 
so that you can select which of these dimensions you want to retrieve from the database, in 
order to continue your drill action. The dialog box also displays the filters that you can 
select to filter the new query. For example, in the illustration above, Web Intelligence 
suggests you filter the query by limiting the additional data for Lines and Category to data 
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for the Accessories line and the Jewelry category. If you don’t select the filter, Web 
Intelligence will return data for all product lines and categories to the document.

1. Select the check box(es) next to the dimension(s) to which you want to drill.
Selecting filters to limit the new data to data necessary for your drill session reduces the 
time Web Intelligence needs to retrieve the data to the report and minimizes the size of 
the document.

2. Select the check box(es) next to the filters you want to use to filter the query.
3. Click OK.

Web Intelligence runs a new query and returns the additional data to the document.
The results for the dimension you drilled to appear on the table.

NOTE: You need permission from your administrator to drill out of the scope of 
analysis during a drill session.

Saving drilled results and ending Drill mode
When you have finished analyzing results on reports using drill, there are several ways to 
save the drilled results and end your drill session.

• take a snapshot – enables you to keep a record of the drilled results in a static format. 
You can then continue your drill analysis on a duplicate report and keep snapshots of 
different anlayses you perform on the same results.
(For information on duplicating reports, see ”To duplicate a report” on page 77.)

• save the drilled report in drilled mode – enables you to save the results you drilled to 
and keep the report drillable for further analysis during another session 

• end drill mode – enables you to save the drilled results in a static format. If you drilled 
on the original report you lose the results displayed prior to your drill session. If you 
drilled on a duplicate report, you retain the results prior to you drill session on the 
original report and keep a copy of the drilled results in static format on the duplicate 
report.
(For information on how to set your drill options to create a duplicate of the original 
report each time you start drill, see ”To set your drill options” on page 27.)

To take a snapshot of drilled results

1. Verify you are working in Drill mode.
The Start Drill Mode button is pressed in when you are in Drill mode.

2. Click the Snapshot button on the main toolbar above the report.
Web Intelligence saves a copy of the drilled report in results mode.

To save a report in drill mode

1. Verify you are working in Drill mode.
The Start Drill Mode button is pressed in when you are in Drill mode.

2. Click Save on the toolbar above the displayed report.
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The InfoView Save page opens.
3. Save the document in the usual way.

For full information, see ”To save a new Web Intelligence document in InfoView” on 
page 248.
The next time the document is opened, it opens in Drill mode.

To end drill mode

1. Verify you are working in Drill mode.
The Start Drill Mode button is pressed in when you are in Drill mode.

2. Click the Start Drill Mode button.
Web Intelligence returns the drilled report to results mode. The drill filters and the 
hyperlinks on drillable values no longer appear.

Using query drill
You can set Web Intelligence to drill in query drill mode, which behaves differently from 
the standard drill mode described so far in this chapter. When you activate query drill, 
Web Intelligence drills by modifying the underlying query (adding and removing 
dimensions and query filters) in addition to applying drill filters. 

Example:  Drilling down from Month to Week

In this example, Month is the lowest dimension currently available in the query from a time 
hierarchy, and Week is the dimension immediately below it in the hierarchy. 

If you drill down on Month = January, three things happen:

• Web Intelligence adds Week to the query scope of analysis.
• Web Intelligence adds a query filter to restrict Month to January.
• Web Intelligence adds a drill filter to restrict Month to January.

If you drill up from Week to Month, the process is reversed:

• Web Intelligence removes Week from the query scope of analysis.
• Web Intelligence removes the query filter.
• Web Intelligence removes the drill filter.

Note:  Drill filters are not strictly necessary in query drill mode. Web Intelligence applies 
them for consistency with standard drill mode. For example, the DrillFilters() function returns 
the correct value in query drill mode because Web Intelligence applies drill filters to match 
the query filters.

For information on how to activate query drill, see ”Activating query drill” on page 57.
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When do you use query drill?
You use query drill when your report contains aggregate measures calculated at the 
database level. It is designed in particular to provide a drill mode adapted to databases 
such as Oracle 9i OLAP, which contain aggregate functions that Web Intelligence either 
does not support, or cannot calculate accurately at the report level during a drill session.

The kinds of aggregate functions that are candidates for drilling in query drill mode are: 
percentages, distinct counts, ranks, standard deviations and variances, running 
aggregates, lead and lag functions. Because query drill modifies the query at each drill 
operation, it ensures that these aggregates are recalculated by the server each time you 
drill.

Query drill is also useful for reducing the amount of data that Web Intelligence must store 
locally during a drill session. Because query drill reduces the scope of analysis when you 
drill up, Web Intelligence is able to purge unecessary data.

Drilling with query drill
Drilling down

When you drill down, query drill behaves similarly to standard drill at the point where the 
data moves outside the scope of analysis. 

When Web Intelligence filters a drilled dimension in query drill mode it does so by adding 
a query filter in addition to a drill filter. For example, if you drill on Year=2001, Web 
Intelligence adds a filter at the query level to restrict the Year dimension to 2001. For this 
reason, the only value that appears in the drill toolbar for the drilled dimension is the value 
on which you drilled (in this case 2001). This is different from standard drill mode, in 
which all values of the dimension are visible in the toolbar. As a result, you cannot change 
filter values in query drill mode (for example, drill on Year=2001 then switch to 
Year=2003) as you can in standard drill mode.

Because query drill automatically extends the scope of analysis, you can use it only if your 
BusinessObjects XI administrator has granted you the the right to drill outside the scope. 
See your administrator for more details.

Drilling up
When you drill up, query drill removes dimensions from the query. For example, if you drill 
up from Month to Quarter, Web Intelligence removes Month from the query. This has two 
consequences:

• Query drill is incompatible with drill snapshots. For more information, see ”Query drill 
and drill snapshots” on page 57.

• Web Intelligence does not allow you to drill up beyond any dimension that appears as 
one of the report objects. For example, if your report displays Year, Quarter and 
Revenue, you cannot drill up from Quarter to Year because this would remove quarter 
from the list of report objects.
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Query drill and the scope of analysis
Query drill adds and removes dimensions from the scope of analysis in response to drill 
actions. For this reason, you cannot set the scope of analysis manually when using query 
drill. In addition, you cannot activate query drill if your document already has a scope of 
analysis defined. In this case the option is unavailable. You must remove the scope of 
analysis to make it available.

Query drill and other reports based on the same data provider
If your document contains other reports that contain dimensions on which you drill in query 
drill mode, these reports are affected because the query drill modifies the dimensions they 
contain.

Example:  Drilling on a dimension that appears in another report

If you have two reports based on a query that contains Year, Quarter and Sales Revenue, 
and you use query drill to drill down to Year = 2001 on the first report, Web Intelligence 
also filters the data for Year in the second report to include 2001 only. 

You can avoid this (at the cost of retrieving duplicate data into Web Intelligence) by 
creating a new data provider and rebuilding the other report against it. Now when you 
drill in query drill mode, the other report remains unaffected.

Query drill and drill snapshots
Do not use drill snapshots when working in query drill mode, because query drill means 
that snapshots cannot be guaranteed to stay the same. (For more information on 
snapshots, see ”Saving drilled results and ending Drill mode” on page 54.) 

In query drill mode, snapshots change when you drill up beyond a dimension that you 
included in a snapshot. Because the drill up removes the dimension from the underlying 
query, it also removes the dimension from the snapshot.

Activating query drill
You activate query drill at the document level.

To activate query drill

1. Click Document > Properties on the Main toolbar.
The Document Properties dialog box appears.

2. Click Use query drill.

NOTE: If your report already has a scope of analysis defined, the option is 
unavailable. You must remove the scope to make it available.
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6
Merging dimensions from multiple data 
providers

Overview
This chapter describes how to synchronize multiple data providers in a Web Intelligence 
report by merging them on common dimensions. After merging common dimensions you 
can place dimensions from different data providers in the same block.

Merged dimensions and data synchronization are new in Web Intelligence XI R2. They 
enormously increase the power and flexibility of Web Intelligence by allowing you to 
synthesise data from different sources in the same report, rather than simply including the 
data. 

For example, if you have one database that contains detailed customer information and 
another database that contains sales data, you can synchronize the two data sources 
around the customer.

Note:  This chapter provides basic information on merging dimensions in Web Intelligence 
in HTML mode. For more detailed information on merged dimensions and synchronization, 
see the “Merging Dimensions from Multiple Data Providers” chapter in the Building 
Reports Using the Web Intelligence Java Report Panel Guide. You can also find further 
information on the behavior of merged dimensions in the BusinessObjects Report 
Conversion Guide.

Synchronizing data providers through merged dimensions
Web Intelligence allows you to synchronize multiple data providers in the same document. 
This allows you to build reports which synchronize data from multiple sources. When you 
synchronize queries through merging, you can include report objects from different queries 
in the same report block.

To create a merged dimension

1. Select the group of dimensions from different data providers that you want to merge in 
the Available Objects section of the Left Panel by holding down the Ctrl key as you 
select the dimensions. (For information on creating documents that contain multiple 
data providers, see the Building Queries Using Web Intelligence Query – HTML 
guide.)

2. Click Merge at the top of the Left Panel.
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Web Intelligence creates a merged dimension with the same name, description, 
qualification and data type as the first dimension you selected.
The original dimensions that make up the merged dimension appear beneath it when 
you expand the merged dimension.
If you select any of these original dimensions, Merge/Unmerge is unavailable.

To remove a merged dimension

1. Select the merged dimension in the Available Objects section of the Left Panel.
The Merge button at the top of the Left Panel becomes the Unmerge button when you 
select a merged dimension.

2. Click Unmerge.

To edit a merged dimension

1. Right-click the merged dimension in the Available Objects section of the Left Panel 
then select Edit Properties on the menu to display the Create Merged Dimension 
dialog box.

2. Type the merged dimension name in the Merged Dimension Name in the Merged 
Dimension dialog box.

3. Type the description in the Description box.
Select the dimension that provides default properties for the merged dimension in the 
Source Dimension dialog box.

Merging dimensions automatically
You can tell Web Intelligence to merge dimension automatically when the dimensions 
come from the same universe, have the same name and the same data type.

To merge dimensions automatically

1. With a Web Intelligence document open, click the arrow next to Document on the 
main toolbar above the report.

2. Select Properties.
The Document Properties dialog box appears.
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3. Select Auto-merge dimensions
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7
Inserting and organizing reports

Overview
Web Intelligence documents can contain multiple reports. This chapter tells you how to:

• insert, delete, and move reports in documents
• name reports
• view document properties

Inserting, deleting, and moving reports
In a single document, you can:

• insert new reports – allows you to display different sub-sets of the document information 
on different reports

• duplicate reports – allows you to copy an existing report and then modify it, instead of 
creating a new report from scratch

• move reports – allows you to re-order the reports in a document
• delete reports – allows you to remove unnecessary reports from a document

To insert a new report

1. With a Web Intelligence document open, right-click the report tab of the report after 
which you want to insert a new report.
The contextual menu appears.

2. Select Insert.
A blank report appears after the report you selected. Web Intelligence numbers the 
report according to where it is located in the document. To find out how to rename the 
report, see ”To rename a report by typing the new name onto the report tab” on 
page 78.

To duplicate a report

1. With a Web Intelligence document open, right-click the report tab of the report after 
which you want to insert a new report.
The contextual menu appears.

2. Select Duplicate.
Web Intelligence inserts a duplicate of the report into the document.

To move a report

1. With a Web Intelligence document open, right-click the report tab of the report after 
which you want to insert a new report.
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The contextual menu appears.
2. Select Move.

A sub-menu appears. You can select where you want to move the report here.
3. Click the appropriate option:

Web Intelligence moves the report to where you selected.

To delete a report

1. With a Web Intelligence document open, right-click the report tab of the report after 
which you want to insert a new report.
The contextual menu appears.

2. Select Remove.
A message asks you to confirm that you want to delete the report.

3. Click Yes.
Web Intelligence deletes the report from the document.

Naming reports
When you create a new report, Web Intelligence names the report “Report 1” by default. 
You can the rename the report to give the report a more meaningful name. If you have 
several reports, naming each report makes it easier to navigate through the document. 

If you are working with a document that has already been created, you can rename the 
existing reports. There are two ways to rename reports:

• by typing the new name onto the report tab
• using the Format Report dialog box

To rename a report by typing the new name onto the report tab

1. With a Web Intelligence document open, right-click the report tab of the report you 
want to rename, and then select Rename on the contextual menu.
Or
Double-click the report tab.

2. Type the new name into the text box on the report tab.

To move the report... click...

to the beginning of the document, First

before the selected report, Previous

after the selected report, Next

to the end of the document, Last
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NOTE: When you rename reports in a document that you want to save as an Excel 
spreadsheet, the names of reports must not include more than 31 characters or 
include spaces or the following special characters: * : \ / [ ]

3. Press Enter.
The new name appears on the report tab.

To rename a report using the Format Report dialog box

1. Right-click an empty area of the report.
The contextual menu appears.

2. Click Format Report.
The Format Report dialog box appears.

3. Click the General tab.

4. In the Name text box, type the name you want to give to the report.
5. Click OK.

Web Intelligence displays the new name on the report tab of the selected report.

Viewing document properties
You can view document information and set the properties for documents. You can view 
the following properties for a document:

Property Description

Title The name of the document in InfoView.

Author The creator of the document.

Description Optional information that describes the 
document.

Keywords Optional keywords that can be used to 
search for the document in InfoView.
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Last refresh date Informs you when the results were last 
refreshed with the latest data from the 
database.

Duration of the 
previous Refresh

Informs you how long it took for Web 
Intelligence to retrieve the data from the 
database the last time the results were 
refreshed.

Locale Tells you the formatting locale of the 
document.

 Version Tells you the version of Web Intelligence 
software used to create the document.

Previous version If the document was upgraded from a 
previous version of Web Intelligence 
software, the Web Intelligence version used 
to create the original document appears 
here.

Enhanced viewing 
mode

When this option is checked, the 
appearance of reports is optimized for 
onscreen viewing. (See ”Using Enhanced 
viewing mode for onscreen viewing” on 
page 38.)

Refresh on Open When this option is checked, Web 
Intelligence automatically refreshes the 
results in reports with the latest data from 
the database each time the document is 
opened. (See ”To set a document to refresh 
automatically when it is opened” on 
page 34.)

Use query drill When this option is checked, Web 
Intelligence drills in query drill mode. For 
more information on query drill and how it 
differs from standard drill, see the chapter 
“Setting up Documents for Drill Analysis” in 
the Building Reports Using the Web 
Intelligence Java Report Panel guide.

Property Description
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Note:  You set the document title, description, and keywords when you save a document. 
(See ”To save a new Web Intelligence document in InfoView” on page 248.)

To view document properties

1. With a Web Intelligence document open, click the arrow next to Document on the 
main toolbar above the report.

2. Select Properties.
The Document Properties dialog box appears.

Auto-merge dimensions When this option is checked, Web 
Intelligence automatically merges 
dimensions with the same name and from 
the same universe. You see the merged 
dimension in the list of available objects 
with the dimensions merged within it below.

Merged dimensions are the Web 
Intelligence mechanism for synchronizing 
data from different data providers.

For more information, see ”Merging 
dimensions from multiple data providers” 
on page 59.

Property Description
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8
Formatting report pages

Overview
You can format the page layout of Web Intelligence reports to create presentation-level 
documents. This chapter tells you how to:

• define the page layout of reports – margins, page orientation and page size, page 
headers and footers, and page numbers

• include titles on reports
• include cells with predefined formulas
• insert images
• insert and format hyperlinks
• inserting HTML

Defining report page layout
This section tells you how to:

• set margins
• set page orientation
• select paper size
• include page headers and footers
• include page numbering

Note:  It is recommended that you view reports in Page Mode when you specify page 
layout. This enables you to see the impact of your modifications to the selected report. To 
find out how to switch to Page Mode, see ”Viewing reports in page mode and draft 
mode” on page 39.

To set margins

1. Right-click an empty area of the report.
The contextual menu appears.

2. Click Format Report.
The Format Report dialog box appears.
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3. Click the Layout Properties tab.

4. In the Margins section, type the measurement you want for the Top, Bottom, Left, 
and Right margins.

5. Click OK.
Web Intelligence applies the margin settings you specified to the selected report.

To set page orientation

1. Right-click an empty area of the report.
The contextual menu appears.

2. Click Format Report.
The Format Report dialog box appears.

3. Click the Layout Properties tab.
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4. In the Orientation section, click the arrow next to the list box, and then select Portrait 
or Landscape as appropriate:

1. Click OK.
Web Intelligence applies the page orientation you specified to the selected report.

To select paper size

1. Right-click an empty area of the report.
The contextual menu appears.

2. Click Format Report.
The Format Report dialog box appears.

3. Click the Layout Properties tab.

4. In the Page size section, click the arrow next to the list box, and then select the 
appropriate page size.

5. Click OK.
Web Intelligence applies the page size you specified to the selected report.

To include a page header or page footer

1. Right-click an empty area of the report.
The contextual menu appears.

Portrait Landscape
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2. Click Format Report.
The Format Report dialog box appears.

3. Click the General tab.

4. To include a page header, select Show header, and then type the height you want for 
the header into the text box.

5. To include a page header, select Show footer, and then type the height you want for 
the footer into the text box.

NOTE: If you want to use a different measurement unit from the one currently 
displayed. (For example, if the current unit is inches and you want to use 
centimeters), you can change the measurement in your My Workspace 
preferences. To find out how to do this, see ”To set the display properties of your 
Web Intelligence workspace” on page 29.

6. If you want to define a background color for the header or footer, refer to step 4 below.
7. Click OK.

Web Intelligence inserts the headers and footers you specified into the selected report.

NOTE: You need to define page headers and page footers for each report.

To define a background color for page headers and footers

1. Right-click an empty area of the report.
The contextual menu appears.

2. Click Format Report.
The Format Report dialog box appears.
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3. Click the General tab.

4. Click the arrow next to Background color, and then either select a predefined color 
or click More colors... to define a custom color, and then click OK.

5. Click OK.
Web Intelligence applies the color(s) you selected to the headers and footers on the 
selected report.

To include page numbers

1. Verify that the Document Properties pane is displayed to the left of the selected report.
To display the Document Properties pane, click the Show left pane arrow at the top 
left of the report.

2. Click the arrow to the right of the drop-down list box, then select Chart and Table 
Types.
The categories of chart, table, and cell types appear.

3. If the Cells category is not visible, click the + next to Report Elements.
4. Click the + next to Cells.
5. Click the + next to Page Number Cells.
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The available page number formats are listed here.

The following table provides examples of the three formats:

1. Select the appropriate page number format and drag it onto a blank area of the report.
The page number appears on each page of the report.
You can define formatting properties for the page number cell, such as a background 
color or font style. You can also type text before or after the page number. For 
example, you can type “Page:” before the special field that displays the number of 
each page, in order to display “Page: 1, Page: 2” and so on. To find out how to 
format and modify the text in page number cells, see ”To format and modify the text in 
page number cells” on page 88.

To format and modify the text in page number cells

1. Right-click the page number cell on the report.
If you have not yet inserted a page number cell onto the report, refer to ”To include 
page numbers” on page 87.

2. On the contextual menu, select Format > Cell.

To display... for example,  select...

the page number of the current 
report page,

1 Page Number

the page number of the current 
report page over the total number 
of pages in the report

1/50 Page 
Number/Total 
Pages

the total number of pages in the 
current report,

50 Total Number 
of Pages

Predefined formats for page numbers
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The Format Cells dialog box appears.
3. To format how the text and cell background appears, click the Font tab, and then 

select the appropriate settings.

4. To format how the borders around the page number cell appear, click the Border tab, 
and then select the appropriate settings for borders.

You can apply the same colors and styles to all borders in the Settings applied to all 
borders section. You can also apply specific colors and styles to one or multiple 
borders using the options in the Settings per border section.

5. To align the page number text on the cell, click the Alignment tab, and then specify 
the appropriate Horizontal and Vertical alignment settings.

6. To enter text before or after the special field that displays the page numbers, click 
General and then type the text into the Name text box.
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NOTE: Type the text you want to display before the [ bracket or after the ] bracket. 
You must not type any text inside the [ ] brackets.

7. Click OK.
Web Intelligence applies the settings you specified to the page number cell on the 
selected report.

Including titles on reports
You can display a title in a report. This is useful if you want to print the report, and 
distribute it to colleagues. The report title appears at the top of the report page.

To add a title to a report and format its display properties

1. Verify that the Document Properties pane is displayed to the left of the selected report.
To display the Document Properties pane, click the Show left pane arrow at the top 
left of the report.

2. Click the arrow to the right of the drop-down list box, then select Chart and Table 
Types.
The categories of chart, table, and cell types appear.

3. If the Cells category is not visible, click the + next to Report Elements.
4. Click the + next to Cells.
5. Click the + next to Formula and Text Cells.

The available cell formats are listed here.

6. Select the Blank Cell format and drag it onto the area of the report page where you 
want to display the report title.
The blank cell appears on the report.

7. Right-click the cell.

Predefined formats for formula and 
text cells
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8. On the contextual menu, select Format > Cell.
The Format Cells dialog box appears.

9. Click the General tab.

10.Type the title you want to give the report into the Name text box.
11.In the Size section, specify the width and height of the report title cell and select Wrap 

text, if you want to continue the title onto the next line.
12.Leave the Read content as option blank.
13.To format how the text and cell background appears, click the Font tab, and then 

select the appropriate settings.
14.To format how the borders around the page number cell appear, click the Border tab, 

and then select the appropriate settings for borders.
You can apply the same colors and styles to all borders in the Setting applied to all 
borders section. You can also apply specific colors and styles to one or multiple 
borders using the options in the Settings per border section.

15.To align the page number text on the cell, click the Alignment tab, and then specify 
the appropriate horizontal and vertical alignment settings.

16.Click OK.
Web Intelligence displays the report title on the report with the formatting settings you 
specified.

Including cells with predefined formulas
You can include single cells in reports that:

• contain predefined formulas – with information on the document name, the last date the 
data in the reports was refreshed, or about the filters applied to reports during a drill 
session

• allow you to type custom formulas – so you can define formulas or calculations of your 
choice
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Note:  You can also include page numbering, (see ”To include page numbers” on 
page 87) and insert a blank cell and then type text, such as a comment or message to 
report reviewers (see ”To insert a free standing cell” on page 104.)

To include a formula to display document information

1. Verify that the Document Properties pane is displayed to the left of the selected report.
To display the Document Properties pane, click the Show left pane arrow at the top 
left of the report.

2. Click the arrow to the right of the drop-down list box, then select Chart and Table 
Types.
The categories of chart, table, and cell types appear.

3. If the Cells category is not visible, click the + next to Report Elements.
4. Click the + next to Cells.
5. Click the + next to Formula and Text Cells.

The available cell formats are listed here.

6. Select the formula cell that you want to include on the report.

Predefined formats for formula and 
text cells
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The following table provides information about each type of formula:

1. Drag the selected cell onto the area of the report page where you want to display the 
formula.
The formula cell appears on the report.

2. If you want to change the formatting properties of the text or the cell background or 
border, right-click the cell, and then on the contextual menu, select Format > Cell.
You can select format options on the Font, Border, and Alignment tabs.

3. Click OK.
Web Intelligence displays the cell you selected on the report with the format settings 
you specified.

To include a blank cell to display a custom formula

1. Verify that the Document Properties pane is displayed to the left of the selected report.
To display the Document Properties pane, click the Show left pane arrow at the top 
left of the report.

2. Click the arrow to the right of the drop-down list box, then select Chart and Table 
Types.
The categories of chart, table, and cell types appear.

3. If the Cells category is not visible, click the + next to Report Elements.
4. Click the + next to Cells.
5. Click the + next to Formula and Text Cells.

If you want to display... then select...

the filters applied to results during a drill 
session,

NOTE: For full information about 
drill analysis, see ”Analyzing 
results” on page 45.

Drill Filters

the date the last time the results in reports 
were refreshed with up-to-date data on 
the database,

Last Refresh Date

the title of the document as it is listed in 
InfoView, 

Document Name
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The available cell formats are listed here.

6. Select the Blank Cell format and drag it onto the area of the report page where you 
want to display the report title.
The blank cell appears on the report.

7. Verify that the Formula bar is displayed above the report.
To display the Formula bar, right-click the main toolbar above the report, and then 
click Formula on the contextual menu.

8. In the Formula bar, type “=” followed by the formula you want, then click the green 
check mark to parse the formula syntax.

Web Intelligence validates the formula and inserts it into the blank cell on the report.

Inserting images
You can insert images in Web Intelligence reports. For example, you can insert a company 
logo or images of the products the report highlights.

This section tells you:

• how to insert images in free standing cells
• how to select images to display on the background of reports

To insert an image in a free standing cell

Predefined formats for formula and 
text cells

Formula bar
Blank cell

Parse formula
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1. Verify that the Document Properties pane is displayed to the left of the selected report.
To display the Document Properties pane, click the Show left pane arrow at the top 
left of the report.

2. Click the arrow to the right of the drop-down list box, then select Chart and Table 
Types.
The categories of chart, table, and cell types appear.

3. If the Cells category is not visible, click the + next to Report Elements.
4. Click the + next to Cells.
5. Click the + next to Formula and Text Cells.

The available cell formats are listed here.

6. Select the Blank Cell format and drag it onto the area of the report page where you 
want to display the report title.
The blank cell appears on the report.

7. Right-click the cell.
8. On the contextual menu, select Format > Cell.

The Format Cells dialog box appears.
9. Select the General tab.

Predefined formats for formula and 
text cells
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10.Type the URL of the image in the Name box as described in the following table:

NOTE: The size of the image is defined when the image is created. You cannot 
modify the size of the image using Web Intelligence.

1. If you know the size of the image, you can adjust the size of the cell to the size of the 
image, type the width of the cell into the Specify width check box and type the height 
of the cell into the Specify height check box. Otherwise you can use drag-and-drop to 
resize the cell later.

2. Click the arrow next to the Read Content As list box, and select Image URL from the 
drop-down list.

3. To align the image, click the Alignment tab, and then select the horizontal and vertical 
alignments you want.

NOTE: If you want to use drag-and-drop to resize the cell later, select left align for 
the Horizontal alignment and select top align for the Vertical alignment.

4. If you want to add or remove a border around the image, click the Border tab, and 
then select or remove borders as appropriate.

5. Click OK.
6. If you want to resize the cell using drag-and-drop, select the cell, and then drag the 

right border and bottom border outwards as appropriate.

To select an image to display on the background of a report

If... then...

the image file has 
been installed by 
your administrator in 
the images directory 
on the 
BusinessObjects 
Enterprise server, 

• type: boimg:// followed by the file name.
For example, if the file name is 
“efashion_logo.gif,” then type:
boimg://efashion_logo.gif

NOTE: Image files need to installed 
by your administrator at the following 
directory on the BusinessObjects 
Enterprise server:

<INSTALL DIR>\Images

the image file is 
located on another 
web server, 

• type the URL.
For example:
http://www.internal.businesscompany.com/image
s/company_logo.gif
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1. With a Web Intelligence document open, right-click an empty area of the report you 
want to format.
The background of the selected report is highlighted gray.
The contextual menu appears.
Depending the area you selected, the options may be slightly different.

2. Select Format Report or Format > Report.
The Format Report dialog box appears.

3. Click the Appearance tab.
4. In the Pattern section, select Image (URL).
5. In the Image (URL) text box, type the file name or URL for the image file.

The following table will help you specify the file name:

If... then...

the image file 
has been 
installed by your 
administrator in 
the images 
directory on the 
BusinessObjects 
Enterprise 
server, 

type: boimg:// followed by the file name.

For example, if the file name is 
“efashion_logo.gif,” then type:

boimg://efashion_logo.gif

NOTE: Image files need to installed by 
your administrator at the following 
directory on the BusinessObjects Enterprise 
server:

<INSTALL DIR>\Images

the image file is 
located on 
another web 
server, 

type the URL.

For example:

http://www.internal.businesscompany.com/images/compan
y_logo.gif
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NOTE: The size of the image is defined when the image is created. You cannot 
modify the size of the image using Web Intelligence.

Click the arrow to the right of the Display drop-down list box, and then select how you 
want the image to be displayed:

1. If you selected Normal as the image display format, you can specify how you want the 
image to be vertically and horizontally aligned by clicking the arrows in the list boxes 
next to Position and selecting the appropriate vertical and horizontal position.

2. Click OK.
Web Intelligence applies the image you selected to the report background.

Inserting and formatting hyperlinks
You can include hyperlinks to web pages on your corporate intranet, extranet or the world 
wide web.

This section tells you how to:

• insert a hyperlink
• select visited and unvisited hyperlink colors

To insert a hyperlink

1. Verify that the Document Properties pane is displayed to the left of the selected report.
To display the Document Properties pane, click the Show left pane arrow at the top 
left of the report.

2. Click the arrow to the right of the drop-down list box, then select Chart and Table 
Types.
The categories of chart, table, and cell types appear.

3. If the Cells category is not visible, click the + next to Report Elements.
4. Click the + next to Cells.

If you want to... then select...
display the image once at the top left of the report, 
section, table, or cell,

Normal

stretch the image over the entire report area,

NOTE: this option is only applied when you 
view or save the report as a PDF file. (See ”To 
save a Web Intelligence document as a PDF 
file” on page 250.)

Stretch (PDF 
only)

repeat the image vertically and horizontally, Tile
repeat the image horizontally across, Horizontal tile
repeat the image vertically downward, Vertical tile
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5. Click the + next to Formula and Text Cells.
The available cell formats are listed here.

6. Select the Blank Cell format and drag it onto the area of the report page where you 
want to display the report title.
The blank cell appears on the report.

7. Right-click the blank cell, then select Format > Cell.
The Format Cells dialog box appears.

8. In the Name text box, type the hyperlink you want.

NOTE: You must not include spaces in the URL or file path.

The following table lists the supported URL types:

1. Select the Read contents as option, and then click the arrow next to the drop-down 
list and select Hyperlink from the list.

2. Click OK.

To insert this link... type this at the start of the URL...
Worldwide Web http://www.
Web server http://
Secured web server https://
Email mailto://
File file://
File Transport Protocol ftp://
Connect with Telnet telnet://
Access to a news group news://
Network News Transfer Protocol nntp://

Predefined formats for formula and 
text cells
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Web Intelligence inserts the hyperlink into the cell on the report.
If you want to select visited and unvisited colors for the hyperlink, refer to ”To format 
visited and unvisited colors on a hyperlink” on page 100.

To format visited and unvisited colors on a hyperlink

1. Right-click a blank area on the report that contains the hyperlink.
To see how to insert a hyperlink, refer to ”To insert a hyperlink” on page 98.

2. On the contextual menu, select Format Report.
The Format Report dialog box appears.

3. Click the Appearance tab.
4. In the Hyperlink color section, click the arrows next to Visited and Unvisited, and 

then either select a predefined color or click More colors... to define a custom color, 
and then click OK.

5. Click OK.
Web Intelligence applies the color settings you selected to the hyperlink on the report.

Inserting HTML
Web Intelligence can treat the contents of a cell as HTML. You can include any HTML 
(for example, HTML formatting tags or variables) that you can include in a normal web 
page.

To insert HTML in a cell

1. If you want to include HTML in a blank cell instead of in a table cell, go to ”To insert a 
hyperlink” on page 98 and follow steps 1 to 7.

2. Right-click the cell, then select Format > Cell from the contextual menu.
The Format Cells dialog box appears.

3. Select the General tab.
4. Click Read Content As and select HTML from the drop-down list.
5. Display the Formula bar by selecting View from the menu, then selecting Toolbars > 

Formula.
6. Type the HTML you want to include in the cell, into the Formula bar and click the 

Parse button.
Web Intelligence displays the result in the cell if the HTML is valid. 
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9
Adding tables and cells to reports

Overview
When you create a new document, Web Intelligence generates a new report with a 
vertical table and standard formatting. This initial table includes all of the data in the query 
behind the document. You can insert more tables onto the same report or onto new reports 
within the same document.

This chapter tells you:

• what table types are available
• how to insert tables and free standing cells
• how to transform tables to different table types
• how to include table headers and footers
• how to add and remove rows and columns
• how to move and swap rows and columns
• how to modify the data included in tables and cells
• how to remove tables and cells from reports

For information on formatting tables, see ”Formatting tables and cells” on page 111.

Available table types
Web Intelligence allows you to include four types of tables in your reports.

Vertical table
Vertical tables display header cells at the top of the table and the corresponding data in 
columns. By default, the header cells display the names of the dimensions, details, and 
measures included in the table. The body cells display the corresponding values.
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Horizontal table
Horizontal tables display header cells at the left of the table and the corresponding data in 
rows. By default, the header cells display the names of the dimensions, details, and 
measures included in the table. The body cells display the corresponding values.

Crosstab
Crosstabs display values for dimensions across the top axis (columns) and on the left axis 
(rows).

You can include more than two dimensions in crosstab. You are not restricted to one 
dimension for the columns and one dimension for the rows. For example, the top axis 
(columns) might split the data by time period (for example Quarter) and location (for 
example State).

Form
A form displays each row of data in free form format. Forms are useful in your report if you 
want to display detailed information per customer, product, or partner. For example, a 
form is a useful way of displaying individual customer records with information such as the 
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customer account, name, address, and so on. Forms are also useful for formatting address 
labels for envelopes.

Note:  When you create a new document and run the query the first time to display the 
results, Web Intelligence generates a report that includes all of the results in a vertical 
table.

Inserting tables and free standing cells
When you create a new document and run the query the first time to display the results, 
Web Intelligence generates a report that includes all of the results in a vertical table. You 
can modify how the table is organized, remove or add data, change the table type to 
display the results differently or insert other tables. You can also insert free standing cells to 
display results in a single cell.

Note:  For information on adding free standing cells that include a predefined formula to 
display report information, such as page numbers, the document name, the last date the 
data in the reports was refreshed, or filters applied to reports during a drill session, see 
”Including cells with predefined formulas” on page 91.

To insert a table

1. Make sure that the Document Properties pane is displayed to the left of the selected 
report.
To display the Document Properties pane, click the Show left pane arrow at the top 
left of the report.

2. Select Chart and Table Types from the drop down list.



Adding tables and cells to reports104

The Left panel now displays all the types of tables, charts and free standing cells that 
you can add to the report.

3. Select the table type that you want to add to the report in the Left panel and drag the 
table onto the report.

4. Right-click the table in the report, select Insert from the menu, then select New column 
or New row to add rows or columns to the table.

5. Select Available Objects from the drop-down list at the top of the left panel.
6. Drag the object that you want to associate with a column to the column in the report 

table.
The column is populated with the data from the report object.

7. Continue dragging objects to table columns until you have associated objects with all 
columns.

To insert a free standing cell

1. Make sure that the Document Properties pane is displayed to the left of the selected 
report.
To display the Document Properties pane, click the Show left pane arrow at the top 
left of the report.

2. Select Chart and Table Types from the drop down list.
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3. The Left panel now displays all the types of tables, charts and free standing cells that 
you can add to the report.

4. Open the free standing Cells item in the report template hierarchy to display the types 
of free standing cell you can add.

5. Drag the type of free standing cell you want to add to the report.
If you choose Blank Cell, the cell remains blank.
If you choose any other type of cell, the cell is populated based on the type of 
information that the cell displays. For example, if you choose Last Refresh Date, the 
cell contains the formula LastExecutionDate() which populates it with the date the report 
was last refreshed.
For more details about the type of cells you can include in a report, see ”Including cells 
with predefined formulas” on page 91.

Transforming tables to different table types
There are two ways to change the type of table for a table already displayed on a report:

• using Turn To
• dragging a different table type onto a table

To modify a table using Turn To

1. Right-click inside the table and select Turn table to... from the menu.



Adding tables and cells to reports106

The Turn To dialog box appears.

2. Make sure that Tables is selected in the left pane.
3. Select the type of table to which you want to change the current table in the Available 

Formats area on the right.
4. Click OK.

Web Intelligence changes the table to the type you selected.

To apply a different table type using drag-and-drop

1. Make sure that the Document Properties pane is displayed to the left of the selected 
report.
To display the Document Properties pane, click the Show left pane arrow at the top 
left of the report.

2. Select Chart and Table Types from the drop down list at the top of the Left panel.
3. Select the table type to which you want to change the existing table and drag it over 

the existing table.
Web Intelligence changes the table to the type you selected.

Including table headers and footers
For a description of the different table types and how they display headers and footers, 
see ”Available table types” on page 101.

To show or hide a table header or footer

1. Right-click inside the table and select Format from the menu, then select Table.
The Format Table dialog box appears.
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2. Select the General tab on the Format Table dialog box.

3. Check/uncheck Table headers to display/hide table headers.
4. Check/uncheck Table footers to display/hide table footers.

Note:  If the table is a crosstab, you have the option to hide either or both of the vertical 
(left) and horizontal (top) headers. In this case the options Left header and Top header 
appear in place of Table headers.

Adding and removing rows and columns
After you have created a table you can modify it by changing the rows and columns.

To add a row to a table

1. Select a row in the table and right-click.
2. Select Insert from the menu, select New Row, then select Above or Below, 

depending on whether you want to insert the row above or below the selected row.

To add a column to a table

1. Select a column in the table and right-click.
2. Select Insert from the menu, select New Column, then select Left or Right, 

depending on whether you want to insert the column to the left or right of the selected 
column.

To remove a row from a table

1. Select a cell in the row and right-click.
2. Select Remove from the menu, then select Row.

To remove a column from a table

1. Select the column and right-click.
2. Select Remove from the menu, then select Column.

Moving and swapping rows and columns
To reorganize how information is displayed on tables, you can move or swap the table 
rows and columns.
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You can also swap the axes on crosstabs to gain a different perspective on results.

To move columns in a table

1. Right-click in the table, select Format from the menu, then select Table.
The Format Table dialog box appears.

2. Select the Pivot tab.

3. Select objects in the Available Objects area, and click >> to add them to the table.
4. Select objects in the Column(s) area and click << to remove them from the table.
5. Drag objects in the Column(s) area to set the order of columns in the table.
6. Click OK.

To move columns in a crosstab

1. Right-click in the crosstab, select Format from the menu, then select Table.
The Format Table dialog box appears.

2. Select the Pivot tab.
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The Pivot tab has sections for the row(s), column(s) and body of the crosstab.
3. Select objects in the Available Objects area, click Row(s), Column(s) or Body and 

click >> to add the objects to the rows, columns or body of the crosstab.
4. Click Row(s), Column(s) or Body and click << to remove objects from the rows, 

columns or body of the crosstab.
5. Drag objects in the Row(s), Column(s) or Body area to set the object order.
6. Click OK.

To swap rows or columns on a crosstab

1. Select the crosstab.
2. Right-click and select Swap axis from the menu.

Web Intelligence swaps the rows and columns of the crosstab.

Modifying the data included in tables and cells
Once you have created a table or free standing cell you can modify the data in it by 
adding or removing objects, clearing the data that the table or cell contains, or deleting 
the table or cell.

To add objects to a table

1. Make sure that the Document Properties pane is displayed to the left of the selected 
report.
To display the Document Properties pane, click the Show left pane arrow at the top 
left of the report.

2. Select Available Objects from the drop down list at the top of the Left panel.
3. Select the object you want to add and drag it over to the table so that a red bar 

appears where you want to place the object.

4. Release the object.
Web Intelligence adds the object to the table.

NOTE: You can add more objects to your document by modifying the query, if you 
have the appropriate security profile. Refer to Building Queries Using the Web 
Intelligence Query – HTML.

To clear table or cell contents

1. Select the cell or column within a table.
2. Display the Formula bar by selecting View from the menu, then selecting Toolbars, 

then Formula.
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3. Delete the cell formula in the Formula bar.
Web Intelligence removes the data from the cell(s).

Removing tables and cells
To remove a table

1. Select the table.
2. Right-click and select Remove from the menu, then select Table.

To remove a cell

1. Select the cell.
2. Right-click and select Remove Cell from the menu.

NOTE: You can only remove free standing cells. You cannot remove single cells 
from a table. For information on how to clear the content from cells in tables, see 
”To clear table or cell contents” on page 109.
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10
Formatting tables and cells

Overview
You can personalize the formatting and choose display properties for tables and cells.

This chapter tells you how to:

• name tables and cells
• align tables and cells on report pages
• set page breaks for tables
• specify the size of cells
• format cell values – by selecting font types, styles and colors
• format numbers and dates
• format table and cell borders
• apply background colors to tables and cells
• insert images and skins on cell backgrounds
• hide empty tables – when there is no data for the tables on the database
• avoid displaying duplicate rows in tables

Naming and tables and cells 
By default, Web Intelligence names each table and free-standing cell with a default name 
Block1, Block2, Block3, and so on. You can rename tables and cells with meaningful 
names to make it easier to select the formatting options for a specific table or cell or to 
align them in relation to other tables or charts on the report page.

Note:  In all the following procedures you can select multiple cells by holding down the Ctrl 
key as you select.

To name tables and free standing cells

1. Select the table or free standing cell, right click, select Format from the menu then 
select Table from the sub menu.
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2. Select the General tab in the Format Table dialog box.

3. Type the table name in the Name box.

Aligning tables and cells
To align a table or cell on a report page

1. Select the table, right-click, select Format from the menu then select Table or Cell from 
the sub menu.

2. Select the Layout Properties tab in the Format Table or Format Cell dialog box.

3. Select the relative distances in the Within the Report section and choose the parts of 
the table that the relative distances are calculated from in the drop down lists.

The options for relative positioning are listed in the table below:

Table part Relative to
Left Left edge of report

Left side of Any other block, cell or free 
standing cell in the documentRight side of

Top Top edge of report
Top side of Any other block, cell or free 

standing cell in the documentBottom side of
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Setting page breaks for tables
To avoid page breaks in a table

1. Select the table, right-click, select Format from the menu then select Table from the sub 
menu.

2. Select the Layout Properties tab in the Format Table dialog box.

3. Check Avoid page breaks in a block.

Sizing cells
You can specify the exact width or height of cells.

To specify cell width and height

1. Select the cell, right click, select Format from the menu and then select Cell from the 
sub menu.

2. Select the General tab in the Format Cells dialog box.

3. Check the Specify width check box and enter the width of the cell.
4. Check the Specify height check box and enter the height of the cell.
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Formatting cell values
You can change the font, color, style or alignment of the display of values in cells.

To change fonts, colors, or styles applied to cell values

1. Select the cell, right-click, select Format from the menu then select Cell from the sub 
menu.

2. Select the Font tab in the Format Cells dialog box.

3. To change the font, select the font name from the list below the Font name box.
4. To change the font style, select the style from the list below the Font style box.
5. To select the font size, select the size from the list below the Font size box.
6. To define underline and/or strikethrough on the font, check the Underline and/or 

Strikethrough boxes.
7. To define the font color, click the down arrow beside Font in the Color section of the 

dialog box to display the color editor.
8. Select the color in the Color Editor or click More colors... to display the Custom 

Color Picker.

9. Select the color in the Custom Color Picker or enter the red, green and blue values of 
the color.

To align cell values
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1. Select the cell, right click, select Format from the menu and then select Cell from the 
sub menu.

2. Select the Alignment tab in the Format Cells dialog box.

3. Use the radio buttons to set the horizontal format (left -justified, centered or 
right-justified) and the vertical format (top, middle or bottom).

4. To set the vertical and horizontal padding (the distance of the cell content from the left 
and top cell borders) enter the padding distances in the Vertical and Horizontal 
boxes.

Merging cells
You can merge cells horizontally .

To merge cells

1. Multi-select the cells or columns you want to merge by holding down Ctrl and selecting 
each cell/column.

2. Select Merge cells.

Formatting numbers and dates
Web Intelligence allows you to format numbers and dates in tables.

To format numbers and dates

1. Select the cell containing the number or date you want to format.
2. Right-click, select Format from the menu then select Cell from the sub menu.

The Format Cells dialog box appears.
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3. Select the Number tab.

4. Select the format from the list of formats and click OK.

NOTE: If the cell contains a number, the list of formats contains number formats. If 
the cell contains a date, the list of formats contains date formats.

Formatting cell borders
You can format the style and color of cell borders. 

To choose a border style and color

1. Select the cell, right-click, select Format from the menu and then select Cell from the 
sub menu.

2. Select the Border tab in the Format Cells dialog box.

3. To set the style for all the borders of the selected cell, select the style from the Settings 
applied to all borders list.

4. To set the style for each border of the selected cell individually, select the styles from the 
four lists in Settings per border.

5. To remove borders, select None in the lists. 

Click here to 
choose the 
border color
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6. Click the down arrow beside each drop down list to display the color editor to choose 
the border color.

7. Select the color in the Color Editor or click More colors... to display the Custom Color 
Picker.

8. Select the color in the Custom Color Picker or enter the red, green and blue values of 
the color.

Setting cell background color
To choose a background color

1. Select the cell, right-click, select Format from the menu and then select Cell from the 
sub menu.

2. Select the Font tab in the Format Cells dialog box.

3. Click the arrow next to Background to display the color editor.
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4. Select the color in the color editor or select More colors... to display the Custom Color 
Picker. (To remove the color, select Default in the color editor.)

5. Select the color in the Custom Color Picker or enter the red, green and blue values of 
the color.

Formatting tables with images or skins
You can display images in a table by linking to an image file, or define a skin for the 
table.

To link to an image file

1. Select the table, right-click, select Format from the menu then select Table from the sub 
menu.

2. Select the Appearance tab in the Format Table dialog box.

3. Click Image URL.
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4. Type the URL of the image in the Image URL box as described in the following table:

1. Click the arrow to the right of the Display drop-down list box, and then select how you 
want the image to be displayed

1. If you selected Normal as the image display format, you can specify how you want the 
image to be vertically and horizontally aligned by clicking the arrows in the list boxes 
next to Position and selecting the appropriate vertical and horizontal position.

2. Type the image spacing and padding in the Spacing and Padding boxes.

To display a skin

If... then...

the image file has 
been installed by 
your administrator in 
the images directory 
on the 
BusinessObjects 
Enterprise server, 

• type: boimg:// followed by the file name.
For example, if the file name is 
“efashion_logo.gif,” then type:
boimg://efashion_logo.gif

NOTE: Image files need to installed 
by your administrator at the following 
directory on the BusinessObjects 
Enterprise server:

<INSTALL DIR>\Images

the image file is 
located on another 
web server, 

• type the URL.
For example:
http://www.internal.businesscompany.com/image
s/company_logo.gif

If you want to... then select...
display the image once at the top left of the report, 
section, table, or cell,

Normal

stretch the image over the entire report area,

NOTE: this option is only applied when you 
view or save the report as a PDF file. (See ”To 
save a Web Intelligence document as a PDF 
file” on page 250.)

Stretch (PDF 
only)

repeat the image vertically and horizontally, Tile
repeat the image horizontally across, Horizontal tile
repeat the image vertically downward, Vertical tile
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1. Select the table, right-click, select Format from the menu and then select Table from 
the sub menu.

2. Select the Appearance tab in the Format Table dialog box.

3. Click Skin then select the skin from the list of server skins in the drop-down list next to 
the Skin radio button.

4. Type the skin spacing and padding in the Spacing and Padding boxes.

Hiding tables when there is no data to show
You can hide table rows or columns when they contain no data; you can also hide entire 
tables when they contain no data.

To show or hide empty rows, columns or tables

1. Select the cell, right-click, select Format from the menu and then select Table from the 
sub menu.

2. Select the General tab on the Format Table dialog box.

3. To hide empty rows, uncheck Show empty rows.
4. To hide empty columns, uncheck Show empty columns.
5. To hide the entire table if it is empty, uncheck Show table when empty.
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Avoiding duplicate rows
You can set the table display so that numeric data in duplicate rows is aggregated. If you 
do not choose this option the duplicate rows appear in the table.

To set duplicate row aggregation

1. Select the cell, right click, select Format from the menu and then select Table from the 
sub menu.

2. Select the General tab on the Format Table dialog box.

3. Uncheck Avoid duplicate row aggregation.

Working with alerters
Alerters enable you to highlight results that meet or fail specific business targets. You can 
create a simple alerter to highlight particularly high or low results with a specific color or 
with a text comment, such as “High Performer.”

Alerters are dynamic. This means that when you refresh reports with the latest data on the 
database, the alerters highlight the new results accordingly.

You cannot create alerters when working in Interactive mode. To do so you use the Java 
Report Panel. For more information on creating alerters in the Java Report Panel, see 
chapter “Using Alerters to Highlight Key Results” in the the Building Reports with the Web 
Intelligence Java Report Panel guide.

When in Interactive mode you can view, activate and deactivate alerters created using the 
Java Report Panel.

To view, activate and deactivate alerters

1. Make sure the Report toolbar is visible by clicking View > Toolbars > Report.
2. Select a column or columns a table.

NOTE: To select multiple columns, hold down the Ctrl key while selecting.

3. Click Alerters on the Report toolbar.
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The Alerters dialog box appears.

4. Check the box next to an alerter to activate it, or uncheck the box to deactivate the 
alerter.
The table appearance changes according to which alerters are activated.
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11
Adding charts to reports

Overview
This chapter explains how to add charts to Web Intelligence reports and edit the data 
charts present.

• chart types available with Web Intelligence
• inserting and removing charts from reports
• transforming charts to different chart types
• modifying how data is included in charts
• duplicating and removing charts

For information on formatting charts, see ”Formatting charts” on page 133.

Available chart types
Web Intelligence offers standard chart formats to graphically display your business 
information. You can select one of five basic chart types in Web Intelligence:

• bar charts
• line charts
• area charts
• pie charts
• radar, polar, and scatter charts

Bar charts
Bar charts display data in bar form, either vertically or horizontally. Bar charts are useful if 
you want to compare similar groups of data; for example one time period to another. 
There are five types of bar charts: grouped, bar and line, stacked, percent, and 3D.

Line charts
Line charts connect specific data values with lines, either horizontally or vertically. Line 
charts are useful if you want to show trends or changes in data over time. There are five 
types of line charts: mixed, stacked, percent, 3D, and 3D surface.

Area charts
Area charts are line charts in which the area between the lines and axis are filled in. Area 
charts are useful if you want to emphasize the size of the total data in a report, as opposed 
to the changes in the data. You may not want to use an area chart if you have a sharp 
contrast between specific data points. Use a line chart instead.
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You can use more than one measure object on the Y-axis as long as the measures are of 
the same type and scale; for example, Number of Guests, and Future Guests. There are 
five types of area charts: absolute, stacked, percent, 3D area, and 3D surface.

Pie charts
Pie charts display data as segments of a whole. Pie charts are useful if you want to show 
how each part of your report data contributes to the total.

You can only include one measure object in a pie chart. If you have several measures in 
your report, you should choose another chart type. There are four types of pie charts: pie, 
3D pie, ring, 3D ring.

Radar, Polar, and scatter charts
In radar charts, the X- and Y-axis connect at the chart’s center. Radar charts are useful if 
you want to look at several different factors related to one item. For example, you could 
use a radar chart to display revenue data for different services within a hotel. On one axis, 
you could display revenue for the rooms. On another you could display revenue for the 
restaurant, and so on.

Scatter charts are similar to line graphs, except that the data points are plotted without a 
line connecting them. Scatter charts are useful if you want to make a comparison between 
specific data points.

There are four types of radar, polar, and scatter charts: radar line, stacked radar, polar, 
and scatter.

Inserting charts
There are three ways to insert a chart into a report:

• insert a blank chart and allocate data to the axes
• duplicate a chart already on the report and then modify the data and/or format
• turn a table into a chart – if you want to retain the original table you can duplicate the 

table first and then turn the duplicate into a chart

To insert a blank chart and allocate data to the axes

1. Verify that the Document Properties pane is displayed to the left of the selected report.
To display the Document Properties pane, click the Show Left Pane arrow at the top 
left of the report.

2. Click the arrow to the right of the drop-down list box, then select Chart and Table 
Types.
The categories of chart, table, and cell types appear.

3. If the Charts category is not visible, click the + next to Report Elements.
4. Click the + next to Charts.

The different types of chart are listed. Each type contains multiple versions with different 
layout and formatting properties.
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5. To view the formats available for the chart type, click the + next to the appropriate 
chart type.
For example, if you want to add a Bar chart to the report, click the + next to Bar.

6. Select the chart format you want to add to the report, and then drag it onto a blank 
area of the report.

The Format Chart dialog box appears.
7. Verify the Pivot tab is selected.

This tab allows you to allocate data to the chart axes.
8. Select objects from the Available Objects list and drop them onto the Y-Axis, X-Axis, 

and Z-Axis panes as appropriate.

NOTE: You can only place measure objects on the Y-Axis.

9. To view the data on the chart now, click OK.
Or
Click Apply and then select the General, Appearance, or Layout Properties tab(s) to 
personalize how the chart is formatted. (For information on the formatting options for 
charts, see ”Formatting charts” on page 133.)

To duplicate a chart

1. Select the chart you want to duplicate.
2. Click Duplicate on the Report toolbar.

Or
Click the arrow next to the Duplicate button and then select where you want the 
duplicate chart to be positioned in relation to the original chart.
Web Intelligence inserts the duplicate chart.
For information on the formatting options for charts, see ”Formatting charts” on 
page 133.

To turn a table into a chart

1. If you want to keep a table in the report and add a chart that displays the same data, 
you can duplicate the table first by selecting the table, and then clicking Duplicate on 
the Report toolbar.
Or
If you want to turn the original table into a chart, go to step 2.
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2. Right-click the table you want to turn into a chart.
3. Click Turn table to...

The Turn To dialog box appears.

4. Select the chart type you want to create in the left pane.
The different formats available for the selected chart type appear on the right.

5. Click the appropriate format, and then click OK.
Web Intelligence turns the table into a chart according to the format you selected.
You can modify how the data is allocated to the chart axes. To find out how to do this, 
see ”Modifying how data is allocated to charts” on page 128.

Transforming charts to different chart types
There are two ways to change the type of chart for a chart already displayed on a report:

• using Turn To
• dragging a different chart type onto a chart

To modify a chart using turn to

1. Right-click the chart you want to modify.
2. Click Turn chart to...
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The Turn To dialog box appears.

3. Select the chart type you want in the left pane.
The different formats available for the selected chart type appear on the right.

4. Click the appropriate format, and then click OK.
Web Intelligence modifies the chart according to the format you selected and 
re-allocates the data to different chart axes, if necessary.
You can modify how the data is allocated to the chart axes. To find out how to do this, 
see ”Modifying how data is allocated to charts” on page 128.

To modify a chart type using drag-and-drop

1. Verify that the Document Properties pane is displayed to the left of the selected report.
To display the Document Properties pane, click the Show Left Pane arrow at the top 
left of the report.

2. Click the arrow to the right of the drop-down list box, then select Chart and Table 
Types.
The categories of chart, table, and cell types appear.

3. If the Charts category is not visible, click the + next to Report Elements.
4. Click the + next to Charts.

The different types of chart are listed. Each type contains multiple versions with different 
layout and formatting properties.

5. To view the formats available for the chart type, click the + next to the appropriate 
chart type.
For example, if you want to change a chart on the report into a Bar chart, click the + 
next to Bar.
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6. Select the chart format you want, and then drag it onto the chart you want to modify.

Web Intelligence transforms the chart on the report to the new chart type you selected 
and re-allocates the data to different chart axes, if necessary.
You can modify how the data is allocated to the chart axes. To find out how to do this, 
see ”Modifying how data is allocated to charts” on page 128.

Modifying how data is allocated to charts
You can allocate different data to charts from among the data available in reports and 
swap the axes on 3D charts to view results from a different perspective. This section tells 
you how to:

• move, add, or remove data on charts
• swap data on 3D Bar chart axes

To move, add, or remove data on charts

1. Right-click the chart you want to modify.
2. Select Format > Chart.

The Format Chart dialog box appears.
3. Click the Pivot tab.
4. To add objects to the chart, select objects from the Available Objects list and drop 

them onto the Y-Axis, X-Axis, and Z-Axis panes as appropriate.
Or
To move objects from one axis to another, select the object in the appropriate axis 
pane, and then drag the object to the pane for the axis where you want to move it.
Or

Dragging a Line chart type onto a Bar chart
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To remove objects from the chart, select the object in the appropriate axis pane, and 
then drop the object onto the Available Objects list.

NOTE: You can only place measure objects on the Y-Axis.

5. Click OK.
Web Intelligence displays the chart with the data allocated to the chart axes as you 
specified.

NOTE: If you want to add data to a chart that isn’t already included in the data 
definition of the document, you can add more data to your document by modifying 
the query, if you have the appropriate security profile. For information on editing 
queries, see the Building Queries Using Web Intelligence Query – HTML guide.

To swap data on 3D chart axes

1. Right-click the chart you want to modify.

Dragging [Quarter] from the X-Axis onto the Z-Axis
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NOTE: You can only swap axes on 3D Bar charts.

The contextual menu appears.

2. Select Swap axes.
The data on the X-Axis is moved to the Z-Axis and the data on the Z-Axis is moved to 
the X-Axis.

Duplicating and removing charts
To avoid building a chart from scratch, you can duplicate an existing chart on a report 
and then modify its formatting and data content, as necessary. You can remove charts 
from reports at any time.

To duplicate a chart

1. Select the chart you want to duplicate.
2. Click Duplicate on the Report toolbar.

Or
Click the arrow next to Duplicate, and then select where you want to position the 
duplicate chart.
Web Intelligence displays the duplicate chart on the report.
You can modify how the data is allocated to the chart axes. To find out how to do this, 
see ”Modifying how data is allocated to charts” on page 128.
For information on the formatting options for charts, see ”Formatting charts” on 
page 133.

To remove a chart from a report

1. Right-click the chart you want to remove.
The contextual menu appears.

2. Select Remove Chart.

X-Axis

Z-Axis
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Web Intelligence removes the selected chart from the report.
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12
Formatting charts

Overview
You can personalize the formatting settings applied to charts. This chapter tells you about:

• the formatting options available per chart type
• resizing charts
• positioning charts on report pages
• setting page breaks on charts
• adding and formatting chart titles
• displaying and formatting legends
• applying a 2D or 3D look
• formatting axis labels
• formatting axis values, grids, and scales
• formatting how data appears on the chart body
• formatting chart borders
• formatting chart backgrounds, floors, and walls
• applying or avoiding duplicate row aggregation

Formatting options per chart type
This section of this chapter includes illustrations that will help you identify the different 
areas of charts you can format. Since not all chart types include all of the possible axes or 
legends, this section provides examples of several different chart types.
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About 2D charts
For example, 2D charts include an optional axis legend that lists the values displayed on 
the bars or lines.

In this example, a 2D bar chart includes the optional Z-Axis. Including data on the Z-Axis 
enables you to show an additional break down of the results displayed on the chart bars. 
The [Sales revenue] measure is on the Y-Axis, the [Year] dimension is on the X-Axis, and 
the [Quarter] dimension is on the Z-Axis.

About 3D charts
3D bar charts do not include an axis legend. You can clearly see what information is 
displayed on the chart bars by looking at the axis labels.

X-Axis Values

X-Axis Label

Y-Axis 
Values

Y-Axis 
Label Legend

Data

Floor

Chart title

Wall
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The following example shows a 3D bar chart.

In this example, the chart bars display sales revenue per quarter, per year. The [Sales 
revenue] measure is on the Y-Axis, the [Quarter] dimension is on the X-Axis, and the [Year] 
dimension is on the Z-Axis.

About pie charts
Pie charts have a single axis displayed on the body of the pie. This is the Y-Axis. Each 
segment of the pie chart displays a value for the measure on the Y-Axis. The pie chart 
legend indicates the dimension on the X-Axis.

In this example, the 3D pie chart shows sales revenue per year. The measure on the Y-Axis 
is [Sales revenue] and the dimension displayed on the X-Axis is [Year]. Like 2D pie charts, 
3D pie charts display measures for a single dimension. The graphical design of 3D pie 
charts, however, gives a 3D appearance.

Resizing charts
When you insert a chart onto a report, the size of the chart is minimal. You can resize the 
chart to make results display more clearly, according to the amount of information the 
chart contains.

X-Axis values

X-Axis label
Z-Axis values

Z-Axis label

Chart title

Floor

Right wall

Y-Axis label

Y-Axis 
values

Chart data

Y-Axis label

Chart title

Legend
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To resize a chart

1. Select the chart, and then dragging the borders outwards.

Web Intelligence resizes the chart according to your modifications.

Positioning charts on report pages
You can specify where you want charts to appear on the report page. 

• Drag the vertical 
borders to the right or 
the left to change the 
chart width.

• Drag the horizontal 
borders up or down to 
change the chart 
height.
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Note:  By default, Web Intelligence names each chart with a default name Block1, Block2, 
Block3, and so on. You can rename charts with meaningful names to make it easier to 
select the formatting options for a specific chart or to align charts in relation to other tables 
or charts on the report page.

This section tells you how to:

• name a chart
• position a chart on the report page

To name a chart

1. Right-click the chart where you want to name.
2. Select Format > Chart.

The Format Chart dialog box appears.
3. Click the General tab.
4. In the Name text box, type the name you want to assign to the chart.

For example, “Pie chart – sales regions”
5. Click OK.

Web Intelligence assigns the name you typed to the chart.
To view the chart name, view the Document Structure and Filters overview. To find 
out how to do this, see ”Viewing the document overview” on page 41.

To position a chart on a report page

1. Right-click the chart for which you want to specify the position.
2. Select Format > Chart.

The Format Chart dialog box appears.
3. Click the Page Layout tab.
4. In the Position section, specify where you want to position the left edge and the top 

edge of the chart in relation to left edge and top edge of the report page.
5. Click OK.

Web Intelligence positions the chart on the report page, as you specified.

Setting page breaks for charts
When your report contains several pages, you can choose to avoid page breaks in charts. 
This enables you to keep charts in their entirety on the same page of a report. You can also 
repeat charts on each page of a report. This is useful on long reports, where the chart is 
necessary to make a comparison with other report data.

To avoid page breaks in a chart and repeat charts on report pages

1. Right-click the chart you want to modify.
2. Select Format > Chart.
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The Format Chart dialog box appears.
3. Click the Page Layout tab.

4. Select the appropriate page layout options:

1. Click OK.
Web Intelligence applies the page layout properties to the chart, as you specified.

Adding and formatting chart titles
You can add titles to charts to identify the information they present. This section tells you 
how to:

• insert a title for a chart
• format a chart title

To insert a title for a chart

1. Right-click the chart where you want to add a title.
2. Select Format > Chart.

The Format Chart dialog box appears.
3. On the General tab, select Show chart title.
4. Click the Appearance tab.
5. Click Chart Title on the preview pane on the left.

If you want to... then select...

Insert a page break so that the 
chart appears at the top of a 
new page,

Start on a new page

Display the chart on every page 
of the report,

Repeat on every page

Prevent page breaks from 
occurring on the chart, wherever 
possible,

Avoid page breaks in a 
block
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6. In the Chart Title pane on the right, type the title you want to give to the chart.

7. To view the title on the report, click OK.
Or
If you want to format the title now, go to step 4, below.

To format a chart title

1. Right-click the chart with the title you want to format.
To see how to insert a title for a chart, refer to ”To insert a title for a chart” on 
page 138.

2. Select Format > Chart.
The Format Chart dialog box appears.

3. Click the Appearance tab, and then click Chart Title on the preview pane on the left.
4. Use the options in the formatting toolbar on the Appearance tab to format the text, cell 

background, and cell borders of the chart title.
5. Click OK.

Web Intelligence applies your formatting changes to the chart title.

Displaying and formatting legends for charts
You can insert a legend for the following chart types:

• 2D bar charts, 2D line charts, and 2D bar and line charts
• pie and doughnut charts
• radar, polar, and scatter charts
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Note:  Axis legends are not available for 3D Bar charts.

You can set Web Intelligence to display the legend to either the left, right, or bottom of the 
chart. You can also hide the legend.

To show or hide a legend and position the legend next to the chart

1. Right-click the chart you want to modify.
2. Select Format > Chart.

The Format Chart dialog box appears.
3. Click the General tab.
4. To display a legend, click Show legend, and then click the arrow next to the 

drop-down list box and select where you want to position the legend (Left, Right, or 
Bottom) in relation to the chart.

Or
If you don’t want to include a legend, verify that Show legend is not selected.

5. If you want to format the appearance of the legend, refer to ”To set formatting 
properties for a legend” on page 141, below.

legend
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6. Click OK.
Web Intelligence shows or hides the legend for the chart, as you specified.

To set formatting properties for a legend

1. Right-click the chart you want to modify.
Verify the chart already has a legend displayed. If you need to insert a legend first, 
refer to”To show or hide a legend and position the legend next to the chart” on 
page 140.

2. Select Format > Chart.
The Format Chart dialog box appears.

3. Click the Appearance tab.
4. On the chart preview pane, click Legend.

The formatting options for the legend appear.

5. Select the appropriate settings for the legend text (font style, size, and color), for the 
legend background (color), and for the legend borders (style and color).

6. Click OK.
Web Intelligence applies the formatting properties to the legend, as you specified.
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Applying a 2D or 3D look
You can format 2D charts with a 3D look. A 3D look shades the chart bars or pie 
segments, giving the 2D chart the appearance of being in relief.

To select a 2D or 3D look for a chart

1. Right-click the chart for which you want to select a 2D or 3D look.
2. Select Format > Chart.

The Format Chart dialog box appears.
3. Click the General tab.
4. If you want to apply a 3D look to the chart, select 3D look.

Or
If you want to apply a 2D look to the chart, verify that the 3D look option is not 
selected.

5. Click OK.
Web Intelligence applies the 2D or 3D look you selected to the chart.

A 2D bar chart without the 3D look A 2D bar chart with the 3D look
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Formatting axis labels
Axis labels help identify the data represented by the values along each of the chart axis.

In this example, above, the Y-Axis label shows you that the dollar totals on the Y-Axis 
correspond to Sales revenue results and the X-Axis label shows you that the figures along 
the X-Axis represent dates for Year.

This section tells you how to:

• show or hide axis labels
• format axis labels

To show or hide axis labels

1. Right-click the chart where you want to modify.
2. Select Format > Chart.

The Format Chart dialog box appears.
3. Click the General tab.

To display axis labels, select the Show X Axis, Show Y Axis, and Show Z Axis 
check boxes, as appropriate.
Or
To hide axis labels, verify that the Show X Axis, Show Y Axis, and Show Z Axis 
check boxes are not selected, as appropriate.

4. Click OK.
Web Intelligence shows or hides the axis labels on the chart, as you specified.

To format an axis label

1. Right-click the chart you want to modify.
2. Select Format > Chart.

The Format Chart dialog box appears.
3. Click the Appearance tab.

Y-Axis label

X-Axis label
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4. Click Label on the X-Axis, Y-Axis, or Z-Axis preview pane, as appropriate.

5. Use the options in the formatting toolbar on the Appearance tab to format the text, cell 
background, and cell borders of the chart title.

6. If you want to apply formatting changes to other axis labels, repeat steps 4 to 5.
Or
If you have finished your formatting modifications, click OK.
Web Intelligence applies your formatting changes to the axis label(s).

Formatting chart axis values, grids, and scales
This section tells you how to format the values, grids, and scales for the different chart 
axes.

Understanding 3D and 2D chart axes
3D charts include three axes: the Y-Axis always displays values for measures (such as sales 
totals, margins, quantities and so on); the X- and Z-Axis display values for dimensions (that 
is, key indicators, such as time, geography, service lines, and so on). In this example, the 
chart bars display sales revenue per quarter, per year. The [Sales revenue] measure is on 
the Y-Axis, the [Quarter] dimension is on the X-Axis, and the [Year] dimension is on the 
Z-Axis:
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When the same data is displayed on a 2D chart it looks like this:

In the second example, the 2D bar chart includes the optional Z-Axis with the values for 
quarter. Including data on the Z-Axis enables you to show an additional break down of the 
results displayed on the chart bars. Just like the 3D chart above, the [Sales revenue] 
measure is on the Y-Axis, the [Year] dimension is on the X-Axis, and the [Quarter] 
dimension is on the Z-Axis. Notice that because the Z-Axis cannot be represented 
graphically on a 2D chart, the legend provides the information for the Z-Axis values.

Formatting grids, values, and scales
This section tells you how to format axis:

• grids
• values
• scales

Formatting the axis grid
The axis grid helps you identify how each result, on the bars or data markers of a chart, 
relates to the values along each axes. The following chart displays a grid along the Y-Axis 
and along the X-Axis:
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This chart only displays a grid on the Y-Axis:

To show or hide an axis grid

1. Right-click the chart you want to modify.
2. Select Format > Chart.

The Format Chart dialog box appears.
3. Click the Appearance tab, and then click Values on the appropriate axis on the 

preview pane on the left.

The options available for the selected axis appear.
4. To show the grid on the selected axis, select Show grid.

Or
To hide the grid on the selected axis, verify that the Show grid option is not selected.

5. Click OK.
The grid is shown or hidden, as you specified.

To format the grid color

1. Right-click the chart you want to modify.
2. Select Format > Chart.

The Format Chart dialog box appears.
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3. Click the Appearance tab, and then click Values on the appropriate axis on the 
preview pane on the left.

The options available for the selected axis appear.
4. Verify that the Show grid option is selected.
5. Click the arrow next to the color wash button, and then either select a predefined color 

or click More colors... to define a custom color, and then click OK.
6. Click OK.

Web Intelligence applies the color(s) you selected to the chart axes.

Axis values
You can format how the values on each chart axis appear as follows:

• axis value format – choose a specific number format for numbers, dates, currency, and 
so on, and choose the font size, orientation, and color for the text

• axis value frequency – display axis values along an axis at an automatic frequency or 
at a frequency you specify

• Y-Axis scale range – specify a min. or max. value on the Y-Axis

To define the text format and number format for axis values

1. Right-click the chart you want to modify.
2. Select Format > Chart.

The Format Chart dialog box appears.
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3. Click the Appearance tab, and then click Values on the appropriate axis on the 
preview pane on the left.

The options available for the selected axis appear.
4. Use the options in the formatting toolbar on the Appearance tab to format the text, cell 

background, and cell borders of the chart title.
5. If you want to change the number format applied to numerical values or dates, click the 

arrow next to the Number drop-down list box, and then select the appropriate format.
6. Click OK.

Web Intelligence applies the formats to the selected axis values on the chart, as you 
specified.

To set how frequently values display on an axis

1. Right-click the chart you want to modify.
2. Select Format > Chart.

The Format Chart dialog box appears.
3. Click the Appearance tab, and then click Values on the appropriate axis on the 

preview pane on the left.

Formatting toolbar
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The options available for the selected axis appear.
4. If you want Web Intelligence to display values along the axis at an automatic 

frequency, select Auto axis value frequency.
5. If you want to specify the frequency at which the values appear, deselect Auto axis 

value frequency, and then type the frequency you want

NOTE: If you type “2” every two values appear on the axis; if you specify “3” 
every three values appear on the axis, and so on.

6. Click OK.
Web Intelligence applies the axis frequency to the chart, as you specified.

To define minimum or maximum values for display on the Y-Axis

1. Right-click the chart you want to modify.
2. Select Format > Chart.

The Format Chart dialog box appears.
3. Click the Appearance tab, and then click Values on the Y-Axis area of the preview 

pane on the left.

The options available for the Y-Axis appear.
4. To specify the minimum value, select Min. value, and then type minimum value you 

want, in the text box.
5. To specify the maximum value, select Max. value, and then type maximum value you 

want, in the text box.
6. Click OK.

Web Intelligence applies the minimum and maximum values to the Y-Axis on the 
selected chart, as you specified.
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Displaying a linear or logarithmic scale for the Y-Axis
By default, Web Intelligence displays the Y-Axis on charts as a linear scale. You can set 
the axis to a logarithmic scale. Logarithmic scales allow you to examine values that span 
many orders of magnitude without losing information on the smaller scales.

Linear scales
In a linear scale, the axis markers are evenly spaced. Linear scales are based on addition. 
Consider, for example, the linear sequence:

1, 3, 5, 7, 9

To get the next number in the sequence, you add 2 to the previous number.

Logarithmic scales
Logarithmic scales are based on multiplication rather than addition. In a logarithmic scale, 
the steps increase or decrease in size. Logarithmic scales are based on multiplication (or 
division). Consider, for example, the logarithmic sequence:

2, 4, 8, 16, 32

To get the next number in the sequence, you multiply the previous number by 2. We can 
say that this sequence represents ``base 2.''

Consider the following sequence:

1, 10, 100, 1000, 10000

This sequence represents ``base 10,'' because you get the next term in the sequence by 
multiplying the previous term by 10.

To change a Y-Axis scale to logarithmic or linear

1. Right-click the chart you want to modify.
2. Select Format > Chart.

The Format Chart dialog box appears.
3. Click the Appearance tab, and then click Values on the Y-Axis area of the preview 

pane on the left.

The options available for the Y-Axis appear.
4. To display the Y-Axis as a logarithmic scale, select Logarithmic scale.
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Or
To display the Y-Axis as a linear scale, verify that the Logarithmic scale option is not 
selected.

5. Click OK
Web Intelligence applies the type of scale you specified to the Y-Axis on the selected 
chart.

Formatting how data appears on the chart body
Results for data appear on charts as a series of bars, lines, markers, or segments 
depending on the type of chart. You can apply the following formatting options to the data 
series on charts:

• show/hide the values – for the data on each chart bar, line, or marker
• select a specific color – for the primary data series (that is, for the bars, lines, or 

markers that display the first measure on the chart body)
• show values on pie charts as percentages

To show or hide data values

1. Right-click the chart you want to modify.
2. Select Format > Chart.

The Format Chart dialog box appears.
3. Click the General tab.
4. To display the figures for each result on the chart bars, lines, markers, or segments, 

select Show data values.
Or

5. To hide the figures for each result on the chart bars, lines, markers, or segments, verify 
that Show data values is not selected.

6. Click OK.
Web Intelligence shows or hides the data values on the selected chart, as you 
specified.

To select a primary color

1. Right-click the chart you want to modify.
2. Select Format > Chart.

The Format Chart dialog box appears.
3. Click the Appearance tab.
4. In the Data: Primary Color section, click the arrow next to the color wash button, and 

then either select a predefined color or click More colors... to define a custom color, 
and then click OK.

5. Click OK.
Web Intelligence applies the color you selected to the first series of results on the chart, 
as you specified.
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To show values on pie charts as percentages

1. Right-click the chart you want to modify.
2. Select Format > Chart.

The Format Chart dialog box appears.
3. Click the Appearance tab.
4. In the Data section, select Show values as percentages.
5. Click OK.

Web Intelligence displays the percentage figure for each result on the corresponding 
segment of the pie chart.

Formatting chart borders
You can select colors and styles for the borders and backgrounds on charts.

To select a border style and color

1. Right-click the chart.
2. Select Format > Chart.

The Format Chart dialog box appears.
3. Click the General tab.
4. In the Chart borders section, click the arrow next to the drop-down list box, and then 

select the style you want for the border.

5. Click the arrow next to the color wash button, and then either select a predefined color 
or click More colors... to define a custom color, and then click OK.

6. Click OK.
Web Intelligence applies the style and color you selected to the chart borders.

To remove a border

1. Right-click the chart.
2. Select Format > Chart.

The Format Chart dialog box appears.
3. Click the General tab.
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4. In the Chart borders section, click the arrow next to the drop-down list box, and then 
select None.

5. Click OK.
Web Intelligence removes the borders from the chart, as you specified.

Formatting chart backgrounds, walls, and floors
You can insert a color background behind charts. You can also show or hide walls and 
floors on charts and define their color.

You can show both walls and floors on 3D charts. You can show floors on 2D charts with 
a 3D look. To find out how to apply a 3D look to a 2D chart, see ”Applying a 2D or 3D 
look” on page 142.

Note:  You cannot show floors or walls on 2D charts without a 3D look.

To select a background color

1. Right-click the chart.
2. Select Format > Chart.

The Format Chart dialog box appears.
3. Click the General tab.
4. Click the arrow next to the color wash button, and then either select a predefined color 

or click More colors... to define a custom color, and then click OK.
5. Click OK.

Web Intelligence applies the color you selected to the chart background.

To show or hide a chart wall or floor

1. Right-click the chart.
2. Select Format > Chart.

The Format Chart dialog box appears.
3. Click the Appearance tab.

Right wall

Floor

Left wall
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4. Click the chart body area on the preview pane.

The options to show the chart floor and walls appear.

NOTE: You can show both walls and floors on 3D charts. You can only show 
floors on 2D charts with a 3D look. 

5. If you want to show the floor and/or walls on the chart, select Show floor, Show left 
wall, and/or Show right wall, as appropriate.
Or
If you don’t want to the floor and/or walls on the chart, verify that Show floor, Show 
left wall, and/or Show right wall are not selected, as appropriate.

6. Click OK.
Web Intelligence shows or hides the chart floors and walls, as you specified.

Avoiding duplicate row aggregation
Web Intelligence automatically aggregates any rows that display the same set of 
dimensions. This example shows a chart that displays sales revenue by state and quarter:

Chart body area
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If you remove the [State] dimension from the chart, Web Intelligence aggregates the sales 
revenue values per quarter and displays the sum of the sales revenue sum of all states per 
quarter:

If you select the Avoid duplicate row aggregation option, each duplicate value (in this 
case, for quarter) is displayed on a separate bar on the chart:

To apply or avoid duplicate row aggregation

1. Right-click the chart where you want to add a title.
2. Select Format > Chart.

The Format Chart dialog box appears.
3. Click the General tab.
4. If you want to aggregate duplicate values on the chart, verify that Avoid duplicate 

row aggregation is not selected.
Or
If you don’t want to aggregate duplicate values on the chart, select Avoid duplicate 
row aggregation.

5. Click OK.
Web Intelligence applies the option you selected to the chart.
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13
Dividing reports into sections

Overview
Dividing reports into sections enables you to group related information together in reports. 
This is particularly useful on large reports, since using sections also helps you navigate 
reports from section-to-section, using the hyperlinks in the Navigation Map. (For 
information on using the Navigation Map to view report sections, see ”To navigate to a 
section” on page 40.)

This chapter tells you about:

• how sections work
• inserting sections
• inserting sub-sections
• including hyperlinks to sections for easy report navigation
• setting page breaks for sections
• positioning sections on the report page
• formatting sections
• removing sections

About sections
You can select a dimension on a table and divide the report into sections according to the 
value of the selected dimension. This enables you to group related information in reports 
and then navigate from section-to-section.

Example:  Divide a long report into sections by state

In this example, you are viewing a report with a long table that provides results for the 
different states where the eFashion store has retail outlets. You want to divide the report 
into results by state and sub-divide each of the sections per state into sub-sections by year. 
To do this, you select "State" in a column header of a table and set State as a section.
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You then select “Year” in the table column header and set “Year” as a section below 
“State.” Web Intelligence divides the report into sections by state with a sub-section per 
year.

Inserting sections
To make reports easy to navigate, you can divide the report into sections that group 
related data together. The tables and charts in a section only display the data relevant to 
the dimension on which the section is created. For example, if you create a section on the 
[Year] dimension, the tables and charts in the section for “2003” will only display data for 
the year 2003.

A section consists of a section cell and the section itself. The section cell is a free standing 
cell that displays a value for a selected dimension (for example, state, customer, year, and 
so on). For example, if a report has a section on the year dimension and the database has 
data for the years 2001-2003, then there will be one section for year 2001 data, a 
second section for year 2002 data, and a third section for year 2003 data.

There are two ways to create sections in reports:

Section cell

Section
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• select a table cell – using this method, you can base sections on cells in tables and 
forms

• select an object available in the document – using this method, you can base sections 
on any objects listed in the Available Objects pane to the left of reports

To create a section from a table cell

1. With a Web Intelligence document open, right-click the table cell you want to make 
into a section.
The contextual menu appears.

2. Click Set as section.
Web Intelligence removes the selected cell from the table and creates the new section. 
The section cell at the top of each section displays one of the values for the object on 
which the section is based. For example, if you create a section by selecting a table 
cell displaying “2001” which is a value for the [Year] dimension, then each section cell 
displays a value for year, such as “2001,” “2002,” “2003,” and so on.

To add a section based on object available in the document

1. With a report in a Web Intelligence document open, verify that the Document 
Properties pane is displayed to the left of the selected report.
To display the Document Properties pane, click the Show left pane arrow at the top 
left of the report.

2. Click the arrow to the right of the drop-down list box, then select Available Objects.
3. Select the object, on which you want to base a section, and then drag-and-drop the 

selected object onto a blank area of the report above the tables and charts you want to 
include inside the section.
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Web Intelligence creates the new section and inserts each value on the dimension that 
you selected for the section, into the section cell.

Creating sub-sections
You can create a report with multiple sections. You create multiple sections in the same 
way you create a section:

• by selecting a cell on a table and selecting Set as section from the contextual menu
or

• by selecting a dimension object listed on the Available Objects pane, and then 
dragging and dropping the dimension below an existing section cell.
For step-by-step instructions on creating sub-sections, follow the instructions in ”To 
create a section from a table cell” on page 159 or ”To add a section based on object 
available in the document” on page 159.

Inserting hyperlinks to sections
You can insert hyperlinks to each section in a report. This is a useful tool to help navigate 
long reports, section-by-section.

To show or hide a bookmark to a section

1. With a Web Intelligence document open, right-click an empty area of the section that 
you want to format.

NOTE: Do not click the section cell. If you click the section cell, the formatting 
options available to you correspond to options you can use to format the individual 
cell, not the entire section.

The contextual menu appears.

2. Select Format > Section.
The Format Section dialog box appears.

3. Click the General tab.
4. Select Include section in the Navigation Map.
5. Click OK.

The gray highlighting on the section background 
indicates that the section is selected
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Web Intelligence creates hyperlinks to each of the section values and includes the 
hyperlinks in the Navigation Map pane. To see how to view the Navigation Map and 
navigate reports section-to-section, refer to ”To navigate to a section” on page 40.

Setting page breaks for sections
You can control page breaks within sections, by selecting the following two options:

• start on a new page
• avoid page breaks in section

Defining page breaks on a section

1. With a Web Intelligence document open, right-click an empty area of the section that 
you want to format.

NOTE: Do not click the section cell. If you click the section cell, the formatting 
options available to you correspond to options you can use to format the individual 
cell, not the entire section.

The contextual menu appears.

2. Select Format > Section.
The Format Section dialog box appears.

3. Click the Page Layout tab.
4. Select the appropriate options:

1. Click OK.

If you want to... then select...

Insert a page break so that the 
section appears at the top of a 
new page,

Start on a new page

Prevent page breaks from 
occurring on the section, 
wherever possible,

Avoid page breaks in a 
block

The gray highlighting on the section background 
indicates that the section is selected
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Web Intelligence applies the page layout properties to the section, as you specified.

Positioning sections on the report page
You can specify the position of a section on a report page, by specifying where you want 
the top of the section to appear.

To position a section on a report page

1. With a Web Intelligence document open, right-click an empty area of the section that 
you want to format.

NOTE: Do not click the section cell. If you click the section cell, the formatting 
options available to you correspond to options you can use to format the individual 
cell, not the entire section.

The contextual menu appears.

2. Select Format > Section.
The Format Section dialog box appears.

3. Click the Page Layout tab.
4. In the Position section, specify where you want to position the left edge and the top 

edge of the section in relation to left edge and top edge of the report page.
5. Click OK.

Web Intelligence positions the top of the section on the report page, as you specified.

Formatting sections
You can personalize how the section background is formatted in the following ways:

• specify a background color
• include an image or skin

Skins are predefined images specially designed for the background of reports, 
sections, tables, or cells.

The gray highlighting on the section background 
indicates that the section is selected
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Note:  Section cells can be formatted just like free standing cells or cells in tables. To 
format section cells see ”Formatting cell values” on page 114 or ”Formatting tables and 
cells” on page 111.

To select a background color for a section

1. With a Web Intelligence document open, right-click an empty area of the section that 
you want to format.
The background of the selected section is highlighted gray.

NOTE: Do not click the section cell. If you click the section cell, the formatting 
options available to you correspond to options you can use to format the individual 
cell, not the entire section.

The contextual menu appears.
2. Select Format > Section.

The Format Section dialog box appears.
3. Click the Appearance tab.
4. Click the arrow next to the color wash button, and then either select a predefined color 

or click More colors... to define a custom color, and then click OK.
5. Click OK.

Web Intelligence applies the color you selected to the section background.

To display an image on a section background

1. With a Web Intelligence document open, right-click an empty area of the section that 
you want to format.
The background of the selected section is highlighted gray.

NOTE: Do not click the section cell. If you click the section cell, the formatting 
options available to you correspond to options you can use to format the individual 
cell, not the entire section.

The contextual menu appears.
2. Select Format > Section.

The Format Section dialog box appears.
3. Click the Appearance tab.
4. In the Pattern section, select Image (URL).
5. In the Image (URL) text box, type the file name or URL for the image file.
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The following table will help you specify the file name:

NOTE: The size of the image is defined when the image is created. You cannot 
modify the size of the image using Web Intelligence.

Click the arrow to the right of the Display drop-down list box, and then select how you 
want the image to be displayed:

If... then...

the image file 
has been 
installed by your 
administrator in 
the images 
directory on the 
BusinessObjects 
Enterprise 
server, 

type: boimg:// followed by the file name.

For example, if the file name is 
“efashion_logo.gif,” then type:

boimg://efashion_logo.gif

NOTE: Image files need to installed by 
your administrator at the following 
directory on the BusinessObjects Enterprise 
server:

<INSTALL DIR>\Images

the image file is 
located on 
another web 
server, 

type the URL.

For example:

http://www.internal.businesscompany.com/images/compan
y_logo.gif

If you want to... then select...
display the image once at the top left of the report, 
section, table, or cell,

Normal

stretch the image over the entire report area,

NOTE: this option is only applied when you 
view or save the report as a PDF file. (See ”To 
save a Web Intelligence document as a PDF 
file” on page 250.)

Stretch (PDF 
only)

repeat the image vertically and horizontally, Tile
repeat the image horizontally across, Horizontal tile
repeat the image vertically downward, Vertical tile
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1. If you selected Normal as the image display format, you can specify how you want the 
image to be vertically and horizontally aligned by clicking the arrows in the list boxes 
next to Position and selecting the appropriate vertical and horizontal position.

2. Click OK.
Web Intelligence applies the image you selected to the section background.

To display a skin on a section background

1. With a Web Intelligence document open, right-click an empty area of the section that 
you want to format.
The background of the selected section is highlighted gray.

NOTE: Do not click the section cell. If you click the section cell, the formatting 
options available to you correspond to options you can use to format the individual 
cell, not the entire section.

The contextual menu appears.
2. Select Format > Section.

The Format Section dialog box appears.
3. Click the Appearance tab.

In the Pattern section, select Skin.
The list of available skins appears in the drop-down list box to the right.

4. Select the skin you want.
5. Click OK.

Web Intelligence applies the skin you selected to the section background.

Removing sections
You can remove sections from reports at any time. When you remove a section, Web 
Intelligence regroups the tables and charts in reports accordingly.

To remove a section

1. With a Web Intelligence document open, right-click a section you want to remove.
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Make sure that the section is selected, and not the section cell.

The contextual menu appears.
2. Select Remove Section.

Web Intelligence removes the section and regroups the report data accordingly.

In this example, the 
section for Year is 
selected
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14
Organizing results on tables using 
breaks and sorts

Overview
You can organize the information displayed in reports, by using sorts and breaks, so that 
reports are easy to read and navigate. Sorts enable you to order results alphabetically or 
numerically and breaks enable you to group related information together in tables.

This chapter tells you:

• about sorts – the sort orders available with Web Intelligence
• how to apply and remove sorts
• about breaks
• how to insert, remove, and prioritize breaks
• set display properties and page layout properties for breaks

About using sorts
You can apply sorts to the results displayed in:

• section cells – to organize the order in which sections are displayed on a report
• tables – to organize the order in which results are displayed in a column or row
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Note:  You can apply multiple sorts to a table or section and then prioritize the sorts, so 
that the information is sorted in the order you require. To do this, you need to set your 
Reporting Rules so that Web Intelligence always makes the last sort you apply either (a) 
take precedence over other sorts or (b) be the last sort to be applied after other sorts. For 
full information on how to do this, see ”To define your reporting rules” on page 30.

Available sort orders
The following sort orders are available:

Note:  To sort months in chronological order, apply the Default sort order.

Applying and removing sorts
You can apply sorts to any of the following types of data on tables or sections:

• dimensions - typically retrieve character-type data.
For example: customer names, line names, or dates.

Sort order Description

Default This is sometimes referred to as the “natural” order. 
Depending on the type of data in the column or row, the 
results are sorted as follows:

• ascending numeric order for numeric data
• ascending chronological order for date
• alphabetical order for alphanumeric data

Ascending When selected, results are arranged in ascending 
order: The smallest value at the top of the column 
moving to the highest value at the bottom.

For example: 100, 200, 300 or California, Colorado, 
Florida.

Descending When selected, results are arranged in descending 
order: The highest value at the top of the column moving 
to the smallest value at the bottom.

For example: 300, 200, 100 or Florida, Colorado, 
California.

Custom When you define a custom sort, you choose your own 
sort order for the data.
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• details – provide descriptive data about a dimension.
For example: [Age] is a detail associated with the [Customer] dimension. 

• measures – Retrieves numeric data that is the result of calculations on data in the 
database.
For example: [Sales Revenue] is the calculation of the number of units sold multiplied 
by the unit price. 

Sorting dimensions and details helps you organize results chronologically, while sorting 
measures helps you see highest or lowest results at a glance.

To apply an ascending or descending sort to a table or section

1. Right-click the table column/row or section cell you want to sort, and then on the 
contextual menu, click Sort > Descending or Sort > Ascending.
Or
Click the table column/row or section cell you want to sort, and then click the 
Ascending or Descending sort button on the Report toolbar.
To display the Report toolbar, right-click the main toolbar above the report, and then 
click Report on the contextual menu.

For a full description of how each sort order impacts character, numeric, and date 
data, see ”Available sort orders” on page 168.
Web Intelligence applies the ascending or descending order to the results on the table 
or section, as you specified.

To apply a custom sort

1. Right-click the table column/row or section cell you want to sort, and then on the 
contextual menu, click Sort > Custom Sort.

The selected column is highlighted

Ascending and Descending 
Sort buttons
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The Custom Sort dailog box appears.

2. Select an item in the list then click the down or up button to the right of the list to move 
the item up or down in the list.

3. Repeat step 2 until the items are sorted in the order you want.
4. Click OK.

Web Intelligence sorts the items according to the custom sort order you specified.

To remove a custom sort

1. Right-click the table column/row or section cell on which you have applied a custom 
sort, then click Sort > Custom Sort on the menu.
The Custom Sort dialog box appears

2. Click Delete Custom Sort.

You can also delete a custom sort by using the following procedure:

1. Right-click the table column/row or section cell on which you have applied a custom 
sort, then click Sort > Properties on the menu.
The Sort Properties dialog box opens showing all the sorts defined on the block.

2. Select the sort you want to delete and click Remove.

To view the sorts defined on a block

1. Select any cell in the table.
2. Right-click and select Sort > Properties.

The Sort Properties dialog box opens and shows the list of sorts defined on the table.
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NOTE: You can also define a custom sort from the Sort Properties dialog box by 
clicking Custom Sort, which takes you to the Custom Sort dialog box.

Defining multiple sorts
You can apply multiple sorts to a table or section and then prioritize the sorts, so that the 
information is sorted in the order you require. To do this, you need to set your Reporting 
Rules so that Web Intelligence always makes the last sort you apply either (a) take 
precedence over other sorts or (b) be the last sort to be applied after other sorts. For full 
information on how to do this, see ”To define your reporting rules” on page 30.

About breaks
A break is a division in a table that groups data with the same results.

Example:  How can I show revenue subtotals for each state in a table?

The table on the left displays sales revenue per year per state, with the total sales revenue 
result displayed at the bottom of the table. The table on the right displays the same data, 
but with a break on “State.” In this table, the results for each state are grouped together. 
This means you can now show a subtotal for the revenue generated by each state. 

Inserting breaks in tables enables you to:

• organize how information is presented, by grouping related information together
• display subtotals for each group of information

How data is sorted when you insert a break
When you insert a break on a dimension, the values for the dimension are automatically 
sorted in ascending order. If the values are numeric, the lowest value appears in the first 
row of the table and the highest result appears in the last row. If the values are 
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alphabetical characters, then the values are sorted in alphabetical order from top to 
bottom. You can change this sort order at any time. For information on how to apply sorts, 
see ”To apply an ascending or descending sort to a table or section” on page 169.

Inserting, removing, and prioritizing breaks
You can insert one or multiple breaks on a table or crosstab. You can insert breaks on any 
columns or rows that display values for:

• dimensions - typically retrieve character-type data.
For example: customer names, line names, or dates.

• details – provide descriptive data about a dimension.
For example: [Age] is a detail object that is associated with the [Customer] dimension. 

Note:  You cannot insert a break on columns or rows that display a measure.

You can prioritize breaks on tables to organize groups of data on tables within other 
groups. For example, if you want to group data on a table by country and then, within 
each country, group that data by customer, you need to insert a break on the [Country] 
dimension and on the [Customer] dimension, and then give first priority to the break on 
[Country].

To insert or remove a break

1. Right-click the table cell containing the results you want to group together, and then on 
the contextual menu, click Break > Insert.
Or
Click the table cell containing the results you want to group together, and then click the 
Break button on the Report toolbar.
To display the Report toolbar, right-click the main toolbar above the report, and then 
click Report on the contextual menu.

Web Intelligence groups the selected data together on the table, by inserting a break, 
and inserts a footer at the end of each break

The selected column 
for “State” is 

Break button

The data for each state 
is grouped together
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To prioritize breaks on a table

1. With a Web Intelligence document open, right-click the cells in the table break.
The contextual menu appears.

2. Click Break > Properties
The Break Properties dialog box appears.
Each break on the selected table is listed in the pane on the left.

3. Select the break you want to move, and then click either the Move break up or the 
Move break down arrow.

4. Click OK.
Web Intelligence reorders the breaks on the table, as you specified.

Setting display properties and page layout for breaks
When you first insert a break on a table, certain display options are applied by default. 
You can edit these default settings and apply options for the following:

• Display properties – how the results display on the break
• Page layout properties – how the breaks display on the report page

The breaks 
are listed here



Organizing results on tables using breaks and sorts174

Break display properties
You can set the following display properties for a break:

Format option When selected...

Break header A header is displayed for each group of results or 
break on the table. For example, this table has a 
break on “Year,” so each value for year has a 
separate break header:

Break footer A footer is added below each group of results or 
break on the table. When you apply a calculation 
to the results, the result is shown in the footer. For 
example, this table has a break on “Year,” so each 
value for year has a separate break footer:

Remove 
duplicates

Removes all duplicate values from the data in a 
table when you insert a break. Each value is only 
shown once.

Center value 
across break

Active when Remove Duplicates is selected. It 
merges empty cells and centers the values for the 
dimension or detail in each break on the table.

Apply sorts Applies an ascending sort to the values in the break.

the break 
header for 

the break 
footer for 
year 2002 
includes the 
Sum for 

The year 
value on the 
break is 
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Break page layout properties
You can set the following page layout properties for breaks:

To set properties for a break

1. With a Web Intelligence document open, right-click the cells in the table break.
The contextual menu appears.

2. Click Break > Properties
The Break Properties dialog box appears.

3. In the Break Display Properties section, select the appropriate break display 
properties.
See ”Break display properties” on page 174.

4. In the Page Layout section, select the appropriate page layout properties.
See ”Break page layout properties” on page 175.

5. Click OK.
Web Intelligence applies the properties to the break, as you specified.

Page layout property Description

Start on a new page Displays each part of the table crosstab, or 
form created by a break on a new page.

Avoid page breaks in 
blocks

Where possible, keeps each break section on 
the same page. This option is not taken into 
account when a block is larger than one 
page.

Repeat header on 
every page

Repeats the header at the top of the table on 
every new page when a table goes over onto 
a new page.

Repeat break value on 
new page

Repeats the current value on each new page.
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15
Filtering results on reports

Overview
This chapter describes how you can limit the data displayed in your Web Intelligence 
reports by using report filters after the report data has been retrieved from the data source.

This chapter explains:

• how report filters work
• how to add and remove filters
• how to combine and nest filters
• how to view, edit, and delete filters

How report filters work
You can filter the data displayed in Web Intelligence reports to focus on the information 
that interests you for a specific business purpose. 

What makes up a report filter?
Web Intelligence supports two types of filters:

• query filters - these filters are defined on the query; they limit the data retrieved from the 
data source and returned to the Web Intelligence document

• report filters - these filters limit the values displayed on reports, tables, charts sections 
within the document, but they don’t modify the data that is retrieved from the data 
source; they simply hide values at the report level

This chapter is concerned with report filters.

What types of report filter can you create?
You can create three type of report filter:

• quick filter - allows you to filter the data in one dimension or measure
• combined filter - allows you to filter the data in multiple dimensions and measures and 

allows filters to be combined
• nested filters - allows you to set up an order of precedence between simple and 

combined filters

Values used with filter operators
The number of values that you can use in the filter depends on the operator. For example, 
you can specify many values when you use the In List operator, you can specify one value 
only when you use the Equal To operator, and you do not specify a value when you use 
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the Is Null operator. The appearance of the Quick Filter dialog box changes slightly 
depending on the operator you select to accommodate the number of values used with the 
operator.

The following table lists the values used with filter operators:

Operators available in report filters
The following table lists the operators that you can use in report filters:

Operator Number of values

Equal to One value

Not equal to

Greater than

Greater than or equal to

Less than

Less than or equal to

Between Two values

Not between

In list A list of values

Not in list

Is Null No value

To obtain 
data...

for example... select... to create the 
filter...

equal to a value 
you specify,

retrieve data for 
the US only,

Equal to [Country] Equal to 
US.

not equal to a 
value you 
specify

retrieve data for 
all countries 
except US

Not equal to [Country\ Not 
equal to US

greater than a 
value you 
specify,

retrieve data for 
customers aged 
over 60,

Greater than [Customer Age] 
Greater than 60
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greater than or 
equal to a value 
you specify,

retrieve data for 
revenue starting 
from $1.5M 
upward,

Greater than 
or equal to

[Revenue] Greater 
than or equal to 
1000500

lower than a 
value you 
specify,

retrieve data for 
exam grades 
below 40,

Less than [Exam Grade] Less 
than 40

lower than or 
equal to a value 
you specify,

customers 
whose age is 
30 or less,

Less than or 
equal to

[Age] Less than or 
equal to 30

between two 
values you 
specify that 
includes those 
two values,

weeks starting 
at week 25 and 
finishing at 36 
(including week 
25 and week 
36),

Between [Weeks] Between 
25 and 36

outside the 
range of two 
values you 
specify,

all the weeks of 
the year, except 
for weeks 25 
through 36 
(week 25 and 
week 36 are 
not included),

Not between [Weeks] Not 
Between 25 and 
36

the same as 
several values 
you specify,

you only want 
to retrieve data 
for the following 
countries: the 
US, Japan, and 
the UK,

In list [Country] In list ‘US; 
Japan; UK’

different from 
the multiple 
values you 
specify,

you don’t want 
to retrieve data 
for the following 
countries: the 
US, Japan, and 
the UK,

Not in list [Country] Not in list 
‘US; Japan; UK’

To obtain 
data...

for example... select... to create the 
filter...
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Adding and removing report filters
You can add quick filters to dimensions, details, or measures

To define a quick report filter

1. Select the dimension, detail or measure in the table.

for which there 
is no value 
entered on the 
database,

customers 
without children 
(the children 
column on the 
database has 
Null as the data 
entry),

Is null [Children] Is null

for which a 
value was 
entered on the 
database,

customers with 
children (the 
children column 
on the database 
does not have 
Null as the data 
entry),

Is not Null [Children] Is not 
Null

that doesn’t 
include a 
specific string,

customers 
whose date of 
birth is not 
1972,

Different 
from pattern

[DOB] Different 
from pattern, ‘72’

that 
corresponds to 
two values you 
specify,

telco customers 
who have both 
a fixed 
telephone and 
a mobile 
phone,

Both [Account Type] 
Both “fixed” and 
“mobile”

that 
corresponds to 
one value you 
specify and 
does not 
correspond to 
another value 
you specify

telco customers 
who have a 
fixed telephone, 
but don’t have 
a mobile 
phone,

Except [Account Type] 
“fixed” Except 
“mobile”

To obtain 
data...

for example... select... to create the 
filter...
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2. Click the Filter button on the Report toolbar or right-click and click Quick Filter on the 
menu. (To display the Report toolbar, click View on the menu, then click Toolbars > 
Report.)
The Quick Filter dialog box appears.

3. Select the operator you wish to use in the filter from the drop-down list. For a list of all 
supported operators, see ”Operators available in report filters” on page 178.

4. Select the values that you wish to use in the filter and click >> to add them to the list of 
filter values. (The number of values that you can add depends on the operator you 
chose. For more details, see ”Values used with filter operators” on page 177.)

5. To remove a value from the filter, select the value in the list of filter values, then click 
<<.

6. Click OK to close the dialog box and apply the report filter.

Combining and nesting filters
Typical business questions require you to retrieve information that matches more than one 
criterion. For example, if you are analyzing customer services data, you will most likely 
want to focus on customers for a specific time period and also for a specific region, and 
probably also for a specific level of customer service contract. With Web Intelligence, you 
retrieve data that answers several criteria like this by combining filters in the same query.

Combining filters
You combine filters by including more than one restriction on dimensions, details or 
measures. For example, the filter Country = ‘US’ AND Resort = ‘Bahamas Beach’ 
combines two filters. In this case Web Intelligence displays only those rows that satisfy 
both criteria.

The AND and OR operators 
The two operators you use to combine and nest filters are the AND operator and the OR 
operator. When you use AND to combine filters, Web Intelligence displays only the data 
that matches the criteria in both the filters linked by the operator. When you use OR, Web 

The list of all values associated 
with the dimension

The list of values used 
in the filter

Filter operators
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Intelligence returns the data that matches the criteria in either one of the filters linked by the 
operator. 

You can mix the AND and OR operators when combining and nesting filters. For example, 
you can link three filters in the relationship (Filter1 OR Filter2) AND Filter3. In this case, 
Web Intelligence first restricts the data by the conditions in either Filter1 or Filter2. Web 
Intelligence then compares this data with the condition in Filter3 and returns only the data 
that corresponds to this condition.

To define a combined filter

1. Display the Document Structure and Filters overview by selecting Left panel from 
the View menu then selecting Document Structure and Filters from the drop down 
list at the top of the Left panel.

2. Select the table that you want to filter in the Document Structure and Filters 
overview.

3. Click Add Filter.
The Filter Editor appears.

Select the operator 
associated with the 
dimension here

Type the value(s) on 
which you wish to 
filter or click Values 
to select them from 
a list of values
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4. Select the dimension, detail or measure that you want to include in the filter, then click 
>> or drag the filter to the Filter pane to add it to the filter.

5. To remove a dimension, detail or measure from the filter, select it in the Filter pane, 
then click << or drag the dimension, detail or measure back to the Available Objects 
pane.

6. Select the dimension, detail or measure in the Filter pane.
7. Select the operator that you want to use with the dimension, detail or measure from the 

drop down list of operators.
8. Type the value or values that you want to associate with the operator or click Values to 

display the Quick Filter dialog box that you use to select the values by which to filter.
For more details on quick filters, see ”To define a quick report filter” on page 180.
The number of values that you associate with the operator depends on the operator. 
For more details, see ”Values used with filter operators” on page 177.

9. Click Update Filter.
The filter on the dimension, detail or measure is updated in the Filter pane. For 
example, if you filtered the Country dimension to return only those rows where the 
country is ‘US’, the text reads ‘Country Equal To US’.

10.Repeat from step 4 for all dimensions, details and measures that you want to include in 
the filter.
When you add multiple dimensions, details or measures, Web Intelligence links them 
by default with the AND operator. To toggle between AND and OR, double click the 
operator. 
For more information on the AND and OR operators, see ”The AND and OR 
operators” on page 181

Nesting filters
When you nest filters you set up an order of precedence between them. Web Intelligence 
executes the first filter in the order or precedence, then applies subsequent filters. (Country 
= ‘US’ AND Resort = ‘Bahamas Beach’) OR (Revenue > 500000) is an example of 
combined and nested filters. Web Intelligence filters according to the nested filter Country 
= US AND Resort = Bahamas Beach (which is also an example of a combined filter) then 
applies this filter along with the combined filter Revenue > 500000.

To nest report filters

1. Create the initial filter.
2. Select the dimension in the initial filter. (Select any of the dimensions or operators in the 

initial filter if it is a combined filter.)
3. Click Add Nested Filter.

Web Intelligence adds a nested OR operator to the initial filter.
4. Select the OR operator.
5. Double click the OR operator to change it to AND if you want your nested filter to be 

linked to the initial filter by an AND operator.
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6. Select the dimension(s) that you want to appear in the nested filter and click >>, or 
drag them to the right of the operator that links the nested filter to the initial filter.
The image below shows a nested filter in the Edit Filter dialog box.

To change the order of nested filters

1. Select a dimension, detail or measure in the filter.
2. Click Move up or Move down to change the place of the dimension, detail or 

measure.

What happens to the dimension, detail or measure depends on its position in the filter. 
In the above example:
• if the Revenue Greater Than filter is moved up, it becomes part of the outer filter and 

the nested filter becomes blank;
• if the Resort Equal To filter is moved up, it moves above the Country Equal To filter 

in the combined filter.

Viewing, editing and deleting report filters
Viewing the filters applied to reports helps understand the context of the results displayed 
on the tables, charts, and sections. You can edit or delete filters from reports at any time.

Insert nested filterNested filter

Move up

Move 
down
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To view the filters applied to reports

1. Display the Document Structure and Filters by selecting Left panel from the View 
menu then selecting Document Structure and Filters from the drop down list at the 
top of the Left panel.
The Document Structure and Filters displays the overview of the filters in the report.

To edit a report filter

1. Select the table on which the filter is applied in the Left panel and click Edit Filter.
The Edit Filter dialog box appears.

2. Follow the steps in ”To define a combined filter” on page 182 to change the filter 
definition.

To edit one dimension in a report filter

1. Display the Document Structure and Filters by selecting Left panel from the View 
menu then selecting Document Structure and Filters from the drop down list at the 
top of the Left panel.

2. Select the filtered dimension in Document Structure and Filters.

3. Click Edit.
The Filter Editor appears.
Edit the filter on the dimension by following the steps described in ”To define a quick 
report filter” on page 180.

To remove a report filter

1. Display the Document Structure and Filters overview by selecting Left panel from 
the View menu then selecting Document Structure and Filters from the drop down 
list at the top of the Left panel.
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2. Select the filter you want to remove.

3. Click Remove.
You can also remove individual parts of the filter by selecting the dimension, detail or 
measure individually then clicking Remove.
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16
Inserting standard calculations

Overview
You can insert predefined calculations into Web Intelligence reports. These predefined 
calculations allow you to perform standard business calculations on your data.

This chapter tells you:

• what predefined calculations you can add to reports
• how to insert and remove calculations

Available predefined calculations
Web Intelligence allows you to add the following predefined calculations:

Calculation Description

Sum Calculates the sum of the numbers in 
the column.

Count Counts the number of rows. (All rows 
in the case of measure objects, 
distinct rows in the case of dimension 
or detail objects.)

Average Calculates the average of the 
numbers in the column.

Min Returns the smallest number in the 
column.

Max Returns the largest number in the 
column.

Percentage Displays each row’s data as a 
percentage of the total. Web 
Intelligence adds an additional row 
to the table to hold the percentages.
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Inserting and removing calculations
You can insert predefined calculations into Web Intelligence reports. These predefined 
calculations allow you to perform standard business calculations on your data. For a list of 
available predefined calculations, see ”Available predefined calculations” on page 187.

You add calculations from the toolbar or from the right-click menu.

To insert a calculation from the toolbar

1. Select the column to which you wish to add the calculation.
2. Display the Report toolbar by selecting View from the menu, then selecting Toolbars, 

then selecting Report.
3. Click the Calculations button on the toolbar to insert the default calculation (SUM).

Or
Click the arrow at the right of the calculation button, and then select the calculation you 
want from the list of predefined calculations.
Web Intelligence adds a footer to the column and places the calculation formula and 
result in it. (In the case of the PERCENTAGE calculation Web Intelligence adds an 
additional column to the table to hold the results of the calculation.)

To insert a calculation from the menu

1. Select a cell in the column to which you want to add a calculation.
2. Right-click, select Calculation then select the calculation from the sub menu.

The calculations that you have already added are marked in the menu. To remove a 
calculation that you added previously, select it again from the menu. 
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17
Creating Custom Calculations

Overview
Custom calculations allow you to add additional calculations to your report beyond its 
base objects and the standard calculations provided by Web Intelligence.

You add a custom calculation by writing a formula that Web Intelligence evaluates when 
you run the report. A formula can consist of base report variables, functions, operators and 
calculation contexts.

This chapter describes:

• creating formulas
• functions
• operators
• defining calculation contexts in formulas
• examples of useful formulas
Example:  Showing average revenue per sale

If you have a report with Sales Revenue and Number Sold objects and you want to add 
revenue per sale to the report. The calculation 

[Sales Revenue]/[Number Sold] 

gives this value by dividing the revenue by the number of items sold in order to give the 
revenue per item.

A custom calculation is a formula that can consist of report objects, functions and 
operators. Formulas have a calculation context that you can specify explicitly if you 
choose.

For information on formulas, see ”Creating formulas” on page 193. For information an 
operators, see ”Examples of useful formulas” on page 218. For information on calculation 
contexts, see ”Defining the calculation context” on page 198.

Creating formulas
This section describes the ways in which you can create formulas in your reports. You can 
add formulas in two ways:

• by typing the formula components into the Formula toolbar
• by using the Formula Editor to build the formula
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The first way is more suitable for experienced users. If you are not familiar with formulas, 
you should use the Formula Editor to build them. The Formula Editor is an interface that 
allows you to select the different components of your formula (that is, operators, objects, 
and functions) and add them to it.

Using the Formula toolbar
You display the Formula toolbar by clicking View > Toolbars > Formula on the main 
menu. Now, when you select a cell, its formula appears in the Formula toolbar:

The Formula toolbar has the following buttons (from left to right):

Typing a formula into the Formula toolbar
Example:  Calculating the average number of items sold

You have a report showing Year, Quarter, Sales Revenue and Quantity Sold and you want 
to add an additional column that shows the average revenue generated per item sold. The 
formula that gives this is:

=[Sales Revenue]/[Quantity Sold]

Entering a formula by typing

To enter a formula by typing:

1. Add an additional column to the right of the Quantity Sold column by selecting this 
column on the table, and then Insert > New Column > Right on the Report toolbar. 

Button Description

Create a variable/

Edit a variable

Create New Variable/Edit variable dialog box.

• If the selected cell does not contain a variable 
or if there is no cell selected, the Create a 
variable button is displayed (shown in the 
toolbar on the left).

• If the selected cell contains a 
previously-created variable, the Edit variable 
button is displayed (shown in the toolbar on 
the right).

Formula Editor Opens the Formula Editor

Validate formula Verifies the formula syntax

Cancel formula Clears the formula



Performing On-Report Analysis with Web Intelligence 195

NOTE: To display the Report toolbar, click View > Toolbars > Report on the 
Main toolbar.

2. Display the Formula toolbar by clicking View > Toolbars > Formula on the Main 
toolbar.

3. In the Formula toolbar, type the formula, then click Enter.
For example, to calculate the average revenue generated per item sold, type:
=[Sales Revenue]/[Quantity Sold] 

NOTE: Formulas always begin with ‘=’ and report objects always appear inside 
square brackets in Web Intelligence formulas. 

Using the Formula Editor
You can use the Formula Editor to enter formulas in the Formula toolbar. The Formula 
Editor is a graphical interface that you use to build formulas. It contains all report objects, 
functions and operators that you can use in a formula. 

Displaying the Formula Editor

To display the Formula Editor:

• Click the Formula Editor button on the Formula toolbar.
The Formula Editor appears:

The Formula Editor shows the report objects, functions and operators that you can use 
to build a formula.

Building a formula using the Formula Editor

To build a formula, using the Formula Editor:
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1. Select the cell on the report where you want to include the formula.
You can select a table cell or a free-standing cell.

2. Display the Formula toolbar by clicking View > Toolbars > Formula on the Main 
menu 

3. Click the Formula Editor button on the Formula toolbar.
4. Build the formula by double-clicking objects, functions and operators to add them to the 

Formula box.

NOTE: When you add a function by double clicking, Web Intelligence places the 
cursor between the function parentheses to make it easier for you to continue 
building your formula. For example, to create the formula Average([Revenue]), 
double-click the Average function, then double-click the Revenue object.

Including text in cells
The text in report cells always begins with ‘=’ . Literal text appears in quotation marks, 
while formulas appear without quotation marks. For example, the formula 
Average([Revenue]) appears in a cell as:

=Average([Revenue])

The text “Average Revenue” appears as:

=”Average Revenue” 

You can use text alone in a cell, or mix formulas and text by using the ‘+’ operator. If you 
want a cell to display the average revenue preceded by the text “Average Revenue”, the 
cell text is as follows:

=”Average Revenue: ” + Average([Revenue])

Note the space at the end of the text string so that the text and the value are not placed 
directly side-by-side in the cell.

Saving formulas as variables
You can save a formula as a variable in order to re-use it throughout a report. For 
information on how to do this, see ”Saving formulas as variables” on page 221.

About functions
A custom calculation might consist of report objects only, for example

[Sales Revenue]/[Number of Sales]

However, calculations often include functions as well. A function is an operation that 
receives zero or more values as input and returns output based on those values. For 
example, the Sum function totals all the values in a measure and outputs the result. The 
formula Sum([Sales Revenue]) outputs a total of sales revenues. In this case, the function input 
is the Sales Revenue measure and the output is the total of all Sales Measures.
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To find out more about Web Intelligence functions, see ”What is a function?” on 
page 229.

About operators
Operators link the various components in a formula. Formulas can contain five kinds of 
operators:

• Mathematical
• Conditional 
• Logical
• Context
• Function-specific

You can see all the operators supported by Web Intelligence by clicking on the Operators 
tab in the Formula Editor.

The following sections describe each type of operator.

Mathematical operators
Mathematical operators are familiar from everyday arithmetic. There are addition (+), 
subtraction (-), multiplication (*), division (/) operators that allow you to perform 
mathematical operations in a formula. The formula:

[Sales Revenue] - [Cost of Sales]

contains a mathematical operator, in this case subtraction.

When used with character strings, the ‘+’ operator becomes a string concatenation 
operator. That is, it joins character strings. For example, the formula “John” + “ Smith” returns 
‘John Smith’.

Conditional operators
Conditional operators determine the type of comparison to be made between values. The 
following table describes them:

Operator Description

= Equal to

> Greater than

< Less than

>= Greater than or equal to

<= Less than or equal to

!= Not equal to
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You use conditional operators in conjunction with If, as in:

If ([Revenue] >= 10000;‘High’;‘Low’)

which returns “High” for all rows where the revenue is greater than or equal to 10000 and 
“Low” for all other rows.

Logical operators
Logical operators are used in expressions that return True or False. You use such 
expressions in the If function. The Web Intelligence logical operators are AND, OR, NOT, 
Between and InList. For example, the expression:

If ([Resort] = ‘Bahamas Beach’ OR [Resort]=’Hawaiian Club’; ‘US’; ‘France’)

returns “US” if the resort is “Bahamas Beach or “Hawiian Club”, “France” otherwise.

The expression:

[Resort] = ‘Bahamas Beach’ OR [Resort]=’Hawaiian Club’

returns True or False, True if the Resort variable is equal to ‘Bahamas Beach’ or ‘Hawaiian 
Club’, False otherwise.

Context operators
Context operators form part of extended calculation syntax. Extended syntax allows you to 
define which dimensions a measure or formula takes into account in a calculation. It is 
described in detail in the section ”Defining the calculation context” on page 198.

Function-specific operators
Some Web Intelligence functions can take specific operators as arguments. For example, 
the Previous() function can take the SELF operator. 

Defining the calculation context
Before you can define a specific calculation context, you need to understand how 
calculation contexts work.

What are calculation contexts?
Calculation contexts give you more control over how a formula or measure is evaluated. 
To understand them, you need to be familiar with basic report concepts. A report contains 
two kinds of objects: dimensions, which are types of data about your business that can 
have measures associated with them (for example: products, years, states) and the 
measures that you can calculate in relation to dimensions (for example: sales revenue, 
number of sales). For example, a report could show sales revenue (measure) by year 
(dimension).

The important thing to remember about measures is that they are semantically dynamic. 
This means that the figures returned by a measure depend on the dimensions with which it 
is associated; in other words, on the context in which it is placed. Web Intelligence places 
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measures in default contexts depending on where they appear in a report. However, you 
can change these default contexts. This is what is meant by defining the calculation 
context.

You can see default contexts by creating a block containing Year and Sales Revenue 
objects. In this case the Sales Revenue object returns the revenue by year, because 
revenue is evaluated in the context of the Year dimension. If you then add the Quarter 
dimension to the block, the figures in the Sales Revenue column change because the 
default context is now year and quarter.

From this you can see that when you place a measure or formula in a block, the default 
calculation context that Web Intelligence applies includes all the dimensions in the block.

Default calculation contexts
Depending on where you place a measure or formula, Web Intelligence selects a default 
context. All the following examples use the Sum() function to illustrate default contexts.

Note:  For more information on the terms input context and output context used in this 
section, see ”Modifying the default calculation context using extended syntax” on 
page 203

Default contexts in a vertical table
A vertical table is a standard report table with headers at the top, data going from top to 
bottom and footers at the bottom. The default contexts in a down table are:

When the calculation is 
in the...

The input context is The output context is

Header The dimensions and 
measures used to 
generate the body of 
the block

All the data is 
aggregated then the 
calculation function 
returns a single value
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Example:  Default contexts in a vertical table

The following table shows the default contexts in a vertical table:

Default context in a horizontal table
A horizontal table is like a vertical table turned on its side. Headers appear at the left, 
data goes left to right and footers appear at the right. The default contexts for a horizontal 
table are the same as those for a vertical table.

Default contexts in a crosstab
A crosstab displays data in a matrix with measures appearing at the intersections of 
dimensions. The default contexts in a crosstab are:

Body of the block The dimensions and 
measures used to 
generate the current 
row

The same as the input 
context

Footer The dimensions and 
measures used to 
generate the body of 
the block

All the data is 
aggregated then the 
calculation function 
returns a single value

When the calculation is 
in the...

The input context is The output context is

Input context 
(Year, Quarter)
Values aggregated 
to single output

Input and output 
context (Year, 
Quarter)

The calculation is in 
the...

The input context is... The output context is...

Header The dimensions and 
measures used to 
generate the body of 
the block.

All the data is 
aggregated, then the 
calculation function 
returns a single value.
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Example:  Default contexts in a crosstab

The report below shows the default contexts in a crosstab:

Body of the block The dimensions and 
measures used to 
generate the body of 
the block.

The same as the input 
context.

Footer The dimensions and 
measures used to 
generate the body of 
the block.

All the data is 
aggregated, then the 
calculation function 
returns a single value.

VBody footer The dimensions and 
measures used to 
generate the current 
column.

All the data is 
aggregated, then the 
calculation function 
returns a single value.

HBody Footer The dimensions and 
measures used to 
generate the current 
row.

All the data is 
aggregated, then the 
calculation function 
returns a single value.

VFooter Same as footer. All the data is 
aggregated, then the 
calculation function 
returns a single value.

HFooter Same as footer. All the data is 
aggregated, then the 
calculation function 
returns a single value.

The calculation is in 
the...

The input context is... The output context is...
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Default contexts in a section
A section consists of a header, body and footer. The default contexts in a section are:

Example:  Default contexts in a section

The calculation is in the... The input context is... The output context 
is...

Body The dimensions and 
measures in the 
report, filtered to 
restrict the data to the 
section data.

All the data is 
aggregated, then the 
calculation function 
returns a single value.

Input context (Year, 
Quarter); data 
aggregated
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Default contexts in a break
A break consists of a header, body and footer. The default contexts in a break are:

Example:  Default contexts in a break

Modifying the default calculation context using extended syntax
What if the default context of a formula or measure is not the context that you need? In this 
case, you can use extended syntax to tailor the context to the context you are looking for.

What is extended syntax?
Extended syntax uses context operators that you add to a formula or measure to specify its 
context. A measure or formula’s context consists of its input context and output context.

What is an input context?
A formula’s input context consists of the dimensions that feed into the formula.

The calculation is in 
the...

The input context is... The output context is...

Header Current instance of 
the break.

All the data is 
aggregated, then the 
calculation function 
returns a single value.

Footer Current instance of 
the break.

All the data is 
aggregated, then the 
calculation function 
returns a single value.

Input context (Year, 
Quarter); data aggregated
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Specifying dimensions in input and output contexts
Input and output contexts consist of lists of dimensions. These lists must always be enclosed 
in parentheses, even if the list contains only one dimension. For example, a context must 
be specified as ([Year];Quarter]) or ([Year]).

Example:  Specifying an input context

In the examples given in ”What are calculation contexts?” on page 198, the input contexts 
consist of (Year) and (Year, Quarter) respectively. That is, in the first example, Web 
Intelligence calculates revenue by year. In the second example it calculates revenue by 
year by quarter. When specified explicitly in a formula, the input context looks like this:

Sum ([Sales revenue] In ([Year];[Quarter]))

That is, the dimensions in the input context appear inside the parentheses of the function (in 
this case, Sum) whose input context you are specifying.

For an explanation of the In operator that appears in this formula, see ”The In context 
operator” on page 208

What is an output context?
A formula’s output context causes the formula to output a value is if it were placed in the 
footer of a block containing a break. Think of an output context as a “break” in a formula.

Example:  Specifying an output context

Look at the following report, which shows revenue by year and quarter, with a break on 
year, and the minimum revenue calculated by year.
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What if you want to show the minimum revenue by year in a block with no break? You can 
do this by specifying the output context in a formula. In this case, the formula looks like 
this:

Min ([Revenue]) In ([Year])

That is, the output context appears after the parentheses of the function whose output 
context you are specifying. In this case, the output context tells Web Intelligence to 
calculate minimum revenue by year.

If you add an additional column containing this formula to the block, the result is as 
follows:

You can see that the Min By Year column contains the minimum revenues that appear in 
the break footers in the previous report.

Notice that in this example, the input context is not specified because it is the default 
context (Year, Quarter) for the block. In other words, the output context tells Web 
Intelligence which revenue by year and quarter to output. In full, with both input and output 
formulas explicitly specified, the formula looks like this:

Min ([Sales Revenue] In([Year];[Quarter])) In ([Year])

Explained in words, this formula tells Web Intelligence to “calculate revenues by year by 
quarter, then output the smallest of these revenues that occurs in each year”.

What would happen if you did not specify the output context in the Min by Year column? 
In this case, these figures would be identical to the figures in the Sales Revenue column. 
Why? Remember that the default context in a block includes the dimensions in that block. 
The minimum revenue by year by quarter is the same as the revenue by year by quarter 
simply, because there is only one revenue for each year/quarter combination.

Specifying input and output contexts
You can specify both input and output contexts in the same formula.

Example:  Specifying input and output contexts in the same formula
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Look at the following table:

Notice that the figures in the Min by Year column are the same as those in the block 
footers in the example ”Specifying an output context” on page 204, even though this 
block contains an additional dimension, Month. This is because the formula for Min by 
Year explicitly excludes Month from the input context. The formula looks like this:

Min ([Sales Revenue] In ([Year];[Quarter])) In ([Year])

This formula tells Web Intelligence to ignore month and calculate revenues by year and 
quarter (the input context), then output the smallest of these revenues for each year (the 
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output context). If you had not explicitly specified the input context, the table would look 
like this:

In this case, the input context is now (Year, Quarter, Month), so Web Intelligence 
calculates revenues by year, quarter and month before outputting the smallest revenue that 
occurs in the Sales Revenue column for each year. For example, 173,756.40 is the 
smallest value that appears in the Sales Revenue column in 2001, so this value appears 
in the Min by Year column in all rows where the year is 2001.

What would happen if you changed output context of the formula to (Year, Quarter)? The 
formula now calculates revenues by year, quarter and month (the input context), but the 
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formula’s “break” occurs at each year/quarter change, rather than each year change. As 
a result, the block is as follows:

In words, this formula tells Web Intelligence to calculate revenues by year, quarter and 
month, then output the smallest of these revenues that occurs in each year/quarter 
combination”.

Extended syntax context operators
In the examples so far, you specified input and output contexts by using the word In, then 
listing the dimensions to be included in the context. In is known as a context operator. The 
other context operators are ForEach and ForAll. The following table describes the 
context operators:

The In context operator

The In context operator specified dimensions explicitly in a context.

Example:  Using In to specify the dimensions in a context

Operator Definition

In Used to specify dimensions explicitly. Also used with 
extended syntax keywords (see ”Extended syntax 
keywords” on page 211)

ForEach Adds dimensions to the context

ForAll Removes dimensions from the context



Performing On-Report Analysis with Web Intelligence 209

In this example you have a report showing Year and Sales Revenue. Your data provider 
also contains the Quarter object but you do not include this dimension in the block. 
Instead, you want to include an additional column to show the maximum revenue by 
quarter in each year. Your report looks like this:

You can see where the values in the Max Quarterly Revenue column come from by 
examining this block alongside a block that includes the Quarter dimension:

The Max Quarterly Revenue column shows the highest quarterly revenue in each year. For 
example, Q4 has the highest revenue in 2002, so the Max Quarterly Revenue shows 
Q4 revenue on the row showing 2002.

Using the In operator, the formula for Max Quarterly Revenue is 

Max ([Sales Revenue] In ([Year];[Quarter])) In ([Year]).

This formula tells Web Intelligence to calculate the maximum sales revenue for each 
(Year,Quarter) combination, then output this figure by year.

Note:  Because the default output context of the block is Year, you do not need to specify 
the output context explicitly in this formula.
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The ForEach context operator

The ForEach operator adds dimensions to a context.

Example:  Using ForEach to add dimensions to a context

In the example ”Using In to specify the dimensions in a context” on page 208 you used the 
formula: 

Max ([Sales Revenue] In ([Year];[Quarter])) In ([Year])

to calculate the maximum revenue by year and quarter in the table, below, which does not 
show the Quarter dimension:

Using the ForEach context operator, you can achieve the same result with the formula:

Max ([Sales Revenue] ForEach ([Quarter])) In ([Year])

Why? Because the Year dimension is the default input context in the block (see ”Default 
calculation contexts” on page 199 for more information on default contexts). By using the 
ForEach operator, you add the Quarter dimension to the context, giving an input context 
of ([Year];[Quarter]).

The ForAll context operator

The ForAll context operator removes dimensions from a context.

Example:  Using ForAll to remove dimensions from a context

You have a report showing Year, Quarter and Sales Revenue and you want to add a 
column that shows the total revenue in each year, as shown in the following block:

To total revenues by year the input context needs to be (Year); by default it is
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(Year; Quarter). Therefore, you can remove Quarter from the input context by specifying 
ForAll ([Quarter]) in the formula, which looks like this:

Sum([Sales Revenue] ForAll ([Quarter]))

Note that you can use the In operator to achieve the same thing; in this case the formula 
is:

Sum([Sales Revenue] In ([Year]))

This version of the formula explicitly specifies Year as the context, rather than removing 
Quarter to leave Year. 

The ForAll and ForEach operators are useful when you have a default context with many 
dimensions. It is often easier to “add” or “subtract” from the context using ForAll and 
ForEach than it is to specify the list explicitly using In.

Extended syntax keywords
Extended syntax keywords are a form of “shorthand” that allows you to refer to dimensions 
in extended syntax without specifying those dimensions explicitly. This helps future-proof 
reports; if formulas do not contain hard-coded references to dimensions, they will continue 
to work even if dimensions are added to or removed from a report. 

There are five extended syntax keywords: Report, Section, Break, Block and Body.

The following sections describe each keyword, with an example to illustrate each. The 
section ”Using keywords to make reports generic” on page 216 illustrates the way in 
which the use of keywords makes reports generic.

The Report keyword
The following table describes the data referenced by the Report keyword depending on 
where it is placed in a report:

Example:  The Report keyword

When placed in... References this data...

A block All data in the report

A block break (header or footer) All data in the report

A section (header, footer, or outside a 
block)

All data in the report

Outside any blocks or sections in the report All data in the report
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You have a report showing Year, Quarter and Sales revenue. The report has a column, 
Report Total, that shows the total of all revenue in the report.

The formula for the Report Total column is Sum([Sales revenue]) In Report. Without the Report 
keyword, this column would duplicate the figures in the Sales Revenue column because it 
would use the default output context ([Year];[Quarter]). For more information on default 
contexts, see ”Default calculation contexts” on page 199.

The Section keyword
The following table describes the data referenced by the Section keyword depending on 
where it is placed in a report

Example:  The Section keyword

You have a report showing Year, Quarter, and Sales revenue. The report has a section 
based on Year. The Section Total column has the formula:

When placed in... References this data...

A block All data in the section

A block break (header 
or footer)

All data in the section

A section All data in the section

Outside any blocks or 
sections

Not applicable
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Sum ([Sales Revenue]) In Section

The figure in the Section Total column is the total revenue for 2001, because the section 
break occurs on the Year object. Without the Section keyword this column would 
duplicate the figures in the Sales revenue column, because it would use the default output 
context ([Year];[Quarter]).

For more information on default contexts, see ”Default calculation contexts” on page 199.

The Break keyword
The following table describes the dimensions referenced by the Break keyword depending 
on where it is placed in a report:

Example:  The Break keyword

You have a report showing Year, Quarter and Sales revenue. The report has break on 
Year. The Break Total column has the formula:

Sum ([Sales Revenue]) In Break

When placed in... References this data...

A block Data in the part of a block delimited by a break.

A block break (header 
or footer)

Data in the part of a block delimited by a break.

A section (header, 
footer, or outside a 
block)

Not applicable.

Outside any blocks or 
sections in the report

Not applicable.
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Without the Break keyword this column would duplicate the figures in the Sales revenue 
column, because it would use the default output context ([Year];[Quarter]).

For more information on default contexts, see ”Default calculation contexts” on page 199.

The Block keyword
The following table describes the dimensions referenced by the Block keyword depending 
on where it is placed in a report: The Block keyword often encompasses the same data as 
the Section keyword. One difference is that Block accounts for filters on a block whereas 

Section ignores them. 

Example:  The Block keyword

You have a report showing Year, Quarter and Sales revenue. The report has a section 
based on Year. The block is filtered to exclude the third and fourth quarters. The Yearly 
Average column has the formula:

Average([Sales revenue] In Section)

When placed in... References this data...

A block Data in the whole block, 
ignoring breaks, respecting 
filters

A block break (header or footer) Data in the whole block, 
ignoring breaks, respecting 
filters

A section (header, footer, or outside 
a block)

Not applicable

Outside any blocks or sections Not applicable
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and the First Half Average column has the formula Average ([Sales revenue]) In Block. You 
can see how the Block keyword takes account of the filter on the block.

The Body keyword
The following table describes the dimensions referenced by the Body keyword depending 
on where it is placed in a report:

Example:  The Body keyword

When placed in... References this data...

A block Data in the block

A block break (header 
or footer)

Data in the block

A section (header, 
footer, or outside a 
block)

Data in the section

Outside any blocks or 
sections

Data in the report
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You have a report showing Year, Quarter and Sales revenue, with a break on Year. 
The report has a section based on Year and a break on Quarter. The Body column has 
the formula Sum ([Sales Revenue]) In Body.

The totals in the Body column are the same as those in the Sales revenue column 
because the Body keyword refers to the data in the block. If you were to remove the 
Month object, the figures in the Block column would change to correspond with the 
changed figures in the Sales revenue column. If you were to place the formula in the 
report footer it would return the total revenue for the block.

Using keywords to make reports generic
Extended keywords future-proof your report against changes. If you refer to data explicitly 
(by specifying dimensions using In, ForEach or ForAll) your reports might return 
unexpected data if dimensions are added or removed. The following example illustrates 
this.

Example:  Using the Report keyword to display percentages

In this example you have a block that contains Year, Quarter and Sales revenue objects. 
You want to display revenues by year and quarter, and the percentage of the total revenue 
in the report that each individual revenue represents, as shown:

The formula for the Percentage of Total column is:

([Sales revenue]/(Sum([Sales revenue]) In Report)) * 100

Remember that, in a block, the Report includes all data in a report, so this formula could 
be written: 

([Sales revenue]/Sum([Sales revenue] ForAll ([Year];[Quarter]))) * 100
Sum([Sales revenue]) ForAll ([Year],[Quarter])

The Body keyword 
gives a different result 
depending on where it 
is placed
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tells Web Intelligence to remove Year and Quarter from the output context; in other 
words, to calculate a grand total, because there are no other dimensions in the report. 
(See ”The ForAll context operator” on page 210 for an explanation of ForAll.) The formula 
then divides each revenue by the grand total to give its percentage of the total.

Although you can use ForAll in this situation, it is much better to use the Report keyword. 
Why? What if the Month dimension were subsequently added to the report? The version 
of the formula that uses the Report keyword still calculates each percentage correctly, but 
the version that explicitly specifies the Year and Quarter dimensions is now wrong:

Why is this? The problem lies in:

Sum ([Sales Revenue] ForAll ([Year];[Quarter]))

When Year and Quarter were the only dimensions in the report, this was equivalent to “a 
grand total of all revenues”. Once you add the Month dimension, this expression removes 
Year and Quarter from the default output context, but leaves Month. 

The formula now has a “break” on month. In other words, on every row where Month is 1, 
this expression now means “the total revenue of all month 1s”. In every row where Month 
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is 2, it means “the total revenue of all month 2s”. As a result, the percentages are not the 
percentages you expect.

Examples of useful formulas
Example:  Calculating a percentage using the Percentage function

Web Intelligence has the Percentage function for calculating percentages. This function 
calculates the percentage of a number in relation to its surrounding context. For example, 
the following table shows revenues by year and quarter. The percentage column contains 
the formula: 

Percentage ([Sales Revenue])

In this case the function calculates each revenue as a percentage of the total revenue. The 
surrounding context is the total revenue; this is the only revenue figure that is relevant 
outside the breakdown by year and quarter in the table.

If the report is split into sections by year, the surrounding context outside the table becomes 
the total revenue in the section.
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If the Percentage cell is placed outside the table but still inside the section, the 
surrounding context becomes the total revenue. In this case the Percentage function 
calculates the total revenue for the section as a percentage of the total overall revenue.

Example:  Calculating a percentage using the Sum function

You can gain more control over the context in which a percentage is calculated by using 
the Sum function. If you divide one figure in a set of figures by the total of those figures, 
you get its percentage of the total; for example, the formula [Sales Revenue]/Sum([Sales 
Revenue]) gives the sales revenue as a percentage of the total revenue.

In the following table the Percentage of Total column has the formula: 

[Sales revenue]/(Sum([Sales revenue] In Report)) and the Percentage of Year column has the 
formula: 

[Sales revenue]/(Sum([Sales revenue] In Section)). 

These formulas take advantage of the extended syntax keywords Report and Section to 
instruct the Sum function to calculate the overall total revenue and yearly revenue 
respectively. 

For more details on the extended syntax that you can use with functions, including the 
Report and Section keywords, see ”Defining the calculation context” on page 198.

Example:  Showing prompt input with UserResponse()
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You have a report showing Year, Quarter and Sales revenue. The State object also 
appears in the report data, although it is not displayed. When the user runs the report they 
are presented with a prompt and they must choose a state. You want to show the state that 
they have chosen in the report title. If your data provider is called “eFashion” and the text 
in the prompt is “Choose a State”, the formula for the title is:

"Quarterly Revenues for " + UserResponse( "eFashion";"Choose a State")

The report is as follows:
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18
Saving formulas as variables

Overview
”Creating Custom Calculations” on page 193 describes Web Intelligence custom 
calculations and using formulas as part of calculations. You can create formulas directly in 
a report cell, but it is often better to save a formula as a variable. By saving a formula as a 
variable you can reuse it throughout the reports in a document without the need to 
continually retype it.

This chapter shows you how to save formulas as variables and use them in reports. It 
contains the following sections:

• Creating, editing, and deleting variables
• Using variables to simplify formulas

Creating, editing, and deleting variables
”Creating Custom Calculations” on page 193 describes how you can create custom 
calculations beyond the simple calculations provided by Web Intelligence. Calculations 
are formulas that can include base report objects and functions. Web Intelligence allows 
you to save a formula as a variable; a variable is simply a named formula. Saving 
formulas as variables has the advantages of:

• allowing you to re-use a formula in a report without the need to re-create it each time
• simplifying complex formulas by breaking them down into variables
Example:  Showing the amount of revenue generated per guest

You have a report that contains [Revenue] and [Number of Guests] objects. The formula:

[Revenue] /[Number of Guests]

gives the average revenue per guest. If you save this formula as a variable called Average 
Revenue, you can re-use it throughout a report.

Creating formulas
Variables and formulas are closely linked because variables are named formulas. To find 
out how to create a formula, see ”Creating formulas” on page 193.

Saving formulas as variables
You save a formula as a variable with the Create New Variable dialog box.

Creating a variable using the Create New Variable dialog box
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To create a variable using the Create New Variable dialog box:

1. Select the cell where you want to create the variable, or make sure that no cell is 
selected.

2. Click Create a variable.
The Create Variable dialog box appears. 
If you had selected a cell, the current cell formula appears in the Formula box. If not, 

the Formula box is blank.

NOTE: The Create a variable button is available on the Formula toolbar when 
you select a cell that does not already contain a variable or when no cell is 
selected.

3. Type the variable name in the Name box.
4. Select the variable type by selecting Dimension, Measure or Detail.

The following table describes the differences between these variable types:
Table 0.1: 

Object Description

Dimension Retrieves the data that will provide the 
basis for analysis in a report. Dimension 
objects typically retrieve character-type 
data, for example; customer names, line 
names, or dates.



Performing On-Report Analysis with Web Intelligence 223

If you select Detail, an Associated Dimension box appears. Click ... next to the box 
to open the Objects and Variables dialog box and select the dimension you want to 
associate with the detail.
For more information on associating details with dimensions, see ”Associating details 
with dimensions” on page 223.

1. Create the variable formula in the Formula box by typing or double-clicking objects, 
functions and operators.

NOTE: If you selected a cell that already contained a formula, the cell formula 
appears in the Formula box.

2. Click OK.
The variable appears in the list of report variables. in the Left Pane under the Variables 
folder.
You can now use the variable in your report just as you do with ordinary report 
objects.

Associating details with dimensions
A detail object is an object that provides additional information about a dimension. For 
example, if you have a Customer and Customer Name objects, you can associate 
Customer Name as a detail of Customer. Web Intelligence requires a one-to-one 
relationship between a dimension and its associated detail(s), but Desktop Intelligence 
documents allow a one-to-many relationship. 

If a detail contains more than one value for one value of the dimension (which might be the 
case in a document migrated from Desktop Intelligence), it returns the #MULTIVALUE error 
when placed in the same block as the dimension.

Detail Provides descriptive data about a 
dimension. A detail is always attached to 
the dimension for which it provides 
additional information. For example, 
Age is a detail object that is associated 
with Customer dimension. Address 
provides additional information on 
customers.

Measure Retrieves numeric data that is the result of 
calculations on data in the database. For 
example; Revenue is the calculation of 
the number of items sold multiplied by 
item price. Measure objects are often 
located in a Measures class.

Table 0.1: 

Object Description
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You can remove the #MULTIVALUE error by activating the Avoid Duplicate Row 
Aggregation block property. For more information, see ”Avoiding duplicate rows” on 
page 121.

Editing and deleting variables
After you have created a variable you can edit it or delete it.

Editing a variable

To edit a variable:

1. Select the variable in the list of report variables under Available Objects in the Left 
Pane.

2. Click the right mouse button and click Edit on the shortcut menu, or click Edit at the top 
of the Left Pane.
The Edit Variable dialog box appears.

3. Edit the variable.
4. Click Validate to check the syntax of the updated variable.
5. Click OK to save the new variable definition.

The variable is saved in the document. You can include the variable in any of the 
reports within the same document.

Deleting a variable

To delete a variable:

1. Select the variable in the list of report variables under Available Objects on the Left 
Pane.

2. Click the right mouse button and click Remove on the shortcut menu or click Remove 
at the top of the Left Pane.

Using variables to simplify formulas
If a formula is complex you can use variables to simplify it. By using variables you break a 
complex formula down into manageable parts and make it much easier to read, as well as 
making building formulas much less error-prone.

You can use previously-created variables in a formula in exactly the same way as you use 
other report objects. Variables appear in the formula editor under the “Variables” folder. 

Example:  Create a formula to return a statistical variance

Variance is a statistical term. The variance of a set of values measures the spread of those 
values around their average. Web Intelligence has the function Var() that calculates the 
variance in one step, but manual calculation of variance provides a good example of how 
to simplify a complex formula using variables. 

You have a report showing numbers of items sold by quarter and you want to include the 
variance. To calculate the variance manually you need to: 

• calculate the average number of items sold
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• calculate the difference between each number of items sold and the average, then 
square this value

• add up all these squared differences
• divide this total by the number of values - 1

Without the use of variables to simplify it, this formula is as follows:

Sum((([Quantity sold] - Average([Quantity sold] ForEach [Quarter]) In Report)*([Quantity 
sold] - Average([Quantity sold] ForEach [Quarter]) In Report)) In [Quarter])/(Count 
([Quantity sold] ForEach [Quarter]) - 1)

This formula is clearly unwieldy. By using variables you can simplify it to:

Sum ([Difference Squared])/[Number of Observations] - 1)

which is much easier to understand. This simplified version of the formula gives you a 
high-level view of what the formula is doing, rather than plunging you into the confusing 
details. You can then examine the formulas of the variables referenced in the high-level 
formula to understand its component parts.

For example, the formula references the variable Difference Squared, which itself 
references the variable Average Sold. By examining the formulas of Difference Squared 
and Average sold, you can drill down into the formula to understand the details of what it 
is doing.

Simplifying a variance formula with variables
As the example above shows, there are several steps involved in creating a variance 
formula. You encapsulate each of these steps in a variable. The variables you create are:

• average number of items sold
• number of observations (that is, the number of separate values of the number of items 

sold)
• difference between an observation and the average, squared
• sum of these differences divided by the number of observations - 1

In this example, your initial report looks like this:

Creating an Average Sold variable

Quarter Quantity sold

Q1 61,808

Q2 54,406

Q3 55,690

Q4 51,325
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To create an Average Sold variable:

1. Display the Formula toolbar by clicking View > Toolbars > Formula on the Main 
toolbar.

2. Make sure that no cell is selected.
3. Click Create a variable on the Formula toolbar.
4. In the Formula pane, type the formula:

Average([Quantity Sold] In ([Quarter])) In Report 

Or
Double-click items in the Available Objects, Available Functions and Available 
Operators boxes to build the formula.

5. Set the formula qualification to Measure.
6. In the Name text box, type:

Average Sold

7. Click OK.

Creating a Number of Observations variable

1. Display the Formula toolbar by clicking View > Toolbars > Formula on the Main 
toolbar.

2. Make sure that no cell is selected.
3. Click Create a variable on the Formula toolbar.
4. In the Formula pane, type the formula:

Count([Quantity Sold] In ([Quarter])) In Report 

Or
Double-click items in the Available Objects, Available Functions and Available 
Operators boxes to build the formula.

5. Set the formula qualification to Measure.
6. In the Name text box, type:

Average Sold

7. Click OK.

Creating a Difference Squared variable

1. Display the Formula toolbar by clicking View > Toolbars > Formula on the Main 
toolbar.

2. Make sure that no cell is selected.
3. Click Create a variable on the Formula toolbar.
4. In the Formula pane, type the formula:

Power(([Quantity sold] - [Average Sold]);2) 

Or
Double-click items in the Available Objects, Available Functions and Available 
Operators boxes to build the formula.

5. Set the formula qualification to Measure.
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6. In the Name text box, type:
Average Sold:

7. In the Name text box, type:
Difference Squared

8. Click OK.

Creating the Variance variable

1. Display the Formula toolbar by clicking View > Toolbars > Formula on the Main 
toolbar.

2. Make sure that no cell is selected.
3. Click Create a variable on the Formula toolbar.
4. In the Formula pane, type the formula:

Sum([Difference Squared] In ([Quarter]))/([Number of Observations] - 
1) 
Or
Double-click items on the Available Objects, Available Functions and Available 
Operators boxes to build the formula.

5. Set the formula qualification to Measure.
6. In the Name text box, type:

Average Sold:
7. In the Name text box, type:

Difference Squared

8. Click OK.

Adding the variance to the report

To add the variance to the report:

1. Select the Variance variable under Available Objects on the Left Pane, and then drop 
the variable onto the report.
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19
Using Web Intelligence functions

Overview
This chapter looks at the functions available in Web Intelligence. You often use functions 
when creating Web Intelligence custom calculations. 

This chapter covers the following topics:

• what is a function?
• using functions
• function examples and descriptions

What is a function?
In mathematics, a function is a rule relating different values or sets of values. Functions 
describe the relationships between variables and allow you to determine the value of one 
variable given the value of another variable or variables. A function prototype (see below) 
is a description of the relationship between input value(s) and output values and allows 
you to derive a value (the output value) given zero or more existing values (the input value 
or values). You input values to a function through its parameters and the function returns a 
value related to the values of the parameters.

For example, the Left() function describes the relationship between two input values (a 
character string and an integer) and a character string output value. It outputs the first 
[integer] characters of this character string as another character string. If the input string is 
‘Hello’ and the input integer is 2, the output string is therefore ‘He’.

Note:  Not all functions require input parameters.

Function prototypes
To use a function you need to know its name, how many input values it requires and the 
data types of these input values. You also need to know the type of data that the function 
outputs. For example, the Sum function takes a numerical object as input (for example a 
measure showing sales revenue) and outputs numeric data (the sum of all the values of the 
measure object). 

This description of a function’s inputs and outputs it known as its prototype. The prototypes 
of all Web Intelligence functions are listed in ”Functions available in Web Intelligence” on 
page 233. 
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Using functions
Often you need to build additional calculations or objects into a report beyond the report’s 
base objects or calculations. In some cases existing report objects are sufficient to create 
these additional objects or calculations. For example, if you have Revenue and Number of 
Sales objects you can create the formula 

[Revenue]/[Number of Sales] 

to show the revenue per sale.

More often you need to use functions to provide the additional calculations and objects 
you need. Web Intelligence has several categories of functions:

You can see a full list of the functions available in Web Intelligence, see ”Functions 
available in Web Intelligence” on page 233

Function examples and descriptions
This section shows how to use some of the functions available with Web Intelligence to 
answer typical business questions. Later in this section, you will find a detailed description 
of each function and gives an example of the information each function enables you to 
include in reports.

Example:  Calculating a percentage using the Percentage function

Web Intelligence has the Percentage function for calculating percentages. This function 
calculates the percentage of a number in relation to its surrounding context. For example, 

Category Description

All All the functions for all the categories listed 
below in this table.

Aggregate Aggregates data (for example by summing 
or averaging a set of values)

Character Manipulates character strings

Date and Time Returns date or time data

Document Returns data about a document

Data Provider Returns data about a document’s data 
provider

Logical Returns TRUE or FALSE.

Numeric Returns numeric data

Misc Functions that do not fit into the above 
categories
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the following table shows revenues by year and quarter. The percentage column contains 
the formula 

Percentage ([Sales Revenue])

In this case the function calculates each revenue as a percentage of the total revenue. The 
surrounding context is in this case the total revenue; this is the only revenue figure that is 
relevant outside the breakdown by year and quarter in the table.

If the report is split into sections by year, the surrounding context outside the table becomes 
the total revenue in the section.
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If the Percentage cell is placed outside the table but still inside the section, the surrounding 
context becomes the total revenue. In this case the Percentage function calculates the total 
revenue for the section as a percentage of the total overall revenue.

Example:  Calculating a percentage using the Sum function

You can gain more control over the context in which a percentage is calculated by using 
the Sum function. If you divide one figure in a set of figures by the total of those figures, 
you get its percentage of the total; for example, the formula

[Sales Revenue]/Sum([Sales Revenue])

gives the sales revenue as a percentage of the total revenue.

In the following table the Percentage of Total column has the formula 

Sales revenue]/(Sum([Sales revenue] In Report))

and the Percentage of Year column has the formula 

Sales revenue]/(Sum([Sales revenue] In Section)) 

These formulas take advantage of the extended syntax keywords Report and Section to 
instruct the Sum function to calculate the overall total revenue and yearly revenue 
respectively. 

Example:  Highlighting values using the If function
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The If function receives three inputs: a condition that returns true or false, a value to output 
if the condition is true and a value to output if the condition is false. For example the 
formula 

If([Sales Revenue]>2000000;"High Revenue";"Low Revenue")

returns “High Revenue” if the value of [Sales Revenue] is greater than 2000000, “Low 
Revenue” otherwise. The condition [Sales Revenue]>2000000 is true in the first case, false 
in the second.

What if you want to output three descriptions, “High revenue” (for revenues over 
2000000), “Medium revenue” (for revenues between 1500000 and 2000000) and “Low 
revenue” (for revenues below 1500000)? In this case you nest If functions. Nesting means 
placing one If function inside another. The formula is as follows:

If ([Sales revenue] > 2000000;"High Revenue"; If ([Sales revenue] >= 
1500000;"Medium Revenue";"Low Revenue"))

The outer If function outputs “High Revenue” if the revenue is greater than 2000000. If it is 
not, the inner If function then determines whether the revenue is greater than or equal to 
1500000 (in which case it outputs “Medium Revenue”) or less than 1500000 (in which 
case it outputs “Low Revenue”). The result is as follows:

Functions available in Web Intelligence
For a full list of the functions, operators and keywords available in Web Intelligence and 
additional information on defining the calculation context of functions and formulas, see 
the Modifying Reports > Adding Formulas and Variables > Functions topic in the 
online help.

For information on OpenDocument, a special function that allows you to link to other 
Web Intelligence documents, see ”Linking documents with OpenDocument” on page 235.
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20
Linking documents with OpenDocument

Overview
OpenDocument is a function that enables you to open another document from within a 
Web Intelligence document using a URL. You can use OpenDocument to create a 
hyperlink in one document that opens another document containing related information. 
Both documents must be stored in the corporate repository and accessible through 
InfoView.

How OpenDocument works
You place the OpenDocument function in a report cell in the form: 

=”<OpenDocument function>”

For example:

=”http://<webserver>/businessobjects/enterprise115/desktoplaunch/opendoc/openDocument.jsp?sTyp
e=wid”

Example:  Link a report, showing sales revenue results for US states to a document 
showing store information for the state you choose

In this example a Web Intelligence report displays sales revenue per US state for each 
quarter. A particularly high result interests you. You would like to find out more information 
about the retail outlets in a specific state, to understand more about their operating 
conditions, and find out the name of the store managers you could contact across that 
state.

You click on the hyperlink on the cell that displays “New York.” A document opens that 
contains detailed information about the stores in New York.

Using prompts to filter results in the opened document
You can define the hyperlink to pass parameters that enter one or more values as the 
response to prompts on the target document. This enables you to dynamically filter the 
document you open by the specific values you want to analyze.

In the example given above, the target document has a prompt on the [State] object and 
the OpenDocument hyperlink in the parent document requests Web Intelligence to use the 
value that is clicked as the value for the prompt. So, when you click the hyperlink on “New 
York”, you see only those values for New York in the target document that opens. 

You can specify a value in the hyperlink that is different from the value displayed in the 
hyperlink. For example, you can create the hyperlink in the cell that displays the sales 
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revenue values and specify that the target report is filtered by whichever state is displayed 
on the same table row as the clicked hyperlink.

You can filter the target document by as many prompts as you like. For example, the same 
hyperlink can also filter the target document by whichever state, product line, and quarter 
is displayed on the same table row.

You can also filter the target document by multiple values, even though the document 
contains only a single prompt. For example, a target document with a single prompt on a 
dimension that represents data for [Flight Number] can be filtered by values for other 
objects in the query definition that are logically related, such as [Arrival Time] and 
[Departure Time]. Information on the syntax for single-value and multi-value prompts is 
provided on ”Using prompts to filter results in the opened document” on page 235.

Supported document types
You can use OpenDocument to create cross-system links to and from the following 
document types:

• .wid: Web Intelligence version 6.x documents 
• .rpt: Crystal reports 
• .car: OLAP Intelligence reports 

OpenDocument syntax
The general syntax of OpenDocument is

http://<webserver>/businessobjects/enterprise115/<platformSpecific>?<parameter_list>

There are two implementations of OpenDocument. The form of the <platformSpecific> portion 
depends on your implementation:

• For Java implementations, use desktoplaunch/opendoc/openDocument.jsp in place of 
<platformSpecific>, for example:
http://<webserver>/businessobjects/enterprise115/desktoplaunch/opendoc/openDocument.jsp?sType=w
id

• For .NET implementations, use InfoView/scripts/opendocument.aspx in place of 
<platformSpecific>, for example:
http://<webserver>/businessobjects/enterprise115/InfoView/scripts/opendocument.aspx?sType=wid

OpenDocument parameters
OpenDocument parameters can appear in any order and must be separated by an 
ampersand (&). For example, sType=wid&sDocName=Sales2003. Do not place spaces around 
the ampersand.
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The parameters are listed in the following tables.

Example:  Example of sPath
http://<webserver>/businessobjects/enterprise115/<platformSpecific>?sPath=Sales+Reports,Sub+Fold
er.

Note:  To ensure correct URL encoding, the spaces in this parameter and several following 
parameters are replaced with +. You can ensure correct URL encoding of parameter values 
with the WebIntelligence URLEncode() function. For more information on URL encoding 
parameter values, see ”URL encoding” on page 244.

Example:  Example of sType
http://<webserver>/businessobjects/enterprise115/<platformSpecific>?sType=wid

Example:  Example of sDocName
http://<webserver>/businessobjects/enterprise115/<platformSpecific>?sPath=Sales+Reports&sDocNa
me=Sales+in+2005

Parameter Description Mandatory? Values accepted

sPath The name of 
the Crystal 
folder and 
subfolder 
containing the 
target 
document.

Yes if sDocName 
is specified and 
is not unique.

Crystal folder and/or 
subfolder:

[folder],

[subfolder]

Parameter Description Mandatory? Values accepted

sType The type of 
target 
document or 
report.

Yes. .wid

.rpt

.car

Parameter Description Mandatory? Values accepted

sDocName The document 
name.

One of 
sDocName or 
iDocID is 
mandatory.

The document name.
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Note:  Do not specify both the sDocID and sDocName parameters in the same parameter list. 
Specify one or the other.

Example:  Example of sDocID
http://<webserver>/businessobjects/enterprise115/<platformSpecific>?sType=wid&iDocID=2010

Note:  To obtain the document ID, navigate to the document in InfoView, hover your mouse 
over the document name hyperlink, and look for the ID number in the browser's status bar. 
You can also obtain the document ID from the Central Management Console. 

Note:  Do not specify both the sDocID and sDocName parameters in the same parameter list. 
Specify one or the other.

Example:  Example of sIDType
http://<webserver>/businessobjects/enterprise115/<platformSpecific>?iDocID=AWimiw9StnhGm993
evk.Amc&sIDType=CUID

Parameter Description Mandatory? Values accepted

iDocID The document 
identifier.

One of 
sDocName or 
iDocID is 
mandatory.

The document 
identifier.

Parameter Description Mandatory? Values 
accepted

sIDType The Crystal 
object type.

Yes if the target is a 
Crystal report or 
OLAP Intelligence 
report (sType=rpt or 
car) . Otherwise, use 
sPath and sDocName).

• CUID 
• GUID 
• RUID 
• ParentID 
• InfoObjectID 

(default)
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Example:  Example of sReportName
http://<webserver>/businessobjects/enterprise115/<platformSpecific>?sType=wid&sDocName=Sales+
in+2003&sReportName=First+Report+Tab

Example:  Example of sOutputFormat
http://<webserver>/businessobjects/enterprise115/<platformSpecific>?sPath=Sales+Reports&sDocNa
me=Sales+in+2003&sOutputFormat=E

Parameter Description Mandatory? Values accepted

sReportName The report to 
open if the 
target 
document is 
multi-report.

No. (First report 
is the default 
value.)

Report name for Web 
Intelligence 
documents, sub-report 
for Crystal Reports, 
pages for OLAP 
Intelligence reports.

Parameter Descriptio
n

Mandatory? Values accepted

sOutputFormat Format in 
which the 
target 
document is 
opened.

No. (Default 
is HTML .)

• H (HTML) 
• P (PDF) 
• E (Excel) 
• W (Word)

Note:  W is supported by 
Crystal Reports only.

Parameter Descriptio
n

Mandatory? Values accepted

sReportPart The part of 
the report to 
open.

No. The name of the report 
part.
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Example:  Example of sReportPart
http://<webserver>/businessobjects/enterprise115/<platformSpecific>?sPath=Sales+Reports&sDocNa
me=Sales+in+2003&sReportPart=Part1

Example:  Example of sPartContext
http://<webserver>/businessobjects/enterprise115/<platformSpecific>?
sPath=Sales+Reports&sDocName=Sales+in+2005&sReportPart=Part1&sPartCo
ntext=0-4-0

Parameter Description Mandatory? Values accepted

sPartContext The data context 
of the report part 
(Crystal Reports 
only).

Yes if a value 
is specified for 
sReportPart.

The data context 
of the report part.

Parameter Description Mandatory
?

Values accepted

sInstance The instance of 
the target report 
to open.

No. • User (Link to latest 
instance owned by 
current user) 

• Last (Link to latest 
instance for report) 

• Param (Link to latest 
instance of report 
with matching 
parameter values)
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Example:  Example of sInstance
http://<webserver>/businessobjects/enterprise115/<platformSpecific>?
sPath=Sales+Reports&sDocName=Sales+in+2003&sReportPart=Part1&sInstan
ce=User

Example:  Example of sReportMode
http://<webserver>/businessobjects/enterprise115/<platformSpecific>?
sPath=Sales+Reports&sDocName=Sales+in+2003&sReportPart=Part1&sReport
Mode=Part

Example:  Example of sRefresh
http://<webserver>/businessobjects/enterprise115/<platformSpecific>?
sType=wid&sDocName=SalesReport&iDocID=2010&sRefresh=Y

Parameter Description Mandatory? Values 
accepted

sReportMode For Crystal targets only, 
indicates whether the link 
should open the full target 
report or just the report 
part specified in 
sReportPart.

No. (Default 
is Full.)

• Full
• Part

Parameter Description Mandatory? Values accepted

sRefresh Indicates whether 
a refresh should 
be forced when 
the target 
document or 
report is opened.

No. • Y (forces the 
document refresh)

• N (note that the 
refresh on open 
feature overrides 
this value)
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Example:  Example of sWindow
http://<webserver>/businessobjects/enterprise115/<platformSpecific>?
sType=wid&sDocName=SalesReport&iDocID=2010&sWindow=New

Example:  Example of lsS[NAME]
http://<webserver>/businessobjects/enterprise115/<platformSpecific>?
sType=wid&sDocName=SalesReport&iDocID=2010&lsSSelect+a+City=Paris

Parameter Description Mandatory? Values accepted

sWindow Indicates whether 
the target report 
will open in the 
current browser 
window or a new 
window.

No • Same (current 
window)

• New (new 
window)

Parameter Description Mandatory? Values accepted

lsS[NAME] Specifies a single 
value for a 
prompt. [NAME] is 
the prompt text.

No. A single prompt value.

Parameter Description Mandatory? Values accepted

lsM[NAME] Specifies multiple 
values for a 
prompt. [NAME] is 
the prompt text.

No. Multiple prompt 
values, separated by 
a comma. If the target 
is a Crystal report, 
each value must be 
enclosed in square 
brackets. If the target 
is a OLAP Intelligence 
report, use the MDX 
WITH clause.
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Example:  Example of lsM[NAME]
http://<webserver>/businessobjects/enterprise115/<platformSpecific>?
sType=rpt&sDocName=SalesReport&lsMSelect+Cities=[Paris],[London]

Example:  Example of lsR[NAME]
http://<webserver>/businessobjects/enterprise115/<platformSpecific>?
sType=rpt&sDocName=SalesReport&lsRTime+Period:=[2000..2004)

Parameter Description Mandatory? Values accepted

lsR[NAME] Specifies a range 
of values for a 
prompt. [NAME] is 
the prompt text.

Note:  Not 
supported by 
OLAP 
Intelligence.

No. A range of values 
separated by a 
double period (..). If 
the target is a Crystal 
report, the range must 
be enclosed in square 
brackets and/or 
parentheses (use a 
square bracket next to 
a value to include it in 
the range, and 
parentheses to 
exclude it). If the 
target is a OLAP 
Intelligence report, use 
the MDX WITH 
clause. 

Parameter Description Mandatory? Values accepted

lsU URL to which the 
user is redirected.

Note:  Not 
supported by 
OLAP 
Intelligence.

No. A URL.
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Example:  Example of lsU
http://<webserver>/businessobjects/enterprise115/<platformSpecific>?
sType=wid&sDocName=SalesReport&iDocID=2010&lsU=http://www.site.com

Example:  Example of lsC
http://<webserver>/businessobjects/enterprise115/<platformSpecific>?
sType=wid&sDocName=SalesReport&iDocID=2010&lsC=Sales

Example:  Example of NAII
http://<webserver>/businessobjects/enterprise115/<platformSpecific>?
sType=wid&sDocName=SalesReport&iDocID=2010&NAII=Y

Further information on syntax and parameters
URL encoding

Parameters cannot contain spaces or other special characters that require URL encoding. 
Use the WebIntelligence URLEncode() function to ensure correct URL encoding.

Example:  Encoding the sDocName parameter

Parameter Description Mandatory? Values accepted

lsC Specifies a 
universe context 
(BusinessObjects 
and Web 
Intelligence 
documents only).

No. Universe context.

Parameter Description Mandatory? Values accepted

NAII Forces the display 
of the prompt 
selection page.

Note:  Not 
supported by 
OLAP 
Intelligence.

No. • Y (all prompts 
whose values are 
passed with lsS, lsM 
or lsR are 
pre-selected).

• N (displays only the 
prompts whose 
values passed with 
lsS, lsM or lsR)
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To pass the string “World Sales Report” in the sDocName parameter, use 
sDocName=URLEncode(“World Sales Report”). This ensures that the string is passed 
URL-encoded as “World+Sales+Report”

The examples given earlier in this section do not specify the URLEncode() function explicitly. 
They give URL parameter values in URL-encoded form.

Trailing spaces
Trim trailing spaces at the end of parameter values and prompt names. Do not replace 
them with a plus sign (+). The viewer may not know whether to interpret the plus sign (+) as 
part of the prompt name or as a space. For example, if the prompt name displays:

Select a City:_

(where _ represents a space), enter the following text in the link:

lsSSelect+a+City:=Paris

where the spaces within the prompt name are replaced with the plus sign, and the trailing 
space is trimmed off.

Note:  You can use the WebIntelligence RightTrim() function to trim trailing spaces. 

Case sensitivity
All the OpenDocument parameters are case sensitive.

Length limit
The encoded URL cannot exceed 2083 total characters.

Prompts for OLAP Intelligence report targets
If the target document is an OLAP Intelligence report (.car) you can use the lsS and lsM 
parameters to specify prompts.

Using the lsS parameter with OLAP Intelligence 
The parameters are passed in as a URL-encoded string using the unique name of the 
parameter set up in the OLAP Intelligence report.

Example:  Opening a report to a specific page

If 23CAA3C1-8DBB-4CF3-BA%2CB8%2CD7%2CF0%2C68%2CEF%2C9C%2C6F is the 
URL-encoded unique name for the page parameter in the OLAP Intelligence report, you use 
the following URL to open the OLAP Intelligence report to page 2:

http://<webserver>/businessobjects/enterprise115/<platformSpecific>?sType=car&sIDType=InfoObje
ct&iDocID=440&lsS23CAA3C1-8DBB-4CF3-BA%2CB8%2CD7%2CF0%2C68%2CEF%2C9C%2C
6F=2

Example:  Opening a cube parameter
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If 8401682C-9B1D-4850-8B%2C5E%2CD9%2C1F%2C20%2CF8%2C1%2C62 is the URL-encoded 
unique name for the cube parameter opening the warehouse cube in the catalogue 
FoodMart 2000 on MSAS, you would use the following URL to open this cube parameter:

http://<webserver>/businessobjects/enterprise115/<platformSpecific>?sType=car&sIDType=InfoObje
ct&lsS8401682C-9B1D-4850-8B%2C5E%2CD9%2C1F%2C20%2CF8%2C1%2C62=CATALOG%3
DFoodMart%202000,CUBE%3Dwarehouse&iDocID=616

Using the lsM parameter with OLAP Intelligence 
lsM parameters are also passed in as a URL-encoded string using the unique name of the 
parameter set up in the OLAP Intelligence report.

The following is an example of using lsM:

http://<webserver>/businessobjects/enterprise115/<platformSpecific>?sType=car&sIDType=InfoObje
ct&lsMADC216EA-D9A5-42B5-AE%2C21%2C84%2CA9%2CF9%2C6E%2C31%2C7=[%5BCusto
mers%5D.%5BCountry%5D.%26%5BMexico%5D],[%5BCustomers%5D.%5BCountry%5D.%26%5
BCanada%5D]&iDocID=544

This is a memberset parameter opening up a report with Customers > Country > Mexico 
and Customers > Country > Canada in the view.

Sub-reports
You cannot pass parameter values to a sub-report of a target Crystal report.
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21
Printing, Saving, and Deleting documents

Overview
You can easily print out Web Intelligence reports, to share information on paper. When 
you print reports, Web Intelligence renders the layout and data of the original reports into 
Portable Document Format (PDF) for optimum print quality.

You can save Web Intelligence documents exclusively for your personal reference or share 
your documents with other users. You save Web Intelligence documents to InfoView. You 
can also save Web Intelligence documents as Microsoft Excel spreadsheets and Adobe 
Acrobat PDF files. The layout and formatting in the original Web Intelligence document is 
closely retained in the new file format.

This chapter tells you how to:

• print out the reports in Web Intelligence documents
• save Web Intelligence documents to InfoView
• save Web Intelligence documents as Excel, PDF, or CSV files
• delete Web Intelligence documents from InfoView

Printing reports in Web Intelligence documents
When you print documents, Web Intelligence renders the reports in Portable Document 
Format (PDF) before you print. This means that the page layout is optimized for printing to 
paper.

Note:  To print documents, you need to have Adobe Acrobat Reader installed on your 
computer. You can download Acrobat Reader free at www.adobe.com

To print reports

1. With the document open, click the arrow next to the View button on the main toolbar 
above the report.

2. Click PDF Mode.

http://www.adobe.com
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Adobe Acrobat reader launches and the reports appear in PDF format.

3. Print the document by using the Acrobat Reader Print command.

Saving Web Intelligence documents to InfoView
You save documents to InfoView. Depending on whether you want exclusive access to 
documents or whether you want to share documents with other users, you can save 
documents to personal or public folders.

Note:  Before you can save a document, you need to run the query at least once. To do 
this, click Run Query or Refresh. The results are displayed on the reports.

To save a new Web Intelligence document in InfoView

1. With the document open, click Save on the main toolbar above the displayed reports.
The InfoView Save Document page opens.

2. In the Title box, type the title of the document.
3. In the Description box, type a meaningful description of the document (optional).
4. In the Keywords box, type keywords that you or other users can use to search for the 

document in the future (optional).
5. To save the document to a different location than the one displayed in the Location 

box, browse to the folder where you want to save the document, and click OK.
6. Select the document category in the Categories box.
7. Select Refresh on open to refresh the document each time it is opened.
8. Select Permanent Regional Formatting to preserve the document regional formatting 

with the document.
9. Click OK.
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The document is saved in InfoView.

Saving documents as Excel, PDF, or CSV files
You can save Web Intelligence documents in the following file formats:

• Microsoft Excel spreadsheets
• Adobe Acrobat PDF files
• Comma Separated Values (CSV) files

Saving Web Intelligence documents as Excel Spreadsheets
Creating a copy of your documents as a Microsoft Excel file is especially useful if you want 
to combine the information in your Web Intelligence document with other data in an Excel 
spreadsheet.

Unlike Web Intelligence documents, the Excel files are not connected to the database. This 
means you cannot refresh the data in the Excel file. To display up-to-date data in Excel 
format, refresh the Web Intelligence document and then save it as a new Excel file.

Note:  When you name reports in a document that you want to save as an Excel 
spreadsheet, the names of reports must not include more than 31 characters or include 
spaces or the following special characters: * : \ / [ ]

Note:  Dates prior to 1900 do not display correctly in Excel.

To save a Web Intelligence document as an Excel spreadsheet

1. With the document open, click Document, on the toolbar above the displayed report.
2. Select Save to my computer as>Excel.

The File Download dialog box appears.
3. Type a file name or accept the default name displayed.
4. Select Save this file to disk, and then click OK.
5. Select a file location on your computer, then click Save.

Web Intelligence saves a copy of your document in Microsoft Excel format to the 
location you specified on your computer. Each report within the Web Intelligence 
document converts to a separate Excel worksheet within the Excel file.

NOTE: Some Web Intelligence chart formats do not exist in Excel. These charts 
are automatically converted to the closest corresponding chart format available in 
Excel.
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To share Excel files with other users, you can save them to InfoView. For more information, 
see the BusinessObjects Enterprise InfoView User’s Guide.

Generating Web Intelligence documents to PDF
Creating a copy of your documents as a PDF file is especially useful if you want to provide 
other users with the document information in a printable format. The page layout and 
formatting of the Web Intelligence document is retained in the PDF file.

To save a Web Intelligence document as a PDF file

1. With the document open, click Document, on the toolbar above the displayed reports.
2. Select Save to my computer as>PDF.

The File Download dialog box appears.
3. Type a file name or accept the default name displayed.
4. Select Save this file to disk, and then click OK.
5. Select a file location on your computer, then click Save.

Web Intelligence saves a copy of your document in Adobe Acrobat PDF format to the 
location you specified on your computer.

To share Excel files with other users, you can save them to InfoView. For more information, 
see the BusinessObjects Enterprise InfoView User’s Guide.

Generating Web Intelligence documents as CSV files
Creating a copy of your documents as a CSV file is useful if you want to export the data in 
a Web Intelligence document to a database tool or application.

To save a Web Intelligence document as a CSV file

1. With the document open, click Document, on the toolbar above the displayed reports.
2. Select Save to my computer as>CSV.

The File Download dialog box appears.
3. Select Save this file to disk, and then click OK.
4. Type a file name or accept the default name displayed.
5. Select a file location on your computer, then click Save.

Web Intelligence saves a copy of your document in CSV format to the location you 
specified on your computer.

Deleting Web Intelligence documents
You can delete the Web Intelligence documents you save to InfoView.
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Note:  You can only delete documents from InfoView if you have the appropriate security 
profile.

To delete your Web Intelligence documents from InfoView

1. From the InfoView home page, navigate to the folder that contains the document you 
want to delete.
The documents are listed.

2. Select the check box next to the name of the document you want to delete.
3. Click Delete.

A message prompts you to confirm if you want to delete the selected document.
4. Click OK.

The document is deleted from InfoView.
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