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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty statements 
accompanying such products and services. Nothing herein should be construed as constituting an additional 
warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. Consistent 
with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and 
Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard 
commercial license.

Copyright Notices

© Copyright 2002-2008 Hewlett-Packard Development Company, L.P.

No part of this document may be copied, reproduced, or translated to another language without the prior 
written consent of Hewlett-Packard Company. The information contained in this material is subject to change 
without notice.

Trademark Notices

Adobe® and Acrobat® are trademarks of Adobe Systems Incorporated. 

HP-UX Release 10.20 and later and HP-UX Release 11.00 and later (in both 32 and 64-bit configurations) on 
all HP 9000 computers are Open Group UNIX 95 branded products.

Java™ and all Java based trademarks and logos are trademarks or registered trademarks of Sun 
Microsystems, Inc. in the U.S. and other countries.

Microsoft®, Windows®, and Windows® XP are U.S. registered trademarks of Microsoft Corporation.

Windows Vista® is either a registered trademark or trademark of Microsoft Corporation in the United States 
and/or other countries.

OpenView® is a registered U.S. trademark of Hewlett-Packard Company.

Oracle® is a registered U.S. trademark of Oracle Corporation, Redwood City, California.

UNIX® is a registered trademark of The Open Group. 

Intel®, Itanium® and Pentium® are trademarks or registered trademarks of Intel Corporation or its 
subsidiaries in the United States and other countries.
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Support

You can visit the HP Software Support web site at:

http://www.hp.com/go/hpsoftwaresupport 

HP Software Support Online provides an efficient way to access interactive technical support tools. As a 
valued support customer, you can benefit by using the support site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a 
support contract.

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp

To find more information about HP Passport, go to:

http://h20229.www2.hp.com/passport-registration.html 
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1 Introduction
This guide describes the installation of HP OpenView Service Desk 4.5 Client 2008 (Client 
2008). With the procedures in this guide you can prepare for installation, install, configure, 
upgrade, and remove Client 2008. There is also a troubleshooting section.

This guide was tested for accuracy primarily against an installation on Windows® XP, 
Windows 2000, Windows 2003, and Windows Vista platforms. Client 2008 installation 
procedures use platform native installers wherever possible.

Only a basic knowledge of computers is sufficient to complete the installation of Client 2008. 
Knowledge of IT Service Management is not required.

Please read through the relevant sections before you install Client 2008.

This guide is organized as follows:

• Chapter 2, Preparing for Installation describes the installation programs of Client 2008, 
and provides a list of files and their version numbers that will be installed when you 
install Client 2008. It also includes information about the system requirements.

• Chapter 3, Installing Client 2008 describes the tasks you must perform to install and 
connect Client 2008.

• Chapter 4, Configuring Client 2008 provides detailed configuration information.

• Chapter 5, Upgrading Client 2008 provides detailed information about how to upgrade to 
future Client 2008 service packs.

• Chapter 6, Removing Client 2008 contains a list of files that will not be removed because 
they may also be used by other applications installed on your system.

• Appendix A describes how to deal with some of the errors that may, under certain 
circumstances, occur during installation. It also contains troubleshooting information 
about configuration and log information.

Related Publications

Client 2008 Documentation

• The HP OpenView Service Desk 4.5 Client 2008: Release Notes gives an overview of Client 
2008 and information that helps you solve known problems. See 
SD45_Client_2008_Release_Notes.pdf.

• The HP OpenView Service Desk 4.5 Client 2008: Supported Platforms List helps you 
determine software requirements and the software versions supported by HP for Client 
2008. See SD45_Client_2008_Supported_Platforms_List.pdf.

• The HP OpenView Service Desk 4.5 Client 2008: Differences between the Previous Client 
and Client 2008 describes the differences between the two clients. See 
SD45_Client_2008_Difference_Guide.pdf.
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Service Desk 4.5 Documentation

You may also need to refer to the Service Desk 4.5 documentation, for example, for more 
information about Service Desk server. The following section lists some of the publications 
provided with Service Desk 4.5. Updates of the publications and additional publications may 
be provided in later service packs. For an overview of the documentation provided in service 
packs, see the readme file of the latest service pack. The service packs and the latest versions 
of publications are available on the Internet, at 
http://support.openview.hp.com/patches/patch_index.jsp and 
http://support.openview.hp.com/selfsolve/manuals respectively.

• The HP OpenView Service Desk: Installation Guide covers all aspects of installing Service 
Desk. See Installation_Guide.pdf.

• The Readme.htm file for Service Desk 4.5 contains information that will help you get 
started with Service Desk. It also contains any last-minute information that became 
available after the other documentation went to manufacturing. 

• The HP OpenView Service Desk: Release Notes describes the features that Service Desk 
provides, compare the current software’s features with those available in previous 
versions of the software, and helps you solve known problems. See Release_Notes.pdf.

• The HP OpenView Service Desk: User’s Guide introduces the key concepts behind Service 
Desk. It gives an overview of what you can do with Service Desk and explains typical 
tasks of different types of Service Desk users. Scenario descriptions are provided as 
examples of how the described features could be implemented. See User’s_Guide.pdf.

• The HP OpenView Service Desk: Supported Platforms List contains information that helps 
you determine software requirements. It lists the software versions supported by 
Hewlett-Packard for Service Desk 4.5. See Supported_Platforms_List.pdf.

• The HP OpenView Service Desk: Administrator’s Guide provides information that helps 
application administrators to set up and maintain the Service Desk application server for 
client usability. See Administrator’s_Guide.pdf.

• The HP OpenView Operations Integration Administrator’s Guide explains the integration 
between Service Desk and HP OpenView Operations for Windows and UNIX®. This guide 
covers the installation and configuration of the integration and explains how to perform 
the various tasks available with the integration. See OVO_Integration_AG.pdf.

• The HP OpenView Service Desk: Migration Guide provides a detailed overview of the 
migration from ITSM to Service Desk, to include an analysis of the differences in the two 
applications. Detailed instructions in this guide lead through the installation, 
configuration and other tasks required for a successful migration. See 
Migration_Guide.pdf.

• The HP OpenView Service Desk: Web API Programmer’s Guide contains information that 
will help you create customized integrations with Service Desk using the Service Desk 
Web API. This API is particularly suited for developing Web applications. See 
Web_API_pg.pdf.

• The HP OpenView Service Desk: Data Dictionary contains helpful information about the 
structure of the application. See Data_Dictionary.htm.

This guide is for Client 2008 only. For detailed information about Service Desk 4.5, see 
Service Desk documents available on your Service Desk CD-ROM, or available from http://
support.openview.hp.com/selfsolve/manuals.
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• The HP OpenView Service Desk 4.5 Computer Based Training (CBT) CD-ROM is intended 
to assist you in learning about the functionality of HP OpenView Service Desk 4.5 from 
both a user and a system administrator perspective. The CD-ROM contains 
demonstration videos and accompanying texts that explain and show how to perform a 
wide variety of tasks within the application. The CBT also explains the basic concepts of 
the Service Desk application.

The HP OpenView Service Desk 4.5 Computer Based Training (CBT) CD-ROM was 
shipped automatically with the regular Service Desk software.

Typographic Conventions

The table below illustrates the typographic conventions used in this guide.

Table 1 Typographic conventions 

Font What the Font Represents Example

Italic References to book titles See also the HP OpenView Service Desk: 
Installation Guide.

Emphasized text Do not delete the System user.

Bold First-time use of a term The service call is the basis for incident 
registration.

Courier File names To start the installation, double-click 
setup.htm.

Computer-generated output, 
such as command lines and 
program listings

If the system displays the following text
C:\>dir a:
The device is not ready
check if the disk is placed in the disk drive.

Courier 
bold

User input: text that you 
must enter in a box or after a 
command line

If the service call must be solved within 30 
minutes, enter 30.

Courier 
italic

Replaceable text: text that 
you must replace by the text 
that is appropriate for your 
situation

Go to the folder X:\\Setup, where X is your 
CD-ROM drive.
Introduction 9



Helvetica bold Menu names You can adjust the data view with the 
commands in the View menu.

Menu commands Choose Save from the menu.

Button names Click Add to open the Add Service Call dialog 
box.

Keyboard keys
A plus sign (+) means you 
must press the first key (Ctrl 
in the example), hold it, and 
then press the second key (F1 
in the example).

Press Ctrl+F1.

Table 1 Typographic conventions  (cont’d)

Font What the Font Represents Example
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2 Preparing for Installation
This chapter describes the installation programs of HP OpenView Service Desk 4.5 Client 
2008, and lists the files and their version numbers that will be installed when you install 
Client 2008.

This chapter suggests how to plan an installation, and provides information about the system 
requirements. It also describes the third-party product that is installed autumatically during 
the installation of Client 2008.

The Installation Program

Client 2008 uses platform native installers. The client software is supplied in the product 
release package. The client installation program installs the software onto a client machine. 
This allows Service Desk to be used on the client machine via a network.

Files That Will Be Installed

The following files are installed when you run Client 2008 installation program. This list does 
not show all the files that are installed, but only those whose version number is important. 
Some of these files may already be installed on your computer before you installed Client 
2008. If these files are already installed, they will not be overwritten. If they are not present 
on your computer, they will be installed.

• Files installed in the %Windir%\system32 folder:

— Client 2008 installs two files into the the Windows system directory if they do not 
exists:
GdiPlus.dll version 5.1.3102.2180
msvcr80.dll version 8.0.50727.762

System Requirements

The latest information about supported software versions is included in the Supported 
Platforms List, which is located in the Docs folder of the release package.

Client 2008 on Windows 2000 and Windows XP Professional

• Processor: Intel® Pentium® PIV, 1.6 GHz 

• Memory: 512 MB RAM
  11



• Disk space: 300 MB

• Display: 800 x 600 resolution, 16-bit color (1024 x 768 resolution, high color, or higher 
recommended)

• Network connection: TCP/IP, 56 KB (higher recommended)

Client 2008 on Windows 2003 R2

• Processor: Intel® Pentium® PIV, 1.6 GHz 

• Memory: 512 MB RAM

• Disk space: 300 MB

• Display: 800 x 600 resolution, 16-bit color (1024 x 768 resolution, high color, or higher 
recommended)

• Network connection: TCP/IP, 56 KB (higher recommended)

Client 2008 on Windows 2003 R2 Terminal Services 

Client 2008 is supported for use with Windows Terminal Service. For information on sizing 
see the white paper created by Microsoft, which is located on the following Web site:
http://www.microsoft.com/windowsserver2003/techinfo/overview/termservlic.mspx.

• Network connection: TCP/IP, 56 KB

Client 2008 on Windows Vista Enterprise 32-bit Edition

• Processor: Intel® Pentium® PIV, 1.6 GHz 

• Memory: 512 MB RAM

• Disk space: 300 MB

• Display: 800 x 600 resolution, 16-bit color (1024 x 768 resolution, high color, or higher 
recommended)

• Network connection: TCP/IP, 56 KB (higher recommended)

Third-Party Software

Client 2008 uses Sun Java Virtual Machine version 1.5.0_14, which is shipped together with 
Client 2008 and is installed automatically during the client installation. You do not need to 
take any steps to install it manually. 

No other third-party software is required to be installed before the client installation. 
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3 Installing Client 2008
This chapter describes the tasks you must perform to install Client 2008 and connect to the 
application server.

Preparing for Installation

Whoever performs the installation must have administrator rights on the machine where 
Client 2008 is being installed.

To prepare for Client 2008 installation, perform the following steps to remove the previous 
client:

1 Go to Start → Control Panel → Add or Remove Programs.

2 In the Add or Remove Programs window, select hp OpenView service desk 4.5 client, and 
click Remove, and then click Yes.

Installing Client 2008

Use this procedure to install the client software on a client PC that can communicate with the 
application server. 

To install software on a Windows computer, you must be logged onto an account with system 
administrator rights to make changes in the Windows registry. If you do not have sufficient 
rights, the installation of the software will not succeed.

You can double-click the executable file (SDSK_00191.exe) to start Client 2008 installation.

Client 2008 can also be installed silently. See Silent Installation on page 19.

To install Client 2008, perform the following tasks:

It is recommended to backup the following file:

<Previous Client Data folder>\Views.DAT

For example, C:\Documents and Settings\<user account>\Application 
Data\Hewlett-Packard\OpenView\Service Desk\Views.DAT

Customized view settings are stored in this file. You can re-use this file to restore the settings 
after installing Client 2008. See Restore Customized View Settings from the Previous Client 
on page 46 for more information.
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Task 1: Unpack the Client 2008 Software

1 Double-click SDSK_00191.exe. When the Welcome to the InstallShield Wizard screen 
appears, click Next:

2 The Location to Save Files dialogue box appears. This is the folder where the Service Desk 
Client software installation files will be extracted. If you do not want the software to be 
extracted to the default folder shown, click Change to enter another installation folder. 
Click Next to extract the software. 

3 While the installation program is unpacking and reading files, your screen shows a 
progress monitor. You can abort the extraction by clicking Cancel at any time.
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Task 2: Install Client 2008

4 The following web page pops up on completion of the extraction. You can click Release 
Notes, Installation Guide, Supported Platforms List, or Difference Guide to get relevant 
document for Client 2008. You can also explore the content of the installation package by 
clicking Explore Package. 

To install Client 2008, click Install HP OpenView Service Desk 4.5 Client 2008. 

5 The File Download - Security Warning dialogue box appears. Click Run.

6 The Internet Explorer - Security Warning dialogue box appears. Click Run.
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7 The start screen for the installation appears. Click Next.

8 The Welcome screen for the Client InstallShield Wizard appears. Click Next to continue.

9 The License Agreement dialog box appears. To proceed, read the agreement, select the I 
accept the terms in the license agreement check box, and then click Next.  
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10 The Customer Information dialog box is displayed. Enter your User Name and Organization 
name. Select either the Anyone who uses this computer or Only for me option button. If you 
select Anyone who uses this computer you make Service Desk Client available for everyone 
who might use this computer. The selection Only for me ensures that only you can see the 
Client 2008 shortcut in the Start menu, although Client 2008 can still be run by other 
users. Click Next to continue.

11 The Destination Folder dialog box appears. This is the folder where the Service Desk 
Client software is placed. If you do not want the software to be placed in the default folder 
shown, click Change to enter another installation folder. Click Next to continue the 
installation. 
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12 The Ready to Install the Program dialog box shows a list of items to be installed. Click 
Install to install the files or Back to make changes in the previous dialog boxes.

13 While the installation program is installing the files, your screen shows a progress 
monitor. You can abort the installation by clicking Cancel at any time.
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14 When the installation is finished, the InstallShield Wizard Completed dialog box appears. 
Click Finish to quit the installation program. The installation is now complete.

Silent Installation

To install Client 2008 silently, follow these steps:

1 Double-click SDSK_00191.exe and unpack it. See Unpack the Client 2008 Software on 
page 14. 

2 Close the web page that pops up on completion of the extraction, go to the folder where 
you unpacked the Client 2008 software, and run setup.exe /S /v/qn from the 
Command Prompt, where:

— /S means silent

— /v passes the following options to the MSI (installer) package

— /qn means no user interface.

The Connection Wizard

After you install Client 2008, go to Start → All Programs → HP OpenView Service Desk 4.5 Client 
2008 → Client 2008. The Service Desk Connection Wizard starts. The Connection Wizard 
enables you to enter the information required to set up your account, such as the name of the 
Service Desk server you connect to, your account name, password, and your “friendly name”.

Click Cancel at any time to quit the Connection Wizard. Click Back at any time to return to the 
previous screen.

To use Connection Wizard, follow these steps:

1 The Service Desk Connection Wizard opens with the Get Connected dialog box. Read the 
welcome text and click Next to continue.

The /S switch is in uppercase and has a space before and after it. See the Microsoft Installer 
documentation (this is available in the Windows online help) for more information on 
command line switches. 
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2 In the Service Desk Server dialog box, fill in the name of the Service Desk server. If the 
server’s port configuration is not the default (30999), add the new port number after the 
server name, for example myappserver:12345. See Chapter 5: Configuring the 
Application Server in the HP OpenView Service Desk: Installation Guide for more 
information. Click Next to continue.
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3 In the Account Name and Password dialog box, enter the account name and password you 
use to log on to your Service Desk service provider. Contact your Service Desk service 
provider if you do not know the name and password. Click Next to continue.

4 Fill in your Friendly Name. The only place where this name is subsequently displayed is 
in the Accounts dialog box available from Start → All Programs → HP Service Desk 4.5 Client 
2008 → Client Settings Editor:

5 Click Finish to set up your account. The Service Desk Connection Wizard closes, and HP 
Service Desk starts.
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Client Account Settings

To add, modify, remove, or set the default client account settings, follow these steps:

1 Go to Start → All Programs → HP OpenView Service Desk 4.5 Client 2008 → Client Settings 
Editor. The Accounts dialog box opens. 

— To add a client account, click the Add button. The Properties dialog box is displayed. 

— To remove an existing account, select the account, click Remove, and then click Yes. 
The account is removed. 

— To edit an existing account, select the account and click Modify. The Properties dialog 
box is displayed. 

— To set an existing account as the default, select the account and click Set As Default. If 
there is only one account entered, it is automatically selected as the default. 

The Install Folder is the product folder where the fixed settings for Client 2008 are stored. 

The Data Folder is the folder containing Client 2008’s variable data (user settings, cache, 
etc.).
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2 If you chose to add a new account or modify an existing account the Properties dialog box is 
displayed. When the details are complete, click OK.

— In the Friendly Name field enter a name for the account. This is the name that will be 
shown in the Accounts dialog box. 

— In the Account Name enter the Service Desk account name, and the password in the 
Password field. 

— In the Server Name field, enter the name of the Service Desk server. If the server’s port 
configuration was changed from the default of 30999, add the new port number after 
the server name, for example myappserver:12345. See Chapter 5: Configuring the 
Application Server in the HP OpenView Service Desk: Installation Guide for more 
information. 

— Click Test Connection to ensure that the account can connect to the server:
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4 Configuring Client 2008
Normally you can just work with the default settings of Client 2008. You do not need to 
configure it.

This chapter provides detailed information to advanced users about the Client 2008 
configuration. 

Client 2008 needs a workspace and a configuration folder to store the Client 2008 window 
position information, system level log and errors, system startup settings and information. 

• Workspace

The instance data location for the current session during the running of Client 2008. All 
packages that Client 2008 used need this location to store their data, such as their own or 
system level logs, window position, and so forth. 

• Configuration

The configuration location for the current run of Client 2008. The configuration 
determines what packages in Client 2008 will run as well as various other system 
settings. 

Configuring Workspace and Configuration Folders

You can configure the Client 2008 workspace location and configuration folders using the 
following methods.

Command Line Parameters or Shortcut

The workspace can be configured by using command line parameters or shortcuts. 

Only the following three applications need workspaces, and the default workspace 
configuration of Client 2008 is located at the following directories:

• servicedesk.exe: <user_home>\Application 
Data\Hewlett-Packard\OpenView\Service Desk\Client 2008\workspace

• clientsettings.exe: <user_home>\Application 
Data\Hewlett-Packard\OpenView\Service Desk\Client 2008\clientsettings

• updatetool.exe: <user_home>\Application 
Data\Hewlett-Packard\OpenView\Service Desk\Client 2008\updatetool

The default configuration folder is under the following directory:

Client 2008 requires writable workspace and configuration folders.

This configuration applies to the current Windows user only.
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<user_home>\Application Data\Hewlett-Packard\OpenView\Service Desk\Client 
2008\configuration

You can change these default settings for a user. To run the applications with the customized 
workspace location, execute the following command:

“<Client_HOME_DIR>\servicedesk.exe” -data <workspace folder>

For example, 

"C:\Program Files\Hewlett-Packard\OpenView\service desk 4.5\Client 
2008\servicedesk.exe" -data "C:\Documents and 
Settings\<username>\Application Data\Hewlett-Packard\OpenView\Service 
Desk\Client 2008\workspace"

Configure Workspace in Application Configuration Files

The workspace can also be configured in the following application launcher .ini files: 

clientsettings.ini
servicedesk.ini
updatetool.ini 

They are located at the same directory as applications clientsettings.exe, 
servicedesk.exe, and updatetool.exe. The default location is <Client_HOME_DIR>, for 
example, C:/Program Files/Hewlett-Packard/OpenView/service desk 4.5/Client 
2008.

The default content of the servicedesk.ini configuration file is:

-data

@user.home/Application Data/Hewlett-Packard/OpenView/Service Desk/Client 
2008/workspace

To change workspace location, you can modify @user.home/Application Data/
Hewlett-Packard/OpenView/Service Desk/Client 2008/workspace to match your custom 
settings. 

For example, after customization the servicedesk.ini configuration file can look like: 

-data

C:/myfolder/myworkspace

If the paths include directory names with spaces, make sure to wrap the paths with double 
quotation marks as shown in the above example.

Normally you do not need to configure the configuration folder. If you DO need to adjust the 
configuration in the command line, follow the sample below:

"<Client_HOME_DIR>\servicedesk.exe" -configuration <location>
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Configuring Memory

The default maximum memory size for Client 2008 is 256 MB. It is enough for normal usage. 
However, many entries in the Table view and many fields in the forms can consume a lot of 
memory. Therefore, you must adjust the memory size. 

Command Line Parameters or Shortcut

The Java heap memory can be configured by using the command line parameters or shortcut. 

To configure the Java heap memory in the command line, run the application with the 
following parameters:

# servicedesk.exe -vmargs -Xms64m -Xmx512m

Modify Memory Settings in Application Config Files

The Java heap memory can be also configured in the following application configuration file: 

servicedesk.ini

The default location for this config file is <Client_HOME_DIR>, for example, C:/Program 
Files/Hewlett-Packard/OpenView/service desk 4.5/Client 2008.

The default content of the servicedesk.ini configuration file is:

-vmargs

-Xms64m

-Xmx256m

To change the Java heap memory, you can modify -Xms64m -Xmx256m parameters. For 
example, the following configuration sets the default memory to 128 MB and the maximum 
memory to 1024 MB:

-vmargs 

-Xms128m 

-Xmx1024m

Only servicedesk.exe application needs memory adjustment.

This configuration applies to the current Windows user only.

If servicedesk.exe application is already configured to run with other 
parameters, add the parameter -vmargs -Xms64m -Xmx512m to the end of those 
parameters.

The parameters should be in separate lines.
Configuring Client 2008 27



Environment Variables

• SD_CLIENT2008HOME

After the installation, this environment variable is added into the system. It points to 
<Client_HOME_DIR>. Many .bat files of Client 2008 use this environment variable.

• SD_CLIENTHOME

This environment variable was added into the system by the previous client. It is used by 
some applications defined in the Service Desk Administration Console settings. 

To make sure that those applications in the Service Desk can still work properly after you 
remove the previous client and install Client 2008, you must add this environment 
variable again. Configure it in such way that it points to the same location as 
SD_CLIENT2008HOME does. 

DO NOT change this environment variable.
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5 Upgrading Client 2008
This chapter describes the mechanism for upgrading the Client 2008 major release to future 
Client 2008 service packs.

Client 2008 is upgraded through service packs. The Client 2008 service packs will be included 
in the Service Desk 4.5 official service packs.

The previous client cannot be upgraded to Client 2008 with this mechanism. You must remove 
the previous client, and then install Client 2008.

There are two approaches available to upgrade Client 2008:

• Client 2008 Remote Updater

• Client 2008 Service Pack installation package

Upgrading Client 2008 Using Remote Updater

You can configure the Remote Updater on a Windows system and create an update site on 
either a Windows or a UNIX system. 

Overview of the Remote Updater

The Remote Updater is the upgrade mechanism for Client 2008. It is an optional component 
containing an update site where Service Desk 4.5 Windows clients can check for software 
updates, an update tool, and remote updater settings in the Administrator console. 

The Update Site

An update site contains features and plugins available for upgrading Client 2008. The 
following is a sample directory structure for the update site:

Client 2008 can check for software updates on startup automatically, or you can start the 
upgrade manually. Whoever performs the upgrade must have write rights to the 
<Client_HOME_DIR>\plugins and <Client_HOME_DIR>\features directories on the 
machine where Client 2008 is being upgraded.
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• site.xml - The configuration xml file for the update site, defines available features 
supported by the update site.

• features directory - Contains available features.

Feature is the update unit for the update site. The update site only supports installation 
by features. A feature can include multiple plug-ins. Currently, the update site supports 
two features:

As shown in the above figure, the package names contain feature ID and version 
information. The version information includes Service Desk version, Service Desk service 
pack version, and minor versions of service pack. The Service Desk version is not 
replaceable. Service packs version information vary with future service packs releases. 

• plugins directory - Contains plugins included in the available features.

The Update Tool

Client 2008 provides a convenient update tool for users who have write permission to the 
<Client_HOME_DIR>\plugins and <Client_HOME_DIR>\features directories, so that 
local users can upgrade Client 2008 without having to log into the Service Desk or having the 
account in the Service Desk. 

The update tool is in the <Client_HOME_DIR>\updatetool.exe directory. It supports 
updating hotfix and the service pack via the command line mode. 

You can also access the update tool function through the client Help menu by clicking Help → 
Update.

You can find more information about the update tool in the following sections.

The Remote Updater Settings

The settings for the remote updater include two parts in the General Settings window 
(accessible from View → Administrator console → hp OpenView service desk → System panel → 
General Settings): 

Table 2 Features Supported by the Update Site

Feature Name Feature ID

Service Pack com.hp.servicepack.feature

Hotfix com.hp.hotfix.feature
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• URL of Latest Software Version setting in the General tab. You can define the update site 
URL here. 

• The settings in the Remote Updater tab. You can choose to upgrade Client 2008 
automatically or manually. 

Preparing the Remote Updater

On startup, Client 2008 connects to the update site to get the latest software updates. Before 
Client 2008 can use the Remote Updater, you must configure the update site on a web server. 
The recommended web servers include:

• Apache

• Microsoft Internet Information Services (IIS)

To prepare the Remote Updater, you need to create an update site using Apache or IIS server. 

Install the Update Site 

• Download the latest Apache http server from website http://httpd.apache.org/. Follow 
the Apache installation guide to install the Apache software.

• Install the Microsoft IIS Server. You can get the latest Windows Internet Information 
Services (IIS) information and documents from http://www.microsoft.com/
WindowsServer2003/iis/default.mspx.

Check related documents for IIS information, for example, IIS 6.0 Deployment Guide and 
IIS 6.0 Operations Guide. 

Configure the Update Site

Task 1: Create a virtual root (web shared folder)

On Apache

1 Modify httpd.conf file to configure Apache Server.

Modify the httpd.conf file to add a virtual directory for the update site on Apache 
Server: 

Alias /updatesite "C:/servicedesk/updatesite"

<Directory " C:/servicedesk/updatesite ">
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
Allow from all

</Directory>

2 Verify and ensure the update site URL is working on Apache Server, for example, http://
localhost/updatesite.

Lower versions of IIS can also be used.

Apache HTTP Server also works on HP-UX and Solaris. The above configuration 
method also applies to these systems.
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On Window IIS Server

1 Add a virtual directory in the IIS Server.

a Go to Start → Control Panel → Administrative Tools → Internet Information Services, in the 
Internet Information Services window that appears, expand the node for local 
computer → Web Sites → Default Web Site. 

b Right-click Default Web Site. In the pop-up menu, click New → Virtual Directory. The 
Virtual Directory Creation Wizard displays. Click Next. 

c In the Virtual Directory Alias page of the Wizard, enter updatesite in the Alias 
field. Click Next.

d In the Web Site Content Directory page of the Wizard, enter 
C:\servicedesk\updatesite in the Directory field. click Next. 
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e In the Access Permissions page of the Wizard, select the Read check box, and then 
click Next. 

f Click Finish.

2 Verify that the update site URL is working on the IIS server. For example, http://
localhost/updatesite.

 

Task 2: Copy the upgrade package to the virtual root

The upgrade service JAR package is provided in the Service Desk 4.5 Service Packs (SP24 or 
later). Copy the update site directory in the Client 2008 service package to the directory 
shared for the virtual directory for your update site. 

Task 3: Configure the Remote Updater configuration file

The configuration file site.xml for the update site is present in the virtual directory. It 
defines available features supported by the update site. 

Normally you do not need to configure the update site xml file. But if you do need to modify 
the xml file for a specific hotfix version, read the following information:

The site.xml file is used to configure the update site JAR packages. The following is a 
sample:

<?xml version="1.0" encoding="UTF-8"?>
<site>
   <feature url="features/com.hp.hotfix.feature_45.24.0.jar" 
id="com.hp.hotfix.feature" version="45.24.0">

When using IIS Server as the update site, sometimes the Remote Updater throws 
a NullPointerException when updating through Help → Update. It may be caused 
by the connection limitation in the IIS Server. 

It is recommended to disable HTTP Keep-Alives Enabled setting in the IIS Server: 
go to Start → Control Panel → Administrative Tools → Internet Information Services, in 
the Internet Information Services window that appears, expand the node for local 
computer → Web Sites → Default Web Site, right click the node and choose 
Properties, uncheck the HTTP Keep-Alives Enabled option. 

If you encounter any issue, see related IIS documents for troubleshooting 
information, for example, IIS 6.0 Deployment Guide and IIS 6.0 Operations Guide.
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      <category name="Service Desk Product"/>
   </feature>
   <feature url="features/com.hp.servicepack.feature_45.24.0.jar" 
id="com.hp.servicepack.feature" version="45.24.0">
      <category name="Service Desk Product"/>
   </feature>
   <category-def name="Service Desk Product" label="Service Desk Product 
Updates"/>
</site>

Task 4: Validate the URL 

You can try to access the site.xml file directly through an IE browser. For example, enter an 
address similar to the following one, in the IE browser:

http://localhost/site.xml.

Upgrade Client 2008 Using the Remote Updater 

There are three methods for downloading the software upgrade packages using the remote 
updater:

• Automatic Upgrading During Client 2008 Startup

• Manual Upgrading Using the Remote Updater

• Upgrading Using the Update Tool 

Automatic Upgrading During Client 2008 Startup 

If you have write permission to the <Client_HOME_DIR>\plugins and 
<Client_HOME_DIR>\features directories, Client 2008 can upgrade the service pack and 
hotfix automatically:

1 Enable the Remote Updater in Client 2008 settings.

a Start Client 2008. 

b Enable the service pack and hotfix.

Go to View → Administrator console → hp OpenView service desk → System panel → 
General Settings. The General Settings window appears.

If you want to modify com.hp.hotfix.feature section to deploy a hotfix, please 
refer to the ReadMe file delivered with the hotfix. 

Do NOT modify the com.hp.servicepack.feature section of the xml file.
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Click Remote updater tab, select the Enabled checkbox for both Service pack and Hot 
fix, and then click Apply. 

In the Remote updater tab, activate or deactivate the remote updater functionality for 
service pack and/or hot fix.

c Provide the URL to the update site. 

Click General tab in the General Settings window. In the URL of Latest Software Version 
field, provide the update site URL for a service pack or a hot fix. The URL must be the 
exact Update Site URL without any extra information. 

If the Enabled checkbox for service pack or Hot fix is not selected, Client 2008 will 
not be upgraded automatically during the startup. You can still upgrade the Client 
manually using the Remote Updater available from Help → Update in Client 2008.
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2 Stop Client 2008, and then restart it.

The service pack and hotfix are downloaded and installed automatically when Client 2008 
starts up. 

Manual Upgrading Using the Remote Updater 

If you do not want the hot fix or service packs to be installed automatically, you can use the 
Remote Updater in the Help menu to upgrade the client manually. Below is an example of 
upgrading to Client 2008 service pack 24.

1 Start Client 2008.

2 Go to Help → Update. The Remote Updater checks the update site for the latest software 
updates. 

3 If the update site configuration is correct, the Install - Search Result window opens. Make 
sure to always select the Show the latest version of a feature only checkbox and select all 
checkboxes under the Service Desk updates site. Click Next.

If you selected the Enable checkbox for service pack and hot fix in the General Settings → 
Remote updater, Client 2008 can check the Update Site when it starts up. However, this 
impacts the Client login time. You can add a parameter in the Client shortcut to ignore this 
upgrade during the logon time. 

Servicedesk /DISABLEUPGRADE
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4 In the Install - Feature License window, select I accept the terms in the license agreement 
and click Next.

5 In the Install - Installation window, click Finish.
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6 In the Feature Verification window, click Install All.

7 After the installation, the Install/Update window pops up. Click Yes.

Upgrading Using the Update Tool 

The update tool is present in <Client_HOME_DIR>\updatetool.exe directory. It supports 
updating hotfix and service pack via the command line mode. You can run the update tool 
with the following command:

UpdateTool [options]

For example:

UpdateTool -SDSERVER=localhost -LOGFILE=UpdateTool.log -INSTALL

UpdateTool -URL=http://localhost -LOGFILE=UpdateTool.log -INSTALL
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Options available for the update tool are listed in Table 3. 

For detailed information about the update tool log, see Update Tool Log Information on 
page 50.

Table 3 UpdateTool Options

Option Parameter Sample Value Description

[-HELP] -HELP Displays help information.

[-SDSERVER=<servername>] -SDSERVER=localhost Service Desk server name. 
The update tool gets the update site 
URL (URL of Latest Software Version) 
through the Service Desk 
application server specified by this 
parameter. 

[-FEATUREID=<featureid>{,
<featureid>,...}] 

If this parameter is not specified, 
all available features are searched 
and installed by the update tool.

[-URL=<url>] -URL=http://localhost URL for the update site. 
If both SDSERVER and URL are 
specified, the SDSERVER parameter 
is ignored.

[-LOGFILE=<filename>] -LOGFILE=UpdateToo
l.log

Log file name.
If this parameter is not specified, 
the output information is shown in 
the current command line window.

[-INSTALL] -INSTALL Installs available plug-in(s).
If this parameter is not specified, 
by default the update tool queries 
all available features or packages 
that can be updated. All 
information of update packages is 
logged into the log file you specified 
through the -LOGFILE parameter.
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Upgrade Using Service Pack Installation Package

Preparing for Client 2008 Upgrade

You should have the local system right to install and upgrade the Client 2008 Service Pack. 

You can upgrade Service Desk clients from the following sources:

• Shared folder installation

If you upgrade the Client 2008 Service Pack from a shared folder, you start the client 
installation program from each Service Desk client computer by accessing a shared folder 
on either the Service Desk application server machine or elsewhere on the network.

• Hyperlink installation

If a Web server is available, you can place the client installation program on the Web 
server. Alternatively, you can place the client upgrade program in a shared folder. By 
making the URL available in Service Desk, users can upgrade the client using the 
intranet.

Preparing for Shared Folder Upgrade

You can upgrade each client directly from a shared folder on the network.

To upgrade Service Desk clients from a shared location, copy the complete contents of the 
Client 2008 Service Pack to the shared folder you want to use to upgrade the clients. The 
client must have access rights to the folder.

Preparing for Hyperlink Upgrades

If Client 2008 is connected to an upgraded database, Client 2008 displays an error message 
with a hyperlink when a mismatch is found between the server and client version numbers. If 
the users click the hyperlink, the Service Desk client is upgraded. To make the hyperlink 
work, you have to make the following preparations.

To install the Service Desk client from a hyperlink, copy the contents of the html page folder 
to a folder in a Web server or to a shared folder. Also copy the complete contents of the Client 
2008 Service Pack to the Web server or to the shared folder you want to use.

You must upgrade at least one client using a shared folder. This client is needed for the 
Service Desk administrator to set the hyperlink.

To make the location of the Service Desk client upgrade installation program available in the 
error message, follow these steps:

1 Using an administrator account, start a client that was upgraded using a shared folder.

The Client 2008 Service Pack is distributed with the SDSK file released on the HP Patch 
Portal.

If you want to use hyperlink installation with a shared folder, you must make sure that all 
Service Desk users have access to the folder.
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2 Start the client by going to Start → All Programs → HP OpenView Service Desk 4.5 Client 2008 
→ Client 2008.

3 In the Client 2008 interface, click View → Administrator console → Hp OpenView service desk 
→ System Panel → General Settings. The General Settings window displays.

4 In the URL Of The Latest Software Version text box, type the path and file name of the 
.exe file.

— If you use a Web server to make the file available, type a URL for the http protocol, for 
example:

http:\\mywebserver\client\Client2008.msp

In this example mywebserver\client is the name of your Web server and location 
where you copied the client upgrade file.

— If you use a shared folder to make the file available, type a URL for the file transfer 
protocol, for example:

file:\\myfileserver\myshare\Client2008.msp

In this example myfileserver\myshare specifies your file server and shared folder 
where you copied the client upgrade files.

When a user starts Client 2008 after the Service Desk application server is upgraded, a 
message is shown supplying a hyperlink to the client upgrade installation program. 

Upgrading Service Desk Clients

You can upgrade Client 2008 either directly from a shared folder, or via a hyperlink that 
points to a Web server.

To upgrade Client 2008 from the share folder, follow these steps:

1 Remove the old client installation using Start → Control Panel → Add or Remove Programs.

2 Install the client as normal application.

The Service Desk client can be installed silently by running setup.exe /S /v/qn from the 
Command Prompt in the client folder. This command works for Windows 2000, Window XP 
and Window Vista.
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6 Removing Client 2008
  
This chapter describes the tasks to remove the Client 2008 software completely from your 
system, including the removal of files and components residing in local systems. It also lists 
the files that will not be removed.

Removing Client 2008

To remove Client 2008, go to Start → All Programs → HP OpenView Service Desk 4.5 Client 2008 → 
Uninstall Client 2008, then click Yes. 

You can also go to Start → Control Panel → Add or Remove Programs, from the list of currently 
installed programs, select HP OpenView Service Desk 4.5 Client 2008, then click Remove.

Files That Will Not Be Removed During Uninstallation

The uninstallation program can only uninstall files that were included in the original 
installation. See the following sections for information on specific files that we recommend 
you do not manually. 

Files Not Removed During Uninstallation of Client 2008

Variable settings files for the server, such as cache, configuration settings, log files, and 
service packs are not removed by the uninstallation program. These can be removed 
manually.

The following folders in the Client 2008 installation directory (<user_home>\Application 
Data\Hewlett-Packard\OpenView\Service Desk\Client 2008\) are not removed:  

clientsettings
configuration
data
updatetool
workspace

They can be removed manually after Client 2008 is removed.
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A Troubleshooting
This section discusses problems that could occur and prevent you from running Client 2008 or 
connecting to the server. When you start the Service Desk Client GUI/console, you can consult 
the Online Help to troubleshoot problems that occur while using Service Desk Client.

Troubleshooting the Installation

Ideally, we would hope that your installation of Client 2008 is completed without 
complications. However, Client 2008 is a finely tuned product and sometimes minor variations 
of hardware or software configuration can cause unexpected results. This section contains a 
number of possible problem scenarios and suggestions for their resolution. 

The list of issues discussed here is by no means comprehensive. If you have a problem not 
addressed in this section, or a problem that persists even when the solutions given here have 
been tried, go to the HP Software Support Web site at http://www.hp.com/go/
hpsoftwaresupport and follow the link for how to get software support in your region.

Reinstalling after Cancelling an Installation

If you cancel the installation process on Windows the installation program removes the 
components already installed before clicking Cancel. A dialog box is displayed showing the 
progress of the uninstallation. Data is retained by Windows and it remembers you have once 
attempted to install Client 2008.

When you then reinstall Client 2008 a screen is displayed enabling you to choose how the 
installation should continue, select an option:

• Modify will display the custom installation screen, enabling you to select components to 
install.

• Repair will continue with a typical installation, replacing all missing and corrupted files 
with clean files from the installation package.

• Remove will completely remove the Client from the computer:
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Unable to Connect to Server on a Windows Platform

If, when you start Service Desk, you are unable to connect to the server, check that the 
installation is complete. For instance, after you have installed the application server, you 
should run the database configuration wizard to set up the database. Without an Oracle or 
SQL Server database installed and configured, Service Desk will not work. 

If you are confident that all the steps of the installation process were done, try to find out if 
the installation was error-free. To do this, check the logserver.txt file located in the 
Service Desk home folder and logclient.txt file located in the user’s Windows profile. 
These files may give information about the cause of the problem. For example, there might be 
a message about different versions of the database and server.

Restore Customized View Settings from the Previous Client

In Client 2008, you can restore and reuse the customized view settings stored in the previous 
client. 

To restore the settings, perform the following steps:

1 Stop Client 2008 if it is running.

2 Locate the Views.DAT file, and copy it into the <Client 2008 data folder>.

The Views.DAT file can be found at the following location:

<Previous Client Data folder>\Views.DAT

For example, C:\Documents and Settings\<user name>\Application 
Data\Hewlett-Packard\OpenView\Service Desk\Views.DAT

3 Restart Client 2008.
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Troubleshooting the Configuration

Support Tools

• sd_clientsupporttool.bat

This support tool is present in <Client_HOME_DIR>\bin directory.

The functionality of this tool is the same as that in the previous client. It creates 
<Client_HOME_DIR>\support folder with a zip file which contains the logs and cache 
file. 

• Debug Client startup parameter

servicedesk.exe /Debug

This parameter enables more debug information to be stored into the <User Data 
folder>log\logclient.txt file.

Optimizing Performance

Limitation on Numbers of Opened Forms

Client 2008 uses the Eclipse technology. Compared to the previous client, Client 2008 
consumes more resources such as user objects and GDI objects. For example, let’s assume that 
you can open 15 forms at the same time for normal use on the Service Desk demo database. 
Then with the previous client, you can open 20 forms at the same time if the form cache is 
enabled. 

Therefore, it is recommended to remove some unnecessary fields in the forms to save 
resources.

Optimize Login Time

Ignore Update Site Checking

If you enabled the Hot fix checkbox in Administrator console → hp OpenView service desk → 
System panel → General Settings → Remote updater, Client 2008 checks the update site during 
client startup time. 

Run the following command line to ignore checking update site:

servicedesk.exe /DISABLEUPGRADE

The sd_clientsupporttool.bat support tool only packages the <Client 2008 
Data Folder>  which is specified in the user_settings.xml. It does not contain 
the following directories: 

clientsettings
configuration
updatetool
workspace
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Optimize Table View Performance

The Table view in Client 2008 is slower than in the previous client. Client 2008 is 
implemented using Eclipse technology. The Table view component in Eclipse differs from the 
previous client, if there are many entries in the Table view. The Table view in the previous 
client was implemented using ActiveX technology, which is more efficient.

Use the following approaches to optimize the Table view performance:

• Query Restriction

This is a very important method to improve performance. The entries in the Table view 
should not exceed 2000. Client 2008 demonstrates a similar Table view performance to 
the one in the previous client.

• Reduce the Sort Columns

Sorting takes a lot of time. If there are two or more columns sorted in the Table view, it 
takes much more time for the Table view to refresh. It is recommended to reduce the 
number of sorted columns.

• Set the Group by to collapse all as the default style

Performing the Group by operation takes more time to refresh the Table view. It is 
recommended to set the Group by to collapse all as the default style. Then you will be able 
to select the entries of your choice by expanding a specific category.

• Reduce the number of columns

Remove unnecessary columns from the Table view. It will save time to construct the cells 
in the Table view.

• Set a specific width for Fields 

Set specific widths for the fields (accessible from View Summary → Fields → Format → 
Format Fields). This will reduce the column width calculation during refreshing the Table 
view.
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• Reduce Auto Format rules and conditions

It is recommended to reduce the Auto Format rules and conditions (accessible from View 
Summary → Auto Format → Auto Format) to improve the performance.

Log Information

Client Log Files

Client 2008 uses Eclipse technology. It provides two types of log files that you can use to check 
for errors:

• <User Data folder>\log\logclient.txt

This is the formal Service Desk Client log file. Usage of this log file is the same as in the 
previous client.

• <User workspace folder>\.metadata\.log 

This type of log file is used by the Eclipse environment. It stores Eclipse Framework 
information, such as application startup parameter and exception in the Eclipse 
Framework.

......

java.version=1.5.0_14

java.vendor=Sun Microsystems Inc.

BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=zh_CN

Framework arguments:  -application com.hp.sd.eclipse.application -product 
com.hp.sd.eclipse.servicedesk

Command-line arguments:  -os win32 -ws win32 -arch x86 -application 
com.hp.sd.eclipse.application -clean -product com.hp.sd.eclipse.servicede

......

Some major exceptions can be redirected into logclient.txt using the following 
command:
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servicedesk.exe /Debug

Update Tool Log Information

• No Available Features

This log entry means there is no available features to install based on the currently 
installed plug-ins of the client.

• Available Feature: "Hotfix Feature"  Version: 
"com.hp.hotfix.feature_45.24.0"
Available Feature: "Service Pack Feature"  Version: 
"com.hp.servicepack.feature_45.24.0"

These logged messages show the available features that can be installed on the current 
client.

• Network connection problems encountered during search.

This log entry means that the update site URL is not available or incorrect.

• Unable to connect to host:..

This log entry means the Service Desk server on the host specified by the -SDSERVER 
parameter is not accessiable.

• java.net.UnknownHostException:...

The log entry means the host name specified by the -SDSERVER parameter is not 
accessible.

• Installed Feature: "Hotfix Feature"  Version: 
"com.hp.hotfix.feature_45.24.0"
Installed Feature: "Service Pack Feature"  Version: 
"com.hp.servicepack.feature_45.24.0" 

These logged messages show the features that have been successfully installed on Client 
2008 by the update tool.
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