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Documentation Updates

The title page of this document contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

• Software Release Date, which indicates the release date of this version of the software.

To check for recent updates, or to verify that you are using the most recent edition of a 
document, go to:

http://h20230.www2.hp.com/selfsolve/manuals 

This site requires that you register for an HP Passport and sign-in. To register for an HP 
Passport ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

Or click the New users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product 
support service. Contact your HP sales representative for details.
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Support

Visit the HP Software Support web site at:

http://www.hp.com/go/hpsoftwaresupport 

This web site provides contact information and details about the products, services, and 
support that HP Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and 
efficient way to access interactive technical support tools needed to manage your business. As 
a valued support customer, you can benefit by using the support web site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many 
also require a support contract.  To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html 

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp 



5

Table of Contents

Welcome to This Guide .........................................................................7
How This Guide Is Organized ...............................................................8
Who Should Read This Guide ...............................................................8
HP Release Control Documentation .....................................................8
Additional Online Resources.................................................................9

Chapter 1: Installing and Deploying HP Release Control...................11
The Deployment Process: Basic Steps..................................................12
Before You Install ................................................................................13
Installing HP Release Control..............................................................18
Configuring the Database or User Schema .........................................19
Launching HP Release Control ...........................................................21
Configure the HP Release Control Server ...........................................23
Configuring the HP Universal CMDB.................................................24
Configuring the Service Desk Integration...........................................25
Working with HP Release Control Configuration Settings ................59

Chapter 2: Upgrading HP Release Control .........................................63

Index....................................................................................................79



Table of Contents

6



7

Welcome to This Guide

Welcome to the HP Release Control Deployment Guide, which explains how to 
install and deploy HP Release Control software and how to upgrade to the 
latest version. HP Release Control provides a common platform of decision 
support for Change Advisory Board members and implementation teams 
during the release life cycle. HP Release Control analyzes each change 
request in the system and provides real-time information and alerts during 
implementation. In addition, HP Release Control enables collaboration, 
feedback, and review throughout the release life cycle. 

This chapter includes:

➤ How This Guide Is Organized on page 8

➤ Who Should Read This Guide on page 8

➤ HP Release Control Documentation on page 8

➤ Additional Online Resources on page 9
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How This Guide Is Organized

This guide contains the following parts:

Chapter 1 Installing and Deploying HP Release Control

Provides instructions on how to install and deploy HP Release Control.

Chapter 2 Upgrading HP Release Control

Provides instructions on how to upgrade to the latest version of HP Release 
Control.

Who Should Read This Guide

This guide is intended for the HP service engineers who are responsible for 
installing and deploying or upgrading HP Release Control.

HP Release Control Documentation

HP Release Control comes with the following documentation:

HP Release Control Deployment Guide explains how to install and deploy 
HP Release Control. This guide is accessible in the following formats, from 
the following locations:

➤ in PDF format on the HP Release Control DVD

➤ in PDF format by selecting Help > HP Release Control Documentation 
Library from the HP Release Control application

HP Release Control User Guide explains how to use and configure the 
HP Release Control application. This guide is accessible in the following 
formats, from the following locations:

➤ in PDF format on the HP Release Control DVD

➤ in both PDF format and online HTML help format by selecting 
Help > HP Release Control Documentation Library from the HP Release 
Control application
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➤ in HTML help format, from specific HP Release Control application 
windows, by clicking in the window and pressing F1, or by selecting Help 
from the main menu

HP Release Control API Reference explains how to work with HP Release 
Control’s API. The API Reference is available in CHM format on the 
HP Release Control DVD, or from the HP Release Control application by 
selecting Help > HP Release Control Documentation Library.

HP Release Control Readme provides information on what’s new in the 
current version of the product as well as comprehensive information on 
known problems and limitations. The Readme is available in HTML format 
on the HP Release Control DVD, or from the HP Release Control application 
by selecting Help > HP Release Control Documentation Library.

Note: Anything published in PDF format can be read and printed using 
Adobe Reader, which can be downloaded from the Adobe Web site (http://
www.adobe.com).

Additional Online Resources

HP Software Support accesses the HP Software Support Web site. This site 
enables you to browse the Self-solve knowledge base. You can also post to 
and search user discussion forums, submit support requests, download 
patches and updated documentation, and more. Choose Help > HP Software 
Support. The URL for this Web site is www.hp.com/go/hpsoftwaresupport.

Most of the support areas require that you register as an HP Passport user 
and sign in. Many also require a support contract.

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp

http://www.adobe.com
http://www.adobe.com
http://www.hp.com/go/hpsoftwaresupport
http://h20230.www2.hp.com/new_access_levels.jsp
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To register for an HP Passport user ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

HP Software Web site accesses the HP Software Web site. This site provides 
you with the most up-to-date information on HP Software products. This 
includes new software releases, seminars and trade shows, customer support, 
and more. Choose Help > HP Software Web site. The URL for this Web site 
is www.hp.com/go/software.

http://h20229.www2.hp.com/passport-registration.html
http://www.hp.com/go/software
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1
Installing and Deploying HP Release 
Control

This chapter provides instructions on how to install and deploy HP Release 
Control.

This chapter includes:

➤ The Deployment Process: Basic Steps on page 12

➤ Before You Install on page 13

➤ Installing HP Release Control on page 18

➤ Configuring the Database or User Schema on page 19

➤ Launching HP Release Control on page 21

➤ Configure the HP Release Control Server on page 23

➤ Configuring the HP Universal CMDB on page 24

➤ Configuring the Service Desk Integration on page 25

➤ Working with HP Release Control Configuration Settings on page 59
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The Deployment Process: Basic Steps

This following diagram describes the basic steps involved in getting your 
HP Release Control environment up and running:

Run the installation
 "Installing HP Release Control" on page 18

Set up the database
"Configuring the Database or User Schema" on page 19

Configure HP Universal CMDB related settings
"Configuring the HP Universal CMDB" on page 24

Configure the service desk
"Configuring the Service Desk Integration" on page 25

Review pre-installation information
 "Before You Install" on page 13

Launch HP Release Control
 "Launching HP Release Control" on page 21

Configure the HP Release Control server
 "Configure the HP Release Control Server" on page 23
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Before You Install

Before you install HP Release Control, review the information in this 
section, including the system requirements. This section includes:

➤ "Supported Service Desks" on page 13

➤ "Server System Requirements" on page 15

➤ "Client Requirements" on page 16

➤ "HP Release Control Advanced Deployment Options" on page 16

➤ "HP Release Control Data Flow" on page 17

➤ "System Architecture" on page 18

Supported Service Desks
The Service Desk Integration module supports the following service desk 
applications:

Application Version

HP Project and Portfolio Management/
Mercury IT Governance Center

➤ 6.0 SP 14 

➤ 7.1 SP6 

➤ 7.5 SP2 

➤ 8.0

HP Service Manager/Center ➤ 6.2.x

➤ 7.0

➤ 7.01 with IIA

➤ 7.10

➤ 7.11

HP Server Automation 7.1 (See readme limitations)

HP Network Automation 7.0 (See readme limitations)

HP Service Desk 4.5

BMC Remedy Action Request System ➤ 5.0

➤ 7.0
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Feature Availability per Service Desk

Certain HP Release Control features are only available when you integrate 
with certain service desk applications. The following table describes these 
features and specifies their availability per service desk. Service desks that are 
not listed in this table do not include these features. 

Note: SM = HP Service Manager, SC = HP ServiceCenter, and PPM = 
HP Project and Portfolio Management / Mercury IT Governance Center

Feature SM SC PPM

Update Approval status. Approval of a change request in the 
Analysis module Collaborate > Resolution tab, results in an 
updated status of the request within the service desk. 

yes yes yes

Retract approval. Retracting approval of a change request in the 
Analysis module Collaborate > Resolution tab, results in an 
updated status of the request within the service desk.

yes yes no 

Update planned times. After you run a simulation in the 
Analysis module Change Planner, you can save the updated 
start and end times to the originating service desk.

yes yes no

Update actual times. In the Director and Implementor 
modules, you can update the actual start and end time of an 
activity. These times are automatically updated in the 
originating service desk ticket.

yes yes no

Update Post Implementation Review. The data that you update 
in the Post Implementation Review dialog box in the Review > 
Conclusions tab is updated in the origination service desk.

yes yes no

Closing Tickets from HP Release Control. You can close service 
desk tickets from the Analysis module Review > Conclusions 
tab. 

yes yes no

Update analysis information. The originating service desk ticket 
is updated with analysis information from HP Release Control 
(for example risk level and impact analysis)

yes 

(requires 
configuration)

no no
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Server System Requirements
The following table describes the system requirements for the HP Release 
Control server:

CPU Intel Pentium 4

Memory (RAM) Minimum of 2 GB

Free Disk Space Minimum of 5 GB

Machine
➤ VMware

➤ Physical

Operating System

The following 32/64-bit Windows operating 
systems are supported:

➤ Windows 2003 Server Enterprise Edition 
Service Pack 2

➤ Windows Server 2008

Database

➤ Microsoft SQL Server 2005 SP2; 
2005 Compatibility Mode 80;
(Enterprise Editions for all)

➤ Oracle 9.2.0.8, 10.2.x, 11.1.x 

HP Universal CMDB

➤ HP Universal CMDB version 7.0x, 7.5x, 8.0x 
(Typical CMDB Installation)

For a full list of system requirements for each of 
these versions, refer to the HP Universal CMDB 
documentation.
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Client Requirements
The following table describes the client requirements for viewing HP Release 
Control:

HP Release Control Advanced Deployment Options
In addition to the regular deployment, HP Release Control can also be 
deployed with the following options: 

➤ Cluster deployment. HP Release Control can be deployed on multiple 
nodes. For details, refer to the section about setting up a cluster 
deployment in the HP Release Control User Guide. 

Browser

➤ Microsoft Internet Explorer 6.0, 7.0.

Note: It is recommended to set Internet 
Explorer to check for newer versions of stored 
pages every time you visit the page. For 
example, in version 6.0, select Tools > 
Internet Options > General tab. In the 
Temporary Internet files area, click Settings 
and select the Every visit to the page option.

➤ Mozilla Firefox 3.x 

Note: You cannot view the HP Universal 
CMDB user interface components with 
Firefox. 

Flash Player Browser Plugin Flash Player 9 or above

Screen Resolution
➤ Minimum 1024x768

➤ Recommended 1280x1024

Color Quality

Minimum of 16 bit

Note: If you are logging on to the HP Release 
Control server through a remote connection, 
ensure that the Remote Desktop color display 
setting is set to a minimum of 16 bit.
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➤ Web servers. You can configure HP Release Control to work with a Web 
server (Microsoft Internet Information Services (IIS) 5.x or 6.x or Apache 
HTTP Server 2.2.x). For details, refer to the section about configuring a 
Web server in the HP Release Control User Guide.

➤ Identity management. You can configure HP Release Control to work 
with a third party identity management solution such as CA SiteMinder. 
For details, refer to the section about identity management in the 
HP Release Control User Guide.

HP Release Control Data Flow
The following diagram illustrates the data flow when running HP Release 
Control:

➤ Change requests originate in the Service Desk application and are 
converted into generic requests.
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➤ HP Release Control sends the requests to HP Universal CMDB for analysis 
and to determine the relationships between configuration items (CIs).

➤ HP Release Control takes the data from HP Universal CMDB and performs 
impact analysis.

➤ HP Release Control further analyzes change requests, performing 
calculations such as risk and collision analysis.

➤ The information is stored on the HP Release Control Database Server. 

➤ Email notifications are sent according to configuration settings to 
decision makers, and changes are approved or rejected.

System Architecture
HP Release Control is a 3-tier application which consists of following:

➤ Flash-based (fat) client, accessed using a Web browser

➤ Application servers

➤ Database servers

The database servers and the HP Release Control application servers must sit 
on the same LAN.

Installing HP Release Control

You install HP Release Control using the InstallShield Wizard for HP Release 
Control.

To install HP Release Control:

 1 Click the setup.exe file located in the Setup folder of your HP Release 
Control installation disk. The InstallShield Wizard for HP Release Control 
opens. Click Next.

 2 Accept the terms of the software license agreement that is displayed. Click 
Next.
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 3 Accept the default installation directory or click Browse to select a 
different directory. Note that the directory you select cannot contain 
spaces. Click Next.

 4 Ensure that the information in the summary screen is correct.

To review or change any settings, click Back. To accept the settings and 
begin installing HP Release Control, click Next.

 5 When the installation process has successfully been completed, click 
Finish in the final InstallShield Wizard screen.

Note: If you are in the middle of performing the upgrade procedure, 
continue with step 2 of "Stage 2: Install and Upgrade HP Release Control" 
(see page 65).

Configuring the Database or User Schema

To work with HP Release Control, you must create either a Microsoft SQL 
Server database or an Oracle Server user schema. You then configure 
connection properties for the HP Release Control database or user schema 
using the Database Configuration Wizard.

Note: For MS SQL Server and Oracle Server system requirements, see "Server 
System Requirements" on page 15.

For information and guidelines about configuring and maintaining MS SQL 
and Oracle Server databases, see the section about database configuration 
and maintenance in the HP Release Control User Guide.

To configure your database:

 1 Allocate a Microsoft SQL Server database or an Oracle Server user schema. 
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➤ For MS SQL Server 2005: Activate snapshot isolation.

 Execute the following command once after creating the database:

For more information about the SQL Server snapshot isolation feature, 
see http://msdn.microsoft.com/en-us/library/tcbchxcb(VS.80).aspx.

➤ For Oracle: Grant the Oracle user only Connect and Resource roles. 
(Populate will fail if the Oracle user has the Select any table privilege.)

 2 Verify the following information, which you will need during this 
configuration process:

 3 Before you run the Database Configuration Wizard, consider the 
following:

➤ Advanced configuration options. If you select the advanced 
configuration option in the wizard, you can specify advanced database 
properties, such as minimum and maximum pool size. For more 
information about these options, see http://www.mchange.com/projects/
c3p0/index.html#configuration_properties

➤ MS SQL URL. If you select the advanced configuration option in the 
wizard, you need to specify the connection URL of the JTDS MSSQL. 
Include a valid MS SQL server name and database name. 

For example:

alter database <ccm_database_name> set read_committed_snapshot on

✔ Required Information

DB host name and port

DB user name and password

For MS SQL: Database name

For Oracle: SID

jdbc:jtds:sqlserver://myServer:1433/
myDataBase;sendStringParametersAsUnicode=false

http://msdn.microsoft.com/en-us/library/tcbchxcb(VS.80).aspx
http://www.mchange.com/projects/c3p0/index.html#configuration_properties
http://www.mchange.com/projects/c3p0/index.html#configuration_properties
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For details about configuring the URL format, see http://
jtds.sourceforge.net/faq.html#urlFormat

➤ Oracle URL. If you select the advanced configuration option in the 
wizard, you need to specify the connection URL of the Oracle native 
driver. Include a valid Oracle server name and SID. Alternatively, if you 
are using Oracle RAC, specify the Oracle RAC configuration details.

➤ Password Encryption. In the configuration page of the wizard, it is 
recommended to select the Encrypt Password option to encrypt your 
password in the database properties file. 

 4 Run the Database Configuration Wizard by selecting Start > Programs > 
HP Release Control 5.00 > Database Configuration Wizard.

Note: If you are in the middle of performing the upgrade procedure, 
continue with step 4 of "Stage 2: Install and Upgrade HP Release Control" 
(see page 65).

 5 When you complete the database configuration, populate the database as 
follows:

Change the command line directory to <HP Release Control installation 
directory>\bin and run the following command:

Launching HP Release Control

This section describes how to launch HP Release Control.

To launch HP Release Control:

 1 If you are using an Apache Web server, restart your Web server.

 2 Start the HP Release Control service.

 a From the Windows menu, select Start > Run and type services.msc.

Populate.bat i

http://jtds.sourceforge.net/faq.html#urlFormat
http://jtds.sourceforge.net/faq.html#urlFormat
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 b In Services window, select HP ReleaseControl 5.00 <server name> and 
click Start Service.

Note: It may take a few minutes for the server to complete the start-up 
process.

 3 Enter the appropriate URL to access HP Release Control (depends on the 
user authentication mode you are using). For example:

 4 Log in to HP Release Control with the user name admin and the password 
admin. Ensure that you change this password once you log in. For details 
on changing your password and creating HP Release Control users, see the 
section about configuring users in the HP Release Control User Guide.

Note: If you are working with HP Release Control’s identity management 
solution or LDAP authentication, see the section about security 
configuration in the HP Release Control User Guide for details on adding an 
administrator and users to HP Release Control.

http://server:8080/ccm
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Configure the HP Release Control Server

This section describes how to configure the HP Release Control server.

 1 Log on to HP Release Control (See "Launching HP Release Control" on 
page 21).

 2 Select Module > Administrator > Configuration > Server and define the 
following settings in the Server pane:

 3 Save a draft of your configuration set. (See "Saving a Draft Configuration 
Set" on page 60.)

UI Elements Description

Server name Enter the server’s Fully Qualified Domain Name (FQDN).

Note: 

➤ Do not use the default value localhost or the IP address.

➤ If you cluster two or more HP Release Control servers 
behind a load balancer, specify the domain name of the 
load balancer.

Server address Specify the HP Release Control server address as follows:

➤ If you install one HP Release Control server, specify the 
URL of this machine. 

Note: If you are using a web server, use the port of the 
web server.

➤ If you cluster two or more HP Release Control servers 
behind a load balancer, specify the URL of the load 
balancer.

SMTP host Enter the host name of the SMTP mail server machine.

SMTP port Specify the port to be used to connect to the SMTP mail 
server.

SMTP username Specify the user name required to connect to the SMTP 
mail server, if one is required.

SMTP password Enter the password required to connect to the SMTP mail 
server. If the password must be encrypted, see the section 
about password encryption in the HP Release Control User 
Guide.
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 4 When you are satisfied with your configuration changes, activate the 
draft. (See "Activating Configuration Changes" on page 61.)

 5 Stop the HP Release Control service:

 a From the Windows menu, select Start > Run and type services.msc.

 b In Services window, select HP ReleaseControl 5.00 <server name> and 
click Stop Service.

 6 Start the HP Release Control service again.

Configuring the HP Universal CMDB

This section contains mandatory configuration settings for configuring 
HP Release Control interaction with HP Universal CMDB. 

For information on optional HP Universal CMDB configuration settings, see 
the section about HP Universal CMDB configuration in the HP Release 
Control User Guide.

Note: If you are working without HP Universal CMDB (Standalone mode), 
see the section about configuring HP Release Control to work in Standalone 
mode in the HP Release Control User Guide.

To configure the HP Universal CMDB: 

 1 Deploy the ccm_package.zip file in the HP Universal CMDB. 

The ccm_package.zip file is located in the <HP Release Control 
installation directory>\uCmdb\ucmdb-<version>\extensions folder. For 
more information about deploying packages, see the HP Universal CMDB 
documentation.

 2 Log on to HP Release Control (See "Launching HP Release Control" on 
page 21).

 3 Select the HP Universal CMDB version number.
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 a In HP Release Control, select Module > Administrator > Configuration 
tab > Integrations > HP Universal CMDB.

 b In the right pane, In the HP Universal CMDB version box, select the 
appropriate version.

 4 Enter the HP Universal CMDB server details.

 a Select Integrations > HP Universal CMDB > Available Connections > 
Enter a valid CMDB server name.

 b In the right pane, in the HP Universal CMDB server name box, enter 
the DNS name of the server on which HP Universal CMDB is installed.

 c In the Port box, specify the port used by the HP Universal CMDB 
server.

 d If you are using HP Universal CMDB version 8.0.x, specify the user 
name and password needed to access HP Universal CMDB, in the 
relevant boxes.

 5 Save a draft of your configuration set. (See "Saving a Draft Configuration 
Set" on page 60.)

 6 When you are satisfied with your configuration changes, activate the 
draft. (See "Activating Configuration Changes" on page 61.)

Configuring the Service Desk Integration

The configuration of your service desk differs depending on which service 
desk you are using:

Service Desk Instructions:

HP Service Manager "Configuring HP Service Manager Integration" on 
page 26

HP ServiceCenter "Configuring HP ServiceCenter Integration" on page 33

HP Project and 
Portfolio Management 
/ IT Governance 
Center

"Configuring HP Project and Portfolio Management / 
IT Governance Center Integration" on page 39
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Configuring HP Service Manager Integration
This task describes how to configure HP Service Manager as your service 
desk and includes the following stages: 

➤ "Stage 1: Prerequisites" below

➤ "Stage 2: Run the Configuration Utility" on page 29

➤ "Stage 3: Apply Configuration Changes" on page 30

Stage 1: Prerequisites

 1 Verify the following information, which you will need during this 
configuration process:

BMC Remedy Action 
Request System

"Configuring BMC Remedy Action Request System 
Integration" on page 43

HP Service Desk "Configuring HP Service Desk Integration" on page 47

Database "Configuring a Database as a Service Desk" on page 50

XML file "Configuring an XML File as a Service Desk" on page 54

HP Server Automation 
and HP Network 
automation.

"Configuring HP Server Automation or HP Network 
Automation as Your Service Desk" on page 57

✔ Required Information

HP Service Manager version

For versions of HP Service Manager earlier than 7.10: 

Is IIA (ITSM Implementation Accelerator) content enabled in HP Service 
Manager?

Is HP's Lightweight Single Sign On (LW-SSO) used?

HP Service Manager user name, password, time zone, host name, and port

Note: Use the Java naming conventions for time zones.

Service Desk Instructions:
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Note: If HP Service Manager is deployed with the default load balancer, 
instead of establishing a direct connection with the HP Service Manager 
server, HP Release Control will establish connections with each 
HP Service Manager user. To optimize the connection between HP Service 
Manager and HP Release Control, use a different load balancer for 
HP Service Manager.

 2 If you are using a version of HP Service Manager earlier than 7.10, and IIA 
content is not enabled: In the HP Service Manager Client, go to System 
Definition > Tables > cm3t. Add the fields actualEnd and actualStart. Set 
the Data type to Date/time.

 3 Load the HP Release Control unload files as follows:

 a In the HP Service Manager Client, select the Database Manager.

 b Select the Import/Load option from the drop-down menu.

 c Load the relevant HP Service Manager files from <HP Release Control 
installation directory>\examples\service-desk-examples\
ServiceManager\<relevant HP Service Manager version>\unload-files. 

Is HTTPS required in order to access HP Service Manager WSDL file?

Note: If HP Service Manager is configured using SSL, you need to import the 
SSL certificate from HP Service Manager to the HP Release Control server. 

URL suffix for the HP Service Manager WSDL file (by default, sc62server/
PWS)

✔ Required Information
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Caution: If you are using HP Service Manager 7.11 (webtier), the 
SMRC1.2_Demo_v6.22.unl unload file may overwrite previous menu 
and format customizations. This file enables you to access HP Release 
Control interfaces, such as the change calendar, directly from 
HP Service Manager 7.11. 

If you prefer to manually perform the steps carried out by this unload 
file, instead of loading it, see "Appendix: Manual Steps for 
SMRC1.2_Demo_v6.22.unl" on page 32.

 d For each file, click Load FG.

 4 If you are using HP Service Manager 7.11 (webtier): Copy the contents of 
<HP Release Control installation directory>\example\
service-desk-examples\ServiceManager\service-manager-711\webtier\i
mages\obj16 to the corresponding HP Service Manager webtier directory.

 5 Configure the HP Release Control server URL in HP Service Manager:

 a In HP Service Manager, go to System Administration > Base System 
Configuration > Miscellaneous > System Information Record.

 b In the Active Integrations tab, select HP Release Control.

 c In the Server URL box, enter the URL of the HP Release Control server. 
For example:

 6 Users who will access HP Service Manager from HP Release Control need 
to have SOAP API Execute Capabilities enabled. In HP Service Manager, 
ensure that this option is enabled for the relevant operators.

http://server:8080/ccm
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 7 (Optional) As part of the SdiConfigurer.bat utility you will run in the next 
stage, certain HP Service Manager fields will be automatically mapped to 
HP Release Control fields. If you want to map any additional fields, 
expose these fields now in the HP Service Manager ChangeRC/
ChangeTaskRC External Access object. You will map these fields in 
conversion scripts in step 3 of "Stage 3: Apply Configuration Changes" 
(see page 31).

Note: To expose and map fields, ensure that you are using ChangeRC and 
ChangeTaskRC external access objects that are dedicated to HP Release 
Control instead of using the default Change and ChangeTask external 
access objects.

Stage 2: Run the Configuration Utility

From the command line, run the following command:

For each question, type your selection and press ENTER. (Refer to the 
information you verified at the beginning of the Prerequisites section.) 
Where relevant, the default selection appears in square brackets at the end 
of the question. 

Note: If you press ENTER without typing anything, the default answer is 
automatically selected. 

Based on your selections, the configuration utility creates new configuration 
files, including a .zip file. To apply the configuration settings to HP Release 
Control, you upload the .zip file as outlined in the following step.

<HP Release Control installation directory>\bin\SdiConfigurer.bat
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Stage 3: Apply Configuration Changes

 1 In HP Release Control, go to Module > Administrator > Configuration tab 
> Integrations > Service Desk Adapters, click the arrow next to the Add 
configuration to configuration set button, and choose Service Desk 
Adapter.

 2 In the Select file to upload dialog box, go to <HP Release Control 
installation directory>\bin\result and open <adapter_name>.zip.

A new node (with the name of the adapter) is added under the 
Integrations > Service Desk Adapters node. The node includes the new 
service desk configuration files. Each configuration file is displayed in the 
right pane in a separate tab. For example: 
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 3 If you exposed additional fields in step 7 of "Stage 1: Prerequisites" (see 
page 29), map these fields in the relevant conversion scripts 
(convertChange.js/convertTask.js). 

➤ To view the conversion scripts, select the Integrations > Service Desk 
Adapters > <adapter name> node and select the relevant tab in the 
right pane that displays the file. 

➤ To make changes to the scripts, see "Modifying Configuration Files in 
the Configuration Tab" on page 60.

 4 You can configure HP Release Control to update HP Service Manager with 
Analysis information. For details, see the relevant section in the 
HP Release Control User Guide

 5 Save a draft of your configuration set. (See "Saving a Draft Configuration 
Set" on page 60.)

 6 When you are satisfied with your configuration changes, activate the 
draft. (See "Activating Configuration Changes" on page 61.)

Note: To modify your service desk settings after the initial configuration, 
see the section about advanced service desk configuration in the 
HP Release Control User Guide.
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Appendix: Manual Steps for SMRC1.2_Demo_v6.22.unl

The SMRC1.2_Demo_v6.22.unl file enables you to access HP Release Control 
interfaces directly from HP Service Manager. This unload file may overwrite 
previous menu and format customizations. This section describes how to 
manually perform the steps carried out by this unload file, instead of 
loading it.

To manually perform the steps carried out by the SMRC1.2_Demo_v6.22.unl 
file:

 1 Add the following four fields in the Info table:

 2 Using the Form Designer, modify the info.company.g form, by adding the 
following controls:

Field Name Data Type

RC Logical

RC.server.url Character

RC.SD.name Character

RC.task Logical

Control Type Input

HP Release Control Checkbox RC

Server URL Text RC.server.url

Specified Service Desk Text RC.SD.name

Enable RC link for Change Tasks Checkbox RC.task
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 3 For the ChM menu name, add the following option: 

 4 For the CM DETAIL menu name, add the following option:

 5 To verify this change, open a non-closed change with Affected-CI from 
the web client and check that the RC calendar option is available in the 
Detail Options context menu.

Configuring HP ServiceCenter Integration
This task describes how to configure HP ServiceCenter as your service desk 
and includes the following stages: 

➤ "Stage 1: Prerequisites" below

➤ "Stage 2: Run the Configuration Utility" on page 37

➤ "Stage 3: Apply Configuration Changes" on page 37

Description Application Condition

RC Calendar us.launch.rc
.calendar

stem.info=1 and nullsub($G.ess, false)=false and 
sysinfo.get("environment")#"scguiwweb" and 
lioption("Change Management") and 
(index("SysAdmin", $lo.ucapex)>0 or 
index("ChMAdmin", $lo.ucapex)>0 or 
index("change request", $lo.ucapex)>0)

Description Application Condition

RC Calendar us.launch.rc
.calendar

RC in $G.system.info=1 and nullsub($G.ess, 
false)=false and 
sysinfo.get("environment")#"scguiwweb"
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Stage 1: Prerequisites

 1 Verify the following information, which you will need during this 
configuration process:

Note: If HP ServiceCenter is deployed with the default load balancer, 
instead of establishing a direct connection with the HP ServiceCenter 
server, HP Release Control will establish connections with each HP 
ServiceCenter user. To optimize the connection between HP ServiceCenter 
and HP Release Control, use a different load balancer for HP 
ServiceCenter.

 2 Load the HP Release Control unload files as follows:

 a In the HP ServiceCenter Client, select the Database Manager.

 b Select the Import/Load option from the drop-down menu.

 c Load the relevant HP ServiceCenter file from <HP Release Control 
installation directory>\examples\service-desk-examples\
ServiceCenter\<relevant HP ServiceCenter directory>\unload-files.

 d Click Load FG.

✔ Required Information

HP ServiceCenter version

Is HP's Lightweight Single Sign On (LW-SSO) used?

HP Service Manager user name, password, time zone, host name, and port

Note: Use the Java naming conventions for time zones.

Is HTTPS required in order to access HP Service Manager WSDL file?

Note: If HP ServiceCenter is configured using SSL, you need to import the 
SSL certificate from HP ServiceCenter to the HP Release Control server.  

URL suffix for the HP Service Manager WSDL file
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 3 In the HP ServiceCenter Client (Eclipse Client), go to System Definition > 
Tables > cm3r. Add the fields implementationEnd and 
implementationStart. Set the Data type to Date/time and check the 
Include in API box. 

 4 In the HP ServiceCenter Client, go to System Definition>Tables>cm3t. 
Add the fields actualEnd and actualStart. Set the Data type to Date/time 
and check the Include in API box.

 5 Expose the relevant HP ServiceCenter change fields.

 a In HP ServiceCenter, select Menu Navigation > Toolkit > WSDL 
Configuration.

 b In the name box, type cm3r and press ENTER.

 c In the Data Policy tab, ensure that the following fields with the 
appropriate properties are included in the list of exposed fields:

 d Click Save.

 6 Expose the relevant HP ServiceCenter task fields.

 a In HP ServiceCenter, select Menu Navigation > Toolkit > WSDL 
Configuration.

 b In the name box, type cm3t and press ENTER.

Field Name API Caption Exclude API Data Type

approval.structure,approv
als.required

ApprovalsRequired false

approval.structure,approv
ed.groups

ApprovedGroups false

approval.structure,curren
t.pending.groups

CurrentPendingGro
ups

false

header,orig.date.entered OrigDateEntered false

implementationEnd ImplementationEnd false DateTimeType

implementationStart ImplementationStart false DateTimeType

sysmodtime sysmodtime false



Chapter 1 • Installing and Deploying HP Release Control

36

 c In the Data Policy tab, ensure that the following fields with the 
appropriate properties are included in the list of exposed fields:

  

 d Click Save.

 7 Restart HP ServiceCenter

 8 (Optional) As part of the SdiConfigurer.bat utility you will run in the next 
stage, certain HP ServiceCenter fields will be automatically mapped to 
HP Release Control fields. If you want to map any additional fields, 
expose these fields now in the HP ServiceCenter Change/ChangeTask 
External Access object. In step 3 of "Stage 3: Apply Configuration 
Changes" (see page 38), you will map these fields in the conversion 
scripts.

Field Name API Caption Exclude API Data Type

actualEnd ActualEnd false DateTimeType

actualStart ActualStart false DateTimeType

approval.structure,approv
als.required

ApprovalsReq
uired

false

approval.structure,approv
ed.groups

ApprovedGro
ups

false

approval.structure,curren
t.pending.groups

CurrentPendi
ngGroups

false

header,approval.status ApprovalStat
us

false

header,orig.date.entered OrigDateEnte
red

false

header,priority.code Priority false

header,risk.assessment RiskAssessme
nt

false

middle,asset Asset false

sysmodtime sysmodtime false
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Stage 2: Run the Configuration Utility

From the command line, run the following command:

For each question, type your selection and press ENTER. (Refer to the 
information you verified at the beginning of the Prerequisites section.) 
Where relevant, the default selection appears in square brackets at the end 
of the question. 

Note: If you press ENTER without typing anything, the default answer is 
automatically selected. 

Based on your selections, the configuration utility creates new configuration 
files, including a .zip file. To apply the configuration settings to HP Release 
Control, you upload the .zip file as outlined in the following step.

Stage 3: Apply Configuration Changes

 1 In HP Release Control, go to Module > Administrator > Configuration tab 
> Integrations > Service Desk Adapters, click the arrow next to the Add 
configuration to configuration set button, and choose Service Desk 
Adapter.

<HP Release Control installation directory>\bin\SdiConfigurer.bat
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 2 In the Select file to upload dialog box, go to <HP Release Control 
installation directory>\bin\result and open <adapter_name>.zip.

A new node (with the name of the adapter) is added under the 
Integrations > Service Desk Adapters node. The node includes the new 
service desk configuration files. Each configuration file is displayed in the 
right pane in a separate tab. For example: 

 3 If you exposed additional fields in step 8 of "Stage 1: Prerequisites" (see 
page 36), map these fields in the relevant conversion scripts 
(convertChange.js/convertTask.js). 

➤ To view the conversion scripts, select the Integrations > Service Desk 
Adapters > <adapter name> node and select the relevant tab in the 
right pane that displays the file. 

➤ To make changes to the scripts, see "Modifying Configuration Files in 
the Configuration Tab" on page 60.

 4 Save a draft of your configuration set. (See "Saving a Draft Configuration 
Set" on page 60.)

 5 When you are satisfied with your configuration changes, activate the 
draft. (See "Activating Configuration Changes" on page 61.)

 6 Users who will access HP ServiceCenter from HP Release Control need to 
have SOAP API Execute Capabilities enabled. In HP ServiceCenter, ensure 
that this option is enabled for the relevant operators.
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Note: To modify your service desk settings after the initial configuration, 
see the section about advanced service desk configuration in the 
HP Release Control User Guide.

Configuring HP Project and Portfolio Management /  
IT Governance Center Integration
This task describes how to configure HP Project and Portfolio Management /  
IT Governance Center as your service desk and includes the following 
stages: 

➤ "Stage 1: Prerequisites" below

➤ "Stage 2: Run the Configuration Utility" on page 40

➤ "Stage 3: Apply Configuration Changes" on page 41

Stage 1: Prerequisites

 1 Verify the following information, which you will need during this 
configuration process:

✔ Required Information

HP Project and Portfolio Management / IT Governance Center version

service desk user name, password, host name, and port
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 2 For versions earlier than HP Project and Portfolio Management version 
7.5: If your HP Project and Portfolio Management / IT Governance Center 
Web Services service desk application is synchronized with the CMDB 
server, add a new change request field in HP Release Control named 
mam-ticket-id of type text. Apply the analysis rule mam-ticket to this 
field, with the analysis rule level set to both Change and Task.

For information about creating new change request fields and applying 
analysis rules, see the section about creating or modifying change request 
fields in the HP Release Control User Guide.

Stage 2: Run the Configuration Utility

From the command line, run the following command:

(optional) If you want to enable approval integration with HP Release 
Control whereby the approval of a change request in HP Release Control, 
results in an updated status of a workflow step within the service desk, you 
need to provide the following information:

➤ Source Workflow Step. Decide which step in HP Project and Portfolio 
Management requires approval. This step will be updated with the 
HP Release Control approval status. 

➤ Oracle DB SID (System ID)

➤ Oracle DB host name

➤ Oracle DB port

➤ Oracle DB user name

➤ Oracle DB password

Write down the workflow steps from HP Project and Portfolio Management. 
This information is found within the HP Project and Portfolio Management 
workbench. For more information, refer to the HP Project and Portfolio 
Management documentation.

<HP Release Control installation directory>\bin\SdiConfigurer.bat

✔ Required Information
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For each question, type your selection and press ENTER. (Refer to the 
information you verified at the beginning of the Prerequisites section.) 
Where relevant, the default selection appears in square brackets at the end 
of the question. 

Note: If you press ENTER without typing anything, the default answer is 
automatically selected. 

Based on your selections, the configuration utility creates new configuration 
files, including a .zip file. To apply the configuration settings to HP Release 
Control, you upload the .zip file as outlined in the following step.

Stage 3: Apply Configuration Changes

 1 In HP Release Control, go to Module > Administrator > Configuration tab 
> Integrations > Service Desk Adapters, click the arrow next to the Add 
configuration to configuration set button, and choose Service Desk 
Adapter.

 2 In the Select file to upload dialog box, go to <HP Release Control 
installation directory>\bin\result and open <adapter_name>.zip.
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A new node (with the name of the adapter) is added under the 
Integrations > Service Desk Adapters node. The node includes the new 
service desk configuration files. Each configuration file is displayed in the 
right pane in a separate tab. For example: 

 3 Map the workflow steps (that you wrote down earlier as part of the 
configuration prerequisites) from HP Project and Portfolio Management 
to status names in HP Release Control in the relevant conversion scripts 
(convertRelease.js/convertChange.js). 

➤ To view the conversion scripts, select the Integrations > Service Desk 
Adapters > <adapter name> node and select the relevant tab in the 
right pane that displays the file. 

➤ To make changes to the scripts, see "Modifying Configuration Files in 
the Configuration Tab" on page 60.

 4 Save a draft of your configuration set. (See "Saving a Draft Configuration 
Set" on page 60.)

 5 When you are satisfied with your configuration changes, activate the 
draft. (See "Activating Configuration Changes" on page 61.)
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Note: To modify your service desk settings after the initial configuration, 
see the section about advanced service desk configuration in the 
HP Release Control User Guide.

Configuring BMC Remedy Action Request System 
Integration
This task describes how to configure BMC Remedy Action Request System as 
your service desk and includes the following stages: 

➤ "Stage 1: Prerequisites" below

➤ "Stage 2: Run the Configuration Utility" on page 43

➤ "Stage 3: Copy BMC Remedy Files to HP Release Control" on page 44

➤ "Stage 4: Apply Configuration Changes" on page 45

Stage 1: Prerequisites

Verify the following information, which you will need during this 
configuration process:

.

Stage 2: Run the Configuration Utility

From the command line, run the following command:

✔ Required Information

BMC Remedy version

BMC Remedy user name, password, and server name

<HP Release Control installation directory>\bin\SdiConfigurer.bat
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For each question, type your selection and press ENTER. (Refer to the 
information you verified at the beginning of the Prerequisites section.) 
Where relevant, the default selection appears in square brackets at the end 
of the question. 

Note: If you press ENTER without typing anything, the default answer is 
automatically selected. 

Based on your selections, the configuration utility creates new configuration 
files, including a .zip file. To apply the configuration settings to HP Release 
Control, you upload the .zip file as outlined in the following step.

Stage 3: Copy BMC Remedy Files to HP Release Control

To connect to the BMC Remedy Action Request System service desk 
application, you must first ensure that certain BMC Remedy Action Request 
System files are accessible to the HP Release Control server.

 1 Stop the HP Release Control service:

 a From the Windows menu, select Start > Run and type services.msc.

 b In Services window, select HP ReleaseControl 5.00 <server name> and 
click Stop Service.

 2 Copy BMC Remedy files to HP Release Control

➤ If you are working with BMC Remedy ARS 5.0: 

 a Copy arapi50.jar and arutil50.jar from the BMC Remedy Action 
Request System installation directory to the  <HP Release Control 
installation directory>\tomcat\lib directory.

 b Copy arapi50.dll, arjni50.dll, arrpc50.dll, and arutl50.dll from the BMC 
Remedy Action Request System installation directory to the 
<HP Release Control installation directory>\apps\ccm\
WEB-INF\os_lib\win32 directory on the HP Release Control server 
machine.

➤ If you are working with BMC Remedy ARS 7.0:
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 c Copy arapi70.jar and arutil70.jar from the BMC Remedy Action 
Request System installation directory to the <HP Release Control 
installation directory>\tomcat\lib directory.

 d Copy all the Windows library files (*.dll) from the BMC Remedy Action 
Request System installation directory to the <HP Release 
Control installation directory>\apps\ccm\WEB-INF\os_lib\win32  
directory on the HP Release Control server machine.

 3 Start the HP Release Control service.

Stage 4: Apply Configuration Changes

 1 In HP Release Control, go to Module > Administrator > Configuration tab 
> Integrations > Service Desk Adapters, click the arrow next to the Add 
configuration to configuration set button, and choose Service Desk 
Adapter.

 2 In the Select file to upload dialog box, go to <HP Release Control 
installation directory>\bin\result and open <adapter_name>.zip.
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A new node (with the name of the adapter) is added under the 
Integrations > Service Desk Adapters node. The node includes the new 
service desk configuration files. Each configuration file is displayed in the 
right pane in a separate tab. For example: 

 3 Save a draft of your configuration set. (See "Saving a Draft Configuration 
Set" on page 60.)

 4 When you are satisfied with your configuration changes, activate the 
draft. (See "Activating Configuration Changes" on page 61.)

Note: To modify your service desk settings after the initial configuration, 
see the section about advanced service desk configuration in the 
HP Release Control User Guide.
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Configuring HP Service Desk Integration
This task describes how to configure HP Service Desk as your service desk 
and includes the following stages: 

➤ "Stage 1: Prerequisites" below

➤ "Stage 2: Run the Configuration Utility" below

➤ "Stage 3: Copy HP Service Desk Files to HP Release Control" on page 48

➤ "Stage 4: Apply Configuration Changes" on page 49

Stage 1: Prerequisites

Verify the following information, which you will need during this 
configuration process:

.

Stage 2: Run the Configuration Utility

From the command line, run the following command:

For each question, type your selection and press ENTER. (Refer to the 
information you verified at the beginning of the Prerequisites section.) 
Where relevant, the default selection appears in square brackets at the end 
of the question. 

Note: If you press ENTER without typing anything, the default answer is 
automatically selected. 

✔ Required Information

HP Service Desk server name and port 

HP Service Desk user name and password

<HP Release Control installation directory>\bin\SdiConfigurer.bat
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Based on your selections, the configuration utility creates new configuration 
files, including a .zip file. To apply the configuration settings to HP Release 
Control, you upload the .zip file as outlined in the following step.

Stage 3: Copy HP Service Desk Files to HP Release Control

To connect to the BMC Remedy Action Request System service desk 
application, you must first ensure that certain BMC Remedy Action Request 
System files are accessible to the HP Release Control server.

 1 Stop the HP Release Control service:

 a From the Windows menu, select Start > Run and type services.msc.

 b In Services window, select HP ReleaseControl 5.00 <server name> and 
click Stop Service.

 2 Copy the web-api.jar file from the HP Service Desk 
servicepages\webapps\
sd-sp45\WEB-INF\lib directory and paste it into the  <HP Release Control 
installation directory>\tomcat\lib directory. Start the HP Release Control 
service.

 3 Start the HP Release Control service.
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Stage 4: Apply Configuration Changes

 1 In HP Release Control, go to Module > Administrator > Configuration tab 
> Integrations > Service Desk Adapters, click the arrow next to the Add 
configuration to configuration set button, and choose Service Desk 
Adapter.

 2 In the Select file to upload dialog box, go to <HP Release Control 
installation directory>\bin\result and open <adapter_name>.zip.

A new node (with the name of the adapter) is added under the 
Integrations > Service Desk Adapters node. The node includes the new 
service desk configuration files. Each configuration file is displayed in the 
right pane in a separate tab. For example: 
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 3 Save a draft of your configuration set. (See "Saving a Draft Configuration 
Set" on page 60.)

 4 When you are satisfied with your configuration changes, activate the 
draft. (See "Activating Configuration Changes" on page 61.)

Note: To modify your service desk settings after the initial configuration, 
see the section about advanced service desk configuration in the 
HP Release Control User Guide.

Configuring a Database as a Service Desk
This task describes how to configure a database as your service desk and 
includes the following stages: 

➤ "Stage 1: Prerequisites" below

➤ "Stage 2: Run the Configuration Utility" on page 52

➤ "Stage 3: Apply Configuration Changes" on page 53

Stage 1: Prerequisites

 1 Depending on which database you are using, verify the following 
connection information and database properties that you will need 
during this configuration process:

➤ For Oracle databases
.

✔ Required Information Description

Oracle SID, DB host name, 
port, user name, and 
password

Database connection properties

change id column name The name of the column in the result set 
that contains the ID field value.
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➤ For MS-SQL databases
.

created date query The SQL query that returns the change 
request set according to the requests’ 
creation-date field values. 

created date field result 
column name

The name of the column in the result set 
that contains the creation-date field value.

created date column type One of the following values: time, 
timestamp, date, milliseconds, or seconds 

Is the created date query a 
stored procedure?

If yes, what are the input and output 
parameter names and the catalog name?

last updated query The SQL query that returns the change 
request set according to the requests’ 
last-update field values.

last updated field result 
column name

The name of the column in the result set 
that contains the last-update field value.

last updated column type One of the following values: time, 
timestamp, date, milliseconds, or seconds 

Is the last updated query a 
stored procedure?

If yes, what are the input and output 
parameter names?

✔ Required Information Description

DB name, DB host name, 
port, user name, and 
password

Database connection properties

change id column name The name of the column in the result set 
that contains the ID field value.

created date query The SQL query that returns the change 
request set according to the requests’ 
creation-date field values. 

created date field result 
column name

The name of the column in the result set 
that contains the creation-date field value.

✔ Required Information Description
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Stage 2: Run the Configuration Utility

From the command line, run the following command:

For each question, type your selection and press ENTER. (Refer to the 
information you verified at the beginning of the Prerequisites section.) 
Where relevant, the default selection appears in square brackets at the end 
of the question. 

Note: If you press ENTER without typing anything, the default answer is 
automatically selected. 

Based on your selections, the configuration utility creates new configuration 
files, including a .zip file. To apply the configuration settings to HP Release 
Control, you upload the .zip file as outlined in the following step.

created date column type One of the following values: time, 
timestamp, date, milliseconds, or seconds 

Is the created date query a 
stored procedure?

If yes, what is the input parameter name?

last updated query The SQL query that returns the change 
request set according to the requests’ 
last-update field values.

last updated field result 
column name

The name of the column in the result set 
that contains the last-update field value.

last updated column type One of the following values: time, 
timestamp, date, milliseconds, or seconds

Is the last updated query a 
stored procedure? 

If yes, what is the input parameter name?

<HP Release Control installation directory>\bin\SdiConfigurer.bat

✔ Required Information Description
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Stage 3: Apply Configuration Changes

 1 In HP Release Control, go to Module > Administrator > Configuration tab 
> Integrations > Service Desk Adapters, click the arrow next to the Add 
configuration to configuration set button, and choose Service Desk 
Adapter.

 2 In the Select file to upload dialog box, go to <HP Release Control 
installation directory>\bin\result and open <adapter_name>.zip.

A new node (with the name of the adapter) is added under the 
Integrations > Service Desk Adapters node. The node includes the new 
service desk configuration files. Each configuration file is displayed in the 
right pane in a separate tab. For example: 
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 3 Save a draft of your configuration set. (See "Saving a Draft Configuration 
Set" on page 60.)

 4 When you are satisfied with your configuration changes, activate the 
draft. (See "Activating Configuration Changes" on page 61.)

Note: To modify your service desk settings after the initial configuration, 
see the section about advanced service desk configuration in the 
HP Release Control User Guide.

Configuring an XML File as a Service Desk
This task describes how to configure and XML file as your service desk and 
includes the following stages: 

➤ "Stage 1: Prerequisites" below

➤ "Stage 2: Run the Configuration Utility" below

➤ "Stage 3: Apply Configuration Changes" on page 55

Stage 1: Prerequisites

 1 Verify the folder in which XML files will be placed and retrieved by 
HP Release Control. You need this information for the configuration 
utility that you will run in the next stage.

 2 Ensure that the HP Release Control user has read permissions to the 
directory in which the service desk application requests are placed in 
XML file format.

Stage 2: Run the Configuration Utility

From the command line, run the following command:

<HP Release Control installation directory>\bin\SdiConfigurer.bat
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For each question, type your selection and press ENTER. (Refer to the 
information you verified at the beginning of the Prerequisites section.) 
Where relevant, the default selection appears in square brackets at the end 
of the question. 

Note: If you press ENTER without typing anything, the default answer is 
automatically selected. 

Based on your selections, the configuration utility creates new configuration 
files, including a .zip file. To apply the configuration settings to HP Release 
Control, you upload the .zip file as outlined in the following step.

Stage 3: Apply Configuration Changes

 1 In HP Release Control, go to Module > Administrator > Configuration tab 
> Integrations > Service Desk Adapters, click the arrow next to the Add 
configuration to configuration set button, and choose Service Desk 
Adapter.

 2 In the Select file to upload dialog box, go to <HP Release Control 
installation directory>\bin\result and open <adapter_name>.zip.
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A new node (with the name of the adapter) is added under the 
Integrations > Service Desk Adapters node. The node includes the new 
service desk configuration files. Each configuration file is displayed in the 
right pane in a separate tab. For example: 

 3 Save a draft of your configuration set. (See "Saving a Draft Configuration 
Set" on page 60.)

 4 When you are satisfied with your configuration changes, activate the 
draft. (See "Activating Configuration Changes" on page 61.)

Note: To modify your service desk settings after the initial configuration, 
see the section about advanced service desk configuration in the 
HP Release Control User Guide.
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Configuring HP Server Automation or HP Network 
Automation as Your Service Desk
This task describes how to configure <service desk> as your service desk and 
includes the following stages: 

➤ "Stage 1: Prerequisites" below

➤ "Stage 2: Run the Configuration Utility" below

➤ "Stage 3: Apply Configuration Changes" on page 58

Stage 1: Prerequisites

 1 Verify the following information, which you will need during this 
configuration process:

.

Stage 2: Run the Configuration Utility

From the command line, run the following command:

For each question, type your selection and press ENTER. (Refer to the 
information you verified at the beginning of the Prerequisites section.) 
Where relevant, the default selection appears in square brackets at the end 
of the question. 

Note: If you press ENTER without typing anything, the default answer is 
automatically selected. 

✔ Required Information

For HP Server Automation: server name, user name, and password

For HP Network Automation: sever URL, user name, and password

<HP Release Control installation directory>\bin\SdiConfigurer.bat
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Based on your selections, the configuration utility creates new configuration 
files, including a .zip file. To apply the configuration settings to HP Release 
Control, you upload the .zip file as outlined in the following step.

Stage 3: Apply Configuration Changes

 1 In HP Release Control, go to Module > Administrator > Configuration tab 
> Integrations > Service Desk Adapters, click the arrow next to the Add 
configuration to configuration set button, and choose Service Desk 
Adapter.

 2 In the Select file to upload dialog box, go to <HP Release Control 
installation directory>\bin\result and open <adapter_name>.zip.
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A new node (with the name of the adapter) is added under the 
Integrations > Service Desk Adapters node. The node includes the new 
service desk configuration files. Each configuration file is displayed in the 
right pane in a separate tab. For example: 

 3 Save a draft of your configuration set. (See "Saving a Draft Configuration 
Set" on page 60.)

 4 When you are satisfied with your configuration changes, activate the 
draft. (See "Activating Configuration Changes" on page 61.)

Note: To modify your service desk settings after the initial configuration, 
see the section about advanced service desk configuration in the 
HP Release Control User Guide.

Working with HP Release Control Configuration Settings

The Configuration tab in the Administrator module enables you to define 
the configuration settings needed to set up your environment. This section 
describes the following common tasks in the Configuration tab. These tasks 
are referred to during the configuration process.

➤ "Modifying Configuration Files in the Configuration Tab" on page 60
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➤ "Saving a Draft Configuration Set" on page 60

➤ "Activating Configuration Changes" on page 61

Modifying Configuration Files in the Configuration Tab
Certain configuration settings are defined in configuration files (for 
example, scripts and XML files) that are available in the Configuration tab. 
This task describes how to modify these files.

To modify configuration files:

 1 In HP Release Control, go to Module > Administrator > Configuration tab 
and select the relevant node that includes the configuration file you want 
to modify. 

 2 In the right pane, click Download: <file> and export the file to your local 
directory using the browse dialog box that opens.

 3 After making the required modifications to the file in your local directory, 
click Upload file to import the modified file from your local directory to 
the HP Release Control system.

Saving a Draft Configuration Set
A new configuration set is initially saved as a draft. A draft is a configuration 
set that has not yet been activated. Only after a draft is activated, are the 
new configuration properties applied to HP Release Control. (See "Activating 
Configuration Changes" on page 61.)

To save a draft configuration set:

 1 Select Module > Administrator > Configuration tab and make the required 
configuration changes. 

 2 In the left pane, click the Save current editable configuration set button  
to open the Save as Draft dialog box and save the modified configuration 
set as a draft.

 3 In the Draft name box, enter the name of the draft and click Save.
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Activating Configuration Changes
This section explains how to activate a draft configuration set and apply the 
configuration properties to HP Release Control. 

To apply configuration changes

 1 Select Module > Administrator > Configuration tab. In the left pane, click 
Open Configuration Set button  to open the Open Configuration Set 
dialog box.

 2 Select the Drafts button to display only the existing drafts.

 3 Select the required draft and click Open. The name of the currently 
selected configuration set appears at the top of the left pane.

 4 In the left pane, click the Activate current configuration set button  to 
activate the selected draft and apply the new configuration properties to 
HP Release Control.
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2
Upgrading HP Release Control

This chapter provides information on how to upgrade from HP Release 
Control 4.12 and later to version 5.00.

To upgrade to version 5.00 from versions earlier than 4.12:

➤ Upgrade to version 4.12 according to the instructions in the HP Release 
Control 4.12 Deployment Guide. 

➤ Upgrade from version 4.12 to version 5.00 by following the instructions 
in this chapter.

The upgrade process includes the following stages:

➤ "Stage 1: Prerequisites" below

➤ "Stage 2: Install and Upgrade HP Release Control" on page 65

➤ "Stage 3: Upgrade Service Desk Adapter" on page 66

➤ "Stage 4: Post Upgrade Recommendations" on page 76

Stage 1: Prerequisites

 1 Make sure that the change request queue is empty as follows: 

 a In the <old HP Release Control installation directory>\conf directory, 
open the relevant service desk adapter configuration files (<service 
desk>-adapter.settings). For example, if you are working with 
HP Service Manager, the relevant file is 
servicemanager-ws-adapter.settings.
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 b In the adapter configuration file, switch the adapter into init-mode as 
follows:

➤ Locate the following line:

➤ Uncomment the line and modify the date/time as follows: 

Where [last polling time] is any time before the last time HP Release 
Control polled the service desk. Polling occurs every thirty seconds 
by default.

It is recommended to set the last polling time to a few hours earlier 
than the current time. For example, if today’s date is 20 January 
2010, set the last polling time as follows:

 c Restart HP Release Control and allow it to process all the change 
requests still in the queue. 

 d Make sure the queue is empty using the Queue Manager utility 
located in <old HP Release Control installation directory>\bin. 

To view a list of change requests in the queue, run the following 
command:

If there are no changes in the queue, you can proceed. If there are still 
changes in the queue, wait until they are processed or use the Queue 
Manager utility to delete them.

For more information about using the Queue Manager utility, see the 
HP Release Control User Guide.

 2 Stop the HP Release Control service.

<!--initial-load-state>1/20/2000 00:00:00 PST</initial-load-state-->

<initial-load-state>[last polling time]</initial-load-state>

<initial-load-state>1/20/2010 00:00:00 PST</initial-load-state>

QueueManager.bat -l
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 3 If you were using a Web server (Apache or IIS) with HP Release Control, 
remove the Web server configuration using the Web server configurer 
utility. To remove it, run the following command:

Note: After you install the new version of HP Release Control, if you still 
want to work with a Web server, configure it using the Web server 
configurer utility in the new installation. For more information, refer to 
the utilities section in the HP Release Control User Guide.

 4 Back up the database to protect your data in case of an error during the 
upgrade procedure.

Stage 2: Install and Upgrade HP Release Control

 1 Install HP Release Control version 5.00 (see "Installing HP Release 
Control" on page 18).

Before you run the installation, review the pre-installation information 
(see "Before You Install" on page 13).

 2 If you were using encrypted passwords in your HP Release Control 
configuration (for example, the database password), copy (and overwrite) 
the contents of <old HP Release Control installation directory>\security 
to <HP Release Control 5.00 installation directory>\security. 

 3 Configure the database that you want to use with the upgraded version of 
HP Release Control. Use the Database Configuration Wizard as described 
in "Configuring the Database or User Schema" on page 19.

 4 From the <HP Release Control 5.00 installation directory>\bin directory, 
run Upgrade.bat to perform the upgrade. When prompted, enter the full 
path of the old HP Release Control installation (for example, 
C:\HP\RC412).

<old HP Release Control installation directory>\bin\WebServerConfigurer.bat 
remove-config 
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 5 If you made any changes to the log levels in the ccmlog4j.properties file 
of your old installation, manually make the same changes again in the 
new ccmlog4j.properties file and the cmdblog4j.properties file.

Stage 3: Upgrade Service Desk Adapter

Note: You need to perform the steps in this stage for each service desk 
adapter that you were using with your old version of HP Release Control.

 1 Return the adapter to polling mode as follows: 

 a In the <old HP Release Control installation directory>\conf directory, 
open the relevant service desk adapter configuration files (<service 
desk>-adapter.settings). 

For example, if you are working with HP Service Manager, the relevant 
file is servicemanager-ws-adapter.settings. 

 b In the adapter configuration file, comment out the following line:

 2 From the <HP Release Control 5.00 installation directory>\bin directory, 
run UpgradeSdi.bat. 

➤ When prompted, enter the full path of the old HP Release Control 
installation (for example, C:\HP\RC412) and select the service desk 
adapter that you want to upgrade.

➤ If you are using HP Service Manager/Center, you will be prompted for 
the version number.

 3 If you are using Remedy as your service desk and you manually added .jar 
files to the <old HP Release Control Installation 
directory>\tomcat\webapps\ccm\WEB-INF\lib directory, copy the 
added files to <HP Release Control 5.00 Installation 
directory>\apps\ccm\WEB-INF\os_lib.

 4 Start the HP Release Control service and log on to HP Release Control (see 
"Launching HP Release Control" on page 21).

<initial-load-state>[last polling time]</initial-load-state>
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 5 Select Module > Administrator > Configuration tab. In the left pane, click 
the Open Configuration Set button to open the Open Configuration Set 
dialog box.

 6 Select the Drafts button to display only the existing drafts.

 7 Select the newly created draft and click Open. The name of the currently 
selected configuration set appears at the top of the left pane.

Next Step:

➤ If you are working with HP Service Manager/Center, continue below.

➤ For all other service desks, continue with step 10 on page 76.

 8 Remove the Action Items filter heading from the Reports template.

 a Select Module > Administrator > Configuration tab > Modules > 
Analysis > Reports > Changes Report - HTML and PDF template

 b Click Download: grid.changes-report.jrxml and export the file to your 
local directory using the browse dialog box that opens. Open the file 
on your local directory.

 c Locate both occurences of the following string:

 d In both places, replace the above string with the following string:

 e Save the file.

<textFieldExpression class="java.lang.String"><![CDATA["Change Requests: 
<style isBold=\"true\">" + $P{CHANGE_FILTER} + "</style>  Action items: <style 
isBold=\"true\">" + $P{COLLABORATION_FILTER} + "</style>"]]></
textFieldExpression>

<textFieldExpression class="java.lang.String"><![CDATA["Filter: <style 
isBold=\"true\">" + $P{CHANGE_FILTER} + "</style>"]]></textFieldExpression>
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 f Select Module > Administrator > Configuration tab > Modules > 
Analysis > Reports > Changes Report - HTML and PDF template. In the 
right pane, click Upload file to import the modified file from your local 
directory to the HP Release Control system.

 9 For HP Service Manager/Center only: Change the operations settings in 
the service desk adapter file.

Caution: During this step, you need to copy and paste large amounts of 
text. When pasting the text, ensure that strings in quotation marks (") 
start and end on the same line.

 a Select the Integrations > Service Desk Adapters > <adapter name> 
node and select the <adapter name>-adapter.settings file in the right 
pane.

 b Click Download: <adapter name>-adapter.settings and export the file 
to your local directory using the browse dialog box that opens. Open 
the file on your local directory.

 c In the <request-type level="1"> element, replace the <operations> 
element with the following text:

<operations>

<operation name="approve">

<operation-type>approveOperation</operation-type>

<connector>

<connector-type>ServiceManagerChangeApprove</
connector-type>

</connector>

<sender-properties>

updateOperation=true

</sender-properties>

</operation>
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<operation name="canApprove">

   <operation-type>alwaysCanApproveOperation</operation-type>

</operation>

<operation name="retract">

<operation-type>retractOperation</operation-type>

<connector>

<connector-type>ServiceManagerChangeRetract</
connector-type>

</connector>

<sender-properties>

updateOperation=true

</sender-properties>

</operation>

<operation name="canRetract">

   <operation-type>alwaysCanRetractOperation</operation-type>

</operation>

<operation name="reviewUpdate">

<operation-type>reviewUpdateOperation</operation-type>

<connector>

<connector-type>ServiceManagerChangeUpdate</
connector-type>

<properties>

scriptName=updateOperations.js

methodName=updateChangeReview

</properties>

</connector>

</operation>
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<operation name="canUpdateReview">

<operation-type>alwaysCanUpdateReviewOperation</
operation-type>

</operation>

<operation name="updatePlannedTimes">

<operation-type>updatePlannedTimesOperation</operation-type>

<connector>

<connector-type>ServiceManagerChangeUpdate</
connector-type>

<properties>

scriptName=updateOperations.js

methodName=updatePlannedTimes

</properties>

</connector>

</operation>

<operation name="canUpdatePlannedTimes">

   <operation-type>alwaysCanUpdatePlannedTimesOperation</
operation-type>

</operation>

<operation name="updateStatus">

<operation-type>updateStatusOperation</operation-type>

<properties>

timeout=30

</properties>

<connector>

<connector-type>ServiceManagerChangeUpdate</
connector-type>

<properties>
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scriptName=updateOperations.js

methodName=updateChangeStatus

</properties>

</connector>

</operation>

<operation name="canUpdateStatus">

<operation-type>alwaysCanUpdateStatusOperation</
operation-type>

</operation>

<operation name="close">

<operation-type>closeOperation</operation-type>

<connector>

<connector-type>ServiceManagerChangeClose</
connector-type>

<properties>guarded=true</properties>

</connector>

</operation>

<operation name="canClose">

 <operation-type>alwaysCanCloseOperation</operation-type>

</operation>

   

<!--operation name="updateAnalysisData">

<operation-type>updateAnalysisDataOperation</operation-type>

<properties>

timeout=30

</properties>

<connector>
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<connector-type>ServiceManagerAnalysisChangeUpdate</
connector-type>

<properties>

userName=falcon

password=

scriptName=updateOperations.js

methodName=updateChangeAnalysisData

</properties>

</connector>

</operation-->

</operations>

 d In the <request-type level="2"> element, replace the <operations> 
element with the following text:

<operations>

<operation name="approve">

<operation-type>approveOperation</operation-type>

<connector>

<connector-type>ServiceManagerTaskApprove</
connector-type>

</connector>

<sender-properties>

updateOperation=true

</sender-properties>

</operation>

   <operation name="canApprove">

   <operation-type>alwaysCanApproveOperation</operation-type>

</operation>
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<operation name="retract">

<operation-type>retractOperation</operation-type>

<connector>

<connector-type>ServiceManagerTaskRetract</connector-type>

</connector>

<sender-properties>

updateOperation=true

</sender-properties>

</operation>

<operation name="canRetract">

   <operation-type>alwaysCanRetractOperation</operation-type>

</operation>

<operation name="reviewUpdate">

<operation-type>reviewUpdateOperation</operation-type>

<connector>

<connector-type>ServiceManagerTaskUpdate</connector-type>

<properties>

scriptName=updateOperations.js

methodName=updateTaskReview

</properties>

</connector>

</operation>

<operation name="canUpdateReview">

<operation-type>alwaysCanUpdateReviewOperation</
operation-type>

</operation>

<operation name="updatePlannedTimes">
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<operation-type>updatePlannedTimesOperation</operation-type>

<connector>

<connector-type>ServiceManagerTaskUpdate</connector-type>

<properties>

scriptName=updateOperations.js

methodName=updatePlannedTimes

</properties>

</connector>

</operation>

<operation name="canUpdatePlannedTimes">

   <operation-type>alwaysCanUpdatePlannedTimesOperation</
operation-type>

</operation>

<operation name="updateStatus">

<operation-type>updateStatusOperation</operation-type>

<properties>

timeout=30

</properties>

<connector>

<connector-type>ServiceManagerTaskUpdate</connector-type>

<properties>

scriptName=updateOperations.js

methodName=updateTaskStatus

</properties>

</connector>

</operation>

<operation name="canUpdateStatus">
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<operation-type>alwaysCanUpdateStatusOperation</
operation-type>

</operation>

<operation name="close">

<operation-type>closeOperation</operation-type>

<connector>

<connector-type>ServiceManagerTaskClose</connector-type>

<properties>guarded=true</properties>

</connector>

</operation>

<operation name="canClose">

 <operation-type>alwaysCanCloseOperation</operation-type>

</operation>

   

<!--operation name="updateAnalysisData">

<operation-type>updateAnalysisDataOperation</operation-type>

<properties>

timeout=30

</properties>

<connector>

<connector-type>ServiceManagerAnalysisTaskUpdate</
connector-type>

<properties>

userName=falcon

password=

scriptName=updateOperations.js

methodName=updateTaskAnalysisData
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</properties>

</connector>

</operation-->

</operations>

 e Save the file.

 f You can configure HP Release Control to update HP Service Manager 
with Analysis information. For details, see the relevant section in the 
HP Release Control User Guide.

 g In HP Release Control, select the <adapter name>-adapter.settings file 
in the right pane and click Upload file to import the modified file from 
your local directory to the HP Release Control system.

 h Save your changes to the draft.

 10 In the left pane, click the Activate current configuration set  button to 
activate the selected draft and apply the new configuration properties to 
HP Release Control.

Stage 4: Post Upgrade Recommendations

 1 Uninstall the old version of the product.

 2 If you did not make any changes to the change-flow.js script of your old 
installation, it is recommended to upload the new change-flow.js script as 
follows:

 a In HP Release Control, select the Module > Administrator > 
Configuration tab > Change Process > change flow script node.

 b In the right pane, click Upload file and upload the change-flow.js 
script from <HP Release Control 5.00 installation 
directory>\examples\scripts directory.

 c Save and activate the configuration changes (see "Working with 
HP Release Control Configuration Settings" on page 59).

 3 If you have filters that include definitions for the Calculated risk criteria, 
the filters will still work but you are not able to edit the Calculated risk 
criteria using the default filter settings. To edit these filters:
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 a In HP Release Control, select Module > Administrator > Configuration 
tab > Integrations > Fields.

 b In the Available Fields pane, select the Analysis Data > calculated-risk 
field.

 c In the Field Attributes pane, in the Filter Layout tab, select the show in 
filter options.

 d Save and activate the configuration changes (see "Working with 
HP Release Control Configuration Settings" on page 59).

 e Log on to HP Release Control and edit your filters.

Note: 

➤ It is recommend to change the filter definition and to use the new Risk 
severity criteria in place of the Calculated risk criteria.

➤ After you edit the filter, it is recommended to return to the Fields pane 
and clear the show filter options for the calculated-risk field.
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