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Before You Install 

Welcome to ProTune, Mercury Interactive’s tool for Tuning in Production 
testing. This guide describes everything you need to know to install 
ProTune. It describes the ProTune package contents, the required system 
configuration, registration and backup procedures, and how to run the 
setup programs. 

Before you begin to install ProTune, review the following pre-installation 
procedures. 

Checking Your ProTune Package 

Make sure that your ProTune package contains the items described below. If 
any items are missing or damaged, contact Mercury Interactive or your local 
distributor. 

Compact Disk 

Your ProTune package includes one compact disk that contains the ProTune 
program and associated files. 

Documentation 

ProTune is supplied with a set of documentation that describes how to: 

➤ install ProTune 

➤ create virtual user scripts 

➤ use the ProTune Console 

➤ analyze the results 

v 



ProTune Installation Guide 

Registering Your Copy of ProTune 

Register your copy of ProTune to become a licensed user with all rights and 
privileges. Registered users have access to technical support and information 
on all Mercury Interactive products. You will also be eligible for updates and 
upgrades. 

To register your copy of ProTune, fill out the Mercury Interactive Software 
Registration card. 

➤	 If you are in the USA, fill out the USA Owners portion of the card. Send the 
card to the Sunnyvale, California address printed on the card. No postage is 
necessary. 

➤	 If you are outside the United States, fill out the Non-USA portion of the 
registration card and send it to the appropriate international address. Affix 
postage to the card before mailing. 

➤	 Remember to notify Mercury Interactive or your local representative if you 
move to a new address, so that you can continue to receive product 
information and updates. 

vi 



Before You Install 

Note: You can also register your copy of ProTune on Mercury Interactive’s 
Customer Support site: http://support.mercuryinteractive.com. 

Terminology 

Vuser 

Load Generator machine 

Console machine 

Vuser Group 

A virtual user—a ProTune-created user that 
emulates a human user. 

The workstation used to host the ProTune 
Vusers. 

The machine used to host the ProTune 
Console. 

A collection of Vusers with common 
characteristics, such as the machine on which 
they run, or the client that they use. 
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Typographical Conventions 

This book uses the following typographical conventions: 

1, 2, 3 

➤ 

> 

Stone Sans 

Bold 

Italics 

Helvetica 

<> 

[  ] 

{ } 

... 

Bold numbers indicate steps in a procedure. 

Bullets indicate options and features. 

The greater than sign separates menu levels (for 
example, File > Open). 

The Stone Sans font indicates names of interface 
elements on which you perform actions (for example, 
“Click the Run button.”). 

Bold text indicates method or function names 

Italic text indicates method or function arguments, file 
names or paths, and book titles. 

The Helvetica font is used for examples and text that is 
to be typed literally. 

Angle brackets enclose a part of a file path or URL 
address that may vary from user to user (for example, 
<Product installation folder>\bin). 

Square brackets enclose optional arguments. 

Curly brackets indicate that one of the enclosed values 
must be assigned to the current argument. 

In a line of syntax, an ellipsis indicates that more items 
of the same format may be included. 
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Introducing the ProTune Installation 

Your ProTune compact disk includes a setup program that guides you 
through the process of installing ProTune’s components. 

You can install the ProTune Console, the virtual user components, or both. 

System Requirements 

In order to successfully run ProTune, you need the following minimum 
system configuration. 

Requirement 
Console with 
Monitors 

Virtual Vuser 
Generator Virtual Users 

Analysis 
Module 

Computer/ 
Processor 

Pentium 300 MHZ 
or higher 

Pentium 300 
MHZ or higher 

Pentium 500 
MHZ dual CPU 
or higher 

Pentium 300 
MHZ or higher 

Operating 
System 

Windows NT® 
service pack 3 
or higher 
Windows 2000 

Windows NT® 
service pack 3 or 
higher 
Windows 2000 

Windows NT® 
service pack 3 
or higher 
Windows 2000 

Windows 2000 

Memory 128 MB or more 128 MB or more At least 1 MB 
RAM for non­
multithreaded 
Vuser or at least 
400 KB multi-
threaded Vuser 

128 MB or 
more 

Swap Space Two times the total 
physical memory 

Two times the 
total physical 
memory 

Two times the 
total physical 
memory 

Two times the 
total physical 
memory 
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Requirement Console with 
Monitors 

Virtual Vuser 
Generator 

Virtual Users Analysis 
Module 

Free Hard 
Disk Space 

200 MB 200 MB Minimum 500 
MB 

500 MB 

Browser IE 4.x or higher 
Netscape 
Navigator 4.x or 
higher 

IE 4.x or higher 
Netscape 
Navigator 4.x or 
higher 

N/A IE 4.x or higher 
Netscape 
Navigator 4.x 
or higher 

Note: Refer to http://www.mercuryinteractive.com/products/ProTune/technical/ 
for the most updated installation requirements. 
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Installing ProTune on Your Computer 

You can install the Console, virtual user components, or both. In addition, 
you can choose to install the full ProTune configuration, a load generator 
configuration, or a custom configuration. Choosing custom configuration 
lets you specify which ProTune components to install. 

Installation 

Note: You must log on as an NT Administrator when performing an 
installation on Windows NT 4.0 or higher. 

To install ProTune on your computer: 

1	 Insert the ProTune CD-ROM into a CD-ROM drive. If you are installing from 
a network drive, connect to that CD-ROM drive. 

2 Click Start, and select Run. 

3	 Type the location that you are installing from, followed by setup.exe. For 
example, if your CD-ROM drive letter is M, type: 

m:\win32\setup.exe 

4	 Click OK. The Installshield Wizard begins and displays the software 
licensing agreement. 

3 



ProTune Installation Guide 

5	 Read the agreement and click Yes to accept it and to display the Registration 
Information dialog box. 

6	 In the Registration Information dialog box, type your name, the name of 
your company, and your ProTune maintenance number. You can find the 
maintenance number in the maintenance pack shipped with ProTune. Click 
Next. 

7	 Your registration information appears in a read-only dialog box. Check that 
the information is correct. 

Click No to return to the previous dialog box and modify the registration 
information as necessary. 

Click Yes to confirm that the details are correct and continue with the 
installation process. 
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8 The Setup Type dialog box displays four setup options. 

9	 Select the type of installation that you want: Full, Load Generator, MI 
Listener, or Custom. 

Typical Installation installs all commonly-used ProTune components, 
including the ProTune Console, Virtual User (including GUI) components, 
and online documentation. Use this option for the main tuning machine. 

Load Generator installs only the components needed for running virtual 
users to generate load. Use this option for machines that are used only to 
generate load and not to control Vusers. 

MI Listener installs the components needed on the MI Listener machine 
used in running Vusers over a firewall and monitoring over a firewall. For 
more information about working with firewalls, refer to the ProTune Console 
User’s Guide. 

Custom Installation lets you install all the ProTune components, or select 
the components that you want to install. For details, see “Custom 
Installation Options,” on page 12. 
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10 Click Next to display the License Information 

11	 Enter the ProTune license code from your license agreement. If you are 
evaluating ProTune or waiting for a permanent license key, enter the license 
key ‘TEMPORARY’. This will let you run up to 25 virtual users for a period of 
10 days. 

Click Next. 

If you have a temporary license, ProTune issues a reminder indicating that 
you have 10 days to evaluate the product. Click OK. 
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12	 In the Choose Destination Location dialog box, choose the location where 
you want to install ProTune. To select a different location, click Browse, 
choose a folder, and click OK. 

Click Next. 
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13	 In the Select Program Folder dialog box, specify a program folder, or accept 
the default folder, ProTune. 

Click Next. 

14	 The installation settings that you selected are displayed in a read-only 
window. To select different installation settings, click Back. To begin 
installation, click Next. The installation process begins. 
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15	 If you installed ProTune’s online documentation, a message tells you to run 
the Acrobat Reader setup after the ProTune setup is complete. You use the 
Acrobat Reader to view the ProTune online documentation.To install 
Acrobat Reader select 
Start > Programs > ProTune > Documentation > Acrobat Reader Setup. 

Note: The Acrobat Reader setup installs the Acrobat 5.05 Reader. If you 
already have this version of the Acrobat Reader installed, it is not necessary 
to run the Acrobat Reader setup. 

16 Click OK to continue with the setup procedure.


17 In the User Login Settings dialog box, select a user login setting.


Select one of the following user login settings: 

Allow virtual users to run on this machine without user login: ProTune will 
automatically log in to the network from the Load Generator machine, so 
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the virtual users can run without any manual intervention. Enter the 
network domain where the user machine resides, a user name, and 
password. Note that you must have administrator privileges. 

Note: You must boot and log in to the system at least once after ProTune 
installation before the automatic login can work. 

Manual log in to the Load Generator machine: The user must manually log 
into the network from the Load Generator machine for each session of 
running Vusers. 

Click OK. 

18	 In the Registration Information dialog box appears, click Next to complete 
the installation. 

19	 The setup program prompts you to restart your computer. You can delay 
restarting your computer until a later point. 
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Note: The following message appears the first time that a user logs on after a 
full ProTune installation: "HCL Inetd CPLInquire cpl 8af40c". This message 
relates to the HCL (Hummingbird Communications Ltd.) Inetd service, 
when Inetd is installed as a Windows NT service. Please close the message 
box and continue to start your computer. 

The ProTune installation is now complete. 

Completing the ProTune Installation Process 

To complete the ProTune installation process: 

➤	 Select Start > Programs > ProTune > Readme to see what’s new in ProTune, 
and any last-minute limitations. 

➤	 To install the Adobe Acrobat Reader 5.05, select 
Start > Programs > ProTune > Documentation > Acrobat Reader Setup. 

➤	 If your version of ProTune is supplied with a plug and you have not already 
installed the plug, do so now by inserting it into the parallel port. 

➤	 To create Vuser scripts for Baan, you need to specify the correct application 
server in the Baan user file: 

The user file, u[username], is located under the Baan installation folder in 
bse/lib/user. Add the following line to the beginning of the user file: 

std_program:ottstpteststand 

This tells ProTune to use the Test Standard Program when recording and 
running Vusers. 

➤ To start ProTune, select Start > Programs > ProTune > Console. 
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Custom Installation Options 

If you choose to perform a Custom installation of ProTune, the setup 
program allows you to select the ProTune components that you want to 
install. You can install the following ProTune components: 

➤	 Console: Controls the tuning session. Includes the online performance 
monitors. Install the Console only on the machine that will control the 
Vusers. 

➤ Analysis: Graphs and reports for analyzing the performance. 

➤	 Vuser Generator: ProTune’s tool for creating virtual user (Vuser) scripts, 
through recording. Vuser scripts emulate users without a graphical user 
interface by using direct function calls. 

➤	 Load Generator: The components for running virtual users (including 
Windows-based GUI Vusers) to generate load. Note: You must have 
WinRunner installed to run GUI Vusers. 

➤	 MI Listener Component: Components for the MI Listener machine used in 
running Vusers and monitoring over the firewall. For more information, 
refer to the Using Firewalls chapter of the ProTune Console User’s Guide. 

➤	 Monitors over FireWall: Components on the agent machine for 
monitoring over the firewall. For more information, refer to the Using 
Firewalls chapter of the ProTune Console User’s Guide. 

➤ Online Documentation: All user guides in Acrobat format. 

12 



Installing ProTune on Your Computer 

Clear the check boxes next to the components that you do not want to 
install, and select the check boxes next to the components that you want to 
install. 

Click Next to proceed with the installation process. 
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Adding ProTune Components 

After you install ProTune, you can run the setup program at any time to add 
ProTune components, such as samples, the Virtual User Generator, or the 
online documentation. 

To add components: 

1 Insert the ProTune CD-ROM into a CD-ROM drive. 

2 Click the Start button, and select Run. 

3	 Type the location that you are installing from, followed by setup.exe. For 
example, if your CD-ROM letter is M, type: 

m:\win32\setup.exe 

Click OK. 

4	 The Installshield Wizard begins and displays the software licensing 
agreement. Read the agreement and click Yes to accept it. The ProTune setup 
program starts. 

5	 In the User Information dialog box, type your name, the name of your 
company, and a ProTune serial number. You can find this number on the 
outside of your ProTune box. Click Next. 

6	 The registration information appears in a read-only dialog box. Check that 
the information is correct. 

Click No to return to the previous dialog box in order to modify the 
registration information. 

Click Yes to confirm that the details are correct and continue the 
installation process. 
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7 Select your installation type - Standalone or Network - and click Next. 

8 Click Custom Installation, and then click Next. 

Select the ProTune components that you want to add. Clear the check boxes 
next to the options that you do not want to add.Click Next. 

9	 The installation settings you selected are displayed in a read-only window. 
Review the settings. If you want to select different installation settings, click 
Back. If you are satisfied with the installation settings, click Next. The 
installation process begins. 

10	 If you installed ProTune’s online documentation, a message tells you to run 
the Acrobat Reader setup after the ProTune set up is complete. You use the 
Acrobat Reader to view ProTune’s online documentation. 

Note: The Acrobat Reader setup installs the Acrobat 5.05 Reader. If you 
already have this version of the Acrobat Reader installed, it is not necessary 
to run the Acrobat Reader setup. 

Click OK to continue with the setup procedure. 
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11	 By default, the setup program creates the program group, ProTune, and 
creates the ProTune icons in the program group. 

To add the ProTune icons to an existing program group, select the group 
from the list of Existing Groups. Click Next. 

12	 Depending on which components you added, the setup program either 
prompts you to restart your computer or informs you that the setup is 
complete. You can delay restarting the computer until a later time. 

17 



ProTune Installation Guide 

18




4

Viewing and Modifying a License 

You can modify your license at any time directly from the ProTune interface. 
This chapter describes: 

➤ Viewing License Information 

➤ Modifying a License 

➤ Troubleshooting 

Normally, you enter your license code during installation. The setup 
program prompts you for a license code. If you do not have your license 
code at the time of installation, you can use the temporary license by typing 
‘TEMPORARY’ in the license key box. This grants you a 7 day license for 20 
topology elements. Afterwards contact Mercury Interactive Customer 
Support to obtain your permanent license key. 

This chapter describes how to enter a license code not during installation, 
and how to upgrade an existing license. 

Viewing License Information 

You can only view license information from the ProTune Console, not from 
the Virtual User Generator. 

To view the current license information: 

1	 In the Console, choose Help > About ProTune, and click License Info. The 
License dialog box opens, displaying the license information. 

2	 Scroll through the license information to determine the scope of your 
current license. 

19 



ProTune Installation Guide 

The license is defined for the number of elements in the topology. 

The License Keys box lists all the available license keys. In addition, you can 
select to view a summary of all the information in all the license keys. 

The License Key Information box displays the license type and validity for 
each selected license key. 

The following types of licenses are available: 

➤ Permanent: The license never expires. 

➤ Time Limited: The license is limited by a start date and an expiration date. 

➤ Temporary: The license is granted for a pre-defined number of days after 
product installation. 

➤ Plugged: The license requires a dongle. 

The Host ID box displays an ID for a specific machine. To receive a license 
key for a specific machine, contact Mercury Interactive’s Customer Support. 

Modifying a License 

You can only modify license information from the ProTune Console, not 
from the Virtual User Generator. 
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To modify the current license information: 

1	 In the Console, choose Help > About ProTune. The About ProTune window 
opens. 

2 Click the New License button. The New ProTune License dialog box opens. 

3	 Enter the new license number exactly as it was given to you. Click OK. If 
your license is limited for a specific amount of time, ProTune issues a 
message accordingly. 

4 Click OK to close the About ProTune window. 

Troubleshooting 

If you have temporary license key, contact Mercury Interactive Customer 
Support to obtain a permanent license key. 

If ProTune does not accept your license key, perform the following checks: 

➤ Make sure you typed in the license code exactly as it was given to you. 
Your license code is case sensitive. 

➤ If your ProTune license requires that you use a plug when running 
ProTune, and a message is issued stating that a plug is not installed, 
perform the following: 

Login as Administrator. 

Run <protune_directory>/bin/hinstall.exe/i. 

Reboot the machine. 

➤ If you receive a “permission denied” error message during Console start-up, 
you must grant “Full Control” permission for the Registry's 
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HKEY_LOCAL_MACHINE key and in the WINNT folder (folder where 

Windows is installed):


To add Registry permissions:


Run regedt32 to modify the registry.


Select the HKEY_LOCAL_MACHINE key.


Select Security > Permissions.


Add “Full Control” permission to the user that is running the Console.


Turn on the Replace Permission on the Existing Subkeys flag.


Click OK.


To add permissions on an NTFS file system:


Select the <System Drive>:\WinNT folder.


Invoke Properties.


Select the Security tab.


Click Permissions.


Add “Full Control” permission for the user.


Turn on the Replace Permissions on Subdirectories flag.


Click OK.
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