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 Chapter 1: Introduction
About This Document 

Mercury Change Management™ is a Mercury IT Governance Center™ 
product that automates the migrations and deployment of software code, 
configurations, and content. These objects are grouped into packages and are 
routed along business processes modeled in Mercury’s configurable workflow. 
Mercury’s workflow automates the process of moving each package through 
required steps, which typically involve system build, testing, quality assurance, 
staging, and final deployment. Mercury Change Management automatically 
deploys the application components necessary for each package; for example, 
XML content, HTML files, Java programs, Oracle application configurations, 
PeopleSoft panels, or Siebel projects.

For example, Mercury Change Management will connect to the development 
environment, copy Java files from the version control repository and transfer 
the files to the quality assurance environment. It will then use the Java 
compiler to compile and link all the files into a single Java program. A built-in 
scheduler allows the customer to schedule deployments. Mercury Change 
Management maintains an audit trail for all activities including package 
information, application components altered, approvals obtained, and 
deployments performed. 

This document contains the following chapters:

� Chapter 1, Introduction, on page 11

This chapter provides an overview of Mercury Change Management and 
lists the chapters found in this document. 

� Chapter 2, Understanding Packages, on page 25

This chapter provides an overview of how packages are viewed, processed, 
and managed in both the Workbench and the standard interface. 

� Chapter 3, Creating New Packages, on page 45

This chapter provides instructions for creating and submitting packages to 
deploy software and application changes. Typically, packages are created 
using the Workbench. 

� Chapter 4, Processing Packages, on page 77

In Mercury Change Management, once a package has been submitted, it 
can be processed. Processing packages refers to working with the package 
as the package proceeds through the workflow. This chapter discusses how 
to move packages through their associated workflow. 
12 Mercury Change Management™ User’s Guide
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� Chapter 5, Managing Packages, on page 109

Managing packages refers to working with the packages; for example, 
copying and deleting existing packages. 

� Appendix A: Change Management Portlets on page 119

Mercury Change Management includes a set of Change Management 
portlets. These portlets allow you to view the current status of packages at 
any point in time. This appendix lists the Mercury Change Management 
portlets. 

� Appendix B: Reports by Category on page 121

Mercury Change Management features a predefined set of reports. The 
reports provided with Change Management allow users to view the current 
detailed status of their deployment data at any point in time. This appendix 
lists the Mercury Change Management reports. 

Who Should Read This Document 

This document is intended for the following audience types:

� End users

� Application administrators

� Application developers or configurators

For More Information

For information about audience types see the Guide to Documentation.
Who Should Read This Document 13



 Chapter 1: Introduction
Prerequisite Documents

Prerequisite documents for this document are:

� Guide to Documentation 

� Key Concepts 

� Getting Started 

For More Information

For information about these documents and how to access them, see the Guide 
to Documentation.

Related Documents

Related documents for this document are:

� Mercury Demand Management User’s Guide

� Commands, Tokens, and Validations Guide and Reference

� Mercury Change Management: Configuring a Deployment System 

� Reports Guide and Reference

� Security Model Guide and Reference

For More Information

For information about these documents and how to access them, see the Guide 
to Documentation. 
14 Mercury Change Management™ User’s Guide



 Chapter 1: Introduction
Overview of Change Management 

Mercury Change Management is an enterprise application designed to deploy 
and audit software changes to mission-critical applications. It does this by 
gathering all information required for a successful deployment (for example, 
information on environments and objects to be migrated) into a single logical 
unit called the package. A package is the fundamental work unit of Mercury 
Change Management. A package consists of the objects that are processed 
through a business workflow. This results in a successful, easy-to-track 
software change. 

Figure 1-1. Mercury Change Management overview 

Essentially, a package is a list of objects. Each object belongs to an object type. 
Each object type has a unique set of parameters that determines the 
information it requires, as well as any additional information it may accept. For 
example, a standard object type is the File Migration object, which copies a file 
(the object) from one environment to another. 

Figure 1-2. A package
Overview of Change Management 15
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While each package line can be acted upon separately, the group of package 
lines and objects represent a logical unit that should be moved and tracked 
together. The processing of a package and package lines can vary greatly 
depending upon the workflow specified for that package. Figure 1-3 shows a 
sample package in the Package window of the Package Workbench.

Figure 1-3. Sample package in the Package window 

Workflows represent the business process associated with the package. 
Workflows consists of a logical series of workflow steps that define the path 
followed by objects in a package. Some of those workflow steps might 
represent decision-making processes; for example, code reviews and 
management approvals. Usually, at least one workflow step represents, or 
actually performs, the migration of the objects from one environment to 
another environment. 

In Figure 1-4, the workflow step Alpha to Beta represents the migration of the 
package’s objects from one environment to another. The workflow steps Initial 
Approval, Code Review, Alpha Test Evaluation, and Alpha to Beta Evaluation 
represent business decisions made concerning the package. 
16 Mercury Change Management™ User’s Guide
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Figure 1-4. Package workflow

Change Management Terms and Concepts 

The Standard Interface, the Workbench, and Change Management 

Mercury Change Management provides two different interfaces with packages. 
In the standard interface, Change Management provides the package’s detail 
page. In the Workbench, Change Management provides the Package 
Workbench. Where there is overlapping functionality between a package’s 
detail page and the Package Workbench, a package detail page does not have 
all of the functionality of the Package Workbench. 

The key difference between the Package Workbench and a package’s detail 
page is in the ability to add package lines and submit a package. You can add 
package lines and submit a package from the Package Workbench. You cannot 
add package lines and submit a package from a package’s detail page. The 
Package Workbench is intended to allow an engineer or developer to create and 
submit a package. Creating and submitting a package requires a great deal of 
specialized knowledge. In some cases, this includes passwords to production 
servers. Some of this information is not available to the resources making 
decisions concerning a package. Additionally, not everyone who makes a 
decision concerning a package should have access to the Workbench. 

From a package’s detail page, and with the correct permissions, you can 
process a package through its workflow. You can add notes and references to 
the package and make decisions concerning the status of the package. 
However, you cannot change or delete a package from the package’s detail 
page. 
Overview of Change Management 17
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Packages and Object Types 

A package is the fundamental work unit of Mercury Change Management. A 
package consists of the objects that are processed through a business 
workflow. Each object belongs to an object type. Each object type has a unique 
set of parameters that determines the information it requires, as well as any 
additional information it may accept. 

While each package line can be acted upon separately, the group of package 
lines and objects represent a logical unit that should be moved and tracked 
together. The processing of a package and package lines can vary greatly 
depending upon the workflow specified for that package. Figure 1-5 shows a 
sample package in the Package window.

Figure 1-5. Sample package in the Package window 

Object types have parameters that determine the information it requires, as 
well as any additional information it may accept. Each object type can also 
have associated commands which determines its behavior as it moves from one 
environment to another. Commands are used to define what a migration means 
for each type of object. For example, a File Object Type might only require the 
copying of a file while a Database Script Object Type might require both 
copying of a file as well as executing it against the destination database.

Object types are user-configurable. Mercury Change Management and its 
extensions also provide libraries of predefined object types, falling under one 
of the following categories:
18 Mercury Change Management™ User’s Guide



 Chapter 1: Introduction
� Standard Objects. Standard objects are predefined object types that are 
shipped with Mercury Change Management or one of the Change 
Management Extensions. These object types encapsulate the basic 
functionality that manages crucial Change Management actions; for 
example, migrating and executing file system-level objects and operating 
system commands, or applying patches to an Oracle applications instance. 
A simple standard object type is the File Migration object, which copies a file 
from one environment to another. A more complex standard object type is 
the SQL Script, which not only copies the file but also executes the script 
against the destination database.

� Custom Objects. Customers will often need to customize standard object 
types, or produce entirely new object types, in order to handle the 
requirements of their software environments and change management 
processes. A custom objects category is provided to help distinguish these 
customized object types from those that come standard with Mercury 
Change Management or its extensions. Such object types may have been 
designed by the customer or by consultants, and are often used for 
integration with specific third-party tools or in-house products.

� Mercury IT Governance Migrator Objects. Mercury IT Governance 
Migrator objects are object types that contain functionality to export and 
import configuration information. These may be used for several purposes 
including: 

� To transfer configuration information between distinct Mercury IT 
Governance instances/installations

� To extract information from a Mercury IT Governance database 
schema into an XML file

� To load information from an XML file into a database schema. 

This means that you can migrate configuration information using standard 
change management test practices, processing a package through a 
workflow.
Overview of Change Management 19
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Workflows and Workflow Steps 

A workflow consists of a logical series of steps that define the path followed 
by objects in a package. Workflow configuration and routing can be 
customized and the workflow engine can handle virtually any business 
practice. This allows a department to generate workflows to automate existing 
processes, rather than forcing users to adopt a new set of processes to perform 
their work.

Workflow steps can range in usage from functional approvals to actual 
migrations. For example, migration steps automatically move specified objects 
from source environments to destination environments.

Workflow steps are events that are linked together to form a complete 
workflow. Mercury Change Management uses four types of workflow steps: 

� Decision Workflow Steps. Decision workflow steps are workflow steps 
where you or group of users need to indicate a result or outcome; for 
example, an approval of work or an indication that a review has been 
completed. 

� Execution Workflow Steps. Execution workflow steps are where the 
system performs an action and then updates the step with its result. These 
actions can be as simple as calculating the value for a token or as complex 
as copying files, running programs, or updating Web pages. 

� Condition Workflow Steps. Condition workflow steps are logic steps 
used for complex workflow processing; for example, allowing a workflow 
to proceed only after all of the prerequisite steps are completed.

� Subworkflow Workflow Steps. Subworkflow workflow steps are entire 
workflows that have been enabled for use as subworkflows. When 
modeling business processes that include predefined procedures, 
subworkflows are a useful time saver.

A sample workflow is shown in Figure 1-6:
20 Mercury Change Management™ User’s Guide
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Figure 1-6. Package workflow

Environments

A Mercury Change Management environment is composed of a unique 
combination of server, client, database, and file system data that represents one 
logical group. 

Figure 1-7. Mercury Change Management environment

The environment server represents the main host machine for the environment. 
This machine may be of any platform type; for example UNIX or Windows 
2000. Typically, the server is a UNIX machine that also houses the database 
for this environment.

The environment client represents a remote client machine that also serves to 
identify the specified environment. The client is typically defined when users 
are doing multiplatform development in a client/server environment, with 
some development done on UNIX, and some on Windows 2000. The client can 
correspond to a file server that stores client code accessed by users. Many 
programs; for example, transactional forms, have both client and server 
components; for example, the user interface code and the database objects, 
respectively. Figure 1-8 shows an example of an environment definition in the 
Environment window. 
Overview of Change Management 21
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Figure 1-8. Sample environment

Integrating Change Management 

Integration with Version Control

Mercury Change Management provides complete integration with all standard 
version control systems including RCS, SCCS, PVCS, ClearCase, CCC/
Harvest, and Visual SourceSafe. The Change Management outbound API 
provides all check-in, check-out, and promotion functions during deployment.

File system objects can be deployed to new installations and updated in version 
control simultaneously. This synchronizes your version control repository, 
physical installations, and Change Management workflows.
22 Mercury Change Management™ User’s Guide



 Chapter 1: Introduction
Integration with Mercury Demand Management

Mercury Change Management serves as a system to manage the physical 
deployment of changes to your applications environment, but of equal 
importance is the gathering and analysis of issues (requests) related to the 
stability of the system. To facilitate this request gathering, Change 
Management is integrated with Mercury Demand Management™.

Like Mercury Change Management, Mercury Demand Management is a 
workflow-based system that features complete audit trail tracking of requests 
from inception to close. The tight integration between Demand Management 
and Change Management allows packages to be automatically generated from 
requests. 

The requests are then automatically updated upon completion of the package. 
This closed-loop integration ensures a coherent and consistent view of your 
issue statuses and removes the need for redundant data across multiple 
applications.

Integration with Third-Party Applications through Change Management Extensions

Mercury Change Management Extensions are application-specific modules 
that automate the deployment and post-deployment steps of objects, files, and 
patches. Extensions are fully integrated with the Mercury Change Management 
to provide a total solution for managing various enterprise applications. The 
following extensions are currently available:

� Mercury Change Management Extension for Databases™

� Mercury Change Management Extension for Oracle® E-Business Suite™ 

� Mercury Change Management Extension for Oracle® Technology™

� Mercury Change Management Extension for E-Commerce Technologies™

� Mercury Change Management Extension for SAP® Solutions™ 

� Mercury Change Management Extension for PeopleSoft® Enterprise™

� Mercury Change Management Extension for Siebel® eBusiness 
Applications™
Overview of Change Management 23
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An Overview of Packages 

Mercury Change Management automates the migrations and deployment of 
software code, configurations, and content. These objects are grouped into 
packages and are routed along business processes (workflows) using the 
Workbench and the standard interface. Workflows automate the process of 
moving each package through their required steps. 

For example, you might want to copy an operating system patch from the 
development environment, Dev, to the test environment, Test (see Figure 2-1). 
Once the operating system patch is thoroughly tested, you can then copy the 
patch to production environment, Prod. 

Figure 2-1. Mercury Change Management 

A package is the fundamental work unit of Mercury Change Management. 
Each package follows a workflow (business process). As with any business 
process, decisions need to be made and actions need to be taken. Each 
decisions or action becomes a workflow step. When a decision needs to be 
made, you must manually update a workflow step to reflect the decision. 
However, some actions; for example, migrating a file from one environment to 
another environment, can be configured to happen automatically. The basic 
components required to configure a workflow step to automatically migrate a 
file from one environment to another environment are:

� A package, which defines the file’s name, location, and type. A package 
also defines which workflow to follow. 

� A workflow, which defines when a file migration (workflow step) will 
happen and the source and destination environments for the file migration. 
26 Mercury Change Management™ User’s Guide
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When a package is created, a workflow is associated with that package. Only 
one workflow can be associated with a package. The workflow defines the 
various workflow steps the package must take. Figure 2-2 shows an example 
of a simple workflow. In this example, the following are the workflow steps:

� Approve Package

� Dev to Test (migration)

� Test Package

� Test to Prod (migration)

� Exit 

Figure 2-2. Workflow and workflow steps 

Approve Package and Test Package are manual workflow steps you will need 
to execute during the workflow. Dev to Test and Test to Prod are automatic 
workflow steps that must be properly configured to execute correctly. 

In Figure 2-3, a package in the Package Workbench is associated with a 
workflow in the Workflow Workbench. Within the workflow are workflow 
steps. Migration workflow steps (for example, Dev to Test and Test to Prod) 
are configured with source and destination environments. Environments are 
accessed and configured in the Environment Workbench. 

In Figure 2-3, the package is configured with a single package line. This 
package line is configured with an object type. There can be only one object 
type per package line. The object type contains information required to migrate 
a file (an object) including the name of the file, the location of the file, and the 
type of file (ASCII or binary). Depending on the definition of the object type, 
other information might be required. 

You do not need to know how to configure a workflow step or even a workflow. You 
do need to know how to access the information in a workflow, workflow step, and 
environment to properly assign a workflow to a package. 
An Overview of Packages 27
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Figure 2-3. How a package comes together 

Object types are defined in the Object Type Workbench. In the Object Type 
Workbench, you can open and access the command sequence used to migrate 
the object across environments. These command sequences include special 
commands, which are defined in the Special Command Workbench. 
28 Mercury Change Management™ User’s Guide
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When you are creating a package, you will need to know the following:

� The workflow (defined in the Workflow Workbench)

� The environments (specified in the workflow step and defined in the 
Environment Workbench)

� The object type (defined in the Object Type Workbench)

An Overview of Packages in the Standard Interface

Existing packages can be viewed in the standard interface using the package’s 
detail page. From a package’s detail page, you can add notes and references to 
the package, and you can process the package through its workflow. When 
adding a new package as a reference to a request, you do not access the 
Package window in the Workbench. Instead, you access a New Package page in 
the standard interface. Creating a new package using the New Package page 
does not create a complete package ready for submission. Instead, the New 
Package page opens and saves a package in the standard interface. You must 
still add the package lines to the package using the Package window in the 
Workbench. Figure 2-4 shows a package’s detail page. 
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Figure 2-4. Package detail page 
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Package Detail Page, Header Section 

A package’s detail page Header section contains general information 
concerning the package; for example, who created the package, the date, and 
the associated workflow. The Header section is included in the package 
creation process and stays with the package throughout the workflow steps. 
Typically, when creating a package, you need to complete some of the fields in 
the Header section. Figure 2-5 shows a typical Header section. The information 
in the package’s detail page Header section is found in the Package window’s 
general information section. 

Figure 2-5. Package detail page, Header section 

Package Detail Page, Status Section 

A package’s detail page Status section displays the current status of the 
package. When a package is first created in the standard interface, the Status 
section does not exist. Once the package is submitted, the Status section 
displays the package lines and all of the workflow steps in the associated 
workflow. Figure 2-6 shows the Status section of a package’s detail page. 

Figure 2-6. Package detail page, Status section 
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Package Detail Page, Notes Section 

A package’s detail page Notes section contains fields where notes and 
information concerning the package can be entered and stored. The Notes 
section is included in the package creation process and continues with package 
until it is closed. Typically, when creating a package, you do not need to add a 
note to the package. 

Figure 2-7 shows a typical Notes section. All Notes sections include the Add 
Note section. The Existing Notes section is created when the request’s first note 
is created. 

Figure 2-7. Package detail page, Notes section 

Package Detail Page, References Section 

A package’s detail page References sections contain additional information 
concerning the package. For example, you might add a URL to a package or 
delete an outdated document from a package. The References section is 
included in the package creation process and continues with the package until 
the package is closed. References can be added or deleted from the package.

The Reference Addition section is used to add a reference to the package. Saved 
references are organized by reference type; for example, all saved reference 
packages are saved in the Packages section. For some references, a functional 
dependency between the package the referenced entity can be created. For 
more information concerning references and their functional dependencies, see 
Reference Relationships on page 41. 

Figure 2-8 shows the References section of a package’s detail page. 
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Figure 2-8. Package detail page, References section 

An Overview of Packages in the Workbench 

Existing packages can be viewed in the Package window using the Package 
Workbench. From a Package window, you can add notes and references to the 
package, and you can process the package through its workflow. From the 
Package window, you can create a package, submit the package, process the 
package through the workflow, cancel the package, and delete the package. 
Figure 2-9 shows a package’s detail page. 

Figure 2-9. Package window 
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Package Window, General Information Section 

A Package window’s general information section contains general information 
concerning the package; for example, who created the package, the date, and 
the associated workflow. The general information section is included in the 
package creation process and stays with the package. Typically, when creating 
a package, you need to complete some of the fields in the general information 
section. Figure 2-10 shows a typical general information section. The 
information in a package’s detail page Header section is found in the Package 
window’s general information section. 

Figure 2-10. Package window, general information 

Package Window, Package Lines Tab 

The Package Lines tab lists the package lines associated with a package. 
Package lines define the object migrating from one environment to another 
environment. Each package line defines one object (file). Typically, objects 
(files) are defined by their object type (for example, File Client > Client or File 
Migration), filename, location, and file type. You cannot define multiple 
objects on a single package line. Figure 2-11 shows a typical Package Line tab 
with package lines. 
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Figure 2-11. Package window, Package Lines tab 

Package Window, Status Tab 

The Package window Status tab displays the current status of the package. 
When a package is first created, the Status tab displays the package lines. Once 
the package is saved or submitted, the Status tab displays the package lines and 
all of the workflow steps in the associated workflow. 

Use the Status tab to see:

� All the possible actions that can take place for the package

� All the actions that have taken place so far 

� The current pending actions that need to be taken for package resolution

Once a package is submitted, the Status tab is where you process the package 
through the workflow. Each package line includes all of the workflow steps in 
the workflow. The workflow steps eligible for action have the word Eligible 
(see Figure 2-12). 
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Figure 2-12. Package window, Status tab 

Once a package is submitted, a package line can be expanded to show any of 
the subworkflow steps used in the workflow definition. To view the 
subworkflow steps, click expand above the subworkflow step. You can also 
click on the Expand All icon to expand all subworkflows contained within the 
Status tab. To hide expanded subworkflow steps, click collapse above the 
subworkflow step. To hide all subworkflow steps, click the Collapse All icon.

Clicking the expand icon horizontally expands the package line to display all 
of the steps within the subworkflow. Subworkflow steps have a different 
colored header and are numbered using additional decimal places 
corresponding to the level of the Workflow. 

If Step 3 of a top-level workflow is a subworkflow, its steps are displayed as 
3.1, 3.2, 3.3, and so forth. Similarly, if the second step in that subworkflow is 
also a subworkflow step, its steps are displayed as 3.2.1, 3.2.2, 3.2.3, and so 
forth. 

From the Status tab, you can access several log files, a graphical view of the 
workflow, transaction histories, and detail files concerning the package. These 
files, views, and histories will help you as you process your package. 

Collapse All Expand All 
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Accessing the Line Execution Log

It is possible to select a package line and get the details of the execution of that 
particular line by viewing the Line Execution Log. The line viewed is a subset of 
the overall execution batch log. 

If the package line has been configured to migrate to multiple environments 
using an environment group, the execution log returns an execution summary 
and link for each Destination Environment. Click the link to get the detailed 
execution logs for each environment.

Accessing the Package Execution History

The Package Execution History displays the execution history of each package 
line. It displays the workflow step name, execution date, and outcome 
(Succeeded or Failed) of each execution step. 

If the package line has been configured to migrate to multiple environments 
using an environment group, the execution log returns an execution summary 
and link for each Destination Environment. Click the link to get the detailed 
execution logs for each environment.

Viewing the Graphical View 

To see the workflow, select the Graphical View window (see Figure 2-13). Use 
the legend at the top of the window to determine which workflow steps have 
been visited and which steps are active. This image displays all of the 
workflow steps and subworkflows used in the workflow definition. 

To obtain a graphical view of a particular subworkflow, select the 
subworkflow name from the Show Subworkflow Step drop-down list located at 
the bottom of the window. This opens a new window that displays the 
graphical view of that subworkflow.
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Figure 2-13. Graphical View window for a package

Viewing Line Permissions 

Workflow permissions are established during the initial workflow 
configuration. The Line Permissions view lists all users in security groups that 
have been enabled for the related workflow step. If you have questions 
regarding the permissions set for a particular workflow step, consult your 
application administrator.

Viewing the Line Transaction History 

You can view the transaction history of each package line. This provides 
detailed information on how the package line has proceeded through a Change 
Management workflow. Information; for example, as the date of the 
transaction event, the user linked to the workflow step, the workflow step 
name and number, status, and results are displayed. 

Select Full transaction history to display information on the subworkflow steps 
that have been traversed more than once by a single package line. 

Selecting Current transaction status will display only information on the most 
recent transaction through that step.
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Viewing the Decision Detail 

The Decision Detail displays the decision history of each workflow step. It 
displays the date, resource, and decision of the decision workflow step. 

Viewing the Workflow Step Information URL 

Workflow steps can be configured to include a URL that provides information 
regarding the workflow step. If the information URL is configured for a 
workflow step, you can view the URL in the Workflow Step Information URL 
window. 

Package Window, Notes Tab 

A package window’s Notes tab (see Figure 2-14) contains fields where notes 
and information concerning the package can be entered and stored. The Notes 
section is included in the package creation process and continues with the 
package until it is closed. Typically, when creating a package, you do not need 
to add a note to the package. 

Figure 2-14. Package window, Notes tab 
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Package Window, References Tab

A package window’s References tab (see Figure 2-15) contains additional 
information concerning the package. For example, you might add a URL to a 
package or delete an outdated document from a package. The References tab is 
included in the package creation process and continues with the package until 
the package is closed. References can be added or deleted from the package.

The Reference Addition section is used to add a reference to the package. Saved 
references are organized by reference type; for example, all saved reference 
packages are saved in the Packages section. For some references, a functional 
dependency between the package and the referenced entity can be created. For 
more information concerning references and their functional dependencies, see 
the next section. 

Figure 2-15. Package window, References tab 
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Reference Relationships 

For some references, a functional dependency between the package and the 
referenced entity can be created. For example, you can specify that a request is 
a predecessor to the package. This means the package will not continue until 
the request is closed. 

� Predecessor Relationships. Predecessor relationships dictate that action is 
not allowed on one entity until the referenced entity closes. For example, a 
package cannot complete any workflow action until the referenced task is 
closed (Completed, Bypassed, or Cancelled). The package’s status is 
Pending Task. When the task closes, the package can be acted upon once 
more. This does not stop other request fields from being edited. 

� Successor Relationships. Successor relationships dictate that action is not 
allowed on referenced entity until the entity closes. For example, a 
referenced task cannot change its status until the original package is closed. 
The task’s status is Pending Request. When the package closes, the task 
can be acted upon once more. This does not stop other task fields from 
being edited. 

See Table 2-1 for a list of the references, their definitions, and their possible 
dependency relationships. 
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Table 2-1. References and relationships 

Reference Reference
Description 

Possible
Relationships

Relationship
Description

Attachment

Attach a file from a local 
machine to the current 
package. The attached file 
is copied to the server. 

Standard attachment 
interaction

(Informational) The attachment is 
related to this package.

Packages 
(Existing)

Reference an existing 
package. 

Duplicate package
(Informational) The referenced 
package is a duplicate of the 
package.

Run before this 
package in a release

(Informational) In a release, the 
selected package should be run 
before this package. 

Run after this 
package in a release

(Informational) In a release, the 
selected package should be run 
after this package. 

Predecessor
(Blocking) Action is not allowed on 
the package until the referenced 
package closes.

Successor
(Blocking) Action is not allowed on 
the referenced package until the 
package closes. 

Packages 
(New)

New packages can also be 
created from a package.

If configured as part of the 
workflow, you can spawn a 
package from a workflow 
step. When this happens, a 
reference to that package is 
automatically generated, 
establishing a two-way link 
between the packages. 

Run before this 
package in a release

(Informational) In a release, the 
selected package should be run 
before this package. 

Run after this 
package in a release

(Informational) In a release, the 
selected package should be run 
after this package. 

Predecessor
(Blocking) Action is not allowed on 
the package until the referenced 
package closes.

Successor
(Blocking) Action is not allowed on 
the referenced package until the 
package closes. 

Programs
Reference a program in 
Mercury Program 
Management™. 

Related to This 
program 

(Informational) Selected program is 
related to this package.

Projects
Reference a project in 
Mercury Project 
Management™. 

Related to This 
package 

(Informational) Selected project is 
related to this package.
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Releases
Reference a release in 
Change Management.

Contains this 
package

(Informational) The package is 
contained in the selected release.

Request 
(Existing)

Reference an existing 
request. 

Parent of this 
package

(Informational) The referenced 
request is the parent of the 
package.

Related to this 
package

(Informational) Referenced request 
is related to this package. 

Predecessor
(Blocking) Action not allowed on 
this package until the referenced 
request closes.

Successor
(Blocking) Action not allowed on 
the referenced request until this 
package closes.

Requests 
(New)

New packages can be 
created from an existing 
package.

Also, if configured as part 
of the workflow, you can 
spawn a package from a 
package. When this 
happens, a reference to 
that package is 
automatically generated, 
establishing a two-way link 
between the packages. 

Parent of this 
package

(Informational) The referenced 
request is the parent of the 
package.

Related to this 
package

(Informational) Referenced request 
is related to this package. 

Predecessor
(Blocking) Action not allowed on 
this package until the referenced 
request closes.

Successor
(Blocking) Action not allowed on 
the referenced request until this 
package closes.

Tasks
Reference a task in a 
Mercury Project 
Management. 

Related to this 
package

(Informational) The referenced task 
is related to this package.

URL
Reference a Web address. 
Documents at the URL 
must be in MIME format. 

Standard URL 
interaction

(Informational) The URL is related 
to this package.

Table 2-1. References and relationships  [continued]

Reference Reference
Description 

Possible
Relationships

Relationship
Description
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Predecessor Relationships 

Predecessor relationships dictate that action is not allowed on one entity until 
the referenced entity closes. For example, a package cannot complete any 
workflow action until the referenced task is closed (Completed, Bypassed, or 
Cancelled). The package’s status is Pending Task. When the task closes, the 
package can be acted upon once more. This does not stop other request fields 
from being edited. 

Successor Relationships 

Successor relationships dictate that action is not allowed on referenced entity 
until the entity closes. For example, a referenced task cannot change its status 
until the original package is closed. The task’s status is Pending Request. 
When the package closes, the task can be acted upon once more. This does not 
stop other task fields from being edited. 
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An Overview of Creating Packages 

This chapter provides instructions for creating and submitting packages to 
deploy software and application changes. Typically, packages are created 
using the Workbench, however, you can create a package in any one of the 
following ways:

� Creating a new package from the Workbench 

� Creating a new package as a referenced entity 

� Creating a new package by copying an existing package 

Once a package is created, it must be submitted to start the workflow (business 
process). See Submitting Packages on page 76 for information on how to 
submit a package. 

Before You Begin Creating Packages

Before you create a package, you need to know the following information:

� The workflow (defined in the Workflow Workbench)

� The environments (specified in the workflow step and defined in the 
Environment Workbench)

� The object type (defined in the Object Type Workbench)

Selecting Workflows 

Each package is processed through a predefined workflow. You must select a 
workflow for each package you create. It is essential that you route your 
packages through workflows that properly model the appropriate business 
process.

To view the graphical layout of a Mercury Change Management workflow:

1. Open the Workbench.

For information on how to open the Workbench, see the Getting Started 
guide. The Workbench opens. 

2. From the shortcut bar, select Configuration > Workflows. 

The Workflow Workbench opens.
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3. In the Workflow Workbench, click List to display all of the workflows. 

You can restrict the search by entering one or more of the query 
parameters.

4. In the Workflow Workbench, select one or more of the listed workflows and 
click Open. 

The Workflow window opens.

5. In the Workflow window, click the Layout tab to view the workflow’s 
graphical representation. 

Make sure the workflow follows the correct business process. If not, open a 
different workflow. 

6. In the Layout tab, double-click on the migration workflow steps. 

The Workflow Step window for that workflow step opens.

7. In the Workflow Step window, verify that the listed source and destination 
environments are correct. 
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8. In the Workflow Step window, open any of the tabs to view the following 
information:

� Properties. This tab contains general information about the workflow 
step.

� Security. This tab is used to define the security groups that are allowed 
to act on a particular step. All of the enabled security groups will 
appear in either the Available Security Groups field or the Linked Security 
Groups field. Each user who belongs to a Linked Security Group is able to 
perform the actions defined for that particular workflow step.

� Notifications. This tab is used to attach email notifications to the 
specific workflow step. Email messages can be sent whenever an event 
occurs at a workflow step. An event can be when the step becomes 
eligible or when the step completes with a specific result.

� Timeout. This tab on displays any timeouts set for this workflow step.
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� User Data. This tab on displays any custom fields for each workflow 
step.

� Results. This tab lists all the valid results the step can have.

9. Close the Workflow Step window. 

Verifying Environments 

Specific workflow steps specify the source and destination environments. If 
you are not sure the specified environments are correct, you can open the 
specified environments in the Environment Workbench.

To access an environment:

1. Open the Workbench.

For information on how to open the Workbench, see the Getting Started 
guide. The Workbench opens. 

2. From the shortcut bar, select Environments > Environments. 

The Environment Workbench opens.

3. In the Environment Workbench, click List to display all of the workflows. 

You can restrict the search by entering one or more of the query 
parameters.

4. In the Environment Workbench, select one or more of the listed 
environments and click Open. 

The Environment window opens.

5. In the Environment window, check the server, client, and database defined. 

6. Close the Environment window.
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Verifying Object Types 

When creating a package, the available object types are listed in an 
auto-complete list. If you want to view the available object types before you 
create a package, you can open an object type in the Object Type Workbench. 
Table 3-1 lists the Mercury-supplied object types.

Additional object types are available with the Mercury Change Management 
Extensions. 

Table 3-1. Object types 

Object Type Description

File Client>Client File copy from client to client.

File Migration File copy from environment to environment.

ITG Data Source Migrator Migrates an IT Governance data source migrator. 

ITG Module Migrator
Migrates an Mercury IT Governance module from 
one Mercury IT Governance Center environment to 
another Mercury IT Governance Center environment. 

ITG Object Type Migrator
Migrates an Mercury IT Governance object type from 
one Mercury IT Governance Center environment to 
another Mercury IT Governance Center environment. 

ITG Overview Page Section 
Migrator

Migrates an Mercury IT Governance overview page 
section from one Mercury IT Governance Center 
environment to another Mercury IT Governance 
Center environment. 

ITG Portlet Definition 
Migrator

Migrates an Mercury IT Governance portlet definition 
from one Mercury IT Governance Center 
environment to another Mercury IT Governance 
Center environment. 

ITG Project Template 
Migrator

Migrates an Mercury IT Governance project template 
from one Mercury IT Governance Center 
environment to another Mercury IT Governance 
Center environment. 

ITG Report Type Migrator
Migrates an Mercury IT Governance report type from 
one Mercury IT Governance Center environment to 
another Mercury IT Governance Center environment. 
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To open an object type:

1. Open the Workbench.

ITG Request Header Type 
Migrator

Migrates an Mercury IT Governance request header 
type from one Mercury IT Governance Center 
environment to another Mercury IT Governance 
Center environment. 

ITG Request Type Migrator

Migrates an Mercury IT Governance request type 
from one Mercury IT Governance Center 
environment to another Mercury IT Governance 
Center environment. 

ITG Special Command 
Migrator

Migrates an Mercury IT Governance special 
command from one Mercury IT Governance Center 
environment to another Mercury IT Governance 
Center environment. 

ITG User Data Context 
Migrator

Migrates an Mercury IT Governance user data 
context from one Mercury IT Governance Center 
environment to another Mercury IT Governance 
Center environment. 

ITG Validation Migrator
Migrates an Mercury IT Governance validation from 
one Mercury IT Governance Center environment to 
another Mercury IT Governance Center environment. 

ITG Workflow Migrator
Migrates an Mercury IT Governance workflow from 
one Mercury IT Governance Center environment to 
another Mercury IT Governance Center environment. 

OS/390 JCL Migration
Migrates an OS/390 JCL from one environment to 
the destination environment. 

PVCS File Migration
Migrates an object from the PVCS archive to the 
destination environment. 

RCS File Migration
This object manages the check out and distribution of 
code in RCS. 

RCS Server File
Old file will be checked in on the destination 
environment. New file will be checked in and checked 
out Read-Only on the destination environment.

SourceSafe File Migration
Manages the check out and promotion of files from 
the SourceSafe version control archive. 

Table 3-1. Object types  [continued]

Object Type Description
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For information on how to open the Workbench, see the Getting Started 
guide. The Workbench opens. 

2. From the shortcut bar, select Change Mgmt > Object Types. 

The Object Types Workbench opens.

3. In the Object Types Workbench, click List to display all of the object types. 

You can restrict the search by entering one or more of the query 
parameters.

4. In the Object Types Workbench, select one or more of the listed object types 
and click Open. 

The Object Types window opens.

5. In the Object Types window, click the Commands tab. 

6. In the Commands tab, check the commands the object type calls.

7. Close the Object Types window.
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Creating New Packages 

Typically, packages are created using the Workbench; however, you can create 
a package in any one of the following ways:

� Creating a new package using the Workbench 

� Creating a new package by copying an existing package

� Creating a new package as a referenced entity 

Creating Packages Using the Workbench

Packages are used to deploy software and application changes. This section 
covers how to define the contents of a package, including adding package lines 
and specifying the appropriate deployment workflow. For each instance of a 
software migration submission, a new package needs to be created. 

To create a new package from the Workbench: 

1. Open the Workbench. 

For information on how to open the Workbench, see the Getting Started 
guide. The Workbench opens. 

2. From the shortcut bar, select Change Mgmt > Packages.

In most cases, Change Mgmt > Packages is default location when a 
Workbench opens. The Package Workbench opens.

3. In the Package Workbench, click New Package. 

The Package window opens. The Package window is where you will define 
the contents of the package. 
Creating New Packages 53



 Chapter 3: Creating New Packages
4. In the general information section, complete the fields. 

For information on how to complete the fields of the general information 
section, see Completing the General Information Section for Packages 
on page 59. 

5. In the Package Lines tab, add the package lines to the package. 

Package lines capture information specifically related to each object that 
you are migrating from one environment to another environment. For 
information on how to add package lines, see Adding Package Lines to 
Packages on page 60. 

6. In the Notes tab, add any notes to the package. 

For information on how to add notes, see Adding Notes to Packages 
on page 63. 

7. In the References tab, add any references to the package. 

For information on how to add notes, see Adding References to Packages 
on page 64. 
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8. Save the package.

To save the package, click OK or Save. Clicking OK saves the package and 
closes the Package window. Clicking Save saves the package and keeps the 
Package window open. 

Creating Packages by Copying Packages 

You can create a new package by copying an existing package. The existing 
package need only exist, even as a new or closed package. You will be able to 
select what sections of the existing package are to be copied into the new 
package. 

To create a new package by copying an existing package: 

1. Open the Workbench. 

For information on how to open the Workbench, see the Getting Started 
guide. The Workbench opens. 

2. From the shortcut bar, select Change Mgmt > Packages.

In most cases, Change Mgmt > Packages is default location when a 
Workbench opens. The Package Workbench opens.

3. In the Package Workbench, in the Query tab, click List. 

The Package Workbench Results tab lists all of the existing packages. 

4. In the Package Workbench, in the Results tab, select an existing package 
and click Copy. 

The Copy Package window opens. 

5. In the Copy Package window, select the sections to be included in the new 
package and click OK. 
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The Package window opens. The selected information from the original 
package appears in the fields.

6. In the Package window, click OK or Save.

The package line is added to the package. 
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Creating Packages as References from Packages 

You can create a new package as part of referencing a new package to an entity 
such as a request or another package. For example, open a saved package and 
click the References tab. In the References tab, select Package (New) as the 
reference to create. The New Reference Package window opens. 

In the New Reference Package window, select the relationship (see Figure 3-1) 
and click Create. Another Package window opens where you can create a new 
package. 

Figure 3-1. New Reference - Package (New) window

Creating Packages as References from Requests 

You can create a package as a reference from a request. When creating a 
package from a request, you do not open the Workbench, even if you have the 
correct permissions. Instead, you work in the standard interface using the 
Create New Package and New Package pages. When you create a package as a 
reference from a request, you cannot add package lines, which means you 
cannot complete and submit the package. Adding package lines to a package 
and submitting a package requires using the Package Workbench. 

To create a package as a reference from a request: 

1. Log on to the Mercury IT Governance Center. 

For information on how to log on to the Mercury IT Governance Center, 
see the Getting Started guide.
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2. Open a request.

You can open an existing request or create a new request from the menu 
bar. To open an existing request or create a new request, see the Demand 
Management User’s Guide. The request’s detail page appears. 

3. In the request’s detail page, scroll down to the References section.

4. In the References section, from the New Reference drop-down list, select 
Package (New) and click Add. 

The Create New Package page appears.

5. On the Create New Package page, select the Relationship and click Create. 

The New Package page appears. 

6. On the New Package page, select the workflow from the drop-down list. 

7. On the New Package page, complete any of the other sections and fields and 
click Save. 

The package is saved. 

8. On the request’s detail page, click Save. 

The changes to the request are saved. 
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Completing the General Information Section for Packages 

To complete the general information section for packages: 

1. Open the Workbench. 

For information on how to open the Workbench, see the Getting Started 
guide. The Workbench opens. 

2. From the shortcut bar, select Change Mgmt > Packages.

In most cases, Change Mgmt > Packages is default location when a 
Workbench opens. The Package Workbench opens.

3. In the Package Workbench, in the Query tab, click New Package. 

The Package window opens. The Package window is where you will define 
the contents of the package. The package number is automatically filled in. 

4. In the Package window, complete the required fields.

� The Package No. field is required. The package number is automatically 
completed. 

� The Workflow field is required. Select the workflow from the 
auto-complete list.

5. In the Package window, click OK or Save.

The package line is added to the package. 
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Adding Package Lines to Packages 

Package lines define the object migrating from one environment to another 
environment. Each package line defines one object (file). Typically, objects 
(files) are defined by their object type (for example, File Client > Client or File 
Migration), filename, location, and file type. You cannot define multiple 
objects on a single package line. 

To add a package line to package: 

1. Open the Workbench. 

For information on how to open the Workbench, see the Getting Started 
guide. The Workbench opens. 

2. From the shortcut bar, select Change Mgmt > Packages.

In most cases, Change Mgmt > Packages is default location when a 
Workbench opens. The Package Workbench opens.

3. In the Package Workbench, open an existing package or create a new 
package. 

The Package window opens. The Package window is where you will define 
the contents of the package. 

4. In the Package window, click New Line. 

The Add Line window opens. In the Add Line window, you will select the 
object type and complete the fields associated with the selected object type. 

5. In the Add Line window, in the Object Type field, select the object type for 
the object (file) you plan to migrate using the auto-complete icon. Selecting 
an object type dynamically updates the fields of the Add Line window. 
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6. In the Add Line window, complete the associated fields and click OK. 

In some cases, you can add multiple package lines from a single Add Line 
window. You can do this when you have multiple objects (files) to migrate 
that are in the same location. To add multiple lines from a single Add Line 
window, the following must be true: 

� Package lines all follow the same workflow and use the same object 
type 

� The object type parameters include at least one auto-complete list field 
with an enabled Multi button.

By selecting multiple files, you will add multiple package lines to the 
package. Remember, you cannot define multiple objects on a single 
package line. 
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The contents of the Add Line window are included in the Packages window 
as a package line. The Add Line window closes. In the Add Line window, 
clicking Add includes the package line in the Package window and the Add 
Line window remains open. 

7. In the Package window, click OK or Save.

The package line is added to the package. To start the package on its 
associated workflow, click Submit. Submitting the package to the 
workflow generates entries under the Status tab for each of the workflow 
steps defined for the workflow. As each step in the workflow is ready to be 
processed, the step shows an Eligible status. You can view the progress of 
each package line by clicking the Status tab. For more information 
concerning submitting a package, see Submitting Packages on page 76. 
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Adding Notes to Packages 

In the Package window, the Notes tab (see Figure 3-2) contains additional 
information concerning the package. Click the Notes tab to access it. Notes are 
attached to the package, not individual package lines. If you have a note that is 
specific to a package line, you must include the package line reference as part 
of the note’s text. 

Figure 3-2. Package window, Notes section 

You can add notes to existing packages, packages being created, and submitted 
packages that have not been closed. You cannot add a note to a closed package. 

To add a note, open a package and click the Notes tab. In the New Notes field, 
enter the text of the note and click Save. The note is added to the Existing Notes 
field. 
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Adding References to Packages 

A Package window References tab contains additional information concerning 
the package. For example, you might add a document or URL to a package. 
The following lists the references that can be added to a package: 

� Attachment

� Package (New and Existing)

� Project

� Release

� Request (New and Existing)

� Task

� URL

For some references (such as requests and other packages), a functional 
dependency to the original package can be created. For example, you can 
specify that a request is a predecessor to the package. This means the package 
will not continue until the request is closed. See Reference Relationships 
on page 41 for a list of the references and their possible dependency 
relationships. 

Adding References 

This section shows how to add an attachment as a reference. For information 
concerning how to add all of the valid references, see Adding Additional 
References on page 66. 

To add a reference to a package:

1. Open the Workbench. 

2. For information on how to open the Workbench, see the Getting Started 
guide. The Workbench opens. 

3. From the shortcut bar, select Change Mgmt > Packages.

In most cases, Change Mgmt > Packages is default location when a 
Workbench opens. The Package Workbench opens.
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4. Open an existing package or create a new package. 

The Package window opens. 

5. In the Package window, click the References tab. 

The References tab opens. 

6. From the New Reference drop-down list, select the type of reference.

For this example, select Attachment. The Add Document window opens. 
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7. In the Add Document window, complete the fields and click Add. The 
attachment is displayed in the References tab.

8. In the Package window, click OK or Save. 

The document is added to the package. 

Adding Additional References 

This section lists the different references that can be added to a request. For 
complete instructions on how to add a reference, see Adding References to 
Packages on page 64. 

Adding Attachments as References 

You can reference an attachment to a package. To reference an attachment, 
from the New Reference drop-down list, select Attachment and click Add. The 
Add Document window opens. 

In the Add Document window, complete the fields and click Add (see 
Figure 3-3). The attachment appears in the References tab. You must save the 
package to add the reference. 

Figure 3-3. Add Document window 
66 Mercury Change Management™ User’s Guide



 Chapter 3: Creating New Packages
Adding Packages (Existing) as References 

You can reference existing packages to a package. To reference an existing 
package, from the New Reference drop-down list, select Package (Existing) and 
click Add. The New Reference Package window opens. 

Select the existing package from the Package No. auto-complete list. (You can 
also click Search to open a search window.) A list of relationship types is 
included in the window (see Figure 3-4). Select the type of relationship, the 
package or packages, and click Add. The package appears on the References 
tab. You must save the package to add the reference. 

Figure 3-4. New Reference Package (Existing) window 
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Adding Packages (New) as References 

You can reference a new package to a package. To reference a new package as 
a reference, from the New Reference drop-down list, select Package (New) and 
click Add. The New Reference Package window opens (see Figure 3-5). In the 
New Reference Package window, select the relationship and click Create. 

A new Package window opens. Complete the new Package window and click 
Save or OK. The package appears on the References tab. You must save the 
package to add the reference.

Figure 3-5. New Reference - Package (New) window
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Attaching Programs as References 

You can reference existing programs to a package. To reference an existing 
program, from the New Reference drop-down list, select Program and click 
Add. The New Reference Program window opens. 

In the New Reference Program window, select the program from the 
auto-complete list. In the New Reference Program window, select the type of 
relationship and click Add (see Figure 3-6). The program appears on the 
References tab. You must save the package to add the reference.

Figure 3-6. New Reference Program window 
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Attaching Projects as References 

To attach existing projects as a reference, from the New Reference drop-down 
list, select Project and click Add. The New Reference Project window opens. In 
the New Reference Project window, select the project from the Project Name 
auto-complete list. 

In the New Reference Project window, select the type of relationship and click 
Add (see Figure 3-7). (You can also click Search to open a search window.) 
The project appears on the References tab. You must save the package to add 
the reference. 

Figure 3-7. New Reference Project window
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Adding Releases as References 

You can reference existing releases to requests. To reference an existing 
release, from the New Reference drop-down list, select Release and click Add. 
The New Reference Release window opens. 

In the New Reference Release window, select the release from the 
auto-complete list. In the New Reference Release window, select the type of 
relationship and click OK (see Figure 3-8). The release appears on the 
References tab. You must save the package to add the reference. 

Figure 3-8. New Reference Release window
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Adding Requests (Existing) as References 

You can reference existing requests to requests. To reference an existing 
request, from the New Reference drop-down list, select Request (Existing) and 
click Add. The New Reference Request (Existing) window opens. 

In the New Reference Request (Existing) window, select the request from the 
Request No auto-complete list. (You can also click Search to open a search 
window.) In the New Reference Request (Existing) window, select the type of 
relationship and click Add. The existing request appears on the References tab. 
You must save the package to add the reference. 

Figure 3-9. Add Reference: Request 
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Adding Requests (New) as References 

You can reference new requests to a package. To reference a new request, from 
the New Reference drop-down list, select Request (New) and click Add. The 
New Reference Request (New) window opens. Select the type of request to 
create. 

In the New Reference Request (New) window, select a relationship and click 
Create (see Figure 3-10). A new browser window opens displaying the Create 
New Request page. Complete the Create New Request page and click Submit. 
The request appears on the References tab. You must save the package to add 
the reference. 

Figure 3-10. Create New Request 
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Adding Tasks as References 

You can reference existing tasks to packages. To reference an existing task, 
from the New Reference drop-down list, select Task and click Add. The New 
Reference Task window opens. In the New Reference Task window, select the 
task from the Task Name auto-complete list. (You can also click Search to open 
a search window.) 

In the New Reference Task window, select the type of relationship and click Add 
(see Figure 3-11). The existing task or tasks appear on the References tab. You 
must save the package to add the reference. 

Figure 3-11. New Reference Task window 
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Adding URLs as References 

You can reference an existing URL to a package. To reference an existing 
URL, from the New Reference drop-down list, select URL and click Add. The 
New Reference URL window opens. 

In the URL field, enter the URL address. In the Description field, enter a brief 
description of the URL and click Add (see Figure 3-12). The URL appears on 
the References tab. You must save the package to add the reference. 

Figure 3-12. Reference URL 
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Submitting Packages 

Once a package is complete, it is eligible for submission. To be complete, a 
package must have the following:

� A package number

� An associated workflow

� At least one package line 

In the Package window, when a package is complete and eligible for 
submission, the Submit button is enabled (see Figure 3-13). Click the Submit 
button to submit a package. Once a package is submitted, the Submit button is 
disabled. 

Figure 3-13. Submitted package, Status tab
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An Overview of Processing Packages

In Mercury Change Management, once a package has been submitted, it can be 
processed and managed. Processing packages refers to working with the 
package as the package proceeds through the workflow. 

You can locate packages requiring attention using one of the following 
methods: 

� Using the Package Workbench. Using the Query tab of the Package 
Workbench allows you to select search criteria when looking for a 
package. Once a package is found, highlight the package and click Open. 
The package opens in the Package window. 

� Using Portlets in the Standard Interface. The quickest way to locate 
relevant packages is through the standard interface. When included on a 
Mercury IT Governance Dashboard™ page, the My Packages portlet 
displays all the packages you have created or are assigned to you. Click a 
package number to open the package in the standard interface. For a list of 
other Mercury Change Management portlets, see Change Management 
Portlets on page 119. 

� Using Searches in the Standard Interface. Using search in the standard 
interface is another way to find a package. In the standard interface, from 
the menu bar, select Search > Packages. The Package Search page appears. 
In the Package Search page, complete the search criteria and click Search. 
The Package Search Results page appears. In the Package Search Results 
page, click a package number to open the package in the standard interface. 

� Using Notifications. As a package proceeds through its workflow, email 
notifications can be sent to alert you of pending actions. The notification 
might include a link to the package. Click the link to open the referenced 
package in the Workbench. If you are not currently logged on to the 
Mercury IT Governance Center, the Logon page opens. 

� Reporting on Open Packages from the Standard Interface. Mercury 
Change Management includes a predefined set of reports that generate 
HTML text and can be accessed by a Web browser. Among these reports is 
the Packages Pending Report, which reports on open packages with pending 
activity. For a list of Mercury Change Management reports, see Reports by 
Category on page 121. 

For More Information

For more information on how to process packages in the standard interface, see 
the next section (Processing Packages Using the Standard Interface). 
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Processing Packages Using the Standard Interface 

You can process packages in the standard interface using a package’s detail 
page. You can process a package through its entire workflow. You can add 
notes and references to the package, and make decisions concerning the status 
of the package. However, you cannot change or delete a package from the 
package’s detail page. To change or delete a package requires the Workbench. 
For information on processing packages using the Workbench, see Processing 
Packages Using the Workbench on page 94. 

Opening Existing Packages in the Standard Interface

To open an existing package:

1. Log on to the Mercury IT Governance Center.

For information on how to log on to the Mercury IT Governance Center, 
see the Getting Started guide

2. From the standard interface, open a package. 

You can open a package in one of the following ways: 

� Using Portlets in the Standard Interface. The quickest way to locate 
relevant packages is through the standard interface. When included on 
a Dashboard page, the My Packages portlet displays all the packages 
you have created. Click a package number to open the package in the 
standard interface. For a list of other Mercury Change Management 
portlets, see Change Management Portlets on page 119. 

� Using Searches in the Standard Interface. Using search in the 
standard interface is another way to find a package. In the standard 
interface, from the menu bar, select Search > Packages. The Package 
Search page appears. In the Package Search page, complete the search 
criteria and click Search. The Package Search Results page appears. In 
the Package Search Results page, click a package number to open the 
package in the standard interface. 

� Using Notifications. As a package proceeds through its workflow, 
email notifications can be sent to alert you of pending actions. The 
notification might include a link to the package. Click the link to open 
the referenced package in the Workbench. If you are not currently 
logged on to the Mercury IT Governance Center, the Logon page 
opens. 
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Approving Packages in the Standard Interface

To approve a package using the standard interface:

1. Log on to the Mercury IT Governance Center.

For information on how to log on to the Mercury IT Governance Center, 
see the Getting Started guide.

2. Open the package’s details page.

For information on how to open a package’s details page, see Opening 
Existing Packages in the Standard Interface on page 79. The following is 
an example of a package’s details page.
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3. The Status section displays the package line(s) for the workflow. In the 
Status section, you can select the following display options:

� Pending Lines Only. This option displays those package lines that are 
eligible for action.

� All Lines. This option displays all the package lines for the workflow.

� Steps Waiting my Action. This options displays only those workflow 
steps awaiting your action. 

� All Steps. This option displays all workflow steps. 

4. Select the checkbox to the left of the Seq column for the package line that 
contains a step you want to approve or disapprove. 

Under the workflow name are the numbered steps that must be completed 
and approved to move the workflow to completion. You can move forward 
or backward through the workflow's steps by clicking the directional 
arrows.

5. Select the radio button to the left of the numbered workflow step to be 
approved. 

6. Select the Eligible checkbox under the step you want to approve or 
disapprove. 

You can select all eligible boxes for the workflow step by clicking Check 
All. This lets you approve or disapprove a number of steps at one time 
instead of individually.

You can deselect all eligible boxes for the workflow step by clicking 
Clear All. 
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7. If one or more package lines are selected for action, click Workflow Action. 

The Package Workflow Action page appears.

8. Under Action Required, select the outcome of the step. 

The outcome is configurable and can therefore be different for each 
workflow step, depending on the configuration at your site. In the above 
example the possible actions are:

� If the workflow step is ready for approval, select Approved.

� If the workflow step is not ready for approval, select Not Approved.

9. On the Package Workflow Action page, click OK. 

The package’s details page appears. Since you approved or disapproved the 
designated workflow step(s), the workflow has moved onto the next step. 
This process continues until the package moves through all of its steps to 
resolution.
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Adding Notes to Packages in the Standard Interface

The Notes section contains fields where notes and information concerning the 
package can be entered and stored. To add a note, in the Add Note section, type 
the information. When the package is saved, the note is added. 

View existing notes in the Existing Notes section. Existing notes are presented 
in chronological order with the most recent notes first. Existing notes can also 
be filtered, using Show Only User Notes, Note Author, and Changed Fields. 

You cannot delete an existing note. 

Figure 4-1. Notes section 

Adding References to Packages in the Standard Interface

You can add a reference to a package from the standard interface. There are 
several reference types defined in Mercury Change Management including: 

� Attachment

� Package (New or Existing)

� Project

� Release

� Request (New or Existing)

� Task

� URL 

For some reference types (such as requests and other packages), you can create 
a functional dependency to the reference. For example, you can specify that a 
request is a Predecessor to the package. This means that the package will not 
continue until the request closes.
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To change the relationship of an existing reference, from the Relationship 
drop-down list, select the new relationship. To delete a reference, click the 
Delete icon at the beginning of the existing reference. 

In some cases it might be useful to reference a Web-accessible file, a 
document, or file from a local machine to the package. Additionally, other 
entities (such as packages, tasks, or other requests) can be referenced to the 
package. 

Figure 4-2. References section 

Adding References 

This section shows how to add an attachment as a reference. For information 
concerning how to add all of the valid references, see Reference Relationships 
on page 41. 

To add a reference to a package:

1. Log on to the Mercury IT Governance Center. 

For information on how to log on to the Mercury IT Governance Center, 
see the Getting Started guide.

2. Open an existing package.

You can open an existing package or create a new package from the menu 
bar. See An Overview of Processing Packages on page 78 for more 
information. 

3. In the package’s detail page, scroll down to the References section.

4. In the References section, from the New Reference drop-down list, select the 
type of reference to be attached and click Add.
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A window opens where the reference’s relationship can be specified. This 
window is different depending on the type of reference selected. In this 
procedure, an Attachment is selected as a reference. For information 
concerning how to add other references, see the next section (Adding 
Additional References). 

� To add an attachment as a reference, from the New Reference 
drop-down list, select Attachment and click Add. 

The Add Document window appears.

5. In the File field, type a pathname or use the Browse icon to search for and 
include an attachment. 

6. In the Description field, enter a description of the attachment and click OK. 

The referenced attachment appears in the References section of the 
package’s detail page. 

7. In the package’s detail page, click Save.

The attachment is added to the package.
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Adding Additional References 

This section lists the different references that can be added to a package. For 
complete instructions on how to add a reference, see Adding References 
on page 85. 

Adding Attachments as References 

You can reference an attachment to a package. To reference an attachment, 
from the New Reference drop-down list, select Attachment and click Add. The 
Add Document window appears. 

In the File field, type a pathname or use the Browse icon to search for and 
include an attachment. In the Description field, type a brief description of the 
attachment and click Add (see Figure 4-3). The attachment appears on the 
package’s detail page. You must save the package to add the reference. 

Figure 4-3. Reference attachment window 

Adding Packages (Existing) as References 

You can reference existing packages to a package. To reference an existing 
package, from the New Reference drop-down list, select Package (Existing) and 
click Add. The Add References: Package window opens. On the Add References: 
Package, complete the search fields as required click Search. 

The Add References: Package window displays the package(s) matching the 
search criteria. A list of relationship types is included on the window (see 
Figure 4-4). Select the type of relationship, the package or packages, and click 
Add. The package appears on the package’s detail page. You must save the 
package to add the reference. 
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Figure 4-4. Add Reference: Package window

Adding Packages (New) as References 

You can reference a new package to a package. To reference a new package, 
from the New Reference drop-down list, select Package (New) and click Add. 
The Create New Package window opens. In the Create New Package window, 
select the relationship and click Create. 

The New Package window opens. Complete the New Package window and click 
Save. The package appears on the package’s detail page. You must save the 
package to add the package.
88 Mercury Change Management™ User’s Guide



 Chapter 4: Processing Packages
Figure 4-5. New Package window

Attaching Programs as References 

You can reference existing programs to a package. To reference an existing 
program, from the New Reference drop-down list, select Program and click 
Add. The Reference Program window opens. Select the program from the 
auto-complete list. In the Reference Program window, select the type of 
relationship and click Add (see Figure 4-6). The program appears on the 
package’s detail page. You must save the package to add the program. 
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Figure 4-6. Reference Program window

Attaching Projects as References 

To attach existing projects as a reference, from the New Reference drop-down 
list, select Project and click Add. The Add Reference: Project window opens (see 
Figure 4-7). In the Add Reference: Project window, complete the search fields as 
required and click Search. 

The Add Reference: Project window displays the projects matching the search 
criteria. A list of relationship types is included on the page. In the Add 
Reference: Project window, select the type of relationship, the project, and click 
Add. The project appears on the package’s detail page. You must save the 
package to add the reference. 

Figure 4-7. Add Reference Project window
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Adding Releases as References 

You can reference existing releases to packages. To reference an existing 
release, from the New Reference drop-down list, select Release and click Add. 
The Reference Release window opens. In Release, select the release from the 
auto-complete list. In the Reference Release window, select the type of 
relationship and click Add (see Figure 4-8). The release appears on the 
package’s detail page. You must save the package to add the reference. 

Figure 4-8. Reference Release window

Adding Requests (Existing) as References 

You can reference existing requests to packages. To reference an existing 
request, from the New Reference drop-down list, select Request (Existing) and 
click Add. The Add Reference: Request window opens. In the Add Reference: 
Request window, complete the search fields as required click Search. 

The Add Reference: Request window displays the requests matching the search 
criteria. A list of relationship types is included (see Figure 4-9). Select the type 
of relationship, the existing request or requests, and click Add. The existing 
request or requests appear on the package’s detail page. You must save the 
package to add the reference. 
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Figure 4-9. Add Reference Request window 

Adding Requests (New) as References 

You can reference new requests to a package. To reference a new request, from 
the New Reference drop-down list, select Request (New) and click Add. The 
Create New Request window opens. Select the type of request to create, select a 
relationship, and click Create (see Figure 4-10). 

The Create New Request window displays the fields of the selected request 
type. Complete the Create New Request window as required and click Save. 
The new request appears on the package’s detail page. You must save the 
package to add the reference. 

Figure 4-10. Create New Request window 
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Adding Tasks as References 

You can reference existing tasks to packages. To reference an existing task, 
from the New Reference drop-down list, select Task and click Add. The Add 
Reference: Task window opens. In the Add Reference: Task window, complete 
the search fields as required click Search. 

The Add Reference: Task window displays the tasks matching the search 
criteria. A list of relationship types is included (see Figure 4-11). In the Add 
Reference: Task window, select the type of relationship, the existing task or 
tasks, and click Add. The existing task or tasks appear on the package’s detail 
page. You must save the package to add the reference. 

Figure 4-11. Add Reference Task window 

Adding URLs as References 

You can reference an existing URL to a package. To reference an existing 
URL, from the New Reference drop-down list, select URL and click Add. The 
Reference URL window opens. 

In the URL field, type the URL address. In the Description field, type a brief 
description of the URL and click OK (see Figure 4-12). 
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Figure 4-12. Reference URL window 

The URL appears on the package’s detail page. You must save the package to 
add the reference. 

Processing Packages Using the Workbench 

You can process submitted packages in the Workbench using the Package 
window. The Package window allows you to process a submitted package 
through its workflow. You can add notes and references to the package, make 
decisions concerning the status of the package, and execute actions for the 
package. You can also change or delete a package in the Package window. 

Opening Existing Packages in the Workbench 

To open an existing package:

1. Open the Workbench.

For information on how to open the Workbench, see the Getting Started 
guide. The Workbench opens. 

2. From the shortcut bar, select Change Mgmt > Packages. 

The Packages Workbench opens.

3. In the Packages Workbench, click List to display all of the existing 
packages. 

You can restrict the search by entering one or more of the query 
parameters.

4. In the Packages Workbench, select one or more of the listed packages and 
click Open. 

The Package window opens.
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Checking Package Status

Each package line must follow a business process defined in its assigned 
workflow. You can view all the workflow and subworkflow steps for each line 
in the Status tab in the Package window. 

To view the status of a submitted package:

1. Open a submitted package. 

For information on how to open a package, see Opening Existing Packages 
in the Workbench on page 94. The Package window opens.

2. In the Package window, click the Status tab.

The Status tab opens. 

3. Review the status of the package.

You can now review the status of each package line. The result of each 
workflow step is recorded in the package line row, allowing you to quickly 
get an idea of which lines have closed successfully or with a failure. While 
all the workflow steps are listed, a package line might not go through each 
step before being resolved. For example, you might have a Rework step that 
is only used when rework is required. For additional information 
concerning the package, select one of the logs, views, or reports concerning 
the package. For more information concerning the Status tab, see Package 
Window, Status Tab on page 35. 

Acting on Eligible Steps 

Once submitted, each package line has one or more workflow steps set to 
Eligible, as shown in Figure 4-13. This indicates that the given execution or 
decision steps need to be performed first in the package’s resolution process. If 
you have permission to act on the Eligible step, the text in the Status column 
appears in boldface type. 

When a step is Eligible, one of the following actions are required:

� You must execute some action and then report the result in Mercury 
Change Management (execution workflow step)

� You must make a decision and report that decision in Mercury Change 
Management (decision workflow step)
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Figure 4-13. Status tab eligible steps

Once you execute the action or make the decision, Mercury Change 
Management indicates the outcome of the decision or action.

To process a workflow step:

1. Open a submitted package. 

For information on how to open a package, see Opening Existing Packages 
in the Workbench on page 94. The Package window opens.

2. In the Package window, click the Status tab.

The Status tab opens. A single step for a single package line can be 
selected or multiple steps for multiple Lines can be selected. Click Select 
All to automatically select all the steps on all the open package lines that are 
currently eligible for action.

You cannot act on multiple workflow steps at once; if you select cells for 
multiple workflow steps, the Action button remains disabled. If the user has 
the security privileges to perform the given workflow step, the button 
becomes enabled. 
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Once a workflow step is selected, the button at the bottom right of the 
Status tab changes its title (originally Action) to the given step name. 

3. Once the Action button is enabled, click the button to perform the action or 
decision.

This opens either a Decision or Execution window.
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In either the Execution or Decision window, select the step’s result. Each 
step is pre-configured with a selection of valid results. In addition to 
selecting a result, you can also enter comments in this window. 

� For information concerning the Decision window, see the next section 
(Acting on Decision Workflow Steps). 

� For information concerning the Execution window, see Acting on 
Execution Workflow Steps on page 101. 

4. Click OK to close the Package window.

Whether the step is a Decision or Execution, the result of the step is processed by 
the workflow engine and can lead to a number of changes. Based on the 
workflow definition (which can contain multiple workflow steps and 
subworkflows) the given workflow step result can cause additional workflow 
steps to become Eligible, indicating the next actions to be performed in the 
package resolution process. 

When subsequent steps become Eligible, those steps are completed sequentially, 
making Eligible the next workflow step(s) in line. This process continues until 
the package reaches its final state and becomes resolved, usually at a Close 
step. 
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Acting on Decision Workflow Steps 

Decisions workflow steps are steps for which you (or a group) need to indicate 
the result or outcome. (For example, an approval of work or an indication that 
a review has been completed.) For example, Approve Migration is an example 
of a decision workflow step. You can either act on the decision step yourself or 
delegate the decision to someone else. 

To act on a decision workflow step:

1. In the Package window, in the Status tab, select the Eligible decision 
workflow step. 

For information on how to access the Status tab and select the Eligible 
decision workflow step, see Acting on Eligible Steps on page 95. 

The Action button is enabled. Notice that the label on the action button 
changes depending on which step is selected.

2. In the Status tab, click Action. 

The Package Decision windows.
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3. From the drop-down list, select Decide Now or Delegate Decision.

� Choosing Decide Now requires you to make a decision regarding the 
decision workflow step; for example, Approve. To make a decision 
regarding the decision workflow step:

a. From the Result drop-down list, select the result. 

b. In the Notes field, enter the text of your note. 

c. In the Decision window, select OK.

The Decision window closes. The results of the decision are added to 
the Status tab. 

� Choosing Delegate Decision allows you to assign the decision to 
someone else. To delegate a decision:

a. From the Delegate To auto-complete list, select a resource. 

b. In the Notes field, enter the text of your note. 

c. In the Decision window, select OK.

The Decision window closes. The results of the decision are added to 
the Status tab. 
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4. In the Package window, click OK.

The decision has been made and entered into the system. If the workflow 
step was configured so that more than one person needs to decide on the 
result, the package line may not move to the next step until all decisions are 
made. For decision workflow steps that require more than one person to 
decide on the result, you can view the current decision results for the 
workflow step using the Decision Detail view. 

Acting on Execution Workflow Steps

Execution workflow steps are workflow steps where the Change Management 
system performs an action and then updates the step with its result. These 
actions can be as simple as calculating the value for a token or as complex as 
copying files, running programs, or updating Web pages. 

To act on an execution workflow step:

1. In the Package window, in the Status tab, select the Eligible decision 
workflow step. 

For information on how to access the Status tab and select the Eligible 
decision workflow step, see Acting on Eligible Steps on page 95. 

The Action button is enabled. Notice that the label on the action button 
changes depending on which step is selected.
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2. In the Status tab, click Action. 

The Execution window opens. 

3. From the drop-down list, select Execute Now, Schedule Execution, or 
Bypass Execution from the drop-down list.

� Choosing Execute Now and clicking OK executes the workflow step. 
The Execution window closes. The result of the workflow step is 
displayed on the package line at the workflow step. This process could 
be a software migration, execution of a PL/SQL function, the closing of 
the package line, or a number of other activities. The execution engine 
executes the step and sets the result accordingly.

� Choosing Schedule Execution displays the Execution Date and Execution 
Time fields. Select the date and time, and click OK. The Execution 
window closes. The schedule execution is displayed on the package 
line at the workflow step. This process could be a software migration, 
execution of a PL/SQL function, the closing of the package line, or a 
number of other activities. The execution engine will execute the step 
and set the results accordingly.

� Choosing Bypass Execution displays the Execution Result field. Select 
the results and click OK. The Execution window closes. The selected 
result is displayed on the package line at the workflow step. 

4. In the Package window, click OK.
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Adding Notes 

In the Package window, the Notes tab (see Figure 4-14) contains additional 
information concerning the package. 

Figure 4-14. Package window, Notes tab 

To add a note, enter the text in the New Notes field and click Save. The note is 
added to the Existing Notes field. 

Adding and Updating References

Package references can be added and updated from the References tab of the 
Package window in the Workbench. The following sections explain how to 
add, update, and delete references.
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Adding References 

A Package window References section contains additional information 
concerning the package. For example, you might add a document or URL to a 
package. The following lists the references that can be added to a package: 

� Attachment

� Package (New and Existing)

� Project

� Release

� Request (New and Existing)

� Task

� URL

For some references (such as requests and other packages), a functional 
dependency to the original package can be created. For example, you can 
specify that a request is a predecessor to the package. This means the package 
will not continue until the request is closed. 

For Additional Information

� For a list of the references and their possible dependency relationships, see 
Reference Relationships on page 41. 

� For information on how to add a reference, see Adding References to 
Packages on page 64. 
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Updating References 

To update an existing reference from the Workbench:

1. Open a package in the Package window.

For information on how to open a package in the Package window, see 
Adding References to Packages on page 64. The Package window opens. 

2. In the Package window, select the References tab.

The References tab opens. 

3. In the References tab, click in the referenced entity’s Relationship column 
and select the desired relationship from the drop-down list that appears. 

4. Click OK or Save.

The change to the package is saved. 
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Deleting References 

To delete an existing reference from the Workbench:

1. Open a package in the Package window.

For information on how to open a package in the Package window, see 
Adding References to Packages on page 64. The Package window opens. 

2. In the Package window, select the References tab.

The References tab opens. 

3. In the References tab, select the reference and click Remove. 

The reference is removed and deleted from the Mercury IT Governance 
Server.

Adding a Package Line to an In-Progress Package 

Aggressive maintenance of your business systems can introduce the need for 
quick code migrations using Change Management packages. You might run 
into situations where you would like to add a package line to a package that has 
already been submitted. 

To add a package line to an in-progress package:

1. Open a package in the Package window.

For information on how to open a package in the Package window, see 
Adding References to Packages on page 64. The Package window opens. 
106 Mercury Change Management™ User’s Guide



 Chapter 4: Processing Packages
2. Click New Line. 

The Add Line window opens.

3. From the Object Type field, select an object type. 

The Parameters tab dynamically display fields corresponding to the 
selected object type.

4. Enter the parameters.
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5. Click OK to accept the parameters and close the window or click Add to 
accept the parameters and reset the window for another line addition. 

The new line is added to the Package window.

6. Click OK.

The new package line has been added to the package.

The new package line is not submitted until you click OK or Save. The Submit button 
remains disabled throughout this process. The new package line is automatically 
submitted when the package is saved. It is submitted to the first step in the workflow, 
and the user can process it individually until it catches up with the other lines in the 
package. When submitted, it is not automatically placed in the same status as the 
other lines.
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Managing Packages

In This Chapter:

� An Overview of Managing Packages
� Copying Packages
� Merging Packages
� Creating New Package Groups
� Editing Package Groups
� Deleting Packages
� Cancelling Package Lines
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An Overview of Managing Packages

In Mercury Change Management, once a package has been submitted, it can be 
processed and managed. Managing packages refers to working with the 
packages; for example, copying, and deleting existing packages. 

Copying Packages 

Copying package requires using the Packages Workbench. To copy a package, 
see Creating Packages by Copying Packages on page 55. Table 5-1 lists the 
options available in the Options tab when copying a package. 

Table 5-1. Copy package options 

Option Description

Copy Package Lines Yes/No radio buttons. Copies all of the package 
lines in the existing package into the new package. 
The default is Yes.

Copy Closed Lines Yes/No radio buttons. Copies all of the closed 
package lines in the existing package into the new 
package. The default is Yes.

Copy Cancelled Lines Yes/No radio buttons. Copies all of the cancelled 
package lines in the existing package into the new 
package. The default is No.

Copy Header’s Notes Yes/No radio buttons. Copies all of the notes 
attached to the existing package to the new 
package. The default is No.

Copy Header’s User Data Yes/No radio buttons. If applicable, copy the user 
data from the existing package to the new 
package.

Submit New Package Yes/No radio buttons. Once the package is copied, 
submit the package. The default is No. If you 
select No, your package is not submitted. To 
submit the package, you must open the copied 
package and click Submit.
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Merging Packages

You can generate a new package by merging two or more existing packages. 
This is advantageous when you would like to generate a single package 
consisting of certain package lines contained in separate packages. 

To merge two packages:

1. Open the Workbench. 

For information on how to open the Workbench, see the Getting Started 
guide. The Workbench opens. 

2. From the shortcut bar, select Change Mgmt > Packages.

In most cases, Change Mgmt > Packages is default location when a 
Workbench opens. The Package Workbench opens.

3. In the Package Workbench, in the Query tab, click List. 

The Results tab, lists all of the existing packages. 

4. In the Results tab, select the packages to merge.

Hold down the Ctrl-key to select nonadjacent rows.

5. In the Results tab, click Merge. 

The Merge Package window opens.
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6. In the Merge Package window, complete the fields and options, and click 
OK. 

A Question dialog opens, asking if you want to edit the new (merged) 
package. 

7. In the Question dialog, click Yes to edit the package and No to save and 
close the package. 

Creating New Package Groups 

It is often advantageous to link the new package to a specific package group 
for tracking and reporting purposes. Creating new package groups is done in 
the Package Workbench. 

To create a new package group:

1. Open the Workbench. 

For information on how to open the Workbench, see the Getting Started 
guide. The Workbench opens. 

2. From the shortcut bar, select Change Mgmt > Packages.

In most cases, Change Mgmt > Packages is default location when a 
Workbench opens. The Package Workbench opens.

3. From the Workbench menu, select Package > New Package Group. 
112 Mercury Change Management™ User’s Guide



 Chapter 5: Managing Packages
The Validation: KNTA - Package and Request Groups window opens, listing 
groupings for packages and requests.

4. In the Validation: KNTA - Package and Request Groups window, click New. 

The Add Validation Value window opens.

5. In the Add Validation Value window, enter all of the required information in 
both the Value Information and User Data tabs.
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6. In the Validation: KNTA - Package and Request Groups window, click OK to 
accept the new package group and close the window.

You can also click Add to accept the new package group and enter another 
new package group. In Validation: KNTA - Package and Request Groups 
window, click OK to accept the new package group and close the window. 

Editing Package Groups 

You can also edit existing package groups from within the Workbench. Only 
users with appropriate access grants and security privileges can alter the KNTA 
Package and Request Groups Validation list. You should consult your application 
administrator before adding or editing any package groups. Package groups are 
typically generated to adhere to specific business application standards.

To edit an existing package group:

1. Open the Workbench. 

For information on how to open the Workbench, see the Getting Started 
guide. The Workbench opens. 

2. From the shortcut bar, select Change Mgmt > Packages.

In most cases, Change Mgmt > Packages is default location when a 
Workbench opens. The Package Workbench opens.

3. From the Workbench menu, select Package > New Package Group. 

The Validation: KNTA - Package and Request Groups window opens, listing 
groupings for packages.

4. Select a package group and click Edit.

The Edit Validation Value window opens.
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5. In the Edit Validation Value window, complete the fields and click OK.

The new validations are added to the Validation: KNTA - Package and Request 
Groups window. 

6. In the Validation: KNTA - Package and Request Groups window, click OK.

The changes to the Validation: KNTA - Package and Request Groups window 
are saved. 

Deleting Packages 

Packages can be deleted from the Packages Workbench. 

To delete an existing package:

1. Open the Workbench. 

For information on how to open the Workbench, see the Getting Started 
guide. The Workbench opens. 

2. From the shortcut bar, select Change Mgmt > Packages.

In most cases, Change Mgmt > Packages is default location when a 
Workbench opens. The Package Workbench opens.
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3. In the Package Workbench, in the Query tab, click List to list all of the 
packages. 

The packages are listed in the Results tab. 

4. In the Results tab, select the packages and click Delete. 

Hold down the Ctrl-key to select nonadjacent rows. A question dialog 
opens and asks you to confirm that you would like to delete the package. 

5. In the question dialog, click OK to delete the package.

The package is deleted from your system.

Cancelling Package Lines 

Package lines might need to be occasionally cancelled. Reasons for cancelling 
a package line might include the fact the files are out of date or no longer 
necessary. Package lines are cancelled using the Package Workbench. 

To cancel a package line:

1. Open the Workbench. 

For information on how to open the Workbench, see the Getting Started 
guide. The Workbench opens. 

2. From the Shortcut bar, select Change Mgmt > Packages.

In most cases, Change Mgmt > Packages is default location when a 
Workbench opens. The Package Workbench opens.

3. In the Package Workbench, in the Query tab, click List to list all of the 
packages. 

The packages are listed in the Results tab. 

4. In the Results tab, select a package and click Open. 

The Package window opens.
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5. In the Package Line tab, select the package line you want to cancel.

6. From the Workbench menu, select Package > Cancel Package Line.

The package line is cancelled.
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A

Change Management Portlets

Mercury Change Management includes a set of Change Management portlets. 
These portlets allow you to view the current status of packages at any point in 
time. 

Table A-1. Packages portlets 

Packages Portlets Description

My Packages
Lists all packages created by or assigned to you. 
Provides a critical view into the most pressing 
packages. 

Package Activity

Lists activity information about the number of 
deployments (package line execution step 
transactions) completed during the last three 
weeks. 

Package List
Lists general information about packages; for 
example, description and status. 

Package References

Lists references attached to package. Filters 
include:

� Reference types

� Relationship

� Time period 
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Package Summary Bar Chart
Bar chart summary of packages including priority 
and the total number of packages for each 
category. 

Package Summary Pie Chart
Pie chart summary of packages including priority 
and the total number of packages for each 
category. 

Pending Deployment
Lists general information about packages which 
have not been deployed. Provides visibility into 
scheduled or required package migration.

Table A-1. Packages portlets  [continued]

Packages Portlets Description
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B

Reports by Category

In This Appendix:

� Overview of Report Categories
� Administrative Reports
� Change Management Reports
� Demand Management Reports
� Financial Management Reports
� Portfolio Management Reports
� Program Management Reports
� Project Management Reports
� Resource Management Reports
� Time Management Reports
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Overview of Report Categories

Reports available through the Mercury IT Governance Center standard 
interface are listed (by category) and described in the following sections.

Administrative Reports

The administrative reports (listed in Table B-1) are available to users with an 
administration license.

Another type of report in Mercury IT Governance Center (not discussed in this 
document) are server reports, which are submitted and viewed from the Workbench 
interface, For information about server reports, see the System Administration Guide 
and Reference.

Table B-1. Administrative reports

Report Definition

Contact Synchronization
Provides an interface for checking whether Mercury 
Demand Management contacts are properly defined.

This report is also in the Resource category.

Environment Comparison
Helps audit environment definitions when different 
environments (for example, development and production) 
are similar to each other.

Environment Detail

Lists the detailed definitions of a given environment or 
group of environments, the major attributes of the 
environments, and the attributes of applications tied to 
the environments.

Environment Group Detail
Contains detailed information about specified 
environment groups.

Import Requests

Imports requests into Demand Management request 
tables, moves the requests to the appropriate status, and 
reports on the results of the execution.

For more information about this report, see the Open 
Interface Guide and Reference.
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Import Users

Imports data from the user interface tables or an LDAP 
server.

For more information about this report, see the Open 
Interface Guide and Reference.

Lookup Types Provides information about one or more lookups.

Notification History
Provides information about notifications that have been 
sent or are pending.

Object Type Detail
Lists all parameters and commands associated with a 
given object type.

Portlet Detail Provides information about a portlet or range of portlets.

RCS Check In
Template of a report used to check files into the RCS 
repository (if the RCS file management system is being 
used).

RCS Check Out
Template of a report used to check files out of the RCS 
repository (if the RCS file management system is being 
used).

Report Type Detail Provides information about report type definitions.

Request Header Type Detail
Lists detailed definitional information for request header 
types.

Request Type Detail Lists detailed definitional information for request types.

Run Field Security Denormalization
Runs field level security-related denormalization tasks for 
particular entities.

Run ITG Organization Unit Interface

Imports data from the organization unit interface tables or 
an LDAP server.

For more information about this report, see the Open 
Interface Guide and Reference.

Run ITG Package Interface

Validates and loads package data from the package open 
interface tables into the standard Mercury Change 
Management data model.

For more information about this report, see the Open 
Interface Guide and Reference.

Run Workflow Transaction Interface

Validates and runs workflow transactions based on data 
in the workflow open interface tables.

For more information about this report, see the Open 
Interface Guide and Reference.

Security Group Detail
Lists definitional information for one or more security 
groups.

Table B-1. Administrative reports [continued]

Report Definition
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For More Information

Unless otherwise indicated in Table B-1, see the Reports Guide and Reference 
for more information about Administrative reports.

Special Command Detail
Provides details for a command (special command) or a 
range of commands.

Synchronize Meta Layer
Assesses or synchronizes the RML (Reporting Meta 
Layer).

User Data Detail
Displays the definition of custom user data field (for 
example, fields on entities like packages, requests, 
workflows, and security groups).

User Detail

Lists the users who have been defined in the Mercury IT 
Governance system, as well as the security groups 
attached to each user.

This report is also in the Resource category.

Validations

Provides information about the various custom 
validations that have been entered into the system as 
well as those that are standard with Mercury IT 
Governance Center products.

Workflow Detail
Provides detailed definitional information about specific 
workflows or sets of workflows.

Workflow Statistics
Given a date range and a workflow (or a range of 
workflows), this report provides statistical information 
regarding workflow usage.

Table B-1. Administrative reports [continued]

Report Definition
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Change Management Reports

The Change Management reports (listed in Table B-2) are available to users 
with a Mercury Change Management application license.

Table B-2. Change Management reports

Report Definition

Compare Custom Database Setup Runs custom database comparisons.

Compare Filesystem Environment Compares the files and file structures of two machines.

Compare MS SQL Server 7 
Environments

Compares the data model of two SQL Server Version 7 
databases.

Compare Oracle Environments Compares the data model of two Oracle schemas.

Distribution Detail Lists the contents and results of a distribution.

Environment Comparison by Objects 
Migrated

Given two environments, this report looks at the history of 
all the objects migrated into each environment (using 
Mercury Change Management) and lists any differences.

Environments/Objects Detail
Lists objects that have been migrated into a given 
environment or set of environments.

Object History
Provides a workflow step transaction history for 
packages.

Objects/Environments Detail
Lists objects that have been migrated into a given 
environment or a set of environments.

Package Details Returns details about a given package.

Package History Lists the complete workflow history of a given package.

Package Impact Analysis

Lists three separate sections for analysis:

� Other packages that contain common objects with a 
given package

� Objects that have migrated alongside one or more of 
the objects being migrated on the given package but 
are not included in the given package

� Recent migrations for each object in the package, 
showing where changes to the given objects have 
recently been deployed

Packages Pending

Lists:

� Open packages with pending activity

� Details about each package

� Pending work for a group of users
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For More Information

For more information about Change Management reports, see the Reports 
Guide and Reference.

Release Detail
Lists requests, packages and distributions associated 
with a release.

Release Notes
Shows all of the requests and packages in a release as 
well as their associations.

Table B-2. Change Management reports [continued]

Report Definition
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Demand Management Reports

The Demand Management reports (listed in Table B-3) are available to users 
with a Mercury Demand Management application license.

For More Information

For more information about Demand Management reports, see the Reports 
Guide and Reference.

Table B-3. Demand Management reports

Report Definition

Contact Detail
Queries the contacts already entered in the Demand 
Management system that are available for entering and 
updating requests.

DEM Demand Creation History
Shows the history of demand creation for a specified 
demand set.

DEM Historical SLA Violation
Shown the history of SLA violations for a specified 
demand set.

DEM Satisfied Demand History
Shows the history of demand that has been satisfied for a 
specified demand set.

Request Detail
Provides information about requests using a number of 
selection criteria.

Request Detail (Filter by Custom 
Fields)

Similar to the Request Detail report except that requests 
can be filtered by values in custom fields.

Request History
Lists the complete workflow and field change history for 
each selected request.

Request Quick View
Lists a quick summary of open and closed requests, 
breaking down the requests by priority.

Request Summary
Displays the total counts for groups of requests matching 
the selection criteria.

Request Summary (Filter by Custom 
Fields)

Similar to the Request Summary report except that 
requests can be filtered by values in custom fields.

Resource Load by Priority
Lists all open requests assigned to different users.

This report is also in the Resource category.
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Financial Management Reports

The Financial Management reports (listed in Table B-4) are available to users 
with a Mercury Time Management™ application license.

For More Information

For more information about Financial Management reports, see the Reports 
Guide and Reference.

Table B-4. Financial Management reports

Report Definition

Actual Time/Cost Summary

Summarizes actual time information entered in 
non-cancelled time sheets and the calculated charge 
dollar totals for each grouping.

This report is also in the Time Management category.

Project Cost Breakdown
Shows the costs for a project, and the activities with 
which the costs are associated.

This report is also in the Project Management category.

Project Cost Details
Shows the cost details for select projects, grouped by 
labor/non-labor or operating categorizations.

This report is also in the Project Management category.
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Portfolio Management Reports

The Portfolio Management reports are available to users with a Mercury 
Portfolio Management ™application license.

There are currently no Mercury-supplied reports in this category, but you can 
create your own custom reports, if you like.

Program Management Reports

The Program Management reports are available to users with a Mercury 
Program Management application license.

There are currently no Mercury-supplied reports in this category, but you can 
create your own custom reports, if you like.
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Project Management Reports

The Project Management reports (listed in Table B-5) are available to users 
with a Mercury Project Management application license.

Table B-5. Project Management reports

Report Definition

Project Cost Breakdown

Shows the costs for a project, and the activities with 
which the costs are associated. 

Totals include both labor and non-labor costs.

This report is also in the Financial Management category.

Project Cost Details
Shows the cost details for select projects, grouped by 
labor/non-labor or operating categorizations.

This report is also in the Financial Management category.

Project Critical Path Displays the tasks that are on a project’s critical path.

Project Custom Detail
Generated in HTML table format, showing only the 
columns that are selected from the header fields and 
custom fields based on the selected project.

Project Detail Queries projects by their header fields.

Project Detail (Filter by Custom 
Fields)

Queries projects by their header fields. You can filter the 
query using the project’s custom fields.

Project Exception Detail
Lists task details for tasks that have violated user-defined 
exception rules.

Project Resource
Lists all resources working on a given project and the 
tasks on which they are working.

This report is also in the Resource category.

Project Schedule Change
Compares a project plan with a baseline, or a baseline to 
another baseline.

Project Status Detail
Summarizes project statuses of selected projects and 
tasks.

Project Summary
Displays all projects that meet the criteria selected in the 
header fields.

Project Task Assignment
Shows assignment information for a user or a group of 
users.

This report is also in the Resource category.

Project Template Detail
Lists the parameters and parameter details for project 
templates.
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For More Information

For more information about Project Management reports, see the Reports 
Guide and Reference.
Project Management Reports 131



Appendix B: Reports by Category
Resource Management Reports

The Resource Management reports (listed in Table B-6) are available to users 
with the licenses indicated in the definition column in the table.

Table B-6. Resource Management reports

Report Definition

Contact Synchronization

Provides an interface for checking whether Mercury 
Demand Management contacts are properly defined.

Available to users with an administration license.

This report is also in the Administrative category.

Project Resource

Lists all resources working on a given project and the 
tasks on which they are working.

Available to users with a Mercury Project Management 
license.

Project Task Assignment

Shows assignment information for a user or a group of 
users.

Available to users with a Mercury Project Management 
license.

Resource Load by Priority
Lists open requests assigned to different users.

Available to users with a Mercury Demand Management 
license.

User Detail

Lists the users who have been defined in the Mercury IT 
Governance system, as well as the security groups 
attached to each user.

This report is available to users with any application 
license.

This report is also in the Administration category.

Work Allocation Details

Shows much of the same information shown on the Work 
Allocation definition page—for example, allocation work 
item information, budget and actuals to date, charge code 
allocations, and resource restrictions.

Available to users with a Mercury Time Management 
application license.

This report is also in the Time Management category.
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For More Information

For more information about Resource Management reports, see the Reports 
Guide and Reference.
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Time Management Reports

The Time Management reports (listed in Table B-7) are available to users with 
a Mercury Time Management application license.

For More Information

For more information about Time Management reports, see the Reports Guide 
and Reference.

Table B-7. Time Management reports

Report Definition

Actual Time/Cost Summary
Summarizes actual time information entered in 
non-cancelled time sheets and the calculated charge 
dollar totals for each grouping.

Actual Time Summary
Summarizes actual time information entered in 
non-cancelled time sheets.

Time Sheet Details Summarizes multiple time sheets displays their details.

Time Sheet Summary
Summarizes time information entered in non-cancelled 
time sheets.

Work Allocation Details

Shows much of the same information shown on the Work 
Allocation definition page—for example, allocation work 
item information, budget and actuals to date, charge code 
allocations, and resource restrictions.

This report is also in the Resource category.
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