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Documentation Updates

This guide’s title page contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

• Software Release Date, which indicates the release date of this version of the software.

To check for recent updates, or to verify that you are using the most recent edition of a document, go to:

http://h20230.www2.hp.com/selfsolve/manuals 

This site requires that you register for an HP Passport and sign-in. To register for an HP Passport ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

Or click the New users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product support service. 
Contact your HP sales representative for details.
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Support

You can visit the HP Software Support Online web site at:

http://www.hp.com/go/hpsoftwaresupport

This web site provides contact information and details about the products, services, and support that HP 
Software offers.

HP Software Support Online provides customer self-solve capabilities. It provides a fast and efficient way to 
access interactive technical support tools needed to manage your business. As a valued support customer, you 
can benefit by using the HP Software Support web site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a 
support contract.

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp 

To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html 
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1 Overview
HP Performance Insight 5.41 (PI 5.41) collects data from many sources, performs in-depth 
trend analysis, maintains performance baselines, and provides users with convenient, 
web-based reporting. Following is a partial list of product features:

• Distributed architecture

• Easy to scale (supports data collection from thousands of agents)

• CODA/PA agent support

• Multi-company security model

• Data warehousing

• Near Real Time reporting

• Forecasting 

• Extensive aggregation (by hour, day, week, month; by location, by customer)

• Thresholding and alerting

• Easy identification of bottlenecks

• Easy assessment of capacity trends

• Accurate and timely documentation for management

• Integration with NNM

• Integration with OVO/OM

The reporting solutions created for PI 5.41 cover many areas of business technology 
optimization, including traffic profiling for networks, specifically, IP QoS Reporting and 
Class-Based QoS Reporting. For a complete list of reporting solutions organized by technology, 
see Appendix A, PI Report Packs.
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Class Based QoS Reporting

The Class Based QoS reporting solution provides comprehensive summarization and 
reporting features that let you view the effect of QoS policies on network traffic. The Class 
Based QoS Report Pack displays reports that provide a comprehensive picture of what is 
happening on the network. Network service providers and their customers can use the Report 
Pack to monitor the usage characteristics of network services with a view to service capacity 
planning and network/service optimization.

The Class Based QoS Report Pack installs on PI 5.41. The Class Based QoS Datapipe runs on 
the PI 5.41 server.

The Datapipe collects data using SNMP and networking devices that support the Class Based 
QoS configuration. The Report Pack aggregates and reports on the data.

Data Collection for Class-Based QoS Reporting

The Datapipe collects QoS statistics from the Cisco Class Based QoS MIB (Management 
Information Base) and populates the Class Based QoS rate tables once every 15 minutes. It 
collects QoS policy configuration data for all routers once a day.

Quality of Service (QoS) lets you dedicate bandwidth to particular types of traffic but does not 
tell you how much traffic of each service class is traversing the network, nor does it provide 
the hourly and daily information needed to design efficient QoS schemes. To find out how 
much traffic of each service class is traversing the network, and when the traffic is taking 
place, it is necessary to poll byte and packet counters in the Cisco Class Based QoS MIB and 
process the collected data. The MIB stores traffic policy data and performance statistics. QoS 
policies define the flow of traffic.

Customer, location, node, and interface information for QoS data is imported via the Common 
Property Tables property import/forms and the Interface Reporting property import/form.

 The Datapipe provides the following data collection functionality:

• Discovers nodes that support the Class Based QoS MIB. The MIB contains a number of 
useful metrics for various QoS policies, including:

— Inventory 

– Parent and child classes applied on the various interfaces of the Class Based 
QoS-enabled devices and the direction information.

— Class statistics

– Pre-policy packets, bytes, and bit rate

– Dropped packets, bytes, and bit rate

– Packets dropped due to no buffers

— Policing statistics

– Conformed packets, bytes, and bit rate

– Exceeded packets, bytes, and bit rate

– Violated packets, bytes, and bit rate
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— Queuing statistics

– Current queue depth

– Maximum queue depth

– Discard bytes and packets

— Traffic shaping statistics

– Delayed bytes and packets

– Dropped bytes and packets

– Current queue size

— Random Early Detect (RED) statistics

– Random dropped bytes and packets

– Tail dropped bytes and packets

– Transmitted bytes and packets

– ECN marked bytes and packets

– Mean queue size

• Recognizes and responds to re-indexing of QoS objects in the Class Based QoS MIB tables.

• Maps data from the rate tables to the Class Based QoS Report Pack base tables.

• Collects QoS statistics according to the QoS policy configuration of the routers.

• Recognizes and responds to interface re-indexing discovered by the Interface Reporting 
Datapipe and the ifEntry Discovery Datapipe.

• Collects QoS policy configuration data within 15 minutes after a re-indexing event or a 
configuration change is discovered on a router. This happens only on routers that are 
re-indexed or reconfigured.

• Collects statistics for routers that need policy configuration updates to minimize gaps in 
the data due to re-indexing or policy configuration changes. Collections are based on the 
previous policy configuration. Statistics for new QoS objects are collected when the new 
policy configuration is known.

• Updates the configuration/information for classes and policies in the Report Pack for all 
nodes requiring a configuration update prior to transferring data.

• Transfers data to the Report Pack only for nodes with complete policy configuration data. 
After a re-index or configuration change, trend sums are suspended until the policy 
configuration is updated.

Class Based QoS Report Pack

The Report Pack issues processing directives to PI 5.41, and displays reports that show the 
distribution of traffic on a per-precedence basis. With this information, you can monitor the 
usage characteristics of provided network services, plan service capacity, and optimize your 
network services.

The Report Pack populates the Class Based QoS daily tables every day as defined in the 
processing schedule. The Class Based QoS monthly tables are updated every day with the 
current month-to-date data. The Class Based QoS forecast tables are populated every day 
using a 42-day baseline period.

Class-Based QoS contains four folders and a total of 17 reports.  See below for details. 
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:

Reports show data by interface, traffic direction, and class. Additional reports may show data 
aggregated by device and for all devices. Reports show hourly, daily, and monthly data.

For details on deploying the reports, see Accessing Deployed Reports on page 21. To see 
example reports, see Sample Reports on page 25.

Customizing the Appearance of Reports

The Report Pack provides Common Property Table forms that enable provisioning additional 
(optional) information, such as node locations and end customers. The Report Pack uses this 
provisioning data to present more detailed information concerning the endpoints of the 
network flows.

The Report Pack inherits property data, including name of node, name of interface, location of 
node, and customer, from the Interface Reporting Report Pack. Any property changes made 
for Interface Reporting using the Common Property Tables automatically appear in Class 
Based QoS Report Pack reports.

You can change the appearance of the reports, including fonts and graph styles, using the Web 
Access Server. 

Folder Report

Admin QoS Polling Overview

Drilldown Bit Rate History
Dropped Bit Rate History
Inventory
Packet Rate History
Percent Packet Drop History
Queuing History
Traffic Forecast
Utilization History

Summary Policing Summary by Class
Queuing Summary by Class
RED Summary by Class
RED Summary by Class/Precedence
Summary by Class
Traffic Shaping Summary by Class

Top N Queuing Top N
Utilization Top N
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Figure 1 Site Appearance Settings  

For detailed instructions, see the HP Performance Insight 5.41 Administration Guide.
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Product Version History  

Sources for Additional Information

The following documents provide additional information:

• HP Performance Insight 5.41 Administration Guide 

• Common Property Tables User Guide 

• Interface Reporting Report Pack User Guide 

• Interface Reporting ifEntry Datapipe User Guide 

These documents can be found either on the product DVD or you can download the latest 
version from the URL shown in Documentation Updates on page 3.

Select Support → Product Manuals to reach the HP Software Product Manuals page. The user 
guides are listed under Performance Insight.

Every manual on the Product Manuals Search page indicates the month and year. If a manual 
is revised and reposted, the date will change. Revised manuals are posted on a regular basis, 
so check the date on your PDF against the date on the PDF on the web and use the web 
version if it is newer.

Version Release Date Features/Enhancements

1.10 June 2007 Initial release

1.10 October 2007

1.30 February 2009 new upgrade package:
• Class_Based_QoS_Upgrade_to_13
new version of datapipe:
• Class_Based_QoS_Datapipe_Upgrade_to_12
defect fix:
• QXCR1000818651 - No data in CB QoS reports
• QXCR1000873210 - A customer's name is visible 

in the Class Based QOS report pack

1.31 November 2009 new upgrade package:
• Class_Based_QoS_Upgrade_to_131
defect fix:
• QCCR1B39239: CBQoS reports do not show Voice 

and Video Traffic information
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2 Package Installation
Guidelines for Installation

The Report Pack CD has the latest report packs and datapipes. When you insert the CD in the 
CD-ROM drive and launch the package extraction program, the install script on the CD 
extracts every package from the CD and copies the results to the Packages directory on your 
system. When the extract finishes, the install script prompts you to launch PI 5.41 and start 
Package Manager. Before using Package Manager, review the following guidelines.

Prerequisites for Installation

The Class Based QoS Report Pack has a combination of core product requirements and 
package level requirements. The core product requirements are:

• PI 5.41

• All service packs available for PI 5.41

The package level prerequisites are:

• Common Property Tables 3.91

• Interface Reporting Report Pack 5.52

Upgrading Common Property Tables

If you are running an earlier version of Common Property Tables, you must upgrade that 
package to version 3.91 (see Upgrade to Common Property Tables 3.91 on page 16).

For more information about installing and using Common Property Tables, refer to the 
Common Property Tables User Guide.

Distributed Environments

If you are running Class Based QoS on a distributed system across multiple servers, the 
central server, every satellite server, and every remote poller must be running the same 
version of Performance Insight and all available service packs for that version of HP 
Performance Insight. When you install the Class Based QoS on the central server, deploy 
reports. When you are done installing packages, you must configure each server by following 
the steps under Configuring the Report Pack and Datapipe on page 33.
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Installing Class Based QoS

Task 1: Extract Packages from the Report Pack CD

1 Log in to the system. On Windows systems, log on with Administrator privileges. On 
UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, type one of the following:

HP-UX: sh /sbin/ovpi_timer stop 

Solaris: sh /etc/init.d/ovpi_timer stop 

3 Insert the Report Pack CD.

Windows: A Main Menu displays automatically.

UNIX: Mount the CD, navigate to the top-level directory for the CD drive, and run the 
./setup command.

4 Select PI 5.41 Report Packs by typing 1 in the choice field and pressing Enter. The install 
script displays a percentage complete bar. When extraction finishes, the install script 
starts Package Manager. The Package Manager welcome window opens.

If you navigate to the Packages directory on your system, you will see the following 
folders:

— Class_Based_QoS

— Class_Based_QoS_Datapipe

Task 2: Upgrade to Common Property Tables 3.91 

1 Do not install any other package with the Common Property Tables upgrade package; 
install the CPT upgrade package and only the CPT upgrade package.

2 When prompted to accept or disable the option to Deploy Reports, accept the default. If 
you do not deploy reports, you will not deploy the change forms that come with Common 
Property Tables.

3 When the install finishes, click Done to return to the Management Console.

If you need more help with this task, refer to the Common Property Tables User Guide.

Task 3: Install the Report Pack and the Datapipe

1 If Package Manager is not running, select Package Manager from the Management 
Console.

2 Click Next. The Package Location window opens.

3 Click the Install radio button.

4 Approve the default installation directory or use the browse feature to select a different 
directory if necessary.

5 Click Next. The Report Deployment window opens.

6 Accept the default settings for Deploy Reports. 

Also accept the defaults for the application server name and port.
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7 Type the same username and password as you used on the Management Console.

8 Click Next. The Package Selection window opens.

9 Select the check box next to the following package names:

— Class_Based_QoS 1.31

— Class_Based_QoS_Datapipe 1.21

10 Click Next. The Type Discovery window opens.

You can run Type Discovery at this point.

11 The Selection Summary window opens. Verify that the contents of this window are 
correct.

12 Click Install to begin the installation process. The Installation Progress window opens and 
the install process begins. When the install process is complete, a success install complete 
message appears.

13 Click Done.

14 Restart OVPI Timer.

Windows NT: Select Settings > Control Panel > Administrative Tools > Services 

UNIX: As root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer start 

Solaris: sh /etc/init.d/ovpi_timer start 

Installing the demo package is optional. You can install the Class Based QoS demo package by 
itself, or you can install the demo package along with the Report Pack.
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Configuring Class Based QoS

The Datapipe lets you select the period when the configuration information will be collected. 
It lets you limit the collection of Class Based QoS data to specified interfaces. And it lets you 
select the period when the Class Based QoS running statistics will be collected.

There are two forms for configuring the Datapipe. The forms are available through the Admin 
Console. Go to Objects > Object/Property Management.

Force CB QoS Rediscovery Form

This form lets you determine when re-polling will take place once the Class Based QoS device 
configuration changes.
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Administer Poll Flag for CB QoS Interfaces Form

This form lets you decide whether the interface on the supported devices can be polled or not.

Once the configuration collection interval and polled interfaces are selected, Class Based QoS 
configuration data is collected from the devices. The data is available in the base tables of the 
Report Pack. The overview report shows the QoS collection overview.
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Accessing Deployed Reports

When you install Class Based QoS, the Deploy Reports option is enabled. As a result, the 
reports in this package (as well as any forms associated with the package) are deployed to the 
PI 5.41 Application Server. Once reports reside on the Application Server, they can be viewed 
in two ways:

• PI 5.41 client applications

• Web browser
    

If the client applications are installed on the user’s system, the user has access to Report 
Viewer, Report Builder, and the Management Console. If the client applications are not 
installed on the user’s system, using a web browser to view reports is the only way the user 
can view reports.

For more information about the clients, refer to the HP Performance Insight Installation 
Guide. For details about the Management Console, including how to use the Object/Property 
Management view to launch reports specific to a selected object, refer to the HP Performance 
Insight 5.41 Administration Guide.
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Uninstalling the Package

Follow these steps to uninstall Class Based QoS. Removing the Report Pack automatically 
removes the Datapipe.

1 Log in to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

3 Start Package Manager. The Package Manager welcome window opens.

4 Click Next. The Package Location window opens.

5 Click the Uninstall radio button.

6 Click Next. The Report Undeployment window opens.

7 If reports were deployed to the PI 5.41 Application Server, accept the defaults for 
Undeploy Reports, Application Server Name, and Port. Otherwise, clear the check box and 
skip to step 9.

8 Type your username and password for the PI 5.41 Application Server.

9 Click Next. The Package Selection window opens.

10 Click the check box next to the following packages:

Class Based QoS Report Pack 1.31

Class Based QoS Report Pack Demo 1.00

11 Click OK.

12 Click Next. The Selection Summary window opens.

13 Click Uninstall. The Progress window opens and the removal process begins. When the 
uninstall process is complete, a package removal complete message appears.

14 Click Done to return to the Management Console.

15 Restart OVPI Timer.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, type the following:

HP-UX: sh /sbin/ovpi_timer start 

Solaris: sh /etc/init.d/ovpi_timer start 

The Class Based QoS Report Pack can be uninstalled independent of any other report pack.
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Troubleshooting

Problem Statement

Reports do not show data.

Solution

• Verify that data collection is successful.

— Check whether the configuration collection interval has been configured correctly

— Check whether the interfaces on the supported devices have been selected for the 
polling

• Check for errors in map procedure.

— Check the “trend.log” for error messages

• Make sure that Trendtimer is running.

• Open the View Troubleshooting external link

http://support.openview.hp.com/troubleshooting.jsp 

Problem Statement

Drilldown reports do not show voice and video traffic forecast information.

Solution

Update the configuration for the VoiceTraffic class in Cisco Class Based QoS MIB device 
configuration file using the following guidelines:

USA-PPY-BUS-RT-01.
policy-map Voice_Policy
class VoiceTraffic
priority percent 75
class class-default
fair-queue
random-detect
 
class-map match-all VoiceTraffic
match access-group name Voice
 
ip access-list extended Voice
remark Voice Traffic
permit tcp any any eq 1719
permit udp any any eq 1719
permit udp any any eq 1720
permit tcp any any eq 1720
permit udp any any range 2048 3028
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3 Sample Reports
This chapter contains samples of the following reports:

• Dropped Bit Rate History

• Queueing History

• Utilization History

• Policing Summary by Class

• Traffic Shaping Summary by Class

• Queuing Top N 

• Utilization Top N
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4 Configuring the Report Pack and Datapipe 
Configuring the Report Pack for Distributed System

These are the steps to follow when setting up a distributed system:

• Decide whether or not you want local reporting

• Install the right set of packages on each server (a central server that is not polling will not 
need datapipes; the satellite servers will need datapipes)

• Verify that the system clocks in your environment are synchronized

• Register your satellite servers

• If you are not copying rate data to the central server, enable LIR on the central server

• If you enable LIR, add LIR mapping with the time type set to rate

• Verify that you have all the copy policies you need

• Configure the central server (manual edits to trendtimer.sched and .pro files)

• Configure each satellite server (manual edits to trendtimer.sched and .pro files)

If you want to set up a distributed system, you can implement local reporting or you can 
implement centralized reporting. If you want local reporting, you need to deploy reports when 
you install the report pack on each satellite server, and you need to allow summarizations to 
run on each satellite server. If you do not want local reporting, then you do not need to deploy 
reports when you install a report pack on a satellite server and you can disable the scripts 
that run summarizations on each satellite server.

Before Location Independent Reporting (LIR) was available, our recommendation to anyone 
setting up a distributed system was to deploy reports on satellite servers, keep rate data on 
satellite servers, copy hourly data to the central server, and disable summarizations above the 
hourly level on satellite servers. The advantage to this approach was that it kept a large 
volume of rate data off the network and it decreased the processing load on the central server. 
The disadvantage is that the central server could not display a Near Real Time (NRT) report. 
The only NRT report was a local NRT report, on a satellite server. LIR overcomes this 
disadvantage. If you enable LIR, you can open an NRT report on the central server and 
drill-down on table selections. The selections you make cause the central server to query a 
satellite server for locally aggregated data. Of course, if you would rather copy rate data to the 
central server, you can. If you do that, then enabling LIR is not necessary. 
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Configuring the Central Server

To configure the central server, perform the following tasks:

Task 1: Register the satellite server by setting the database role

1 Start the Management Console (log on with Administrator privileges).

2 Click the Systems icon in the navigation pane.

3 Navigate to the HP Performance Insight Databases folder and select the database system.

4 Click Database Properties.

5 From the Database Role list, select the Satellite Server role.

6 Enter any information necessary to configure the Satellite Server role.

To add a new database reference, you can use the Add Database Reference Wizard in the 
System and Network Administration application.

Task 2: Enable LIR

1 Start the Management Console (log on with Administrator privileges).

2 Click the Systems icon in the navigation pane.

3 Navigate to the HP Performance Insight Databases folder and select the central server.

4 Click LIR Configuration.

5 Select the LIR enabled check box.

Task 3: Add LIR mappings

1 Start the Management Console (log on with Administrator privileges).

2 Click the Systems icon in the navigation pane.

3 Navigate to the HP Performance Insight Databases folder and select the central server. 

4 Click LIR Configuration.

5 Click Add Mapping.

6 Select a satellite server to which you need to add a mapping from the Select Satellite 
Server list.

7 Select the Category data table option.

8 Select Class Based QoS from the drop-down list.

9 Select the rate data type.

10 Click Add to List.

11 Ensure that the LIR mapping has not missed mapping any of the following tables. Also, 
ensure that the following tables are of rate data type:

• K_CBQOS_ServicePolicy

• K_CBQOS_ClassName

• K_CBQOS_PolicyName

• K_CBQOS_Class

• K_CBQOS_ClassPrec
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• KV_CBQOS_Class

• KV_CBQOS_ClassPrec

• KV_CBQOS_CLASSREPORT

The following figure depicts this:

12 If you want to add additional LIR mappings, click Add to list and repeat step 6 through 
step 12.

13 Click OK.

14 Click Apply.

A copy policy is automatically generated for the hourly data and for each LIR mapping that 
you add. The data type selected when adding an LIR mapping (in step 9 above) determines 
the type of data copied that is defined in the generated copy policy (the type of data copied 
that is defined in the generated copy policy is for one greater than the data type selected in 
the LIR mapping). For example, if you select an hourly data type, a daily data copy policy is 
generated.

Task 4: Verify the automatically generated copy policies

Verify that a copy policy has been generated for the following tables and that the copy type is 
set correctly (to Property and Data):

1 Start the Management Console (log on with Administrator privileges).

2 Click the Copy Policy icon in the navigation pane to start the Copy Policy Manager.

3 Find the following tables and ensure that the table types are as mentioned in the 
following table.
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If a copy policy has not been generated for a table, do the following:

4 Click the New Copy Policy icon or select File > New Copy Policy from the Copy Policy 
Manager. The Copy Policy Wizard opens.

5 Click Next. The Satellite Server and Copy Policy Selection Page opens.

6 Select a satellite server from the pull down list. This is the satellite server from which 
data is copied to the central server.

7 Select Single Table and select the table from the pull down list.

8 Click Next. The Copy Type Selection Page opens.

9 Select Property and Data.

Table 1 LIR Mapping Table Types

Table Name Table Type

SRCBQOS_Class Property and Data

SHCBQOS_Class Property and Data

SHCBQOS_ClassPolice Property and Data

SHCBQOS_ClassPolice Property and Data

SHCBQOS_ClassQueueing Property and Data

SHCBQOS_ClassRED Property and Data

SHCBQOS_ClassPrecRED Property and Data

SHCBQOS_ClassTS Property and Data

SHCBQOS_PolicyName Property
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10 Click Next. The Summary page opens.

11 Verify the information in the summary window. If the information is not correct, you can 
modify it by clicking Back.

12 Click Finish.

13 Repeat step 4 - step 12 for all missing tables.

If the copy type is not set to Property and Data, do the following:

1 Double-click the copy policy.

2 Select the Property and Data copy type.

3 Click OK.

Task 5: Modify the trendtimer.sched file

You can find the trendtimer.sched file in the {DPIPE_HOME}/lib/ directory. In this 
instance, {DPIPE_HOME} is the directory in which HP Performance Insight is installed.

Change this file by finding and commenting out the following line:

1:00+15 - - {DPIPE_HOME}/bin/trend_proc -f 
{DPIPE_HOME}/scripts/CB_QOS_Hourly.pro

Configuring Satellite Servers

Follow these steps to configure each satellite server.

1 Modify the {DPIPE_HOME}/lib/trendtimer.sched file (where {DPIPE_HOME} is the 
directory in which HP Performance Insight is installed). Do the following:

• Find and comment out the following line (to switch off interface aggregations above 
the hourly level):

24:00+3:00 - - {DPIPE_HOME}/bin/trend_proc -f
{DPIPE_HOME}/scripts/CB_QOS_Daily.pro

• Modify the *.pro trendtimer entry in the {DPIPE_HOME}/lib/trendtimer.sched file. By 
default, this process starts at 30 minutes after the hour. To make sure the satellite 
server completes hourly summarizations before the central server begins hourly 
summarizations, change the start time from 1:00+30 to 1:00+15.

2 Modify the *.pro file (found in the {DPIPE_HOME}/scripts/directory. In this instance, 
{DPIPE_HOME} is the directory in which HP Performance Insight is installed):

3 Configure polling policies for the Class Based QoS Datapipe, making sure that each 
Interface is polled by one satellite server only.

System Clocks

Make sure that the system clock on each satellite server is synchronized with the system clock 
on the central server.
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Configuring the Datapipe for Multiple Pollers

The Class Based QoS Datapipe requires additional configuration for use with multiple pollers. 
The standard installation configures 21 groups and 20 polling policies for a single poller. For 
use with multiple pollers, additional sets of groups and polling policies must be configured for 
each additional poller. 

The datapipe package includes additional group and collection policy files for two pollers. If 
you need to configure the datapipe for more than two pollers against a single database, follow 
these steps to generate additional sets of group files and policies:

1 Log in as the PI Administrator (trendadm).

2 Navigate to Class_Based_QoS_Datapipe\Class_Based_QoS_Datapipe.ap
\Multi_Pollers\ in the Package directory.

3 Run the following command:

trend_proc -f create_cbqos_groups_multi_pollers.pro

4 Run the following command (this is a single command and must be typed in the same 
line):

collection_manager -import -file 
CBQOS_Collection_Policies_multi_pollers.txt

5 Start Polling Policy Manager and select Edit → Datapipe Installations....

6 Click Create... to create new pollers.

7 Add the hostname and (optionally) the IP address of each poller and click OK.

8 When all pollers have been added, click Close to exit the Edit Datapipe Installations 
window.

9 Click All in the left panel to display all polling policies.

10 Delete the original *_Collection, *_ Immediate and *_C15 policies (those without a 
_poller1 or _poller2 at the end of the name). 

11 Modify the new *_Collection_poller1 policies by double-clicking the policy.

Change the Polling Assigned to setting to be the hostname of poller1.

12 Modify the new *_Collection_poller2 policies by double-clicking the policy.

Change the Polling Assigned to setting to be the hostname of poller2.

At this point, the policies should look similar to those in the following table.

Policy Name Table Name Group Name to Collect From Poll From

QoS_ServicePolicy_
Immediate_poller1

XCBQOSDP_ServicePolicy CBQoS_ImmediateConfig-poller1 Hostname of 
poller1

QoS_ServicePolicy_
Collection_poller1

XCBQOSDP_ServicePolicy CLASS_BASED_QOS-poller1 Hostname of 
poller1

QoS_Objects_
Immediate_poller1

XCBQOSDP_Objects CBQoS_ImmediateConfig-poller1 Hostname of 
poller1

QoS_Objects_
Collection_poller1

XCBQOSDP_Objects CLASS_BASED_QOS-poller1 Hostname of 
poller1
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QoS_PolicyMap_
Collection_poller1

XCBQOSDP_PolicyMap CBQOS_ConfigALL-poller1 Hostname of 
poller1

QoS_QueueingCFG_
Collection_poller1

XCBQOSDP_QueueingCfg CBQOS_ConfigQueue-poller1 Hostname of 
poller1

QoS_PoliceCFG_
Collection_poller1

XCBQOSDP_PoliceCfg CBQOS_ConfigPolice-poller1 Hostname of 
poller1

QoS_PoliceActCFG_
Collection_poller1

XCBQOSDP_PoliceActionCfg CBQOS_ConfigPolice-poller1 Hostname of 
poller1

QoS_MatchStmtCFG_
Collection_poller1

XCBQOSDP_MatchStmtCfg CBQOS_ConfigMatch-poller1 Hostname of 
poller1

QoS_ClassMapCFG_
Collection_poller1

XCBQOSDP_ClassMapCfg CBQOS_ConfigALL-poller1 Hostname of 
poller1

QoS_SetCFG_
Collection_poller1

XCBQOSDP_SetCfg CBQOS_ConfigSet-poller1 Hostname of 
poller1

QoS_TrafShapeCFG_
Collection_poller1

XCBQOSDP_TSCfg CBQOS_ConfigTS-poller1 Hostname of 
poller1

QoS_REDCFG_
Collection_poller1

XCBQOSDP_REDCfg CBQOS_ConfigRED-poller1 Hostname of 
poller1

QoS_REDClassCFG_
Collection_poller1

XCBQOSDP_REDClassCfg CBQOS_ConfigRED-poller1 Hostname of 
poller1

QoS_ClassMapStats_
C15_poller1

XCBQOSDP_ClassMapStats CBQoSDP_Objects2ClassMap-
poller1

Hostname of 
poller1

QoS_QueueingStats_
C15_poller1

XCBQOSDP_QueueingStats CBQoSDP_Objects4Queue-poller1 Hostname of 
poller1

QoS_MatchStats_
C15_poller1

XCBQOSDP_MatchStmtStats CBQoSDP_Objects3MatchStmt-
poller1

Hostname of 
poller1

QoS_PoliceStats_
C15_poller1

XCBQOSDP_PoliceStats CBQoSDP_Objects7Police-poller1 Hostname of 
poller1

QoS_TrafShapeStats_
C15_poller1

XCBQOSDP_TSStats CBQoSDP_Objects6TS-poller1 Hostname of 
poller1

QoS_REDClassStats_
C15_poller1

XCBQOSDP_REDClassStats CBQoSDP_REDObjects5RED-
poller1

Hostname of 
poller1

QoS_ServicePolicy_
Immediate_poller2

XCBQOSDP_ServicePolicy CBQoS_ImmediateConfig-poller2 Hostname of 
poller2

QoS_ServicePolicy_
Collection_poller2

XCBQOSDP_ServicePolicy CLASS_BASED_QOS-poller2 Hostname of 
poller2

QoS_Objects_
Immediate_poller2

XCBQOSDP_Objects CBQoS_ImmediateConfig-poller2 Hostname of 
poller2

Policy Name Table Name Group Name to Collect From Poll From
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13 Select Edit → Polling Groups... → All Nodes in Same View in the upper pane, then select 
poller1 in the lower pane. Assign nodes to be collected by poller1 to the poller1 view.

14 Select Edit → Polling Groups... → All Nodes in Same View in the upper pane, then select 
poller2 in the lower pane. Assign nodes to be collected by poller2 to the poller2 view.

QoS_Objects_
Collection_poller2

XCBQOSDP_Objects CLASS_BASED_QOS-poller2 Hostname of 
poller2

QoS_PolicyMap_
Collection_poller2

XCBQOSDP_PolicyMap CBQOS_ConfigALL-poller2 Hostname of 
poller2

QoS_QueueingCFG_
Collection_poller2

XCBQOSDP_QueueingCfg CBQOS_ConfigQueue-poller2 Hostname of 
poller2

QoS_PoliceCFG_
Collection_poller2

XCBQOSDP_PoliceCfg CBQOS_ConfigPolice-poller2 Hostname of 
poller2

QoS_PoliceActCFG_
Collection_poller2

XCBQOSDP_PoliceActionCfg CBQOS_ConfigPolice-poller2 Hostname of 
poller2

QoS_MatchStmtCFG_
Collection_poller2

XCBQOSDP_MatchStmtCfg CBQOS_ConfigMatch-poller2 Hostname of 
poller2

QoS_ClassMapCFG_
Collection_poller2

XCBQOSDP_ClassMapCfg CBQOS_ConfigALL-poller2 Hostname of 
poller2

QoS_SetCFG_
Collection_poller2

XCBQOSDP_SetCfg CBQOS_ConfigSet-poller2 Hostname of 
poller2

QoS_TrafShapeCFG_
Collection_poller2

XCBQOSDP_TSCfg CBQOS_ConfigTS-poller2 Hostname of 
poller2

QoS_REDCFG_
Collection_poller2

XCBQOSDP_REDCfg CBQOS_ConfigRED-poller2 Hostname of 
poller2

QoS_REDClassCFG_
Collection_poller2

XCBQOSDP_REDClassCfg CBQOS_ConfigRED-poller2 Hostname of 
poller2

QoS_ClassMapStats_
C15_poller2

XCBQOSDP_ClassMapStats CBQoSDP_Objects2ClassMap-
poller2

Hostname of 
poller2

QoS_QueueingStats_
C15_poller2

XCBQOSDP_QueueingStats CBQoSDP_Objects4Queue-poller2 Hostname of 
poller2

QoS_MatchStats_
C15_poller2

XCBQOSDP_MatchStmtStats CBQoSDP_Objects3MatchStmt-
poller2

Hostname of 
poller2

QoS_PoliceStats_
C15_poller2

XCBQOSDP_PoliceStats CBQoSDP_Objects7Police-poller2 Hostname of 
poller2

QoS_TrafShapeStats_
C15_poller2

XCBQOSDP_TSStats CBQoSDP_Objects6TS-poller2 Hostname of 
poller2

QoS_REDClassStats_
C15_poller2

XCBQOSDP_REDClassStats CBQoSDP_REDObjects5RED-
poller2

Hostname of 
poller2

Policy Name Table Name Group Name to Collect From Poll From
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A PI Report Packs
Business Technology Reporting Solution

Application Application Report Pack:
• WebLogic SPI
• WebSphere SPI

Database Database SPI Report Pack

HP Business Process Insight BPI Report Pack

HP Internet Services Internet Services Report Pack

HP Network Node Manager NNM Event & Availability Report Pack

HP Operations OVO Report Pack

IP Telephony • Cisco IP Telephony Call Detail
• Cisco IP Telephony Gateway Statistics

MPLS VPN MPLS VPN Report Pack

Networking Infrastructure Usage

• Interface Reporting
• Device Resource Report Pack

LAN/WAN Edge

• Frame Relay (SNMP only) 
• ATM (SNMP only)

WAN Core

• Frame Relay (multiple switch vendors)
• ATM (multiple switch vendors)

Traffic Profiling

• RMON II

• NetFlow Interface

• NetFlow Global View

• IP QoS Report Pack

• Class-Based QoS
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Networking (continued) Quality Assurance

• Cisco Ping Report Pack
• Service Assurance
• IP Access Rate

System Resources • System Resource Report Pack

Business Technology Reporting Solution
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