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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty statements 
accompanying such products and services. Nothing herein should be construed as constituting an additional 
warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. Consistent 
with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and 
Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard 
commercial license.

Copyright Notices

© Copyright 2004 - 2007 Hewlett-Packard Development Company, L.P.

Trademark Notices

UNIX® is a registered trademark of The Open Group.

Windows® and MS Windows® are US registered trademarks of Microsoft Corporation.

Oracle® is a registered US trademark of Oracle Corporation, Redwood City, California.

Java™ is a U.S. trademark of Sun Microsystems, Inc.
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Documentation Updates

This guide’s title page contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

To check for recent updates, or to verify that you are using the most recent edition of a document, go to:

http://ovweb.external.hp.com/lpe/doc_serv/ 

You will also receive updated or new editions if you subscribe to the appropriate product support service. 
Contact your HP sales representative for details.
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Support

You can visit the HP software support web site at:

http://support.openview.hp.com/support.jsp 

HP Software online support provides an efficient way to access interactive technical support tools. As a valued 
support customer, you can benefit by using the support site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a 
support contract.

To find more information about access levels and HP Passport, go to:

http://support.openview.hp.com/new_access_levels.jsp 
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1 Overview
This chapter covers the following topics

• OVPI and RMON2 Probes

• Enhancements in version 3.1

• Objects, reports, and groups

• Ways to customize reports

• Sources for additional information

OVPI and RMON2 Probes

HP Performance Insight is a performance management application that collects data from 
many sources, performs in-depth trend analysis, maintains performance baselines, and 
provides users with convenient, web-based reporting. Following is a partial list of product 
features:

• Distributed architecture

• Easy to scale (supports data collection from thousands of agents)

• CODA/OVPA agent support

• Multi-company security model

• Data warehousing

• Near Real Time reporting

• Forecasting 

• Extensive aggregation (by day, week, month; by location, by customer)

• Thresholding and alerting

• Bottlenecks easy to spot; capacity trends easy to review

• Accurate and timely documentation for management

The RMON2 Traffic Profiling Report Pack installs on OVPI. Using processing directives 
supplied by this report pack, OVPI generates the following statistics:

• Utilization host-by-host

• Utilization application-by-application

• Percentage of total interface traffic associated with each host and each application

• Bytes

• Average bytes per packet
7



In the figure below, an RMON2 probe queries network elements for information about 
network traffic and stores the results in an SNMP MIB. The data in the SNMP MIB indicates 
where network traffic is going, traffic volume, and which protocols are involved. The RMON2 
Traffic Profiling Datapipe collects data from the SNMP MIB and populates database tables 
maintained by OVPI. 

RMON2 Traffic Profiling supports the following RMON2 probes:

• Agilent

• Cisco NAM

• NetScout

Enhancements in Version 3.1

Version 3.1 includes new features, a revised datapipe, a new upgrade package, and defect 
fixes. For details about the enhancements made to previous releases, see Appendix A, Version 
History.

New Features

• LIR Configuration

• Copy Policies modified for LIR

• SQL modified for node delete

New Release of the Datapipe

• RMON2 Traffic Profiling Datapipe 3.2

New Upgrade Package

• UPGRADE_RMON2_Traffic_Profiling_to_31.ap

Defect Fixes

• QXCR1000219262

• QXCR1000221988
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Objects, Reports, and Groups

If you have access to the Management Console, you can display the reports in this package by 
opening the Object/Property Management window and navigating to the following object:

• RMON2 Probe Interface

Look for a list of reports under Report Specific Tasks. If you log in to the OVPI Application 
Server, you will see three folders: 

• ALMATRIX

• HOST

• TOP_TEN 

The ALMATRIX folder contains the following reports: 

• Daily ALMATRIX Details

• Daily ALMATRIX Summary 

• Hourly ALMATRIX Details 

• Hourly ALMATRIX Summary 

• Monthly ALMATRIX Detail 

• Monthly ALMATRIX Summary 

The HOST folder contains the following reports

• Daily Host Detail

• Daily Host Summary

• Hourly Host Detail

• Hourly Host Summary

• Monthly Host Detail

• Monthly Host Summary

The TOP_TEN folder contains the following reports:

• Daily Top Ten

• Hourly Top Ten

• Monthly Top Ten

Summary reports aggregate data by application and host devices and display hourly, daily, 
and monthly trending analysis. Use these reports to find out whether recent excess traffic was 
a short-lived anomaly or a long-standing trend that requires corrective action.

Detail reports drill down on Summary reports, allowing you to see which source/destination 
combinations and host/protocol combinations are contributing to excess traffic.

Top Ten reports indicate which protocols had the greatest impact on interface utilization, and 
which hosts had the greatest impact on interface utilization. 
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RMON2 Traffic Profiling adds the following groups to the object tree:

Options for Customizing Reports

The contents of a report can be customized by importing location data, by applying group 
filters, by editing parameters, and by editing tables and graphs,. While service providers use 
group filters to produce customer-specific reports, any user can import locations, edit 
parameters, or change view options for tables and graphs. 

Group Filters

If you intend to share your reports with customers, or let divisions within your enterprise see 
division-specific performance data, you must produce customer-specific reports by filtering 
the database. Creating customer-specific reports involves the following tasks:

• Importing customer names and device locations using Common Property Tables 

• Creating a group account for all of the users affiliated with a particular customer

• Creating a group filter for the group account

For more information about group filters, refer to the OVPI Administration Guide. 

Editing Parameters

When you edit a parameter, you apply a constraint to the report. The constrain eliminates the 
data you are not interested in seeing. For example, if you edit the RMON2 Probe parameter, 
the only data that appears in the report is data for the probe you typed in the RMON2 Probe 
field.

You can apply multiple constraints at the same time. RMON2 Traffic Profiling supports the 
following parameter edits:

• IF_Customer_Name

• IF_Customer_ID

• Start_Time
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• End_Time

• Client_Name (of source)

• Server_Name (of destination)

• Application_Name (of protocol)

• RMON2 Probe Interface

• RMON2 Probe

If you are using the Web Access Server to view reports, edit parameters by clicking the Edit 
Parameters icon at the bottom right-hand corner of the report. When the Edit Parameters 
window opens, enter the constraint in the field and click Submit. 

If the client component of OVPI is installed on your system, you have access to Report Viewer. 
To edit a parameter, select Edit > Parameter Values from the menu bar. The Modify Parameter 
Values window opens. Click the Current Value field, enter a new value, and click OK.

Importing Locations

Although RMON2 Traffic Profiling operates without importing custom property information, 
none of the location-oriented reports will contain useful information unless you add locations. 
To add locations to reports, use the property import utility bundled with Common Property 
Tables. For details, refer to the Common Property Tables 3.6 User Guide.

Sources for Additional Information

This user guide contains samples of some of the reports in the RMON2 package. The demo 
package that comes with RMON2 is complete, containing a sample of every report in the 
package. If you have access to the demo package and you want to know what fully-populated 
reports look like, install the demo package. Like real reports, demo reports are interactive. 
Unlike real reports, demo reports are static and do not change over time.

The following documents are related to this manual: 

• RMON2 Traffic Profiling Report Pack Release Notes

• Interface Reporting Report Pack User Guide

• Common Property Tables User Guide

• Interface Discovery Datapipe User Guide

• OVPI Report Packs, Release Notes, April 2007

Manuals for OVPI and the reporting solutions that run on OVPI are posted to the 
following website:

http://ovweb.external.hp.com/lpe/doc_serv/ 

User guides for OVPI are listed under Performance Insight. User guides for report packs and 
datapipes are listed under Performance Insight Report Packs. Each manual indicates a date. If a 
manual is revised and reposted, the date will change. Since we post revised manuals on a 
regular basis, you should compare the date of your PDF against the date of the PDF on the 
this web site and download the web edition if it is newer.
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2 Package Installation
This chapter covers the following topics: 

• Guidelines for a Smooth Install

• Upgrading to Version 3.1

• Installing RMON2 Traffic Profiling

• Accessing Deployed Reports

• Package Removal

Guidelines for a Smooth Install

Each reporting solution that runs on OVPI consists of a report pack and one datapipe, or 
sometimes a report pack and multiple datapipes. When you install the datapipe, you configure 
OVPI to collect a specific type of performance data at a specific polling interval. When you 
install the report pack, you configure OVPI to summarize and aggregate the performance data 
collected by the datapipe. 

The report pack CD contains report packs, datapipes, and shared packages. When you insert 
the CD in the CD-ROM drive and launch the package extraction program, the install script 
extracts every package from the CD and copies the results to the Packages directory on your 
system. When the extract finishes, the install script prompts you to start Package Manager. 
Before using Package Manager, review the following guidelines. 

Software Prerequisites

RMON2 Traffic Profiling has the following prerequisites:

• Performance Insight 5.3

• Any and all available service packs for PI 5.3

• Common Property Tables 3.7

• Interface Reporting Report Pack 5.3

• Interface Discovery Datapipe 2.5

If you are not currently running any version of the Interface Discovery Datapipe, or any 
version of Common Property Tables, you can install these packages when you install RMON2 
Traffic Profiling. 

If you are running earlier versions of Common Property Tables, version 3.6 or earlier, upgrade 
to version 3.7. Installing the upgrade package is no different from installing other upgrade 
packages; however, do not install the upgrade package and other packages at the same time. 
Install the upgrade package for Common Property Tables and only the upgrade package for 
Common Property Tables. 
  13



Install Procedure for Distributed Systems

Installation is more complex if you intend to run this package as a distributed system across 
multiple servers. Here is an overview of the installation procedure:

1 Verify that all servers are running the same version of OVPI and all available service 
packs for that version. 

2 Disable trendcopy on the central server.

3 Install RMON2 Traffic Profiling on the central server.

4 Install RMON2 Traffic Profiling and the RMON2 Traffic Profiling Datapipe on each 
satellite server. 

5 Re-enable trendcopy on the central server.

6 Configure the central server and each satellite server. For details, see Chapter 4, Setting 
Up a Distributed System.

Upgrading Common Property Tables

If you are running version 3.6 or earlier of Common Property Tables, upgrade to version 3.7 by 
installing the “to 3.7” upgrade package. Do not install other packages at the same time. Install 
the upgrade package for Common Property Tables and only the upgrade package for Common 
Property Tables. 

Datapipes and Remote Pollers

When you uninstall an existing datapipe, the following information will be lost:

• Single polling policy for a emote pollers

• Clone polling policies for multiple remote pollers

• Type and group information associated with a modified polling policy 

You can export existing configurations by using the collection_manager and group_manager 
commands.

Exporting Polling Policy Configurations

If your environment contains polling policy assignments to remote pollers, use the 
collection_manager command to export polling policies to a file. 

UNIX: As user trendadm, run the following command: 

cd $DPIPE_HOME

./bin/collection_manager -export -file /tmp/savePollingPolicy.lst

Windows: As Administrator, launch a command window. Navigate to the OVPI install 
directory and execute the following command: 

bin\collection_manager -export -file \temp\savePollingPolicy.lst

Exporting Custom Polling Groups

If your environment contains customized polling groups, use the group_manager command to 
export groups to individual .xml files in a directory. 
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UNIX: As user trendadm, execute the following command: 

cd $DPIPE_HOME

./bin/group_manager -export_all -outfile /tmp/savePollingGroups

Windows: As Administrator, launch a command window, then navigate to the OVPI install 
directory and execute the following command: 

bin\group_manager -export_all -outfile \temp\savePollingGroups

Custom Table Views

If you created custom views for data or property tables, the views you created may interfere 
with the report pack upgrade, causing the process to fail. Whether or not your custom views 
interfere with the upgrade process depends on how you created them. If you created them 
using SQL, the upgrade will succeed but your custom table views will not be available once 
the upgrade is complete. If you created them using Datapipe Manager, the upgrade is likely to 
fail. To prevent the upgrade from failing, delete custom table views before you upgrade the 
report pack, then recreate them after the upgrade is complete.

Upgrading to Version 3.1

If you are currently running RMON2 Traffic Profiling version 3.0 or earlier and you are 
familiar with Package Manager, you should have no difficulty upgrading to the latest release. 
Keep in mind that you must delete certain packages that cannot be upgraded. Here is an 
outline of the upgrade procedure:

• Task 1: Stop OVPI Timer and extract packages from the report pack CD

• Task 2: Upgrade to Common Property Tables 3.7

• Task 3: Upgrade to Interface Reporting 5.3

• Task 4: Install the UPGRADE_RMON2_Traffic_Profiling_to_31 upgrade package

• Task 5: Remove RMON2 Traffic Profiling Datapipe

• Task 6: Install RMON2 Traffic Profiling Datapipe 3.2

• Task 7: Restart OVPI Timer

Task 1: Stop OVPI Timer and extract packages from the report pack CD

1 Log in to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

On Windows, do the following:

a Select Control Panel > Administrative Tools > Services.

b Select OVPI Timer from the list of services.

c From the Action menu, select Stop.

On UNIX, as root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop
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3 Insert the report pack CD in the CD-ROM drive. On Windows, a Main Menu opens 
automatically; on UNIX, mount the CD if the CD does not mount automatically, navigate 
to the top level directory on the CD, and run the ./setup command. 

4 Type 1 in the choice field and press Enter. The install script displays a percentage complete 
bar. When the copy is complete, the install script starts Package Manager. The Package 
Manager welcome window opens.

If you navigate to the Packages directory on your system, you will see the following folders 
under the ATM folder:

• Docs

• RMON2_Traffic_Profiling.ap

• RMON2_Traffic_Profiling_Demo.ap

• UPGRADE_RMON2_Traffic_Profiling_31.ap

Task 2: Upgrade to Common Property Tables 3.7

Follow these rules:

• Do not install any other package with the Common Property Tables upgrade package; 
install the Common Property Tables upgrade package and only the Common Property 
Tables upgrade package. 

• When prompted to accept or disable the option to Deploy Reports, accept the default. If 
you do not deploy reports, you will not deploy the change forms that come with Common 
Property Tables.

• When the install finishes, click Done to return to the Management Console.

If you need more help with this task, refer to the Common Property Tables User Guide.

Task 3: Upgrade to Interface Reporting 5.3

1 If you have not already upgraded to Interface Reporting 5.2, install the 
UPGRADE_Interface_Reporting_to_52 package.

2 Upgrade the Interface Reporting datapipes.

• If you have one of the following versions of datapipes installed, you must remove this 
version of the datapipe and install the new datapipe (version 2.5):

— Interface Discovery Datapipe 1.1 / 2.0 / 2.1 / 2.2

• If you have the following version of a datapipe installed, you must upgrade to the new 
version of the datapipe (version 2.5):

— Interface Discovery Datapipe 2.4

Refer to the Interface Reporting Report Pack User Guide for more information about the 
upgrade procedure.

When the new datapipes are installed, click Done to return to the Management Console.

Task 4: Install the UPGRADE_RMON2_Traffic_Profiling_to_31 upgrade package

1 Start Package Manager. The Package Manager welcome window opens.

2 Click Next. The Package Location window opens.

3 Click Install.
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4 Click Next. The Report Deployment window opens. Accept the defaults for Deploy Reports, 
Application Server, and Port. Type your user name and password for the PI Application 
Server. 

5 Click Next. The Package Selection window opens. 

6 Click the check box next to the following package:

UPGRADE_RMON2_Traffic_Profiling_to_31

7 Click Next. The Type Discovery window opens. Disable the default.

8 Click Next. The Selection Summary window opens

9 Click Install. The Installation Progress window opens and the install begins. When the 
install finishes, a package install complete message appears. 

10 Click Done.

Task 5: Remove RMON2 Traffic Profiling Datapipe 

The RMON2 Traffic Profiling Datapipe cannot be upgraded. You must remove the existing 
datapipe and then install RMON2 Traffic Profiling Datapipe 3.2. Start Package Manager and 
follow the on-screen instructions for package removal. When Package Manager tells you that 
removal is complete, click Done to return to the Management Console. 

Task 6: Install RMON2 Traffic Profiling Datapipe 3.2 

1 Start Package Manager. The Package Manager welcome window opens.

2 Click Next. The Package Location window opens.

3 Click Install.

4 Click Next. The Report Deployment window opens; disable the default for Deploy Reports.

5 Click Next. The Package Selection window opens. 

6 Click the check box next to the following package:

RMON2 Traffic Profiling Datapipe 3.2

7 Click Next. The Type Discovery window opens. 

8 Click Next. The Selection Summary window opens.

9 Click Install. The Installation Progress window opens and the install begins. When the 
install finishes, the package installation complete message appears.

10 Click Done.

Task 7: Restart OVPI Timer 

On Windows, do the following:

1 Select Control Panel > Administrative Tools > Services.

2 Select OVPI Timer from the list of services.

3 From the Action menu, select Start.

On UNIX, as root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start
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Installing RMON2 Traffic Profiling 

Complete the following tasks to install RMON2 Traffic Profiling:

• Stop OVPI Timer and extract OVPI packages from the report pack CD

• If necessary, upgrade to Common Property Tables 3.7

• Install RMON2 Traffic Profiling

Task 1: Stop OVPI Timer and extract OVPI packages from the report pack CD

1 Log on to the system. On UNIX® systems, log on as root.

2 Stop OVPI Timer and wait for processes to terminate.

On Windows, do the following:

a From the Control Panel, select Administrative Tools > Services.

b Select OVPI Timer from the list of services.

c From the Action menu, select Stop.

On UNIX, as root, do one of the following:

— HP-UX: sh /sbin/init.d/ovpi_timer stop

— Sun: sh /etc/init.d/ovpi_timer stop

3 Insert the report pack CD in the CD-ROM drive. 

Windows: The Main Menu automatically displays. 

UNIX: 

a Mount the CD (if the CD does not mount automatically)

b Navigate to the top level directory on the CD

c Run ./setup.

4 Type 1 in the choice field and press Enter. The install script displays a percentage 
complete bar. When the copy is complete, the install script starts Package Manager. The 
Package Manager welcome window opens.

Task 2: If necessary, upgrade to Common Property Tables 3.7 

If you have not already upgraded to Common Property Tables 3.7, install the upgrade package 
now. Do not install other packages at the same time. Install the upgrade package for Common 
Property Tables and only the upgrade package for Common Property Tables. When the 
upgrade install is complete, click Done to return to the Management Console.

Task 3:Install RMON2 Traffic Profiling 

1 From the Management Console, select Tools > Package Manager. The Package Manager 
welcome window opens. 

2 Click Next. The Package Location window opens.

3 Click Install. Approve the default installation directory or select a different directory if 
necessary. 

If you are not running any version of Common Property Tables, skip this task and let Package 
Manager install Common Property Tables for you
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4 Click Next. The Report Deployment window opens. Accept the default for Deploy Reports. 
Type your user name and password for the OVPI Application Server. 

5 Click Next. The Package Selection window opens. 

6 Click the check box next to the following packages:

• RMON2 Traffic Profiling 3.1

• RMON2 Traffic Profiling Demo

• RMON2 Traffic Profiling Datapipe 3.2

• Interface Discovery Datapipe 2.5 (if not already installed)

7 Click Next. The Type Discovery window opens. Disable the default.

8 Click Next. The Selection Summary window opens. 

9 Click Install. The Installation Progress window opens. When installation finishes, a 
package installation complete message appears.

10 Click Done to return to the Management Console. 

11 Restart OVPI Timer.

On Windows, do the following:

a From the Control Panel, select Administrative Tools > Services

b Select OVPI Timer from the list of services.

c From the Action menu, select Start.

On UNIX, as root, enter one of the following commands:

— HP-UX: sh /sbin/init.d/ovpi_timer start

— Sun: sh /etc/init.d/ovpi_timer start

Accessing Deployed Reports

When you installed this report pack, you enabled the Deploy Reports option. As a result, the 
reports in this package (as well as any forms that come with this package) were deployed to 
the OVPI Application Server. Once reports reside on the OVPI Application Server, you have 
two ways to view them:

• OVPI client applications

• Web browser

If the OVPI client applications are installed on your system, you have access to Report Viewer, 
Report Builder, and the Management Console. If the clients are not installed on your system, 
using a web browser to log into the Web Access Server is the only way you can view reports.

For more information about OVPI clients, refer to the OVPI Installation Guide. For details 
about the Management Console, including how to use the Object/Property Management view 
to launch reports specific to a selected object, refer to the OVPI Administration Guide.

Installing the demo package is optional. You may install the demo package by 
itself, with no other packages, or you may install the demo package along with 
everything else. 
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Package Removal 

Follow these steps to uninstall the RMON2 Traffic Profiling Report Pack and RMON2 Traffic 
Profiling Datapipe:

1 Log on to the system. On UNIX systems, log on as root.

2 Stop OVPI Timer and wait for processes to stop running.

On Windows, do the following:

a From the Control Panel, select Administrative Tools > Services

b Select OVPI Timer from the list of services.

c From the Action menu, select Stop.

On UNIX, as root, enter one of the following commands:

— HP-UX: sh /sbin/init.d/ovpi_timer stop

— Sun: sh /etc/init.d/ovpi_timer stop

3 From the Management Console, start Package Manager. The Package Manager welcome 
window opens.

4 Click Next. The Package Location window opens.

5 Click Uninstall.

6 Click Next. The Report Undeployment window opens. Accept the default for Undeploy 
Reports, application server name, and port. 

7 Click Next. The Package Selection window opens.

8 Click the check box next to the following packages:

• RMON2 Traffic Profiling

• RMON2 Traffic Profiling Datapipe

• RMON2 Traffic Profiling Demo (if installed)

9 Click Next. The Selection Summary window opens.

10 Click Uninstall. The Progress window opens. When the uninstall process is complete, a 
package removal complete message appears.

11 Click Done to return to the Management Console.

12 Restart OVPI Timer.

On Windows, do the following:

a From the Control Panel, select Administrative Tools > Services

b Select OVPI Timer from the list of services.

c From the Action menu, select Start.

On UNIX, as root, enter one of the following commands:

— HP-UX: sh /sbin/init.d/ovpi_timer start

— Sun: sh /etc/init.d/ovpi_timer start

Uninstalling the RMON2 Traffic Profiling Report Pack automatically 
uninstalls the datapipe even if you do not select the datapipe for removal.
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3 Polling Groups and MIB Values
This chapter covers the following topics:

• How to add RMON2 probes to polling groups

• How to set MIB values

• Command line options for configAlMatrix.pl

Adding Probes and Setting MIB Values

Follow these steps to add probes to Polling Groups:

1 Using Polling Policy Manager, do the following:

a Add each RMON2 probe node to the RMON2 polling group.

b Specify the Community String Profile for each node added to the RMON2 polling 
group. Typically, you use the default settings (Read: public; Write: private). However, 
if you configured an RMON2 probe to use a non-default community string profile, you 
must configure this non-default community string profile for each node.

2 Using the OVPI SNMP Tool ConfigAlMatrix.pl command (click the Set Table button), or a 
tool of your own choice, set the following MIB objects:

Table 1 Variables Under hlMatrixControlTable

MIB Object OID Value

hlMatrixControlNIMaxDesiredEntries .1.3.6.1.2.1.16.15.1.1.6 6,000

hlMatrixControlAIMaxDesiredEntries .1.3.6.1.2.1.16.15.1.1.10 12,000

hlMatrixControlStatus .1.3.6.1.2.1.16.15.1.1.12 active

Table 2 Variables under alMatrixTopNControlTable

MIB Object OID Value

alMatrixTopNControlRateBase .1.3.6.1.2.1.16.17.3.1.3 alMatrixTopNTerminalsPkts

alMatrixTopNControlTimeRemaining .1.3.6.1.2.1.16.17.3.1.4 900

alMatrixTopNControlRequestedSize .1.3.6.1.2.1.16.17.3.1.7 400

alMatrixTopNControlStatus .1.3.6.1.2.1.16.17.3.1.11 active
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Command Line Options for ConfigAlMatrix.pl

ConfigAlMatrix.pl is a tool supplied with the RMON2 Traffic Profiling Datapipe. You can 
use this tool to create the RMON2 data source to MIB-2 ifIndex and set all the MIB objects to 
the values listed in Table 2 for a specified RMON2 probe. 

If you are using these MIB objects for other purposes, and if you do not want them set to these 
values, do not run this tool; instead, use the OVPI SNMP Tool or some other tool of your 
choice.

The following command line options are available:

ConfigAlMatrix.pl -a ProbeHost [-c CommunityString -f ConfigFile]

-a ProbeHost Required The name of the RMON2 probe.

-c CommunityString Optional Default: private. 

The write community string profile of the RMON2 probe. If 
the write community string profile of the RMON2 probe is 
set to something other than private, then you must use this 
option to specify the probe’s write community string profile.

-f ConfigFile Optional Default: 
\OVPI\packages\RMON2_Traffic_Profiling_Datapip
e\RMON2_Traffic_Profiling_Datapipe.ap\alMatrix
Config.xml. 

XML configuration file for the RMON2 probe. This file 
contains the MIB objects that can be modified. By default, 
MIB objects are set to the values listed in the preceding 
table. Modifying MIB objects will change the amount of data 
collected.
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4 Setting Up a Distributed System
These are the steps to follow when setting up a distributed system:

• Decide whether or not you want local reporting

• Install the right set of packages on each server (a central server that is not polling will not 
need datapipes; the satellite servers will need datapipes)

• Verify that the system clocks in your environment are synchronized

• Register your satellite servers

• If you are not copying rate data to the central server, enable LIR on the central server

• If you enable LIR, add LIR mapping with the time type set to rate

• Verify that you have all the copy policies you need

• Configure the central server (manual edits to trendtimer.sched and .pro files)

• Configure each satellite server (manual edits to trendtimer.sched and .pro files)

If you want to set up a distributed system, you can implement local reporting or you can 
implement centralized reporting. If you want local reporting, you need to deploy reports when 
you install the report pack on each satellite server, and you need to allow summarizations to 
run on each satellite server. If you do not want local reporting, then you do not need to deploy 
reports when you install a report pack on a satellite server and you can disable the scripts 
that run summarizations on each satellite server.

Before Location Independent Reporting (LIR) was available, our recommendation to anyone 
setting up a distributed system was to deploy reports on satellite servers, keep rate data on 
satellite servers, copy hourly data to the central server, and disable summarizations above the 
hourly level on satellite servers. The advantage to this approach was that it kept a large 
volume of rate data off the network and it decreased the processing load on the central server. 
The disadvantage is that the central server could not display a Near Real Time (NRT) report. 
The only NRT report was a local NRT report, on a satellite server. LIR overcomes this 
disadvantage. If you enable LIR, you can open an NRT report on the central server and 
drill-down on table selections. The selections you make cause the central server to query a 
satellite server for locally aggregated data. Of course, if you would rather copy rate data to the 
central server, you can. If you do that, then enabling LIR is not necessary.

Configuring the Central Server

To configure the central server, perform the following tasks:

• Task 1: Register the satellite server by setting the database role

• Task 2: If you are not copying rate data to the central server, enable LIR

• Task 3: If you enable LIR, add LIR mappings
  23



• Task 4: Verify the automatically generated copy policies

• Task 5: Modify the trendtimer.sched file

Task 1: Register the satellite server by setting the database role

1 Start the Management Console (log on with Administrator privileges).

2 Click the Systems icon in the navigation pane.

3 Navigate to the OVPI Databases folder and select the database system.

4 Click Database Properties.

5 From the Database Role list, select the Satellite Server role.

6 Enter any information necessary to configure the Satellite Server role.

Task 2: Enable LIR

1 Start the Management Console (log on with Administrator privileges).

2 Click the Systems icon in the navigation pane.

3 Navigate to the OVPI Databases folder and select the central server.

4 Click LIR Configuration.

5 Select the LIR enabled check box.

Task 3: Add LIR mappings

1 Start the Management Console (log on with Administrator privileges).

2 Click the Systems icon in the navigation pane.

3 Navigate to the OVPI Databases folder and select the central server.

4 Click LIR Configuration.

5 Click Add Mapping.

6 From the Select Satellite Server list, select a satellite server to which to add a mapping.

7 Select the Category data table option.

8 Select RMON2 Traffic Profiling from the drop down list.

9 Select the rate data type.

10 Click Add to List.

11 If you want to add additional LIR mappings, click Add to list and repeat step 6 through 
step 10.

12 Click OK.

13 Click Apply.

A copy policy is automatically generated for the hourly data and for each LIR mapping that 
you add. The data type selected when adding an LIR mapping (in step 9 above) determines 
the type of data copied that is defined in the generated copy policy (the type of data copied 
that is defined in the generated copy policy is for one greater than the data type selected in 
the LIR mapping). For example, if you select an hourly data type, a daily data copy policy is 
generated.

To add a new database reference, you can use the Add Database Reference Wizard in the 
System and Network Administration application.
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Task 4: Verify the automatically generated copy policies

Verify that a copy policy has been generated for the SHRMN2 table and that the copy type is 
set correctly (to Property and Data):

1 Start the Management Console (log on with Administrator privileges).

2 Click the Copy Policy icon in the navigation pane to start the Copy Policy Manager.

3 Find the SHRMN2 table and verify the copy type is set to Property and Data.

If a copy policy has not been generated for a table, do the following:

1 Click the New Copy Policy icon or select File > New Copy Policy from the Copy Policy 
Manager. The Copy Policy Wizard displays.

2 Click Next. The Satellite Server and Copy Policy Selection Page displays.

3 Select a satellite server from the pull down list. This is the satellite server from which 
data is copied to the central server.

4 Select Single Table and select SHRMN2 from the pull down list.

5 Click Next. The Copy Type Selection Page displays.

6 Select Property and Data.

7 Click Next. The Summary page displays.

8 Verify the information in the summary window. If the information is not correct, you can 
modify it by clicking Back.

9 Click Finish.

If the copy type is not set to Property and Data, do the following:

1 Double-click the copy policy.

2 Select the Property and Data copy type.

3 Click OK.

Task 5: Modify the trendtimer.sched file

The trendtimer.sched file is found in the {DPIPE_HOME}/lib/ directory where 
{DPIPE_HOME} is the directory in which OVPI is installed.

Make the following change:

• Find and change the following line (modify the daily processing time):

1:00+10 - - {DPIPE_HOME}/bin/trend_proc -f  
{DPIPE_HOME}/scripts/RMN2_Hourly.pro

to

1:00+15 - - {DPIPE_HOME}/bin/trend_proc -f  
{DPIPE_HOME}/scripts/RMN2_Hourly.pro

Configuring a Satellite Server

Follow these steps to configure each satellite server.

1 Modify the trendtimer.sched file (found in the {DPIPE_HOME}/lib/ directory where 
{DPIPE_HOME} is the directory in which OVPI is installed).
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Find and comment out the following line:

24:00+3:00+30 - - {DPIPE_HOME}/bin/trend_proc -f  
{DPIPE_HOME}/scripts/RMN2_Daily.pro

2 Modify the RMN2_Hourly.pro file (found in the {DPIPE_HOME}/scripts/ directory 
where {DPIPE_HOME} is the directory in which OVPI is installed). Do the following:

• Uncomment the RMN2 block (uncomment the begin:RMN2 wait and end:RMN2 lines).

• Comment out the block1, block3, block4, block6 and block7 blocks (comment out 
the begin:blockx and end:blockx lines).

System Clocks

Verify that the system clock on each satellite server is synchronized with the system clock on 
the central server.
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5 Sample Reports
RMON2 Traffic Profiling includes 15 reports. The following reports are reproduced below:

1 Monthly Top Ten Summary

2 Hourly AlMatrix Summary

3 Hourly AlMatrix Detail

4 Daily Host Summary

5 Daily Host Detail

Top Ten reports serve as a starting point for in-depth analysis of traffic problems. They 
contain the following information:

• Hourly utilization (in the hourly report only)

• Busy hour utilization (daily and monthly reports)

• A list of applications generating the most traffic, sorted from most to least

• A list of hosts generating the most traffic, sorted from most to least

ALMATRIX reports display traffic information by protocol and by source/destination host. 
RMON2 Traffic Profiling includes summary reports for ALMATRIX and detail reports for 
ALMATRIX. The summary reports aggregate data by protocol and by host devices; the detail 
reports contain information about the traffic between specific source and destination nodes for 
a selected protocol.

Host reports display traffic information by source. RMON2 Traffic Profiling includes 
summary reports for hosts and detail reports for hosts. The summary reports display traffic 
information for source nodes (listed by IP address) that generate the most traffic on the probe; 
the detail reports display traffic information sent by a protocol/application to a destination 
node for a selected source node. 
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A Version History
Package Version Release Date Features/Enhancements

1.0 May 2003 15 reports
RMON2 Traffic Profiling Datapipe 1.0
Sybase support

2.0 October 2003 OVPI Object Manager support
RMON2 Traffic Profiling Datapipe 2.0

3.0 November 2004 Oracle support
RMON2 Traffic Profiling Datapipe 3.0

3.0 June 2005 UPGRADE_RMON2_Traffic_Profiling_to_3.0

3.1 May 2006 QXCR1000243590 (map procedure appending “4”)

3.1 April 2007 new features:
• LIR Configuration
• Copy Policies modified for LIR
• SQL modified for node delete
new release of the datapipe:
RMON2 Traffic Profiling Datapipe 3.2
new upgrade package:
UPGRADE_RMON2_Traffic_Profiling_to_31.ap
defect fixes:
• QXCR1000219262
• QXCR1000221988

3.1 October 2007 new prerequisites: 
• PI 5.3
• Common Property Tables 3.7
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B Editing Tables and Graphs
Any table or graph can be viewed in several ways. Although the default view is usually 
adequate, you can easily change to a different view. If you are using Report Viewer, right-click 
the object to open a list of view options. If you are using the Web Access Server, follow these 
steps to change the default view of a table or graph:

1 Click Preferences on the links bar.

2 Expand Reports in the navigation frame.

3 Click Viewing.

4 Select the Allow element editing box.

5 Click Apply.

6 Click the Edit icon next to the table or graph. 

View Options for Tables

Right-clicking a table, or selecting the Edit Table icon if you are using the Web Access Server, 
opens a list of table view options.

Select Set Time Period to alter the relative time period (relative to now) or set an absolute time 
period. The Set Time Period window opens.

You may shorten the period of time covered by the table from, for example, 42 days to 30 days 
or to 7 days. If you are interested in a specific period of time that starts in the past and stops 
before yesterday, click Use Absolute Time and select a Start Time and an End Time.

Select Change Constraint Values to loosen or tighten a constraint, thereby raising or lowering 
the number of elements that conform to the constraint. The Change Constraint Values 
window opens. To loosen a constraint, set the value lower; to tighten a constraint, set the 
value higher.

The Select Nodes/Interfaces allows you to change the scope of the table by limiting the table to 
specific nodes, specific interfaces, or a specific group of nodes or interfaces. The Select Node 
Selection Type window opens.
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Change Max Rows increases or decreases the number of rows in a table. The default is 50. If 
you expand the default, the table may take more time to open. If you are trending a large 
network, using the default ensures that the table opens as quickly as possible. 
View in new Frame opens the table in a Table Viewer window, shown below. If necessary, make 
the data in the table more legible by resizing the window. 

View Options for Graphs

Right-clicking a graph, or clicking the Edit Graph icon if you are using the Web Access Server, 
opens the following list of view options. 
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The following table provides details about each option.

Style Options

Select Style to display a list of seven view options for graphs.

Option Function

Set Time Period Same as the table option shown above.

Change Constraint Values Same as the table option shown above.

Select Nodes/Interfaces Same as the table option shown above.

Displayed Data For every point on a graph, display data in a 
spreadsheet.

Grid Add these to the graph:
X axis grid lines
Y axis grid lines
X and Y axis grid lines

Legend Delete or reposition the legend. 

Style See the illustrations below.

Change Max Rows... Same as the table option shown above.

Display Data Table See below.

Export Element as CSV... Same as the table option shown above.

View in New Frame Opens graph in a Graph Viewer window.

Print Graph Same as the table option shown above.
Editing Tables and Graphs 43



Style > Area

The plot or bar chart changes to an area graph. While relative values and total values are 
easy to view in this format, absolute values for smaller data types may be hard to see. Click 
anywhere within a band of color to display the exact value for that location 

To shorten the time span of a graph, press SHIFT+ALT and use the left mouse button to 
highlight the time span you want to focus on. Release the mouse button to display the selected 
time span.

Style > Stacking Area

The area or plot graph changes to a stacking area graph. This view is suitable for displaying a 
small number of variables.
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Style > Bar

The graph changes to a bar chart. This view is suitable for displaying relatively equal values 
for a small number of variables. There are three variables in the graph below.

Style > Stacking Bar

The plot or area graph changes to a stacking bar chart. If you increase the width of the frame, 
the time scale becomes hourly. If you increase the height of the frame, the call volume shows 
in units of ten.
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Style > Plot

Bands of color in an area graph change to lines. If you adjust the frame width, you can make 
the data points align with hour; if you adjust the frame height, you can turn call volume into 
whole numbers.

Style > Pie

An area graph becomes a pie chart. Bands in an area graph convert to slices of a pie and the 
pie constitutes a 24-hour period. This view is helpful when a small number of data values are 
represented and you are looking at data for one day.

If you are looking at data for more than one day, you will see multiple pie graphs, one for each 
day. 
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Display Data Table

This option changes a graph into a spreadsheet. 

View in New Frame

The graph opens in a Graph Viewer window. Improve legibility by resizing the window. 
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Glossary
average bytes per packet 

The average number of bytes per packet passed by the host or application or passed between 
the source/destination.

busy hour utilization

The maximum hourly average for the day. Unlike the average for the day, this value does not 
smooth out daily peaks and valleys. Unlike daily maximum, or peak, this value represents a 
relatively persistent phenomenon, not a momentary condition. Note that since busy hour is an 
average, actual utilization may have been well above the average for a portion of that hour. 

bytes

The number of bytes passed by the host or application or passed between the source/
destination.

day

The day of the year for which the information was collected.

destination

Where the application/protocol traffic is going.

host

Where the application/protocol traffic is coming from.

hour

The hour for which the information was collected.

interface

The network interface number of the probe.

month

The month for which the information is collected.

packets

The total number of packets passed by the host or application or passed through the source/
destination.

percentage of traffic

The percentage of traffic attributed to the host, application, or source/destination in relation 
to the total traffic passing through the interface.
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probe

The name of an RMON2 probe.

protocol

The name of the protocol through which the network traffic is being routed.

source

See host.

utilization

The percentage of system resources used for one hour, beginning at the listed time.
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