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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty statements 
accompanying such products and services. Nothing herein should be construed as constituting an additional 
warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. Consistent 
with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and 
Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard 
commercial license.

Copyright Notices

© Copyright 2003 - 2007 Hewlett-Packard Development Company, L.P.

Trademark Notices

Java™ is a U.S. trademark of Sun Microsystems, Inc.

Oracle® is a registered U.S. trademark of Oracle Corporation, Redwood City, California. 

UNIX® is a registered trademark of The Open Group.

Windows® and Windows NT® are U.S. registered trademarks of Microsoft Corporation. 
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Documentation Updates

This guide’s title page contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

To check for recent updates, or to verify that you are using the most recent edition of a document, go to:

http://ovweb.external.hp.com/lpe/doc_serv/ 

You will also receive updated or new editions if you subscribe to the appropriate product support service. 
Contact your HP sales representative for details.
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Support

You can visit the HP software support web site at:

http://support.openview.hp.com/support.jsp 

HP Software online support provides an efficient way to access interactive technical support tools. As a valued 
support customer, you can benefit by using the support site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a 
support contract.

To find more information about access levels and HP Passport, go to:

http://support.openview.hp.com/new_access_levels.jsp 
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1 Overview
This chapter covers the following topics:

• OVPI and internet service reporting

• Folders and reports

• Data collection and daily processing; time periods

• Options for customizing reports

• Sources for additional information

Performance Insight and Internet Service Reporting

Performance Insight is a performance management application that collects data from many 
sources, performs in-depth trend analysis, maintains performance baselines, and provides 
users with convenient, web-based reporting. Following is a partial list of product features:

• Distributed architecture

• Easy to scale (supports data collection from thousands of agents)

• CODA/OVPA agent support

• Multi-company security model

• Data warehousing

• Near Real Time reporting

• Forecasting 

• Extensive aggregation (by day, week, month; by location, by customer)

• Thresholding and alerting

• Easy identification of bottlenecks

• Easy assessment of capacity trends

• Accurate and timely documentation for management

• Integration with NNM

• Integration with OVO

The Internet Services Report Pack installs on OVPI and provides detailed information about 
the performance of OVIS probe types and OVIS services on a customer-by-customer basis. The 
reports in this package can help you spot problem areas, make comparisons, and anticipate a 
developing problem. For ranking information, go to the reports in the Hot Spots folder and the 
Detail folder. These reports highlight problem areas. Use the reports in the Summary folder 
when you want to see how yesterday’s performance compares to last week’s performance, a 
30-day rolling baseline, and to performance over previous months. 
7



In addition to ranking probes and services, generating a rolling baseline, and forecasting 
future performance, the Internet Services Report Pack serves as a centralized data warehouse 
for OpenView Internet Services (OVIS). 

The following table outlines recent changes to the Internet Services Report Pack.

Folders and Reports

Internet Services includes twenty reports. If you are viewing reports from the web, you will 
see four report folders:

• Detail

• Hot Spots

• Forecasts

• Summary

The detail folder contains the following probe and service reports:

• Daily Probe Type Detail

• Monthly Probe Type Detail

• 30 Day Probe Type Detail

• Daily Service Detail

• Monthly Service Detail

• 30 Day Service Detail

Version Release Date Changes

1.0 April 2004 [RNS 5.0] 20 reports
Oracle support
Internet Services Datapipe 1.0

2.0 March 2006 Launch point page
report linking
UPGRADE_Internet_Services_to_20.ap

2.0 May 2006 Defect fixes for the Internet Services Datapipe 1.1

2.0 April 2007 Location Independent Reporting (LIR)
Copy Policies
Internet Services Datapipe 1.2
UPGRADE_IS_to_20
defect fixes: 
• QXCR1000293040
• QXCR1000347546
• QXCR1000365069

2.0 October 2007 Prerequisites:
• PI 5.3
• Common Property Tables 3.7
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The hot spots folder contains the following probe and service reports:

• Daily Probe Type Hot Spots

• Monthly Probe Type Hot Spots

• 30 Day Probe Type Hot Spots

• Daily Services Hot Spots

• Monthly Services Hot Spots

• 30 Day Services Hot Spots

The forecast folder contains the following probe and service reports:

• Probe Type Forecast

• Service Forecast

The summary folder contains the following probe and service reports:

• Daily Probe Type Summary

• Monthly Probe Type Summary

• 30 Day Probe Type Summary

• Daily Service Summary

• Monthly Service Summary

• 30 Day Service Summary

Data Collection and Daily Processing

The Internet Services Datapipe provides tables and routines responsible for collecting raw 
data from OVIS. The routines copy OVIS data into a flat file and move data from datapipe 
tables to report pack tables. The Internet Services Datapipe collects data from OVIS every 15 
minutes. Data collection is controlled by directives in the Internet_Services_DP.pro file.

The Internet_Services_Daily.pro file is responsible for calculating averages and aggregating 
data by customer, service, and probe type. Because there are no hourly reports, all hourly 
processing is done once a day. If you need hourly reports, or if performance issues make it 
necessary to process hourly data in an incremental manner, throughout the day, you must 
modify the Internet_Services_Hourly.pro file.

Time Periods

Except for the forecast reports, every report fits into one of the following categories:

• Daily

• Monthly

• 30 day

The daily report begins with statistics for yesterday and allows you to compare yesterday’s 
statistics to performance over the preceding 30 days. The tables at the top show data for the 
selected day, while the graphs below let you see a full 30 days of data. 

The monthly report lets you see what the trend has been for the past 12 months. You will see 
two aggregations, one for month-to-date (the beginning of the current month until yesterday), 
and one for previous calendar months, up to a maximum of 12 months. 
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The 30 day report aggregates data for the preceding 30 days. The tables at the top show totals 
and averages for a rolling 30 day baseline, while the graphs below show data for each day 
within the rolling 30 day baseline. 

Special Terms and Statistics

The following table defines special terms and statistics.

Term Definition

Availability The percentage of tests that were successful; serves as an 
estimate of service availability.

Customer The customer as defined in the OVIS Server; the name of the 
customer for whom services are being monitored.

OVIS test One execution of a simulated service from one probe system 
to one target.

Probe system Also referred to as a probe. The system that contains 
software that initiates the simulated service, measures the 
results, and sends the results back to the OVIS server.

Probe type Also referred to as Service Type or Service in the OVIS 
system. A simulated network business activity, such as 
HTTP, FTP, DNS, etc. 

Response time The response time measured by probe systems for successful 
OVIS tests. In a daily report, and in the graphs of 30 day 
reports, response time is the highest (worst) hourly average 
for each day. In a monthly report, and in the selection tables 
of 30 day reports, response time is the average of the highest 
hourly average for each day. The graphs in monthly reports 
also show the maximum of the daily highest hourly averages 
during the month.

Service Also referred to as Service Group in the OVIS system. A 
grouping of measurements of a single service or probe type 
that have common service level objectives. 

Service level violation The number of tests that exceeded a threshold as defined by 
the OVIS system user.

Target The target of the simulated service. This could be a URL, a 
DNS server, an FTP server, etc.

Throughput The throughput measured by probe systems for successful 
OVIS tests. The throughput displayed in daily reports, and 
in the graphs of 30 day reports, is the lowest (worst) hourly 
average for each day. 
The throughput displayed in monthly reports, and in the 
selection tables of 30 day reports, is the average of the lowest 
hourly average for each day. The graphs in the monthly 
reports also show the minimum of the daily lowest hourly 
averages during the month. 
Note: Not all OVIS tests measure throughput.
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Provisioning

Provisioning this report pack is not necessary. OVPI uses customer information maintained 
by the OVIS Management Server to populate the appropriate table in the Common Property 
Tables package, then the Internet Services Report Pack uses the customer data in that table 
to populate reports with customers. As a result, OVPI knows which services belong to each 
customer, and OVPI knows which probe types are used by each customer

Integration with NNM

If you use NNM, you have the option of integrating PI and NNM. The steps required to 
integrate NNM and OVPI are covered in the NNM/PI Integration Guide. As explained in 
more detail in the user guide, integration entails running an integration script on NNM and 
launching the Integration Wizard on OVPI. (Installing various integration packages on NNM 
and OVPI is no longer necessary.) Once NNM and OVPI are integrated, you can launch 
reports in the Internet Services Report Pack directly from NNM. Because OVIS Management 
Servers are already integrated with NNM, the Internet Services Report Pack, unlike most 
report packs, does not include a separate thresholds sub-package.

Options for Customizing Reports

You can customize the contents of a report by applying group filters, by editing parameters, 
and by editing tables and graphs. While group filters are usually used by service providers to 
create customer-specific reports, any user can apply constraints to a report and edit tables 
and graphs. For details about options for viewing tables and graphs, see Appendix A, View 
Options for Tables and Graphs.

Group Filters

If you intend to share reports with customers, you must configure PI to produce 
customer-specific reports. Configuring PI to produce customer-specific reports involves the 
following tasks:

• Importing custom property information (customer names and device locations) using 
Common Property Tables

• Creating a group account for all of the users affiliated with a particular customer

• Creating a group filter for the group account

For more information about group filters, refer to the PI Administration Guide. 

Editing Parameters

Editing a parameter applies a constraint. The constraint eliminates data you are not 
interested in seeing. For example, if you edit the Customer Name parameter, data for every 
customer except the customer you typed in the Customer Name field would drop from the 
report. Internet Services supports the following parameters: 

• Customer

• Service 
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• Probe Type

• Cust_id

If you are using the Web Access Server to view reports remotely, edit parameters by clicking 
the Edit Parameters icon at the bottom right-hand corner of the report. When the Edit 
Parameters window opens, enter the constraint in the field and click Submit. 

If you are using Report Viewer, select Edit > Parameter Values from the menu bar. When the 
Modify Parameter Values window opens, click the Current Value field. Type a new value and 
click OK.

Sources for Additional Information

This user guide provides samples of some of the reports in the Internet Services Report Pack. 
The demo package that comes with Internet Services contains a sample of every report in the 
package. If you have access to the demo package and you want to see fully-populated reports, 
install the demo package. Like real reports, demo reports are interactive. Unlike real reports, 
demo reports are static.

The following documents are related to the Internet Services Report Pack: 

• Internet Services Report Pack 2.0 Release Notes

• Internet Services RP Datapipe Release Notes

• OVIS Custom Probes API Guide 

• OVPI Report Packs, CD-ROM Release Notes, October 2007

You can download manuals for OVPI and the reporting solutions that run on OVPI from 
this site:

http://ovweb.external.hp.com/lpe/doc_serv/

The user guides for OVPI are listed under Performance Insight. The user guides for report 
packs and datapipes are listed under Performance Insight Reporting Solutions. Each document 
indicates the date. If a document is revised and reposted, the date will change. Since we post 
revised manuals on a regular basis, you should compare the date on your PDF to the PDF 
posted to this web site and download the web edition if it is newer.
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2 The Upgrade Install
This chapter covers the following topics: 

• Guidelines for a Smooth Upgrade

• Upgrading to Version 2.0

• Removing Internet Services

If you are installing the Internet Services Report Pack for the first time, this chapter does not 
apply to you. See Chapter 3, The New Install.

Guidelines for a Smooth Upgrade

When you insert the report pack CD in the CD-ROM drive and launch the package extraction 
program, the install script extracts every package from the CD and copies the results to the 
Packages directory on your system. When the extract finishes, the install script prompts you 
to launch Performance Insight and start Package Manager. Before running Package Manager, 
review the following guidelines:

• Prerequisites for the Internet Services Report Pack

• Upgrading Common Property Tables

• Datapipes and Remote Pollers

• Custom Table Views

• Upgrading Internet Services in a Distributed Environment

Prerequisites for the Internet Services Report Pack

Make sure the following software is installed before upgrading to Internet Services 2.0:

• OVPI 5.3

• All service packs available for OVPI 

• Common Property Tables 3.7

Upgrading Common Property Tables

If you are running an older version of Common Property Tables, you must upgrade that 
package to version 3.7 or higher. If you are not running any version of Common Property 
Tables, Package Manager will install the latest version of Common Property Tables for you, 
automatically.
  13



Do not install an upgrade for Common Property Tables and other packages at the same time. 
Install the upgrade package for Common Property Tables and only the upgrade package for 
Common Property Tables. For more information about installing and using Common Property 
Tables, refer to the Common Property Tables User Guide.

Datapipes and Remote Pollers

If you uninstall an existing datapipe, the following information is lost:

• Single polling policy for a remote poller

• Cloned polling policies for multiple remote pollers

• Customized polling groups 

To prevent this information from being lost, you can use the following commands to export 
existing polling policy configurations and customized polling groups:

• collection_manager

• group_manager 

Exporting Polling Policy Configurations

If your environment contains polling policies for remote pollers, use the collection_manager 
command to export existing policy configurations to a file. 

UNIX: As user trendadm, run the following command: 

cd $DPIPE_HOME

./bin/collection_manager -export -file /tmp/savePollingPolicy.lst

Windows: As Administrator, launch a command window. Navigate to the OVPI install 
directory and execute the following command: 

bin\collection_manager -export -file \temp\savePollingPolicy.lst

Exporting Polling Group Configurations

If your environment contains customized polling groups, use the group_manager command to 
export groups to individual .xml files. 

UNIX: As user trendadm, execute the following command: 

cd $DPIPE_HOME

./bin/group_manager -export_all -outfile /tmp/savePollingGroups

Windows: As Administrator, launch a command window, then navigate to the OVPI install 
directory and execute the following command: 

bin\group_manager -export_all -outfile \temp\savePollingGroups

Custom Table Views

If you are using table views you created yourself, the views you created may interfere with the 
report pack upgrade, causing the upgrade to fail. Whether or not your views interfere with the 
upgrade process depends on how you created them. If you used SQL to create them, the 
upgrade will succeed, however, your custom views will not be available once the upgrade is 
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complete. If you used Datapipe Manager to create them, the upgrade is likely to fail. To 
prevent the upgrade from failing, delete custom table views before you upgrade the report 
pack, then recreate those views after the report pack is upgraded.

Upgrading Internet Services in a Distributed Environment

The following is an overview of the installation procedure for a distributed environment:

1 Disable trendcopy on the central server.

2 For the central server:

• Upgrade to Common Property Tables 3.7; deploy reports

• Upgrade to Internet Services 2.0; deploy reports

3 For each satellite server:

• Upgrade to Common Property Tables 3.7 

• Upgrade to Internet Services 2.0

• Remove Internet Services Datapipe 1.1.

• Install Internet Services Datapipe 1.2

4 Re-enable trendcopy on the central server.

When Internet Services was installed, the person who installed that version had to set up 
connections with satellite server databases, configure trendcopy commands, and switch off 
aggregations above the hourly level at each satellite server. If you recently upgraded to PI 5.3, 
server configuration changes that were made when Internet Services was installed must be 
redone. Reconfigure the central server and each satellite server. For details, see Chapter 4, 
Setting Up a Distributed System.

Upgrading to Version 2.0

Perform the following tasks to upgrade to version 2.0:

• Task 1: Stop OVPI Timer and extract packages from the report pack CD

• Task 2: Upgrade to Common Property Tables 3.7

• Task 3: Install the Upgrade Packages

• Task 4: Remove Internet Services Datapipe 1.1

• Task 5: Install Internet Services Datapipe 1.2

• Task 6: Restart OVPI Timer

Task 1: Stop OVPI Timer and extract packages from the report pack CD

1 Log in to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

On Windows, do the following:

a Select Control Panel > Administrative Tools > Services.

b Select OVPI Timer from the list of services.
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c From the Action menu, select Stop.

On UNIX, as root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop

3 Insert the report pack CD in the CD-ROM drive. On Windows, a Main Menu opens 
automatically; on UNIX, mount the CD if the CD does not mount automatically, navigate 
to the top level directory on the CD, and run the ./setup command. 

4 Type 1 in the choice field and press Enter. The install script displays a percentage complete 
bar. When the copy is complete, the install script starts Package Manager. The Package 
Manager welcome window opens.

If you navigate to the Packages directory on your system, you will see the following folders 
under the Internet Services folder:

• Internet_Services.ap

• Internet_Services_Demo.ap

• UPGRADE_IS_to_20.ap

Task 2: Upgrade to Common Property Tables 3.7

Follow these rules to update Common Property Tables:

• Do not install any other package with the Common Property Tables upgrade package; 
install the Common Property Tables upgrade package and only the Common Property 
Tables upgrade package. 

• When prompted to accept or disable the option to Deploy Reports, accept the default. If 
you do not deploy reports, you will not deploy the change forms that come with Common 
Property Tables.

• When the install finishes, click Done to return to the Management Console.

If you need more help with this task, refer to the Common Property Tables User Guide.

Task 3: Install the Upgrade Packages

1 From the Management Console, select Tools > Package Manager. The Package Manager 
welcome window opens.

2 Click Next. The Package Location window opens.

3 Click Install. 

4 Click Next. The Report Deployment window opens. Accept the defaults for Deploy Reports, 
Application Server, and Port. Type your user name and password for the OVPI 
Application Server. 

5 Click Next. The Package Selection window opens. 

6 Click the check box next to the following packages (depending on which packages you are 
upgrading):

UPGRADE_IS_to_20.ap

7 Click Next. The Type Discovery window opens. Disable the default.

8 Click Next. The Selection Summary window opens

9 Click Install. The Installation Progress window opens and the install begins. When the 
install finishes, a package install complete message appears. 
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10 Click Done. 

Task 4: Remove Internet Services Datapipe 1.1 

The Internet Services Datapipe cannot be upgraded. You must remove the existing datapipe 
and then install Internet Services Datapipe 1.2. Start Package Manager and follow the 
on-screen instructions for package removal. When Package Manager tells you that removal is 
complete, click Done to return to the Management Console. 

Task 5: Install Internet Services Datapipe 1.2 

1 Start Package Manager. The Package Manager welcome window opens.

2 Click Next. The Package Location window opens.

3 Click Install.

4 Click Next. The Report Deployment window opens; disable the default for Deploy Reports.

5 Click Next. The Package Selection window opens. 

6 Click the check box next to the following package:

Internet Services Datapipe 1.2

7 Click Next. The Type Discovery window opens. 

8 Click Next. The Selection Summary window opens.

9 Click Install. The Installation Progress window opens and the install begins. When the 
install finishes, the package installation complete message appears.

10 Click Done.

Task 6: Restart OVPI Timer 

On Windows, do the following:

a Select Control Panel > Administrative Tools > Services.

b Select OVPI Timer from the list of services.

c From the Action menu, select Start.

On UNIX, as root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start

Removing Internet Services

Follow the steps under Task 1 to uninstall Internet Services. Removing Internet Services will 
automatically remove the datapipe. Task 2 tells you how to remove an OVIS system defined as 
a Generic Supported Database. Removing the OVIS system is not mandatory; this step is 
recommended.

Do not be surprised if the UPGRADE package you just installed disappears from 
view. Package Manager will display what you just installed as Internet Services 
Report Pack 2.0. This is not an error
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Task 1: Uninstalling the Internet Services Report Pack

1 Log in to the system. On Unix systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

Unix: As root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop

3 Start Package Manager. The Package Manager welcome window opens.

4 Click Next. The Package Location window opens.

5 Click Uninstall.

6 Click Next. The Report Undeployment window opens.

7 If Internet Services reports were deployed from this server, accept the defaults for 
Undeploy Reports, Application Server Name, and Port. If Internet Services reports were 
not deployed from this server, clear the check box and skip to step 9.

8 Type the username and password for the OVPI Application Server.

9 Click Next. The Package Selection window opens. 

10 Click the check box next to the following package:

 Internet Services Report Pack

11 Click Next. The Selection Summary window opens. 

12 Click Uninstall. The Progress window opens and the removal process begins. When the 
uninstall process is complete, a package removal complete message appears. 

13 Click Done to return to the Management Console.

14 Restart OVPI Timer.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

Unix: As root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start

Task 2: Removing an OVIS system defined as a Generic Supported Database

1 Click the Systems icon on the left-hand side of the Management Console.

2 Select the local system. OVPI and generic databases appear in the main window.

3 Right-click the OVIS system and select Delete System...

4 Click Yes in the pop-up window. 

The OVIS system is now removed.
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3 The New Install
This chapter covers the following topics: 

• Guidelines for a smooth installation

• Installing the Internet Services Report Pack

• Adding the OVIS database to OVPI (defining an OVIS collection) 

• Accessing deployed reports

• Changes to the object model

• Seeing performance data in reports

• Package removal and OVIS system removal

Guidelines for a Smooth Installation

An OVPI reporting solution has at least two ingredients, a report pack and a datapipe. Some 
reporting solutions offer multiple, vendor-specific datapipes. When you install the datapipe, 
you configure OVPI to collect performance data from a MIB or from a flat file at a specific 
interval. When you install the report pack, you configure OVPI to calculate averages (hourly, 
daily, monthly) and aggregate the averages in some manner—by device, by location, or by 
customer.

The report pack CD-ROM contains report packs, datapipes, and shared packages. If you, or 
someone else, extracted packages from the report pack CD, the Internet Services Report Pack 
is available for installation. To install the package, start Package Manager and follow the 
on-screen directions. If the package extract step has not taken place yet, follow the procedure 
for extracting packages in this chapter. Before installing any software, review the information 
below about prerequisites and running OVIS and OVPI on the same server.

OVIS and OVPI on the Same Server

Although you may install OVPI on the same server that is running OVIS, we recommend 
installing OVPI and OVIS on separate servers. If you decide to install OVPI and OVIS on the 
same system, you must indicate an alternate hostname by adding a new line to the system 
hosts file. The path to the file is:

Windows:

\windows\system32\drivers\etc\hosts

UNIX:

/etc/hosts
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The line you add to the hosts file must contain two pieces of information:

• An IP address for the OVIS system

• An alternate hostname for the OVIS system

For example:

192.192.192.192 ovisnode

You will use the alternate hostname when you define OVIS collections. 

Prerequisites for the Report Pack

Make sure the following software is already installed before installing the Internet Services 
Report Pack:

• Performance Insight 5.3

• Any and all service packs available for PI 5.3

• Common Property Tables 3.7

If you are running an older version of Common Property Tables, upgrade to the latest version 
by installing the upgrade package. If you are not running any version of Common Property 
Tables, do nothing. Package Manager will install the latest version of Common Property 
Tables for you, automatically.

If you need to install the upgrade for Common Property Tables, do this first, before upgrading 
or installing anything else, and do not install the upgrade package and other packages at the 
same time. Install the upgrade package for Common Property Tables and only the upgrade 
package for Common Property Tables. 

Distributed Systems

If your system is distributed, the installation procedure is more complicated. Following is a 
summary of the installation procedure for a distributed system:

Central Server

1 Disable trendcopy on the central server.

2 If you are not running version 3.7, upgrade to verson 3.7.

3 Install Internet Services Report Pack 2.0.

Satellite Servers

1 If you are not running version 3.7, upgrade Common Property Tables

2 Install these packages:

• Internet Services Report Pack 2.0

• Internet Services Report Pack Datapipe 1.2

When you finish installing packages on the satellite serves, re-enable trendcopy on the central 
server. After you re-enable trendcopy, configure the central server and each satellite server. 
These steps are covered in Chapter 4, Setting Up a Distributed System.
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Installing Internet Services Report Pack 2.0

This section covers the following tasks:

• Task 1: Extract packages from the report pack CD

• Task 2: If necessary, upgrade Common Property Tables

• Task 3: Install these packages:

— Internet Services Report Pack 2.0

— Internet Services Datapipe 1.2

Task 1: Extract packages from the report pack CD

1 Log in to the system. On Unix systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, type one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop

3 Insert the report pack CD in the CD-ROM drive. On a Windows operating system, a Main 
Menu opens automatically; on Unix, mount the CD, navigate to the top-level directory for 
the CD drive, and type the setup command. 

4 Extract OVPI report packs to the Packages directory on your system by typing 1 in the 
choice field and pressing Enter. A completion bar shows progress. When the extract 
finishes, the install script starts Package Manager. The Package Manager welcome 
window opens.

If you want to confirm that packages on the CD are now in the Packages directory on your 
system, navigate to the Packages directory. You will see the following folders under the 
Internet Services folder:

• Internet_Services.ap

• Internet_Services_Demo.ap

• UPGRADE_Internet_Services_to_20.ap

• Docs

Installing the demo package is optional. You may install the demo package and only the demo 
package, or you can install the demo package along with the report pack. 

Task 2: Upgrade to Common Property Tables 3.7

If you are running version 3.6 or earlier, upgrade to version 3.7. Observe these rules:

• Do not install other packages at the same time; install the upgrade package for Common 
Property Tables and only the upgrade package for Common Property Tables. 

• When prompted to accept or disable the option to Deploy Reports, accept the default. If 
you do not deploy reports, you will not have access to the forms that come with Common 
Property Tables.

• When the install finishes, click Done to return to the Management Console.

If you need help with the upgrade, refer to the Common Property Tables User Guide. 
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Task 3: Install the report pack and the datapipe

1 From the Management Console select Tools > Package Manager. The Package Manager 
welcome window opens.

2 Click Next. The Package Location window opens.

3 Click Install. Approve the default installation directory or use the browse feature to select 
a different directory if necessary. 

4 Click Next. The Report Deployment window opens. Accept the default for Deploy Reports; 
accept the default for application server name and port. Type your username and 
password for the OVPI Application Server. 

5 Click Next. The Package Selection window opens. 

6 Click the check box next to the following package:

Internet Services 2.0 

Internet Services Datapipe 1.2

Internet Services Demo (optional)

7 Click Next. The Type Discovery window opens. 

8 Disable the default to run Type Discovery immediately after package installation. (If you 
are installing other report packs in addition to Internet Services, you may need to run 
Type Discovery for those packages.)

9 Click Next. The Selection Summary window opens.

10 Click Install. The Installation Progress window opens and the install process begins. When 
the install finishes, a package install complete message appears. 

11 Click Done to return to the Management Console. 

12 Restart OVPI Timer.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, type one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start

Once the Internet Services Report Pack and the Internet Services Report Pack Datapipe are 
installed, your next task is to add the OVIS system as a supported database.

Adding OVIS as a Supported Database

You cannot collect data from OVIS until OVPI recognizes OVIS as a supported database. 
Follow these steps to add OVIS as a supported database: 

1 Determine which port the OVIS system is using. The default for an OVIS system installed 
on Oracle is port 1521. If for some reason port 1521 is not available, discuss this with your 
your Oracle system administrator. To determine the port for an OVIS system installed on 
SQL server, follow these steps: 

a From the command line, type: svrnetcn.exe

b The SQL Server Network Utility opens. Under Enabled protocols select TCP/IP.

c Click Properties. The port number appears in the pop-up window.
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2 Start Performance Insight and open the Management Console.

3 Click the Systems icon located on the left-hand side of the Management Console.

4 Expand the information under the OVPI system by clicking “+”.

5 Right-click the Databases folder.

6 Select Add Database. The Add Database Wizard opens.

7 Click Next.

8 Select Generic Supported Database and click Next.

9 The Database Connection Information window opens. Add the following information:

• Hostname – Either the hostname or the IP address of the OVIS server

• Port – The TCP/IP port number 

• Description – Must include either “OVIS” or “ovis” to enable collection of OVIS data

• Vendor – Select the database vendor for the OVIS system

• Database Instance – Specify OVOPS for SQL server; reporter for Oracle

• Database Username – Username with access to the OVIS database

• Password – Database password

If OVPI and OVIS are installed on the same platform, use of the alternate 
hostname/IP address you added to the system hosts file. (See page 20 for details.)
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10 Click Finish.

11 Click Next.

12 Type a unique, identifying System name. Do not use spaces or numbers in the name. 
Typing a description is optional.

13 Click Next. The Summary window opens.

You can test the connection you just defined without having to wait for the next scheduled 
collection of data. Follow these steps to test the connection:

1 Expand the system tree.

2 Select the OVIS database.

3 Click Test Connection.

If the connection is good, the Internet Services Datapipe will begin collecting data from the 
OVIS system at the next scheduled collection. The next scheduled collection will take place in 
15 minutes or less. Because an OVIS system will store data for several days (the default is 7 
days), the first collection can take a long time to complete. Subsequent collections will be 
much faster since there will be much less data to collect.

To verify that the collection worked as expected, open Table Manager from the Management 
Console and look for data in these tables:

• ROVISDP (a data table)

• K_OVISDP (a property table)

There are two ways to stop collecting data from an OVIS system:
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• Delete the OVIS system as a supported database

• Edit the database description, removing any references to OVIS or ovis

Accessing Deployed Reports

When you installed the Internet Services Report Pack, you enabled the Deploy Reports option. 
As a result, the reports in this package (as well as any forms that come with it) were deployed 
to the PI Application Server. Once reports reside on the PI Application Server, you have two 
ways to view them:

• PI client applications 

• Web browser

If the client applications are installed on your system, you have access to Report Viewer, 
Report Builder, and the Management Console. If the client applications are not installed on 
your system, using a web browser is the only way you can view reports.

For details about the clients applications, see the PI Installation Guide. For details about the 
Management Console, including the Object/Property Management view and how to launch 
reports and forms specific to a selected object, see the PI Administration Guide.

Changes to the Object Model

Installing the Internet Services Report Pack modifies the object model maintained by OVPI. 
The following objects are added to the customer view:

• Service

• OVIS Probe type

OVIS customers are viewable from the Management Console by doing the following:

Select Objects > View > Change View > Customers

You can view any report in the package by highlighting a customer and selecting one of the 
reports listed under Object Specific Reports. For example:

Customer XYZ > Object Specific Reports > Daily Probe Type Hot Spots

The report that opens will be constrained, containing data for customer XYZ only. You can 
launch summary or detail reports by selecting a specific probe type or service, as follows: 

XYZ > Probe Type N > Daily Probe Type Detail Report

Customer XYZ > Service N > Daily Service Summary Report

The report that opens will be constrained, containing data for N probe type, or N service, for 
customer XYZ only.
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Seeing Performance Data in Reports

If you are familiar with other PI reports, you know that Near Real Time reports are the first 
reports to populate with data. Since there are no NRT reports in this package, you will not see 
data right away. Processing occurs at night, so tomorrow is the soonest that data will appear 
in reports. 

In the days immediately following installation, you will see some data in daily reports, 30 day 
reports, and monthly reports, specifically: 

• In daily reports, totals and averages for each day for which you have data

• In the 30 day reports, aggregated data representing all the days for which you have data

• In the monthly reports, month-to-date aggregations in selection tables

If the data you collected includes data for any part of the previous calendar month, the graphs 
in monthly reports will be populated. If the data you collected has no data for the previous 
month, the graphs in monthly reports will be empty. These graphs will remain empty until 
you begin collecting data on the first day of the next month.

Forecast reports are generated from a rolling baseline. Although forecast reports will contain 
some data before the first rolling baseline (30 days) is complete, reliable forecasts will not be 
available until the first rolling baseline is complete.

Removing Internet Services

Follow the steps under Task 1 to uninstall Internet Services. Removing Internet Services will 
automatically remove the datapipe. Task 2 tells you how to remove an OVIS system defined as 
a Generic Supported Database. Removing the OVIS system is not mandatory; this step is 
recommended.

Task 1: Uninstalling the Internet Services Report Pack

1 Log in to the system. On Unix systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop

3 Start Package Manager. The Package Manager welcome window opens.

4 Click Next. The Package Location window opens.

5 Click Uninstall.

6 Click Next. The Report Undeployment window opens.

7 If Internet Services reports were deployed from this server, accept the defaults for 
Undeploy Reports, Application Server Name, and Port. If Internet Services reports were 
not deployed from this server, clear the check box and skip to step 9.

8 Type the username and password for the OVPI Application Server.

9 Click Next. The Package Selection window opens. 
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10 Click the check box next to the following package:

 Internet Services Report Pack 2.0

11 Click Next. The Selection Summary window opens. 

12 Click Uninstall. The Progress window opens and the removal process begins. When the 
uninstall process is complete, a package removal complete message appears. 

13 Click Done to return to the Management Console.

14 Restart OVPI Timer.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start

Task 2: Removing an OVIS system defined as a Generic Supported Database

1 Click the Systems icon on the left-hand side of the Management Console.

2 Select the local system. OVPI and generic databases appear in the main window.

3 Right-click the OVIS system and select Delete System...

4 Click Yes in the pop-up window. 

The OVIS system is now removed.
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4 Setting Up a Distributed System
These are the steps to follow when setting up a distributed system:

• Decide whether or not you want local reporting

• Install the right set of packages on each server (a central server that is not polling will not 
need datapipes; the satellite servers will need datapipes)

• Verify that the system clocks in your environment are synchronized

• Register your satellite servers

• If you are not copying rate data to the central server, enable LIR on the central server

• If you enable LIR, add LIR mapping with the time type set to rate

• Verify that you have all the copy policies you need

• Configure the central server (manual edits to trendtimer.sched and .pro files)

• Configure each satellite server (manual edits to trendtimer.sched and .pro files)

If you want to set up a distributed system, you can implement local reporting or you can 
implement centralized reporting. If you want local reporting, you need to deploy reports when 
you install the report pack on each satellite server, and you need to allow summarizations to 
run on each satellite server. If you do not want local reporting, then you do not need to deploy 
reports when you install a report pack on a satellite server and you can disable the scripts 
that run summarizations on each satellite server.

Before Location Independent Reporting (LIR) was available, our recommendation to anyone 
setting up a distributed system was to deploy reports on satellite servers, keep rate data on 
satellite servers, copy hourly data to the central server, and disable summarizations above the 
hourly level on satellite servers. The advantage to this approach was that it kept a large 
volume of rate data off the network and it decreased the processing load on the central server. 
The disadvantage is that the central server could not display a Near Real Time (NRT) report. 
The only NRT report was a local NRT report, on a satellite server. LIR overcomes this 
disadvantage. If you enable LIR, you can open an NRT report on the central server and 
drill-down on table selections. The selections you make cause the central server to query a 
satellite server for locally aggregated data. Of course, if you would rather copy rate data to the 
central server, you can. If you do that, then enabling LIR is not necessary.

Verifying Correct Package Installation

If you intend to run Internet Services as a distributed system, you must configure all of the 
servers in the system. Before doing that, verify that you have the right packages installed on 
each server. 

Packages on the Central Server

• Internet Services Report Pack; with reports deployed to the OVPI Application Server
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• Common Property Tables; with forms deployed to the OVPI Application Server

Typically, the central server does not poll. If you want the central server in your system to 
poll, install the Internet Services Datapipe on the central server. 

Packages on Each Satellite Server

• Internet Services Report Pack; reports deployed

• Common Property Tables; forms deployed

• Internet Services Report Pack Datapipe 1.2

If you need local reporting, that is, if you want to use the satellite server to see reports and 
forms, you must deploy reports to the PI Application Server when you install packages on a 
satellite server. If the central server is the only server you will use to view reports and forms, 
deploying reports is optional. 

Configuring the Central Server

To configure the central server, perform the following tasks:

• Task 1: Register the satellite server by setting the database role

• Task 2: If you are not copying rate data to the central server, enable LIR

• Task 3: If you are enabling LIR, add LIR mappings

• Task 4: Verify the automatically generated copy policies

• Task 5: Modify the Internet_Services_Hourly.pro file

• Task 6: Modify the Internet_Services_Daily.pro file

Task 1: Register the satellite server by setting the database role

1 Start the Management Console (log on with Administrator privileges).

2 Click the Systems icon in the navigation pane.

3 Navigate to the OVPI Databases folder and select the database system.

4 Click Database Properties.

5 From the Database Role list, select the Satellite Server role.

6 Enter any information necessary to configure the Satellite Server role.

Task 2: Enable LIR

1 Start the Management Console (log on with Administrator privileges).

2 Click the Systems icon in the navigation pane.

3 Navigate to the OVPI Databases folder and select the central server.

4 Click LIR Configuration.

5 Select the LIR enabled check box.

To add a new database reference, you can use the Add Database Reference Wizard in the 
System and Network Administration application.
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Task 3: Add LIR mappings

1 Start the Management Console (log on with Administrator privileges).

2 Click the Systems icon in the navigation pane.

3 Navigate to the OVPI Databases folder and select the central server.

4 Click LIR Configuration.

5 Click Add Mapping.

6 From the Select Satellite Server list, select a satellite server to which to add a mapping.

7 Select the Category data table option.

8 Select Internet Services from the drop down list.

9 Select the rate data type.

10 Click Add to List.

11 If you want to add additional LIR mappings, click Add to list and repeat step 6 through 
step 10.

12 Click OK.

13 Click Apply.

A copy policy is automatically generated for the hourly data and for each LIR mapping that 
you add. The data type selected when adding an LIR mapping (in step 9 above) determines 
the type of data copied (defined in the generated copy policy). The type of data copied (defined 
in the generated copy policy) is one summarization level greater than the data type selected in 
the LIR mapping. For example, if you select an hourly data type, you will generate a daily 
data copy policy.

Task 4: Verify the automatically generated copy policies

Verify that a copy policy has been generated for the SHOVIS table and that the copy type is 
set correctly (to Property and Data):

1 Start the Management Console (log on with Administrator privileges).

2 Click the Copy Policy icon in the navigation pane to start the Copy Policy Manager.

3 Find the SHOVIS table and verify the copy type is set to Property and Data.

If a copy policy has not been generated for a table, do the following:

1 Click the New Copy Policy icon or select File > New Copy Policy from the Copy Policy 
Manager. The Copy Policy Wizard displays.

2 Click Next. The Satellite Server and Copy Policy Selection Page displays.

3 Select a satellite server from the pull down list. This is the satellite server from which 
data is copied to the central server.

4 Select Single Table and select SHOVIS from the pull down list.

5 Click Next. The Copy Type Selection Page displays.

6 Select Property and Data.

7 Click Next. The Summary page displays.

8 Verify the information in the summary window. If the information is not correct, you can 
modify it by clicking Back.

9 Click Finish.
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If the copy type is not set to Property and Data, do the following:

1 Double-click the copy policy.

2 Select the Property and Data copy type.

3 Click OK.

Task 5: Modify the Internet_Services_Hourly.pro file

The Internet_Services_Hourly.pro file is found in the {DPIPE_HOME}/scripts/ 
directory where {DPIPE_HOME} is the directory in which OVPI is installed.

Make the following change:

• Find and uncomment the following lines:

begin:block1 wait 
end:block1

Task 6: Modify the Internet_Services_Daily.pro file

The Internet_Services_Daily.pro file is found in the {DPIPE_HOME}/scripts/ 
directory where {DPIPE_HOME} is the directory in which OVPI is installed.

Make the following changes:

• Find and comment out the following lines:

begin:block1 wait 
end:Source:SHOVIS

Configuring Satellite Servers

Follow these steps to configure each satellite server.

1 Modify the trendtimer.sched file (found in the {DPIPE_HOME}/lib/ directory where 
{DPIPE_HOME} is the directory in which OVPI is installed). Do the following:

• Find and change the following line (modify the daily processing time):

1:00+30 - - {DPIPE_HOME}/bin/trend_proc -f  
{DPIPE_HOME}/scripts/Internet_Services_Hourly.pro

to

1:00+20 - - {DPIPE_HOME}/bin/trend_proc -f  
{DPIPE_HOME}/scripts/Internet_Services_Hourly.pro

• Find and comment out the following line:

24:00+3:00 - - {DPIPE_HOME}/bin/trend_proc -f  
{DPIPE_HOME}/scripts/Internet_Services_Daily.pro

2 Modify the Internet_Services_Hourly.pro file (found in the {DPIPE_HOME}/
scripts/ directory where {DPIPE_HOME} is the directory in which OVPI is installed).

Uncomment the block2 block (uncomment the begin:block2 wait and end:block2 
lines).
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Synchronizing System Clocks

Make sure that the system clock on each satellite server is synchronized with the system clock 
on the central server.
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5 Hot Spots
The Hot Spots reports make it easy for you to find out which probe types and services are 
experiencing the worst performance. Each report pinpoints the 10 probe types or 10 services 
that are reporting the highest service level violations, lowest availability, highest response 
time, and lowest throughput.

The Hot Spots folder contains three probe type reports and three service reports:

• 30 Day Probe Type Hot Spots

• Daily Probe Type Hot Spots

• Monthly Probe Type Hot Spots

• 30 Day Services Hot Spots

• Daily Services Hot Spots

• Monthly Services Hot Spots

If you want to watch for problem areas as they arise, use the daily reports. As soon as you spot 
a problem area, you can investigate further by using the summary and detail reports in the 
other folders.

The monthly reports show:

• Month-to-date totals for the current month

• Month-to-date averages for the current month

• Monthly totals for previous months

• Monthly averages for previous months

Use these reports to compare actual performance to monthly Service Level Agreements.

The 30 Day reports provide an aggregated view of recent performance. These reports smooth 
out daily anomalies, while crossing the boundary between two months.

See below for samples of these reports:

• 30 Day Probe Type Hot Spots

• 30 Day Services Hot Spots
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6 Summary Reports
The reports in the summary folder provide statistics at the service and probe type level. The 
summary folder contains the following reports:

• 30 Day Probe Type Summary

• Daily Probe Type Summary

• Monthly Probe Type Summary

• 30 Day Service Summary

• Daily Service Summary

• Monthly Service Summary 

Summary reports provide a historical context for hot spots reports. For example, if a report in 
the Hot Spots folder has just alerted you to a problem, you can use the corresponding 
summary report to find out whether you are dealing with an unusual situation that could not 
have been predicted or a trend that has been steadily worsening over time. 

In a summary report, you drill down from a customer to a list of services or probe types 
associated with the customer. For each probe type or service, you have the following 
aggregated statistics:

• Service level violations

• Availability

• Response time

• Throughput

The figures in the probe type/service selection table aggregate data for every probe type/target 
associated with each probe type or service. Beneath the probe type/service table are graphs for 
service violations, availability, response time, and throughput. Use these graphs to see what 
the trend has been like for the past 30 days and the past 12 months.

See below for two sample reports, the Daily Probe Type Summary and the Daily Service 
Summary. 
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7 Detail Reports 
The reports in the detail folder allow you to find out which OVIS tests are experiencing 
problems and whether or not the problem is typical or unusual compared to past performance. 
The detail folder contains the following probe type and service reports:

• 30 Day Probe Type Detail 

• Daily Probe Type Detail

• Monthly Probe Type Detail

• 30 Day Service Detail

• Daily Service Detail

• Monthly Service Detail

All detail reports begin with a list of customers. Select a customer to display a list of services/
probe types, sorted by violations highest to lowest, with data for the following statistics 
aggregated over all OVIS tests:

• Service level violations

• Availability

• Response time

• Throughput

By selecting a particular service or probe type, you can display:

• The associated probe system/target combinations, sorted by violations highest to lowest

• Performance data for each combination

The graphs below the second table are linked to the item selected in the second table. These 
graphs provide test-level trending analysis, allowing you see whether violations, availability, 
response time, and throughput are improving or getting worse.

See below for samples of all six reports in the detail folder.

All OVIS tests calculate response time, but not all OVIS tests calculate 
throughput. If Null appears in a table or graph showing throughput, none of 
the OVIS tests that target this particular service calculates throughput. 
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8 Forecast Reports
The two reports in the forecast folder identify the services and probe types that are expected 
to see their performance deteriorating at the fastest rates in the weeks and months ahead. 
Use the forecast reports to spot:

• Probe types/services with the greatest rate of increase in service level violations

• Probe types/services with the greatest rate of increase in response time

• Probe types/services with the greatest rate of decrease in throughput

Forecast reports contain tables and charts. The tables perform the following functions:

• Calculate the 90-day forecast

• Calculate the baseline average

• Sort items by the rate of growth

The graphs perform the following functions:

• Display 30-day, 60-day, and 90-day forecasts (forecast tab)

• Compare the baseline average to 30/60/90 forecasts (forecast tab)

• Show the data in the baseline that was used to generate the forecast (history tab)

See below for samples of the Probe Type Forecast and the Services Forecast.
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A View Options for Tables and Graphs
Any table or graph can be viewed in several ways. While the default view is usually adequate, 
you can easily change to a different view. If you are using Report Viewer, right-click the object 
to open a list of view options. If you are using the Web Access Server, follow these steps to 
change the default view of a table or graph:

1 Click Preferences on the links bar.

2 Expand Reports in the navigation frame.

3 Click Viewing.

4 Select the Allow element editing box.

5 Click Apply.

6 Click the Edit icon next to the table or graph. 

Options for Tables

Right-clicking a table, or selecting the Edit Table icon if you are using the Web Access Server, 
opens a list of table view options.

Select Set Time Period to alter the relative time period (relative to now) or set an absolute time 
period. The Set Time Period window opens.

You may shorten the period of time covered by the table from, for example, 42 days to 30 days 
or to 7 days. If you are interested in a specific period of time that starts in the past and stops 
before yesterday, click Use Absolute Time and select a Start Time and an End Time.

Select Change Constraint Values to loosen or tighten a constraint, thereby raising or lowering 
the number of elements that conform to the constraint. The Change Constraint Values 
window opens. To loosen a constraint, set the value lower; to tighten a constraint, set the 
value higher.

The Select Nodes/Interfaces allows you to change the scope of the table by limiting the table to 
specific nodes, specific interfaces, or a specific group of nodes or interfaces. The Select Node 
Selection Type window opens.
 65



Change Max Rows increases or decreases the number of rows in a table. The default is 50. If 
you expand the default, the table may take more time to open. If you are trending a large 
network, using the default ensures that the table opens as quickly as possible. 
View in new Frame opens the table in a Table Viewer window, shown below. If necessary, make 
the data in the table more legible by resizing the window. 

Options for Graphs

Right-clicking a graph, or clicking the Edit Graph icon if you are using the Web Access Server, 
opens the following list of view options. 
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The following table provides details about each option.

Style Options

Select Style to display a list of seven view options for graphs.

Option Function

Set Time Period Same as the table option shown above.

Change Constraint Values Same as the table option shown above.

Select Nodes/Interfaces Same as the table option shown above.

Displayed Data For every point on a graph, display data in a 
spreadsheet.

Grid Add these to the graph:
X axis grid lines
Y axis grid lines
X and Y axis grid lines

Legend Delete or reposition the legend. 

Style See the illustrations below.

Change Max Rows... Same as the table option shown above.

Display Data Table See below.

Export Element as CSV... Same as the table option shown above.

View in New Frame Opens graph in a Graph Viewer window.

Print Graph Same as the table option shown above.
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Style > Area

The plot or bar chart changes to an area graph. While relative values and total values are 
easy to view in this format, absolute values for smaller data types may be hard to see. Click 
anywhere within a band of color to display the exact value for that location 

To shorten the time span of a graph, press SHIFT+ALT and use the left mouse button to 
highlight the time span you want to focus on. Release the mouse button to display the selected 
time span.

Style > Stacking Area

The area or plot graph changes to a stacking area graph. This view is suitable for displaying a 
small number of variables.
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Style > Bar

The graph changes to a bar chart. This view is suitable for displaying relatively equal values 
for a small number of variables. There are three variables in the graph below.

Style > Stacking Bar

The plot or area graph changes to a stacking bar chart. If you increase the width of the frame, 
the time scale becomes hourly. If you increase the height of the frame, the call volume shows 
in units of ten.
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Style > Plot

Bands of color in an area graph change to lines. If you adjust the frame width, you can make 
the data points align with hour; if you adjust the frame height, you can turn call volume into 
whole numbers.

Style > Pie

An area graph becomes a pie chart. Bands in an area graph convert to slices of a pie and the 
pie constitutes a 24-hour period. This view is helpful when a small number of data values are 
represented and you are looking at data for one day.

If you are looking at data for multiple days, you will see multiple pie graphs, one per day.
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Display Data Table

This option changes a graph into a spreadsheet. 

View in New Frame

The graph opens in a Graph Viewer window. Improve legibility by resizing the window. 
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