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Processing Packages (Change Management)
 Chapter

Introduction

Mercury Change Management automates the migrations and deployment of 
software code, configurations, and content. These objects are grouped into 
Packages and are routed along business processes modeled in Mercury’s 
configurable Workflow. Mercury’s Workflow automates the process of 
moving each Package through required steps, which typically involve system 
build, testing, quality assurance, staging, and final deployment. Mercury 
Change Management automatically deploys the application components 
necessary for each Package, such as XML content, HTML files, Java 
programs, Oracle Application configurations, PeopleSoft panels or Siebel 
projects.

For example, Mercury Change Management will connect to the development 
environment, copy Java files from the version control repository and transfer 
the files to the quality assurance environment. It will then use the Java 
compiler to compile and link all the files into a single Java program. A built-in 
scheduler allows the customer to schedule deployments. Mercury Change 
Management maintains an audit trail for all activities including Package 
information, application components altered, approvals obtained and 
deployments performed. 

About This Document
This guide describes how to navigate and use Change Management . Each 
chapter covers a specific topic on navigation or usage:

Key Concepts and 
Definitions

Defines the key concepts and definitions related to 
using Mercury Change Management to deploy software 
and application changes.
Introduction 1
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Intended Audience
The intended audience for this document include:

• Users of Change Management 

• Managers who create and manage Packages 

• Business users responsible for reporting on Packages 

Document Conventions
Table 1-1 lists the types of conventions used in this document.

Accessing Change 
Management

Provides instructions for logging onto Mercury Change 
Management. 

Creating New 
Packages

Provides instructions for creating and submitting 
Packages to deploy software and application changes. 

Processing Packages Provides instructions for viewing and processing 
Packages. This includes information on locating 
Packages, acting on eligible steps and viewing key 
Package information and statuses. 

Change Management 
Reports

Describes the procedures used to submit and view 
reports. 

Table 1-1. Document conventions

Convention Description Example

Button, menu, tabs Names of interface components that can be 
clicked (such as buttons, menus, and tabs) 
are shown in bold.

Apply button

Fields, Windows, Pages Names of windows, fields, and pages are 
shown as displayed.

New Request window

Code Code input and output are shown as 
displayed.

CauchoConfigFile 
C:/ITG_Home/conf/
resin.conf
2 Introduction
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Additional Resources
Mercury Interactive provides the following additional resources to help you 
successfully use Mercury IT Governance Center:

• Related Documentation

• Customer Support

• Education Services

Related Documentation
The Library includes additional documents related to the topics discussed in 
this guide. Access the Library through the Mercury ITG Center online help.

Link Linked URLs, filenames, and cross references 
are shown as blue italicized text.

www.mercury.com

Variable Variables are shown as italicized text. ITG_Home/bin directory

Note Used to identify note boxes that contain 
additional information.

Caution Used to identify caution boxes that contain 
important information. Follow the instructions 
in all caution boxes, failure to do so may result 
in loss of data.

Example Used to identify example boxes that contain 
examples of related procedure.

Table 1-1. Document conventions

Convention Description Example

Using the Dashboard This document provides details for defining and 
configuring the Mercury ITG Dashboard and 
custom Portlets.
Introduction 3
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Customer Support
Customer support and downloads for the Mercury ITG Center and additional 
product information can be accessed from the Mercury Interactive Support 
Web site at http://support.mercuryinteractive.com.

Education Services
Mercury Interactive provides a complete training curriculum to help you 
achieve optimal results using the Mercury IT Governance Center. For more 
information, visit the Education Services Web site at http://www.merc-
training.com/main/ITG.

Processing Requests (Demand 
Management)

This document explains how to process Requests 
using Demand Management.

Managing Your Projects (Project 
Management)

This document explains how to work with Projects 
using Project Management.

Using the Workbench This document explains how to navigate through 
the Workbench interface.

Commands and Tokens Guide 
and Reference

This document provides information on using 
Commands and Tokens.

Security Model Guide and 
Reference

This document presents an overview of the data 
security model and provides instructions for 
controlling access to different entities.

Configuring a Deployment 
System (Change Management)

This document provides instructions for 
configuring a deployment system. This includes 
requirements gathering, modeling your processes 
in a Workflow, defining commands used by the 
execution engine, and rolling out this system to 
your users.

Configuring a Release 
Management System

This document provides details for configuring, 
defining and processing Releases in Mercury 
Change Management.

Reports Guide and Reference This document provides details for running 
Reports.

Open Interface Guide and 
Reference

This document provides details for integrating 
non-Mercury ITG products with Mercury ITG 
entities.
4 Introduction
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 Chapter

Key Concepts and Definitions

This chapter defines the key concepts and definitions related to using Mercury 
Change Management to deploy software and application changes. 

This chapter covers the following topics:

• Software Deployment

• Packages

• Workflows

• Environments

• Workflow Steps

• Results

• Object Types

• Dashboard

• Portlets

• References

• Participant 

• Displaying Mercury Change Management Data

• Integration with Version Control

• Integration with Mercury IT Governance Products
Key Concepts and Definitions 5
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Software Deployment
The various objects of a Package are automatically deployed by the Mercury 
Change Management built-in Java Execution Engine. Based on the Object 
Type, the execution engine performs the tasks required to install the objects 
correctly. For example, the execution engine will log into the Development 
environment with a username and encrypted password, checkout a C Program 
from your version control repository, and transfer the file to the QA 
environment. It will then use the C compiler to compile and link the program. 
Additionally, using the built-in scheduler, you can schedule the deployments to 
suit your business needs. For example, you can schedule deployments for late 
at night or during a weekend when system load is minimal.

Packages
Mercury Change Management is an enterprise application designed to deploy 
and audit software changes to mission critical applications. It does this by 
gathering all information required for a successful deployment (such as 
information on Environments and Objects to be migrated) into a single logical 
unit called the Package. The Package, consisting of the migrating Objects, is 
then processed through a business Workflow. This results in a successful, 
easy-to-track software change. 

A Package consists of Objects, each of which is on a separate Package Line. 
While each line can be acted upon separately, the group of Package Lines and 
Objects represent a logical unit that should be moved and tracked together. The 
processing of a Package and Package Lines can vary greatly depending upon 
the Workflow specified for that Package. Figure 2-1 shows a sample Package.

A Package:

• Is the fundamental work unit of Mercury Change Management.

• Represents a logical unit of Objects that should be moved and tracked 
together.

• Contains all the information needed to process the Package, including the 
Package Lines, priority, and status.

• Specifies the Workflow to be used to deploy the change.

• Contains a list of all Objects to be tracked and/or migrated as the Package 
moves through its Workflow.
6 Key Concepts and Definitions
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Figure 2-1 Sample Package

Workflows
A Workflow consists of a logical series of steps that define the path followed 
by Objects in a Package. Workflow configuration and routing is a 
customizable feature of Mercury Change Management and the Workflow 
engine can handle virtually any business practice. This allows a department to 
generate Workflows to automate existing processes, rather than forcing users 
to adopt a new set of processes to perform their work.

Workflow Steps can range in usage from functional approvals to actual 
migrations. For example, migration steps automatically move specified 
Objects from source Environments to destination Environments.

A sample Workflow is shown in Figure 2-2:
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Figure 2-2 Package Workflow

Environments
A Mercury Change Management Environment is composed of a unique 
combination of server, client, database, and file system data that represents one 
logical group. For example, the ‘DEV’ Environment signifies the machines 
and database that represent the Development instance in the enterprise. One 
particular machine may be referenced by more than one Environment. For 
example, two Environments might have databases on the same UNIX machine. 
One Environment could be used for Development and the other Environment 
could be used for Quality Control.

The Environment server represents the main host machine for the 
Environment. This machine may be of any platform type: UNIX, WindowsNT, 
etc. Typically, the server is a UNIX machine that also houses the database for 
this Environment.

The terms server and client are defined very specifically for Mercury Change 
Management.
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The Environment client represents a remote client machine that also serves to 
identify the specified Environment. The client is typically defined when users 
are doing multi-platform development in a client/server Environment (with 
some development done on UNIX, and some on Windows NT). The client can 
correspond to a file server that stores client code accessed by users. Many 
programs, such as transactional forms, have both client and server components 
(the user interface code and the database Objects, respectively). A sample 
Environment is shown in Figure 2-3.

Figure 2-3 Sample Environment

Workflow Steps
Workflow Steps are events that are linked together to form a complete 
Workflow. Mercury Change Management uses three types of Workflow Steps: 
Decisions, Executions, and Conditions. 

• Decisions are steps where a user or group of users need to indicate the result 
or outcome, such as an approval of work or an indication that a review has 
been completed. ‘Approve Migration’ is an example of a Decision step. 
Key Concepts and Definitions 9
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• Executions are steps where the system performs an action and then updates 
the step with its result. These actions can be as simple as calculating the 
value for a Token or as complex as copying files, running programs, or 
updating Web pages. 

• Conditions are logic steps used for complex Workflow processing, such as 
allowing a Workflow to proceed only after all of the prerequisite steps are 
completed.

• Workflows are entire Workflows that have been enabled for use as 
Subworkflows. When modeling business processes that include predefined 
procedures, Subworkflows are a useful time saver.

The Workflow Step Sources window is shown in Figure 2-4.

Figure 2-4 Workflow Step Sources Window

Results
A single step can have multiple valid results which manage the Workflow. For 
example, the ‘Approve Migration’ step can have two results: Approved or Not 
Approved. Depending on the Workflow configuration, these results route the 
Objects differently through the Workflow. Results are user-defined.
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Object Types
The Object Types Workbench allows users to define the different types of 
entities they want to control and migrate. Every Object Type has a unique set 
of parameters that determines the information it requires, as well as any 
additional information it may accept. Each Object Type can also have 
associated Commands which determines its behavior as it moves from one 
Environment to another. Commands are used to define what a migration means 
for each type of Object. For example, a File Object Type might only require the 
copying of a file while a Database Script Object Type might require both 
copying of a file as well as executing it against the destination database.

Object Types are user-configurable. Mercury Change Management and its 
Extensions also provide libraries of pre-defined Object Types, falling under 
one of the following categories:

• Standard Objects

• Custom Objects

• Mercury IT Governance Migrator Objects

Standard Objects
Standard Objects are predefined Object Types that are shipped with Mercury 
Change Management or one of the Change Management Extensions. These 
Object Types encapsulate the basic functionality that manages crucial Change 
Management actions such as migrating and executing file-system level objects 
and operating-system commands, or applying patches to an Oracle 
Applications instance. A simple standard Object Type is the File Migration 
object, which copies a file from one Environment to another. A more complex 
standard Object Type is the SQL Script, which not only copies the file but also 
executes the script against the destination database.

As shown in Figure 2-2, once the status of the ‘Design Review’ step becomes 
Approved, the status of the “Evaluate” step becomes eligible. If, however, the 
status becomes No, the ‘Exit - Close (failure)’ step becomes eligible.
Key Concepts and Definitions 11
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Custom Objects
Customers will often need to customize standard Object Types, or produce 
entirely new Object Types, in order to handle the requirements of their 
software environments and change management processes. A Custom Objects 
category is provided to help distinguish these customized Object Types from 
those that come standard with Mercury Change Management or its Extensions. 
Such Object Types may have been designed by the customer or by consultants, 
and are often used for integration with specific third-party tools or in-house 
products.

Mercury IT Governance Migrator Objects
Mercury ITG Migrator Objects are Object Types that contain functionality to 
export and import configuration information. These may be used for several 
purposes: to transfer configuration information between distinct Mercury ITG 
instances/installations, to extract information from a Mercury ITG database 
schema into an XML file, or to load information from an XML file into a 
database schema. This means that you can migrate configuration information 
using standard Change Management test practices—processing a Package 
through a Workflow.

A sample Object Type is shown in Figure 2-5.

Figure 2-5 Sample Object Type
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Dashboard
The Mercury ITG Dashboard consists of a set of configurable, role-based 
visual displays called Portlets that provide relevant summary information. 
Users can drill down to any desired level of detail. The Dashboard displays the 
true status of the initiatives, based on current data captured automatically when 
the work is performed.

The Dashboard is designed for use by participants throughout the Technology 
Chain. For example, developers can use the Dashboard to view all their own 
action items, and end-users can consult their own Dashboards to see the status 
of all the Requests they have submitted. Tabs in the Dashboard interface allow 
users to group Portlets according to their own needs. To save time in 
configuration, your application administrator can define a default Dashboard 
layout for all users.

A sample Dashboard configuration is shown in Figure 2-6.

Figure 2-6 Sample Dashboard Configuration 

Portlets
Portlets are configurable, role-based visual displays that provide relevant 
summary information of your business data. Each user can select which 
Portlets they would like to display on their Dashboard. They can then 
Key Concepts and Definitions 13
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personalize those Portlets to display only the information that is relevant to 
their Projects, Tasks, Packages or Requests. 

In addition to providing relevant information for higher visibility, Portlets also 
provide the user with the ability to drill down into the details of the Project, 
Task, Request or Package. This enables the user to access and update 
information from a single Web page. 

Mercury IT Governance Center features a set of Portlets for each product. 
These Portlets are designed to provide the most efficient and flexible access to 
your business data. It is also possible for advanced users to create custom 
Portlets for further adaptability.
 

A sample Portlet is shown in Figure 2-7.

Figure 2-7 Sample Portlet 

References
In addition to header and detailed field information, Packages can have 
references to other entities or points of information that allow for easy access 
and visibility to related data. Summary information for References is viewed as 
part of the Package. Each reference can be viewed in detail with a simple click 
of the mouse. There are several reference types defined in Mercury Change 
Management: Attachment, Package, Project, Release, Request, Task, and URL. 
Sample References are shown in Figure 2-8.

You can only add Portlets to your Dashboard which are associated with the 
Mercury ITG products licensed at your site. For a full list of the available 
Portlets, see Using the Dashboard.
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Figure 2-8 Package References

Package
You can add a reference to a Package to relate to other Packages. References to 
the Package(s) are automatically generated, establishing a two-way tie between 
the referenced Package(s) and the original.

In addition to referencing existing Packages, you can also create a new 
Package to be referenced from the References tab. You can then specify a 
relationship (informational or dependent) between the Package and the new 
reference. 

Request
You can add a reference to a Package to relate to Requests. In addition to 
referencing existing Requests, you can also create a new Request to be 
referenced from the References tab. You can then specify a relationship 
(informational or dependent) between the Package and the new reference. 

For Packages that were spawned from a Request Workflow step, reference to 
the Request is automatically generated, establishing a two-way tie between the 
spawned Package and the Request.
Key Concepts and Definitions 15
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Release
You can reference a Package to a given Release. For Packages already 
associated with a given Release, reference to the Release is automatically 
generated, establishing a two-way tie between the Package and the Release.

Attachment
You can attach a file from your local machine to the current Package. The 
attached file is copied to the server and can then accessed by other Mercury 
Change Management users. This feature is particularly helpful when you need 
to reference a document that is not already Web-accessible.

Document URL
You can reference an unlimited number of document URLs to a given 
Package. Document URLs need to be Web-accessible and are attached by 
simply entering the Web address of the document. Once attached, the 
document URLs can be opened by selecting the Reference.

Task
You can attach the current Package to a Task in a Mercury Project 
Management Project. The Task is then associated with this Package. Using 
Mercury Project Management, you can then set dependencies between the 
Package and the Task.

Project
You can attach the current Package to a Mercury Project Management Project. 
The Project is then associated with this Package.

Participant
Users who are involved in moving a Package through a Workflow are 
considered to be ‘Participants’ in that Package. A Participant can be:

• The ‘Assigned To’ user

• A member of the assigned group

• The creator of the Package
16 Key Concepts and Definitions
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• A member of a Security Group associated with any of the Workflow Steps 
contained in the Workflow. 

Depending on the settings configured by the application administrator, a 
Package may not be visible to users who are not Participants in its Workflow. 
This means users will only see Packages relevant to their business role in their 
organization. Additionally, users running Reports will only see information for 
Packages for which they are considered to be Participants.

Displaying Mercury Change Management Data
As more of business processes and solutions are modeled using Mercury 
Change Management, the data in the system will grow. For example, Change 
Management may be used to automate 200 different processes—thus 
potentially introducing 200 Workflows. Sifting through 200 entries in an auto-
complete list or 200 search results could be cumbersome.

Mercury Change Management can be configured to display only information 
that is most relevant to your business role. Depending on this configuration and 
the Access Grants you have been given by your application administrator, 
some data will not display when, for instance, you click on an auto-complete 
list or perform a search for a particular entity.

For more information on Access Grants and restricting Mercury ITG data, 
refer to Security Model Guide and Reference.

A Project Manager and a Software Developer will each have different Access 
Grants. Each sees different sets of Workflows when clicking on auto-
complete lists or running searches, with each set suited to their particular 
business role.
Key Concepts and Definitions 17
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Integration with Version Control
Mercury Change Management provides complete integration with all standard 
version-control systems including RCS, SCCS, PVCS, ClearCase, 
CCC/Harvest, and Visual SourceSafe. The Change Management outbound 
API provides all check-in, check-out, and promotion functions during 
deployment.

File system objects can be deployed to new installations and updated in version 
control simultaneously. This synchronizes your version-control repository, 
physical installations, and Change Management Workflows.

Integration with Mercury IT Governance Products
Mercury Change Management can be integrated with other products within the 
Mercury IT Governance Center. 

This section covers the following topics:

• Integration with Mercury Demand Management

• Integration with the Mercury IT Governance Dashboard

• Integration with Third Party Applications through Change Management 
Extensions

Integration with Mercury Demand Management
Mercury Change Management serves as a system to manage the physical 
deployment of changes to your applications environment, but of equal 
importance is the gathering and analysis of issues (Requests) related to the 
stability of the system. To facilitate this Request gathering, Change 
Management is integrated with Demand Management. Like Change 
Management, Demand Management is a Workflow based system that features 
complete audit trail tracking of Requests from inception to close. Demand 
Management can also be configured to automatically generate Packages in 
Change Management. The tight integration between Demand Management and 
Change Management allows Packages to be automatically generated from 
Requests. The Requests are then automatically updated upon completion of the 
Package. This closed-loop integration ensures a coherent and consistent view 
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of your issue statuses and removes the need for redundant data across multiple 
applications.

Integration with the Mercury IT Governance Dashboard
Mercury Change Management provides an additional level of efficiency when 
used in conjunction with the Dashboard. The Dashboard is a highly 
configurable, high-level application that offers greater visibility and control 
over your business processes. As a complement to the HTML Interface, the 
Dashboard seamlessly integrates with all Mercury ITG products in a way that 
allows for delivery of real-time status and exception information on IT 
initiatives and operational tasks.

Integration with Third Party Applications through Change 
Management Extensions

Mercury Change Management Extensions are application-specific modules 
which automate the deployment and post-deployment steps of objects, files, 
and patches. Extensions are fully integrated with the Mercury Change 
Management to provide a total solution for managing various enterprise 
applications. The following Extensions are currently available:

• Extension for Databases

• Extension for Oracle E-Business Suite 

• Extension for Oracle Technology

• Extension for eCommerce Technologies

• Extension for SAP® Solutions 

• Extension for PeopleSoft Enterprise

• Extension for Siebel eBusiness Applications
Key Concepts and Definitions 19
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 Chapter

Accessing Change Management

This chapter provides instructions for logging onto Mercury Change 
Management. 

Change Management features two interfaces: the standard interface and the 
Workbench. The standard interface uses HTML and Javascript to provide users 
with access to many key areas of functionality, such as approving Packages 
and running reports.

The Workbench is a Java applet designed to help administrators, product 
configuration experts, and power users perform advanced configuring and 
processing tasks, such as creating Packages, Object Types and Workflows. 

Mercury Change Management users will interact mostly with the Workbench. 
The following sections provide instructions for logging onto Change 
Management and launching the Workbench:

• Logging on to Mercury Change Management

• Launching the Workbench

• Downloading Workbench Files

Logging on to Mercury Change Management
Mercury Change Management is accessed using a Web browser over a 
network. Mercury Change Management is a Java based, Web-enabled software 
system. The software can be executed using certain Java-enabled Web 
browsers, such as Netscape Communicator 7.02+, or Microsoft Internet 
Explorer 5.0+. 
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To access Change Management:

1. Contact your Administrator or Webmaster to obtain the URL where 
Mercury Change Management is installed.

2. Enter the information in the Location or Address field of your Web browser.

The Logon page opens.

3. Enter your Username and Password in the corresponding fields in the Logon 
page. 

Contact your Administrator to obtain your passwords and permissions.

To allow Change Management to retain your password information, click 
the Remember my logon check box. After clicking this check box, you will 
not be required to enter your password again until your session times out.

4. Click Submit.

If you enter an incorrect password, you will be prompted to correct it. Re-
enter the logon information and click Submit.

Mercury Change Management opens. 
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Changing Your Password
After logging onto Mercury Change Management, you may wish to change 
your password.

To change your password:

1. From the menu bar, select Settings -> Edit My Profile.

2. In the Old Password field, enter your old password.

3. In both the New Password and Repeat New Password fields, enter your new 
password 

4. Click Done.

You will receive an error message if:

• You did not enter your old password correctly.

The initial page may appear differently at your site, depending on your 
system data and default configuration. The various Portlets might not contain 
information until you personalize them. 
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• The New Password and Repeat New Password fields do not contain the same 
exact entry.

• The new password you entered is identical to your old password.

If you do not receive an error message, your password has been accepted by 
the system.

Launching the Workbench
The Workbench is accessed from the Mercury ITG menu bar. Users with a 
Power license can launch the Workbench by clicking the Administration > 
Open Workbench menu item. 

If you have installed a pop-up blocker in your web browser, the Workbench 
will not open.
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Downloading Workbench Files
The first time you access the Workbench across a network, the entire 
application will need to be downloaded onto your computer. Make sure to 
follow all instructions given by the browser and logon screen during this 
download process.

Subsequently, the program will only download if there is a new version on the 
server. For this reason it is recommended that the first time you run the 
Workbench on a computer, you do so across a network with bandwidth of at 
least 56 kbps.

The first time a user accesses the Workbench after an installation or an 
upgrade, the necessary files are downloaded onto the client’s computer. This 
means that following an installation or upgrade, the Workbench will take 
slightly longer to launch than it would under normal operating conditions.

Launching the Workbench will open a small browser window that will indicate 
the current state of the Workbench. It will display any download or installation 
activities and will indicate when the Workbench has become active. This 
window must remain open for the duration of your Workbench session. 
Closing this window will close the Workbench window.
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 Chapter

Creating New Packages

This chapter provides instructions for creating and submitting Packages to 
deploy software and application changes. Packages are created using the 
Workbench. 

This chapter covers the following topics:

• Creating New Packages

• Submitting a Package

Creating New Packages
Packages are used to deploy software and application changes. This section 
covers the following topics related to defining the contents of a Package, 
including adding Package Lines and specifying the appropriate deployment 
Workflow:

• Defining a Package

• Adding Multiple Package Lines Simultaneously

• Adding a Reference

• Copying an Existing Package

• Merging Packages

• Generating a New Package Group

• Editing a Package Group

• Selecting a Workflow for a Package

• Submitting a Package
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Defining a Package
For each instance of a software migration submission, a new Package needs to 
be created. 

To define a new Package:

1. Open the Workbench.

2. Click Change Mgmt in the shortcut bar and click the Packages icon. 

The Package Workbench opens.

3. Click New Package on the Package Workbench or select File -> New Package 
from the menu. 

The Package window opens.
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4. Enter a description in the Description field, select a Workflow, and enter any 
additional information that you would like to capture in the Package fields.

After entering information in the Package fields, add one or more Package 
Lines to the Package. Package Lines capture information specifically 
related to each object that you are migrating/tracking as the Package 
proceeds through the Workflow.

5. Click New Line to add a Package Line. 

The Add Line window opens. The fields on this window let you enter Object 
Type specific information.

6. From the Object Type field, select the Object Type for the item that you 
would like to migrate.

If you don’t know which Object Type you would like to use or you would 
like to view all of the possible choices, you can search for an Object Type. 
To search for and select an Object Type:

a. Click the auto-complete icon to open the Object Type Validate window. 
You can also type a full or partial name in the Object Type text field, 
before clicking the auto-complete icon, to find the Object Type you 
want to select.
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b. Select the appropriate Object Type from the list and click OK. The 
Validation window closes and the Parameters tab in the Add Line window 
is dynamically updated and displays information fields corresponding 
to the selected Object Type.

7. Fill in the fields on the Parameters tab.
30 Creating New Packages



Processing Packages (Change Management)
If the User Data tab is enabled, fill in the fields for that tab as well. Only the 
fields displayed in red are required, but you are encouraged to fill out the 
tabs as completely as possible.

8. Click OK to put the current Package Line into the Package and close the 
Add Line window. Click Add to put the current Package Line into the 
Package and clear the screen to add additional Object Types in the Add Line 
window.

9. Click the Notes tab and enter any additional information that would be 
useful for the Package. This field is not required, but it can be used to 
produce more robust reports and increase Package tracking information 
and accountability.

10. If User Data has been defined, the User Data tab is enabled. Click the User 
Data tab and fill in the appropriate fields.

11. To save the Package information without submitting it to the Workflow, 
click Save.

12. Click Submit to submit the Package to the Workflow. 

Submitting the Package to the Workflow generates entries under the Status 
tab for each of the Workflow Steps defined for the Workflow. As each step 
in the Workflow is ready to be processed, the step shows an Eligible status. 
You can view the progress of each Package Line by clicking the Status tab.
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13. Click OK to close the Package window.

Adding Multiple Package Lines Simultaneously
In some instances, you can add multiple Package Lines from a single Add Line 
window. Multiple Package Lines can be added with different parameters for a 
given Workflow and Object Type. You can add multiple Package Lines 
simultaneously when the following conditions exist:

• Package Lines all follow the same Workflow and use the same Object 
Type.

• The Object Type Parameters include at least one auto-complete list field 
with an enabled Multi button.

The following example illustrates how to add multiple Package Lines 
simultaneously. The user is creating a new Package using a Workflow named 
Dev -> Test -> Prod.

1. In the Package window (in the Workbench), click New Line. The Add Line 
window opens.
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2. Select File Migration (Web) from the Object Type field. The Object Type 
specific parameters are dynamically displayed. 

3. Click the File Name auto-complete list. The following Validate window 
opens.

The File Migration (Web) Object Type was constructed for this example. You 
can select any Object Type with an enable multi auto-complete list 
parameter.
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4. Double-click or select all desired entities and click the right arrow to move 
them to the right hand selection box.

5. Click OK to accept your multiple selections and close the window. 

Notice that the items that you selected in the Validate window are listed in 
the File Name field and separated by commas.
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6. Click Add.

A new Package Line is created for each parameter you specified in the Validate 
window. These lines are then processed through the selected Workflow.
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Adding a Reference
You can add a reference to a Package from the Workbench or the standard 
interface. There are several reference types defined in Mercury Change 
Management: Attachment, Package, Project, Release, Request, Task, and URL. 
For some reference types, such as for Requests and other Packages, you can 
create a functional dependency to the reference. For example, you can specify 
that a Request is a “Predecessor” to the Package. This means that the Package 
will not continue until the Request closes.

To add a Reference to a new or existing Package from the Workbench:

1. Within the Package window, click the References tab. 

2. Select the type of reference to be generated from the New Reference drop 
down list and click Add. 

You can only select Multi for objects that use an auto-complete or file 
chooser window to select the object name. All other parameters for that 
object are assumed to be identical.
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The following sections provide instructions for referencing different entities 
from the Package:

• “Attaching Requests” on page 37

• “Attaching Packages” on page 41

• “Attaching Releases” on page 45

• “Attaching Projects” on page 46

• “Attaching Tasks” on page 49

• “Adding an Attachment” on page 51

• “Adding a URL” on page 52

Attaching Requests
To attach Requests to a Package:

1. Open the Package window.

2. Click the References tab

3. Click the New Reference drop down list.

4. Select Request (Existing) from the drop down list.

5. Click Add. 

The New Reference - Request (Existing) window opens.

The following procedures detail how to add References to a Package from 
the Workbench. The procedure for adding References from the standard 
(HTML) interface uses the same fields and dependencies. 
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6. To select a Request for an attachment, use one of the following methods:

• Enter the Request Number in the Request No. field or click the Request 
No. auto-complete list to locate and select the Request in a Validate 
window. (Hold down Ctrl+Click or Shift+Click to select more than one 
Request.) The selected Request displays in the Request No. field. If you 
selected multiple Requests, they all display in the Request No. field 
separated by semi-colons. 

• Click Search to search for Requests in a separate query window and 
follow the procedure in “Searching for Requests to Attach” on 
page 39.

7. Select the type of relationship you want to assign between the Package and 
its attachment by selecting the appropriate radio button. 

See Table D-5 on page 19 for a description of the various relationships that 
can be assigned. 

8. Click OK. 

You return to the References tab in the Package window. The new attached 
Request is displayed as a Reference.

9. Click OK to save the attached Request as a Reference and close the Package 
window.
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10. Click Save to save the attached Request as a Reference in the Package 
without closing the Package window.

Searching for Requests to Attach

This procedure lets you use additional criteria and expand the search capability 
for Requests to attach to a Package.

To search for a Request to attach to a Package:

1. From the New Reference - Request (Existing) window, click Search. 

The Request Selection window opens.

2. Query for the Request(s) you want to use by entering search criteria in the 
appropriate fields.

3. Click List. 
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The Requests that match your search criteria display in the Query Results 
section of the window. 

4. Select the Request(s) in the Query Results section that you want to attach to 
the Package.

5. Select the type of relationship you want to assign between the Package and 
its attachment from the Select Relationship for New References drop down 
list. 

See Table D-5 on page 19 for a description of the various relationships that 
can be assigned.

6. Click OK to attach the Request(s) to the Package and close the current 
window. 

You return to the References tab in the Package window. The new attached 
Request displays as a Reference.

7. Click OK to save the new Reference and close the Package window.

8. Click Save to save the new Reference in the Package without closing the 
Package window.

Creating a New Request

To create a new Request from the Package’s References tab:

1. Select Request (New) from the Reference Type drop down list and click 
Add. 

The New Reference - Request (New) window opens.

2. Select a Request Type from the Request Type auto-complete list and a 
relationship from the available radio buttons. 
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3. Click Create to create the new Request. 

A browser window opens the the Create Request page. The new Request’s 
Description field is defaulted to the Package’s description. Fill in all 
required Request fields and any optional fields.

4. Click Submit. 

The Create Request page closes and returns you to the References tab in the 
Package window. The newly created Request displays as a Reference.

5. Click OK to save the Request as a Reference and close the Package 
window.

6. Click Save to save the Request as a Reference in the Package without 
closing the Package window.

Attaching Packages
To attach Packages to a Package:

1. Open the Package window.

2. Click the References tab

3. Click the New Reference drop down list.

4. Select Package from the drop down list.

5. Click Add. 

The New Reference - Package (Existing) window opens.
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6. To select a Package for an attachment, use one of the following methods:

• Enter the Package Number in the Package No. field or click the Package 
No. auto-complete list to locate and select the Package in a Validate 
window. (Hold down Ctrl+Click or Shift+Click to select more than one 
Package.) The selected Package displays in the Package No. field. If 
you selected multiple Packages, they all display in the Package No. field 
separated by semi-colons. 

• Click Search to search for Packages in a separate query window and 
follow the procedure in “Searching for Packages to Attach” on 
page 42.

7. Click the Relationship drop down list to open it. Select the type of 
relationship you want to assign between the Packages by selecting the 
appropriate radio button. 

See Table D-5 on page 19 for a description of the various relationships that 
can be assigned.

8. Click OK. 

You return to the References tab in the Package window. The new attached 
Package displays as a Reference.

9. Click OK to save the attached Package as a Reference and close the 
Package window.

10. Click Save to save the attached Package as a Reference in the Package 
without closing the Package window.

Searching for Packages to Attach

This procedure lets you use additional criteria and expand the search capability 
for Packages to attach to a Package.

To search for Packages to attach as References to Packages:

1. From the New Reference - Package window, click Search. 

The Package Selection window opens.
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2. Query for the Package(s) you want to use by entering search criteria in the 
appropriate fields.

3. Click List. 

The Packages that match your search criteria display in the Query Results 
section of the window. 

4. Select the Package(s) in the Query Results section that you want to attach to 
the Package.

5. Select the type of relationship you want to assign between the Package and 
its attachment from the Select Relationship for New References drop down 
list. 

See Table D-5 on page 19 for a description of the various relationships that 
can be assigned.

6. Click OK.
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You return to the References tab in the Package window. The new attached 
Package displays as a Reference.

7. Click OK to save the new Reference and close the Package window.

8. Click Save to save the new Reference in the Package without closing the 
Package window.

Creating a New Package

A new Package can be created from a Package’s References tab. 

1. Select Package (New) from the Reference Type drop down list and click 
Add. 

The New Reference - Package (New) window opens.

2. Select a relationship from the available radio buttons. 

3. Click Create to create the new Package. 

A new Package window opens. The new Package’s Description field is 
defaulted to the original Package’s description. 

4. Specify a Workflow and add Package Lines as you would for any other 
Package submittal. 

5. Click Submit.
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The Package window closes and returns you to the References tab in the 
original Package window. The newly created Package displays as a 
Reference.

6. Click OK to save the Package as a Reference and close the Package 
window.

7. Click Save to save the Package as a Reference in the Package without 
closing the Package window.

Attaching Releases
To attach Releases to a Package:

1. Open the Package window.

2. Click the References tab

3. Click the New Reference drop down list.

4. Select Release from the drop down list.

5. Click Add. The New Reference - Release window opens.

6. Enter the Release Name in the Release Name field or click the Release 
Name auto-complete list to locate and select the Release in a Validate 
window. (Hold down Ctrl+Click or Shift+Click to select more than one 
Release.) The selected Release displays in the Release Name field. If you 
selected multiple Releases, they all display in the Release Name field 
separated by semi-colons. 
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7. Click OK.

You return to the References tab in the Package window. The new attached 
Release displays as a Reference.

8. Click OK to save the attached Release as a Reference and close the Package 
window.

9. Click Save to save the attached Release as a Reference in the Package 
without closing the Package window.

Attaching Projects
To attach Projects to a Package:

1. Open the Package window.

2. Click the References tab

3. Click the New Reference drop down list.

4. Select Project from the drop down list.

5. Click Add. The New Reference - Project window opens.

6. To select a Project for an attachment, use one of the following methods:

• Enter the Project Name in the Project Name field or click the Project 
Name auto-complete list to locate and select the Project in a Validate 
window. (Hold down Ctrl+Click or Shift+Click to select more than one 
Project.) The selected Project displays in the Project Name field. If you 
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selected multiple Projects, they all display in the Project Name field 
separated by semi-colons. 

• Click Search to search for Projects in a separate query window and 
follow the procedure in “Searching for Projects to Attach” on page 47.

7. Click OK. 

You return to the References tab in the Package window. The new attached 
Project displays as a Reference.

8. Click OK to save the attached Project as a Reference and close the Package 
window.

9. Click Save to save the attached Project as a Reference in the Package 
without closing the Package window.

Searching for Projects to Attach

This procedure lets you use additional criteria and expand the search capability 
for Projects to attach to a Package.

To search for a Project to attach as a Reference:

1. From the New Reference - Project window, click Search. 

The Project Selection window opens.
Creating New Packages 47



Processing Packages (Change Management)
2. Query for the Project(s) you want to use by entering search criteria in the 
appropriate fields.

3. Click List.

The Projects that match your search criteria display in the Query Results 
section of the window. 

4. Select the Project(s) in the Query Results section that you want to attach to 
the Project.

5. Select the type of relationship you want to assign between the Package and 
its attachment from the Select Relationship for New References drop down 
list. 

See Table D-5 on page 19 for a description of the various relationships that 
can be assigned.

6. Click OK to attach the Project(s) to the Package and close the current 
window. 
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You return to the References tab in the Package window. The new attached 
Project displays as a Reference.

7. Click OK to save the new Reference and close the Package window.

8. Click Save to save the new Reference in the Package without closing the 
Package window.

Attaching Tasks
To attach Tasks to a Package:

1. Open the Package window.

2. Click the References tab

3. Click the New Reference drop down list.

4. Select Task from the drop down list.

5. Click Add. The New Reference - Task window opens.

6. To select a Task for an attachment, use one of the following methods:

• Enter the Task Name or click the Task Name auto-complete list to locate 
and select the Task in a Validate window. (Hold down Ctrl+Click or 
Shift+Click to select more than one Task.) The selected Task displays in 
the Task Name field. If you selected multiple Tasks, they all display in 
the Task Name field separated by semi-colons. 

• Click Search to search for Tasks in a separate query window and 
follow the procedure in “Searching for Tasks to Attach” on page 50.

7. Click OK. 
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You return to the References tab in the Package window. The new attached 
Task displays as a Reference.

8. Click OK to save the attached Task as a Reference and close the Package 
window.

9. Click Save to save the attached Task as a Reference in the Package without 
closing the Package window.

Searching for Tasks to Attach

This procedure lets you use additional criteria and expand the search capability 
for Tasks to attach to a Package.

To search for Tasks to attach to the Package:

1. From the New Reference - Existing Task window, click Search. A new query 
window opens.

2. Query for the Task(s) you want to use by entering search criteria in the 
appropriate fields.
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3. Click List. 

The Task that match your search criteria display in the Query Results 
section of the window. 

4. Select the Task(s) in the Query Results section that you want to attach to the 
Package.

5. Click OK to attach the Task(s) to the Package and close the current 
window. 

You return to the References tab in the Package window. The new attached 
Task displays as a Reference.

6. Click OK to save the new Reference and close the Package window.

7. Click Save to save the new Reference in the Package without closing the 
Package window.

Adding an Attachment
To add an attachment as a Reference:

1. Select Attachment from the New Reference drop down list and click Add.

The New Reference - Attachment window opens.

2. Select the desired file from your local machine and enter a description if 
desired.

3. Click Add to add the selected Attachment as a Reference and continue to 
add more. Click OK to add the selected Attachment as a Reference and 
Creating New Packages 51



Processing Packages (Change Management)
close the References: New window. Click Cancel to exit the References: New 
window without making changes.

Adding a URL
To add a URL as a Reference:

1. Select URL from the New Reference drop down list and click Add. 

The New Reference - URL window opens.

2. Type the URL into the URL field and enter a description if desired.

3. Click OK to add the specified URL as a Reference and close the New 
Reference - URL window. Click Cancel to exit the window without making 
changes.

Valid Package References

Table 4-1. Valid References in the Reference Tab 

Type Description

Attachment You can attach a file from your local machine to the current 
Package. The attached file is copied to the server and can then be 
accessed by other Mercury Change Management users. This 
feature is particularly helpful when you need to reference a 
document that is not already Web accessible.
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Reference Dependency Relationships
The relationships that can exist between a Package and a Reference are listed 
below in table Table 4-2.

Package 
(Existing)

You can reference other Packages directly from the Reference 
tab. Also, if configured as part of the current Workflow, you can 
spawn a Package from another Package. When this happens, a 
reference to that Package is automatically generated, establishing 
a two-way link between the primary and secondary Package. 

Package (New) New Packages can also be created from a Package in the 
References tab.

Project You can attach the current Package to a Mercury Project 
Management Project. 

Release You can associate a Package with a Release by referencing the 
Release number.

Request 
(Existing)

You can reference Requests directly from the Reference tab. 
Also, if configured as part of the Mercury Demand Management 
Workflow, you can spawn a Package from a Request. When this 
happens, a reference to that Request is automatically generated, 
establishing a two-way link between the Request and Package. 

Request (New) New Requests can also be created from a Package in the 
References tab.

Task You can attach the current Package to a Mercury Project 
Management Task.

URL You can reference URLs from a Package. Once attached, click on 
the Web address to open the document in your Web browser. The 
document must be in a MIME format recognized by your Web 
browser (Word, Excel, etc.)

Use URLs to include more detailed information than what is 
included in the Package notes, such as a screenshot for a Bug or 
a report.

Table 4-1. Valid References in the Reference Tab  [continued]

Type Description
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Copying an Existing Package
To copy a Package:

1. Locate and select the Package to be copied in the Results tab of the 
Packages Workbench.

Table 4-2. Reference Relationships 

Entity Relationships Description

Attachment Standard Attachment 
interaction

The attachment is related to this Package.

Packages Related to this Package Selected Package is related to this Package

Run Before this Package in a 
Release

Selected Package should be run before this Package 
when both are in a Release.

Run After This Package in a 
Release

Selected Package should be run after this Package 
when both are in a Release.

Predecessor Action not allowed on the this Package until the selected 
Package closes.

Successor Action not allowed on the selected Package until this 
Package closes.

Projects Related to This Package Selected Project is related to this Package.

Releases Contains This Package The Package is contained in the selected Release.

Requests Parent of This Package Selected Request is the parent of this Package.

Related to This Package Selected Request is related to this Package. 

Predecessor Action not allowed on the this Package until the selected 
Request closes.

Successor Action not allowed on the selected Request until this 
Package closes.

Tasks Related to This Package Selected Task is related to this Package.

URL Standard URL interaction The URL is related (informational reference only) to this 
Package.
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2. Click Copy. 

The Copy Package window opens.

3. Enter the new Description and select a Workflow.

4. Select Yes or No for the various items on the Options tab to specify which 
Package-specific information should be copied to the new Package. 
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5. Click the Details tab to specify which Package Lines are carried over. 

6. To exclude a Package Line, select the line and click Exclude. The newly 
excluded line appears in italics.

7. Check the Show Parameters check box to see more information about the 
Package Lines.

8. Click OK. 

A Question dialog opens.

9. Select Yes to edit or No to return to the Package Workbench. 

You must also decide whether or not to automatically submit the Package 
after a successful copy. To automatically submit the Package, select Yes for 
the Submit New Package radio button.

If you did not select Yes for the Submit New Package radio button, under the 
Options tab, then your Package is not submitted. To submit the Package, you 
must open the copied Package and click Submit.
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Merging Packages
You can generate a new Package by merging two or more existing Packages. 
This is advantageous when you would like to generate a single Package 
consisting of certain Package Lines contained in separate Packages. 

To merge two Packages:

1. Locate and select the Packages to be copied in the Results tab of the 
Packages Workbench. Hold down the Ctrl key to select nonadjacent rows.
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2. Click Merge. 

The Merge Package window opens.

3. Enter the new Description and select a Workflow.

4. Select Yes or No for the various items on the Options tab to specify which 
Package specific information should be copied to the new combined 
Package. 

5. Click the Details tab to specify which Package Lines are carried over. 

6. To exclude a Package Line, select the line and click Exclude. 

The newly excluded line appears in italics.

To automatically submit the Package after a successful copy, select Yes for 
the Submit New Package radio button.
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7. Check the Show Parameters check box to see more information about the 
Package Lines.

8. Click OK. 

A Question dialog opens.

9. Select Yes to edit or No to return to the Package Workbench. 

If you did not select Yes for the Submit New Package radio button, under the 
Options tab, then your Package is not submitted. To submit the Package, you 
must open the copied Package and click Submit.
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Generating a New Package Group
It is often advantageous to link the new Package to a specific Package Group 
for tracking and reporting purposes. 

To add a new Package Group:

1. From the Workbench menu, select Package > New Package Group.

The Validation: KNTA - Package and Request Groups window opens, listing 
groupings for Packages and Requests.

2. Click New. 

The Add Validation Value window opens.
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3. Enter all of the required information in both the Value Information and User 
Data tabs.

4. Click OK to accept the new Package Group and close the window, or click 
Add to accept the new Package Group and enter another new Package 
Group.

5. Click OK to save the changes.

Editing a Package Group
You can also edit existing Package Groups from within the Package 
Workbench. 

To edit an existing Package Group:

1. From the Workbench menu, select Package > New Package Group.

The Validation: KNTA - Package and Request Groups window opens, listing 
groupings for Packages and Requests.
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2. Select the Package Group that you would like to edit.

3. Click Edit. 

The Edit Validation Value window opens.

4. Make any desired changes and click OK to save the changes.
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Selecting a Workflow for a Package
Each Package is processed through a Workflow that was defined by your 
process configuration team. Mercury Change Management users are required 
to select a Workflow for each Package that they initiate. It is essential that 
Change Management users route their Packages through Workflows that 
properly model the appropriate business process.

Mercury IT Governance Center allows for extremely flexible Workflows, 
allowing you to map and configure almost any business process. Each Mercury 
ITG implementation will have uniquely defined Workflows. 

Although companies typically restrict Workflow editing permissions to certain 
users, all Change Management power users have permission to view the 
Workflow windows. Mercury Change Management users are encouraged to 
familiarize themselves with the Workflows that they are using to process their 
Packages. Viewing the Workflow’s graphical layout can help users decide 
whether they are using the appropriate Workflow for the current Package.

To view the graphical layout of a Mercury Change Management 
Workflow:

1. Click Configuration in the shortcut bar and click the Workflows icon. 

The Workflow Workbench opens.

Only users with appropriate Access Grants and security privileges can alter 
the KNTA Package and Request Groups Validation list. You should consult your 
Administrator before adding or editing any Package Groups. Package 
Groups are typically generated to adhere to specific business application 
standards.

Check with your administrator to verify that you are using the Workflow that 
accurately represents the business process that you would like to follow.
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2. Click List to display all of the Workflows in the system. 

You can restrict the search by entering one or more of the query 
parameters.

3. Select one or more of the listed Workflows and click Open. 

The Workflow window opens.
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4. Click the Layout tab to view the Workflow’s graphical representation.

5. Double-click on any numbered step. 
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The Workflow Step window opens.

6. Click on any of the tabs to view the following information:

• Properties: This tab contains general information about the Workflow 
Step.

• Security: This tab is used to define the Security Groups that are allowed 
to act on a particular step. All of the enabled Security Groups will 
appear in either the Available Security Groups field or the Linked Security 
Groups field. Each user who belongs to a Linked Security Group is able to 
perform the actions defined for that particular Workflow Step.

• Notifications: This tab is used to attach email Notifications to the 
specific Workflow Step. Email messages can be sent whenever an 
event occurs at a Workflow Step. An event can be when the step 
becomes eligible or when the step completes with a specific result.

• User Data: This tab on the Workflow Step displays any custom fields 
for each Workflow Step.

• Results: This tab that lists all the valid results the step can have.
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7. Double-click on any transition arrow to view the Step Transitions window. 
This window details the conditions that must be met in order to continue to 
the next Workflow Step.

For more information about a particular Workflow or general information on 
Change Management Workflow processing, consult your administrator or refer 
to the Workflow chapter in "Configuring a Deployment System".

Submitting a Package
Once a Workflow is selected and Package Lines have been added, the Package 
is eligible for submission. The following figure illustrates a Package pending 
submission. Notice that the Submit button remains enabled for pending 
submission. Submit the Package by clicking Submit. The Package begins 
moving through its assigned Workflow to completion.

Figure 4-1 shows a Package that has not yet been submitted. 

Workflows can consist of multiple Subworkflows which are represented in 
the Layout tab by a single Subworkflow icon. Users can view each of these 
Subworkflows in the same manner as described above or by opening the 
desired Workflow in the Workflow Step Source window.
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Figure 4-1 Non-submitted Package
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 Chapter

Processing Packages

This chapter provides instructions for viewing and processing Packages. This 
includes information on locating Packages, acting on eligible steps and 
viewing key Package information and statuses. 

During the initial entry of a Package, users specify the Workflow through 
which the Package is processed. This Workflow is the business and migration 
process that the Package follows. Workflows are initially determined during 
system configuration and are modified as needed.

This chapter covers the following topics:

• Viewing Package Permissions

• Locating In Progress Packages

• Checking a Package Status

• Viewing Information on Packages and Package Lines

• Acting on an Eligible Step - Overview

• Updating Packages in the HTML Interface

• Processing Packages in the Workbench

• Configuring Workflow Display

If you have questions concerning the configuration and use of a specific 
Workflow in your Mercury Change Management instance, consult your 
business configuration expert.
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Viewing Package Permissions
To increase general accountability and control over the Package process, 
Mercury Change Management has implemented Package security in two key 
ways: 

• Security Group Security: Users must be included in specific Security 
Groups (that have the correct Access Grants) for them to have edit-access 
to different levels of Package processing.

• Workflow Step Security: Each Workflow Step explicitly states which 
Security Groups can act on that step.

Although the process of setting up Security Group and Workflow Step 
securities remains an issue for application configuration experts and 
administrators, all Change Management Power Users have full read-access to 
view individual security privileges.

To view a user’s Security Group(s) membership:

1. In the Workbench, click the Sys Admin screen group and click the Users 
icon. 

The User Workbench opens.

2. In the Username field, enter the username. 

3. Click List. 
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The Results tab opens and displays the username listed on the Query tab. 

4. Select the username and click Open. 

The User window opens.

5. Click the Security Groups tab.

The Security Groups to which the user belongs are listed in Security Groups 
tab. These Security Groups dictate the level of Mercury Change Management 
view and edit access. Security Groups are highly configurable and can vary 
greatly between Mercury Change Management implementations. See Security 
Model Guide and Reference for details. 

Locating In Progress Packages
Packages are sometimes routed through a lengthy business process involving 
testing, various approvals and rework. Users may wish to check on all of their 
open Packages to locate any bottlenecks and assist in Package processing. 

This section covers the following topics:

• Using the My Packages Portlet

• Querying for In Progress Packages

• Reporting on Open Packages
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• Using Smart URLs to Locate Open Packages

Using the My Packages Portlet
The quickest way to locate relevant Packages is through the Mercury ITG 
Dashboard. When included on the Dashboard, the My Packages Portlet displays 
all Packages you have created. 

Querying for In Progress Packages
To query for In-Progress Packages:

1. Click the Change Mgmt screen group and click the Packages icon.

The Package Workbench opens.
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2. From the Package Status drop down list, select In Progress .

3. If you would like to limit the search to Packages that you generated, select 
your username from the Created By drop down list.

4. Click List. 

The Results tab is displayed. Packages are listed in the Results tab.

Reporting on Open Packages
Mercury Change Management includes a pre-defined set of Reports that 
generate HTML text and can be accessed by a Web browser. Among these 
reports is the Packages Pending Report, which reports on open Packages with 
pending activity. 

To Run the Packages Pending Report:

1. Click Change Mgmt in the shortcut bar and click the Reports icon. 

The Report Submission Workbench opens.

The Query tab can also be helpful in finding all Open (i.e. Not Closed) 
Packages. The Advanced tab allows you to set up entire lists of inclusions 
and exclusions in your database search. For more information on using the 
Advanced query, refer to “Query Tab” on page 6.
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2. Click New Report. 

The New Report Submission window opens.

3. From the Report Type auto-complete list, select Packages Pending Report.

The window is dynamically updated.
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4. Since you are looking for a Report on all open Packages, accept the default 
parameters and click OK. 

The report runs and returns you to the Results tab.

5. Select the Completed line and click View Report. 

This displays the following page in a new browser window:
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This provides a detailed list of all of the Open Packages. For more information 
on the Packages Pending Report parameters as well as other Reports available 
in Change Management, refer to “Change Management Reports” on page 117.

Using Smart URLs to Locate Open Packages
As a Package proceeds through its Workflow, email Notifications can be sent 
to alert users of pending actions. The logic regarding when emails are sent and 
the content for each email is defined in the Workflow. Notifications can be sent 
when a step becomes Eligible, alerting specific users that they need to perform 
an action or decision. They can also be sent after a step is completed to inform 
assigned users of the specific outcome.

Change Management Notifications typically instruct the user to review a 
Package or act on a pending Workflow Step (an execution or a decision). 
Follow the instructions detailed in the Notification for the appropriate course 
of action.

The Notification may include a “Smart URL” which points to the specific 
Package in Mercury Change Management. Enter this URL into your Web 
browser to proceed to this destination. If you are currently logged onto Change 
Management, the referenced Package opens. If you are not currently running 
Change Management, the Mercury IT Governance logon page opens. After 
you logon, the referenced Package opens. 

Figure 5-1 shows a sample Notification.

Figure 5-1 Sample Notification

Checking a Package Status
Each Package Line must follow a business process defined in its assigned 
Workflow. You can view all the Workflow and Subworkflow Steps for each 

http://machine.company.com/itg/itg.html

Notified Users: jsmith@itg.com

Status change for Request #: 30004.
Description: Sample Notification.
Priority: High
Workflow: Migration Workflow
Workflow Step: 1. Approve (One User)
Old Status: New Status: Eligible
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Line in the Status tab in the Package window. This is the current view of the 
situation. 

To view the Status of a particular Package:

1. Click Change Mgmt in the shortcut bar and click the Packages icon. 

The Package Workbench opens.

2. Query for the desired Package using one or more of the query parameters. 

The results display in the Results tab.

3. Select the Package and click Open. 

The Package window opens.

4. Click the Status tab.
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You can now review the status of each Package Line. The result of each 
Workflow Step is recorded in the Package Line row, allowing you to quickly 
get an idea of which lines have closed successfully or with a failure.

Viewing the Subworkflow Step Statuses
The Package Line can be expanded to show any Subworkflow Steps used in 
the Workflow definition. To view the Subworkflow steps, click the expand 

 symbol above the Subworkflow Step. You can also click on the 
expand all  symbol to expand all Subworkflows contained within the Status 
panel. To hide expanded Subworkflow steps, click the collapse  
symbol above the Subworkflow step. To hide all Subworkflow steps, click the 
collapse all  symbol.

Clicking the expand  symbol horizontally expands the Package Line 
to display all of the steps within the Subworkflow. Subworkflow Steps have a 
different colored header and are numbered using additional decimal places 
corresponding to the level of the Workflow. 

While all the Workflow Steps are listed, a Package Line might not go 
through each step before being resolved. For example, you might have a 
Rework step that is only used when rework is required.
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Figure 5-2 shows expanded Subworkflow Steps on the Package’s Status tab.

Figure 5-2 Expanded Subworkflow Steps in Status Tab

Viewing Information on Packages and Package Lines
From within a Package’s Status tab in the Workbench, users can also view 
information concerning their Packages and Package Lines.

This section covers the following topics:

• Viewing the Line Execution Log

• Viewing the Package Execution History

• Graphically Viewing a Package Line Status Within a Workflow

• Viewing Line Permissions

• Viewing the Line Transaction History

• Viewing the Decision Detail

• Viewing the Concurrent Package Log

• Viewing the Workflow Step Information URL

If Step 3 of a top-level Workflow is a Subworkflow, its steps are displayed as 
3.1, 3.2, 3.3, etc. Similarly, if the second step in that Subworkflow is also a 
Subworkflow step, its steps are displayed as 3.2.1, 3.2.2, 3.2.3, etc. 
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• Updating References

Viewing the Line Execution Log
It is possible to select a Package Line and get the details of the execution of 
that particular line by viewing the Line Execution Log. The line viewed is a 
subset of the overall execution batch log.

To view the Line Execution Log for a particular Package Line:

1. In the Package window, click the Status tab.

2. Select a Package Line.

3. Select Line Exec Log (Latest) from the drop down list next to the View--> 
button near the bottom of the window.

4. Click View-->. 

A browser window displaying the Line Execution Log opens.
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Viewing the Package Execution History
The Package Execution History displays the execution history of each Package 
Line. It displays the Workflow Step name, execution date, and outcome 
(succeeded or failed) of each Execution step.

If the Package Line has been configured to migrate to multiple Environments 
using an Environment Group, the execution log returns an execution 
summary and link for each Destination Environment. Click the link to get the 
detailed execution logs for each Environment.
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To view the Package Execution History for a particular Package Line:

1. Navigate to the Package’s Status tab in the Package window.

2. Select Package Exec History from the drop down list next to the View--> 
button near the bottom of the window.
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3. Click View-->. 

A browser window displaying the Package Execution Log History opens.

Graphically Viewing a Package Line Status Within a Workflow
To graphically view a Package Line status for a particular Package Line:

1. Navigate to the Package’s Status tab in the Package window.

2. Select a Package Line.

If the Package Line has been configured to migrate to multiple Environments 
using an Environment Group, the execution log returns an execution 
summary and link for each Destination Environment. Click the link to get the 
detailed execution logs for each Environment.
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3. Select Graphical View from the drop down list next to the View--> button 
near the bottom of the window.

4. Click View-->. 

This opens the Graphical View window. Use the legend at the top of the 
window to determine which Workflow Steps have been visited and which 
steps are active. 
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This image displays all of the Workflow Steps and Subworkflows used in the 
Workflow definition. 

To obtain a graphical view of a particular Subworkflow, select the 
Subworkflow name from the Show Subworkflow Step drop down list located at 
the bottom of the window. This opens a new window that displays the 
graphical view of that Subworkflow.

Viewing Line Permissions
To view the permissions for acting on a particular Package Line:

1. Navigate to the Package’s Status tab in the Package window.

2. Select a Package Line.
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3. Select Line Permissions from the drop down list next to the View--> button 
near the bottom of the window.

4. Click View-->.

This opens the Authorized Users window and displays the users who can act 
on the specific steps in the current Package Line. Each Workflow Step is 
linked to a unique set of Authorized Users. 
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Viewing the Line Transaction History
You can view the transaction history of each Package Line. This provides 
detailed information on how the Package Line has proceeded through a 
Change Management Workflow. Information such as the date of the 
transaction event, the user linked to the Workflow Step, the Workflow Step 
name and number, status and results are displayed. 

To view the Line Transaction History for a particular Package Line:

1. Navigate to the Package’s Status tab in the Package window.

2. Select a Package Line.

Workflow permissions are established during the initial Workflow 
configuration. The Line Permissions lists all users in Security Groups that 
have been enabled for the related Workflow. If you have questions regarding 
the permissions set for a particular Workflow Step, consult your 
administrator.
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3. Select Line Trans History from the drop down list next to the View--> button 
near the bottom of the Status tab.

4. Click View-->.

The Transaction History window opens.

5. Select either Current transaction status or Full transaction history from the 
Show drop down list.

Viewing the Decision Detail
To view the results of a particular Decision step:

1. Navigate to the Package’s Status tab in the Package window.

2. Select a Package Line.

Select Full transaction history to display information on the Subworkflow 
steps that have been traversed more than once by a single Package Line. An 
example of a Package that retries a Subworkflow step and then returns from 
the Subworkflow is shown below.

Selecting Current transaction status will display only information on the 
most recent transaction through that step.
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3. Select the step for which you would like to see the decision results.

4. Select Decision Detail from the drop down list next to the View--> button 
near the bottom of the window.

5. Click View-->. 

The the Detail for Evaluate window opens.
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Viewing the Concurrent Package Log
Mercury Change Management is able to track and report on system-triggered 
concurrent Packages. Users can view the Oracle Applications Concurrent 
Package Logs for Package activities. 

To view the Concurrent Package Log for a particular Package:

1. Navigate to the Package’s Status tab in the Package window.

2. Select a Package Line.

3. Select Line Exec Log (Latest) from the drop down list next to the View--> 
button near the bottom of the window.

4. Click View-->. 

A browser window displaying the Line Execution Log opens. The Line 
Execution Log contains a section titled Concurrent Request Output that 
contains the Concurrent Package Log.
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Viewing the Workflow Step Information URL
To view information on a particular Workflow Step:

1. Navigate to the Package’s Status tab in the Package window.

2. Select the step for which you would like to see the Workflow Step 
Information.

3. Select Information URL from the drop down list next to the View--> button 
near the bottom of the window.

4. Click View-->. 

If the Package Line has been configured to migrate to multiple Environments 
using an Environment Group, the execution log returns an execution 
summary and link for each Destination Environment. Click the link to get the 
detailed execution logs for each Environment.
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A new browser window that contains information specific to the selected 
Workflow Step opens.

Updating References
Package References can be updated from the References tab of the Package 
window in the Workbench and the References section of the Package Detail 
page in the standard (HTML) interface. See “Adding a Reference” on page 36 
for details on adding a Reference to a Package and additional information on 
setting dependent relationships to references. 

This section covers the following topics:

• Changing a Reference

• Deleting a Reference

Changing a Reference
To modify an existing Reference from the Workbench:

1. In the Package window, click the References tab.

2. Click in the referenced entity’s Relationship column and select the desired 
relationship from the drop down list that appears. 

3. Click OK or Apply.

Deleting a Reference
To delete an existing Reference from the Workbench:

1. In the Package window, click the References tab.

2. Select the reference to delete.

3. Click Remove. 

The reference is removed and deleted from the Mercury ITG server.

Acting on an Eligible Step - Overview
Once submitted, each Package Line has one or more Workflow Steps set to 
Eligible, as shown in Figure 5-3. This indicates that the given execution or 
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decision steps need to be performed first in the Package’s resolution process. If 
you have permission to act on the Eligible step, the text in the Status column 
appears in boldface type. 

When a step is Eligible, one of the following actions are required:

• A user must execute some action and then report the result in Mercury 
Change Management

Or

• A user must make a decision and report that decision in Mercury Change 
Management.

Figure 5-3 Status Tab Eligible Steps

Once the appropriate user executes the action or makes the decision, he uses 
Mercury Change Management to indicate the outcome of the step.

To indicate the outcome of a step:

1. Navigate to the Package Status tab for the desired Package.

2. Select the eligible Workflow Step to be processed. 
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A single step for a single Package Line can be selected or multiple steps for 
multiple Lines can be selected. Click Select All to automatically select all 
the steps on all the open Lines that are currently eligible for action.

You cannot act on multiple Workflow Steps at once; if you select cells for 
multiple Workflow Steps, the Action button remains disabled. If the user 
has the security privileges to perform the given Workflow Step, the button 
becomes enabled. Refer to “Viewing Line Permissions” on page 85 for 
instructions on viewing Workflow Step line permissions.

Once a Workflow Step is selected, the button at the bottom right of the 
Status tab changes its title (originally ‘Action’) to the given step name. 

3. Once the Action button is enabled, click it to perform the action or decision.

This opens either the Execution or Decision window.

4. In either the Execution or Decision window, select the step’s result. 

Each step is pre-configured with a selection of valid results. In addition to 
selecting a result, you can also enter free-form comments in this window. 

5. Click OK to close the Package window.

Whether the step is a Decision or Execution, the result of the step is processed by 
the Workflow engine and can lead to a number of changes. Based on the 
Workflow definition (which can contain multiple Workflow Steps and 
Subworkflows) the given Workflow Step result can cause additional Workflow 
Steps to become Eligible, indicating the next actions to be performed in the 
Package resolution process. 

When subsequent steps become Eligible, those steps are completed sequentially, 
making Eligible the next Workflow Step(s) in line. This process continues until 
the Package reaches its final state and becomes resolved, usually at a Close 
step. 

Use the Status tab to see:

• All the possible actions that can take place for the Package

The final Package state might not always be a successful migration. A 
Package might be divided into several Packages that are more manageable, 
or the Package be cancelled altogether. 
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• All the actions that have taken place so far 

• The current pending actions that need to be taken for Package resolution

Updating Packages in the HTML Interface
Change Management users can update certain information on Packages using 
the standard HTML interface. 

This section covers the following topics:

• Approving Packages in the HTML Interface

• Adding a Reference to a Package

Approving Packages in the HTML Interface
To approve a Package using the HTML interface:

1. Logon to Mercury Change Management. 

2. Navigate to the details page for the Package you want to approve.

The following process of approving a Package in the HTML interface 
starts in the Package Details page. You can access a Package's Details page 
using any of the following methods:

• From the My Packages Portlet, click the Package Number of the Package 
to be approved.

• Selecting Search > Packages from the menu and searching for the 
desired Package. From the Package Search Results page, click the 
Package Number of the Package to be approved.

• In an email Notification, click the URL of the Package to be approved.

The Package Details page for an example Package is shown below.

If you have Package Manager authority, it is also possible to Cancel a 
Package at any point using the Package > Cancel Package menu option.
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3. The Status section of the Package Details page displays the Package Line(s) 
for the Workflow. In the Status section, you can select the following 
display option from the View drop down list:

• Pending Lines Only to display only those Package Lines that are 
eligible for action. Click Go to use this option.

or

• All Lines to display all the Package Lines for the Workflow. Click Go to 
use this option.
96 Processing Packages



Processing Packages (Change Management)
4. Select the check box to the left of the Seq column for the Package Line that 
contains a step you want to approve or disapprove. 

5. (Optional) To display details about the selected Package Line in a separate 
browser window, click Line Details.

6. Under the Workflow name are the numbered steps that must be completed 
and approved to move the Workflow to completion. You can move forward 
or backward through the Workflow's Steps by clicking the directional 
arrows.

7. Select the radio button to the left of the numbered Workflow Step to be 
approved. 

8. Select the Eligible checkbox under the Step you want to approve or 
disapprove. 

You can check all eligible boxes for the Workflow Step by clicking Check 
All. This lets you approve or disapprove a number of steps at one time 
instead of individually.

You can uncheck all eligible boxes for the Workflow Step by clicking 
Clear All. 

9. If one or more Package Lines are selected for action, click Workflow 
Action. 

The Package: Workflow Action page opens.
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10. Under Action Required, select the outcome of the step. 

The outcome is configurable and can therefore be different for each 
Workflow Step, depending on the configuration at your site. In the above 
example the possible actions are:

• If the Workflow Step is ready for approval, select Approved.

or

• If the Workflow Step is not ready for approval, select Not Approved.

11. Enter any necessary information in the Notes text area.

12. Click OK. 

You return to the Package Details page. 

Since you approved or disapproved the designated Workflow Step(s), the 
Workflow has moved onto the next step. Another user is probably responsible 
for approving/disapproving the next step in the Package Line. This process 
continues until the Package moves through all of its steps to resolution.

You can only approve Package decision steps using the standard interface. 
To perform execution steps, logon to the Workbench. 
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Adding a Reference to a Package
You can add a reference to a Package from the standard interface. There are 
several reference types defined in Mercury Change Management: Attachment, 
Package, Project, Release, Request, Task, and URL. For some reference types, 
such as for Requests and other Packages, you can create a functional 
dependency to the reference. For example, you can specify that a Request is a 
“Predecessor” to the Package. This means that the Package will not continue 
until the Request closes.

To add a Reference to a new or existing Package:

1. Open the Package page. 

You can locate your Package using the Search > Packages menu item.

2. Scroll down to the References section.

3. From the New Reference field, select the type of Reference that you would 
like to add. 

See “Valid Package References” on page 52 for a list of available 
References. 

4. Click Add. 

When adding a Package, Request, Task or Project, a page opens presenting 
search criteria for the entity to be referenced. The following figure displays 
the page that opens when adding a reference to an existing Request. 
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5. Enter the appropriate information and click Search. 

A page opens presenting search results.
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6. Select the check box next to the entity or entities to be referenced. 

To check all boxes, click Check All. To uncheck all boxes, click Clear All.

7. Select a relationship by clicking on of the relationship radio buttons. 

For a complete list of all reference relationships, see Table D-4 on page 18.

8. Click Add.

9. The entities referenced appear in the References to be added on Save list on 
the Package Detail page. 

The References have not been added yet.

10. Click Save to add the References to the Package.
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Referencing a URL
To add a URL as a Reference:

1. Navigate to the Package’s Detail page and scroll down to the References 
section.

2. From the New Reference drop down list, select URL.

3. Click Add. 

The Reference URL page opens.

4. Type the URL into the URL field and enter a description if desired.

5. Click OK to add the specified URL as a Reference. 

6. The referenced URL appears in the References to be added on Save list on 
the Package Detail page. The Reference has not been added yet.

7. Click Save to add the Reference to the Package.

Referencing an Attachment 
To add an attachment as a Reference:

1. Navigate to the Package’s Detail page and scroll down to the References 
section.

2. From the New Reference drop down list, select Attachment.

3. Click Add. 

The Reference Attachment page opens.
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4. Select the desired file from your local machine and enter a description if 
desired.

5. Click OK to add the selected attachment as a Reference.

The referenced attachment appears in the References to be added on Save 
list on the Package Detail page. 

The Reference has not been added yet.

6. Click Save to add the attachment to the Package.

Processing Packages in the Workbench
The majority of user interactions with Packages occur in the Workbench. 

This section covers the following topics:

• Acting on a Decision Step

• Acting on an Execution Step

• Using Notifications

• Adding a Package Line to an ‘In Progress’ Package

• Cancelling Package Lines

• Deleting Packages

Acting on a Decision Step
Decisions are steps in a Workflow where a user or group of users need to 
indicate the result or outcome, such as an approval of work or an indication 
that a review has been completed. ‘Approve Migration’ is an example of a 
Decision step. You can either act on the decision step yourself or delegate the 
decision to someone else. 
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This section covers the following topics:

• Making the Decision on a Decision step

• Delegating the Decision on a Decision Step

Making the Decision on a Decision step
To act on a Decision step:

1. Navigate to the Package Status tab for the desired Package.

2. Select the Eligible Decision step. 

The Action button is enabled. Notice that the label on the Action button 
changes depending on which step is selected.

3. Click Action. 

The Package Decision window opens.

4. Select Decide Now from the drop down list.

5. Select the desired Result (such as Approved or Failed) and enter any 
relevant notes in the Notes field.

6. Click OK.

The Decision has been made and entered into the system.
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Delegating the Decision on a Decision Step
If a Workflow Step has been configured for more than one user to participate 
in a decision, you can delegate your decision to another Change Management 
user.

To delegate the decision on a Decision step:

1. In the Package window, click the Status tab.

2. Select the Eligible Decision step. 

The Action button is enabled. Notice that the label on the Action button 
changes depending on which step is selected.

3. Click Action. 

The Package Decision window opens.

4. Select Delegate Decision from the drop down list.

5. Select the user to whom you would like to delegate the decision 
responsibility in the Delegate To field. 

If the step has been configured so that more than one person has to decide on 
the result, the Package Line may not move to the next step until all decisions 
are made. For Decision steps that require more than one person to decide on 
the result, you can view the current decision results for the Workflow Step 
using the Decision Detail. For instructions on viewing the Decision Detail, 
refer to “Viewing the Decision Detail” on page 88.
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6. Click OK.

The user to whom you delegated your decision now has authority to vote on 
the Workflow Step, even if that user did not previously have authority to do so. 

Acting on an Execution Step
Executions are steps where the Change Management system performs an 
action and then updates the step with its result. These actions can be as simple 
as calculating the value for a Token or as complex as copying files, running 
programs, or updating Web pages. 

This section covers the following topics:

• Starting the Execution Process

• Scheduling an Execution Step for a Later Time

If the step has been configured so that more than one person has to decide on 
the result, the Package Line may not move to the next step until all decisions 
are made. However, once your decision has been recorded, the step will 
remain Eligible but the cell will be unbolded, indicating that you no longer 
need to act on this step. 

For Decision steps that require more than one person to decide on the result, 
you can view the current decision results for the Workflow Step using the 
Decision Detail. For instructions on viewing the Decision Detail, refer to 
“Viewing the Decision Detail” on page 88.
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• Bypassing the Execution

Starting the Execution Process
To Start the execution process for an Eligible Execution Step

1. Navigate to the Package Status tab for the desired Package.

2. Select the Eligible Execution step.

The Action button is enabled. Notice that the label on the Action button 
changes depending on which step is selected.

3. Click the Action button. 

The Package Execution window opens.

4. Select Execute Now from the drop down list.

5. Click OK. 

The execution process has begun.

Scheduling an Execution Step for a Later Time
To schedule an execution step for a later time:

This process could be a software migration, execution of a PL/SQL function, 
the closing of the Package Line, or a number of other activities. The 
Execution engine executes the step and sets the result accordingly.
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1. Navigate to the Package Status tab for the desired Package.

2. Select the Eligible Execution step. 

The Action button is enabled. Notice that the label on the Action button 
changes depending on which step is selected.

3. Click Action. 

The Package Execution window opens.

4. Select Scheduled Execution from the drop down list.

5. Fill in the Execution Date and Execution Time for when you would like the 
step to execute.

6. Click OK. 

The execution process will begin on the scheduled date and time.

Bypassing the Execution
You can also bypass the execution and manually set the result of the step 
without the Execution engine performing any activity.

To bypass the execution:

You might choose to schedule a software migration for later in the evening 
when fewer users are on the system. At the scheduled time, the Execution 
engine executes the step and returns the result.
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1. Navigate to the Package Status tab for the desired Package.

2. Select the Eligible Execution step. 

The Action button is enabled. Notice that the label on the Action button 
changes depending on which step is selected.

3. Click Action. 

The Package Execution window opens.

4. Select Bypass Execution from the drop down list.

5. Select the desired result (such as Succeeded or Failed) from the Execution 
Result drop down list.

6. Click OK.

Using Notifications
As Package Lines make their way through their Package Workflow, email 
Notifications are often sent to alert individuals regarding certain actions. The 
logic for when emails are sent and the content for each email is part of the 
definition for each Workflow.

If you know that a software migration has already been manually performed, 
you may want to mark the step as Successful without actually migrating the 
software again.
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Notifications will typically instruct the user to review a Package or act on a 
pending Workflow Step (either an execution or a decision). Follow the 
instructions detailed in the Notification for the appropriate course of action.

Figure 5-4 illustrates a sample Notification.

Figure 5-4 Sample Notification

Adding a Package Line to an ‘In Progress’ Package
Aggressive maintenance of your business systems can introduce the need for 
quick code migrations using Change Management Packages. You may run into 
situations where you would like to add a Package Line to a Package that has 
already been submitted. 

To add a Package Line to an In Progress Package:

1. From the Package Workbench, query and select the desired Package.

2. Click Open. 

The Package window opens.

http://machine.company.com/itg/itg.html

Notified Users: jsmith@itg.com

Status change for Request #: 30004.
Description: Sample Notification.
Priority: High
Workflow: Migration Workflow
Workflow Step: 1. Approve (One User)
Old Status: New Status: Eligible

You define and submit a Package that includes a set of Objects to migrate 
into your production instance. After you click the Submit button, a co-
developer notifies you that there is one more file that needs to be migrated 
into production. You assess the change and decide that it falls within the 
logical unit of Objects that should be moved and tracked together. You 
decide to add a Package Line to an In Progress Package.
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3. Click New Line. 

The Add Line window opens.

4. From the Object Type field, select an Object Type. 

The Parameter tab dynamically display fields corresponding to the selected 
Object Type.
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5. Enter the parameters.

6. Click OK to accept the parameters and close the window or Add to accept 
the parameters and reset the window for another line addition. 

The new line is added to the Package window.

7. Click OK.

The new Package Line has been added to the Package.

Cancelling Package Lines
Package Lines may need to be cancelled occasionally, for a number of reasons; 
the files may be out of date, or no longer necessary.

To cancel a Package Line:

1. From the Package Workbench, query and select the desired Package.

2. Click Open. 

The Package window opens.

The new Package Line is not submitted until you click OK or Save. The 
Submit button remains disabled throughout this process. The new Package 
Line is automatically submitted when the Package is saved. It is submitted to 
the first step in the Workflow, and the user can process it individually until it 
catches up with the other lines in the Package. When submitted, it is not 
automatically placed in the same status as the other lines.
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3. Select the Package Line you wish to cancel.

4. Select Package > Cancel Package Line from the Workbench menu.

The Package Line has been cancelled.

Deleting Packages
To delete an existing Package:

1. From the Package Workbench, query and select the desired Package.

2. Click Delete. 

A question dialog opens and asks you to confirm that you would like to 
delete the Package. 

3. Click OK to delete the Package.

The Package is deleted from your system.
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Configuring Workflow Display
You can configure the display of Workflow Steps in the Status tab by 
changing your User Profiles.

To configure the Workflow display:

1. Select Edit > User Profiles from the Workbench menu.

2. Click the Workflow Status tab.

3. Choose either to show all Workflow Steps or to limit your display of 
Workflow Steps in the Workflow Steps drop down list. 

If you choose to limit the steps that you see, select one of the following 
options:

• Show Traversed Steps. You can choose whether or not you want to see 
steps that have been completed and are no longer active.

• Hide Immediate and Condition Steps Not in Progress. Since you 
typically cannot act on immediate Execution or Condition steps, you 
can choose to hide these steps.

The display of Workflow Steps will change according to your choice.

Hiding Cancelled Package Lines
You can configure the display of your Package in the Package Lines tab and 
the Status tab by changing your User Profiles. 

To hide cancelled Package Lines:
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1. Select Edit > User Profiles from the Workbench menu.

The User Profiles window opens.

2. Click the Package tab.

3. Select whether or not to display cancelled Package lines by selecting the 
Hide Cancelled Package Lines. 

If you check the Hide Cancelled Package Lines check box, the ordering of the 
remaining Package Lines and their respective sequence numbers remain 
the same. Also, reordering the visible lines will not affect the hidden 
(cancelled) lines. The sequence numbers of the visible lines being 
reordered will swap correspondingly.
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 Chapter

Change Management Reports

Mercury Change Management features a pre-defined set of HTML-based 
reports that are accessed through a Web browser. The reports provided with 
Change Management allow users to view the current detailed status of their 
deployment data at any point in time. 

This chapter describes the procedures used to submit and view reports using 
both the standard interface and the Workbench. 

This chapter covers the following topics:

• “Reports Overview” on page 117

• “Processing Reports” on page 120

Reports Overview
The standard reports that ship with Mercury Change Management and a brief 
description are listed in the following table. These reports can be accessed 
through both the Workbench and the HTML interface. A complete list of 
Mercury IT Governance Center Reports, including details for parameters in 
each report, are located in Reports Guide and Reference.

The following table lists all standard Report Types that have a product scope 
of Change Management or All Products. 
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Table 6-1. Standard Change Management Reports 

Report Description

Compare Custom Database Setup 
Report

Runs custom Mercury ITG database comparisons for the 
comparison of actual data within a database as well as within the 
data model.

Compare Filesystem Environments 
Report

Compares the files and file structure of two machines.

Compare MS SQL Server 7 
Environments Report

Compares the data models of two SQL Server Version 7 
databases. 

Compare Oracle Environments 
Report

Compares the data models of two Oracle schema. 

Distribution Detail Report A Release Management report used to list the contents and results 
of a Distribution.

Environment Comparison by 
Objects Migrated Report

Looks at the history of all the objects migrated using Mercury 
Change Management into each environment and lists any 
differences.

Environment Comparison Report A System Administration report that audits Environment setup.

Environment Detail Report A System Administration report that lists the detailed setup of a 
given Environment or group of Environments.

Environment Group Detail Report Contains detailed information from the specified Environment 
Groups.

Environments/Objects Detail 
Report 

Lists objects that have been migrated into a given Environment or 
sets of Environments grouping the report output by Environment 
name; an ‘Object inventory’ for newly migrated objects.

Lookup Types Report View the configuration details of one or more lookups.

Notification History Report A Workflow report that lets you view Notifications that have been 
sent or are pending. 

Object Type Detail Report A System Administration report used to audit the setup of an Object 
Type or a group of Object Types.

Object History Report Provides a Workflow Step transaction history for your Packages. It 
lists all the transactions matching your selection criteria.

Objects/Environments Detail 
Report

Lists objects that have been migrated into a given Environment or a 
set of Environments, grouping the report output by Object Type 
name.

Package Details Report Use this report for auditing individual Packages. Based on the 
selection criteria, this report lists individual Packages and detailed 
information regarding each Package.

Package History Report Audits the transaction history of individual Packages and lists the 
complete Workflow history for each selected Package.

Package Impact Analysis Report Analyzes the impact of a given Package based on the audit history 
stored in Mercury Change Management.
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Packages Pending Report A worklist of Packages pending user action. Based on your 
selection criteria, this report lists open Packages with pending 
activity. 

Portlet Detail Report Returns the definitions of selected Portlets, including columns, filter 
fields, access security, ‘used by,’ and the Portlets’ full SQL query.

RCS Check In Report (If you use an RCS file management system) Checks a file into the 
RCS repository.

RCS Check Out Report (If you use RCS file management system) Checks a file out of the 
RCS repository.

Release Detail Report A Management report used to list the contents of a Release.

Release Notes Report A Release Management Report that shows all of the Requests and 
Packages in a Release as well as their associations.

Report Type Detail Report The parameters and parameter details for each Report Type, as 
well as the exact commands used to run the report.

Run Field Security Denormalization Runs Field Level Security related denormalization tasks for 
particular entities.

Run ITG Organization Unit 
Interface

Imports data from the organization unit interface tables or an LDAP 
server.

Run ITG Package Interface Report Validates and loads Package data from the Package open interface 
tables into the standard Mercury Change Management data model. 

Run ITG User Interface Report Imports data from the user interface tables or an LDAP server.

Run License Usage report View current License usages.

Run Workflow Transaction 
Interface Report

Validates and runs Workflow transactions based on data in the 
Workflow open interface tables. Used to kick-off process steps from 
outside the end-user screens

Security Group Detail Report Lists the setup information for one or more Security Groups.

Special Command Detail Report This report lists details for a Special Command or a range of 
Special Commands.

Synchronize Meta Layer Report Assesses or synchronizes the Meta Layer.

User Data Detail Report Reports on the definition of each custom field. 

User Detail Report Lists the users defined in your Mercury ITG system as well as the 
Security Groups attached to each user.

Validation Report A System Administration report on the various custom Validations 
that your System Administrator has entered into the system or 
which come standard with the Mercury ITG Center.

VC - Check In Check a file into Version Control.

VC - Check Out Check a file out of Version Control.

VC - Diff Report Reporting the differenced between two files in the RCS repository.

Report Description
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Processing Reports
Mercury Change Management reports can be run either from the Workbench 
or the standard (HTML) interface. Similarly, previously run reports can be 
viewed from either interface. The following sections provide instructions for 
processing and viewing reports:

• Submitting a Report from the Workbench

• Submitting a Report from the HTML Interface

• Viewing Previously Submitted Reports

Submitting a Report from the Workbench
To submit a report from the Workbench: 

1. Click the Change Mgmt shortcut and click the Reports icon.

2. The Report Submission Workbench opens.

VC - Employee History Report History of the employee specified (i.e. what files the employee has 
touched).

VC - File Report History or status of the file specified.

VC - Lock Break Breaks a lock on a file.

VC - Locked Files report List of all locked files.

Workflow Detail Report Use this report to view the complete definition of a specific 
Workflow or a set of Workflows.

Workflow Statistics Report Uses a given date range and a Workflow (or a range of Workflows) 
to provide statistical information regarding the usage of the 
Workflow.

Report Description

All Report Types that end with ‘Report’ are textual reports that list details 
about specific entities. Report Types that end with ‘Program’ perform some 
activity and then report on their results.
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3. Click New Report. 

The New Report Submission window opens.

4. Select the type of report to submit from the Report Type auto-complete list.

After selecting the Report Type, report-specific parameters appear in the 
Parameters tab of the New Report Submission window. 

5. Fill in all the required parameters (as indicated by the red field label) and 
any optional parameters for the report.

6. Set up the schedule for running the report:

a. Click the Scheduling tab and specify when the report is to be run. If no 
scheduling information is entered, the report runs immediately.

b. Enter the frequency with which the report should be re-run.

7. Set up the Notification:

a. Click the Notifications tab. 

b. Click New. 

c. Select any users who should be informed of the report results. 

d. Click OK to close the Add Notification for Report Submission window.

8. Click Submit to run the report. 

9. Click View Report to view the results in your Web browser.

10. If the report fails, click View Log to view the technical details of the report 
execution.

You may not have access to all Report Types. If you need access to a Report 
Type, but do not see it listed, contact your administrator for permission. 
Change Management Reports 121



Processing Packages (Change Management)
Submitting a Report from the HTML Interface
Mercury Change Management reports can be run from the standard (HTML) 
interface. 

To run a report from the standard interface:

1. Logon to Mercury Change Management.

2. From the menu bar, select Reports > Package Reports. 

The Available Reports page opens.

3. Choose the report to be submitted from the list of Report Types by clicking 
on its name. 

The report’s creation page opens. 
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This example of a Report page shows the required and optional fields for 
the Package Details Report. Each Report Type has its own set of required 
and optional fields. The Report creation page always displays a different 
set of fields depending on which Report Type is selected.

4. Enter information in the Report creation page’s required fields.

5. (Optional) Enter information in the Report creation page’s optional fields.

6. Click Submit.

The Report Submitted page opens. The report’s output is displayed in a separate 
page.

Viewing Previously Submitted Reports
You can view previously submitted reports. This section discusses the 
following topics: 

• Viewing Reports from the Workbench

• Viewing Reports from the HTML Interface
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Viewing Reports from the Workbench
To view previously submitted reports:

1. Enter search criteria in the Query tab of the Reports Workbench.

2. Click Search. 

All matching report submissions are listed in the Results tab. 

3. Click Open to view the criteria used for the report.

4. Click View Report to view the report output.

Viewing Reports from the HTML Interface
To view a previously submitted report from the standard (HTML) 
interface:

1. Logon to Mercury Change Management.

2. Select Search > Reports. 

The Report Search page opens. 

You may not have permission to view all reports. If that is the case, contact 
your System Administrator to get permission for reports that are restricted by 
Security Groups. You may also not have access to any reports that are 
restricted to Creator only.

It is not possible to modify the values used for a previous report submission. 
However, it is possible to select a particular report submission on the Results 
tab of the Report Submissions Workbench and click Copy. This makes an exact 
duplicate of the report submission. The duplicate report submission can be 
modified and submitted.
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3. In the Search Information section, enter search criteria in the appropriate 
fields. 

4. Under Result Display Options, enter the maximum number of results to be 
displayed.

5. Click Search. 

The Report Search Results page opens. The page displays summary 
information about any reports that match your search criteria.

6. Click the Report Number under the Report # column to see the output 
details of any report.
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