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1 Installation Guide Overview

The Executive Scorecard Installation and ConfigurationGuide provides instructions for installing and

configuring Executive Scorecard on a single server.

Executive Scorecard Architecture
Figure 1: Executive Scorecard Architecture on page 9 shows the configuration of all of the components that

Executive Scorecard comprises.This guide details the installation and configuration of these components.

Table 1: Executive Scorecard Architecture Descriptions on page 10 lists the description for each of the

numbered items.

Figure 1: Executive Scorecard Architecture
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Table 1: Executive Scorecard Architecture Descriptions

Item Description

1 Source Databases: Executive Scorecard is configured out-of-box to use data from HP Business Service Management

8.00, HPDecisionCenter 2.0.xx, HP IT Analytics Financial Planning & Analysis 2.0.x, and HP Project and Portfolio

Management (PPM) 7.50. If you use PPM 8.00 or PPM 9.10, you can install Executive Scorecard 1.00 Hotfix 1

(XS1.00.001-HF1) to enable you to use the Executive Scorecard with PPM 8.00 or PPM 9.10.

2 The Executive Scorecard server.

3 Analytics Content Packs (BIAR files):

XD_CIO: Contains metadata and KPI reports for all four sources as well as the Executive Scorecard page analytics.

XD_BSM: Contains the universe and metric reports for the components that use Business Service Management

data.

XD_DC: Contains the universe and metric reports for the components that use DecisionCenter data.

XD_FPA: Contains the universe and metric reports for the components that use Financial Planning & Analysis data.

XD_PPM: Contains the universe and metric reports for the components that use Project and Portfolio Management

data.

4 SAP® BusinessObjects Enterprise XI 3.1 applications.

5 Executive Scorecard uses visual components from BusinessObjects Enterprise.

6 The Antivia Xcelsius Web Intelligence Integration Suite enables Executive Scorecard to retrieve data from the

BusinessObjects Enterprise server.

7 Antivia Xcelsius Web Intelligence Integration Suite applications.

8 The Executive Scorecard application.

9 Browser: Internet Explorer 7.

10 MSSQL Databases: Executive Scorecard database, BusinessObjects Enterprise CMS database, BusinessObjects

Enterprise Audit database, and Antivia Xcelsius Web Intelligence Integration Suite database.

11 Security: Lightweight Directory Access Protocol (LDAP) or Active Directory authentication.
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Installation Guide Chapter Overview
The table below summarizes the contents of each chapter.

Chapter Description

Getting Started on page 13 Overview of installation procedures.

Meet System Requirements on page 15 The hardware, server software, and client workstation requirements. Also lists

the supported data sources.

Generate a License on page 19 Information about how to obtain your Executive Scorecard license.

Configure Required Databases on page 20 The creation and configuration of the relational database management systems

that you need for Executive Scorecard.

Install and Configure Executive Scorecard

and Third Party Tools on page 30

How to install Executive Scorecard and use the Configuration Tool to install

and configure third party tools.

Complete Post-Installation Configurations

on page 38

How to configure authentication, create universe connections, and complete

other required configurations.

Component Reference Information on page

88

Details about what data source each Executive Scorecard component

references and the naming conventions for the components.

Installation Guide Chapter Overview 11





2 Getting Started

The Executive Scorecard installation package guides the installation and configuration of all the components

necessary to run the application successfully.

These are the processes to follow to install and configure Executive Scorecard:

1. Meet System Requirements on page 15

2. Generate a License on page 19

3. Configure RequiredDatabases on page 20

4. Install and Configure Executive Scorecard and Third Party Tools on page 30

5. Complete Post-Installation Configurations on page 38
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3 Meet System Requirements

Before you begin the Executive Scorecard installation, make sure your systemmeets the minimum

requirements for the following areas:

l Hardware Requirements on page 15

l Server Software Requirements on page 16

l ClientWorkstation Requirements on page 17

l Compatibility withOther HP Products on page 18

Hardware Requirements
These are the minimum hardware requirements for Executive Scorecard and the related components.

Item Minimum Requirement

RAM Application server: 8 GB

Xcelsius customization workstation: 4 GB

Virtual Memory Application server: 8 GB

Xcelsius customization workstation: 4 GB

Disk Space Application server: 13 GB

Xcelsius customization workstation: 1.25 GB

Java Heap Size The Java virtual machine on the server that hosts the Executive Scorecard application requires a heap

size of at least 1024 MB.

For example: -Xmx1024m -XX:MaxPermSize=256m

Note: You can install BusinessObjects Enterprise on an auxiliary disk drive; however, the installation process

still requires a minimum of 5 GB of temporary file space on the C drive. Verify that you have this free space

available.
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Server Software Requirements

Product Notes

Windows Server™ 2003 SP2 operating system - Obtain Microsoft Windows Server 2003 software and license keys

directly fromMicrosoft Corporation.

- Make sure service pack 2 is installed.

- Install the patches listed in Microsoft Patches on page 16.

Microsoft SQL Server 2005 SP2 - Supported driver (client): Microsoft SQL Server JDBC driver

1.2.2828 (sqljdbc-1.2.jar)

- Obtain Microsoft SQL Server 2005 Enterprise Edition software

and license keys directly fromMicrosoft Corporation.

- Make sure service pack 2 is installed.

SAP® BusinessObjects Enterprise XI 3.1 Fix Pack 1.2 Included on the Executive Scorecard installation media.

Java™ 2 SDK, Standard Edition 5.0, v 1.5.0_15 Included on the Executive Scorecard installation media. Installed

with BusinessObjects Enterprise.

Tomcat 5.5 Included on the Executive Scorecard installation media. Installed

with BusinessObjects Enterprise.

Antivia Xcelsius Web Intelligence Integration Suite Included on the Executive Scorecard installation media.

Adobe Reader 9 or higher Free download available from the Adobe web site:

www.adobe.com. (http://www.adobe.com).

Adobe Flash Player 10.0.45.2 or higher Free download available from the Adobe web site:

www.adobe.com. (http://www.adobe.com).

Note: A Microsoft SQL Server client is required on the machine that you run the Configuration Tool on.

Microsoft Patches
Install these Microsoft operating system patches before you begin the Executive Scorecard installation process.

l TheMicrosoft Windows Server 2003 (KB925336) patch. Available fromwww.microsoft.com.

(http://www.microsoft.com/downloads/details.aspx?FamilyId=8EFFE1D9-7224-4586-BE2B-

42C9AE5B9071&displaylang=en)

l Install the Microsoft Visual C++ 2005 SP1 Redistributable Package (x86) patch that contains Visual C++

Libraries runtime components. Available fromwww.microsoft.com.

(http://www.microsoft.com/downloads/details.aspx?FamilyID=200b2fd9-ae1a-4a14-984d-

389c36f85647&displaylang=en)

l Microsoft Core XML Services (MSXML) 6.0 Service Pack 1 (msxml6_x86.msi). Available from

www.microsoft.com.

(http://www.microsoft.com/downloads/

details.aspx?displaylang=en&FamilyID=d21c292c-368b-4ce1-9dab-3e9827b70604)

16 Chapter 3

http://www.adobe.com/
http://www.adobe.com/
http://www.microsoft.com/downloads/details.aspx?FamilyId=8EFFE1D9-7224-4586-BE2B-42C9AE5B9071&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=200b2fd9-ae1a-4a14-984d-389c36f85647&displaylang=en
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=d21c292c-368b-4ce1-9dab-3e9827b70604


Note: Microsoft Core XML Services (MSXML) 6.0 Service Pack 2 (msxml6-KB954459-enu-x86.exe) is

an optional security patch onMSXML 6.0 SP1. Available fromwww.microsoft.com.

(http://www.microsoft.com/downloads/details.aspx?FamilyId=59914795-60c7-4ebe-828d-

f28cb457e6e3&displaylang=en)

Client Workstation Requirements

Product Notes

Microsoft Windows Networked with Internet Explorer 7 browser.

Adobe Flash Player 10.0.45.2 or higher Free download available from the Adobe web site: www.adobe.com.

(http://www.adobe.com).

Microsoft Office XP Version 2003 or 2007. BusinessObjects Enterprise requires Microsoft

Excel.

JRE 5.0 Free download available from the Oracle web site: www.oracle.com.

(http://www.oracle.com).

Monitor Resolution The maximum resolution for viewing Executive Scorecard is 1440 x 1050.

If the resolution is set higher than 1440 x 1050, the component hover text

becomes truncated.

Client Workstation Requirements 17
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Compatibility with Other HP Products
Executive Scorecard is configured to use data from these four data sources:

l HPBusiness Service Management 8.00

l HPDecisionCenter 2.0.xx

l HP IT Analytics Financial Planning & Analysis 2.0.x

l HP Project and PortfolioManagement 7.50

Note: You can install Executive Scorecard 1.00 Hotfix 1 (XS1.00.001-HF1) to enable you to use the

Executive Scorecard with PPM 8.00 or PPM 9.10.

AlthoughExecutive Scorecard supports these sources out-of-box, you can customize the product to use your

own sources. Executive Scorecard components that use data from a source that you do not use will be

populated with sample data until you clean out the sample data or supply the related data from your own data

sources. For information about purging the sample data, see Step 1: Use the Clean All Data Utility on page 75.
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4 Generate a License

TheHP License Key Delivery Service web site (webware.hp.com) manages HP software licensing for

Executive Scorecard. You can download the latest version of theESD and Webware License Management Guide

from this site. The guide describes the process to obtain your entitlement certificate, which contains the HP

order number that you need to generate your permanent license keys.

Follow the steps in theESD and Webware License Management Guide to give your HP order number, select the

products that need licenses, and provide other required information. If you are a first time visitor to the web

site, you will be asked to create an account with an email address and password. Most requests to generate

permanent license keys require the following information:

l The Executive Scorecard product name and number shown on the product receipt or in the email sent by

HP to acknowledge the order.

l The order number from the entitlement certificate.

l A target server name and IP address.

l Contact information, such as company name, your name, fax and phone numbers, and license ownership

details.

Managing Permanent License Keys
After you create your user account on the HP License Key Delivery Service web site, generate the entitlement

certificate, and generate the license keys, the License Key Delivery Service sends permanent keys to you in an

email file attachment. When you receive the permanent license key file, save it in a convenient directory on the

server where you plan to install the Executive Scorecard. During the Executive Scorecard installation and

configuration, you will be prompted to install this license file.

If necessary, you can return to the HP License Key Delivery Service web site and retrieve the permanent

license keys again by selectingManage Licenses on the web site home page and logging into your account.
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5 Configure Required Databases

The supported relational database management system (RDBMS) is Microsoft SQL Server 2005. Verify that

you have a complete installation and configuration of the RDBMS server environment before you install the

Executive Scorecard components. You must create the required databases on the RDBMS server and define

OpenDatabase Connectivity (ODBC) connections to connect the Executive Scorecard application to the

databases.

Note: Although the databases in this sectionmust be MS SQL server databases, Executive Scorecard does

support data sources that are onOracle databases.

Complete these steps to configure the required databases:

l Step 1: Install Microsoft SQL Server 2005 SP2 on page 21

l Step 2: Set SQL Server Authentication Properties on page 21

l Step 3: Enable TCP/IP on page 21

l Step 4: Create the RequiredDatabases on page 22

l Step 5: Create ODBCConnections to the BOE Databases on page 27
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Step 1: Install Microsoft SQL Server 2005 SP2
Executive Scorecard uses the Microsoft SQL Server 2005 client with service pack 2 (SP2) as the relational

database management system (RDBMS).

If you use Microsoft SQL Server 2005, install SP2. You can download SP2 from the Microsoft Download

web site: http://www.microsoft.com/downloads/details.aspx?FamilyID=d09c1d60-a13c-4479-9b91-

9e8b9d835cdc&displaylang=en.

If you do not use Microsoft SQL Server 2005, you must purchase and install the product. Then upgrade to

SP2.

If you have already installedMicrosoft SQL Server 2005 SP2, proceed to Step 2: Set SQL Server

Authentication Properties on page 21.

Step 2: Set SQL Server Authentication Properties
1. From theWindows Start menu, click All Programs>Microsoft SQL Server 2005 > SQL Server

Management Studio.

2. Log in the with appropriate credentials.

3. In the Object Explorer, right-click the server name and select Properties.

4. Select the Security page in the left navigation pane.

5. Make sure SQL Server and Windows Authentication mode is selected.

Step 3: Enable TCP/IP
Enable Transmission Control Protocol (TCP)/Internet Protocol (IP) to permit communication between

computers and between the web browser and web server.

1. From theWindows Start menu, click All Programs>Microsoft SQL Server 2005 > Configuration

Tools> SQL Server Configuration Manager.

2. In the left navigation pane, click SQL Server 2005 Network Configuration to expand it, then select

Protocols for MSSQLSERVER.

3. In the right pane, make sure that the TCP/IP protocol is enabled. If necessary, right-click TCP/IP and

selectEnable.
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Step 4: Create the Required Databases
Executive Scorecard requires that you create four databases:

l A BusinessObjects Enterprise (BOE) Central Management Server (CMS) database, whichmanages

security, metadata, and content such as reports and universes. For more information about the CMS, see

the BusinessObjects EnterpriseAdministrator's Guide.

l A BOE Audit database, whichmonitors user actions and helps track andmanage your BOE deployment.

For more information about the Audit database, see the BusinessObjects EnterpriseAdministrator's Guide.

l AnExecutive Scorecard database, which stores the Executive Scorecard tables.

l AnAntivia XcelsiusWeb Intelligence Integration Suite (XWIS) database, which contains data such as

business intelligence system entries and XWIS license and user information.

Complete these tasks to create the required databases:

l Create the BOE CMSDatabase on page 23

l Create the BOE Audit Database on page 24

l Create the Executive Scorecard Database on page 25

l Create the Antivia XWIS Database on page 26

Follow the recommendations inGuidelines for Creating Databases on page 22 when you create the databases.

Guidelines for Creating Databases
Follow these guidelines when you create the required databases:

l Database names: RDBMS applications and BOE allow blank or empty database passwords. However,

Executive Scorecard does not support databases with blank or empty passwords.

HP recommends that you do not create database names with embedded spaces. Executive Scorecard

supports only alphanumeric characters and underscores in database names. You can use underscores or

camel case to create more descriptive names. For example, boecms can be boe_cms or boeCms, but avoid

“boe cms” with an embedded blank space. If database names have embedded blank spaces, dashes, or

other special characters, results may be unpredictable.

l Collation: When you define each required database, you must specify a collation that supports Unicode

nchar, nvarchar, and ntext column data types.

l Login names: Each database must have a different login name. Also, the loginmust be assigned the

appropriate roles so that the user has permission to create tables.

l Passwords: The ampersand special character (&), exclamation point (!), double quotationmark (“), single

quotationmark (‘), pipe (|), and carat (^) are not supported in a password. Underscores are valid.
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Create the BOE CMS Database
1. From theWindows Start menu, select Programs>Microsoft SQL Server 2005 > SQL Server

Management Studio.

2. Log in to SQL Server Management Studio.

3. SelectDatabases in the Object Explorer pane, right-click, and selectNew Database. The New Database

window opens.

4. On the General page, type the database name. Do not create a BOE CMS database with embedded blanks

or special characters in the database name.

Example: boecms

Invalid names: boe cms, boe@cms

5. ClickOptions to open the Options page.

6. Select SQL_Latin1_General_CP1_CI_AS from the Collation drop-down list. This collation type

supports Unicode nchar, nvarchar, and ntext column data types.

7. ClickOK.

8. In the Object Explorer pane, select the Security folder. This is the Security folder for the main server.

Right-click the folder, and selectNew> Login. The Login - New window opens.

9. On the General page, type the login name. You must create a different login name for the CMS, Audit,

Executive Scorecard, and XWIS databases.

10. Select SQL Server authentication.

11. In the Password field, type the password for the login name. Then retype the password in the Confirm

password field.

12. Clear theEnforce password policy,Enforce password expiration, andUser must change

password at next login check boxes.

13. Select the BOE CMS database name from the Default database drop-down list.

14. Click Server Roles to open the Server Roles page.

15. Select the public (if available) and sysadmin roles.

16. ClickUser Mapping to open the User Mapping page.

17. In the Users mapped to this login area, select the CMS database that you just created. The Users column

becomes populated with the login name that you created in step 8.

18. In the Default Schema column, click in the cell to the right of the User column, and type the same value that

appears in the User column.

19. PressEnter.

20. In the Database role membership for area, select db_owner. Alsomake sure public is selected.

21. ClickOK.
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For information about additional database and security settings, refer to the Microsoft SQL Server

documentation.

Create the BOE Audit Database
1. From theWindows Start menu, select Programs>Microsoft SQL Server 2005 > SQL Server

Management Studio.

2. Log in to SQL Server Management Studio.

3. SelectDatabases in the Object Explorer pane, right-click, and selectNew Database. The New Database

window opens.

4. On the General page, type the database name. Do not create a BOE Audit database with embedded blanks

or special characters in the database name.

Example: boeaudit

Invalid names: boe audit, boe@audit

5. ClickOptions to open the Options page.

6. Select SQL_Latin1_General_CP1_CI_AS from the Collation drop-down list. This collation type

supports Unicode nchar, nvarchar, and ntext column data types.

7. ClickOK.

8. Select Security in the Object Explorer pane, right-click, and selectNew> Login. The Login - New

window opens.

9. On the General page, type the login name. You must create a different login name for the CMS, Audit,

Executive Scorecard, and XWIS databases.

10. Select SQL Server authentication.

11. In the Password field, type the password for the login name. Then retype the password in the Confirm

password field.

12. Select the BOE Audit database name from the Default database drop-down list.

13. Click Server Roles to open the Server Roles page.

14. Select the public and sysadmin roles.

15. ClickUser Mapping to open the User Mapping page.

16. In the Users mapped to this login area, select the Audit database that you just created. The Users column

becomes populated with the login name that you created in step 8.

17. In the Default Schema column, click in the cell to the right of the User column, and type the same value that

appears in the User column.

18. PressEnter.

19. In the Database role membership for area, select db_owner. Alsomake sure public is selected.

20. ClickOK.
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For information about additional database and security settings, refer to the Microsoft SQL Server

documentation.

Create the Executive Scorecard Database
1. From theWindows Start menu, select Programs>Microsoft SQL Server 2005 > SQL Server

Management Studio.

2. Log in to SQL Server Management Studio.

3. SelectDatabases in the Object Explorer pane, right-click, and selectNew Database. The New Database

window opens.

4. On the General page, type the database name. Do not create an Executive Scorecard database with

embedded blanks or special characters in the database name.

Example: executivescorecard

Invalid names: executive scorecard, executive@scorecard

5. ClickOptions to open the Options page.

6. Select SQL_Latin1_General_CP1_CI_AS from the Collation drop-down list. This collation type

supports Unicode nchar, nvarchar, and ntext column data types.

7. ClickOK.

8. Select Security in the Object Explorer pane, right-click, and selectNew> Login. The Login - New

window opens.

9. On the General page, type the login name. You must create a different login name for the CMS, Audit,

Executive Scorecard, and XWIS databases.

10. Select SQL Server authentication.

11. In the Password field, type the password for the login name. Then retype the password in the Confirm

password field.

12. Select the Executive Scorecard database name from the Default database drop-down list.

13. Click Server Roles to open the Server Roles page.

14. Select the public and sysadmin roles.

15. ClickUser Mapping to open the User Mapping page.

16. In the Users mapped to this login area, select the Executive Scorecard database that you just created. The

Users column becomes populated with the login name that you created in step 8.

17. In the Default Schema column, click in the cell to the right of the User column, and type the same value that

appears in the User column.

18. PressEnter.

19. In the Database role membership for area, select db_owner. Alsomake sure public is selected.

20. ClickOK.
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For information about additional database and security settings, refer to the Microsoft SQL Server

documentation.

Create the Antivia XWIS Database
1. From theWindows Start menu, select Programs>Microsoft SQL Server 2005 > SQL Server

Management Studio.

2. Log in to SQL Server Management Studio.

3. SelectDatabases in the Object Explorer pane, right-click, and selectNew Database. The New Database

window opens.

4. On the General page, type the database name. Do not create a BOE Audit database with embedded blanks

or special characters in the database name.

Example: antiviaxwis

Invalid names: antivia xwis, antivia@xwis

5. ClickOptions to open the Options page.

6. Select SQL_Latin1_General_CP1_CI_AS from the Collation drop-down list. This collation type

supports Unicode nchar, nvarchar, and ntext column data types.

7. ClickOK.

8. Select Security in the Object Explorer pane, right-click, and selectNew> Login. The Login - New

window opens.

9. On the General page, type the login name. You must create a different login name for the CMS, Audit,

Executive Scorecard, and XWIS databases.

10. Select SQL Server authentication.

11. In the Password field, type the password for the login name. Then retype the password in the Confirm

password field.

12. Select the XWIS database name from the Default database drop-down list.

13. Click Server Roles to open the Server Roles page.

14. Select the public and sysadmin roles.

15. ClickUser Mapping to open the User Mapping page.

16. In the Users mapped to this login area, select the XWIS database that you just created. The Users column

becomes populated with the login name that you created in step 8.

17. In the Default Schema column, click in the cell to the right of the User column, and type the same value that

appears in the User column.

18. PressEnter.

19. In the Database role membership for area, select db_owner. Alsomake sure public is selected.

20. ClickOK.

Create the Antivia XWIS Database 26



For information about additional database and security settings, refer to the Microsoft SQL Server

documentation.

Step 5: Create ODBC Connections to the BOE Databases
Use theWindowsODBCData Source Administrator wizard to create the OpenDatabase Connectivity

(ODBC) connections for the BusinessObjects Enterprise (BOE) databases that you created in Step 4: Create

the RequiredDatabases on page 22. You do not need to create ODBC connections to the Executive

Scorecard and XWIS databases. The Executive Scorecard Configuration Tool will create the ODBC

connections to those databases.

l Step 5a: Create anODBCConnection to the BOE CMSDatabase on page 27

l Step 5b: Create anODBCConnection to the BOE Audit Database on page 28

Step 5a: Create an ODBC Connection to the BOE CMS Database
Youmust create anODBC connection to the BOE Central Management Server (CMS) database that you

created in Create the BOE CMSDatabase on page 23.

1. Open theWindowsODBCData Source Administrator wizard. From theWindows Start menu, select

Control Panel > Administrative Tools>Data Sources (ODBC).

2. Click the System DSN tab.

3. Click Add.

4. Select SQL Server from the list of drivers.

5. Click Finish.

6. Type the data source name (DSN) in the Name field.

For example: boecms_dsn

7. Type a description of the data source in the Description field.

For example: DSN for the BOE CMS database

8. From the Server drop-down list, select (local). If SQL Server is on a different server, select that server.

9. ClickNext.

10. Select the SQL Server authentication option.

11. Make sureConnect to SQL Server to obtain default settings for the additional configuration

options is selected.

12. Type the SQL Server Login ID and Password.

13. ClickNext.

14. ClickNext, then click Finish. Review the configuration information on the ODBCMicrosoft SQL Server

Setup window.

15. Click Test Data Source tomake sure the ODBC connection can be established.

16. ClickOK, then clickOK again.
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Step 5b: Create an ODBC Connection to the BOE Audit Database
Youmust create anODBC connection to the BOE Audit database that you created in Create the BOE Audit

Database on page 24.

1. Open theWindowsODBCData Source Administrator wizard. From theWindows Start menu, select

Control Panel > Administrative Tools>Data Sources (ODBC).

2. Click the System DSN tab.

3. Click Add.

4. Select SQL Server from the list of drivers.

5. Click Finish.

6. Type the data source name (DSN) in the Name field.

For example: boeaudit_dsn

7. Type a description of the data source in the Description field.

For example: DSN for the BOE Audit database

8. From the Server drop-down list, select (local). If SQL Server is on a different server, select that server.

9. ClickNext.

10. Select the SQL Server authentication option.

11. Make sureConnect to SQL Server to obtain default settings for the additional configuration

options is selected.

12. Type the SQL Server Login ID and Password.

13. ClickNext.

14. ClickNext, then click Finish. Review the configuration information on the ODBCMicrosoft SQL Server

Setup window.

15. Click Test Data Source tomake sure the ODBC connection can be established.

16. ClickOK, then clickOK again.
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6 Install and Configure Executive Scorecard and
Third Party Tools

The Executive Scorecard installer is self-directing with embedded instructions. There are two installation tools:

the installer, which builds the directory structure and positions the files for configuration, and the

Configuration Tool, which collects relevant information and configures the associated applications.

Installation Media

The installationmedia consolidates all of the required components into twoDVDs. DVD 1, labeled HP

Executive Scorecard 1.00 Installation, contains all of the installation files for Executive Scorecard, SAP®

BusinessObjects Enterprise, and the Antivia XcelsiusWeb Intelligence Integration Suite. Use this DVD to

complete steps 1 – 6.

DVD 2, labeled DashboardDevelopment Kit, contains the installation files for the SAP BusinessObjects

Xcelsius Engage Server. You will use the DVD 2 installationmedia and theWindows command line to

complete step 7. Copy the contents of DVD 2 to your hard drive to install Xcelsius.

To install Executive Scorecard, complete the following steps.

l Step 1: Install Executive Scorecard on page 31

l Step 2: Import the License File on page 31

l Step 3: Install and Configure SAP BusinessObjects Enterprise on page 31

l Step 4: Configure Your Data Sources on page 33

l Step 5: Set Up the Executive Scorecard Database Connection on page 35

l Step 6: Install and Configure Antivia XWIS on page 35

l Step 7: Install Xcelsius and the Xcelsius XWIS Add-On on page 36
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Step 1: Install Executive Scorecard
Before you start the installation process, make sure that you completed the steps to acquire the license keys file

fromHP and have placed the license file on the server. For more information, see Generate a License on page

19.

HP recommends that you use a DVD drive that is local to the machine that you want to install Executive

Scorecard on. You can also copy the files from the installationmedia to a directory on that machine. HP also

recommends that you use the default installation path for Executive Scorecard. The default path is

C:\Program Files\HP\Executive Scorecard.

Note: Make sure that a Microsoft SQL Server client is installed on the machine that you run the Configuration

Tool on.

To install Executive Scorecard

1. Double-clickHP_Executive_Scorecard_100.msi.

2. Follow the prompts. The installer builds the directory structure on the server and stages the files for final

installation in the specified path.

3. Click Finish. The Configuration Tool opens and prompts you to import the license file. If the

Configuration Tool does not open automatically, you can open it manually: from theWindows Start menu,

click Programs>HP Executive Scorecard> Configuration Tool.

Step 2: Import the License File
1. On the License Management screen, click Browse, and navigate to the location of the license file that you

acquired inGenerate a License on page 19.

2. Select the license file and clickOpen.

3. Click Import License.

4. ClickOK. The Configuration Tool validates the license.

5. ClickMain Menu.

Step 3: Install and Configure SAP BusinessObjects Enterprise
To install and configure SAP® BusinessObjects Enterprise XI 3.1 (BOE), designate the BOE installation

directory and set up connections to the Central Management Server (CMS) database and the Audit database.

Note: You can install BOE on an auxiliary disk drive; however, the installation process still requires a

minimum of 5 GB of temporary file space on the C drive. Verify that you have this free space available.
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Step 3a: Designate the BOE Installation Directory
1. From the Configuration Tool mainmenu, click 1 Configure SAP BusinessObjects Enterprise Server.

2. On the Install Directory tab, click Browse and select the directory where you want to install BOE. If

necessary, you can click the folder icon in the Openwindow and create a new folder. Follow these rules

when you designate the installation directory:

n Donot nest the BOE installation inside the Executive Scorecard directory.

n Make sure the directory path does not exceed 39 characters. Avoid all special characters in paths except

underscores (_), periods (.), back slashes (\), and blanks.

3. ClickOpen.

4. ClickNext to go to the CMSDatabase tab and set up the connection to the BOE CMS database.

Step 3b: Set Up the CMS Database Connection
On the CMSDatabase tab, designate the BOE Central Management Server (CMS) that the BOE repository

will map to.

1. Provide the following details. Use the information that you entered when you created the CMS database in

Create the BOE CMSDatabase on page 23.

n ODBC data source name: Type the OpenDatabase Connectivity (ODBC) data source name of the

CMS.

n Database name: Type the name of the CMS database.

n Login: Type the name that you use to log in to the CMS database.

n Password: Type the password that you use to access the CMS.

n Confirm password: Retype the password.

2. Click Verify Connection to test if Executive Scorecard can connect to the CMS database.

3. ClickNext to go to the Audit Database tab and set up the connection to the BOE Audit database.

Step 3c: Set Up the Audit Database Connection
On the Audit Database tab, designate the BOE Audit database that the BOE repository will map to. Though

you can store audit information in the CMS database, for improved performance, HP recommends that you

use separate databases.

1. Provide the following details. Use the information that you entered when you created the Audit database in

Create the BOE Audit Database on page 24.

n ODBC data source name: Type the ODBC data source name of the Audit database.

n Database name: Type the name of the Audit database.

n Login: Type the name that you use to log in to the Audit database.
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n Password: Type the password that you use to access the Audit database.

n Confirm password: Retype the password.

2. Click Verify Connection to test if Executive Scorecard can connect to the Audit database.

3. ClickNext to go to the Review tab to review your BOE installation and configuration settings and

complete the configuration.

If you want the Audit database to use the same database as the CMS database, selectUse the same database

as the CMS. However, to improve performance, HP recommends that you keep these databases separate.

Step 3d: Review Your Settings and Complete the BOE Configuration
On the Review tab, review the settings that you entered for the BOE installation directory and the CMS and

Audit databases.

1. Review your settings for the BOE installation directory and the CMS and Audit databases. If you receive

errors or need tomake changes, click the appropriate tab, make the changes, and then return to the Review

tab to complete the BOE configuration.

2. Click Run Configuration. The Configuration Tool extracts the BOE files, creates the installation

directory, and installs and configures the appropriate files.

3. ClickMain Menu to return to the Configuration Tool mainmenu.

Step 4: Configure Your Data Sources
To configure data sources, select the data sources that you use, then enter the configuration details for each

source that you selected.

Step 4a: Select Data Sources
1. From the Configuration Tool mainmenu, click 2 Configure Data Sources.

2. On the Select Data Sources tab, select the data source or sources that you use.

3. ClickNext to go to the Configure Data Sources tab and configure Executive Scorecard to use each data

source that you selected.

Step 4b: Configure Data Sources
On the Configure Data Sources tab, configure each of the data sources that you selected on the Select Data

Sources tab. The list of data sources that are available to configure is based on the sources that you selected.

The Configuration Tool creates the OBDC data source names for your sources. This name is predefined and

cannot be changed.
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1. Make sure that the BusinessObjects Enterprise (BOE) Server Intelligence Agent service is running. If you

just installed and configured BOE (step 1 in the Configuration Tool), this service is running. However, if

you installed and configured BOE at an earlier time, this service may be stopped.

To check the status of the service:

a. From theWindows Start menu, select Programs> Business Objects XI 3.1 > BusinessObjects

Enterprise > Central Configuration Manager.

b. In the Display Name column in the Central ConfigurationManager, locate the Server Intelligence

Agent (ExecutiveScorecard) service.

c. View the Status column for this service. If the Status is Running, close the Central Configuration

Manager. If the service is stopped, right-click the service and select Start. Then close the Central

ConfigurationManager.

2. From the Configuration Tool mainmenu, click 2 Configure Data Sources.

3. From the Data source name drop-down list, select the data source that you want to configure. The

Configuration Tool displays the OBDC data source name for the source that you selected. The OBDC data

source name is predefined and cannot be changed.

Note: If you use PPM 8.00 or 9.10, select Project and Portfolio Management 7.50 for the data source

name. After you install and configure the Executive Scorecard, follow the instructions provided with

XS1.00.001-HF1 to install Hotfix 1 and reconfigure Executive Scorecard to use data from PPM 8.00 or

9.10.

4. Select the type of database that the source uses.

n If you chose Oracle for the database type, provide these details:

o Oracle JDBC library location: Type the Oracle Java Database Connectivity (JDBC) library location or

click Browse to navigate to the location.

o Connection name: Type the connection name for the data source.

o Login: Type the name that you use to log in to the data source.

o Password: Type the password that you use to access the data source.

o Confirm password: Retype the password.

n If you chose SQL Server for the database type, provide these details:

o Server name: Type the name of the server that the data source is on.

o Database name: Type the data source database name.

o Login: Type the name that you use to log in to the data source.

o Password: Type the password that you use to access the data source.

o Confirm password: Retype the password.

5. Click Verify Connection to test if Executive Scorecard can connect to the source database.

6. If you selected additional data sources, complete steps 1 - 3 for each source that you selected on the Select

Data Sources tab.
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7. ClickNext to go to the Review tab to review your data source configuration settings and complete the

configuration.

Step 4c: Review Your Settings and Complete the Data Source Configuration
1. Review your settings for the selected data sources. If you receive errors or need tomake changes, click the

appropriate tab, make the changes, and then return to the Review tab to complete the data source

configuration.

2. Click Run Configuration. The Configuration Tool creates the SQL Server ODBCDSN connections for

your data sources and deploys the data integration packages for all four supported data sources. These data

integration packages contain sample data so that you can view all of the Executive Scorecard features

regardless of the data sources you have. You can use the import clean data utility to purge the sample data

for each source. However, HP recommends that you do not purge the sample data until you are ready to

move to a production environment and enable other users to use Executive Scorecard. For information

about the import clean data utility, see Step 1: Use the Clean All Data Utility on page 75.

3. ClickMain Menu to return to the Configuration Tool mainmenu.

Step 5: Set Up the Executive Scorecard Database Connection
To configure the web application, set up the connection to the Executive Scorecard database that you created

in Create the Executive Scorecard Database on page 25.

1. From the Configuration Tool mainmenu, click 3 Configure Web Application.

2. On the Executive Scorecard Application tab, provide these details:

n Database server: Type the name of the server that the Executive Scorecard database is on.

n Database name: Type the name of the Executive Scorecard database.

n Login: Type the name that you use to log in to the Executive Scorecard database.

n Password: Type the password that you use to access the Executive Scorecard database.

n Confirm Password: Retype the password that you use to access the Executive Scorecard database.

3. Click Run Configuration.

Step 6: Install and Configure Antivia XWIS
To install and configure Antivia XcelsiusWeb Intelligence Integration Suite (XWIS), set up connections to the

XWIS database. When you configure the database, use the information you entered when you created the

database in Create the Antivia XWIS Database on page 26.

Step 6a: Set Up the XWIS Database Connection
On the XWIS tab, designate the BOE Central Management Server (CMS) that the BOE repository will map

to.
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1. Stop the Tomcat service:

a. From theWindows Start menu, click Programs> BusinessObjects XI 3.1 > BusinessObjects

Enterprise > Central Configuration Manager.

b. Right-click the Apache Tomcat service and select Stop.

2. From the Configuration Tool mainmenu, click Configure XWIS.

3.  On the XWIS tab, provide these details:

n Server name: Type the name of the server that the XWIS database is on.

n Database name: Type the name of the XWIS database.

n Login: Type the name that you use to log in to the XWIS database.

n Password: Type the password that you use to access the XWIS database.

n Confirm password: Retype the password.

4. Click Verify Connection to test if Executive Scorecard can connect to the XWIS database.

5. ClickNext to review your Antivia XWIS installation and configuration settings and complete the

configuration.

Step 6b: Review Your Settings and Complete the XWIS Configuration
1. On the Review tab, review your settings for the XWIS database. If you receive errors or need tomake

changes, click the appropriate tab, make the changes, and then return to the Review tab to complete the

XWIS configuration.

2. Click Run Configuration. The Configuration tool installs and configures Antivia XWIS and populates the

XWIS database.

Note: Several exceptions will appear in the Config log file after the configuration. The error messages are

expected and indicate that the XWIS database has been populated for the first time.

3. ClickMain Menu to return to the Configuration Tool mainmenu.

4. Delete all of the contents in the Tomcat work folder:

<BOE installation directory>\Tomcat55\work\

5. Restart the Tomcat service:

a. From theWindows Start menu, click Programs> BusinessObjects XI 3.1 > BusinessObjects

Enterprise > Central Configuration Manager.

b. Right-click the Apache Tomcat service and select Start.

Step 7: Install Xcelsius and the Xcelsius XWIS Add-On
To enable you to customize Executive Scorecard components or configure Executive Scorecard to use

custom data sources, you must install SAP BusinessObjects Xcelsius Engage Server (BOXES) on a client

workstation that hasMicrosoft Excel and Adobe Flash Player 10.0.45.2 installed. BOXES is provided on

DVD 2 of the Executive Scorecard installationmedia. Copy the contents of DVD 2 onto your hard drive, and

then install BOXES from your hard drive using the Windows command line. Also install the Antivia XWIS
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Xcelsius add-on to enable Executive Scorecard to retrieve data from the BOE server.

Step 7a: Install Xcelsius
1. Open a Windows command line window.

2. Change the current directory to the ..\Setup\BO Installers\xcelsius directory that is in the folder for the

DVD 2 contents that you copied to your hard drive:

3. Type this command:

install-xcelsiusSP3.bat -installdir
Where the installdir value is the directory path where you want to install Xcelsius. For example:

install-xcelsiusSP3.bat -installdir "C:\Program
Files\HP\BO\xcelsius\"
Note: If other BOE applications exist on the host server where you want to install BOXES, BOXES

installs in the same directory as BOE, regardless of the -installdir specification.

4. PressEnter. After the Xcelsius installation completes, your systemmay restart.

Step 7b: Install the Xcelsius XWIS Add-On
Install the Antivia XcelsiusWeb Intelligence Integration Suite for HPOEM add-on to enable Executive

Scorecard to retrieve data from the BOE server.

1. Download the add-on from the XWIS web application. To do so, openWindows Internet Explorer and

type the address of the XWIS application.

For example: http://xd1.americas.hpqcorp.net:8080/xwis-webapp

2. From the Components list on the web application getting started window, clickDownload antivia-xwis

XLX.

3. Navigate to the location on your computer where you want to save the file, and click Save. Antivia saves

the file to your computer as a .zip file.

4. Change the extension of the file to .xlx. Replace zipwith xlx.

5. OpenXcelsius. From the File menu, selectManage Add-Ons to open the Xcelsius Add-OnManager.

6. Click Install Add-On, navigate to the location of the antivia-xwis.xlx file you saved in step 4, and double-

click it. Xcelsius installs the add-on. When the add-on is successfully installed,Antivia Xcelsius Web

Intelligence Integration Suite for HP OEM appears in the Xcelsius Add-OnManager window.

7. Click Close to close the Add-OnManager.

8. Close the XWIS application. XWIS prompts you to save your new untitled file.

9. ClickNo.
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7 Complete Post-Installation Configurations

Follow the instructions in these steps to configure Executive Scorecard:

1. Configure User Roles and Authentication on page 39

2. Change Connection Properties in the BOE Central Management Console on page 61

3. Run the BSM andDCView Scripts on page 63

4. Change Session Time Out Parameters on page 64

5. Modify Universes on page 66

6. (BSMUsers) Create the BSM Service Health Page on page 71

7. Configure Single SignOn on page 73

8. Launch Executive Scorecard on page 75

9. Clear the Sample Data on page 75

10. (Users without FPA)Modify the Last Refresh Reports on page 77

11. Schedule Reports to Refresh on page 80

12. (DCUsers) Populate Dates in Service KPI Trend when BSM is Not Available on page 84

13. Customize the Components on page 86
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Configure User Roles and Authentication
The Executive Scorecard security model uses a predefined access level and security role. The Authentication

process involves the Executive Scorecard application and BusinessObjects Enterprise (BOE). The

authentication process consists of these steps:

1. Executive Scorecard passes the user name and password to the authentication source (LDAP or AD). This

step uses the applicationContext.xml file.

2. The authentication source replies with the user name and attribute details.

3. Executive Scorecard passes the information received in Step 2 to BOE. This action starts the second phase

of the authentication process and references the web.xml file.

4. BOE queries the authentication source with the user name and password.

5. BOE receives authorization from the authentication source.

6. BOE passes a session ID to the Executive Scorecard application.

Executive Scorecard supports Lightweight Directory Access Protocol (LDAP) or Windows Active Directory

(AD) authentication.

File-based security is configured out-of-box as a quick way to set up authentication for proof-of-concept,

demo, or prototype installations. However, file-based authentication should not be used in a production

environment.

l If your authentication source is LDAP, follow the instructions in Configure LDAPAuthentication on page

40 to configure LDAP authentication.

l If your authentication source is AD, follow the instructions in Configure Active Directory Authentication

on page 48 to configure AD authentication.

l If you want to configure simple, temporary authentication, see Configure File-Based Authentication on

page 57.
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Configure LDAP Authentication
Complete the following processes to configure LDAP authentication for Executive Scorecard and SAP

BusinessObjects Enterprise. Before you define and enable LDAP authentication, create an LDAP server and

make sure that your LDAP directory is valid. For more information, see your LDAP documentation.

l Step 1: Create the LDAP applicationContext.xml File on page 40

l Step 2: Add the XD_CIOUser Group to Your LDAP Server on page 40

l Step 3: Configure LDAP on the BOE Central Management Console on page 41

l Step 4: Add the XD_CIOUser Group to the BOE Central Management Console on page 42

l Step 5: Modify the BusinessObjects web.xml File on page 42

l Step 6: Test BOE Central Management Console LDAPUser Access on page 42

l Step 7: Modify the Executive Scorecard web.xml File for LDAPAuthentication on page 43

l Step 8: Modify the LDAP applicationContext.xml File on page 43

l Step 9: Test LDAP BOE InfoView Access on page 45

l Step 10: Configure BOE Access Rights on page 45

l Step 11: Test LDAPAuthentication with Executive Scorecard on page 46

Step 1: Create the LDAP applicationContext.xml File

Because Executive Scorecard enables you to use LDAP, AD, or file-based authentication, you must designate

the type of authentication you are using by making the appropriate applicationContext.xml file active. Out-of-

box, the applicationContext.xml file for file-based authentication is the active file.

To create the LDAP applicationContext.xml file

1. Navigate to this directory:

C:\Program Files\HP\Executive Scorecard\WebApplications\executiveScorecard\WEB-INF

2. Find applicationContext.xml. This is the active file-based authentication file.

3. Rename this file tomake it a backup file. For example, name it applicationContext.xml_filebased.

4. Find applicationContext.xml_ldap.

5. Rename this file to applicationContext.xml. The applicationContext.xml file for LDAP becomes the

active authentication file.

Step 2: Add the XD_CIO User Group to Your LDAP Server

Add the following Executive Scorecard group to the LDAP server before you make configuration changes to

BusinessObjects Enterprise.

XD_CIO: This role enables access to the Executive Scorecard application.

For instructions on adding user groups to LDAP, see your LDAP documentation.

Notes:
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l The Executive Scorecard security framework prefixes XD_CIOwith ROLE_ so that the group becomes

ROLE_XD_CIO for Executive Scorecard.

l Changes to group names require changes to both the web.xml file and the LDAP server.

Step 3: Configure LDAP on the BOE Central Management Console

1. From theWindows Start menu, click Programs> BusinessObjects XI 3.1 > BusinessObjects

Enterprise > BusinessObjects Enterprise Central Management Console.

2. Log in to the Central Management Console as an administrator.

3. Click Authentication, then click the LDAP tab.

4. Click Start LDAP Configuration Wizard.

5. In the Add LDAPHost (hostname: port) field, type your host and port information.

6. Click Add.

7. ClickNext.

8. In the LDAP Server Type drop-down list, select your LDAP server, and clickNext.

9. In the Base LDAPDistinguishedName field, type the distinguished name, and clickNext.

10. Type the LDAP host credentials:

n LDAP Server Administration Credentials: Type the distinguished name and password for a user account

that has rights to administer your LDAP server.

n LDAP Referral Credentials: Type the same distinguished name and password you entered for LDAP

Server Administration Credentials.

11. In the MaximumReferral Hops field, type the number of referral hops to limit forwarding the credential

request. If you set this field to zero, no referral hops are allowed.

12. ClickNext.

13. From the Type of SSL authentication drop-down list, selectBasic (no SSL) and clickNext.

14. From the Authentication drop-down list, selectBasic (no SSO) and clickNext.

15. Select the following LDAP options:

n Create a new account for every added LDAP alias

n Create new aliases only when the user logs on

n New users are created as named users

16.  ClickNext.

17. Click Finish.
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Step 4: Add the XD_CIO User Group to the BOE Central Management Console

1. Click Start > Programs> BusinessObjects XI 3.1 > BusinessObjects Enterprise >

BusinessObjects Enterprise Central Management Console.

2. Log in to the Central Management Console as an administrator.

3. Click Authentication, then click the LDAP tab.

4. InMapped LDAPMember Groups, add theXD_CIO group to the Add LDAP group (by cn or dn) field.

5. Click Add.

6. ClickUpdate.

7. Log out of BOE Central Management Console.

Step 5: Modify the BusinessObjects web.xml File

Change the web.xml file for the BusinessObjects InfoView application so that BOE can retrieve the login

options.

1. Openweb.xml with a text editor. The file is in:

<BOE installation directory>\Tomcat55\webapps\InfoViewApp\WEB-INF

2. Set the authentication visible parameter to true.

For example:

<context-param>
<param-name>authentication.visible</param-name>
<param-value>true</param-value>

</context-param>

3. Save and close web.xml.

Step 6: Test BOE Central Management Console LDAP User Access

1. Click Start > Programs> BusinessObjects XI 3.1 > BusinessObjects Enterprise >

BusinessObjects Enterprise Central Management Console.

2. Type the username and password for an Active Directory user.

3. From the Authentication drop-down list, selectLDAP. Navigation items are not available because the

LDAP groups do not have rights.

If the login fails, repeat the steps in Step 3: Configure LDAP on the BOE Central Management Console on

page 41 and Step 4: Add the XD_CIOUser Group to the BOE Central Management Console on page 42.

Step 4: Add the XD_CIOUser Group to the BOE Central Management

Console
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Step 7: Modify the Executive Scorecard web.xml File for LDAP Authentication

1. Stop the Tomcat service:

a. From theWindows Start menu, click Programs> BusinessObjects XI 3.1 > BusinessObjects

Enterprise > Central Configuration Manager.

b. Right-click the Apache Tomcat service and select Stop.

2. Openweb.xml with a text editor.

The file is in: C:\Program Files\HP\Executive Scorecard\WebApplications\executiveScorecard\WEB-

INF

3. Locate the biAuthType parameter section.

4. Change the parameter value to secLDAP.

<context-param>
<param-name>biAuthType</param-name>
<param-value>secLDAP</param-value>

</context-param>

5. Save and close web.xml.

Step 8: Modify the LDAP applicationContext.xml File

1. Open applicationContext.xml with a text editor. The file is in:

C:\Program Files\HP\Executive Scorecard\WebApplications\executiveScorecard\WEB-INF

2. In the initialDirContextFactory bean, locate the following properties andmake the necessary changes:

n constructor-arg value: Change this element value to the LDAP server and port. For example:

<constructor-arg
value="ldap://myldapserver.secure.mycompany.com:
389/dc=secure,dc=mycompany,dc=com"/>

n managerDn: Change this property value to the LDAP administrator:

For example:

<property name="managerDn">
<value>cn=Directory Manager</value>

</property>

n managerPassword: Change this property value to the LDAP administrator password. For example:

<property name="managerPassword">
<value>Password123</value>

</property>

3. In the authenticator bean, locate the userDnPatterns property. Use this property to specify all of the paths

used to locate the users in your LDAP database who need access to Executive Scorecard. The value is the

unique attribute of the user and the Organizational Unit that the user is in. List all of the possible search

paths. For example:

<property name="userDnPatterns">
<list>
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<value>uid={0},ou=People</value>
<value>uid={0},ou=contractors,ou=People</value>
<value>uid={0},ou=managers,ou=People</value>
<value>uid={0},ou=parttime,ou=employees,
ou=People</value>
<value>uid={0},ou=fulltime,ou=employees,
ou=People</value>
</list>

</property>

4. In the userSearch bean, locate the following properties andmake the necessary changes:

n In the value for the first constructor-arg element, type the folder path within the LDAP server where

users are located. For example:

<constructor-arg>
<value>ou=People,dc=labs,dc=hp,dc=com</value>

</constructor-arg>

n In the value for the second constructor-arg element, type the LDAP attribute that will be used to locate

the user. For example:

<constructor-arg>
<value>(uid={0})</value>

</constructor-arg>

n In the searchSubtree property, type true if the users are located on several levels under the tree. If the

value is not true, Executive Scorecard will not search through the tree.

5. In the populator bean, locate the following properties andmake the necessary changes:

n In the second constructor-arg element, add group information. For example:

<constructor-arg>
<value>ou=Groups</value>

</constructor-arg>

n groupRoleAttribute: Type the attribute that is used to identify the group. For example:

<property name="groupRoleAttribute">
<value>cn_</value>

</property>

n groupSearchFilter: Type the attribute in the LDAP server that defines the members of the group. For

example:

<property name="groupSearchFilter">
<value>uniqueMember={0}</value>

</property>

n In the searchSubtree property, type true if the users are located on several levels under the tree. If the

value is not true, Executive Scorecard will not search through the tree.

6. Save and close applicationContext.xml.

7. Delete all of the contents in the Tomcat work folder:

<BOE installation directory>\Tomcat55\work\
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8. Restart the Tomcat service:

a. From theWindows Start menu, click Programs> BusinessObjects XI 3.1 > BusinessObjects

Enterprise > Central Configuration Manager.

b. Right-click the Apache Tomcat service and select Start.

Step 9: Test LDAP BOE InfoView Access

1. From theWindows Start menu, click Programs> BusinessObjects XI 3.1 > BusinessObjects

Enterprise > BusinessObjects Enterprise Java InfoView.

2. Log in to InfoView with the same username and password that you used to log in to the BOE Central

Management Console in Step 6: Test BOE Central Management Console LDAPUser Access on page 42.

3. From the Authentication drop-down list, selectLDAP.

If the login fails, repeat these steps:

l Step 3: Configure LDAP on the BOE Central Management Console on page 41

l Step 4: Add the XD_CIOUser Group to the BOE Central Management Console on page 42

Step 10: Configure BOE Access Rights

Youmust enable the Executive Scorecard group to view or edit the contents of a BusinessObjects Enterprise

(BOE) folder. To configure BOE access rights, assign access to the Executive Scorecard folders, then enable

access to the Root folder.

Assign Access to the Executive Scorecard Folders

1. From theWindows Start menu, click Programs> BusinessObjects XI 3.1 > BusinessObjects

Enterprise > BusinessObjects Enterprise Central Management Console.

2. Log in as an administrator.

3. Click Folders.

4. Click All Folders to expand the folder.

5. Do the following for each of the Executive Scorecard folders:

XD_BSM

XD_DC

XD_Financial

XD_FPA

XD_PPM

XD_Program

XD_Service

XD_Summary

XD_Xcelsius_Source
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a. Right-click the folder, and selectUser Security.

b. On the User Security screen, click Add Principals.

c. SelectXD_CIO in the Available users/groups list and click > tomove the group to the Selected

users/groups list.

d. Click Add and Assign Security.

e. On the Assign Security screen, select Full Control in the Available Access Levels list and click > to

move access level to the Assigned Access Levels list.

f. ClickOK.

g. Click Close.

h. Make sure you complete step 5 for all of the folders listed.

Enable Access to the Root Folder

1. In the left pane of the BOE Central Management Console, right-click All Folders and select Properties.

2. ClickUser Security in the left pane.

3. Click Add Principals.

4. SelectXD_CIO in the Available users/groups list and click > tomove the group to the Selected

users/groups list.

5. Click Add and Assign Security.

6. Click the Advanced tab.

7. Click Add/Remove Rights. This link is directly under the tabs.

8. In the right pane on the Add/Remove Rights screen, findView Objects in the General Global Rights list.

Do the following for the View Objects right:

a. Select theGranted radio button (in the first columnwith the green check mark).

b. Clear the Apply to Sub Object check box (in the last column).

9. ClickOK, then clickOK again.

10. Click Close.

Step 11: Test LDAP Authentication with Executive Scorecard

1. OpenWindows Internet Explorer (IE).

2. Type the URL to the Executive Scorecard application.

For example: http://xd1.americas.hp.net:8080/executiveScorecard

3. Log in to Executive Scorecard with the same user name and password that you used to test BOE InfoView

access in Step 9: Test LDAP BOE InfoView Access on page 45.
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4. When the Executive Scorecard pages attempt to load, you may get prompted to run the Java Applet and

install or upgrade Adobe Flash Player. Click Yes for both prompts to avoid seeing these messages in the

future.

5. Log out of Executive Scorecard and close IE.
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Configure Active Directory Authentication
Before you define and enable Active Directory (AD) authentication, make sure that you have the correct

domain and group information and a user account for SAP BusinessObjects Enterprise (BOE) that enables

you to authenticate administrative users and groups.

Complete the following processes to configure AD authentication for Executive Scorecard and BOE.

l Step 1: Create the Active Directory applicationContext.xml File on page 49

l Step 2: Add the XD_CIOMember Group to Active Directory on page 49

l Step 3: Configure Active Directory on the BOE Central Management Console on page 49

l Step 4: Configure Java Authentication for Active Directory on page 50

l Step 5: Configure Tomcat for Active Directory on page 51

l Step 6: Test BOE Central Management Console Active Directory User Access on page 52

l Step 7: Modify the Executive Scorecard web.xml File for Active Directory Authentication on page 52

l Step 8: Modify the Active Directory applicationContext.xml File on page 52

l Step 9: Test Active Directory BOE InfoView Access on page 54

l Step 10: Configure BOE Access Rights on page 55

l Step 11: Test Active Directory Authentication with Executive Scorecard on page 56

Active Directory Guidelines

You can avoid initial Active Directory (AD) configuration issues by following these suggestions:

l Make sure that the AD groups are Security Groups and not DistributedGroups.

l DoNOT use Secure Socket Layer during the initial configuration. You can add this option after you

confirm authentication on port 389.

When you create a Security Principal user, follow these suggestions:

l Ensure that this user is a member of the DomainUsers groupwith rights to search all users.

l Assign this user to the same AD container as other users whowill be trying to authenticate.

l Verify that this user has DES encryption set and that the password has not expired.

l DoNOT select the do not require Kerberos preauthentication option.

l Add the Security Principal user to the Executive Scorecard XD_CIO group for initial testing to confirm

successful authentication.
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Step 1: Create the Active Directory applicationContext.xml File

Because Executive Scorecard enables you to use LDAP, AD, or file-based authentication, you must designate

the type of authentication you are using by making the appropriate applicationContext.xml file active. Out-of-

box, the applicationContext.xml file for file-based authentication is the active file.

To create the Active Directory applicationContext.xml file

1. Navigate to this directory:

C:\Program Files\HP\Executive Scorecard\WebApplications\executiveScorecard\WEB-INF

2. Find applicationContext.xml. This is the active file-based authentication file.

3. Rename this file tomake it a backup file. For example, name it applicationContext.xml_filebased.

4. Find applicationContext.xml_activedirectory.

5. Rename this file to applicationContext.xml. The applicationContext.xml file for Active Directory

becomes the active authentication file.

Step 2: Add the XD_CIO Member Group to Active Directory

Add the following Executive Scorecard group to the Active Directory server before you make configuration

changes to BusinessObjects Enterprise.

XD_CIO: This role enables access to the Executive Scorecard application.

For instructions on adding member groups to Active Directory, see your Active Directory documentation.

Notes:

l The Executive Scorecard security framework prefixes XD_CIOwith ROLE_ so that the group becomes

ROLE_XD_CIO for Executive Scorecard.

l Changes to group names require changes to both the web.xml file and the Active Directory server.

Step 3: Configure Active Directory on the BOE Central Management Console

Once you enable Active Directory (AD) on the BusinessObjects Enterprise (BOE) Central Management

Console, add administration credentials to enable a BOE user to use AD authentication, map groups, check

rights, and perform other tasks. In addition, choose Kerberos authentication and set other AD authentication

options.

Important: Any time you type a domain name, you must use upper case letters. Kerberos uses upper case

letters, and BOE InfoView uses Kerberos. If you do not use upper case letters for domains, you will not be

able to log in to BOE InfoView.

1. From theWindows Start menu, click Programs> BusinessObjects XI 3.1 > BusinessObjects

Enterprise > BusinessObjects Enterprise Central Management Console.

2. Log in to the BOE Central Management Console as an administrator.

3. In the Manage section, click Authentication.

4. Click theWindows AD tab.
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5. SelectEnable Windows Active Directory (AD).

6. Click the value for the AD Administration Name to change it. Type the name of the user account on the

AD server. BOE will use this name and password to authenticate AD users and groups.

For example: administrator@SERVER.DOMAIN.COM

7. Click the value for theDefault AD Domain to change it. Specify a default domain to enable AD

authentication and tomap groups. By specifying the default AD domain name, users will not have to type

the AD domain name when they log in to BOE with Active Directory authentication.

For example: SERVER.DOMAIN.COM

8. In the Add ADGroup field, typeXD_CIO, then click Add.

9. SelectUse Kerberos authentication.

10. SelectCache security context (required for SSO to database).

11. If necessary, clear theEnable Single Sign On for selected authentication mode check box. Make

sure this option is not selected.

12. Use the default options for the remaining options on this screen, and clickUpdate. A message appears

stating that it will take several seconds to update the member groups.

13. ClickOK.

14. Log out of the BOE Central Management Console.

Step 4: Configure Java Authentication for Active Directory

BOE uses the Krb5AuthLoginModule Java authenticationmodule. This module requires that you add some

additional configuration information in two configuration files: krb5.ini and bscLogin.conf. The krb5.ini file

gives Java information about your domain and location of the Kerberos Key Distribution Center. This file can

be simple or complex depending on the size and implementation of your Active Directory domain. The

bscLogin.conf file contains an entry that specifies the authentication technology to be used.

1. Create krb5.ini:

a. Create a text file that contains the information that Java needs about Kerberos and your domain. For

example:

[libdefaults]
default_realm = DOMAIN.COM
dns_lookup_kdc = true
dns_lookup_realm = true
[realms]
DOMAIN.COM = {
kdc = ADSERVER.DOMAIN.COM
default_domain = DOMAIN.COM
}
Important: The domain values must use upper case letters.
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b. Name the file krb5.ini, and save it in the directory of your choice. By default, Java looks for this file in

C:\winnt. Since Tomcat loads Java at startup, if you save krb5.ini somewhere other than C:\winnt, you

must configure Tomcat so that Java can find the file.

2. Create bscLogin.conf:

a. Create a text file that specifies that you are using Active Directory authentication. When you use Sun

Java SDK, the entry looks like this:

com.businessobjects.security.jgss.initiate {
com.sun.security.auth.module.Krb5LoginModule required;
};

b. Name the file bscLogin.conf, and save it in the directory of your choice. By default, Java looks for this

file in C:\winnt. Since Tomcat loads Java at startup, if you save bscLogin.conf somewhere other than

C:\winnt, you must configure Tomcat so that Java can find the file.

3. If you saved krb5.ini and bscLogin.conf in a directory other than C:\winnt, follow the instructions in Step 5:

Configure Tomcat for Active Directory on page 51 to configure Tomcat so that Java can find these files.

Step 5: Configure Tomcat for Active Directory

Since Tomcat loads Java at startup, you must make sure that Tomcat can find the krb5.ini and bscLogin.conf

files you created in Step 4: Configure Java Authentication for Active Directory on page 50. If you saved these

files in a location other than C:\winnt, follow these instructions to configure Tomcat to find the files.

1. Stop the Tomcat service:

a. From theWindows Start menu, click Programs> BusinessObjects XI 3.1 > BusinessObjects

Enterprise > Central Configuration Manager.

b. Right-click the Apache Tomcat service and select Stop.

2. From theWindows Start menu, click Programs> Tomcat > Tomcat Configuration.

3. Click the Java tab.

4. At the bottom of the list of options in the Java Options text box, type the following value:

-Djava.security.auth.login.config=<path to krb5.ini>\bscLogin.conf

-Djava.security.krb5.conf=<path to krb5.ini>\krb5.ini

For example:

-Djava.security.auth.login.config=C:\
activedirectory\java\bscLogin.conf
-Djava.security.krb5.conf=C:\activedirectory\java\
krb5.ini

5. ClickOK.

6. Delete all of the contents in the Tomcat work folder:

<BOE installation directory>\Tomcat55\work\
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7. Restart the Tomcat service:

a. From theWindows Start menu, click Programs> BusinessObjects XI 3.1 > BusinessObjects

Enterprise > Central Configuration Manager.

b. Right-click the Apache Tomcat service and select Start.

Step 6: Test BOE Central Management Console Active Directory User Access

1. From theWindows Start menu, click Programs> BusinessObjects XI Release 3.1 >

BusinessObjects Enterprise > BusinessObjects Enterprise Central Management Console.

2. Type the username and password for an Active Directory user.

3. From the Authentication drop-down list, selectWindows AD. Navigation items are not available because

the Active Directory groups do not have rights.

If the login fails, repeat steps 1 - 8 in Step 3: Configure Active Directory on the BOE Central Management

Console on page 49.

Step 7: Modify the Executive Scorecard web.xml File for Active Directory Authentication

1. Stop the Tomcat service:

a. From theWindows Start menu, click Programs> BusinessObjects XI 3.1 > BusinessObjects

Enterprise > Central Configuration Manager.

b. Right-click the Apache Tomcat service and select Stop.

2. Openweb.xml with a text editor. The file is in:

C:\Program Files\HP\Executive Scorecard\WebApplications\executiveScorecard\WEB-INF

3. Locate the biAuthType parameter section.

4. Change the parameter value to secWinAD.

<init-param>
<param-name>biAuthType</param-name>
<param-value>secWinAD</param-value>

</init-param>

5. Save and close web.xml.

Step 8: Modify the Active Directory applicationContext.xml File

1. Open applicationContext.xml with a text editor. The file is in:

C:\Program Files\HP\Executive Scorecard\WebApplications\executiveScorecard\WEB-INF

2. In the initialDirContextFactory bean, locate the following properties andmake the necessary changes:

n constructor-arg value: Change this element value to the Active Directory server and port. For

example:

<constructor-arg value="ldap://

Step 6: Test BOE Central Management Console Active Directory User

Access
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myadserver.secure.mycompany.com:389"/>

n managerDn: Change this property value to the LDAP administrator:

For example:

<property name="managerDn">
<value>CN=user password,OU=XDTEST,DC=secure,
DC=mycompany,DC=com</value>

</property>

n managerPassword: Change this property value to the LDAP administrator password. For example:

<property name="managerPassword">
<value>Password123</value>

</property>

3. In the authenticator bean, locate the userDnPatterns property. Use this property to specify all of the paths

used to locate the users in your Active Directory database who need access to Executive Scorecard. The

value is the unique attribute of the user and the Organizational Unit that the user is in. List all of the possible

search paths. For example:

<property name="userDnPatterns">
<list>
<value>cn={0},ou=People</value>
<value>cn={0},ou=contractors,ou=People</value>
<value>cn={0},ou=managers,ou=People</value>
<value>cn={0},ou=parttime,ou=employees,
ou=People</value>
<value>cn={0},ou=fulltime,ou=employees,
ou=People</value>
</list>

</property>

4. In the userSearch bean, locate the following properties andmake the necessary changes:

n In the value for the first constructor-arg element, type the folder path within the AD server where users

are located. For example:

<constructor-arg>
<value>OU=XDTEST,DC=secure,
DC=mycompany,DC=com</value>
</constructor-arg>

n In the value for the second constructor-arg element, type the AD attribute that will be used to locate the

user. For example:

<constructor-arg>
<value>(sAMAccountName={0})</value>

</constructor-arg>

n In the searchSubtree property, type true if the users are located on several levels under the tree. If the

value is not true, Executive Scorecard will not search through the tree.
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5. In the populator bean, locate the following properties andmake the necessary changes:

n In the second constructor-arg element, add group information. For example:

<constructor-arg>
<value>ou=Groups</value>

</constructor-arg>

n groupRoleAttribute: Type the attribute that is used to identify the group. For example:

<property name="groupRoleAttribute">
<value>cn_</value>

</property>

n groupSearchFilter: Type the attribute in LDAP server that defines the members of the group. For

example:

<property name="groupSearchFilter">
<value>group={0}</value>

</property>

n In the searchSubtree property, type true if the users are located on several levels under the tree. If the

value is not true, Executive Scorecard will not search through the tree.

6. Save and close applicationContext.xml.

7. Delete all of the contents in the Tomcat work folder:

<BOE installation directory>\Tomcat55\work\

8. Restart the Tomcat service:

a. From theWindows Start menu, click Programs> BusinessObjects XI 3.1 > BusinessObjects

Enterprise > Central Configuration Manager.

b. Right-click the Apache Tomcat service and select Start.

Step 9: Test Active Directory BOE InfoView Access

1. From theWindows Start menu, click Programs> BusinessObjects XI 3.1 > BusinessObjects

Enterprise > BusinessObjects Enterprise Java InfoView.

2. Log in to InfoView with the same username and password that you used to log in to the BOE Central

Management Console in Step 6: Test BOE Central Management Console Active Directory User Access on

page 52.

3. From the Authentication drop-down list, selectWindows AD.

If the login fails, repeat these steps:

l Step 2: Add the XD_CIOMember Group to Active Directory on page 49

l Step 3: Configure Active Directory on the BOE Central Management Console on page 49
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Step 10: Configure BOE Access Rights

Youmust enable the Executive Scorecard group to view or edit the contents of a BusinessObjects Enterprise

(BOE) folder. To configure BOE access rights, assign access to the Executive Scorecard folders, then enable

access to the Root folder.

Assign Access to the Executive Scorecard Folders

1. From theWindows Start menu, click Programs> BusinessObjects XI 3.1 > BusinessObjects

Enterprise > BusinessObjects Enterprise Central Management Console.

2. Log in as an administrator.

3. Click Folders.

4. Click All Folders to expand the folder.

5. Do the following for each of the Executive Scorecard folders:

XD_BSM

XD_DC

XD_Financial

XD_FPA

XD_PPM

XD_Program

XD_Service

XD_Summary

XD_Xcelsius_Source

a. Right-click the folder, and selectUser Security.

b. On the User Security screen, click Add Principals.

c. SelectXD_CIO in the Available users/groups list and click > tomove the group to the Selected

users/groups list.

d. Click Add and Assign Security.

e. On the Assign Security screen, select Full Control in the Available Access Levels list and click > to

move access level to the Assigned Access Levels list.

f. ClickOK.

g. Click Close.

h. Make sure you complete step 5 for all of the folders listed.

Enable Access to the Root Folder

1. In the left pane of the BOE Central Management Console, right-click All Folders and select Properties.

2. ClickUser Security in the left pane.

3. Click Add Principals.
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4. SelectXD_CIO in the Available users/groups list and click > tomove the group to the Selected

users/groups list.

5. Click Add and Assign Security.

6. Click the Advanced tab.

7. Click Add/Remove Rights. This link is directly under the tabs.

8. In the right pane on the Add/Remove Rights screen, findView Objects in the General Global Rights list.

Do the following for the View Objects right:

a. Select theGranted radio button (in the first columnwith the green check mark).

b. Clear the Apply to Sub Object check box (in the last column).

9. ClickOK, then clickOK again.

10. Click Close.

Step 11: Test Active Directory Authentication with Executive Scorecard

1. OpenWindows Internet Explorer (IE).

2. Type the URL to the Executive Scorecard application.

For example: http://xd1.americas.hpqcorp.net:8080/executiveScorecard

3. Log in to Executive Scorecard with the same user name and password that you used to test BOE InfoView

access in Step 9: Test Active Directory BOE InfoView Access on page 54.

4. When the Executive Scorecard pages attempt to load, you may get prompted to run the Java Applet and

install or upgrade Adobe Flash Player. Click Yes for both prompts to avoid seeing these messages in the

future.

5. Log out of Executive Scorecard and close IE.

Step 11: Test Active Directory Authentication with Executive Score-
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Configure File-Based Authentication
Follow these steps to configure authentication specified by a file. This is a quick way to set up temporary

authentication for a test environment or prototype, but file-based authentication should not be used in a

production environment.

l Step 1: Create a User and a Group in the BOE Central Management Console on page 57

l Step 2: Modify the Executive Scorecard web.xml file for File-Based Authentication on page 58

l Step 3: Configure Executive Scorecard Access on page 58

l Step 4: Test File-Based Authentication with Executive Scorecard on page 58

l Step 5: Configure BOE Access Rights on page 59

Step 1: Create a User and a Group in the BOE Central Management Console

1. From theWindows Start menu, click Programs> BusinessObjects XI Release 3.1 >

BusinessObjects Enterprise > BusinessObjects Enterprise Central Management Console.

2. Log in to the Central Management Console as an administrator.

3. ClickUsers and Groups.

4. Right-clickUser List and selectNew User.

5. Accept the default Authentication Type:Enterprise.

6. Type anAccount Name. For example: demo.

7. Type a password. For example: demo

8. In the Confirm field, retype the password.

9. Accept the default Connection Type:Concurrent User.

10. Click Create & Close.

11. Right-clickGroup List and selectNew Group.

12. Type a GroupName. For example: XD_CIO

13. ClickOK. The new group appears in the right pane.

14. Right-click the new group and selectAdd Members to Group.

15. Add one or more users to the group by selecting a user role in the middle pane and clicking the right arrow

(>) tomove that user role into the group. For example, select Everyone to include all users, or select

Administrators to limit the access to administrators.

16. ClickOK.

17. Log out of the BOE Central Management Console and close the application.
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Step 2: Modify the Executive Scorecard web.xml file for File-Based Authentication

1. Stop the Tomcat service:

a. From theWindows Start menu, click Programs> BusinessObjects XI 3.1 > BusinessObjects

Enterprise > Central Configuration Manager.

b. Right-click the Apache Tomcat service and select Stop.

2. Openweb.xml with a text editor. The file is in:

C:\Program Files\HP\Executive Scorecard\WebApplications\executiveScorecard\WEB-INF

3. Locate the biAuthType parameter section.

4. Change the parameter value to secEnterprise.

<init-param>
<param-name>biAuthType</param-name>
<param-value>secEnterprise</param-value>

</init-param>

5. Save and close web.xml.

Step 3: Configure Executive Scorecard Access

Change the Executive Scorecard user properties file to add the user that you created in Step 1: Create a User

and a Group in the BOE Central Management Console on page 57.

1. Open user.propertieswith a text editor. The file is in:

C:\Program Files\HP\Executive Scorecard\WebApplications\executiveScorecard\WEB-INF

2. Add to this file the user name, password, and group that you added to the BOE Central Management

Console in Step 1: Create a User and a Group in the BOE Central Management Console on page 57.

For example:

demo=demo,ROLE_XD_CIO

3. Save and close user.properties.

4. Delete all of the contents in the Tomcat work folder:

<BOE installation directory>\Tomcat55\work\

5. Restart the Tomcat service:

a. From theWindows Start menu, click Programs> BusinessObjects XI 3.1 > BusinessObjects

Enterprise > Central Configuration Manager.

b. Right-click the Apache Tomcat service and select Start.

Step 4: Test File-Based Authentication with Executive Scorecard

1. OpenWindows Internet Explorer (IE).

2. Type the URL to the Executive Scorecard application.

For example: http://xd1.americas.hp.net:8080/executiveScorecard

Step 2: Modify the Executive Scorecard web.xml file for File-Based

Authentication
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3. Log in to Executive Scorecard with the same user name and password that you added to the user.properties

file Step 3: Configure Executive Scorecard Access on page 58.

4. When the Executive Scorecard pages attempt to load, you may get prompted to run the Java Applet and

install or upgrade Adobe Flash Player. Click Yes for both prompts to avoid seeing these messages in the

future.

5. Log out of Executive Scorecard and close IE.

Step 5: Configure BOE Access Rights

Youmust enable the Executive Scorecard group to view or edit the contents of a BusinessObjects Enterprise

(BOE) folder. To configure BOE access rights, assign access to the Executive Scorecard folders, then enable

access to the Root folder.

Assign Access to the Executive Scorecard Folders

1. From theWindows Start menu, click Programs> BusinessObjects XI 3.1 > BusinessObjects

Enterprise > BusinessObjects Enterprise Central Management Console.

2. Log in as an administrator.

3. Click Folders.

4. Click All Folders to expand the folder.

5. Do the following for each of the Executive Scorecard folders:

XD_BSM

XD_DC

XD_Financial

XD_FPA

XD_PPM

XD_Program

XD_Service

XD_Summary

XD_Xcelsius_Source

a. Right-click the folder, and selectUser Security.

b. On the User Security screen, click Add Principals.

c. SelectXD_CIO in the Available users/groups list and click > tomove the group to the Selected

users/groups list.

d. Click Add and Assign Security.

e. On the Assign Security screen, select Full Control in the Available Access Levels list and click > to

move access level to the Assigned Access Levels list.

f. ClickOK.

g. Click Close.

h. Make sure you complete step 5 for all of the folders listed.
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Enable Access to the Root Folder

1. In the left pane of the BOE Central Management Console, right-click All Folders and select Properties.

2. ClickUser Security in the left pane.

3. Click Add Principals.

4. SelectXD_CIO in the Available users/groups list and click > tomove the group to the Selected

users/groups list.

5. Click Add and Assign Security.

6. Click the Advanced tab.

7. Click Add/Remove Rights. This link is directly under the tabs.

8. In the right pane on the Add/Remove Rights screen, findView Objects in the General Global Rights list.

Do the following for the View Objects right:

a. Select theGranted radio button (in the first columnwith the green check mark).

b. Clear the Apply to Sub Object check box (in the last column).

9. ClickOK, then clickOK again.

10. Click Close.
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Change Connection Properties in the BOE Central Management
Console

Because each Executive Scorecard component uses a connection to BusinessObjects Enterprise (BOE), you

must increase the default settings for the connections in the BOE Central Management Console.

1. From theWindows Start menu, click Programs> BusinessObjects XI 3.1 > BusinessObjects

Enterprise > BusinessObjects Enterprise Central Management Console.

2. Log in to the BOE Central Management Console as an administrator.

3. Click Servers.

4. Expand Service Categories in the left pane.

5. ClickWeb Intelligence.

6. Double-click ExecutiveScorecard.WebIntelligenceProcessingServer in the right pane.

7. In the Properties window, change the values for the following settings:

n Maximum Documents per User: HP recommends that you increase this setting to 20. However, this

value should be set according to the needs of your company.

This setting specifies the maximum number of active sessions or Web Intelligence reports that can be

associated with a user at any time. The valid range is 1 – 20.

n Maximum Connections: HP recommends that you increase this setting to 700. However, this value

should be set according to the needs of your company.

This setting specifies the approximate maximum number of simultaneous sessions that can be opened at

one time. The valid range is 5 – 65,535.

n Idle Connection Timeout (minutes): HP recommends that you increase this setting to 40.

However, this value should be set according to the needs of your company.

This setting specifies the number of minutes that the server waits for a request from an idle connection.

If you set this value too low, the request may close prematurely. If you set this value too high, requests

will be queued while the server waits for idle requests to close.

8. Click Save & Close.

9. Log out of the BOE Central Management Console and close the application.

10. Stop the BOE service:

a. From theWindows Start menu, click Programs> BusinessObjects XI 3.1 > BusinessObjects

Enterprise > Central Configuration Manager.

b. Right-click the Server Intelligence Agent (ExecutiveScorecard) service and select Stop.

11. Stop the Tomcat service:

a. In the Central ConfigurationManager, right-click the Apache Tomcat 5.5 service and select Stop.
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12. Restart the BOE service:

a. In the Central ConfigurationManager, right-click the Server Intelligence Agent

(ExecutiveScorecard) service and select Start.

13. Delete all of the contents in the Tomcat work folder:

<BOE installation directory>\Tomcat55\work\

14. Restart the Tomcat service:

a. In the Central ConfigurationManager, right-click the Apache Tomcat 5.5 service and select Start.

Change Connection Properties in the BOE Central Management Con-

sole
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Run the BSM and DC View Scripts
If you use HP Business Service Management (BSM) or HPDecisionCenter (DC) as a data source, you must

run a view script on that source database to create the views that Executive Scorecard will use to access data

from those sources.

l If you use BSM, see Run the BSMView Script on page 63 for instructions on running the BSM view script.

l If you use DC, see Run the DCView Script on page 63 for instructions on running the DC view script.

Run the BSM View Script
1. Open the database client for your BSM database and log in with the proper login or schema.

2. From the database client, navigate to the location of the appropriate view script and run the script:

n If you use anOracle database, navigate to the script for Oracle.

For example: C:\Program Files\HP\Executive Scorecard\ContentPacks\bsm\schema\oracle

RunBSM8.0.sql.

n If you use a SQL Server database, navigate to the script for SQL Server.

For example: C:\Program Files\HP\Executive Scorecard\ContentPacks\bsm\schema\mssql

RunBSM8.0.sql.

Run the DC View Script
1. Open the database client for your DC database and log in with the proper login or schema.

2. From the database client, navigate to the location of the appropriate view script and run the script:

n If you use anOracle database, navigate to the script for Oracle.

For example: C:\Program Files\HP\Executive Scorecard\ContentPacks\dc\schema\oracle

RunDC2.0.sql.

n If you use a SQL Server database, navigate to the script for SQL Server.

For example: C:\Program Files\HP\Executive Scorecard\ContentPacks\dc\schema\mssql

Run DC2.0.sql
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Change Session Time Out Parameters
The default timeout value for BOE applications is 20 minutes. To extend the session timeout parameter for

the applications, follow these steps:

1. Stop the Tomcat service:

a. From theWindows Start menu, click Programs> BusinessObjects XI 3.1 > BusinessObjects

Enterprise > Central Configuration Manager.

b. Right-click the Apache Tomcat service and select Stop.

2. Open dsws.propertieswith a text editor. The file is in

<BOE installation directory>\Tomcat55\webapps\dswsbobje\WEB-INF\classes

3. Add the following property at the end of the file. Express the timeout value in seconds. For example, this is

a session timeout value of 24 hours:

# Session timeout
session.timeout=86400

4. Save and close the file.

5. Open server.xml with a text editor. The file is in

<BOE installation directory>\Tomcat55\conf

6. Update the connectionTimeout property for port 8080 tomatch the value that you specified in

dsws.properties. However, express the timeout value for the Tomcat instance inmilliseconds. For example,

this is a session timeout value of 24 hours:

connectionTimeout=86400000

7. Save and close the file.

8. Open theweb.xml file in this directory with a text editor:

<BOE installation directory>\Tomcat55\webapps\infoViewApp\WEB-INF

9. Also open theweb.xml file in this directory:

<BOE installation directory>\Tomcat55\webapps\infoViewAppActions\WEB-INF

10. In addition, open theweb.xml file in this directory:

<BOE installation directory>\Tomcat55\conf

11. In all three web.xml files, update the session timeout property tomatch the value that you specified in

dsws.properties. However, express the timeout value inminutes. For example, this is a session timeout

value of 24 hours:

<session-config>
<session-timeout>1440</session-timeout>
</session-config>

12. Save and close the files.

13. Delete all of the contents in the Tomcat work folder:

<BOE installation directory>\Tomcat55\work\
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14. Restart the Tomcat service:

a. From theWindows Start menu, click Programs> BusinessObjects XI 3.1 > BusinessObjects

Enterprise > Central Configuration Manager.

b. Right-click the Apache Tomcat service and select Start.
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Modify Universes
Youmust configure each universe to add a connection to your specific data source.

Follow the instructions in these tasks tomodify the universes:

l Step 1: Import Universes in BOE Universe Designer on page 66

l Step 2: Create Universe Connections on page 66

Step 1: Import Universes in BOE Universe Designer
1. From theWindows Start menu, click Programs> BusinessObjects XI 3.1 > BusinessObjects

Enterprise >Designer.

2. Log in to Universe Designer. If necessary, close the Welcome screen.

3. From the Designer Filemenu, select Import.

4. From the Folder drop-down list, select \webi universes. The Available Universes list becomes populated

with the available universes.

5. If not already selected, select theOpen the selected universes check box so that Designer opens the

universes that you import.

6. Select the universe for each data source that you have. You can press Ctrl and click to select multiple

universes. Do not select universes for data sources that you do not have.

n XD_BSM: The universe for Business Service Management.

n XD_DC: The universe for DecisionCenter.

n XD_FPA: The universe for IT Analytics Financial Planning & Analysis.

n XD_PPM: The universe for Project and PortfolioManagement.

7. ClickOK.

8. ClickOK to close the Universe successfully importedmessage. Designer opens the imported universes.

9. Follow the instructions in Step 2: Create Universe Connections on page 66 to add a database connection to

each universe.

Step 2: Create Universe Connections
Modify each universe that you imported in Step 1: Import Universes in BOE Universe Designer on page 66 to

add a connection to the corresponding source database. Follow the instructions below for each universe that

you imported.

l Create a connection in the Business Service Management universe on page 67

l Create a connection in the DecisionCenter universe on page 68

l Create a connection in the Financial Planning & Analysis universe on page 69
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l Create a connection in the Project and PortfolioManagement universe on page 70

Create a connection in the Business Service Management universe

1. From the File menu inDesigner, selectXD_BSM.unv. The Business Service Management (BSM) universe

opens.

2. From the File menu, select Parameters.

3. Make sure thatXD_BSM appears in the Name field.

4. Make sure thatXD_BSM_DSN is selected in the Connection drop-down list.

5. ClickNew. The New ConnectionWizard guides you through the process to create a connection.

6. ClickNext.

7. Make sure that Secured is selected in the Connection Type drop-down list.

8. In the ConnectionName field, typeXD_BSM_DB.

9. In the bottom pane, select the type of RDBMS for the BSM database. If this is a Microsoft SQL Server

database, selectMicrosoft >MS SQL Server 2005 >ODBC Drivers. If this is anOracle database,

selectOracle >Oracle 10 >Oracle Client.

10. ClickNext.

11. Make sureUse specified user name and password is selected in the AuthenticationMode drop-down

list.

12. Type the user name for the BSM database.

13. Type the password for this user for the BSM database.

14. MSSQL: If you selected a Microsoft SQL Server database in step 9, selectXD_BSM_DSN from the Data

source name drop-down list.

Oracle: If you selected anOracle database in step 9, type the tnsnames value for your BSM database in the

Service field.

15. Click Test Connection tomake sure the connection works.

16. ClickNext.

17. On the Configuration Parameters [4/5] screen, accept the default settings and clickNext.

18. Click Finish.

19. Save the universe changes.

20. Export the universe to your CMS database:

a. From the File menu, selectExport.

b. SelectXD_BSM in the bottom pane.

c. ClickOK.
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d. ClickOK to close the Universe successfully exportedmessage. If you need to create a connection in

another universe, follow the instructions for that universe. If you do not need tomodify other universes,

close Designer.

Create a connection in the DecisionCenter universe

1. From the File menu inDesigner, selectXD_DC.unv. The DecisionCenter (DC) universe opens.

2. From the File menu, select Parameters.

3. Make sure thatXD_DC appears in the Name field.

4. Make sure thatXD_DC_DSN is selected in the Connection drop-down list.

5. ClickNew. The New ConnectionWizard guides you through the process to create a connection.

6. ClickNext.

7. Make sure that Secured is selected in the Connection Type drop-down list.

8. In the ConnectionName field, typeXD_DC_DB.

9. In the bottom pane, select the type of RDBMS for the DC database. If this is a Microsoft SQL Server

database, selectMicrosoft >MS SQL Server 2005 >ODBC Drivers. If this is anOracle database,

selectOracle >Oracle 10 >Oracle Client.

10. ClickNext.

11. Make sureUse specified user name and password is selected in the AuthenticationMode drop-down

list.

12. Type the user name for the DC database.

13. Type the password for this user for the DC database.

14. MSSQL: If you selected a Microsoft SQL Server database in step 9, selectXD_BSM_DSN from the Data

source name drop-down list.

Oracle: If you selected anOracle database in step 9, type the tnsnames value for your BSM database in the

Service field.

15. Click Test Connection tomake sure the connection works.

16. ClickNext.

17. On the Configuration Parameters [4/5] screen, accept the default settings and clickNext.

18. Click Finish.

19. Save the universe changes.

20. Export the universe to your CMS database:

a. From the File menu, selectExport.

b. SelectXD_DC in the bottom pane.

c. ClickOK.
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d. ClickOK to close the Universe successfully exportedmessage. If you need to create a connection in

another universe, follow the instructions for that universe. If you do not need tomodify other universes,

close Designer.

Create a connection in the Financial Planning & Analysis universe

1. From the File menu inDesigner, selectXD_FPA.unv. The Financial Planning & Analysis (FPA) universe

opens.

2. From the File menu, select Parameters.

3. Make sure thatXD_FPA appears in the Name field.

4. Make sure thatXD_FPA_DSN is selected in the Connection drop-down list.

5. ClickNew. The New ConnectionWizard guides you through the process to create a connection.

6. ClickNext.

7. Make sure that Secured is selected in the Connection Type drop-down list.

8. In the ConnectionName field, typeXD_FPA_DB.

9. In the bottom pane, selectMicrosoft >MS SQL Server 2005 >ODBC Drivers.

10. ClickNext.

11. Make sureUse specified user name and password is selected in the AuthenticationMode drop-down

list.

12. Type the user name for the FPA database.

13. Type the password for this user for the FPA database.

14. From the Data source name drop-down list, selectXD_FPA_DSN.

15. Click Test Connection tomake sure the connection works.

16. ClickNext.

17. On the Configuration Parameters [4/5] screen, accept the default settings and clickNext.

18. Click Finish.

19. Save the universe changes.

20. Export the universe to your CMS database:

a. From the File menu, selectExport.

b. SelectXD_FPA in the bottom pane.

c. ClickOK.

d. ClickOK to close the Universe successfully exportedmessage. If you need to create a connection in

another universe, follow the instructions for that universe. If you do not need tomodify other universes,

close Designer.
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Create a connection in the Project and Portfolio Management universe

1. From the File menu inDesigner, selectXD_PPM.unv. The Project and PortfolioManagement (PPM)

universe opens.

2. From the File menu, select Parameters.

3. Make sure thatXD_PPM appears in the Name field. XD_PPM_DSN is selected in the Connection drop-

down list.

4. ClickNew. The New ConnectionWizard guides you through the process to create a connection.

5. ClickNext.

6. Make sure that Secured is selected in the Connection Type drop-down list.

7. In the ConnectionName field, typeXD_PPM_DB.

8. In the bottom pane, selectOracle >Oracle 10 >Oracle Client.

9. ClickNext.

10. Make sureUse specified user name and password is selected in the AuthenticationMode drop-down

list.

11. Type the user name for the PPM database.

12. Type the password for this user for the PPM database.

13. In the Service field, type the tnsnames value for your PPM database.

14. Click Test Connection tomake sure the connection works.

15. ClickNext.

16. On the Configuration Parameters [4/5] screen, accept the default settings and clickNext.

17. Click Finish.

18. Save the universe changes.

19. Export the universe to your CMS database:

a. From the File menu, selectExport.

b. SelectXD_PPM in the bottom pane.

c. ClickOK.

d. ClickOK to close the Universe successfully exportedmessage. If you need to create a connection in

another universe, follow the instructions for that universe. If you do not need tomodify other universes,

close Designer.
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(BSM Users) Create the BSM Service Health Page
If you use HP Business Service Management (BSM) as a data source, you can add to Executive Scorecard a

page to track service health. To create the Service Health page, create a new page, a new component to add to

the page, and a new category so that you can organize the components you will use on the new page.

1. Log in to Executive Scorecard.

2. ClickNew Page.

3. Click Components.

4. In the Categories pane on the left side of the Component Gallery, clickNew Category.

5. Type a name for the category.

For example: Service Health

6. ClickOK. The new category appears in the Categories pane.

7. In the pane on the right side of the Component Gallery, click Add External Component.

8. Retrieve the URL for the BSM application. To do so, open a new Windows Internet Explorer window and

type this URL:

http://<BSM server name>/topaz/bam/pages/topview.jsp?customer=1&fromAgora=true

For example: http://dc2003sql-29db.labs.peregrine.com/

topaz/bam/pages/topview.jsp?customer=1&fromAgora=true

Once you have the URL that accesses the BSM login page, copy it. Then return to Executive Scorecard.

9. In the New Component window, provide these details:

n Name: Type a name for the new component.

For example: Service Health

n URL: Paste the URL that you copied in step 8.

n Description: Type a brief description of the new component.

n Categorize Component: If necessary, click Categorize Component to expand the list of categories.

Select the category that you created in steps 4 - 6.

You do not need to provide Wiring Context or URL Parameter information.

10. ClickOK. The new component becomes available in the Component Gallery.

11. Click the new component and drag it onto the new page.

12. Click Save.

13. Type a name for the new page.

For example: Service Health

14. ClickOK.
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15. Log off of Executive Scorecard, then log in again to view the new page that accesses BSM. You can

configure single sign-on for Executive Scorecard and BSM so that you are not prompted to log in to BSM

when you access the BSM Service Health page in Executive Scorecard. To configure single sign-on, see

Step 1: Configure Single Sign-On for Executive Scorecard and BSM on page 73.
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Configure Single Sign On
Executive Scorecard is anHP Lightweight Single Sign-On (LW-SSO) enabled application. It can be

configured tomake single sign-on possible between Executive Scorecard and BSM or other HP LW-SSO

enabled applications.

Configuring single sign-on is optional. If you do not implement it and you use BSM as a data source, Executive

Scorecard will prompt you to log in to BSMwhen you view the Service Health dashboard.

Note: For single sign-on to work, the same user or loginmust exist for Executive Scorecard and the other

applications. Also, you must access Executive Scorecard from a fully qualified domain, not a localhost URL.

For example: http://xd1.americas.hpqcorp.net:8080/executiveScorecard

Follow the instructions in these sections to configure single sign-on:

l Step 1: Configure Single Sign-On for Executive Scorecard and BSM on page 73

l Step 2: AddOther Domains to the List of TrustedDomains in IE on page 74

Step 1: Configure Single Sign-On for Executive Scorecard and BSM
For single sign-on to work, the same user or loginmust exist for Executive Scorecard and the other

applications. Also, you must access Executive Scorecard from a fully qualified domain, not a localhost URL.

For example: http://xd1.americas.hp.net:8080/executiveScorecard

To configure single sign-on

1. View the LW-SSO configuration information for BSM:

a. Log in to BSM.

b. From the Adminmenu, select Platform.

c. Click theUser and Permissions tab.

d. Click Authentication Management.

e. In the Single Sign-OnConfiguration window, note the Token CreationKey (initString) value.

For example: Xy6stqZ

2. Open lwssofmconf.xml with a text editor. The file is in

<Tomcat installation directory>\common\classes

3. Change the value in the domain element to the Executive Scorecard server domain.

For example:

<lwssoValidation id="ID000001">
<domain>americas.hp.net</domain>

4. Change the value of the initString attribute in lwssofmconf.xml tomatch the token creation key for BSM.

For example:

initString= "Xy6stqZ"

73 Chapter 7



5. Add the domain that BSM uses as well as the domain that Executive Scorecard uses to the list of protected

domains in lwssofmconf.xml. Do not use the server name. For example, if the server is

xd1.americas.hpqcorp.net, the domain is americas.hpqcorp.net. Add the domains in a URL element.

For example:

<protectedDomains>
<url>americas.hp.net</url>
<url>emea.hp.net</url>

</protectedDomains>

Note: To enable access to Executive Scorecard content from BSM, add the Executive Scorecard domain

to the ProtectedDomains list in AuthenticationManagement in BSM. For more information, see your BSM

documentation.

6. Change the URL in the logoutURLs element to replace localhost with a fully qualified domain name.

For example:

<logoutURLs>
<url>http://xd1.americas.hp.net
:8080/executiveScorecard/j_acegi_ logout</url>
</logoutURLs>

7. Save and close lwssofmconf.xml.

8. Add the BSM and Executive Scorecard domains to the list of trusted domains inWindows Internet

Explorer. See Step 2: AddOther Domains to the List of TrustedDomains in IE on page 74.

Step 2: Add Other Domains to the List of Trusted Domains in IE
If Executive Scorecard has a connection to anHP LW-SSO enabled application, such as BSM, and the

application is on a different domain, Windows Internet Explorer (IE) may reject the LW-SSO cookie for that

application, disabling single sign-on. To ensure that single sign-on works for HP LW-SSO enabled applications

on other domains, add the other domains to the list of trusted intranet sites in IE.

1. OpenWindows IE.

2. From the Tools menu, select Internet Options.

3. Click the Security tab.

4. Select Intranet, then click Sites.

5. Click Advanced.

6. In the Add this website to the zone field, type the URL for the application you want to add to the list of

trusted intranet sites. To add all of the pages in a domain, type an asterisk (*) in place of the application.

For example: *.hp.net

7. Click Add.

For more information, see the Windows IE Help.
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Launch Executive Scorecard
Log in to Executive Scorecard and wait for all of the components load. The first time you launch Executive

Scorecard, it may take some time to load the components. Click each page to let that page fully load. The data

that you see in the components on each page is the sample data that is delivered with Executive Scorecard. To

configure the application to use your data, follow the instructions in Clear the Sample Data on page 75 to clean

out the sample data.

Clear the Sample Data
When you are ready to deploy Executive Scorecard in the production environment, use the clean all data utility

to purge the sample integration data. When you run the clean all data utility, the utility removes all of the data

from theWeb Intelligence (Webi) reports so that the components no longer show the sample data. In addition

to clearing the Webi reports, if you use Financial Planning & Analysis you must also clear the data out of the

Financial Scorecard and Financial KPI Trend Components.

Follows these steps to clear all of the sample data from the Executive Scorecard components:

l Step 1: Use the Clean All Data Utility on page 75

l (FPA Users) Step 2: Remove Sample Data from the Financial Scorecard and Financial KPI Trend

Components on page 75

Step 1: Use the Clean All Data Utility
1. Back up your BusinessObjects Enterprise CMS database.

2. Double-click clean_all_data.bat in this directory:

C:\Program Files\HP\Executive Scorecard\ContentPacks\clean_data

3. You can log in to Executive Scorecard to view the components without data. To view your own data in the

Executive Scorecard, follow the instructions in Schedule Reports to Refresh on page 80 to refresh the

Webi reports.Do NOT refresh the reports manually. Always use the BusinessObjects Enterprise

InfoView scheduler. After the Webis refresh, the next time you log in to Executive Scorecard, the

application displays your live data.

4. If you use FPA, follow the instructions in (FPA Users) Step 2: Remove Sample Data from the Financial

Scorecard and Financial KPI Trend Components on page 75 to remove data from the Financial Scorecard

and Financial KPI Trend components.

(FPA Users) Step 2: Remove Sample Data from the Financial Scorecard and
Financial KPI Trend Components

Important: HP recommends that an experienced Xcelsius user completes this process.
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The values that the components display exist in Xcelsius spreadsheets that are embedded in the components.

To provide a complete set of sample data, some values are hard coded into some components. If you want to

view the Executive Scorecard without any data, you can remove the sample data from these components. You

do not need to remove the sample data in order to view these components with your data. Your data will

overwrite the sample data.

To remove sample data from the Financial Scorecard and Financial KPI Trend components

1. From theWindows Start menu, click Programs > Xcelsius.

2. From the File menu in Xcelsius, selectOpen from Platform.

3. Log in to BusinessObjects Enterprise.

4. Remove the sample data from the Financial Scorecard component:

a. In the Open dialog box, expand theXD_Xcelsius_Source folder.

b. SelectXD_Financial_Scorecard_P.xlf, and clickOpen.

c. Click theConnection tab in the spreadsheet.

d. Scroll to the right of the spreadsheet, and delete the data in the Total Revenue column. Do not delete the

header row. Delete the values in rows 3, 4, and 5.

e. From the Xclesius File menu, click Export > SAP BusinessObjects Platform.

f. In the Save As dialog box, expand theXD_Financial folder.

g. SelectXD_Financial_Scorecard_P, and click Save. Xcelsius exports a .swf file and saves it and saves

it in the BOE repository in place of the Financial Scorecard component that included the sample data.

h. From the Xclesius File menu, select Save to Platform.

i. In the Save As dialog box, expand theXD_Xcelsius_Source folder.

j. SelectXD_Financial_Scorecard_P.xlf, and click Save. Xcelsius saves this .xlf file in place of the

Financial Scorecard component source file that included the sample data.

5. Remove the sample data from the Financial KPI Trend component:

a. From the Xcelsius File menu, selectOpen from Platform.

b. In the Open dialog box, expand theXD_Xcelsius_Source folder.

c. SelectXD_Financial_KPI_Trend_S.xlf, and clickOpen.

d. Click theConnection tab in the spreadsheet.

e. Scroll to the right of the spreadsheet to columnN, the IT POR vs. Total Revenue column. Then scroll

down to the Company Revenue section in the IT POR vs. Total Revenue column. Delete the values in

the Company Revenue section in rows 164 through 214. Do not delete the Company Revenue header.

f. From the Xclesius File menu, click Export > SAP BusinessObjects Platform.

g. In the Save As dialog box, expand theXD_Financial folder.

h. SelectXD_Financial_KPI_Trend_S, and click Save. Xcelsius exports a .swf file and saves it in place

of the Financial KPI Trend component that included the sample data.

(FPA Users) Step 2: Remove Sample Data from the Financial Scorecard

and Financial KPI Trend Components
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i. From the Xclesius File menu, select Save to Platform.

j. In the Save As dialog box, expand theXD_Xcelsius_Source folder.

k. SelectXD_Financial_KPI_Trend_S.xlf, and click Save. Xcelsius saves this .xlf file in place of the

Financial KPI Trend component source file that included the sample data.

6. Close Xcelsius.

7. Log in to the Executive Scorecard application, and click Admin.

8. ClickDownload BOE components to Tomcat server. Executive Scorecard downloads to the

Tomcat application the components that you exported to the BusinessObjects Enterprise repository.

(Users without FPA) Modify the Last Refresh Reports
If you do not use FPA, you must modify the last refresh reports for the metadata components to enable the

reports to refresh with new data. If you use FPA, you do not need to complete this process.

Tomodify the last refresh reports

1. From theWindows Start menu, select Programs> BusinessObjects XI 3.1 > BusinessObjects

Enterprise > BusinessObjects Enterprise Java InfoView.

2. Log in to InfoView.

3. ClickDocument List.

4. ExpandPublic Folders.

5. Find the report folders for the data sources:

n XD_BSM: Contains the reports for Business Service Management.

n XD_DC: Contains the reports for DecisionCenter.

n XD_PPM: Contains the reports for Project and PortfolioManagement.

6. Do the following for each data source that you have:

n BSM:

i. Click theXD_BSM folder. InfoView displays the contents of the folder in the right pane.

ii. Right-click XD_BSM_LastRefresh, and selectModify. InfoView opens the report in the Edit

Report panel.

iii. Click Edit Query in the toolbar on the top left side of InfoView.

iv. Click Add Query.

v. In the Universe dialog box, selectXD_BSM from the list of available universes, and clickOK.

vi. On the Data tab in the left pane, expand theXD Dimensions folder, then expand theXD

Metadata folder.

vii. Drag theCurrent Year object into the Result Objects window.
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viii. Right-click theQuery 1 tab at the bottom of the report, and selectDelete Query. Click Yes.

ix. Click Run Queries in the toolbar on the top right of InfoView.

x. In the New Query dialog box, select Include the result object in the document without

generating a table, and clickOK.

xi. Save and close the report.

n DC:

i. Click theXD_DC folder. InfoView displays the contents of the folder in the right pane.

ii. Right-click XD_DC_LastRefresh, and selectModify. InfoView opens the report in the Edit

Report panel.

iii. Click Edit Query in the toolbar on the top left side of InfoView.

iv. Click Add Query.

v. In the Universe dialog box, selectXD_DC from the list of available universes, and clickOK.

vi. On the Data tab in the left pane, expand theXD Dimensions folder, then expand theXD

Metadata folder.

vii. Drag theCurrent Year object into the Result Objects window.

viii. Right-click theQuery 1 tab at the bottom of the report, and selectDelete Query. Click Yes.

ix. Click Run Queries in the toolbar on the top right of InfoView.

x. In the New Query dialog box, select Include the result object in the document without

generating a table, and clickOK.

xi. Save and close the report.

n PPM:

i. Click theXD_PPM folder. InfoView displays the contents of the folder in the right pane.

ii. Right-click XD_PPM_LastRefresh, and selectModify. InfoView opens the report in the Edit

Report panel.

iii. Click Edit Query in the toolbar on the top left side of InfoView.

iv. Click Add Query.

v. In the Universe dialog box, selectXD_PPM from the list of available universes, and clickOK.

vi. On the Data tab in the left pane, expand theXD Dimensions folder, then expand theXD

Metadata folder.

vii. Drag theCurrent Year object into the Result Objects window.

viii. Right-click theQuery 1 tab at the bottom of the report, and selectDelete Query. Click Yes.

ix. Click Run Queries in the toolbar on the top right of InfoView.
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x. In the New Query dialog box, select Include the result object in the document without

generating a table, and clickOK.

xi. Save and close the report.

7. Follow the steps in Schedule Reports to Refresh on page 80 to create a schedule for refreshing reports.
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Schedule Reports to Refresh
Youmust schedule the Web Intelligence (Webi) reports to refresh automatically to get the most current data

from your sources. However, it is important that you only refresh the reports for the data sources that

you have. The Xcelsius components require that you use the schedule feature to properly retrieve data. Do

not refresh reports manually or run them interactively to refresh them.

Follow the instructions in these sections to schedule all of the appropriate reports to refresh:

l Step 1: Schedule the Metric Reports to Refresh on page 80

l Step 2: Schedule the Metadata andKPI Reports to Refresh on page 81

Step 1: Schedule the Metric Reports to Refresh
1. From theWindows Start menu, select Programs> BusinessObjects XI 3.1 > BusinessObjects

Enterprise > BusinessObjects Enterprise Java InfoView.

2. Log in to InfoView.

3. ClickDocument List.

4. ExpandPublic Folders.

5. Find the report folders for the data sources that you have:

n XD_BSM: Contains the reports for Business Service Management.

n XD_DC: Contains the reports for DecisionCenter.

n XD_FPA: Contains the reports for IT Analytics Financial Planning & Analysis.

n XD_PPM: Contains the reports for Project and PortfolioManagement.

6. Click the folder for your data source. The reports in that folder appear in the right pane.Do not refresh

reports in folders for data sources that you do not have.

7. Schedule a report to refresh:

a. Select a report in the right pane.

b. Right-click and select Schedule.

c. Click Recurrence in the left pane.

d. From the Run object drop-down list, select a recurrence value according to how often your business

needs to refresh data.

e. Depending on the recurrence value that you choose, InfoView displays additional fields to enable you to

enter specifics about when to refresh the report. Provide the information for these fields, then click

Schedule.

8. Repeat step 7 for each report in the folder.
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9. Repeat steps 5 – 7 for the report folder for each data source that you have.Do not refresh reports in

folders for data sources that you do not have.

10. Follow the instructions in Step 2: Schedule the Metadata andKPI Reports to Refresh on page 81 to

schedule the rest of the reports to refresh.

Step 2: Schedule the Metadata and KPI Reports to Refresh
Follow these instructions to set up a schedule to refresh the metadata andKPI reports. These reports are in the

page folders in InfoView. Some of the reports contain data frommultiple sources.

1. Click theXD_Financial folder. TwoWebis and several Flash files appear in the right pane. The Flash files

are the components that appear on the Executive Scorecard Financial page. You do not need to do

anything with these files. TheWebis in this folder need to be scheduled to refresh depending on the data

sources that you have.

2. Select theXD_Financial_Metadata report and schedule it to refresh:

a. Right-click and select Schedule.

b. Click Recurrence in the left pane.

c. From the Run object drop-down list, select a recurrence value according to how often your business

needs to refresh data.

d. Depending on the recurrence value that you choose, InfoView displays additional fields to enable you to

enter specifics about when to refresh the report. Provide the information for these fields, then click

Schedule.

3.  DoONE of the following:

n If you use BOTH FPA and PPM as data sources: Select theXD_Financial_KPI report and

schedule it to refresh by following steps a – d in step 2.

n

n If you use FPA and do NOT use PPM, follow these steps:

i. Right-click XD_Financial_KPI and selectModify. InfoView opens the report in the Edit Report

panel.

ii. Right-click theReport 4 tab at the bottom of the report, and selectDelete Report. Click Yes.

iii. Click Edit Query in the toolbar on the top left side of InfoView.

iv. Right-click theQuery 4 tab at the bottom of the report, and selectDelete Query. Click Yes.

v. Click Run Queries in the toolbar on the top right of InfoView. InfoView refreshes the report.

vi. Click Save to save your changes, and then close the report.

vii. Select theXD_Financial_KPI report and schedule it to refresh by following steps a – d in step 2.

If you use PPM and do NOT use FPA, follow these steps:

i. Right-click XD_Financial_KPI and selectModify. InfoView opens the report in the Edit Report

panel.

ii. Right-click theReport 1 tab at the bottom of the report, and selectDelete Report. Click Yes.
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iii. Right-click theReport 2 tab at the bottom of the report, and selectDelete Report. Click Yes.

iv. Right-click theReport 3 tab at the bottom of the report, and selectDelete Report. Click Yes.

v. Click Edit Query in the toolbar on the top left side of InfoView.

vi. Right-click theQuery 1 tab at the bottom of the report, and selectDelete Query. Click Yes.

vii. Right-click theQuery 2 tab at the bottom of the report, and selectDelete Query. Click Yes.

viii. Right-click theQuery 3 tab at the bottom of the report, and selectDelete Query. Click Yes.

ix. Click Run Queries in the toolbar on the top right of InfoView. InfoView refreshes the report.

x. Click Save to save your changes, and then close the report.

xi. Select theXD_Financial_KPI report and schedule it to refresh by following steps a – d in step 2.

4. Click theXD_Program folder. TwoWebis and several Flash files appear in the right pane. The Flash files

are the components that appear on the Executive Scorecard Program page. You do not need to do

anything with these files. TheWebis in this folder need to be scheduled to refresh depending on the data

sources that you have.

5. Select theXD_Program_Metadata report and schedule it to refresh:

a. Right-click and select Schedule.

b. Click Recurrence in the left pane.

c. From the Run object drop-down list, select a recurrence value according to how often your business

needs to refresh data.

d. Depending on the recurrence value that you choose, InfoView displays additional fields to enable you to

enter specifics about when to refresh the report. Provide the information for these fields, then click

Schedule.

6. If you use PPM as a data source, select theXD_Program_KPI report and schedule it to refresh by

following a – d in the previous step. If you do NOT use PPM, do NOT refresh XD_Program_KPI.

7. Click theXD_Service folder. TwoWebis and several Flash files appear in the right pane. The Flash files

are the components that appear on the Executive Scorecard Service page. You do not need to do anything

with these files. TheWebis in this folder need to be scheduled to refresh depending on the data sources that

you have.

8. Select theXD_Service_Metadata report and schedule it to refresh:

a. Right-click and select Schedule.

b. Click Recurrence in the left pane.

c. From the Run object drop-down list, select a recurrence value according to how often your business

needs to refresh data.

d. Depending on the recurrence value that you choose, InfoView displays additional fields to enable you to

enter specifics about when to refresh the report. Provide the information for these fields, then click

Schedule.
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9. DoONE of the following:

n If you use BOTH BSM and DC as data sources, select theXD_Service_KPI report and

schedule it to refresh by following steps a – d in step 8.

n If you use DC and do NOT use BSM, follow these steps:

i. Right-click XD_Service_KPI and selectModify. InfoView opens the report in the Edit Report

panel.

ii. Right-click theReport 5 tab at the bottom of the report, and selectDelete Report. Click Yes.

iii. Right-click theReport 2 tab at the bottom of the report, and selectDelete Report. Click Yes.

iv. Click Edit Query in the toolbar on the top left side of InfoView.

v. Right-click theQuery 6 tab at the bottom of the report, and selectDelete Query. Click Yes.

vi. Right-click theQuery 7 tab at the bottom of the report, and selectDelete Query. Click Yes.

vii. Click Run Queries in the toolbar on the top right of InfoView. InfoView refreshes the report.

viii. Click Save to save your changes, and then close the report.

ix. Select theXD_Service_KPI report and schedule it to refresh by following steps a – d in step 8.

n If you use BSM and do NOT use DC, follow these steps:

i. Right-click XD_Service_KPI and selectModify. InfoView opens the report in the Edit Report

panel.

ii. Right-click theReport 3 tab at the bottom of the report, and selectDelete Report. Click Yes.

iii. Right-click theReport 4 tab at the bottom of the report, and selectDelete Report. Click Yes.

iv. Click Edit Query in the toolbar on the top left side of InfoView.

v. Right-click theQuery 8 tab at the bottom of the report, and selectDelete Query. Click Yes.

vi. Right-click theQuery 9 tab at the bottom of the report, and selectDelete Query. Click Yes.

vii. Click Run Queries in the toolbar on the top right of InfoView. InfoView refreshes the report.

viii. Click Save to save your changes, and then close the report.

ix. Select theXD_Service_KPI report and schedule it to refresh by following steps a – d in step 8.

10. Log out of InfoView and close the application.
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(DC Users) Populate Dates in Service KPI Trend when BSM is Not
Available

Important: HP recommends that an experienced Xcelsius user completes this process.

The Service Scorecard and Service KPI Trend components on the Service page use two key performance

indicators (KPIs) whose data originates inDecisionCenter (DC) and twoKPIs whose data originates in

Business Service Management (BSM). If you use DCwithout BSM, you must make some changes to the

Service KPI Trend component to populate dates when there is no data for the BSMKPIs. In a scenario where

BSM is present without DC, you do not need tomodify the component.

Follow these instructions tomodify the Service KPI Trend component to include dates when BSM data is not

available:

1. From theWindows Start menu, click Programs > Xcelsius.

2. From the File menu in Xcelsius, selectOpen from Platform.

3. Log in to BusinessObjects Enterprise.

4. Expand theXD_Xcelsius_Source folder.

5. SelectXD_Service_KPI_Trend_S.xlf and clickOpen.

6. Click the Info tab in the component spreadsheet. In the Connection Info table, type the Antivia URL. This

URLwill have the same server name and port number as the Executive Scorecard application.

For example: http://xd1.secure.hp.com:8080

7. If necessary, open the Object Browser pane. From the View menu, selectObject Browser.

8. In the Object Browser pane, selectAntivia Connect 1. Xcelsius displays the properties for Antivia

Connect 1 in the Properties pane on the right side of the window.

9. In the Properties pane, click Check URL tomake sure there are no errors. Xcelsius will not display any

messages if the check is successful.

10. In theDesign time connection area, type the user name and password that you used to log in to

BusinessObjects Enterprise, and then click Connect. The Design time connection changes fromDesign

time connection: Not connected toDesign time connection: Connected.

11. In the Object Browser pane, right-click Antivia Table 1, and selectDelete.

12. Right-click Antivia Table 5, and selectDelete.

13. Right-click Antivia Table 4, and select Properties. Xcelsius displays the properties for Antivia Table 4 in

the Properties pane.

14. In the Properties pane, click Report.

15. Click theContent tab.

16. Change the order of the objects in the Available Objects area so that QualifiedMonth is first and Incident

Response Time to SLA is second. Make sure that the date order for QualifiedMonth is descending.

17. Click theData tab.

(DCUsers) Populate Dates in Service KPI Trend when BSM is Not

Available
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18. Click the icon next to the gray Insert data into field, and then typeConnection!$K$18:$L$53 in the

Select a range dialog box.

19. Click the icon next to the gray Insert Headings Into field, and then typeConnection!$K$2:$L$2 in the

Select a range dialog box.

20. In the Object Browser pane, right-click Antivia Table 8, and select Properties. Xcelsius displays the

properties for Antivia Table 8 in the Properties pane.

21. In the Properties pane, click Report.

22. Click theContent tab.

23. Change the order of the objects in the Available Objects area so that QualifiedMonth is first and Achieved

SLA Count is second. Make sure that the date order for QualifiedMonth is descending.

24. Click theData tab.

25. Click the icon next to the gray Insert data into field, and then typeConnection!$K$125:$L$160 in the

Select a range dialog box.

26. In the Object Browser pane, right-click Antivia Table 9, and select Properties. Xcelsius displays the

properties for Antivia Table 9 in the Properties pane.

27. Click theContent tab.

28. Change the order of the objects in the Available Objects area so that QualifiedMonth is first and Total SLA

Count is second. Make sure that the date order for QualifiedMonth is descending.

29. Click theData tab.

30. Click the icon next to the gray Insert data into field, and then typeConnection!$K$179:$L$214 in the

Select a range dialog box.

31. Click theConnection tab in the spreadsheet for the component.

32. Select all of the contents in columnO. Right-click and selectClear Contents.

33. In column range Connection!$L$56:$L$106, change the goal to 90.

34. From the Xclesius File menu, click Export > SAP BusinessObjects Platform.

35. In the Save As dialog box, expand theXD_Service folder.

36. SelectXD_Service_KPI_Trend_S, and click Save. Xcelsius exports a .swf file and saves it in place of the

existing Service KPI Trend component.

37. If you want to save this source file, from the Xclesius File menu, select Save to Platform.

38. In the Save As dialog box, expand theXD_Xcelsius_Source folder.

39. SelectXD_Service_KPI_Trend_S.xlf, and click Save. Xcelsius saves this .xlf file in place of the existing

Service KPI Trend component source file.

40. Close Xcelsius.

41. Log in to the Executive Scorecard application, and click Admin.
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42. ClickDownload BOE components to Tomcat server. Executive Scorecard downloads to the

Tomcat application the component that you exported to the BusinessObjects Enterprise repository.

Customize the Components
You can customize the components to change settings such as the goals, thresholds, and company revenue so

that the values are appropriate for the business.

To customize components

1. From theWindows Start menu, click Programs > BusinessObjects XI 3.1 > BusinessObjects

Enterprise > Xcelsius.

2. From the File menu in Xcelsius, selectOpen from Platform.

3. Log in to BusinessObjects Enterprise.

4. In the Open dialog box, expand theXD_Xcelsius_Source folder. This folder contains all of the

component source files.

5. Select the .xlf file that you want to customize, and clickOpen. To view a list of the source file names that

correspond to each component title in the Executive Scorecard application, see Component Naming

Conventions on page 88.

6. In the .xlf file, click the Info tab and review the information about the component.

7. Click theConnection tab. In cells with a white background, you can edit the values that you want to

change. DoNOT change the values in cells with a yellow or green background color. Values in green cells

come from your data source, and values in yellow cells get calculated from data in other cells.

8. When you are finishedmaking changes, from the Xclesius File menu, click Export > SAP

BusinessObjects Platform.

9. In the Save As dialog box, find the .swf file with the same file name as the .xlf file you are exporting. Select

the .swf file, and click Save. Xcelsius exports a .swf file and saves it in the BOE repository in place of the

previous version of the component.

10. From the Xclesius File menu, select Save to Platform.

11. In the Save As dialog box, navigate to the folder that contains this file, and click Save. Xcelsius saves this

.xlf file in place of the source file for this component.

12. Repeat the steps in this section to customize any additional components, and then close Xcelsius.

13. Log in to the Executive Scorecard application, and click Admin.

14. ClickDownload BOE components to Tomcat server. Executive Scorecard downloads to the

Tomcat application the .swf files for the components that you exported to the BusinessObjects Enterprise

repository in step 9.
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A Component Reference Information

This appendix provides information about the Executive Scorecard component names, associatedWeb

Intelligence reports, and data sources.

Component Naming Conventions
This section provides a list of each out-of-box component by source name. It lists the default page for the

component, and it also provides the name for the component as it appears in the Component Gallery. For

information about the corresponding data sources andWeb Intelligence reports for the components, see

Component Data Sources on page 91.

Some components are wired so that they can interact with each other on a page. For example, on the Financial

page, if you select a key performance indicator (KPI) on the Financial Scorecard (XD_Financial_Scorecard_P)

component, the Financial KPI Trend (XD_Financial_KPI_Trend_S) component displays information related

to that KPI. The Financial Scorecard component and the Financial KPI Trend components are wired so that

the Financial Scorecard component publishes information to the Financial KPI Trend component. And the

Financial KPI Trend component is wired to subscribe to the Financial Scorecard component.

Component file names are appended with the following values to indicate whether the component is a

subscriber, publisher, or a standalone component:

l _S: The component currently subscribes to another component or is configured to be a subscriber in the

future.

l _P: The component currently publishes to another component.

l _N: The component is a standalone component. It is not wired to subscribe or publish to other

components.

Source File Name and
Component Title as Shown on Default Page Component Gallery Name Default Page

XD_ActualVsPlannedCost_Vertical_S

Actual vs. Planned Cost for FY2010 (x100,000)

Actual vs. Planned Cost (Subscriber) Financial, Summary

XD_DiscVsNonDiscCost_Pie_S

Discretionary vs. Non-Discretionary for FY2010

(x100,000)

Disc vs. NonDisc Cost (Subscriber) Financial, Summary

XD_CapexVsOpexCost_Pie_S

Capex vs. Opex for FY2010 (x100,000)

Capex vs. Opex Cost (Subscriber) Financial, Summary

XD_DepartmentActualVsPlan_Bullet_N

Actual vs. Planned Costs Top 5 Organizations

Actual vs. Planned by Organizations Top 5 Financial
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Source File Name and
Component Title as Shown on Default Page Component Gallery Name Default Page

XD_Financial_Scorecard_P

No title

Financial Scorecard (Publisher) Financial

XD_Financial_KPI_Trend_S

No title

Financial KPI Trend (Subscriber) Financial

XD_Financial_Metadata_N

Financial Dashboard

Financial Metadata Financial

XD_OverallYTDProjectHealth_HorizontalStack_N

Project Health for Active Porjects

Project Health for Active Projects Program, Summary

XD_ProgramActualVsPlanned_Bullet_N

Actual vs. Planned Cost Top 5 Programs

Actual vs. Planned by Program Top 5 Program

XD_ProjectHealthByRegion_Top5_HorizontalStack_N

Project Health Top 5 Regions

Project Health by Region Top 5 Program

XD_SpendingbyBO_Pie_S

Budget Allocation by Business Objective

Budget Alloc by Business Objective

(Subscriber)

Program

XD_Program_Scorecard_P

No title

Program Scorecard (Publisher) Program

XD_Program_KPI_Trend_S

No title

Program KPI Trend (Subscriber) Program

XD_Program_Metadata_N

Program Dashboard

ProgramMetadata Program

XD_MonitoredAvailability_Pie_S

Monitored Availability to SLA

Monitored Availability (Subscriber) Service

XD_SLABreached_Vertical_S

Reported Exceptions to SLA

Reported Exceptions to SLA (Subscriber) Service

XD_SLAIncidentResponseTime_Vertical_S

Incident Response Time to SLA

Incident Response Time to SLA

(Subscriber)

Service

XD_ServiceActualVsPlanned_Bullet_N

Actual vs. Planned Cost Top 5 Services

Actual vs. Planned by Services Top 5 Service

XD_Service_Scorecard_P

No title

Service Scorecard (Publisher) Service

XD_Service_KPI_Trend_S

No title

Service KPI Trend (Subscriber) Service

XD_Service_Metadata_N

Service Dashboard

Service Metadata Service

89 Chapter A



Source File Name and
Component Title as Shown on Default Page Component Gallery Name Default Page

XD_ProjActualVsPlannedCost_Vertical_S

Actual vs. Planned Cost Projects for FY2010 (x100,000)

Actual vs. Planned by Project (Subscriber) Summary

XD_ServicePerformanceAnalysis_Sparkline_N

Service Performance Analysis

Service Performance Analysis Summary

XD_ServiceLevelAchievementOvertime_

StackedColumn_S

Monitored Availability to SLA

Monitored Availability to SLA (Subscriber) Summary

XD_Summary_Metadata_N

Summary Dashboard

Summary Metadata Summary
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Component Data Sources
The table below lists the corresponding data sources and associatedWeb Intelligence (Webi) reports for each

Executive Scorecard component. For information about component naming conventions and Component

Gallery names, see Component Naming Conventions on page 88.

Financial Page

Component Source Associated Webi Report

XD_ActualVsPlannedCost_Vertical_S FPA XD_FPA_ActualCost

XD_FPA_PlannedCost

XD_DiscVsNonDiscCost_Pie_S FPA XD_FPA_Discretionary

XD_FPA_Non_Discretionary

XD_CapexVsOpexCost_Pie_S FPA XD_FPA_Opex

XD_FPA_Capex

XD_DepartmentActualVsPlan_Bullet_N FPA XD_FPA_ActualvsPlan

XD_Financial_Scorecard_P FPA and PPM XD_Financial_KPI:

FPA Tab 1: Financial Control

FPA Tab 2: Innovation Delivery

PPM Tab 4: Unhealthy Budget Risk

FPA XD_FPA_ActualCost

XD_FPA_BusinessServiceActualCost

XD_Financial_KPI_Trend_S FPA and PPM XD_Financial_KPI:

FPA Tab 1: Financial Control

FPA Tab 2: Innovation Delivery

PPM Tab 4: Unhealthy Budget Risk

FPA XD_FPA_Discretionary

XD_FPA_ActualCost

XD_FPA_PlannedCost

XD_FPA_BusinessServiceActualCost

XD_Financial_Metadata

XD_Financial_Metadata_N FPA and PPM XD_Financial_Metadata
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Program Page

Component Source Associated Webi Report

XD_OverallYTDProjectHealth_HorizontalStack_N PPM XD_PPM_TotalProjectCount

XD_ProgramActualVsPlanned_Bullet_N FPA XD_Actual_vs_Plan_Top_Programs

XD_ProjectHealthByRegion_Top5_HorizontalStack_N PPM XD_PPM_ RegionProjectHealthByBudget

XD_SpendingbyBO_Pie_S PPM XD_PPM_BudgetofBOProjects

XD_Program_Scorecard_P PPM XD_Financial_KPI:

Tab 4: Unhealthy Budget Risk

XD_Program _KPI:

Tab 3: % Healthy Projects

XD_BusinessObjective_ProjectCount:

Tab 3: Projects aligned to Business Objectives

FPA XD_FPA_ProjectActualvsPlan

XD_Program_KPI_Trend_S PPM XD_ Program _KPI:

Tab 3: % Healthy Projects

XD_Financial_KPI:

Tab 4: Unhealthy Budget Risk

XD_BusinessObjective_ProjectCount

Tab 1: Total Project Count

Tab 3: % Project Aligned to Business Objectives

FPA XD_Summary_ProjectActualCost

XD_Summary_ProjectPlannedCost

XD_FPA_ProjectActualvsPlan

XD_Program_Metadata_N PPM and FPA XD_Program_Metadata
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Service Page

Component Source Associated Webi Report

XD_MonitoredAvailability_Pie_S BSM XD_BSM_Monitored_Availibility

XD_SLABreached_Vertical_S DC XD_DC_AvailabilitySLABreachCount_

AvailabilitySLATotalCount:

Tab 1: Breached SLA Count

Tab 2: Total SLA Count

XD_SLAIncidentResponseTime_Vertical_S DC XD_DC_IncidentResponseTime:

Tab 1: Achieved SLA Count

Tab 2: Total SLA Count

XD_ServiceActualVsPlanned_Bullet_N FPA XD_Actual_vs_Plan_Top_Services

XD_Service_Scorecard_P BSM and DC XD_Service_KPI:

BSM Tab 1: Service Avail %

BSM Tab 2: Service Response Time %

DCTab 3: % SLA Avail Breached

DC Tab 4: % SLA Response Time Achieve

XD_Service_KPI_Trend_S BSM and DC XD_Service_KPI:

BSM Tab 1: Service Avail %

BSM Tab 2: Service Response Time %

DCTab 3: % SLA Avail Breached

DC Tab 4: % SLA Response Time Achieve

XD_Service_Metadata_N BSM and DC XD_Service_Metadata
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Summary Page

Component Source Associated Webi Report

XD_ActualVsPlannedCost_Vertical_S FPA XD_FPA_ActualCost

XD_FPA_PlannedCost

XD_DiscVsNonDiscCost_Pie_S FPA XD_FPA_Discretionary

XD_FPA_Non_Discretionary

XD_CapexVsOpexCost_Pie_S FPA XD_FPA_Opex

XD_FPA_Capex

XD_ProjActualVsPlannedCost_Vertical_S FPA XD_Summary_ProjectActualCost

XD_Summary_ProjectPlannedCost

XD_ServicePerformanceAnalysis_Sparkline_N FPA XD_FPA_BusinessServiceActualCost

XD_FPA_BusinessServicePlannedCost

DC XD_DC_%SLAAchieved

BSM XD_BSM_%SLABreached

XD_ServiceLevelAchievementOvertime_

StackedColumn_S

BSM XD_BSM_SLACountsCategorization

XD_Summary_Metadata_N FPA, PPM, BSM,

and DC

XD_Summary_Metadata
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