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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty statements 
accompanying such products and services. Nothing herein should be construed as constituting an additional 
warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. Consistent 
with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and 
Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard 
commercial license.

Copyright Notices

© Copyright 2007 – 2008 Hewlett-Packard Development Company, L.P.

Trademark Notices

Microsoft® and Windows® are U.S. registered trademarks of Microsoft Corporation.
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Documentation Updates

To check for recent updates, or to verify that you are using the most recent edition of a document, go to:

http://ovweb.external.hp.com/lpe/doc_serv/ 

You will also receive updated or new editions if you subscribe to the appropriate product support service. 
Contact your HP sales representative for details.
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Support

You can visit the HP software support web site at:

http://www.hp.com/go/hpsoftwaresupport 

HP Software online support provides an efficient way to access interactive technical support tools. As a valued 
support customer, you can benefit by using the support site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a 
support contract.

To find more information about access levels and HP Passport, go to:

http://support.openview.hp.com/new_access_levels.jsp 
4



Contents
1 Introduction . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9

Migration Requirements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9
Migration Environment . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9
Migration Notes  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9

Migration Scenarios . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10

2 Customize the Data Warehouse Schemas . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11

Schema Customization Tips  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
DecisionCenter Analytics Content  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
XML Schema Descriptions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13

Dimension, Fact, and Aggregate Tables  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
The <dimension> Tag  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14
The <dimensionTableName> and <dataSourceTableName> Tags . . . . . . . . . . . . . . . . . . . . . . . . . . 15
The <dimensionTableField> Tag. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16
The <uniqueKeys> Tag . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17

The Fact Table Definition . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
The <scdKeys> Tag . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
The <aggregateKeys> Tag. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20

Associate Table . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21
Hierarchy Table  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22
Direct Mapping Table . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 23

The <directMapping> Tag . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24
The <directMappingField> Tag  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24
The <directMappingIndex> Tag . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25

Arrays  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26
The rdbms_keywords.xml File  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28
Changes to the XML File for Adding Custom Structures . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29

3 Migrate the Data Warehouse . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31

Migration Prerequisites. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31
Migration Checklist . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32
Task 1: Back Up Existing Schema and Scenario Files. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32
Task 2: Upgrade to Connect-It 3.80  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33
Task 3: Run the DecisionCenter 2.00 Installer  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33

Step 1: Install the Data Warehouse for ServiceCenter. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33
Step 2: Install the Data Warehouse for AssetCenter . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 34

Task 4: Reconcile the Files  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 34
Step 1: Update the ServiceCenter Files. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 34
Step 2: Update the AssetCenter Files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 35
 5



Step 3: Edit Connect-It Synchronization Times . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36

4 Customize Scenarios and Universes  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37

ETL Scenario Mapping  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37
Dimension Table and Referenced Dimension Table Changes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39
Universe Filter Conditions for Query or Reporting . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39
Customizing the Scenario . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 40

Simple Field Arrays  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 40
Functions for Dimension Attributes  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43

Viewing the Data Warehouse Universe  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43
Types of Changes to an Existing Universe . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 45
Impact of Universe Changes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 45
Universe Customization Tips  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 45

5 Migrate Reports and Universes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 47

Migration Checklist . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 47
Task 1: Back Up the Business Objects Databases . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 48
Task 2: Save the Customized Files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 48
Task 3: Delete the Original Folders and Content. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 48
Task 4: Install DecisionCenter 2.00 ITPA Content  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 48
Task 5: Complete the Migration . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 49

Step 1: Add Security . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 49
Step 2: Apply Customizations  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 49

6 Business Impact Analysis Migration . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51

Migration Checklist . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51
Task 1: Back Up Existing Files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51
Task 2: Upgrade the Database  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52
Task 3: Run the DecisionCenter 2.00 Installer  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52
Task 4: Configure the Files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52

Step 1: Update database.properties. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52
Step 2: Update process.properties . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 53
Step 3: Update log4j.xml  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 53
Step 4: Update querydefinitions.xml . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 53
Step 5: Update mssql_templates.sql  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 53

Task 5: Complete the Migration . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 54

7 Migrate the Optimization Engine . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 55

Migration Checklist . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 55
Task 1: Back Up Existing Files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 55
Task 2: Run the DecisionCenter 2.00 Installer  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 55
Task 3: Configure the Files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56

Step 1: Copy jmx.properties and priority.properties . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56
Step 2: Update database.properties. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56
Step 3: Update log4j.xml  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56

Task 4: Complete the Migration . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57
6



A Customization Planning  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 59

Customization Checklist . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 60
Task 1: Review Current System and Report Requirements  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 61
Task 2: Customize the Schema . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 61

Step 1: Back Up Existing Files  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 61
Step 2: Modify and Verify the Schema. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 62
Step 3: Run the rds_init Utility . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63

Task 3: Customize the Connect-It Scenario . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 64
Step 1: Modify Data Warehouse Connect-It Scenarios . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 64
Step 2: Test the Scenario  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 67
Step 3: Review Global Functions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 68

Task 4: Customize the Universe . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 68
Step 1: Generate the Universe Report. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 68
Step 2: Check Data Integrity . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 69
Step 3: Modify the Universe . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 69
Step 4: Export the Universe . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 70

Task 5: Implement the Changes in a Test Environment . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 71
Task 6: Map and Test the Tailored Data Schema  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 71
Task 7: Deploy to a Production Environment. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 72
Task 8: Continue to Customize Your Environment . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 72

B Schema Changes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 73

DecisionCenter 1.00 Table Changes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 73

C Scenario Changes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 75

DecisionCenter 2.00 Scenario Changes  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 75
7



8



1 Introduction
The HP DecisionCenter 2.00 migration process requires familiarity with data warehouse 
schemas, Connect-It scenarios, and Business Objects universes. The information in this 
document is for advanced users who are responsible for:

• Customizing and configuring the DecisionCenter data warehouse schemas, reports, 
universes. 

• Installing DecisionCenter with the three product components: IT Performance 
Analytics (ITPA), Business Impact Analytics (BIA), and Optimization.

Ensure that you have access to, and permissions to use, the resources on the computer and 
network of the HP DecisionCenter 2.00 installation.

Migration Requirements

HP DecisionCenter 1.00 is a candidate for migration if you can meet these requirements:

• DecisionCenter 1.00 successfully installed with all required components

• ServiceCenter 5.1, 6.0, 6.1, or 6.2 with one of the following schema conditions

— An out-of-box schema

— A well-migrated schema

— A ServiceCenter schema customized only with additional tables or fields

Ensure that you complete all ServiceCenter migration steps before you begin migration. 
You must run the DecisionCenter 2.00 unload file for ServiceCenter that is in the Support 
files directory on the DecisionCenter installation media.

• AssetCenter 4.3, 4.4, or 5.0

Ensure that you complete all AssetCenter migration steps before you begin migration. 
You must run the DecisionCenter 2.00 script file for AssetCenter that is in the Support 
files directory on the DecisionCenter installation media.

Migration Environment

Ensure that you meet all of the requirements described in the DecisionCenter Installation 
Guide and in the DecisionCenter Support Matrix on the HP Software Support web site.

Migration Notes

The following list describes the BusinessObjects resources that you can use during the 
migration process.
9
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• If you customized DecisionCenter 1.00 reports and universes, you should install the 
DecisionCenter 2.00 reports and universes and re-apply the original customization.

• Review the BusinessObjects documentation for any post-migration tasks that you might 
need to complete, and how to validate the migrated objects, such as universes and reports, 
in the new environment.

Migration Scenarios

The DecisionCenter migration process enables you to merge your customized schemas, 
reports, and universes with the DecisionCenter 2.00 features. 

See the DecisionCenter Installation Guide for information about running the installer to get 
the latest files that you need to take advantage of the new DecisionCenter features. 

The migration instructions guide you through upgrading:

• DecisionCenter 1.00 data warehouse schemas and content (reports and universes)

• DecisionCenter 1.00 ITPA

• DecisionCenter 1.00 ITPA + BIA

• DecisionCenter 1.00 ITPA + BIA + Optimization

This guide has separate chapters for each major upgrade step. The chapters are in the 
suggested order of migration.

Table 1 Document Map

Chapter Description

Chapter 1, Introduction Migration scenarios

Chapter 2, Customize the Data Warehouse 
Schemas

Customization hints for the data warehouse 
schema

Chapter 3, Migrate the Data Warehouse Migration steps for a customized data 
warehouse

Chapter 4, Customize Scenarios and 
Universes

Customization hints for the data warehouse 
scenario and universes

Chapter 5, Migrate Reports and Universes Migration steps for customized reports and 
universes

Chapter 6, Business Impact Analysis 
Migration

Migration steps for business impact analysis

Chapter 7, Migrate the Optimization Engine Migration steps for the optimization engine

Appendix A, Customization Planning How to plan the implementation strategy 
when customizing the data warehouse

Appendix B, Schema Changes Data warehouse table changes in the 
rds_etl.xml file

Appendix C, Scenario Changes Scenario structure changes that support 
ServiceCenter 6.2 and Service Manager 7.0 
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2 Customize the Data Warehouse Schemas
The Data Warehouse Administration Online Help topics and Best Practices for Data 
Warehouse Administration Guide provide an introduction to the data warehouse schemas. 
The following information is for advanced users who customize the data warehouse schema. 
Topics include:

— Schema Customization Tips on page 11

— DecisionCenter Analytics Content on page 12

— XML Schema Descriptions on page 13

— The rdbms_keywords.xml File on page 28

— Changes to the XML File for Adding Custom Structures on page 29

Schema Customization Tips

For easy migration and maintenance, set proper naming conventions for customized fields 
and tables. For example, to modify the data warehouse schema, the new attributes or tables 
can start with C_ to mean Customized. The data warehouse uses consistent naming 
conventions. All the entities in the data warehouse, such as tables or fields, use uppercase. For 
example, INCIDENT_D.

The rds_etl.xml file provides data warehouse schema data. The rds_etl.xsd file defines the 
XML schema syntax. These files are in the data warehouse installation conf directory: 
\\…\HP\DecisionCenter 2.00\ITPA-SM for ServiceCenter and Service Manager and 
\\…\HP\DecisionCenter 2.00\ITPA-AM for Asset Management. 

Always back up the rds_etl.xml file before you modify the data warehouse schema. To adhere 
to best practices, do not remove the out-of-box data warehouse files and fields. 

When customizing any XML file, use an XML editor tool to validate your changes against the 
schema file. 

The DecisionCenter synchronization process marks AssetCenter and ServiceCenter deletion 
event records in the data warehouse. To adhere to best practices, do not customize the deletion 
process because it may break the existing metadata and sample reports. 
  11



DecisionCenter Analytics Content

The data warehouse default schema contains tables for ServiceCenter OLAP summary 
reporting and operational detail reporting as well as AssetCenter Portfolio, Finance, and 
Contract. Sample reports are available for ServiceCenter and AssetCenter modules. Common 
support files are linked with ServiceCenter modules.

Table 2 Default Schema Content

Content ServiceCenter AssetCenter

Modules • Change Management
• Configuration Management
• Incident Management
• Problem Management
• Request Management
• Service Level Agreement Management
• Service Management

• Portfolio
• Finance
• Contract

Common Support Files • Contacts
• Location
• Dept
• Company
• Operator
• Vendor
• Model
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XML Schema Descriptions

The data warehouse XML files have several types of defined tables. Each table has a unique 
purpose and definition. The tables are:

Each table type has its own section in the XML file. Make sure that you create a table within 
the defined tags for that type. The following sections explain each table type and its syntax in 
detail.

Dimension, Fact, and Aggregate Tables

Dimension tables are robust tables with associated fact (measure) and aggregate tables. Use 
dimension tables to map tables with commonly used measure information. Otherwise, map 
the table as a direct mapping table.

The following code is a simplified version of the out-of-box INCIDENT_D dimension table.

<dimension name=”INCIDENT” rdsVersion=”5.3” attributeAction=”update”>
      <dimensionTableName>
        INCIDENT_D
      </dimensionTableName>
      <dataSourceTableName>
        incidents
      </dataSourceTableName>
      <dimensionTableFields>

Table 3 Data Warehouse Tables

Table Type Description

Dimension Dimension tables map the tables in your source database 
containing the dimensions and measures at the core of your 
reports. Good candidates for this type of table are financial 
information (expline, amExpenseLine), Configuration Items 
(device, amAsset), Call and Incident (incidents, 
probsummary), or any tables containing counts and sums 
that require tracking.
Dimension tables are often paired with:
• Fact tables, which contain simplified measure 

information and links to other common Dimension tables. 
• Aggregate tables, which roll up measures based on the 

most common grouping fields for faster processing.

Direct Mapping You can map tables that are useful for reports in a 
supporting capacity as direct mappings. These tables are 
simplest to set up.

Associate Associate, or bridge, tables normalize many-to-many 
relationships, thus preventing many of the traps that can 
lead to bad data.

Hierarchy Drill down functions in reports rely on parent-child 
relationships between records. Hierarchy tables create a 
drill tree for easy layering of data. These are useful for 
organization charts, CI relationships, and locations.
Customize the Data Warehouse Schemas 13



        <dimensionTableField name=”INCIDENT_ID” type=”char” size=”100”/>
        <dimensionTableField name=”CONTACT_NAME” type=”char” size=”140”/>
        <dimensionTableField name=”SEVERITY” type=”char” size=”60”/>
        <dimensionTableField name=”HANDLE_TIME” type=”float”/>
        <dimensionTableField name=”OPEN_TIME” type=”date”/>
        <dimensionTableField name=”CLOSE_TIME” type=”date”/>
        <dimensionTableField name=”FIRST_CALL” type=”char” size=”1”/> 
        <dimensionTableField name=”ASSIGNMENT” type=”long”/>
        <dimensionTableField name=”AGEDURATION” type=”float”/>
      </dimensionTableFields>
      <uniqueKeys name=”incident_unique”>
        <uniqueKey fieldName=”INCIDENT_ID” srcFieldName=”''incident.id''” 

srctype=”char” size=”100” 
          seqIndex=”1” defaultValue=”no match”/>
      </uniqueKeys>
      <facts>
        <fact name=”INCIDENT_F”>
          <factKeys>
             <factKey name=”Z_RDSINCIDENT_DID”/>
             <factKey name=”Z_RDSCONTACT_DID” fieldName=”CONTACT_NAME”
               tableName=”CONTACT_D” matchFieldName=”CONTACT_NAME”/>
          </factKeys>
          <factMeasures>

<factMeasure name=”HANDLE_TIME” srcType=”src”/>
<factMeasure name=”INCIDENT_OPEN” srcType=”rdsfactless”/>
<factMeasure name=”INCIDENT_CLOSE” srcType=”rds” 

sqlConditions=”CLOSE_TIME is 
               not null” resetCount=”INCIDENT_OPEN”/>
             <factMeasure name=”FIRST_CALL_COUNT” srcType=”rds” 

sqlConditions=”FIRST_CALL ='1'”
               resetCount=””/>
          </factMeasures>
        </fact>
      </facts>
      <scdKeys>
        <scdKey rdsFieldName=”OPENPRGN” srcFieldName=”OPEN” srctype=”char”/>
        <scdKey rdsFieldName=”SEVERITY” srcFieldName=”SEVERITY” 

srctype=”char”/>
      </scdKeys>
      <aggregateKeys>
        <aggregateKey name=”SEVERITY” type=”char” size=”60”/>
        <aggregateKey name=”OPEN_TIME” type=”TIME”/>
      </aggregateKeys>
    </dimension>

You need to understand the tags and their attributes before you customize the schema. The 
following sections describe the attributes and tags in this sample code.

The <dimension> Tag

The <dimension> tag frames the whole object. 

<dimension name=”INCIDENT” rdsVersion=”5.3” attributeAction=”update”> 
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It has the following attributes:  

The <dimensionTableName> and <dataSourceTableName> Tags

The <dimensionTableName> displays the name of the table with the _D suffix. Make sure 
that this matches the name attribute from the <dimension> tag. 

The <dataSourceTableName> tag contains the name of the source table as it appears in 
HP ServiceCenter or HP AssetCenter. Make sure that the name matches exactly because it is 
case-sensitive.

Table 4 <dimension> Attributes

Attribute Description

name The root name (not including suffixes) of the dimension 
table, and any related fact or aggregate tables. The data 
warehouse uses the following conventions as best practices: 
• The name must be unique in the data warehouse.
• The name matches the name of the source table in 

HP ServiceCenter or HP AssetCenter.
• The name cannot be longer than 15 characters. 
• If the source table name is plural, use the singular 

version of the word. For example, incidents becomes 
incident.

rdsVersion If you set this to ”5.0”, the table ignores the 
rdbms_keywords.xml file. Any other setting is simply 
informative. For more information, see The 
rdbms_keywords.xml File on page 28.

attributeAction Optional. This attribute tells the migration program how to 
properly handle the changes. 

For proper formatting, make sure that you include </dimension> as the closing tag.

<dimensionTableName>
INCIDENT_D

</dimensionTableName>
<dataSourceTableName>
incidents

</dataSourceTableName>
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The <dimensionTableField> Tag

The <dimensionTableField> contains the main body of the table, defining each field.

It has the following attributes: 

<dimensionTableFields>
   <dimensionTableField name=”INCIDENT_ID” type=”char” size=”100”/>
   <dimensionTableField name=”CONTACT_NAME” type=”char” size=”140”/>
   <dimensionTableField name=”SEVERITY” type=”char” size=”60”/>
   <dimensionTableField name=”HANDLE_TIME” type=”float”/>
   <dimensionTableField name=”OPEN_TIME” type=”date”/>
   <dimensionTableField name=”CLOSE_TIME” type=”date”/>
   <dimensionTableField name=”FIRST_CALL” type=”char” size=”1”/>
   <dimensionTableField name=”ASSIGNMENT” type=”long”/>
   <dimensionTableField name=”AGEDURATION” type=”float”/>
 </dimensionTableFields>

Table 5 <dimensionTableField> Attributes

Attribute Description

name The name that you use for the field. The data warehouse uses the 
following conventions as best practices: 
• The name must be unique in the table.
• The name matches the name of the source table in 

HP ServiceCenter or HP AssetCenter.
• The underscore character (_) replaces the period (.) in the field 

name. For example, contact.name becomes CONTACT_NAME.

type This is the data type to use. The data warehouse uses four data types: 
char, float, date, and long. The following chart shows how they map 
from common HP ServiceCenter data types:

size You use this attribute only when type=”char”. This is the length of 
the field according to your data.

attributeAction Optional. This attribute tells the migration program how to properly 
handle the changes.

ServiceCenter Data Type Data Warehouse Data Type

character char 

number float 

date date 

date (relative) float 

logical char size=1 

array (simple) long 

array of structure map to new table (see Arrays on 
page 26.
16 Chapter 2



The <uniqueKeys> Tag

The <uniqueKeys> tag defines the unique key for the table. It has only the name property. For 
best practices, use the name of the table, followed by ”_unique”. This name must be unique 
in the database.

<uniqueKeys name=”incident_unique”>
 <uniqueKey fieldName=”INCIDENT_ID” srcFieldName=”''incident.id''” 

srctype=”char” size=”100” seqIndex=”1” defaultValue=”no match”/>
</uniqueKeys>

Inside the <uniqueKeys> set of tags is one or more <uniqueKey> tag with the following 
attributes:

Table 6 <uniqueKey> Attributes

Attribute Description

fieldName This is the name of the field from the <dimensionTableField> tag. 
The data warehouse uses the following conventions as best practices:
• The <dimensionTableFields> section must have an equivalent 

field defined.
• The field must be type=”char”. If the key field is a different data 

type, create a second field with the extension _KEY to contain the 
text version of the data. For example, the OUTAGE_D table has the 
the following code:

<dimensionTableField name=”OUTAGE_ID” type=”float”/> 
<dimensionTableField name=”OUTAGE_ID_KEY” type=”char” 
size=”60”/> 

The original numeric data is mapped to OUTAGE_ID, and a text 
equivalent is mapped to OUTAGE_ID_KEY. The <uniqueKey> tag 
uses the latter.

scrFieldName This is the name of the field as it appears in HP ServiceCenter or 
HP AssetCenter. This is case-sensitive. The data warehouse uses the 
following conventions as best practices:
•  If the field is contained in a structure, include the structure name, 

separated by a period. For example, In the PROBLEM table, 
srcFieldName=”header.number”.

• If the field name contains a period, surround the name with two 
single quotation marks. For example, in the INCIDENT table, the 
attribute reads: 

     srcFieldName=”''incident.id''” 

The TZFILE_SWITCH table has the following key: 

srcFieldName=”switchover.''local.switchover.time''” 

scrType This is the data type of the original field (char, date, float, or long). If 
you converted the field to char from another type, list the data 
warehouse data type closest to the original type.
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The Fact Table Definition

The fact table definition section is optional. If you do not need a fact table, replace the entire 
section with the <facts> tag.

A fact table has two sections: <factKeys> and <factMeasures>.

The <factKeys> section defines the links between dimension tables. The first key is the 
unique fact key for this table. It contains only the name attribute. For best practices, use the 
naming convention Z_RDS<table name>_DID.

size You use this attribute only when type=”char”. This is the size of the 
field from the <dimensionTableField> tag.

seqIndex If you use more than one field in the key, the order to process the fields 
starts from 1. The data warehouse uses the following conventions as 
best practices:
• To determine which fields to use and in what order, open the 

Database Dictionary tool from HP ServiceCenter. View the 
structure of the source table and look at the Indexes section on the 
right. Find the FIRST key with a unique designation. Mimic the 
order of these fields. This ensures that delete synchronization 
works properly.

• You can use a maximum of 5 fields in a composite key for a 
dimension table. If the table requires more than that, consider 
making a direct mapping table instead.

defaultValue This must always be ”no match”.

Table 6 <uniqueKey> Attributes

Attribute Description

<facts>
 <fact name=”INCIDENT_F”>
   <factKeys>
     <factKey name=”Z_RDSINCIDENT_DID”/>
     <factKey name=”Z_RDSCONTACT_DID” fieldName=”CONTACT_NAME”
      tableName=”CONTACT_D” matchFieldName=”CONTACT_NAME”/>
     <factKey name=”OPEN_TIMEID” fieldName=OPEN_TIME” 
tableName=RDS_TIMEDIM_D” matchFieldName=”FULLDATE”/>
    </factKeys>
    <factMeasures>
       <factMeasure name=”HANDLE_TIME” srcType=”src”/>
       <factMeasure name=”FIRST_CALL_COUNT” srcType=”rds”/>       
sqlConditions=”FIRST_CALL ='1'”
               resetCount=””/>
       <factMeasure name=”INCIDENT_OPEN” srcType=”rdsfactless”/>
       <factMeasure name=”INCIDENT_CLOSE” srcType=”rds” 
sqlConditions=”CLOSE_TIME is not null” resetCount=”INCIDENT_OPEN”/>
    <factMeasures>
 </fact>
</facts>
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All other keys are foreign keys to other dimension tables. They use the following attributes:

Use the following conventions as best practices for fact keys:

• At least one fact key must be a DATE field linked to RDS_TIMEDIM_D.FULLDATE.

• The maximum number of fact keys in a single table is 10.

The <factMeasures> section contains the numeric fields that you want to track and 
aggregate. Most measures are mappings for fields from the <dimensionTableFields> 
section. In that case, use only the attribute srcType=”src”. 

A special pair of types, rdsfactless and rds, create a flag field to use for counts and filters.

To create a simple flag, use the properties srcType=”rds” and resetCount=””. For each 
record, this flags the column with a 1 if the criteria in the sqlConditions is met, and with a 0 
if not met. FIRST_CALL_COUNT is an example of this method.

A more advanced option is to create a binary pair of flags where one is always true and one 
false. To do this, create one measure with the attribute srcType=”rdsfactless” (see 
INCIDENT_OPEN in the previous code). Then create a second with the properties 
srcType=”rds” sqlConditions=”<your criteria>” resetCount=”<factless measure 
name>” (see INCIDENT_CLOSE in the previous code). For each record, the ETL process 
determines if the condition in the sqlConditions attribute is met. If it is, INCIDENT_OPEN 
gets a value of 0, and INCIDENT_CLOSE gets a value of 1. If not, the opposite happens.

The <scdKeys> Tag

The Slowly Changing Dimension (SCD) fields section is optional. If you do not need a fact 
table, replace the entire section with the <scdKeys> tag. 

The SCD key tracks the history of a field. When you update a record in a way that alters the 
SCD key, a copy of the record is made. The original record is marked obsolete, but remains in 
the database.

The maximum number of SCD fields is 10.

Table 7 Foreign Key Attributes

Attribute Description

name The name of the fact key for the foreign table.

fieldName The name of the dimension table field (from this table) used for the 
join.

tableName The name of the foreign dimension table.

matchFieldName The name of the dimension table field (from the foreign table) used for 
the join.

You can have only one rdsfactless measure per table.

<scdKeys>
<scdKey rdsFieldName=”OPENPRGN” srcFieldName=”OPEN” srctype=”char”/>
<scdKey rdsFieldName=”SEVERITY” srcFieldName=”SEVERITY” srctype=”char”/>

</scdKeys>
Customize the Data Warehouse Schemas 19



SCD fields have the following attributes:

The <aggregateKeys> Tag

The aggregate table definition section is optional. If you do not need an aggregate table, 
replace the entire section with the <aggregateKeys> tag. 

All the measures from your fact table are summed up over time for each unique value in each 
aggregate key. 

Table 8 SCD Field Attributes

Attribute Description

rdsFieldName This is the name of the field from the <dimensionTableFields> 
section. The data warehouse uses the following conventions as best 
practices:
• There must be an equivalent field defined in the 

<dimensionTableFields> section.
• The field must be type=”char”. If the key field is a different data 

type, create a second field with the extension _KEY to contain the 
text version of the data.

srcFieldName This is the name of the field as it appears in HP ServiceCenter or 
HP AssetCenter. The data warehouse uses the following conventions 
as best practices:
•  If the field is contained in a structure, include the structure name, 

separated by a period. For example, In the PROBLEM table, 
srcFieldName=”header.number”.

• If the field name contains a period, surround the name with two 
single quotation marks. For example, in the INCIDENT table, the 
attribute reads: 

     srcFieldName=”''incident.id''” 

The TZFILE_SWITCH table has the following key: 

srcFieldName=”switchover.''local.switchover.time''” 

srctype This is the data type of the original field (char, date, float, or long). 
If you converted the field to char from another type, list the data 
warehouse data type closest to the original type.

<aggregateKeys>
   <aggregateKey name=”SEVERITY” type=”char” size=”60”/>
   <aggregateKey name=”OPEN_TIME” type=”TIME”/>
</aggregateKeys>
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Aggregate keys have the following attributes: 

Aggregate keys use the following conventions:

• Aggregate keys (except the last key) must use the type=”char” attribute.

• The last aggregate key must be a date field with the type=”TIME” attribute. Only one 
date type is allowed.

• The maximum number of aggregate keys is 15. 

Associate Table

The associate tables, also called bridge tables, are used for many-to-many relationships 
between dimension tables.

<associates>
<associate name=”INCIDENT_MODEL_ASS” tableName=”INCIDENT”     

fieldName=”MODEL” tableName2=”MODEL”fieldName2=”MODEL”/>
<associate name=”CM3R_DEVICE_ASS” tableName=”CM3R” 

fieldName=”logical_name” longFieldName=”assets” tableName2=”DEVICE” 
fieldName2=”LOGICAL_NAME”/>

</associates>

Associate tables have the following parameters:

Table 9 <aggregateKeys> Attributes

Attribute Description

name This is the name of the field from the <dimensionTableFields> 
section.

type This is the data type of the field (char, date, float, or long).

size You use this attribute only when type=”char”. This is the size of the 
field from the <dimensionTableField> tag.

For proper formatting, include </dimension> as the closing tag.

Table 10 Associate Table Attributes

Attribute Description

name The unique name for this table. For best practices, use the first 8 
letters of the tables to be joined, separated by an underscore, followed 
by the extension _ASS.

tableName The name of the first dimension table (with no suffix).

fieldName The name of the field to bridge in the first dimension table.

longFieldName Optional. If the join in question involves a list of values (such as an 
array of character field in HP ServiceCenter), map that array to a 
long data type in the dimension table, then refer to that long field 
here. The data in the array of character field merges with the field in 
fieldName to create a list of associate records.
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For example, the cm3r table (Change Management) contains a primary configuration item for 
the change (cm3r.logical.name) and an array of additional configuration items (cm3r.assets).

If your original record contains:

then the associate table contains these records:

• tableName2 The name of the second dimension table (with no suffix).

• fieldName2 The name of the field to bridge in the second dimension table.

Hierarchy Table

Hierarchy tables based on dimension tables are created for Online Analytical Processing 
(OLAP) summary reports. You can use the hierarchy levels to drill to lower, or detail, levels. 
The predefined hierarchy examples in HP ServiceCenter include location, department, 
contacts, and device.

<hierarchies>
     <hierarchy tablename=”location” type=”fullpath” level=”5” 

uniquefieldName=”location” fullpathfieldname=”location_full_name”/>
     <hierarchy tablename=”contact” type=”parent” level=”5” 

uniquefieldName=”contact_name” parenttableName=”contact” 
parentfieldname=”manager”/>

</hierarchies> 

The two types of hierarchies are: fullpath and parent.

The fullpath style of hierarchy assumes the presence of a field in the table containing the fully 
qualified path of the object in the hierarchy. This is the traditional method that 
HP AssetCenter tables use. The location in the previous example illustrates this method.

The parent style of hierarchy assumes the table contains a foreign key that maps to the 
unique key of the parent record. The contact table in the previous example uses this method. 
Each contact record contains a manager field holding the ID of another contact record.

Change Number: C1

Primary CI: Server101

Affected CIs: PC001, PC002, PC003

Change Number Logical Name

C1 Server101

C1 PC001

C1 PC002

C1 PC003
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Hierarchies have the following attributes:

Direct Mapping Table

Direct mapping tables are simple structures with no associated fact, hierarchy, or aggregate 
tables. Use direct mappings for supporting and detail tables.

The following code is a simplified version of the out-of-box Activity direct mapping table.

    <directMapping name=”activity” rdsVersion=”5.0” 
dataSourceTableName=”activity”       
parentDimensionTableName=”PROBSUMM” attributeAction=”update”>

      <directMappingFields>
        <directMappingField name=”THENUMBER” type=”char” size=”50”/>
        <directMappingField name=”NUMBERPRGN” type=”char” size=”60”/>
        <directMappingField name=”TYPE” type=”char” size=”60”/>
        <directMappingField name=”NEGDATESTAMP” type=”float”/>
      </directMappingFields>
      <directMappingIndexes>
        <directMappingIndex name=”UNIQACTIVITY_IDX”>
          <DirectMappingIndexKey fieldName=”numberprgn” srcFieldName=”number” 

srctype=”char” size=”60” seqIndex=”1”/>
          <DirectMappingIndexKey fieldName=”negdatestamp” 

srcFieldName=”negdatestamp” srctype=”date” seqIndex=”2”/>
          <DirectMappingIndexKey fieldName=”thenumber” 

srcFieldName=”thenumber” srctype=”char” size=”60” seqIndex=”3”/>
        </directMappingIndex> 
        <directMappingIndex name=”DELACTIVITY_IDX”>
          <DirectMappingIndexKey fieldName=”NUMBERPRGN” 

srcFieldName=”NUMBERPRGN” srctype=”char” size=”60”/>
        </directMappingIndex>
      </directMappingIndexes>
    </directMapping>

Table 11 Hierarchy Table Attributes

Attribute Description

tablename The name of the dimension table to extract the hierarchy from.

type Enter fullpath or parent as appropriate.

level The number of tiers to process. By default this is 5 and the maximum 
is 10.

uniquefieldName For a fullpath type, this contains the field used to build the fullpath. 
For a parent type, this contains the unique ID of the parent table. 

fullpathfieldname For the fullpath type only, this is the field containing the fully 
qualified path.

parenttablename For the parent type only, this is the name of the table containing the 
parent record. This can be the same as the tablename attribute if the 
table refers to itself.

parentfieldname For the parent type only, this is the field containing the foreign key.
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You need to understand the tags and their attributes before you customize the schema. The 
following sections describe the attributes and tags in this sample code.

The <directMapping> Tag 

 The <directMapping> tag frames the whole object. 

It has the following attributes: 

The <directMappingField> Tag

The <directMappingField> contains the main body of the table, defining each field.

 <directMapping name=”activity” rdsVersion=”5.0” dataSourceTableName=”activity” 
      parentDimensionTableName=”PROBSUMM” attributeAction=”update”>

Table 12 <directMapping> Attributes

Attribute Description

name The root name for the table. This must match the name of 
the source table.

rdsVersion If you set this to ”5.0”, the table ignores the 
rdbms_keywords.xml file. All other settings are informative. 
For more information, see The rdbms_keywords.xml File on 
page 28.

dataSourceTableName The name of the table as it appears in HP ServiceCenter or 
HP AssetCenter.

parentDimensionTableName Optional. If you use cascading deletions, this is the name of 
the dimension table where deletions trigger a deletion of 
related records in your direct mapping table. You must 
specify a delete index.

attributeAction Optional. This attribute tells the migration program how to 
properly handle the changes. 

For proper formatting, make sure that you include </directMapping> as the closing tag.

<directMappingFields>
<directMappingField name=”THENUMBER” type=”char” size=”50”/>
<directMappingField name=”NUMBERPRGN” type=”char” size=”60”/>
<directMappingField name=”TYPE” type=”char” size=”60”/>
<directMappingField name=”NEGDATESTAMP” type=”float”/>

</directMappingFields>
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It has the following attributes: 

The <directMappingIndex> Tag

The two index types are unique and delete. The unique key is required. You only use the delete 
key if you set up a cascading delete, described in the parentDimensiontableName attribute on 
page 24. 

The <directMappingIndex> tag has one attribute: name. The name attribute typically follows 
the pattern UNIQ<TABLENAME>_IDX for unique keys and DEL<TABLENAME>_IDX for 
delete keys.

Table 13 <directMappingField> Attributes

Attribute Description

name The name that you use for the field. The data warehouse uses the 
following conventions as best practices: 
• The name must be unique in the table.
• The name matches the name of the source table in 

HP ServiceCenter or HP AssetCenter.
• The underscore character (_) replaces the period (.) in the field 

name. For example, contact.name becomes CONTACT_NAME.

type This is the data type to use. The data warehouse uses four data types: 
char, float, date, and long. The following chart shows how they map 
from common HP ServiceCenter data types: 

size You use this attribute only when type=”char”. This is the length of 
the field according to your data.

attributeAction Optional. This attribute tells the migration program how to properly 
handle the changes.

ServiceCenter Data Type Data Warehouse Data Type

character char 

number float 

date date 

date (relative) float 

logical char size=1 

array (simple) long 

array of structure map to new table (see Arrays on 
page 26.
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Inside the <DirectMappingIndexKey> set of tags is one or more <DirectMappingIndexKey> 
tag with the following attributes:  

Arrays

HP ServiceCenter tables contain array and structure data types that typical RDBMS 
systems do not support. As such, they require special handling. 

The two methods for mapping arrays are:

• Simple Array of Char type fields (a list of strings) where you can create a single field in 
the main table of type long. This concatenates all lines into a single body of text. This is 
useful for comments and lists of items that do not need to be individually processed.

Table 14 <directMappingIndexKey> Attributes

Attribute Description

fieldName This is the name of the field from the <directMapingField> tag. 

scrFieldName This is the name of the field as it appears in HP ServiceCenter or 
HP AssetCenter. This is case-sensitive. The data warehouse uses the 
following conventions as best practices:
•  If the field is contained in a structure, include the structure name, 

separated by a period. For example, In the PROBLEM table, 
srcFieldName=”header.number”.

• If the field name contains a period, surround the name with two 
single quotation marks. For example, in the INCIDENT table, the 
attribute reads: 

     srcFieldName=”''incident.id''” 

The TZFILE_SWITCH table has the following key: 

srcFieldName=”switchover.''local.switchover.time''” 

scrType This is the data type of the original field (char, date, float, or long). 
Unlike dimension tables, direct mapping keys can be any data type.

size You use this attribute only when type=”char”. This is the size of the 
field from the <dimensionTableField> tag.

seqIndex If you use more than one field in the key, the order to process the fields 
starts from 1. The data warehouse uses the following conventions as 
best practices:
• To determine which fields to use and in what order, open the 

Database Dictionary tool on HP ServiceCenter. View the structure 
of the source table and look at the Indexes section on the right. 
Find the FIRST key with a unique designation. Mimic the order of 
these fields. This ensures that delete synchronization works 
properly.

• A maximum of 10 fields is allowed in a composite key for a direct 
mapping table.

For proper formatting, include </directMapping> as the closing tag.
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• Complex items, such as Array of Structure types, where you must map the data to a new 
data warehouse table that is associated to the original.

The clock table in the following example contains an array of structure called events.

The main table, created as a dimension table because it contains measure information, is 
CLOCK_D. The array is mapped to direct mapping table CLOCK_EVENTS because it 
contains only supporting data. 

As a best practice, the name contains the name of the parent and the name of the array, 
separated by an underscore. The parentDimensionTableName attribute is set to CLOCK, 
indicating that this table is dependent on another table.

<directMappingFields>               
<directMappingField name=”TYPE” type=”char” size=”60”/>
<directMappingField name=”KEY_CHAR” type=”char” size=”60”/>
<directMappingField name=”KEY_NUMERIC” type=”float”/>   
<directMappingField name=”NAME” type=”char” size=”60”/>
<directMappingField name=”START” type=”date”/>
<directMappingField name=”STOP” type=”date”/>

</directMappingFields>

The events array contains only two fields: START and STOP. Because it is necessary to associate 
each record with the parent record from CLOCK_D, you must add a copy of all fields that 
comprise the unique key for the parent table. In this case, CLOCK_D has a composite key made 
of four fields: TYPE, KEY_CHAR, KEY_NUMERIC, and NAME.

<directMappingIndexes>
<directMappingIndex name=”UNIQCLOCKEV_IDX”>
<DirectMappingIndexKey fieldName=”TYPE” srcFieldName=”type” 

srctype=”char” size=”60” seqIndex=”1”/>
    <DirectMappingIndexKey fieldName=”KEY_CHAR” srcFieldName=”''key.char''” 

srctype=”char” size=”60” seqIndex=”2”/>
    <DirectMappingIndexKey fieldName=”KEY_NUMERIC” 

srcFieldName=”''key.numeric''” srctype=”float” seqIndex=”3”/>
    <DirectMappingIndexKey fieldName=”NAME” srcFieldName=”name” 

srctype=”char” size=”60” seqIndex=”4”/>
    <DirectMappingIndexKey fieldName=”START” srcFieldName=”events.start” 

srctype=”date” seqIndex=”5”/>
    <DirectMappingIndexKey fieldName=”STOP” srcFieldName=”events.stop” 

srctype=”date” seqIndex=”6”/>
</directMappingIndex> 

<directMapping name=”CLOCK_EVENTS” rdsVersion=”5.3” attributeAction=”add” 
      parentDimensionTableName=”CLOCK”>
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Arrays do not contain their own unique key, so it is necessary to build a unique set of fields. 
You start by adding all the unique keys from the parent table. Then you add as many fields as 
necessary from the array to enforce uniqueness. In this case, you cannot guarantee a unique 
record unless you add both START and STOP. The result is a six-part composite key.

Because the data warehouse only tracks deletions on source tables, it is necessary to associate 
this table with the parent for cascading deletes. A second index is made containing all fields 
that comprise the unique key for the parent.

Using the Connect-It scenario, you must create a new mapping for this destination table. You 
can reuse the same produced document from HP ServiceCenter that mapped the parent, but 
you must make a separate mapping.

The rdbms_keywords.xml File

The data warehouse has a predefined rdbms_keywords.xml file to accommodate every 
RDBMS set of reserved words. When the field names specified in the rds_etl.xml file match 
one of the keywords in rdbms_keywords, the data warehouse field name uses the field name 
with the suffix of PRGN. For example, the type field name becomes the TYPEPRGN field 
name.

For backward compatibility, reserved words domain and value do not change for 
PROBSUMM_D and DEVICE_D. Reserved words type, month, year, and action do not 
change for direct mapping tables with the <rdsVersion> attribute set to 5.0. 

<directMappingIndex name=”DELCLOCKEV_IDX”>
<DirectMappingIndexKey fieldName=”TYPE” srcFieldName=”type” srctype=”char” 

size=”60” seqIndex=”1”/>
<DirectMappingIndexKey fieldName=”KEY_CHAR” srcFieldName=”''key.char''” 

srctype=”char” size=”60” seqIndex=”2”/>
<DirectMappingIndexKey fieldName=”KEY_NUMERIC” 

srcFieldName=”''key.numeric''” srctype=”float” seqIndex=”3”/>
<DirectMappingIndexKey fieldName=”NAME” srcFieldName=”name” srctype=”char” 

size=”60” seqIndex=”4”/>
</directMappingIndex>
</directMappingIndexes>

</directMapping> 
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Changes to the XML File for Adding Custom Structures

The following table contains tags that the XML file uses only for migration. When you add or 
change tables after you run the rds_init utility, you can use these tags to avoid deleting 
tables and data. 

Make sure that you add all the appropriate attributeAction tags to any objects you altered or 
added. The attributeAction tags:

• Include add, deletedata, historical, update, and updatewithfact values at the table 
level.

• Include the add value at the column level.

• Are not available for fact or associate tables.

• Require the update value when you need to change a unique key for a table.

• Do not support attributeAction=”delete”.

• Add SQL exception entries to the rds_etl_migrate.log file. If you find entries in the 
rds_etl_migrate.err file, the migration is not complete. The only way to recover is to 
restore from your backup file and start the migration process again.

• Require the updatedwithfact value when you update a dimension table and add a new 
associated fact table.

Table 15 Valid attributeAction Tags

attributeAction Tag Description

Add Creates a new table with fields specified in the rds_etl.xml 
file.

Deletedata Deletes all records in the table.

Historical Marks all records to be historical.

Update Updates table with new fields and creates unique keys. Does 
not recreate the associated fact tables.

Updatewithfact Updates table with new fields and creates unique keys. 
Recreates the associated fact tables.
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You can use this decision tree to help you determine what attributeAction tags you need when 
migrating.

How are you 
changing the 

schema?

Adding a new table

Modifying an 
existing table

Determine the 
table level tag 

(repeat for each 
affected table)

Replacing or retiring 
an existing  table

Will you be 
keeping historical 

SCD data?

YesNo

Use the 
<historical>

tag at the table 
level

Use the 
<deletedata> tag 
at the table level

Will you be
replacing this 

table?

No

Done

Yes
Use the <add>
tag at the table 

level

Done

Will you be 
modifying the Fact

table at all?

YesNo

Use the 
<updatewithfact>

tag at the table 
level

Use the <update> 
tag at the table 

level

Determine the 
field level tag 

(repeat for each 
affected field in 

the table)

Start

How are you 
changing the 

table?

Adding a new 
Dimension or

Direct Mapping field

Use the <add>
tag at the field 

level

Modifying Fact keys 
or measures

Done

Modifying an existing 
Dimension or

Direct Mapping field

Not supported at 
this time. Add a 

new field instead.
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3 Migrate the Data Warehouse
The data warehouse is a repository of integrated information that is available for queries and 
analysis. It contains information about the data warehouse database, Connect-It scenarios, 
and schemas that run the Extract, Transform, and Load (ETL) process. 

You can migrate your out-of-box or customized DecisionCenter 1.00 data warehouse to be 
compatible with a DecisionCenter 2.00 installation. If your installation meets the 
requirements, you can complete the migration tasks described in this chapter to ensure that 
your existing data warehouse is compatible with DecisionCenter.

Migrating customized data requires advice from HP Support and may require assistance from 
HP Professional Services personnel. For more information visit the HP Software Support web 
site at:

http://www.hp.com/go/hpsoftwaresupport/

Migration Prerequisites

Before you migrate the data warehouse, ensure that you have the following: 

• DecisionCenter 1.00 successfully installed with all required components

• Sufficient capacity in your database transaction log file size and tablespace allocation to 
avoid “out of space” conditions

Contact your database administrator to verify the allocations.

• Backup files of your existing data warehouse database

The backup file is critical if you need to rerun the migration because of errors in the 
rds_etl_migrate.err file.

• Administrative rights to modify schemas, scenarios, reports, and universes

If you customized the schema (*_etl.xml), scenario (rds_*.scn), reports, or universes, you 
must manually merge the changes from the new files with your customized files. Make 
sure that you have appropriate access rights to the files.
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Migration Checklist

See the DecisionCenter Installation Guide for information about running the installer to get 
the latest files that you need to take advantage of the new features in DecisionCenter 2.00. 

Print this checklist to use during the migration process. As you complete each task, mark it 
finished.

Task 1: Back Up Existing Schema and Scenario Files on page 32

Task 2: Upgrade to Connect-It 3.80 on page 33

Task 3: Run the DecisionCenter 2.00 Installer on page 33

— Step 1: Install the Data Warehouse for ServiceCenter on page 33

— Step 2: Install the Data Warehouse for AssetCenter on page 34

Task 4: Reconcile the Files on page 34

— Step 1: Update the ServiceCenter Files on page 34

— Step 2: Update the AssetCenter Files on page 35

— Step 3: Edit Connect-It Synchronization Times on page 36

Task 1: Back Up Existing Schema and Scenario Files

1 Stop the data warehouse Connect-It scenario from the Connect-It Service Console.

For ServiceCenter, the scenario is rds_sc.

For AssetCenter, the scenario is rds_ac.

2 Back up the existing data warehouse, files, folders, and sub-folders in the original data 
warehouse location. 

For DecisionCenter with ServiceCenter, the default location is: 
\\Program Files\HP OpenView\DC\RDS_SC

For DecisionCenter with AssetCenter, the default location is: 
\\Program Files\HP OpenView\DC\RDS_AC

3 Back up the existing data warehouse database in Oracle or Microsoft SQL Server.

4 Open Connect-It 3.6 Service Console and delete rds_sc service.
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Task 2: Upgrade to Connect-It 3.80

1 Install and configure the latest version of Connect-It. See the DecisionCenter Installation 
Guide.

2 For ServiceCenter only, copy the following files from the DecisionCenter installation 
media SupportFiles\CIT directory to your Connect-It installation.

Task 3: Run the DecisionCenter 2.00 Installer

Follow the steps in the next section to install the DecisionCenter data warehouse files for 
ServiceCenter or AssetCenter.

Step 1: Install the Data Warehouse for ServiceCenter

ServiceCenter and Service Manager unload files contain records that you need to use with 
DecisionCenter. Your ServiceCenter or Service Manager user profile must have system 
administration rights to complete this procedure.

If you have an existing DecisionCenter installation, it is important to apply the newest unload 
to meet the requirements of DecisionCenter 2.00. Do not skip this step.

1 Import the DecisionCenter unload file from the DecisionCenter installation media. See 
the DecisionCenter Installation Guide for detailed instructions.

For ServiceCenter 6.2 and later, use DCA20.unl. 

ServiceCenter 6.2 and Service Manager 7.0 only: Complete these additional steps.

a From the ServiceCenter or Service Manager navigation pane, click Toolkit > 
Database Manager.

b Type triggers in the Table field, or select it from the drop-down list.

c Click Search.

d Type deviceparent.bi.after.delete in the Trigger Name field and click Search on 
the toolbar. ServiceCenter populates the remaining fields with information about this 
trigger.

e Click Delete on the toolbar to remove the record and confirm the deletion when 
prompted. ServiceCenter returns this message: Trigger record deleted.

For versions prior to ServiceCenter 6.2, use DCA20_PreSC62.unl. 

2 Install the DecisionCenter data warehouse for ServiceCenter. See the DecisionCenter 
Installation Guide.

From SupportFiles\CIT  To \\Program Files\HP OpenView\Connect-It 3.80 en

rds.bas
rds.scp

\config\rds\bas\rds.bas
\config\rds\const\rds.scp

sc*.cfg \config\sc\config\
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Step 2: Install the Data Warehouse for AssetCenter

Install the DecisionCenter data warehouse files for AssetCenter. See the DecisionCenter 
Installation Guide.

Task 4: Reconcile the Files

You must manually merge changes from the previous schema and scenario files with the 
newly installed files.

Step 1: Update the ServiceCenter Files

1 If you customized the schema, manually merge the customized rds_etl.xml file changes 
from \\Program Files\HP OpenView\DC\RDS_SC\conf\ to 
\\Program Files\HP\DecisionCenter 2.00\ITPA-SM\conf\

2 Copy rds_sc.ini from \\Program Files\HP OpenView\DC\RDS_SC\cit to 
\\Program Files\HP\DecisionCenter 2.00\ITPA-SM\cit

3 To ensure that the tables synchronize, use a text editor to delete the following lines from 
the rds_sc.ini file. Because Connect-It scans the complete table, the synchronization time 
increases as you delete additional lines.

cm3rSrc
incidentSrc
outageSrc
outageeventSrc
rootcauseScr

4 Migrate DecisionCenter for ServiceCenter. 

a From the Start menu, click Run, type CMD, and click OK to open a command window. 

b Change directories to 

\\Program Files\HP\DecisionCenter 2.00\ITPA-SM\common\bin

c Type this command:

rds_sc61_migrate.bat

5 If the rds_etl_migrate_err file has errors, rerun the migration.

a Correct the errors in the file.

b Delete rds_etl_migrate.err and rds_etl.migrate.log files.

c Restore the backup data warehouse database.

d Run rds_sc61_migrate.

Search for the attributeAction attribute in the new rds_etl.xml file to identify the changes. 
See Appendix B, Schema Changes for the specific changes. Manually add your original 
customizations to this file.

To verify the migration, view the rds_etl_migrate.err file. An empty file indicates that the 
migration is successful.
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6 From the Oracle or SQL Server database, change the PROG_PATH field in the 
RDS_DBINFO table to the DecisionCenter 2.00 location. For example:

UPDATE RDS_DBINFO
SET PROG_PATH ='C:\Program Files\HP\DecisionCenter 2.00\ITPA-SM'

7 Update the views. From the Oracle or SQL Server database, run the scripts in 
\\ITPA\ITPA-SM\SupportFiles\DatabaseFiles 

a To delete views no longer used in the data warehouse:
For Oracle, run itpa_migrateviews_sqlsrvr.sql
For SQL Server, run itpa_migrateviews_oracle.sql

b To create new views:
For Oracle, run itpa_dcviews_oracle.sql
For SQL Server, run itpa_dcviews_sqlsrvr.sql

8 If you customized the scenario, use Connect-It Scenario Builder to manually update the 
changes.

a Merge rds_sc.scn from \\Program Files\HP OpenView\DC\RDS_SC\cit\ to 
\\Program Files\HP\DecisionCenter 2.00\ITPA-SM\cit\

b Restart the scenarios services from the Connect-It Service Console.

c Run the modified Connect-It scenarios in your test or production environment.

Step 2: Update the AssetCenter Files

1 From the Oracle or SQL Server database:

a Change the PROG_PATH field in the RDS_DBINFO table to the DecisionCenter 2.00 
location. For example:

UPDATE RDS_DBINFO
SET PROG_PATH ='C:\Program Files\HP\DecisionCenter 2.00\ITPA-AM'

b In both the database and the rdsac_etl.xml file, change the size of the VALUE field in 
the AMITEMLISTVAL table from 42 to 80. 

2 If you customized the scenario or schema, copy the files to the new DecisionCenter 
installation. You do not need to reconcile the files because there are no DecisionCenter file 
changes.

a Copy the rds_ac.scn scenario from 
\\Program Files\HP Openview\DC\RDS_AC\cit\ to 
\\Program Files\HP\DecisionCenter 2.00\ITPA-AM\cit\

b Copy the rdsac_etl.xml schema from 
\\Program Files\HP Openview\DC\RDS_AC\conf\ to 
\\Program Files\HP\DecisionCenter 2.00\ITPA-AM\conf

Be sure to change the size of the VALUE field. For example: 

<dimensionTableField name=”VALUE” type=”char” size=”80”/>

3 Copy rds_ac.ini from \\Program Files\HP OpenView\DC\RDS_AC\cit\ to 
\\Program Files\HP\DecisionCenter 2.00\ITPA-AM\cit\

4 Restart the scenarios services from the Connect-It Service Console.

5 Run the modified Connect-It scenarios in your test or production environment.
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Step 3: Edit Connect-It Synchronization Times

Due to changes in the schema, you must re-synchronize certain tables to get accurate updates.

1 Using a text editor, open the \\Program Files\HP\DC\RDS_SC\cit\rds_sc.ini file.

2 Delete the following lines.  

slaSrc (Required)
deviceparentSrc (Required)
screlationSrc (Required)
servicecontractSrc (Required)
slaresponseSrc (Required)
slamonthlySrc (Required)
Rootcausesrc1 (Optional, but strongly encouraged)
outagedetailSrc (Optional)
categorySrc (Optional)

Because Connect-It scans the complete table, the synchronization time increases as you 
delete additional lines.
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4 Customize Scenarios and Universes
The data warehouse Extract, Transform, and Load ETL process has the following 
components:

• Data warehouse Connect-It scenario (rds_sc.scn or rds_ac.scn)

• Data warehouse synchronization module (rds_sync.bat) that populates data warehouse 
fact tables, dimension SCD records, associated tables and system tables

• Data warehouse aggregation (rds_agg.bat) population module

• Data warehouse hierarchy (rds_hier.bat) population module

The rds_all Connect-It scheduler groups all these modules. The data warehouse ETL process 
runs daily, based as the incremental updates. 

These programs generate the output files in the 
\\Program Files\HP\DecisionCenter 2.00\ITPA-SM\logs directory and save error messages 
to ERR files. Check the ERR files to verify that the size is not greater than 0 bytes. If so, check 
the errors and correct them accordingly.

See the Connect-It documentation for more information about customizing the scenarios.

ETL Scenario Mapping

Connect-It data warehouse scenarios such as rds_sc.scn describe the metadata for the ETL 
process. 

To View the Mapping

1 From the Windows Start menu, click Programs > HP Openview > Connect-It 3.8 en > Scenario 
Builder. 

2 Open rds_sc.scn. The default path is: 
\\Program Files\HP\DecisionCenter 2.00\ITPA-SM\cit\rds_sc.scn 

3 Click Scenario > Open all connectors to ensure that you configured the connectors correctly.
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4 Select any Source/Mapping and click the Edit icon to review the ETL mapping information. 

The following diagram shows the mapping for Contact.  

5 Click the Edit a mapping icon. 
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The ServiceCenter data source appears on the left and the data warehouse destination 
table is on the right. The middle section defines the mapping script for each attribute. See 
the Connect-It User Guide for more information.

Dimension Table and Referenced Dimension Table Changes

Based on the data warehouse dimensional modeling techniques, the following scenarios 
include all the possible fact table ETL processes. Bold text indicates changes to the 
DecisionCenter Analytics implementation.

When changes to dimension tables occur in ServiceCenter, the ETL process makes changes to 
the data warehouse.

Universe Filter Conditions for Query or Reporting 

The universe has filters that all reports use. The fact and dimensional tables use the following 
filters:

• The fact table is not obsolete.

• Dimensional foreign keys are greater than 5 (>= 5).

• Referenced dimensions do not include obsolete records. 

Table 16 Changes to Dimension Tables

ServiceCenter Activity ETL Activity

Main dimension 
table change

• Creates a new line item such as 
incident or portfolio

• Updates the existing line item

• Updates the existing Slowly 
Changing Dimension (SCD) line item

• Marks the existing line item as 
deleted

• Adds a new fact record

• Updates the matched fact record 
only when you change the 
dimensional foreign keys or 
measurements

• Updates the matched fact records 
main foreign key from the old key 
to the new SCD3 key

• Marks the matched fact record as 
obsolete

Referenced 
dimension table 
changes

• Creates a new record in the 
referenced dimension tables 

• Updates existing referenced 
dimensional records

• Updates existing referenced 
dimensional SCD records

• Deletes existing referenced 
dimensional records 

• Makes no changes in the fact table

• Makes no changes in the fact tables

• Updates all the related fact 
records and related dimensional 
foreign key with the new 
surrogate keys

• Makes no changes in the fact tables
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Customizing the Scenario

You can map a simple field array and a simple field array in a substructure.

Simple Field Arrays

You can map alternate.contacts from the ServiceCenter contacts file to the CONTACT_D 
alternate_contacts long text field with the data warehouse RDSCollection2LongText method.

RDSCollection2LongText(”'alternate.contacts'”)

The approval.structure in cm3r mapping defines the simple field array approvals.req.seq. You 
can map the CM3R_D approved_req_seq long string field with the data warehouse 
RDSAnyCollection2LongText method.

RDSAnyCollection2LongText(”'approval.structure'.'approvals.req.seq'”,
”'approvals.req.seq'”)

To map a substructure array

By using the separate table created for the structure array, you can edit the rds50db.cfg file to 
associate the main table with the separate dependent table. Follow the steps in this example 
to complete the Connect-It scenario changes. For SLA_D, you create the SLAARAVA_D 
separate table for the sla availability structure array. 

1 With a text editor, open rds50db.cfg. The default path is:

\\…\HP OpenView\ConnectIt 3.80 en\RDS_SC\cit

2 Create the relationships between SLA_D and SLAARAVA_D.

3 Save and close the file.

4 From the Windows Start menu, click Programs > HP Openview > Connect-It 3.8 en > Scenario 
Builder. 

5 Click File > Open and navigate to rds_sc.scn.

6 Click Scenario > Open all connectors.

7 Select the Mappings connector.

8 In Source/Mapping, select SLA and click the Edit a mapping icon.

9 Create the mappings from the availability array to SLA_AVAILABILITY elements.

10 Select the SLA_AVAILABILITY collection, type availability for the Source for the 
collection mapping. 

{ STRUCT SLA_D_OUT
    MODEOUT = 0
    TABLE = SLA_D sl
    { ATTRIBUTE AllFields
      FIELD = sl.self
   }
    { ARRAY SLA_AVAILABILITY
      TABLE = SLAARAva_D
      LINK = @{…agreement_id_key} = agreement_id_key
      { ATTRIBUTE AllFields
        FIELD = self
     }

}
…
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11 Check Active collection reconciliation.

To map unique key fields

If you modify the unique keys or add new tables, you must update the data warehouse 
scenario.

1 From the Windows Start menu, click Programs > HP Openview > Connect-It 3.8 en > Scenario 
Builder. 

2 Click File > Open and navigate to rds_sc.scn.

3 Click Scenario > Open all connectors.

4 Select the Mappings connector.

5 Select the appropriate Source/Mapping mapping, then click the Edit a mapping icon.

6 Select the unique key element.

7 Start the key.

8 Use the CSTR mapping function.

CONTACT_NAME in CONTACT_D mapping is one of the unique key mappings:
CSTR(['contact.name'])

To map the retdate date field function

You can use the retdate data warehouse function to map the date field. For example, in the 
CONTACT_D mapping, the mapping for VALID_FROM is:

retdate(['valid.from'])

To map the RetLongText function for a long string data field

You can use the RetLongText data warehouse function to map the long field. For example, in 
CONTACT_D mapping, the mapping for the comment field is:

RetLongText([comments])

To map functions for dimension tables

The following functions populate dimension data. The input variable names are based on the 
dimension name. Check any predefined dimension mapping for detail examples, such as 
CONTACT_D.
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The following example is from the CONTACT_D OpenSession method.

To create the OpenSession method at the dimension table level

1 From the Windows Start menu, click Programs > HP Openview > Connect-It 3.8 en > Scenario 
Builder. 

2 Click File > Open and navigate to rds_sc.scn.

3 Click Scenario > Open all connectors.

4 Select the Mappings connector.

5 In the OpenSession method, use the dimension name without _D for the global variable 
names and the input parameter.

6 At the root level, AMCONTRACT_D in this example, define the mapping scripts as: 

g_tableName = ”AMCONTRACT”
Dim etlStatus as string
etlStatus=RetETLStatus()

You need to change only the g_tableName based on the dimension name without _D.
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Functions for Dimension Attributes

The following functions use the CONTACT_D table. Replace contact with the proper 
dimension table name.

Complete Dimension Table Mappings

You can create mappings for the dimension element from the appropriate ServiceCenter 
source fields. Make sure that you define the ServiceCenter sysmodtime file for more efficient 
data synchronization.

Start the dimension primary key by using the unique key fields and data warehouse system 
unified sequence key field Z_RDSXXX_DID. The dimension name is XXX_D.

Viewing the Data Warehouse Universe

You can use the Business Objects designer tool to customize the data warehouse universe. See 
the Business Objects documentation for developing your own universes. You can also create a 
report of the universe contents that shows the existing tables and objects.

You must have administrator access rights to change the universe.

1 From the Windows Start menu, click Programs > BusinessObjects XI Release 2 > 
BusinessObjects Enterprise > Designer. 

2 Log on as the designer user (Administrator).

Table 17 Dimension data warehouse attributes

Attribute Function

Z_ETLSTATUS field g_ETLProcess_Status

Z_RDSACTIVESTATUSIND field ”Y”

Z_RDSCONTACT_DID system 
unified sequence key

newID=RetRDSDID(g_lMaxCounter_contact)
if newID > g_lMaxCounter_contact then
g_lMaxCounter_contact = newID 

end if
retval = newID

Z_RDSCREATEDDATE field retval = RetRDSCreateDateAll()

Z_RDSLASTMODDATE field retval = RetRDSLastModDateAll()

Z_RDSTRANSLASTIND field ”Y”
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3 Click File > Open and navigate to ITPA Service Management. The default path is: 
\\...\<Business Objects>\Universes. The following diagram shows the data warehouse 
universe for ServiceCenter.

4 Open the object properties to determine the object definitions for the data warehouse data 
sources. The following diagram shows the Open Time object where OPEN_TIME is the 
data source field in the PROBSUMM_D table.
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Types of Changes to an Existing Universe

The Business Objects Designer tool enables you to make the following types of changes to an 
existing universe:

Impact of Universe Changes

The changes you make to the universe impact your schema and existing documents.

Universe Customization Tips

The following suggestions can improve the performance of your universe customization: 

• Add tables to the universe structure.

• Insert joins and set cardinalities.

• Detect aliases.

• Detect contexts.

• Create new objects.

• Set up Hierarchies.

Table 18 Impact of Universe Changes

Change Element Description

Schema • Enhanced Impact:
— Adding new columns
— Adding new tables

• Severe Impact:
— Renaming or moving the database
— Changing existing column and table names
— Deleting tables and columns

Existing Document • No Impact:
— Redefining Object SQL
— Renaming an Object
— Copying to a different class
— Moving in the same class or to a different class
— Adding new objects 

• Impact:
— Deleting an existing object
— Deleting and then recreating an object with 

exactly the same definition

• Modify the Array Fetch parameter in Universe Parameters.

• Use shortcut joins.

• Create and use aggregate tables in your database.
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5 Migrate Reports and Universes
The information in this chapter is for advanced users who customized DecisionCenter 
out-of-box reports or universes. Prior to migrating the content, you must save existing reports 
and universes.

See the Business Objects documentation for information about backing up your Business 
Objects repositories and migrating customized reports or universes that you need in 
DecisionCenter 2.00. 

Migrating customized data requires advice from HP Support and may require assistance from 
HP Professional Services personnel. For more information visit the HP Software Support web 
site at:

http://www.hp.com/go/hpsoftwaresupport/

Migration Checklist

See the DecisionCenter Installation Guide for information about running the installer to get 
the latest files that you need to take advantage of the new features in DecisionCenter 2.00. 

Print this checklist to use during the migration process. As you complete each task, mark it 
finished.

Task 1: Back Up the Business Objects Databases on page 48

Task 2: Save the Customized Files on page 48

Task 3: Delete the Original Folders and Content on page 48

Task 4: Install DecisionCenter 2.00 ITPA Content on page 48

Task 5: Complete the Migration on page 49

— Step 1: Add Security on page 49

— Step 2: Apply Customizations on page 49
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Task 1: Back Up the Business Objects Databases

Always back up your existing files, folders, sub-folders, and databases to avoid overwriting the 
information.

1 Make sure that you have appropriate administrative access rights in Business Objects.

2 Back up the Central Manager Server database (cmsdb) from Oracle or SQL Server. 

3 Back up the Performance Management database (pmdb), if needed.

Task 2: Save the Customized Files

Follow the steps in the next section to identify the customized out-of-box reports and prepare 
them for migration. 

1 If needed, create a temporary folder for the customized reports. The temporary folder 
must not be a DecisionCenter default folder. For example, DCStagingFolder.

2 From Business Objects InfoView, open the report.

3 Click Properties.

The report displays a create date and last modified date.

4 Click Save as to save the customized reports to the temporary folder. Make sure that you 
save all drills and links.

5 Repeat Step 2 through Step 4 for each report.

Task 3: Delete the Original Folders and Content 

From Business Objects, use either InfoView or Central Management Console to delete the 
original folders, including all the content. A complete installation includes:

ITPA Asset Management
ITPA Help Desk
ITPA Incident
ITPA Service Level Management
BIA Business Impact

Task 4: Install DecisionCenter 2.00 ITPA Content

Follow the steps in the next section to install the DecisionCenter IT Performance Analytics 
content that includes universes and reports for ServiceCenter and AssetCenter. See the 
DecisionCenter Installation Guide for detailed information.

1 Install the ITPA content.

2 Import the reports and universes.

3 Update the universe database connections.
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4 Run the PMDT tool.

5 Add and update the metric universes in Performance Management.

6 Refresh the metrics.

Task 5: Complete the Migration

Follow the steps in the next section to finalize the migration. 

Step 1: Add Security

1 With the BusinessObjects Enterprise Central Management Console, set folder security 
access to prevent users from overwriting out-of-box reports.

a Click Start > Programs > Business Objects XI Release 2 > BusinessObjects Enterprise > 
BusinessObjects Enterprise Java Administration Launchpad.

b Click Central Management Console.

c Log on as Administrator.

d Select Folders > Folder Title (for example, ITPA Service Management).

e Click the Rights tab.

f In the Access Level column next to the user or group, select Advanced from the 
drop-down menu.

g On Advanced Rights, change the Advanced Access Level setting for The Right To:

       Copy object to another folder, select Explicitly Granted.

       Edit objects, select Explicitly Deny.

2 Apply additional security as needed to the new reports and folder structure in Business 
Objects. See the Business Objects documentation for detailed information. 

Step 2: Apply Customizations

1 With BusinessObjects Enterprise InfoView, add changes from your DecisionCenter 1.00 
customized reports to the newly installed reports.

2 With BusinessObjects Enterprise Designer, add changes from DecisionCenter 1.00 
customized universes to the newly installed universes.

You can prevent users from overwriting the out-of-box reports by applying security access 
settings. To adhere to best practices, save a copy of the out-of-box reports to another folder, 
and then modify the copy.
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6 Business Impact Analysis Migration
You can migrate your out-of-box or customized Business Impact Analysis (BIA) module to be 
compatible with a DecisionCenter 2.00 installation. The installer maintains the previous 
version so that you can merge any changes in your files with the new installation.

Migrating customized data requires advice from HP Support and may require assistance from 
HP Professional Services personnel. For more information visit the HP Software Support web 
site at:

http://www.hp.com/go/hpsoftwaresupport/

Migration Checklist

See the DecisionCenter Installation Guide for information about running the installer to get 
the latest files that you need to take advantage of the new features in DecisionCenter 2.00. 

Print this checklist to use during the migration process. As you complete each task, mark it 
finished.

Task 1: Back Up Existing Files on page 51

Task 2: Upgrade the Database on page 52

Task 3: Run the DecisionCenter 2.00 Installer on page 52

Task 4: Configure the Files on page 52

— Step 1: Update database.properties on page 52

— Step 2: Update process.properties on page 53

— Step 3: Update log4j.xml on page 53

— Step 4: Update querydefinitions.xml on page 53

— Step 5: Update mssql_templates.sql on page 53

Task 5: Complete the Migration on page 54

Task 1: Back Up Existing Files

1 From HP Connect-It Scenario Builder, stop the scenario scheduler.

2 Back up BIA existing files. The default location is:

\\Program Files\HP OpenView\DC\BIA
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Task 2: Upgrade the Database

• From the DecisionCenter installation media \SupportFiles\Database directory, run the 
database upgrade script:

upgrade_rds_bia_mssql_1.0_2.0.sql 

The script creates the PREP_BUSINESS_SERVICE_V view, which defines the devices that 
business services will consider. DecisionCenter 1.00 defined the out-of-box business services 
as devices using BS as the logical name prefix. To be consistent with ServiceCenter 6.2 and 
Service Manager 7.0, DecisionCenter 2.00 defines the business services as devices with the 
type bizservice. 

To adhere to best practices, set up your ServiceCenter data to match this definition of 
business services. If necessary, you can modify the PREP_BUSINESS_SERVICE_V view to use 
your own criteria to ensure that this definition is associated with all data mining activities.

Task 3: Run the DecisionCenter 2.00 Installer

Follow the steps in the DecisionCenter Installation Guide to install the BIA application. 

Task 4: Configure the Files

You must manually merge the changes from your DecisionCenter 1.00 files with the newly 
installed files. Make sure that you have appropriate access rights to the files. Use a text editor 
or XML parser to configure the files.

Step 1: Update database.properties

You must update this file only if you changed the default connection options.

1 Open the file with a text editor. The default location is:

\\…\DecisionCenter 2.00\BIA\DataMining\config\database.properties

2 Merge changes from the old file to the new file. If you changed specific database 
connection options, add them to the file.

3 Save and close.

DecisionCenter 2.00 does not support the Sprinta driver for Microsoft SQL Server. 
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Step 2: Update process.properties

The DecisionCenter 2.00 file has one new property with the corresponding comment:

1 Open the file with a text editor. The default location is:

\\…\DecisionCenter 2.00\BIA\DataMining\config\process.properties

2 Merge your changes from the old file to the new file. 

3 Save and close the file.

Step 3: Update log4j.xml

1 Open the file with a text editor or XML parser. The default location is:

\\…\DecisionCenter 2.00\BIA\config\log4j.xml

2 Merge your changes from the old file to the new file. Or, overwrite the new file with the old 
one, then update the File property of the different appenders to point to the \logs folder. 
For example, change the hibernate log from

<param name=”File” value=”hibernate.log”/>

to

<param name=”File” value=”…/logs/hibernate.log”/>

3 Save and close the file.

Step 4: Update querydefinitions.xml

The out-of-box querydefinitions.xml file has one fewer bean definition.

1 Open the file with a text editor or XML parser. The default location is:

\\…\DecisionCenter 2.00\BIA\config \querydefinitions.xml

2 Merge your changes from the old file to the new file. Or, overwrite the new file with the old 
one, then delete the ttniProbsummQuery bean by removing this code:

<!-- Query definition for the PROBSUMM_D table -->
<bean id=”ttniProbsummQuery” parent=”queryTemplate”>
 …
</bean>

3 Save and close the file.

Step 5: Update mssql_templates.sql

The startSet date parameter defines the PREP_PROBSUMM_V view. All incidents created or 
updated on or after this date are tracked for history. 

Make sure that you:

# Portion of work time effectively spent on incidents. It must be a 
# number > 0 (no time spent on incident) and <= 1 (full time spent on 
incidents).

operator.focus_factor=.75
Business Impact Analysis Migration 53



• Use the new file.

• Set this parameter to a value that corresponds to your current data set. 

Task 5: Complete the Migration

The old data_mining.bat command file is now bia_datamining.bat. If you configured the batch 
file in DecisionCenter 1.00, you must move the configuration parameters to the new file.

1 Merge the configuration parameters from data_mining.bat to bia_datamining.bat. The 
default location is:

\\…\DecisionCenter 2.00\BIA\bin\

2 From HP Connect-It Scenario Builder, apply changes from the previous dco_sc.scn and 
dco_rds.scn scenarios to the newly installed files.

3 From the Windows Start menu, click Control Panel > Add or Remove Programs to uninstall 
the DecisionCenter 1.00 BIA module. If necessary, manually delete the old folder.

To adhere to best practices, document customizations that you make to the scenarios to ease 
the migration in future releases.
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7 Migrate the Optimization Engine
You can migrate your out-of-box or customized DecisionCenter Optimization engine to be 
compatible with a DecisionCenter 2.00 installation. The installer maintains the previous 
version so that you can merge any parameter changes in your files with the new installation.

Migrating customized data requires advice from HP Support and may require assistance from 
HP Professional Services personnel. For more information visit the HP Software Support web 
site at:

http://www.hp.com/go/hpsoftwaresupport/

Migration Checklist

See the DecisionCenter Installation Guide for information about running the installer to get 
the latest files that you need to take advantage of the new features in DecisionCenter 2.00. 

Print this checklist to use during the migration process. As you complete each task, mark it 
finished.

Task 1: Back Up Existing Files on page 55

Task 2: Run the DecisionCenter 2.00 Installer on page 55

Task 3: Configure the Files on page 56

— Step 1: Copy jmx.properties and priority.properties on page 56

— Step 2: Update database.properties on page 56

— Step 3: Update log4j.xml on page 56

Task 4: Complete the Migration on page 57

Task 1: Back Up Existing Files

1 From the command line window running the Optimizer, click Ctrl+C to stop the engine.

2 Back up the Optimization existing files. The default location is:

\\Program Files\HP Openview\DC\Optimization

Task 2: Run the DecisionCenter 2.00 Installer

Follow the steps in the DecisionCenter Installation Guide to install the Optimizer engine. 
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Task 3: Configure the Files

You must manually merge the changes from your DecisionCenter 1.00 files with the newly 
installed files. Make sure that you have appropriate access rights to the files. Use a text editor 
or XML parser to configure the files.

Step 1: Copy jmx.properties and priority.properties

1 Copy the old jmx.properties file from 
\\Program Files\HP OpenView\DC\Optimization\config\jmx.properties to   
\\Program Files\HP\DecisionCenter 2.00\Optimization\config\jmx.properties

2 Copy the old priority.properties file from 
\\Program Files\HP OpenView\DC\Optimization\config\priority.properties to 
\\Program Files\HP\DecisionCenter 2.00\Optimization\config\priority.properties

Step 2: Update database.properties

You must update this file only if you changed the default connection options.

1 Open the file with a text editor. The default location is:

\\…\DecisionCenter 2.00\Optimization\config\database.properties

2 Merge changes from the old file to the new file. If you changed specific database 
connection options, add them to the file.

3 Save and close.

Step 3: Update log4j.xml

The out-of-box log4j.xml file contains new elements that help redirect information messages 
to the console.

1 Open the file with a text editor or XML parser. The default location is:

\\…\DecisionCenter 2.00\Optimization\config\log4j.xml

2 Merge your changes from the old file to the new file. Make sure that you keep the new 
elements.

• A new appender (logger) describes how to log the information to the console.

<!-- Datamining additional appender -->
 <appender name=”datamining” class=”org.apache.log4j.ConsoleAppender”>
    <layout class=”org.apache.log4j.PatternLayout”>
      <param name=”ConversionPattern” value=”%m%n” />
    </layout>
 </appender><param name=”File” value=”hibernate.log”/>

DecisionCenter 2.00 does not support the Sprinta driver for Microsoft SQL Server. 
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• Two new category elements direct the information from the time to next incident tool 
to the new datamining appender.

3 Save and close the file

Task 4: Complete the Migration

The old data_mining.bat command file is now bia_datamining.bat. If you configured the batch 
file in DecisionCenter 1.00, you must move the configuration parameters to the new file.

1 Merge run_optimizer.bat changes with the new file. The default location is:

\\…\DecisionCenter 2.00\Optimization\bin\run_optimizer.bat

2 Configure the new common.properties and optimizer.properties files. See the 
DecisionCenter Installation Guide for information about configuring the files. 

3 If you need to set additional JVM parameters, update the new opt_datamining.bat file 
with the changes. The default location is:

\\…\DecisionCenter 2.00\Optimization\bin\opt_datamining.bat

4 From the Windows Start menu, click Control Panel > Add or Remove Programs to uninstall 
the DecisionCenter 1.00 Optimization engine. If necessary, manually delete the old folder.

<!-- data mining -->

<category

    
name=”com.peregrine.decisioncenter.optimization.engine.model.support.ttni”>

 <priority value=”info” />

 <appender-ref ref=”datamining” />

</category>

<category name=”com.peregrine.decisioncenter.optimization.tools”>

 <priority value=”info” />

 <appender-ref ref=”datamining” />

</category>
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A Customization Planning

Planning the customization implementation is critical when you change the 
schema or DecisionCenter Analytics reporting content. A successful plan 
requires these actions:

• Define the requirements analysis of reports and systems such as data 
sources, version, and data volume.

• Install DecisionCenter in a test environment that includes configuring 
DecisionCenter and creating reports based on the requirements.

By editing the out-of-box data warehouse rds_etl.xml file, you can customize 
the data warehouse schema. When you edit any XML file, use an XML editor 
tool such as XML Spy, which validates your changes against the schema file. 
See the Data Warehouse Administration Online Help topics for more 
information about customization guidelines. See Best Practices for Data 
Warehouse Administration Guide for information about optimizing the data 
warehouse performance.

Advanced data warehouse customization requires advice from HP Support 
and may require assistance from HP Professional Services personnel. For 
more information visit the HP Software Support web site at:

http://www.hp.com/go/hpsoftwaresupport/
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Customization Checklist

The specific tasks to customize DecisionCenter Analytics include modifying 
the schema, Connect-It scenarios, and the universe. Complete all the tasks to 
implement the plan.

Print this checklist to use during the planning process. As you complete each 
task, mark it finished.

Task 1: Review Current System and Report Requirements on page 61

Task 2: Customize the Schema on page 61

— Step 1: Back Up Existing Files on page 61

— Step 2: Modify and Verify the Schema on page 62

— Step 3: Run the rds_init Utility on page 63

Task 3: Customize the Connect-It Scenario on page 64

— Step 1: Modify Data Warehouse Connect-It Scenarios on page 64

— Step 2: Test the Scenario on page 67

— Step 3: Review Global Functions on page 68

Task 4: Customize the Universe on page 68

— Step 1: Generate the Universe Report on page 68

— Step 2: Check Data Integrity on page 69

— Step 3: Modify the Universe on page 69

— Step 4: Export the Universe on page 70

Task 5: Implement the Changes in a Test Environment on page 71

Task 6: Map and Test the Tailored Data Schema on page 71

Task 7: Deploy to a Production Environment on page 72

Task 8: Continue to Customize Your Environment on page 72
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Task 1: Review Current System and Report Requirements

When planning, allow one to three days to complete this task.

— Step 1: Review current system and overall DecisionCenter Analytics 
deployment environment.

— Step 2: Verify assumptions and gather requirements, such as data 
sources, ServiceCenter version, data volume, and synchronization 
back point. 

Task 2: Customize the Schema

You can customize the data warehouse schema by editing the out-of-box 
rds_etl.xml file. When customizing any XML file, use an XML editor tool such 
as XML Spy, which validates your changes against the schema file. The 
instructions to add tables and fields are available in the DecisionCenter Data 
Warehouse Administration Online Help. 

If you customized the schema, see Appendix B, Schema Changes for 
DecisionCenter updates that reflect new tables and changes to existing tables 
in the data warehouse.

Step 1: Back Up Existing Files

1 Stop the data warehouse Connect-It scenario from the Connect-It Service 
Console.

For ServiceCenter, the scenario is rds_sc.

For AssetCenter, the scenario is rds_ac.
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2 Back up the existing data warehouse, files, folders, and sub-folders in the 
original data warehouse location. 

For DecisionCenter with ServiceCenter, the default location is: 
\\Program Files\HP OpenView\DC\RDS_SC

For DecisionCenter with AssetCenter, the default location is: 
\\Program Files\HP OpenView\DC\RDS_AC

3 Back up the existing data warehouse database in Oracle or Microsoft SQL 
Server.

Step 2: Modify and Verify the Schema

This file defines the structure of all fields and tables in the schema. Add or 
edit objects as required. To adhere to best practices, do not delete objects. The 
HP Connect-It scenario and Business Objects universe deal with unused and 
obsolete structures. 

1 Open the file with a text editor or XML parser. The default location is:

\\Program Files\HP\DecisionCenter 2.00\ITPA-SM\rds_etl.xml
\\Program Files\HP\DecisionCenter 2.00\ITPA-AM\rdsac_etl.xml

2 Modify the file as needed. See Appendix B, Schema Changes for more 
detailed information.

This file defines the structure of all fields and tables in the schema. Add or 
edit objects as required. To adhere to best practices, do not delete objects. 
The HP Connect-It scenario and Business Objects universe deal with 
unused and obsolete structures. 

3 Validate your changes against the XML file.

rds_etl.xml (ServiceCenter)
rdsac_etl.xml (AssetCenter)
rdbms_keywords.xml 
rds_sc.scn (ServiceCenter)
rds_ac.scn (AssetCenter)
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Step 3: Run the rds_init Utility

After you edit and validate your XML file, you must run the rds_init utility to 
build or edit the database schema. You can use the utility to start the 
RDSInitRun command, which causes the changes you make in the default 
rds_etl.xml file to take effect.

If you are running a clean installation, run the utility: 
\\Program Files\HP\DecisionCenter 2.00\ITPA-SM\common
\bin\rds_init.bat 

If you are migrating from an existing data warehouse, make sure that you add 
all the appropriate attributeAction tags to any objects you altered or added, 
then run the batch file:

\\Program Files\HP\DecisionCenter 2.00\ITPA-SM\common\bin
\rds_sc61_migrate.bat 

The rds_init program generates two output files in the 
\\Program Files\HP\DecisionCenter 2.00\ITPA-SM\logs directory.

If the ERR file size is not 0, check the error messages, correct the problem, and 
rerun the program.

Do not run this file if you are updating an existing data warehouse because it 
will delete and recreate all the tables.

Table 19 Output Files

File Name Description

rds_etl_init.log Stores all the executed SQL statements.

rds_etl_init.err Tracks all the error messages.
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Task 3: Customize the Connect-It Scenario

The data warehouse uses HP Connect-It scenarios to synchronize data. You 
can customize the AssetCenter and ServiceCenter scenario mappings with 
Connect-It Scenario Builder. If you customized the scenario, see Appendix C, 
Scenario Changes for DecisionCenter changes made to the Connect-It 
scenario.

After you modify and verify the scenario, you must run the scenario in a test 
or production environment, and review global functions. 

Step 1: Modify Data Warehouse Connect-It Scenarios

Changes to the scenario require several tasks that involve modifying and 
verifying the schema.

To modify the scenario

1 Click Start > Programs > HP OpenView > Connect-It 3.8 en > Connect-It 
Scenario Builder.

2 Click File > Open and navigate to rds_sc.scn.

3 Select a connector.

4 Select the Document Types tab.

5 Modify the Data sources document type.

6 Modify the produced document types:

• Dimension tables mapping scripts.

• Direct mapping tables mapping scripts.

7 Run the modified Connect-It scenario in your test or production 
environment.

To open the scenario to verify the schema

1 Open the Windows command prompt.

2 Change to the 
\\Program Files\HP\DecisionCenter 2.00\ITPA-SM\common\bin 
directory. 
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3 Run the test_rdssc.bat command.

4 Check the test_rdssc.log log file in 
\\Program Files\HP\DecisionCenter 2.00\ITPA-SM\logs

The file contains the synchronization activity records. 

5 Search for the string -53. 

• If you do not find -53, the verification is successful.

• If you find -53 or -XX, errors, confirm that the connectors’ 
configuration information is correct by verifying config_rdssc.txt in 
the \\Program Files\HP\DecisionCenter 2.00\ITPA-SM\cit 
directory. The rds_init program must be error-free before you can run 
the Connect-It scenario.

To reconfigure the connectors that fail to connect

1 With a text editor, modify the content of config_rdssc.txt in the 
\\Program Files\HP\DecisionCenter 2.00\ITPA-SM\cit directory.

2 Open the Windows command prompt.

3 Change to the 
\\Program Files\HP\DecisionCenter 2.00\ITPA-SM\common\bin 
directory.

4 Run the following commands and check the corresponding log files in the 
\\Program Files\HP\DecisionCenter 2.00\ITPA-SM\logs directory. 
Make sure the test log files have successful in the last line.

• upd_rdssc.cmd 

• test_rdssc.cmd 

To verify the schema

1 Back up rds_sc.scn. The default path is: 
\\Program Files\HP\DecisionCenter 2.00\ITPA-SM\cit

2 From the Windows Start menu, click Programs > HP Openview > Connect-It 
3.8 en > Scenario Builder. 

3 Click File > Open and navigate to rds_sc.scn.

4 Click Scenario > Open all connectors to ensure that you configured the 
connectors correctly.
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5 Click the Mapping connector.

6 Select the Mappings tab.

7 Select any predefined mapping; for example, select 
contactSrc CONTACT_DDst to CONTACT_D (CONTACT_DDst). 

8 Click the Edit a mapping icon.

The verification is successful if no schema error window appears. If not 
successful, copy the schema errors to Notepad and save as a text file for later 
use.

To modify data sources document types

If you have schema verification errors, or if you need to map new 
ServiceCenter files or fields to the data warehouse, modify the data sources.

1 From the Windows Start menu, click Programs > HP Openview > 
Connect-It 3.8 en > Scenario Builder. 

2 Click File > Open and navigate to rds_sc.scn.

3 Click Scenario > Open all connectors.

4 Select the ServiceCenter connector.

5 Select the Document Types tab.

6 Modify Produced document types for the updates or error ServiceCenter 
files by removing, updating, or adding the tables.

To modify produced data sources for data warehouse tables

1 From the Windows Start menu, click Programs > HP Openview > 
Connect-It 3.8 en > Scenario Builder. 

2 Click File > Open and navigate to rds_sc.scn.

3 Click Scenario > Open all connectors.

4 Select the RDS connector.

5 Select the Document Types tab.

6 Modify Produced document types for the updates or error data warehouse 
tables by removing, updating, or adding tables.
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To modify the mapping scripts

1 From the Windows Start menu, click Programs > HP Openview > 
Connect-It 3.8 en > Scenario Builder. 

2 Click File > Open and navigate to rds_sc.scn.

3 Click Scenario > Open all connectors.

4 Select the Mapping connector.

5 Select the Mappings tab.

6 Click the Edit the mapping icon.

Step 2: Test the Scenario

Before you run the new scenario through the Connect-It service console, test 
the scenario from Connect-It Scenario Builder.

1 From the Windows Start menu, click Programs > HP Openview > 
Connect-It 3.8 en > Scenario Builder. 

2 Click File > Open and navigate to rds_sc.scn.

3 Click Scenario > Open all connectors.

4 Check or clear the tables that you want to include in the synchronization.

a From the ServiceCenter connector, click Document Types and check or 
clear the tables from Produced document types. 

b From the Mapping connector, click Mappings and check or clear the 
tables from Source/Mapping.

c From the Mapping connector, click Document Types and check or clear 
the tables from Produced document types. 

5 Set the condition.

a From the ServiceCenter connector, click Produced document type, then 
click Edit produced document type. 

b Add the condition to the WHERE clause. For example:

sysmodtime > '11/15/03'

6 Click Tools > Produce now to test the modified scenario.

7 Validate the data and log file to ensure that you have no -xx errors.
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8 Click Scenario > Scheduling to modify the scheduling if you have new 
mapping data sources.

9 Start the rds_sc service through the Connect-It Service Console.

Step 3: Review Global Functions

You can use predefined data warehouse global functions for data warehouse 
scenario mapping scripts. 

1 From the Windows Start menu, click Programs > HP Openview > 
Connect-It 3.8 en > Scenario Builder. 

2 Click File > Open and navigate to rds_sc.scn.

3 Click Scenario > Global functions.

4 Select the rds.bas script. 

Task 4: Customize the Universe

The universe is the metadata layer that contains data attributes and data 
structures. You can use the Business Objects Designer tool to customize the 
universe (UNV) file. Before you customize the customize, you can create a 
report of the universe contents that details the existing tables, objects, 
formulas for the objects, and joins for the universe. 

Step 1: Generate the Universe Report

You can create a report of the universe contents with the Designer tool. The 
Portable Document Format (PDF) report produces the universe metadata.

1 From the Windows Start menu, click Programs > BusinessObjects XI 
Release 2 > BusinessObjects Enterprise > Designer. 

2 Log on as the Administrator designer user.

To ensure that the data warehouse Connect-It global functions work, you 
must name the data warehouse connector RDS.
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3 Click File > Open and navigate to the universe. The default path is: 
\\Program Files\Business Objects\BusinessObjects Enterprise 11.5
\FileStore\Input. 

4 Click File > Save As.

5 From the Save as types drop-down list, select Portable Document Format 
(*.pdf) and type the file name and location.

6 Click Save.

7 Click Tools > Options > Print/PDF to select the universe data that you want 
to review.

Step 2: Check Data Integrity

After you modify the data warehouse universe, make sure to perform an 
integrity check to detect any join loops or context errors.

1 From the Windows Start menu, click Programs > BusinessObjects XI 
Release 2 > BusinessObjects Enterprise > Designer.

2 Log on as the Administrator designer user.

3 Click Tools > Check Integrity.

4 Select Check All.

5 Click OK. The utility scans the universe and suggests potential problems.

6 Correct any problems.

7 Save your changes.

Step 3: Modify the Universe

Because DecisionCenter Analytics sample reports use the out-of-box data 
warehouse universe, limit your changes to the examples in the following 
section. See Universe Customization Tips on page 45 for some tips about 
customizing the universe.

For more information about universe changes, see the Business Objects 
Designer Guide.
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To change the sample universe

After you modify the data warehouse universe, make sure to perform an 
integrity check to detect any join loops or context errors.

1 From the Windows Start menu, click Programs > BusinessObjects XI 
Release 2 > BusinessObjects Enterprise > Designer.

2 Log on as the Administrator designer user.

3 Click Tools > Connections to change an existing connection or create a new 
connection.

4 Refresh the database structure and perform an integrity check.

5 Limit your universe changes to:

— Table and joins

— Context

— Alias

— Class/objects (Description, SQL and Where) 

— Aggregation

Step 4: Export the Universe

After you modify the data warehouse universe, export the universe to the 
universe domain to have the new universe take effect.

1 From the Windows Start menu, click Programs > BusinessObjects XI 
Release 2 > BusinessObjects Enterprise > Designer.

2 Click File > Export.

3 From the Domain drop-down list, select your domain.

4 In the Groups list, select an application group.

5 Click OK to export the universe to the application group. You see a 
message indicating that the export is successful.
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Task 5: Implement the Changes in a Test Environment

When planning, allow one to five days to complete this task.

— Step 1: Install DecisionCenter Analytics with a typical configuration 
on the test servers.

— Step 2 Configure all components to start DecisionCenter Analytics.

— Step 3: Create a test DecisionCenter Analytics user account with logon 
rights.

For more information, see the DecisionCenter Installation Guide. 

Task 6: Map and Test the Tailored Data Schema

When planning, allow three to 12 days to complete this task.

— Step 1: Customize the DecisionCenter Analytics data schema and 
synchronization. 

— Step 2: Test the following:

– Schema difference checking based on your ServiceCenter schema

– Customization for changed fields

– Data warehouse schema updates

– Connect-It scenarios updates

– Universe updates

– Connect-It data warehouse scenario execution

– Report creation for three to five reports

For more information, see the DecisionCenter Installation Guide. 
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Task 7: Deploy to a Production Environment

See the DecisionCenter Installation Guide for information about running the 
installer to get the latest files that you need to take advantage of the new 
DecisionCenter Analytics features. 

Task 8: Continue to Customize Your Environment

Customization is an ongoing process. To adhere to best practices, always back 
up your files before you make changes to schemas, scenarios, and universes.
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B Schema Changes
Schemas contain information from tables in the data warehouse. If you changed your 
schemas, you need to be aware of changes that may affect your customizations.

DecisionCenter 1.00 Table Changes

The following section identifies ServiceCenter data warehouse table changes in the 
rds_etl.xml file. There are no changes to AssetCenter.

The following tables contain schema updates that reflect new tables and changes to existing 
tables in the DecisionCenter data warehouse. 

Table 20 New Tables

Table Type Table Name

Dimension DEVICEGROUP_D
DEVICEGROUPMAP_D
DEVICEGROUPMAP_F
CIRELATIONSHIP_D
REQUEST_D
REQUEST_F
REQLINE_D
REQUEST_F
BISVCCART_D
BISVCCARTITEM_D

DirectMapping BIZSERVICE
REQ_APPROVALLOG
SERVICE_CATALOG
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Table 21 Updates to Existing Dimension Tables

Table Updated Information

INCIDENT_D <dimensionTableField name=”SVCCART_CARTID” type=”char” 
size=”30” attributeAction=”add”/>

<dimensionTableField name=”SVCCART_COST” type=”float” 
attributeAction=”add”/>

<dimensionTableField name=”APPROVAL_STATUS” type=”char” 
size=”60” attributeAction=”add”/>

<dimensionTableField name=”APPROVED_COUNT” type=”float” 
attributeAction=”add”/>

CM3R_F Changed
<factKey name=”date_enteredID” fieldName=”date_entered” 
tableName=”RDS_TIMEDIM_D” matchFieldName=”FULLDATE”/>

To:
<factKey name=”PLANNED_STARTID” 
fieldName=”PLANNED_START” tableName=”RDS_TIMEDIM_D” 
matchFieldName=”FULLDATE”/>

OUTAGE_D <dimensionTableField name=”RELATED_TO_CHANGE” 
type=”char” size=”1” attributeAction=”add”/>

<dimensionTableField name=”RELATED_TO_INCIDENT” 
type=”char” size=”1” attributeAction=”add”/>

OUTAGEEVENT <directMappingField name=”REFERENCE_KEY_NODEP” 
type=”char” size=”40” attributeAction=”add”/> 
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C Scenario Changes
Scenarios contain information from tables in the data warehouse. If you customized your 
scenario, you must merge the changes with your modified scenario.

DecisionCenter 2.00 Scenario Changes

The new structures needed to support ServiceCenter 6.2 and Service Manager 7.0 required 
several changes to the Connect-It scenario.

Table 22 Scenario Changes

Change Type Affected Table Change

Modified 
Document

INCIDENT Added fields: 

• svcCart.cartId
• svcCart.cost
• approval.status
• approved.count 

(if 
(['approval.status'] = ”approved”) 
then
retVal=”1”
else 
retVal=”0”
end if)

OUTAGEEVENT Added fields:
• reference_key_nodep 

RetVal = 
Replace(RightPart(['record.tag'], 
”;”, 0),”DEP”,””,0)
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Added Document DEVICEGROUP Added fields from cigroup:

• logical.name
• baseline.version.version.number

Added fields from cigroupStage:

• sysmodtime
• sysmoduser
• TopCIGroup
• TopCIVersion

DEVICEGROUPMAP Added fields from cigroupStage:

• cigroupStage
• leafmemberci
• sysmodtime
• sysmoduser

Added Document DEVICEPARENT Added fields from cirelationshipBSStage:

• childCI
• nbrLvl
• outage.threshold
• parentCI
• sysmodtime
• sysmoduser

CIRELATIONSHIP Added fields from cirelationshipStage:

• ChildCI
• CIRelationshipName
• CIRelationshipSubtype
• CIRelationshipType
• outage.dependency
• outage.threshold
• PhysicalParentCI
• sysmodtime
• sysmoduser

Table 22 Scenario Changes

Change Type Affected Table Change
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Added Document REQUEST Added fields from default 'REQUEST' 

ocmq

• approval.status
• assigned.dept
• close.date
• submit.date
• priority
• requested.for
• number
• requestor.name
• status
• sysmodcount
• sysmodtime
• sysmoduser
• total.cost
• update.date

Added fields if coming from 'CATALOG' of a 
request. This is turned off by default.

svcCart

• cartId
• interaction.'approval.status'
• interaction.'assignment', 'assignment'
• interaction.'close.time'
• interaction.'priority.code'
• interaction.'contact.name'
• sdID
• interaction.'callback.contact'
• interaction.severity
• interaction.open
• interaction.'open.time'
• interaction.sysmodcount
• interation.sysmodtime
• interaction.sysmoduser
• cost
• intereaction.'update.time'

Table 22 Scenario Changes

Change Type Affected Table Change
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Added Document REQLINE Added fields from default 'REQUEST'

ocml

• unit.cost
• status
• category
• number
• part.desc
• phase.num
• quantity
• ocmq.'requested.for'
• ocmq.number
• ocmq.'requestor.name'
• 'submit.date'
• sysmodcount
• sysmodtime
• sysmoduser

Added fields if coming from 'CATALOG' of a 
request. This is turned off by default.

svcCartItem

• svcCatalogId
• cost
• status
• svcCatalog.parent
• cartItemId
• item.description
• cartItemId
• quantity
• requested.for
• sdID
• requested.by
• sla.breach
• request.time
• sysmodcount
• sysmodtime
• sysmoduser

Table 22 Scenario Changes

Change Type Affected Table Change
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Added Document BIZSERVICE Added fields:

• logical.name
• problem.manager
• sysmodcount
• sysmodtime
• sysmoduser

REQ_APPROVALLOG Added fields:

• date
• group
• name
• counter
• file.name
• unique.key
• sysmodcount
• sysmodtime
• sysmoduser

SERVICE_CATALOG Added fields:

• active
• description
• id
• name
• non.cart
• owner
• parent
• sysmodcount
• sysmodtime
• sysmoduser
• type

Table 22 Scenario Changes

Change Type Affected Table Change
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