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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty 
statements accompanying such products and services. Nothing herein should be construed as 
constituting an additional warranty. HP shall not be liable for technical or editorial errors or 
omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. 
Consistent with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software 
Documentation, and Technical Data for Commercial Items are licensed to the U.S. 
Government under vendor's standard commercial license.

Copyright Notices

© Copyright 2007 – 2008 Hewlett-Packard Development Company, L.P.

Trademark Notices

Adobe® is a trademark of Adobe Systems Incorporated. 

Microsoft® and Windows® are U.S. registered trademarks of Microsoft Corporation.

UNIX® is a registered trademark of The Open Group.
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Documentation Updates

To check for recent updates, or to verify that you are using the most recent edition of a 
document, go to:

http://ovweb.external.hp.com/lpe/doc_serv/ 

You will also receive updated or new editions if you subscribe to the appropriate product 
support service. Contact your HP sales representative for details.
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Support

You can visit the HP software support web site at:

www.hp.com/go/hpsoftwaresupport

HP Software online support provides an efficient way to access interactive technical support 
tools. As a valued support customer, you can benefit by using the support site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many 
also require a support contract.

To find more information about access levels and HP Passport, go to:

http://support.openview.hp.com/new_access_levels.jsp 
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1 Introduction

HP DecisionCenter is a business intelligence application that enhances your 
ability to make decisions about your IT infrastructure. Out-of-box analytics 
show performance metrics for Service Strategies, Service Design, Service 
Transition, and Service Operation based on your historical data. 
DecisionCenter can display analytics in a dashboard for quick access and 
supports an integrated BusinessObjects Enterprise XI suite of analytic tools. 

DecisionCenter has three levels:

— IT Performance Analytics (ITPA)

— Business Intelligence Analytics (BIA)

— Optimization

Each component installs separately with separate licensing requirements. 

Installation Guide Overview

Although you can install the complete product on one workstation, the typical 
scenario is a distributed installation where there are several servers hosting 
different components. The DecisionCenter installer guides you through all the 
activities on one server before you move to the next server.

The installation instructions follow this same path. There is a separate 
chapter with installation steps and activities for each server. The chapters are 
in the suggested order of installation. HP recommends that you complete all 
the steps and activities in one chapter before you begin the next chapter.
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Hardware Requirements

The following table describes the minimum hardware requirements for 
DecisionCenter. For more information, see the DecisionCenter Support Matrix 
on the HP Software Support web site (http://support.openview.hp.com/
sc/support_matrices.jsp).

Table 2 Hardware Requirements

Item Minimum Requirement

RAM ITPA only: The minimum recommended RAM is 2 GB for the 
Tomcat server and 4 GB for the BusinessObjects server.
BIA and Optimization: The minimum recommended RAM is 2 GB 
for the Optimization engine server, 2 GB for the Tomcat server, 
and 4 GB for the BusinessObjects server. 
The minimum recommended RAM is 4 GB if the Optimization 
engine and Tomcat are on the same server.
Multiple instances of the application server, or very large 
databases may require more than the minimum amount of 
memory.

Disk Space 5 GB for BusinessObjects Enterprise XI R2 
1.5 GB for BusinessObjects Enterprise XI Performance 
Manager Deployment Tool (PMDT)
5 GB for any database server
Windows: 200 MB for the DecisionCenter application
Unix: 600 MB minimum for the DecisionCenter application

Heap Size The heap size setting on the Web server that hosts the 
DecisionCenter application must be at least 512 MB. The 
recommended setting is 1024 MB.
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Software and Platform Requirements

For complete information about required software that must be installed and 
configured before you install DecisionCenter, see the DecisionCenter Support 
Matrix on the HP Software Support web site (http://
support.openview.hp.com/sc/support_matrices.jsp).

Server Configuration

DecisionCenter can run in a single or multi-server environment. In a single 
server configuration, all software resides on the same server. The most 
common configuration for an enterprise organization is a multi-server 
environment with five different servers.
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The Optimization engine can reside on the data warehouse server, or you 
might want it to install it on a separate server with more resources.

DecisionCenter and Third Party Software

Before you begin the DecisionCenter installation process, make sure that:

• You have all required licenses for third-party database products that 
interact with DecisionCenter.

• You have the BusinessObjects Enterprise XI installation media and 
installation instructions available. If you have an existing 
BusinessObjects Enterprise XI installation, you must have these three 
BusinessObjects components installed to support DecisionCenter:

— BI Platform

— Dashboard Manager

— Performance Manger

For more information, contact your Business Objects sales representative.

• Users who will log on to the BusinessObjects Enterprise XI server have 
appropriate rights.

DecisionCenter and Other HP Software Products

There are additional considerations as you continue the DecisionCenter 
installation process:

• The HP ServiceCenter, Service Manager, and AssetCenter applications 
should reside on servers that are separate from installed DecisionCenter 
components.

• The ServiceCenter, Service Manager, or AssetCenter data warehouse 
usually resides on a server that is separate from the server hosting those 
applications.

• Install HP Connect-It on the same server where you install the 
ServiceCenter, Service Manager, or AssetCenter data warehouse.

For more information, see Server Configuration on page 18.
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Installation Media

The DecisionCenter installation media consists of applications on separate 
CD-ROM media. They contain the following information.

Connect-It

Connect-It 3.80 is required; however, you must obtain the correct version 
directly from HP Support. You can obtain Connect-It 3.80 (build 7236) by 
contacting your HP sales representative or visiting the HP software 
support (www.hp.com/go/hpsoftwaresupport) web site.

Table 3 Installation Media

CD-ROM
Number 
of Disks Contents Required?

DecisionCenter 2.00 1 Application

ServiceCenter or Service 
Manager data warehouse

AssetCenter data 
warehouse

Business Impact Analytic 
(BIA) tools, Connect-It 
scenarios, and related 
Analytics

Optimization engine

Yes

BusinessObjects XI 
R2 SP1

3 BusinessObjects 
Enterprise XI application

Yes

BusinessObjects XI 
R2 Supplement

1 File to repair the command 
line import tool 
(bexir2_60080.zip)

Performance Management 
Deployment Tool (PMDT)

Yes
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License Information

DecisionCenter packaging includes licenses for BusinessObjects 
Enterprise XI R2 and Connect-It 3.80. Other applications require separate 
licenses. You can obtain DecisionCenter licenses by contacting your HP sales 
representative or visiting the HP software support (www.hp.com/go/
hpsoftwaresupport) web site. The following table describes all of the 
licenses and passwords that you should have available when you begin the 
installation.

Table 4 Required Licenses

Application Included? Notes

DecisionCenter IT Performance 
Analytics (ITPA)

Yes

DecisionCenter Business Impact 
Analytics (BIA))

Yes BIA authorization code 
required during installation.

DecisionCenter Optimization Yes Optimization authorization 
code required during 
installation.

BusinessObjects Enterprise XI Yes License keys required.
HP Service Agreement ID 
required to download 
BusinessObjects Critical Hot 
Fix

Connect-It Yes License key included with 
DecisionCenter

AssetCenter No Separately licensed 
application

ServiceCenter or 
Service Manager

No Separately licensed 
application
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If you choose Microsoft SQL Server, you must purchase two sets of licenses.

Microsoft SQL Server connections require that you purchase four or more licenses 
from Microsoft.

Before You Begin

Consider the following information before you begin:

• There are several tasks required to create a complete DecisionCenter 
installation where you can access and customize Analytics, perform 
Business Impact analysis, view historical IT performance, and run 
Optimization scenarios and simulations. The tasks involve setting up a 
database, populating it with relevant data, and installing the 
DecisionCenter software components. The number of tasks depends on the 
number of DecisionCenter components that you choose to install.

• Plan to complete the tasks in each chapter in sequential order and the 
steps within each task in sequential order.

• You must have an existing installation of a supported database product. 

One of the following: 
• Oracle 10g
• Microsoft SQL Server 2000
• Microsoft SQL Server 2005

No Separately licensed 
application

One of the following:
• Tomcat
• IBM WebSphere

Tomcat is available in the 
Business Objects 
installation. IBM 
WebSphere is a separately 
licensed application.

JDBC drivers No Separately licensed 
applications

Table 4 Required Licenses

Application Included? Notes
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• Because DecisionCenter relies on the Sun Java Runtime Environment 
(JRE) for Daylight savings time support, the Optimization engine requires 
Sun j2re 1.4.2_11 or a later version of 1.2.4. You can access the latest 
version on the Sun (http://www.java.com/en/download/
manual.jsp#win) web site.

Make sure that this version is available on the Optimization engine 
server, the data warehouse server, and on the application server.

Review the DecisionCenter Support Matrix before you begin to ensure that 
you have the required environment. For more information, see the 
DecisionCenter Support Matrix on the HP Software Support web site 
(http://support.openview.hp.com/sc/support_matrices.jsp).

JDBC Drivers

You need JDBC drivers on the data warehouse and DecisionCenter 
application servers for the ITPA and BIA installations. You also need JDBC 
drivers on the server that hosts the DecisionCenter Optimization engine. 
Oracle JDBC drivers are embedded in the client software installation. You can 
download the JDBC drivers for SQL Server from the Microsoft web site. 

If you already have the correct drivers, you do not have to install and 
configure the drivers again, but you should verify that the drivers are in the 
appropriate locations.

Whether you use existing drivers, or install new ones, make sure that the 
required JDBC drivers are available before you begin the DecisionCenter 
installation and that you are familiar with the path to the drivers. 
DecisionCenter will ask for the path during the installation process.  

Check your database vendor licensing policies if you copy the drivers from a 
licensed installation.

Table 5 JDBC Driver Paths

Database Driver Type Driver Name

Oracle JDBC ojdbc14.jar 

Microsoft SQL Server 2000 JDBC msbase.jar, mssqlserver.jar, msutil.jar

Microsoft SQL Server 2005 JDBC sqljdbc.jar
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2 DecisionCenter Components

DecisionCenter has three product components to support user needs. The 
components are:

• IT Performance Analytics (ITPA)

• ITPA and Business Impact Analytics (BIA)

• ITPA, BIA, and Optimization

IT Performance Analytics

ITPA includes:

• Dashboards 

• Out-of-box analytics that support the ITIL version 3 view of service 
strategies, service operations, and service transitions

• The BusinessObjects Enterprise XI suite of tools 

• Data warehouse schema support for ServiceCenter 5.1 and later releases, 
Service Manager 7.00, and AssetCenter 4.3, 4.4, and 5.0

ITPA and Business Impact Analytics 

BIA adds more functionality and analytics to ITPA:

• Dashboards 

• Out-of-box analytics that support the ITIL version 3 view of service 
strategies, service operations, and service transitions

• The BusinessObjects Enterprise XI suite of tools 

• Data warehouse schema support for ServiceCenter 5.1 and later releases, 
Service Manager 7.00, and AssetCenter 4.3, 4.4, and 5.0
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• Business Intelligence Analytics and views

• Business and Environment models

• Impact definition

• Change impact calculator

• Incident impact calculator

• Data mining tools

• History Builder

• Scenario Manager

ITPA, BIA, and Optimization

Optimization includes ITPA and BIA components:

• Dashboards 

• Out-of-box analytics that support the ITIL version 3 view of service 
strategies, service operations, and service transitions

• The BusinessObjects Enterprise XI suite of tools 

• Data warehouse schema support for ServiceCenter 5.1 and later releases, 
Service Manager 7.00, and AssetCenter 4.3, 4.4, and 5.0

• Business Intelligence Analytics and views

• Business and Environment models

• Impact definition 

• Change impact calculator

• Incident impact calculator

• Data mining tools

• History Builder

• Scenario Manager

• The Optimization engine
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DecisionCenter Data

DecisionCenter depends on data that is extracted from HP ServiceCenter, 
HP Service Manager, or HP AssetCenter. The software that manages the ETL 
process is HP Connect-It 3.80. DecisionCenter supplies different out-of-box 
scenarios to extract source data at different times. Each has a specific purpose 
to extract new data or to update existing data. 

Table 6 Connect-It Scenarios

Scenario Name Purpose

rds_sc.scn Initially imports ServiceCenter or Service 
Manager data for ITPA. This scenario is 
automatically configured for the version of 
ServiceCenter or Service Manager that you 
specify during installation. May be re-run to 
capture new data, or changes to existing 
data, that populates ITPA analytics.

rds_ac.scn Initially imports AssetCenter data for ITPA. 

dco_sc.scn Imports additional data into the 
DecisionCenter data warehouse to populate 
BIA and Optimization analytics. May be 
re-run regularly to capture new data or 
changes to existing data. This scenario does 
not import change request data.

 dco_rds.scn Converts imported data in the 
DecisionCenter data warehouse. Adds 
required columns for BIA and Optimization. 
May be re-run regularly to update new data 
used by BIA and Optimization.

dco_change.scn Imports only change data from Service 
Manager. May be re-run regularly to gather 
new change data or update existing change 
data.
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3 Build the Data Warehouse

The chapter includes the information that you need to build and configure the 
data warehouse for ServiceCenter, Service Manager, or Asset Center data. For 
more information, see the DecisionCenter Support Matrix on the HP 
Software Support web site (http://www.hp.com/go/hpsoftwaresupport).

Data Warehouse Checklist

Print this checklist to use during the installation process. As you complete 
each task, mark it finished. Complete these tasks on the RDBMS, 
DecisionCenter data warehouse, and ServiceCenter, Service Manager, or 
AssetCenter servers. For more information, see the distributed server 
configuration diagram on page 18.

If you have an existing DecisionCenter data warehouse, back it up before you 
begin. The installer can detect an existing data warehouse and will attempt to 
upgrade it to meet the requirements of DecisionCenter 2.00. After you 
complete the installation, follow the instructions in the DecisionCenter 
Migration Guide to complete the upgrade.
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 Task 1: Prepare the Source Data on page 32.

— Step 1: Import ServiceCenter or Service Manager Unload Files on 
page 32.

Or

— Step 1a: Import AssetCenter Script Files on page 33.

 Task 2: Create the Tablespace and Users on page 34.

— Step 1: Run the Oracle Configuration Script File on page 35.

Or

— Step 1a: Run the Microsoft SQL Server Configuration Script File on 
page 36.

— Step 2: Capture the Database Server Information on page 37.

 Task 3: Install and Configure Connect-It on page 37.

— Step 1: Install Connect-It on page 37.

— Step 2: Copy the Connect-It Configuration Files on page 38.

— Step 3: Configure the Time Zone on page 39.

 Task 4: Configure the Database Clients on page 40.

— Step 1: Configure the Oracle Database Client on page 40.

Or

— Step 1a: Configure the Microsoft SQL Server Database Client on 
page 42.

— Step 2: Collect Installation Information on page 43.

Complete Task 1 on the ServiceCenter, Service Manager, or AssetCenter 
server. There are two instances of Step 1. Choose the one that matches your 
data source.

Complete Task 2 on the RDBMS server. There are two instances of Step 1. 
Choose the one that matches your RDBMS, then complete Step 2.

Complete Task 3, 4, and 5 on the data warehouse server. For Task 4, there are 
two instances of Step 1. Choose the one that matches your RDBMS.
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 Task 5: Install the Data Warehouse on page 46.

— Step 1: Start the ServiceCenter Server on page 46.

— Step 2: Start the Service Manager 7.00 Server on page 46.

— Step 3: Install the Data Warehouse on page 48.

— Step 4: Point to the ServiceCenter 6.2.2 Server on page 50.

 Task 6: Create the Database Tables and Views on page 51.

— Step 1: Create the ITPA Tables and Views on page 51.

— Step 2: Create the BIA Tables and Views on page 52.

 Task 7: Import ITPA Service Management Data on page 52.

 Task 7a: Import ITPA Asset Management Data on page 53.

 Task 8: Verify the Results on page 55.

Task 

Complete Task 6 on the RDBMS server.

Complete Task 7 on the DecisionCenter data warehouse server.
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Task 1: Prepare the Source Data

The following instructions are for supported versions of ServiceCenter, Service 
Manager, or AssetCenter.

Step 1: Import ServiceCenter or Service Manager Unload Files

Unload files contain records that you need to use ServiceCenter or Service 
Manager with DecisionCenter. The DecisionCenter installation media 
contains one required unload file. Your ServiceCenter or Service Manager user 
profile must have system administration rights to complete this procedure.

If you have a DecisionCenter 1.0 installation, it is important to apply the 
newest unload to meet the requirements of DecisionCenter 2.00. Do not skip 
this step.

1 Insert the DecisionCenter installation media in your hard drive. The 
installer starts automatically, or you can click Autorun.exe to start the 
installer.

2 Select the Data Warehouse tab and click ITPA for SM.

3 Click Import Service Manager or ServiceCenter Unload Files.

4 Copy DCA20.unl to your local hard drive if your data originates with 
ServiceCenter 6.2.x or Service Manager 7.00. Copy DCA20_PreSC62.unl 
to your local hard drive if your data originates with ServiceCenter 5.1.x or 
6.0.x.

5 Start the ServiceCenter or Service Manager client that connects to the   
ServiceCenter or Service Manager server. Make sure the associated 
service is running.

6 From the ServiceCenter or Service Manager navigation pane, select one of 
the following:

Toolkit > Database Manager (ServiceCenter)

Tailoring > Tailoring Tools > Database Manager (Service Manager)

7 Right-click anywhere on the screen to open the pop-up menu.

8 Select Import/Load.

9 Click the File Name folder icon to locate the unload file that you copied to 
your local hard drive.
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10 Select DCA20.unl or DCA20_PreSC62.unl. Click Open.

11 Click Load FG on the toolbar. ServiceCenter or Service Manager displays a 
confirmation message when the unload is complete.

12 Close the ServiceCenter or Service Manager client.

Step 1a: Import AssetCenter Script Files

Script files contain records that you need to use for AssetCenter with 
DecisionCenter. Your user profile in AssetCenter must have system 
administration rights to complete this procedure. If you have a 
DecisionCenter 1.0 installation, it is important to import the newest scripts to 
meet the requirements of DecisionCenter 2.00. Do not skip this step.

1 Insert the DecisionCenter installation media in your hard drive. The 
installer starts automatically, or you can click Autorun.exe to start the 
installer.

2 Select the Data Warehouse tab and click ITPA for AM.

3 Click Run AssetCenter Import Scripts.

4 Copy the contents of this folder to your local hard drive:

\\ITPA\ITPA-AM\SupportFiles\import

5 Start the AssetCenter client that connects to the AssetCenter server.

6 Click File > Import.

7 Click Execute a Script.

8 Click Browse to locate the folder you copied to your local hard drive.

9 Change the Files of Type drop-down to All Files (*.*).

10 Select the dca.lst file.

11 Click Import.

12 Close the AssetCenter client.
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Task 2: Create the Tablespace and Users

DecisionCenter supports Oracle, Microsoft SQL Server 2000, or Microsoft SQL 
Server 2005. These instructions assume that you have a licensed database 
server installed before you begin the DecisionCenter installation. 

Always consult your database administrator before installing and configuring 
the database.

HP strongly recommends that your data warehouse be case-sensitive. Make 
sure that the TCP/IP service for your RDBMS is running and that the ports 
for this service are set to 1433. 

If you have an existing DecisionCenter installation, you should not 
re-configure the database server and create new connectors. Skip this task 
and proceed to Task 3: Install and Configure Connect-It on page 37.

Configuration Scripts

You can use DecisionCenter scripts to configure the database. There are three 
types of users and three tablespaces:

• A data warehouse user and a data warehouse tablespace for 
DecisionCenter (rdsdb)

• A Central Management Console user and a CMS tablespace for 
BusinessObjects Enterprise XI (cmsdb)

• A Performance Management user and a PM tablespace (pmsdb)

The DecisionCenter scripts create tablespaces and users that match the 
default values specified in this chapter. If you want different tablespace and 
user names, edit the scripts, or configure the data warehouse manually.
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Database Connectors

With most databases, you can access the database server from different clients 
with different names. Because DecisionCenter has multiple components and 
servers, you must reference the database server with the same name. The 
following table lists the database and the terminology for client configuration.

To simplify the names, the client configuration in this document is called the 
database connector.

Step 1: Run the Oracle Configuration Script File

You can change the default values for the database user name, password, and 
database name. If you change the default values, do not exceed the limitation 
of 20 characters each for the user name, password and database name. Use 
any text editor to change these values in the script file that configures the 
SQL Server database server. 

1 Insert the DecisionCenter installation media in your hard drive. The 
installer starts automatically, or you can click Autorun.exe to start the 
installer.

2 Select the Data Warehouse tab and click ITPA for SM or ITPA for AM.

3 Click Create Database Tablespace and Users.

4 Copy the contents of this folder to your local hard drive:

\\ITPA-SM\...\SupportFiles\DatabaseFiles

5 Open this file with a text editor:

\\..DatabaseFiles\crtusers_oracle.sql 

6 Verify that the settings are appropriate for your installation. 

7 If necessary, change the settings.

Table 7 Client Configuration

Database Type Client Configuration

Oracle TNS Alias

SQL Server ODBC System DSN
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8 Save the file locally. 

9 Run the script. 

Step 1a: Run the Microsoft SQL Server Configuration Script File

You can change the default values for the database user name, password, and 
database name. If you change the default values, do not exceed the limitation 
of 20 characters each for the user name, password and database name. Use 
any text editor to change these values in the script file that configures the 
SQL Server database server. 

1 Insert the DecisionCenter installation media in your hard drive. The 
installer starts automatically, or you can click Autorun.exe to start the 
installer.

2 Select the Data Warehouse tab and click ITPA for SM (or ITPA for AM).

3 Click Create Database Tablespace and Users.

4 Copy the contents of this folder to your local hard drive:

\\ITPA-SM\...\SupportFiles\DatabaseFiles

5 Open this file with a text editor:

\\..\DatabaseFiles\crtusers_sqlsrvr.sql 

6 Verify that the settings are appropriate for your installation. 

7 If necessary, change the settings.

8 Save the file locally. 

9 Open the file with Microsoft SQL Server.

10 Click Execute to run the query that builds the databases and users.
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Step 2: Capture the Database Server Information

Record your Oracle or Microsoft SQL Server connection information in the 
following table for later reference. 

Task 3: Install and Configure Connect-It

Connect-It is a software product that integrates HP Software applications, 
such as DecisionCenter, with other HP Software applications, such as 
ServiceCenter, Service Manager, or AssetCenter. You must install 
Connect-It 3.80 on the same dedicated server where you plan to install the 
ServiceCenter, Service Manager, or AssetCenter data warehouse. 

If you have an earlier version of Connect-It, it is important to install the 
newest supported version to meet the requirements of DecisionCenter 2.00 
and complete the configuration steps. Do not skip this task.

Step 1: Install Connect-It

1 Insert the Connect-It 3.80 installation CD into the CD-ROM. If the 
Connect-It installer does not start automatically, click setup.exe to start 
the installer. If you obtain an electronic version of Connect-It 3.80 from 
HP Support, unzip the archive and click setup.exe to start the installer.

2 At the Welcome screen, click Next.

3 Accept the License Agreement and click Next.

Table 8 RDBMS Server Values

Server Default Value Your Value

Server name server_name 

Port 1433 

Data warehouse name rdsdb 

CMS database name cmsdb

PM database name pmdb
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4 Provide your customer information and click Next.

5 Choose the Typical option in the Connect-It setup screen and click Next.

6 Click Next to install to the default location, or click Change to install to a 
different directory.

7 Click Install.

8 Click Finish to complete the installation.

9 Copy the license.txt file to the Connect-It installation directory. 

HP Support provides a text file that contains an authorization code for 
Connect-It when you purchase DecisionCenter. If you receive an 
out-of-date license message, copy the contents of your new license.txt file 
and paste it in the Authorization Certificate dialog box.

10

Step 2: Copy the Connect-It Configuration Files

1 Copy all the .cfg files in one of these DecisionCenter installation media 
directories, depending on your source data:

\\ITPA\ITPA-SM\SupportFiles\CIT\*.cfg

\\ITPA\ITPA-AM\SupportFiles\CIT\*.cfg

To this Connect-It directory:

\\..\HP OpenView\Connect-It 3.80 en\config\sc\config

2 Copy this file from the DecisionCenter installation media:

\\ITPA\ITPA-SM\SupportFiles\cit\gbbase.xml 

To this Connect-It directory:

\\..\HP OpenView\Connect-It 3.80 en\dbb

3 Copy one of these files from the DecisionCenter installation media. Choose 
the appropriate directory, depending on your source data:

\\ITPA\ITPA-SM\SupportFiles\CIT\rds.bas

\\ITPA\ITPA-AM\SupportFiles\CIT\rds.bas

If the \dbb folder does not exist, create the folder and then paste 
the gbbase.xml file in it.
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To this Connect-It directory:

\\..\HP OpenView\Connect-It 3.80 en\config\rds\bas

Step 3: Configure the Time Zone

DecisionCenter depends on precise time of day information to apply rules and 
calculate impact. Connect-It and AssetCenter store data in GMT and convert 
to local time for display purposes. DecisionCenter stores data in local time. 
You must configure Connect-It to use the local time of the BusinessObjects 
server. 

1 Open Connect-It Help and search for information about the 
PifDateToTimezone setting. The PifDateToTimezone documentation contains 
list of valid time zones. Locate the syntax for the time zone where the 
BusinessObjects server resides.

2 Make a backup copy of this file:

\\..\HP OpenView\ConnectIt 3.80 en\config\rds\bas\rds.bas

If you store the backup copy in the same directory as the original, do not 
use .bas as the file extension. Connect-It will attempt to load both files 
and generate errors.

3 Open rds.bas with a text editor.

4 Search for the function named UTCToLocalDate. You should find three 
uncommented lines containing this function:

— retAgeTmp=DateDiff(now,UTCToLocalDate(startDate))

— retAgeTmp=DateDiff(UTCToLocalDate(endDate),
UTCToLocalDate(startDate))

— RetDate=UTCToLocalDate(scDate)

5 For each instance of UTCToLocalDate(variable), replace it with:

PifDateToTimezone(<variable>,"UTC", 0,<BusObjServer_time_zone>,0)

For example:

RetDate=UTCToLocalDate(scDate)

Becomes
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RetDate=PifDateToTimezone(scDate,"UTC", 0,"Pacific Standard Time", 0)  

Save and close the file.

Task 4: Configure the Database Clients

The following table shows where the database client must be installed. If any 
installations are missing, correct the omissions.

Step 1: Configure the Oracle Database Client

To configure the Oracle client, create a net service (TNS) name for the Oracle 
database server where DecisionCenter components reside. When prompted, 
select settings that correspond with your database type. You can disregard 
any value that does not apply to your database environment. Record your 
settings for future reference.

Table 9 Database Servers

Database Client
Data 
Warehouse Server 

BusinessObjects 
Enterprise XI server

Oracle Required Required

SQL Server Required Required
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1 Click Start > Programs > Oracle OraHome<version> > Configuration and 
Migration Tools > Net Configuration Assistant.

2 Select Local Net Service Name configuration.

3 Click Next.

4 Select Add and click Next.

5 Type the Service Name and click Next. You can find the Oracle Service 
name in your Windows services.

6 Select TCP and click Next.

7 Type the Host name of the Oracle service, confirm the Port number, and 
click Next.

8 Select Yes, perform a test and click Next.

9 Do one of the following:

— If the Test successful message appears, click Next.

— If you receive an error message, click Change Login. Type the new 
log-on information, click OK, and click Next. If you continue to receive 
an error message, contact your database administrator.

Table 10 Oracle Values

Oracle Default Value Your Value

Hostname physical_device_name 

Port 1521 

Database service 
name

orcl 

JDBC URL jdbc:oracle:thin:@server_name:
1521:orcl 

Data warehouse 
tablespace name

rdsts 
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10 Type a TNS name. Record the TNS information that you specify for the 
Oracle client. Click Next. 

11 Click Next.

12 Click Next again.

13 Click Finish.

Make sure that you configure the tnsnames.ora file correctly. The file is 
in this directory:

\\Oracle\product\version_#\server_directory\network\admin

For example:

rdsdb =
(DESCRIPTION =

    (ADDRESS_LIST =
      (ADDRESS = (PROTOCOL = TCP)(HOST = dbsrv)(PORT = 1521))

)
    (CONNECT_DATA =
      (SID = orcl)

)
) 

Step 1a: Configure the Microsoft SQL Server Database Client

Configuring the SQL Server database client means creating a DSN ODBC 
connection for each database on each server that hosts a SQL Server client.

1 Click Start > Settings > Control Panel > Administrative Tools > Data Sources.

2 Click the System DSN tab in the ODBC Data Source Administrator dialog.

3 Click Add. 

Table 11 TNS Information

Oracle Default Value Your Value

Data warehouse db rdsdb

CMS db cmsdb

PM db pmdb
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4 Select SQL Server.

5 Click Finish.

6 In the Name field, type the database name specified in the configuration 
script file that you ran in Step 1a: Run the Microsoft SQL Server 
Configuration Script File on page 36. For example, type rdsdb. 

7 Type an optional Description.

8 From the Server drop-down menu, select the SQL Server you are using.

9 Click Next.

10 Select With SQL Server authentication using a login ID and password entered 
by the user.

11 In the Login ID field, type the database administrator’s name specified in 
the configuration script file. For example, type rds_dba.

12 In the Password field, type the password provided in the script (or by your 
database administrator). For example, type passw0rd. 

13 Click Next.

14 Make sure that the Change Default Database to check box is clear and that 
the DSN name appears in the background of the text box. Do not change 
the other check boxes.

15 Click Next. 

16 Do not change any check boxes. Click Finish.

17 Click Test Data Source to test the connection. 

18 If the connection is valid, a confirmation message appears. Click OK.

19 Click OK again to see the new entry in the System Data Source list.

20 Repeat Step 3 on page 42 through Step 19 to create a DSN ODBC 
connection for the cmsdb and pmdb databases.

21 Click OK to exit the ODBC Data Source Administrator.

Step 2: Collect Installation Information

You need to collect various pieces of information to complete the installation of 
the data warehouse, as well as the installation of the BusinessObjects Central 
Management Server (CMS) and Performance Management (PM), and the 
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analytic content. Record your user information in the following tables for later 
reference. You will use the information in Table 12 to complete the steps in 
this chapter.  

Table 12 Required Installation Information for the Data Warehouse

Required Information
 Default Value

MS SQL          Oracle Your Value

RDBMS server name None server_name

RDBMS server port 
number

1433 1521

Data warehouse name rdsdb rdsdb

DSN (or TNS) Alias rdsdb rdsdb

Data warehouse user 
name

rds_dba rds_dba

Data warehouse password passw0rd passw0rd

Host name of the 
ServiceCenter or Service 
Manager server

None server_name

ServiceCenter or Service 
Manager server port 
number

12670 (SC)
12690 (SM)

ServiceCenter or Service 
Manager connector user 
name

bi_connector
(specified in the .unl file)

bi_connector

ServiceCenter or Service 
Manager connector 
password

None
(user-defined)
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You will use the information in Table 13 to complete the steps in Chapter 5, 
Install BusinessObjects Enterprise XI.  

You will use the information in Table 14 to complete the steps in Chapter 7, 
Install the DecisionCenter Analytics.  

Table 13 BusinessObjects XI R2 Installation Information

Required Information
 Default Value

MS SQL          Oracle Your Value

CMS database name cmsdb cmsts

CMS user name cms_dba cms_dba 

CMS password passw0rd passw0rd 

PM database name pmdb pmts 

PM user name pm_dba pm_dba 

PM password passw0rd passw0rd 

Table 14 Analytic Installation Information

Required Information
 Default Value

MS SQL          Oracle Your Value

CMS server name None server_name

CMS server port number 6400

CMS server administrator 
name

Administrator

CMS server administrator 
password

None
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Task 5: Install the Data Warehouse

Before you begin, ensure that Connect-It and the ServiceCenter, Service 
Manager, or AssetCenter data warehouse are on the same server. If you have a 
DecisionCenter 1.0 installation, you must upgrade your existing data 
warehouse. Do not skip this task. 

Step 1: Start the ServiceCenter Server

If you have ServiceCenter 5.1, 6.0, or 6.2, make sure that the ServiceCenter 
server is running before you begin installing the data warehouse. If you have 
Service Manager 7.00, you must also complete the next step before you 
proceed with the DecisionCenter installation.

Step 2: Start the Service Manager 7.00 Server

If you do not have Service Manager 7.00 data, skip this step and proceed to 
Step 3: Install the Data Warehouse on page 48.

1 Ensure that you complete the unload process Task 1: Prepare the Source 
Data on page 32.

2 Service Manager 7.00 installs a folder that contains useful legacy 
application files for ServiceCenter 6.2.2. Open this ServiceCenter 6.2.2 file 
with a text editor:

\\..\HP\Service Manager 7.00\Server\LegacyIntegration\RUN
\sc.ini

3 Open this Service Manager 7.00 file with a text editor:

\\..\HP\Service Manager 7.00\Server\RUN\sm.ini file

4 Copy the database parameter section from sm.ini into sc.ini. For 
example, if you use SQL Server 2005, replace the following lines with the 
same lines copied from sm.ini:

sqldictionary:sqlserver
[sqlserver]
sqldb:database_name
sqllogin:login/password
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5 If your database is case sensitive, uncomment these three parameters:

sqldicttable:DBDICTM1
sqldictkey:NAME
sqldictrecord:DESCRIPTOR

6 Choose a port number for the ServiceCenter 6.2.2 server that is not the 
same as the port number specified for the Service Manager server. Change 
the port number parameter if you do not want to use the default 
ServiceCenter 6.2.2 port number, which is 12690.

system:12690

For example, if you choose port number 12345, change the system 
parameter to that value:

system:12345

7 Save and close both files.

8 Click Start > Control Panel > Administrative Tools > Services to start the HP 
Service Manager 7.00 Server.

9 Open a command window.

10 Change directories to point to the ServiceCenter 6.2.2 server directory. For 
example:

\\..\HP\Service Manager 7.00\Server\LegacyIntegration\RUN

11 Type this command and parameters. Substitute the port number specified 
in Step 6 on page 47 and a user-defined log file name if you do not want to 
use the default log file (sc_readonly.log) name.

scenter –listener:12690 –RPCReadOnly –log:sc_readonly.log

12 Verify that the ServiceCenter 6.2.2 server is running in your log file:

\\..\HP\Service Manager 7.00\Server\LegacyIntegration\RUN
\sc_readonly.log

Look for messages that confirm there is a connection. For example:

Connection established to database rdsdb

Connected to Data source 'rdsdb' SQL server 'server-name' 
version: 9.0.1399 Using database 'rdsdb' as user 'rds_dba'

Neither dblanguage nor language parameter are specified.
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MS SQL Server collation 'SQL_Latin1_General_CP1_CS_AS', 
varchar codepage 1252, comparison 196608: case sensitive, 
accent sensitive

Now using 327680 bytes for SQL buffersb

Step 3: Install the Data Warehouse

If you have an existing data warehouse, the installation performs an upgrade 
instead of a new installation. You should back up your existing data 
warehouse before you begin. Make sure that you complete all the preceding 
tasks and steps in this chapter before you begin to install the data warehouse. 

1 Insert the DecisionCenter installation media in your hard drive. The 
installer starts automatically, or you can click Autorun.exe to start the 
installer.

2 Select the Data Warehouse tab and click ITPA for SM (or ITPA for AM).

3 Click Install Data Warehouse for Service Management (or Install Data 
Warehouse for Asset Management).

4 From the Welcome screen, click Next.

5 Accept the End User License Agreement and click Next.

6 DecisionCenter has a default installation directory. Do one of the 
following:

• Accept the default installation directory and click Next.

• Click Change to choose another directory. then click OK, and click Next.

7 Select the ServiceCenter or Service Manager version that will transfer 
data into DecisionCenter.

8 DecisionCenter requires JRE 1.4.2_11 or a later version of 1.4.2. If you do 
not have this version, cancel this installation and install the correct 
version before you restart the DecisionCenter installation. 
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For more information, see Before You Begin on page 22. 

9 DecisionCenter locates the first Java installation directory that it finds. 
Do one of the following:

• Accept the default destination directory and click Next.

• Click Change to choose the directory with the required JRE. then click 
OK, and click Next.

10 Choose the correct RDBMS and click Next. If you select Microsoft SQL 
Server, choose the version and click Next.

11 If you selected Microsoft SQL Server, click Change to navigate to the 
location of the .jar  JDBC driver files. For more information about JDBC 
drivers, see JDBC Drivers on page 23.

12 Click Next.

13 Use the information that you recorded in Table 12 on page 44 to specify 
your RDBMS settings.

14 Click Next.

15 The installer displays the database configuration settings. Click Next or 
Back to correct errors.

16 The installer displays the JDBC URL, click Next or Back to correct errors. 

17 Accept or change the date parameters for your data warehouse server. 
These include the start year and stop year that the data warehouse uses 
for populating tables with data, and the month in which the fiscal year 
begins. 

18 Click Next.

19 Specify values for the following parameters: 

— The Host name of the ServiceCenter (or Service Manager) server and its 
port number. For example: server_name and 12670.

If you have incident data from the calendar year 2007 or later, or 
you want to run impact calculations or simulations for 2007 or 
later, you must obtain JRE 1.4.2_13 or a later version of 1.4.2 to 
support the changes to Daylight Savings Time in the United States. 
If your data is older, or you are not affected by time zones in the 
United States, you can use JRE 1.4.2_11.
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If you are connecting to Service Manager, specify the port number of 
the ServiceCenter 6.2.2 server. For example: 12690

— The ServiceCenter or Service Manager connection user name is 
always bi-connector. 

The DecisionCenter unload file adds bi-connector to the operator table 
to enable Connect-It to synchronize data between ServiceCenter or 
Service Manager and the data warehouse.

— Type the existing connection password if you created a password. 
(The out-of-box database connection has no password.)

20 The installer displays the ServiceCenter or Service Manager configuration 
information. Click Next, or Back to correct errors. 

21 Click Install to begin the installation process. Click Back to correct errors. 
The installation process can take several minutes. The installer displays 
its progress and opens a command window to run various scripts. 

If errors occur, review the recommended error log in this directory:

\\...\HP\DecisionCenter 2.00\ITPA-SM\logs

Correct the errors, and rerun any recommended scripts listed in the error 
message. All logs in this folder should have no error messages.

22 Click Finish. 

Step 4: Point to the ServiceCenter 6.2.2 Server

If you are using ServiceCenter 6.2 or an earlier version, skip this step and 
proceed to Task 6: Create the Database Tables and Views on page 51. 
Complete this step only if you have Service Manager 7.00. 

1 From the Windows Start menu, click Programs > HP OpenView > 
Connect-it 3.80 en > Scenario Builder.

2 Click File > Open and browse to open this file:

\\...\HP\DecisionCenter 2.00\ITPA-SM\cit\rds_sc.scn

3 If the Connect-It Toolbox is not enabled, click Display > Toolbox.

4 From the Connect-It Toolbox, expand Hewlett-Packard > OpenView Service 
Management connectors > OpenView ServiceCenter connectors.

5 Double-click OpenView ServiceCenter to start the Connector Wizard.
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6 Click Next.

7 Make sure that the Server name, Login, and Password are correct to connect 
to the ServiceCenter 6.2.2 server, and that the port number is the one 
assigned to the ServiceCenter 6.2.2 server, not the port number associated 
with Service Manager 7.00.

8 Click Test to start a connection test between Connect-It and the 
ServiceCenter 6.2.2 server. Ensure the connection test is successful.

9 Click Finish.

10 Save the scenario and close Connect-It.

Task 6: Create the Database Tables and Views

Identify a local directory where you can copy the import files. For example, 
DecisionCenter_files. If you have an existing DecisionCenter installation, it is 
important to create database views for DecisionCenter 2.00. Do not skip this 
task.

Step 1: Create the ITPA Tables and Views

1 Insert the DecisionCenter installation media in your hard drive. The 
installer starts automatically, or you can click Autorun.exe to start the 
installer.

2 Select the Data Warehouse tab and click ITPA for SM.

3 Click Create Database Views.

4 From the DecisionCenter installation media, copy

\\ITPA\ITPA-SM\SupportFiles\DatabaseFiles
\itpa_dcviews_oracle.sql 

Or

\\ITPA\ITPA-SM\SupportFiles\DatabaseFiles
\itpa_dcviews_sqlsrvr.sql

to a temporary folder on your local hard drive.
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5 Open the file with Microsoft SQL Server.

6 Click Execute to run the query that builds the tables and views.

Step 2: Create the BIA Tables and Views

You can skip this step if you do not want to install the BIA component. 
Otherwise, follow these steps to create BIA tables and views on the Microsoft 
SQL Server data warehouse server:

1 Click the BIA tab.

2 Click Create Database Tables and Views.

3 From the DecisionCenter installation media, copy 

\\BIA\SupportFiles\DatabaseFiles\rds_bia_mssql.sql

Or

\\BIA\SupportFiles\DatabaseFiles\rds_bia_oracle.sql

to a folder on your hard drive. 

4 Open the file with Microsoft SQL Server.

5 Click Execute to run the query that builds the tables and views.

Task 7: Import ITPA Service Management Data

You can skip this task if you do not plan to import Service Management data. 
The rds_sc.scn scenario collects ServiceCenter or Service Manager data and 
synchronizes it with the data warehouse. It can take several hours to execute 
when there is a large quantity of data. It is important that you do not change 
the connector names defined in data warehouse Connect-It scenarios.

1 From the Windows Start menu, click Programs > HP OpenView > 
Connect-it 3.80 en > Service Console.

2 The Service Console should be pointing to this scenario file: 

\\..\HP\DecisionCenter 2.00\ITPA-SM\cit\rds_sc.scn 

3 Select the rds_sc scenario.
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4 Click Configure.

5 From the List of connectors, select RDS (rdsdb).

6 Click Configure connector.

7 Click Next until you reach the Advanced Configuration interface.

8 Click Execute an initial import. 

9 Click Finish.

10 Click Validate to save the changes and close the window.

11 From the Service Console window, click Start to begin the initial data 
import.

12 Immediately after the initial data synchronization completes, you should 
back up your database. This can be crucial when the synchronization 
takes a long time, and you need to restore the data.

13 Repeat Step 3 through Step 7 again.

14 Clear the Execute an initial import. checkbox to ensure that future update 
synchronization operations run successfully.

15 Click Finish.

16 Click Validate.

Task 7a: Import ITPA Asset Management Data

You can skip this task if you do not plan to import Asset Management data. 
The rds_ac scenario collects AssetCenter data and synchronizes it with the 
data warehouse. It can take several hours to execute when there is a large 
quantity of data. It is important that you do not change the connector names 
defined in data warehouse Connect-It scenarios.

1 On the AssetCenter server, copy this dynamic library file (.dll):

\\..\aamapixx.dll

where xx refers to the AssetCenter version number.

2 Paste it in a location on the data warehouse server that is accessible to the 
installed Connect-It application.
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3 From the Windows Start menu (on the data warehouse server), click 
Programs > HP OpenView > Connect-it 3.80 en > Service Console.

4 The Service Console should be pointing to this scenario file: 

\\..\HP\DecisionCenter 2.00\ITPA-SAM\cit\rds_ac.scn 

5 Select the rds_ac scenario.

6 Click Configure.

7 From the List of connectors, select Asset Management.

8 Click Configure connector.

9 Click Next until you reach the Advanced Configuration interface.

10 Point Dynamic library to use to the location of this file:

\\..\aamapixx.dll

11 Click Finish.

12 From the List of connectors, select rds (rdsdb).

13 Click Configure connector.

14 Click Next until you reach the Advanced Configuration interface.

15 Click Execute an initial import. 

16 Click Finish.

17 Click Validate to save the changes and close the Connector configuration 
window.

18 From the Service Console window, click Start to begin the initial data 
import.

19 Immediately after the initial data synchronization completes, you should 
back up your database. This can be crucial when the synchronization 
takes a long time, and you need to restore the data.

20 Select the rds_ac scenario.

21 Click Configure.

22 Repeat Step 12 through Step 14 again.

23 Clear the Execute an initial import. checkbox to ensure that future update 
synchronization operations run successfully.
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24 Click Finish.

25 Click Validate.

Task 8: Verify the Results

1 Log on to the data warehouse as the rds_dba user.

2 Perform the following queries on the rdsdb database:

— Select * from PROBSUMM_D

— Select * from OPERATOR_D

— Select * from ASSIGNMENT

Each query should return rows of information. If any query does not return 
rows, the rds_sc.scn Connect-It scenario did not run successfully. Check the 
Connect-It log for errors and re-run the query until you can complete this 
verification successfully. If there are database connection issues, repeat the 
tasks in this chapter and verify that the database connections are successful.

Refresh the Data

Connect-It automatically schedules the data synchronization scenario to run 
daily on a 24-hour schedule. The amount of time required to synchronize the 
data depends on the volume of data to be processed and the capacity of your 
server. Make sure that you schedule the synchronization to occur during 
off-peak hours when the server has no other demands.
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4 Install Business Impact Analysis

The chapter describes the software installation and configuration tasks to 
support the Business Impact Analysis (BIA) component of DecisionCenter.

BIA Installation Checklist

Print this checklist to use during the installation process. As you complete 
each task, mark it finished. Complete these tasks on the DecisionCenter data 
warehouse server. For more information, see the distributed server 
configuration diagram on page 18.

If you have an existing DecisionCenter data warehouse, back it up before you 
begin. The installer can detect an existing data warehouse and attempts to 
upgrade it to meet the requirements of DecisionCenter 2.00. After you 
complete the installation, follow the instructions in the DecisionCenter 
Migration Guide to complete the upgrade.

 Task 1: Install the BIA Application on page 58.

 Task 2: Point to the ServiceCenter 6.2.2 Server on page 60.

 Task 3: Import BIA and Optimization Data on page 60.

 Task 4: Verify the Results on page 61.

Complete Task 1 – 4 on the DecisionCenter data warehouse server.
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Task 1: Install the BIA Application

Make sure that you complete all the steps in Chapter 3, Build the Data 
Warehouse before you start this task.

1 Insert the DecisionCenter installation media in your hard drive. The 
installer starts automatically, or you can click Autorun.exe to start the 
installer.

2 Select the Data Warehouse tab and click the BIA tab.

3 Click Install BIA Component Files.

4 From the Welcome screen, click Next.

5 Type your DecisionCenter BIA Authorization Code.

6 Click Next.

7 Accept the end user license agreement.

8 Click Next.

9 DecisionCenter has a default installation directory. Do one of the 
following:

• Accept the default installation directory and click Next.

• Click Change to choose another directory, then click OK, and click Next.

10 Select the version of ServiceCenter or Service Manager that generates the 
data to be used by DecisionCenter.

11 Click Next.

12 Verify that the JAVA_HOME Environment Variable points to the 
supported JDK version. Do one of the following:

• Accept the default installation directory and click Next.

• Click Change to choose another directory.

13 Click Next.

14 Choose the correct RDBMS and click Next. If you select Microsoft SQL 
Server, choose the version and click Next.

15 If you selected Microsoft SQL Server, click Change to navigate to the 
location of the JDBC .jar driver files. For more information about JDBC 
drivers, see JDBC Drivers on page 23.
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16 Click Next.

17 Use the information that you recorded in Table 12 on page 44 to specify 
your RDBMS settings.

18 Click Next.

19 The installer displays the database configuration settings. Click Next or 
Back to correct errors.

20 Specify values for the following parameters: 

— The Host name of the ServiceCenter or Service Manager server and its 
Port number. For example, localhost or server_name.

If you are connecting to Service Manager, specify the port number of 
the ServiceCenter 6.2.2 server.

— The ServiceCenter or Service Manager connection user name is 
bi-connector.

The DecisionCenter unload file adds bi-connector to the operator table 
to enable Connect-It to synchronize data between ServiceCenter or 
Service Manager and the data warehouse.

— Type the existing connection Password if you created a password. 
(The out-of-box database connection has no password.)

21 Click Next.

22 The installer displays the ServiceCenter or Service Manager configuration 
information. Click Next, or Back to correct errors. 

23 Click Install to begin the installation process. Click Back to correct errors. 
The installation process can take several minutes. The installer displays 
its progress and opens a command window to run various scripts. 

If errors occur, review the recommended error logs in this directory:

\\..\HP\DecisionCenter 2.00\BIA\logs

All logs in this folder should have no error messages. If they occur, correct 
the errors, and rerun any recommended command files in the 
\\..\BIA\CIT directory that are listed in the error message. 

24 Click Finish.
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Task 2: Point to the ServiceCenter 6.2.2 Server

If you are using ServiceCenter 6.2 or an earlier version, skip this step and 
proceed to Task 3: Import BIA and Optimization Data on page 60. Complete 
this step only if you have Service Manager 7.00 data. 

1 From the Windows Start menu, click Programs > HP OpenView > 
Connect-it 3.80 en > Scenario Builder.

2 Click File > Open and browse to open this file:

\\...\HP\DecisionCenter 2.00\BIA\cit\dco_sc.scn

3 If the Connect-It Toolbox is not enabled, click Display > Toolbox.

4 From the Connect-It Toolbox, expand Hewlett-Packard > OpenView Service 
Management connectors >  OpenView ServiceCenter connectors.

5 Double-click OpenView ServiceCenter to start the Connector Wizard.

6 Click Next.

7 Make sure that the Server name, Login, and Password are correct to connect 
to the ServiceCenter 6.2.2 server, and that the port number is the one 
assigned to the ServiceCenter 6.2.2 server, not the port number associated 
with Service Manager 7.00.

8 Click Test to start a connection test between Connect-It and the 
ServiceCenter 6.2.2 server. Ensure the connection test is successful.

9 Click Finish.

10 Save the scenario and close Connect-It.

Task 3: Import BIA and Optimization Data

The dco_sc.scn scenario collects the data that you need to populate BIA and 
Optimization analytics and use in simulations. Follow these steps to run the 
scenario:

1 From the Windows Start menu, click Programs > HP OpenView > 
Connect-it 3.80 en > Service Console.
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2 Point the Service Console to this scenario file: 

\\..\HP\DecisionCenter 2.00\BIA\cit\dco_sc.scn 

3 Click Start.

Immediately after the initial data synchronization completes, you should back 
up your database.

Task 4: Verify the Results

1 Log in to the data warehouse as the rds_dba user.

2 Run this query:

Select * from PROBLEM

This query should return rows of information. If the query does not return any 
data, the dco_sc.scn Connect-It scenario did not run successfully. Check the 
Connect-It log for errors and re-run the query until you can complete this 
verification successfully.
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5 Install BusinessObjects Enterprise XI

BusinessObjects Enterprise XI is a third-party product that integrates with 
DecisionCenter to produce Analytics. BusinessObjects Enterprise XI requires 
a separate BusinessObjects Enterprise XI license and it has its own 
installation instructions that accompany the DecisionCenter installation 
media.

When you install BusinessObjects Enterprise, you are adding a business 
intelligence platform and toolkit that supports reporting, ad-hoc queries and 
analysis of your IT performance data.

BusinessObjects XI Installation Checklist

Print this checklist to use during the installation process. As you complete 
each task, mark it finished. Complete these tasks on the Business Objects 
server. For more information, see the distributed server configuration diagram 
on page 18.

 Task 1: Obtain the BusinessObjects Critical Hot Fix Files on page 64.

 Task 2: Install BusinessObjects Enterprise XI on page 65.

 Task 3: Install the Required Critical Hot Fixes on page 66.

— Step 1: Install the Primary CHF on page 66.

— Step 2: Install the Supplemental CHF on page 68.

— Step 3: Restart the Server on page 68.

 Task 4: Install PMDT on page 68.

 Task 5: Customize BusinessObjects Enterprise XI Files on page 69.

— Step 1: Add the Drill Icon on page 69.

— Step 2: Change the ODBC Settings for Outer Joins on page 69.

 Task 6: Verify the BusinessObjects XI Installation on page 70.
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 Task 7: Configure BusinessObjects Enterprise XI on page 70.

— Step 1: Add the License Key on page 71.

— Step 2: Verify System User Information on page 71.

— Step 3: Configure the Performance Management Database 
Connections on page 72.

— Step 4: Configure the Repository on page 74.

— Step 5: Update Fonts on the BusinessObjects Enterprise XI Server on 
page 75.

 Task 8: Verify the Results on page 75.

Task 1: Obtain the BusinessObjects Critical Hot Fix Files

BusinessObjects Enterprise XI produces patch releases, called Critical Hot 
Fixes (CHFs), at regular intervals. DecisionCenter requires you install only 
those Critical Hot Fixes that are recommended by HP to ensure that 
BusinessObjects Enterprise XI integrates seamlessly with DecisionCenter. 
These recommended CHFs are required for full functionality.

Before you begin the ITPA installation, you must download the required 
BusinessObjects XI Release 2 CHF and have it available on the 
BusinessObjects server when you are directed to install this CHF.

1 Start a Windows Internet Explorer browser session and point to this URL:

http://support.openview.hp.com/patches

2 If you do not already have an HP Passport, click New user registration.

3 Follow the instructions to register with HP.

4 Select DecisionCenter from the drop-down product list.

5 Click the Search icon.

6 Click Product patches in the HP-Peregrine links section.

7 Click DecisionCenter and look for the BusinessObjects XI Release 2 July 5th 
Critical Hot Fix.

8 Download boXIr2win_chf.zip and unzip it to a temporary directory. 
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Task 2: Install BusinessObjects Enterprise XI

HP recommends that you follow the “Full Java Installation” scenario 
described in the BusinessObjects Enterprise XI Installation Guide. This 
scenario guides you through these critical steps:

• Creating a Tomcat application server. If you already have a Tomcat 
instance, or you want Tomcat to reside on a different server, see 
Chapter 8, Configure the Application Server before you proceed.

• Choosing which components to install.

• Deploying InfoView.

Installation Tips

Make sure that you log in to the server as an administrator before you begin 
the BusinessObjects Enterprise XI R2 installation. You must make choices 
during the installation that will affect your DecisionCenter configuration 
later. Refer to Table 14 on page 45 for configuration information. The 
following table lists the critical decisions you must make during the 
installation and the recommended choices.

Table 15 BusinessObjects Enterprise XI Installation Tips

On This Dialog Use These Values

Select Client or Server Installation Perform Server Installation

User Information Install Performance Management
Use the same HP-supplied Product 
Keycode for Performance Management

Install Type Use an existing database server 

Windows Logon Information Leave it blank
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Task 3: Install the Required Critical Hot Fixes

Follow these steps to install the required HP-supplied CHFs to a full 
BusinessObjects Enterprise XI R2 SP1 installation. For more information 
about downloading the first CHF, see Task 1: Obtain the BusinessObjects 
Critical Hot Fix Files on page 64. For more information about installing the 
first CHF, see the Business Objects readme.txt file in the zip file.

Step 1: Install the Primary CHF

1 From the Windows Start menu, click Control Panel > Administrative Tools > 
Services and stop these services:

— Microsoft SQL Server or Oracle RDBMS services

— Antivirus services

2 Delete all the cached files in this directory:

\\..\BusinessObjects\Tomcat\work

3 Create a backup directory. For example:

\\BOXML_backup

CMS Database Information Clear the Auditing Database check box 
after you specify the CMS Database 
information

SQL Server Login (for your CMS 
database)

Use the cmsdb name that you defined 
when you created the database

Choose Web Component Adapter 
Type

Java application server

Table 15 BusinessObjects Enterprise XI Installation Tips

On This Dialog Use These Values
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4 Move all files except webcompadapterwar.xml from this directory:

\\..\BusinessObjects\Tomcat\conf\Catalina\localhost

 to the backup directory that you created in Step 3 on page 66.

5 Move this file:

\\..\BusinessObjects Enterprise 11.5\Web Services\en
\dswsbobje.war

 to the backup directory that you created in Step 3.

6 Navigate to the directory where you stored the downloaded CHF zip file.

7 Unzip the archive to a local temporary directory.

8 Run setup.exe.

9 When you are prompted to restart the services, click No.

10 Delete the following folders in this directory:

\\Program Files\BusinessObjects\Tomcat\webapps: 

— analysishelp 

— businessobjects 

— dswsbobje 

— jsfadmin 

— styles

11 From the Windows Start menu, click Control Panel > Administrative Tools > 
Services and start the Tomcat service. Ensure that it creates this 
directory:

\\..\BusinessObjects\Tomcat\webapps\businessobjects\WEB-INF

12 From the Windows Start menu, click Control Panel > Administrative Tools > 
Services and stop the Tomcat service.

13 Restore the .xml files that you backed up in Step 4 on page 67 to:

\\..\BusinessObjects\Tomcat\conf\Catalina\localhost

14 Restore the dswsbobje.war file that you backed up in 
Step 5 on page 67 to:

\\..\BusinessObjects Enterprise 11.5\Web Services\en
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Step 2: Install the Supplemental CHF

1 Rename this file:

\\..\Business Objects\Common\3.5\java\lib\cexsd.jar

To

\\..\Business Objects\Common\3.5\java\lib\cexsd.bak

2 Insert the BusinessObjects XI R2 Supplement media into your CD-ROM 
drive.

3 Copy bexir2_600804.zip to a local temporary directory, unzip the files, 
and copy cexsd.jar to:

\\..\Business Objects\Common\3.5\java\lib

Step 3: Restart the Server

1 Restart the server. 

2 Ensure that these Windows services restarted:

— RDBMS services

— Antivirus services

— Tomcat service

— Other related BusinessObjects Enterprise XI services

Task 4: Install PMDT

When you deploy the analytics for DecisionCenter in Chapter 7, Install the 
DecisionCenter Analytics, you must use the Performance Management 
Deployment Tool (PMDT). Follow these steps to install PMDT.

1 Insert the BusinessObjects XI R2 Supplement media into your CD-ROM 
drive.
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2 Copy pmdt.zip to a local temporary directory and unzip the files into a 
permanent directory. For example:

\\Program Files\Business Objects\PMDT

3 Verify that the server has a supported JDK (jdk1.4.2_11 or a later version 
of 1.4.2).

4 Verify that the JAVA_HOME Environment Variable points to the 
supported JDK version. If the CLASSPATH or the PATH environment 
variables reference an earlier version, you must remove that reference to 
run the batch files correctly. 

5 If necessary, you can change the default heap size to the recommended 
values by modifying the run_DeploymentTool.bat file. For more 
information about recommended heap size, see Table 2 on page 17.

Task 5: Customize BusinessObjects Enterprise XI Files

BusinessObjects Enterprise XI R2 requires a moderate amount of 
customization to integrate successfully with DecisionCenter.

Step 1: Add the Drill Icon

1 Copy this file from the DecisionCenter installation media:

\\ITPA\ITPA-SM\BOCustomization\images\drill.gif file

2 To this BusinessObjects directory:

\\..\Business Objects\BusinessObjects Enterprise 11.5\Images

Step 2: Change the ODBC Settings for Outer Joins

1 Back up this file before you complete the next step:

\\..\Business Objects\BusinessObjects Enterprise 11.5
\win32_x86\dataAccess\connectionServer\odbc\sqlsrv.prm

2 Open sqlsrv.prm with a text editor.
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3 Locate this parameter:

<Parameter Name="OUTERJOINS_GENERATION">

4 Replace USUAL with FULL_ODBC.

5 Add a new parameter:

<Parameter Name="OUTERJOINS_COMPLEX">Y</Parameter>

6 Save and close the file.

Task 6: Verify the BusinessObjects XI Installation

Verify that you can log in to Central Configuration Management and 
Performance Manager.

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > Central 
Configuration Manager.

2 Log in as Administrator with no password.

3 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > 
BusinessObjects Enterprise Java InfoView.

4 Log in as Administrator with no password.

5 Close each application.

Task 7: Configure BusinessObjects Enterprise XI

Complete these configuration steps to ensure that BusinessObjects Enterprise 
XI R2 integrates correctly with DecisionCenter.
70 Chapter 5



Step 1: Add the License Key

The normal BusinessObjects installation installs two license keys. You must 
manually add a third license key for Dashboard Manager.

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > 
BusinessObjects Enterprise Java Administration Launchpad.

2 Click Central Management Console.

3 Log in as Administrator with no password.

4 In the Manage section, click License Keys.

5 Type the HP-supplied Dashboard Manager license key in the Add Key text 
box and click Add.

Step 2: Verify System User Information

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > 
BusinessObjects Enterprise Java InfoView.

2 Log in as Administrator with no password.

3 Click Go to Performance Management.

4 Click Setup on the Toolbar.

5 Click the System Setup tab.

6 Click System User.

7 Verify that the User Name in the System User and Initialization User sections 
is Administrator. If necessary, type Administrator into each User Name text 
box and click Apply in each section. 

8 When InfoView returns a verification message, click OK.

9 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > 
Central Configuration Manager.

10 Select the Central Management Server service.

11 Click Restart.
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Step 3: Configure the Performance Management Database 
Connections

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > Designer.

2 Log in as Administrator with no password.

3 Click Tools > Connections. BusinessObjects Enterprise XI displays a list of 
connections.

4 Click Add.

5 The New Connection Wizard appears. Click Next.

6 Do one of the following:

For MS SQL Server, expand the database middleware node for Microsoft 
and click MS SQL Server 2000 > ODBC Drivers.

For MS SQL Server, expand the database middleware node for Microsoft 
and click MS SQL Server 2005 > ODBC Drivers.

For Oracle, expand the database middleware node for Oracle and click 
Oracle 10 > Oracle Client. 

7 Click Next.

8 Select or type the following values:

9 Click Next.

Table 16 Connection Wizard Settings

Parameter MS SQL Server 200x Oracle 10

Type Secured Secured

Name pmdb pmdb

User name pm_dba pm_dba 

Password passw0rd passw0rd

Data source name pmdb pmts

Make sure the credentials boxes are not checked.
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10 Click Test Connection to ensure the server is responding. If the connection 
fails, click Back to verify that you specified the correct values. Make sure 
the associated service is running, and that your ODBC connections are 
defined correctly. To review the steps to define ODBC connections, see 
Task 4: Configure the Database Clients on page 40.

11 If the connection works, click Next.

12 Accept the advanced parameter default values, or change them to support 
your environment. Click Next.

13 Add any optional custom parameters to suit your environment. Click 
Finish. 

14 To repeat the process for the rdsdb, click Add.

15 The New Connection Wizard appears. Click Next.

16 Do one of the following:

For MS SQL Server, expand the database middleware node for Microsoft 
and click MS SQL Server 2000 > ODBC Drivers.

For MS SQL Server, expand the database middleware node for Microsoft 
and click MS SQL Server 2005 > ODBC Drivers.

For Oracle, expand the database middleware node for Oracle and click 
Oracle 10 > Oracle Client. 

17 Click Next.

18 Select or type the following values.

Table 17 Connection Wizard Settings

Parameter MS SQL Server 200x Oracle 10

Type Secured Secured

Name rdsdb rdsdb

User name rds_dba rds_dba 

Password passw0rd passw0rd

Data source name rdsdb rdssts

Make sure the credentials boxes are not checked.
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19 Click Next.

20 Click Test Connection to ensure the server is responding. If the connection 
fails, click Back to verify that you specified the correct values. If the 
connection works, click Next.

21 Accept the advanced parameter default values, or change them to suit 
your environment. Click Next.

22 Add any optional custom parameters to suit your environment. Click 
Finish.

Step 4: Configure the Repository

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > 
BusinessObjects Enterprise Java InfoView.

2 Log in as Administrator with no password.

3 Click Go to Performance Management.

4 Click Setup on the Toolbar.

5 Click the System Setup tab.

6 On the Repository tab, click Change in the Repository Information section.

7 If necessary, select pmdb from the drop-down list in the Choose repository 
connection dialog box. Click OK.

8 In the Repository Information section, click Check.

9 When the verification message appears, click OK.

10 Click Set Up Repository.

11 Accept the defaults and click Next.

12 Click Execute, then click OK.

13 When the Execution Successful message appears, click OK.

14 Close Performance Management.

For more information about configuring connections, click 
Help > Designer Help in the BusinessObjects Enterprise XI 
Designer application.
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Step 5: Update Fonts on the BusinessObjects Enterprise XI Server

Decision Center uses the Verdana and Lucida Console fonts. You must change 
the configuration file to add these fonts to the report editor.

1 Back up the fontalias.xml file. The default path is:

\\..\Business Objects\BusinessObjects Enterprise 11.5
\win32_x86\fonts

2 Open fontalias.xml with a text editor.

3 Locate <FONT NAME="default">.

4 Open this file on the DecisionCenter installation media with a text editor:

\\ITPA\ITPA-SM\BOCustomization\xml\fonts.xml

5 Copy the contents of fonts.xml and paste them above this line in 
fontalias.xml:

<FONT NAME="default">

6 Save and close fontalias.xml.

Task 8: Verify the Results

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > 
BusinessObjects Enterprise Java Administration Launchpad.

2 Click Central Management Console.

3 Log in as Administrator with no password.

4 Click Servers in the Organize section.

5 If necessary, click the group box by Server Name to select all the servers.

6 Click Enable.

7 Click OK. BusinessObjects displays a progress bar while it enables the 
servers. When there is a green arrow on each server icon, the servers are 
running.

8 Click Logoff and close the application.
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6 Security

DecisionCenter security models use predefined access levels and security 
roles. Administrators must grant access rights to the groups and security roles 
using the BusinessObjects Enterprise XI Central Management Console 
(CMC).

DecisionCenter supports Lightweight Directory Access Protocol (LDAP) or 
Windows Active Directory authentication. Administrators can configure the 
Common Web Client (CWC) to enable LDAP. The BI Authentication 
Processing filter validates users and groups.

After you set up an LDAP or Active Directory server, you must:

• Create DecisionCenter users and groups on the LDAP or Active Directory 
server. 

• Configure LDAP or Active Directory authentication on the 
BusinessObjects Enterprise XI server. 

For more information about configuring LDAP or Active Directory 
authentication, see your BusinessObjects Enterprise XI documentation.
Security 77



Security Checklist

Print this checklist to use during the installation process. As you complete 
each task, mark it finished. Complete these tasks on the LDAP or Active 
Directory server.

 Task 1: Create DecisionCenter Users and Groups on page 79.

If You Choose LDAP Authentication

 Task 2: Configure LDAP on page 80.

— Step 1: Configure the LDAP Host in BusinessObjects Enterprise XI on 
page 80.

— Step 2: Configure the LDAP Mapping Options on page 81.

— Step 3: Map LDAP Groups on page 81.

If You Choose Active Directory Authentication

 Task 2: Configure Active Directory for Business Objects on page 82.

— Step 1: Enable Active Directory on page 82.

— Step 2: Configure Administration Credentials on page 82.

— Step 3: Add Member Groups on page 83.

— Step 4: Choose Kerberos Authentication Options on page 83.

— Step 5. Choose Active Directory Authentication Options on page 84.

 Task 3: Configure the JAVA Authentication Module on page 85.

— Step 1: Create a krb5.ini File on page 85.

— Step 2: Create a bscLogin.conf File on page 85.

 Task 4: Configure Tomcat on page 110. (You must finish the installation 
and deployment tasks before you can finalize the authentication.)
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Task 1: Create DecisionCenter Users and Groups

You must configure the LDAP or Active Directory host before you make 
configuration changes to BusinessObjects Enterprise XI. This includes adding 
DecisionCenter out-of-box groups and your own groups to the LDAP or Active 
Directory server. Changes to group names require changes to both the 
web.xml file and the LDAP or Active Directory) server. 

DecisionCenter recognizes the following out-of-box groups.

If you create these nine groups and assign the user name dcuser to each one 
on the LDAP or Active Directory server, you will be able to log in to the 
DecisionCenter application. Make sure that you also assign the appropriate 
access rights within BusinessObjects for these users; otherwise, users will not 
be able to refresh reports. For more information, see the BusinessObjects 
Enterprise XI documentation.

LDAP Security

Lightweight Directory Access Protocol (LDAP) is the default authentication 
tool for DecisionCenter. Complete the following tasks to configure LDAP. 
Before you define and enable LDAP authentication, create an LDAP server 
and ensure that your LDAP directory is valid. For more information, see your 
LDAP documentation.

Table 18 DecisionCenter Out-Of-Box Groups

Analytic Type
General 
Manager Role

Advanced 
Analysis Role

Administration 
Role

Performance 
Analytics

ITPA_GM ITPA_AA ITPA_Admin

Business Impact 
Analytics

BIA_GM BIA_AA BIA_Admin

Performance 
Optimization

ITPO_GM ITPO_AA ITPO_Admin
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Task 2: Configure LDAP

Complete the following steps to configure the host, Secure Socket Layer 
authentication, LDAP mapping options, and LDAP groups.

Step 1: Configure the LDAP Host in BusinessObjects Enterprise XI

1 Click Start > Programs > BusinessObjects XI Release 2 > BusinessObjects 
Enterprise > BusinessObjects Enterprise Java Administration Launchpad.

2 Select the Central Management Console.

3 Log in with your user name and password.

4 Click Authentication, then click the LDAP tab.

5 Click Start LDAP Configuration Wizard.

6 In the Add LDAP Host (hostname: port) field, type your host and port 
information.

7 Click Add.

8 Click Next.

9 In the LDAP Server Type drop-down list, select your server, and click Next.

10 In the Base LDAP Distinguished Name field, type the distinguished name 
and click Next.

11 Type the LDAP host credentials:

— In LDAP Server Administration Credentials, type the distinguished name 
and password for a user account that has rights to administer your 
LDAP server.

— In LDAP Referral Credentials, type the same distinguished name and 
password you entered for LDAP Server Administration Credentials.

12 In the Maximum Referral Hops field, type the number of referral hops. If you 
set this field to zero, no referrals are followed.

13 Click Next.

14 From the Type of SSL authentication drop-down list, select Basic (no SSL) 
and click Next.

15 From the Authentication drop-down list, select Basic (no SSO) and click 
Next.
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Step 2: Configure the LDAP Mapping Options

1 Select the following LDAP mapping options:

— Create a new account for every added LDAP alias 

— No new aliases will be added and new users will not be created 

— New users are created as named users 

2 Click Next.

3 Click Finish.

Step 3: Map LDAP Groups

1 Click Start > Programs > BusinessObjects XI Release 2 > BusinessObjects 
Enterprise > BusinessObjects Enterprise Java Administration Launchpad.

2 Select the Central Management Console.

3 Log in with your user name and password.

4 Click Authentication, then click the LDAP tab.

5 In Mapped LDAP Member Groups, add the nine DecisionCenter out-of-box 
groups listed in Table 18 on page 79 in the Add LDAP group (by cn or dn) 
field.

6 Click Add.

7 Repeat Step 5 and Step 6 to add another group. 

8 To remove a group, select the group and click Delete. 

9 Click Update.

For more information, see the BusinessObjects XI R2 documentation.

Active Directory

Windows Active Directory is an optional method of authentication. Before you 
set up and enable Active Directory authentication, make sure that you have 
the correct domain and group information and that you have a user account on 
the Business Objects server that enables you to authenticate administrative 
users and groups.
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Task 2: Configure Active Directory for Business Objects

Complete the following steps to configure the host, Secure Socket Layer 
authentication, LDAP mapping options, and LDAP groups.

Step 1: Enable Active Directory

1 On the Business Objects server, ensure that the Central Management 
Server is running.

2 Click Start > Programs > BusinessObjects XI Release 2 > 
BusinessObjects Enterprise > BusinessObjects Enterprise Java Administration 
Launchpad.

3 Click Central Management Console.

4 Type your User Name, Password, and click Log On.

5 In the Manage section, click Authentication.

6 Click the Windows AD tab.

7 If necessary, select Windows Active Directory Authentication is enabled.

Step 2: Configure Administration Credentials

Administration credentials enable a Business Objects user to use Active 
Directory authentication, map groups, check rights, and perform other tasks.

1 Click the value for the AD Administration Name to change it.

2 Type the Name and Password of the domain user account configured on 
your Active Directory server. Business Objects Enterprise will use this 
name and password to authenticate Active Directory users and groups. 
Use one of these formats:

— NT name (DomainName\UserName). For example:

server.domain.com\dc_administrator

— User Principal Name (UPN) (user@DNS_domain_name). For example:

dc_administrator@DNS_domain.com
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3 Type the Default AD Domain value. You must specify a default domain to 
enable Active Directory authentication and to map groups. For example:

server.domain.com

4 Click Update.

Step 3: Add Member Groups

1 Type the group name in the Add AD Group (Domain\Group) field in this 
format:

DomainName\GroupName

For example: 

server.domain\ITPA_AA

2 Click Add.

3 Repeat the following steps for each DecisionCenter out-of-box group name 
described in Table 18 on page 79.

4 When you finish adding all groups, click Update.

Step 4: Choose Kerberos Authentication Options

1 Select Use Kerberos authentication

2 Select Cache security context (required for SSO to database).

3 Type the Service principal name. This should be the administrator user that 
you created in Step 2: Configure Administration Credentials on page 82. 
For example:

dc_administrator@DNS_domain.com

If you specify the Default AD Domain name, users do not have to 
specify the Active Directory domain name when they log in to 
Business Objects Enterprise with Active Directory authentication.
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Step 5. Choose Active Directory Authentication Options

1 Choose these options.

2 Click Update. A message appears stating that it will take several seconds 
to update the member groups.

3  Click OK.

Table 19 Authentication Options

Option Description

Assign each added AD alias to 
an account with the same name

Use this option when you know users 
have an existing enterprise account with 
the same name. Active Directory aliases 
are assigned to existing users if auto 
alias creation is active. Users who do not 
have an existing enterprise account, or 
who do not have the same name in their 
enterprise and Active Directory account, 
are added as new Active Directory users.

New aliases will be added and 
new users will be created

Choose this option to automatically 
create a new alias for every Active 
Directory user mapped to Business 
Objects Enterprise. 

New users are created as 
named users

or

New users are created as 
concurrent users

Choose this option for Named User 
licenses.

or

Choose this option for Processor 
licenses. 

New Active Directory accounts are added for users without 
Business Objects Enterprise accounts or for all users if you selected 
the Create a new account for every added AD alias option.
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Task 3: Configure the JAVA Authentication Module

BusinessObjects Enterprise XI Release 2 uses a Java authentication module 
called Krb5AuthLoginModule. This log-in module requires some additional 
configuration information. There are two configuration files, krb5.ini and 
bscLogin.conf.

By default, the Java SDK automatically looks for these configuration files in 
C:\winnt folder even if this folder does not exist. You can create the files in the 
C:\winnt folder, or in any other folder.

Step 1: Create a krb5.ini File

This file gives Java information about your domain and location of the 
Kerberos Key Distribution Center. This file can be simple or complex 
depending on the size and implementation of your Active Directory domain. 
For example: 

[libdefaults] 
default_realm = DOMAIN.COM 
dns_lookup_kdc = true 
dns_lookup_realm = true 
[realms] 
DOMAIN.COM = { 
kdc = ADSERVER.DOMAIN.COM 
default_domain = DOMAIN.COM 
}

Step 2: Create a bscLogin.conf File

The bscLogin.conf file is the JAAS log-in configuration file. It contains an 
entry that specifies the authentication technology to be used. When you use 
the SUN Java SDK, the entry looks like:

com.businessobjects.security.jgss.initiate { 
com.sun.security.auth.module.Krb5LoginModule required; 
}; 

4
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7 Install the DecisionCenter Analytics

DecisionCenter out-of-box analytics enable you to evaluate your service 
strategies, service operations, and service transitions performance. Before you 
begin, ensure that you complete the tasks in the preceding chapters.

Analytics Installation Checklist

Print this checklist to use during the installation process. As you complete 
each task, mark it finished. Complete these tasks on the Business Objects 
server. For more information, see the distributed server configuration diagram 
on page 18.

 Task 1: Prepare for Installation on page 89.

— Define the Calendars on page 89.

 Task 2: Gather the Database Connection Information on page 90.

 Task 3: Install ITPA on page 90.

— Step 1: Install the ITPA Analytics on page 90.

— Step 2: Update the ITPA Database Connections and Universes on 
page 90.

— Step 3: Add and Update the ITPA Metric Universes on page 92.

— Step 4: Run the PMDT on page 93.

— Step 5: Set the Database ID at 6000 on page 94.

 Task 4: Install BIA on page 95.

— Step 1: Install the BIA Analytics on page 95.

— Step 2: Update the BIA Database Connection and Universes on 
page 96.

— Step 3: Add and Update the Business Impact Metric Universes on 
page 96.

— Step 4: Run the PMDT on page 97.
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 Task 5: Install Optimization on page 98.

— Step 1: Install the Optimization Analytics on page 98.

— Step 2: Update the Optimization Database Connection and Universe 
on page 99.

 Task 6: Verify the Results on page 99.

Before You Begin

If you have existing reports or universes from an earlier release of 
DecisionCenter that you modified, Business Objects does not allow you to 
import them again to replace these existing versions. For more information, 
see the DecisionCenter Migration Guide.
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Task 1: Prepare for Installation

This section describes the preparation and installation of IT Performance 
Analysis (ITPA) universes and analytics. 

Define the Calendars

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > 
BusinessObjects Enterprise Java InfoView.

2 Log in as Administrator with no password.

3 Click Go to Performance Management > Setup > Time Config > Calendar. 

4 Click Add to create new calendars called Monthly Calendar, Scenario 
Daily Calendar, and Quarterly Calendar.

5 Log off InfoView.

Table 20 New Calendars

Calendar Name Interval
Duration Display

Show Format
Calendar 
Span

Monthly Calendar Monthly First Day of Period Sep-06 User-defined 

Scenario Daily 
Calendar

Daily First Day of Period 9/21/
04

User-defined 

Quarterly Calendar Quarterly First Day of Period Q3-04 User-defined

The calendar start date and end date in the Calendar Span dialog 
box must reflect the time periods for which you have data.
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Task 2: Gather the Database Connection Information

During the installation, you must provide information about the data 
warehouse that you built in Chapter 3, Build the Data Warehouse. Use the 
information collected in Table 13 on page 45 to complete the tasks in this 
chapter.

Task 3: Install ITPA

Installing ITPA content creates baseline analytics that you can populate with 
historical data. Before you begin, ensure that you have a valid authorization 
code. If necessary, contact HP Software Support (www.hp.com/go/
hpsoftwaresupport).

Step 1: Install the ITPA Analytics

1 Insert the DecisionCenter installation media in your hard drive. The 
installer starts automatically, or you can click Autorun.exe to start the 
installer.

2 Click the Analytic Content tab.

3 Click ITPA Content.

4 Click Import Business Objects Universes and Analytics.

5 Follow the installation prompts and type the authorization code when 
requested.

6 Use Table 14 on page 45 to provide required CMS server information.

Step 2: Update the ITPA Database Connections and Universes

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > Designer.

2 Log in as Administrator with no password.
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3 If necessary, repeat the steps in Task 4: Configure the Database Clients on 
page 40 to create a valid connection to your data warehouse.

4 Click File > Import. 

5 Click the Universes folder from the Folder drop-down list. 

6 Click Browse and select the universes to import.

For AssetCenter, select:

— ITPA Asset Management

For Change Management, select:

— ITPM Change Analysis

— ITPM Change Metrics

For Help Desk, select:

— ITPM Helpdesk Analysis

— ITPM Helpdesk Metrics

For Incident, select:

— ITPM Incident Analysis

— ITPM Incident Metrics

For Request Management, select:

— ITPM Request Analysis

— ITPM Request Metrics

For Service Level Management, select:

— Alignment Analysis

— Alignment Metrics

For ServiceCenter or Service Manager

— ITPA Service Management

7 Click OK.

8 For each universe, do the following:

a Click File > Parameters. 
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b On the Definition tab, select your database connection from the 
drop-down Connection list. For example, select rdsdb.

c Click OK.

9 Click File > Export. 

10 Click OK.

Step 3: Add and Update the ITPA Metric Universes

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > 
BusinessObjects Enterprise Java InfoView.

2 Log in as Administrator with no password.

3 Click Go to Performance Management.

4 Click Setup on the Toolbar.

5 Click the System Setup tab.

6 Click Universes.

7 Click Add Universe.

8 From the drop-down Measure Universe list, select each metric universe and 
click OK.

• Alignment Metrics

• ITPM Change Metrics

• ITPM Helpdesk Metrics

• ITPM Incident Metrics

• ITPM Request Metrics

Each metric universe should appear in the Universe Definition window.

9 For each new metric universe, click the universe name and select the 
Update Metrics and Control Charts Definitions check box.
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10 Click Update. You should see a list of Available Objects in the lower left 
corner.

Step 4: Run the PMDT

This step extracts the metrics file to the target machine.

1 From the Windows Start menu, click Run, and type CMD to open a 
command window.

2 Navigate to the directory where you stored the PMDT files Task 4: Install 
PMDT on page 68.

3 Run this application:

\\..\PMDT\run_DeploymentTool_PSO.bat 

4 Double-click this batch file to run it.

5 When the Performance Management Deployment Tool appears, click Next.

6 Click Source File.

7 Click Browse.

8 Navigate to the ITPA metrics file:

\\..\HP\DecisionCenter 2.00\Analytical Content\ITPA
\itpa_sm_metrics.xml

9 Click Next

10 For each analytic package that you purchased, select the appropriate 
metrics. Do not select metrics for uninstalled packages.

If you do not see a connection name listed next to your universe:

a From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > 
Designer.

b Log in as Administrator with no password.

c Verify that the universe has the correct connection 
parameters.

d Export the universe.
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For Change Management, select:

Check UNIVERSE: Change Metrics

For Help Desk, select:

Check UNIVERSE: ITPM Helpdesk Metrics

For Incident, select:

Check UNIVERSE: ITPM Incident Metrics

For Request Management, select:

Check UNIVERSE: Request Metrics

For Service Level Management, select:

Check UNIVERSE: Alignment Metrics

11 Click Next.

12 On the Export screen, click Target Repository and for CMS, specify the 
hostname where the Target CMS repository resides, the username, and 
password.

13 Click Export. The Check Screen returns success messages for the assets 
that added to the target repository.

14 Click Close.

15 Return to the command window. Follow the instructions to complete the 
session and close the window.

Step 5: Set the Database ID at 6000

This is an important step, but you can do it only once. Omit this task in the 
future if you run PMDT again to extract the metrics. If you have 
DecisionCenter 1.0 installed, do not repeat this task.

It is important to reserve the 5000 series IDs tagged for each metric. This step 
sets the cursor ID in your database at 6000.

1 From the Windows Start menu, click Run, and type CMD to open a 
command window.

2 Navigate to the directory where you stored the PMDT files Task 4: Install 
PMDT on page 68.
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3 Run this application:

\\..\PMDT\run_DeploymentTool_PSO.bat 

4 When the Performance Management Deployment Tool appears, click Next.

5 Type your host_name:6400 in the CMS text box.

6 Click ID Reservation.

7 Select Increment Manually. 

8 Change the value for each of these cursors to begin at 6000:

— New Metric Cursor

— New Probe Dimension Cursor

— New Goal Cursor

— New Goal Type Cursor

— New Metric Tree Cursor

9 Click Apply.

10 Close PMDT.

Task 4: Install BIA

The BIA installation provides the files to create Connect-It services for BIA 
scenarios, and configure the scenario connections. It also installs the Data 
Mining tool and the History Builder. Before you begin, ensure that you have a 
valid authorization code. If necessary, contact HP Software Support 
(www.hp.com/go/hpsoftwaresupport). 

Step 1: Install the BIA Analytics

1 Insert the DecisionCenter installation media in your hard drive. The 
installer starts automatically, or you can click Autorun.exe to start the 
installer.

2 Click the Analytic Content tab.

3 Click the BIA Content tab.
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4 Click Import Business Objects Universes and Analytics.

5 Follow the installation prompts and type the authorization code when 
requested.

6 Use Table 14 on page 45 to provide required CMS server information.

Step 2: Update the BIA Database Connection and Universes

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > Designer.

2 Log in as Administrator with no password.

3 Create a new connection, as necessary, to your data warehouse.

4 Click File > Import. 

5 Click the Universes folder from the Folder drop-down list. 

6 Click Browse and select the universes to import. For Business Impact, 
select 

— Business Impact Analysis

— Business Impact Metrics

7 Click OK.

8 When a success message appears, click OK. If a connection error message 
appears, click OK.

9 Click File > Parameters. 

10 On the Definition tab, select your database connection from the drop-down 
Connection list. For example, select rdsdb.

11 Click OK.

12 Click File > Export.

13 Click OK.

Step 3: Add and Update the Business Impact Metric Universes

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > 
BusinessObjects Enterprise Java InfoView.
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2 Log in as Administrator with no password.

3 Click Go to Performance Management.

4 Click Setup on the Toolbar.

5 Click the System Setup tab.

6 Click Universes.

7 Click Add Universe.

8 From the drop-down Measure Universe list, select the Business Impact 
Metrics universe and click OK. The Business Impact Metrics universe 
should appear in the Universe Definition window.

9 Click Business Impact Metrics and select the Update Metrics and Control 
Charts Definitions check box.

10 Click Update. You should see a list of Available Objects in the lower left 
corner.

Step 4: Run the PMDT

This step extracts the XML source file of metrics to the target machine.

1 From the Windows Start menu, click Run, and type CMD to open a 
command window.

2 Navigate to the directory where you stored the PMDT files Task 4: Install 
PMDT on page 68.

3 Run this application:

\\..\PMDT\run_DeploymentTool_PSO.bat 

If you do not see a connection name listed next to your universe:

a From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > 
Designer.

b Log in as Administrator with no password.

c Verify that the universe has the correct connection 
parameters.

d Export the universe.
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4 When PMDT appears, click Next.

5 Click Source File.

6 Click Browse.

7 Navigate to the BIA metrics file:

\\...\HP\DecisionCenter\BIA\business_impact_metrics.xml

8 On the Export screen, click Target Repository and for CMS, specify the 
hostname where the Target CMS repository resides, the username, and 
password.

9 Click Export. The Check Screen returns success messages for the assets 
that added to the target repository.

10 Click Close.

11 Return to the command window. Follow the instructions to complete the 
session and close the window.

Task 5: Install Optimization

Before you begin, make sure that you have a valid authorization code. If 
necessary, contact HP Software Support (www.hp.com/go/
hpsoftwaresupport). 

Step 1: Install the Optimization Analytics

1 Insert the DecisionCenter installation media in your hard drive. The 
installer starts automatically, or you can click Autorun.exe to start the 
installer.

2 Click the Analytic Content tab.

3 Click the Optimization Content tab.

4 Click Import Business Objects Universes and Analytics.

5 Follow the installation prompts and type the authorization code when 
requested.

6 Use Table 14 on page 45 to provide required CMS server information.
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Step 2: Update the Optimization Database Connection and Universe

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > Designer.

2 Log in as Administrator with no password.

3 Create a new connection, as necessary, to your data warehouse.

4 Click File > Import. 

5 Click the Universes folder from the Folder drop-down list. 

6 Click Browse and select the universes to import. For Optimization, select 
Simulation Optimization Analysis.

7 Click OK.

8 When a success message appears, click OK.

9 If a connection error message appears, click OK.

10 Click File > Parameters. 

11 On the Definition tab, select your database connection from the drop-down 
Connection list. For example, select rdsdb.

12 Click OK.

13 Click File > Export.

14 Click OK.

Task 6: Verify the Results

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > 
BusinessObjects Enterprise Java InfoView.

2 Log in as Administrator with no password.

3 In the left navigation pane, expand Public Folders. You should see a list of 
the DecisionCenter folders, such as ITPO Simulation and Optimization, 
SOPR Incident Management, SSTR Business Impact, or STRN Change 
Management.
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4 Expand each folder to see a list of available analytics. For example:

— If you select SOPR Incident Management, you should see an Incident 
Aging analytic. 

— If you select SSTR Business Impact, you should see an Impact 
Analysis analytic.

— If you select STRN Change Management, you should see a Cost of 
Change Variance analytic.

5 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > 
BusinessObjects Enterprise Java Administration Launchpad.

6 Click Central Management Console.

7 Log in as Administrator with no password.

8 Click Central Management Console.

9 Log in as Administrator with no password.

10 In the Organize section, click Universes.

11 Click the Universes tab to view the data warehouse and ITPM universes.

ServiceCenter 5.1 Workarounds

Some DecisionCenter out-of-box analytics display no results when you use 
ServiceCenter 5.1 data. When your Connect-It scenario finishes running, you 
should review and refresh all analytics. The following analytics will return no 
data:

• Alignment analytics

— Variable Service Costs by SLA and CI 

— Variable Service Costs by SLA, CI, and Cost Category

• ITPA Service Management 

— Configuration Items by Age 

— Economic Impact of SLA Failure

— Recurrent Outages
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— SLA Availability Successes

— SLA Response Time Successes

Recurrent Outages

Recurrent Outages and SLA Response Time Success analytics can produce 
results if you implement the following workaround.The links between the 
outage and outagedetail tables changed in ServiceCenter 6.x.

1 Edit the analytic using BusinessObjects InfoView.

2 Select the Edit Query tab.

3 Click View SQL.

4 Select Use Custom SQL. 

5 Edit the following SQL statements to remove the strikethrough text.

SELECT
  DEVICE_D.LOGICAL_NAME,
  DEVICE_D.TYPEPRGN,
  DEVICE_D.MODEL,
  DEVICE_D.SUBTYPE,
  DEVICE_D.VENDOR,
  DEVICE_D.ASSET_TAG,
  DEVICE_D.MANUFACTURER,
  RDS_TIMEDIM_D.MONTH,
  RDS_TIMEDIM_D.WEEK,
  count(distinct(OUTAGE_F.Z_RDSOUTAGE_DID)),
  OUTAGE_D.OUTAGE_START
FROM
  DEVICE_D,
  RDS_TIMEDIM_D,
  OUTAGE_F,
  ( 
  Select OUTAGEDETAIL.* , SLOAVAIL_D.SLO_ID AS SLO_ID2 from 
OUTAGEDETAIL,SLOAVAIL_DWhere OUTAGEDETAIL.SLO_ID = 
SLOAVAIL_D.SLO_ID
  )  OUTAGEDETAIL_DR,
  OUTAGE_D,
  DEVICE_F
WHERE
  ( DEVICE_F.Z_RDSDEVICE_DID=DEVICE_D.Z_RDSDEVICE_DID  )
    AND  ( OUTAGEDETAIL_DR.OUTAGE_ID=OUTAGE_D.OUTAGE_ID  )
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  AND  ( OUTAGE_D.Z_RDSOUTAGE_DID=OUTAGE_F.Z_RDSOUTAGE_DID  )
  AND  ( DEVICE_F.INSTALL_DATEID=RDS_TIMEDIM_D.RDS_TIMEDIM_DID  )
  AND  ( OUTAGE_F.Z_RDSDEVICE_DID=DEVICE_D.Z_RDSDEVICE_DID  )
  AND  ( OUTAGE_F.Z_RDSOBSOLETEIND  =  'N' AND 
OUTAGEDETAIL_DR.LOGICAL_NAME = DEVICE_D.LOGICAL_NAME  )
GROUP BY
  DEVICE_D.LOGICAL_NAME, 
  DEVICE_D.TYPEPRGN, 
  DEVICE_D.MODEL, 
  DEVICE_D.SUBTYPE, 
  DEVICE_D.VENDOR, 
  DEVICE_D.ASSET_TAG, 
  DEVICE_D.MANUFACTURER, 
  RDS_TIMEDIM_D.MONTH, 
  RDS_TIMEDIM_D.WEEK, 
  OUTAGE_D.OUTAGE_START

6 Save the analytic.

SLA Response Time Successes

The response time average is a decimal value in ServiceCenter 5.x data. 
Therefore, the chart values are 1/100th of the correct value. Follow these 
workaround steps.

1 Edit the analytic using BusinessObjects InfoView.

2 Edit the properties of the chart.

3 Edit the property Y-Axis > Values > Format. 

4 Select type Number and use the percentage format.

5 Edit the property Y-Axis > Scale > Max Value.

6 Set the value to 1.

7 Save the analytic.
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Refresh the Data

Performance Management can synchronize the data after you complete the 
installation steps. The amount of time required to synchronize the data 
depends on the volume of data to be processed and the capacity of your server. 
Schedule the synchronization to occur during off-peak hours when the server 
has no other demands.

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > 
BusinessObjects Enterprise Java InfoView.

2 Log in as Administrator with no password.

3 Click Go to Performance Management.

4 Click Setup on the toolbar.

5 Click the System Setup tab.

6 Click Dimensions.

7 Select an existing Dimension in the upper text box and click Edit 
Dimension.

8 Click Next.

9 Click Refresh.

10 Click Next.

11 Click END.

12 Repeat Step 7 – Step 11 for all dimensions.

13 Click the Home icon to return to the Home page.

14 Click Go To Performance Management.

15 Click the Dashboard Manager tab.

16 Click the Metrics tab.

17 Click the Refresh icon next to the Available Metrics to refresh the list of 
metrics.

18 Select Call Metrics and Dimensions from the Available Metrics drop-down list.

19 For each category listed, select the metric.

20 Click the Purge icon, then the Refresh icon.
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21 When this warning appears, “This operation can be very long. Do you want 
to continue,” click OK. 

22 Repeat Step 18 – Step 21 to refresh other metrics in the list.

Each metric will refresh and when the process is complete, you can see a Last 
Refresh Date in the Metric History section.
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8 Configure the Application Server
The typical DecisionCenter distributed installation has a standalone Tomcat 
or WebSphere application server. There are three typical web server 
configurations:

• You can take advantage of the Tomcat installation embedded within 
BusinessObjects Enterprise XI R2. Because BusinessObjects requires its 
own web application server, it installs Tomcat within the Business Objects 
installation folder structure. 

• You can use an existing Tomcat application server that is compatible with 
BusinessObjects Enterprise XI R2 but resident on a separate networked 
server. This server can have either a Windows or HP-UX operating 
system. You must copy certain files from the Business Objects web 
application server to the remote web application server to support the 
remote connection to BusinessObjects software.

• You can use an existing IBM WebSphere application server that is 
compatible with BusinessObjects Enterprise XI R2 but resident on a 
separate networked server.

If you use an existing instance of an application server, make sure that 
DecisionCenter supports the version that you are running. For more 
information, see the distributed server configuration diagram on page 18 and 
see the DecisionCenter Support Matrix on the HP Software Support web 
site (http://support.openview.hp.com/sc/support_matrices.jsp).

Before You Begin

Success depends on meeting these prerequisites. Make sure that:

• You have administrative rights to the application server where you plan to 
deploy the DecisionCenter WAR file. 
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• There is connectivity between the BusinessObjects XI server and the 
application server operating system.

• You have knowledge and experience deploying applications in the selected 
application server environment.

• Either Tomcat or IBM Websphere is installed and running successfully on 
the application server.

• The correct Java version is installed on the application server.
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Tomcat (Windows) Installation Checklist

Print this checklist to use during the installation process. As you complete 
each task, mark it finished. Complete these tasks on the Tomcat server. For 
more information, see the distributed server configuration diagram on 
page 18.

 Task 1: Install the Web Component Adapter on page 108.

 Task 2: Modify the webcompadapterwar.xml File on page 108.

 Task 3: Install the JDBC Drivers on page 109.

 Task 4: Deploy the WAR File on page 109.

 Task 5: Configure Tomcat on page 110.

 Task 6: Configure the JNDI Interface on page 111.

 Task 7: Copy and Modify BusinessObjects Files on page 113.

 Task 8: Start Tomcat on page 114.

 Task 9: Copy the Required Library on page 114.

 Task 10: Configure Performance Manager on page 115.

 Task 11: Configure Tomcat Java Options on page 115.

 Task 12: Configure the BusinessObjects Files on page 116.

 Task 13: Customize the Installation on page 117.

 Task 14: Configure Time Zones on page 120.

 Task 15: Configure Properties Files on page 120.

 Task 16: Update the jaas.config File on page 121.

 Task 17: Start the Server on page 123.
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Task 1: Install the Web Component Adapter

You can install the BusinessObjects Enterprise XI Web Component Adapter 
(WCA) from the BusinessObjects installation media. If you upgrade your 
BusinessObjects server installation, you must repeat the steps that require 
files to be copied from the BusinessObjects server.

1 Install the BusinessObjects WCA component on the same drive where you 
installed BusinessObjects on the BusinessObjects server. Follow the 
instructions in the BusinessObjects Enterprise XI installation 
documentation to install the WCA. 

2 Copy this file from the BusinessObjects server:

\\..\BusinessObjects\BusinessObjects Enterprise 11.5\java
\applications\webcompadapter.war 

To this application server directory:

\\..\Tomcat\webapps

Tomcat deploys the WAR file automatically when you start the Tomcat 
service.

Task 2: Modify the webcompadapterwar.xml File

1 Copy this file from the BusinessObjects server:

\\..\BusinessObjects\Tomcat\conf\Catalina\localhost
\webcompadapterwar.xml 

To this application server directory:

\\..\Tomcat\conf\Catalina\localhost 

2 Open webcompadapterwar.xml with a text editor.

3 Edit the docBase parameter to point to the webcompadapterwar.war file 
in the BusinessObjects installation directory. For example:

docBase="\\...\Business Objects\BusinessObjects Enterprise 
11.5\java\applications\webcompadapter.war"

4 Save and close the file.
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5 From the Windows Start menu, click Control Panel > Administrative Tools > 
Services to start the Tomcat service. This step deploys the WCA 
application.

Task 3: Install the JDBC Drivers

1 From the Windows Start menu, click Control Panel > Administrative Tools > 
Services to stop the Tomcat service.

2 Copy one or more supported JDBC driver files from the RDBMS server to 
this application server directory:

\\..\Tomcat 5.x\common\lib

For more information about JDBC drivers, see JDBC Drivers on page 23.

3 Clear the DecisionCenter cache by deleting the files in this directory:

\\..\Tomcat\work\Catalina\localhost\DecisionCenter

4 Clear the businessobjects cache by deleting the files in this directory:

\\..\Tomcat\work\Catalina\localhost\businessobjects

Task 4: Deploy the WAR File

The DecisionCenter application is a web archive (WAR) file on the 
DecisionCenter installation media. The installation process prompts you to 
store the WAR file in the appropriate web server directory. Tomcat deploys the 
file. 

1 Insert the DecisionCenter installation media in your hard drive. The 
installer starts automatically, or you can click Autorun.exe to start the 
installer.

2 Click the Web Application tab.

3 Click DecisionCenter Web Interface.

4 Copy decisionCenter.war and paste it into this web server deployment 
folder:

\\..\Tomcat 5.x\webapps

Tomcat deploys the WAR file automatically when you start the Tomcat 
service.
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5 Back up this directory before you proceed to the next task:

\\..\Tomcat 5.x\conf\Catalina\localhost

Task 5: Configure Tomcat 

Tomcat loads Java at startup. Java needs to know the location of krb5.ini 
and bscLogin.conf. 

1 Stop Tomcat.

2 Click Start > Programs > Tomcat > Tomcat Configuration. 

3 Click the Java tab.

4 Click the mouse at the bottom of the list of options in the Java Options text 
box. 

5 Type these values:

-Djava.security.auth.login.config=C:\directory\bscLogin.conf 
-Djava.security.krb5.conf=C:\directory\Krb5.ini 

6 Click OK.

Edit Authentication Parameters

1 Open this file with a text editor:

\\..\Tomcat\webapps\decisionCenter\WEB-INF\web.xml

2 For Active Directory only, change this parameter:

<init-param>
<param-name>biAuthType</param-name>
<param-value>secLDAP</param-value>

</init-param>

      To

<init-param>
<param-name>biAuthType</param-name>
<param-value>secWinAD </param-value>

</init-param>

3 Open this file with a text editor:
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\\..\Tomcat\webapps\decisionCenter\WEB-INF\
applicationContext.xml

4 Locate this section:

<bean id="jaasAuthenticationProvider" class="....">

5 Change the value in this section:

<property name="loginContextName">
<value>dpJndi</value>

</property>

To

<property name="loginContextName">
<value>QAAD</value>

</property>

6 Delete this directory:

\\..\Tomcat\work\Catalina\localhost\decisionCenter

Restart the Tomcat service.

Task 6: Configure the JNDI Interface

You must configure the Java Naming and Directory Interface (JNDI) before 
you deploy the DecisionCenter WAR file.

1 Open this file with a text editor:

\\..\Tomcat 5.x\conf \tomcat-users.xml

2 Verify that Tomcat has an entry to configure admin and manager user 
roles. If necessary, edit the file to include these lines:

<role rolename=”manager”/>
<role rolename=”admin”/>
<user username=”manager” password=”manager” roles=”manager”/>
<user username=”admin” password=”admin” roles=”admin”/>

3 Save and close the file.

4 From the Windows Start menu, click Control Panel > Administrative Tools > 
Services to start the Tomcat service.

5 Start a Microsoft Internet Explorer browser session.
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6 Type http://host-name:port_number in a browser to display the 
Tomcat Home page. For example, you might type:

http://server_name:8080

7 In the Administration section, click Tomcat Administration.

8 Type the User Name and Password for the admin user that you configured 
in Step 2. Based on the users that you defined in Step 2, type admin in the 
User Name text box, and admin in the Password text box. Make sure that 
the values you specify match the parameter settings in the 
tomcat-users.xml file.

9 In the left navigation pane, expand the Tomcat Server > Service (Catalina) > 
Host > Context (/decisionCenter) > Resources nodes.

10 Click Data Sources to view the configured JNDI entries for the 
decisionCenter context.

11 From the drop-down Available Actions list, select Create New Data Source.

12 Type values for the JNDI parameters. The following table shows 
examples; however, they must match your local configuration. For exact 
values, see your database administrator.

Table 21 JNDI Parameters

Parameter Suggested Value

JNDI Name: jdbc/dc
(This is a required value)

Data Source URL: 

• SQL Server: 
(see Table 8 on page 37)
• Oracle: 
(see Table 10 on page 41)

Examples (verify your local URLs):
• jdbc:microsoft:sqlserver: //sqlserverHost:1433 

• jdbc:oracle:thin:@server_name:1521:ORCL 

JDBC Driver Class:

• SQL Server:
• Oracle:

Examples (verify your local URLs):
• com.microsoft.jdbc.sqlserver.SQLServerDriver
• oracle.jdbc.driver.OracleDriver

User Name:
 (see Table 12 on page 44)

rds_dba
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13 Click Save.

14 Click Commit Changes. Tomcat saves the changes and updates the 
DecisionCenter application. 

15 Click Log Out.

16 To verify that the DecisionCenter application deploys correctly, return to 
the Tomcat Home page (http://host-name:port_number)using the 
same browser session.

17 Click Tomcat Manager. 

18 Type the User Name and Password for the manager role that you configured 
in Step 2 on page 111. Based on the users that you defined in Step 2, type 
manager in the User Name text box, and manager in the Password text box. 
Make sure that the values you specify match the parameter settings in the 
tomcat-users.xml file.

19 Verify that the DecisionCenter application listed in Applications has a 
value of true in the Running column. If not, click Start in the Command 
column.

Task 7: Copy and Modify BusinessObjects Files

1 From the Windows Start menu, click Control Panel > Administrative Tools > 
Services to stop the Tomcat service.

2 Copy the remaining WAR files from this BusinessObjects directory:

Password:
 (see Table 12 on page 44)

passw0rd

Max. Active Connections: 50

Max. Idle Connections: 10

Max. Wait for Connection: 10000

Validation Query: 
(Optional)

Table 21 JNDI Parameters

Parameter Suggested Value
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\\..\BusinessObjects Enterprise 11.5\java\applications 

To this application server directory: 

\\..\Tomcat\conf

3 Copy the remaining .xml files from this BusinessObjects directory:

\\..\BusinessObjects\Tomcat\conf\Catalina\localhost

To this application server directory:

\\..\Tomcat\conf\Catalina\localhost

4 Open each .xml file with a text editor.

5 Edit the docBase parameter in each file to point to the appropriate 
WAR file. For example: 

docBase="C:\Program Files\Business Objects\BusinessObjects 
Enterprise 11.5\java\applications\filename.war"

Task 8: Start Tomcat

Follow these steps to deploy the WAR file on the remote application server.

1 From the Windows Start menu, click Control Panel > Administrative Tools > 
Services to start the Tomcat service. 

2 Verify that no error messages occur except this one:

CANNOT READ INITCONFIG.PROPERTIES af.configdir PROPERTY 
SETTING.

This message is acceptable.

Task 9: Copy the Required Library

1 From the Windows Start menu, click Control Panel > Administrative Tools > 
Services to stop the Tomcat service.

2 Copy this file from the BusinessObjects server:

\\..\BusinessObjects\Tomcat\shared\lib\cewcanative.jar

To this application server directory:

\\..\Tomcat\shared\lib
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Task 10: Configure Performance Manager

1 Create a directory on the application server for the BusinessObjects 
Enterprise XI Performance Management application. For example:

\\..\BusinessObjects\your_directory

2 Copy all of the .properties files from this BusinessObjects server directory:

\\..\Business Objects\Performance Management 11.5

To this new application server directory:

\\..\Business Objects\your_directory

3 Open the InitConfig.properties file with a text editor.

4 Ensure that the path to the Central Management Server in the 
initialization.CMSName parameter points to the BusinessObjects 
Enterprise XI server.

Task 11: Configure Tomcat Java Options

1 From the Windows Start menu, click Programs > Tomcat > 
Tomcat Configuration.

2 Click the Java tab.

3 In the Java Options section, make sure that the following Java options 
exist and these paths reflect the correct locations on the remote 
application server. If necessary, modify the paths to these local directories 
for BusinessObjects Enterprise XI WCA and Performance Manager. For 
example:

-Djava.library.path=WINDIR\system32\;C:\Program Files
\Business Objects\BusinessObjects Enterprise 11.5\win32_x86\

-Daf.configdir=C:\Program Files\Business Objects
\your_directory\
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where your_directory is the directory that you created in Task 10: 
Configure Performance Manager on page 115. 

Task 12: Configure the BusinessObjects Files

1 Skip this step if you have a dswsbobje application in the following 
directory on the application server:

\\..\Tomcat\webapps

Otherwise, do the following:

a Copy this file from the BusinessObjects server:

\\..\Business Objects\BusinessObjects Enterprise 11.5
\Web Services\en\dswsbobje.war

To this application server directory:

\\..\Tomcat\webapps

b Copy this file from the BusinessObjects server:

\\..\Business Objects\\Tomcat\conf\Catalina\localhost
\dswsbobje.xml

To this application server directory:

\\..\Business Objects\Tomcat\conf\Catalina\localhost

c From the Windows Start menu, click Control Panel > 
Administrative Tools > Services to start the Tomcat service. 

2 Open this file with a text editor:

\\..\Tomcat\webapps\dswsbobje\WEB-INF\classes\dsws.properties

If you use Cygwin-based %CATALINA_HOME%\bin\*.sh scripts 
to start and stop your Tomcat server, you should omit spaces in any 
property settings. JAVA_OPTS errors can occur in a Windows 
installation when you try to pass multiple properties with spaces. 
Either omit spaces, or use non-Cygwin %CATALINA_HOME%\bin
\*.sh scripts to start and stop your Tomcat server. If you use .bat 
scripts, you can use spaces.
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3 Change the domain= parameter to point to your BusinessObjects server. 
For example:

domain=server_name

4 Change the report.server parameter to point to your remote application 
server. For example:

report.server=remote_server_name

5 For each .wsdl file in this directory:

\\..\Tomcat\webapps\dswsbobje\WEB-INF\classes

Do the following:

a Open the file with a text editor.

b Search for:

soap:address location="http://localhost:8080/dsws
/services/bicatalog" 

c Change localhost:8080 to your application server name and port 
number.

d Save and close the file.

6 For each web.xml file in these application server directories:

\\..\Tomcat\webapps\application\WEB-INF\web.xml

Do the following:

a Open the file with a text editor.

b Search for any parameter that points to the Central Management 
Server. The parameter value should point to the BusinessObjects 
server.

c Save any changed file.

Task 13: Customize the Installation

The DecisionCenter installation media contains customized BusinessObjects 
files that the application server needs to run DecisionCenter. Use the 
installation media for the following steps. 

1 From the Windows Start menu, click Control Panel > Administrative Tools > 
Services > Stop to stop the Tomcat service.
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2 Clear the DecisionCenter cache by deleting the files in this directory:

\\..\Tomcat\work\Catalina\localhost\DecisionCenter

3 Clear the businessobjects cache by deleting the files in this directory:

\\..\Tomcat\work\Catalina\localhost\businessobjects

4 Copy this file from the DecisionCenter installation media: 

\\..\ITPA\ITPA-SM\BOCustomization\desktoplaunch\InfoView\main
\home.jsp

To this application server directory: 

\\..\Tomcat\webapps\businessobjects\enterprise115
\desktoplaunch\InfoView\main

5 Click OK to confirm the replacement. 

6 Copy this file from the DecisionCenter installation media:  

\\..\ITPA\ITPA-SM\BOCustomization\desktoplaunch\InfoView
\utils\utils.js

To this application server directory: 

\\..\Tomcat\webapps\businessobjects\enterprise115\
desktoplaunch\InfoView\utils

7 Click OK to confirm the replacement. 

8 Navigate to this DecisionCenter installation media directory: 

\\..\ITPA\ITPA-SM\BOCustomization\desktoplaunch\jsp

9 Copy these files: 

— aa-promptcontent.jsp

— appsContentFrame.jsp

— headerPlusAF.jsp

— performanceManagementHome.jsp

— workspaceHeaderAF.jsp

To this application server directory: 

\\..\Tomcat\webapps\businessobjects\enterprise115
\desktoplaunch\jsp

10 Click OK to confirm each replacement.
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11 Copy this file from the DecisionCenter installation media:  

\\..\ITPA\ITPA-SM\BOCustomization\desktoplaunch\jsp\ce
\cestartpage.jsp. 

To this application server directory:

\\..\Tomcat\webapps\businessobjects\enterprise115
\desktoplaunch\jsp\ce

12 Click OK to confirm the replacement.

13 Copy this file from the DecisionCenter installation media: 

\\..\ITPA\ITPA-SM\BOCustomization\desktoplaunch\scripting
\aa-linkbar.js. 

To this application server directory:

\\..\Tomcat\webapps\businessobjects\enterprise115
\desktoplaunch\scripting

14 Click OK to confirm the replacement.

15 Navigate to this DecisionCenter installation media directory: 

\\..\ITPA\ITPA-SM\BOCustomization\desktoplaunch\viewers
\cdz_adv

16 Copy these files:

— viewCDZDocument.jsp

— viewReport.jsp

To this application server directory:

\\..\Tomcat\webapps\businessobjects\enterprise115
\desktoplaunch\viewers\cdz_adv

17 Click OK to confirm each replacement.

18 From the Windows Start menu, click Control Panel > Administrative Tools > 
Services to start the Tomcat service.

19 Start a browser session to test the application.

20 Type the following URL. Modify it to point to the BusinessObjects 
Enterprise XI web server provider name and the assigned port number:

http://server.name:port number/dswsbobje/services 

The BusinessObjects Services page should appear.
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Task 14: Configure Time Zones

DecisionCenter relies on accurate time information to apply rules and 
calculate impact. All tools must have the same time zone configuration to 
ensure this accuracy. You must configure the correct time zone parameter on 
these three servers:

•  The application server

• The data warehouse server

• The Optimization engine server 

Follow these steps to configure the application server.

1 Open this file with a text editor: 

\\..\Tomcat\webapps\decisionCenter\WEB-INF\common.properties

2 Change this value:

database.timezone=GMT

To

database.timezone=GMT+/-nn

Where nn is a numeric value for the number of time zones displaced from 
Greenwich Mean Time for your local time zone. For example, GMT-5 is the 
displacement for Eastern Standard Time in North America.

3 Save and close the file.

Task 15: Configure Properties Files

Under certain circumstances, you must change the parameters in two 
properties files.

hibernate.properties

If your RDBMS is Oracle, follow these steps.

1 Open this file with a text editor:

\\..\Tomcat\webapp\decisionCenter\WEB-INF
\hibernate.properties
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2 Remove the pound sign (#) from this statement:

#hibernate.dialect=org.hibernate.dialect.Oracle9Dialect

3 Insert a pound sign (#) at the beginning of this statement:

hibernate.dialect=org.hibernate.dialect.SQLServerDialect

4 Verify that the result looks like this:

#hibernate.dialect=org.hibernate.dialect.SQLServerDialect
hibernate.dialect=org.hibernate.dialect.Oracle9Dialect

5 Save and close the file.

jmx.properties

If the Optimization engine is not installed on the application server, follow 
these steps.

1 Open this file with a text editor:

\\..\Tomcat\webapps\decisionCenter\WEB-INF\jmx.properties

2 Locate this parameter:

localhost:9999

3 Replace this with the server URL and port number of the Optimization 
engine server.

4 Save and close the file.

Make sure that the server URL and port number match the server URL and 
port number specified in the jmx.properties file on the Optimization 
engine server.

Task 16: Update the jaas.config File

The jaas.config file contains the information to connect to BusinessObjects 
using LDAP or Active Directory authentication. You must edit the parameters 
to point to the LDAP or Active Directory server and specify the administrative 
logon and password.
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LDAP Users

1 Open this file with a text editor:

./../Tomcat/webapps/decisionCenter/WEB-INF/jaas.config

2 Locate the dpJndi section.

3 Edit the user.provider.url parameter. Identify the fully qualified name of 
the LDAP server that you specified in Task 2: Configure LDAP on page 80, 
and the assigned server port. For example:

user.provider.url=”ldap://ldap.server:port_number/
ou=people,dc=server”

4 Edit the uid value in the security.principal parameter. Identify the 
administrative logon that you specified for the LDAP server. For example:

security.principal="uid=admin,ou=administrators,ou=topologyma
nagement,o=netscaperoot" 

5 Edit the security.credentials parameter. Specify the LDAP administration 
(or designated account) password. For example:

security.credentials="password" 

6 Edit the group.provider.url parameter. Identify the fully qualified name of 
the LDAP server that you specified in Task 2: Configure LDAP on page 80, 
and the assigned server port. For example:

group.provider.url=”ldap://server_name.xx.yy.com:port_number/
OU=Groups,OU=server_name,DC=xx,DC=yy,DC=com”

7 Save and close the file.

Active Directory Users

1 Open this file with a text editor:

./../Tomcat/webapps/decisionCenter/WEB-INF/jaas.config

2 Locate the QAAD section.

You can locate suffix information in the Directory Server Settings of 
the LDAP configuration procedures.

You can locate suffix information in the Directory Server Settings of 
the LDAP configuration procedures.
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3 Edit the user.provider.url parameter. Identify the fully qualified name of 
the Active Directory server that you specified in Task 2: Configure Active 
Directory for Business Objects on page 82, and the assigned server port. 
For example:

user.provider.url=”ldap://server_name.xx.yy.com:port_number
/OU=Users,OU=server_name,DC=xx,DC=yy,DC=com”

4 Edit the security.principal parameter. Identify the administrative logon 
that you specified for the Active Directory server. For example:

security.principal="CN=admin,ou=Users,OU=server_name,DC=xx,
DC=yy,DC=com" 

5 Edit the security.credentials parameter. Specify the LDAP administration 
(or designated account) password. For example:

security.credentials="password" 

6 Edit the group.provider.url parameter. Identify the fully qualified name of 
the Active Directory server that you specified in Task 2: Configure Active 
Directory for Business Objects on page 82, and the assigned server port. 
For example:

group.provider.url="ldap://server_name.xx.yy.com:port_number
/OU=Groups,OU=server_name,DC=xx,DC=yy,DC=com"

7 Examine the remaining parameters to make sure they are correct for your 
environment.

8 Save and close the file.

Task 17: Start the Server

From the Windows Start menu, click Control Panel > Administrative Tools > 
Services to start the Tomcat service. 
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Tomcat (HP-UX) Installation Checklist

Print this checklist to use during the installation process. As you finish each 
task, mark it finished. Complete these tasks on the HP-UX Tomcat web 
server. 

For more information, see the distributed server configuration diagram on 
page 18.

 Task 1: Configure the HP-UX Environment on page 125.

 Task 2: Create the Directory Structure on page 125.

 Task 3: Create the BusinessObjects XI Environment Setup File on 
page 125.

 Task 4: Configure the Tomcat Installation on page 126.

 Task 5: Install the Web Component Adapter on page 127.

 Task 6: Modify the webcompadapterwar.xml File on page 127.

 Task 7: Install the JDBC Drivers on page 128.

 Task 8: Deploy the DecisionCenter WAR File on page 128.

 Task 9: Configure the JNDI Interface on page 129.

 Task 10: Copy and Modify BusinessObjects Files on page 131.

 Task 11: Start Tomcat on page 132.

 Task 12: Copy the Required Library File on page 132.

 Task 13: Configure the BusinessObjects Files on page 132.

 Task 14: Customize the Installation on page 134.

 Task 15: Configure Time Zones on page 136.

 Task 16: Configure Properties Files on page 137.

 Task 17: Update the jaas.config File on page 138.

 Task 18: Start the Server on page 140.
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Task 1: Configure the HP-UX Environment

1 Define the locale by adding these lines to your user profile. 

LANG=locale 

For example, the locale for the United States would be en_US.utf8.

2 Navigate to the JAVA_HOME variable. Define the following value.

JAVA_HOME=/opt/javal.4

export JAVA_HOME

Task 2: Create the Directory Structure

1 Create a directory for BusinessObjects files. This is the root directory for 
related sub-directories. For example:

./../Tomcat/bobje

2 Create a subdirectory for BusinessObjects WAR files. For example: 

./../Tomcat/bobje/enterprise115/java/applications

3 Create a subdirectory for BusinessObjects configuration files. For 
example:

./../Tomcat/bobje/af_config

4 Create a subdirectory for BusinessObjects environment setup scripts. For 
example: 

./../Tomcat/bobje/setup

5 Create a subdirectory for the HP-UX BusinessObjects environment. For 
example: 

./../Tomcat/bobje/enterprise115/hpux_pa_risc

Task 3: Create the BusinessObjects XI Environment Setup File

1 Navigate to this directory:

./../Tomcat/bobje/setup

2 Use a text editor to create a file named env.sh.
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3 Type the following text in the env.sh file.

LIBPATH=/../Tomcat/bobje/enterprise115/hpux_pa_risc:$LIBPATH
export LIBPATH

PATH=/../Tomcat/bobje/enterprise115/hpux_pa_risc:$PATH
export PATH

LD_LIBRARY_PATH=/../Tomcat/bobje/enterprise115/
hpux_pa_risc:$LD_LIBRARY_PATH
export LD_LIBRARY_PATH

4 Save and close the file.

Task 4: Configure the Tomcat Installation

1 Navigate to this directory:

. /../Tomcat/bin

2 Open the startup.sh file with a text editor. 

3 Insert the following text at the top of the file: 

./../Tomcat/bobje/setup/env.sh

export JAVA_OPTS="-Daf.configdir=/../Tomcat/bobje/af_config 
-Djava.library.path=/../Tomcat/bobje/enterprise115/java/
applications/webcompadapter.war"

export JAVA_HOME=/../java1.4

4 Save and close the file.

5 Open the shutdown.sh file with a text editor. 

6 Insert the following text at the top of the file:

export JAVA_HOME=/../java1.4

7 Save and close the file.
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Task 5: Install the Web Component Adapter

You can install the BusinessObjects Enterprise XI Web Component Adapter 
(WCA) from the BusinessObjects installation media. If you upgrade your 
BusinessObjects server installation, you must repeat the steps that require 
files to be copied from the BusinessObjects server.

Copy  this file from your BusinessObjects server:

\\..\BusinessObjects\BusinessObjects Enterprise 11.5\java
\applications\webcompadapter.war 

To these application server directories:

./../Tomcat/webapps

./../Tomcat/webapps/bobje/enterprise115/java/applications

Tomcat deploys the WAR file automatically when you start the Tomcat 
service.

Task 6: Modify the webcompadapterwar.xml File

1 Copy this file from the BusinessObjects server:

\\..\BusinessObjects\Tomcat\conf\Catalina\localhost
\webcompadapterwar.xml 

To this application server directory:

./../Tomcat/conf/Catalina/localhost 

2 Open webcompadapterwar.xml with a text editor.

3 Edit the docBase parameter to point to the webcompadapterwar.war file 
in the BusinessObjects installation directory. For example:

docBase="./../Tomcat/webapps/webcompadapter.war"

4 Save and close the file.

5 Run this script to start the Tomcat service and deploy the WCA 
application:

./../Tomcat/bin/startup.sh
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Task 7: Install the JDBC Drivers

1 Run this script to stop the Tomcat service:

./../Tomcat/bin/shutdown.sh 

2 Copy the supported JDBC driver file for your RDBMS from the RDBMS 
server to the application server and store it in this directory:

./../Tomcat/common/lib

For more information about JDBC drivers, see JDBC Drivers on page 23.

3 Run this script to stop the Tomcat service:

./../Tomcat/bin/shutdown.sh 

4 Clear the DecisionCenter cache by deleting the files in this directory:

\\..\Tomcat\work\Catalina\localhost\DecisionCenter

5 Clear the businessobjects cache by deleting the files in this directory:

\\..\Tomcat\work\Catalina\localhost\businessobjects

Task 8: Deploy the DecisionCenter WAR File

The DecisionCenter application is a web archive (WAR) file on the 
DecisionCenter installation media. The installation process prompts you to 
store the WAR file in the appropriate web server directory. The web 
application server deploys the file. 

1 Insert the DecisionCenter installation media in your hard drive on a 
Windows workstation. The installer starts automatically, or you can click 
Autorun.exe to start the installer.

2 Click the Web Application tab.

3 Click DecisionCenter Web Interface.

4 Copy decisionCenter.war and transfer it into this web server 
deployment folder:

./../Tomcat 5.x/webapps

Tomcat deploys the WAR file automatically when you start the 
application.
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5 Back up this directory before you proceed to the next task:

./../Tomcat 5.x/conf/Catalina/localhost

Task 9: Configure the JNDI Interface

You must configure the Java Naming and Directory Interface (JNDI) before 
you deploy the DecisionCenter WAR file.

1 Open this file with a text editor:

./../Tomcat 5.x/conf/tomcat-users.xml

2 Verify that Tomcat has an entry to configure admin and manager user 
roles. If necessary, edit the file to include these lines:

<role rolename=”manager”/>
<role rolename=”admin”/>
<user username=”manager” password=”manager” roles=”manager”/>
<user username=”admin” password=”admin” roles=”admin”/>

3 Save and close the file.

4 Run this script to start the Tomcat service:

./../Tomcat/bin/startup.sh

5 Start a Microsoft Internet Explorer browser session.

6 Type http://host-name:port_number in the browser address window to 
display the Tomcat Home page. For example, you might type:

http://server.name:8080

7 In the Administration section, click Tomcat Administration.

8 Type the User Name and Password for the admin user that you configured 
in Step 2. Based on the users that you defined in Step 2, type admin in the 
User Name text box, and admin in the Password text box. Make sure that 
the values you specify match the parameter settings in the 
tomcat-users.xml file.

9 In the left navigation pane, expand the Tomcat Server > Service (Catalina) > 
Host > Context (/decisionCenter) > Resources nodes.

10 Click Data Sources to view the configured JNDI entries for the 
decisionCenter context.

11 From the drop-down Available Actions list, select Create New Data Source.
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12 Type values for the JNDI parameters. The following table shows 
examples; however, they must match your local configuration. For exact 
values, see your database administrator.

13 Click Save.

Table 22 JNDI Parameters

Parameter Suggested Value

JNDI Name: jdbc/dc
(This is a required value)

Data Source URL: 

• SQL Server: 
(see Table 8 on 
page 37)
• Oracle: 
(see Table 10 on 
page 41)

Examples (verify your local URLs):
• jdbc:microsoft:sqlserver: //

sqlserverHost:1433 

• jdbc:oracle:thin:@server_name:1521:ORCL 

JDBC Driver Class:

• SQL Server:
• Oracle:

Examples (verify your local URLs):
• com.microsoft.jdbc.sqlserver.SQLServerDriver
• oracle.jdbc.driver.OracleDriver

User Name:
 (see Table 12 on 
page 44)

rds_dba

Password:
 (see Table 12 on 
page 44)

passw0rd

Max. Active 
Connections:

50

Max. Idle Connections: 10

Max. Wait for 
Connection:

10000

Validation Query: 
(Optional)
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14 Click Commit Changes. The Tomcat server saves the changes and updates 
the DecisionCenter application. 

15 Click Log Out.

16 To verify that the DecisionCenter application deploys correctly, return to 
the Tomcat Home page (http://host-name:port_number) using the 
same browser session.

17 Click Tomcat Manager. 

18 Type the User Name and Password for the manager user that you 
configured in step 2 on page 129. Based on the users that you defined in 
Step 2, type manager in the User Name text box, and manager in the 
Password text box. Make sure that the values you specify match the 
parameter settings in the tomcat-users.xml file.

19 Verify that the DecisionCenter application listed in Applications has a 
value of true in the Running column. If not, click Start in the Command 
column.

20 Run this script to stop the Tomcat service:

./../Tomcat/bin/shutdown.sh

Task 10: Copy and Modify BusinessObjects Files

1 Copy this file from the BusinessObjects server:

\\..\BusinessObjects Enterprise 11.5\java\applications
\desktop.war 

To this application server directory: 

./../Tomcat/webapps/bobje/enterprise115/java/applications

2 Copy this file from the BusinessObjects server:

\\..\BusinessObjects\Tomcat\conf\Catalina\localhost\
desktopwar.xml

To this application server directory:

./../Tomcat/conf/Catalina/localhost
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3 Open the desktopwar.xml file with a text editor. 

4 Edit the docBase parameter to point to the desktop.war file in the 
BusinessObjects installation directory. For example: 

docBase="./../Tomcat/bobje/enterprise115/java/applications/
desktop.war"

Task 11: Start Tomcat

1 Run this script to start the Tomcat service:

./../Tomcat/bin/startup.sh

2 Error messages that are likely to occur include:

— FileNotFoundException (a logging problem)

— WCA startup error message (the Web Computer Adapter is not 
installed on the HP-UX server)

These messages are acceptable.

Task 12: Copy the Required Library File

1 Run this script to stop the Tomcat service:

./../Tomcat/bin/shutdown.sh

2 Copy this file from the BusinessObjects server:

\\BusinessObjects\Tomcat\shared\lib\cewcanative.jar

To this application server directory:

./../Tomcat/shared/lib

Task 13: Configure the BusinessObjects Files

1 Skip this step if you have a dswsbobje application in the following 
directory on the application server:

./../Tomcat/webapps
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a Copy this file from the BusinessObjects server:

\\..\Business Objects\BusinessObjects Enterprise 11.5
\Web Services\en\dswsbobje.war

To this application server directory:

./../Tomcat/webapps

b Copy this file from the BusinessObjects server:

\\..\Business Objects\Tomcat\conf\Catalina\localhost
\dswsbobje.xml

To this application server directory:

./../Tomcat/conf/Catalina/localhost

c Open the dswsbobje.xml file with a text editor. 

d Edit the docBase parameter to point to the dswsbobje.war file in the 
BusinessObjects installation directory. For example:

docBase="./../Tomcat/webapps/dswsbobje.war" 

e Run this script to start the Tomcat service:

./../Tomcat/bin/startup.sh

2 Open this file with a text editor:

./../Tomcat/webapps/dswsbobje/WEB-INF/classes/dsws.properties

3 Change the domain= parameter to point to your BusinessObjects server. 
For example:

domain=server_name

4 Change the report.server parameter to point to your remote application 
server. For example:

report.server=remote_server_name

5 For each .wsdl file in this directory:

./../Tomcat/webapps/dswsbobje/WEB-INF/classes

Do the following:

a Open the file with a text editor.
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b Search for:

soap:address location="http://localhost:8080/dsws
/services/bicatalog" 

c Change localhost:8080 to your application server name and port 
number.

d Save and close the file.

6 For each web.xml file in this directory on the application server:

./../Tomcat/webapps/decisionCenter/WEB-INF

Do the following:

a Open the file with a text editor.

b Search for any parameter that points to the Central Management 
Server. The parameter value should point to the BusinessObjects 
server.

c Save any changed file.

Task 14: Customize the Installation

The DecisionCenter installation media contains customized BusinessObjects 
files that the application server needs to run DecisionCenter.

1 Run this script to stop the Tomcat service:

./../Tomcat/bin/shutdown.sh

2 Clear the DecisionCenter cache by deleting the files in this directory:

./../Tomcat/work/Catalina/localhost/DecisionCenter

3 Clear the businessobjects cache by deleting the files in this directory:

./../Tomcat/work/Catalina/localhost/businessobjects

4 Insert the DecisionCenter installation media in your hard drive on a 
Windows workstation.

5 Copy this file from the DecisionCenter installation media: 

\\..\ITPA\ITPA-SM\BOCustomization\desktoplaunch\InfoView\main
\home.jsp
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To this application server directory: 

./../Tomcat/webapps/businessobjects/enterprise115
/desktoplaunch/InfoView/main

6 Click OK to confirm the replacement. 

7 Copy this file from the DecisionCenter installation media: 

\\..\ITPA\ITPA-SM\BOCustomization\desktoplaunch\InfoView
\utils\utils.js

To this application server directory: 

./../Tomcat/webapps/businessobjects/enterprise115
/desktoplaunch/InfoView/utils

8 Click OK to confirm the replacement. 

9 Navigate to this DecisionCenter installation media directory: 

\\..\ITPA\ITPA-SM\BOCustomization\desktoplaunch\jsp

Copy each file:

— aa-promptcontent.jsp

— appsContentFrame.jsp

— headerPlusAF.jsp

— performanceManagementHome.jsp

— workspaceHeaderAF.jsp

To this application server directory: 

./../Tomcat/webapps/businessobjects/enterprise115
/desktoplaunch/jsp

10 Click OK to confirm each replacement.

11 Copy this file from the DecisionCenter installation media: 

\\..\ITPA\ITPA-SM\BOCustomization\desktoplaunch\jsp\ce
\cestartpage.jsp

To this application server directory: 

./../Tomcat/webapps/businessobjects/enterprise115
/desktoplaunch/jsp/ce

12 Click OK to confirm the replacement.
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13 Copy this file from the DecisionCenter installation media:

\\..\ITPA\ITPA-SM\BOCustomization\desktoplaunch\scripting
\aa-linkbar.js 

To this application server directory: 

./../Tomcat/webapps/businessobjects/enterprise115
/desktoplaunch/scripting

14 Click OK to confirm the replacement.

15 Navigate to this DecisionCenter installation media directory: 

\\..\ITPA\ITPA-SM\BOCustomization\desktoplaunch\viewers
\cdz_adv

Copy each file:

— viewCDZDocument.jsp

— viewReport.jsp

To this application server directory: 

./../Tomcat/webapps/businessobjects/enterprise115
/desktoplaunch/viewers/cdz_adv

16 Click OK to confirm each replacement.

17 Run this script to start the Tomcat service:

./../Tomcat/bin/startup.sh

18 Start a browser session to test the application.

19 Type the following URL. Modify it to point to the BusinessObjects 
Enterprise XI web server and the assigned port number:

http://BusinessObjects_ application_server:port number
/dswsbobje/services 

Task 15: Configure Time Zones

DecisionCenter relies on accurate time information to apply rules and 
calculate impact. All tools must have the same time zone configuration to 
ensure this accuracy. 
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You must configure the correct time zone parameter on these three servers:

• The application server

• The data warehouse server

• The Optimization engine server 

Follow these steps to configure the application server.

1 Open this file with a text editor: 

\\..\Tomcat\webapps\decisionCenter\WEB-INF\common.properties

2 Change this value:

database.timezone=GMT

To

database.timezone=GMT+/-nn

where nn is a numeric value for the number of time zones displaced from 
Greenwich Mean Time for your local time zone. For example, GMT-5 is the 
displacement for Eastern Standard Time in North America.

3 Save and close the file.

Task 16: Configure Properties Files

Under certain circumstances, you must change the parameters in two 
properties files.

hibernate.properties

If your RDBMS is Oracle, follow these steps.

1 Run this script to stop the Tomcat service:

./../Tomcat/bin/shutdown.sh

2 Open this file with a text editor:

./../Tomcat/webapps/decisionCenter/WEB-INF/
hibernate.properties

3 Remove the pound sign (#) from this statement:

#hibernate.dialect=org.hibernate.dialect.Oracle9Dialect
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4 Insert a pound sign (#) at the beginning of this statement:

hibernate.dialect=org.hibernate.dialect.SQLServerDialect

5 Verify that the result looks like this:

#hibernate.dialect=org.hibernate.dialect.SQLServerDialect
hibernate.dialect=org.hibernate.dialect.Oracle9Dialect

6 Save and close the file.

jmx.properties

If the Optimization engine is not installed on the application server, follow 
these steps.

1 Open this file with a text editor:

./../Tomcat/webapps/decisionCenter/WEB-INF/jmx.properties

2 Locate this parameter:

localhost:9999

3 Replace this with the server URL and port number of the Optimization 
engine server.

4 Save and close the file.

Make sure that the server URL and port number match the server URL and 
port number specified in the jmx.properties file on the Optimization 
engine server.

Task 17: Update the jaas.config File

The jaas.config file contains the information to connect to BusinessObjects 
using LDAP or Active Directory authentication. You must edit the parameters 
to point to the LDAP or Active Directory server and specify the administrative 
logon and password.

LDAP Users

1 Open this file with a text editor:

./../Tomcat/webapps/decisionCenter/WEB-INF/jaas.config
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2 Locate the dpJndi section.

3 Edit the user.provider.url parameter. Identify the fully qualified name 
of the LDAP server that you specified in Task 2: Configure LDAP on 
page 80, and the assigned server port. For example:

user.provider.url=”ldap://ldap.server:port_number/
ou=people,dc=server”

4 Edit the uid value in the security.principal parameter. Identify the 
administrative logon that you specified for the LDAP server. For example:

security.principal="uid=admin,ou=administrators,ou=topologyma
nagement,o=netscaperoot" 

5 Edit the security.credentials parameter. Specify the LDAP 
administration (or designated account) password. For example:

security.credentials="password" 

6 Edit the group.provider.url parameter. Identify the fully qualified 
name of the LDAP server that you specified in Task 2: Configure LDAP on 
page 80, and the assigned server port. For example:

group.provider.url=”ldap://server_name.xx.yy.com:port_number/
OU=Groups,OU=server_name,DC=xx,DC=yy,DC=com”

7 Save and close the file.

Active Directory Users

1 Open this file with a text editor:

./../Tomcat/webapps/decisionCenter/WEB-INF/jaas.config

2 Locate the QAAD section.

You can locate suffix information in the Directory Server Settings of 
the LDAP configuration procedures.

You can locate suffix information in the Directory Server Settings of 
the LDAP configuration procedures.
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3 Edit the user.provider.url parameter. Identify the fully qualified name 
of the Active Directory server that you specified in Task 2: Configure 
Active Directory for Business Objects on page 82, and the assigned server 
port. For example:

user.provider.url=”ldap://server_name.xx.yy.com:port_number/
OU=Users,OU=server_name,DC=xx,DC=yy,DC=com”

4 Edit the security.principal parameter. Identify the administrative 
logon that you specified for the Active Directory server. For example:

security.principal="CN=admin,ou=Users,OU=server_name,DC=xx,
DC=yy,DC=com" 

5 Edit the security.credentials parameter. Specify the LDAP 
administration (or designated account) password. For example:

security.credentials="password" 

6 Edit the group.provider.url parameter. Identify the fully qualified 
name of the Active Directory server that you specified in Task 2: Configure 
Active Directory for Business Objects on page 82, and the assigned server 
port. For example:

group.provider.url="ldap://server_name.xx.yy.com:port_number/
OU=Groups,OU=server_name,DC=xx,DC=yy,DC=com"

7 Examine the remaining parameters to make sure they are correct for your 
environment.

8 Save and close the file.

Task 18: Start the Server

Run this script to start the Tomcat service:

./../Tomcat/bin/startup.sh 
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WebSphere Installation Checklist

Print this checklist to use during the installation process. As you finish each 
task, mark it finished. Complete these tasks for the IBM WebSphere 
application server installed on a server with an AIX operating system. 

For more information, see the distributed server configuration diagram on 
page 18. You can also see the BusinessObjects XI R2 documentation for more 
information about configuring the application server.

 Task 1: Create the Directory Structure on page 142.

 Task 2: Create the Environment Variables on page 143.

— Step 1: Identify the RDBMS on page 143.

— Step 2: Define the Library Path on page 143.

 Task 3: Copy the Property Files on page 144.

 Task 4: Define the JDBC Connection on page 144.

— Step 1: Identify Your RDBMS on page 144.

— Step 2: Identify the Database Connection on page 145.

— Step 3: Define the Database Server on page 146.

— Step 4: Define the Port Number on page 146.

— Step 5: Specify the URL on page 146.

 Task 5: Copy the Required Library on page 147.

 Task 6: Define the Path to the Configuration Directory on page 148.

 Task 7: Configure Performance Manager on page 148.

 Task 8: Deploy the DecisionCenter WAR File on page 149.

 Task 9: Customize the DecisionCenter Configuration on page 151

 Task 10: Customize Business Objects on page 151.

 Task 11: Configure JAAS on page 153.

 Task 12: Configure Time Zones on page 155.

 Task 14: Start the Server on page 156.
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Before You Begin

Make sure that you have:

• Administrative rights to WebSphere application and AIX.

• Connectivity between WebSphere and the AIX operating system.

• A good working knowledge of deploying applications in an AIX 
environment.

Task 1: Create the Directory Structure

1 Create this directory to contain the BusinessObjects Performance 
Manager configuration files: 

./../installedApps/node-cell./af_config/

2 Copy all of the .properties files from this BusinessObjects directory:

\\..\Business Objects\Performance Management 11.5

To this application server directory:

./../installedApps/node-cell./af_config

3 Create this directory to store DecisionCenter WAR files: 

./../installedApps/node-cell./DecisionCenter_war/

4 Create this directory to store .jar files: 

./../installedApps/node-cell./shared/lib/

5 Copy this file from the BusinessObjects server:

\\..\Business Objects\BusinessObjects Enterprise 11.5\java
\applications\cewcanative.jar

To this application server directory:

./../installedApps/node-cell./shared/lib
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Task 2: Create the Environment Variables

1 Start a browser session. 

2 Type the URL to connect to the WebSphere administration console. For 
example: 

server.name:admin_port_number/ibm/console

3 Log on with your administrative credentials.

4 From the left navigation pane, click Environment > WebSphere Variables.

Step 1: Identify the RDBMS

1 Click New. 

2 Type an identifier in the Name field. For example: 

Oracle_JDBC_Driver 

3 Type the path to the driver. For example:

./../app/oracle/10gClient/jdbc/lib

4 Type an optional Description.

5 Click Apply.

6 In the Messages box, click Save to apply the changes.

7 Click Save again.

Step 2: Define the Library Path

1 From the same WebSphere Variables section of the WebSphere 
administration console, click New.

2 Type LD_LIBRARY_PATH in the Name field.

3 Type this path into the Value field:

 ./../installedApps/node-cell./bobje/enterprise115/aix_rs6000

4 Type an optional Description.

5 Click Apply.
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6 In the Messages box, click Save to apply changes.

7 Click Save again.

Task 3: Copy the Property Files

1 Click New.

2 Type af.configdir in the Name field. The identifier must match the name 
specified in step 1 on page 142.

3 Type the path where the .properties files reside. For example:

./../installedApps/node-cell./af_config/

4 Type an optional Description.

5 Click Apply.

6 In the Messages box, click Save to apply changes.

7 Click Save again.

Task 4: Define the JDBC Connection

From the left navigation pane, click Resources > JDBC Providers.

Step 1: Identify Your RDBMS

1 Click New.

2 Select Oracle as the database type from the dropdown list.

3 Select Oracle JDBC Driver as the provider type from the dropdown list.

4 Select the implementation type. This is the connection pool data source.

5 Click Next. WebSphere populates some of the General Properties fields 
automatically  depending on what you selected in Steps 3 and 4.

6 Type an optional Description.

7 The class path automatically matches the RDBMS selection. In this case, 
it should be: 

${ORACLE_JDBC_DRIVER_PATH}/ojdbc14.jar 
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If this is not correct, replace it with the correct path. For example:

./../apploracle/10gclient/jdbc/lib/ojdbc14.jar

8 The Implementation class name is also based on the database type that 
you selected. If you change the automatic selection, the results are 
unpredictable. In this case, verify that this is the Implementation class 
name: 

oracle.jdbc.pool.OracleConnectionPoolDataSource 

9 Click Apply.

10 In the Messages box, click Save to apply changes.

11 Click Save again.

Step 2: Identify the Database Connection

1 Click the JDBC driver name that you just defined.

2 From the Additional Properties section, click Data sources (Version 4).

3 Click New.

4 Although the JNDI name is specified, you must change it to jdbc/dc.

5 Leave Category field blank.

6 Type the Database name. For example: rds_db. 

This should be the same name specified in the installation and when you 
configure the database connectors.

7 Type the Default user ID for the database. For example: rds_dba.

8 Type the Default password. If you do not have a password assigned, leave 
the field blank.

9 Click Apply.

10 In the Messages box, click Save to apply changes.

11 Click Save again.

12 From the JDBC Providers page, select the JDBC connection that you just 
defined.

The related driver files must be resident on this AIX server for 
WebSphere to find the correct path.
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13 Click Test Connection. If an error message appears, repeat the steps in this 
section.

Step 3: Define the Database Server

1 Click the name of the JDBC connection.

2 From the Additional Properties section, click Custom Properties.

3 Click New.

4 Type a Name to identify the database server. For example: dbServer.

5 Type a Value for the server name that is the identifier for the database 
server. For example: server.name.

6 Type an optional Description.

7 The Type is selected automatically.

8 Click Apply.

9 In the Messages box, click Save to apply changes.

10 Click Save again.

Step 4: Define the Port Number

1 Click New.

2 Type an identifier for the port in the Name field. For example: dbPort.

3 Type the actual database port number in the Value field. For example: 
12345.

4 Click Apply.

5 In the Messages box, click Save to apply changes.

6 Click Save again.

Step 5: Specify the URL

1 Click New.

2 Type URL in the Name field.
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3 Type the Oracle JDBC URL in the Value field. For example:

jdbc:oracle:thin:@server_name:1521:ORCL 

4 Click Apply.

5 Click Save.

6 Click Save again.

Task 5: Copy the Required Library

1 From the WebSphere administration console, click Servers > Application 
servers.

2 Click the server name.

3 On the Configuration tab, in the Server Infrastructure section, expand the 
Java Process Management node.

4 Click Process Definition.

5 In the Additional Properties section, click Java Virtual Machine.

6 Type the Classpath recommended by the Business Objects documentation. 
For example: 

./../installedApps/node-cell/shared/lib/cewcanative.jar

7 In the Boot Classpath field, type the path recommended by the Business 
Objects documentation. For example: 

./../installedApps/node-cell/bobje/enterprise115/aix_rs6000

8 In the Debug arguments field, the debug options are optional. You can 
accept the default options.
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9 In the Generic JVM arguments, type the path to the configuration directory. 
For example: 

-Djava.library.path=/app/WAS6/profiles/default/installedApps
/qaaix53-0 1Node01Cell/businessobjects.ear
/webcompadapter.war:-Daf.configdir=/app/WAS6/profiles/default
/installedApps/node-cell/af_config

10 Click Apply.

11 In the Messages box, click Save to apply changes.

12 Click Save again.

Task 6: Define the Path to the Configuration Directory

1 In the Additional Properties section, click Custom Properties.

2 Click New.

3 Type the Name of the configuration directory.

4 Type the path to the configuration in the Value field. For example: 

./../installedApps/node-cell/af_config

5 Click Apply.

6 In the Messages box, click Save to apply changes.

7 Click Save again.

Task 7: Configure Performance Manager

1 Navigate to the directory that contains the BusinessObjects Performance 
Manager configuration files. For example: 

./../installedApps/node-cell./af_config/

2 Open the InitConfig.properties file with a text editor.

3 Type the path that points to the BusinessObjects server in the CMSName 
and CMSClusterName fields.
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Task 8: Deploy the DecisionCenter WAR File

The DecisionCenter application is a web archive (WAR) file on the 
DecisionCenter installation media. The installation process prompts you to 
store the WAR file in the appropriate web server directory. The web 
application server deploys the file. 

1 Insert the DecisionCenter installation media in your hard drive on a 
Windows workstation. The installer starts automatically, or you can click 
Autorun.exe to start the installer.

2 Click the Web Application tab.

3 Click DecisionCenter Web Interface.

4 Copy decisionCenter.war and transfer it into the AIX installation 
directory that you created in step 3 on page 142. For example: 

./../installedApps/node-cell./DecisionCenter_war.

5 Copy these files into the same directory:

— \\..\Business Objects\BusinessObjects Enterprise 
11.5\java\applications\webcompadapter.war

— \\..\Business Objects\BusinessObjects Enterprise 11.5\Web 
Services\en\dswsbobje.war

— \\..\Business Objects\BusinessObjects Enterprise 
11.5\java\applications\desktop.war

6 From the WebSphere administration console, click Application > Install New 
Application.

7 Click Remote files system.

8 Click Browse to locate the directory with the WAR files. For example: 

./../installedApps/node-cell./DecisionCenter_war

9 Select a WAR file from Table 23. Select one file at a time in the specified 
order.
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10 Specify the Context root for the selected file using the information in the 
following table.

11 Click Next.

12 Click Next to use the default bindings and mappings.

13 Click Continue on the Application Security Warnings screen.

14 Click Next to accept the Select installation options.

15 To map the application modules to a server, select the server where 
DecisionCenter will run from the list of servers. For more information, 
contact your AIX administrator. 

16 Click Apply.

17 Select the checkbox for the WAR file that you are deploying.

18 Click Next.

19 Select the Virtual Host for the application module that you are deploying 
from the drop-down list. Make sure that all deployed WAR files are on the 
same host. For example: select default_host. The admin_host is where 
the WebSphere administration console resides, and it has a different port 
number. HP recommends that you do not deploy your DecisionCenter 
WAR files on the admin host.

20 Select the appropriate check box and click Next.

21 You can ignore the warning on the Summary screen. Click Finish. 
WebSphere deploys the WAR file and displays a log. Look for a success 
message.

22 Click the Save to Master Configuration message in the log.

23 Click Save.

Table 23 Deployment Order

WAR File Context Root

webcompadapter.war /businessobjects

dswsbobje.war /dswsbobje

desktop.war /businessobjects/enterprise115/desktoplaunch

decisionCenter.war /decisionCenter
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24 If a conflicts log appears, review the log for override messages that need 
your attention. These messages appear when you re-deploy a new set of 
files over an existing set of files. 

25 Click Save to override the existing files.

26 For each WAR file, repeat Step 9 on page 149 – Step 25.

Task 9: Customize the DecisionCenter Configuration

1 Click Applications > Enterprise Applications.

2 Click decisionCenter.war.

3 In the Related Items section, click Web modules.

4 Click decisionCenter.war.

5 From the Class loader mode drop-down list, select Parent Last.

6 Click Apply.

7 In the Messages box, click Save to apply changes.

8 Click Save again.

Task 10: Customize Business Objects

Complete these tasks on the application server.

1 Use a text editor to open this file: 

./../installedApps/node-cell/dswsbobje_war.ear/dswsbobje.war
/WEB-INF/classes/dsws.properties

2 Change the domain value to point to your target Business Objects server. 
For example:

domain=Business_Objects_server_name_URL
report.server=DecisionCenter_server_name_URL

3 Save and close the file.
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4 Open each *.wsdl file in the same directory. Change the <soap:address> 
parameter in each file in Table 24 to point to the correct server.

5 Save and close the file.

6 To apply Business Objects InfoView customization for DecisionCenter, 
replace the existing Business Objects files with files from the 
DecisionCenter installation media.

Table 24 WSDL Parameters

.wsdl File Edit This Parameter

publish.wsdl <soap:address location=
"http://server_name:port_number/dsws/
services/publish" />

queryservice.wsdl <soap:address location=
"http://server_name:port_number/dsws/
services/queryservice" />

reportengine.wsdl <soap:address location=
"http://server_name:port_number/dsws/
services/reportengine" />

session.wsdl <soap:address location=
"http://server_name:port_number/dsws/
services/session" />

Table 25 Customized Business Objects Files

DecisionCenter File

Replace in
./../installedApps/node-cell/
desktop_war.ear/desktop.war

cestartpage.jsp /jsp/ce

aa-linkbar.js /scripting
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Task 11: Configure JAAS

You must configure the Java Authentication and Authorization Service 
(JAAS) on the application server to authenticate users and grant log-on 
permission.

1 Start a browser session. 

2 Type the URL to connect to the WebSphere administration console. For 
example: 

server_name:9999/ibm/console

Where 9999 is the admin port number.

3 Log on with your administrative credentials.

4 From the left navigation pane, click Security > Global Security.

5 From the Authentication section of the WebSphere administration 
console, expand JAAS Configuration and click Application Logins.

6 Click New.

7 Type dpJndi in the Alias field.

8 In the Addition Properties section, click JAAS login Modules.

9 Click New.

home.jsp /InfoView/main

aa-promptcontent.jsp
appsContentFrame.jsp
headerPlusAF.jsp
performanceManagement
Home.jsp
workspaceHeaderAF.jsp

/jsp

viewCDZDocument.jsp
viewReport.jsp

/Viewers/cdz_adv

Table 25 Customized Business Objects Files

DecisionCenter File

Replace in
./../installedApps/node-cell/
desktop_war.ear/desktop.war
Configure the Application Server 153



10 Type the following in the Module class name field:

com.hp.ov.cwc.security.jaas.JndiLoginModule

11 Select REQUIRED in the Authentication strategy field.

12 Click Custom Properties.

13 Click New.

14 Type group.provider.url in the Name field.

15 Type the URL of the LDAP server in the Value field. For example:

ldap://server_name:99999/ou=xxxxx,dc=server,dc=name,dc=com

Where 

server_name is the DNS domain server
99999 is the port number
ou= organizational_unit
dc= domain_name_component

16 Click Apply.

17 Click New.

18 Type group.search.objectClass in the Name field.

19 Type groupOfUniqueNames in the Value field.

20 Click Apply.

21 Click New.

22 Type security.credentials in the Name field.

23 Type the password in Value field.

24 Click Apply.

25 Click New.

26 Type security.principal in the Name field.

27 Type your security information in the Value field. For example:

uid=admin, ou=group_name, ou=group_name, o=base_domain

28 Click Apply.

29 Click New.

30 Type user.provider.url in the Name field.
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31 Type the URL in the Value field. For example: 

ldap://server_name:99999/ou=xxxxx, dc=server, dc=name, dc=com

32 Click Apply.

33 Click Save.

34 Click Save again.

Task 12: Configure Time Zones

DecisionCenter relies on accurate time information to apply rules and 
calculate impact. All tools must have the same time zone configuration to 
ensure this accuracy. 

You must configure the correct time zone parameter on these three servers:

•  The application server

• The data warehouse server

• The Optimization engine server 

Follow these steps to configure the application server.

1 Open this file with a text editor: 

./../installedApps/node-cell/decisionCenter_war.ear
/decisionCenter_war/WEB-INF/common.properties

2 Change this value:

database.timezone=GMT

To

database.timezone=GMT+/-nn

where nn is a numeric value for the number of time zones displaced from 
Greenwich Mean Time for your local time zone. For example, GMT-5 is the 
displacement for Eastern Standard Time in North America.

3 Save and close the file.
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Task 14: Start the Server

1 From your AIX command line window, navigate to the /bin directory.

2 Run this script to start the server:

./startServer.sh server_name
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9 Configure DecisionCenter

In Chapter 8, Configure the Application Server, you deployed the 
DecisionCenter WAR file. This file contains JavaServer pages, configuration 
files, code libraries, and other support files that create a web application.

Before you begin configuring DecisionCenter, ensure that you have a valid 
authorization code. If necessary, contact HP Software Support 
(www.hp.com/go/hpsoftwaresupport). 

DecisionCenter Installation Checklist

Print this checklist to use during the installation process. As you complete 
each task, mark it finished. Complete these tasks on the application server. 

 Task 1: Stop the Application Server on page 158.

 Task 2: Configure Time Zones on page 158.

 Task 3: Start the Application Server on page 159.

 Task 4: Verify the Results on page 160.
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Task 1: Stop the Application Server

Depending on your application server platform, invoke one of these commands 
to stop the application server. 

Task 2: Configure Time Zones

DecisionCenter relies on accurate time information to apply rules and 
calculate impact. All tools must have the same time zone configuration to 
ensure this accuracy. You configured a time zone parameter in Chapter 3, 
Build the Data Warehouse after installing Connect-It. The next step is to 
configure the time zone for the DecisionCenter application.

1 Open this file with a text editor: 

Windows:

\\..\Tomcat\webapps\decisionCenter\WEB-INF\common.properties

HP-UX:

./../Tomcat/webapps/decisionCenter/WEB-INF/common.properties

AIX:

./../installedApps/node-cell//decisionCenter_war.ear/
decisionCenter.war/WEB-INF/common.properties

Table 26 Stop the server

Operating System Command

Windows From the Windows Start menu, click Control Panel > 
Administrative Tools > Services > Stop

HP-UX Run this script:

./../Tomcat/bin/shutdown.sh

AIX Run this script:

./stopServer.sh server_name
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2 Change this value:

database.timezone=GMT

To

database.timezone=GMT+/-nn

Where nn is a numeric value for the number of time zones displaced from 
Greenwich Mean Time for your local time zone. For example, GMT-5 is the 
displacement for Eastern Standard Time in North America.

3 Save and close the file.

Task 3: Start the Application Server

Depending on your application server platform, invoke one of these commands 
to start the application server. 

Table 27 Start the server

Operating System Command

Windows From the Windows Start menu, click Control Panel > 
Administrative Tools > Services > Start

HP-UX Run this script:

./../Tomcat/bin/startup.sh

AIX Run this script:

./startServer.sh server_name
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Task 4: Verify the Results

It is important to test the installation and verify if there is communication 
among the Business Objects Enterprise XI server, the remote application 
server, and the DecisionCenter application. 

1 Type the following URL and modify it to point to the server and the 
assigned port number:

http://application.server:port_number/decisionCenter

2 Click Go.

3 Log on with your user name and password that you defined in 
Chapter 6, Security. The default user name is dcuser.

4 Verify that you can expand the Navigation tree and view both the Analytic 
and Optimization nodes.

5 Click Impact and Optimization > Impact Definition > Calculations. You should 
see the Calculation interface where you can define a new impact 
calculation.

If you cannot connect, review the steps in this chapter and ensure that you 
restart your application server (Tomcat or Websphere) before you start 
DecisionCenter.
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10 Install the Optimization Engine

The chapter describes the software installation and configuration required to 
run the DecisionCenter Optimization engine. The installation includes data 
mining components that must reside on the data warehouse server. You 
should complete these installation tasks on the data warehouse server. After 
the initial installation, you can move the Optimization engine to a 
high-capacity server for production efficiency. For more information, see the 
distributed server configuration diagram on page 18.

Optimization Installation Checklist

Print this checklist to use during the installation process. As you complete 
each task, mark it finished. 

 Task 1: Stop the Application Server on page 162

 Task 2: Install the Optimization Engine on page 162.

 Task 3: Configure the Memory Allocation on page 164.

 Task 4: Configure Time Zones on page 164.

 Task 5: Move the Optimization Engine (Optional) on page 165.

 Task 6: Configure Concurrent Simulations on page 166.

 Task 7: Restart the Application Server on page 166.
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Task 1: Stop the Application Server

Before you install the Optimization engine, invoke one of these commands to 
stop the application server. 

Task 2: Install the Optimization Engine

Before you begin, ensure that you have a valid authorization code. If 
necessary, visit the HP Software Support (www.hp.com/go/
hpsoftwaresupport). To correct any path or setting during the installation, 
click Back.

1 Insert the DecisionCenter installation media in your hard drive. The 
installer starts automatically, or you can click Autorun.exe to start the 
installer.

2 Click the Optimization Engine tab.

3 Click Optimization to start the installer.

4 Type the authorization code and click Next.

5 Accept the End User License Agreement and click Next.

Table 28 Stop the server

Operating System Command

Windows From the Windows Start menu, click Control Panel > 
Administrative Tools > Services > Stop

HP-UX Run this script:

./../Tomcat/bin/shutdown.sh

AIX Run this script:

./stopServer.sh server_name
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6 DecisionCenter has a default installation directory. Do one of the 
following:

• Accept the default installation directory and click Next.

• Click Change to choose another directory. then click OK, and click Next.

7 DecisionCenter locates your Java installation directory. Do one of the 
following:

• Accept the default destination directory and click Next.

• Click Change to choose another directory. then click OK, and click Next.

8 Select your RDBMS and click Next.

9 If you selected Microsoft SQL Server, choose your JDBC driver and click 
Next. 

10 DecisionCenter locates your JDBC directory. Do one of the following:

• Accept the default destination directory and click Next.

• Click Change to choose another directory. then click OK, and click Next.

11 Use the information that you gathered in Step 2: Collect Installation 
Information on page 43 to specify your RDBMS settings.

12 Click Next.

13 DecisionCenter displays these settings. Click Next or Back to correct 
errors. 

14 Specify the same server name and port number for the Optimization 
engine and click Next.

15 The installer displays the Optimization settings. Click Next or Back to 
correct errors. 

16 Click Install.

17 Click Finish and Exit Install.
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Task 3: Configure the Memory Allocation

If you process large data sets, you may want to increase the amount of 
available memory for the Optimization engine.

1 Open this file with a text editor: 

\\..\HP\DecisionCenter 2.00\Optimization\bin
\run_optimizer.bat

2 Change this value:

java -Xmx1250m

To

java -Xmxnnnnm

3 Save and close the file.

Task 4: Configure Time Zones

DecisionCenter relies on accurate time information to apply rules and 
calculate impact. All tools must have the same time zone configuration to 
ensure this accuracy. You configured a time zone parameter in Chapter 3, 
Build the Data Warehouse after installing Connect-It, and in Chapter 9, 
Configure DecisionCenter. The next step is to configure the time zone for the 
Optimization engine.

1 Open this file with a text editor: 

\\..\HP\DecisionCenter 2.00\Optimization\config
\common.properties

2 Change this value:

database.timezone=GMT

To

database.timezone=GMT+/-nn

Where nn is a numeric value for the number of time zones displaced from 
Greenwich Mean Time for your local time zone. For example, GMT-5 is the 
displacement for Eastern Standard Time in North America.
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3 Save and close the file.

Task 5: Move the Optimization Engine (Optional)

You can improve simulation performance by running the Optimization engine 
on a high capacity Windows or Unix server. 

Windows Server

1 Navigate to this directory:

\\..\HP\DecisionCenter 2.00\Optimization

2 Compress the Optimization folder and all subordinate files and folders 
into a zip archive.

3 Transfer the .zip archive to the destination server.

4 On the destination Windows server, unzip the archive into the location of 
your choice. For example:

\\..\DecisionCenter 2.00

Unix Server

Your JAVA_HOME environment variable must point to a compatible Sun JDK 
or JRE. For more information, see the DecisionCenter 
Support Matrix on the HP Software Support web site (http://
support.openview.hp.com/sc/support_matrices.jsp).

1 Navigate to this directory on the data warehouse server:

\\..\HP\DecisionCenter 2.00\Optimization

2 Compress the Optimization folder and all subordinate files and folders 
into a standard tar file using a third party tar compression tool.

3 Transfer the .tar file to the destination server.

4 On the destination Unix server, extract the files from the archive into the 
location of your choice. For example:

./../DecisionCenter 2.00
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Task 6: Configure Concurrent Simulations

If you install the Optimization engine on a multi-processor server, you can 
improve simulation performance by increasing the number of concurrent 
simulations.

1 Open this file with a text editor: 

\\..\HP\DecisionCenter 2.00\Optimization\config
\optimizer.properties

2 Change this value:

maximumConcurrentSimulations=1

To

maximumConcurrentSimulations=nn

Where nn is a numeric value equal to the number of processors on the 
server. If you increase the number on a single processor server, results are 
unpredictable. There may be no effect, or even degraded performance.

3 Save and close the file.

Task 7: Restart the Application Server

1 For Tomcat, clear the cache by deleting the files in this directory:

\\..\Tomcat\work\Catalina\localhost\DecisionCenter

Websphere clears the cache automatically.
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2 Invoke one of these commands to start the application server. 

Table 29 Start the server

Operating System Command

Windows From the Windows Start menu, click 
Control Panel > Administrative Tools > Services > 
Start

HP-UX Run this script:

./../Tomcat/bin/startup.sh

AIX Run this script:

./startServer.sh server_name

Although you finished installing the Optimization engine, you must wait to 
start it until you complete Task 4: Load the DecisionCenter Tables on 
page 194.
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11 Data Mining

Before you begin, ensure that you complete the installation tasks in the prior 
chapters. Data mining tasks assume that you have some ServiceCenter or 
Service Manager administration knowledge and that you are skilled at 
running SQL queries. Complete the data mining tasks on the data warehouse 
server.

Data Analysis

The most time-consuming steps to prepare for DecisionCenter BIA and 
Optimization are the preparation activities for existing data, and decisions 
required to populate new tables and fields with new data. For example, 
DecisionCenter requires that each incident be associated with a business 
service or value center, directly or indirectly through an associated 
configuration item. Existing incident data may not have those association 
built into each incident record. For BIA and Optimization, you must create 
those associations.

Review the checklist of business and data preparation decisions. You may 
require the combined expertise of a ServiceCenter or Service Manager 
Administrator, Database Administrator, and Professional Services personnel 
to arrive at the decisions and complete the required actions.

Business Services and Value Centers

DecisionCenter BIA and Optimization relies heavily on the concepts of 
business services and value centers. It is important that you understand how 
they impact your organization and daily activities.
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Business Services

A business service is the combination of one or more business applications 
plus the supporting configuration items that enable delivery of the business 
service to the customer. The products that IT offers its customers are internal 
and external business services. Business services often have one or more 
associated value centers.

Enterprise resource planning (ERP) is a good example of a business service. 
ERP is a business management system that integrates all facets of the 
business, including planning, manufacturing, sales, and marketing. There can 
be many component business applications such as inventory control, order 
tracking, customer service, finance, and human resources.

DecisionCenter creates the PREP_BUSINESS_SERVICE_V view of business 
services when you install BIA components. This view is based on information 
in the ServiceCenter or Service Manager DEVICE_D table and displays all 
records where TYPEPRGN=’bizservice’.

Value Centers

A value center is that part of your business that provides a product or service 
to an internal or external customer. It can be an entire business unit, a cost or 
profit center, or a functional department. It is an entity that adds value 
directly, or indirectly, to your customer community. 

It is easy to see that any revenue producing business unit can be described as 
a value center. However, cost centers also affect corporate value. For example, 
a finance department is a value center. It does not sell a product to an external 
customer, but its forecasts, balance sheets, public statements and other 
outputs affect the profitability of the enterprise.

IT is another example of a value center. How effectively it meets its Service 
Level Agreements obligations affects the performance and profitability of the 
customers that it serves.

DecisionCenter automatically creates value centers from all defined 
ServiceCenter or Service Manager departments.
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Business Services and Value Centers

An enterprise business service can have many associated value centers. A 
Claims service is an example of a business service; Claims entry, Claims 
processing, and Claims arbitration are examples of value centers that support 
the Claims business service.

Data Analysis Checklist

Gathering this information may be the most difficult aspect of preparing for 
the actual installation. These are business decisions that require a broad 
range of business expertise at the operational and executive levels. It is 
advisable to consult these experts before you translate these decisions into 
physical data.

 What is the range of data that I want to work with? Should it extend over 
a month, a quarter, or a year?

 What is the beginning date of relevant incidents?

 What are your identifiable business services? This needs to be a specific 
list, preferably in a database table. You may need to import this 
information into the DecisionCenter data warehouse.

 Which configuration items impact each business service when an outage 
occurs?

 What are your identifiable value centers? This needs to be a specific list, 
preferably in a database table. You may need to import this information 
into the DecisionCenter data warehouse.

The answers to these questions will help you customize the ETL and data 
analysis processes for your organization.
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Data Mining Checklist

Print this checklist to use during the data mining process. As you finish each 
task, check it as completed. Complete these tasks on the DecisionCenter data 
warehouse server. For more information, see the distributed server 
configuration diagram in Server Configuration on page 18. 

 Task 1: Customize Business Service Data on page 175.

 Task 2: Prepare the Data on page 175.

— Step 1: Identify the Target Range for Your Data on page 175.

— Step 2: Create the Problem PREP View on page 176.

— Step 3: Populate the Assignment Group PREP Table on page 177.

— Step 4: Populate the Operator PREP Table on page 178.

— Step 5: Populate the Assignment Shift PREP Table on page 181.

— Step 6: Populate the Business Service CI PREP Table on page 186.

— Step 7: Populate the Business Service Incident PREP Table on 
page 186.

— Step 8: Add Assignment Transitions on page 187.

— Step 9: Populate the Incident Exclusion PREP Table on page 189.

— Step 10: Add Full Time Equivalent (FTE) Employee Values on 
page 189.

 Task 3: Customize the Data Mapping on page 190.

— Step 1: Customize the Organization Table Mapping on page 190.

— Step 2: Customize Value Center Mappings on page 191.

— Step 3: Customize the Labor Cost on page 192.

— Step 4: Customize Incident Mapping on page 192.

— Step 5: Customize SLO Mapping on page 193.

 Task 4: Load the DecisionCenter Tables on page 194.

— Step 1: Load Data into the DecisionCenter Tables on page 194.

— Step 2: Run the Data Cleanup Script File on page 195.
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— Step 3: Point the Scenario to the ServiceCenter 6.2.2 Server on 
page 195.

— Step 4: Load Change Data into the DecisionCenter Tables on 
page 196.

 Task 5: Start the Optimization Engine on page 196.

 Task 6: Compute Time to Next Incident on page 197.

 Task 7: Verify the Results on page 202.
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Getting Started

A business service is the combination of one or more business applications 
plus the supporting configuration items that enable delivery of the business 
service to the customer. These can be internal or external business services. 
Business services often have one or more associated value centers. 
DecisionCenter uses these tables to add business service information to 
ServiceCenter or Service Manager incident data. 

Table 30 Business Service Customization

Table or View Populated With Data From Notes

business_service PREP_BUSINESS_SERVICE_V Customize before you begin 
Task 1: Customize Business 
Service Data on page 175.

business_service_type PREP_BS_TYPE_V

configuration_item PREP_CONFIG_ITEM_V

configuration_item_type PREP_CI_TYPE_V

businessservice_configitem PREP_BS_CI Customize when you 
populate the PREP_BS_CI 
table in Step 6: Populate 
the Business Service CI 
PREP Table on page 186.

incident_business_service PREP_BS_INCIDENT If necessary, customize 
when you populate the 
PREP_BS_INCIDENT 
table in Step 7: Populate 
the Business Service 
Incident PREP Table on 
page 186.

valuecenter_businessservice DEPT and COMPANY fields in 
the DEVICE_D table
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Task 1: Customize Business Service Data

PREP_BUSINESS_SERVICE_V is a view of business services defined in the 
ServiceCenter or Service Manager DEVICE_D table where 
TYPEPRGN=’bizservice’. If you decide to modify the view definition, make 
sure the view will return the same columns and type of information. Then 
recreate the view using the new definition.

Task 2: Prepare the Data

There are several steps to follow in this preparation phase that load data into 
DecisionCenter PREP tables. These are new tables that contain specialized 
ServiceCenter or Service Manager data. Each of the new tables contains data 
that is essential to advanced analysis, simulation, and optimization activities. 
In some cases, you will extract data from a native ServiceCenter or Service 
Manager field and populate a new field in a PREP table. In other cases, you 
will collect certain data from diverse ServiceCenter or Service Manager tables 
into a single new PREP table.

Step 1: Identify the Target Range for Your Data

This is a business decision. Evaluate the calendar interval that you want to 
see represented in the results. DecisionCenter will use all the ServiceCenter 
or Service Manager data related to an incident, such as clock time, problem 
records, service level agreements, and so on during this time period. 

For BIA, you must choose a start date for the period of time included in the 
historical impact analysis. For Optimization, you must choose a start date 
that encompasses incidents representing your current incident workflow. For 
example, if you made process or workflow changes that affect the elapsed time 
until an incident closes, you might want to use only incidents opened after the 
process or workflow changes occurred. 

If the BIA starting date and the Optimization starting dates are different, and 
you plan to run Optimization simulations, choose the most recent as the single 
start date.
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The resulting incident pool must contain one or more months of meaningful 
data to produce reliable results. It must also include the following attributes 
to calculate a meaningful historical impact analysis. 

• The PROBSUMM_D table must contain all the incidents:

— Open on or after the selected date.

— Open before and closed on or after the selected date.

• The PROBLEM and CLOCK_EVENTS tables must contain complete 
information about incidents that represent events that occurred on or 
after the selected date. 

You will set this date when you create the PREP_PROBSUMM_V view in the 
next step.

Step 2: Create the Problem PREP View

Follow these steps to create the PREP_PROBSUMM_V view. 

1 Locate the appropriate SQL template file for your environment on the 
DecisionCenter installation media. 

For Microsoft SQL Server, open:

\\BIA\SupportFiles\DatabaseFiles\mssql-templates.sql

For Oracle, open:

\\BIA\SupportFiles\DatabaseFiles\oracle-templates.sql

2 Search for the General Settings section.

3 Change the startSet variable to the date that you chose in Step 1: 
Identify the Target Range for Your Data on page 175.

Microsoft SQL Server example:

SET @startSet = 'yyyy-mm-dd';

Oracle example:

startSet varchar2(60):= 'yyyy-mm-dd';

4 Run the query statements that begin with $NAME=CREATE_VIEW.
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Step 3: Populate the Assignment Group PREP Table

Follow these steps to populate the PREP_ASSIGNMENT_GROUP table with 
valid assignment groups.

1 Locate the appropriate SQL template file for your environment on the 
DecisionCenter installation media. 

For Microsoft SQL Server, open:

\\BIA\SupportFiles\DatabaseFiles\mssql-templates.sql

For Oracle, open:

\\BIA\SupportFiles\DatabaseFiles\oracle-templates.sql

2 Search for the Updating PREP_ASSIGNMENT_GROUP section.

3 Run the query statements that begin with $NAME=AG_ADD.

Validate Assignment Groups

After you populate the PREP_ASSIGNMENT_GROUP table, make sure that 
the assignment groups in the table are valid groups that were part of the 
ServiceCenter or Service Manager assignment table. Records with valid 
groups will have a value of 1 in the VALID field. 

Invalid assignment groups can occur when the name was mis-typed by an 
operator, the group was deleted, the group was renamed, or the group was 
split into multiple groups.

1 Locate the appropriate SQL template file for your environment on the 
DecisionCenter installation media. 

For Microsoft SQL Server, open:

\\BIA\SupportFiles\DatabaseFiles\mssql-templates.sql

For Oracle, open:

\\BIA\SupportFiles\DatabaseFiles\oracle-templates.sql

2 Search for the Updating PREP_ASSIGNMENT_GROUP section.

3 Run the query statements that begin with $NAME=AG_VALID_NULL.
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4 Examine the resulting record where VALID is 0 or null and do the 
following:

a If the name was mis-typed and you know what it should be, change 
VALID to 1 and ALIAS_FOR to the correct group name.

b If the name was mis-typed and you do not know what it should be, do 
not change the VALID value of 0. If the value is null, change it to 0.

c If the group name was deleted from the current assignment table, but 
was once valid, change VALID to 1. 

Best practice: Update the REASON_DROPPED field with the value 
deleted for future reference.

d If the group name was changed to another name, change VALID to 1 
and ALIAS_FOR to the new assignment group name. 

Best practice: Update the REASON_DROPPED field with the value 
renamed for future reference.

e If the group was split into multiple sub-groups, change VALID to 1. 

Best practice: Update the REASON_DROPPED field with the value 
split for future reference.

f If the group name contains non-assignment group information, do not 
change the VALID value of 0.

Step 4: Populate the Operator PREP Table

Follow these steps to populate the PREP_OPERATOR table with information 
about operator incident interaction. 

1 Locate the appropriate SQL template file for your environment on the 
DecisionCenter installation media.

For Microsoft SQL Server, open:

\\BIA\SupportFiles\DatabaseFiles\mssql-templates.sql

For Oracle, open:

\\BIA\SupportFiles\DatabaseFiles\oracle-templates.sql

2 Search for the Updating PREP_OPERATOR section.

3 Run the query statements that begin with $NAME=OP_ADD.
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Optionally, on a data refresh, you might want to refresh the FOUND field to 
reflect whether the user is still in the operator table or not. In that case, run 
the query statements that begin with $NAME=OP_SET_FOUND.

Validate Operators

After you populate the PREP_OPERATOR table, you must ensure that the 
operators in the table are valid operators that were part of the ServiceCenter 
or Service Manager operator table. If the operator name is valid, the VALID 
field will have a value of 1. If the operator name is invalid, the VALID field will 
have a value of 0. If the VALID field contains a null value, it is assumed to be 1. 

Best Practice: All VALID fields should contain 1 or 0.

Invalid operators can occur when the operator name is mis-typed or part of an 
automated process. For validation purposes, if the same operator name 
appears in the SYSMODUSER field in a related table, you can assume it is a valid 
operator. The following steps check the operator name against the 
SYSMODUSER field in other tables and reduce the number of VALID fields that 
contain null values.

1 Locate the appropriate SQL template file for your environment on the 
DecisionCenter installation media.

For Microsoft SQL Server, open:

\\BIA\SupportFiles\DatabaseFiles\mssql-templates.sql

For Oracle, open:

\\BIA\SupportFiles\DatabaseFiles\oracle-templates.sql

2 Search for the Updating PREP_OPERATOR section.

3 To validate operators found in the SYSMODUSER column of the 
PROBSUMM_D table, run the query statements that begin with 
$NAME=OP_SET_VALID_PROBSUMM.

4 To validate operators found in the SYSMODUSER column of the PROBLEM 
table, run the query statements that begin with 
$NAME=OP_SET_VALID_PROBLEM.

5 To validate operators found in the SYSMODUSER column of the CLOCK_D 
table, run the query statements that begin with 
$NAME=OP_SET_VALID_CLOCK.
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6 To verify these operator names from other related tables (such as 
ACTIVITY), run the query statements that begin with 
$NAME=OP_SET_VALID_ACTIVITY.

7 To find the remaining VALID fields with no value, run the query 
statements that begin with $NAME=OP_VALID_NULL.

8 When the number of remaining records is manageable, you should be able 
to examine them individually and change the VALID value to 1 or 0. 

Identify Automated Process Operators

The AUTOMATIC_PROCESS flag value must be 1 if the operator is part of a 
ServiceCenter or Service Manager automatic process. It can be an internal 
process, a background process., or an external process that involves other 
HP software. Automatic process operators should be omitted from 
DecisionCenter calculations and simulation activities because these operators 
do not have incident assignments. If the AUTOMATIC_PROCESS field contains a 
null value, it is assumed to be 0. 

Best Practice: It is important that all AUTOMATIC_PROCESS fields contain 1 or 0. 
You should run a query to identify any AUTOMATIC_PROCESS fields that contain 
null values.

Is an Operator an Individual or a Group?

DecisionCenter produces the best results when each operator works 
independently and ServiceCenter or Service Manager captures the amount of 
time spent on each incident. You should run a query to identify any 
INDIVIDUAL fields that contain null values. Valid values are 1 for individual 
operators or 0 for an operator group.

Best Practice: Create unique operator IDs for each operator in ServiceCenter or 
Service Manager; do not assign a single operator name to a group of operators.

Identify Operators with Multiple Operator Names

One ServiceCenter or Service Manager user may have multiple operator 
names because they have multiple user roles. For any user with more than one 
operator name, you must choose which is to be the primary operator name. In 
all other records for this user, ensure that the primary name is the value in 
the ALIAS_FOR field.
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Choose one or more of these methods to identify operators with multiple 
operator names.

1 Locate the appropriate SQL template file for your environment on the 
DecisionCenter installation media.

For Microsoft SQL Server, open:

\\BIA\SupportFiles\DatabaseFiles\mssql-templates.sql

For Oracle, open:

\\BIA\SupportFiles\DatabaseFiles\oracle-templates.sql

2 To run a query on the FULL_NAME field in the OPERATOR_D table to find 
individual operators with duplicate FULL_NAMEs:

a Search for the FULL_NAME section.

b Run the query statements that begin with 
$NAME=OP_DUP_FULLNAME. The query returns the FULL_NAME and 
the number of times it appears in the OPERATOR_D table.

c List the operator records that correspond to the list of FULL_NAMEs.

d For each FULL_NAME, decide whether the FULL_NAME is just an alias for 
another FULL_NAME. The objective is to identify alias operator names 
the primary operator name for each individual. 

e Set the ALIAS_FOR field in the PREP_OPERATOR table for the alias 
entries that reference the primary operator name. 

Step 5: Populate the Assignment Shift PREP Table

The PREP_ASSIGNMENT_SHIFT table must contain information about time 
zones and work schedules. There are several data mining tasks for this table 
to prepare it for DecisionCenter.

• Add Assignment Group Shifts on page 182.

• Assign Multiple Shifts on page 182.

• Associate a Valid Schedule on page 183.

• Set the Time Zone on page 184.
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Add Assignment Group Shifts

Every assignment group in the PREP_ASSIGNMENT_TRANSITION table 
must have one or more assignment shifts. Follow these steps to populate the 
PREP_ASSIGNMENT_SHIFT table.

1 Locate the appropriate SQL template file for your environment on the 
DecisionCenter installation media.

For Microsoft SQL Server, open:

\\BIA\SupportFiles\DatabaseFiles\mssql-templates.sql

For Oracle, open:

\\BIA\SupportFiles\DatabaseFiles\oracle-templates.sql

2 Search for the Updating PREP_ASSIGNMENT_SHIFT section.

3 Run the query statements that begin with $NAME=SHIFT_ADD. 

This script creates default assignment group shift records, one for each 
assignment group. For each record, the script sets the TZ_NAME field to <tbd>, 
and sets the SCHEDULE_NAME field with the corresponding assignment group 
CALENDAR_NAME field, or to <tbd> if the assignment group CALENDAR_NAME 
field is null.

You can add more shifts to the assignment groups as necessary.

Assign Multiple Shifts

It is possible to set up an assignment group with more than one shift. For 
example, for an assignment group that works 24x7, with significant 
differences in staffing during different shifts, DecisionCenter can produce 
more accurate results if you define the different shifts and their Full Time 
Equivalent (FTE) employees.

You can remove the default assignment shift for the assignment group in the 
PREP_ASSIGNMENT_SHIFT table and create your own shifts records.
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Associate a Valid Schedule

Some assignment shifts have a SCHEDULE_NAME value that does not match a 
valid schedule name in the CALDUTYHOURS table. You can locate the 
records by running the query SHIFT_UNKNOWN_SCHEDULES. This query 
returns a list of unmatched schedule names and the number of assignment 
shifts that reference each unmatched name.

Identify the Records with Invalid Schedules

Follow these steps to run the SHIFT_UNKNOWN_SCHEDULES query.

1 Locate the appropriate SQL template file for your environment on the 
DecisionCenter installation media.

For Microsoft SQL Server, open:

\\BIA\SupportFiles\DatabaseFiles\mssql-templates.sql

For Oracle, open:

\\BIA\SupportFiles\DatabaseFiles\oracle-templates.sql

2 Search for the Updating PREP_ASSIGNMENT_SHIFT section. 

3 Run the query statements that begin with 
$NAME=SHIFT_UNKNOWN_SCHEDULES. 

The query inserts a value of <tbd> into the invalid schedule field. You must 
analyze each record with a <tbd> value in the schedule field. For each record, 
you can resolve the <tbd> by applying the remedy described in one or more of 
the following cases.

Case 1: The Correct Schedule Is Not in the CALDUTYHOURS Table

In this case, the required schedule information is not in the 
CALDUTYHOURS table. Follow these steps to modify the schedules in the 
CALDUTYHOURS table and then re-create your assignment group records. 

1 Use the ServiceCenter or Service Manager client to add, change, or delete 
schedules in the CALDUTYHOURS table.

2 Use the ServiceCenter or Service Manager client to update the records in 
the assignment group table with the modified schedule information.

3 Re-run the Connect-It scenario file (dco_sc.scn) to refresh the 
DecisionCenter data warehouse. 
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4 Repeat Step 1 through Step 3 on page 183 to run the 
SHIFT_UNKNOWN_SCHEDULES query again to ensure that there are 
no unmatched schedules. If there are records with <tbd> in the schedule 
field, repeat this process until there are no invalid fields.

Case 2: Update the <tbd> Records Manually

If the CALDUTYHOURS table is correct, but there are <tbd> values in the 
schedule field, you can replace the missing schedule information in each 
affected record with a valid schedule values using a manual editing process. 

Case 3: Update the <tbd> Records With a Single Value

1 Identify the records that require manual updating with special schedule 
information.

2 Apply the steps in Case 1 and Case 2 until you have a set of records that 
should be populated with the same shift schedule value.

3 Locate the $NAME=SHIFT_SET_SCHEDULE section.

4 Edit the default schedule value with a valid schedule name. The valid 
schedule name will replace the <tbd> value. The default schedule value is:

‘Mo. - Fr. 08:00 - 17:00’ 

For example, you might substitute a schedule value of 

‘Mo. – Fr. 7:00 – 11:00 12:00 – 4:00’ 

If that is a valid schedule name. Make sure that the value exists in the 
NAME field of the CALDUTYHOUR table.

5 Run the query.

Set the Time Zone

The dates specified in a ServiceCenter or Service Manager CALDUTYHOUR 
table are in local time; however, DecisionCenter processes dates within a time 
zone. When you ran the $NAME=SHIFT_ADD script (Add Assignment Group 
Shifts on page 182), the script inserted a <tbd> value in the TZ_NAME field. 
Now you must populate that field with a valid time zone name.
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Obtain a List of Valid Time Zones

You can get a list of all names using the bia_datamining utility, or you can 
get a smaller list of time zone values where the standard time corresponds to a 
specific offset from Greenwich Mean Time (GMT). Follow these steps to obtain 
a list of all possible time zone names.

1 From the Windows Start menu, click Run, and type CMD to open a 
command window.

2 Change directories to:

\\..\HP\DecisionCenter 2.00\BIA\bin

3 Type this command:

bia_datamining ListTimeZones

4 Press Enter.

Follow these steps to obtain a list of time zone values expressed as an offset 
from GMT.

1 From the Windows Start menu, click Run, and type CMD to open a 
command window.

2 Change directories to:

\\..\HP\DecisionCenter 2.00\BIA\bin

3 Type this command:

bia_datamining ListTimeZones GMT<s>NN

Where <s> is a plus (+) or minus (-) sign, and NN is the offset in hours from 
GMT.

4 Press Enter.

Populate TZ_NAME With a Valid Time Zone Value

The SHIFT_SET_TZ script replaces <tbd> with one of the valid time zone 
names that you identified in the last steps.

1 Locate the appropriate SQL template file for your environment on the 
DecisionCenter installation media.

For Microsoft SQL Server, open:

\\BIA\SupportFiles\DatabaseFiles\mssql-templates.sql
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For Oracle, open:

\\BIA\SupportFiles\DatabaseFiles\oracle-templates.sql

2 Search for the Updating PREP_ASSIGNMENT_SHIFT section. 

3 Locate the query statements that begin with $NAME=SHIFT_SET_TZ. 

4 Replace ‘Europe/Paris’ with a valid time zone value. 

5 Run the query statements that begin with $NAME=SHIFT_SET_TZ. 

Step 6: Populate the Business Service CI PREP Table

The PREP_BS_CI table creates relationships between the business service 
and the configuration items that support the business service. 
ServiceCenter 6.1.x and earlier versions do not capture business service 
relationships; however, DecisionCenter impact calculations and optimization 
tasks require business service data. 

Follow these steps to populate the PREP_BS_CI table.

1 Locate the appropriate SQL template file for your RDBMS on the 
DecisionCenter installation media. 

For Microsoft SQL Server, open:

\\BIA\SupportFiles\DatabaseFiles\mssql-templates.sql

For Oracle, open:

\\BIA\SupportFiles\DatabaseFiles\oracle-templates.sql

2 Search for the Updating PREP_BS_CI section.

3 Run the query statements that begin with $NAME=BS_CI_REFRESH.

Step 7: Populate the Business Service Incident PREP Table

ServiceCenter 6.1.x and earlier versions do not capture business service 
relationships; however, DecisionCenter impact calculations and optimization 
tasks require business service data. The PREP_BS_INCIDENT table creates 
relationships between a business service and an incident through the device 
connected to the incident. 
186 Chapter 11



By default, DecisionCenter assumes an affected device maps to a business 
service. Or, you can improve the granularity of business service assignment by 
manually mapping more sophisticated business service values to the 
appropriate fields in the PREP_BS_INCIDENT table.

You need to populate the PREP_BS_INCIDENT table if:

• There is no device associated with the incident.

• The device is not associated with a business service in the PREP_BS_CI 
table.

• The device is associated with a business service, but another business 
service is affected by the incident.

• The device is associated with more than one business service and not all 
those business services are affected by the incident.

Follow these steps to populate the PREP_BS_INCIDENT table.

1 Locate the appropriate SQL template file for your RDBMS on the 
DecisionCenter installation media. 

For Microsoft SQL Server, open:

\\BIA\SupportFiles\DatabaseFiles\mssql-templates.sql

For Oracle, open:

\\BIA\SupportFiles\DatabaseFiles\oracle-templates.sql

2 Search for the Updating PREP_BS_INCIDENT section.

3 Run the query statements that begin with $NAME=BS_INCIDENT_ADD.

Step 8: Add Assignment Transitions

This step requires you to configure the process.properties file, then 
populate the PREP_ASSIGNMENT_TRANSITION table.

Configure the Process Properties File

1 If you use the default installation path, open this file with a text editor:

\\..\HP\DecisionCenter 2.00\BIA\config\process.properties
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2 Verify (or change) the following values.

Populate the Table

1 From the Windows Start menu, click Run, and type CMD to open a 
command window.

2 Change directories to:

\\..\HP\DecisionCenter 2.00\BIA\bin\

3 Type this command:

bia_datamining GenerateIncidentTransitions

4 Press Enter. The amount of time that the process takes depends on your 
configuration and the amount of data. It may take from a few seconds to 
as long as an hour to run.

Table 31 Parameters in process.properties

Parameter Description

rds.database.timezone Set this parameter to a time zone value 
that matches the time zone of the date 
and time fields in the data warehouse. 
You can express this as GMT, 
GMT+HH:MM, or GMT-HH:MM where 
the HH:MM value is the offset from 
GMT.

global.defaultUserTimeZone This value must be a valid Java time 
zone name. From the command line, you 
can run the 
bia_datamining ListTimeZones 
command to obtain a list of valid time 
zones. It should represent the time zone 
of the technician’s default location, which 
takes daylight savings into account. 

If you get an out of memory error, you may need to change the default memory 
limits temporarily. You can change the settings for the DATA_MINING_OPTS 
variable in the bia_datamining.bat file to this value:

SET DATA_MINING_OPTS=-Xms128m -Xms1024m
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Step 9: Populate the Incident Exclusion PREP Table

The PREP_PROBSUM_EXT table captures incidents that are not relevant for 
simulation scenarios. You should identify incidents that were opened against 
obsolete devices, or incidents reported by a customer who no longer exists, or 
is not actively reporting incidents. This can be a manual process or a data 
mining exercise that creates one record for each incident that meets this 
criteria. Ensure that the incident number is recorded in the NUMBERPRGN field 
and a value of 1 in the OMIT_FROM_SIMULATION field.

Step 10: Add Full Time Equivalent (FTE) Employee Values

If you plan to run Optimization scenarios or simulations, you must complete 
this manual step to estimate the number of Full Time Equivalent (FTE) 
employees for each shift. This number is an integer greater than or equal to 1.

You can create your own formula, or you can estimate by summing all the time 
worked on incidents by all employees in a shift for one month. Divide this 
number by the total work hours of one full time employee during a month. 
Usually, this number will be lower than the actual number of technicians 
assigned to a shift, due to tasks unrelated to working the ticket queues.

For example:

• There are five employees who work the 8 – 5 shift each day (an eight-hour 
work day). 

• Each employee works on incidents about six hours a day. 

• Their total hours spent on incidents for an entire month is 600 
(5 employees x 30 hours per week x 4 weeks in a month).

• Total hours spent on incidents divided by the total work hours of one FTE 
is 3.75 FTEs (600/160). For fractional results, round up.

Populate the FTE column in the PREP_ASSIGNMENT_SHIFT table with the 
computed FTE value.
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Task 3: Customize the Data Mapping

DecisionCenter requires historical data that contains information about:

• Business services

• The organization

• Value centers

• Labor cost

• Impact

• Service Level Objectives

You completed mapping business services information when you completed 
Task 1: Customize Business Service Data on page 175.

There are assumptions made in the Connect-It scenarios to map data that 
adds other required information to ordinary incident data. Because each 
organization runs differently, you may need to customize the mapping 
scenario to accurately reflect how your organization operates. You may need to 
rebuild these views and tables if you make changes. You can use Connect-It to 
review the mapping relationships.

Step 1: Customize the Organization Table Mapping

The organization table describes the internal organizational structure of the 
business.

Table name: organization

Populated with data from: DEPT_D

The mapping concatenates the company name and the department name to 
produce an organization name. You may need to customize the dco_rds.scn 
scenario to accurately reflect how your organization identifies the 
organizational structure.
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Step 2: Customize Value Center Mappings

A value center is that part of your business that provides a product or service 
to an internal or external customer. It is an entity that adds value directly, or 
indirectly, to your customer community. An enterprise business service can 
have multiple associated value centers. There are four tables that support the 
concept of a value center. You may need to customize the dco_rds.scn scenario 
to accurately reflect how your organization supports the concept of a value 
center. 

Table 32 Value Center Customization

Table or View
Populated With Data 
From Notes

value_center DEPT_D There are two mappings that 
describe how to import value 
centers.

• Mapping 1: 
DEPT_DSrc1_1-value_cente
rDst1 creates value centers 
and updates their main 
attributes.

• Mapping 4: 
DEPT_DSrc4_1-value_cente
rDst4 connects a value 
center to its parent. 

value_center_type No ServiceCenter or 
Service Manager 
equivalent

Use the DecisionCenter 
interface to apply value center 
types to value center records.

valuecenter_businessservice DEPT and COMPANY field 
in DEVICE_D 

incident_valuecenter DEPT and COMPANY field 
in PROBSUMM_D 
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Step 3: Customize the Labor Cost

Maps an average hourly labor cost to close an incident. 

Table name: ASSIGNMENT_GROUP 

Populated with this data: No ServiceCenter or Service Manager equivalent

The default value is 10; however, you can customize dco_rds.scn to use a 
different value. This value is used in all labor cost calculations. There are no 
special considerations for currency unit or exchange rates. It is an absolute 
value used for computations and relative value comparisons.

Step 4: Customize Incident Mapping

Incident mapping adds additional data to ServiceCenter or Service Manager 
incident records. You can accept the default values used in the dco_rds.scn 
scenario, or you can customize the scenario to use other values. 

Table 33 Incident Customization

Table or View
Populated With 
Data From Notes

impact_scope_type incident The default mapping is 
Business_unit. You may need to 
customize the scenario to 
accurately map impact scope type 
information. Other valid values 
are Department, Enterprise, or 
Single_user.

incident_impact_type incident The default mapping value is 
Outage, which categorizes each 
incident as a total loss of 
operation. You may need to 
customize the scenario to 
accurately map incident impact 
type information. Other valid 
values are Capacity, Corruption, 
Inquiry, or Degradation.
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Step 5: Customize SLO Mapping

Incidents are associated with Service Level Objectives (SLOs) to measure how 
well an organization meets is response time and availability goals. If IT 
cannot meet the service levels described in the SLO, an SLO breach occurs 
that increases Mean Time to Repair (MTTR) metrics. SLOs have a built-in 
escalation and alert scheme that begins when a user opens an incident to 
report an outage. DecisionCenter imports response time and availability 
SLOs, but uses only response time SLOs for Optimization scenarios.

Priority

As an incident approaches the SLO breach point, the priority of the incident 
escalates in the assignment group queue. DecisionCenter Optimization 
assumes that an available technician will select on the highest priority 
incident in the assignment queue. 

SLOs in DecisionCenter

For any incident, DecisionCenter first selects the Service Level 
Agreement (SLA) that is assigned to the department referenced in the 
incident. Next, DecisionCenter applies the Response Time SLOs that are 
associated with the selected SLA. Although ServiceCenter or Service Manager 
supports customization using RAD expressions to further restrict the 
association between an SLO and an incident, DecisionCenter does not support 
these customization actions. DecisionCenter works only with severity and 
user priority selection criteria.

DecisionCenter uses these response time SLO states:

• Open

• Work in progress

• Resolved

When the Connect-It scenario imports SLOs, it converts a Closed state to a 
Resolved state. Thereafter, DecisionCenter ignores SLOs with any other state.
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SLO Mapping

The dco_rds.scn scenario imports SLO information with no conditions. Each 
SLO has a condition field. DecisionCenter selects incidents that have a 
matching impact and urgency. Impact and urgency correspond to severity and 
user priority in the ServiceCenter or Service Manager probsummary record. 
You must create a mapping that imports the SLO condition settings into the 
incident_slo_condition and incident_impact_urg_slo_cond tables.

There are two mapping examples in the dco_rds.scn that show how to import 
SLO condition information into the incident_slo_condition and 
incident_impact_urg_slo_cond tables. These are examples only; you must 
modify them to meet the format of your data.

Task 4: Load the DecisionCenter Tables

You must run a Connect-It scenario to populate the appropriate tables with 
business service and configuration item information before you load the 
remaining DecisionCenter tables with prepared data.

Step 1: Load Data into the DecisionCenter Tables

This step uses another Connect-It scenario to extract data from both resources 
and load it into DecisionCenter tables. To run the dco_rds.scn scenario:

1 From the Windows Start menu, click Programs > HP OpenView > 
Connect-it 3.80 en > Service Console.

2 The Service Console should point to this scenario file:

\\..\HP\DecisionCenter 2.00\BIA\cit\dco_rds.scn 

3 Click Start.

It can take several hours to execute if there is a large quantity of data. 
Immediately after the initial data synchronization finishes, it is recommended 
that you back up your database. If synchronization takes a long time, you can 
use the backup to restore the data. 
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Step 2: Run the Data Cleanup Script File

The imported data may contain invalid characters with underscore and 
incidents without transitions. Run this script to replace the invalid characters 
with underscores and flag any incident without transition information.

1 Copy one of these files from the DecisionCenter installation media to a 
local directory.

For Microsoft SQL Server:

\\BIA\SupportFiles\DatabaseFiles\mssql-post_dco_rds_scn.sql

For Oracle:

\\BIA\SupportFiles\DatabaseFiles\oracle-post_dco_rds_scn.sql

2 Run the script. 

Step 3: Point the Scenario to the ServiceCenter 6.2.2 Server

If you are using ServiceCenter 6.2 or an earlier version, skip this step and 
proceed to Step 4: Load Change Data into the DecisionCenter Tables on 
page 196. Complete this step only if you have Service Manager 7.00. 

1 From the Windows Start menu, click Programs > HP OpenView > 
Connect-it 3.80 en > Scenario Builder.

2 Click File > Open and browse to open this file:

\\...\HP\DecisionCenter 2.00\BIA\cit\dco_change.scn

3 If the Connect-It Toolbox is not enabled, click Display > Toolbox.

4 From the Connect-It Toolbox, expand Hewlett-Packard > OpenView Service 
Management connectors > OpenView ServiceCenter connectors.

5 Double-click OpenView ServiceCenter to start the Connector Wizard.

6 Click Next.

7 Make sure that the Server name, Login, and Password are correct to connect 
to the ServiceCenter 6.2.2 server, and that the port number is the one 
assigned to the ServiceCenter 6.2.2 server, not the port number associated 
with Service Manager 7.00.

8 Click Test to start a connection test between Connect-It and the 
ServiceCenter 6.2.2 server. Make sure the connection test is successful.
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9 Click Finish.

10 Save the scenario and close Connect-It.

Step 4: Load Change Data into the DecisionCenter Tables

This step uses another Connect-It scenario to extract planned change data 
from both resources and load it into DecisionCenter tables. To run the 
dco_change.scn scenario:

1 Make sure that ServiceCenter or Service Manager is running.

2 From the Windows Start menu, click Programs > HP OpenView > 
Connect-it 3.80 en > Service Console.

3 The Service Console should point to this scenario file:

\\..\HP\DecisionCenter 2.00\BIA\cit\dco_change.scn 

4 Click Start.

Immediately after the initial data synchronization finishes, it is recommended 
that you back up your database. If synchronization takes a long time, you can 
use the backup to restore the data. 

Task 5: Start the Optimization Engine

Run one of the following command files on the server where you installed (or 
moved) the Optimization engine.

Windows

\\..\DecisionCenter 2.00\Optimization\bin\run_optimizer.bat

HP-UX or AIX:

./../DecisionCenter 2.00/Optimization/bin/runoptimizer.sh

Make sure the runoptimizer.sh script is syntactically correct for your 
HP-UX or AIX operating system, or you can use the ksh shell to run the 
script directly. Start the Optimization engine by typing this command:

source run_optimizer.sh
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Verify the Result

1 Type the following URL and modify it to point to the server and the 
assigned port number:

http://your application server:port number/decisionCenter

2 Click Go.

3 Log on with your user name and password that you defined in Chapter 6, 
Security. The default user name is dcuser.

4 Verify that you can expand the Navigation tree.

5 Click Impact and Optimization > Simulation Manager. If this message appears:

Optimizer is down

Do the following:

a Repeat the tasks in Install the Optimization Engine on page 161 and 
ensure that you restart your application server (Tomcat or Websphere) 
before you start DecisionCenter. 

b Repeat Step 1 through Step 5 on page 197.

Task 6: Compute Time to Next Incident

If you plan to run Optimization scenarios or simulations, you must compute a 
Time to Next Incident (TTNI) value. Analyzing normal historical and 
simulated incident data shows that there are usually some discrepancies, 
gaps, and a general lack of smooth curve statistics for the average amount of 
time that elapses between timestamps on incident records. This data mining 
step gathers statistics about seasonal variations by month, day, and hour from 
existing data, estimates missing data points, and filters data for anomalies to 
produce a refined TTNI value that is stored in the database and used by the 
Optimization engine. 

The DecisionCenter TTNI command line utility can create this refined value 
that you need for more precise input to the Optimization engine. 
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The TTNI utility has embedded documentation that describes the command 
names and parameters that you can invoke to extract the required data. 
Follow these steps to configure and run the TTNI utility.

1 Open this file with a text editor.

\\..\HP\DecisionCenter 2.00\Optimization\config
\dataminingContext.xml

2 Change any of the following parameter values. 

3 Save and close the file.

4 From the Windows Start menu, click Run, and type CMD to open a 
command window.

5 Change directories to:

\\..\HP\DecisionCenter 2.00\Optimization\bin

6 Type this command:

opt_datamining parameter

You must run this utility before you attempt to start DecisionCenter and run 
simulation scenarios.

monteCarloSampleCount The default value is 50. This value dictates 
how many Monte Carlo simulations it takes to 
produce one data point. As you increase the 
number of Monte Carlo simulations, the more 
precise the sampling; however, run time also 
increases proportionally.

calibrationMinCountFactor Minimum historical average hourly incident 
count. The data mining engine computes the 
average of the minimum and maximum 
incident counts. The default value is .9.

calibrationMaxCountFactor Maximum historical average hourly incident 
count. The data mining engine computes the 
average of the minimum and maximum 
incident counts. The default value is 1.1

calibrationSampleCount The number of simulations to run. The default 
value is 19; the minimum value is 5. 

calibrationFunctionDegree The degree of the function used to estimate 
TTNI. The default value is 2.
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TTNI Commands and Parameters

You can add one or more parameters to modify the basic functionality of the 
opt_datamining command. 

You can mix the format using either the long or short form of the command. 
For example:

opt_datamining ttni -n --runtest myResults.txt

opt_datamining ComputeTTNI --dontSave -t myResults.txt

TTNI Notes

You cannot use the -l parameter for the initial run. There must be a saved 
TTNI value before you use this parameter. 

The utility saves only one set of TTNI values. Subsequent runs with save 
enabled will replace the current value with a new set of TTNI values.

Table 34 TTNI Commands

Command Result

 -h Display help.

ComputeTTNI (or ttni) Compute an average time to next incident value 
and save it in the database.

ComputeTTNI -n 
(or --dontSave)

Do not save the computed TTNI value in the 
database.

ComputeTTNI -l 
(or --loadOnly)

Do not compute a new TTNI; load the saved 
value from the database.

ComputeTTNI -t fileName 
(or --runTest  fileName)

Compute the TTNI value, run a simulation with 
that value, compare with history, and save the 
results in fileName. Save the TTNI value for a 
future run.

TestDatabaseConnection 
(or testdb)

Connect to the database and verify that the 
OPERATOR_D table exists and contains a field 
NAME.
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Types of Output

The TTNI utility produces three types of output files that you can view and 
edit with Microsoft Excel.

• Time to Next Incident Measurements are computed by month, day, and hour.

• Calibration describes the sampled hourly incident count based on selected 
calibration points.

• Simulation Test generates historic and average incident counts produced by 
simulation runs that use the TTNI value.

Customizing TTNI

The Time to Next Incident model determines how frequently the incidents 
occur, taking into account the seasonal variations (month, day of week, and 
hour of day). The TTNI utility computes these parameters using your data.

If you accept the out-of-box TTNI settings for the incident rate, they will be 
accurate for a range of -10% to +10% of your historical hourly incident count.

During scenarios defining potential business services, the number of incidents 
produced in a period can decrease or increase depending on whether you 
remove business services or add business services. If the rate of incidents 
described by the scenario is significantly different from the historical rate, it is 
possible that the variation will be greater than the default value -10% to +10% 
range. In that case, the precision of the results is unpredictable. 

In extreme cases, it is possible that the incident rate is so far from the -10% to 
+10% range that the Optimization engine (and the simulation) fails. The  
optimization engine log (dc_optimizer.log) displays this error:

java.lang.IllegalArgumentException: Exponential mean must be >=0

Tuning the incident rate

The solution is to change the default configuration of the TTNI utility. 

1 Open this file with a text editor.

\\..\HP\DecisionCenter 2.00\Optimization\config
\dataminingContext.xml
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2 Locate this parameter:

<property name="calibrationMinCountFactor"> 
<value>.9</value>

</property>

3 Change the .9 value, which corresponds to -10% of the historic rate, to a 
more reasonable value for your simulation scenarios. For example, if you 
change this value to .1, this lowers the minimum average hourly incident 
count to 10% of the historical incident rate:

<property name="calibrationMinCountFactor"> 
<value>.1</value>

</property>

4 Locate this parameter:

<property name="calibrationMaxCountFactor"> 
<value>1.1</value>

</property>

5 Change the 1.1 value, which corresponds to +10% of the historic hourly 
incident rate, to a more precise value for your simulation scenarios. For 
example, if you change this value to 1.3, this raises the maximum average 
hourly incident count to 130% of the historical incident rate:

<property name="calibrationMinCountFactor"> 
<value>1.3</value>

</property>

6 Save the file.

7 Stop the Optimization engine.

8 Re-run the TTNI utility. 

9 Re-start the Optimization engine.
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Task 7: Verify the Results

1 Log on to the data warehouse as the rds_dba user.

2 Run the following queries on the rdsdb database:

— Select * from incident_transition

— Select * from business_service

— Select * from timetonext_incident_factor

Each query should return rows of information. If any query does not return 
rows, the data mining process was unsuccessful. Repeat the tasks in this 
chapter for that table and verify the results.

Refresh the Data

Connect-It scenarios run only once. There is no automatic schedule defined. 
Mapping scenarios run once to synchronize all the data from identified 
resources. You may need to re-run the scenarios, data mining activities, and 
the History Builder if you have changes to your original source data. 

If you schedule BIA scenarios to run periodically to re-synchronize the data, 
consult the Connect-It documentation for best practice guidelines. 

The amount of time required to synchronize the data depends on the volume 
of data to be processed and the capacity of your server. You should schedule 
the synchronization to occur during off-peak hours when the server has no 
other demands.

If you schedule the dco_rds.scn scenario to run periodically, create the 
scheduling grouped by the order of data source connector sequences. For 
example, sequence data warehouse source 1, data warehouse source 2, data 
warehouse source 3, and so on. 
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A Troubleshooting

Before you attempt to troubleshoot a problem, make sure that your 
environment complies with the requirements of the Support Matrix. If you do 
not have the correct platform, version, browser, or other required component, 
DecisionCenter cannot run successfully. For more information, see the 
DecisionCenter Support Matrix on the HP Software Support web site 
(http://support.openview.hp.com/sc/support_matrices.jsp).

BusinessObjects Critical Hot Fix

If you deploy the report content before you apply the BusinessObjects 
Enterprise Critical Hot Fix (CHF), you cannot re-deploy the content 
successfully because the existing reports and universes cannot be overwritten. 
After you install the CHF, you must delete all the folders and the universes 
from the repository before you attempt to deploy the report content again. 

Best practice: Make sure that you complete the tasks in Chapter 5, Install 
BusinessObjects Enterprise XI before you begin the tasks in Chapter 7, Install 
the DecisionCenter Analytics.

Error Messages

Error Message: An unexpected system error occurred. Repeat the procedure 
and if the error persists, contact your system administrator or HP Software 
Support.

Explanation: This message may occur because your browser setting does not 
allow the browser to check for newer versions of stored pages.

Action: Follow these steps to apply the correct setting.

1 Start a browser session.

2 Click Tools > Internet Options > General.
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3 Click Delete Files and the Delete all offline content checkbox to clear the 
internet files cache.

4 Click OK.

5 Click Settings.

6 Click Automatically under Check for newer versions of storage pages.

7 Click OK.

8 Click OK.

9 Close the browser session.

10 Start a new browser session.

11 Type the URL to start DecisionCenter.

Heap Size

The heap size setting on the Web application server hosting DecisionCenter 
must be at least 512 MB. The recommended setting is 1024 MB.

Installation Error Messages

The installer may display warning and error messages if you attempt to 
complete a step out of sequence, or if you repeat a step. Use the information in 
the message to correct the errors and repeat the step.

When you complete the ITPA-SM portion of the installation, there are a series 
of scripts that depend on correct completion of earlier steps. Any error 
generates the following message.

One or more installation errors occurred. Review specific error 
messages located at: 

\\..\DecisionCenter 2.00\ITPA-SM\logs\*.log

\\..\DecisionCenter 2.00\ITPA-SM\logs\rds_etl_init.err
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If the log indicates that the rds_init or test_rdssc scripts failed, the failure 
might be caused by one of the following errors. 

• This file has incorrect settings:

\\..\HP\DecisionCenter 2.00\ITPA-SM\cit\config_rdssc.txt

Open the file with a text editor, correct the errors, and save the file. Run 
these scripts in this order:

a \\..\DecisionCenter 2.00\ITPA-SM\common\bin\upd_rdssc.cmd

b \\..\DecisionCenter 2.00\ITPA-SM\common\bin
\test_rdssc.cmd

• If test_rdssc and rds_init failed, run these scripts in this order:

a \\..\DecisionCenter 2.00\ITPA-SM\common\bin
\upd_rdssc.cmd

b \\..\DecisionCenter 2.00\ITPA-SM\common\bin
\test_rdssc.cmd

c \\..\DecisionCenter 2.00\ITPA-SM\common\bin\rds_init.bat

• The ServiceCenter or Service Manager server is not running. Start the 
server and repeat the ITPA-SM installation steps.

• The database server is not running. Start the server and repeat the 
ITPA-SM installation steps.

• You did not complete the earlier steps to unload the required files in 
ServiceCenter or Service Manager. This unload process creates the 
bi-connector user and operator records, and provides triggers and scripts 
that support the ETL process. Repeat the unload steps and then the 
ITPA-SM installation steps.

Socket Error

If the error message in the rds_etl_init.err file reports “Error establishing 
socket,” complete these steps.

• Verify that you imported the ServiceCenter or Service Manager unload 
files correctly. If not, repeat Task 1: Prepare the Source Data on page 32 
throughTask 5: Install the Data Warehouse on page 46. 
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• Use your RDBMS application to verify that the new tables exist in the 
database. If not, repeat Task 2: Create the Tablespace and Users on 
page 34 throughTask 5: Install the Data Warehouse on page 46.

Log Files

DecisionCenter produces log files that you can access to troubleshoot errors:

The main Optimization engine logs are:

\\..\HP\DecisionCenter 2.00\Optimization\bin\dc_optimizer.log

\\..\HP\DecisionCenter 2.00\Optimization\bin
\hibernate_optimizer.log

The main application logs are:

 \\..\Tomcat\bin\dc.log

\\..\Tomcat\bin\hibernate.log

Windows: If you're running Tomcat as a service instead of from a .bat file, the 
application log files are in this directory:

\\windows\system32

HP-UX: The application log files are in the same folder that contains the 
startup.sh script. 

DecisionCenter produces BIA log files that can help you debug errors. Look for 
them in this directory:

\\..\HP\DecisionCenter 2.00\BIA\logs

Table 35 BIA Log Files

Log File Name Purpose

createsvc_dcords.log Logs actions to install or uninstall the dco_rds 
service

createsvc_dcosc.log Logs actions to install or uninstall the dco_sc 
service

test_dcords.log Logs connector information
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Session Timeout Value

To adhere to best practices, change the session timeout values of the 
Business Objects Connection Server and the Web_IntelligenceReportServer. 
Unless otherwise noted, the default value is in seconds. For more information, 
refer to the Business Objects documentation.

1 Click Start > Programs > Business Objects XI Release 2 > BusinessObjects 
Enterprise > BusinessObjects Enterprise Java Administration Launchpad. 

2 Click Central Management Console. 

3 Log on as Administrator. 

4 Click Servers. 

5 Click server_name > Connection Server. 

6 From the Properties tab Connection Pooling section, select No Timeout.

7 In the Connection Server Job section, change the Timeout for Inactive Jobs 
to 120. 

8 Click Update.

9 Click server_name > Web_IntelligenceReportServer. 

10 From the Properties tab Connection Time Out field, change the value to 60 
minutes. 

11 Click Update.

If you click Apply instead of Update, you must restart the server for the 
changes to be effective.

test_dcosc.log Logs connector information

upd_dcords.log Logs connector update information

upd_dcosc.log Logs connector update information

Table 35 BIA Log Files

Log File Name Purpose
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Changing web.xml Default Parameters

You can change the default values in the web.xml file if necessary. 
Follow these instructions.

1 From the Windows Start menu, click Control Panel > Administrative Tools > 
Services and stop the Tomcat service.

2 Open this file with a text editor:

 \\..\Tomcat\webapps\...\WEB-INF\web.xml

3 Modify one or more parameters. Use the information in Table 36 as a 
reference.

4 Save and close the file.

5 From the Windows Start menu, click Control Panel > Administrative Tools > 
Services and start the Tomcat service.

Table 36 Default web.xml Parameters

Name Description Default Values

folderPrefix Display folders in Business 
Objects with the specified 
prefix in DecisionCenter 
navigation menu

ITPA, BIA, ITPO

boProgPath Business Objects InfoView 
application installation path

/businessobjects/enterprise115
/desktoplaunch

ITPA Groups defined for the ITPA 
tier

ITPA_GM, ITPA_AA, 
ITPA_Admin

BIA Groups defined for the BIA 
tier

BIA_GM, BIA_AA, 
BIA_Admin

ITPO Groups defined for the 
Optimization tier

ITPO_GM, ITPO_AA, 
ITPO_Admin
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JDBC Connection Pool Errors

The maxActive property in the JNDI data source configuration defines the 
maximum number of active connections in the pool. You must evaluate the 
factors that drive how large your connection pool should be. If users close their 
browser sessions without logging out, the connections they use remain open 
until:

• The connection expires after being unused for the amount of time specified 
in the JNDI configuration. Some connections can become available 
automatically as the specified timeout occurs.

• The user session expires after the amount of time specified in the 
web.xml file. 

For optimum results, this value can be as low as 10 or as high as 100, 
depending on the number of concurrent users and abandoned browser 
sessions. If you see JDBC connection pool errors, increase the number of 
connections to a value that works in your environment.

Broken Database Server Connections

When a database server reboots, or a network failure occurs that breaks your 
database server connection, you must restart the application server to 
re-establish the connection. You can configure Tomcat to re-create a broken 
connection automatically by editing the decisioncenterContext.xml file 
and adding the validationQuery parameter.

1 From the Windows Start menu, click Control Panel > Administrative Tools > 
Services and stop the Tomcat service.

2 Open this file with a text editor:

\\..\Tomcat\conf\Catalina\localhost\decisionCenter.xml

3 For Microsoft SQL Server, add the following parameter to the file.

<parameter>
<name>validationQuery</name>
<value>select 1</value>

</parameter>
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4 For Oracle, add the following parameter to the file.

<parameter>
<name>validationQuery</name>
<value>select 1 from dual</value>

</parameter>

5 Save and close the file.

6 From the Windows Start menu, click Control Panel > Administrative Tools > 
Services and start the Tomcat service.
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