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Troubleshooting Installation

Problem: CSA for Matrix installation fails

Symptoms Installation of CSA for Matrix fails.

Hardware

Operating System(s)

Is this an integration issue? No

Primary software component CSA for Matrix

Other dependencies

Failure message e not found <filename>
correct missing files or other problems
e Neither OO Dir, 10 Dir nor SiteScope dir are
found on this server. Perhaps configuration
is incorrect in <propertiesFile>
e  Central Login URL: <CentralURL>
URL status: not available.
e  Central Login URL: <CentralURL>
URL status: available.
Logging on to Central:
Invalid username or password.
Could not open: <CentralURL>

Probable cause e Required file <filename> is missing.

e Directory path configured in the file
csad4mInstall.propertiesis
incorrect or the server does not host HP 10,
00, or SiteScope.

e 0O Central URL configured is wrong.

e 0O Central login credentials are specified
incorrectly.

For more information See the HP Cloud Service Automation for Matrix
Configuration Guide.

Solution:

e  For missing files, make sure the file <filename> exists and retry the installation.
NOTE: If you use standalone OO, and if the displays that the HP IO directory is missing, make sure to
complete the standalone OO configuration for HP 10 and retry the installation.

e [fthe installer does not find 10, OO, or SiteScope directory, make sure the server hosts at least one
of these products. Verify that the csa4mInstall.properties file is configured with correct
paths for these directories.

NOTE: These directory paths should not be left blank. If the server does not host a particular
component, do not edit the default value for the component.

e  Verify that the OO Central URL specified in the csadmInstall.properties fileis correct and
working.
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e Verify that the OO Central login details specified in the csa4mInstall.properties file are
correct.

Troubleshooting Integration (HP SA)

Integration

Problem: No HP SA software listed in the 10 Software Tab

This failure manifests when HP SA software does not appear in the HP 10 Operations Console Software tab.

Symptoms Unable to retrieve OS Policy or APP Policy Inventory
from HP SA primary core. Any software presented by
the HP SA server to HP 10 is not listed on the HP 1O
Software tab.

Hardware

Operating System(s)

Is this an integration issue? Yes

Primary software component HP 10 and HP SA

Other dependencies

Failure message There might be a message in the HP 10 or ALC log
files, but not always.

Probable cause The permissions of the account used by HP |0 do not

have list and view permissions to the software to be
used by HP 10. HP SA is not fully up and running.

How to access log files

For more information See the HP Cloud Service Automation for Matrix
Configuration Guide.

Solution:

Review the HP Cloud Service Automation for Matrix Configuration Guide chapter on setting HP SA account
permissions. There are two parts to the permissions needed by this account. The first are those set in the OCC
Web interface used to create the account and the appropriate group. The second are the folder permissions,
viewable in the OCC Java application that contains the software packages, software profiles, OS profiles and
OS sequences.

1) Verify that the HP SA server is up and running all HP SA services:
a) Loginasroottothe HP SA server.
b) Runthecommand /etc/init.d/opsware-sas status
c) Review the output to see that all status messages are marked SUCCESS.
2) Verify that network connectivity between the CMS and the target HP SA primary core is working
(for example, perform a basic ping check).
3) Verify that the mxnode security credential that was supplied for the HP SA primary core is

correct by opening a command shell on the CMS and running the following command:
mxnodesecurity -1

a) Avalid credential must include the following:
e The IP address or hostname of the HP SA primary core
e A protocol type of dsc_sas
e The login and password of account that was created on the HP SA primary
core for BladeSystem Matrix’s use and access
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b) If the credential that was created is invalid, delete the current credential using the
command:
mxnodesecurity -r -p dsc_sas -n <IP address or hostname>

NOTE: If the incorrect protocol type was specified, you must substitute the value that is
currently stored in the invalid entry for dsc_sas above.

c) Torecreate the credential, issue the command:
mxnodesecurity —-a -p dsc_sas —-c¢ <username>:<password> -n
<SA primary core IP Address or hostname>

4) Verify that network connectivity and the mxnodesecurity credential are correct. It is possible
that the account that created on the HP SA primary core does not have access to the correct
group or that the folder permissions on the HP SA primary core have not been correctly
updated. Refer to the “Updating HP SA Security and Roles” in the HP Cloud Service Automation
for Matrix Configuration Guide for details on configuring folder permissions.

HP 10 also provides a support tool that can be used to retrieve a command-line listing of the current software
inventory.

1) Openacommand prompt on the CMS.

2) Change directory to: C: \Program Files\HP\Insight Orchestration\support

3) Execute the command: sbapi.bat GetImages

Problem: Orphaned servers observed in HP SA Devices folders

Symptoms The HP SA Devices subfolders in the OCCWeb or
NGUI have server records that are not associated
with any active CSA for Matrix service.

Hardware

Operating System(s) Windows

Is this an integration issue? Yes

Primary software component HP SA, HP 10

Other dependencies A prior provision or de-provision of servers
associated with the orphaned server records may
have failed or had problems.

Failure message None. Disconnected server icons or server icons
marked with a red X appears as shown in the figures
below.

Probable cause

For more information

Solution:

1) Loginto the HP SA server via the NGUI client.
2) Review each of the following subfolders under the Servers folder for orphaned resources:
All Managed Servers
Unprovisioned Servers
3) Evaluate any servers in the All Managed Servers folders that do not have corresponding managed
instances in CSA for Matrix, or whose small blue server icon is not connected to a small network icon
just to its right.
4) Evaluate any servers in the Unprovisioned Servers folders that do not have corresponding managed
instances in CSA for Matrix, or whose small server icon has a red X.
5) Evaluate what is managed in HP SIM, HP 10, VSE, VCEM, vCenter/ESX and Hyper-V.
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6) Review any server records that are stray or orphaned for deactivation and removal from the HP SA

Servers sub-folders.

Figure 1 Orphaned Servers in HP SA Devices, Part One
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Figure 2: Orphaned Servers in HP SA Devices, Part Two

[SIHP Server Automation - 192.168.10.44 & x|
File Edit Yiew Took ‘Window Actions Help

[ server

[ saved searrhes ...

IF Address ®
Gl dhep-client-00:50:56:48: 17:F2 192.168.10,242 WINPEGS =l

Ll @]

Advanced Search

B @ Device Groups
@ hpio
&) Public
= [ servers
B Al Managed Servers
- 0 Wirtual Servers

Ervers
8] unmanaged Servers
= B Storage

¥ SAN Arrays

L@ Nas Filers

No devices found

-
<[} Devices

% Library
Reports

@ Jobs and Sessions

{a} Administration

< =l

| i | Fri 2un 25 21:24 2000 EtcpUCT

Litem |

Histart| |3 @8 P @ @ )| %y services [l HP Server Automatio... () HPESA-ALT-A - vSphere ... | (@) HP Sitescope - MazilaFir.. 12 B &l 247 P

Problem: Personalization fails during provisioning on a dual-homed server

Symptoms During HP SA provisioning, the provisioning fails at
the personalization step.

Hardware

Operating System(s)

Is this an integration issue? No

Primary software component HPIO, HP SA

Other dependencies

Failure message

Probable cause e The network associated with the provisioning
step is defined in the HP 10 template as DHCP,
but there is no actual DHCP server available on
that network.

e |nthe case of a dual-homed server, even if the
boot network is correctly identified as DHCP and
there is actually a DHCP server available, a
provisioning failure at the personalization step
occurs if any other networks are defined as
DHCP-enabled and there is no associated DHCP
server.

For more information See the HP Server Automation Installation and
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| Configuration Guide.

Solution:

Make sure that all networks identified in the template as DHCP enabled have DHCP services available at

provision time.

Problem: Target server cannot download HP SA agent or OS

The service or production OS does not have a driver that enables it to use the system’s primary network

interface card (NIC).

Symptoms The target server cannot do a network download of
the HP SA agent or the OS components to be
deployed.

Hardware Any physical server or virtual machine (VM) guest
type

Operating System(s) Any

Is this an integration issue? No

Primary software component

OS Install media and NIC driver software

Other dependencies

Failure message

Target server cannot do a network download of the
HP SA agent or the OS components to be deployed

Probable cause

Missing or incorrect NIC driver in the HP SA service or
the production OS

For more information

Solution:

Verify that the OS sequence can be deployed against each server type before adding the servers to the pool
of available HP IO resources.

To do this you need to manually deploy each OS type from HP SA to each physical server or VM guest type in
your environment that may deploy the OS.

After the server PXE boots, verify that the OS installation sequence can access the HP SA server infrastructure
over the provisioning network.

Problem: Check reachability failure on HP SA

Check reachability failure on HP SA with “crypto” error during Run OS sequence.

Symptoms Check reachability failure on HP SA with “crypto”
error occurs during a Run OS sequence.

Hardware

Operating System(s)

Is this an integration issue?

No

Primary software component

HP SA

Other dependencies

Failure message

“Check reachability failure” on HP SA

Probable cause

SSL certificate on the target server is invalid;
therefore, the reachability check fails on HP SA.

For more information
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Solution:

1) Boot the target server and enter the BIOS settings of the target server.

2) Make sure the date/time in the BIOS settings of the target server are in sync with the HP SA Core
date/time.

3) If the date/time are out of sync with the HP SA Core, change the date/time setting to reflect the
date/time on the HP SA Core.

4) On the target server, the time and date goes out of sync with the HP SA Core after an erase disk on
the BIOS settings, which resets the time. Changing the time on the OS does not fix this issue. Change
the date/time on the BIOS settings of the target server, which become the default time settings for
the server during provisioning.

Problem: The Create Service operation is not allowed in the current lifecycle
state of the server

The Create Service operation is not allowed in the current lifecycle state of the server. The Create Service
operation in the HP 10 console fails with the following error:

Failure: The requested operation is not allowed in the current lifecycle
state of the server according to the deployment server. One possible
reason is that a node with the same MAC address or UUID exists on the
deployment server.

Symptoms The Create Service operation is not allowed in the
current lifecycle state of the server. The Create
Service operation in the HP 10 console fails with the
following error:

Failure: The requested operation is
not allowed in the current lifecycle
state of the server according to the
deployment server. One possible
reason 1s that a node with the same
MAC address or UUID exists on the
deployment server.

Hardware

Operating System(s)

Is this an integration issue? No

Primary software component HP SA

Other dependencies

Failure message Task for Logical Server <system_name> has failed.

Logical server job (ID = <system_name>.domain.com)
completed with a failure status. Failure: The
requested operation is not allowed in the current
lifecycle state of the server according to the
deployment server. One possible reason is that a
node with the same MAC address or UUID exists on
the deployment server.

Probable cause An entry of the server is already present on the
deployment server (SA) in the managed or partially
managed state.

Solution:

1) Open the devices tab in SA.

2) Verify that there is an entry of the target server on managed or un-provisioned servers.

3) If an entry of this server is present, delete the server (deactivate and delete if it is completely
managed).
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Recreate the 10 service.

Problem: Server provisioning fails for OS sequences with defined policies

End-to-End server provisioning fails in HP |0 when the SA OS sequence contains a defined policy.

Symptoms End-to-End server provisioning fails in HP 10 when
the SA OS sequence contains a defined policy.

Hardware

Operating System(s)

Is this an integration issue? No

Primary software component HP 10, SA

Solution:

1)
2)

3)
4)

When you use an SA OS sequence with a defined policy, end-to-end server provisioning fails. Do the
following for successfully provisioning a server with attached policies:

In SA, remove the policies attached to the OS sequence.

In the HP |0 designer console, edit the Server Group Configuration in the template to add the
policies as additional software in the (optional) Select additional software tab.

Save the template.

Create service with this template.

Problem: The Check Server Audit Compliance workflow fails

The Check Server Audit Compliance workflow fails.

Symptoms The Check Server Audit Compliance workflow fails.
Hardware

Operating System(s)

Is this an integration issue? No

Primary software component SA, OO

Failure message e Unable to get audit task name. Check if

CSA_SA_AUDIT_TASKNAME_LIN and
CSA_SA_AUDIT_TASKNAME_WIN System
Properties are set.

e Cannot initiate compliance check as list of
CSA4M servers is empty. Please check if the
target servers in the audit is set correctly.

Probable cause e  Audit Task is not set in the OO Studio.

e Incorrect SA credentials on OO.

e Incorrect HP IO-SA user account
permissions.

e The server is not part of the target list in the
audit task.

Solution:
Error logs can be found in <CSA_DEBUG_LOGDIR>\<CSA_DEBUG_LOGNAME>.

If you see the error message “System properties not set,” do the following:

1. Open OO Studio.
2. Set the appropriate task name variable under System Properties.
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e If you see the error message “Cannot initiate compliance check as list of CSA servers is empty,” add
the server to the Target list in SA.
o Verify that the SA credentials are correctly set in the system account HpioSACredentials.
e  Verify that the user SA user permissions are correctly set for the HPIO-SA user. See the CSA for
Matrix Configuration Guide for more information.
NOTE: CSA_DEBUG_LOGDIR and CSA_DEBUG_LOGNAME are system properties that appear in OO Studio. For
more information on these properties, see the Configuring Workflows in the OO Studio section in the CSA for
Matrix Configuration Guide.

Troubleshooting Central Management Server

(CMS)

CMS Installation

Problem: HP SIM install fails with missing files

HP SIM install fails with log indicating missing files in the install.

Symptoms SIM install reports intermittent failures, while running the integrated installer
Hardware Any
Operating Windows
System(s)

Is this an No
integration

issue?

Primary HP SIM
software

component

Other No

dependencies

Failure message

From the HP SIM install logs, for example:

C:\HPIC\logs\ICM_2010072882213\HPIS--setup.log

[Wed Jul 28 23:03:36 MDT 2010] HPIC Install:
CopyFile(src[C:\hpsmh.ini]dest[C:\HPIC\logs\ICM_ 201007282213\ ]bAddTo
DeletionList[false])

[Wed Jul 28 23:03:36 MDT 2010] HPIC Install: CopyFile failed: File
not found

[Wed Jul 28 23:03:36 MDT 2010] HPIC Install: Trying again...

[Wed Jul 28 23:03:36 MDT 2010] HPIC Install: CopyFile failed: File
not found

[Wed Jul 28 23:03:36 MDT 2010] HPIC Install:
DeleteFile(sFile[C:\hpsmh.ini])

Probable cause

HP 10 performance of the DVD media or mounted ISO is falling below a specific
performance level.

For more
information

Review the HPIS-setup log: C:\HPIC\logs\ICM_2010072882213\HPIS--setup.log

Solution:

Run the integrated installer again.
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Problem: HP SIM install cannot access HP SA

SA server cannot be reached during the installation.

Symptoms HP SIM install refuses to carry on until HP SA server
can be accessed.

Hardware

Operating System(s) Windows

Is this an integration issue? Yes

Primary software component Integrated installer and HP SA

Other dependencies

Failure message Integrated installer does not proceed with the
installation.

Probable cause SA services could not be contacted.

For more information

Solution:
Verify that the HP SA server is UP and running all the HP SA services.

1) Login asroot to the HP SA server.
2) Runthe command /etc/init.d/opsware-sas status.
3) Review the output to see that all status messages are marked SUCCESS.

Verify that the HP SA server can be accessed using the IP address or FQDN that is given to the SIM installer by
issuing an SSH command to the HP SA server IP address or issuing FQDN.

Verify that the HP SA account given to SIM can log in to the HP SA services:
1) Openabrowsertohttps://SA-IP-Address/
2) Login to the HP SA services with the same account you are giving to the HP SIM installer for
accessing HP SA services.
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CMS Configuration

Problem: No VM ESX or Hyper-V host or network resources in HP 10 Ul

Symptoms When browsing the HP 10 homepage, previously
discovered, registered VM host resources do not
appear in the Servers or Networks tab.

Hardware

Operating System(s) Windows

Is this an integration issue? Yes

Primary software component vCenter, VMWare, VMM, HP 10, Hyper-V, LSM

Other dependencies

ESX resources may have shown up in the past or may
never have shown up after discovery.

Failure message

None. But there will be missing entries for resources
in the Servers and Networks tabs in HP 10.

Probable causes e vCenter server is down or has shut down.

e VMWare servers is down or shutdown.
e VMWare hosts are not registered with HP SIM.
e vCenter servers are not recognized by HP SIM.

e e) Hyper-V hosts are not register with HP SIM.

For more information

Solution:
Software Actions
VMWare Verify that VMWare hosts are running:

1) Login to the Windows system that is hosting the vCenter server software.
2) Open the Windows Services management console.

3) Search for the service VMWare VirtualCenter Server.

4) Its status should be Started. If it is not, start the service.

5) Set the services Startup Type to Automatic.

Hyper-V Verify that Hyper-V hosts are running.
Insight 1) Go to Options > VMware vCenter >Settings to verify that any vCenter servers are visible to Insight
Dynamics Dynamics.

2) Go to Configure> Virtual Machine>Register Virtual Machine Host to verify that VMWare hosts,
managed by the vCenter server(s), are registered.

3) Go to Configure > Virtual Machine>Register Virtual Machine Host to verify that any Hyper-V hosts
are registered.

4) Go to Tools > Virtualization manager > Tools > Logical Servers. To refresh the system, select Insight
Control virtual machine management (VMM).

NOTE: This should trigger a re-run of the API to collect hypervisor resource information within 10-15

minutes

To verify that the changes you have made:
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1) Open the HP IO Portal Networks tab and refresh to verify that the servers above can now be

seen from the UI.

2) Click the Click to refresh icon on the HP 10 Servers tab.
3) Click the Click to refresh icon on the HP |0 Networks tab.
4) Verify that the hypervisor server resources are visible.

If the resources still don’t show, do the following on the CMS:

1) Stop the HP IO service.
2) Restart the LSA service.

3) Wait until the LSA service is fully restarted, and then restart the HP |10 service.

Problem: Virtual Connect cClass blade servers do not show up in HP 10 Ul

Resources do not show up in HP |0 Ul.

Symptoms Virtual Connect cClass blade servers do not appear in
the HP 10 Server Pool tab.

Hardware

Operating System(s)

Is this an integration issue? No

Primary software component HP 10

Other dependencies

Failure message

Probable cause

e The Virtual Connect Domain Group/VCDG is not
created.

e The cClass enclosure not licensed.

e Hardware problems exist with the cClass
enclosure.

For more information

See the HP Cloud Service Automation for Matrix
Configuration Guide.

Solution:

Address and verify each probable cause listed above:

1) Verify the virtual connect domain group (VCDG) setup. If there is no setup, then create one. For

more information see the HP Cloud Service Automation for Matrix Configuration Guide, section.”

2) License the cClass enclosure. For more information, see “Configure HP |10 to use Blades” in the HP
Cloud Service Automation for Matrix Configuration Guide.
3) Verify whether or not there are hardware problems with the enclosure. Access the Virtual Connect

(VC) or Onboard Administrator (OA) to verify the settings and status of your enclosure. Sometimes a

reset of the modules is necessary, depending on the state of your enclosure.
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Problem: Cannot retrieve OS variation data for automated provisioning

HP 10 Designer is unable to retrieve the OS variation data required for automated provisioning of
deployment server to VMware VMs. This error is encountered while creating a VMWare-based VM
server in an HP 10 service template.

Symptoms This error is seen in HP 10 Designer under the
Software Selection dialog that is used to select the
OS software type for the target server.

Hardware

Operating System(s)

Is this an integration issue? Yes

Primary software component HP 10, vCenter and LSM

Other dependencies

Failure message Designer is unable to retrieve OS variation data
required for Deployment Server automated
provisioning to VMware VMs.

Probable causes e |SM service and HP 10 Ul may be out-of-sync.

vCenter server settings may be missing.

vCenter server may be down or unreachable.

VMware ESX hosts may not be registered.

e VMware ESX hosts may be down or unreachable.

For more information

Solution:

1) From the HP IO Portal, select Options > VMware vCenter Settings to verify that the correct vCenter
server settings have been provided to HP SIM.
2) Select Configure > Virtual Machine > Register Virtual Machine Hosts to verify that the VMware ESX
hosts have been discovered and registered in SIM.
3) Verify that the vCenter server is running:
a) Login tothe Windows system that is hosting the vCenter server software.
b) Open the Windows Services management console.
c) Search for this service: VMware VirtualCenter Server. Its status should be Started. If it is not,
start the service.
4) Make sure the service Startup Type is set to Automatic.
5) Verify that the VMware ESX host server(s) are running:
a) Open a browser session or vSphere client to the VMware host server(s).
b) LoginasaVMware administrator
6) Verify that the VMware ESX host server(s) can be seen by the vCenter server:
a) Open a browser session or vSphere client to the vCenter server.
b) Login as a vCenter administrator.
c) Verify that the VMware ESX hosts under management are part of the data center the
vCenter server is managing.
7) After all of the verification steps have been successfully completed, do the following on the CMS:
a) Stop the HP 10 service.
b) Restart the LSA service.
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c) Wait until the LSA service is fully restarted.

d) Restart the HP 10 service.
8) Return to the HP IO Portal and re-open the template in which you were unable to see the OS types.
9) Verify that the VMware OS types are now visible.
10) Refresh VMM by following these steps:

a) Open Virtualization Manager in the HP Insight dynamics console (Tools > Virtualization

Manager).

b) Open Refresh Server Resource Information in Virtualization Manager (tools -> Logical

Servers -> Refresh).

c) Select Insight Control virtual machine management (VMM) and click Refresh.
d) After the VMM is refreshed, log on to the 10 designer console again. The OS variations now

appear in the 10 designer.

Problem: Virtual Connect (VC) server incorrectly appears to be in use

Software resources do not show up in HP 10 Ul.

Symptoms Virtual Connect server incorrectly appears to be in
use

Hardware

Operating System(s)

Is this an integration issue? No

Primary software component HP 10

Other dependencies

Failure message

Probable cause

e The target server is powered on.

e The target server already has a profile created.

For more information

Solution:

1) Determine whether the target server is already in use and provisioned; make sure it is intended to

stay in use. If it is not intended to stay in use in the current state, power off the server.

2) Go to Tools > Integrated Consoles > VCEM > Profile. Make sure the target server has an assigned

profile. If it does, and you want to re-use your server for another provisioning, then un-assign the

profile. Then you can continue the provisioning service for this server.
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Problem: HP 10 storage pool database is corrupt

Symptoms The HP 10 database has incorrect or missing storage
pool entries.

Hardware

Operating System(s)

Is this an integration issue? Yes

Primary software component HP 10, storage pool manager

Other dependencies

Failure message

Probable cause Provisioning failures trigger the resource to be in the
wrong state or unaccounted for.

For more information

Solution:

1) Delete all Storage Pool Entries (SPEs) from logical server manager (LSM).
2) From a Command window on the CMS, stop the HP 10 service by running the following command:

net stop "HP Insight Orchestration"

3) Stop the LSM service by running the following command:

net stop "HP Logical Server Automation"

A IMPORTANT: Before proceeding, carefully understand the following:
. The Ismutil —deletedb operation deletes all of your existing logical servers
and storage from SIM.
. Once deleted, servers, storage pool entries and storage pools must be re-

discovered, re-created and re-populated.
4) Delete the LSM database by running the following command:

<VSE>\bin\lsmutil -deletedb
5) Restart LSM by running the following command:
net start "HP Logical Server Automation"

6) Wait until LSM fully starts before restarting HP 10.
7) Restart the HP 10 service by running the following command:

net start "HP Insight Orchestration"

8) Rebuild your SPEs to return the database to a consistent state.

Problem: Orphaned VMs exist in vCenter inventory

A provisioning failure leaves orphans in the VCenter database of VM storage, server or network resources.
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Symptoms The VM names are unavailable. The VMs are
inaccessible and are marked (orphaned).

Hardware

Operating System(s) Windows

Is this an integration issue? Yes

Primary software component vCenter, ESX, HP 10

Other dependencies A prior provision of servers associated with the
orphaned VMs may have failed or had problems.

Failure message None. But the unavailable, orphaned VMs appear as

shown in the figure below.

Probable cause

For more information

Solution:

1) Open the vCenter console to the inventory section.

2) Carefully review the list of allocated VMs.

3) Note if any of the VMs are unavailable and marked (orphaned).

4) Verify in HP 10, VSE, and HP SA if any of the unavailable VMs are stale entries.
5) Right-click and select Remove From Inventory for each orphaned VM.

Figure 3 View of Orphaned VMs in VCenter
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Problem: Orphaned VMs exist in ESX server

Orphaned VMs exist in VMWare server’s data stores under /vmfs/volumes.
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Symptoms A VM from an older, deleted service cannot be
recreated.

Hardware

Operating System(s) Windows

Is this an integration issue? Yes

Primary software component VMWare ESX

Other dependencies

A prior provision or de-provision of servers
associated with the orphaned VMs may have failed
or had problems.

Failure message

Orphaned VMs may collide with new VMs of the
same name.

Probable cause

For more information

Solution:

1) Logintothe VMWare server as root.
2) Change the directory:

cd /vmfs/volumes
3) Search for VMs:
find .|more

4) Look at the find output and note whether there are any .vmx files belonging to orphaned VM
servers.
5) Carefully review the list of properly allocated VMs versus potentially orphaned ones.

ﬂ Before proceeding, carefully verify in HP 10, VSE, VCenter and HP SA that any of the
suspected orphan VMs are actually orphans. Once deleted, a VM cannot be
reactivated or recovered and its storage is gone.

6) After confirming that the VMs are stale entries, remove them from the /vmmfs/volumes
subdirectory by using an rm command.

Problem: Orphaned servers observed in HP Insight Dynamics VSE Ul

A provisioning failure leaves orphaned resources in the VSE database of logical servers.

Symptoms The All Systems subfolder in the ID VSE page has
server records that are not associated with active
CSA for Matrix services.

Hardware

Operating System(s) Windows
Is this an integration issue? Yes
Primary software component VSE, HP IO

Other dependencies

A prior provision or de-provision of servers
associated with the orphaned server records may
have failed or had problems.

Failure message

None. But unaffiliated server entries appear as
shown in the figure below.
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Probable cause

For more information

Solution:

1) Login to the SIM console on the CMS.
2) Inthe All Systems folder, select System and Event Collections to check for orphaned resources:
a) Note any servers in this folder that do not have corresponding managed instances in HP I0.
b) Perform a review of what is managed in SIM, HP 10, VSE, VCEM, vCenter/ESX and Hyper-V.
c) Any server records that are stray or orphaned should be reviewed for deactivation and
removal from the All Systems folder.

Figure 4 View of Orphaned Servers in IDE VSE ID
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Problem: ESX VMs created outside of HP IO

If VMs are created outside of HP 10 on an ESX server, HP 10 takes some time to register that additional
resources have been used and could over-provision the server.

WiE

Symptoms Unexpected OS provision failures. Some may be
related to disk space and pause a VM service
creation to report that additional disk space is
required.

Hardware

Operating System(s)

Is this an integration issue?

No
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Primary software component(s) HP 10
Other dependencies ESX VMs
Failure message Various messages related to failures or out of disk
space on the ESX server.
Probable cause 10 does not scan the ESX servers at the beginning of

a service request to make sure that resources exist
for the new provision.

For more information More information may be available be in the HP 10
release notes.

Solution:

If possible, force HP 10 to do a server re-scan after VMs are created outside of HP |0 on an ESX server:
e  From the Servers tab, select Click to refresh server resources. This forces HP 10 to get updated usage

information on the servers and hypervisors that HP IO uses.

Problem: Physical resources are not returned if a provision fails

Physical resources are not returned to appropriate pools if a provision fails.

Symptoms If an OS provision fails, the physical resources
(servers and SAN storage) are not returned to a
usable state.

Hardware Physical Servers and SAN storage

Operating System(s)

Is this an integration issue? No

Primary software component(s) HP 10

Other dependencies

Failure message Any message relating to a physical server provision
operation.

Probable cause HP 10 is designed so that when a failure occurs

during the provisioning of physical servers, the
resources are left in the same state they were in
when the failure occurred. This allows the
administrator to identify and resolve the issues that
caused the failure.

For more information See the HP 10 User Guide, the HP 10 Release Notes,
and HP 10 online help.

Solution:

After triage is complete, there are a number of steps to return physical resources to a usable state:

1) Make sure the servers in question are powered off.

2) Start HP SIM. If HP SIM is SSAP mode, click Restore Size in the top left corner, so that you can see all
of the SIM menus.

3) From the Tools menu, select Virtualization Manager.

4) From the Perspective drop down box, select Logical Server.

5) Each failed server is renamed Clean-me-<Service name>. Select the check box associated
with the first server.

6) From the Visualization Tools menu, select Logical Servers > Deactivate. Follow the prompts to
deactivate the server.

7) After the server is deactivated, select the server again.
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8) From the Visualization Delete menu, select Delete Logical Server. Follow the prompts to delete the

server.

9) Go to Server Automation > Devices > Servers > Unmanaged Servers and delete the orphan record

listed in critical state which is associated to the server for which the provisioning request has failed.

10) Repeat steps five through nine for each server marked Clean-Me-<service name>.

11) Return to the HP IO page (Tools > Insight Orchestration).

12) From the Servers tab, select the server pool that the server should be associated with and click
Modify Pool.

13) From the Select servers from pool drop-down box, select Maintenance.

14) Select each server and click >> to move the server to the target server pool.

15) Click Save to save the changes.

16) Select Click to refresh server resources to update HP |0 with the state of the newly added servers.

Problem: HP 10 Service pauses because of IP Address limitation

Software resources do not show up in the HP |0 UL.

Symptoms HP 10 service pauses because of an IP address
limitation.

Hardware

Operating System(s)

Is this an integration issue? No

Primary software component HP 10

Other dependencies

Failure message

Probable cause

The network usable IP address space exceeded the
capacity.

For more information

Solution:

1) Go to Tools > Insight Orchestration > Networking.

a) Select the network used by the paused service and click Edit.

b) Under the Usable IP Address space section, verify the DCHP and Static IP Address Space,
and their usage and IP address limitation. If all of the IP addresses in the address space are

used, add extra IP addresses so the service can continue.
c) To verify the network, the address space, and the type (DCHP or Static) used by the service

template, follow these steps:

i
ii.
iii.
iv.

Go to the HP 10 Templates tab.

Select the template used by the paused service.
Click Edit.

Edit the Networking and the Server components.
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Problem: The progress of the Create Service operation is not refreshed

automatically

The progress of the Create Service operation is not refreshed automatically.

Symptoms The progress of the Create Service operation is not
refreshed automatically at the 10 request tab.

Hardware

Operating System(s)

Is this an integration issue? No

Primary software component HP 10

Other dependencies

Failure message

For more information

Solution:

To obtain the latest status, refresh the HP 10 console by using the Refresh button of the web browser.

Problem: The Create Service operation in the HP 10 console fails

The Create Service operation in the HP 10 console fails with the following error:
No MAC address found for network in HP Logical Service Automation (LSA)

service

Symptoms The Create Service operation in the HP 10 console
fails with the following error:
No MAC address found for network in
HP Logical Service Automation (LSA)
service

Hardware

Operating System(s)

Is this an integration issue? No

Primary software component HP 10

Other dependencies

Failure message

Task for Logical Server <system_name> has failed.
Logical server job (ID = <system_name>.vlan8.lab)
completed with a failure status. Failure: No MAC
address was found for network VLAN8_Network in
HP Logical Service Automation (LSA) service.

Probable cause

The template in the HP |0 designer does not reflect
the selected network. The template instead displays
the default network.

For more information

Solution:

1) Logon tothe HP IO designer.

2) Open the template that you are using to create the service.

3) Check the name of the network on it. If the displayed network name is not the same as the name of
the required network, double-click the network object.

4) Uncheck and check the network required. Now the template should display the correct network

name.

5) Save the template, and then recreate the 10 service.
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Problem: Server registeration fails during the Create Service operation

The Create Service operation in the HP 10 console fails with the following error:

Failure: Encountered problem with the Deployment Server Access Layer

Symptoms The Create Service operation in the HP 10 console
fails with the following error:
Failure: Encountered problem with
the Deployment Server Access Layer

Hardware

Operating System(s)

Is this an integration issue? No

Primary software component HP 10

Other dependencies HP SA

Failure message

Task for Logical Server <server_name> has failed.
Logical server job (ID = <server_name>.vlan7.lab)
completed with a failure status. Failure:
Encountered problem with the Deployment Server
Access Layer.

Probable cause

The version of the opswclient.jar file on the CMS
does not match with the version of the opswclient.jar
file on the SA Core.

For more information

Solution:

1.
Insight Manager\1lib folder on the CMS.

Delete the existing opswclient. jar file from the C: \Program Files\HP\Systems

INF/1lib/opswclient.jar (alternative

2. From the SA Core, copy the opswclient . jar file from the location
/opt/opsware/da/webapps/arm/WEB-
location: /opt/opsware/twist/extlib/client/opswclient.jar), and then place the
fileinthe C:\Program Files\HP\Systems Insight Manager\1lib folder on the CMS.

3. Restart the “HP System Insight Manager” service.

4. Recreate the IO service now.
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Problem: HP ProlLiant DL servers remain in the powered ON state when the
Delete Service operation is complete

HP ProLiant DL servers remain in the powered ON state even after the Delete Service operation is completed
in the 10 console.

Symptoms After the Delete Service operation is completed in

the 10 console, HP ProLiant DL servers remain in the
powered ON state.

Hardware

Operating System(s)

Is this an integration issue? No
Primary software component HP 10

Other dependencies

Solution:

After deleting the service for the HP ProLiant DL server, follow these steps:

1.
2.

Open the iLO of the server and power it off.
Run a logical server refresh of the static servers.

The server is now ready to be allocated for a new service.

To automatically power OFF the servers after service deletion, follow these steps:

1.
2.
3.

On the CMS, go to the <HPIO_Install_dir>/conf directory

Open the hpio.properties file.

Change the power .preserve.onfailure =true settingto
power .preserve.onfailure =false.

Restartthe HP Insight Orchestration service.
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Problem: Data disks added to a target server using dynamic Storage Pool
Entry (SPE) are not visible

Data disks added to a target server using dynamic Storage Pool Entry (SPE) are not visible.

Symptoms Data disks added to a target server using dynamic
Storage Pool Entry (SPE) are not visible.

Hardware

Operating System(s)

Is this an integration issue? No

Primary software component HP 10

Other dependencies

Solution:

If the data disk added to a target server is not visible after service completion, verify that the data volume
added is masked in the SPE.
In the SPE, if the data volume added is unmasked, follow these steps:

1. Remove the volume from the SPE.

2. Save the SPE.
3. Add the volume into the SPE again, and save the SPE.
4. Rescan the disks on the target server. The disk should now be visible.
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Problem: Error while creating dynamic storage pool entry (SPE)

The following error appears in the HP 10 console while creating dynamic storage pool entry (SPE):
presentation completed with errors

Symptoms The following error appears in the HP 10 console
while creating dynamic storage pool entry (SPE):
presentation completed with errors

Hardware

Operating System(s)

Is this an integration issue? No

Primary software component HP 10

Other dependencies HP OO, ESA

Failure message presentation completed with errors

Probable cause If the failure occurs with the EMC CLARIiON array

volume presentation, the target initiator port may
not have been registered with the EMC CLARIiiON
array.

If the failure occurs with the HDS or XP array volume,
the time taken for the volume presentation to the
server under the given configuration might be longer
than the default time-out value.

For more information

Solution:

If the failure occurs with the EMC CLARIiON array volume presentation, verify that the target initiator
port is registered with the array. If not, register the port, and then try the presentation again.

If the failure occurs for the HDS or XP array volume presentation, increase the default time-out value to

complete the volume presentation successfully, and then try the presentation again. See the CSA for
Matrix Configuration Guide for more details on increasing the default time-out value.
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Problem: Virtual server disappears from the Server Pool

Symptoms Virtual server disappears from the Server Pool.
Hardware

Operating System(s)

Is this an integration issue? No

Primary software component HP 10 and HP SIM

Other dependencies

Failure message

Probable cause e ESX or Hyper-V services have been stopped.

e HP SIM is missing the login credentials for ESX
/Hyper-V.

Solution:

1) Verify system and application events.
a) Verify whether or not the services for ESX and Hyper-V server are running.
b) Restart the services if necessary. NOTE: Hyper-V may require that you restart the following system
services:
services : Hyper-v Image Management, Hyper-V Networking Management, Hyper-V Virtual
Machine Management
2) Select Options > Security > Credentials.
3) Add ESX and/or Hyper-V login credentials to both HP SIM system credentials and global
credentials under SIM menu. NOTE: You may need to identify /re-discover ESX and/or Hyper-V
via HP SIM discovery.

Problem: Non-VC-enabled servers do not appear in HP |10 Ul

Symptoms Non-VC-enabled servers do not appear under the
HP 10 Ul Server Pools tab.

Hardware

Operating System(s)

Is this an integration issue? Yes

Primary software component CSA for Matirx, HP 10, LSM, ESAS, and OO

Other dependencies

Failure message

Probable cause One of the following:
e Incorrect OO credentials have been added to the

following file: esa.properties

e Incorrect tags or values have been added to the
three flow-input data files:

o ServerInfo.xml
o InventoryList.xml

o uuildHostMapper.xml
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e Mismatched UUID element values exist between
the three files:

o ServerInfo.xml
o InventoryList.xml

o uuildHostMapper.xml

e Missing identification information exists for a

ProLiant server in the following file:
blade_models.properties

e Incorrect ILO credentials exist for the target
server listed by 0O.

e LSM database is out-of-sync.

HP 10 database is out-of-sync.

For more information See the HP Insight Orchestration User Guide.

Solution:

Verify that the CSA for Matrix flows that are being used to import the server inventory have run to
completion correctly. Follow these steps:

1) From a browser window, log in to the OO Central dashboard on the CMS by entering the following
command: https://localhost:16443/PAS/static/Login.htm

NOTE: Use the CMS administrator credentials you provided at CMS installation.

2) Check the entries for the following flows to see if they have been run since restarting the services:
e GetServerInventory
e GetServerInfo
3) Check to see if the most recent Get ServerInventory flow succeeded.
4) Check to see if the most recent GetServerInfo flows succeeded. NOTE: There should be one run
of the GetServerInfo flow for each server entry in InventoryList.xml.
5) If any of the flows failed, you may be able to determine what went wrong by drilling down into the
details of the failed flow:
a) Right-click one of the failed flows in the OO Central dashboard.
b) Try to determine what may have triggered the failure. Common problems are malformed or
missing tags or values in the XML files.
6) Verify the following regarding InventoryList.xml, serverInfo.xml and
uuidHostMapper .xml:
a) Are these files in the right directory for the OO import workflows to find them?
b) Do these files have syntax, format, or content errors?
c) If either of the above conditions is present, fix the problems.

NOTE: These XML files are closely correlated, so it is important to verify that:

e TInventoryList.xml has corresponding entries for each entry in serverInfo.xmnl file
and vice-versa.
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e uuidHostMapper .xml has corresponding entries for each entry in the
inventoryList.xml and vice-versa.
e The UUID element is an index to identify each entry across these XML files. The value of the

UUID tag in each file must match across all three files: ServerInfo.xml,
InventoryList.xml, uuidHostMapper.xml

For more information about how these files are related, see “Configuring 10 to list heterogeneous hardware”
in the HP Insight Orchestration User Guide.

Verify the credentials that the CSA for Matrix flows used for OO sign-in. Follow these steps:

1) Verify that <Root Drive>:\Program Files\HP\Virtual Server
Environment\conf\esa.properties includes the correct OO administrator password in the
entry: esa.0o0.admin.password=<your-oo-admin-password>

2) Verify and (if necessary) add entries to the file: C: \Program Files\HP\Insight
Orchestration\conf\blade_models.properties
NOTE: Include all the Non-VC-enabled server models for each server model defined in the XML files. For
more information see “Configuring IO to list heterogeneous hardware” in the HP Insight Orchestration
User Guide.

3) Verify and (if necessary) correct iLO system credentials in OO for the non-VC-enabled server models. For
more information, see “Configuring IO to list heterogeneous hardware” HP Insight Orchestration User
Guide.

4) After making any corrections using the steps above, restart the following services on the CMS (in the
order given):

a) Stop these OO0 and other services on the CMS:

net stop "RSScheduler"

net stop "RSCentral"

net stop "RSJRAS"

net stop "HP Extensible Storage & Server Adapter"
net stop "HP Logical Server Automation"

net stop "HP Insight Orchestration"

b) Restart the services in the following order:

net start "RSScheduler"

net start "RSCentral"

net start "RSJRAS"

net start "HP Extensible Storage & Server Adapter"
net start "HP Logical Server Automation"

(Pause here a minute or two until the HP Logical Server Automation service is fully started.)
net start "HP Insight Orchestration"

¢) Wait about 10-15 minutes for the following CSA for Matrix flows to run:
e GetServerInventory
[ GetServerInfo
d) Then verify that the flows were run after the services above restart. To verify that the flows were
successfully run, do the following:
i From a browser window and using OO administrator credentials, log in to the OO
Central dashboard on the CMS at https://localhost:16443/PAS/static/Login.htm.
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ii. Check the entries for the flows GetServerlnventory and GetServerinfo to see if they
have been run since restarting the services

iii. Make sure the most recent GetServerlnventory flow succeeded.

iv. Make sure the most recent GetServerinfo flows succeeded. There should be
one run of the GetServerinfo flow for each server entry in the inventoryList.xml file.

When the steps above have been successfully completed, return to the HP IO Servers tab. Refresh and then
verify that the servers you defined can be seen in the Unassigned server pool.

Problem: A CSA for Matrix service delete fails

Symptoms A CSA for Matrix service delete fails.

Hardware

Operating System(s)

Primary software component HP 10 and HP SA

Other dependencies HP 10 and HP SA

Failure message There might be a message in the HP 10 or ALC log files, but
not always.

Probable cause e  Erase disk APX failed.

e The HP SA server record is stuck in an intermediate state.

e There are connectivity or NIC driver problems to the OS
of the target being deleted.

e The deactivate/delete operation of the logical server for
the target server failed.

For more information

Solution:

HP |10 attempts to automatically handle failure conditions by removing the failed target server from the HP SA
primary core. This action allows the server to be re-used without further intervention once the underlying
error condition has been triaged and resolved. The one exception to this is a failure during the erase disk
process described below.

Erase disk fails

If HP 10 cannot successfully clean the disks on the target server during service delete, the server is placed into
a maintenance pool and a best effort is made to remove the server from the HP SA primary core. If the server
cannot be removed from the HP SA primary core, it is vital that the server be manually removed from the

HP SA primary core prior to attempting a new create service request involving the server. When this problem
is encountered, it is most often necessary to go to the HP Server Automation CLIENT and explicitly remove
the existing server record from the HP SA primary core. Then re-try the create service request, as shown in
the figure below:
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Figure 5 Service Delete Fails
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The server record in the figure above exists and is in an unreachable state. If HP IO attempts to re-provision
that the server in this state, the process fails during server registration. The workaround is to explicitly delete
the server from HP SA by right-clicking on the server and selecting Delete Server. This scenario does not
happen often, but can occur if there was a manual clean-up operation that has been run at the HP 10 or
Insight Dynamics level without also cleaning the server record from within HP SA.

Logical server cleanup process on a failed request
If HP 10 has detected a failure involving a server, three things may occur:

1) The server is re-named with a “clean-me” prefix within the Insight Dynamics Operations Console.
2) It will be powered off.
3) It may be continue to be registered on the HP SA primary core.

This is intentional and leaves the failed server in a state where it cannot be inadvertently reused in another
create service request until the underlying issues have been triaged and resolved. Therefore, server is left “in-
tact” so that the administrator can work with the server in its failed state to determine the failure condition.
Once the server has been repaired and is ready to be re-admitted into the free pool, perform the steps
below.

1) On the HP SA primary core, using the HP Server Automation CLIENT, locate the server record under
either All Managed Servers or Unprovisioned Servers.

2) Deactivate and then Delete the server.

3) Onthe CMS, using the Insight Dynamics Operations Console and the Logical Server view, locate the

server as shown in figure below:
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Figure 6 Locate the Server
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4)
5)

Select the server that is currently in an active state.
Deactivate the server.

a. From the Perspective drop-down box, select Logical Server.
b. Each failed server is renamed Clean-me-<Service name>.
c. From the Visualization Tools menu, select Logical Servers > Deactivate. Follow the

prompts to deactivate the server.
Once the server is deactivated, return to the Operations Console Logical Server view.
Select the server. From the Visualization Delete menu, select Delete Logical Server. Follow the
prompts to delete it as shown in figure below.

6)
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Figure 7 Delete the Server
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8) Following this process, the physical server remains assigned to the maintenance pool. Using the
HP 10 Operations Console, move the server from the Maintenance pool to its target pool.

9) Once the server has been moved back into the target pool, it can be used for a new create service
request.

Problem: A CSA for Matrix service create fails

Symptoms In the request summary, a service create is reported
as failed for a variety of reasons.

Hardware

Operating System(s)

Primary software component HP 10 and HP SA

Other dependencies HP 10 and HP SA

Failure message There might be a message in the HP 10 or ALC log
files, but not always.

Probable cause . A server with a duplicate UUID was

already provisioned by HP SA in a previous
service create request.

. A previous service create request failed
and the HP SA server has a stale server record
stuck in an intermediate state.

° There are connectivity or NIC driver
problems with the OS being deployed to the
target.
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. The HP SA OS personalization APX's may
not support the OS you are trying to provision.

For more information

Solution:

There are several error conditions that may occur related to HP SA integration. The first scenario usually
occurs if HP SA already has a server record for a server and the server is in the wrong lifecycle state. The next
scenario is not specific to the HP SA integration, but typically indicates a basic OS Policy or Application Policy
issue. The last scenario may occur if the personalization APX that is included with the HP SA integration
encounters some sort of environmental condition on the target OS.

"Unable to register server" in the HP 10 request log

When this error occurs, it is almost always necessary to go to the HP Server Automation CLIENT and explicitly
remove the existing server record from the HP SA primary core. Then re-try the create service request, as
shown in the figure below.

Figure 8 Unable to Register Server
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In this scenario, the server record above exists but is in an unreachable state. If HP 10 attempts to re-
provision that the server in this state, the process fails during server registration.

The workaround is to explicitly delete the server from HP SA by right-clicking on the server and selecting
Delete Server. This scenario does not happen often, but can occur if there was a manual clean-up operation
that has been run at the HP 10 or Insight Dynamics level without also cleaning the server record from within
HP SA.

OS Policy or Application Policy fails.
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In scenarios where an OS Policy or an Application Policy fails, the first level of triage must occur within HP
Server Automation CLIENT as shown in the figures below.

Figure 9 Job Logs
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In this scenario, the OS policy has failed following the initial reboot. The typical cause is either an intermittent
network problem between the target server and the HP SA primary core, or a missing NIC driver in the OS
policy. Assuming network connectivity is stable, the solution is to locate the NIC driver required for the target
server type and update the OS Policy.

OS personalization fails

OS Personalization typically fails if there is some sort of HP SA agent connectivity issue following the OS Policy
deployment process. If this occurs, consult the job log details for the failure. If network connectivity between
the HP SA primary core and the target server has not been compromised, it may be necessary to contact HP
Support regarding the failure condition. If testing is being performed for OS types outside those explicitly
supported in the Cloud Service Automation for Matrix Configuration Guide, it is possible that the current

HP SA personalization APX does not yet support the target OS.

Problem: The Create Service operation fails with timeout

The Create Service operation in HP 10 fails due to timeout.

Symptoms The Create Service operation in HP 10 fails due to
timeout.

Hardware

Operating System(s)

Is this an integration issue? No

Primary software component HP 10

Other dependencies SA

Failure message

Probable cause Time taken by the job to create a single logical server
exceeds the default timeout value set by HP |10
properties.

Solution:

Edit the hpio.properties file to increase the timeout value.
1) Open the hpio.properties file found at the location <HPIO Install directory>/conf.

2) For physical servers, edit the property timeout.create.physical.logicalserver. Set the property to 180
(minutes) or more (default: 120 minutes).

3) For virtual servers, edit the property timeout.create.virtual.logicalserver. Set the property to 180
(minutes) or more (default: 120 minutes).

4) Save the file.

5) Restart the HP Insight Orchestration service.

Similarly, you can change the timeout value for the Delete Service operation too.

Problem: Local disk configured for a physical server is not visible in HP IO

Local disk configured for a physical server is not visible in HP 10.

Symptoms The Local Disks field for a physical server in HP 10 is
empty after configuring the local disk for the server
by using Ismutil.

Hardware

Operating System(s)

Is this an integration issue? No
Primary software component HP IO

Other dependencies

Failure message
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Probable cause

LSM annotations in the XML file contains some
empty tags.

Solution:

1) Discover the physical server.

2) Onthe CMS, open a command prompt and run the following command to export LSM annotations:

Ismutil -export -an -file Ism.xml

3) Edit the local disk section <CliLocalDisk></CliLocalDisk> for each of the servers in the file Ism.xml:

NOTE: Do not leave empty tags, otherwise the disk will not be updated to LSM.
<CliComputePhysical>

<name>USE6452ADF</name>
<uuid>36343034-3736-5355-4536-343532414446</uuid>
<portabilityGroupIld>123</portabilityGroupId>
<portabilityGroupName>VC GP</portabilityGroupName>
<CliLocalDisk>

<name>DAS</name>

<description>Test</description>
<deviceType>0</deviceType>
<storageType>0</storageType>
<storageDeviceType>0</storageDeviceType>
<storageSizeType>MB</storageSizeType>
<raidLevel>NONE</raidLevel>
<volumeNumber>1</volumeNumber>
<storageSize>10000</storageSize>
<sharable>false</sharable>
<storageSpeed>0</storageSpeed>
<diskStatus>AVAILABLE</diskStatus>
</CliLocalDisk>

</CliComputePhysical>

4) Save the changes.

5) Import LSM annotations by running the following command:

Ismutil -import -an -file Ism.xml

6) Refresh LSM logical servers.

7) Refresh HP |0 Server resources. The server is now updated with local disks.

Problem: OOWEF servers show “in use” status

Operations Orchestration Workflows (OOWF) servers are discovered by HP 10, but the server status is always

shown as “in use”.

Symptoms OOWEF server status is “in use”.
Hardware

Operating System(s)

Is this an integration issue? No

Primary software component HP 10

Other dependencies HP OO

Failure message

Probable cause

The OOWF server’s ILO credentials are not correctly
configured on HP OO System accounts ILOUser.
Because of this, 00 workflows fail to get the power
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status of servers; HP 10 reflects this as always “in

”

use".

For more information

Solution:
8) Add the ILO credentials in the HP OO System Accounts ILOUser by following these steps:

a) Launch the OO studio (Start > Programs > Hewlett-Packard > Operation Orchestration > HP
Operation Orchestration Studio)

b) Go to Configuration > System Accounts > ILOUser

c) Check-out the ILOUser System Account by clicking the Lock icon.

d) Add or edit the ILO credentials and description. NOTE: These credentials are used when OOWF
servers get power status. This should be common for all OOWF servers.

e) Check-in your changes by clicking Lock icon.

f)  Refresh the Logical Servers on Insight Dynamics to reinitiate OOWF server discovery.

Problem: HP 10 shows blade status as always “in-use”

HP 10 shows bade status as always “in-use”, even after cleaning up the Logical Server Entry.

Symptoms HP 10 shows blade status as always “in-use” even
after cleaning up the Logical Server Entry.

Hardware

Operating System(s)

Is this an integration issue? No

Primary software component HP 10

Other dependencies

Failure message Blade is already in use

Probable cause A Virtual Connect (VC) profile is already assigned to
the server.

For more information

Solution:

1) Check to see if a VC profile is already assigned to the server. NOTE: The VC profile is not
automatically unassigned during blade logical server clean-up. The profile has to be manually
unassigned to make the blade server available for further use.

2) If a VC profile is already assigned, un-assign the profile and wait until un-assign job completes.

The status of the blade server changes to “Unused” after the un-assign job completes and the blade
server is now available for other services.

Problem: HP 10 service fails with “Operation not completed” error

HP 10 service fails with this error message: “Operation not completed. [Error during Create server profile]”

Symptoms The HP 10 Create Service fails with this error:
“Operation not completed. [Error
during Create server profile (..)]”

Hardware

Operating System(s)

Is this an integration issue? No
Primary software component HP 10
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Other dependencies

Failure message See below for an example message:

"Operation not completed. [Error
during Create server profile
[BLWin2k8x323701_12a00cd80ce] .
Details: There was a problem
allocating the WWN address
50:01:43:80:02:A3:00:f0. Possible
causes are: 1) The address is being
requested by an upper level manager
but it was not previously reserved.
2) The address is part of an
exclusion range. 3) The address does
not belong to any range known to
VCEM. To resolve this issue,
respectively: 1) Verify the address
is reserved by the upper level
manager application by checking the
owner field of this address is
correctly set. 2) Remove or adjust
the exclusion range to leave out the
address from the exclusion range. 3)
Create a user defined address range
that contains all the addresses in
use by the server profiles. Then try
to perform the Create Profile
operation again.]"

Probable cause The WWN used by the SPE is already in use by the
VCEM.

For more information

Solution:

1) Check the Worldwide Name (WWN) assigned to Storage Pool Entry (SPE) used by the service:
a) Isthe status “in-use” with an owner assigned to it?
b) Is the status “free” with an owner assigned to it?
NOTE: The Create service fails in both the cases with the failure message shown in the table above.
2) Modify all the matching SPEs with free WWNs on VCEM (status must be “free” with no assigned
owners).
3) Clean up the Logical Server and create the service again.

Troubleshooting HP SiteScope
HP SiteScope Client Access

Problem: Cannot access HP SiteScope using a browser

Various conditions cause the HP SiteScope Java Application to display incorrectly in the browser.

Symptoms The browser displays “HP SiteScope" at the top of the
frame, but shows only a small red [x] instead of the HP
SiteScope application.

Hardware

Operating System(s) Windows
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Primary software component

SiteScope

Other dependencies

Failure message

Probable cause

As a pre-requisite for displaying the HP SiteScope client,
your browser must have the Java plug-in version 1.6
installed and enabled. In some cases, you must also flush
the Java plug-in cache of temporary files. The Java plug-in
can be downloaded from here

How to access log files

On the HP SiteScope server, the most important log files for
diagnosing problems are shown in the example below:

c:\SiteScope\logs\error.log
c:\SiteScope\logs\SiteScope2010_06_15.1log
c:\SiteScope\logs\RunMonitor.log

For more information

HP SiteScope Documentation is location below the Install
directory. By default, it can be found at C:\SiteScope\docs

Solution:

1) Download and install the Java plug-in on each client system, as required.

2) Determine the correct URL for the HP SiteScope server. The following example assumes that the HP
SiteScope server hostname is sitescopeServer, and that the server is configured to listen on port
8080 (the installation default port number): http://sitescopeServer:8080/SiteScope/

IMPORTANT: You must replace the hostname and port number in the example URL above with the values
you specified in the csaInstall.properties file during the CSA for Matrix oo-sis-install process.

3) Verify that the HP SiteScope server has a Java process listening on the port number specified in the

HP SiteScope URL (see step above):

a) From the HP SiteScope server command line, enter the following command:

netstat

—anob > netstat.out

b) View the output file netstat.out in an editor.
c) Verify that SiteScope.exe is on the specified port.

d) If necessary, restart the HP SiteScope process:

net start SiteScope

4) From each client system:

a) Install or verify installation of the Java plug-in.

b) Flush the browser cache, and quit all browser instances.

c) Flush the Java cache as follows:

i) Go to the Control Panel.

ii) Launch the Java Configuration Applet.

iii) Under General > Temporary Internet Files, click Delete Files.
iv) Click Settings > Delete Files.
v) Select all checkboxes, and press OK.

5) Start up a new browser session pointing to the new HP SiteScope URL.
a) Ifthe URL brings up a web page with “HP SiteScope” at the top, you know that the URL is
correct and that the HP SiteScope service is running.
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b) If the page displays a red X instead of the normal HP SiteScope application display, as shown
in the figure below, follow these steps:
i) Install the Java plug-in on all client systems that connect to HP SiteScope
ii) Verify that Java is enabled in the browser.

Figure 11 HP SiteScope Browser Not Displaying
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HP SiteScope CPU Monitor Configuration

Problem: The CPU monitor is not reporting on a Linux target

On a Linux target, the Disk and memory monitors are reporting, but the CPU monitor is not.

Symptoms In the HP SiteScope dashboard, the CPU monitor for
a Linux target, shows a red circled x, instead of
showing a true measure for CPU usage. The disk and
memory monitor reporting is OK.

Hardware

Operating System(s) RHELS5 or Susel0 Linux

Is this and integration issue? No

Primary software component HP SA OS installation profile

Other dependencies

Failure message

Probable cause Missing sysstat module in the Linux kernel of the
target OS.

For more information

Solution:

Verify that the sysstat package has been installed and is available on the Linux OS that was provisioned to
the server. To do this, follow these steps:
1) Login asroot to a target server running the Linux OS that is failing to produce data for the CPU

monitor.

2) Enter the mpstat command from a terminal session on that target. NOTE: If the mpstat
command is not found, you must install and activate the sysstat RPM package. HP SiteScope uses
the mpstat command on the Linux target to retrieve CPU values.

3) If the target OS is missing the sysstat package, follow these instructions to install and configure
the package:

RedHat Enterprise Linux (version 5, by default, does not have sysstat installed)
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1) Add adirective to the kickstart.cfg toinclude the sysstat package in the kernel upon
install. Modify the kickstart.cfgfile (from the OS Installation profile) by adding the single line
to the end of the kickstart.cfgfile:
sysstat

2) From the HP SA server’s NGUI interface, upload the new kickstart . cfg file to the RHEL5 OS
Installation profile.

Suse Linux

1) Add a directive to trigger YAST to install sysstat for you. You can edit the autoinst .xml
response file for SUSE and search for <software>.

2) If you already have the following:
<packages config:type="list">
</packages>
Then add this line:
<package>sysstat</package>
If not, insert the following lines just above </software>
<packages config:type="list">

<package>sysstat</package>

</packages>

3) Upload the new autoinst.xml from the HP SA server’s NGUI interface to the SUSE OS

installation profile.

HP SiteScope Installation

Problem: Problems with HP SiteScope templates

After installing HP SiteScope with CSA for Matrix templates, you would like to diagnose any problems that
may exist. There are several conditions that should be verified:

SiteScope service is running

The HP SiteScope Client Application Help->About SiteScope shows Version 11.10

The HP SiteScope Client Application shows a template container named CSA templates
CSA templates for WINDOWS and LINUX can be manually deployed

No errors are reported in the HP SiteScope error.log file

Symptoms e Wrong HP SiteScope version number

Client URL doesn’t seem to work

e  CSA templates container not present

Manual deployments fail

Hardware

Operating System(s) Windows
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Primary software component

SiteScope

Other dependencies

Failure message

Probable causes

1) SiteScope service is not running

2) CSA templates were not imported during the oo-sis-
install process

3) Wrong user name or password configured in one or
both of the HP SiteScope target credentials:

o WINDOWS-CSA-TARGETS
o0 LINUX-CSA-TARGETS

How to access log files

On the HP SiteScope server, the most important log files for
diagnosing problems are:

c:\SiteScope\logs\error.log
c:\SiteScope\logs\SiteScope2011_06_15.1log
c:\SiteScope\logs\RunMonitor.log

NOTE: example filename for June 15, 2011

For more information

0O0-SIS installation steps in the Cloud Service Automation for
Matrix Configuration Guide.

Solution

1) HP SiteScope service is not running

a) Verify that SiteScope.exe is listening on the port number specified during HP SiteScope

installation.

net start SiteScope

netstat —-anob > netstat.out

b) Reviewnetstat.out inan editor.
c) The port number must also match the value defined in csaInstall.properties during
the oo-sis-install process on the CMS (this is needed for OO to connect to HP SiteScope during

monitor deploy and delete).

2) HP SiteScope version number is incorrect (patch not installed).

See the CSA for Matrix Support Matrix to locate supported versions.
If an unsupported version of HP SiteScope has been installed:

i) Remove the incorrect version of HP SiteScope.

ii) Install the correct SiteScope version.

3) A Container named CSA templates is not present in the HP SiteScope client.

If the CSA Templates folder does not appear in the Templates folder in the SiteScope dashboard
after installation, this indicates that the oo-sis-install process was not successful.

There are two possible solutions:

a) Copy the file CSA-servers-autoimport. tmpl (located in CSA4M.zip) to directory
C:\SiteScope\persistency\import\

After 90 seconds, the CSA templates container should appear under the HP SiteScope client
Templates view. Otherwise, review error messages in
c:\SiteScope\logs\error. log for clues.

Page | 46




HP CSA for Matrix Troubleshooting Guide

2011, June

b) The alternate solution is to manually import CSA for Matrix flows, and manually create the
associated target credentials.

i) Copythe file CSA-servers.tmpl (located in CSA4M. zip) to directory
c:\SiteScope\export\.
ii) Create the CSA templates container by right clicking on HP SiteScope in the
HP SiteScope client Templates view and selecting New > Template Container.
iiii) Name the new container CSA templates (NOTE: spelling is case sensitive, and must
be correct in order to match the expectations of the CSA OO flows).
iv) Right click on the new container and select import.
V) Verify that the Path value shows “c:\SiteScope\export” (this is the directory where
you should have copied the .tmpl file).
vi) After the file name prompt, enter: CSA-servers. tmpl
vii) If the import fails, review the error messages in
c:\SiteScope\logs\error. log.
viii) If the import is successful, two new templates will appear under the CSA templates
container, named WINDOWS and LINUX.

NOTES: The HP SiteScope client URL must be based on the HP SiteScope server hostname, and the port
number specified during HP SiteScope installation. These values must also match the IP address and port
number specified during the CSA oo-sis-install process (in the csaInstaller.properties file) on the
CMS server.

Figure 12 CSA Templates Folder
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Problem: Communication error between HP OO and HPIO

At the end of a successful completion of a service provision, an error is listed in the Request Details in HP 10.
No monitors are deployed to monitor any of the servers in the service.

Symptoms

At the end of a successful completion of a service provision, an
error is listed in the Request Details in HP 10.

Hardware

Operating System(s)

Is this an integration issue?

Yes

Primary software component(s)

HP 10, HP SiteScope

Failure message

"09/01/2010 10:00 AM",MAJOR, "A
communication error occurred between
Operations Orchestration and Insight
Orchestration, the external workflow
Deploy Monitors cannot be executed. The
current request will continue its
execution."

Probable cause

The template in use is configured with the OO workflows to
manage the HP SiteScope monitors. However, the workflows
are not installed on the OO server used by HP 10. This can
occur if the template is exported and then imported into an
HP 10 configuration where the OO_SiS work flows have not yet
been installed.

For more information

See the OO-SIS installation steps in the Cloud Service
Automation for Matrix Configuration Guide.

Solution:

Install the OO-SiteScope workflows as described the Cloud Service Automation for Matrix Configuration

Guide.

Problem: Monitor Deployment on SiteScope fails

Monitor deployment on the SiteScope server fails.

Symptoms Monitor deployment on the SiteScope server fails.
Hardware

Operating System(s)

Is this an integration issue? Yes

Primary software component(s) HP SiteScope

Other dependencies 00

Probable cause

e SiteScope extension license is missing.

e Some of the inputs needed for the deployment are
specified incorrectly.

e SiteScope is configured to use secured APIs.

Solution:

1. If deploying a solution template fails, verify that the extension license for the respective solution

template is installed.
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2. Verify that the required inputs for deploying the template are correctly configured in OO Studio.
Check the required system properties and system accounts.
3. Onthe SiteScope server, verify that the required credential profiles are configured correctly.
4. On the SiteScope server, remove secure APl configuration by following these steps:
a. Stop the SiteScope service:
c:\> net stop SiteScope
b. Open the SiteScope master configuration file located at
"c:\SiteScope\groups\master.config"
c. Change the following property value from true to false:
"_accessControlled=false"
d. Save thefile.
e. Restart the SiteScope service:
c:\> net start SiteScope

SiteScope Configuration

Problem: The Deploy Monitors operation fails to create monitor

A Deploy Monitors OO workflow triggered by an HP 10 workflow callout fails to create the target(s) monitor
in the HP SiteScope server.

Symptoms A “Deploy Monitors” operation to instantiate CPU, DISK and MEMORY
monitors for a provisioned target fails to create a monitor and the
monitor does not appear in the HP SiteScope server dashboard.

Hardware

Operating System(s) Windows 2003

Is this an integration issue? Yes

Primary software component HP SiteScope server

Other dependencies

Failure message In the OO log on the CMS for the “Deploy Monitors” flow, you may see an

error similar to this one:
com.mercury.sitescope.api.configuration.exception.
ExternalServiceAPIException: Error: Parameter
error occurred property The following properties
had verification errors: Property Disk : / 1s not
a valid digk drive

Error: Error Code: 12017. Error Description:
Unable to deploy the template because it contains
a reference to a credential (LINUX-CSA-TARGETS)
that no longer exists in SiteScope. Add the
migsing credential to Credential Preferences or
manually enter credentials for the resource in the
template object, and deploy the template

again. ;returnResult=Unknown error:
com.mercury.sitescope.api.configuration.exception.
ExternalServiceAPIException

Probable cause The credentials for the OS deployed in the credentials profile—(in this
case LINUX-CSA-TARGETS) either don’t exist on the HP SiteScope server,
or they do not match sufficient credentials on the deployed target’s OS to
initiate monitoring of the target.

How to access log files Log onto CMS and look at the OO central service under the URL:
https://localhost:16443/PAS/app
a) Navigate to the Reports section.
b) Select the instance of the flow run that corresponds to the failed
flow.
c) Enable Advanced viewing of the flows operations.
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d) Add Result to the Report Columns and look for an error similar to
the “Failure message” above in the results for the “Deploy
Template” Step# column.

For more information

Solution:

1) Go to the HP SiteScope dashboard on your HP SiteScope server.

2) Open the Preferences dialog.

3) Open the Credential Preferences dialog.

4) Add or repair the “LINUX-CSA-TARGETS” credentials object to match the credentials for the Linux OS’
of your target(s).

5) While you are in this part of the HP SiteScope dashboard, also verify that the “WINDOWS-CSA-
TARGETS” credentials object matches the credentials for the Windows operating system of your
target(s).

Problem: Application monitor deployment fails

Symptoms Application monitor deployment on managed systems fails.
Hardware
Operating System(s)
Is this an integration issue?
Primary software component SiteScope
Other dependencies 00
Probable cause e If you attempt to deploy application monitors on a managed
server without deploying the server monitor, the deployment
fails.
e  While deploying solution templates, the SiteScope extension
license is missing.
e System accounts or properties needed for the application are
configured incorrectly.

Solution:

e Add the server monitors for the server before deploying the application monitors. In the HP 10
template, add the workflows for server monitoring before application monitoring workflows.

e  Verify that the extension license for the solution template is installed.

e Verify that the required system properties and system accounts for the application are correctly
configured in OO Studio.

Problem: Orphaned entries exist in the HP SiteScope console under the
Remote Servers tab

Symptoms Lists of no longer monitored or non-existent servers have stale entries in
the HP Site Remote Servers tab

Hardware

Operating System(s) Windows

Is this an integration issue? Yes

Primary software component SiteScope

Other dependencies A prior de-provision of managed servers cannot delete the remote server
entries.

Failure message None. Orphaned remote servers may collide with new service deploys
with different monitoring credentials.
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Probable cause Bad or incorrect SAN zoning
Bad or incorrect WWN’s
Bad or incorrect LUN mapping

How to access log files NA

For more information

Figure 13 New Service Deploys with Different Monitoring Credentials
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e Login to the HP SiteScope dashboard on your HP SiteScope server.

e Open the Remote Servers tab from the lower left.

e Review the list of Microsoft Windows Remote Servers and UNIX Remote Servers for extraneous
entries.

e Open the Microsoft Windows Remote Servers folder and select with left clicks any extraneous
servers.

e Left click the red-X to Delete Remote Server in that pane

e Repeat the steps for any extraneous servers in the UNIX Remote Servers folder
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Troubleshooting CSA for Matrix Workflows

Problem: CSA for Matrix flows do not appear in HP OO Studio

If CSA for Matrix HP OO flows do not appear after running the CSA for Matrix flows installer you can try to
manually import flows using HP OO Studio.

Symptoms

After running the CSA for Matrix OO flows installer, OO Studio shows missing
flows, or flow names appear in red text.
The CSA for Matrix Flows imported by the co-sis-install process are:

e /Library/Hewlett-Packard/Insight Orchestration/
Service Actionsg/Deploy Monitors

e /Library/Hewlett-Packard/Insight Orchestration/
Service Actions/Disable Monitors

e /Library/Hewlett-Packard/Insight Orchestration/
Service Actions/Enable Monitors

e /Library/Hewlett-Packard/Insight Orchestration/
Service Actions/Delete Monitors

CSA System Properties (shown with example values) are:

e /Configuration/System
= gitescope.server.hp.

/Configuration/System
= Administrator

/Configuration/System
= password

/Configuration/System
= 8080

/Configuration/System

Properties/SiSFQDN
com
Properties/SiSUserName

Properties/SiSPassword

Properties/SiSIPPort

Properties/SiSDefaultMonitorFrequency = 60

/Configuration/System
= http

/Configuration/System

Properties/SiSProtocol

Properties/SiSCSATemplateFolder

= CSA templates

The CSA installer imports 4 flows and 7 properties in OO Studio, under Library and
Configuration, respectively. If successfully imported, the flow names appear in
blue, as shown in Error! Reference source not found..

Problems are indicated if a flow is missing, or if it appears with red text, as shown
in Error! Reference source not found..
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Hardware
Operating System(s) Windows
Is this an integration Yes

issue?

Primary software
component

00, HP SiteScope

Other dependencies

The SiS System Properties must match the HP SiteScope configuration, especially
the following:
e /Configuration/System Properties/SiSFQDN
SiteScope hostname

e /Configuration/System Properties/SiSPassword
SiteScope Administrator password

e /Configuration/System Properties/SiSIPPort
port number specified during SiteScope
installation

Failure message

Problems are indicated if a flow is missing, or if it appears with red text as shown
in Error! Reference source not found..

Probable cause

Mismatch between HP SiteScope System Property settings and HP SiteScope
server configuration.

How to access log files

Relevant OO logfiles are:
e c:\Program Files\HP\Operations
Orchestration\Central\logs\Central_wrapper.log

e c:\Program Files\HP\Operations
Orchestration\Central\logs\audit.log

e c:\Program Files\HP\Operations
Orchestration\RAS\Java\Default\webapp\logs\
wrapper.log

For more information

The README file included with the CSA for Matrix SiteScope Flows installer
(CSA4M.zip) contains additional information.

Solution

NOTE: if a manual import is attempted after running the CSA for Matrix flows installer, the first two steps
listed below may have already been performed by the installer.

1) Copy the flow .zip filesto ¢: \Program Files\HP\Operations

Orchestration\Studio

2) Unzip each of the two flow archive files into the Studio directory.
3) Login to OO Studio
4) From the Repository menu, choose Import Repository.

5) From the file selector popup box, choose csaServiceActions.flows.zip.

6) Inthe Import popup box, click the plus (+) icon on the toolbar.

7) For each of the four CSA for Matrix flows, verify the Action and Description columns:

a) The Action column will have the green Up Array icon highlighted.

b) The description column will say Modify in Repository.

c) If necessary, click the green Up Array in the Action column.
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8) When all flows are correctly configured, click the Apply icon on the toolbar (the rightmost icon,

colored in with Red, Green and blue).
Repeat the import steps for the file csaSystemProperties. flows.zip:

1) From the Repository menu, choose Import Repository.
2) From the file selector popup, choose csaServiceActions.flows.zip.

3) For each of the seven CSA System Properties, verify the Action and Description columns.

4) When all flows are correctly configured, click the Apply icon on the toolbar (the rightmost icon,

colored in with Red, Green and blue).
Check the imported flows and System Properties into the Repository:

1) Right click Library and click Repository -> check in -> OK.
2) Right click Configuration and click Repository -> check in -> OK.

Figure 14 Successful Import of CSA for Matrix Flows
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Figure 15 Unsuccessful Imp
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Problem: Using OO Studio to debug the CSA for Matrix Deploy Monitor Flow.

The CSA for Matrix Deploy Monitor Flow can be run in debug mode using default values. By creating DNS
entries for a default Windows server and a default Linux server, it is possible to partially test the

configuration of OO and

HP SiteScope.

Symptoms You need to verify that OO is able to connect to HP SiteScope with the current OO
System Properties and that HP SiteScope CSA templates and credentials are correctly
configured.

Hardware

Operating System(s) Windows

Is this an integration Yes

issue?

Primary software
component

00, HP SiteScope

Other dependencies

00 SiS System Properties must match HP SiteScope configuration for hostname,
port, username and password.
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NOTE 1: By default, OO is installed on the CMS at ¢ : \Program
Files\HP\Operations Orchestration

NOTE 2: by default, HP SiteScope is installed on the HP SiteScope server at
c:\SiteScope

Failure message

Failure to deploy within one or two minutes may be caused by ping timeouts for the
two test server alias names. If the deploy fails, the failed steps are marked with a red
X, and should be examined for clues as to the cause of the failure.

Probable cause

e Configuration of OO SiteScope System Properties is not valid
e One or more OO services not running on the CMS server

e SiteScope service not running on HP SiteScope server

How to access log
files

Relevant OO logfiles:
e c:\Program Files\HP\Operations Orchestration\
Central\logs\Central_ wrapper.log

e c:\Program Files\HP\Operations Orchestration\
Central\logs\audit.log

e c:\Program Files\HP\Operations
Orchestration\RAS\Java\Default\webapp\logs\wrapper.log

Relevant HP SiteScope logfiles:
c:\SiteScope\logs\error.log
c:\SiteScope\logs\RunMonitor.log
c:\SiteScope\logs\SiteScope2010_06_15.1log

NOTE: example filename for Jun 15, 2010

For more information

The README file included with the CSA for Matrix SiteScope Flows installer
(csa4M. zip) contains additional information.

Solution:

1) Addanew DNS alias named siswintarg to refer to an existing Windows server.

2) Addanew DNS alias named sislintarg to refer to an existing Linux server.

3) Under SiteScope > Preferences > Credentials, edit CSA target credentials:

e LINUX-CSA-TARGETS must match login requirements for the islintarg alias.
o  WINDOWS-CSA-TARGETS must match login requirements for the siswintarg alias.
4) Verify that you can ping both of these aliases from a command line on the CMS server.

5) Editthe Deploy Monitors.xml file, changing all references to the appropriate values for your

network:

<OO0DIR>\Studio\csaServiceActions.flows\data\Library\Hewlett-
Packard\Insight Orchestration\Service Actions\Deploy Monitors.xml

NOTE 1: <O0Dir> refers to the Operations Orchestration installation directory

NOTE 2: Deploy Monitors.xml iscreated when the oo-sis-install is run on the CMS.
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6) Import csaServiceActions. flows, containing the modified Deploy Monitors.xml file.
For information on how to manually import CSA for Matrix flows, see the section of this document
called “Error! Reference source not found..”

7) In OO Studio, double-click the Deploy Monitors flow.

8) Click the debug icon in the taskbar above the Deploy Monitors pane.

9) Click the Play icon (a green triangle on the left side of the toolbar) to start the flow.

10) Verify the creation of a CSA monitors group, with associated monitors, under the Monitors pane.

Failure to deploy within a minute or more may be caused by ping timeouts for the two test server alias
names. If the deploy fails, the failed steps are marked with a red X and should be examined for clues as to the
cause of the failure.

After performing these tests, restore HP SiteScope credentials (LINUX-CSA-TARGETS and WINDOWS-
CSA-TARGETS) for the OS images that will be deployed by HP SA. The username and password must match
the values specified in unattend.xml, kickstart .xml, or equivalent for target OS images.

Problem: How to prepare the CMS prior to installing CSA OO Flows

The oo-sis-install process assumes that a fresh OO instance has just been installed by HP 10 and that none of
the CSA for Matrix flows are present in OO. Before a re-installation can be attempted, OO must be properly
prepared.

Symptoms One or more CSA flows and/or SiteScope System Properties are visible
in OO Studio prior to running the CSA4M.zip CSA flows installer.

Hardware

Operating System(s) Windows

Is this an integration issue? Yes

Primary software component(s) 00, HP SiteScope

Other dependencies The SiteScope System Properties must match the HP SiteScope

configuration, especially the following:

e /Configuration/System Properties/SiSFQDN
SiteScope hostname

e /Configuration/System Properties/SiSPassword
SiteScope Administrator password

Failure message

Probable cause Most commonly, this is the result of a previous CSA for Matrix flows
installation.
How to access log files Relevant OO logfiles are:

e c:\Program Files\HP\Operations Orchestration\
Central\logs\Central_wrapper.log

e c:\Program Files\HP\Operations Orchestration\
Central\logs\audit.log

e c:\Program Files\HP\Operations
Orchestration\RAS\Java\Default\webapp\logs\
wrapper.log
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For more information The README file included with the CSA SiteScope Flows installer
(CSA4M.zip) contains additional information.

Solution:

The oo-sis-install process assumes that a fresh OO instance has just been installed by HP 10, and that none of
the CSA flows are present in 00. To meet these expectations, it is necessary to perform preparatory steps
before running the the install.bat file from the CSA4M.zip, as described in the README file.

The pre-install preparation steps are as follows:

1) Start OO Studio.

2) Delete all CSA flows (right-click each flow, select Delete, and answer Yes to all prompts).
/Library/Hewlett-Packard/Insight Orchestration/Service Actions/
Deploy Monitors
/Library/Hewlett-Packard/Insight Orchestration/Service Actions/
Disable Monitors
/Library/Hewlett-Packard/Insight Orchestration/Service Actions/
Enable Monitors
/Library/Hewlett-Packard/Insight Orchestration/Service Actions/
Delete Monitors

3) Delete the CSA System Properties.

/Configuration/System Properties/SiSFQDN
/Configuration/System Properties/SiSUserName
/Configuration/System Properties/SiSPassword
/Configuration/System Properties/SiSIPPort
/Configuration/System Properties/SiSDefaultMonitorFrequency
/Configuration/System Properties/SiSProtocol
/Configuration/System Properties/SiSCSATemplateFolder

4) Checkin changes to the repository.
a. Right-click Library and select Repository > Check in Tree.
b. Answer Yes or OK to all prompts.
c. Right-click Configuration and select Repository > Check in Tree.
d. Answer Yes or OK to all prompts.

5) Stop services:
net stop "RSScheduler"
net stop "RSCentral"
net stop "RSJRAS"
net stop "HP Extensible Storage & Server Adapter"”
net stop "HP Logical Server Automation"
net stop "HP Insight Orchestration"

6) Delete the OO metadata directory, including all subfiles:
C:/Program Files/HP/Operations Orchestration/central/rcrepo/
data/.metadata

7) Restart services:
net start "RSScheduler"
net start "RSCentral"
net start "RSJRAS"
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net start "HP Extensible Storage & Server Adapter"
net start "HP Logical Server Automation"
net start "HP Insight Orchestration”

8) 00 is now ready for the CSA flows to be re-installed.

Diagnosing Failed CSA Flow imports

If CSA OO Flows did not install successfully, be sure to verify that all the preparatory
steps have been performed, as listed above. The following log files can provide useful clues regarding possible
causes of errors.

C:\Program Files\HP\Operations
Orchestration\Central\logs\Central_wrapper.log

C:\Program Files\HP\Operations Orchestration\Centralllogs\audit.log
C:\Program Files\HP\Operations Orchestration\RAS\Java\Default\webapp\logs\
wrapper.log

Problem: Audit policy not deleted after compliance scan

Symptoms Audit policies are not deleted in SA after running only the compliance scan
without remediation.

Hardware

Operating System(s) Windows

Is this an integration issue? | No

Primary software 00

component(s)

Other dependencies SA

Solution:

Audit policies will not be deleted if you run only the compliance scan without remediation. In this case, delete
the audit copy manually in the SA console. The audit copy will have a name in the following format:

<SA Audit task name>-<CSA service name>.

The SA audit task name will be defined in OO system properties— one for Windows and one for Linux.

For example, an audit copy may look like CSA WindowsAudit-CSA SVC 001.

NOTE: Compliance check may fail the next time if the audit copy is not removed.

Problem: How to Recognize Problems with CSA Flows in OO Studio

Symptoms Missing or mis-configured flows are displayed in OO Studio

Hardware

Operating System(s) Windows

Is this an integration Yes

issue?

Primary software 00, HP SiteScope

component(s)

Other dependencies The SiS System Properties must match the HP SiteScope configuration, especially

the following:
e /Configuration/System Properties/SiSFQDN
SiteScope hostname

e /Configuration/System Properties/SiSPassword
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SiteScope Administrator password

Failure message

Flow problems are indicated if a flow is missing, or if displayed in red text, as
shown in Error! Reference source not found..

Probable cause

OO0 was not properly prepared prior to CSA4M. zip installation.

How to access log files

Relevant OO log files are:
e c:\Program Files\HP\Operations
Orchestration\Central\logs\Central_wrapper.log

e c:\Program Files\HP\Operations
Orchestration\Central\logs\audit.log

e c:\Program Files\HP\Operations
Orchestration\RAS\Java\Default\webapp\logs\wrapper.
log

For more information

The README file included with the CSA SiteScope Flows installer (CSA4M.zip)
contains additional information.

Solution:

Open OO Studio and verify that the installed CSA flows and properties are present.

CSA Flows imported by the oo-sis-install process are:
/Library/Hewlett-Packard/Insight Orchestration/Service
Actions/Deploy Monitors
/Library/Hewlett-Packard/Insight Orchestration/Service
Actions/Disable Monitors
/Library/Hewlett-Packard/Insight Orchestration/Service
Actions/Enable Monitors
/Library/Hewlett-Packard/Insight Orchestration/Service
Actions/Delete Monitors

CSA System Properties (shown with example values) are:
/Configuration/System Properties/SiSFQDN =
sitescope.server.hp.com
/Configuration/System Properties/SiSUserName =

Administrator

/Configuration/System Properties/SiSPassword =
password

/Configuration/System Properties/SiSIPPort = 8080
/Configuration/System Properties/SiSDefaultMonitorFrequency = 60
/Configuration/System Properties/SiSProtocol = http
/Configuration/System Properties/SiSCSATemplateFolder = CSA

templates

After successful installation of CSA flows, all four flows and seven System Properties will appear in OO Studio
under Library and Configuration, respectively. In addition, flow names will appear in blue as shown in Error!
Reference source not found., rather than in red as shown in Error! Reference source not found.

Problem: Operation Orchestration workflows do not run for third party

servers.

Symptoms Operation Orchestration workflows do not run for
third party servers.

Hardware
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Operating System(s)
Is this an integration issue? Yes
Primary software component HP 10 and OO
Other dependencies
Failure message N/A
Probable cause e Incorrect OO credentials have been added to

esa.properties file.

e Incorrect tag values in the three data files:
ServerInfo.xml, InventoryList.xml,

uuidHostMapper .xml.

e  Mismatching UUID element values between
the three data files:
ServerInfo.xml, InventoryList.xml,

uuidHostMapper .xml.

e  Missing identification info for third party
ProLiant server in the
blade_models.properties file.

e Incorrect iLO credentials for the target server
listed by 0O0.

How to access log files

For more information

Solution:

1) Add the correct credentials for OO sign-in:
a) Modify <Root Drive>:\Program Files\HP\
Virtual Server Environment\conf\esa.properties toincludethe HP OO
Administrator password.

Esa.oo.admin.password=<your-oo-admin-password>

b) Verify the value of each in the files: ServerInfo.xml, InventoryList.xml,
uuidHostMapper .xml . For more information use the HP Insight Orchestration User
Guide, “Configuring 10 to list heterogeneous hardware” section.

2) The UUID element value should match for all three data files:

ServerInfo.xml
InventoryList.xml

uuidHostMapper .xml.

3) Editthe C:\Program Files\HP\Insight Orchestration\
conf\blade_models.properties file to include the third party target server model. For
more information see the HP Insight Orchestration User Guide, “Configuring 10 to list heterogeneous
hardware” section.
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4) Verify and, if needed, correct the iLO system credentials for the third party target server in OO. For
more information see the HP Insight Orchestration User Guide, “Configuring 10 to list heterogeneous
hardware” section.

5) You may need to stop the services HP 10, LSA, ESA, RSCentral, RSJRAS and restart them in reverse
order.
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Troubleshooting Storage

Storage Configuration

Problem: Not enough VM storage available

Not enough VM storage is available during activation or deactivation of VM servers.

Symptoms Server deactivation or activation fails from inadequate VM host storage
availability.
Hardware Virtual Servers and VM storage

Operating System(s)

Is this an integration issue?

No

Primary software
component

HP 10

Other dependencies

Failure message

Any message for a physical server provision

Probable cause

HP 10 is designed so that if a failure occurs during the provisioning of physical
servers, the resources are left in the same state as when the failure occurs. The
administrator must power on and access the servers to resolve the issues that
caused the failure.

How to access log files

The default location of the HP 10 log file on the CMS server is as follows:
c:\Program Files\HP\Insight Orchestration\logs\
hpio-controller.log

For more information

HP Insight Orchestration User Guide, HP Insight Orchestration Release Notes,
and HP Insight Orchestration online help

Solution:

1) From a command line on the CMS, run:

net stop "HP Insight Orchestration"”

2) Openthe hpio.properties filein atext editor. The default location of the HP 10 properties file

on the CMS server is:

C:\Program Files\HP\Insight Orchestration\conf\hpio.properties

3) Increase the value of the vm.memory.overhead property; for example:

vm.memory.overhead =

1.2

4) Increase the value of the vin. disk . overhead property, for example:

vmm.disk.overhead=10

5) Savethe hpio.properties file.

6) From a command line on the CMS, run the following:

net start

"HP Insight Orchestration”
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Problem: Servers do not return to HP 10 Server Pool after failed provision

Symptoms Servers don’t return to the Server Pool after a failed
provisioning request.

Hardware

Operating System(s)

Is this an integration issue? No

Primary software component HP 10

Other dependencies

Failure message

Probable cause

Logical server listed in “clean-me” state.

For more information See the troubleshooting section of the HP Insight

Orchestration User Guide.

Solution:

HP 10 is designed so that if a failure occurs during the provisioning request of physical servers, the resources
are left in the “in-use” state when the failure occurs. Leaving the resources in the “in-use” state allows the
administrator to power on and to access the servers; then to identify and resolve the issues that caused the
failure. This problem occurs with physical servers managed using Virtual Connect-enabled hardware and with
non-Virtual Connect (third party OOWF) servers.

1) Make sure the identified servers are powered off.
2) Launch Insight Dynamics (CMS).
3) Go to Tools menu > Virtualization Manager; select Perspective = Logical Server.

a. Select the server that is listed in the “clean me” state.

b. Goto Tools > Logical Server > Deactivate.

c. After the logical server is deactivated, go to Delete > Logical Server.

d. If the target server is a third-party server, go to Delete > Unmanage Logical Server.

e. Repeat the above steps for each logical server that is listed in the “clean-me” state.

4) Each deleted server is placed in the Maintenance Server Pool. You must move it back to its dedicated
server pool.

a. Goto Tools > Insight Orchestration.

b. From Servers tab, select a server pool that was associated with one or more logical servers
listed as in the “clean me” state and press Modify Pool.

c. From the Select servers from pool drop-down, select Maintenance.

d. Select the server that was associated with selected pool and press >> to move the server
back to the selected pool.

e. Press Save.

5) Repeat steps 3 and 4 for each server identified in step 3a.

6) From the Server Pool tab, refresh server resources to update HP 10 with the new state for the

identified servers.
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Problem: Allocated SAN storage not detected

Target server fails to detect SAN storage that was allocated to it from the CMS.

Symptoms Target server fails to detect SAN storage that was
allocated to it from the HP Insight Dynamics CMS

Hardware

Operating System(s)

Is this an integration issue?

Primary software component OS Install media and HBA driver software.

Other dependencies

Failure message

Probable cause A missing HBA driver in the production operating
system or a zoning issue.

For more information

Solution:
1) Check the Worldwide Name (WWN) allocated to the HBA in the target server. This should be done in
two places to make sure that they agree:

a. InHPIO go to the SPE to view the volume allocated to the provisioning job that failed. Note
the server WWN, as shown in the figure below (red) and the volume details as shown in the
figure below (blue).

b. On the target server go into the HBA BIOS. Check to see that the WWN allocated to the
active port is the same as the one in the SPE.

o If there is more than one active port, deactivate any ports that are not operating
with this WWN and retry the operation after the next steps.

o If none of the ports have the required WWN, deactivate all but one port and retry
the provision after the next steps.
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Figure 16: Check WWN and Volume Details
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2)

3)
4)

Contact the storage administrator with the server WWN and volume details. Request that the
storage administrator check that the volume is presented to the specified server WWN and to no

others.

NOTE: It is important that the volume and the server are connected via a zone whose definition
contains only those two WWNs and that the server WWN is not included in any other zones.

All of the above should be rechecked by the storage administrator and altered as required.

The user can then re-attempt the provision request. If it still fails, contact HP Professional Services

for more detailed SAN troubleshooting.
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Problem: Target server fails to install OS to SAN

The target operating system does not have a driver for local or SAN storage boot disk.

Symptoms Target server fails to install operating system to SAN
storage allocated to it from the CMS
e Windows “black screens”

e Server continuously rebooting into PXE,
defaulting to non-existent local disk and looping
until it times out

e No boot disk detected
e Failed to format disk

e Failure message

Hardware

Operating System(s)

Is this an integration issue?

Primary software component OS Install media and HBA driver software
Other dependencies
Failure message The following message displays in some cases:

Diskpart has finished scanning your
configuration-disk not valid-there
is no disk supported.

Probable cause e Missing or incorrect disk driver in the production
operating system

e Incorrect operating system configuration files

e Incorrect boot disk order (local-disk-enabled)

For more information HP Server Automation documentation

Solution:

When deploying an operating system, HP Server Automation (HP SA) starts by booting the target server into a
known state using PXE. This known state provides a minimal operating system (either Windows or Linux) with
up-to-date drivers that can detect basic devices.

Soon after, HP SA deploys the production operating system configured by the user to the target server. For
most late-model operating systems, many, if not all, of the necessary drivers are already in place. For older
software (for example, Windows 2003 x86), the SAN HBA drivers are likely to be missing and must be
installed.

1. Gotowww.hp.com.

2. Select Support & Drivers > Download drivers and software (and firmware). To complete the

download, you must identify the server type.
Generally, this problem requires you to generate a new sysprep image with the correct drivers in place. For

Linux, installing a later minor release of the OS normally resolves the problem. Add the missing storage
drivers for the target server. See the HP recommended storage drivers for the identified target server.
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Check operating configuration files for Linux or unattend file for Windows to make necessary corrections.
For more information, refer to the HP Server Automation documentation.

Verify the boot disk order is setup correctly as described in the Cloud Service Automation for Matrix

Configuration Guide. If SAN boot provisioning continues to fail, disable the local disk as part of the BIOS disk
boot order.

Problem: SAN storage resources do not show up in HP 10 Ul

SAN storage resources do not show up in HP 10 Ul.

Symptoms Storage pool entries and storage resources do not
show up in HP IO Ul.

Hardware

Operating System(s)

Is this an integration issue?

Primary software component SPM, HP 10, VCEM

Other dependencies

Failure message

Probable cause e Timing issue
e LSM database is out of synch

e The SPE is not made available for HP IO use

For more information

Solution:

1) Wait few minutes after the creation of SPE for HP |0 Storage Pools to be updated.
2) Refresh the resources:
a. Go to Tools > Virtualization Manager > Tools > Logical Servers > Refresh
b. Check Storage Pool Entries.
c. Select Refresh.
d. Return to Tools > Insight Orchestration. Select the Storage tab.
e. Verify that the storage pool entries are listed.
3) If the storage pool entries are still not found, the entries may not have the Ready checkbox enabled.
a. Go to Tools > Insight Orchestration. Select the Storage tab.

b. Click Manage Storage Pools.

c. Select the SPE that should be listed under 10 Storage Pools Ul.

d. Click Modify.

e. Under Manage server WWNs, select the Ready check box for the SPE.
f.  Select Save.

g.

Repeat step 2 to verify that you can see all the storage listed.
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Problem: HP 10 service pauses during SAN boot with request for data disk

Symptoms

HP 10 service pauses during SAN boot with a request
for a data disk.

Hardware

Operating System(s)

Is this an integration issue?

Primary software component

HP 10 and HP SA

Other dependencies

Failure message

Probable cause

Disk size listed by SPE does not meet the
minimum limits for successful provisioning.

HP 10 template requests a data disk, but there is
no Storage Pool Entry (SPE) with a data disk
record matching the service template

The data disk is not presented to the target
server.

The data disk available has insufficient disk space.

The SPE has two volumes but both of them are
listed as boot disks.

The Storage Pool Entry lists a data disk with an
incorrect RAID level or LUN.

Incorrect disk presentation/zoning.

For more information

HP Insight Orchestration User Guide

Solution:

HP 10 must list sufficient Storage Pool Entries (SPEs) available in an “Unused” state to meet the service
template requirements. The minimum required sizes for Windows, Linux, and Solaris are as follows:
e  Windows requires a minimum of 20 GB.

e Linux and Solaris require 10 GB for OS installation only.

1) Verify SPE entries are in an available state:

a. Go to Tools > Insight Orchestration. Select the Storage tab.

b. Click Refresh.

c. Verify the availability status of the SPE that is necessary to meet the service template

requirements.

2) If the SPE is missing a data disk or available resources in the storage pool:

a. Go to Tools > Virtualization Manager > Modify > Logical Server Storage Pools
b. Edit the SPE used by the service that has paused:

Add a new volume with type = data
List the correct RAID level, size, and LUN information retrieved from the array
manager for this disk/volume.
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NOTE: Verify that the new data disk meets the service template requirements
for size and type (correct numbers of boot and data disks).
Using the array manager, present the data disk that was added to SPE to the target server.
Verify that the switch zoning is listing the correct WWN information for the target server. For more
information, see “Corrective Procedures” in the HP Insight Orchestration User Guide.
Verify that the volume presentation has the correct information (matching the information from
SPE; see WWN.) in the array manager.

Problem: SAN and local boot provisioning fails for non-VC Proliant servers

Symptoms SAN and local boot provisioning can fail for non-VC-

enabled Proliant Servers, if the storage pool entry
used by the service request contains both a SAN boot
disk and a SAN data disk at the request starting time.

Hardware

Operating System(s)

Is this and integration issue?

Primary software component HP 10

Other dependencies VSE/SPEs configuration

Failure message

Probable cause The OS attempts deploy on the data disk instead of

the boot disk listed in the SPE. For non-VC-enabled
ProlLiant servers, there is no guarantee which disk is
used first for OS deployment. A failure occurs if the
data disk does not meet the minimum disk space for
OS provisioning.

How to access log files

For more information

Solution:

1)

2)

3)

For non-VC-enabled ProLiant blade-server provisioning, service requests for a boot disk and a data
disk should be created separately.
If the operating system is booted to SAN, the Storage Pool Entry (SPE) should initially list only the
SAN boot disk. When a local boot disk is used for operating system provisioning, no SPE should be
created for the SAN data disk in the initial service request.
NOTE: After the SAN or local boot, the service request provisioning pauses to request that you
manually allocate the SAN data disk to an already existing SPE or create a new SPE for the SAN data
disk.
When the request pauses, modify the identified SPE to include the second volume as a data disk:

a. Goto 10 > Storage Pool tab > Manage Storage Pools.

b. Select the associated SPE for the target server.

c. Click Modify.

d. Go to Volume and click Add volume to add the data disk. Make sure you select
boot option = NO.

e. Enter the RAID level and disk space.

f.  Click Save and Close.

g. Go to IO Storage Pool tab. Select Refresh to see changes to SPE.

h. Goto IO request.

Click Restart/Continue 10 request.
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SAN Usage

Problem: HPIO Delete Service fails due to HP SA erase disk failure

Symptoms Software resources do not show up in HP 10 Ul.
Hardware

Operating System(s)

Is this an integration issue? Yes

Primary software component 10 and HP SA

Other dependencies

Failure message N/A

Probable cause SA failed to erase the disk.

For more information HP IO User Guide, Troubleshooting section
Solution:

1) If HP SA failed to erase the disk during the service deletion, the server and the disk will be left in an
unstable state. If this occurs, do the following:
a) Remove references to HP SA from any leftover records on the server, and manually scrub
the disk.
b) For more information, see the HP IO User Guide, Manual Clean-up process section.

Problem: Storage pool entries for the third party servers show N/A

Symptoms Storage Pool Entry for the third party servers show
available status = N/A.

Hardware

Operating System(s)

Is this an integration issue?

Primary software component HP 10 and VSE

Other dependencies

Failure message

Probable cause SPE/Storage Pool Entry for OOWF/non-Virtual
Connect/third party servers shows available status =
N/A.

For more information

Solution:
The listing of the available status as N/A for the third party servers in the Manage Storage Pool user
interface is by design. Instead, you can verify the correct status (used/unused) in the 10 Storage Pool tab
after that tab is refreshed.
Only SPEs for third party servers will have the available status of N/A. The SPEs Virtual Connect/cClass
blade servers will list the available value of 1 or 0. These values can be associated with the unused/used
value shown for SPE in the 10 Storage Pool tab.
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Problem: The HP 10 service pauses when a Local boot is performed and asks
for data disk allocation

Symptoms The HP 10 service pauses when a Local boot is
performed and asks for data disk allocation, even
though the SPE lists both boot and data disks.

Hardware

Operating System(s)

Is this an integration issue? No

Primary software component 10 and HP SA

Other dependencies

Failure message Provisioning request for <servername> has paused.
Manual data disk allocation using VSE Logical Server
Storage Pools is required. An HP 10 Administrator has
been notified.

Probable cause 1) There is an Operating System mismatch between

the template, SPE, and host OS assignment in the
Array Manager (e.g. CV-EVA).

2) There is a Raid level mismatch for the data disk
between the template, SPE, and disk in the Array
Manager (e.g. CV-EVA).

3) Both 1) and 2) above are correct, but the request
continues to pause although the SPE has both
boot and data disks that match what the
template requests. This is possibly caused by a
previous de-provision of the server, which failed
due to an Erase Disk issue.

How to access log files
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Solution:

1) Verify the following to make sure they all specify the same OS:
e The template for the server-allocated Operating System
e The SPE Storage Entry Operating System
e The host-associated OS in the Array Manager (CV-EVA)
2) To resolve an OS mismatch:
a) Inthe Template:
i) Go to Edit Template> Server. Right-click on Server. Edit the Server Group
Configuration.
ii) Go to the Software tab and select the correct OS.
iii) Save and close the tab.
b) For the SPE:
i) Go to 10 > Storage Pool > Manage Storage Pools.

ii) Select the associated SPE for the target server.

iii) Click Modify and edit Storage Entry Operating System to include the correct
os.

iv) Save your changes.

c) Onthe Host:
i) Go to the Array Manager (CV-EVA).
ii) Click Hosts; then select the target server and click Properties.
iii) In the General tab, correct the OS.
iv) Save your changes.
d) Go tothe HP IO Storage Pool and refresh the view to see the changes to the SPE.
e) Go tothe HP IO Request tab and click Restart/Continue HP 10 Request.
3) Verify that the Raid level for the disks used by SPE, the template, and the array manager (for
example, CV-EVA) match.
a) Inthe Template:
i) Go to Edit Template> Server and right-click on the disk.
ii) Edit the Storage Configuration by selecting the appropriate Raid Level.
iii) Save your changes.
b) For the SPE:
i) Go to 10 > Storage Pool > Manage Storage Pools and select the associated SPE
for the target server.

ii) Click Modify and go to the Volume section to make sure the disks listed have
the appropriate Raid Level (the level needs to match the value of the Raid
found for these disks in the Array Manager).

iii) Save your changes.

c) For the Disk:

i) Go to the Array manager (e.g. CV-EVA) and select the virtual disk associated
with the target server.

ii) Select the Redundancy option to verify that it matches the value in the SPE.

d) Go tothe HP IO Storage Pool and refresh the view to see the changes to the SPE.
e) Go tothe IO Request tab and select Restart/Continue 10 Request.
4) If the steps above do not apply, you may need to remove the data disk from SPE and re-add it:
a) Forthe SPE, go to 10 > Storage Pool > Manage Storage Pools:
i) Select the associated SPE for the target server.

i) Click Modify and go to the Volume section.

i) Select the disk labeled boot = No (this is your data disk) and delete it.

iv) Save your changes.
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Re-add the data disk to the SPE that was modified above by going to 10 > Storage Pool >
Manage Storage Pools and selecting the associated SPE for the target server. Click
Modify.
i) Go to the Volume section.

i) Click Add volume to add the data disk.

iii) Enter the Raid level and disk space.

iv) Save your changes.
Go to the 10 Storage Pool and refresh the view to see the changes to the SPE.
Go to the 10 Request tab and select Restart/Continue 10 request.
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Other Troubleshooting Processes

Enabling logging in product components
CSA for Matrix

Set the system property CSA_DEBUG in OO Studio to true to enable CSA for Matrix to log diagnostic
messages into a log file. The name and location of the log file are specified in OO Studio with the
CSA_DEBUG_LOGDIR and CSA_DEBUG_LOGNAME properties.

NOTE: The log file does not include results of Audit and Remediation operations. You can see results of Audit
and Remediation operations in OO Central as results of the workflows.

You can send email notifications on success and failure of workflows. See the Insight Dynamics
documentation for information on configuring email notification. If you want to send notifications only when
workflows fail, set the CSA_NOTIFY_ONLY_FAILURE property in OO Studio to t rue. When the property is set
to false, notifications are sent for all events.

HP 10
1) Edit the file logdj.properties in the HP 10 install directory (for example, ¢ : \Program

Files\HP\Insight Orchestration\conf).
2) Change these entries in this file FROM:

log4j.category.com.hp.hpio.sbapi=INFO
log4dj.category.com.hp.hpio.controller=INFO

TO

log4j.category.com.hp.hpio.sbapi=DEBUG
log4dj.category.com.hp.hpio.controller=DEBUG

3) Save the file and restart the HP IO service.

VMM
1) Go to the VMM install directory (for example, c: \Program Files\HP\HP Insight

Virtual machine management\clientapi\bin\).
2) Follow these steps:

a) Enter the following command: adminlogin.cmd

b) Enter the following command: cli setLogLevel -level DEBUG

c) Restart the VMM service.

VSE
1) From the VSE install directory (for example, c: \program files\hp\virtual server
environment), copy the file .vsedebug.xml to c:\vsedebug.xml
2) Restart the VSE service.

Extra log files are added to a new folder: C:/var/opt/vse/logs

HP SIM
1) To enable debug for Administrator, enter the following command:

mxuser -m Administrator -p debug
2) Login to https://localhost:50000/mxdebug/dbgMain.jsp
3) Use the debug page to set debug levels for the various components.
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Use the debug page to enable file logging.

NOTE: HP SIM debugging choices should generally be self-explanatory.

HP SA Access Layer and Areslite Controller

1)

2)

3)
4)

Edit the file DomainManager.props file (for example, Systems Insight
Manager\config\debugsettings\DomainManager .props) .
Change these entries in this file FROM:

com.hp.sa.LSUplugin.SAAccessLayer=false,0,com.hp.sa.LSUplugin.SAAcce
ssLayer,

com.hp.sa.LSUplugin.SAplugin=false, 0,com.hp.sa.LSUplugin.SAplugin,

TO:

com.hp.sa.LSUplugin.SAAccessLayer=true, 40,com.hp.sa.LSUplugin.SAAcce
ssLayer,

com.hp.sa.LSUplugin.SAplugin=true, 40,com.hp.sa.LSUplugin.SAplugin,

For each of the com.hp.alc entries in this file, change the instances of false,0 to true,40.
Restart SIM:

Run mxstop and wait for all HP SIM processes to finish.
Run mxstart and wait for all HP SIM processes to start.

HP SA Server

The HP SA job logs are the primary logging source for HP SA. On the HP SA primary core, it is possible to
locate server logs directly by their MAC addresses. Go to the following directory:

/var/opt/opsware/log/buildmgr/servers
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Problem: Data disk presented to the LINUX host is not visible

Data disk presented by the 10 service to the LINUX target server is not visible.

Symptoms Data disk presented by the 10 service to the LINUX
target server is not visible.

Hardware

Operating System(s) Any Linux target server

Is this an integration issue? No

Primary software component

Other dependencies

Failure message

Probable cause

For more information

Solution:

Rescan the bus on the LINUX host to which the disk is presented.
Use the following commands:

echo 1 > /sys/class/fc_host/host<n>/issue_lip

echo - - - > /sys/class/scsi_host/host<n>/scan

In this instance, the number of host adapter ports that need to be rescanned is n-1.

For example, host0 for a host with only one port, host1 for a host with two ports, and so on.
The disk should be visible now.
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Problem: VMM is not able to connect to the host

The Create Service operation in the HP 10 console fails with the following error:
VMM is not able to connect to the host

Symptoms The Create Service operation in the HP 10 console

fails with the following error:
VMM is not able to connect to the

host
Hardware
Operating System(s)
Is this an integration issue? No
Primary software component VMware VirtualCenter
Other dependencies
Failure message Task for Logical Server <server_name> has failed.

Logical server job (ID = <server_name>.vlan8.lab)
completed with a failure status. Failure: VMM is not
able to connect to the host.

Probable cause VMware VirtualCenter Server service has stopped on
the VCenter server

For more information

Solution:
1. Verify that the “VMware VirtualCenter Server” service is running on the VCenter server.

2. If the “VMware VirtualCenter Server” service is stopped, start the service.
3. Recreate the 10 service.
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Performance and Tuning

This section provides preliminary steps for configuration and tuning of various components in the CMS
environment to improve performance and reliability.

VMware Virtual Center Server Configuration and Tuning

Microsoft Sysprep files in Virtual Center Server

Install the precise version of sysprep files recommended by VMware from the following Knowledge Base

articles:
http://kb.vmware.com/kb/1005593
http://support.microsoft.com/kb/926028/en-us

e WindowsServer2003.WindowsXP-KB926028-v3-x64-ENU.exe
(for example, W2K3 SP2 x64 sysprep tools)

e WindowsServer2003-KB926028-v2-x86-ENU.exe
(for example, W2K3 SP2 x86 sysprep tools)

vCenter Database Size

1) Login to the Windows vCenter server and open SQL Studio Express.

2) Select the database VM_VCDB and right click for properties.

3) Select the Initial Size (MB) cell. You can use the increment control, or just type the new size directly
into the cell.

4) Select OK to persist the value.
NOTE: If the value is not accepted, it may indicate that you are running SQL Express (which has a
maximum database size of 4 GB).
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vCenter Database Retention Policy

Set the database retention policy VCenter as follows.
1) Set tasks to be retained for 30 days.

2) Set events to be retained for 30 days.

Figure 18 vCenter Data Base Retention Policy
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HP 10 Properties Configuration and Tuning

Several settings should be configured in the HP 10 properties file.
Location: C:\Program Files\HP\Insight Orchestration\conf\hpio.properties

Changes required:
e cleanup.messages.max.age = 44640

e oo.service.action.fail.request = true
e esx.max.concurrent.requests=15
e vm.memory.overhead = 1.0

Actions required for changes to take effect:
e Save the properties file.

e  Restart the “HP Insight Orchestration” service.

HP IO Sysprep Files

Several sysprep.inf files have been created for the various Windows Server 2003, Windows Server 2008, 32-
bit, and 64-bit operating systems. These sysprep.inf files must be copied from the POC to the production
environment.

Location: C:\Program Files\HP\Insight Orchestration\conf\sysprep\*.inf

Actions required for changes to take effect:
e  Copy files from POC CMS to Production CMS.

e Ensure HP 10 templates refer to the correct sysprep files.

HP LSM Properties

The HP 10 log contains the full record of the provisioning requests; it is not necessary to keep the full history
in the HP LSM level of the infrastructure. Consequently, the number of jobs retained in the LSM log should be
reduced.

Location: C:\Program Files\HP\Virtual Server Environment\conf\Isa\lsa.properties

Changes required:
e JOB_ROLLOVER_MAX=500

Actions required for changes to take effect:
e Save the properties file.

e  Restart the HP Logical Server Automation service.
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HP SIM Tuning

Change default HP SIM Daily Identification scheduled task to run at 1:05 AM CET.

Figure 19 HP SIM Scheduled Tasks
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CMS Server Tuning

1) Turn off power capping on the CMS through the BIOS, if it is enabled.
2) Set the performance mode for the CMS blade in iLO to High Performance.
3) For 32-bit operating systems, add the /PAE parameter to the boot.ini file to access > 4 GB physical
memory.
4) Set the virtual memory to at least the amount of physical memory in the CMS server.
a. Select System properties and note the amount of physical memory on the system.

b. Verify virtual memory settings are the same as the physical memory setting in task manager (see
above).
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Figure 20 Verify Physical Memory Settings
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Figure 21 Verify Virtual Memory Settings
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CMS Database Tuning

Overview

To tune the database, follow these steps:
1) Open aremote desktop the database server.

2) Run SQL Server Management Studio.
3) Select the appropriate database instance.
4) Right click and select properties.

Tuning Database Operating System: only for CMS using an off-host Database

Follow steps on the database server described under the section “CMS Server Tuning”.

1) Turn off power capping on the CMS, if enabled.
2) Set performance mode for the CMS blade in iLO to High Performance.

3) For 32-bit operating systems, add the /PAE parameter to the boot.ini file to access > 4 GB physical

memory.

4) Set virtual memory at least the amount of physical memory in the CMS server.

Set the MIN and Max memory and AWE

1) Select the Memory page on the database server properties screen.
2) Value should be set per the following formula:

Physical Memory - 2 GB for OS - 1 GB for Multiple Page Access (MPA) - 1 GB for every 8 cores

Example of database server with 32 GB of memory and 8 cores:
32GB- 2GB-1GB-1GB =28 GB=28672 MB

3) Specify the value calculated in the previous step in both the MIN and MAX memory fields, as illustrated

below.
4) Check the Use AWE to allocate memory checkbox, as well.
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Figure 22 Set MIN, MAX memory and AWE
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Set Database Index Fill Factor

1) Select the Database Settings page on the database server properties screen.
2) Change the Default index fill factor to 90 as shown below.

Figure 23 Set Database Index Fill Factor
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SQL Server Max Degree of Parallelism

1) Select the Advanced page on the database server properties screen.
2) Change the Max Degree of Parallelism to 1 for systems with fewer than 16 processor cores. Set this
property to 8 for systems with 16 or more processor cores.

Figure 24 Change Max Degree of Parallelism

F Server Properties - DLIVA
8 Scrpt = Iy Help
A General ; lj
A Memory — .
A Secury B Filestream
& Conneclions Fiestream Access Level Disabled
2 Datshass Setling: E Micellanecous
& Advanced Alowe Triggers ta Fire Others True
A Pamizions Blocked Pracess Theeshold 2
Curscn Thigshold -1
Defadt Full- Texdt Language 1033
Defoudt Language Englizh
Fll-T et Upagrade Opticn Impaoat
Max Text Replcation See 65536
Ophmeze for Ad hoc Wk loads False
Scan bor Startup Paocs False
Tweo Digt Ve Cutolt 20439
B Metwok
Metvwork Facket Soe 4096
Femote Logn Timeout 20
B Parallelsm
Connection Lok Thowhold o P g
- Locks 0
Server | Max Degres of Parabelam Bl
localhost Clussy wiait A1
Connechion
OLRVENSdministrabon
7 View coonection progeties Max Degree of Pasolickism
Limst ther rumbeer of processors bo use in parallel plan execubion.
Progress 8
Fleady
= Corligured values " Bunring values
ok | cowe |
&

Page | 89




HP CSA for Matrix Troubleshooting Guide

2011, June

SQL Memory Page Locking (64-bit systems only)

Installing Cumulative Update 4

Install the Cumulative Update 4 for SQL Server 2005.
e SQL 2008 Standard, Enterprise edition SP1 CU2 (Cummulative Update 2)

e SQL 2005 Standard, Enterprise edition SP3 CU4 (Cummulative Update 2)

The update can be downloaded from:

http://support.microsoft.com/kb/970279
Documentation for this feature can be found at:
http://blogs.msdn.com/psssql/archive/2009/05/19/an-update-for-standard-sku-supportforlocked-pages.aspx

Set Trace Flag in SQL Startup Parameters

1) In SQL Server Configuration Manager, click SQL Server Services.
a) Intheright pane, right-click SQL Server (<instance_name>), and then click Properties.
b) On the Advanced tab, in the Startup Parameters box, add —T845; (ensure all parameters are
separated by a semicolon).
c) References:
2) The following explains how to configure locked pages:
http://support.microsoft.com/kb/970070
3) The following explains all SQL server parameters:

http://msdn.microsoft.com/en-us/library/ms1907 37 .aspx

4) The following explains how to set SQL server parameters:

http://msdn.microsoft.com/en-us/library/ms345416.aspx

Enable User Rights for Locked Pages in Memory

e |[F THE ACCOUNT running SQL is LOCAL SYSTEM STOP, it already has this right.

e If the database is running on another system than the CMS the changes below may optimize the
environment. If the database is running on the same system as the CMS, none of the changes below
are required.

If changes are warranted, follow these steps. For 64-bit installations of SQL Server 2008/2005, the lock pages
in memory right needs to be granted to the user running SQL Server service. The Default LOCAL SYSTEM user
already has that right, but it is not recommended to run SQL Server with the system account in production for
security reasons, and rather have a SQL specific windows account and add the right to it.

To enable the lock pages in memory option
1) On the Start menu, click Run. In the Open box, type gpedit.msc.

2) The Group Policy dialog box opens.

3) On the Group Policy console, expand Computer Configuration, and then expand Windows Settings.
4) Expand Security Settings, and then expand Local Policies.

5) Select the User Rights Assignment folder.

6) The policies will be displayed in the details pane.

7) Inthe pane, double-click Lock pages in memory.

8) In the Local Security Policy Setting dialog box, click Add.
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9) Inthe Select Users or Groups dialog box, add an account with privileges to run sqlservr.exe
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The user running SQL Server can be identified by opening Windows Services:
e Right click on the SQL Server service.

e Select properties and view the Log On tab.

Figure 25 The SQL Server Log On Tab
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Figure 26 Lock Pages in Memory
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