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User’s Guide
Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty 

statements accompanying such products and services. Nothing herein should be 

construed as constituting an additional warranty. HP shall not be liable for technical or 

editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

For information about third party license agreements, see the Third Party and Open 

Source Notices document in the product installation media directory.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or 

copying. Consistent with FAR 12.211 and 12.212, Commercial Computer Software, 

Computer Software Documentation, and Technical Data for Commercial Items are 

licensed to the U.S. Government under vendor's standard commercial license.

Copyright Notices

© Copyright 2000-2008 Hewlett-Packard Development Company, L.P.

Trademark Notices

Microsoft®, Windows®, Windows Vista®, and Windows® XP are U.S. registered 

trademarks of Microsoft Corporation.

UNIX® is a registered trademark of The Open Group.
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Documentation Updates

The title page of this document contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

• Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using the most recent edition of a 

document, go to:

http://h20230.www2.hp.com/selfsolve/manuals

This site requires that you register for an HP Passport and sign in. To register for an HP 

Passport ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

Or click the New users - please register link on the HP Passport login page.

Support

Visit the HP Software Support Online web site at:

www.hp.com/go/hpsoftwaresupport 

This web site provides contact information and details about the products, services, and 

support that HP Software offers.

For downloads, see:

https://h10078.www1.hp.com/cda/hpdc/display/main/
index.jsp?zn=bto&cp=54_4012_100__ 

HP Software online support provides customer self-solve capabilities. It provides a fast 

and efficient way to access interactive technical support tools needed to manage your 

business. As a valued support customer, you can benefit by using the support web site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts
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• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. 

Many also require a support contract. To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp 
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Preface

Overview of this Guide
This guide describes how to use HP Application Storage Automation System (ASAS) to 

discover, visualize, search for, report on, and troubleshoot storage objects, their attributes, 

and devices in your IT environment.

Audience and Assumptions
This guide is intended for the following audience:

• Storage Administrator—A storage administrator (also known as a storage operator or 

a storage engineer) is responsible for day-to-day management of the NAS or SAN 

infrastructure. Typical tasks include:

• Provisioning new storage for new or existing applications

• Managing SAN devices (firmware upgrades, configuration, security settings, and so 

on)

• Migrating or reclaiming allocated storage as necessary

• Troubleshooting SAN performance or availability problems

• Deploying, configuring, and cabling SAN switches

• Fabric Administrator: A fabric administrator manages the network that ties all of the 

storage devices together. Typical tasks include:

• Deploying a new switch with the appropriate firmware to support the zoning or 

virtualization functions in use within the SAN 

• Upgrading a switch with a new configuration or firmware, without disrupting the data 

path

• Removing a switch in a fabric

• Replacing a failed component, such as a switch, and coordinate the restoration of 

services (multipathing, ISLs, and so on) that depend on that resource
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• Verifying that the connections are valid and switches are operable

• Connecting and disconnecting devices on ports in a switch

• Adding, deleting, and updating zones, zonesets, and zone alias

• Reviewing SAN security measures to ensure that all systems and data are secure 

using fabric zoning 

• Server Administrator—A server administrator (also known as a server operator) 

manages and maintains servers; in particular, a server administrator performs 

server-related tasks. Typical tasks include:

• Setting up servers to support new applications, including requesting or utilizing new 

storage

• Adding a new server to an existing application or application cluster and attaching to 

an existing storage resource or newly allocated storage resources

• Requesting or adding new storage to an existing application (In some IT 

environments, this might be a database administrator’s responsibility.)

• Upgrading software and patching, including installation and configuration of HBA and 

associated drivers, and so on

• Troubleshooting server and application availability or performance problems

• Ensuring compliance of existing servers with existing standards or newly defined 

standards

• Network Administrator—A network engineer who works closely with system 

administrators to troubleshoot and resolve problems with applications that are running 

across a network. Typical tasks include creating and managing network device groups 

that support applications across multiple servers.

• Application (Tools) Administrator—An administrator, architect, or manager who 

manages the customer’s IT tools environment. Typical tasks include:

• Evaluating IT applications and tools

• Making IT applications and tools recommendations

• Designing an overall IT application environment that meets IT requirements and 

provides a more holistic management environment

• Installing, deploying, and configuring IT applications

• Managing and troubleshooting IT applications
8



• Interacting with software product support for the managed software and escalating 

issues

• Interfacing with the IT operational teams, collecting information on unmet 

requirements and problems with implemented software, aggregating these issues 

and working with current and potential vendors to resolve them

• Database Administrator (DBA)—An administrator who is responsible for database 

storage operations and planning.

• Storage Manager—A storage manager (also known as a storage architect or a 

principal engineer) is someone whose primary role is managerial or strategic, with less 

day-to-day technical responsibilities. Typical tasks include:

• Communicating with other teams, such as team performance with regard to SLA or 

goals, documenting adherence to policies, and so on

• Helping to guide the behavior of other teams, such as evangelizing, encouraging, 

and incenting efficient and proper use of storage resources

• Communicating with management, such as team performance with regard to plans 

and goals, justifying expenses and requests, and so on

• Identifying potential problems in the storage architecture, implementation, or capacity 

ahead of time and mitigating risk

• Estimating future storage hardware requirements and allocations

• Assisting finance operations with support contract renewals

This documentation also assumes that you are familiar with storage networks and Server 

Automation System (SAS)—because ASAS is an SA add-on feature.

It is also assumed that you have the required administrator permissions to view storage 

information.

Conventions in this Guide
This guide uses the following typographical and formatting conventions.

NOTATION DESCRIPTION

Bold Identifies field menu names, menu items, button names, and 

inline terms that begin with a bullet.
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Icons in this Guide
This guide uses the following icons.  

Courier Identifies text that is entered or displayed at the 

command-line prompt, such as Unix commands, HP Server 

Automation commands, file names, paths, directories, 

environment variable names, contents of text files that are 

viewed or edited with a text editor, source code in a 

programming language, and SQL (database) commands.

Italics Identifies document titles, DVD titles, web site addresses. 

Used to introduce new terms when they are first defined in a 

document and for emphasis.

ICON DESCRIPTION

This icon represents a note. It identifies especially important 

concepts that warrant added emphasis.

This icon represents a requirement. It identifies a task that 

must be performed before an action under discussion can be 

performed.

This icon represents a tip. It identifies information that can 

help simplify or clarify tasks.

This icon represents a warning. It is used to identify significant 

information that must be read before proceeding.

NOTATION DESCRIPTION
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Guides in the Documentation Set and Associated Users
• The HP SA User’s Guide: Server Automation is intended for system administrators 

responsible for all aspects of managing servers in an operational environment. It 

describes how to use SA, introducing the system and the user interface. It provides 

information about managing servers, remediating servers, script execution, 

configuration tracking, deploying and rolling back code, and agent deployment. It also 

explains how to use the Global Shell and open a Remote Terminal on managed 

servers.

• The HP SA User’s Guide: Application Automation is intended for system administrators 

responsible for performing the day-to-day functions of managing servers. It reviews 

auditing and compliance, software packaging, visual application management, 

application configuration, and software and operating system installation on managed 

servers.

• The SA Administration Guide is intended for administrators responsible for monitoring 

and diagnosing the health of the SA core components. It also documents how to set up 

SA user groups and permissions.

• The HP SA Planning and Installation Guide is intended for advanced system 

administrators responsible for planning all facets of an SA installation. It documents all 

the main features of SA, scopes out the planning tasks necessary to successfully install 

SA, explains how to run the BSA Installer, and details how to configure each of the 

components. It also includes information on system sizing and checklists for 

installation.

• The SA Policy Setter’s Guide is intended for system administrators responsible for 

setting up OS provisioning, configuration tracking, code deployment, and software 

management. 

• The Content Utilities Guide is intended for advanced system administrators responsible 

for importing content such as software packages into HP Server Automation. It 

documents the following command-line utilities: OCLI 1.0, IDK, and DET (CBT).

• The Automation Platform Developer’s Guide is intended for software developers 

responsible for customizing, extending, and integrating HP Server Automation. It 

documents how to create Web Services, Java RMI, Python, and CLI clients that invoke 

methods on the SA API. 
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Chapter 1: Introduction to ASAS

Overview of ASAS
The Application Storage Automation System (ASAS) offers storage management 

capabilities designed for storage administrators and server administrators by enabling 

end-to-end visibility and management of the entire storage supply chain.

Figure 1-1: Application Storage Automation System (ASAS)

ASAS helps storage administrators and server administrators by providing tools that 

increase cost savings through application storage, dependency and visibility, storage 

audits, storage capacity and utilization trending, and scripting and automation.

I N  T H I S  C H A P T E R

This section discusses the following topics:

• Overview of ASAS

• ASAS Benefits

• ASAS Features

• ASAS Icons
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ASAS Benefits
ASAS provides many benefits that add business value.

Figure 1-2: Ways That ASAS Creates Business Value

Improve Storage Utilization With Capacity and Utilization Reporting

ASAS offers reporting of storage capacity and utilization that is intended to create sizeable 

cost savings by better utilization of current resources and better forecasting of future 

needs. ASAS allows capacity and utilization information to be explored at any level in the 

storage stack, including per-application utilization, departmental utilization, database 

utilization, utilization of specific storage resource classes, and so on. ASAS also provides 

the historical dimension by tracking and reporting historical utilization, as well as 

forecasting future storage needs that are based on past trends.

IT environments typically achieve less, if not far less, than 50% utilization of available 

storage resources. There are several reasons for this. Most IT departments still do much of 

their SAN configuration tracking manually through the use of LUN map spreadsheets and 

the like. Inevitably, mistakes are made and information becomes out of date, leading to 

orphaned storage. There are so many levels in the storage supply chain where storage 

can be under-utilized, such as SAN, volume manager, file system, database, and so on. 

Even relatively minor under-utilization at each of these layers can result in overall 

utilization of less than 25%.
4
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ASAS helps organizations reach 80%-90% utilization by:

• Providing the missing visibility into whether and how storage resources are being used 

to allow reclamation of unused volumes.

• Allowing storage administrators to identify the true utilization through all levels in the 

supply chain for a given server, database, or application. The storage administrator can 

then maintain an appropriate reserve at the right level in the infrastructure and reclaim 

unused storage.

• Providing the reporting and visibility necessary to better align end-user storage 

consumption behavior with business goals and storage costs. The storage 

administrator can then set up charge-backs, provide executive-level visibility into 

storage utilization and costs by internal customer, department or application, and so on.

Improve IT Efficiency Through Operational Insight

ASAS provides storage administrators and server administrators with deep operational 

insight into the entire storage supply chain. This insight begins with the automatic 

discovery of all relevant storage resources, whether it is software, server, 

network-attached, or SAN resources. From a storage resource, the administrator has the 

ability to view and report on the storage inventory, as well as viewing and navigating 

dependencies throughout the storage infrastructure. Using Service Automation Visualizer 

(SAV), the storage supply chain can be depicted and navigated graphically as well. 

The following cost savings result from this rich operational insight:

• ASAS greatly increases IT efficiency by streamlining troubleshooting operations, 

providing an accurate baseline for planning provisioning and audit activities, identifying 

un-utilized or under-utilized resources for reclamation, highlighting configuration 

change in the storage infrastructure, facilitating training, and increasing situational 

awareness. 

• ASAS understands business applications and how these applications are built up from 

a variety of constituent IT resources. This understanding allows ASAS to report on how 

storage resources are used to service specific applications and business services. This, 

in turn, allows you to identify storage resource conflicts and contention between 

applications. 

• ASAS allows you to better understand the storage configuration holistically, across IT 

silos. When permitted, server administrators will have limited visibility into how the 

servers and applications they own consume SAN resources. Storage administrators are 

provided limited visibility into how their storage resources are consumed by servers and 
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applications. This holistic picture of the storage environment improves communication 

between teams in IT, and reduces friction and delay when provisioning storage or 

troubleshooting storage issues.

Storage information is protected by AAA (authentication, authorization and accounting) 

permissions. This ensures that sensitive storage data can only be accessed by staff 

members who have been granted access permissions.

Reduce Risk With the Compliance View

In most IT environments, no single user has a complete overview of the entire storage 

infrastructure. This is because much record keeping is manual, and because there are 

many point tools and command-line interfaces used to manage pieces of the 

infrastructure without being able to see or visualize the whole.

This situation has the following significant implications for an IT organization:

• It makes it difficult and costly to perform internal technology audits of the storage 

configuration. These audits are designed to ensure that the storage infrastructure is 

configured in a standardized manner, that best practices are followed, and that 

misconfigurations have not cropped up. These audits are necessary to ensure the 

integrity and reliability of the storage infrastructure. Because these audits can be 

extremely costly to perform, they are typically done in an ad-hoc, as-time-allows 

fashion, resulting in increased risk.

• The lack of visibility into the storage infrastructure and how specific storage resources 

are used by business applications make it extremely difficult and costly to confirm and 

document compliance. In the model regulatory climate, organizations are required to 

guarantee and document that their IT environment is secure and robust. Organizations 

need to be able to show that specific business applications are configured to meet 

defined internal standards. Without a clear understanding of what storage resources 

these business applications are using and visibility into the compliance status of these 

storage resources, the process of documenting compliance of the storage 

infrastructure becomes costly and confusing.

ASAS fills this gap by providing the single, automated source for storage infrastructure 

audits and compliance documentation. ASAS automatically analyzes the storage 

infrastructure and dependencies to ensure that a wide variety of storage best practices 

are properly implemented and that known misconfigurations have been prevented. This 

information is rolled up into the Compliance View at the device level or at the application 
6
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level. The Compliance View provides a single clearinghouse that helps identify potential 

risks in the environment, address these risks, and document the bill of health of the 

storage environment and of specific critical applications.

ASAS Features
Table 1-1 describes the capabilities and benefits of operational insight, reporting, audit 

and compliance, scripting and automation, enterprise features, and administrative 

features.

Table 1-1: ASAS Features and Benefits

FEATURE DESCRIPTION BENEFIT

Operational Insight

Discovery • Discover servers using the Agent 

Deployment feature

• Discover SAN resources using 

appropriate management station

• Discover storage inventory details of 

hosts, SAN resources, and NAS 

resources

• Discover inventory changes over time

• Discover dependencies between 

storage resources throughout the 

storage supply chain

• Quick startup with minimal 

overhead

• Maintain detailed up-to-date 

inventory of all storage resources 

and configurations
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Server Browser • Explore server storage properties:

Volume management software

Multipath I/O software

Disks

File systems

Mounted and available LUNs

Logical and physical volumes

• Explore and navigate server storage 

dependencies:

Attached or downstream SAN 

switches

SAN arrays and mounted volumes

NAS filers and mounted file systems

Resident databases and applications

• Identify and troubleshoot server 

storage configuration

• Identify and navigate downstream 

storage dependencies

• Provide information to facilitate 

efficient provisioning and 

modification of storage resources

• Identify available and unused 

storage resources

Table 1-1: ASAS Features and Benefits (continued)

FEATURE DESCRIPTION BENEFIT
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SAN Array 
Browser

• Support for SAN arrays and NAS filers

• Explore array properties:

Disks

Volumes and RAID groups

Pools

Fibre controllers and ports

• Explore and navigate array 

dependencies:

Dependent servers, applications and 

databases

Attached and upstream storage 

switches

• Support for vendor proprietary volume 

technologies:

NAS: aggregates, exports, …

SAN: meta, BCVs, LUSEs, …

• Report and navigate volume mirroring 

and replication relationships

• Identify and troubleshoot array / 

filer configuration

• Effectively manage existing and 

new storage resources

• Identify and navigate upstream 

storage dependencies

• Provide information to facilitate 

efficient provisioning and 

modification of storage resources

• Identify available / unused storage 

resources

Switch Browser • Explore storage switch properties:

Firmware

Fibre controllers and ports

• Explore and navigate switch 

dependencies:

Upstream servers, applications and 

databases

Downstream storage arrays

Attached storage switches and 

fabrics

• Support for director-class switches

• Identify and troubleshoot switch 

and fabric configuration:

Topology

Zones and zone sets

• Identify and troubleshoot 

performance bottlenecks and 

failure points in the SAN 

• Provide information to facilitate 

efficient fabric provisioning

Table 1-1: ASAS Features and Benefits (continued)

FEATURE DESCRIPTION BENEFIT
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Database 
Browser

• Explore database properties:

Tablespaces

Data files

Configuration files

• Explore and navigate database 

dependencies:

Dependent applications

Host servers

Downstream storage resources and 

arrays

• Identify and troubleshoot 

database configuration

• Identify and navigate downstream 

storage dependencies

• Identify available and unused 

storage resources

• Identify how database fits into 

business application delivery

Fabric Browser • Explore and navigate fabric properties:

Aliases

Zones

Zonesets

• Explore and navigate fabric residents:

Servers, HBAs and fibre ports

Switches and fibre ports

Arrays and fibre ports

• Gain visibility into zone 

configuration and facilitates 

effective zone management

Visualization • Dynamic visualization of the storage 

infrastructure devices and resources in 

the context of the broader IT and 

business-application environment:

Expand or collapse the level of detail

Dependency tree navigation

• Logical, physical, and hybrid storage 

views

• Trace and troubleshoot 

application dependencies

• Build situational awareness of the 

current storage infrastructure 

configuration

• Visually identify upstream and 

downstream dependencies, 

contention and conflicts

• Document and visually compare 

storage infrastructure changes 

over time

Reporting

Table 1-1: ASAS Features and Benefits (continued)

FEATURE DESCRIPTION BENEFIT
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Search-Based 
Reporting

• Create ad-hoc tabular reports using a 

simple search-based user interface:

Arrays and filers

Storage switches

Hosts

Databases and applications

LUNs, file systems, volumes and 

disks

HBAs and fibre ports

• Save reports

• Export or email the results

• Run reports periodically

• Quick access to data needed for 

daily operational tasks

• Automate both ad-hoc and 

recurring asset, inventory and 

storage configuration reports that 

often require manual compilation 

today

Inventory Reports • System offers built-in inventory reports 

on the storage infrastructure as a 

whole and specific elements within it

• Host reports:

Host Storage Inventory

Host Storage Detail

Host Storage Dependencies

• Array / filer reports:

Array Inventory

Array Detail

Array Dependencies

• Storage switch reports:

Storage Switch Inventory

Storage Switch Detail

Storage Switch Dependencies

• Report at the host/array level or break 

out information by LUN

• Export or email the report output

• Simple, at-a-glance view of the 

storage infrastructure

• Facilitates communication and 

troubleshooting between groups

• Make data in the system available 

for non-users

Table 1-1: ASAS Features and Benefits (continued)

FEATURE DESCRIPTION BENEFIT
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Capacity & 
Utilization 
Reports

• System offers built-in capacity and 

utilization reports

• Organizational reports:

Application

Department/Business Unit Storage 

Detail

Site Storage Detail

Device Group Storage Detail (applies 

to any arbitrary device group)

• Host reports:

Host Capacity & Utilization

Host Capacity & Utilization Trend

Host Capacity & Utilization Trend 

Detail

• Array reports:

Array Capacity & Utilization

Array Capacity & Utilization Trend

Array Capacity & Utilization Trend 

Detail

• Filter or group data by Application, 

Department, Site or any Device Group

• Timeseries reports show past 

information

• Trend reports show future projections

• Identify opportunities for 

reclamation of un-used or 

under-utilized storage

• Map out storage utilization for 

upper management

• Implement charge-backs

• Encourage better utilization of 

assigned storage resources

• Analyze historical storage trends

• Forecast future storage needs

Audit & Compliance

Table 1-1: ASAS Features and Benefits (continued)

FEATURE DESCRIPTION BENEFIT
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Compliance View • Automatically audit the storage 

infrastructure to determine and report 

host compliance with key best 

practices, such as:

Proper multipathing at all levels in 

the storage supply chain

All LUNs on the SAN that are 

mapped to specific hosts should be 

properly mounted by those hosts

Replication target volumes should 

not be mounted

Storage has replication configured 

but replication is failing

• Configure compliance metrics to match 

organizational policies

• Integrated with the compliance 

dashboard:

Feeds into unified audit of overall 

application compliance

• Reduce risk

• Increase standardization and 

adoption of best practices

• Reclaim resources orphaned due 

to misconfiguration

Scripting & Automation

Table 1-1: ASAS Features and Benefits (continued)

FEATURE DESCRIPTION BENEFIT
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Global Shell File 
System (OGFS)

• Standard shell interface into storage 

inventory

• Navigate all storage entities in a file 

system-like presentation:

Arrays and filers

Storage switches

Servers

Databases

• Ideal for scripting

• Supports all common scripting 

languages, such as Perl, TCL, Python, 

shell-script, and so on

• Quickly and easily create scripts 

for:

Custom reports

Custom audits

Ad-hoc exploration of storage 

information

Unified API • Unified API provides full programmatic 

access to all data and features:

Supports web-services programming 

interfaces

Provides a single API for datacenter 

automation across storage, servers, 

and IP networks

• Extend and customize ASAS

• Integrate with external systems, 

such as CMDB, change request, 

ticketing, monitoring, and so on

Enterprise Features

Multimaster • Connect multiple ASAS instances 

together, spanning multiple data 

centers

• Each ASAS instance has a complete 

view of the entire storage infrastructure

• Each ASAS instance can manage local 

resources (with failover when an 

instance becomes unavailable)

• Data is synchronized across instances 

automatically

• Built-in high availability and 

disaster recovery

• ASAS scales seamlessly, both 

within a single datacenter and 

across the global IT network

• Users in each datacenter have a 

local UI, improving UI 

responsiveness

Table 1-1: ASAS Features and Benefits (continued)

FEATURE DESCRIPTION BENEFIT
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Gateway • Secure tunnel between system 

components:

• Enable management of overlapping 

IP networks

• Enable management across bastion 

hosts

• Providing redundant routing between 

system components

• Allow public networks to be used for 

management without security 

concerns

• Ensure system security in 

distributed deployments

• Manage complex network 

topologies seamlessly

• Support fault tolerant distributed 

ASAS deployments

AAA 
(Authentication, 
Authorization, & 
Accounting)

• User authentication:

• Use built-in database or leverage 

external authentication mechanisms 

(such as LDAP) 

• Role-based user authorization:

• Control access by server or storage 

device

• Control access by user role to 

include some, all or no server/

application visibility

• Control access by user role to 

include some, all or no storage 

infrastructure visibility

• Prevent unauthorized or improper 

use of the system; ensure data 

integrity

• Ensure proper levels of separation 

between server and storage 

teams

• However, facilitate an appropriate 

level of visibility between teams 

where such visibility is lacking 

today, which will reduce 

organizational friction and delay

• Ensure sub-groups within server 

and storage teams only have 

access to the devices appropriate 

to their job function

Administrative Features

Table 1-1: ASAS Features and Benefits (continued)

FEATURE DESCRIPTION BENEFIT
35



User’s Guide

3

Device Groups • Create device groups containing any 

combination of storage arrays, storage 

switches, and servers:

• Static groups

• Dynamic groups computed 

automatically based on device 

properties

• Hierarchical groups

• Powerful array of grouping 

mechanisms allow devices to be 

organized to align with corporate 

structure, IT processes, physical 

device attributes, and so on

• Dynamic grouping ensures 

groups are always up to date with 

no maintenance required

• Groups allow operations and 

reports to be performed on large 

groups of devices easily and 

accurately

Server Discovery • Server discovery automatically 

discovers and classifies all servers on 

the network in preparation for 

automated agent deployment

• Streamline ASAS rollout

• Ensure accurate inventory 

information

Automated Agent 
Deployment 

• Agent Deployment system deploys 

server agents automatically—leverages 

existing SA agents without modification 

or upgrade needed

• Storage Agents are deployed 

automatically using built-in software 

deployment capabilities

• Streamline ASAS rollout 

• Minimize ongoing administrative 

costs

Storage Agent 
Management 
Console

• Provides at a glance view of all ASAS 

Storage Agents:

• Full inventory of deployed storage 

agents and hosting servers

• Storage agent status

• Storage agent configuration

• Minimize ASAS administration 

costs

Table 1-1: ASAS Features and Benefits (continued)

FEATURE DESCRIPTION BENEFIT
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For a list of supported storage device hardware and software from various vendors, see 

the ASAS Installation and Administration Guide.

ASAS Icons
Table 1-2 identifies icons used in the ASAS user interface. For expanded descriptions of 

these icons, see “Asset Discovery” on page 41. Text in parenthesis indicates the 

terminology used in this documentation.

Table 1-2: Icons in ASAS

ASAS ICON DESCRIPTION

Administration ASAS Agents

Databases
(Oracle Database Assets)

Data Files

Device Group Assets

Ethernet Ports

Fibre Channel Ports
(Fibre Channel Adapter Ports)

File Systems
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Fibre Channel Adapters

NAS Filer Aggregates
(Aggregates)

NAS Filers
(NetApp Assets)

NetApp LUNs

SAN Arrays
(SAN Array Assets)

SAN Fabrics
(Fabric Assets)

SAN Fabric Aliases
(Alias)

SAN Fabric Zones
(Zoning Database and Zones)

SAN Fabric Zone Sets
(Zonesets)

SAN Switches
(Fibre Switch and Fabrics)

Server Assets

Table 1-2: Icons in ASAS (continued)

ASAS ICON DESCRIPTION
8
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Static Device Groups

Storage
(SAN Array Storage Systems)

Storage Clusters
(NetApp Cluster)

Storage Disks
(Disks)

Storage Initiators

Storage Pools

Storage Replication
(SRDF/TimeFinder (Replication))

Storage Targets

Tablespaces

Volumes
(Storage Volumes)

Table 1-2: Icons in ASAS (continued)

ASAS ICON DESCRIPTION
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Overview of Asset Discovery
IT administrators have a strong need for perfect discovery—to find all resources known 

and unknown in the environment, without any performance, reliability or alarm impacts.

In order to discover all key asset and storage-allocation information about each resource, 

ASAS must be seeded with basic information about the SAN and NAS resources in your IT 

environment. ASAS also requires access to the following proprietary vendor APIs:

• Storage Agents

• Storage Host Agent Extensions

• Storage Assets Groups

For other ways that ASAS displays discovered storage agents, see “Storage Visualization” 

on page 291 and “Storage Reports” on page 293.

I N  T H I S  C H A P T E R

This section discusses the following topics: 

• Overview of Asset Discovery

• How Discovery Works

• What Gets Discovered

• Server Assets

• SAN Array Assets

• Fabric Assets

• NetApp Assets

• Oracle Database Assets

• Device Group Assets
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How Discovery Works
Figure 2-1 shows the end-to-end process of discovering and synchronizing a storage 

device.

Figure 2-1: Storage Agents Monitor Storage Systems

Storage Device

A storage device in the ASAS model is an entity that represents the volumes, extents, and 

other things in the real world that contain the actual bits and bytes. A storage device can 

be any block storage device that has a capacity measured in bytes, such as physical 

disks, partitions, and database tablespaces. 

There are two types of storage devices:

Logical Volume—A block storage extent, such as partition, database tablespace, and 

remote initiator volume.

Physical Disk—A physical storage device that provides the raw storage for a storage 

system, such as storage array disks or spindles.
2
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Deleting a Storage Device

This action only removes a storage device (SAN array, SAN switch, SAN fabric, NAS filer, 

and database) from the Model Repository. This delete action does not affect the 

corresponding Storage Agent and its storage device access controls that monitor this 

device.

To remove a storage device from the Model Repository, perform the following steps:

1 From the Navigation pane, select Devices ➤Storage and then select a device type, 

such as SAN Arrays, SAN Switches, SAN Fabrics, or NAS Filers. 

Or

From the Navigation pane, select, Library ➤ Databases.

2 In the content pane, select a device. You can also select more than one device.

3 From the Actions menu, select Delete.

Figure 2-2: Delete SAN Arrays Dialog

4 Click Delete to remove the device from the Model Repository.

Storage Agents

A Storage Agent is an ASAS component that runs on a managed server to collect storage 

device information, such as SAN arrays, SAN switches, SAN fabrics, NAS filers, and Oracle 

databases. A Storage Agent must be installed in the core and then deployed on a 

managed server.

To support the discovery of different types of storage data, Storage Agents are installed 

independently of each other—you are not required to install all Storage Agents, only the 

ones that your environment requires.

ASAS provides the following two types of Storage Agents:
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• Java Storage Agents—Send binary messages to the storage server. ASAS provides 

a command line management interface for this type of Storage Agent.

• XML Storage Agents—Send XML messages to the storage server. ASAS provides a 

graphical user management interface for this type of Storage Agent.

Table 2-3 lists the types of ASAS Storage Agents.

For information about installing Storage Agents, see the ASAS Installation & 

Administration Guide.

Storage Host Agent Extension (SHA)

A Storage Host Agent Extension (SHA) runs on a managed server to discover storage 

related data on that managed server, such as Fibre Channel Adapter (FCA) hardware and 

drivers, file system mounts, and so on.

SHAs are C++/Python modules that are centrally scheduled and triggered by the way 

XML output is sent to the storage server. An SHA is not an agent.

Table 2-3: ASAS Storage Agents

JAVA STORAGE AGENT XML STORAGE AGENT

Brocade Storage Agent HiCommand Storage Agent (Hitachi)

CLARiiON Storage Agent (EMC) NetApp Storage Agent

McDATA Storage Agent

Oracle Storage Agent

Symmetrix Storage Agent (EMC)
4
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Figure 2-3 shows the end-to-end process of the SHA that captures storage-related data 

on a managed server.

Figure 2-3: SHA on a Managed Server

What Gets Discovered
Storage code running inside of the Web Service Data Access Engine (twist) connects the 

supply chain between the server, fabric, and storage domains.

Figure 2-4 shows a high level view of what gets discovered (server data, fabric data, and 

storage data) and then sent to the twist server. The twist server connects the supply chain 
45



User’s Guide

4

between the server data, fabric data, and storage data to where it becomes visible to the 

end user.

Figure 2-4: Storage Data that is Discovered
6
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Figure 2-5 shows how server, fabric, and storage elements are connected in a typical 

storage domain.

Figure 2-5: Storage Domains
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Server Assets 

This feature provides visibility into the storage configuration in a managed server attached 

to the Storage Area Network (SAN) or Network Attached Storage (NAS). These 

configurations can help you understand the dependency on SAN and NAS elements.

Storage elements in a server (server assets) include logical entities, such as volumes and 

physical hardware. This feature allows you to view and evaluate storage-related 

information for a managed server, such as FCAs and FCA drivers, volume mounts, volume 

manager information, and so on.

The discovery of server storage elements is enabled by processes that periodically query 

the managed server and then push the data to the core.

ASAS displays server storage assets after the hardware registration process is 

successfully completed. Hardware registration typically occurs within the first 24 hours of 

the Storage Agent deployment. For information about how to initiate the hardware 

registration process as needed, see the SA User’s Guide: Server Automation.

You can define the job schedule for capturing storage data. For more information, see 

“Scheduling Server Asset Discovery” on page 50.

With this feature, a server administrator can view:

• Storage-related information in each managed server, such as FCAs and FCA drivers, 

volume mounts, volume manager information, and so on

• Unmounted storage resources that the SAN is making available to the host

• LUN volume (SAN LUN) that is bounded to a server

• Aggregate information on storage elements (such as volumes used) that are 

associated with an application in a server

This feature also provides quick navigation to downstream physical or logical storage 

elements associated with an application or a single managed server. At any level in the 

storage supply chain, you can drill down to the associated storage entities to view:

• Physical entities—fibre switches, filers, disks, and so on

• Logical entities—zones, LUNs, and so on
8
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From these entities, you can drill down or drill up to see storage resources that are shared 

between two or more selected applications or managed servers.

ASAS captures the following server assets:

• Fibre Channel Adapter (FCA) —Storage information on the active Fibre Channel 

Adapter (FCA). In the storage industry, FCA also applies to the hardware interface that 

uses non-Fabric Channel protocol. ASAS discovers the Manufacturer, Model, Serial 

Number, Software Driver Version, Software Firmware Version, and Physical Hardware 

Version for an FCA. 

• Fibre Channel Adapter Port —The port on the FCA to provide access to the 

outside world—storage information on the active Fibre Channel Port World Wide Name 

(WWN). For information about storage in the connectivity between FCA Port and FC 

Switch Port, see “Fabric Assets” on page 142.

• Base Volumes—Basic raw storage capacity (primordial storage). This raw storage 

may be virtualized and consumed in the layers above (Volume Managers, File 

Systems). These storage elements include local storage (Root Volumes) based disks, 

Direct Attached Storage (DAS), and LUN Volumes (SAN LUNs). 

• Root Volumes (Local and DAS)—Storage exposed through disks that are local and 

are based on DAS as logical Root Volume. Hardware information of the spindles or 

disk controllers is not captured.

• LUN Volumes (SAN LUNs)—The volume presented to a host or server on the 

storage array port. For storage elements that are bounded to the managed server 

through Fibre Channel protocol and SAN, ASAS captures information, as available, on 

the source (SAN Array or SAN Gateway). This information includes source identifier, 

Fabric Port participating in the LUN Mapping (FCA Port WWN, SAN Array/Gateway 

WWN), LunID, and so on. ASAS also captures the dependency chain for the LUN 

Volumes on Fabrics, SAN Array, and Gateway. For more information, see “Fabric 

Assets” on page 142. ASAS does not support LUNs mounted from remote servers. 

ASAS displays the LUN in decimal format. The native management tool uses 

hexidecimal format.

• Multipath IO (MPIO)—Information on the MPIO software and all of the Fibre Channel 

protocol based storage access paths to remote storage volumes. This information 

includes access path information for each of the LUN bounded to the server. For each 

path, ASAS captures the following information:

– State of the path—active or passive
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– Is Preferred Path

– FCA Port consumed for each of the path

• Volume Manager (Logical Volume Manager/Logical Disk Manager)—Native and 

third party Volume Manager Software information. This includes information on all 

aspects of storage, such as capacity and storage layout, that are consumed and 

produced by the Volume Manager. ASAS does not provide detailed information on 

internals of the Volume Manager. However, for each of the volumes produced by the 

Volume Manager, ASAS provides dependencies on primordial storage, such as 

dependency chain that includes consumed storage. ASAS does not support layered 

volume managers and layered volumes.

• Consumed Storage—Storage that is directly consumed by the Volume Manager from 

the server primordial storage. ASAS discovers storage capacity if the applicable volume 

group (Disk Group) is the source of the consumable storage (server level primordial 

storage only). ASAS also captures storage consumed by a volume manager, which 

consumes external storage. Not all storage resources are virtualized to create volume 

manager volumes.

• Produced Storage—Storage capacity when the applicable volume group (Disk Group) 

is the type (SIMPLE, RAID5, and so on) for the produced storage (volumes). Produced 

storage consists of storage units created by a hosted service, such as file systems, 

volume managers, and databases. 

• File Systems —Consumers of the produced storage. This functionality includes 

capturing the file systems that are based on primordial storage and storage offered by 

volume manager volumes. ASAS discovers Block Driver, Cluster Size, Is Remote, File 

System Size, File System Type (nfs, ufs, vxfs, hfs, ext2, ext3, ntfs, and so on), Mount 

Point, and Root and Storage capacity information. ASAS also discovers the dependency 

chain for the File System based on NetApp. For more information, see “NetApp Assets” 

on page 179. For this release, ASAS does not support Distributed File System.

Scheduling Server Asset Discovery

In ASAS, the discovery of server storage elements is enabled by processes (jobs) that 

periodically query the managed server and then push the data to the core. You can define 

the job schedule for capturing storage data.
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Server Storage and SAN Relationships

ASAS captures relationships between server storage elements and other storage asset 

discovery features. See Table 2-4.

ASAS does not include relationships that are local to the discovery server storage asset.

Frequently Asked Questions

Table 2-5 shows you how to use this documentation to find answers to some frequently 

asked questions about finding information about server storage elements in a managed 

server.

Table 2-4: Server Assets and SAN Relationships

SERVER ASSET EXTERNAL ELEMENT DESCRIPTION

File System Remote File Systems

(only NFS mounted file system 

dependency)

Captures only NFS-mounted file 

system dependency information.

LUN Volumes Resides on storage volumes and disks 

from SAN Array/Gateway

The volume presented to a host or 

server on the storage array port.

FCA Port Connected FC switch port The port on the FCA to provide 

access to the outside world—storage 

information on the active Fibre 

Channel Port World Wide Name 

(WWN). 

Table 2-5: Frequently Asked Questions About Server Assets

QUESTION HOW TO FIND THE ANSWER

1. What are the application storage configurations 

in a managed server?

• “Viewing File Systems Mounted on a 

Server” on page 60

• “Viewing Databases Hosted by a Server” 

on page 93
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2. What is causing application performance 

degradation? How is all of the server storage 

configuration impacting the application? What 

are the shared resources between applications?

• “Viewing Ports and Volumes in an FCA” on 

page 57

• “Viewing Port Connections and Zones” on 

page 58

• “Viewing Access Paths to Storage Targets” 

on page 86

• “Viewing Fabrics Attached to a Server” on 

page 89

• “Viewing Storage Volumes with Access 

Paths for Remote Initiators” on page 109

• “Viewing the Access Path from the Disk” on 

page 126

• “Viewing the Access Path from the Volume” 

on page 134

• “Viewing Storage Initiators” on page 167

3. What SAN elements (switches, arrays, and 

gateways) are applications, through server 

storage assets, dependent on?

• “Viewing Antecedents and Dependents of 

Volumes” on page 68

• “Viewing File Systems Mounted on a 

Server” on page 60

• “Viewing Volume Details” on page 63

4. What are the storage expansion opportunities 

for an application and for a managed server?

• “Viewing Storage Summary in a Server” on 

page 59

• “Viewing File Systems Mounted on a 

Server” on page 60

• “Viewing Volumes Created on a Disk” on 

page 76

• “Viewing Unmounted Volumes” on page 80

5. Are critical applications configured for high 

availability, such as multiple paths?

• “Viewing Ports and Volumes in an FCA” on 

page 57

Table 2-5: Frequently Asked Questions About Server Assets (continued)

QUESTION HOW TO FIND THE ANSWER
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6. Why is a LUN Volume not visible to the server? • “Viewing FCAs Attached to a Server” on 

page 55

• “Viewing Unmounted Volumes” on page 80

• “Viewing SAN Fabrics and Attached 

Devices” on page 158

• “Viewing Storage Initiators” on page 167

• “Viewing Storage Volumes with Access 

Paths for Remote Initiators” on page 109

• “Viewing the Access Path from the Disk” on 

page 126

• “Viewing the Access Path from the Volume” 

on page 134

7. What are the unmounted storage resources that 

the SAN is making available to the managed 

server?

• “Viewing Unmounted Volumes” on page 80

• “Viewing the Access Path from the Disk” on 

page 126

• “Viewing the Access Path from the Volume” 

on page 134

Table 2-5: Frequently Asked Questions About Server Assets (continued)

QUESTION HOW TO FIND THE ANSWER
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8. What are the LUN volumes (SAN LUN) bounded 

to a server?

• “Viewing Volume Details” on page 63

• “Viewing Antecedents and Dependents of 

Volumes” on page 68

• “Viewing Access Paths for a Volume” on 

page 69

• “Viewing Volumes in a SAN Array” on 

page 128

• “Viewing SAN Fabrics and Attached 

Devices” on page 158

• “Viewing Storage Initiators” on page 167

• “Viewing Storage Volumes with Access 

Paths for Remote Initiators” on page 109

9. What is the aggregate information on storage 

elements (volumes used) associated with an 

application in a server?

• “Viewing Antecedent of Aggregate Storage 

Supply Chain” on page 83

10. How do I navigate to downstream physical or 

logical storage elements associated with an 

application or a single managed server?

• “Viewing Antecedents and Dependents of 

Volumes” on page 68

11. How do I navigate to the associated storage 

entities at any level in the storage supply chain, 

such as:

• Physical entities—fibre switches, filers, disks, 

and so on

• Logical entities—zones, LUNs, and so on?

• “Viewing Ports and Volumes in an FCA” on 

page 57

• “Viewing Port Connections and Zones” on 

page 58

Table 2-5: Frequently Asked Questions About Server Assets (continued)

QUESTION HOW TO FIND THE ANSWER
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Viewing FCAs Attached to a Server

To troubleshoot fibre channel connectivity and identify the inventory, operational status, 

and storage resources consumed through a Fibre Channel Adapter, you need to know 

what FCAs are attached to a certain managed server.

To view FCAs that are attached to a server, perform the following steps:

12. How can I view storage resources that are 

shared between two or more selected 

applications or servers?

• “Viewing Storage Volumes with Access 

Paths for Remote Initiators” on page 109

• “Viewing SAN Fabrics and Attached 

Devices” on page 158

• “Viewing Storage Initiators” on page 167

• “Viewing the NAS Filer Storage 

Configuration” on page 186

Table 2-5: Frequently Asked Questions About Server Assets (continued)

QUESTION HOW TO FIND THE ANSWER
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1 From the Navigation pane, select Servers ➤ All Managed Servers.

Figure 2-6: Fibre Channel Adapters Attached to a Server

2 In the content pane, select a server.

3 In the View drop-down list, select Hardware. The Hardware pane displays information 

about the server and the FCAs that are attached to it. This information is captured by 

Storage Host Agent Extensions (SHAs).

Important to Know

Manufacturer—The name of the hardware vendor.

Model—The model number of the hardware.

Processors—The CPU running inside the server.

Memory (RAM)—The Random Access Memory on the server.

Memory (SWAP)—The virtual memory on the server.

Fibre Channel Adapters—The name (WWN of one of the port or node WWN) and 

model number of the FCAs attached to the selected managed server.
6
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Viewing Ports and Volumes in an FCA

To view which ports and volumes are in an FCA, perform the following steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.

3 From the Navigation pane, select Inventory.

4 In the Views pane, expand the Hardware list and then select the Fibre Channel 

Adapter (FCA) name. For more information about FCA, see “Server Assets” on 

page 48.

Figure 2-7: Ports and Volumes in an FCA

Important to Know

Name—The Fibre Channel Adapter name (WWN of one of the port or node WWN).

Model—The model number of the FCA.

Serial—The serial number of the FCA.

Driver Version—The driver version of the FCA.
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Firmware Version—The firmware version of the FCA.

Hardware Version—The hardware version of the FCA.

Ports—A list of ports in the FCA, including the fabric that is attached to the port.

Volumes—Detailed information about the FCA, such as the volume in the server that 

is LUN bound through this port, the target name of the SAN array, and so on.

Viewing Port Connections and Zones

To view switch ports that a port is connected to and zones that a port belongs to, perform 

the following steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.

3 From the Navigation pane, select Inventory.

4 In the Views pane, expand the Hardware list and then select the fibre channel port.

Figure 2-8: Switch Ports and Zones
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5 Click the name of the switch in the Connected To field to open the Switch Browser for 

the switch that this port is connected to.

6 Review the Zones section to see what zone set the zone belongs to and verify 

whether the zone is Active (Yes).

Important to Know

FCID—The Fibre Channel ID of the FCA port.

WWN—The World Wide Name of the FCA port.

Fabric—The fabric that is attached to the port.

Connected to—The switch port combination that this port is connected to. Click this 

link to open the Switch Browser.

Status—The status of the port, such as Online or Linkdown. Linkdown means that 

there is no fibre connected.

Volumes—Detailed information about the volumes that are using this port, such as 

the volume in the server that is LUN bound through this port (Volume), the LUN ID 

(LUN), the name of the SAN Array or NAS Filer (Target), and the Target Port.

Zones—The zones that this port is a member of, such as the name of the zone, the 

zone set that the zone is a member of, and whether the zone set is active (Yes). A 

dash (-) in the Active column means unknown.

Viewing Storage Summary in a Server

To view storage summary in a managed server, perform the following steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.
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3 From the Views pane, select Inventory ➤  Storage.

Figure 2-9: Server Storage

Important to Know

File Systems—The file system usage for the managed server.

Local and Direct Attached Storage—The local and direct attached disks usage for 

the managed server

SAN Storage—The SAN storage usage for the managed server.

Network Attached Storage—The network attached storage for the managed server 

Database Storage—The database usage for the managed server 

Viewing File Systems Mounted on a Server

To view file systems mounted on a server, perform the following steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.
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3 From the Views pane, select Inventory ➤  Storage ➤ File Systems. The content 

pane displays information about all file systems that are mounted on the selected 

server.

Figure 2-10: Mounted File Systems

Important to Know

Mount—The mount point of the file system.

Type—The file system type, such as ext2, ext3, hfs, nfs, ntfs, ufs, vxfs, and so on.

Capacity—The total capacity of the file system.

Free Space—The unused capacity of the file system.

Viewing File System Properties

To view properties of a file system, perform the following steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.

3 From the Views pane, select Storage ➤ File Systems.
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4 In the content pane, select a file system to display the Properties pane. This pane 

displays details about the file system.

Figure 2-11: File System Properties

Important to Know

Mount—The name of the current mount.

Description—A description of the file system as assigned by HP.

Mount Options—The mount options of the file system.

Mount Point—The mount point of the file system.

Root—The root of the file system.

Type—The type of file system, such as ext2, ext3, hfs, nfs, ntfs, ufs, vxfs, and so on.

Capacity—The total capacity of the file system.

Free—The free capacity of the file system.
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Viewing Volume Details

You can view volume details, such as properties, composition, disks, access path, and 

connectivity by volume.

To view volume details, perform the following steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.

3 From the Views pane, select Inventory ➤  Storage ➤ File Systems.

4 In the content pane, select a file system to display the Volumes pane.

5 From the View drop-down list, select Volumes.

6 (Optional) From the View drop-down list, select an option to display properties, 

volumes, disks, or connectivity by volume.

Figure 2-12: Volumes Consumed

Important to Know

Name—The name of the volume.
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Type—JBOD, RAID3, RAID5, RAID5PLUS1, RAIDS_3_PLUS_1, RDF_R1_RAID_S, 

SPARE, BCV, BCV_RDF_R1, VDEV, BCV_RDF_R1_RAID5_7_PLUS_1, SIMPLE, 

CONCATENATED, STRIPED, MIRRORED, and so on.

Service Type—The type of volume, such as LUN, Root, or VOLUME MANAGER. Root 

volumes are extents created on the local disk or DAS disks. LUN are the extents 

created on the Remote SAN based LUN disks. VOLUME MANAGER are the storage 

extents created using a server based storage virtualization software.

Status—The status of the volume, such as OK, Online, Disabled, Not Ready, Error, or 

READONLY.

Capacity—The capacity of the volume, in MB or GB.

Paths—The total number of paths that this volume can be accessed through, such as 

0, 1, 2, and so on. A hyphen (-) means that HP is unable to determine this 

information.

Viewing Local Disks

To view local disks used by a file system, perform the following steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.

3 From the Navigation pane, select Inventory ➤Storage ➤  File Systems.

4 In the content pane, select a file system.
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5 From the View drop-down list, select Disks to display the Disks pane. This pane 

displays information about disks that are consumed by a file system.

Figure 2-13: Local Disks

Important to Know

Name—The name of the disk.

Manufacturer—The manufacturer of this disk.

Model—The model number of the disk.

Device—The device that contains the disk.

Capacity—The capacity of the disk.

Status—Identifies the disk health, such as OK, ONLINE, Disable, Not Ready, Error, 

READONLY, and so on.

Spare—Indicates whether the disk is used as a spare (Yes) or not used as a spare 

(No).

Viewing the Storage Supply Chain

To view the storage supply chain as a tree, perform the following steps:
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1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.

3 From the Navigation pane, select Inventory ➤ Storage ➤  File Systems.

4 In the content pane, select a file system.

5 From the View drop-down list, select Connectivity to display the Connectivity pane. 

This pane displays Storage Supply Chain for the selected file system.

Figure 2-14: Storage Supply Chain

Important to Know

Root Level—The file system mount point.

Level 1—Volume.

Level 2—Disk with multipath information.

Level 3—SAN volume from the SAN array.

Level 4—SAN-based disk.
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Viewing Volume Properties

To view properties of a volume, perform the following steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.

3 From the Views pane, select Inventory ➤  Storage ➤ Volumes.

4 In the content pane, select a volume.

5 From the View drop-down list, select Properties to display the Properties pane. This 

pane displays information about the selected volume.

Figure 2-15: Volume Properties

Important to Know

Name—The name of the volume.

Type—JBOD, RAID3, RAID5, RAID5PLUS1, RAIDS_3_PLUS_1, RDF_R1_RAID_S, 

SPARE, BCV, BCV_RDF_R1, VDEV, BCV_RDF_R1_RAID5_7_PLUS_1, SIMPLE, 

CONCATENATED, STRIPED, MIRRORED, and so on.
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Service Type—The type of volume, such as LUN, Root, or VOLUME MANAGER. Root 

volumes are extents created on the local disk or DAS disks. LUN are the extents 

created on the Remote SAN based LUN disks. VOLUME MANAGER are the storage 

extents created using a server based storage virtualization software.

Status—The status of the volume, such as HEALTHY.

Description—A description of the volume as assigned by HP.

Capacity—The total capacity of the volume, in MB or GB.

Paths—The total number of paths that this volume can be accessed through, such as 

0, 1, 2, and so on. A hyphen (-) means that HP is unable to determine this 

information.

Viewing Antecedents and Dependents of Volumes

To view antecedent and dependents of the volume storage supply chain, perform the 

following steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.

3 From the Views pane, select Inventory ➤  Storage ➤ Volumes.

4 In the content pane, select a volume.

5 From the View drop-down list, select Composition to display the Composition pane. 

This pane displays information about the selected antecedent or dependent storage 

resource.
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6 (Optional) In the Composition pane, right-click on a storage resource to open its 

corresponding SAN Array Browser.

Figure 2-16: Volume Composition

Important to Know

Name—The name of the antecedent or dependent storage resource.

Type—The type of storage resource, such as DATAFILE, PHYSICALDISK, 

STORAGEVOLUME, or TABLESPACE.

Device/Database—The device or database that owns the storage resource.

Relation—The location in the storage supply chain, such as Downstream or 

Upstream.

Viewing Access Paths for a Volume

Access paths include Target and Target Port LUN based volumes. This provides visibility 

into the MPIO configuration of a volume.

To view a list of access paths, perform the following steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.
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2 In the content pane, select a server and then open it.

3 From the Views pane, select Inventory ➤  Storage ➤ Volumes.

4 In the content pane, select a volume.

5 From the View drop-down list, select Access Path to display the Access Path pane. 

This pane provides visibility into the MPIO configuration of a volume by displaying 

Target and Target LUN based volumes in the list of access paths.

6 (Optional) Select a path and then select one of the following options from the 

Actions menu:

• Open Target—Displays the SAN Array Browser or the NAS Filer Browser, 

depending on the AAA permission.

• Open Target Port—Displays the SAN Array Ports Browser or the NAS Filer Ports 

Browser, depending on the AAA permission.

• Open Target Volume—Displays the SAN Array Volume Browser or the NAS Filer 

Volume Browser, depending on the AAA permission.

Figure 2-17: Access Paths
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Important to Know

Initiator Port—The FCA port in the server that is used for data access.

LUN—The LUN ID.

Target—The target of the volume, such as SAN Array or NAS Filer (Block).

Target Port—The target port that is LUN mapped to the LUN volume.

Target Volume—The volume on the target that makes up the host volume, such as 

SAN array, NAS filer, or target volume that makes up the host volume.

Viewing Volume Connectivity

To view the connectivity of a volume, perform the following steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.

3 From the Views pane, select Inventory ➤  Storage ➤ Volumes.

4 In the content pane, select a volume.

5 From the View drop-down list, select Connectivity to display the Connectivity pane. 

This pane displays the connectivity information for the volume.
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6 (Optional) Select a level and then select Actions ➤  Open (Enter) to display the 

SAN Array Browser or the NAS Filer Browser.

Figure 2-18: Connectivity of a Volume

Important to Know

Root Level—Volume

Level 1—SAN Volume from the SAN Array.

Level 2—SAN based disk.

Viewing Disks Utilized by a Volume

To view disks (local or remote SAN disks) utilized by the volume, perform the following 

steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.

3 From the Views pane, select Inventory ➤  Storage ➤ Volumes.

4 In the content pane, select a volume.
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5 From the View drop-down list, select Disks to display the Disks pane. This pane lists 

the disks that are consumed by the volume.

Figure 2-19: Disks Consumed by a Volume

Important to Know

Name—The name of the disk.

Manufacturer—The manufacturer of the disk.

Model—The model number of the disk.

Device—The device that contains the disk.

Capacity—The capacity of the disk.

Status—The status of the disk, such as OK, Online, Disabled, Not Ready, Error, or 

READONLY.

Spare—Indicates whether the disk is used as a spare (Yes) or is not used as a spare 

(No).

Viewing Local Disks or DAS Attached to a Server

To view local disks or DAS attached to a managed server, perform the following steps:
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1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.

3 From the Views pane, select Inventory ➤  Storage ➤ Disks.

Figure 2-20: Local Disks Attached to a Server

Important to Know

Name—The name of the disk.

Manufacturer—The manufacturer of the disk.

Model—The model number of the disk.

Device—The device that contains the disk.

Capacity—The capacity of the disk.

Status—The status of the disk, such as OK, Online, Disabled, Not Ready, Error, or 

READONLY. 

Spare—Indicates whether the disk is used as a spare (Yes) or is not used as a spare 

(No).
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Viewing Disk Properties

To view the properties of a selected disk, perform the following steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.

3 From the Views pane, select Inventory and then select Storage ➤ Disks.

4 Select a disk to display the Properties pane.

Figure 2-21: Disk Properties

Important to Know

Name—The name of the disk.

Manufacturer—The manufacturer of the disk.

Model—The model number of the disk.

Device—The device that contains the disk.

Capacity—The total capacity of the disk.

Status—The status of the disk, such as OK, Online, Disabled, Not Ready, Error, or 

READONLY. 
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Spare—Indicates whether the disk is used as a spare (Yes) or is not used as a spare 

(No).

Viewing Volumes Created on a Disk

To view volumes created on a selected disk, perform the following steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.

3 From the Views pane, select Inventory ➤  Storage ➤ Disks.

4 Select a disk and then select Volumes from the View drop-down list to display the 

Volumes pane.

Figure 2-22: Volumes Created on a Disk

Important to Know

Name—The name of the volume.
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Type—The type of the volume. Root volumes are extents created on the local disk. 

LUN are the extents created on the remote SAN based LUN disks. VOLUME 

MANAGER are the storage extents created using server based storage virtualization 

software.

Service Type—The type of service, such as LUN, which represents MPIO configured 

on SAN based volumes.

Status—The status of the disk, such as OK, Online, Disabled, Not Ready, Error, or 

READONLY.

Capacity—The total capacity of the volume.

Paths—The total number of paths that this volume can be accessed through, such as 

0, 1, 2, and so on. A hyphen (-) means that HP is unable to determine this 

information.

Viewing File Systems Created on a Disk

To view volumes created on a selected disk, perform the following steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.

3 From the Views pane, select Inventory and then select Storage ➤ Disks.
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4 Select a disk and then select File Systems from the View drop-down list to display 

the File Systems pane.

Figure 2-23: File Systems Created on a Disk

Important to Know

Mount—The mount point of the file system.

Type—The file system type, such as ext2, ext3, hfs, nfs, ntfs, ufs, vxfs, and so on.

Capacity—The total capacity of the file system.

Free Space—The unused capacity of the file system.

Viewing Volume Manager and MPIO

To view file systems created on a selected disk, perform the following steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.
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3 From the Views pane, select Inventory and then select Storage ➤ Manager 
Software.

Figure 2-24: Volume Manager and MPIO

Important to Know

Name—The name of the manager software.

Vendor—The vendor of the manager software.

Version—The version of the manger software.

Viewing Volumes Available Through Manager Software

To view volumes that are available through manager software, perform the following 

steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.

3 From the Views pane, select Inventory and then select Storage ➤ Manager 
Software.
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4 Select a Manager Software.

Figure 2-25: Volumes Output to Volume Manager

Important to Know

Name—The name of the volume.

Type—The type of storage.

Service Type—The type of service, such as LUN, which represents MPIO configured 

on SAN based volumes.

Status—The status of the disk, such as OK, Online, Disabled, Not Ready, Error, or 

READONLY.

Capacity—The total capacity of the volume.

Paths—Indicates whether a remote volume is attached to an antecedent multipath 

service (Yes) or is not attached (No). Yes includes the number of paths. A dash (-) in 

this column means unknown.

Viewing Unmounted Volumes

To view SAN based volumes that are accessible to the managed server but are not 

mounted, perform the following steps:
0



Chapter 2: Asset Discovery
1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.

3 From the Views pane, select Inventory and then select Storage ➤ Unmounted 
Volumes.

4 (Optional) Select a unmounted volume and then select Actions ➤  Open with ➤  

Remote Terminal to open the remote device that this (remote) unmounted volume 

resides on.

Figure 2-26: Unmounted Volumes

Important to Know

Name—The name of the volume.

Type—JBOD, RAID3, RAID5, RAID5PLUS1, RAIDS_3_PLUS_1, RDF_R1_RAID_S, 

SPARE, BCV, BCV_RDF_R1, VDEV, BCV_RDF_R1_RAID5_7_PLUS_1, SIMPLE, 

CONCATENATED, STRIPED, MIRRORED, and so on.

Service Type—The type of volume service, such as LUN, which represents MPIO 

configured on SAN based volumes.
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Status—The status of the volume, such as OK, Online, Disabled, Not Ready, Error, or 

READONLY.

Capacity—The total capacity of the volume.

Target Device—The device this volume resides on (remotely).

Viewing Unmounted Volume Properties

To view properties of unmounted volumes, perform the following steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.

3 From the Views pane, select Inventory and then select Storage ➤ Unmounted 
Volumes.

4 Select a volume and then select Properties from the View drop-down list.

Figure 2-27: SAN Based Volume Properties

Important to Know

Name—The name of the volume.
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Type—JBOD, RAID3, RAID5, RAID5PLUS1, RAIDS_3_PLUS_1, RDF_R1_RAID_S, 

SPARE, BCV, BCV_RDF_R1, VDEV, BCV_RDF_R1_RAID5_7_PLUS_1, SIMPLE, 

CONCATENATED, STRIPED, MIRRORED, and so on.

Service Type—The storage service type of the unmounted volume, such as LUN, 

which represents MPIO configured on SAN based volumes.

Status—The status of the disk, such as OK, Online, Disabled, Not Ready, Error, or 

READONLY.

Capacity—The total capacity of the volume.

Target Device—The device that hosts this unmounted volume, such as a SAN Array.

Viewing Antecedent of Aggregate Storage Supply Chain

To view the antecedent of the aggregate storage supply chain, perform the following 

steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.

3 From the Views pane, select Inventory and then select Storage ➤ Unmounted 
Volumes.

4 Select a volume and then select Composition from the View drop-down list.
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5 (Optional) From the Composition pane, select an antecedent or dependent and then 

open its corresponding SAN Array Browser.

Figure 2-28: Antecedent of Aggregate Storage Supply Chain

Important to Know

Name—The name of the antecedent or dependent storage resource.

Type—The type of storage resource, such as DATAFILE, PHYSICALDISK, 

STORAGEVOLUME, or TABLESPACE.

Device/Database—The device or database that owns the storage resource.

Relation—The location in the storage supply chain, such as Downstream or 

Upstream.

Viewing Remote SAN Based Disks

To view remote SAN based disks, perform the following steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.

3 From the Views pane, select Inventory ➤  Storage ➤ Unmounted Volumes.
4



Chapter 2: Asset Discovery
4 In the content pane, select a volume.

5 From the View drop-down list, select Disks to display the Disks pane. This pane 

displays information about disks that are consumed by unmounted volumes.

6 (Optional) If the volume is LUN based, select then open it to display its 

corresponding SAN Array Browser

Figure 2-29: Remote SAN Based Disks

Important to Know

Name—The name of the disk.

Manufacturer—The manufacturer of the disk.

Model—The model number of the disk.

Device—The device that contains the disk.

Capacity—The capacity of the disk.

Status—The status of the disk, such as OK, Online, Disabled, Not Ready, Error, or 

READONLY.

Spare—Indicates whether the disk is used as a spare (Yes) or is not used as a spare 

(No).
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Viewing Storage Targets

To view storage targets (SAN Array or NAS Filer (Block)), perform the following steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.

3 From the Views pane, select Relationships and then select Storage Targets.

Figure 2-30: Storage Targets

Important to Know

Name—The name of the target device.

Type—The type of the target device, such as a SAN Array or NAS Filer.

Customer—The customer assigned to the target device.

Facility—The facility of the target device.

Viewing Access Paths to Storage Targets

To view access paths to storage targets, perform the following steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.
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2 In the content pane, select a server and then open it.

3 From the Views pane, select Relationships ➤  Storage Targets.

4 Select a target to display the access paths.

5 (Optional) Select an access path and then select one of the following options from 

the Actions menu:

• Open Target—Displays the SAN Array Browser or the NAS Filer Browser, 

depending on the AAA permission.

• Open Target Port—Displays the SAN Array Ports Browser or the NAS Filer Ports 

Browser, depending on the AAA permission.

• Open Target Volume—Displays the SAN Array Volume Browser or the NAS Filer 

Volume Browser, depending on the AAA permission.

Figure 2-31: Access Paths to Storage Targets

Important to Know

Volume—The host volumes.

LUN—The LUN ID.
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Target—A SAN array.

Target Port—A port on the SAN array.

Target Volume—A logical volume that the SAN array presents through the target 

port.

Viewing Switches Attached to a Server

To view switches attached to a managed server, perform the following steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.

3 From the Views pane, select Relationships ➤  SAN Switches.

4 (Optional) Select a switch and then open it to display its SAN Switch Browser.

Figure 2-32: Switches Attached to a Server

Important to Know

Name—The name of the switch.

Manufacturer—The manufacturer of the switch.
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Model—The model of the switch.

Firmware Version—The version of the software that is running on the SAN switch.

Model—The model number of the SAN switch.

IP Address—The primary address of the SAN switch.

Customer—The customer assigned to the SAN switch.

Facility—The facility of the SAN switch

Status—The status of the SAN switch at the time of the snapshot by the Storage 

Agent.

Description—A description of the SAN switch.

# of Ports—The number of ports on the SAN switch.

Opsware ID—The internal HP identification associated with the SAN switch in a core. 

The primary key associated with the SAN array in the Model Repository.

Virtual—Indicates whether the SAN switch is virtual or not.

Viewing Fabrics Attached to a Server

To view fabrics attached to a server, perform the following steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.

3 From the Views pane, select Relationships and then select SAN Fabrics.
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4 (Optional) Select a switch and then open it to display its SAN Fabric Browser.

Figure 2-33: Fabrics Attached to a Server

Important to Know

Name—The name of the fabric.

Description—A description of the fabric.

Viewing FCA Ports Attached to a Fabric

To view FCA ports attached to a fabric, perform the following steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.

3 From the Views pane, select Relationships and then select SAN Fabrics.

4 From the View drop-down list, select Ports.
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5 Select a port and then open it to display the Ports pane.

Figure 2-34: FCA Ports Attached to a Fabric

Important to Know

Name—The name of the server port that is attached to the fabric.

WWN—The World Wide Name of the FCA port.

Number—The port number of the switch port.

Controller—The controller of the FCA port.

Fabric—The fabric of the FCA port.

FCID—The Fibre Channel ID of the connected switch port.

State—The status of the port, such as Online, Offline, NoModule, and Unknown.

Viewing Zone Membership

To view zones where a managed server is a member of a certain fabric, perform the 

following steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.
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2 In the content pane, select a server and then open it.

3 From the Views pane, select Relationships and then select SAN Fabrics.

4 From the View drop-down list, select Zones.

5 (Optional) Select a zone and then select one of the following options from the 

Actions menu:

• Open Zone—Displays the SAN Fabric Browser that identifies port members.

• Open ZoneSet—Displays the SAN Fabric Browser.

Figure 2-35: Zone Membership

Important to Know

Name—The name of the zone.

Zone Set—The name of the zone set the zone is a member of.

Active—If the zone set is active, this value is Yes. A dash (-) means that the zone set 

is not active. More than one zone set can be configured in the same fabric and the 

fabric uses zones from the active set at any particular time. Selecting another 
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zoneset to be active modifies fabric security—the fabric controls access to the data 

using zones from a new zone set. Access to data is defined in zones and zones are 

grouped in zonesets.

Viewing Databases Hosted by a Server

To view databases that a selected server hosts, perform the following steps:

1 From the Navigation pane, select Servers ➤ All Managed Servers.

2 In the content pane, select a server and then open it.

3 From the Views pane, select Relationships and then select Databases.

4 (Optional) Select a database and then open it to display the Database Browser. You 

must have Read permissions on the server that is hosting the database.

Figure 2-36: Databases Hosted by a Server

Important to Know

Name—The name of the database.

Manufacturer—The manufacturer of the database software.

Version—The version of the database.
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Server—The IP address of the server that is hosting the database.

Status—The status of the target device.

SAN Array Assets 

This feature provides visibility into various storage array configurations that are attached to 

a SAN. This excludes SAN array devices that are directly attached to servers. ASAS 

captures generic SAN array assets as well as vendor-specific assets.

Vendor-specific discovery of SAN array assets is enabled by the following Storage 

Agents:

• Symmetrix Storage Agent

• CLARiiON Storage Agent

• HiCommand Storage Agent

For information about installing and configuring these Storage Agents, see the ASAS 

Installation & Administration Guide.

Using this feature, a storage administrator can view the following:

• SAN array storage utilization and configuration

• SAN Array security configuration

• Storage resources shared between applications or hosts

ASAS captures the following generic SAN array assets:

SAN Array (Storage Systems) —SAN array configuration information. ASAS uses an 

IP-based network based mechanism to access the device or device interface, such as 

API, CLI, and so on. ASAS discovers the Manufacturer, Model, Serial Number, Firmware 

Version, Serial Number, and Storage Capacity for a SAN Array.

Disk Controllers—Disk controllers are discovered only for EMC Symmetrix arrays. 

However, the ASAS user interface does not display the association or relationship 

between a disk controller and a disk for any disk controller.

Disks —Disk storage capacity. ASAS discovers the Free Capacity, Firmware, Label, 

Location, Manufacturer, Model, Serial Number, and whether a disk is a spare.

Storage Volumes —Storage volumes that are carved out of disks. ASAS discovers 

the Storage Capacity, Block Size (if available), Storage Type, and Volume ID. Meta 
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volumes (devices) are composite volumes that are created using two or more regular 

storage volumes.

Composite Volumes—Some SAN arrays support composite volumes, such as Meta 

Volumes in EMC and LUSE in Hitachi. 

Meta devices allow individual devices to be concatenated to create larger devices. A meta 

device consists of a meta head and its member devices.

Port Controllers—The port controller and a list of fabric ports in the controller.

Fabric Ports—SAN array fabric ports are used to provide FC connectivity between SAN 

array and fibre switch (standalone or part of a fabric). ASAS does not capture internal 

fabric ports in the system. ASAS discovers the Port Number, State (Offline, Online), LUN 

Security Mode (applicable to Hitachi), Host Mode (applicable to Hitachi), and the World 

Wide Name.

Storage Pools —Some SAN arrays support grouping volumes together, based on 

common characteristics. For example, for a Hitachi SAN array, groups of storage volumes 

are grouped together in an entity called Array Groups. Not all SAN arrays support storage 

pool concepts. For SAN arrays that do support pool concepts, ASAS captures the storage 

type and storage capacity. For supported SAN arrays, ASAS captures the free extents in 

the pool. If the storage pool is not supported by the device, HP creates the storage pool 

for the storage volumes, based on the storage type.

Initiator Groups—Initiator groups are discovered but are not displayed in the ASAS user 

interface.

LUN Mapping—Lun Mapping information, such as Storage Volume, SAN Array Port, Lun 

ID, and Host FC Port/FCA information.

EMC Symmetrix Assets

ASAS uses the Symmetrix Solution Enabler SDK to capture the following Symmetrix data:

Gatekeeper Storage Pool—Pools of volumes that are designated as gatekeeper 

volumes. Gatekeeper volumes are bound to the server for EMC Symmetrix device 

interface. HP captures these volumes, including the Storage Type, Block Size, and Storage 

Capacity information.

VCM Devices and VCM Database—Information about LUN masking and defines which 

hosts can access LUNs on an EMC array. Symmetrix Device Masking, or VCM, devices 

are Symmetrix devices that have been masked for visibility to certain hosts. The device 
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masking database (VCMDB) holds device masking records and typically resides on a 

small disk device (such as a 16 cylinder, 8 MB device).

SFS Storage Pool—A Symmetrix File System is a collection of special volumes that are 

used by an EMC Symmetrix array.

Supported Storage Types—UNPROTECTED, MIRR_2, MIRR_3, MIRR_4, BCV, RAID_S, 

RAID_S_MIRR, RDF_R1, RDF_R2, RDF_R1_RAID_S, RDF_R2_RAID_S, RDF_R1_MIRR, 

RDF_R2_MIRR, SPARE, BCV_MIRR_2, BCV_RDF_R1, BCV_RDF_R1_MIRR, DRV, DRV_

MIRR_2, BCV_RDF_R2, BCV_RDF_R2_MIRR, VDEV, COVD, RAID5, RDF_R1_RAID_S, 

RDF_R2_RAID_S, RDF_R1_RAID_5, RDF_R2_RAID_5, BCV_RAID5, BCV_RDF_R1_RAID5, 

BCV_RDF_R2_RAID5

Hypers—Symmetrix hyper-volume storage capacity information.

Meta Volumes—An asset for EMC Symmetrix to be consistent.

SRDF/TimeFinder (Replication) —Local and remote properties specify whether the 

device belong to this array or another array. ASAS discovers device groups and composite 

groups configured for the SRDF/Timefinder Manager. ASAS also discovers the ports 

involved in SRDF replication. The Symmetrix Remote Data Facility (SRDF™) maintains a 

mirror image of Symmetrix array data at the device level, which can be located in 

physically separate sites. In an SRDF configuration, the individual Symmetrix devices are 

designated as either a source (R1) or a target (R2) to synchronize and coordinate SRDF 

activity. If the source (R1) device fails, the data on its corresponding target (R2) device 

can be accessed by the local host. After the source (R1) device is replaced, it can be 

resynchronized. SRDF configurations have at least one source (R1) device mirrored to one 

target (R2) device. For concurrent SRDF systems, there can be two R2 targets. A source 

(R1) device can only belong to an RDF1 device group, while a target (R2) device can only 

belong to an RDF2 device group.

EMC CLARiiON Assets

ASAS uses Navisphere Command Line Interface (CLI) to capture the following EMC 

CLARiiON storage data:

Meta Volumes—Composite volumes that are created using two or more regular storage 

volumes.

Supported Storage Types—UNBOUND, RAID5, RAID3, RAID1, RAID0, RAID0PLUS1, 

DISK, SPARE
6
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Hitachi Assets

ASAS uses the HiCommand Device Manager XML interface to capture the following 

Hitachi storage data:

LUSE Volumes—Composite volumes that are created using two or more regular storage 

volumes.

Supported Storage Types—RAID1, RAID5, RAID6, RAID0, RAID0+1

SAN Array Assets and Relationships

ASAS captures relationships between SAN array elements and other storage asset 

discovery features. See Table 2-6.

Frequently Asked Questions

Table 2-7 answers some frequently asked questions on finding information about SAN 

arrays.

Table 2-6: SAN Arrays Assets and Relationships

SAN ARRAY 
ASSET

EXTERNAL ELEMENT DESCRIPTION

Connected fabric 

port

Ports connectivity Provides the point-to-point links 

through a fabric.

Connected device Fabric zone/alias context Captures devices attached to the 

ports that are members of a zone or 

alias.

LUN mapping and 

masking (access 

paths)

LUN volumes in a server Provides storage supply chain data 

based on Block I/O between server 

and SAN array storage volumes. 

MultiPath paths to storage volumes 

are also discovered with these 

relationships.

Table 2-7: Frequently Asked Questions About SAN Array Assets

QUESTION HOW TO FIND THE ANSWER

1. What storage is available in a SAN array in a 

datacenter?

• “Viewing Storage Summary for a SAN 

Array” on page 122
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2. What LUNs are bound to the servers? • “Viewing Storage Initiators Consuming 

Storage Resources from an Array” on 

page 107

• “Viewing Initiator Volumes and Ports” on 

page 108

• “Viewing Storage Volumes with Access 

Paths for Remote Initiators” on page 109

• “Viewing Volumes Served by a SAN Array 

Port” on page 119

3. Are critical applications configured for high avail-

ability, such as multiple access paths)? What 

are the redundant paths between a server and a 

SAN array for an application?

• “Viewing Storage Volumes with Access 

Paths for Remote Initiators” on page 109

4. What is the storage utilization of the SAN array? • “Viewing Storage Summary for a SAN 

Array” on page 122

5. Are the critical applications backed up? • “Viewing Storage Volumes with Access 

Paths for Remote Initiators” on page 109

• “Viewing Replicated Storage Devices” on 

page 140

6. Do the SAN arrays provide room for growth? • “Viewing Storage Summary for a SAN 

Array” on page 122

7. When will the SAN arrays run out of space? • “Viewing Storage Summary for a SAN 

Array” on page 122

8. What is causing application performance 

degradation? How is all of the SAN configuration 

impacting the application? What are the shared 

resource between applications?

• “Viewing Storage Volumes with Access 

Paths for Remote Initiators” on page 109

• “Viewing Volumes of a Disk” on page 125

• “Viewing the Access Path from the Disk” on 

page 126

• “Viewing the Access Path from the Volume” 

on page 134

Table 2-7: Frequently Asked Questions About SAN Array Assets (continued)

QUESTION HOW TO FIND THE ANSWER
8
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Viewing SAN Arrays

To view a list of SAN arrays with their hardware and status, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 Select a SAN array to view the Summary in the content pane. The content pane 

displays information about the SAN array hardware and status.

9. Why is a LUN volume not visible to the server? 

Does the configuration need to be modified?

• “Viewing Storage Volumes with Access 

Paths for Remote Initiators” on page 109

• “Viewing Attached Fabrics in an Array” on 

page 110

• “Viewing Zones Configured for an Array” on 

page 112

• “Viewing SAN Switches Attached to the 

Array” on page 114

• “Viewing Volumes Served by a SAN Array 

Port” on page 119

Table 2-7: Frequently Asked Questions About SAN Array Assets (continued)

QUESTION HOW TO FIND THE ANSWER
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Figure 2-37: Information for SAN Arrays

Important to Know

Name—The name of the array as assigned by the Storage Agent. The name will be a 

serial number for EMC Symmetrix and DMX, Model with IP Address of the array for 

Hitachi, Model for Engenio and a combination of Manufacturer, Model and Serial 

Number for CLARiiOn. The name can be edited if the user has permission.

Manufacturer—The manufacturer of the SAN array.

Model—The model number of the array.

Serial Number—The serial number of the SAN array.

Firmware Version—The firmware version of the SAN array.

IP Address—The IP address of the array.

Customer—The customer associated with the SAN array.

Facility—The facility associated with the SAN array.

Status—The status of the managed element.

Description—The description about the SAN array, usually the vendor information.
0
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Discovered On—The discovery date of the SAN array.

Synchronized Date—The synchronization date of the last message from the Storage 

Agent associated with the managed element.

Synchronization Status—The synchronization (FullSync or DeltaSync) status can be 

Incomplete or Success.

Opsware ID—The primary key associated with the SAN array in the Model 

Repository.

Viewing SAN Arrays and Storage Configurations

To view the SAN array and storage configurations, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array. The content pane displays information about 

the SAN array hardware and status.

3 (Optional) Select a target and then select one of the following options from the 

Actions menu:

• Open—Displays the SAN array details in a separate window, depending on the 

AAA permission.

• Open With HP Service Automation Visualizer—Opens the target with Service 

Automation Visualizer (SAV) and displays the storage map.

• Rename—Displays an editable field to rename the SAN array directly in the table, 

depending on the AAA permission.
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• Delete—Removes the SAN array from the Model Repository.

Figure 2-38: Summary Information for a SAN Array Configuration 

Important to Know

System—The name, number of installed drives, and the maximum capacity.

Opsware Registration—The status, date, and time of discovery by the Storage 

Agent.

Viewing Summary of a SAN Array

To view a SAN array summary, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array.

3 From the View drop-down list, select Summary.

4 In the content pane, select a SAN array and then open it to display the summary.
2
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Figure 2-39: SAN Array Summary

Viewing SAN Array Properties

To view properties for a SAN array, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array.

3 From the View drop-down list, select Properties. The content pane displays properties 

of the SAN array.

4 (Optional) Select a target and then select one of the following options from the 

Actions menu:

• Open—Displays the SAN array, depending on the AAA permission.

• Open With HP Service Automation Visualizer—Opens the target with Service 

Automation Visualizer (SAV) and displays the storage map.

• Rename—Renames the target. Changes are saved in the system.

• Delete—Removes the SAN array from the Model Repository.
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Figure 2-40: SAN Array Properties

Important to Know

Name—The name of the SAN array.

Description—The manufacturer, model and serial number.

IP Address—The IP address of the SAN array.

Customer—The customer associated with the SAN array.

Facility—The facility associated with the SAN array.

Synchronization Status—The synchronization status of the SAN array that indicates 

whether data received from the Storage Agent was successfully stored in the Model 

Repository.

Managed Server—The location of the SAN array's Storage Agent.

Opsware ID—The primary key associated with the SAN array in the Model 

Repository.

Status—The status of the SAN array.
4
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Viewing Customers for a SAN Array

To view customers for a SAN array, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array.

3 From the View drop-down list select Properties.

4 From the Actions menu, select Open, or right-click and then select Open. The 

Properties window displays.

5 Click the Change link to open the Select Customer window.

6 Select a customer and then click Select.

Figure 2-41: Customers for a SAN Array

Important to Know

• Customer—Customers that exist in the Model Repository.

• Select Customer—Select only one customer.

Viewing the SAN Array History Log

To view the history log for a SAN array, perform the following steps:
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1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array.

3 In the View drop-down list, select History. The content pane displays the history log 

for the SAN array.

4 In the content pane, select an event from the history log and then select the following 

option from the Actions menu:

• View Event Details—Displays detailed information about the event.

Or

• Right-click on the event and select View Event Details.

Figure 2-42: History Log

Important to Know

• Date—The date of the event.

• Event—A description of the event.

• User—The name of the user who performed the event.

• Status—The current status.
6



Chapter 2: Asset Discovery
Viewing Storage Initiators Consuming Storage Resources from an Array

To view storage initiators consuming resources from an array, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array.

3 In the View drop-down list, select Storage Initiators. The content pane displays a list 

of storage initiators.

4 (Optional) In the lower content pane, select a storage initiator and then select the 

following option from the Actions menu:

• Open Device—Opens the Server Browser.

Or

Right-click on the target and select Open Device.

Figure 2-43: Storage Initiators

Important to Know

Name—The name of the Storage Initiator.
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Viewing Initiator Volumes and Ports

To view initiator volumes and ports in a SAN array, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array.

3 In the View drop-down list, select Storage Initiators.

4 Double-click on a SAN Array. The SAN Array browser displays.

5 In the SAN Array browser, select a storage initiator. The content pane displays a list of 

initiator volumes and ports.

6 (Optional) In the lower content pane, select a target and then select the following 

option from the Actions menu:

• Open Device—Opens the Server Browser for the selected server.

• Open Initiator Port—Displays the hardware information for the selected server.

• Open Initiator Volume—Displays the storage information for the selected server.

Figure 2-44: Initiator Volumes and Ports in a SAN Array 
8
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Important to Know

Volume —The storage volume caption.

LUN—The LUN ID of the mapping.

Target Port—The SAN array port through which the volume was mapped to the 

initiator port.

Initiator Device—The name of the managed server to which storage is mapped from 

the SAN Array.

Initiator Port—A port from the managed server (Initiator Device).

Initiator Volume—The volume that is hosted by the servers. This is not specified ("-") 

if the Storage Host Agent Extension (SHA) is not installed, if you have not mounted 

the storage, or if the volume is unknown to HP.

Viewing Storage Volumes with Access Paths for Remote Initiators

To view storage volumes with access paths for remote initiators not managed by HP, 

perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array.

3 In the View drop-down list, select Storage Initiators. The content pane displays a list 

of initiator volumes and ports.

4 In the lower content pane, select a storage initiator.

5 Right-click on the selected SAN array and then select Open. The content pane 

displays a list of storage volumes.
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Figure 2-45: Storage Volumes in a SAN Array 

Important to Know

Volume —Displays the storage volume caption.

LUN—Displays the LUN ID of the mapping.

Target Port—Displays the target port used for the mapping.

Initiator Device—The name of the managed server to which storage is mapped from 

the SAN Array.

Initiator Port—A port from the managed server (Initiator Device).

Initiator Volume—The volume that is hosted by the servers. This is not specified ("-") 

if the Storage Host Agent Extension (SHA) is not installed, if you have not mounted 

the storage, or if the volume is unknown to HP.

Viewing Attached Fabrics in an Array

To view attached fabrics in a SAN array, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array.
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3 In the View drop-down list, select SAN Fabrics. The content pane displays 

information about attached fabrics.

4 (Optional) Select a target and then select the following option from the Actions 

menu:

• Open Fabric—Opens the browser for the selected fabric.

Figure 2-46: Attached Fabrics in a SAN Array 

Important to Know

Name —The name of the fabric attached to this storage device.

Description—The description of the fabric.

Viewing Fabric Ports and Connectivity in an Array

To view array ports and their connectivity to the selected fabric, perform the following 

steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array and then open it.

3 In the View drop-down list, select SAN Fabrics.

4 In the content pane, select a SAN fabric.
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5 In the View drop-down list, select Ports. The content pane displays information about 

array ports.

Figure 2-47: Array Ports in a SAN Array 

Important to Know

Name—The name of the storage array port.

WWN—The World Wide Name of the storage array port.

Number—The port number of the storage array port.

Controller—The name of the port controller.

Fabric—The fabric that is connected to the port.

FCID—The Fibre Channel ID of the storage system port.

State—The state of the Storage System port.

Viewing Zones Configured for an Array 

To view zones configured for an array in a selected fabric, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.
2



Chapter 2: Asset Discovery
2 In the content pane, select a SAN array.

3 In the View drop-down list, select SAN Fabrics.

4 In the content pane, open a SAN array.

5 In the SAN Array browser, select a Fabric.

6 In the View drop-down list, select Zones. The content pane displays the information 

for zone sets.

7 In the lower content pane, right-click on a zone set and then select Open Zone. A list 

of zones will be displayed.

8 (Optional) In the Views pane, you can toggle between views: Zone Sets, Zones, and 

Alias.

9 (Optional) Select a target and then select the following option from the Actions 

menu:

• Open Zone—Opens the SAN Fabrics Zone view.

• Open Zoneset—Opens the SAN Fabrics ZoneSet view

Figure 2-48: Zones Configured for an Array
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Important to Know

Name —The name of the zone.

ZoneSet—The name of the ZoneSet. A “-” in this column indicates that this value is 

unknown.

Active—If the zone set is active, this value is Yes. A dash (-) means that the zone set 

is not active. More than one zoneset can be configured in the same fabric and the 

fabric uses zones from the active set at any particular time. Selecting another 

zoneset to be active modifies fabric security—the fabric controls access to the data 

using zones from a new zone set. Access to data is defined in zones and zones are 

grouped in zonesets.

Viewing SAN Switches Attached to the Array

To view SAN switches attached to the array, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array.

3 In the View drop-down list, select SAN Switches. The content pane displays the 

information for SAN switches.

4 (Optional) Select a switch and then select the following option from the Actions 

menu:

• Open Device—Opens the SAN Switch Summary.
4
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Figure 2-49: SAN Switches Attached to the Array

Important to Know

Name —The name of the SAN switch.

Manufacturer—The manufacturer of the SAN switch.

Model—The model of the SAN switch.

Firmware Version—The firmware version of the SAN switch.

Customer—The customer assigned to the SAN switch.

Facility—The facility assigned to the SAN switch.

Status—The status of the SAN switch.

Description—The description of the SAN switch.

Pool —The name of the storage pool that the volume belongs to.

Virtual—Indicates whether the SAN switch is virtual.

Viewing Hardware Information for the Array

To view the hardware information for the SAN array, perform the following steps:
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1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array.

3 In the View drop-down list, select Hardware. The content pane displays the hardware 

information.

Figure 2-50: Hardware Information

Important to Know—General Sub-panel

Manufacturer —The manufacturer of the SAN array.

Model—The model of the SAN array.

Serial Number—The serial number of the SAN array.

Firmware Version—The firmware version of the SAN array.

Storage Capacity—The total storage capacity of the SAN array.

Important to Know—Controllers Sub-panel

Controller Number—The port number of the fabric port—the number within the 

controller.

Name —The name of the controller.
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Manufacturer —The manufacturer of the controller.

Model—The model of the controller.

Serial—The serial number of the controller.

Firmware—The firmware version of the controller.

Viewing Front End Fabric Ports

To view front end fibre ports, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array.

3 In the View drop-down list, select Ports. The content pane displays the port 

information.

Figure 2-51: Port Information

Important to Know

Name—The name of the SAN array fibre port.

WWN—The World Wide Name of the SAN array fibre port.
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Number—The port number of the SAN array fibre port.

Controller—The controller that the SAN array fibre port is attached to.

Fabric—The name of fabric that is connected to the SAN array fibre port.

FCID—The Fibre Channel ID of the SAN array fibre port.

State—The status of the SAN array fibre port.

Viewing Properties of the Fabric Port in an Array

To view the properties of the fibre port, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array.

3 In the View drop-down list, select Ports.

4 In the lower content pane, highlight a port to select it.

5 In the upper content pane, open a SAN array. The content pane displays the 

properties of the fibre port.

Figure 2-52: Fabric Port Properties
8
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Important to Know

FCID—The Fibre Channel ID of the SAN array fibre port.

WWN—The World Wide Name of the SAN array fibre port.

Number—The port number of the SAN array fibre port.

Controller—The controller that the SAN array fibre port is attached to.

Fabric—The name of the fabric that this port is attached to.

Connected To—The name of the switch and the port this is connected to. if 

connected, a hyperlink to the Switch Browser is provided.

Status—The status of the SAN port

Viewing Volumes Served by a SAN Array Port

To view volumes served by a SAN array port, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array.

3 In the View drop-down list, select Ports.

4 In the content pane, open a SAN array.

5 In the SAN array browser, highlight a port to select it.

6 In the View drop-down list, select Volumes. The content pane displays a list of 

volumes.

7 (Optional) Select a target and then select the following option from the Actions 

menu:

• Open Device—Opens the Server Browser for the selected server.

• Open Initiator Port—Displays the hardware information for the selected server.

• Open Initiator Volume—Displays the storage information for the selected server.
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Figure 2-53: Volumes Served by a SAN Array Port

Important to Know

Volume —Displays the storage volume caption.

LUN—Displays the LUN ID of the mapping.

Target Port—The SAN array port through which the volume was mapped to the 

initiator port.

Initiator Device—The name of the managed server to which storage is mapped from 

the SAN Array.

Initiator Port—A port from the managed server (Initiator Device).

Initiator Volume—The volume that is hosted by the servers. This is not specified ("-") 

if the Storage Host Agent Extension (SHA) is not installed, if you have not mounted 

the storage, or if the volume is unknown to HP.

Viewing Zones Configured for an Array Port

To view zones configured for an array port, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.
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2 In the content pane, select a SAN array.

3 In the View drop-down list, select SAN Fabrics.

4 In the content pane, open a SAN array.

5 In the SAN Array browser, highlight a SAN Fabric.

6 From the View drop-down list, select Ports. The content pane displays the properties 

of the fibre port.

7 In the lower content pane, highlight the port to select it.

8 In the View drop-down list, select Zones. A list of zones will display.

9 Double-click a zone. The content pane displays a list of zones.

10 (Optional) Select a target and then select the following option from the Actions 

menu:

• Open Zone—Opens SAN Fabrics Zone view.

• Open ZoneSet—Opens SAN Fabrics ZoneSet view.

Figure 2-54: Zones Configured for an Array Port
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Important to Know

Name —The name of the zone.

ZoneSet—The name of the zoneset. The column value can be empty (-).

Active—Indicates if the zone is active.

Viewing Storage Summary for a SAN Array

To view the summary of storage information offered by a SAN Array, perform the following 

steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array and then open it.

3 From the View drop-down list, select Storage and then select the SAN array. The 

content pane displays summary information.

Figure 2-55: Summary of SAN Array Storage 

Important to Know

Disks—The total number of disks.

Disk Capacity—The total raw capacity of all disks for the SAN array.
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Volumes—The total number of volumes.

Volume Capacity—The capacity of the volumes in the storage array.

Allocated Volumes—The number of LUN mapped volumes.

Allocated Capacity—The total capacity of the volumes that are mapped to the 

initiator.

Unallocated Volumes—The total number of unmapped volumes.

Unallocated Capacity—The total capacity in the array not offered to any initiator.

Viewing Disks in an Array

To view disks in an array, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array and then open it.

3 From the Views pane, select Inventory ➤  Storage ➤ Disks. The content pane 

displays a list of disks.

Figure 2-56: Disks in an Array
123



User’s Guide

12
Important to Know

Name —The name of the disk.

Manufacturer —The manufacturer of the disk.

Model—The model number of the disk.

Device—The device that contains this disk.

Capacity—The capacity of the disk.

Status—The status of the disk.

Spare—Yes, if the disk is a spare.

Viewing Disk Properties

To view the detail properties of the selected disk, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array and then open it.

3 From the Views pane, select Inventory ➤  Storage ➤ Disks.

4 In the content pane, click on a Disk. The content pane displays the properties.

Figure 2-57: Disk Properties 
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Important to Know

Name —The name of the disk.

Description —The description of the disk.

Manufacturer —The manufacturer of the disk.

Model—The model number of the disk.

Capacity—The capacity of the disk.

Status—The status of the disk.

Spare—Yes, if the disk is a spare.

Viewing Volumes of a Disk

To view volumes of a selected disk, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array and then open it.

3 From the Views pane, select Inventory ➤  Storage ➤ Disks.

4 In the View drop-down list, select Volumes. The content pane displays the Volumes.

Figure 2-58: Volumes of a Disk
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6

Important to Know

Name —The name of the volume.

Type —The storage type of the volume.

Pool —The name of the storage pool that the volume belongs to.

Status —The status of the disk.

Commitment—The commitment level of the volume. Values could be Reserved, LUN 

Mapped, LUN Mapped/Partitioned.

Capacity—The capacity of the volume.

Replication—Source indicates that the volume is the source for the replication pair. 

Target indicates that the volume is the target for the replication pair. Replication can 

also indicate both Source and Target. The status values for replication volumes 

include the following:

unitialized: If the volumes have a status of uninitialized, they are mapped to a 

sync state of Not Specified.

snapmirrored: If the volumes have a status of snapmirrored, they are mapped to a 

sync state of Synchronized.

broken-off: If the volumes have a status of broken-off, they are mapped to a sync 

state of Broken.

quiesced: If the volumes have a status of quiesced, they are mapped to a sync 

state of Quiesced.

source: If the volumes have a status of source, they are mapped to a sync state of 

Not Specified.

unknown: If the volumes have a status of unknown, they then are mapped to sync 

state of Not Specified.

normal: The snapshot volumes that have a status of normal are mapped to a sync 

state of Frozen. A status of normal only applies to snapshot volumes. A status of 

normal does not apply to replication volumes.

Viewing the Access Path from the Disk

To view the access path from the disk, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array and then open it.

3 From the Views pane, select Inventory ➤  Storage ➤ Disks.
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4 In the View drop-down list, select Access Path. The content pane displays the access 

path.

5 (Optional) Select a target and then select the following option from the Actions 

menu:

• Open Device—Opens the Server Browser for the selected server.

• Open Initiator Port—Displays the hardware information for the selected server.

• Open initiator Volume—Displays the storage information for the selected server.

Figure 2-59: Access Path from the Disk 

Important to Know

Volume —Displays the storage volume caption.

LUN—The LUN ID of the mapping.

Target Port—Displays the target port used for the mapping.

Initiator Device—The name of the managed server to which storage is mapped from 

the SAN Array.

Initiator Port—A port from the managed server (Initiator Device).
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Initiator Volume—The volume that is hosted by the servers. This is not specified ("-") 

if the Storage Host Agent Extension (SHA) is not installed, if you have not mounted 

the storage, or if the volume is unknown to HP.

Viewing Volumes in a SAN Array

To view volumes in a SAN Array, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array and then open it.

3 From the Views pane, select Inventory ➤  Storage ➤ Volumes. The content pane 

displays the volumes.

Figure 2-60: Volumes in a SAN Array 

Important to Know

Name —The name of the volume.

Type —The storage type of the volume.

Pool —The name of the storage pool that the volume belongs to.

Status —The volume health indicator.
8
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Commitment—The commitment level of the volume. Values could be Reserved, LUN 

Mapped, LUN Mapped/Partitioned.

Capacity—The capacity of the volume.

Replication—Source indicates that the volume is the source for the replication pair. 

Target indicates that the volume is the target for the replication pair. Replication can 

also indicate both Source and Target. The status values for replication volumes 

include the following:

unitialized: If the volumes have a status of uninitialized, they are mapped to a 

sync state of Not Specified.

snapmirrored: If the volumes have a status of snapmirrored, they are mapped to a 

sync state of Synchronized.

broken-off: If the volumes have a status of broken-off, they are mapped to a sync 

state of Broken.

quiesced: If the volumes have a status of quiesced, they are mapped to a sync 

state of Quiesced.

source: If the volumes have a status of source, they are mapped to a sync state of 

Not Specified.

unknown: If the volumes have a status of unknown, they then are mapped to sync 

state of Not Specified.

normal: The snapshot volumes that have a status of normal are mapped to a sync 

state of Frozen. A status of normal only applies to snapshot volumes. A status of 

normal does not apply to replication volumes.

Viewing Volume Properties

To view properties of a volume, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array and then open the SAN array.

3 From the Views pane, select Inventory ➤  Storage ➤ Volumes.

4 In the content pane, select a volume and then open it. The content pane displays the 

properties.
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Figure 2-61: Properties of a Volume

Important to Know

Name —The name of the volume.

Description —The description of the volume.

ID —The HP ID of the volume.

Type —The storage type of the volume.

Status —The status of the volume.

Capacity—The capacity of the volume.

Block Size—The block size of the volume.

Commit State—The commitment level of the volume. Values could be Reserved, 

LUN Mapped, LUN Mapped/Partitioned.

Replication Source—Yes, if source of the replication, else no.

Replication Target—Yes, if target of the replication, else no.
0
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Viewing the Connectivity of a Volume

To view the storage supply chain connectivity of a volume, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array and then open the SAN array.

3 From the Views pane, select Inventory ➤  Storage ➤ Volumes.

4 In the content pane, select a volume.

5 From the View drop-down list, select Connectivity. The content pane displays the 

connectivity of the volume.

Figure 2-62: Connectivity of a Volume

Important to Know

Root Node—The volume name with pool information.

Leaf —The disks that make up the volume.
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Viewing the Composition of a Volume

To view the antecedents and dependents of the volume storage supply chain, perform 

the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array and then open the SAN array.

3 From the Views pane, select Inventory ➤  Storage ➤ Volumes.

4 In the content pane, select a volume.

5 From the View drop-down list, select Composition. The content pane displays the 

composition of the volume.

6 (Optional) Select a target and then select the following option from the Actions 

menu:

• Open—Opens the SAN array or Server Storage view.

Figure 2-63: Composition of a Volume
2
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Important to Know

Name—The name of the antecedent and dependent of the volume storage supply 

chain.

Type —The type of the storage resource.

Device/Database —The device or the database that owns the storage resource.

Relation —Downstream or upstream depending on the location in the supply chain.

Viewing Disks Used to Create a Volume

To view disks used to create a volume, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array and then open the SAN array.

3 From the Views pane, select Inventory ➤  Storage ➤ Volumes.

4 In the content pane, select a volume.

5 From the View drop-down list, select Disks. The content pane displays a list of disks.

Figure 2-64: Disks Used to Create a Volume
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Important to Know

Name —The name of the disk.

Manufacturer —The manufacturer of the disk.

Model—The model number of the disk.

Device—The device that contains this disk.

Capacity—The capacity of the disk.

Status—The status of the disk.

Spare—Yes, if the disk is a spare, else No.

Viewing the Access Path from the Volume

To view the access path, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array and then open it.

3 From the Views pane, select Inventory ➤  Storage ➤ Volumes.

4 In the content pane, select a volume.

5 From the View drop-down list, select Access Path. The content pane displays the 

access path.

6 (Optional) Select a target and then select the following option from the Actions 

menu:

• Open Device—Opens the Server Browser for the selected server.

• Open Initiator Port—Displays the hardware information for the selected server.

• Open initiator Volume—Displays the storage information for the selected server.
4
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Figure 2-65: Access Path from the Volume

Important to Know

Volume —Displays the storage volume caption.

LUN—The LUN ID of the mapping.

Target Port—Displays the target port used for the mapping.

Initiator Device—The name of the managed server to which storage is mapped from 

the SAN Array.

Initiator Port—A port from the managed server (Initiator Device).

Initiator Volume—The volume that is hosted by the servers. This is not specified ("-") 

if the Storage Host Agent Extension (SHA) is not installed, if you have not mounted 

the storage, or if the volume is unknown to HP.

Viewing Array Ports from the Selected Volume

To view the array port that is part of the LUN mapping, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.
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2 In the content pane, select a SAN array and then open it.

3 From the Views pane, select Inventory ➤  Storage ➤ Volumes.

4 In the content pane, select a volume.

5 From the View drop-down list, select Ports. The content pane displays the ports.

6 (Optional) Select a target and then select the following option from the Actions 

menu:

• Open Port—Opens the SAN arrays view.

Figure 2-66: Array Ports That are Part of the LUN Mapping

Important to Know

Name—The name of the storage array port.

WWN—The World Wide Name of the storage array port.

Number—The port number of the storage array port.

Controller—The name of the port controller.

Fabric—The fabric that is connected.
6
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FCID—The Fibre Channel ID of the storage array port.

State—The status of the storage array port.

Viewing Storage Pools

To view storage pools configured in the storage system, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array and then open it.

3 From the Views pane, select Inventory ➤  Storage ➤ Pools. The content pane 

displays the list of storage pools.

Figure 2-67: Storage Pools

Important to Know

Name—The name of the storage pool.

Type—The storage type of the storage pool.

Capacity—The capacity of the pool.

Free Space—The free capacity of the storage pool, in bytes.
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Viewing Storage Pool Properties

To view the properties of a storage pool, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array and then open it.

3 From the Views pane, select Inventory ➤  Storage ➤ Pools.

4 In the content pane, select a storage pool. The content pane displays the properties.

Figure 2-68: Storage Pool Properties

Important to Know

Name—The name of the storage pool.

Description—The name and description of the storage pool.

Type—The storage type of the storage pool.

Capacity—The capacity of the pool.

Free Space—The free capacity of the storage pool, in bytes.
8
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Viewing Volumes for a Selected Pool

To view volumes for a selected pool, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array and then open it.

3 From the Views pane, select Inventory ➤  Storage ➤ Pools.

4 In the content pane, select a pool.

5 In the View drop-down list, select Volumes. The content pane displays the volumes.

Figure 2-69: Volumes for a Pool

Important to Know

Name—The name of the volume.

Type—The type of the volume, such as SIMPLE, MIRRORED, RAID0, RAID4, RAID5, 

RAID_DP, or UNDEFINED.

Pool—The name of the storage pool that the volume is created from.

Status—The status of the SAN pool at the time of the snapshot by the Storage 

Agent.
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Commitment—The commitment level of the volume. Values could be Reserved, LUN 

Mapped, LUN Mapped/Partitioned.

Capacity—The capacity of the volume.

Replication—Source indicates that the volume is the source for the replication pair. 

Target indicates that the volume is the target for the replication pair. Replication can 

also indicate both Source and Target. The status values for replication volumes 

include the following:

unitialized: If the volumes have a status of uninitialized, they are mapped to a 

sync state of Not Specified.

snapmirrored: If the volumes have a status of snapmirrored, they are mapped to a 

sync state of Synchronized.

broken-off: If the volumes have a status of broken-off, they are mapped to a sync 

state of Broken.

quiesced: If the volumes have a status of quiesced, they are mapped to a sync 

state of Quiesced.

source: If the volumes have a status of source, they are mapped to a sync state of 

Not Specified.

unknown: If the volumes have a status of unknown, they then are mapped to sync 

state of Not Specified.

normal: The snapshot volumes that have a status of normal are mapped to a sync 

state of Frozen. A status of normal only applies to snapshot volumes. A status of 

normal does not apply to replication volumes.

Viewing Replicated Storage Devices

To view replicated storage devices, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Arrays.

2 In the content pane, select a SAN array, and then open it.

3 From the Views pane, select Inventory ➤  Storage ➤ Replication. The content 

pane displays the storage devices.
0
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Figure 2-70: Replicated Storage Devices

Important to Know

Source Device—The source SAN array for the replication pair.

Source Volume—The source storage volume for the replication pair.

Target Device—The target SAN array for the replication pair.

Target Volume—The target storage volume for the replication pair.

Copy Type—The copy type of the replication pair, such as Async, Sync, 

UnSyncAssoc, UnSyncUnAssoc, or NotSpecified.

Replica Type—The replica type of the replication pair, such as FullCopy, BeforeDelta, 

AfterDelta, Log, or NotSpecified.

Status—The status of the replication pair, such as Initialized, PrepareInProgress, 

Prepared, ResyncInProgress, Synchronized, FractureInProgress, QuiesceInProgress, 

Quiesced, RestoreInProgress, Idle, Broken, Fractured, Frozen, CopyInProgress, Failed, 

CopyOnWrite, NotCreated, TerminationInProgress, CopyOnAccess, Invalid, 

SplitBeforeRestore, SplitBeforeSync, Restored, SplitNoIncremental, Mixed, 

Suspended, R1UpdInProgress, R1Updated, FailedOver, NotSpecified.
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Fabric Assets 

This feature provides visibility into fabric configurations in a SAN. Storage elements in a 

fabric include physical entities, such as fabric switches, ports, and security items, such as 

Zones and Zonesets.

With this feature, a fabric administrator can view the following:

• Physical fabric configuration

• Security configuration enabled in the fibre channel network

• Servers and SAN storage devices connected to the fibre channel network

• Storage resources shared between applications or managed servers

ASAS captures the following fabric information in a SAN:

Fibre Switch and Fabrics —Identifies whether a fibre switch is a principal switch or a 

subordinate switch of the fabric. After the principal switch is identified, ASAS gathers 

information on the connected fibre switches and end devices, such as servers, SAN-

based storage devices, and so on. ASAS lists the switch ports for all switches in the fabric. 

ASAS discovers the Manufacturer, Model, Serial Number, Firmware, Hardware Version, 

World Wide Name (WWN), Domain Name, IP, and the number of Ports for each of the 

switch. ASAS identifies a physical fabric by the WWN of the principal switch. If the role of 

a switch changes from subordinate to principal, the identity of the fabric changes—this 

change is discovered by ASAS. ASAS does not discover routing table information in each 

switch and does not support multiple vendor fabrics that are in an interop configuration. 

Switch Enclosure—Information about the switch enclosure includes blades and slots that 

make up that enclosure. This feature applies to director-class switches. ASAS discovers 

the Part Number, Serial Number, Manufacturer, and Model. 

Switch Blade—Blade information about the enclosure. ASAS discovers the Manufacturer, 

Model and Serial Number of the blade.

Switch Ports—The fibre channel port World Wide Name (WWN), including information 

about F_Ports, E_Ports, and G_Ports. For each port, ASAS discovers the WWN, Port 

Number, Port State, and Port FCID (Fibre Channel ID). If enclosure is captured, ASAS also 

discovers slot information for the ports. ASAS does not discover node loop ports attached 

to an arbitrated loop. However, ASAS discovers fabric switch loop port. 

E_Ports/Inter-Switch Links—Inter-Switch Link (ISL) information. ASAS identifies the E_

Ports that participate in the ISLs for each pair of fibre switches.
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Ports Connectivity and N_Ports—For each fibre switch port, ASAS discovers the World 

Wide Name (WWN) of the connected N_Port, such as FCA Port (REF-008) and Storage 

Array Port (REF-009). This information helps identify the dependency chain from the 

initiators to the targets through the fabric, and also displays information about the multi-

path between the initiators and the targets. Ports that are discovered without any parent 

device information are marked as Unknown Connected Ports. ASAS does not discover 

node loop ports attached to an arbitrated loop.

Zoning Database and Zones —All zones configured in the zoning database of the 

principal switch. Zones contain a list of World Wide Name (WWN) and alias naming. Alias 

naming may not be supported by all fibre switch vendors. A zoning database may not be 

synchronized between switches. The administrator should verify that zoning databases 

across the fabric are synchronized. ASAS does not capture the zoning information if the 

list (members) are configured as Domain:Port format.

Alias —ASAS discovers all alias in a zoning database. Alias is not supported by 

McData-based fabric switches. ASAS does not discover the alias information if the list 

(members) are configured as Domain:Port format. 

Zonesets —ASAS discovers all active and inactive zonesets in a fabric. ASAS also 

discovers all zones that make up a zoneset.

Fabric Assets and Relationships

ASAS captures relationships between fabric elements and other storage asset discovery 

features. See Table 2-8.

Table 2-8: Fabric Assets and Relationships

FABRIC ASSET EXTERNAL ELEMENT DESCRIPTION

Connected N_Port Ports connectivity Provides the point-to-point links 

through a fabric.
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Frequently Asked Questions

Table 2-9 answers some frequently asked questions on finding information about fabrics.

Table 2-9: Frequently Asked Questions About Fabric Assets

QUESTION HOW TO FIND THE ANSWER

1. What is the fibre channel SAN network 

configuration that an application depends on?

• “Viewing SAN Switches in a Fabric” on 

page 148

• “Viewing Managed Servers Attached to the 

Fabric” on page 156

• “Viewing SAN Arrays in the Fabric” on 

page 155

2. Are critical applications configured for high 

availability, such as multiple access paths? What 

are the redundant paths between a server and 

storage array for an application?

• “SAN Map” on page 291

• “Storage Map” on page 292

3. What are the security configurations enabled to 

address business on the network?

• “Viewing Zone Sets” on page 159

• “Viewing Members of a Zone Set” on 

page 161

• “Viewing Zones in a Fabric” on page 162

• “Viewing Ports in a Zone” on page 163

4. Are the Inter-Switch Links configured for critical 

applications?

• “SAN Map” on page 291

• “Storage Map” on page 292

5. What is causing application performance degra-

dation? How is the SAN configuration impacting 

the application? What are the shared resources 

between applications?

• “SAN Map” on page 291

• “Storage Map” on page 292

6. Does the SAN provide room for growth? • “Viewing SAN Switches in a Fabric” on 

page 148

• “Viewing SAN Arrays in the Fabric” on 

page 155

• “Viewing Managed Servers Attached to the 

Fabric” on page 156
4
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Viewing SAN Fabrics

To view SAN fabrics, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Fabrics. The content pane 

displays fabrics discovered by a Storage Agent.

2 (Optional) Select a target and then select one of the following options from the 

Actions menu:

• Open—Opens the SAN Fabric Browser.

• Rename—Provides an editable field to rename the fabric. Press Esc to revert to the 

old name.

• Delete—Removes the SAN fabric from the Model Repository.

7. What SAN elements (servers, switches, arrays, 

and gateways) do certain applications depend 

on?

• “SAN Map” on page 291

• “Storage Map” on page 292

8. What are the storage expansion opportunities 

for an application, using the existing fabric 

configuration?

• “SAN Map” on page 291

• “Storage Map” on page 292

• “Viewing SAN Switches in a Fabric” on 

page 148

• “Viewing SAN Arrays in the Fabric” on 

page 155

• “Viewing Managed Servers Attached to the 

Fabric” on page 156

• “Viewing SAN Switch FC Ports” on 

page 175

• “Viewing Storage Initiators” on page 167

9. Why is a LUN volume not visible to the server? 

Does the fabric configuration need to be 

modified?

• “Viewing Storage Initiators” on page 167

Table 2-9: Frequently Asked Questions About Fabric Assets (continued)

QUESTION HOW TO FIND THE ANSWER
145



User’s Guide

14
Figure 2-71: SAN Fabrics

Important to Know

Name—The World Wide Name of the principal switch. When the principal switch 

changes in the fabric, a new fabric instance is created. If you have permission, you 

can edit the name.

Description—A brief description of the SAN fabric, such as vendor information.

The name and description fields are not editable in the Properties sub-view in the main 

panel. They are editable in the SAN Fabrics Properties window.

Viewing SAN Fabric Properties

To view SAN fabric properties, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Fabrics.

2 In the View drop-down list, select Properties.

3 In the content pane, select a SAN fabric and then open it. The content pane displays 

the properties.
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Figure 2-72: SAN Fabric Properties

Important to Know

Name—The World Wide Name of the principal switch. When the principal switch 

changes in the fabric, a new fabric instance is created. The name can be edited if the 

user has permission.

Description—The description about the SAN fabric, usually the vendor information.

Managed Server—The name of the server where the Storage Agent is installed and 

managing this fabric. A hyperlink to the server is provided.

Opsware ID—The primary key associated with the fabric in the Model Repository.

File ➤  Save—Enabled when Name or Description is edited. Saves the changes to 

the system.

File ➤  Revert—Enabled when Name or Description is edited. Reverts the changes.

Viewing the SAN Fabrics History Log

To view the history log for SAN fabrics, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Fabrics.

2 In the View drop-down list, select History. The content pane displays the history log.
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3 (Optional) Select a target and then select the following option from the Actions 

menu:

• View Event Details—Displays detail information of the event in a dialog box.

Figure 2-73: SAN Fabrics History Log

Important to Know

Date—The date of the event.

Event—A description of the event.

User—The name of the user who performed the event.

Status—The current status.

Viewing SAN Switches in a Fabric

To view SAN switches in a fabric, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Fabrics.

2 In the View drop-down list, select SAN Switches.

3 Select a SAN switch.
8
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4 (Optional) Select a target and then select one of the following options from the 

Actions menu:

• Open —Opens the SAN Fabric Browser.

Commands

• Double-Click—Opens the SAN Switch Browser.

Figure 2-74: SAN Switches

Important to Know

Name—The name of the SAN switch.

Manufacturer—The manufacturer of the SAN switch.

Model—The model number of the SAN switch.

Firmware Version—The firmware version of the SAN switch.

IP Address—The IP address of the SAN switch.

Customer—The customer assigned to the SAN switch.

Facility—The facility assigned to the SAN switch.
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Status—The status of the SAN switch at the time of the snapshot by the Storage 

Agent.

Description—The description of the SAN switch.

Number of Ports—The number of ports on the SAN switch.

Opsware ID—The ID of the SAN switch assigned by HP SA.

Virtual—Indicates whether the SAN switch is virtual.

Viewing SAN Switches

To view SAN switches discovered by the Storage Agent, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Fabrics.

2 In the View drop-down list, select SAN Switches.

3 In the content pane select a fabric and then open it. The content pane displays a list 

of SAN switches.

4 (Optional) Select a target and then select one of the following options from the 

Actions menu:

• Open—Opens the Switch Browser with the selected view.

• Open with HP Service Automation Visualizer— Opens the target with Service 

Automation Visualizer (SAV) and displays the fabric map.

• Rename (F2)—Provides editable field to rename switch directly in the table. 

Pressing Esc will revert to the old name.

• Delete—Removes the switch from the Model Repository. This command will not 

remove the Access control or deactivate the Storage Agent. The user needs write 

permission to remove the data.

Commands

Double-Click—Opens the SAN Switch Browser.
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Figure 2-75: Discovered SAN Switches

Important to Know

Name—The name of the SAN switch.

Manufacturer—The manufacturer of the SAN switch.

Model—The model number of the SAN switch.

Firmware Version—The firmware version of the SAN switch.

IP Address—The IP address of the SAN switch.

Customer—The customer assigned to the SAN switch.

Facility—The facility assigned to the SAN switch.

Status—The status of the SAN switch at the time of snapshot by the Storage Agent.

Description—The description of the SAN switch.

Number of Ports—The number of ports on the SAN switch.

Opsware ID—The ID of the SAN switch assigned by HP SA.

Virtual—Indicates if the SAN switch is virtual or not.
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The name and description fields are not editable in the Properties sub-view in the main 

panel. They are editable in the SAN Switches Properties window.

Viewing SAN Switch Properties

To view the properties of the SAN switch, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Fabrics.

2 In the View drop-down list, select SAN Switches.

3 In the content pane select a fabric and then open it.

4 In the SAN switches content pane select a switch and then open it.

5 In the Views pane, select Properties. The content pane displays the properties.

6 (Optional) Select either of the following options from the File menu:

File ➤  Save—Enabled when Name or Description is edited. Saves the changes to 

the system.

File ➤  Revert—Enabled when Name or Description is edited. Reverts the changes.

Figure 2-76: SAN Switch Properties
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Important to Know

Name—The name of the SAN switch.

Description—The description about the switch, usually the vendor information. The 

description can be edited if the user has permissions.

Customer—The customer associated with the switch. A hyperlink to change the 

customer is provided.

Facility—The facility associated with the switch.

Managed Server—The name of the server where the Storage Agent is installed and 

managing this fabric. A hyperlink to the Server Browser is provided.

Opsware ID—The primary key associated with the switch in the Model Repository.

Firmware Version—The firmware version of the SAN switch.

IP Address—The IP address of the SAN switch.

Manufacturer—The manufacturer of the SAN switch.

Model—The model number of the SAN switch.

Status—The status of the SAN switch at the time of snapshot by the Storage Agent.

Select the Change link to open the Customer dialog box.

Viewing Customers

To view customers that exist in the Model Repository, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Fabrics.

2 In the View drop-down list, select SAN Switches.

3 In the content pane select a fabric and then open it.

4 In the SAN switches content pane select a switch and then open it.

5 In the Views pane, select Properties.

6 In the content pane, select the Change hyperlink. The content pane displays a list of 

customers.
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Figure 2-77: Customers in the Model Repository

You can select only one customer. When a customer is selected, the Select button is 

enabled.
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Viewing SAN Arrays in the Fabric

To view SAN arrays monitored by the Storage Agent, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Fabrics.

2 In the View drop-down list, select SAN Arrays. The content pane displays a list of SAN 

arrays.

3 (Optional) Select a target and then select one of the following options from the 

Actions menu:

• Open —Opens the SAN Array Browser or the NAS Filer Browser. 

Commands

• Double-Click—Opens the SAN Array Browser or the NAS Filer Browser.

Figure 2-78: SAN Arrays in the Fabric

Important to Know

Name—The name of the SAN array or NAS filer.

Manufacturer—The manufacturer of the SAN array or NAS filer.

Model—The model number of the SAN array or NAS filer.
155



User’s Guide

15
Serial Number—The model number of the SAN array or NAS filer.

Firmware Version—The firmware version of the SAN array or NAS filer.

IP Address—The IP address of the SAN array or NAS filer.

Customer—The customer assigned to the SAN array or NAS filer.

Facility—The facility assigned to the SAN array or NAS filer.

Status—The status of the SAN array or NAS filer at the time of the snapshot by the 

Storage Agent.

Description—The description of the SAN array or NAS filer.

Discovered On—Discovered date by the Storage Agent.

Synchronized Date—The last synchronized date of the message from the Storage 

Agent.

Synchronization Status—The status of the process that stores Storage Agent data 

in the Model Repository.

Opsware ID—The ID of the NAS Filer assigned by HP SA.

Viewing Managed Servers Attached to the Fabric

To view managed servers attached to the fabric, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Fabrics.

2 In the View drop-down list, select Servers. The content pane displays a list of 

managed servers.

3 (Optional) Select a target and then select the following option from the Actions 

menu:

• Open —Opens the Server Browser.

Commands

• Double-Click—Opens the Server Browser.
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Figure 2-79: Managed Servers Attached to the Fabric 

Important to Know

Name—The name of the server.

Hostname—The name of the host server.

IP Address—The IP address of the server.

OS—The name of the Operating System.

Customer—The customer assigned to the SAN array or NAS filer.

Facility—The facility assigned to the SAN fabric.

Stage—The stage of deployment for a server, such as Live or Offline.

Use—How an organization is using the managed server, such as a staging server, a 

production server, a development server, and so on.

Lifecycle—The server's stage in the HP Lifecycle, such as Unprovisioned, Available, 

Managed, or Deactivated.

Virtualization—Indicates whether the virtual server is a hypervisor or a virtual 

machine.
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Realm—The name of the agent.

Agent Version—The version of the Agent.

Device Type—The type of device.

Manufacturer—The manufacturer of the Server.

Model—The model number of the server.

Description—The description of the server.

Opsware ID— The ID of the NAS Filer as assigned by HP SA.

Viewing SAN Fabrics and Attached Devices

To view information about SAN fabrics and attached devices, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Fabrics.

2 In the View drop-down list, select Zone Sets.

3 In the content pane, select a SAN fabric and then open it. The content pane displays 

information on fabrics and attached devices.

4 (Optional) Select a target and then select the following option from the Actions 

menu:

• Right-Click Actions—Depends on the view with which the browser is opened. 

Please refer to the appropriate view section.
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Figure 2-80: SAN Fabrics and Attached Devices

Important to Know

Name—The World Wide Name of the principal switch. When the principal switch 

changes in the fabric, a new fabric instance is created. If you have permission, you 

can edit the name.

State—The state of the zone set, such as Active or Inactive.

Viewing Zone Sets

To view zone sets, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Fabrics.

2 In the View drop-down list, select Zone Sets. The content pane displays a list of zone 

sets.
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Figure 2-81: Zone Sets

Important to Know

Name—The name of the zone set.

State—The state of the zone set, such as Active or Inactive.

Viewing Zone Set Properties

To view zone set properties, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Fabrics.

2 In the View drop-down list, select Zone Sets.

3 In the content pane, select a SAN fabric and then open it. The content pane displays 

the properties.
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Figure 2-82: Zone Set Properties

Important to Know

Name—The name of the zone set.

Description—The description of the zone set. It is an entity that is generated by HP 

SA.

State—The state of the zone set. The possible values are Active, Inactive or “-”.

Viewing Members of a Zone Set

To view members of a zone set, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Fabrics.

2 In the View drop-down list, select Zones. The content pane displays the members 

view.
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Figure 2-83: Members of a Zone Set

Important to Know

Name—The name of the zone.

Description—The description of the zone. It is an entity that is generated by HP SA.

Viewing Zones in a Fabric

To view zones in a fabric, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Fabrics.

2 In the View drop-down list, select Zones.

3 In the content pane, select a SAN fabric and then open it. The content pane displays 

a list of zones.
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Figure 2-84: Zones in a Fabric

Important to Know

Name—The name of the zone.

Description—The description of the zone. It is an entity that is generated by HP SA.

Viewing Ports in a Zone

To view ports in a selected zone, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Fabrics.

2 In the View drop-down list, select Zones.

3 In the content pane, select a SAN fabric and then open it. The content pane displays 

a list of ports.

4 (Optional) Select a target and then select one of the following options from the 

Actions menu:

• Open Device—Opens the Server Browser if the device is a server. Opens the SAN 

Array Browser if the device is a SAN array. Opens the NAS Array Browser if the 

device is a NAS array. Opens the Switch Browser if the device is a SAN switch. 
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• Open Ports—Opens the server hardware if the device is a server. Opens the SAN 

array ports if the device is a SAN array. Opens the NAS array ports if the device is a 

NAS array. Opens the switch ports if the device is a SAN switch. The user needs 

permissions to view (read) on the device.

Figure 2-85: Ports in a Zone

Important to Know

Name—The name of the port. It could be World Wide Name or port name as 

discovered by HP SA.

Device—The name of the attached device. This can be a SAN array, SAN switch or 

NAS (FC facing).

Port ID—The World Wide Name of the port.

Viewing Aliases in a Zone

To view aliases in a selected zone, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Fabrics.

2 In the View drop-down list, select Alias. The content pane displays a list of aliases.
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Figure 2-86: Aliases in a Zone

Important to Know

Name—The name of the alias.

Viewing Aliases in a Fabric

To view aliases in a fabric, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Fabrics.

2 In the View drop-down list, select Alias.

3 In the content pane, select a SAN fabric and then open it. The content pane displays 

a list of aliases.
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Figure 2-87: Aliases in a Fabric

Important to Know

Name—The name of the alias.

Viewing Port Members for an Alias

To view port members for an alias, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Fabrics.

2 In the View drop-down list, select Alias.

3 In the Alias content pane, select an alias and then open it. The content pane displays 

a list of port members.

4 (Optional) Select a target and then select one of the following options from the 

Actions menu:

• Open Device—Opens the Server Browser if the device is a server. Opens the SAN 

Array Browser if the device is a SAN array. Opens the NAS Array Browser if the 

device is a NAS array. Opens the Switch Browser if the device is a SAN switch. To 

view (read) the device, you must have the required permission.
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• Open Ports—Opens the server ports if the device is a server. Opens the SAN array 

ports if the device is a SAN array. Opens the NAS array ports if the device is a NAS 

array. Opens the switch ports if the device is a SAN switch.

Figure 2-88: Port Members for an Alias

Important to Know

Name—The name of the port. It could be World Wide Name or port name as 

discovered by HP SA.

Device—The name of the attached device. This can be a SAN array, SAN switch or 

NAS (FC facing).

Port ID—The World Wide Name of the port.

Viewing Storage Initiators

To view storage initiators that consume volume through the switch, perform the following 

steps:

1 From the Navigation pane, select Storage ➤  SAN Switches.
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2 In the View drop-down list, select Storage Initiators.

3 In the content pane select a switch and then open it. The content pane displays the 

storage initiators.

4 (Optional) Select a target and then select one of the following options from the 

Actions menu:

• Open—Opens the Server Browser for the selected server.

• Open Volumes— Opens and displays server storage information.

• Open Ports—Opens and displays server hardware information.

Commands

• Double-Click—Opens the Server Browser.

Figure 2-89: Storage Initiators

Important to Know

Name—The name of the server.

LUN Volume—The LUN volume served to the server through this switch.

Controller—The controller attached to the server that is attached to this switch.
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Port—The server (initiator) ports attached to this switch.

LUN—The Logical Unit Number for the LUN volume.

Viewing Switches Connected to the Array

To view switches connected to the array, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Switches.

2 In the View drop-down list, select SAN Arrays.

3 In the content pane, open the switch. The content pane displays the connected 

switches.

Figure 2-90: Connected Switches to the Array

Important to Know

Name—The name of the fabric of this switch.

Manufacturer—The name of the manufacturer. 

Model—The model number of the storage system.

Serial Number—The serial number of the storage system.

Firmware Version—The firmware version of the switch.
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IP Address—The IP address of the SAN switch.

Customer—The customer assigned to the switch.

Facility—The facility assigned to the switch.

Status—The status of the device.

Description—The description of the fabric.

Discovered On—Discovered date by the Storage Agent.

Synchronized Date—The last synchronized date of the message from the Storage 

Agent.

Synchronization Status—The status of the process that stores Storage Agent data 

in the Model Repository.

Opsware ID—The primary key associated with the switch in the Model Repository.

Viewing Information on Switches and SAN Attached Devices

To view information on switches and SAN attached devices, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Switches.

2 In the View drop-down list, select SAN Switches.

3 In the SAN switches content pane select a switch and then open it. The content pane 

displays information on the switches and SAN attached devices.

4 (Optional) Select a target and then select the following option from the Actions 

menu:

• Right-Click Actions—Depends on the view with which the browser is opened. 

Please refer to the appropriate view section.
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Figure 2-91: Switches and SAN Attached Devices Information

Viewing Switch Summary

To view the switch summary, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Switches.

2 In the View drop-down list, select SAN Switches.

3 In the SAN switches content pane select a switch and then open it. The content pane 

displays the summary of switch properties.
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Figure 2-92: Switch Properties Summary

The name and description fields are not editable. 

Viewing Connected Switches

To view connected switches, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Switches.

2 In the View drop-down list, select SAN Switches.

3 In the content pane, select a switch and then open the Switch Browser. The content 

pane displays the connected switches.

4 (Optional) Select a target and then select the following option from the Actions 

menu:

• Open—Opens the Switch Browser.
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Figure 2-93: Connected Switches

Important to Know

Name—The name of the fabric of this switch.

Manufacturer—The name of the manufacturer. 

Model—The model number of the switch.

Firmware Version—The firmware version of the switch.

IP Address—The IP address of the SAN switch.

Customer—The customer assigned to the switch.

Facility—The facility assigned to the switch.

Status—The status of the device.

Description—The description of the fabric.

Number of Ports—The number of switch ports.

Opsware ID—The internal HP SA identification associated with the SAN switch in a 

core. The primary key associated with the SAN array in the Model Repository.

Virtual—Indicates whether the SAN switch is virtual or not.
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Viewing the Fabric of a Switch

To view the fabric of a switch, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Switches.

2 In the View drop-down list, select SAN Fabrics.

3 In the content pane, select a switch. The content pane displays the SAN fabric.

4 (Optional) Select a target and then select the following option from the Actions 

menu:

• Open—Opens the Fabric Browser.

Figure 2-94: Switch Fabric

Important to Know

Name—The name of the fabric of this switch.

Description—The description of the fabric.

Viewing SAN Switch Hardware

To view the hardware of a SAN switch, perform the following steps:
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1 From the Navigation pane, select Storage ➤  SAN Switches.

2 In the View drop-down list, select Hardware.

3 In the content pane, select a switch. The content pane displays the hardware 

information.

Figure 2-95: SAN Switch Hardware Information

Important to Know

Manufacturer—The manufacturer of the SAN switch.

Model—The model of the SAN switch.

Serial Number—The serial number of the SAN switch.

Hardware Version—The hardware version of the SAN switch.

Firmware Version—The firmware version of the SAN switch.

Number of Ports—The number of FC ports in the SAN switch.

Viewing SAN Switch FC Ports

To view SAN switch FC ports, perform the following steps:
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1 From the Navigation pane, select Storage ➤  SAN Switches.

2 In the View drop-down list, select Ports.

3 In the content pane, select a switch. The content pane displays a list of FC ports.

Figure 2-96: SAN Switch FC Ports

Important to Know

Name—The name of the FC port. Either it is the WWN, port number or a combination 

of slot and port number.

WWN—The World Wide Name of the fabric port.

Number—The port number.

Controller—The controller information from the switch.

Fabric—The fabric that this switch is attached to.

FCID—The Fibre Channel ID of the switch port.

State—The state of the FC port.
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Viewing Properties of the Fabric Port in a Switch

To view port properties, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Switches.

2 In the View drop-down list, select Ports.

3 In the content pane select a port and then open it. The content pane displays the 

properties.

Figure 2-97: Port Properties in a Switch

Important to Know

FCID—The Fibre Channel ID of the switch port.

WWN—The World Wide Name of the fabric port.

Number—The port number.

Controller—The controller information from the switch.

Fabric—The fabric that this switch is attached to.
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Connected To—The device and port connected to. Click the hyperlink to opens the 

Device Browser.

Status—The state of the fabric port.

Viewing Zones

To view zones that this port is a member of, perform the following steps:

1 From the Navigation pane, select Storage ➤  SAN Switches.

2 In the View drop-down list, select Ports.

3 In the content pane select a switch and then open it.

4 In the View drop-down list, select Zones.

5 In the Zones content pane, select a port. The content pane displays the zones.

6 (Optional) Select a target and then select one of the following options from the 

Actions menu:

• Open Zone —Opens the SAN fabrics settings zone view.

• Open ZoneSet —Opens the SAN fabrics settings zone set view.

Commands

• Double-Click—Opens the SAN fabrics settings zone view.
8



Chapter 2: Asset Discovery
Figure 2-98: SAN Switch Zones

Important to Know

Name—The name of the zone.

Zone Set—The name of the zone set. The column value can be empty (-).

Active—Indicates whether the zone is active. The column value can be empty (-).

NetApp Assets 

This feature provides visibility into NetApp storage configurations in a SAN or IP network, 

such as File I/O based storage entities (Filer Volumes, Qtrees), Block I/O based entities 

(NetApp LUNs), and Fabric elements (FCA/Ports).

A NetApp storage administrator can view the following:

• NetApp storage utilization and configuration

• Storage resources shared between applications or managed servers

ASAS captures the following NetApp information in a SAN:
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NetApp Filer—Filer Name, Manufacturer, Model, Serial Number, Firmware Version, 

Customer, IP Address, Facility, Status, Description, Discovered on, Synchronized Date, 

Synchronized Status, Opsware ID.

Disks—NetApp disk storage capacity. ASAS discovers the raw capacity of the disk and 

discovers whether the disk is consumed by RAID groups.

RAID Groups—NetApp creates RAID groups based on disks. RAID group is an internal 

entity that is not configured by the user. ASAS does not display storage information for 

RAID groups. The storage information is not available through the API. It is derived by the 

size of the disk and configuration, such as RAID 4 or RAID 4DP.

Plex—NetApp creates Plex based on RAID Groups. Plex is an internal entity that is not 

configured by the user. ASAS does not display storage information for Plex. The storage 

information is not available through the API—it is derived by the size of the RAID Group.

Aggregates —Aggregate is a storage entity that is introduced by ONTAP 7.0. ASAS 

discovers aggregate caption and aggregate capacity.

File I/O and Block I/O—NetApp exposes storage resources for File I/O and Block I/O. 

NetApp volumes, Qtree, and directories are exported through CIFS or NFS for File I/O. 

NetApp LUNs are LUN-mapped for Block I/O access. ASAS discovers storage information 

related to the File I/O and Block I/O access.

NetApp Volumes—Filer volume information that includes storage capacity, Vfiler that the 

volumes are associated with, aggregate that the volume consumes, volume type 

(Traditional or Flex), snapshot reserve, snapshot reserve size, and whether the volume is a 

target or a source of replication.

Traditional Volumes—Volumes based on ONTAP 6.5 and traditional volumes in ONTAP 

7.0 or higher.

Flex Volumes—Flex is a storage entity that is introduced by ONTAP 7.0. In addition to filer 

volume information, ASAS also discovers committed capacity and space guarantee 

(volume, none, file) for flex volumes.

Qtrees—A subdirectory in a volume that acts as a virtual sub-volume with special 

attributes, such as primarily quotas and permissions.

Quota—The quota against the NetApp volumes. Quota that is applied on the Qtrees is 

also captured at the volume level. ASAS discovers the following quota information:

• Caption

• Type (tree, user, or group)
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• Qtree (Qtree that is applicable)

• Unix ID (ID of the user or group, whichever is applicable)

• Windows ID (ID of the user or group, whichever is applicable)

• Space threshold

• Space threshold unit (in KB/MB, and so on)

• Quota target (Default targets are discovered as *.)

Quota will also have zero or more QuotaLimit. QuotaLimit captures the following 

information:

• Limit type (DiskSpace or NumberOfFiles)

• Soft Limit Value

• Soft Limit Unit

• Hard Limit Value

• Hard Limit Unit

Directory—Directory paths that are exported through CIFS share or NFS. ASAS does not 

discover all directories that are residing in the NetApp volume.

File I/O Exports—NetApp provides exporting NetApp Volumes using File I/O through 

CIFS and NFS protocol.

CIFS—Common Internet File System. NetApp shares and the volume/qtree/directory path. 

ASAS does not discover the managed servers that are consuming the NetApp resources 

through CIFS protocol.

NFS—Network File System. Export information for the volumes/Qtree/directory path. HP 

might discover stale information, based on the data available to it through the API. 

NetApp LUNs —NetApp exposes Block I/O through NetApp LUNs, which can be 

carved out of NetApp volumes, Qtrees or directories. When these are carved out of 

flexible volumes, they become committed storage resources for NetApp LUNs. ASAS 

discovers the NetApp LUNs and storage capacity. For each LUN, ASAS also discovers 

LUN mapping information. 

NetApp FC Port—The fabric port used by NetApp for exporting Block I/O LUNs. ASAS 

discovers the World Wide Number of the port.

Initiator Groups—Initiator groups configured in the NetApp.
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LUN Mapping—LUN mapping information, such as NetApp LUN, NetApp FC Port, LUN ID, 

and managed server FC Port/FCA information.

Replication—Sync Mirror, Snapmirror, and snapshot information.

Snapshot—Source resource, target resource, copy type (always UnSyncAssoc for 

Snapshot), replica type (AfterDelta), and Sync Status (if available) for the NetApp volumes. 

ASAS also discovers the snapshot reserve and snapshot reserve size for each volume, 

and the number of snapshots and the total space used by all snapshots in the volume.

NetApp VFiler —VFiler configuration. ASAS discovers IP addresses and the volume 

path that is configured for each VFiler. NetApp requires that a MultiStore license is 

enabled in the filer to support virtual filers. If a MultiStore license is not enabled, ASAS 

assumes that a default vfiler0 exists in the system.

NetApp Cluster —Cluster partners for the NetApp Filer. Table 2-10 describes the 

cluster information that ASAS discovers.

Table 2-11 describes the cluster partner information that ASAS discovers.

Table 2-10: Cluster Information Discovered by ASAS

PROPERTY EXAMPLE

Cluster Status OK, ERROR

Interconnection Status up, down

Cluster Setting Enabled, Disabled

Takeover Cause -

Table 2-11: Cluster Partner Information Discovered by ASAS

PROPERTY EXAMPLE

Status Online

Customer -

Facility -

Realm -
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NetApp Assets and Relationships

ASAS captures relationships between NetApp elements and other storage asset 

discovery features. See Table 2-12.

Frequently Asked Questions

Table 2-13 answers some frequently asked questions on finding information about 

NetApp assets.

Table 2-12: Fabric Assets and Relationships

FABRIC ASSET EXTERNAL ELEMENT DESCRIPTION

Connected fabric port Ports connectivity Provides the point-to-point links 

through a fabric.

NFS exports and file I/O 

storage elements

Remote file system in a server Provides supply chain from the man-

aged server to the NetApp, based 

on NFS protocol.

NetApp LUNs LUN volumes in a server Provides supply chain based on 

block I/O between a server and 

NetApp LUNs.

Table 2-13: Frequently Asked Questions About NetApp Assets

QUESTION HOW TO FIND THE ANSWER

1. What storage is available in the NetApp in a 

datacenter?

• “Viewing Summary of a NAS Filer” on 

page 187

2. What file systems are exported to the servers? • “Viewing Exports for a VFiler” on page 202

• “Viewing the Access Path from a LUN 

Volume” on page 240

3. Are critical applications configured for high 

availability, such as multiple access paths? What 

are the redundant paths between a server and 

NetApp for an application?

• “Viewing LUN Volumes with Access Paths 

for Remote Initiators” on page 194

• “Viewing the Access Path from a LUN 

Volume” on page 240

4. What is the storage utilization of the NetApp? • “Viewing Summary of a NAS Filer” on 

page 187
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Viewing NAS Filers

To view NAS Filers, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

5. Are the critical applications backed up? • “Viewing the Access Path from a LUN 

Volume” on page 240

• “Viewing Replicated Storage Devices” on 

page 244

6. Does the NetApp Filer provide room for growth? • “Viewing Summary of a NAS Filer” on 

page 187

7. When do the NetApp Filers run out of space? • “Viewing Summary of a NAS Filer” on 

page 187

8. What is causing application performance 

degradation? How is all of the SAN configuration 

impacting the application? What are the shared 

resources between applications?

• “Viewing LUN Volumes with Access Paths 

for Remote Initiators” on page 194

• “Viewing the Access Path from a LUN 

Volume” on page 240

9. Why is a LUN volume not visible to the server? 

Does the configuration need to be modified?

• “Viewing Storage Initiators Consuming 

Storage Block I/O Resources from a NAS 

Filer” on page 193

• “Viewing LUN Volumes with Access Paths 

for Remote Initiators” on page 194

“Viewing Volumes Served by a NAS Filer 

Port” on page 208

Table 2-13: Frequently Asked Questions About NetApp Assets (continued)

QUESTION HOW TO FIND THE ANSWER
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2 In the View drop-down list, select Summary.

Figure 2-99: NAS Filers Browser

Important to Know

Name—The name of the Filer as assigned by the Storage Agent. You can edit this 

name if you have the required permissions.

Manufacturer—The manufacturer of the NAS Filer.

Model—The model number of the NAS Filer.

Serial Number—The serial number of the NAS Filer.

Firmware Version—The firmware of the NAS Filer.

Customer—The customer associated with the NAS Filer.

Facility—The facility associated with the NAS Filer.

Status—The status of the NAS Filer.

IP Address—The primary address of the NAS Filer.

Description—A description of the NAS Filer.

Discovered On—Discovered date by the Storage Agent.
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Synchronized Date—The last synchronized date of the message from the Storage 

Agent.

Synchronization Status—The status of the process that stores Storage Agent data 

in the Model Repository.

Opsware ID—The ID of the NAS Filer as assigned by HP SA.

Commands

Double-click—Opens NAS Filer Browser with the selected view.

Context Menu—(Right-Click/Actions)

Open (Enter)—Opens NAS Filer Browser with the selected view.

Open With HP Service Automation Visualizer—Opens the target with Service 

Automation Visualizer (SAV) and displays the storage map.

Rename (F2)—Provides an editable field to rename a NAS Filer directly in the 

table.

Esc—Reverts to the previous name.

Delete—Removes the NAS Filer from the Model Repository. This action does not 

remove the Access control or deactivate the Storage Agent.

Viewing the NAS Filer Storage Configuration

To view information about NAS Filer storage configuration, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 Open a NAS Filer.

3 From the Navigation pane, select Inventory.
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4 In Views pane, select a configuration to change the display in the content pane.

Figure 2-100: NAS Filer Storage Configuration

Important to Know

Name—The name of the Filer as assigned by the Storage Agent.

IP Address—The primary address of the NAS Filer.

Viewing Summary of a NAS Filer

To view a NAS filer summary, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the View drop-down list, select Summary.
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3 In the content pane, select a NAS Filer and open it to display the Summary.

Figure 2-101: Summary of the NAS Filer

Viewing NAS Filer Properties

To view the properties for the NAS Filer, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the View drop-down list, select Properties.
8
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3 In the content pane, select a NAS Filer and open it to display the Properties.

Figure 2-102: NAS Filer Properties

Important to Know

Name—The name of the Filer as assigned by the Storage Agent. You can edit this 

name if you have the required permissions.

Description—A description of the NAS Filer. This is an editable field if you have the 

required permissions.

Manufacturer—The manufacturer of the NAS Filer.

Model—The model number of the NAS Filer.

Serial Number—The serial number of the NAS Filer.

Firmware—The firmware of the NAS Filer.

IP Address—The primary address of the NAS Filer.

Customer—The customer associated with the NAS Filer.

Facility—The facility associated with the NAS Filer.
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Synch Status—The synchronization (FullSync or DeltaSync) status can be 

Incomplete or OK.

Managed Server—The name of the managed server where the Storage Agent is 

installed. The managed server is a hyperlink when you have permissions to read the 

server.

Opsware ID—The primary key associated with the NAS Filer in the Model Repository.

Status—The status of the NAS Filer.

Viewing Existing Customers

To view customers that exist in the Model Repository, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the View drop-down list, select Properties.

3 In the content pane, select a NAS Filer and open it to display the Properties.

4 Click the “Change” link next to Customers to open the Select Customer dialog.
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5 In the Select Customer dialog, select a customer and then click Select to display its 

Properties.

Figure 2-103: Customers in the Model Repository

Viewing the NAS Filer History Log

To view the history log for the NAS Filer, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the View drop-down list, select History.

3 In the content pane, select a NAS Filer and open it to display the history log.

4 From the View drop-down list, select a time range for this history log, such as Last 

Day, Last Week, Last Month, Last Quarter, or Custom Range.

5 (Optional) Right-click an event to open the Event Details dialog.
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6 (Optional) Click Export to export the history log to a file, such as .csv or .html.

Figure 2-104: NAS Filer History Log

Important to Know

Date—The date and time of when the event occurred.

Event—The type of event.

User—The user who performed the event.

Status—The status of the event, such as Completed.
2
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Viewing Storage Initiators Consuming Storage Block I/O Resources from a 
NAS Filer

To view storage initiators consuming storage (Block I/O) resources from a NAS Filer, 

perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the View drop-down list, select Storage Initiators.

3 In the content pane, select a NAS Filer and then open it.

4 In the content pane, select a SAN device to display the volumes in the NAS Filer. 

5 (Optional) Select a target and then select the following option from the Actions 

menu:

• Open Device—Opens the Server Browser.

Figure 2-105: Storage Initiators
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Important to Know

Viewing LUN Volumes with Access Paths for Remote Initiators

To view LUN volumes with access paths for remote initiators that are not managed by HP, 

perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer.

3 In the View drop-down list, select Storage Initiators.

4 Right-click on a NAS Filer and then select Open.

5 In the content pane, select a target from the list of SAN devices.

Figure 2-106: Storage Volumes in a NAS Filer

Important to Know

Volume —Displays the storage volume caption.
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LUN—Displays the LUN ID of the mapping.

Target Port—Displays the target port used for the mapping.

Initiator Device—The name of the managed server to which storage is mapped from 

the SAN Array. 

Initiator Port—The port from the managed server to which storage is mapped from 

the SAN Array.

Initiator Volume—Always displays “-”.

Viewing Initiator Ports and LUN Volumes

To view initiator ports and LUN volumes that are known to ASAS, perform the following 

steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer.

3 In the View drop-down list, select Storage Initiators.

4 Right-click on a NAS Filer and then select Open.

5 In the content pane, select a target from the list of SAN devices.
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Figure 2-107: Initiator Ports and Volumes in a NAS Filer

Important to Know

Volume —Displays the storage volume caption.

LUN—Displays the LUN ID of the mapping.

Target Port—Displays the target port used for the mapping.

Initiator Device—The name of the managed server to which storage is mapped from 

the SAN Array.

Initiator Port—A port from the managed server (Initiator Device).

Initiator Volume—The volume that is hosted by the servers. This is not specified ("-") 

if the Storage Host Agent Extension (SHA) is not installed, if you have not mounted 

the storage, or if the volume is unknown to HP.

Viewing Attached Fabrics in a NAS Filer

To view attached fabrics in a NAS Filer, perform the following steps:
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1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer.

3 In the View drop-down list, select SAN Fabrics.

4 (Optional) Select a target and then select the following option from the Actions 

menu:

• Open Fabric—Opens the browser for the selected fabric.

Figure 2-108: Attached Fabrics in a NAS Filer

Important to Know

Name—The name of the fabric attached to this storage device.

Description—A description of the fabric.

Viewing Zones Configured for a NAS Filer

To view zones configured for a NAS Filer in a selected fabric, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS filer and then open it.
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3 In the Views pane, select Inventory ➤ Ports.

4 In the content pane, select a SAN fabric.

5 In the View drop-down list, select Zones.

6 (Optional) Select a target and then select the following option from the Actions 

menu:

• Open Zone—Opens the SAN Fabrics Zone view.

• Open Zoneset—Opens the SAN Fabrics ZoneSet view

Figure 2-109: Zones Configured for a NAS Filer

Important to Know

Name —The name of the zone.

ZoneSet—The name of the ZoneSet.

Active—Indicates whether the zone is active (Yes) or not active (No).

Viewing SAN Switches Attached to a NAS Filer

To view SAN switches attached to a NAS filer, perform the following steps:
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1 From the Navigation pane, select Devices ➤ Storage ➤  NAS Filers.

2 In the content pane, select a NAS filer.

3 In the View drop-down list, select SAN Switches. The content pane displays the 

information for SAN switches.

4 (Optional) Select a target and then select the following option from the Actions 

menu:

• Open Device—Opens the SAN Switch Browser.

Figure 2-110: SAN Switches Attached to a NAS Filer

Important to Know

Name —The name of the SAN switch.

Manufacturer—The manufacturer of the SAN switch.

Model—The model of the SAN switch.

Firmware Version—The firmware version of the SAN switch.

IP Address—The primary address of the NAS Filer.

Customer—The customer assigned to the SAN switch.
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Facility—The facility assigned to the SAN switch.

Status—The status of the SAN switch.

Description—The description of the SAN switch.

# of Ports—The number of ports on the SAN switch.

Opsware ID—The internal HP identification associated with the SAN switch in a core. 

The primary key associated with the SAN array in the Model Repository.

Virtual—Indicates whether the SAN switch is virtual or not.

Viewing VFilers

To view the vfilers that are configured in the NetApp system, perform the following steps:

1 From the Navigation pane, select Device ➤  Storage ➤ NAS Filers.

2 In the content pane, select a NAS Filer.

3 In the View drop-down list, select Virtualization.

Figure 2-111: VFilers in the NetApp System

Important to Know

Name—The name of the vfiler.
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IP Address—The primary IP address of the vfiler.

Viewing Volumes Configured for a VFiler

To view the volumes that are configured for a vfiler, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Virtualization.

4 In the View drop-down list, select Volumes.

5 In the content pane, select a VFiler.

Figure 2-112: Volumes Configured for a VFiler

Important to Know

Name—The name of the filer volume.

Type—The type of the volume, such as Flex, Clone, or Trad.

Status—The status of the filer volume.

Capacity—The capacity of the filer volume.
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Free Space—The free space in the filer volume.

Committed Capacity—The committed capacity of the filer volume.

Space Reserved Type—The space reserved type for the flex volume.

Volume Type—The type of the volume, such as Flex, Clone, or Trad.

Viewing Exports for a VFiler

To view the exports for a vfiler, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Virtualization.

4 In the View drop-down list, select Exports.

5 In the content pane, select a VFiler.

Figure 2-113: Exports for a VFiler

Important to Know

Name—The name of the Common Internet File System (CIFS) share or the Network 

File System (NFS) path.
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Device—For the CIFS, this is "-". For the NFS, this is the name of the managed server. 

If a Storage Host Agent Extension (SHA) is not installed, this is "-".

File System—For the CIFS, this is "-". For the NFS, this is File System. If a Storage 

Host Agent Extension (SHA) is not installed, this is "-".

Mount Options—For the CIFS, this is "-". For the NFS, this is Mount Options. If a 

Storage Host Agent Extension (SHA) is not installed, this is "-".

Description—For the CIFS, this is "-". For the NFS, this is File System Description. If a 

Storage Host Agent Extension (SHA) is not installed, this is "-".

Viewing Cluster Status

To view the cluster status, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the View drop-down list, select Cluster.

Figure 2-114: Cluster Status
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Important to Know

Cluster Status—The status of the cluster configuration.

Interconnection Status—The status of the interconnection.

Cluster Setting—This is “enabled” if the cluster is configured.

Takeover Cause—This is additional information that is displayed when a cluster 

takeover or a give-back occurs.

Name—The name of the cluster partner.

Customer—The customer of the cluster partner.

Facility—The facility of the cluster.

Status—The status of the partner.

Viewing Fabric Ports and Connectivity in a NAS Filer

To view fabric ports and connectivity, perform the following steps:

1 From the Navigation pane, select Device ➤  Storage ➤ NAS Filers.

2 In the content pane, select a NAS Filer.
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3 In the View drop-down list, select Ports. 

Figure 2-115: Fabric Ports and Connectivity to a Fabric

Important to Know

Name—The name of the NAS Filer fabric port.

WWN—The World Wide Name of the NAS Filer fabric port.

Number—The port number of the NAS Filer fabric port.

Controller—The port controller name.

Fabric—The connect fabric.

FCID—The Fibre Channel ID of the fabric port.

State—The state of the NAS Filer fabric port.

Viewing Fabric Ports in a NAS Filer

To view front end fabric ports in a NAS Filer, perform the following steps:

1 From the Navigation pane, select Device ➤  Storage ➤ NAS Filers.

2 In the content pane, select a NAS filer.
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3 In the View drop-down list, select Ports.

Figure 2-116: Fabric Ports in a NAS Filer

Important to Know

Name—The name of the storage array port.

WWN—The World Wide Name of the storage array port.

Number—The port number of the storage array port.

Controller—The name of the port controller.

Fabric—The fabric that is connected to the port.

FCID—The Fibre Channel ID of the storage system port.

State—The state of the Storage System port.

Viewing Properties of the Fabric Port in a NAS Filer

To view properties of the fabric port, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.
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3 In the Views pane, select Inventory ➤ Ports.

4 In the View drop-down list, select Properties.

5 In the content pane, select a storage port.

Figure 2-117: Fabric Port Properties

Important to Know

FCID—The Fibre Channel ID of the fabric port.

WWN—The World Wide Name of the fabric port.

Number—The port number of the fabric port.

Controller—The controller that the fabric port is attached to.

Fabric—The name of the fabric that this port is attached to.

Connected To—The name of the switch and the port this is connected to. if 

connected, a hyperlink to the Switch Browser is provided.

Status—The status of the fabric.
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Viewing Volumes Served by a NAS Filer Port

To view filer volumes that are served by a NAS Filer port, perform the following steps:

1 From the Navigation pane, select Device ➤  Storage ➤ NAS Filers.

2 In the content pane, select a NAS filer.

3 In the View drop-down list, select Ports.

4 Double-click the selected NAS Filer.

5 In the View drop-down list, select Volumes.

6 In the content pane, double-click a storage port.

7 (Optional) Select a target and then select the following option from the Actions 

menu:

• Open Device—Opens the Server Browser for the selected server.

• Open Initiator Port—Displays the hardware information for the selected server.

• Open Initiator Volume—Displays the storage information for the selected server.

Figure 2-118: Volumes Served by a NAS Filer Port
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Important to Know

Volume —Displays the storage volume caption.

LUN—Displays the LUN ID of the mapping.

Target Port—The SAN array port through which the volume was mapped to the 

initiator port.

Initiator Device—The name of the managed server to which storage is mapped from 

the SAN Array.

Initiator Port—A port from the managed server (Initiator Device).

Initiator Volume—The volume that is hosted by the servers. This is not specified ("-") 

if the Storage Host Agent Extension (SHA) is not installed, if you have not mounted 

the storage, or if the volume is unknown to HP.

Viewing Zones Configured for a Fabric Port

To view the zones that are configured for a fabric port, perform the following steps:

1 From the Navigation pane, select Device ➤  Storage ➤ NAS Filers.

2 In the content pane, select a NAS filer.

3 In the View drop-down list, select Ports.

4 Double-click the selected NAS Filer.

5 In the View drop-down list, select Zones.

6 In the content pane, double-click a storage port.

7 (Optional) Select a target and then select the following option from the Actions 

menu:

• Open Zone—Opens SAN Fabrics Zone view.

• Open ZoneSet—Opens SAN Fabrics ZoneSet view.
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Figure 2-119: Zones Configured for a NAS Filer Port

Important to Know

Name —The name of the zone.

ZoneSet—The name of the zoneset. The column value can be empty (-).

Active—Indicates if the zone is active.

Viewing Storage Summary for a NAS Filer

To view the summary of storage information offered by a NAS filer, perform the following 

steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS filer and then open it.
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3 In the Views pane, select Inventory ➤ Storage. The content pane displays 

summary information.

Figure 2-120: Summary of NAS Filer Storage 

Important to Know

Disks—The total number of disks.

Disk Capacity—The total raw capacity of the disk.

LUN Volumes—The total number of LUN volumes.

LUN Volumes Capacity—The total capacity of the LUN volumes in the storage array.

Allocated LUN Volumes—The number of LUN mapped volumes.

Allocated LUN Volumes Capacity—The total capacity of the LUN volumes that are 

mapped to the initiator.

Unallocated LUN Volumes—The total number of unmapped LUN volumes.

Unallocated LUN Volumes Capacity—The total capacity of the LUN volumes in the 

array not offered to any initiator.

Viewing Disks in a NAS Filer

To view the disks in a NAS Filer, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.
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2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  Disks.

4 Select a disk and then open it.

Figure 2-121: Disks in a NAS Filer

Important to Know

Name—The name of the disk.

Description—A brief description of the disk.

Manufacturer—The manufacturer of the disk.

Model—The model number of the disk.

Capacity—The capacity of the disk, in gigabytes.

Free Space—The free capacity of the disk, in bytes.

Status—The status of the disk, such as OK.

Spare—Specifies whether the disk is a spare (Yes) or is not a spare (No).
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Viewing NAS Filer Disk Properties

To view the properties of a NAS Filer disk, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  Disks.

4 From the View drop-down list, select Properties.

5 Select a disk to display its properties.

Figure 2-122: NAS Filer Disk Properties

Important to Know

Name—The name of the disk.

Description—A brief description of the disk.

Manufacturer—The manufacturer of the disk.

Model —The model number of the disk.

Capacity—The capacity of the disk.
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Free Space—The free capacity of the disk.

Status—The status of the disk, such as OK.

Spare—Specifies whether the disk is a spare (Yes) or is not a spare (No).

Viewing Filer Volumes Created by a Disk

To view the Filer volumes that are created by a disk, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  Disks.

4 Select a disk.

5 From the View drop-down list, select Volumes.

Figure 2-123: Filer Volumes Created by a Disk

Important to Know

Name—The name of the filer volume.

Type—SIMPLE, MIRRORED, RAID0, RAID4, RAID_DP, or UNDEFINED.
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Status—The status of the filer volume.

Capacity—The capacity of the filer volume.

Free Space—The free capacity of the volume.

Committed Capacity—The committed capacity of the filer volume.

Space Reserved Type—The space reserved type for the flex volume.

Volume Type—The type of the volume, such as Flex, Clone, or Trad.

Viewing Aggregates Created by a Disk

To view the NAS Filer aggregates that are created by a disk, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  Disks.

4 Select a disk.

5 From the View drop-down list, select Aggregates.

Figure 2-124: Aggregates Created by a Disk
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Important to Know

Name—The name of the aggregate.

Status—The status of the aggregate, such as Healthy.

Capacity—The capacity of the aggregate, in gigabytes.

Free Space—The free capacity of the aggregate, in gigabytes.

Viewing Plexes on a Disk

To view the plexes that are on top of a disk in the storage supply chain, perform the 

following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  Disks.

4 Select a disk.

5 From the View drop-down list, select Plexes.

Figure 2-125: Plexes on a Disk
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Important to Know

Name—The name of the plex.

Status—The status of the filer plex.

Capacity—The capacity of the plex.

Viewing RAID Groups on a Disk

To view the RAID groups that are on top of a disk in the storage supply chain, perform the 

following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  Disks.

4 Select a disk.

5 From the View drop-down list, select RAID Groups.

Figure 2-126: RAID Groups on a Disk

Important to Know

Name—The name of the RAID group.
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Status—The status of the RAID group.

Capacity—The capacity of the RAID group.

Viewing Aggregates Configured in a NAS Filer

To view the aggregates that are configured in a NAS Filer, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  Aggregates.

4 From the View drop-down list, select Properties.

Figure 2-127: Aggregates Configured in a NAS Filer

Important to Know

Name—The name of the aggregate.

Status—The status of the filer aggregate.

Capacity—The capacity of the aggregate.

Free Space—The free space of the aggregate.
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Viewing Aggregate Properties

To view the properties of an aggregate, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  Aggregates.

4 From the View drop-down list, select Properties.

5 Select an aggregate.

Figure 2-128: Aggregates Configured in a NAS Filer

Important to Know

Name—The name of the aggregate.

Description—A brief description of the aggregate.

Status—The status of the Filer aggregate.

Capacity—The capacity of the aggregate.

Free Space—The free space of the aggregate.
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Viewing Filer Volumes Created by an Aggregate

To view the filer volumes that are created by an aggregate, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  Aggregates.

4 From the View drop-down list, select Volumes.

5 Select an aggregate.

Figure 2-129: Aggregates Configured in a NAS Filer

Important to Know

Name—The name of the aggregate.

Type—SIMPLE, MIRRORED, RAID0, RAID4, RAID_DP, or UNDEFINED.

Status—The status of the filer aggregate.

Capacity—The capacity of the aggregate.

Free Space—The free capacity of the aggregate.

Committed Capacity—The committed capacity of the aggregate.
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Space Reserved Type—The space reserved type for the aggregate.

Volume Type—The type of the volume, such as Flex, Clone, or Trad.

Viewing Antecedents and Dependents of an Aggregate

To view the antecedent and dependent of the aggregate storage supply chain, perform 

the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  Aggregates.

4 Select an aggregate.

5 From the View drop-down list, select Composition.

Figure 2-130: Antecedent and Dependent of an Aggregate

Important to Know

Name—The name of the antecedent or dependent storage resource.

Type—The type of the storage resource.

Device/Database—The type device or database that owns the storage resource.
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Relation—Downstream or Upstream, depending on the location in the supply chain.

Viewing Plexes Used by an Aggregate

To view the plexes that are used by an aggregate, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  Aggregates.

4 Select an aggregate.

5 From the View drop-down list, select Plexes.

Figure 2-131: Plexes Used by an Aggregate

Important to Know

Name—The name of the plex.

Status—The status of the Filer plex.

Capacity—The capacity of the plex, in gigabytes.

Free Space—The free space of the plex, in gigabytes.
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Viewing RAID Groups Consumed by an Aggregate

To view the RAID groups that are consumed by an aggregate, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  Aggregates.

4 Select an aggregate.

5 From the View drop-down list, select RAID Groups.

Figure 2-132: RAID Groups Consumed by an Aggregate

Important to Know

Name—The name of the RAID group.

Status—The status of the Filer RAID group.

Capacity—The capacity of the RAID group, in gigabytes.

Free Space—The free space of the RAID group, in gigabytes.
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Viewing Filer Volumes Configured in a NAS Filer

To view the Filer volumes that are configured in a NAS Filer, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  Volumes.

4 From the View drop-down list, select Properties.

Figure 2-133: Filer Volumes Configured in a NAS Filer

Important to Know

Name—The name of the Filer volume.

Type—SIMPLE, MIRRORED, RAID0, RAID4, RAID_DP, or UNDEFINED.

Status—The status of the Filer volume, such as OK or Healthy.

Capacity—The capacity of the Filer volume.

Free Space—The free space in the Filer volume.

Committed Capacity—The committed capacity of the filer volume.

Space Reserved Type—The space reserved type for the flex volume.
4
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Volume Type—The type of the volume, such as Flex, Clone, or Trad.

Viewing Filer Volume Properties

To view the properties of a Filer volume, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  Volumes.

4 From the View drop-down list, select Properties.

5 In the content pane, select a filer volume.

Figure 2-134: Filer Volume Properties

Important to Know

Name—The name of the filer volume.

Type—SIMPLE, MIRRORED, RAID0, RAID4, RAID_DP, or UNDEFINED.

Description—A brief description of the filer volume.

Status—The status of the filer volume.
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Capacity—The capacity of the filer volume.

Committed Capacity—The committed capacity of the filer volume.

Snapshot Reserved Percentage—The percentage of disk space that only 

snapshots can use. The filer cannot use the reserved space for the active file system.

Snapshot Reserve Size—The disk space that snapshots can use.

Space Reserved Type—The space reserved type for the flex volume.

Volume Type—The type of the volume, such as Flex, Clone, or Trad.

Viewing Antecedents and Dependents of a Volume

To view the antecedent and dependent of a volume storage supply chain, perform the 

following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  Volumes.

4 Select a volume.

5 From the View drop-down list, select Composition.
6
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Figure 2-135: Antecedents and Dependents of a Volume

Important to Know

Name—The name of the antecedent or dependent storage resource.

Type—The type of the storage resource.

Device/Database—The type device or database that owns the storage resource.

Relation—Downstream or Upstream, depending on the location in the supply chain.

Viewing Qtrees Created in a Volume

To view the Qtrees that are created in a volume, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  Volumes.

4 Select a volume.

5 From the View drop-down list, select Qtree.
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Figure 2-136: Qtrees Created in a Volume

Important to Know

Name—The name of the Qtree.

Security—The security options for the Qtree.

Oplock—The oplock for the Qtree.

Viewing Quota Created at the Volume or Qtree

To view the quota that is created at the volume or the Qtree for a volume, perform the 

following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  Volumes.

4 Select a volume.

5 From the View drop-down list, select Quota.
8
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Figure 2-137: Quota Created in a Volume or Qtree

Important to Know

Name—The name of the quota.

Type—The type of the quota, such as user, group, or Qtree.

Qtree—The name of the Qtree that is associated with this quota.

Space Threshold—The maximum number of bytes of disk space that can be used 

for this quota before a warning message is issued by the device.

Quota Target—The quota target of the type specified. Quota directives in /etc/

quotas are used to form the quota target. If there is an error in the quota entry, this 

value is not present.

Limit Type—The limit type, such as Disk Space or File.

Hard Limit—The hard limit of the quota. If the Limit Type is Disk Space, then this field 

specifies the maximum amount of disk space that the quota target can use. If the 

limit is File, then this field specifies the maximum number of files that the quota 

target can use. The value in this field represents a hard limit that cannot be 

exceeded.
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Soft Limit—The soft limit of the quota. Specifies the amount of disk space that the 

quota target can use before a warning is issued. If the limit is File, this field specifies 

the number of files that the quota target can use before a warning is issued.

A disk quota is a set of rules that restrict disk space and the number of files used by a 

user or a group. A quota can also restrict the total space and files used in a Qtree or the 

usage of users and groups within a Qtree. For example, you could create a user quota 

that specifies that a particular user can use up to 225MB of disk space in a given Qtree in 

a given volume before a warning is issued (soft limit) and up to 250MB maximum (hard 

limit).

Viewing LUN Volumes Created Inside a Volume

To view the LUN volumes that are created inside a volume (Qtree and directory), perform 

the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  Volumes.

4 Select a volume.

5 From the View drop-down list, select LUN Volumes.
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Figure 2-138: LUN Volumes Created Inside a Volume

Important to Know

Name—The name of the LUN volume.

Status—The status of the LUN volume.

Commitment—The commitment level of the volume, such as Reserved, LUN 

Mapped, Lun Mapped/Partitioned, and so on.

Capacity—The capacity of the volume.

Replication—Source indicates that the volume is the source for the replication pair. 

Target indicates that the volume is the target for the replication pair. Replication can 

also indicate both Source and Target. The status values for replication volumes 

include the following:

unitialized: If the volumes have a status of uninitialized, they are mapped to a 

sync state of Not Specified.

snapmirrored: If the volumes have a status of snapmirrored, they are mapped to a 

sync state of Synchronized.

broken-off: If the volumes have a status of broken-off, they are mapped to a sync 

state of Broken.
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quiesced: If the volumes have a status of quiesced, they are mapped to a sync 

state of Quiesced.

source: If the volumes have a status of source, they are mapped to a sync state of 

Not Specified.

unknown: If the volumes have a status of unknown, they then are mapped to sync 

state of Not Specified.

normal: The snapshot volumes that have a status of normal are mapped to a sync 

state of Frozen. A status of normal only applies to snapshot volumes. A status of 

normal does not apply to replication volumes.

Viewing Exports for a Volume

To view the exports for a volume, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  Volumes.

4 Select a volume.

5 In the View drop-down list, select Exports.

Figure 2-139: Exports for a Volume
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Important to Know

Name—The name of the Common Internet File System (CIFS) share or the Network 

File System (NFS) path. 

Device—For the CIFS, this is "-". For the NFS, this is the name of the managed server. 

If a Storage Host Agent Extension (SHA) is not installed, this is "-".

File System—For the CIFS, this is "-". For the NFS, this is File System. If a Storage 

Host Agent Extension (SHA) is not installed, this is "-". 

Mount Options—For the CIFS, this is "-". For the NFS, this is Mount Options. If a 

Storage Host Agent Extension (SHA) is not installed, this is "-". 

Description—For the CIFS, this is "-". For the NFS, this is File System Description. If a 

Storage Host Agent Extension (SHA) is not installed, this is "-".

Viewing LUN Volumes Configured in a Filer

To view the LUN volumes that are configured in a Filer, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  LUN Volumes.

4 From the View drop-down list, select Properties.
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Figure 2-140: LUN Volumes Configured in a Filer

Important to Know

Name—The name of the LUN Volume.

Status—The status of the LUN Volume.

Commitment—The commitment level of the volume, such as Reserved, LUN 

Mapped, Lun Mapped/Partitioned, and so on.

Capacity—The capacity of the volume.

Replication—Source indicates that the volume is the source for the replication pair. 

Target indicates that the volume is the target for the replication pair. Replication can 

also indicate both Source and Target. The status values for replication volumes 

include the following:

unitialized: If the volumes have a status of uninitialized, they are mapped to a 

sync state of Not Specified.

snapmirrored: If the volumes have a status of snapmirrored, they are mapped to a 

sync state of Synchronized.

broken-off: If the volumes have a status of broken-off, they are mapped to a sync 

state of Broken.
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quiesced: If the volumes have a status of quiesced, they are mapped to a sync 

state of Quiesced.

source: If the volumes have a status of source, they are mapped to a sync state of 

Not Specified.

unknown: If the volumes have a status of unknown, they then are mapped to sync 

state of Not Specified.

normal: The snapshot volumes that have a status of normal are mapped to a sync 

state of Frozen. A status of normal only applies to snapshot volumes. A status of 

normal does not apply to replication volumes.

Viewing LUN Volume Properties

To view the LUN volumes that are configured in a Filer, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  LUN Volumes.

4 Select a volume.

5 From the View drop-down list, select Properties.
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Figure 2-141: LUN Volume Properties

Important to Know

Name—The name of the LUN Volume.

Status—The status of the LUN volume.

Commitment—The commitment level of the volume, such as Reserved, LUN 

Mapped, LUN Mapped/Partitioned, and so on.

Capacity—The capacity of the volume.

Replication—Source indicates that the volume is the source for the replication pair. 

Target indicates that the volume is the target for the replication pair. Replication can 

also indicate both Source and Target. The status values for replication volumes 

include the following:

unitialized: If the volumes have a status of uninitialized, they are mapped to a 

sync state of Not Specified.

snapmirrored: If the volumes have a status of snapmirrored, they are mapped to a 

sync state of Synchronized.

broken-off: If the volumes have a status of broken-off, they are mapped to a sync 

state of Broken.
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quiesced: If the volumes have a status of quiesced, they are mapped to a sync 

state of Quiesced.

source: If the volumes have a status of source, they are mapped to a sync state of 

Not Specified.

unknown: If the volumes have a status of unknown, they then are mapped to sync 

state of Not Specified.

normal: The snapshot volumes that have a status of normal are mapped to a sync 

state of Frozen. A status of normal only applies to snapshot volumes. A status of 

normal does not apply to replication volumes.

Viewing LUN Volume Connectivity

To view the storage supply chain connectivity of a LUN volume, perform the following 

steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  LUN Volumes.

4 Select a LUN volume.

5 From the View drop-down list, select Connectivity.
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Figure 2-142: LUN Volume Connectivity

Important to Know

Root Node (Level 1)—The name of the LUN Volume.

Level 2 Nodes—NetApp Volume

Level 3 Nodes—NetApp Aggregate

Level 4 Nodes—NetApp Plexes

Level 5 Nodes—NetApp RAID Groups

Level 6 Nodes (Leaf Node)—NetApp Disks

Viewing Antecedents and Dependents of a LUN Volume

To view the antecedent and dependent of the LUN volume storage supply chain, perform 

the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  LUN Volumes.

4 Select a LUN volume.
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5 From the View drop-down list, select Composition.

Figure 2-143: LUN Volume Antecedents and Dependents

Important to Know

Name—The name of the antecedent and dependent storage resource.

Type—The type of the storage resource.

Device/Database—The device or the database associated with the storage 

resource.

Relation—Downstream or upstream depending on the location in the supply chain. 

Viewing Disks Consumed by a LUN Volume

To view that disks that are consumed by a LUN volume, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  LUN Volumes.

4 Select a LUN volume.

5 From the View drop-down list, select Disks.
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Figure 2-144: Disks Consumed by a LUN Volume

Important to Know

Name—The name of the disk.

Capacity—The capacity of the disk.

Free Space—The free capacity of the disk.

Status—The status of the disk, such as OK or Healthy.

Spare—Specifies whether the disk is a spare (Yes) or is not a spare (No).

Viewing the Access Path from a LUN Volume

To view the access path from a LUN volume, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  LUN Volumes.

4 Select a LUN volume.

5 From the View drop-down list, select Access Paths.
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Figure 2-145: Access Paths from a LUN Volume

Important to Know

Volume—The LUN Volume caption.

LUN—The Lun ID of the mapping.

Target Port—The SAN array port through which the volume was mapped to the 

initiator port.

Initiator Device—The name of the managed server to which storage is mapped from 

the SAN Array.

Initiator Port—A port from the managed server (Initiator Device).

Initiator Volume—The volume that is hosted by the servers. This is not specified ("-") 

if the Storage Host Agent Extension (SHA) is not installed, if you have not mounted 

the storage, or if the volume is unknown to HP.

Viewing Ports for a LUN Volume

To view ports for a LUN volume, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.
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2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  LUN Volumes.

4 From the View drop-down list, select Ports.

Figure 2-146: Ports for a LUN Volume

Important to Know

Name—The name of the LUN Volume.

Status—The status of the LUN volume.

Commitment—The commitment level of the volume.

Capacity—The capacity of the volume.

Replication—Source indicates that the volume is the source for the replication pair. 

Target indicates that the volume is the target for the replication pair. Replication can 

also indicate both Source and Target. The status values for replication volumes 

include the following:

unitialized: If the volumes have a status of uninitialized, they are mapped to a 

sync state of Not Specified.

snapmirrored: If the volumes have a status of snapmirrored, they are mapped to a 
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sync state of Synchronized.

broken-off: If the volumes have a status of broken-off, they are mapped to a sync 

state of Broken.

quiesced: If the volumes have a status of quiesced, they are mapped to a sync 

state of Quiesced.

source: If the volumes have a status of source, they are mapped to a sync state of 

Not Specified.

unknown: If the volumes have a status of unknown, they then are mapped to sync 

state of Not Specified.

normal: The snapshot volumes that have a status of normal are mapped to a sync 

state of Frozen. A status of normal only applies to snapshot volumes. A status of 

normal does not apply to replication volumes.

Viewing Ports Associated with a LUN Volume

To view ports associated with a LUN volume, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.

3 In the Views pane, select Inventory ➤ Storage ➤  LUN Volumes.

4 From the View drop-down list, select Ports.

5 Select a volume to display port information in the lower pane.
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Figure 2-147: Ports Associated with a LUN Volume

Important to Know

Name—The name of the storage port.

WWN—The World Wide Name of the FCA port.

Number—The position of the port on the controller.

Controller—The name of the controller this port resides on.

Fabric—The fabric this port is registered with.

FCID—The Fibre Channel ID of the connected switch port.

State—The status of the port, such as Online, Offline, NoModule, and Unknown.

Viewing Replicated Storage Devices

To view the storage devices that are replicated, perform the following steps:

1 From the Navigation pane, select Devices ➤  Storage ➤  NAS Filers.

2 In the content pane, select a NAS Filer and then open it.
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3 In the Views pane, select Inventory ➤ Storage ➤  Replication.

Figure 2-148: Storage Devices that are Replicated

Important to Know

Source Device—The source filer of the replication.

Source Volume—The source storage resource of the replication.

Target Device—The target filer of the replication.

Target Volume—The target storage resource of the replication.

Copy Type—The copy type of the replication.

Replica Type—The replica type of the replication.

Status—The status of the replication.
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Oracle Database Assets 

This feature provides visibility into the Oracle storage configurations in a SAN or Network 

Attached Storage (NAS). These configurations include physical entities, such as fabric 

switches and SAN Arrays.

A database administrator can view the following:

• Oracle database storage configuration

• System resources available to the Oracle databases in one or more servers in a data 

center

• Servers and SAN Storage devices connected to the FC network

• Storage resources shared between Oracle Instances and/or hosts

• Network Attached Storage (NAS) resources that the Oracle Databases depends on

ASAS captures the following Oracle database storage configuration in a SAN or NAS:

Oracle Instance—Storage-related information for the Oracle Instance. ASAS discovers the 

version of the Oracle database that is running the Oracle instance.

Storage Elements—Storage elements configured for an Oracle instance can be 

classified as physical database storage and logical database storage. Physical database 

storage includes data files and redo logs that directly consume system storage resources, 

such as file systems and partitions. Logical database storage includes entities such as 

tablespaces that are created inside the instance that is consuming different physical and 

logical storage entities.

Data Files —The file path, allocated space, and space used for each data file. Oracle 

data files can reside directly on the file system or they can utilize raw partitions.

• Based on File System—Data files can be created directly in a file system and 

specified to the Oracle database. ASAS discovers information on the file path of the 

data file. HP uses this information to calculate the file system that is consumed by the 

data file.

• Based on Symbolic Link—You can configure data files using symbolic links. HP 

resolves the symbolic link and provides the absolute resolved location of the data 

files for the Oracle instance. HP uses this resolved path to calculate the file system 

that is consumed by the data file.
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To discover and resolve symbolic links, the Oracle Agent must be installed on each 

Oracle instance. To run the Oracle Agent, Java must be enabled in each Oracle 

Instance.

• Based on Raw Partition—ASAS discovers partition information. HP uses this 

information to calculate the storage supply chain that is consumed by the data file.

Redo Logs—Redo logs information for the Oracle instance, such as file path and 

allocated space for the redo log.

Logical Database Storage—Storage-related information for the tablespace and its 

association to the physical storage entities. ASAS does not discover storage entities, such 

as data segments, extents, data block, schema, table, and index.

Tablespaces —ASAS discovers tablespace information for each Oracle instance, 

such as the status, allocated space, and space used for each of the tablespaces.

Database Assets and Relationships

ASAS captures relationships between the database elements and other storage asset 

discovery features. See Table 2-14.

Table 2-14: Database Assets and Relationships

DATABASE ASSET EXTERNAL ELEMENT DESCRIPTION

SAN-based physical 

database storage

Block storage dependency Provides the dependency chain 

between the database storage 

elements and SAN arrays through 

System (server) resources and 

fabric.

NAS-based physical 

database storage

NAS storage dependency Provides the dependency chain 

between the database storage 

elements, Server resources and 

NetApp.
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Frequently Asked Questions

Table 2-15 answers some frequently asked questions on finding information about Oracle 

database assets.

Table 2-15: Frequently Asked Questions About Database Assets

QUESTION HOW TO FIND THE ANSWER

1. What are the storage resources used by an 

Oracle instance?

• “Viewing Tablespaces Configured in the 

Oracle Instance” on page 253

• “Viewing Tablespace Antecedents and 

Dependents” on page 255

• “Viewing Storage Supply Chain 

Connectivity of the Tablespace” on 

page 257

2. What is the FC SAN network configuration that 

an Oracle database depends on?

• “Viewing Storage Supply Chain 

Connectivity of the Tablespace” on 

page 257

3. Are critical Oracle instances configured for high 

availability, such as multiple access paths? What 

are the redundant paths between a server and a 

storage array for an Oracle instance?

• “Viewing Storage Supply Chain 

Connectivity of the Tablespace” on 

page 257

• “SAN Map” on page 291

• “Storage Map” on page 292

4. What is the storage utilization of an Oracle 

instance?

• “Viewing Properties of the Oracle Instance” 

on page 252

5. Is Oracle-consumed storage on a remote SAN 

array configured for replication?

• “Viewing Replicated Storage Devices” on 

page 140

• “Viewing Storage Supply Chain 

Connectivity of the Tablespace” on 

page 257

• “Viewing Utilized Targets” on page 270
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Viewing Databases

To view databases discovered by the Storage Agent, perform the following steps:

1 From the Navigation pane, select Library ➤ Databases.

2 In the View drop-down list, select Properties.

6. What is causing Oracle instance performance 

degradation? How is all of the SAN configuration 

impacting the Oracle instance? What are the 

shared resources between Oracle instances?

• “Viewing Storage Volumes with Access 

Paths for Remote Initiators” on page 109

• “Viewing Volumes of a Disk” on page 125

• “Viewing the Access Path from the Disk” on 

page 126

• “Viewing the Access Path from the Volume” 

on page 134

• “Viewing Storage Initiators” on page 167

• “Viewing the Access Path from a LUN 

Volume” on page 240

• “Viewing Storage Supply Chain 

Connectivity of the Tablespace” on 

page 257

7. Does the SAN provide room for growth? • “Viewing Storage Supply Chain 

Connectivity of the Tablespace” on 

page 257

• “Viewing Utilized Fabrics” on page 267

• “Viewing Utilized Switches” on page 268

• “Viewing Utilized Targets” on page 270

8. What are the NAS (Network Attached Storage) 

resources used by an Oracle instance?

• “Viewing Storage Supply Chain 

Connectivity of the Tablespace” on 

page 257

• “Viewing Utilized Targets” on page 270

Table 2-15: Frequently Asked Questions About Database Assets (continued)

QUESTION HOW TO FIND THE ANSWER
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3 In the content pane, select the database. The content pane displays a list of 

databases.

4 (Optional) Select a target and then select one of the following options from the 

Actions menu:

• Open—Opens the Database Browser with the selected view.

• Rename (F2)—Provides an editable field to rename the database directly in the 

table. The command is enabled only if the user has permissions.

• Delete—Removes the database from the Model Repository. The command is 

enabled only if the user has permissions. The command does not remove the 

access control or deactivate the Storage Agents.

Figure 2-149: Databases

Important to Know

Name—The name of the Oracle instance as discovered by the Storage Agent. If you 

have the required permission, you can edit the name.

Manufacturer—The name of the manufacturer of the database software. 

Version—The version of the Oracle database.
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Server—The IP address of the server that is hosting the Oracle instance.

Status—The status of the database.

Viewing Database Storage Configurations

To view database storage configurations, perform the following steps:

1 From the Navigation pane, select Library ➤ Databases.

2 In the View drop-down list, select Properties.

3 In the content pane, select the database and then open it.

4 In the Views pane, select Inventory ➤ Redologs. The content pane displays the 

information.

5 (Optional) Select a target and then select the following option from the Actions 

menu:

Right-click—Depends on the view with which the browser is opened. Please refer 

to the appropriate view section.

Figure 2-150: Database Storage Configurations
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Important to Know

Name—The name of the Oracle instance as discovered by the Storage Agent. If you 

have the required permission, you can edit the name.

Manufacturer—The name of the manufacturer of the database. 

Version—The version of the Oracle database.

Server—The IP address of the server that is hosting the Oracle instance.

Status—The status of the database.

Viewing Properties of the Oracle Instance

To view the properties of the Oracle instance, perform the following steps:

1 From the Navigation pane, select Library ➤ Databases.

2 In the View drop-down list, select Properties.

3 In the content pane, select the database and then open it. The content pane displays 

the properties of the selected database.

Figure 2-151: Database Properties
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Commands

File ➤ Save—Enabled when the name or description is edited. Saves the changes to the

system.

File ➤  Revert—Enabled when the name or description is edited. Reverts the changes.

Important to Know

Name—The name of the Oracle instance as discovered by the Storage Agent. If you 

have the required permission, you can edit the name.

Description—The description of the Oracle instance as assigned by the Oracle 

Storage Agent. If you have the required permission, you can edit this information.

Manufacturer—The name of the manufacturer of the database software. 

Version—The version of the Oracle database.

Managed Server—The managed server where the Oracle Storage Agent is installed.

Status—The status of the database.

Opsware ID—The primary key associated with the database instance in the Model 

Repository. 

Viewing Tablespaces Configured in the Oracle Instance

To view tablespaces configured in the Oracle instance, perform the following steps:

1 From the Navigation pane, select Library ➤ Databases.

2 In the View drop-down list, select Properties.

3 In the content pane, select the database and then open it.

4 From the Navigation pane, select Inventory.

5 From the Views pane, select ➤ Tablespaces. The content pane displays a list of 

tablespaces.
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Figure 2-152: Tablespaces Configured in the Oracle Instance

Important to Know

Name—The name of the tablespace.

Capacity—The capacity of the tablespace. 

Free Space—The free capacity of the tablespace. 

Status—The status of the tablespace.

Viewing Tablespace Properties

To view tablespace properties, perform the following steps:

1 From the Navigation pane, select Library ➤ Databases.

2 In the View drop-down list, select Properties.

3 In the content pane, select the database and then open it.

4 From the Navigation pane, select Inventory.

5 From the Views pane, select ➤ Tablespaces.
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6 In the content pane, select a tablespace and then review the lower part of the 

content pane for the properties.

Figure 2-153: Tablespace Properties

Important to Know

Name—The name of the tablespace.

Description—The description of the Oracle instance as assigned by the Oracle 

Storage Agent.

Capacity—The capacity of the tablespace. 

Free Space—The free capacity of the tablespace. 

Status—The status of the tablespace.

Viewing Tablespace Antecedents and Dependents

To view antecedents and dependents of a tablespace, perform the following steps:

1 From the Navigation pane, select Library ➤ Databases.

2 In the View drop-down list, select Properties.

3 In the content pane, select the database and then open it.
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4 In the View command, select Inventory ➤ Tablespaces.

5 In the content pane, select a tablespace and then review the lower part of the 

content pane.

6 In the View drop-down list, select Composition. The content pane displays the 

composition.

7 (Optional) Select a target and then select the following option from the Actions 

menu:

• Open—Opens the SAN array.Storage, Server.Storage, or NAS filer.Storage view.

Figure 2-154: Storage Supply Chain Composition

Important to Know

Name—The name of the antecedent and dependent storage resource.

Type—The type of the storage resource. 

Device/Database—The device or database associated with the storage resource. 

Relation—Downstream or upstream depending on the location in the storage supply 

chain.
6
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Viewing Storage Supply Chain Connectivity of the Tablespace

To view the connectivity of the database storage element, perform the following steps:

1 From the Navigation pane, select Library ➤ Databases.

2 In the View drop-down list, select Properties.

3 In the content pane, select the database and then open it.

4 In the Views pane, select Inventory ➤ Tablespaces.

5 In the content pane, select a tablespace and then review the lower part of the 

content pane.

6 In the View drop-down list, select Connectivity. The content pane displays the 

connectivity.

Figure 2-155: Storage Supply Chain Connectivity

Important to Know

Root Node (Level 1)—The database storage element.

Viewing Redo Logs

To view the redo logs, perform the following steps:
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1 From the Navigation pane, select Library ➤ Databases.

2 In the View drop-down list, select Properties.

3 In the content pane, select the database and then open it.

4 In the Views pane, select Inventory ➤ Redologs. The content pane displays the 

information.

Figure 2-156: Redo Logs

Important to Know

Name—The name of the redo log.

Path—The file system path consumed by the redo log.

Capacity—The capacity of the redo log. 

Free Space—The free capacity of the redo log. 

Status—The status of the redo log.

Viewing Redo Log Properties

To view properties of a redo log, perform the following steps:
8
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1 From the Navigation pane, select Library ➤ Databases.

2 In the View drop-down list, select Properties.

3 In the content pane, select the database and then open it.

4 In the Views pane, select Inventory ➤ Redologs.

5 In the content pane, select a redo log and then review the lower part of the content 

pane for the properties.

Figure 2-157: Properties of a Redo Log

Important to Know

Name—The name of the redo log.

Description—The description of the redo log as assigned by the Storage Agent.

Path—The file system path consumed by the redo log.

Capacity—The capacity of the redo log. 

Free Space—The free capacity of the redo log. 

Status—The status of the redo log.
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Viewing Redologs Antecedents and Dependents

To view the composition of the redo logs, perform the following steps:

1 From the Navigation pane, select Library ➤ Databases.

2 In the View drop-down list, select Properties.

3 In the content pane, select the database and then open it.

4 In the Views pane, select Inventory ➤ Redologs.

5 In the View drop-down list, select Composition.

6 In the content pane, select a redo log and then review the lower part of the content 

pane for the composition.

7 (Optional) Select a target and then select the following option from the Actions 

menu:

• Open—Opens the SAN array.Storage, Server.Storage, or NAS filer.Storage view.

Figure 2-158: Composition of a Redo Log

Important to Know

Name—The name of the antecedent and dependent storage resource.
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Type—The type of the storage resource.

Device/Database—The device or the database associated with the storage 

resource.

Relation—Downstream or upstream depending on the location in the supply chain. 

Viewing Redologs Connectivity

To view the connectivity of the database storage element, perform the following steps:

1 From the Navigation pane, select Library ➤ Databases.

2 In the View drop-down list, select Properties.

3 In the content pane, select the database and then open it.

4 In the Views pane, select Inventory ➤ Redologs.

5 In the content pane, select a redolog and then review the lower part of the content 

pane.

6 In the View drop-down list, select Connectivity. The content pane displays the 

connectivity.

Figure 2-159: Storage Supply Chain Connectivity of a Redolog
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Important to Know

Root Node (Level 1)—The database storage element.

Viewing Datafiles

To view the datafiles, perform the following steps:

1 From the Navigation pane, select Library ➤ Databases.

2 In the View drop-down list, select Properties.

3 In the content pane, select the database and then open it.

4 In the Views pane, select Inventory ➤  Datafiles. The content pane displays a list of 

datafiles.

Figure 2-160: Datafiles

Important to Know

Name—The name of the datafile.

Path—The file system path consumed by the datafile.

Capacity—The capacity of the datafile. 

Free Space—The free space of the datafile. 
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Status—The status of the datafile.

Viewing Datafile Properties

To view the properties of a datafile, perform the following steps:

1 From the Navigation pane, select Library ➤ Databases.

2 In the View drop-down list, select Properties.

3 In the content pane, select the database and then open it.

4 In the Views pane, select Inventory ➤ Datafiles.

5 In the View drop-down list, select Properties. The content pane displays the 

properties.

6 In the content pane, select a datafile and then review the lower part of the content 

pane.

Figure 2-161: Datafile Properties

Important to Know

Name—The name of the datafile.

Description—The description of the datafile as assigned by the Storage Agent.
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Path—The file system path consumed by the datafile.

Capacity—The capacity of the datafile. 

Free Space—The free space of the datafile. 

Status—The status of the datafile.

Viewing Datafile Antecedents and Dependents

To view the composition of the datafiles, perform the following steps:

1 From the Navigation pane, select Library ➤ Databases.

2 In the View drop-down list, select Properties.

3 In the content pane, select the database and then open it.

4 In the Views pane, select Inventory ➤ Datafiles.

5 In the View drop-down list, select Composition.

6 In the content pane, select a datafile and then review the lower part of the content 

pane for the composition.

7 (Optional) Select a target and then select the following option from the Actions 

menu:

• Open—Opens the SAN array.Storage, Server.Storage, or NAS filer.Storage view.
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Figure 2-162: Composition of a Datafile

Important to Know

Name—The name of the antecedent and dependent storage resource.

Type—The type of the storage resource.

Device/Database—The device or the database associated with the storage 

resource.

Relation—Downstream or upstream depending on the location in the supply chain. 

Viewing Datafile Connectivity

To view the connectivity of the database storage element, perform the following steps:

1 From the Navigation pane, select Library ➤ Databases.

2 In the View drop-down list, select Properties.

3 In the content pane, select the database and then open it.

4 In the Views pane, select Inventory ➤ Datafiles.

5 In the content pane, select a datafile and then review the lower part of the content 

pane.
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6 In the View drop-down list, select Connectivity. The content pane displays the 

connectivity.

Figure 2-163: Storage Supply Chain Connectivity of a Datafile

Important to Know

Root Node (Level 1)—The database storage element.

Viewing Servers Hosting a Database

To view servers hosting a database, perform the following steps:

1 From the Navigation pane, select Library ➤ Databases.

2 In the View drop-down list, select Properties.

3 In the content pane, select the database and then open it.

4 In the Views pane, select Relationships ➤ Severs. The content pane displays a list 

of servers.

5 (Optional) Select a target and then select one of the following options from the 

Actions menu:

• Open—Opens the Server Browser.
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Figure 2-164: Servers Hosting a Database 

Important to Know

Name—The name of the server.

IP Address—The IP address of the server.

Customer—The customer assigned to the server.

Facility—The facility assigned to the server. 

The column in this panel is the same as the main panel for the server rendered in the All 

Managed Servers feature. All columns are not described above.

Viewing Utilized Fabrics

To view utilized fabrics, perform the following steps:

1 From the Navigation pane, select Library ➤ Databases.

2 In the View drop-down list, select Properties.

3 In the content pane, select the database and then open it.
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4 In the Views pane, select Relationships ➤  SAN Fabrics. The content pane displays 

a list of fabrics.

5 (Optional) Select a target and then select the following option from the Actions 

menu:

• Open—Opens the Fabric Browser.

Figure 2-165: Utilized Fabrics

Important to Know

Name—The name of the fabric.

Description—The description of the fabric.

Viewing Utilized Switches

To view utilized switches, perform the following steps:

1 From the Navigation pane, select Library ➤ Databases.

2 In the View drop-down list, select Properties.

3 In the content pane, select the database and then open it.
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4 In the Views pane, select Relationships ➤  SAN Switches. The content pane 

displays a list of switches.

5 (Optional) Select a target and then select the following option from the Actions 

menu:

• Open—Opens the Switch Browser.

Figure 2-166: Utilized Switches 

Important to Know

Name—The name of the switch.

Manufacturer—The manufacturer of the switch.

Model—The model of the switch.

Firmware Version—The firmware version of the switch.

IP Address—The IP address of the switch

Customer—The customer of the switch.

Facility—The facility of the switch. 

Status—The status of the switch. 
269



User’s Guide

27
# of Ports —The number of ports on the switch.

Opsware ID—The ID of the switch as assigned by HP SA.

Virtual—Indicates whether the switch is virtual or not.

The column in this panel is the same as the main panel for the switch rendered in the 

SAN Switches feature. All columns are not described above.

Viewing Utilized Targets

To view utilized targets, perform the following steps:

1 From the Navigation pane, select Library ➤ Databases.

2 In the View drop-down list, select Properties.

3 In the content pane, select the database and then open it.

4 In the Views pane, select Relationships ➤  SAN Arrays. The content pane displays 

a list of targets.

5 (Optional) Select a target and then select one of the following options from the 

Actions menu:

• Open—Opens the SAN Array Browser.
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Figure 2-167: Targets Attached to a Server 

Important to Know

Name—The name of the target device.

Manufacturer—The manufacturer of the target device.

Model—The model of the array.

Serial Number—The serial number of the array.

Firmware Version—The firmware version of the array.

Customer—The customer of the target device.

Facility—The facility of the target device. 

Status—The status of the target device. 

The column in this panel is the same as the main panel for the arrays rendered in the SAN 

Array feature. All columns are not described above.
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Viewing the Database History Log

To view the history log, perform the following steps:

1 From the Navigation pane, select Library ➤ Databases.

2 In the View drop-down list, select History.

3 In the content pane, select the database and then open it. The content pane displays 

the history log.

4 (Optional) Select a target and then select the following option from the Actions 

menu:

• View Event Details—Displays the detailed information for the event.

Figure 2-168: Database History Log

Device Group Assets 

The Device Groups feature in ASAS provides a useful way for gathering storage devices 

into collections. Grouping storage devices enables you to view all of the devices 

simultaneously, instead of viewing individual devices, one at a time.
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This feature allows you to include storage devices in a device group and view a history of 

events for a device group. You can view detailed storage device history, such as 

information in snapshot messages from the synchronization process. Device groups and 

a history log can help you troubleshoot problems.

The Device Groups feature in ASAS is modeled after the Device Groups feature in SA. For 

more information, see the SA User’s Guide: Server Automation.

You can create the following types of storage device groups:

• Static Device Group—This group contains heterogeneous storage devices, such as 

any combination of servers, storage arrays, storage switches, and NetApp filers.

• Dynamic Device Group—This group contains only a homogeneous set of storage 

devices, such as servers, storage systems (SAN Arrays and NAS filers), or SAN 

switches. A dynamic device group contains only one type of storage device because 

it is generated based on device properties. A dynamic device group cannot contain a 

combination of different types of storage devices.

For information about adding a server to a static or dynamic device group, see the SA 

User’s Guide: Server Automation.

Static Device Groups 

Static storage device groups can contain heterogeneous devices—one or more SAN 

arrays, SAN switches, NAS filers, and managed servers.

Creating a Static Device Group

To create a static device group, perform the following steps:

1 From the Navigation pane, select Device Groups ➤ Public.
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2 From the Actions menu, select Device Group ➤ New Static Group.

Figure 2-169: Creating a New Static Device Group
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3 Enter a new name for the static device group that you just created. Click outside the 

name field to save it. The default name is New Device Group.

Figure 2-170: Naming the New Static Device Group

Adding a Device to a Static Device Group

To add a storage device to a static device group, perform the following steps:

1 In the Device Group Browser, select the device group.

2 From the Actions menu, select Open to display the Group Browser.

3 In the Views pane, select Device Membership.

Figure 2-171: Adding Storage Devices to a Static Group
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4 In the Device Membership window, from the Actions menu, select Add.

Figure 2-172: Add Members to Static Group Dialog

5 In the Add Members to Static Group dialog, select one or more members, such as 

such as any combination of servers, storage arrays, storage switches, and NetApp 

filers.

6 Click Add to Group.

Removing a Device from a Static Device Group

To remove a storage device from a static device group, perform the following steps:

1 In the Static Device Group window, select one or more storage devices.

2 From the Actions menu, select Remove Members.

Figure 2-173: Removing a Storage Device from a Static Device Group
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Dynamic Device Groups 

Dynamic storage device groups can contain only homogeneous devices—one or more 

storage systems (SAN arrays and NAS filers), SAN switches, and managed servers.

Creating a Dynamic Device Group

To create a dynamic device group, perform the following steps:

1 From the Navigation pane, select Device Groups ➤ Public.

2 From the Actions menu, select Device Group ➤ New Dynamic Group

Figure 2-174: Creating a New Dynamic Device Group
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3 Enter a new name for the dynamic device group that you just created.

4 Press enter to save it. The default name is New Device Group plus an incremental 

number, such as New Device Group 4.

Figure 2-175: Naming the New Dynamic Device Group

Adding a Device to a Dynamic Device Group

To add a storage device to a dynamic device group, perform the following steps:

1 In the Device Group Browser, select the device group.

2 From the Actions menu, select Open to display the Group Browser.
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3 In the Views pane, select Device Membership. In the Content pane, specify the rules 

for the dynamic storage device group, as shown in Figure 2-176.

Figure 2-176: Defining Rules for a Dynamic Device Group

4 From the first drop-down list, select Server, Storage Systems, or SAN Switch. 

Depending on the attribute you select, options available for the operator and values 

for the rule will change. The default is Storage Systems.

5 From the second drop-down, select Facility Name, Manufacturer, Model, Name, 

Opsware ID, Port, RAID Type, or Serial Number. The default is Manufacturer.

6 Select the operator from the third drop-down list. The default is Contains.

7 Enter a value in the field, or select a value from the drop-down list, or click  to 

select multiple values from the Select Values window. 

8 Click  to add additional rules and repeat steps 4 through 6. Click  to delete any 

rules.

9 Select the logic (And/Or) to be applied for every rule in the query. 
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10 Click Preview to view the storage devices that matched the rule—the rule that 

defines members of the dynamic device group.

Figure 2-177: Dynamic Device Group Members

11 From the File menu, click Save to save the rules. 

Editing a Rule for a Dynamic Device Group

To change a rule for a dynamic device group, perform the following steps:

1 Open the Group Browser and then select a dynamic device group.

2 From the Device Membership window, change the rule and then save it.

Device History Log

A history of events for a storage device group can help you troubleshoot problems.

Viewing the History Log

To view the history log for a device group, perform the following steps:

1 Open a storage device group.

2 From the Views pane, select History.

3 From the View drop-down list, select the time period for the history log.

4 (Optional) Right-click an event to open the Event Details dialog.
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5 (Optional) Click Export to export the history log to a file, such as .csv or .html.

Figure 2-178: History Log

Important to Know

Date—The date and time of when the event occurred.

Event—The type of event.

User—The user who performed the event.

Status—The status of the event, such as Completed.
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Chapter 3: Storage Compliance

Overview of Storage Compliance
Storage compliance provides storage administrators and server administrators the ability 

to audit storage infrastructure to identify any potential issues. A storage administrator 

typically needs to audit the infrastructure to identify the potential for problems or issues 

before they have a chance of affecting an internal customer (business owner, application, 

or server). A server administrator typically needs to make sure the storage provided meets 

certain Service Level Agreements (SLAs) for reliability and performance. From a 

compliance perspective, provided storage information would also help auditors, 

compliance officers, and managers, when applied globally to classes of servers or 

applications.

Because storage administrators and server administrators generally share a common goal 

of ensuring consistency with the unique software stack that has been approved and 

tested by an organization, they need to monitor firmware and other software compliance. 

A storage administrator needs to confirm the right firmware levels. A server administrator 

needs to make sure the HBAs, volume managers, MPIOs, and so on, are the correct 

versions. The shared end-goal is a standardized environment where interoperability 

between all moving parts is much more reliable.

I N  T H I S  C H A P T E R

This section discusses the following topics: 

• Overview of Storage Compliance

• Compliance View

• SA Client Integration

• Audit Rules and Parameters
283



User’s Guide

28
SA Client Integration
Storage compliance in ASAS is integrated with the Audit and Remediation feature in the 

SA Client. To implement storage compliance, you must be familiar with the basics of SA 

Audit and Remediation. See the SA User’s Guide: Application Automation for information 

about using the following Audit and Remediation capabilities:

• Compliance View

• Configuring a storage audit

• Configuring specific rules

• Selecting target servers

• Configuring a snapshot specification

• Running and scheduling an audit

• Viewing audit results

• Deleting an audit

Compliance View
To help troubleshoot problems, the Compliance View allows you to view storage 

compliance for managed servers in a facility. In the Compliance View, you can navigate to 

a managed server to view the audits you created and see whether the server is 

compliant. Figure 3-1 shows storage compliance information for a managed server.
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For more information about the Compliance View, see the SA User’s Guide: Application 

Automation.

Figure 3-1: Compliance View for Storage Audits

Audit Rules and Parameters
The storage compliance feature provides visibility into storage configurations in a 

managed server or device group by allowing you to specify audit rules that check initiator 

ports connected to multiple ports, FCAs, and switches, LUNs available but not mounted, 

RAID levels, SAN storage, and so on.

Storage audit rules are run against data in the Model Repository.
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Table 3-1 lists the audit rules and parameters for storage compliance. These rules allow 

you to define the check for minimum, maximum, or exact numbers.

Table 3-1: Storage Audit Rules and Parameters

AUDIT RULE PARAMETER

Unmounted Volume Capacity Acceptable total capacity of unmounted volumes in 

bytes

Unmounted Volume Count Acceptable number of unmounted volumes

Fabrics Acceptable number of fabrics

FCA Acceptable number of Fibre Channel Adapters (FCAs)

Initiator Ports Acceptable number of ports

Switches Acceptable number of switches

Target Ports Acceptable number of ports

RAID Type Acceptable RAID types on the target storage array

Note: The audit will fail if this rule is selected and no 

RAID type is specified.

Unreplicated LUN Count Acceptable number of unreplicated LUNs

Note: SA identifies whether a LUN (remote storage vol-

ume) is replicated only for supported replication 

software.
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Audit Browser

Figure 3-2 shows storage rules selected in an audit. For information about specifying rule 

details, see the SA User’s Guide: Application Automation.

Figure 3-2: Audit Browser for Storage Rules
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Select Server

Figure 3-3 shows how you specify which servers are used as targets in the audit. See the 

SA User’s Guide: Application Automation for information about adding audit targets.

Figure 3-3: Target Server for a Storage Audit
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Audit Schedule

Figure 3-4 shows how to schedule an audit. See the SA User’s Guide: Application 

Automation for information about scheduling audits.

Figure 3-4: Schedule for a Storage Audit
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Chapter 4: Storage Visualization

Overview of Service Automation Visualizer
The Service Automation Visualizer (SAV) feature in Server Automation (SA) allows you to 

visualize logical storage dependencies and physical storage connections in your data 

center. SAV displays how these dependencies and connections relate to your business 

applications in mapping diagrams. These diagrams map out the storage supply chain 

from servers to spindles—how servers map to the storage devices they are connected to. 

SAV diagrams also show file systems and their relationships to local and remote storage, 

FC adapters, FC switches (physical and virtual), connections and ports, disk arrays, NAS 

filers, LUN mappings, RAID configurations, SAN fabrics, and so on.

For more information about SAV, see the SA User’s Guide: Application Automation.

Storage Mapping Features
SAV provides visual maps that display physical and logical drawings of storage devices 

and connections in your environment—in a Storage Map and a SAN map.

SAN Map

The SAN map shows a superset of the Storage Map, including a graphical view of the 

SAN involved in a SAV snapshot, all servers and their FCAs (including fibre channel ports), 

and each adapter’s connections to switches in the SAN. For more information, see the SA 

User’s Guide: Application Automation.

I N  T H I S  C H A P T E R

This section discusses the following topics: 

• Overview of Service Automation Visualizer

• Storage Mapping Features
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Storage Map

The Storage Map displays storage dependencies for servers, FCAs, NAS filers, SAN 

arrays, fabrics, switches, ports, and so on, that you have scanned with SAV. This map 

provides a graphical view that displays servers, the process families running on them, 

including the file systems and local or remote storage devices these files are stored on 

and served from, either through local disks, NAS filers, or remote disk arrays. The map 

shows connections between process families and their open files and where the files are 

stored. For more information, see the SA User’s Guide: Application Automation.
2



Chapter 5: Storage Reports

Overview of Storage Reports
Storage reports provide comprehensive, real-time information about storage 

configurations in managed servers, and storage hardware and software in your 

environment. You can use these reports to help determine when an application will run 

out of storage, what the storage trend is for an application, and so on.

These parameterized reports are presented in graphical and tabular format, and are 

actionable—which means that you can perform appropriate actions on objects, such as a 

policy or an audit, within the report. These reports are also exportable to your local file 

system (as .html and .xls files) to facilitate use within your organization.

Storage reports are organized by the following folders:

• Reports ➤ Storage Reports ➤  Database Storage Reports

• Reports ➤ Storage Reports ➤  Host and Application Storage Reports

• Reports ➤ Storage Reports ➤  Storage Array Reports

• Reports ➤ Storage Reports ➤  Storage Switch and Fabric Reports

Storage reports are available only for managed servers that have a Storage Host Agent 

Extension (SHA) installed and running. For more information, see the ASAS Installation & 

Administration Guide.

I N  T H I S  C H A P T E R

This section discusses the following topics: 

• Overview of Storage Reports

• Service Automation Reporter Client Integration

• Database Storage Reports
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Service Automation Reporter Client Integration
The reports feature in ASAS is integrated with the reports feature in the Service 

Automation Reporter (SAR) Client. To use storage reports, you must be familiar with the 

basic capabilities of SAR reports. See the SAR User’s Guide for information about using 

the following report capabilities:

• Report formats

• Running a report

• Scheduling a report

• Exporting a report

• Printing a report

Database Storage Reports
Table 5-1 describes the database storage reports available in ASAS.

Table 5-1: Database Storage Reports

REPORT TITLE DESCRIPTION

Database Allocation Trend This report shows how allocated and used capacity 

for a set of databases has changed over time and 

is projected to change in the future.

Database Capacity and Utilization Trend Data This report shows how usage information for a set 

of databases has changed over time and is 

projected to change in the future.

Database Utilization Trend This report shows how usage information for a set 

of databases has changed over time and is 

projected to change in the future.

Tablespace Allocation Trend This report shows how allocated and used capacity 

for one or more tablespaces across one or more 

databases has changed over time and is projected 

to change in the future.

Tablespace Capacity and Utilization Overview This report lists tablespaces and their capacity and 

utilization information, grouped by database.
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Host and Application Storage Reports
Table 5-2 describes the host and application storage reports available in ASAS.

Tablespace Capacity and Utilization Trend Data This report shows how usage information for one or 

more databases, or for one or more tablespaces 

has changed over time and is projected to change 

in the future.

Tablespace Utilization Trend This report shows how usage information for one or 

more tablespaces across one or more databases 

has changed over time and is projected to change 

in the future.

Table 5-1: Database Storage Reports (continued)

REPORT TITLE DESCRIPTION

Table 5-2: Host and Application Storage Reports

REPORT TITLE DESCRIPTION

Host Available Capacity Overview This report identifies the amount of available 

storage of various types for a set of hosts.

Host Capacity and Utilization Overview This report shows detailed capacity and utilization 

information for multiple hosts that are potentially 

grouped by customer, facility or device group.

Host Capacity and Utilization Trend Data This report shows detailed capacity and utilization 

trend data for a collection of hosts that are grouped 

by customer, facility or device group.

Host DB Storage Allocation Trend This report shows how allocated and used 

database storage for a set of hosts (grouped by 

customer, facility or device group) has changed 

over time and is projected to change in the future.

Host DB Storage Utilization Trend This report shows how the database storage 

utilization rate for a set of hosts (grouped by 

customer, facility or device group) has changed 

over time and is projected to change in the future.
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Host File System Storage Allocation Trend This report shows how allocated and used file 

system storage for a set of hosts (grouped by 

customer, facility or device group) has changed 

over time and is projected to change in the future.

Host File System Storage Utilization Trend This report shows how the file system storage 

utilization rate for a set of hosts (grouped by 

customer, facility or device group) has changed 

over time and is projected to change in the future.

Host Reclaimable Storage Overview This report shows the amount of readily reclaimed 

storage of various types for a set of hosts.

Host Storage Detail This report shows a detailed inventory of all 

storage-related information related to a specific 

host.

Host Total Storage Allocation Trend This report shows how total allocated and used 

storage for a set of hosts (grouped by customer, 

facility or device group) has changed over time and 

is projected to change in the future.

Host Total Storage Utilization Trend This report shows how the total storage utilization 

rate for a set of hosts (grouped by customer, facility 

or device group) has changed over time and is 

projected to change in the future.

Host Volume Manager Storage Allocation 

Trend

This report shows how allocated and used volume 

manager storage for a set of hosts (grouped by 

customer, facility or device group) has changed 

over time and is projected to change in the future.

Host Volume Manager Storage Utilization 

Trend

This report shows how the volume manager 

storage utilization rate for a set of hosts (grouped by 

customer, facility or device group) has changed 

over time and is projected to change in the future.

Storage Allocated to Unmanaged Hosts This report identifies arrays and filers providing 

storage to hosts that are unknown to or unmanaged 

by ASAS.

Table 5-2: Host and Application Storage Reports (continued)

REPORT TITLE DESCRIPTION
6
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Storage Array Reports
Table 5-3 describes the storage array reports available in ASAS.

Storage Switch and Fabric Reports
Table 5-4 describes the storage switch and fabric reports available in ASAS.

Table 5-3: Storage Array Reports

REPORT TITLE DESCRIPTION

Array Capacity and Utilization Overview This report provides summary capacity and 

utilization statistics for SAN storage arrays and NAS 

filers, grouped by customer, facility, or device group 

as desired.

Array Detail This report shows a detailed inventory of storage-

related information related to a specific storage 

array or filer.

Array Inventory This report provides basic inventory information and 

storage statistics for SAN storage arrays and NAS 

filers.

Storage Allocated to Hosts Unmanaged by 

ASAS

This report identifies arrays and filers providing 

storage to hosts that are unknown to or unmanaged 

by ASAS.

Table 5-4: Storage Switch and Fabric Reports

REPORT TITLE DESCRIPTION

Zone Inventory This report details the zone configuration for a 

specified zone set.
297



User’s Guide

29
8



Chapter 6: Storage Search

Overview of Search
In ASAS, you can search for storage information in your IT environment, such as Database, 

SAN Switch, Server, and Storage Systems objects and attributes.

SA Client Integration
The search feature in ASAS is integrated with the SA Client Search tool in the SA Client. To 

use search, you must be familiar with the basics of the SA Client Search tool. See the SA 

User’s Guide: Server Automation for information about using the following SA Client 

Search capabilities:

• Performing a simple search by using keywords

• Performing an advanced search by creating search queries

• Saving a search query

• Deleting a saved search

• Running a saved search query

• Performing actions on search results

• Emailing search results

• Printing search results

I N  T H I S  C H A P T E R

This section discusses the following topics: 

• Overview of Search

• SA Client Integration

• Storage Objects and Attributes
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Figure 6-1 shows a simple search for Brocade as the SAN switch manufacturer.

Figure 6-1: Search for Brocade Switches in a SAN

Storage Objects and Attributes
By using the SA Client Search tool, you can search for the following storage objects and 

attributes:

• Database: Server Name and Version

• SAN Switch: Device Customer, Device Facility, Device Group, Discover Date, Facility 

Name, Manufacturer, Model, Name, Opsware ID, and Port

• Server: FCA Manufacturer, FCA Model, FCA Port, FCA Version (Fibre Channel 

Adapter), Storage Make & Model, Storage Manager Software Manufacturer, and 

Storage Manager Software Type

• Storage Systems: Device Customer, Device Facility, Device Group, Discover Date, 

Facility Name, Manufacturer, Model, Name, Opsware ID, Port, RAID Type, and Serial 

Number
0



Appendix A: Global File System (OGFS)

Overview of OGFS
The Global File System (OGFS) feature shows storage inventory in a file system-like 

presentation. The OGFS feature in ASAS is integrated with the OGFS feature in the SA 

Client. To use the OGFS feature, you must be familiar with its basic capabilities in the SA 

Client. For more information, see the SA User’s Guide: Server Automation.

The OGFS represents the data model as a hierarchical structure of file directories and text 

files. For example, in the OGFS, the /opsw/Server directory contains information about 

managed servers and includes subdirectories that represent the contents of the managed 

servers, such as storage, ports, and disks.

Global Shell
The Global Shell is a command-line interface to the OGFS. This command-line interface is 

a Unix shell, such as bash, that runs in a terminal window. The default shell in Global Shell 

is bash. 

The OGFS unifies the data model and the contents of storage devices and managed 

servers, including files, into a single, virtual file system. You open a Global Shell session 

from within a SA Client or from a direct ssh connection in a terminal client on your 

I N  T H I S  A P P E N D I X

This section discusses the following topics:

• Overview of OGFS

• Global Shell

• Permissions

• Storage Directory in the OGFS
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desktop. With the Global Shell, you can automate repetitive system administration tasks 

by running scripts across multiple storage devices and servers in a secure environment. 

Common scripting languages, such as Perl and Python, are supported.

The OGFS represents the data model as a hierarchical structure of file directories and text 

files. For example, in the OGFS, the /opsw/ Server/@/e-

commerce.example.com/Storage directory contains details about storage 

dependencies for the server named e-commerce.example.com.

For more information on how to use Global Shell, see the SA User’s Guide: Server 

Automation.

Permissions
The actions that you can perform within the Global Shell are determined by the operations 

specified by the aaa utility. The aaa utility grants and revokes permissions for operations 

that use the OGFS. For example, the aaa utility grants permission for the 

readServerFilesystem operation, which allows you to browse a server’s file system 

in the SA Client. To run the aaa utility, you must belong to the Administrators user group. 

The permissions granted and revoked by the aaa utility are stored in the /opsw/ 

Permissions directory of the OGFS. For information on how to use the aaa utility see 

the SA User’s Guide: Server Automation.

You must have permissions in the Global Shell to view the file systems for storage 

inventory. 

Storage Directory in the OGFS
The following sections describe subdirectories that contain storage content. The directory 

layout is designed to reflect the natural locations of storage objects, with the intent to 

facilitate intuitive navigation by OGFS users.

The primary storage directory roots are /opsw/Storage, which contains all storage 

system and storage network content and /opsw/Server/.../ Storage, which 

contains storage objects specific to their respective servers.
2
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Additional storage directory trees are provided to scope the content contained within 

/opsw/Storage. Examples include the /opsw/Customer/.../Storage directories, 

which contain storage resources that are assigned to customers, and the 

/opsw/Facility/.../Storage directories, which contain storage resources that are 

associated with facilities.

Although storage trees exist in multiple scoped locations, each and every object has a 

single location at which it can be reliably located in the OGFS. These locations are 

collectively referred to as canonical locations. Within each storage directory tree, symbolic 

links (symlinks) are used to traverse storage topology and reference storage information 

located in canonical directory paths.

The canonical location for a volume of a server is in the following directory:

/opsw/Server/.../Storage/Volume

In the following example, the Volume directory contains content pertaining to a raid0 

volume on the server:

/opsw/Server/@/myserver.opsware.com/Storage/Volume/raid0

If a file system is mounted on that volume, this is reflected in the OGFS as a symbolic link 

to the volume, which is located in its canonical location:

/opsw/Server/@/myserver.opsware.com/Storage/FileSystem/myfs/
Volume/raid0 -> /opsw/Server/@/myserver.opsware.com/Storage/
Volume/raid0

/opsw/api/com/opsware/storage Directory

This directory is automatically provided by the existing (SA Client) UAPI infrastructure. The 

api directory contains executables that invoke methods on the HP SAS API.

/opsw/Storage Directory

This directory contains storage system and storage network artifacts. This directory is 

replicated in the following paths with filtered content:

• /opsw/Facility/<facility>/@/Storage—This directory shows the content of /

opsw/Storage with the top-level directories filtered by facility.

• /opsw/Group/<Public|Private>/<group>/@/Storage—This directory shows 

opsw/Storage content with the top level directories filtered by group.

• /opsw/Customer/<customer>/@/Storage—This directory shows opsw/

Storage content filtered by customer.
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/opsw/Server/.../Storage Directory

This directory contains server-related storage artifacts.

/opsw/Server/.../Storage

/opsw/Server/.../Storage/Controller Directory

This directory contains a subdirectory with symlinks to controller ports and a subdirectory 

with symlinks to volumes imported through this controller.

/opsw/Server/.../Storage/Controller/Port
/opsw/Server/.../Storage/Controller/Volume

/opsw/.../Disk/Dependent Directory

This directory contains symlinks to dependent volumes. There are several places where 

the Disk directory can exist. It can occur on the server side (to show the local disks on a 

server), such as:

/opsw/Server/@/myserver.opsware.com/Disk

Or, it can be located on a storage system (to show the disks contained in a storage array), 

such as:

/opsw/Storage/System/emcdmx-01/Disk

The Dependent subdirectory can exist in many locations (one of which is a subdirectory 

of a disk). In each case, the Dependent subdirectory shows storage artifacts that are 

dependent on the object represented in the current directory, such as:

/opsw/Storage/System/emcdmx-01/Disk/01A\:C0/Dependent

In this example, this path shows the objects that directly depend on disk 01A:C0.

/opsw/.../Server/Storage/Fabric Directory

This directory contains symlinks to fabric-connected devices, zones on the fabric, 

symlinks to ports in the zone, zone aliases on the fabric, symlinks to zone aliases that 

reference the zone, zone sets, and switches on the fabric.

/opsw/Server/.../Storage/Fabric/ConnectedDevice
/opsw/Server/.../Storage/Fabric/Switch
/opsw/Server/.../Storage/Fabric/Zone
/opsw/Server/.../Storage/Fabric/Zone/Member
/opsw/Server/.../Storage/Fabric/Zone/ZoneAlias
/opsw/Server/.../Storage/Fabric/Zone/ZoneSet
/opsw/Server/.../Storage/Fabric/ZoneAlias
/opsw/Server/.../Storage/Fabric/ZoneAlias/Member
4
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/opsw/Server/.../Storage/Fabric/ZoneAlias/Zone
/opsw/Server/.../Storage/Fabric/ZoneSet
/opsw/Server/.../Storage/Fabric/ZoneSet/Zone
/opsw/Server/.../Storage/Fabric/Switch

/opsw/Server/.../Storage/FileSystem Directory

This directory contains symlinks to the volume underlying the file system.

/opsw/Server/.../Storage/FileSystem/Volume

/opsw/Server/.../Storage/Port Directory

This directory contains symlinks to a connected device, symlinks to a connected port, 

symlinks to a protocol controller, symlinks to the connected fabric, symlinks to volumes on 

this port, symlinks zones referencing this port, and symlinks to zone aliases referencing 

this port. This directory can reside under multiple storage domains.

/opsw/Port/Connected Device
/opsw/.../Port/ConnectPort
/opsw/.../Port/Controller
/opsw/.../Port/Fabric
/opsw/.../Port/Volume
/opsw/.../Port/Zone
/opsw/.../Port/ZoneAlias

/opsw/Server/.../Storage/Service Directory

This directory contains MPIO Manager and Volume Manager software, symlinks to 

volumes exported, and symlinks to volumes imported by each service.

/opsw/Server/.../Storage/Service/<service-name>/Volume
/opsw/Server/.../Storage/Service/<service-name>/InputVolume
/opsw/Server/.../Storage/Service/<service-name>/OutputVolume

/opsw/Server/.../Storage/Switch Directory

This directory contains symlinks to connected devices, symlinks to connected fabrics, and 

switch ports.

/opsw/Server/.../Storage/Switch/Fabric
/opsw/Server/.../Storage/Switch/Port
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/opsw/Server/.../Storage/System Directory

This directory contains storage system protocol controllers, storage system physical disks, 

storage system volume pools, symlinks to volumes within a storage pool, storage system 

ports, and storage volumes.

/opsw/Server/.../Storage/System/Controller
/opsw/Server/.../Storage/System/Disk
/opsw/Server/.../Storage/System/Pool
/opsw/Server/.../Storage/System/Pool/Volume
/opsw/Server/.../Storage/System/Pool/Volume/Antecedent
/opsw/Server/.../Storage/System/Pool/Volume/Dependent
/opsw/Server/.../Storage/System/Pool/Volume/Initiator
/opsw/Server/.../Storage/System/Pool/Volume/Pool
/opsw/Server/.../Storage/System/Pool/Volume/Port
/opsw/Server/.../Storage/System/Port
/opsw/Server/.../Storage/System/Volume

/opsw/Server/.../Storage/Volume Directory

This directory contains symlinks to antecedent storage volumes and physical disks, 

symlinks to controllers importing this volume, symlinks to dependent storage volumes, 

symlinks to dependent file systems, paths through which the volume is imported, 

symlinks to storage ports importing this volume, symlink to the service that provides this 

volume, symlink to the target volume in the storage system domain, symlinks to 

connected host initiator volumes, and symlinks to the storage pool associated with this 

volume.

/opsw/Server/.../Storage/Volume/Antecedent
/opsw/Server/.../Storage/Volume/Controller
/opsw/Server/.../Storage/Volume/Dependent
/opsw/Server/.../Storage/Volume/FileSystem
/opsw/Server/.../Storage/Volume/Path
/opsw/Server/.../Storage/Volume/Port
/opsw/Server/.../Storage/Volume/Service
/opsw/Server/.../Storage/Volume/Target
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