
HPE Service Virtualization
ソフトウェア・バージョン:3.80
ドキュメント・リリース日:2015 年 12 月
ソフトウェア・リリース日:2015 年 12 月
注:このドキュメントの最新版と,その他の HPE Service Virtualization ドキュメントの更新をチェックするには,HPE ソフトウェア製品マニュアル・サイトを参照してください(HPE Passport が必要)。
このファイルには,HPE Service Virtualization 3.80 に関する次の情報が記載されています。
本項では,HPE Service Virtualization 3.80 で導入された機能や拡張された機能の概要を説明します。詳細については,『HPE Service Virtualization ユーザーズ・ガイド』またはアプリケーション内のヘルプセンターを参照してください。
プロトコルと仮想化の機能拡張
Java 仮想化:Java アプリケーションの仮想化に対するサポートが導入されました。Java メソッド呼び出しをシミュレートし,動的な仮想化のランタイムを設定できます。
FS および FTP/S 経由のファイル転送:一般的なファイル・システムおよび FTP 経由でのファイル転送の仮想化に対するサポートが追加されました。カンマ区切り値やその他のテキスト・ベース形式など,XML とフラット・ファイル・ベースの通信を使用できます。
ISO 8583:設定可能かつ拡張可能な JPOS ブリッジを使用して ISO 8583 メッセージをシミュレートする機能が追加されました。ネイティブ通信を HTTP 経由の XML に変換することで,ISO 8583 を使用してアプリケーションを仮想化できます。Service Virtualization には,JPOS ブリッジ設定アクセラレータも含まれており,サポートされていない JPOS 形式をすばやく調整できます。
ローカル MQ バインド:MQ キュー・マネージャへの直接ローカル接続を実現することで,Service Virtualization が WebSphere MQ サーバと同じマシンにデプロイされている場合の MQ 通信のパフォーマンスが改善されました。
ルート要素のルーティング(ラボ機能):MQ 経由の XML サービスを複数の仮想サービスに分割する機能,および XML メッセージのルート要素に基づいたルーティングを追加することで,データ・モデルのメンテナンスとシミュレーションのパフォーマンスが改善されました。
仮想サービス管理とログ記録の機能拡張
Web アクセス可能メッセージ:メッセージのログ記録を有効または無効にし,ログに記録されたメッセージを Service Virtualization Management インタフェースから直接確認できるようになりました。メッセージのログ記録設定のバルク操作機能を活用したり,フローの確認やログに記録されたメッセージ間の差異の確認を行ったりすることができます。
ランタイム・メッセージのログ記録:仮想サービスを再起動することなく,メッセージのログ記録を有効または無効にできるようになりました。この機能は,Service Virtualization Designer と Service Virtualization Management インタフェースの両方で使用できます。
仮想サービス統計:仮想サービス統計の操作性とパフォーマンスが改善されました。
統合とパフォーマンスの改善
NV v9.00 との統合:HPE Network Virtualization 9.00 との統合が追加され,Service Virtualization 環境内でネットワーク条件を直接設定できるようになりました。
パフォーマンス・モデルの改善:シミュレーションでパフォーマンス・モデルを使用する場合の,シミュレーション・モードのパフォーマンスが改善されました。
Java スクリプト・ルールのパフォーマンス:データ・モデルで Java スクリプトを使用する場合の,シミュレーション・モードのパフォーマンスが改善されました。
その他の改善
製品の安定性:Service Virtualization Designer と Service Virtualization Management インタフェースの安定性が改善されました。
HPE のリブランディング:Service Virtualization Designer と Service Virtualization Management インタフェースが,新会社のブランド規格に合わせて変更されました。
Service Virtualization の詳細なインストール手順は,『HPE Service Virtualization インストール・ガイド』に記載されています。インストール・ガイドは,Service Virtualization インストール・パッケージのルート・フォルダに PDF 形式で用意されています。
また,インストール後に Windows スタート・メニューから開くこともできます。
Service Virtualization Server のアップグレード:FIPS モードで Service Virtualization 3.80 を使用する場合,Service Virtualization Server 3.80 を正常にインストールしてから,FIPS を有効にしてください。
本項の内容
サポートされるオペレーティング・システム,データベース・サーバ,ブラウザ,開発環境の一覧については,HPE ソフトウェア・サポート・サイトの Service Virtualization サポート・マトリクスを参照してください(https://softwaresupport.hp.com/group/softwaresupport/support-matrices)。
HPE Service Virtualization Server 3.80 と HPE Service Virtualization Designer 3.80 は,サポート対象のオペレーティング・システムと,製品あたり 1 GB 以上の物理メモリが搭載されているすべてのハードウェア環境で実行できます。
最小ハードウェア構成では,すべての機能テスト・シナリオを実行できます。また,仮想サービスで過度な負荷が発生しないことを条件に一部の基本的なパフォーマンス・テスト・シナリオの実行にも対応します。
仮想ハードウェアのサイジングは複雑な作業であり,さまざまな要素を考慮する必要があります。推奨構成の詳細については,HPE カスタマ・サポートにお問い合わせください。連絡先情報については,HPE ソフトウェア・サポート・オンラインを参照してください。
次に,各製品を別のマシンにインストールすることにより,通常のシナリオでバランスのとれたパフォーマンスを発揮できるハードウェア構成を示します。
| Service Virtualization Designer |
|
| Service Virtualization Server(32 ビット版) |
|
| Service Virtualization Server(64 ビット版) |
|
| データベース・サーバ |
|
前バージョンのリリース後に,次の問題が修正されました。
JDBC の問題:仮想化データを受信しているアプリケーションから ClassCastException が発生する(データ型マッピング)。
問題:HP SV JDBC ドライバでは多くの場合,データをコードと互換性のないタイプに変換するため,ClassCastException が発生します。コード側が CLOB を期待している場合に,データは文字列に変換されます。
解決策:JAR ファイルまたはファイル・システム内の別のファイルのリソースを指定することで,各データ・ソースごとにマッピングを設定できるようになりました。
Windows ユーザ・アカウントがネットワークから切断されたときに,Service Virtualization がそのユーザ・アカウントをロックアウトする。
解決策:ユーザの資格情報が無効のときは,Service Virtualization Management(SVM)は Service Virtualization Server からデータをロードしません。有効な資格情報が利用可能になると,データが更新されます。
Service Virtualization が,MQ 経由の SOAP プロジェクト TSYS MAINT をアップグレードしない。
問題:この問題の原因は,親タイプで追加または削除した要素にあります。
解決策:削除/追加した要素のすべての子孫と親が,正しく更新されるようになりました。
JDBC:サポートされていない SQL タイプ:1111(JSON) - PostgreSQL バックエンド - 要求。
解決策:org.postgresql.util.PGobject タイプのサポートを追加しました。
JDBC の問題:無効なデータ変換エラー。
解決策:コンバータを修正しました。
RFH2 ヘッダを含む MQ メッセージを JMS 経由で送信すると,MQ メッセージの読み取りが失敗する。
問題:キュー拡張プロパティ・コントロールを "Force MQRFH2" に設定すると,侵入型 MQ がメッセージを読み取れません。
解決策:MQMessage.Format で MQC.MQFMT_RF_HEADER_2 の値を確認します。一致した場合,次に ReadString を呼び出したときに実際のペイロードを読み込めるように,ヘッダは一部が解析され(ヘッダ長を取得),ヘッダのコンテンツはスキップされます。このヘッダから処理チェーンに渡される(メタ)データはありません。
REST Service Virtualization インスタンスで JSON 応答を追加するときに問題が発生する。
問題:REST 仮想サービスで,第 3 の URI 空間を追加すると,仮想サービスの機能に問題が発生します。
解決策:プロパティの書き込み時に,全サブタイプの同じ名前を持つプロパティがすべて設定されます。プロパティのデータ・タイプが異なる場合,例外が作成されてルールは実行されません。さらに,HPSV オブジェクトにプロパティが 1 つだけ追加されます。タイプは,作成した割り当て名を持つ最初のプロパティに基づきます。
RFH2 メッセージの書き込みに失敗する。
問題:侵入型 MQ を使用し,RFH2 ヘッダを含む MQ メッセージで,問題が発生します。Designer は,実サービスにメッセージを渡すことに失敗し,無効なヘッダの作成に関するエラーをレポートします。
解決策:メッセージが RFH2 形式で生成されている場合,実際のペイロードの前に最小限の疑似 RFH2 ヘッダが挿入されます。
JDBC の問題:PostgreSQL DB のサポートされていない SQL タイプ 1111 - 応答。
解決策:PGobject 値に文字列として格納されている JSON 値の読み取りを有効にしました。
侵入型 MQ が記録中にメッセージ・ヘッダを正しく渡さない。
解決策:GetOptions 関数の補正フラグ MQC.MQGMO_PROPERTIES_IN_HANDLE を使用すると,プロパティが正しくロードされます。
要求:メッセージ列を基準に実行時ビューをソートするオプションを追加する。
問題:多数の仮想サービスがあるプロジェクトでは,メッセージを受信したサービスを見つけるため,実行時ビューをスクロールする必要があります。[メッセージ (固有)]列でソートできれば,この作業にかかる時間を大幅に短縮できます。
解決策:実行時ビューで,仮想サービスをソートできます。
要求:操作名で分割して仮想サービスを導入する(ルート要素のルーティング)。
問題:MQ 経由の SOAP プロトコルを使用する Service Virtualization MQ プロジェクトが大きすぎます。
解決策:仮想サービス設定で,要求/応答の「ルート」要素名を指定できるようになりました。これはメッセージのサブセットを示します。指定したルート要素を持つメッセージのみが,サービスによって消費されます。
SOAP 仮想化の問題:WSSE Signature Verification の失敗(元の要求の転送)。
解決策:SignBodyAndHeaders セキュリティ・スキーマを追加しました。
要求:複数回繰り返し選択スキーマの学習に対するサポートを追加する。
問題:MQ 経由の SOAP は,WSDL がないと機能しません。
解決策:xs:choice 学習が実装されました。
要求:PATCH メソッドを動詞 REST に追加する。
問題:Service Virtualization は,RESTful サービス実装で PATCH メソッドをサポートしていません。
解決策:PATCH 動詞サポートが追加されました。パッチが適用された後,完全な PATCH 動詞サポートを得るために,新規 REST 仮想サービスを作成する必要があります。
IE8:
Microsoft Internet Explorer 8 のサポートは終了しました。http://support.microsoft.com/kb/323308 に記されている手順を実行してから,コンピュータを再起動してください。
JDBC
次の JDBC タイプはサポートされていません。
REST サービス
文字列としてのワイルドカード文字 * の廃止:Service Virtualization バージョン 3.70 より,ワイルドカード文字 * は文字列としてはサポートされなくなりました。ワイルドカード文字 * または ** は,ワイルドカード・セグメントを表します。たとえば,a*b はサポートされません。新しくサポートされる形式は a/*/b で,* は任意のセグメント値を表します。
REST サービスを使用するプロジェクトの移行の制限:文字列ワイルドカード * が廃止されたため,Service Virtualization は URI 空間の文字列ワイルドカードのすべてのインスタンスを ** に変換します。このワイルドカード形式は,任意の値の 1 つ以上のセグメントを表します。たとえば,a*b は ** に変換されます。
URI 空間で複数の文字列ワイルドカードが使用されており,新しい形式のために変換によって重複するエントリが生じる場合,移行は失敗します。たとえば,/some/a*b と /some/c*d はどちらも /some/** に変換されます。このような場合は,HPE サポートにプロジェクトの移行の支援を要請してください。
サービスの呼び出しアクティビティ(SCA)
Service Virtualization Management(SVM),SVConfigurator,またはサーバの変更を通じた SCA によるサービスのデプロイメントは,選択されたエージェントに影響を与えます。
回避策:デプロイメントの後で,Designer から手動でエージェントを選択する必要があります。
データ・モデルでの SCA へのメッセージのインポートはサポートされていません。
回避策:データ・モデルで SCA を手動で入力します。
FIPS
問題:バージョン 3.70 より前に作成された暗号化された Service Virtualization プロジェクトは,12.50 より前のバージョンの LoadRunner/Unified Functional Testing(UFT)統合で使用される Service Virtualization ライブラリからは読み取れません。
これは,Service Virtualization 3.70 で,FIPS を採用したマシンでの使用を可能にするために暗号化が変更されたことが原因です。
回避策:Service Virtualization 3.70 と LoadRunner/Unified Functional Testing(UFT)統合の 12.50 より前のバージョンを組み合わせて使用するには,Designer の設定ファイル VirtualServiceDesigner.exe.config の設定を変更します。
ファイルの次のセクションで,SV.Encryption.Version の値を 1 に設定します。
<!-- Allows to choose encryption version. Should be kept empty unless really needed.
Empty - use most recent version
1 - version used before SV 3.70; can be used for instance when project is used in integration scenario
by old versions of LR/UFT (before 12.50); does not work with FIPS!
2 - introduced in SV 3.70, works with FIPS
-->
<add key="SV.Encryption.Version" value="" />
注:
その他の制限
TIBCO EMS のキューで実行している場合,実サービスを無効にできない。
現象:仮想サービスのシミュレーションを実行しているにもかかわらず,実サービスが要求を受信しています。
回避策:シミュレーション開始前に実サービスを停止します。
TIBCO EMS の動的な宛先に対するサービスをシミュレートできない - EMS API の制限。
現象:サービスをシミュレーション・モードにすると,エラーが発生し,次のメッセージがサーバ・ログに書き込まれます:TIBCO.EMS.ADMIN.AdminSecurityException: Properties of dynamic destinations are not mutable(動的な宛先のプロパティは変更できません)。
回避策:動的な宛先が作成されるのを避けるため,BusinessWorks(BW)サービスを BW ランタイム・エージェントにデプロイする前に,当該サービスに対する宛先を EMS で作成します。
管理者ログインで EMS サービスのシミュレーションを開始しようとすると,"Not allowed to change permissions of specified principal(指定したプリンシパルのアクセス許可を変更できません)" というメッセージが表示されて失敗する。
現象:サービスをシミュレーション・モードにすると,エラーが発生し,次のメッセージがサーバ・ログに書き込まれます:TIBCO.EMS.ADMIN.AdminSecurityException: Not allowed to change permissions of specified principal(指定したプリンシパルのアクセス許可を変更できません)。
回避策:サービスの設定を変更して,管理者 EMS アカウントを使用しないようにします。
MTOM サービス:データ・モデルを編集した後に Service Virtualization がフリーズする。
現象:メッセージに巨大な添付ファイルがあると,データ・モデル・エディタがフリーズすることがあります。
回避策:既知の回避策はありません。
MS Office と Microsoft Access Database Engine 2010 を同時にインストールできない。
現象:データ駆動機能に必要な Microsoft Access Database Engine 2010 は,64 ビット版 MS Office と同じコンピュータにインストールできません。
回避策:32 ビット版 MS Office をインストールします。
WebLogic JMS URL のサポートの制限。
現象:JMS 仮想サービスが設定されており,Designer の仮想サービス・ウィザードで WebLogic JMS サービスの WSDL がインポートされた場合,WebLogic JMS の URL が正しく解析されず,仮想サービス・ウィザードで実宛先名(実サービスのエンドポイント)の自動入力が正しく行われません。
回避策:仮想サービス・ウィザードで実宛先名を手動で入力します。WebLogic は特定の JMS URI 形式を使用します。例:jms://myHost:7001/transports/JMSTransport?URI=JMSTransportQueue(http://download.oracle.com/docs/cd/E12839_01/web.1111/e13735/jmstransport.htm を参照)。
英語以外の文字を含むユーザ名またはパスワードでスタンドアロン・サーバに接続できない。
現象:英語以外の文字を含むユーザ名またはパスワードを使用した場合,セキュリティ保護されたスタンドアロン Service Virtualization Server に接続できません。
回避策:セキュリティ保護されていないスタンドアロン・サーバを使用します。
HTTP(s)ゲートウェイ・エージェントで,基本認証と英語以外の文字を含む資格情報でサービスを仮想化できない。
現象:クライアント資格情報に英語以外の文字が含まれていると,HTTP 基本認証でセキュリティ保護されたサービスの仮想化が HTTP(s)ゲートウェイ・エージェントで失敗します。
回避策:HTTP(s)プロキシ・エージェントを使用してサービスを仮想化します。
HTTPS 相互認証を使用した場合,実サービスへの接続が失敗する。
現象:クライアント・アプリケーションが,HTTPS 相互認証接続の確立に必要なクライアント証明書を送信しません。
解決策:Service Virtualization がインストールされているマシンの信頼されたルート証明機関リストに含まれるインストールされた機関の数が多すぎないことを確認します(50~100)。使用していない機関や不要な機関を削除して,リストを小さくします。HTTPS 相互認証では,信頼された機関のリストを,制限されたサイズのパケットでクライアントに送信する必要があります。クライアントはこのリストを使用して,適切なクライアント証明書を選択します。機関数が多すぎると送信されるリストが切り詰められるため,必要な機関が除外されてしまう可能性があります。
すべての関連プロトコルでの COBOL メッセージのインポートの制限。
現象:COBOL 関連のすべてのプロトコルでの COBOL メッセージのインポートには,次の制限があります。
1. ファイル内容のプレビューに無効な文字が表示されます。
2. 処理される内容には,標準設定のエンコーディング/文字セットが使用されます。標準設定値は IBM037(IBM COM EUROPE EBCDIC)です。
回避策:
1. 現時点で回避策はありません。
2. Designer/Server のアプリケーション設定ファイル(ファイル名は HP.SV.StandaloneServer.exe.config または VirtualServiceDesigner.exe.config)を変更して,次の行を追加/更新し,値を必要なエンコーディングに置き換えます。
<configuration>
<appSettingsOverride>
…
<add key="ImsMessageProcessor.DefaultCodePage" value="IBM037" />
<add key="CobolMessageProcessor.DefaultCodePage" value="IBM037" />
…
</appSettingsOverride>
</configuration>
HTTP プロキシ・エージェント経由で IPv4 アドレスに接続できない。
現象:IPv4 アドレス(例:16.55.195.180)を使用してサービスに接続しようとすると,"Bad Request - Invalid Hostname - HTTP Error 400. The request hostname is invalid(無効なリクエスト - 無効なホスト名 - HTTP エラー 400。リクエストのホスト名が無効です)" といったエラー・メッセージがブラウザに表示されます。
回避策:IPv4 ではなくサービスのホスト名を使用するか,プロキシ・サーバを HTTP プロキシ・エージェントのホスト名でなく IPv4 アドレスに設定します。
Websphere JMS サービスのシミュレーション中に次のエラーが発生する:The value for 'JMS_IBM_Character_Set':'sim_default_JMS_IBM_Character_Set' is not valid('JMS_IBM_Character_Set':'sim_default_JMS_IBM_Character_Set' の値が有効ではありません)。
現象:Websphere JMS サービスのシミュレーション中に,クライアントが応答を受信せず,Service Virtualization が次のようなエラーを生成します:The value for 'JMS_IBM_Character_Set':'sim_default_JMS_IBM_Character_Set' is not valid('JMS_IBM_Character_Set':'sim_default_JMS_IBM_Character_Set' の値が有効ではありません)。
回避策:関連するデータ・モデルに対してデータ・モデル・エディタを開き,標準設定ルールを展開します。応答の JMS_IBM_Character_Set 列に適切な値を入力するか,[存在しない]に設定します。必要な操作すべてに対して繰り返します。
シミュレーション・モードで MQ サービスから応答が受信されない。
現象:MQ クライアントがタイムアウトまたは大幅に遅れた応答を受信し,Service Virtualization が次のようなエラーを生成します:“宛先 'hp.sv.dynamic.response.queue.1' を取得できません: MQ 理由コードは 2085,MQ エラーは MQRC_UNKNOWN_OBJECT_NAME です。---> IBM.WMQ.MQException: MQRC_UNKNOWN_OBJECT_NAME”。これは,MQ サーバと Service Virtualization Server の時刻とパフォーマンス・モデルが異なっており,長い応答時間が記録されるために発生します。
回避策:すべてのピアで,適切な時刻同期が設定されている必要があります。記録される時刻の違いを修正するには,パフォーマンス・モデルを編集して応答時間の値を更新するか,シミュレーションに[なし]パフォーマンス・モデルを使用します。
COBOL/MQ サービスの標準設定ルールのシミュレーションが正しくない。
現象:MQ サービス経由の COBOL のシミュレーションが失敗する場合があります。これは,標準設定ルールから追加された MQIIH ヘッダの標準設定値が原因である可能性があります。
回避策:サービスのデータ・モデルを編集します。標準設定ルールで,MQIIH ヘッダの値を[存在しない]に設定します。
タイプが XML 継承の一部である場合に,XML サービスのスキーマを更新できない。
現象:サービス記述の複合 XML スキーマ・タイプの手動変更は,複合タイプがタイプ派生(制限または拡張)によって作成されているか,複合タイプ派生のベース・タイプである場合にはサポートされません。
回避策:変更したサービス記述を使用して,新しいサービスを作成します。
ALM クライアントから Service Virtualization リソースにファイルをアップロードするとプロジェクトが破損する。
現象:ALM のリソース・モジュールで,Service Virtualization リソースにファイルをアップロードすると,Service Virtualization プロジェクト/サービスが破損します。
回避策:ALM クライアントを使用して Service Virtualization リソースにファイルをアップロードしないでください。
260 個の操作を持つ WSDL 用 OOM を使用すると Designer がクラッシュする。
現象:大規模なスキーマ(200 リーフ以上)を持つ操作を 100 個以上含む WSDL はサポートされません。
回避策:WSDL を分割します。
Designer が起動後または起動中にランダムにクラッシュする。
現象:Service Virtualization Designer が起動中または起動直後にランダムにクラッシュし,ログに致命的重要度のエラー・メッセージが記録されます。
回避策:Designer をもう一度起動します。
IMS プロトコルのエラー・メッセージのサポートの追加。
現象:IMS Connect プロトコルのエラー・メッセージがサポートされていません。
回避策:ありません。
Oracle サービスが標準設定のルールに対して無効な値を生成する。
現象:サービス記述の学習中に,学習対象の値のタイプが不明な場合に発生します(標準設定の文字列値になりますが,この値は数値に変換できません)。
回避策:データ・モデル・エディタで,標準設定ルールの値を編集して,数値に変換できるようにします。
SVM:非 ASCII 文字の資格情報を使用して Service Virtualization Server に接続できない。
現象:ユーザ名またはパスワードに非 ASCII(各国語)文字が含まれる場合,ユーザは SVM(Service Virtualization Management)にログインできますが,資格情報が Service Virtualization Server に認識されません。
回避策:資格情報に ASCII 文字だけが含まれたユーザ・アカウントを使用します。
無効にされているメタデータを有効にすると,新しい列には IgnoreCondition でなく IsCondition が含まれる。
現象:無効にされている要求メタデータを有効にすると,新しい列に[無視]条件でなく[次の値に一致]条件が含まれます。
回避策:メタデータ列の関数を手動で[無視]に変更します。
ユーザがサービスに対するすべての権限(r,w,d,m)を持っていても,サービスのエンドポイントを参照できない。
現象:ユーザがサービスに対するすべての権限(r,w,d,m)を持っていても,サービスのエンドポイントを正しく参照できません。
回避策:ユーザの特定のエージェントに読み取り権限を付与します。
SVM:IE 8 および IE 9 ブラウザで ALM からファイルをダウンロードできない。
現象:IE 8 で ALM からプロジェクト・アーカイブをダウンロードしようとすると,新しいウィンドウが開き,ファイルを保存するためのダイアログ・ボックスが開きません。IE 9 で ALM からプロジェクト・アーカイブをダウンロードしようとすると,新しいタブが開き,ファイルを保存するためのプロンプトが表示されません。
回避策:
IE 8:http://support.microsoft.com/kb/323308 に記されている手順を実行してから,コンピュータを再起動します。
IE 9:前のタブに切り替えると,ファイルの保存プロンプトが表示されます。
次のエラーのために ALM に接続できない:Failed to initialize JVM: JNI_ENOMEM (-4)(JVM を初期化できませんでした: JNI_ENOMEM (-4))。
現象:ユーザが ALM に接続しようとします。すると,“Failed to initialize JVM: JNI_ENOMEM (-4)(JVM を初期化できませんでした: JNI_ENOMEM (-4))” というエラー・メッセージが表示されます。これは,JVM が要求された量のメモリを予約できなかったことを示します。
回避策 1:“Designer\bin” フォルダにある “virtualservicedesigner.exe.config” ファイルを開きます。appSettings セクションで,"SV.JavaVm.PrealocatedMemorySize" というキーを見つけ,必要なメモリ量を設定します。推奨値は 256 です。次に例を示します:“<add key="SV.JavaVm.PrealocatedMemorySize" value="256" />”。Designer を再起動し,ALM に再接続します。
回避策 2:“Designer\bin\config” フォルダにある “jvm-context” ファイルを開きます。JavaOptions セクションの最初のパラメータの値を小さくします。初期値(推奨値)は “-Xmx128M”(128 MB)なので,これを “-Xmx64M” に設定してみます。Designer を再起動し,ALM に再接続します。
注:両方の設定を併用することもできます。この場合,“SV.JavaVM.PrealocatedMemorySize” の値を “–Xm” の値の 2 倍に設定することを推奨します。
JavaScript エンジンがネイティブ・コードで 80000003 例外コードによりクラッシュする。
現象:スクリプト化されたルールを持つ 1 つの仮想サービスに対して 10 を超える並列クライアントが動作している高負荷条件で,アプリケーションが 80000003 例外コードによってクラッシュする場合があります。これは主に 32 ビットシステムで起こります。
回避策:“Designer\bin\Config” または “Server\bin\Config” にある “scripted-rule-context.xml” ファイルで,最大エンジン・バッファ・サイズを 11 未満に設定します。
RPC/Enc 通信で参照がインラインになる。
現象:SOAP RPC/Encoded 通信で参照される要素を送信する際に,参照される要素がインラインになります。
回避策:なし。
複数のサーバで動作しているサービスの統計またはリストをエクスポートできない。
現象:複数のサービスが選択されている場合,メニュー項目[統計のエクスポート]または[リストのエクスポート]が無効になります。
回避策:同じサーバからサービスを選択するようにします。不要なサーバを除外します。
パフォーマンス・モデルのホット・スワップでバッチ・シミュレーションが動作しない。
現象:バッチシミュレーションが設定されている新規パフォーマンス・モデルに対してホット・スワップを実行すると,バッチ・シミュレーションが動作しません。
回避策:新しく選択したパフォーマンス・モデルを使用するようにシミュレーションを再起動します。
IBM WebSphere MQ 非侵入型プロトコル:データ・モデルを使用しない仮想サービスに対して,パフォーマンス・モデルのシミュレーションがサポートされない。
インストーラが "Error 997. Overlapped I/O operation is in progress(エラー 997。オーバーラップする I/O 操作が実行中です)" というエラーで失敗する。
現象:.msi インストーラをコマンド・ラインから実行する際に,ログ記録を有効にし,/l*vx! install.log オプションを使用して各行の後でログ・ファイルをフラッシュするように指定した場合,インストーラが "Error 997. Overlapped I/O operation is in progress(エラー 997。オーバーラップする I/O 操作が実行中です)" というエラー・メッセージを生成して失敗することがあります。
回避策:msiexec のログ記録パラメータから感嘆符を削除します(! - 各行をログにフラッシュ)。
例:
正:msiexec /i HPEServiceVirtualizationServer-x86.msi /l*vx install.log
誤:msiexec /i HPEServiceVirtualizationServer-x86.msi /l*vx! install.log
3.61 から 3.62 へのアップグレード:Server が実行されていると,1 回目のバックアップが失敗することがある。
現象:この問題は,.msp インストール・ファイルを使用して 3.61 から 3.62 にアップグレードした場合に発生します。インストール中に,[バックアップ]オプションを選択して[次へ]をクリックした後で,Server は自動的に停止されますが,バックアップは Server が実行されているというエラーによって失敗します。バックアップ・プロセスは Server の停止を短時間しか待たずに続行するため,バックアップが失敗します。次にバックアップを実行しようとすると成功します。
回避策:バックアップをもう一度実行するか,バックアップを実行する前に Windows サービス管理コンソールで Server を手動で停止します。
C# のスクリプト化されたルールでシミュレーション・プレビューが動作しない。
現象:C# ルールは,仮想サービスがシミュレーション・モードになっていないと,シミュレーション・プレビューで結果を表示しません。
回避策:仮想サービスをシミュレーション・モードに切り替えます。
Service Virtualization が,スタンバイおよび学習モード中に無効なエンドポイントに要求を送信する可能性がある。
現象:これは,仮想サービスが次の条件に一致すると発生します。
回避策:実サービスと仮想サービスに同じ URI パスを使用するか,HTTP プロキシ・エージェントを使用します。
Apache ActiveMQ 5.12 汎用 JMS エージェントを使用すると,エージェント設定の検証中にエラーが発生する。
現象:apache-activemq-5.12.0 に SLF4J ログ記録ライブラリが含まれています。Service Virtualization Java ランタイムと Apache ActiveMQ フレームワークの両方が SLF4J を使用するため,エラーが発生します。
回避策:activemq-all-5.12.0.jar から org.apache.commons.logging ディレクトリを削除します。
Resource Manager のデプロイ・ツールで,サーバ応答の遅れによりリモート Service Virtualization サーバへのプロジェクトのデプロイに失敗する。
現象:オンラインで ResourceManager を使用している Service Virtualization サーバへのプロジェクトのデプロイが失敗し,「スタンドアロン サーバが利用できません」というメッセージが表示されます。
回避策:次の行をアプリケーション設定ファイル(ResourceManager.exe.config)に追加し,ニーズに合わせてタイムアウト値を調整します。
<appSettings>
<add key="SeV.Global.PingTimeout" value="10000" />
</appSettings>
HPE ソフトウェアサポートオンラインWebサイトを参照してください。https://softwaresupport.hp.com
このサイトでは,HPE のお客様窓口のほか,HPE ソフトウェアが提供する製品,サービス,およびサポートに関する詳細情報をご覧いただけます。
HPE ソフトウェアオンラインではセルフソルブ機能を提供しています。お客様のビジネスを管理するのに必要な対話型の技術サポートツールに,素早く効率的にアクセスできます。HP ソフトウェア・サポートの Web サイトでは,次のようなことができます。
一部のサポートを除き,サポートのご利用には,HPE Passport ユーザとしてご登録の上,サインインしていただく必要があります。また,多くのサポートのご利用には,サポート契約が必要です。HPE Passport ID を登録するには,次の Web サイトにアクセスしてください。https://softwaresupport.hp.com で[Register]をクリックします。
アクセス・レベルの詳細については,次の Web サイトをご覧ください。https://softwaresupport.hp.com/web/softwaresupport/access-levels
「HPE Software Solutions Now」(https://softwaresupport.hp.com/group/softwaresupport/search-result/-/facetsearch/document/KM01702710)では,HPE ソフトウェア・カタログ内の製品の連携方法,情報の交換方法,ビジネス・ニーズの解決方法などをご覧いただけます。
「Cross Portfolio Best Practices Library」(https://hpln.hpe.com/group/best-practices-hpsw)では,ベスト・プラクティスに関して広範囲にわたるドキュメントや資料をご覧いただけます。
Hewlett Packard Enterprise Development LP製品、またはサービスの保証は、当該製品、およびサービスに付随する明示的な保証文によってのみ規定されるものとします。ここでの記載で追加保証を意図するものは一切ありません。ここに含まれる技術的、編集上の誤り、または欠如について、HPEはいかなる責任も負いません。
ここに記載する情報は,予告なしに変更されることがあります。
機密性のあるコンピュータ・ソフトウェアです。これらを所有、使用、または複製するには、HPEからの有効な使用許諾が必要です。商用コンピュータ・ソフトウェア,コンピュータ・ソフトウェアに関する文書類,および商用アイテムの技術データは,FAR 12.211 および 12.212 の規定に従い,ベンダーの標準商用ライセンスに基づいて米国政府に使用許諾が付与されます。
© Copyright 2011-2015 Hewlett Packard Enterprise Development LP
Internet Explorer®、SQL Server®、Microsoft®, Windows®、Windows Server®、およびWindows® 7は、米国におけるMicrosoft Corporationの登録商標です。
Oracle,Java,およびJDBCは,Oracle Corporationおよびその関連会社の登録商標です。
IBM®,WebSphere®,IMS™,およびCICS®は,米国およびその他の国におけるInternational Business Machines Corporation (IBM) の商標または登録商標です。
TIBCO®は,米国およびその他の国におけるTIBCO Software, Inc.およびその子会社の登録商標または商標です。
Intel®,Core™2,およびXeon®は,米国およびその他の国におけるIntel Corporationの商標です。
SAP® および SAP NetWeaver® は,ドイツおよびその他の国における SAP AG の登録商標です。