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Legal Notices

Warranty

The only warranties for Hewlett Packard Enterprise products and services are set forth in the express
warranty statements accompanying such products and services. Nothing herein should be construed as
constituting an additional warranty. HPE shall not be liable for technical or editorial errors or omissions
contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HPE required for possession, use or copying. Consistent
with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and
Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard
commercial license.

Copyright Notice
© Copyright 2015 Hewlett Packard Enterprise Development LP

Trademark Notices

Adobe™ is a trademark of Adobe Systems Incorporated.

Microsoft® and Windows® are U.S. registered trademarks of Microsoft Corporation.
UNIX® is a registered trademark of The Open Group.

This productincludes an interface of the 'zlib' general purpose compression library, which is Copyright ©
1995-2002 Jean-loup Gailly and Mark Adler.

Documentation Updates

The title page of this document contains the following identifying information:

« Software Version number, which indicates the software version.
« Document Release Date, which changes each time the document is updated.
« Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using the most recent edition of a document, go to:
https://softwaresupport.hp.com

This site requires that you register for an HPE Passport and sign in. To register for an HPE Passport ID, go
to: https://hpp12.passport.hpe.com/hppcf/createuser.do

Or click the Register link at the top of the HPE Software Support page.

You will also receive updated or new editions if you subscribe to the appropriate product support service.
Contact your HPE sales representative for details.

Support
Visit the HPE Software Support Online web site at: https://softwaresupport.hp.com

This website provides contact information and details about the products, services, and support that HPE
Software offers.

HPE Software online support provides customer self-solve capabilities. It provides a fast and efficient way to
access interactive technical support tools needed to manage your business. As a valued support customer,
you can benefit by using the support website to:
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Search for knowledge documents of interest

Submit and track support cases and enhancement requests
Download software patches

Manage support contracts

Look up HPE support contacts

Review information about available services

Enter into discussions with other software customers
Research and register for software training

Most of the support areas require that you register as an HPE Passport user and sign in. Many also require a
support contract. To register for an HPE Passport ID, go to:

https://hpp12.passport.hpe.com/hppcficreateuser.do
To find more information about access levels, go to:
https://softwaresupport.hp.com/web/softwaresupport/access-levels

HPE Software accesses the HPE Software to explore Enterprise Solutions that meet your business needs,
and a full list of Enterprise Software Products and Services. The URL for this website is
https://www.hpe.com/us/en/software.html.

About this PDF Version of Online Help

This documentis a PDF version of the online help. This PDF file is provided so you can easily print multiple
topics from the help information or read the online help in PDF format. Because this content was originally
created to be viewed as online help in a web browser, some topics may not be formatted properly. Some
interactive topics may not be presentin this PDF version. Those topics can be successfully printed from
within the online help.
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Chapter 1: Taxonomy Editor Guide

Welcome to the Taxonomy Editor User Guide. This guide describes how to use Taxonomy Editor as part of
HPE Enterprise Maps (HPE EM).

This guide contains the following chapters:

« " Taxonomy Editor" on page 8
Provides an overview of the main features of Taxonomy Editor.
« "Getting Started" on page 14
Describes the installation of the main features and shows you how to create a taxonomy project.
« "Managing Taxonomies" on page 21
Explains how to create, download, edit, and compare taxonomies.
« "Deploying Taxonomies" on page 27
Shows how to publish taxonomies and build and deploy a Taxonomy Extension.
« "Conflicts and Validation Issues" on page 32
Shows how to resolve conflicts with taxonomies.
« "Example: Creating and Publishing a Department Taxonomy" on page 34
A walkthrough example of creating and deploying a new taxonomy.
« "Keyboard Shortcuts" on page 35
Keyboard shortcuts reference.
« "Dialog Boxes Reference" on page 37
Dialog box reference.
« "Troubleshooting" on page 39
Troubleshooting tips.

HPE Enterprise Maps (3.10) Page 7 of 40



Chapter 2: Taxonomy Editor

HPE Enterprise Maps is a set of HPE EM Workbench features that enable you to manage taxonomies in
HPE EM.

You can use Taxonomy Editor to create, modify, and delete taxonomies. You can also download taxonomies
from, or upload them to, any number of HPE EM servers.

This chapter introduces Taxonomy Editor in the following sections:
o "HPE EM Workbench Suite" below

« "Overview" below

« "User Interface" on the next page

HPE EM Workbench Suite

HPE EM Workbench is a suite of editor tools enabling you to customize your deployment of HPE EM.

HPE EM Workbench consists of the following editor tools, distributed as a single Eclipse development
platform:

o Customization Editor
Customizes the underlying System Data Model (SDM) within HPE EM.
« Taxonomy Editor
Customizes the taxonomies used to categorize artifacts in HPE EM.
« Assertion Editor
Customizes the conditions applied by your business policies within HPE EM.
« Report Editor
Customizes report definitions for use with HPE EM.

Overview

Taxonomies are, in their simplest form, a visual representation of what your organization actually knows. A
well-constructed, meaningful taxonomy enables users in your organization to quickly find the information they
need to achieve their goals.

Taxonomy Editor enables you to organize and reorganize content easily, giving more flexibility for knowledge
sharing in your organization

Use Taxonomy Editor to do the following:

1. Create a Taxonomy Project.
For details, see the following sections:
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« "Creating a Taxonomy Project" on page 17
« "Downloading Taxonomies from a Server" on page 18
« "Searching for Taxonomies" on page 18

2. Create and Manage Taxonomies.
For details, see the following sections:
« "Creating Taxonomies" on page 21

« "Editing Taxonomies" on page 21

« "Editing Categories" on page 22

« "Deleting and Restoring Taxonomies" on page 24

o "Comparing Taxonomy Files" on page 25

» "Updating Taxonomies from the Server" on page 25

« "Importing and Exporting Taxonomy Files" on page 25

3. Publish taxonomies to an HPE EM server.
For details, see the following sections:
« "Publishing Taxonomies" on page 27

« "Deploying Taxonomies" on page 27

4. Check local validity and manage conflicts.

For details, see "Conflicts and Validation Issues" on page 32.

User Interface

The default perspective is split into a number of sections, with menu options across the top.
The platform perspective consists of the following views:

« Project Explorer
The tree view of your taxonomy projects. For details, see "Project Explorer" on the next page.
« Server Explorer

The view listing HPE EM server connections to the HPE EM Workbench. For details, see "Server
Explorer" on page 11.

« Editor

The view showing the components of the taxonomy. For details, see "Editor View" on page 11.
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Project Explorer

Project Explorer contains a hierarchical list of projects, the taxonomies in each project, and the categories
and subcategories of each taxonomy, as shown in the following screenshot.

The Project Explorer contains additional context menu options enabling you to interact with a running HPE
EM server. Right-click the project name or a particular assertion, and select HPE EM to view the options
listed in the following tables.

Project Context Menu Options

Option

Download
Taxonomies

Upload to
Server

Update from
Server

Remove from
Server

Upload To
Other Server

Build
Extension

Function

Import taxonomies from HPE EM. For details, see "Downloading Taxonomies from a
Server" on page 18.

Export taxonomies to the default HPE EM server. For details, see "Publishing
Taxonomies" on page 27.

Update taxonomies from HPE EM. For details, see "Updating Taxonomies from the
Server" on page 25.

Delete taxonomies from HPE EM. For details, see "Deleting and Restoring Taxonomies"
on page 24.

Export taxonomies to a specified HPE EM server.

Create a taxonomy extension for HPE EM containing all the taxonomies in your project.
For details, see "Building a Taxonomy Extension" on page 28.

Taxonomy Context Menu Options

Option

Upload to Server

Update from
Server

Remove from
Server

Upload To Other
Server

Validate Data
Consistency

Show Taxonomy
Usage

Compare With
Latest From
Server

HPE Enterprise Maps (3.10)

Function

Export a taxonomy to the default HPE EM server. For details, see "Publishing
Taxonomies" on page 27.

Update a taxonomy from HPE EM. For details, see "Updating Taxonomies from the
Server" on page 25.

Delete the taxonomy from HPE EM. For details, see "Deleting and Restoring
Taxonomies" on page 24.

Export a taxonomy to a specified HPE EM server.

Check the validity of the taxonomies. For details, see "Conflicts and Validation
Issues" on page 32.

Find the artifacts that use the taxonomy for categorization. For details, see "Conflicts
and Validation Issues" on page 32.

Compares the selected taxonomy with the latest version on the server.
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Taxonomy Context Menu Options, continued

Option Function

Build Extension Create a taxonomy extension for HPE EM containing all the taxonomies in your
project. For details, see "Building a Taxonomy Extension" on page 28.

Server Explorer

The Server Explorer displays the HPE EM servers connected to HPE EM Workbench. The functionality is
shared by all the HPE EM Workbench editors.

Right-click a server in the Server Explorer to open the context menu described in the following table.
Server Explorer Context Menu Options

Option Function

New Server Add a server for downloading assertions and taxonomies (Assertion Editor, Taxonomy
Editor, and Customization Editor).

Remove Delete a server from the Server Explorer.

Server

Download Download a taxonomy from a server (Taxonomy Editor and Customization Editor).
Taxonomy

Download Download assertions from a platform server (Assertion Editor).

Assertion

Download Download reports from a reporting server (Report Editor).

Report

Properties View and edit the server name, URL, username, and password.

Editor View

The Editor pane is the main feature of the Taxonomy Editor Ul.
It has four tabs, described in the following sections:

« Overview Tab
The Overview tab shows the components of the taxonomy.
The first section is General Information, where you can view and edit the following properties:
« Name

Name for the taxonomy. The content of the name element in the taxonomy's XML representation.

« Taxonomy ID

Identifier for the taxonomy, with the preceding uddi :. The value of tModelKey attribute in the
taxonomy's XML representation.
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« Description

Description of the taxonomy (optional).

The second section is Origin, which shows:
« Resource URL

REST interface URL enabling the published taxonomy to be viewed on the server.

« Value Display Format

These options allow changing how the value is presented.

. Categories Tab
The Categories tab enables you to change the structure and properties of taxonomy categories.
You can use the Categories tab to do the following:
« "Adding a Category" on page 23

« "Removing a Category" on page 23
« "Copying a Category" on page 23
« "Moving a Category" on page 24

« Advanced Tab
The Advanced tab enables you to set properties used with UDDI.
Itis divided into the following sections:
« Compatibility

Enables you to select one or more of the main UDDI structures for the taxonomy. For example,
businessEntity, businessService, bindingTemplate, and tModel.

All structure types are selected by default which is the required setting if you want your taxonomy to
integrate with UDDI Registry.
« Categorization
Enables you to select from the following taxonomy types:
o categorization
Tags the UDDI structure with additional information, such as identity, location, and description.
o categorizationGroup

Groups several categorizations into one logical category. For example, a categorizationGroup
could be a geographical location comprised of two categorizations: longitude and latitude.

The categorizationGroup option is disabled if the taxonomy has any categories.
o ldentifiers

Reference published information in businessEntities and tModels.
o Relationships

Defines the relationship between two businessEntities in Publisher Assertions.

« Validation
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Sets whether or not the values in keyedReferences within the taxonomy are checked. The validation
service can check the expected syntax of values. For example, a credit card number or an ISBN
number.

Validation can be against Taxonomy Editor's internal validation service or against an external service.
To select an external validation service, do one of the following:
o Enter the endpoint URL.

o Leave keyedReferences unvalidated.

« Reference

Enables you to add a reference to a key type.

« Value Type
Enables you to Select a Value type for keyValues, using one of the following comparators:
o em-com.comparator.string
keyValues are treated as string values. The maximum length is 255 characters.
o em-com.comparator.numeric

keyValues are treated as decimal numbers. The value can have a maximum of 19 digits before the
decimal point and a maximum of 6 digits after the decimal point.

o em-com.comparator.date
keyValues are treated as dates.
o custom

Endpoint URL of a custom comparator.

o Source Tab

The Source tab enables you to view and directly edit the XML representation of the taxonomy.
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Chapter 3: Getting Started

This chapter describes the prerequisites for working with taxonomies in Taxonomy Editor. It contains the
following sections:

« "Installing HPE EM Workbench" below

« "SSL Configuration" on page 16

« "Creating a Taxonomy Project" on page 17

« "Customizing Taxonomy Editor" on page 18

« "Downloading Taxonomies from a Server" on page 18

» "Searching for Taxonomies" on page 18

Installing HPE EM Workbench

HPE EM is an Eclipse development platform distributed as a zip file, hpe-em-workbench-3.10-win64. zip.

Note: HPE EM requires Java SE Development Kit (JDK) 1.8.0 (64 bit version only) or higher. You must
include the path to this version of the JDK in the JAVA_HOME environment variable.
To install Enterprise Maps as a new Eclipse platform:

« Extract the archive to your required location, referred to in this document as WB_HOME.

Note: The path must not be longer than 97 characters.

To Start HPE EM:

« Execute WB_HOME/workbench/start.exe.
The first time you start HPE EM Workbench, the welcome screen opens.

Select one of the options to open one of the editor tools, start a new editing project, or view the documentation
set.

You can return to the welcome screen from any of the editor tools by selecting Help > Welcome from the
menu options.

Tip: By default, HPE EM Workbench runs in 'normal’ mode which prevents users from uploading system

taxonomies (IDs start with uddi:systinet.com:soa:model:taxonomies)and the Report Editor
.rptlibrary file to HPE EM servers. If you need to work with system taxonomies or want to upload the
.rptlibrary file you can switch HPE EM Workbench into 'admin’ mode.

Caution: Be extremely careful when working with system taxonomies, HPE EM uses some hard-coded
values from system taxonomies. Changing or removing them may cause errors.

To Switch HPE EM Workbench to Admin Mode
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1. OpenWB_HOME/configuration/config.ini with atext editor.
2. Add mode=adminto config.ini.
3. Restart HPE EM Workbench.

Tip: HPE Enterprise Maps is memory-intensive. If you experience performance issues, HPE
recommends increasing the memory allocation.

To increase the memory allocation for HPE Enterprise Maps:

1. Open WB_HOME /workbench/start.ini for editing.
2. Setthese new values:
e -Xmsl1l28m

e -Xmx1024m

3. Save your changes.
4. Restart HPE EM Workbench.

Tip: HPE Enterprise Maps downloads from HPE EM may time out. If you experience issues, HPE
recommends increasing the time out.

To increase the time out for HPE Enterprise Maps:

1. Open WB_HOME/workbench/start.ini (oreclipse.ini for stand-alone installation) for editing.
2. Set the new value:
-Dorg.em.platform.rest.Client.timeout=200000

The value is in milliseconds with a default value of 120000 (2 minutes).
3. Save your changes.

4. Restart HPE EM Workbench.

Tip: HPE EM Workbench may fail to store saved credentials of servers. In such cases, HPE
recommends clearing the secure storage.

To reset the secure storage for Enterprise Maps server credentials:
1. In Enterprise Maps, go to Windows > Preferences > General > Security > Security Storage >
Contents tab.

2. Click root node Default Secure Storage and then click Delete button.
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== Preferences '?'@

type filter text Secure Storage =T v v

4 General -
. Appearance Contents | Advanced

Capabilities
Compare/Patch
Content Types

» Editors
Keys

> Metwork Connectior
Perspectives

. [Default Secure Storage] Values associated with the selected node:

D Value

Search
4 Security
Secure Storage
Service Policies
» Startup and Shutdov
Tracing
Web Browser

m

» Workspace
- Ant
» Data Management
» Help 4 m P
» HPE Enterprise Maps
- Install/Update Save
- Java

» Java Persistence

, JavaScript Storage location:

» Plug-in Development CiiUsershy ‘.eclipseorg.eclipse.equinox.security\secure_storage

- Report Design

7 n.._rn.lr;r.._ . [Restore Qefaults] [ Apply l

@j [ OK ] ’ Cancel ]

3. Restart the Workbench.

SSL Configuration

By default, HPE EM Workbench trusts all HPE EM server certificates. You may want HPE EM Workbench
to verify HPE EM certificates.
To Verify HPE EM Server Certificates:

« Add the following options to WB_HOME /workbench/start.ini:

-Dcom.hp.em.security.ssl.verifyCert=true
-Djavax.net.ssl.trustStore=USER_TRUSTSTORE
-Djavax.net.ssl.trustStorePassword=TRUSTSTORE_PASS
-Djavax.net.ssl.trustStoreType=TRUSTSTORE_FORMAT

If HPE EM is configured for 2-way SSL, you must provide HPE EM Workbench certificates to HPE EM.
To Provide HPE EM Workbench Client Certificates to HPE EM:
« Add the following options to WB_HOME /workbench/start.ini:

|—Djavax.net.ssl.keyStore:USER_KEYSTORE |
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-Djavax.net.ssl.keyStorePassword=KEYSTORE_PASS
-Djavax.net.ssl.keyStoreType=KEYSTORE_FORMAT

Creating a Taxonomy Project

To work with taxonomies, you need a Taxonomy Project. You can create any number of Taxonomy Projects
to help organize your work.

To Create a Taxonomy Project:

1. Do one of the following:

« Inthe HPE EM Workbench Welcome page, click Create Taxonomy Project.

e Click New " to open the Select a Wizard window, and select HPE EM > Taxonomy Project.
« From the menu, select File > New > Taxonomy Project.

« Press Alt+Shift+N, and then press R, to open the Select a Wizard window. Then select HPE
EM>Taxonomy Project.

The New Taxonomy Project dialog box opens.

2. Inthe New Taxonomy Project dialog box, enter the following parameters:
Parameter Definition

Project Name = The name of your assertion project.

Taxonomy The URN prefix to apply to all taxonomies in the project.

ID Prefix

Create from Select this option if you want to create a new project from a previous taxonomy
Existing extension. If selected, input the path or browse for the location of the taxonomyn
Extension extension.

Use Default If selected, Taxonomy Editor stores the project in your default workspace. If
Location unselected, input the path or browse for an alternative workspace.

3. Click Next to select or create a server.
Note: If no servers are currently defined, the dialog box continues to step 5.
4. Do one of the following:
« Select Create a New Server, and click Next.
Continue to step 5.

« Select Use an Existing Server, select the server from the list and input its credentials, and then
click Next.

Continue to step 6.

In the New Server dialog box, add the required parameters, and then click Next.

6. Select the taxonomies to download from the server. Optionally, select Show System Taxonomies to
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view system taxonomies for selection.
7. Click Finish.

Customizing Taxonomy Editor

Some settings are customizable in Taxonomy Editor.
To Change Taxonomy Editor Preferences:

1. Select Window > Preferences.

The Preferences dialog box opens.

In the tree menu, select HPE EM > Taxonomy Editor.
3. You can change the following:

« Default taxonomy namespace

The default namespace setting is 5.5.This defines taxonomy compatibility level with other UDDI
products.

. Data consistency

Select Validate before publishing taxonomies to validate changes before publishing them to the
server

Downloading Taxonomies from a Server

Initially, Taxonomy Editor does not contain any taxonomies. To edit HPE EM taxonomies, you must
download them from a server.

To Download Taxonomies from a Server:

1. In Server Explorer, right-click the server containing the taxonomies you need to open its context menu,
and select Download Taxonomies.

The Download Taxonomies wizard opens.
2. Select the taxonomies to download and click Next.
The Choose Location dialog box opens.
3. Select the project to add the taxonomies to, and then click Finish.

Taxonomy Editor displays the download progress. When the download is complete, the taxonomies are
visible in Project Explorer.

Searching for Taxonomies

This section describes the search facilities provided by Taxonomy Editor.
Quick Find is the easiest way to find a taxonomy.

To use Quick Find:

HPE Enterprise Maps (3.10) Page 18 of 40



Taxonomy Editor User Guide
Chapter 3: Getting Started

1. Do one of the following:
« Click Search, and then select Quick Jump.

e Press Ctri+J.

The Find Taxonomy dialog box opens. For details, see "Find Taxonomy Dialog" on page 38.
In the input field, enter a search string.

Click View Menu ~, and then select one of the following options:

o Show in the tree without opening detail

Shows the taxonomy in the tree but does not open its details page.

« Case-sensitive

Enables a case-sensitive or case-insensitive search.

4. Inthe in project field, select in which project to search for the taxonomy.
Taxonomies that match your search criteria are displayed in the Matching taxonomies pane.
5. Select the required taxonomy and click Open taxonomy.
The taxonomy opens in the Editor pane.
For a more detailed search, you can use Advanced Search to do the following:
« Search for a specific property type.
« Search according to a specific value of a property.
« Search different text strings: full text, regular expression, or whole word.
To Use Advanced Search:
1. Do one of the following:
o Select Search>Search.

e Press Ctri+H.

The Search dialog box opens.

2. Select the Taxonomy Search tab to open the dialog box. For details, see "Search Taxonomy Dialog" on
page 38.

3. Inthe Containing text field, do one of the following:
« Enterthe text to search.

» Select text used in a previous search by using the drop-down list.

In Search only in, choose the taxonomy properties or categories to search.
In Search controls, select one or more of the following:
« Case-sensitive

To perform a case-sensitive search.

« Whole words only
To search for whole word matches.
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« Regular expression
To search using regular expressions.

6. InScope, select one of the following:
o Workspace
To search the Eclipse workspace.

» Selected resources
To search all entities selected in Project Explorer.

« Working set
To customized resources from Project Explorer.

7. Click Choose.
The Select Working Sets wizard opens.
Do one of the following:
« Select from existing working sets.

« Create new working sets.

8. Click Search.
The results are displayed in the Search view of the Ul.
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This chapter describes how to work with taxonomies, as detailed in the following sections:

"Creating Taxonomies" below

"Editing Taxonomies" below

"Editing Categories" on the next page

"Deleting and Restoring Taxonomies" on page 24
"Comparing Taxonomy Files" on page 25
"Updating Taxonomies from the Server" on page 25

"Importing and Exporting Taxonomy Files" on page 25

Creating Taxonomies

In "Creating a Taxonomy Project" on page 17, you created a Taxonomy Project and looked at how to
download taxonomies. The following section describes how to create new taxonomies.

To Create a New Taxonomy:

1.

Do one of the following:

o Click New " to open the Select a Wizard dialog box, and select HPE EM > Taxonomy, and then
click Next.

« Select File > New > Taxonomy.

« Press Alt+Shift+N to open the context menu, and then select Taxonomy.

The New Taxonomy wizard opens.

In the New Taxonomy wizard, enter the required parameters.

Note: Note: A default Taxonomy ID and Filename are assigned according to the Taxonomy Name
entered. The Source Folder is assigned by default, according to whether there is an active
extension project. You can change these parameters to meet your requirements.

Click Finish to create the taxonomy.
The taxonomy is now visible in Project Explorer and the Taxonomy Editor opens.

Open the Categories tab and add the categories you need. For details, see "Editing Categories" on the
next page.

5. Open the Advanced tab and enter the required parameters, as described in "Editor View" on page 11.

Editing Taxonomies

A taxonomy can be modified in the following ways:
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« "Editing Taxonomy Properties" below
« "Refreshing Taxonomies to Reflect External Changes" below
« "Copying Taxonomies" below

Editing Taxonomy Properties

To Edit Taxonomy Properties:

1. Double-click the taxonomy in Project Explorer to open the Editor view.
2. Edit properties as required in the tabs of the Editor view. For details, see "Editor View" on page 11.
3. Click Save.

The changed status of the taxonomy is displayed in Project Explorer.

Refreshing Taxonomies to Reflect External Changes

If you want the Editor to reflect changes made outside Taxonomy Editor, you can refresh the taxonomy.
To refresh a taxonomy, do one of the following:

« Right-click the individual taxonomies or the project in Project Explorer to open the context menu, and then
select Refresh.

« Select the individual taxonomies or the project in Project Explorer, and then press F5.
The selected taxonomies are then updated to reflect external changes.

Copying Taxonomies

You can copy or move taxonomies from one project to another using cut, copy, or paste.
To Copy or Move a Taxonomy to a Different Project:

1. Right-click the taxonomy in Project Explorer and select Copy or Cut.
2. Right-click the project to which you want to copy or move the taxonomies and select Paste.
The taxonomies are then either copied or moved to the other project.
A pasted taxonomy has the status:
o New
If a taxonomy of that name is new to that location.
o Modified

If an existing taxonomy is overwritten.

Editing Categories

A taxonomy can be modified in the following ways:
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» "Adding a Category" below

« "Removing a Category" below

« "Copying a Category" below

« "Moving a Category" on the next page

Adding a Category

To Add a New Category to a Taxonomy:

1. Open the required taxonomy in the Editor pane and click the Categories tab.
2. Do one of the following:
o Click Add Nextto add a new category at the same level.

o Click Add Child to add a new sub-category.

The New Category wizard opens.
3. Enter the category properties, as follows:
« Name

Name for the category. This represents the value of the keyName attribute in the taxonomy's XML
representation.

o Value

Identifier for the category. This represents the value of the keyValue attribute in the taxonomy's XML
representation.

« Disabled
Select this check box to make sure the category cannot be used in an artifact.

4. Click Finish.
The new category is displayed in Category Structure.

Removing a Category

To Remove a Category:

1. Open the required taxonomy in the Editor pane and click the Categories tab.
2. Right-click the category in the Category Structure pane to open its context menu, and select Delete.
The deleted category is no longer visible in the Category Structure pane.

Copying a Category

To Copy a Category:

1. Open the required taxonomy in the Editor pane and click the Categories tab.

2. Right-click the required source category in the Category Structure pane to open its context menu, and
then select Copy or Cut.
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3. Right-click the required destination category in the Category Structure pane to open its context menu.

4. Do one of the following:
« Select Paste to add the category as a sub-category.

« Select Paste as Sibling to add the category at the same level.

Moving a Category

To Move a Category:

1. Open the required taxonomy in the Editor pane and click the Categories tab.

2. Select the required category in the Category Structure pane.
3. Do one of the following:

o Click Up, to move a category up.
« Click Down, to move a category down.
« Click Unindent, to move a category to the left.

« Click Indent, to move a category to the right.

Note: Note: To move multiple categories at the same time, you must select categories that are

consecutive.

Deleting and Restoring Taxonomies

You can also delete taxonomies and restore them from your local history.

To Delete a Local Taxonomy:

1. Right-click the taxonomy in Project Explorer to open its context menu, and then select Delete.

2. Confirm deletion of the taxonomy when prompted.
To Restore a Deleted Taxonomy:

1. Right-click the project in Project Explorer to open its context menu and select Restore from Local

History.
The Restore from Local History dialog box opens.
Select the check box of the required taxonomy and click Restore.

Download the published taxonomy from the server, as described in “Downloading Taxonomies from a

Server’.

To Delete a Taxonomy from the Server:

1. Right-click the taxonomy in Project Explorer to open its context menu and select HPE EM > Remove

from Server.
Choose if you also want to delete the local copy.
3. Confirm deletion of the taxonomy when prompted.
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Note: Note: Taxonomy Editor automatically performs a data consistency check before removing the
taxonomy from the server. For details, see “Conflict With Server”.

Comparing Taxonomy Files

If you are importing or exporting taxonomies between servers, it is essential to compare taxonomies to keep
track of changes.

Taxonomy Editor enables you to compare the following taxonomies:
« Local taxonomy against the server taxonomy.

« Server taxonomy against a local history taxonomy.

To Compare Taxonomies:

Right-click the taxonomies you want to compare in Project Explorer to open a context menu, and then select
one of the following:

o Compare With > Each Other

« HPE EM > Compare with the latest on server
o Compare With > Local History

The results are displayed in the Compare view.

Updating Taxonomies from the Server

If the most current version of a taxonomy exists on a server, you can update your local copy to reflect any
changes.

To Update a Local Taxonomy:

« Right-click the taxonomy in Project Explorer to open the context menu, and then select HPE EM >
Update from Server.

Note: Confirmation is required to overwrite existing taxonomies.

Importing and Exporting Taxonomy Files

You can import and export taxonomies between your projects and your local file system.
To Import a Taxonomy from your File System:

1. InProject Explorer, right-click the taxonomy project to which you want to import taxonomies to open its
context menu, and then select Import > Taxonomy.

The Import Taxonomies wizard opens. For details, see "Import Taxonomies" on page 37.
2. Browse for the folder from which you want to export taxonomies in the Folder field.

The selected folder is displayed in the left pane.
3. Click the check box of the chosen folder.

Compatible file types are displayed in the right pane.
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Click the check box of the files you want to import and, and then browse for the required import folder in
the Into folder field.

5. Click Finish.

6. Publish the taxonomies to an HPE EM repository, as described in "Publishing Taxonomies" on page 27.

Tip: Tip: When importing a taxonomy from a file whose file name already exists in the local folder,
Taxonomy Editor asks if you want to overwrite the taxonomy. If you click Yes or Yes To All, the current
taxonomy is updated by attributes and categories from the XML file and its status is changed to modified.

To Export a Taxonomy:

1. Right-click the taxonomy in Project Explorer to open its context menu, and then select Export to open
the Export wizard. For details, see "Export Taxonomies Wizard" on page 37.

Select the required file type and click Next to open the corresponding wizard.

Browse for the required destination and enter the required parameters.

Select whether to overwrite existing files.

Click Finish.

o > 0D

Note: Note: You can export a taxonomy to any file type supported by Eclipse. For example:
o XML file
« JAR archive

« EAR-deployable or JAR-deployable archiv

HPE Enterprise Maps (3.10) Page 26 of 40



Chapter 5: Deploying Taxonomies

This chapter explains how to deploy a set of taxonomies as an Extension Project.

You can publish individual taxonomies as described in "Publishing Taxonomies" below.

Alternatively, create a taxonomy extension and deploy it as described in the following sections:

"Publishing Taxonomies" below
"Building a Taxonomy Extension" on the next page
"Applying Extensions " on the next page

"Redeploying the EAR File" on page 30

Publishing Taxonomies

Publishing is the process of updating changes to an HPE EM server.

To Publish a Taxonomy:

« Right-click the taxonomy in the Project Explorer to open its context menu, and then select HPE EM>
Upload to Server. Multiple taxonomies may be selected by holding CTRL and selecting them.

The taxonomy is published to the defined HPE EM server.

Caution: Caution: You cannot publish a System taxonomy to a remote repository.

The status of a taxonomy after publishing updates as described in the following table.

Taxonomy Status After Publication

Status Description

UP-TO- Local and server versions are identical.
DATE

NEW ? Local version of the taxonomy has not

been published to the server.

MODIFIED @ Changes have been made to a local
> version of a taxonomy after it has been
published.

SYSTEM  Taxonomies automatically generated by
[% HPE EM. For system use only.

HPE Enterprise Maps (3.10)

Impact

Publication was successful, including any
modifications.

Publication was unsuccessful and the status is
unchanged. Possibly due to one of the
following:

« Exception error.
« Breach of server data integrity.

Changes to these taxonomies cannot be
published.
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Building a Taxonomy Extension

After publishing taxonomies, you can create a Taxonomy Extension.

To Build a Taxonomy Extension:

1.

Right-click the taxonomy project in Project Explorer to open its context menu, and expand HPE EM >
Build Extension to open the location browser.

Enter a name for the extension project and browse for the location you want to save the project to, and
click Save.

All taxonomies from the selected taxonomy project are copied to the Taxonomy Extension.

Applying Extensions

You can extend HPE EM by adding libraries or JSPs to the deployed EAR files, by modifying the data model,
by configuring the appearance of the Ul, and by importing prepackaged data.

Extensions to HPE EM come from the following sources:

Customization Editor

Typical extensions created by Customization Editor contain modifications to the data model and artifact
appearance, and possibly data required by the customization (taxonomies). They may also contain new
web components, which may include custom JSP and Java code.

If your extension contains new artifact types, HPE EM does not create default ACLs for them. Set default
ACLs for the new artifact types in HPE EM.

Assertion Editor, Report Editor, and Taxonomy Editor

These extensions contain assertion, reporting, and taxonomy data only. They do not involve changes to
the data model.

The Setup Tool opens the EAR files, applies the extensions, and then repacks the EAR files.

Apply extensions according to one of the following scenarios:

"Single-Step Scenario " on the next page

The Setup Tool performs all the processes involved in applying extensions, including any database
alterations, as a single step.

"Decoupled DB Scenario " on page 30

Database SQL scripts are run manually. The Setup Tool performs the other processes as individual steps
that are executable on demand. This scenario is useful in organizations where the user applying
extensions does not have the right to alter the database, which is done by a database administrator.

Caution: In some specific circumstances (underscores and numbers in property names), extension
application may fail because HPE EM cannot create short enough database table names (31
character maximum for most databases).

The errorin setup. log resembles the following:

[java] --- Nested Exception ---
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[java] java.lang.RuntimeException: cannot reduce length of identifier
'ry_c_es_Artifact@2s_c_priEspPty@1Group_c_priEspPtyel’,
rename identifier elements or improve the squeezing algorithm

[java] at com.em.platform.rdbms.design.decomposition.naming.impl.
BlizzardNameProviderImpl.getUniquelLimitedLengthName(

BlizzardNameProviderImpl.java:432)

[java] at com.em.platform.rdbms.design.decomposition.naming.impl.

BlizzardNameProviderImpl.filterTableName(BlizzardNameProviderImpl.java:374)

If you do not require backward compatibility with these older versions, you can change the table naming
algorithm.

To change the table naming algorithm:

1. Open EM_HOME/1ib/pl-repository-old.jar#META-INF/rdbPlatformContext.xml with atext
editor.

2. Inthe rdb-nameProvider bean element, edit the following property element:
<property name="platform250Compatible" value="false"/>
3. Save rdbPlatformContext.xml

Caution: This solution only impacts properties with multiple cardinality. If the problem persists,
then review the property naming conventions in your extension.

Single-Step Scenario

Follow this scenario if you have permission to alter the database used for HPE EM.
To apply extensions to HPE EM in a single step:

1. Make sure that all extensions are in the following directory:
EM_HOME/extensions
The Setup Tool automatically applies all extensions in that directory.
If you are applying extensions to another server, substitute the relevant home directory for EM_HOME
Stop the server.
Start the Setup Tool by executing the following command:
EM_HOME/bin/setup.bat(sh)
4. Select the Apply Extensions scenario, and click Next.

The Setup Tool automatically validates the step by connecting to the server, copying the extensions,
and merging the SDM configuration.

5. Click Next for each of the validation steps and the setup execution.

This process takes some time.

Click Finish to end the process.

Deploy the EAR file:

The Setup Tool deploys the EAR file automatically.

If you need to deploy the EAR file to JBoss manually, see Redeploying the EAR File.
8. Restart the server.

HPE Enterprise Maps (3.10) Page 29 of 40



Taxonomy Editor User Guide
Chapter 5: Deploying Taxonomies

Caution: Applying an extension that modifies the SDM model may drop your full text indices.
EM_HOME/log/setup.log contains the following line in these cases:

Could not apply alteration scripts, application will continue with slower DB
drop/create/restore scenario.

In these cases, reapply full text indices.

Decoupled DB Scenario

Follow this scenario if the user who applies extensions does not have permission to modify the database.
To apply extensions and modify the database separately:

1. Make sure that all extensions are in the following directory:
EM_HOME/extensions
The Setup Tool automatically applies all extensions in that directory.
Stop the server.
Start the Setup Tool by executing the following command:
EM_HOME/bin/setup -a.

4. Select the Apply Extensions scenario, and click Next.
Click Next, to execute the extension application, and exit the Setup Tool.
Provide the scripts from EM_HOME/sq1 to the database administrator.

The database administrator can use all.sql to execute the scripts that drop and recreate the database
schema.

7. Execute the Setup Tool in command-line mode to finish the extension application:
EM_HOME/bin/setup -c

8. Redeploy the EAR file:
The Setup Tool deploys the EAR file automatically.
If you need to deploy the EAR file to JBoss manually, see Redeploying the EAR File.

Redeploying the EAR File

After using the Setup Tool to apply extensions or updates, you must redeploy the EAR file to the application
server. For JBoss, you can do this using the Setup Tool.

To Redeploy the EAR file to JBoss:
1. Stop the application server.
2. Start the Setup Tool by executing the following command:
EM_HOME/bin/setup.bat(sh)
3. Select the Advanced scenario, and click Next.
Scroll down, select Deployment, and then click Next.
When the Setup Tool validates the existence of the JBoss Deployment folder, click Next.
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5. Click Finish to close the Setup Tool.
6. Restart the application server.
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Editing taxonomies can result in validation and conflict issues, as described in the following sections:

« "Local Validity" below
o "Server Conflicts" below

« "Repair Action" below

Local Validity

By default, the validity of local taxonomies is constantly checked as you modify them.. Invalid taxonomies
are marked in Project Explorer and the associated errors are listed in the Problems view.

To disable validation, from the menu, deselect Build automatically.

Server Conflicts

A local taxonomy and the version on a server can come into conflict either when the version on the server is
changed or when changes to the local version affect artifacts on the server.

Conflicts are displayed when you try to publish the taxonomy. An error message is displayed, stating that the
taxonomy could not be published.

To help prevent conflicts, you can do the following:
« Right-click the taxonomy in Project Explorer to open its context menu, and then select one of the following:

« HPE EM > Show Taxonomy Usage
All artifacts categorized by the taxonomy are displayed in the Taxonomy Usage view.

« Right-click the taxonomy in Project Explorer to open its context menu, and then select HPE EM >
Validate Data Consistency

Conflicts are displayed in the Validation Results view.

Repair Action

The Data Consistency Check reports artifacts that use categories which no longer exist in the taxonomy
project.

Taxonomy Editor features a Repair Action which enables you to resolve these inconsistencies.
To Repair an Inconsistency:

1. Inthe Validation Results view, expand the problem category, and right-click an artifact to open its
context menu, then select one of the following:
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« Remove Referenced Category From Artifact
« Change Category

2. Re-run validation.

Note: Note: Some conflicts relate to the validity of policy and lifecycle data (non-standard artifacts). The
repair actions cannot resolve these conflicts.
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a Department Taxonomy

In this example, you create and deploy a new taxonomy containing the identities of departments in your
organization.

Before proceeding, you must do the following:

« Define your HPE EM server.
« Update the local taxonomies, as described in "Updating Taxonomies from the Server" on page 25.
To Create a Department Taxonomy:
1. Create a new taxonomy, entering Departments as the Taxonomy Name.
For details of the procedure, see "Creating Taxonomies" on page 21.
2. Open the Editor for the Departments taxonomy and select the Categories tab.
3. Add the following categories:
« HR

o IT

« Payroll

« Finance

« Sales

« Development
« QA

For details of the procedure, see "Adding a Category" on page 23.
4. Press Ctrl+S to save the taxonomy.
The Departments taxonomy is now visible in Project Explorer.
5. Right-click the Departments taxonomy to open its context menu, and then select one of the following:
« HPE EM > Publish Taxonomy
To publish the taxonomy to the defined HPE EM server.

« HPE EM > Publish To Other Server
To publish the taxonomy to a different server.
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Shortcut

CtrI+Alt+S

Ctrl+N

Alt+A, Insert

Alt+C

Alt+U, Ctrl+ArrowUp
Alt+D, Ctrl+ArrowDown
Alt+E, Ctrl+ArrowLeft
Alt+l, Ctri+ArrowRight
F2

Esc

Ctrl+PgDn

Ctrl+PgUp

F12
Ctrl+W, Ctrl+F4

Ctri+Shift+W,
Ctrl+Shift+F4

Ctrl+F6
Ctrl+Shift+F6
Ctrl+Shift+E
Ctrl+J

Ctrl+H
Alt+Shift+W
F5

Ctrl+S
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Keyboard Shortcuts

Action

Add HPE EM server.

New taxonomy.

Add next category.

Add child category.

Move category up.

Move category down.

Move category left (unindent).
Move category right (indent).
Navigate to Category Name field.

Ignore changes in current test field and switch to Category
Structure

Switch to next editor tab.
Switch to previous editor tab.

Activate Editor.
Close current editor.

Close all editors.

Go to next editor.

Go to previous editor.

Switch to editor.

Quick find taxonomy.

Search taxonomy or category.

Show editing resource in Taxonomy Editor.
Refresh items.

Save changes for active editor.

Context
Global

Global
Categories tab
Categories tab
Categories tab
Categories tab
Categories tab
Categories tab
Categories tab

Categories tab

Taxonomy
Editor

Taxonomy
Editor

Global
Global

Global

Global
Global
Global
Global
Global
Global
Global

Global
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Shortcut
Ctrl+Shift+S
Ctrl+C, Ctrl+Insert
Ctri+X, Shift+Delete
Delete

Ctrl+V, shift+Insert
Ctrl+Shift+L
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Action

Save changes for all editors.

Copy
Cut
Delete
Paste

Show key assist

Context
Global
Global
Global
Global
Global

Global
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Each Taxonomy Editor input dialog is described in the following sections:

« "Import Taxonomies" below

« "Export Taxonomies Wizard" below

« "Find Taxonomy Dialog" on the next page

« "Search Taxonomy Dialog" on the next page

Import Taxonomies

Select taxonomy files to import into your taxonomy project:

Parameter
Folder

Left Pane
Right Pane

Into Folder

Definition

Browse for the source folder containing the taxonomy files you want to import.
Select the source folder containing the taxonomy files you want to import.
Select the individual taxonomy files you want to import.

Browse for the destination folder into which you want to import the selected taxonomies.

Export Taxonomies Wizard

Select a destination for the taxonomies you wish to export:

Parameter

Definition

Select an export destination = Enter text to filter your search.

Tree View

Select File System as your destination folder.

Select the taxonomies you want to export, then browse for the destination directory:

Parameter
Left Pane
Right Pane

To Directory

Definition
Select the project from which you want to export taxonomies.
Select the individual taxonomies you want to export.

Browse for and select the directory into which you want to export the selected taxonomies.
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Find Taxonomy Dialog

A quick search for matching taxonomies:

Parameter

Top Field

Definition

Enter text to filter your search results.

Matching Taxonomies = A list of taxonomies matching your search request.

In Project

Select the project in which you want to search for taxonomies.

Search Taxonomy Dialog

An advanced search for matching taxonomies:

Parameter
Containing Text

Working Set

HPE Enterprise Maps (3.10)

Definition
Enter text to search or use the drop-down menu to select a previous search parameter.

Browse for and select a working set as a scope for your search.
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Case

A taxonomy was
changed on the
remote server
while you were
modifying your
local version.

A taxonomy was
published that has
the same file
name as a new
taxonomy you are
trying to publish to
the remote server.

The taxonomy
you have created
has the same ID
as an existing
taxonomy on the
remote server

You have
changed the ID of
ataxonomy used
by artifacts.

A category that
you modified is
used by other
artifacts.

A new taxonomy
ID is identical to
that of another

Indications

Your local taxonomy is
CONFLICTING. The local
version cannot be
published and its
modifications are kept.

Taxonomy is
CONFLICTING. The local
version cannot be
published. Changes to the
local taxonomy and server
remain in Project Explorer.

The local taxonomy
cannot be published.
Changes to the local
taxonomy and server
remain in Project Explorer.
The Validation Results
include a node giving the
taxonomy ID.

The local taxonomy
cannot be published and
remains MODIFIED. The
Validation Results list
artifacts that use the
taxonomy.

The local taxonomy
cannot be published and
remains MODIFIED.
Validation Results lists
artifacts that use the
category.

An error message for this
taxonomy is shown.
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Resolution

To replace the local
taxonomy with the server
version, use the taxonomy
context action HPE EM >
Update Taxonomy. You
might want to first copy your
local version to a temporary
location.

To replace the local
taxonomy with the remote
server version, use the
taxonomy context action
HPE EM > Update
Taxonomy. You might want
to first make a backup copy
your local version.

Change the ID of the new
taxonomy.

To restore the original
taxonomy, use the taxonomy
context action HPE EM >
Update Taxonomy.

To restore the original
taxonomy, use the taxonomy
context action HPE EM >
Update Taxonomy.

Change taxonomy ID to
another value.

Type Severity
Conflict Error
Conflict Error
Validation Error
Results

Validation Error
Results

Validation Error
Results

Local Error

Inconsistency
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Case Indications
local taxonomy.

Taxonomy ID A warning message for
format is invalid.  this taxonomy is shown.

Category valueis | An error message for this
duplicated by taxonomy is shown.
another category

in the same

taxonomy.

Taxonomy file An error message for this
name contains taxonomy is shown.
invalid character

for REST URL.

HPE Enterprise Maps (3.10)

Resolution

Change taxonomy ID to valid
format.

Change the category value.

Change file name so that it
does not contain invalid
character.

Type Severity

Local Warning
Inconsistency

Local Error
Inconsistency

Local Error
Inconsistency
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