Cache Files have lost sync with your directory data. Would you like to delete your cache files and have them re-created?

  • 7940279
  • 19-Aug-2009
  • 17-Jan-2014

Environment

SecureLogin
SecureLogin SSO
All Versions


Situation

Issue

Customer upgraded from SecureLogin version 3.04 to version 3.5.2.

Every time the cache is refreshed - either automatically or manually (Refresh Cache from the system tray icon) the following message appears;

""Your cache files have lost sync with your directory data. Would you like to delete your cache files and have them re-created?

Warning any SL details not stored in the directory will be lost.""

Customer answers yes and the product still works but it is annoying.

Resolution

Cause

SecureLogin includes an option to enable an offline cache which is used if the network server is unavailable and/or when using offline mode (e.g. laptop). When SecureLogin loads, it reads SecureLogin data such as SSO enabled applications, user IDs and passwords, and copies and encrypts them on the hard disk of the local workstation.

The cache had lost synchronization with the Directory and could not auto correct itself.

Solution

To solve the problem the customer completely cleared and resynchronized the cache by performing the following tasks;

  • Closed down SecureLogin
  • Checked for (and deleted .cache files) in cache location;

Default Location

* C\:Documents and Settings\USERNAME\Application Data\SecureLogin\Cache\V3SLC

Location if cache is not stored in user profile directory

* C:\Program Files\ActivIdentity\SecureLogin\Cache\V3SLC

Earlier versions of SL stored cache in V2SLC

* C:\Program Files\Protocom\SecureLogin\Cache\V2SLC

* C:\Documents and Settings\USERNAME\Application Data\SecureLogin\Cache\V2SLC

  • Once the cache file has been deleted, start SecureLogin and the problem should be resolved.