SecureLogin client failing to start - cache not being created

  • 7940146
  • 19-Aug-2009
  • 07-Jan-2014

Environment

SecureLogin
SecureLogin SSO
All Versions
MS AD, LDAP, NT4, Citrix, Terminal Services


Situation

Issue

Customer installed SecureLogin Single Sign-On on a user’s workstation. They then tried to start SecureLogin. They were able to set a passphrase but the client failed to load.

Resolution

Cause

As well as Directory rights to read SSO data and write their passphrase and other SSO data such as application usernames and passwords against their user object, users must have rights to create a local cache on the workstation hard disk when SecureLogin loads.

By default, the cache is stored in the user profile so the user typically has rights to save it (to view the cache you may have to change your settings to view hidden files/folders).

The customer had changed the default cache location to the root of C: drive but the user doesn’t have rights to create it. They are able to read the data from the Directory, but not write the data to the hard disk cache.

Solution

To correct the problem grant the user write rights to the directory where the cache files are stored. By default the cache file is stored in the users profile and they have rights but some organizations wish to change the directory and rights must be assigned.