SecureLogin slow to load in Microsoft ADS environment

  • 7940145
  • 19-Aug-2009
  • 07-Jan-2014

Environment

SecureLogin
SecureLogin SSO
All Versions
Active Directory


Situation

Issue

Customer installed SecureLogin in ADS mode and it was slow to load. The message on the screen displayed advising SecureLogin data was loading, but it sat there for a long time and appeared to hang.

Resolution

Cause

When SecureLogin loads it must be able to locate servers on your network. The problem at this site was caused by DNS. Check the TCP/IP DNS settings on the workstation.

SecureLogin uses DNS for service location (e.g. to contact the Domain Contollers etc.).

Solution

Ensure the IP address of your DNS server is at the top of the DNS Server Search Order list under the DNS tab of the TCP/IP settings. For most organizations these settings should be configured using DHCP.