Environment
Situation
User has SSO enabled some windows applications. The applications are running in the background. When the user attempts to close SecureLogin by right clicking on the system tray icon, a message appears stating that SecureLogin can’t close because the SSO enabled windows applications are running (they are open in the background).
Resolution
Root Cause
SecureLogin uses windows hooks to watch for SSO enabled applications. Prior to version 3.5, for a clean shutdown of SecureLogin, these hooks had to be released by closing the applications SSO was ""watching"" first.
Solution
The only way SecureLogin can be closed cleanly in versions prior to v3.5 is if the SSO enabled applications SecureLogin is ""watching"" for are closed first.
This issue has been solved in version 3.5 (and later) of SecureLogin. SecureLogin can be closed without any error messages appearing.