Environment
Situation
SecureLogin installed in ADS environment. The client was installed on the workstation and a passphrase set; however, Error -174 is received every 5 minutes (cache refresh rate in minutes defined against the OU).when SecureLogin loads.
The following tests to establish the cause of the problem;
- With the offline cache disabled, the error didn’t appear (since SecureLogin is reading straight from the Directory).
- When logged onto the same workstation as administrator, the error didn’t appear.
- Changed the cache location with the following key and the error didn’t appear.
HKLM/Software/Protocom/SecureLogin/CacheDirectory
Resolution
To change the default cache location;
- Edit the registry to specify the new location by creating a new string value under the following key. The String value should be set to the directory for the cache to be written to e.g. C:Cache
HKLM/Software/Protocom/SecureLogin/CacheDirectory - During installation, if the defaults are selected, the following registry key instructs SecureLogin to save the cache to the user profile. The DWORD value should be set to 1.
HKLM/Software/Protocom/SecureLogin/UseUserProfileDirectory
Note: The cache location can be specified during installation (when prompted to do so).
Additional Information
Root Cause
Error -174 means BROKER_CACHE_SAVE_FAILED
When SecureLogin loads with the offline cache enabled, the user must be able to write SecureLogin data from the Directory to the cache directory on the local hard disk.
By default the cache directory is located under the user profile i.e.
Application DataSecureLoginCache (check the option to view hidden folders in selected)
However, the cache was being saved under;
C:\Program Files\Protocom\SecureLogin\Cache
The user did not have rights to save the cache (write rights required).