Environment
NetIQ AppManager 7.0.x
NetIQ AppManager 8.0.x
NetIQ AppManager 8.0.x
Situation
Several agents are not passing encryption (level 2) info to their Primary MS
Error: 'Failed in call to CryptAcquireContext()' in MS.log
Error: 'Failed in call to CryptAcquireContext()' in MS.log
Resolution
If the RSA Encryption Machine Keys are unavailable the permissions on the folder c:\users\all users\application data\microsoft\crypto\rsa\machinekeys are probably wrong. You will need to make sure that the Management Service is running with an account that has permissions to this path.
In the case of corrupted RSA Encryption Machine Keys, deleting the keys located in c:\users\all users\application data\microsoft\crypto\rsa\machinekeys, and letting the NetIQ Management Service re-create what it needs should resolve the issue.
Cause
The machine keys used for RSA encryption on the Management Server are either corrupted or unavailable.
Additional Information
Formerly known as NETIQKB73423