NetIQ AppManager adapter version 2.0 fails to install (NETIQKB73390)

  • 7773390
  • 23-Feb-2012
  • 23-Feb-2012

Environment

NetIQ Aegis 2.x
NetIQ AppManager Integration Adapter 2.0

Situation

During the upgrade, the installer presents the following error:
Product: NetIQ AppManager Integration Adapter -- The installer failed to upgrade NetIQ AppManager Integration Adapter.
In the installation log the following error is presented:

ERROR2012-02-14 02:11:41 ? Upgrade AppManager Adapter : Error - Unable to cast object of type 'System.String' to type 'System.Byte[]'. - at AppManagerAdapterInstallerActions3.Util.UpgradeAppManagerAdapter.Encrypt2(Object pwd, RegistryKey key, String defaultKeyContainer, Byte[] defaultSessionKey, String registryName)

Resolution

Before following this process, please take a full back up of the Registry.

If the NetIQ AppManager Integration Adapter v1.5 was installed on an Aegis 2.1 installation, use the process below:

  1. From the Aegis server, open the system registry.
    • Start -> Run -> Regedit
  2. Navigate to the following registry path (note: on 32 bit installs the Wow6432Node portion should be excluded)
    • HKLM\SOFTWARE\Wow6432Node\NetIQ\AegisIQConnect\providers\IQAM\CCDBs\{database}
  3. Delete the key named sqlPassword entirely.  An empty value will not work, the entire Key should be removed.
    • Repeat this process for any database entered under the CCDB's registry key.
  4. Navigate to the following registry path (note: on 32 bit installs the Wow6432Node portion should be excluded)
    • HKLM\SOFTWARE\Wow6432Node\NetIQ\AegisIQConnect\providers\IQAM\QDBs\{database}
  5. Delete the key named sqlPassword entirely.  An empty value will not work, the entire Key should be removed.
    • Repeat this process for any database entered under the QBB's registry key.
  6. Exit the registry.
  7. Run the NetIQ AppManager Integration Adapter 2.0 upgrade.

If the NetIQ AppManager Integration Adapter v1.5 was installed on an Aegis 2.2+ installation, use the process below:

  1. From the Aegis server, open the system registry.
    • Start -> Run -> Regedit
  2. Navigate to the following registry path (note: on 32 bit installs the Wow6432Node portion should be excluded)
    • HKLM\SOFTWARE\Wow6432Node\NetIQ\AegisIQConnect73\providers\IQAM\CCDBs\{database}
  3. Delete the key named sqlPassword entirely.  An empty value will not work, the entire Key should be removed.
    • Repeat this process for any database entered under the CCDB's registry key.
  4. Navigate to the following registry path (note: on 32 bit installs the Wow6432Node portion should be excluded)
    • HKLM\SOFTWARE\Wow6432Node\NetIQ\AegisIQConnect73\providers\IQAM\QDBs\{database}
  5. Delete the key named sqlPassword entirely.  An empty value will not work, the entire Key should be removed.
    • Repeat this process for any database entered under the QBB's registry key.
  6. Exit the registry.
  7. Run the NetIQ AppManager Integration Adapter 2.0 upgrade.

Cause

The NetIQ AppManager Integration Adapter version 1.5 creates two registry keys via the Adapter Configuration Utility to allow for SQL authentication to the database.  If the adapter is set to use Windows Authentication, these created fields are left blank.  When the an attempt is made to upgrade the NetIQ AppManager Integration Adapter to version 2.0, the installer expects an encrypted password in the SQL Password field, which is blank.  This will cause the installer to halt and roll back the upgrade, presenting you with the error noted above.

Additional Information

Formerly known as NETIQKB73390