No data is available in Analysis Center reports after applying a product hotfix or service pack (NETIQKB73383)

  • 7773383
  • 16-Feb-2012
  • 22-Feb-2012

Situation

No data is available in Analysis Center reports after applying a product hotfix or service pack

Resolution


1. Disable all ETL & Analysis Center OLAP Processing SQL jobs

2. Maually run the 'Create Data Sources Data Marts' for each Data Source to trigger a rebuild of the SSIS packages & ETL SQL processing job, and wait for each to complete successfully

3. Once the ETL jobs have completed, temporarily disable the jobs & ensure they are not currently running.

4. Manually run the 'Analysis Center Installation' SQL job & wait for the OLAP processing job to complete in this step.  NOTE: This could take a significant amount of time to complete depending on the size of the environment & volume of data stored each data mart.

5. Once the OLAP Processing SQL job completes successfully, re-enable all ETL jobs to resume scheduled processing and verify data availability in your Analysis Center reports.

Cause

In certain situations, after installing a hotfix or service pack that requires you to rebuild the Analysis Services AC_OLAP database, the databases may get out of synchronization & will not fully process the data.  Using the steps below will trigger a rebuild & full process of the AC_OLAP databases after which the all the processed data will be available to Analysis Center reports.

Additional Information

Formerly known as NETIQKB73383