Environment
NetIQ AppManager 8.0.x
NetIQ Control Center 8.0.x
Situation
The logs may show that the task attempted to be created:
[INFO] [Assembly=DeploymentService; Method=DeploymentCore.Detection.Processing.RuleProcessor.ProcessRule ThreadID=62] : Calling CreateTasksForRule() to create tasks for machine(s):
Resolution
The following two corrections on agents fix this issue:
- Corrected the DeploymentEndpoint registry key setting where the configured value was incorrect:
HKLM\Software\NetIQ\AppManager\4.0\AgtShared\DeploymentEndpoint
- Clearing out the value in the InstallPath registry key, where the existing value pointed to a share that no longer existed:
HKLM\Software\NetIQ\AppManager\4.0\InstallPath
Cause
The upgrade process relies on correct software inventory in Control Center. The Deployment Endpoint value identifies which machine handles software inventory. The install path will identify where the previous MSI existed when the agent was installed. By clearing this value out it will no longer try to contact that previous install file.