PowerShell script returns ExecuteScript cannot proceed: No runspace host has been acquired. (NETIQKB73243)

  • 7773243
  • 09-Nov-2011
  • 09-Nov-2011

Environment

NetIQ AppManager 7.0.x
NetIQ AppManager 8.x

Situation

Unexpected error encountered during job execution
ExecuteScript cannot proceed: No runspace host has been acquired.

Resolution

To resolve this issue, please follow the steps detailed below:

  1. Stop the NetIQ Client Resource Monitor Service
  2. Stop the NetIQ Client Communication Manager Service.
  3. Configure both of the agent services to run as Local System temporarily.
  4. Log on to the server with an account other than the service account that has administrative rights.
  5. Delete the profile for the service account from windows.
  6. Log back on to the server with the service account.
  7. Configure both of the agent services to run as the service account.
  8. Restart the agent services.

Cause

This issue can be caused if the profile for the service account has become corrupted.

Additional Information

Formerly known as NETIQKB73243