Inactive Node of SQL Cluster throwing availablility alarms within AMPP (NETIQKB73203)

  • 7773203
  • 10-Oct-2011
  • 03-Nov-2011

Environment

NetIQ AppManager 7.0.x
NetIQ AppManager Performance Profiler 4.1.x

Situation

Availability alarms are being throw for the inactive node of a SQL Cluster.

Resolution

Remove the nodes from AMPP, along with the cluster element.
In AppManager make sure the Analytics_CompleteNTCounters and Analytics_CompleteSQLCounters are running against both nodes of the cluster.
In AppManager Performance Profiler:

  1. Click Administration
  2. Select the QDB Data Source for the cluster nodes.
  3. Choose to Add New Managed Elements and click submit
  4. Click Elements
  5. Click New Managed Element
  6. Click New Cluster
  7. Name the Cluster
  8. Add the nodes of the cluster
  9. Click Submit
  10. Wait for at least on cycle of the analytics job and ensure the elements look correct.

Cause

This is due to the elements being invalidly scanned during the their addition to the AMPP Datasource. This issue should only occur during during the addition of the nodes, not after the nodes have been functioning properly for some time.

Additional Information

Formerly known as NETIQKB73203