Environment
NetIQ AppManager 7.x
NetIQ AppManager 8.x
Microsoft Windows
Situation
AppManager Agent installation generates an Error 1327: invalid drive U:
Resolution
This issue can be resolved by following the below referenced Microsoft knowledgebase article:
http://support.microsoft.com/kb/327763
Which states:
To resolve this behavior, enter the correct value data for the registry key. To do this, follow these steps.
- Click Start, and then click Run.
- In the Open box, type regedit, and then click OK.
- In Registry Editor, locate the following registry key:
- HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
- In the right pane, note the values in the Data field of each entry. If any value contains a drive that is not correct for your computer, right-click the entry, type c:\my documents in the Value data box, and then click OK.
- Repeat step 4 for each entry whose Data value contains an incorrect drive.
- Repeat steps 3 through 5 for each of the following registry keys:
- HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
- HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion
- HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
- HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
- Close Registry Editor.
After following this process the AppManager Agent installer should complete without generating the described error.
Cause
This behavior may occur if a registry key contains an incorrect value in a Data field.
Additional Information
Formerly known as NETIQKB73172