Operations console indicates a workflow completed, when it did not. (NETIQKB73146)

  • 7773146
  • 11-Aug-2011
  • 02-Sep-2011

Environment

NetIQ Aegis 2.1
NetIQ Aegis 2.2

Situation

A workflow in the NetIQ Aegis Operations Console is shown as completed in the 'My Work Items' view, yet viewing the progression of the workflow in the console, the process halted before reaching the End of Workflow activity, with no errors.

Resolution

To resolve this issue you will need to examine the logic of the conditional connectors exiting the last activity that was completed.  You should compare the conditions that the workflow is looking for to the conditions as they were at the time of the failure to ensure that the condition was met.  If the condition is based on a Work Item Attribute, you should evaluate what the value of the Work Item was at the time of failure.

Cause

This is commonly caused by the use of conditional connectors.  When the process reaches an activity and can only exit that activity under precise conditions that have not been met, the process will terminate with a completed status.  NetIQ Aegis views this process as being completed due to the fact that the process has been executed as far as the logic provided will allow it to proceed.

Additional Information

Formerly known as NETIQKB73146