Agents unable to report software inventory to the deployment web service. (NETIQKB73136)

  • 7773136
  • 09-Aug-2011
  • 09-Aug-2011

Environment

NetIQ Control Center 7.0.x
NetIQ AppManager 7.0.x
NetIQ Deployment Web Service

Situation

Agents unable to report software inventory

Deployment::Config::GetSoftwareDetectionPollInterval: SOAP FAULT: SOAP-ENV:Client "End of file or no input: 'The handle is invalid.

Deployment::Config::GetSoftwareDetectionPollInterval: SOAP FAULT: SOAP-ENV:Client "End of file or no input: 'Operation interrupted or timed out'"

Resolution

Ensure that the web.config file exist in this directory the following directory:

  •  <install path> Program Files\NetIQ\AppManager\Control Center

If not either obtain a copy from NetIQ Tech Support or reinstall the NetIQ Control Center Deployment Web Service (using the modify option), tol reconfigure the Deployment Web Server back to its default settings.

Cause

The Web.config file that the deployment service is looking for is either missing or corrupt.

Upon a restart of the the NetIQ Client Resource Monitor service, the agent will attempt to send software inventory to the Deployment Web Server.  Once the service is restarted you can evaluate the mctrace.log found at the following location:

  • <install path>\Program Files\NetIQ\Temp\NetIQ_Debug\<server name> folder.

ISearch for entried in the log that contain either of the following two outputs.

  • "Deployment::Config::GetSoftwareDetectionPollInterval: SOAP FAULT: SOAP-ENV:Client "End of file or no input: 'The handle is invalid." 
  • "Deployment::Config::GetSoftwareDetectionPollInterval: SOAP FAULT: SOAP-ENV:Client "End of file or no input: 'Operation interrupted or timed out"

Additional Information

Formerly known as NETIQKB73136