Environment
NetIQ Aegis 2.X
Situation
Resolution
To resolve this issue, please follow the process noted below:
Locate the Program Files\NetIQ\Aegis\DB\RPT directory.
Verify that ImportData.cmd, RemoveTables.sql, AllRPTTables.sql, and LoadRPTRefTables.sql are all present.
From SQL Server Management Studio execute the following query's against the Aegis database
EXEC RemoveTables.sql
EXEC AllRPTTables.sql
From the command line, change directories into the Program Files\NetIQ\Aegis\DB\RPT directory and execute the following:
Call ImportData.cmd
Go back to Microsoft SQL Server Management Studio and execute the following against the Aegis DB
EXEC LoadRPTRefTables.sql
Restart all Aegis Services (NETIQKB73021)
Attempt re-running your reports.
Cause
A possible reason you may be receiving the "No Data for Report" message is that the RPT.Numbers table may not have been populated during installation of the Aegis database.
To verify that this is the issue you are seeing; execute the following SQL Query against the Aegis Database in Microsoft SQL Management Studio:
USE AEGIS
SELECT * FROM RPT.Numbers
If you have any rows returned the contents of this knowledge base article will not resolve your issue, and you should contact NetIQ Technical Support for further assistance.
If upon the completion of this query no rows are returned please follow the instructions below.