Get User Detail, Resource Management, activity does not find the user. (NETIQKB73126)

  • 7773126
  • 05-Aug-2011
  • 05-Aug-2011

Environment

NetIQ Aegis - All Versions

Situation

The Get User Detail, Resource Management, activity does not return information on the user that you selected.

Resolution

To correct this behavior and allow the Get User Detail, Resource Management to pull the user detail, follow the steps below:

  1. Log in to the NetIQ Aegis Configuration Console.
  2. Select 'Security' from the Navigation Pane.
  3. Select 'Users" from the 'Security - Navigation Pane'.
  4. Select 'Import Domain Users' from the Task Pane.
  5. Enter the name of the user you would line to import in the 'Select Users' popup.
    • You may enter multiple names in this field, or select 'Advanced' to bring up a complete list of users and then multi-select them.
  6. After the user is imported it will show up in the Users list, and will also be in the Namespace.


You can find the full IQRM resource locator in the Namespace by drilling down in the Namespace browser and looking at each user ID until you locate the one that you want to use, or by finding the resource locator within the Work Flow and using the activity output.  The following is an example of the full IQRM resource locator path:

/IQRM_TopLevelContainer=IQRM/IQRM_Users=Users/IQRM_User=3c33f4d9-730b-4d2b-88f9-96a77d73ee92

Cause

This is caused due to the method that is used to attain the requested information.  You must provide the activity with an IQRM resource locator to pull the information, you cannot simply enter a Domain\UserName in to the User input field.  You can attain the resource locator string through various methods, including browsing the Namespace to locate the individual user account desired and copying the IQRM path in to this field.  You may also use input builder to pull the Resource Locator from the output of another activity.  The IQRM Namespace will not know about all accounts that are in Active Directory by default, and users must be manually input in to Aegis to use this activity.  If you do not add all of the users into Aegis as registered users, you will need to use the NetIQ Directory & Resource Administrator activity library to pull user details.  This will require that you have NetIQ Directory & Resource Administrator installed in your environment as well as have the NetIQ Directory & Resource Administrator Aegis adapter installed and configured.

Additional Information

Formerly known as NETIQKB73126