Environment
NetIQ AppManager 7.0.4
Situation
When you stop the NetIQ AppManager Client Resource Monitor service, the Process does not stop running.
Resolution
Cause
When system pop-ups are present for the Console account they can:
1. Cause the AM Agent to hang or be effectively blocked from processing.
2. Prevent the Agent services from successfully re-starting.
When you log onto that server as yourself or some other service account and you stop the NetIQ AppManager Client Resource Monitor service, you can find the NetIQmc.exe process will remain running, and the Agent Port will remain open (in use).
When you re-start that service, it will resume using the Process that never stopped. You'll think that you've re-started the service (to clear up a problem) and technically, the service did re-start... but the process which is tied to that service did not re-start, and thus the problem was not cleared and the Agent will remain un-responsive.