NetIQ AppManager Agent stops responding, Agent Processes will not stop. (NETIQKB73111)

  • 7773111
  • 29-Jul-2011
  • 01-Aug-2011

Environment

NetIQ AppManager 7.0.4

Situation

NetIQ AppManager Agent stops responding, Agent Processes will not stop.
When you stop the NetIQ AppManager Client Resource Monitor service, the Process does not stop running.

Resolution

In order to correct this issue, you must log onto the server as the local Administrator account, and Acknowledge/Close the System Pop-Up Message.  Once the pop-up is cleared, the service will correctly restart (which means that the NetIQmc.exe Process will stop, and be re-created upon service re-start) when told to, and everything will work as expected going forward.

Cause

When system pop-ups are present for the Console account they can:

1. Cause the AM Agent to hang or be effectively blocked from processing.
2. Prevent the Agent services from successfully re-starting.

When you log onto that server as yourself or some other service account and you stop the NetIQ AppManager Client Resource Monitor service, you can find the NetIQmc.exe process will remain running, and the Agent Port will remain open (in use).

When you re-start that service, it will resume using the Process that never stopped. You'll think that you've re-started the service (to clear up a problem) and technically, the service did re-start... but the process which is tied to that service did not re-start, and thus the problem was not cleared and the Agent will remain un-responsive.

Additional Information

Formerly known as NETIQKB73111