Agent Install Error: Management server port and Windows client port are same (NETIQKB73088)

  • 7773088
  • 06-Jul-2011
  • 06-Jul-2011

Environment

NetIQ AppManager 7.x

Situation

Agent Install Error: Management server port and Windows client port are same, Enter different port numbers
nqAMInstMC.log file shows similar errors:

01/04/2008 09:23:25 ERROR: Failed to retrieve MC_B_ONMS property with error code=5 with error message "Access is denied.
"
01/04/2008 09:23:25 exit CMsi::PropertyGetEx
01/04/2008 09:23:25 start CMsi::PropertySetEx
01/04/2008 09:23:25 ERROR: Failed to set MC_B_ONMS property with error code=5 with error message "Access is denied.
"
01/04/2008 09:23:25 exit CMsi::PropertySetEx
01/04/2008 09:23:25 start CMsi::PropertyGetEx
01/04/2008 09:23:25 ERROR: Failed to retrieve MC_DISPLAYNAME property with error code=5 with error message "Access is denied.
"
01/04/2008 09:23:25 exit CMsi::PropertyGetEx
01/04/2008 09:23:25 start CMsi::PropertySetEx
01/04/2008 09:23:25 ERROR: Failed to set MC_DISPLAYNAME property with error code=5 with error message "Access is denied.
"
01/04/2008 09:23:25 exit CMsi::PropertySetEx
01/04/2008 09:23:25 start CMsi::PropertyGetEx
01/04/2008 09:23:25 ERROR: Failed to retrieve MC_MSPRIMARY property with error code=5 with error message "Access is denied.
"
01/04/2008 09:23:25 exit CMsi::PropertyGetEx
01/04/2008 09:23:25 start CMsi::PropertySetEx
01/04/2008 09:23:25 ERROR: Failed to set MC_MSPRIMARY property with error code=5 with error message "Access is denied.
"
01/04/2008 09:23:25 exit CMsi::PropertySetEx
01/04/2008 09:23:25 start CMsi::PropertyGetEx
01/04/2008 09:23:25 ERROR: Failed to retrieve MC_EXCHSVR property with error code=5 with error message "Access is denied.
"
01/04/2008 09:23:25 exit CMsi::PropertyGetEx
01/04/2008 09:23:25 start CMsi::PropertySetEx
01/04/2008 09:23:25 ERROR: Failed to set MC_EXCHSVR property with error code=5 with error message "Access is denied.
"

Resolution

To verify DCOM permissions on the system are set properly, use the following steps:

  • Go to Start, Run and type in 'dcomcnfg' to launch the Component Services tool. 
  • Then right-click My Computer in the Componenet Services interface & select propertes.
  • Go to the COM Security Tab & verify proper permissions for:

Access Permissions:

  • System & Self should have local & remote access

Launch & Activation Permissions:

  • Administrators, Interactive & System should have local & remote access.

After correcting the necessary permissions, restart the NetIQ AppManager Agent installation.

Cause

Incorrect DCOM permissions are configured on this system.  By default SYSTEM and SELF should have access along with whatever account is attempting the installation.

Additional Information

Formerly known as NETIQKB73088