AutoDeployment App Pool is failing when trying to connect to deploymentwebservice.asmx (NETIQKB73074)

  • 7773074
  • 01-Jul-2011
  • 12-Jul-2011

Environment

NetIQ AppManager 7.0.x

Situation

The AutoDeployment app pool in IIS fails when a user tries to connect to deploymentwebservice.asmx
The deploymentwebservice.asmx page is unavailable

Resolution

In order to correct this issue, please perform the following steps on teh IIS Server hosting the NetIQ Web Deployment Server.

  1. Open the Microsoft IIS Snap-in
  2. Expand MachineName > Application Pools
  3. Right Click the AutoDeployment App Pool, and select Properties
  4. Click Identity
  5. Configure a User who has access rights to the CCDB.
  6. Update the password by retyping it for this user account.
  7. Click OK
  8. Right Click on the AutoDeployment App Pool, and select Start.
  9. Try to access the page again.

To check the accounts membership in the IIS Worker Process Group:

  1. Start > Run: compmgmt.msc
  2. Expand Local Users and Groups
  3. Right Click IIS_WPG, and select Properties
  4. Verify this user is present in this group, if not add the user.
  5. Right Click on the AutoDeployment App Pool, and select Start.
  6. Try to access the page again.

The issue should be resolved at this point.

Cause

The credentials for the Identity account responsible for the pool is invalid
The account does not exist in the IIS Workers Process Group on the local machine.

Additional Information

Formerly known as NETIQKB73074