What issues are resolved in NetIQ Appmanager Managemetn Server Hotfix 73018? (NETIQKB73018)

  • 7773018
  • 07-Jun-2011
  • 22-Sep-2011

Environment

NetIQ AppManager Management Server v7.0.4

Situation

Custom Property Over-rides Not Working for String Parameters
Changing Severity Settings Causes Events to Be Acknowledged Automatically
The Action_SMTPMail Knowledge Script Encounters a Maximum String Length Error
Unreachable UNIX Servers Cannot Be Placed in Maintenance Mode
Management Server Stops Unexpectedly
Unable to Run NetIQ Diagnostics on Windows 2003 Computer with AppManager Agent Version 7.0.2 Installed
MS.log File Mixes UTC and Local Time Zones
Management Server Incorrectly Stops UNIX Jobs
NetIQDiag Utility Fails on Windows Server 2008 R2

Resolution

Why Install This Hotfix?

This hotfix resolves the following management server issues:

Custom Property Overrides Not Working for String Parameters
This hotfix resolves an issue where custom property overrides defined for string parameters in policy-based jobs are not used by the Knowledge Script job. This error occurs when no length is defined for the string parameter or the length of the custom property exceeds the length defined for the string parameter. (ENG267218)

Changing Severity Settings Causes Events to Be Acknowledged Automatically
This hotfix resolves an issue where changing event severity ranges causes new events to be generated in an Acknowledged rather than an Open state. (ENG284365, ENG303511)

The Action_SMTPMail Knowledge Script Encounters a Maximum String Length Error
This hotfix resolves an issue where the Action_SMTPMail Knowledge Script fails due to a maximum string length error when the action is generated by the management server and the Knowledge Script is longer than 200 lines. (ENG285283)

Unreachable UNIX Servers Cannot Be Placed in Maintenance Mode
This hotfix resolves an issue where UNIX servers with agents that a management server cannot reach cannot be placed in maintenance mode to supress alerts from any running remote monitoring jobs. (ENG288166)

Management Server Stops Unexpectedly
This hotfix resolves an issue where a Knowledge Script job with an action configured to run on a management server causes the management server to stop unexpectedly. It also resolves an issue where the management server stops unexpectedly due to an inability to update the Appmanager repository with information about jobs configured to run on a management server. (ENG296342, ENG309083, ENG308606, ENG308508)

Unable to Run NetIQ Diagnostics on Windows 2003 Computer with AppManager Agent Version 7.0.2 Installed
This hotfix resolves an issue where the process for the NetIQdiag.exe file disappears after clicking the Diagnose button in the Diagnostic wizard. (ENG300102)

MS.log File Mixes UTC and Local Time Zones
This hotfix resolves an issue where the ms.log file uses both the local timezone as well as UTC time to record events in the log. After applying this hotfix, the ms.log file records entries using the local timezone only. (ENG308114)

Management Server Incorrectly Stops UNIX Jobs
This hotfix resolves an issue where the management server incorrectly stops UNIX jobs if it is not able to resolve the UNIX computer name to the IP address. (ENG298384)

NetIQDiag Utility Fails on Windows Server 2008 R2
This hotfix resolves an issue where the NetIQDiag utility fails when run on a Windows Server 2008 R2 computer with an error indicating that the "NetIQ AppManager Suite NetIQCTRL utility has stopped working" when you select the option to collect information for the management server. (ENG309207)


System Requirements

This hotfix has the following requirements:

  • Hotfix 72040 installed on all AppManager repository (QDB) computers.
  • Hotfix 72041 installed on all management server computers.
  • Hotfix 72616 installed on all agent computers.
  • Hotfix 71473 installed on all Operator Web Console computers.
  • Hotfix 71949 installed on all Control Center console computers.
  • If you have installed the AppManager 7.x Platform Update, you do not need to install Hotfix 72040, 72041, 71473, or 71949 separately. These hotfixes are included as part of the Platform Update. For more information about the AppManager 7.x Platform Update, contact Technical Support.


Contents of the Download Package

The download package contains the following files, which are used by the hotfix setup program unless otherwise noted:

  • AM704_HF73018_Setup.exe, the hotfix setup program.
  • BaseInstall.dll.
  • MFC71u.dll.
  • msvcp71.dll.
  • msvcr71.dll.
  • Patch.ini.
  • AM704_ReadMe73018.htm, this readme.
  • Setup Files, a folder that contains AM704_HF73018_MSSetup.msp, the management server setup program. The hotfix setup program automatically runs this file to update the management server.


Installing This Hotfix

To install this hotfix, run AM704_HF73018_Setup.exe on all management server computers.

The PATCH.log file lists all changes and problems encountered during the installation process. The Windows installer log file, AM704_HF73018_MSSetup.msp.log, lists only the changes associated with the hotfix installation. By default, these files are located in the \NetIQ\Temp\NetIQ_Debug folder.


Known Issues

NetIQ Corporation strives to ensure our products provide quality solutions for your enterprise software needs. The following issue is currently being researched. If you need further assistance, please contact Technical Support.

Upgrading the management server computer from Microsoft SQL Server 2005 to SQL Server 2008 relocates the Binn folder where AppManager libraries reside. The upgrade process does not move files to the new Binn folder. You may not be able to log in to the Operator Console after the SQL Server upgrade and may see the following message: (ENG290143)

Failed to establish network connection for one of the following reasons:

  • The SQL server is down.
  • The password is incorrect.
  • The user ID is incorrect.
  • The repository name is incorrect.

To resolve the issue:

  1. Open the old SQL Server Binn folder, by default C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Binn.
  2. Copy the nqsql.dll and nqsqlext.dll files.
  3. Open the new SQL Server Binn folder, by default C:\Program Files\Microsoft SQL Server\MSSQL10.MSSQLSERVER\MSSQL\Binn.
  4. Paste the nqsql.dll and nqsqlext.dll files to the new Binn folder.


Modified Files

This hotfix modifies the following files on all management server computers:

  • Netiqms.exe (Build Number 7.0.41018)
  • NetIQdiag.exe (Build Number 7.0.41018)
  • NetIQexec.exe (Build Number 7.0.41018)
  • NetIQ_ENU.dll (Build Number 7.0.41018)
  • nqWin32Ext.dll (Build Number 7.0.41018)
  • NetIQLic.dll (Build Number 7.0.41018)
  • nqcmctrl.dll (Build Number 7.0.41018)
  • nqDbghlp.dll (Build Number 7.0.41018)


Previous Releases

Hotfix 71471 [April 16, 2009]

This hotfix resolved the following management server issues:

Resolved an issue where the management server does not correctly execute actions when you specify two proxy actions for an event. After the management server executes the first action, even though the second action appears to be in progress, the management server never executes it and instead repeats the first action. (ENG185521)

Resolved an issue where the management server crashes with an access violation. (ENG254770)

Resolved an issue where the AMAdminUnix_SetPrimaryMS job incorrectly generates a proxy event. If you select the Display "AppManager Proxy Events" as objects in treeview option on the Preference - Event Options dialog box when setting repository options, when you run the job on a UNIX agent that AppManager discovered by hostname, it generates a proxy event with the UNIX agent's IP address instead of generating an event for the UNIX agent. (ENG254811)

Resolved an issue where the AMAdminUnix_SetPrimaryMS job fails to set the secondary management server value and update the MSDesignation table. When you run the job to set a secondary management server for a UNIX agent, the job does not update the agent properties, and it does not add an entry to the MSDesignation table. (ENG263098)

Hotfix 71362 [Jan 14, 2009]

This hotfix resolved an issue with the management server having excessive open connections with the AppManager repository. Before you apply this hotfix, when the management server monitors a large number of servers, the NetIQ Management Service opens some connections to the AppManager repository over a period of time and does not close them. Eventually this creates a strain on both the SQL Server computer that hosts the AppManager repository, and the management server computer. As a result, either or both the computers lose the ability to communicate with the network. After you apply this hotfix, all the open connections from the management server to the AppManager repository are closed when they are no longer necessary. (ENG245143)

Hotfix 71352 [Dec 10, 2008]

This hotfix resolved an issue where the UNIX agents stop communicating with the management server. Before you apply this hotfix, the UNIX agents stop communicating with the management server and lose connection to the AppManager repository. This issue occurs randomly on different UNIX agents on different management servers at different time periods. After you apply this hotfix, the UNIX agents no longer stop communicating with the management server and do not lose the connection to the AppManager repository. (ENG255402)

Hotfix 71253 [Oct 10, 2008]

This hotfix resolved an issue with the synchronization report of jobs when you migrate the AppManager repository. Before you apply this hotfix, when you migrate the AppManager repository from one SQL Server to another SQL Server, the netiqsync utility does not correctly display the synchronization report for the jobs running on the agents. After you apply this hotfix, when you migrate the AppManager repository, the netiqsync utility displays the correct synchronization report about jobs running on agents. (ENG195063, ENG252726)

Hotfix 71243 [Oct, 2008]

This hotfix resolved the following management server issues:

Resolved an issue where the management server stops responding to the UNIX agents. Before you apply this hotfix, when the management server monitors a large number of UNIX agents, it stops responding to the UNIX agents after a certain time period and becomes inactive. The issue occurs because the management server initiates a large number of open connections with the UNIX agents and becomes inactive when the number of connections exceeds the maximum limit of 1000. After you apply this hotfix, the management server will no longer stop responding to the communication from the UNIX agents and will continue to remain active. (ENG249419)

Resolved an issue where the UNIX agents stop communicating with the management server. Before you apply this hotfix, the UNIX agents stop communicating with the management server and lose connection to the AppManager repository. This issue occurs randomly on different UNIX agents on different management servers at different time periods. After you apply this hotfix, the UNIX agents no longer stop communicating with the management server and do not lose the connection to the AppManager repository. (ENG252298)

 

Cause

This hotfix for the AppManager management server resolves specific issues. This document outlines why you should install this hotfix and identifies files modified by the hotfix.  This hotfix replaces Management Server Hotfixes 72041, 71471, 71362, 71352, 71253, and 71243.

Additional Information

Formerly known as NETIQKB73018