Aegis Adapter Configuration Console errors upon launching it. (NETIQKB72842)

  • 7772842
  • 02-Mar-2011
  • 06-Sep-2011

Environment

NetIQ Aegis 2.1

Situation

Aegis Adapter Configuration Console errors upon launching it.
System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.

at System.ThrowHelper.ThrowKeyNotFoundException()
at System.Collections.Generic.SortedList`2.get_Item(TKey key)
at GenericDBConfigurator.GenericDB.ReadAllProviderEntries(Stringpath)
at GenericDBConfigurator.GenericDB.LoadRegistryEntries(StringproviderKeyPath, String configuratorKeyPath)
at AegisConfigurator.Configurator.Configurator_Load(Object sender,EventArgs e) ind:\Build_2.1\Dev\iqproviders\configurator\AegisConfigurator\Configurator.cs:line 610
at System.Windows.Forms.Form.OnLoad(EventArgs e)
at NetIQ.NqWinFramework.BaseWindow.OnLoad(EventArgs e)
at System.Windows.Forms.Form.OnCreateControl()
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl()
at System.Windows.Forms.Control.WmShowWindow(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ContainerControl.WndProc(Message& m)
at System.Windows.Forms.Form.WmShowWindow(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at NetIQ.NqWinFramework.BaseWindow.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message&m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg,IntPtr wparam, IntPtr lparam)

Resolution

NOTE: You should export a copy of the Registry on the affected NetIQ Aegis server before applying the following fix, as accidentally deleting an incorrect registry key may cause unexpected problems on the server.

To correct this issue please back up your registry and use the process below to determine which path should be removed:

  1. Open Regedit.
  2. Browse to the following path:
    • [HKEY_LOCAL_MACHINE\SOFTWARE\NetIQ\AegisIQConnect\providers\IQGENERICDB\DBs
  3. In this subfolder you should see a folder that names the database server (I.E. AegisSql-01)
  4. If there is a second folder present with the following format, it should be deleted:
    • ServerName#InstanceName#DatabaseName (I.E. AegisSql-01#NetIQ#Aegis)
  5. Restart the Aegis Adapter Configuration Console.

The Aegis Adapter Configuration Console should no longer generate the above error when launched.

Cause

A duplicate registry key is not properly formatted and must be removed to prevent the application from generating this error.

Additional Information

Formerly known as NETIQKB72842