7.0.1 AppManager for UNIX Agent Hotfix (NETIQKB72754)

  • 7772754
  • 11-Jan-2011
  • 05-May-2011

Environment

  • NetIQ AppManager
  • 7.0.1 AppManager for UNIX Agent

Situation

Resolves an issue on Solaris platforms where the CPULoaded Knowledge Script sometimes causes the agent to stop unexpectedly. Resolves an issue where sending a SIGHUP signal to the agent process sometimes causes the agent to stop responding or stop unexpectedly.

Resolution

Installing This Hotfix

  1. Copy AppManager-UNIX_HF72754.tar.z to the computer where you want to update the UNIX agent.
  2. Extract the contents. The extraction process puts the contents of the .tar file in a subdirectory named HF72754.
  3. Change directories to HF72754.
  4. Switch to the root user account.
  5. Run the install.sh script specifing the full path to the UNIX agent. For example, if the UNIX agent is installed in /opt/netiq/UnixAgent, type the following command:
    1. sh ./install.sh /opt/netiq/UnixAgent start
  6. The script runs without interaction from the user. When the script completes, the agent restarts automatically.
  7. Repeat Steps 1 through 5 on each computer running the AppManager UNIX agent 7.0.1.

Cause

This Hotfix resolves the following issues:

  1. Resolves an issue on Solaris platforms where the CPULoaded Knowledge Script sometimes causes the agent to stop unexpectedly. (ENG298429)
  2. Resolves an issue where sending a SIGHUP signal to the agent process sometimes causes the agent to stop responding or stop unexpectedly. (ENG305668)
  3. Resolves an issue on multiple-processor computers where the Management Server unexpectedly stops a job on the agent computer. This problem occurs because the agent omits the job from the list of running jobs sent to the Management Server when the job completed an iteration while the job sync is in progress. (ENG259790)

Additional Information

Formerly known as NETIQKB72754

If you have additional questions, please contact NetIQ technical support.