Environment
NetIQ AppManager 7.0.x
Microsoft Internet Information Server 6
Microsoft Internet Information Server 7
Situation
AppManager Agent installation package does not get checked-in during Control Center install
New install of Control Center 7.0.4 does not contain NetIQ AppManager Windows Agent
Package Check-ins Fail for Packages Larger than 30 MB
New install of Control Center 7.0.4 does not contain NetIQ AppManager Windows Agent
Package Check-ins Fail for Packages Larger than 30 MB
Resolution
To work around this issue, increase the file size limit in IIS.
To increase the file size limit in IIS, complete the followign steps:
- Log on to the Deployment Web Service computer.
- Run the following command from the command prompt as an administrator:
%windir%\system32\inetsrv\appcmd set config "Default Web Site/WebDepot" -section:requestFiltering -requestLimits.maxAllowedContentLength:60000000
Changing the value to 60000000 doubles the default file size from 28.6 MB to 57.2 MB. - Re-start the IIS service using the Services administrative tool.
Once those steps are done, re-attempt the package check-in that was previously failing. The check-in should then succeed.
Cause
Some installations of Microsoft Internet Information Server (IIS) use file size limiters that will prevent large files (files larger than 28.6 Mb in size, like the AM Windows Agent) from being checked-in successfully.
Additional Information
Formerly known as NETIQKB72732