ckPowerShellHost.exe is crashing when trying to install the Exchange 2007 Module (NETIQKB72696)

  • 7772696
  • 30-Nov-2010
  • 30-Nov-2010

Environment

NetIQ AppManager 7.0.x
NetIQ AppManager Exchange 2007 Module

Situation

ckPowerShellHost.exe is crashing when trying to install the Exchange 2007 Module
A stop message pops up during the installation with the following message, 'Product File for NetIQ AppManager 7.0.0.0 has stopped working'. When clicking product details the Application name will be ckPowerShellHost.exe

Resolution

The proper location for these keys is under HKLM>Software>Wow6432node>NetIQ

  1. Verify they keys in HKLM>Software>NetIQ
  2. Recreate these keys in HKLM>Software>Wow6432node>NetIQ
  3. Rename HKLM>Software>NetIQ to NetIQ-bak
  4. Attempt the installation again.

If the issue persists please contact NetIQ Technical Support and reference this KB.

Cause

The ckPowerShellHost.exe checks the registry to find the NetIQ Install Path. In some instances a registry key will be placed in the HKLM>Software>NetIQ directory prior to the installation of the NetIQ AppManager Agent. Since Microsoft Exchange 2007 can only be hosted on a 64 Bit machine these keys are populated in the wrong place during a build process.

Additional Information

Formerly known as NETIQKB72696