Cache Manager errors with execution terminated by the provider because a resource limit was reached. (NETIQKB72651)

  • 7772651
  • 29-Oct-2010
  • 08-Aug-2011

Environment

NetIQ AppManager 7.0.x
NetIQ Control Center Database (NQCCDB)
Microsoft SQL Server 2005

Situation

Cache Manager errors with execution terminated by the provider because a resource limit was reached.
SQL JOB: NetIQ CC ManagementGroup [Server Name\Instance.Database]
[SQL STEP: Synchronize Policy information] Executed as user: Domain\User Name. The OLE DB provider "SQLNCLI" for linked server "Server Name\Instance" reported an error.
Execution terminated by the provider because a resource limit was reached. [SQLSTATE 42000] (Error 7399) Cannot fetch the rowset from OLE DB provider "SQLNCLI" for linked server "Server Name\Instance". . [SQLSTATE 42000] (Error 7421) OLE DB provider "SQLNCLI" for linked server "Server Name\Instance" returned message "Query timeout expired". [SQLSTATE 01000] (Error 7412). The step failed. (SQL severity 16).

Resolution

To correct this issue please follow the process below:
  1. Open Microsoft SQL Management Studio.
  2. Select New Query.
  3. Execute the following query on each NetIQ AppManager QDB repository:

    sp_configure 'remote query timeout', 0

  4. Restart the SQL services on each NetIQ AppManager Repository server.
  5. Allow of the query to complete, and the Cache Manager to come out of the error state in NetIQ Control Center.
  6. Execute the following query on each NetIQ AppManager QDB repository:

    sp_configure 'remote query timeout', 600

For more information, please see the below linked Microsoft Knowledge Base article:

http://support.microsoft.com/kb/314530

Cause

A query took more time to process than the time that is configured in SQL for remote query's to execute.

Additional Information

Formerly known as NETIQKB72651